%%ItemTitle%%

XFINIUM.PDF Documentation
XFINIUM.PDF Library
XFINIUM.PDF library is a cross platform library for PDF development. We support a wide set of features, ranging from simple PDF creation to form filling, content redaction or complex color conversions. The simple object model follows the PDF specification so you can have complete control over the generated PDF files. Code written for XFINIUM.PDF can be compiled on all supported platforms without changes.
Namespaces
Namespace | Description
Xfinium.Pdf |
Xfinium.Pdf.Actions |
Xfinium.Pdf.Annotations |
Xfinium.Pdf.Content |
Xfinium.Pdf.Core |
Xfinium.Pdf.Core.Cos |
Xfinium.Pdf.Core.Encodings |
Xfinium.Pdf.Core.Exceptions |
Xfinium.Pdf.Core.Security |
Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper |
Xfinium.Pdf.Destinations |
Xfinium.Pdf.FlowDocument |
Xfinium.Pdf.Forms |
Xfinium.Pdf.Graphics |
Xfinium.Pdf.Graphics.FormattedContent |
Xfinium.Pdf.Graphics.Operators |
Xfinium.Pdf.Graphics.OptionalContent |
Xfinium.Pdf.Graphics.Svg |
Xfinium.Pdf.Graphics.Text |
Xfinium.Pdf.Imaging |
Xfinium.Pdf.Imaging.Png |
Xfinium.Pdf.Imaging.Tiff |
Xfinium.Pdf.PdfFunctions |
Xfinium.Pdf.Portfolios |
Xfinium.Pdf.Redaction |
Xfinium.Pdf.Services |
Xfinium.Pdf.Spatial |
Xfinium.Pdf.Standards |
Xfinium.Pdf.Transforms |
Send Feedback


Xfinium.Pdf Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfDocument | Defines an abstract PDF document.
Class | PdfDocumentFeatures | Specifies the available features that are supported for a PdfFixedDocument created from external content, a file or a stream.
Class | PdfDocumentFileAttachment | Defines an attachment included in a PDF document.
Class | PdfDocumentFileAttachmentCollection | Defines a collection of document attachments.
Class | PdfDocumentInformation | Defines the general document information.
Class | PdfFixedDocument | Defines a Pdf document. Defines a Pdf document. Defines a Pdf document. Defines a Pdf document.
Class | PdfJavaScriptBlock | Defines a block of JavaScript code.
Class | PdfJavaScriptBlockCollection | Defines a collection of JavaScript source code blocks.
Class | PdfOutlineItem | Defines a PDF outline item.
Class | PdfOutlineItemCollection | Defines a collection of outline items.
Class | PdfOutputIntent | Defines a PDF output intent.
Class | PdfOutputIntentCollection | Defines a collection of PDF output intents.
Class | PdfPage | Defines a PDF page.
Class | PdfPageCollection | Defines a collection of PDF pages.
Class | PdfPageLabelingRange | Defines a labeling range for PDF pages.
Class | PdfPageLabelingRangeCollection | Defines a collection of page labels.
Class | PdfVersionExtension | Defines an extension to an existing PDF version.
Class | PdfViewerPreferences | Defines the way the document is to be presented on the screen or in print.
Class | PdfXmpMetadata | Defines the XMP metadata.
Enumerations
 | Enumeration | Description
Enumeration | PdfDisplayMode | Supported display modes for a PDF document.
Enumeration | PdfDuplexPrinting | Supported values for duplex printing.
Enumeration | PdfFileAttachmentRelationship | Specifies the supported relationship types between a file attachment and its owner.
Enumeration | PdfOutlineItemVisualStyle | Supported styles for outline item's text.
Enumeration | PdfOutputIntentType | Supported output intent types.
Enumeration | PdfPageLabelNumberStyle | Supported numbering styles for page labels.
Enumeration | PdfPageLayout | Supported page layouts for PDF documents.
Enumeration | PdfPrintScaling | Suported print scaling options.
Enumeration | PdfVersion | Supported PDF specification versions.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfDocumentFileAttachmentCollection
Xfinium.Pdf.PdfJavaScriptBlockCollection
Xfinium.Pdf.PdfOutlineItemCollection
Xfinium.Pdf.PdfOutputIntentCollection
Xfinium.Pdf.PdfPageCollection
Xfinium.Pdf.PdfPageLabelingRangeCollection
Xfinium.Pdf.PdfContentStreamContainer
Xfinium.Pdf.PdfPage
Xfinium.Pdf.PdfDocument
Xfinium.Pdf.FlowDocument.PdfFlowDocument
Xfinium.Pdf.PdfFixedDocument
Xfinium.Pdf.Portfolios.PdfPortfolio
Xfinium.Pdf.PdfDocumentFeatures
Xfinium.Pdf.PdfDocumentFileAttachment
Xfinium.Pdf.PdfDocumentInformation
Xfinium.Pdf.PdfJavaScriptBlock
Xfinium.Pdf.PdfOutlineItem
Xfinium.Pdf.PdfOutputIntent
Xfinium.Pdf.PdfPageLabelingRange
Xfinium.Pdf.PdfVersionExtension
Xfinium.Pdf.PdfViewerPreferences
Xfinium.Pdf.PdfXmpMetadata
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfDocument Class
Members

Xfinium.Pdf Namespace : PdfDocument Class
Defines an abstract PDF document.
Object Model
PdfDocument ClassPdfCosDictionary ClassPdfSecurityHandler Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfDocument
'Usage

Dim instance As PdfDocument
public abstract class PdfDocument
public ref class PdfDocument abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfDocument
Xfinium.Pdf.FlowDocument.PdfFlowDocument
Xfinium.Pdf.PdfFixedDocument
Xfinium.Pdf.Portfolios.PdfPortfolio

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocument Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfDocument Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfDocument Class

The following tables list the members exposed by PdfDocument.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | ID | Gets the document ID.
Public Property | SecurityHandler | Gets the document security handler.
Top
Public Methods
 | Name | Description
Public Method | Save | Overloaded. Saves the Pdf document to the specified stream.
Top
See Also

Reference

PdfDocument Class
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Methods$$

PdfDocument Class Methods

Xfinium.Pdf Namespace : PdfDocument Class

For a list of all members of this type, see PdfDocument members.

Public Methods
 | Name | Description
Public Method | Save | Overloaded. Saves the Pdf document to the specified stream.
Top
See Also

Reference

PdfDocument Class
Xfinium.Pdf Namespace


Save Method (PdfDocument)

Xfinium.Pdf Namespace > PdfDocument Class : Save Method
Saves the Pdf document to the specified stream.
Overload List
Overload | Description
Save(Stream) | Saves the Pdf document to the specified stream.
Save(Stream,PdfSecurityHandler) | Saves the Pdf document to the specified stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocument Class
PdfDocument Members


Save(Stream) Method

Xfinium.Pdf Namespace > PdfDocument Class > Save Method : Save(Stream) Method
Destination stream.
Saves the Pdf document to the specified stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PdfDocument
Dim stream As Stream

instance.Save(stream)
public void Save(
   Stream stream
)
public:
void Save(
   Stream^ stream
)

Parameters

stream
Destination stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocument Class
PdfDocument Members
Overload List


Save(Stream,PdfSecurityHandler) Method

Xfinium.Pdf Namespace > PdfDocument Class > Save Method : Save(Stream,PdfSecurityHandler) Method
Destination stream.
Security handler for encrypting the saved file.
Saves the Pdf document to the specified stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Sub Save( _
   ByVal stream As Stream, _
   ByVal securityHandler As PdfSecurityHandler _
)
'Usage

Dim instance As PdfDocument
Dim stream As Stream
Dim securityHandler As PdfSecurityHandler

instance.Save(stream, securityHandler)
public virtual void Save(
   Stream stream,
   PdfSecurityHandler securityHandler
)
public:
virtual void Save(
   Stream^ stream,
   PdfSecurityHandler^ securityHandler
)

Parameters

stream
Destination stream.
securityHandler
Security handler for encrypting the saved file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocument Class
PdfDocument Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfDocument Class Properties

Xfinium.Pdf Namespace : PdfDocument Class

For a list of all members of this type, see PdfDocument members.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | ID | Gets the document ID.
Public Property | SecurityHandler | Gets the document security handler.
Top
See Also

Reference

PdfDocument Class
Xfinium.Pdf Namespace


CosDictionary Property (PdfDocument)

Xfinium.Pdf Namespace > PdfDocument Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfDocument
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocument Class
PdfDocument Members


ID Property (PdfDocument)

Xfinium.Pdf Namespace > PdfDocument Class : ID Property
Gets the document ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ID As Byte()
'Usage

Dim instance As PdfDocument
Dim value() As Byte

value = instance.ID
public byte[] ID {get;}
public:
property array<byte>^ ID {
   array<byte>^ get();
}

Property Value

The Pdf identifier of this document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocument Class
PdfDocument Members


SecurityHandler Property (PdfDocument)

Xfinium.Pdf Namespace > PdfDocument Class : SecurityHandler Property
Gets the document security handler.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SecurityHandler As PdfSecurityHandler
'Usage

Dim instance As PdfDocument
Dim value As PdfSecurityHandler

value = instance.SecurityHandler
public PdfSecurityHandler SecurityHandler {get;}
public:
property PdfSecurityHandler^ SecurityHandler {
   PdfSecurityHandler^ get();
}

Property Value

A Xfinium.Pdf.Core.Security.PdfSecurityHandler that represents the handler used to encrypt the file loaded in this PdfDocument.
Remarks
Both RC4 and AES security handlers are supported.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

PdfDocumentFeatures Class
Members

Xfinium.Pdf Namespace : PdfDocumentFeatures Class
Specifies the available features that are supported for a PdfFixedDocument created from external content, a file or a stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDocumentFeatures
'Usage

Dim instance As PdfDocumentFeatures
public class PdfDocumentFeatures
public ref class PdfDocumentFeatures
Remarks
When a feature is disabled its content is not loaded from disk and it cannot be modified in the PdfFixedDocument object. For example if page graphics is disabled, the page content is not loaded from the file and new graphic content cannot be added to the pages loaded from the file.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfDocumentFeatures

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfDocumentFeatures Class Members
Properties

Xfinium.Pdf Namespace : PdfDocumentFeatures Class

The following tables list the members exposed by PdfDocumentFeatures.

Public Constructors
 | Name | Description
Public Constructor | PdfDocumentFeatures Constructor | Initializes a new PdfDocumentFeatures object.
Top
Public Properties
 | Name | Description
Public Property | EnableDocumentFileAttachments | Gets or sets a value indicating whether document file attachments are enabled.
Public Property | EnableDocumentFormFields | Gets or sets a value indicating whether document form fields are enabled.
Public Property | EnableDocumentJavaScriptFragments | Gets or sets a value indicating whether document javascripts are enabled.
Public Property | EnableDocumentNamedDestinations | Gets or sets a value indicating whether document named destinations are enabled.
Public Property | EnableDocumentOutline | Gets or sets a value indicating whether document outline is enabled.
Public Property | EnablePageAnnotations | Gets or sets a value indicating whether page annotations are enabled.
Public Property | EnablePageGraphics | Gets or sets a value indicating whether page graphics is enabled.
Public Property | EnablePages | Gets or sets a value indicating whether pages are enabled.
Top
See Also

Reference

PdfDocumentFeatures Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfDocumentFeatures Constructor

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : PdfDocumentFeatures Constructor
Initializes a new PdfDocumentFeatures object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDocumentFeatures()
public PdfDocumentFeatures()
public:
PdfDocumentFeatures();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


%%PageItemTitle%% $$Properties$$

PdfDocumentFeatures Class Properties

Xfinium.Pdf Namespace : PdfDocumentFeatures Class

For a list of all members of this type, see PdfDocumentFeatures members.

Public Properties
 | Name | Description
Public Property | EnableDocumentFileAttachments | Gets or sets a value indicating whether document file attachments are enabled.
Public Property | EnableDocumentFormFields | Gets or sets a value indicating whether document form fields are enabled.
Public Property | EnableDocumentJavaScriptFragments | Gets or sets a value indicating whether document javascripts are enabled.
Public Property | EnableDocumentNamedDestinations | Gets or sets a value indicating whether document named destinations are enabled.
Public Property | EnableDocumentOutline | Gets or sets a value indicating whether document outline is enabled.
Public Property | EnablePageAnnotations | Gets or sets a value indicating whether page annotations are enabled.
Public Property | EnablePageGraphics | Gets or sets a value indicating whether page graphics is enabled.
Public Property | EnablePages | Gets or sets a value indicating whether pages are enabled.
Top
See Also

Reference

PdfDocumentFeatures Class
Xfinium.Pdf Namespace


EnableDocumentFileAttachments Property

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : EnableDocumentFileAttachments Property
Gets or sets a value indicating whether document file attachments are enabled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableDocumentFileAttachments As Boolean
'Usage

Dim instance As PdfDocumentFeatures
Dim value As Boolean

instance.EnableDocumentFileAttachments = value

value = instance.EnableDocumentFileAttachments
public bool EnableDocumentFileAttachments {get; set;}
public:
property bool EnableDocumentFileAttachments {
   bool get();
   void set (    bool value);
}

Property Value

If true, the document file attachments are enabled.
Remarks
If document file attachments are not enabled, then the PdfFixedDocument.FileAttachments property will be null and new attachments cannot be created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


EnableDocumentFormFields Property

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : EnableDocumentFormFields Property
Gets or sets a value indicating whether document form fields are enabled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableDocumentFormFields As Boolean
'Usage

Dim instance As PdfDocumentFeatures
Dim value As Boolean

instance.EnableDocumentFormFields = value

value = instance.EnableDocumentFormFields
public bool EnableDocumentFormFields {get; set;}
public:
property bool EnableDocumentFormFields {
   bool get();
   void set (    bool value);
}

Property Value

If true, the document form fields are enabled.
Remarks
If document form fields are not enabled, then the PdfFixedDocument.Form and PdfPage.Fields properties will be null and new form fields cannot be created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


EnableDocumentJavaScriptFragments Property

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : EnableDocumentJavaScriptFragments Property
Gets or sets a value indicating whether document javascripts are enabled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableDocumentJavaScriptFragments As Boolean
'Usage

Dim instance As PdfDocumentFeatures
Dim value As Boolean

instance.EnableDocumentJavaScriptFragments = value

value = instance.EnableDocumentJavaScriptFragments
public bool EnableDocumentJavaScriptFragments {get; set;}
public:
property bool EnableDocumentJavaScriptFragments {
   bool get();
   void set (    bool value);
}

Property Value

If true, the document javascripts are enabled.
Remarks
If document javascripts are not enabled, then the PdfFixedDocument.JavaScriptBlocks property will be null and new javascript fragments cannot be created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


EnableDocumentNamedDestinations Property

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : EnableDocumentNamedDestinations Property
Gets or sets a value indicating whether document named destinations are enabled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableDocumentNamedDestinations As Boolean
'Usage

Dim instance As PdfDocumentFeatures
Dim value As Boolean

instance.EnableDocumentNamedDestinations = value

value = instance.EnableDocumentNamedDestinations
public bool EnableDocumentNamedDestinations {get; set;}
public:
property bool EnableDocumentNamedDestinations {
   bool get();
   void set (    bool value);
}

Property Value

If true, the named destinations are enabled.
Remarks
If named destinations are not enabled, then the PdfFixedDocument.NamedDestinations property will be null and new named destinations cannot be created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


EnableDocumentOutline Property

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : EnableDocumentOutline Property
Gets or sets a value indicating whether document outline is enabled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableDocumentOutline As Boolean
'Usage

Dim instance As PdfDocumentFeatures
Dim value As Boolean

instance.EnableDocumentOutline = value

value = instance.EnableDocumentOutline
public bool EnableDocumentOutline {get; set;}
public:
property bool EnableDocumentOutline {
   bool get();
   void set (    bool value);
}

Property Value

If true, the document outline is enabled.
Remarks
If document outline is not enabled, then the PdfFixedDocument.Outline property will be null and new outline items cannot be created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


EnablePageAnnotations Property

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : EnablePageAnnotations Property
Gets or sets a value indicating whether page annotations are enabled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnablePageAnnotations As Boolean
'Usage

Dim instance As PdfDocumentFeatures
Dim value As Boolean

instance.EnablePageAnnotations = value

value = instance.EnablePageAnnotations
public bool EnablePageAnnotations {get; set;}
public:
property bool EnablePageAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

If true, the page annotations are enabled.
Remarks
If page annotations are not enabled, then the PdfPage.Annotations property will be null for pages loaded from the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


EnablePageGraphics Property

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : EnablePageGraphics Property
Gets or sets a value indicating whether page graphics is enabled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnablePageGraphics As Boolean
'Usage

Dim instance As PdfDocumentFeatures
Dim value As Boolean

instance.EnablePageGraphics = value

value = instance.EnablePageGraphics
public bool EnablePageGraphics {get; set;}
public:
property bool EnablePageGraphics {
   bool get();
   void set (    bool value);
}

Property Value

If true, the page graphics are enabled.
Remarks
If page graphics is not enabled, then the PdfPage.Graphics property will be null for pages loaded from the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


EnablePages Property

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : EnablePages Property
Gets or sets a value indicating whether pages are enabled.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnablePages As Boolean
'Usage

Dim instance As PdfDocumentFeatures
Dim value As Boolean

instance.EnablePages = value

value = instance.EnablePages
public bool EnablePages {get; set;}
public:
property bool EnablePages {
   bool get();
   void set (    bool value);
}

Property Value

If true, the page are enabled.
Remarks
If pages are not enabled, then the PdfFixedDocument.Pages property will be null and new pages cannot be added.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


%%PageItemTitle%%

PdfDocumentFileAttachment Class
Members

Xfinium.Pdf Namespace : PdfDocumentFileAttachment Class
Defines an attachment included in a PDF document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDocumentFileAttachment
'Usage

Dim instance As PdfDocumentFileAttachment
public class PdfDocumentFileAttachment
public ref class PdfDocumentFileAttachment
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfDocumentFileAttachment

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfDocumentFileAttachment Class Members
Properties

Xfinium.Pdf Namespace : PdfDocumentFileAttachment Class

The following tables list the members exposed by PdfDocumentFileAttachment.

Public Constructors
 | Name | Description
Public Constructor | PdfDocumentFileAttachment Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CreationDate | Gets or sets the creation date.
Public Property | Description | Gets or sets the file description.
Public Property | FileName | Gets or sets the file name.
Public Property | MimeType | Gets or sets the MIME type.
Public Property | ModifyDate | Gets or sets the modify date.
Public Property | Payload | Gets or sets the attachment content.
Public Property | RelationshipToOwner | Gets or sets the relationship between the file attachment and its owner.
Top
See Also

Reference

PdfDocumentFileAttachment Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfDocumentFileAttachment Constructor

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class : PdfDocumentFileAttachment Constructor
Overload List
Overload | Description
PdfDocumentFileAttachment Constructor() | Initializes a new PdfDocumentFileAttachment object.
PdfDocumentFileAttachment Constructor(Byte[]) | Initializes a new PdfDocumentFileAttachment object with the given content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members


%%PageItemTitle%%

PdfDocumentFileAttachment Constructor()

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class > PdfDocumentFileAttachment Constructor : PdfDocumentFileAttachment Constructor()
Initializes a new PdfDocumentFileAttachment object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDocumentFileAttachment()
public PdfDocumentFileAttachment()
public:
PdfDocumentFileAttachment();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members
Overload List


%%PageItemTitle%%

PdfDocumentFileAttachment Constructor(Byte[])

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class > PdfDocumentFileAttachment Constructor : PdfDocumentFileAttachment Constructor(Byte[])
The binary content to embed in the Pdf file.
Initializes a new PdfDocumentFileAttachment object with the given content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fileData() As Byte _
)
'Usage

Dim fileData() As Byte

Dim instance As New PdfDocumentFileAttachment(fileData)
public PdfDocumentFileAttachment(
   byte[] fileData
)
public:
PdfDocumentFileAttachment(
   array<byte>^ fileData
)

Parameters

fileData
The binary content to embed in the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfDocumentFileAttachment Class Properties

Xfinium.Pdf Namespace : PdfDocumentFileAttachment Class

For a list of all members of this type, see PdfDocumentFileAttachment members.

Public Properties
 | Name | Description
Public Property | CreationDate | Gets or sets the creation date.
Public Property | Description | Gets or sets the file description.
Public Property | FileName | Gets or sets the file name.
Public Property | MimeType | Gets or sets the MIME type.
Public Property | ModifyDate | Gets or sets the modify date.
Public Property | Payload | Gets or sets the attachment content.
Public Property | RelationshipToOwner | Gets or sets the relationship between the file attachment and its owner.
Top
See Also

Reference

PdfDocumentFileAttachment Class
Xfinium.Pdf Namespace


CreationDate Property (PdfDocumentFileAttachment)

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class : CreationDate Property
Gets or sets the creation date.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PdfDocumentFileAttachment
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time when the attachment was created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members


Description Property (PdfDocumentFileAttachment)

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class : Description Property
Gets or sets the file description.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PdfDocumentFileAttachment
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

The description of the file attachment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members


FileName Property (PdfDocumentFileAttachment)

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class : FileName Property
Gets or sets the file name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PdfDocumentFileAttachment
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The file name corresponding to the content in Payload property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members


MimeType Property (PdfDocumentFileAttachment)

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class : MimeType Property
Gets or sets the MIME type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MimeType As String
'Usage

Dim instance As PdfDocumentFileAttachment
Dim value As String

instance.MimeType = value

value = instance.MimeType
public string MimeType {get; set;}
public:
property String^ MimeType {
   String^ get();
   void set (    String^ value);
}

Property Value

The MIME type of the attachment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members


ModifyDate Property (PdfDocumentFileAttachment)

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class : ModifyDate Property
Gets or sets the modify date.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ModifyDate As Date
'Usage

Dim instance As PdfDocumentFileAttachment
Dim value As Date

instance.ModifyDate = value

value = instance.ModifyDate
public DateTime ModifyDate {get; set;}
public:
property DateTime ModifyDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time when the attachment was modified.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members


Payload Property (PdfDocumentFileAttachment)

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class : Payload Property
Gets or sets the attachment content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Payload As Byte()
'Usage

Dim instance As PdfDocumentFileAttachment
Dim value() As Byte

instance.Payload = value

value = instance.Payload
public byte[] Payload {get; set;}
public:
property array<byte>^ Payload {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The content of the attachment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members


RelationshipToOwner Property

Xfinium.Pdf Namespace > PdfDocumentFileAttachment Class : RelationshipToOwner Property
Gets or sets the relationship between the file attachment and its owner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RelationshipToOwner As PdfFileAttachmentRelationship
'Usage

Dim instance As PdfDocumentFileAttachment
Dim value As PdfFileAttachmentRelationship

instance.RelationshipToOwner = value

value = instance.RelationshipToOwner
public PdfFileAttachmentRelationship RelationshipToOwner {get; set;}
public:
property PdfFileAttachmentRelationship RelationshipToOwner {
   PdfFileAttachmentRelationship get();
   void set (    PdfFileAttachmentRelationship value);
}

Property Value

A PdfFileAttachmentRelationship enumeration member specifying how the file attachment is related to its owner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachment Class
PdfDocumentFileAttachment Members


%%PageItemTitle%%

PdfDocumentFileAttachmentCollection Class
Members

Xfinium.Pdf Namespace : PdfDocumentFileAttachmentCollection Class
Defines a collection of document attachments.
Object Model
PdfDocumentFileAttachmentCollection ClassPdfDocumentFileAttachment Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfDocumentFileAttachmentCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfDocumentFileAttachment)
'Usage

Dim instance As PdfDocumentFileAttachmentCollection
[DefaultMember("Item")]
public class PdfDocumentFileAttachmentCollection : System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>
[DefaultMember("Item")]
public ref class PdfDocumentFileAttachmentCollection : public System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfDocumentFileAttachmentCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachmentCollection Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfDocumentFileAttachmentCollection Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfDocumentFileAttachmentCollection Class

The following tables list the members exposed by PdfDocumentFileAttachmentCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Property | Item | Gets the file atttachment with the specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Top
See Also

Reference

PdfDocumentFileAttachmentCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Properties$$

PdfDocumentFileAttachmentCollection Class Properties

Xfinium.Pdf Namespace : PdfDocumentFileAttachmentCollection Class

For a list of all members of this type, see PdfDocumentFileAttachmentCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Property | Item | Gets the file atttachment with the specified name.
Top
See Also

Reference

PdfDocumentFileAttachmentCollection Class
Xfinium.Pdf Namespace


Item Property (PdfDocumentFileAttachmentCollection)

Xfinium.Pdf Namespace > PdfDocumentFileAttachmentCollection Class : Item Property
Name of the file attachment to retrieve.
Gets the file atttachment with the specified name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal name As String _
) As PdfDocumentFileAttachment
'Usage

Dim instance As PdfDocumentFileAttachmentCollection
Dim name As String
Dim value As PdfDocumentFileAttachment

value = instance.Item(name)
public new PdfDocumentFileAttachment this[
   string name
]; {get;}
public:
new property PdfDocumentFileAttachment^ default [String^] {
   PdfDocumentFileAttachment^ get(String^ name);
}

Parameters

name
Name of the file attachment to retrieve.

Property Value

The file attachment with the specified name or null if the name is not found.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFileAttachmentCollection Class
PdfDocumentFileAttachmentCollection Members


%%PageItemTitle%%

PdfDocumentInformation Class
Members

Xfinium.Pdf Namespace : PdfDocumentInformation Class
Defines the general document information.
Object Model
PdfDocumentInformation ClassPdfCosDictionary Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDocumentInformation
'Usage

Dim instance As PdfDocumentInformation
public class PdfDocumentInformation
public ref class PdfDocumentInformation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfDocumentInformation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfDocumentInformation Class Members
Properties

Xfinium.Pdf Namespace : PdfDocumentInformation Class

The following tables list the members exposed by PdfDocumentInformation.

Public Constructors
 | Name | Description
Public Constructor | PdfDocumentInformation Constructor | Initializes a new PdfDocumentInformation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the author.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | CreationDate | Gets or sets the creation date.
Public Property | Creator | Gets or sets the creator.
Public Property | Keywords | Gets or sets the keywords.
Public Property | ModifyDate | Gets or sets the modify date.
Public Property | Producer | Gets or sets the produced.
Public Property | Subject | Gets or sets the subject.
Public Property | Title | Gets or sets the title.
Top
See Also

Reference

PdfDocumentInformation Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfDocumentInformation Constructor

Xfinium.Pdf Namespace > PdfDocumentInformation Class : PdfDocumentInformation Constructor
Initializes a new PdfDocumentInformation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDocumentInformation()
public PdfDocumentInformation()
public:
PdfDocumentInformation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


%%PageItemTitle%% $$Properties$$

PdfDocumentInformation Class Properties

Xfinium.Pdf Namespace : PdfDocumentInformation Class

For a list of all members of this type, see PdfDocumentInformation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the author.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | CreationDate | Gets or sets the creation date.
Public Property | Creator | Gets or sets the creator.
Public Property | Keywords | Gets or sets the keywords.
Public Property | ModifyDate | Gets or sets the modify date.
Public Property | Producer | Gets or sets the produced.
Public Property | Subject | Gets or sets the subject.
Public Property | Title | Gets or sets the title.
Top
See Also

Reference

PdfDocumentInformation Class
Xfinium.Pdf Namespace


Author Property (PdfDocumentInformation)

Xfinium.Pdf Namespace > PdfDocumentInformation Class : Author Property
Gets or sets the author.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PdfDocumentInformation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the person who created the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


CosDictionary Property (PdfDocumentInformation)

Xfinium.Pdf Namespace > PdfDocumentInformation Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfDocumentInformation
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


CreationDate Property (PdfDocumentInformation)

Xfinium.Pdf Namespace > PdfDocumentInformation Class : CreationDate Property
Gets or sets the creation date.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PdfDocumentInformation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time the document was created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


Creator Property

Xfinium.Pdf Namespace > PdfDocumentInformation Class : Creator Property
Gets or sets the creator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Creator As String
'Usage

Dim instance As PdfDocumentInformation
Dim value As String

instance.Creator = value

value = instance.Creator
public string Creator {get; set;}
public:
property String^ Creator {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the application that created the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


Keywords Property

Xfinium.Pdf Namespace > PdfDocumentInformation Class : Keywords Property
Gets or sets the keywords.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Keywords As String
'Usage

Dim instance As PdfDocumentInformation
Dim value As String

instance.Keywords = value

value = instance.Keywords
public string Keywords {get; set;}
public:
property String^ Keywords {
   String^ get();
   void set (    String^ value);
}

Property Value

Keywords associated with the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


ModifyDate Property (PdfDocumentInformation)

Xfinium.Pdf Namespace > PdfDocumentInformation Class : ModifyDate Property
Gets or sets the modify date.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ModifyDate As Date
'Usage

Dim instance As PdfDocumentInformation
Dim value As Date

instance.ModifyDate = value

value = instance.ModifyDate
public DateTime ModifyDate {get; set;}
public:
property DateTime ModifyDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time the document was most recently modified.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


Producer Property

Xfinium.Pdf Namespace > PdfDocumentInformation Class : Producer Property
Gets or sets the produced.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Producer As String
'Usage

Dim instance As PdfDocumentInformation
Dim value As String

instance.Producer = value

value = instance.Producer
public string Producer {get; set;}
public:
property String^ Producer {
   String^ get();
   void set (    String^ value);
}

Property Value

The PDF module that generated the PDF document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


Subject Property (PdfDocumentInformation)

Xfinium.Pdf Namespace > PdfDocumentInformation Class : Subject Property
Gets or sets the subject.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As PdfDocumentInformation
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

The subject of the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


Title Property (PdfDocumentInformation)

Xfinium.Pdf Namespace > PdfDocumentInformation Class : Title Property
Gets or sets the title.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As PdfDocumentInformation
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The title of the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


%%PageItemTitle%%

PdfFixedDocument Class
Members

Xfinium.Pdf Namespace : PdfFixedDocument Class
Defines a Pdf document. Defines a Pdf document. Defines a Pdf document. Defines a Pdf document.
Object Model
PdfFixedDocument ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfCosDictionary ClassPdfDocumentInformation ClassPdfDocumentFileAttachmentCollection ClassPdfDocumentFileAttachment ClassPdfForm ClassPdfJavaScriptBlockCollection ClassPdfJavaScriptBlock ClassPdfNamedDestinationCollection ClassPdfNamedDestination ClassPdfAction ClassPdfOptionalContentProperties ClassPdfOutlineItemCollection ClassPdfOutlineItem ClassPdfOutputIntentCollection ClassPdfOutputIntent ClassPdfPageLabelingRangeCollection ClassPdfPageLabelingRange ClassPdfPageCollection ClassPdfPage ClassPdfSecurityHandler ClassPdfVersionExtension ClassPdfViewerPreferences ClassPdfXmpMetadata Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFixedDocument
   Inherits PdfDocument
'Usage

Dim instance As PdfFixedDocument
public class PdfFixedDocument : PdfDocument
public ref class PdfFixedDocument : public PdfDocument
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfDocument
Xfinium.Pdf.PdfFixedDocument

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfFixedDocument Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfFixedDocument Class

The following tables list the members exposed by PdfFixedDocument.

Public Constructors
 | Name | Description
Public Constructor | PdfFixedDocument Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | DisplayMode | Gets or sets how the document should be displayed when opened in the viewer.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | FileAttachments | Gets the list of file attachments embedded in this document.
Public Property | Form | Gets the Pdf form included in the document.
Public Property | ID | Gets the document ID. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | JavaScriptBlocks | Gets the JavaScript source code blocks.
Public Property | NamedDestinations | Gets the list of named destination included in the document.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | OptionalContentProperties | Gets the optional content properties for this document.
Public Property | Outline | Gets the document outline.
Public Property | OutputIntents | Gets or sets the collection of output intents.
Public Property | PageLabelingRanges | Gets the list of page labeling ranges in the Pdf document.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | Pages | Gets the list of pages in the document;
Public Property | PdfVersion | Gets or sets the Pdf version of this PdfDocument object.
Public Property | SecurityHandler | Gets the document security handler. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | VersionExtension | Gets or sets the version extension.
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Public Property | XmpMetadata | Gets or sets the XMP document metadata.
Top
Public Methods
 | Name | Description
Public Method | AppendFile | Appends a Pdf file at the end of the document.
Public Method | BeginSave | Overloaded. Initializes a save procedure for the Pdf file.
Public Method | EndSave | Finishes the save procedure initiated by BeginSave(Stream) method.
Public Method | InsertFile | Inserts a Pdf file in the document.
Public Method | Save | Overloaded. Overridden. Saves the Pdf document to the specified stream.
Top
See Also

Reference

PdfFixedDocument Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfFixedDocument Constructor

Xfinium.Pdf Namespace > PdfFixedDocument Class : PdfFixedDocument Constructor
Overload List
Overload | Description
PdfFixedDocument Constructor() | Initializes a new PdfDocument object.
PdfFixedDocument Constructor(Stream) | Initializes a new PdfDocument object from a Pdf stream.
PdfFixedDocument Constructor(Stream,PdfDocumentFeatures) | Initializes a new PdfDocument object from a Pdf stream with the specified features.
PdfFixedDocument Constructor(Stream,String) | Initializes a new PdfDocument object from a Pdf stream.
PdfFixedDocument Constructor(Stream,String,PdfDocumentFeatures) | Initializes a new PdfDocument object from a Pdf stream with the specified features.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


%%PageItemTitle%%

PdfFixedDocument Constructor()

Xfinium.Pdf Namespace > PdfFixedDocument Class > PdfFixedDocument Constructor : PdfFixedDocument Constructor()
Initializes a new PdfDocument object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFixedDocument()
public PdfFixedDocument()
public:
PdfFixedDocument();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members
Overload List


%%PageItemTitle%%

PdfFixedDocument Constructor(Stream)

Xfinium.Pdf Namespace > PdfFixedDocument Class > PdfFixedDocument Constructor : PdfFixedDocument Constructor(Stream)
Stream that contains Pdf content.
Initializes a new PdfDocument object from a Pdf stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfFixedDocument(stream)
public PdfFixedDocument(
   Stream stream
)
public:
PdfFixedDocument(
   Stream^ stream
)

Parameters

stream
Stream that contains Pdf content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members
Overload List


%%PageItemTitle%%

PdfFixedDocument Constructor(Stream,PdfDocumentFeatures)

Xfinium.Pdf Namespace > PdfFixedDocument Class > PdfFixedDocument Constructor : PdfFixedDocument Constructor(Stream,PdfDocumentFeatures)
Stream that contains Pdf content.
Features to load from the Pdf file.
Initializes a new PdfDocument object from a Pdf stream with the specified features.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal documentFeatures As PdfDocumentFeatures _
)
'Usage

Dim stream As Stream
Dim documentFeatures As PdfDocumentFeatures

Dim instance As New PdfFixedDocument(stream, documentFeatures)
public PdfFixedDocument(
   Stream stream,
   PdfDocumentFeatures documentFeatures
)
public:
PdfFixedDocument(
   Stream^ stream,
   PdfDocumentFeatures^ documentFeatures
)

Parameters

stream
Stream that contains Pdf content.
documentFeatures
Features to load from the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members
Overload List


%%PageItemTitle%%

PdfFixedDocument Constructor(Stream,String)

Xfinium.Pdf Namespace > PdfFixedDocument Class > PdfFixedDocument Constructor : PdfFixedDocument Constructor(Stream,String)
Stream that contains Pdf content.
Password required to open the Pdf file.
Initializes a new PdfDocument object from a Pdf stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal password As String _
)
'Usage

Dim stream As Stream
Dim password As String

Dim instance As New PdfFixedDocument(stream, password)
public PdfFixedDocument(
   Stream stream,
   string password
)
public:
PdfFixedDocument(
   Stream^ stream,
   String^ password
)

Parameters

stream
Stream that contains Pdf content.
password
Password required to open the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members
Overload List


%%PageItemTitle%%

PdfFixedDocument Constructor(Stream,String,PdfDocumentFeatures)

Xfinium.Pdf Namespace > PdfFixedDocument Class > PdfFixedDocument Constructor : PdfFixedDocument Constructor(Stream,String,PdfDocumentFeatures)
Stream that contains Pdf content.
Password required to open the Pdf file.
Features to load from the Pdf file.
Initializes a new PdfDocument object from a Pdf stream with the specified features.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal password As String, _
   ByVal documentFeatures As PdfDocumentFeatures _
)
'Usage

Dim stream As Stream
Dim password As String
Dim documentFeatures As PdfDocumentFeatures

Dim instance As New PdfFixedDocument(stream, password, documentFeatures)
public PdfFixedDocument(
   Stream stream,
   string password,
   PdfDocumentFeatures documentFeatures
)
public:
PdfFixedDocument(
   Stream^ stream,
   String^ password,
   PdfDocumentFeatures^ documentFeatures
)

Parameters

stream
Stream that contains Pdf content.
password
Password required to open the Pdf file.
documentFeatures
Features to load from the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfFixedDocument Class Methods

Xfinium.Pdf Namespace : PdfFixedDocument Class

For a list of all members of this type, see PdfFixedDocument members.

Public Methods
 | Name | Description
Public Method | AppendFile | Appends a Pdf file at the end of the document.
Public Method | BeginSave | Overloaded. Initializes a save procedure for the Pdf file.
Public Method | EndSave | Finishes the save procedure initiated by BeginSave(Stream) method.
Public Method | InsertFile | Inserts a Pdf file in the document.
Public Method | Save | Overloaded. Overridden. Saves the Pdf document to the specified stream.
Top
See Also

Reference

PdfFixedDocument Class
Xfinium.Pdf Namespace


AppendFile Method

Xfinium.Pdf Namespace > PdfFixedDocument Class : AppendFile Method
Stream with the file to append.
Appends a Pdf file at the end of the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AppendFile( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PdfFixedDocument
Dim stream As Stream

instance.AppendFile(stream)
public void AppendFile(
   Stream stream
)
public:
void AppendFile(
   Stream^ stream
)

Parameters

stream
Stream with the file to append.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


BeginSave Method

Xfinium.Pdf Namespace > PdfFixedDocument Class : BeginSave Method
Initializes a save procedure for the Pdf file.
Overload List
Overload | Description
BeginSave(Stream) | Initializes a save procedure for the Pdf file.
BeginSave(Stream,PdfSecurityHandler) | Initializes a save procedure for the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


BeginSave(Stream) Method

Xfinium.Pdf Namespace > PdfFixedDocument Class > BeginSave Method : BeginSave(Stream) Method
Destination stream where the Pdf file will be saved.
Initializes a save procedure for the Pdf file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub BeginSave( _
   ByVal stream As Stream _
)
'Usage

Dim instance As PdfFixedDocument
Dim stream As Stream

instance.BeginSave(stream)
public void BeginSave(
   Stream stream
)
public:
void BeginSave(
   Stream^ stream
)

Parameters

stream
Destination stream where the Pdf file will be saved.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members
Overload List


BeginSave(Stream,PdfSecurityHandler) Method

Xfinium.Pdf Namespace > PdfFixedDocument Class > BeginSave Method : BeginSave(Stream,PdfSecurityHandler) Method
Destination stream where the Pdf file will be saved.
Security handler for encrypting the saved file.
Initializes a save procedure for the Pdf file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub BeginSave( _
   ByVal stream As Stream, _
   ByVal securityHandler As PdfSecurityHandler _
)
'Usage

Dim instance As PdfFixedDocument
Dim stream As Stream
Dim securityHandler As PdfSecurityHandler

instance.BeginSave(stream, securityHandler)
public void BeginSave(
   Stream stream,
   PdfSecurityHandler securityHandler
)
public:
void BeginSave(
   Stream^ stream,
   PdfSecurityHandler^ securityHandler
)

Parameters

stream
Destination stream where the Pdf file will be saved.
securityHandler
Security handler for encrypting the saved file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members
Overload List


EndSave Method

Xfinium.Pdf Namespace > PdfFixedDocument Class : EndSave Method
Finishes the save procedure initiated by BeginSave(Stream) method.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub EndSave()
'Usage

Dim instance As PdfFixedDocument

instance.EndSave()
public void EndSave()
public:
void EndSave();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


InsertFile Method

Xfinium.Pdf Namespace > PdfFixedDocument Class : InsertFile Method
Position in the Pages collection where the pages from the file are inserted.
Position in the Outline collection where the outlines from the file are inserted.
Stream with the file to insert.
Inserts a Pdf file in the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub InsertFile( _
   ByVal pageIndex As Integer, _
   ByVal outlineIndex As Integer, _
   ByVal stream As Stream _
)
'Usage

Dim instance As PdfFixedDocument
Dim pageIndex As Integer
Dim outlineIndex As Integer
Dim stream As Stream

instance.InsertFile(pageIndex, outlineIndex, stream)
public void InsertFile(
   int pageIndex,
   int outlineIndex,
   Stream stream
)
public:
void InsertFile(
   int pageIndex,
   int outlineIndex,
   Stream^ stream
)

Parameters

pageIndex
Position in the Pages collection where the pages from the file are inserted.
outlineIndex
Position in the Outline collection where the outlines from the file are inserted.
stream
Stream with the file to insert.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


Save Method (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : Save Method
Saves the Pdf document to the specified stream.
Overload List
Overload | Description
Save(Stream,PdfSecurityHandler) | Saves the Pdf document to the specified stream.
Save(Stream) | Saves the Pdf document to the specified stream. (Inherited from Xfinium.Pdf.PdfDocument)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


Save(Stream,PdfSecurityHandler) Method

Xfinium.Pdf Namespace > PdfFixedDocument Class > Save Method : Save(Stream,PdfSecurityHandler) Method
Destination stream.
Security handler for encrypting the saved file.
Saves the Pdf document to the specified stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Save( _
   ByVal stream As Stream, _
   ByVal securityHandler As PdfSecurityHandler _
)
'Usage

Dim instance As PdfFixedDocument
Dim stream As Stream
Dim securityHandler As PdfSecurityHandler

instance.Save(stream, securityHandler)
public override void Save(
   Stream stream,
   PdfSecurityHandler securityHandler
)
public:
void Save(
   Stream^ stream,
   PdfSecurityHandler^ securityHandler
) override

Parameters

stream
Destination stream.
securityHandler
Security handler for encrypting the saved file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFixedDocument Class Properties

Xfinium.Pdf Namespace : PdfFixedDocument Class

For a list of all members of this type, see PdfFixedDocument members.

Public Properties
 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | DisplayMode | Gets or sets how the document should be displayed when opened in the viewer.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | FileAttachments | Gets the list of file attachments embedded in this document.
Public Property | Form | Gets the Pdf form included in the document.
Public Property | ID | Gets the document ID. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | JavaScriptBlocks | Gets the JavaScript source code blocks.
Public Property | NamedDestinations | Gets the list of named destination included in the document.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | OptionalContentProperties | Gets the optional content properties for this document.
Public Property | Outline | Gets the document outline.
Public Property | OutputIntents | Gets or sets the collection of output intents.
Public Property | PageLabelingRanges | Gets the list of page labeling ranges in the Pdf document.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | Pages | Gets the list of pages in the document;
Public Property | PdfVersion | Gets or sets the Pdf version of this PdfDocument object.
Public Property | SecurityHandler | Gets the document security handler. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | VersionExtension | Gets or sets the version extension.
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Public Property | XmpMetadata | Gets or sets the XMP document metadata.
Top
See Also

Reference

PdfFixedDocument Class
Xfinium.Pdf Namespace


AfterPrintAction Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : AfterPrintAction Property
Gets or sets the javascript action to execute after the document is printed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AfterPrintAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfJavaScriptAction

instance.AfterPrintAction = value

value = instance.AfterPrintAction
public PdfJavaScriptAction AfterPrintAction {get; set;}
public:
property PdfJavaScriptAction^ AfterPrintAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed after the document is printed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


AfterSaveAction Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : AfterSaveAction Property
Gets or sets the javascript action to execute after the document is saved.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AfterSaveAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfJavaScriptAction

instance.AfterSaveAction = value

value = instance.AfterSaveAction
public PdfJavaScriptAction AfterSaveAction {get; set;}
public:
property PdfJavaScriptAction^ AfterSaveAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed after the document is saved.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


BeforeCloseAction Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : BeforeCloseAction Property
Gets or sets the javascript action to execute before the document is closed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BeforeCloseAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfJavaScriptAction

instance.BeforeCloseAction = value

value = instance.BeforeCloseAction
public PdfJavaScriptAction BeforeCloseAction {get; set;}
public:
property PdfJavaScriptAction^ BeforeCloseAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed before the document is closed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


BeforePrintAction Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : BeforePrintAction Property
Gets or sets the javascript action to execute before the document is printed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BeforePrintAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfJavaScriptAction

instance.BeforePrintAction = value

value = instance.BeforePrintAction
public PdfJavaScriptAction BeforePrintAction {get; set;}
public:
property PdfJavaScriptAction^ BeforePrintAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed before the document is printed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


BeforeSaveAction Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : BeforeSaveAction Property
Gets or sets the javascript action to execute before the document is saved.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BeforeSaveAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfJavaScriptAction

instance.BeforeSaveAction = value

value = instance.BeforeSaveAction
public PdfJavaScriptAction BeforeSaveAction {get; set;}
public:
property PdfJavaScriptAction^ BeforeSaveAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed before the document is saved.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


DisplayMode Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : DisplayMode Property
Gets or sets how the document should be displayed when opened in the viewer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisplayMode As PdfDisplayMode
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
public PdfDisplayMode DisplayMode {get; set;}
public:
property PdfDisplayMode DisplayMode {
   PdfDisplayMode get();
   void set (    PdfDisplayMode value);
}

Property Value

A PdfDisplayMode enumeration member specifying how the viewer should display the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


DocumentInformation Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : DocumentInformation Property
Gets or sets the document information.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DocumentInformation As PdfDocumentInformation
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfDocumentInformation

instance.DocumentInformation = value

value = instance.DocumentInformation
public PdfDocumentInformation DocumentInformation {get; set;}
public:
property PdfDocumentInformation^ DocumentInformation {
   PdfDocumentInformation^ get();
   void set (    PdfDocumentInformation^ value);
}

Property Value

The document's metadata.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


FileAttachments Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : FileAttachments Property
Gets the list of file attachments embedded in this document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FileAttachments As PdfDocumentFileAttachmentCollection
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfDocumentFileAttachmentCollection

value = instance.FileAttachments
public PdfDocumentFileAttachmentCollection FileAttachments {get;}
public:
property PdfDocumentFileAttachmentCollection^ FileAttachments {
   PdfDocumentFileAttachmentCollection^ get();
}

Property Value

PdfDocumentFileAttachmentCollection object specifying the list of document attachments.
Remarks
When a Pdf file is imported into a PdfDocument object, this collection is populated automatically with the attachments in the file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


Form Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : Form Property
Gets the Pdf form included in the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Form As PdfForm
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfForm

value = instance.Form
public PdfForm Form {get;}
public:
property PdfForm^ Form {
   PdfForm^ get();
}

Property Value

A Xfinium.Pdf.Forms.PdfForm object representing the Pdf form included in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


JavaScriptBlocks Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : JavaScriptBlocks Property
Gets the JavaScript source code blocks.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property JavaScriptBlocks As PdfJavaScriptBlockCollection
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfJavaScriptBlockCollection

value = instance.JavaScriptBlocks
public PdfJavaScriptBlockCollection JavaScriptBlocks {get;}
public:
property PdfJavaScriptBlockCollection^ JavaScriptBlocks {
   PdfJavaScriptBlockCollection^ get();
}

Property Value

The collection of JavaScript source code block that are embedded in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


NamedDestinations Property

Xfinium.Pdf Namespace > PdfFixedDocument Class : NamedDestinations Property
Gets the list of named destination included in the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property NamedDestinations As PdfNamedDestinationCollection
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfNamedDestinationCollection

value = instance.NamedDestinations
public PdfNamedDestinationCollection NamedDestinations {get;}
public:
property PdfNamedDestinationCollection^ NamedDestinations {
   PdfNamedDestinationCollection^ get();
}

Property Value

The list of named destinations included in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


OpenAction Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : OpenAction Property
Gets or sets the action to execute when the document is opened.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OpenAction As PdfAction
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfAction

instance.OpenAction = value

value = instance.OpenAction
public PdfAction OpenAction {get; set;}
public:
property PdfAction^ OpenAction {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfAction object specifying the action to be executed when documents opens in the viewer.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


OptionalContentProperties Property

Xfinium.Pdf Namespace > PdfFixedDocument Class : OptionalContentProperties Property
Gets the optional content properties for this document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OptionalContentProperties As PdfOptionalContentProperties
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfOptionalContentProperties

instance.OptionalContentProperties = value

value = instance.OptionalContentProperties
public PdfOptionalContentProperties OptionalContentProperties {get; set;}
public:
property PdfOptionalContentProperties^ OptionalContentProperties {
   PdfOptionalContentProperties^ get();
   void set (    PdfOptionalContentProperties^ value);
}

Property Value

The properties related to optional content included in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


Outline Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : Outline Property
Gets the document outline.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Outline As PdfOutlineItemCollection
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfOutlineItemCollection

value = instance.Outline
public PdfOutlineItemCollection Outline {get;}
public:
property PdfOutlineItemCollection^ Outline {
   PdfOutlineItemCollection^ get();
}

Property Value

A tree-structured hierarchy of outline items.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


OutputIntents Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : OutputIntents Property
Gets or sets the collection of output intents.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutputIntents As PdfOutputIntentCollection
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfOutputIntentCollection

instance.OutputIntents = value

value = instance.OutputIntents
public PdfOutputIntentCollection OutputIntents {get; set;}
public:
property PdfOutputIntentCollection^ OutputIntents {
   PdfOutputIntentCollection^ get();
   void set (    PdfOutputIntentCollection^ value);
}

Property Value

A collection of PdfOutputIntent objects describing the color characteristics of output devices on which the document might be rendered.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


PageLabelingRanges Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : PageLabelingRanges Property
Gets the list of page labeling ranges in the Pdf document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PageLabelingRanges As PdfPageLabelingRangeCollection
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfPageLabelingRangeCollection

value = instance.PageLabelingRanges
public PdfPageLabelingRangeCollection PageLabelingRanges {get;}
public:
property PdfPageLabelingRangeCollection^ PageLabelingRanges {
   PdfPageLabelingRangeCollection^ get();
}

Property Value

The list of page labeling ranges in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


PageLayout Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : PageLayout Property
Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageLayout As PdfPageLayout
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfPageLayout

instance.PageLayout = value

value = instance.PageLayout
public PdfPageLayout PageLayout {get; set;}
public:
property PdfPageLayout PageLayout {
   PdfPageLayout get();
   void set (    PdfPageLayout value);
}

Property Value

The document's page layout.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


Pages Property

Xfinium.Pdf Namespace > PdfFixedDocument Class : Pages Property
Gets the list of pages in the document;
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Pages As PdfPageCollection
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfPageCollection

value = instance.Pages
public PdfPageCollection Pages {get;}
public:
property PdfPageCollection^ Pages {
   PdfPageCollection^ get();
}

Property Value

The document's pages.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


PdfVersion Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : PdfVersion Property
Gets or sets the Pdf version of this PdfDocument object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PdfVersion As PdfVersion
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfVersion

instance.PdfVersion = value

value = instance.PdfVersion
public PdfVersion PdfVersion {get; set;}
public:
property PdfVersion PdfVersion {
   PdfVersion get();
   void set (    PdfVersion value);
}

Property Value

A PdfVersion enumeration member specifying the Pdf version of this PdfDocument object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


VersionExtension Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : VersionExtension Property
Gets or sets the version extension.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VersionExtension As PdfVersionExtension
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfVersionExtension

instance.VersionExtension = value

value = instance.VersionExtension
public PdfVersionExtension VersionExtension {get; set;}
public:
property PdfVersionExtension^ VersionExtension {
   PdfVersionExtension^ get();
   void set (    PdfVersionExtension^ value);
}

Property Value

The extended Pdf version this document implements.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


ViewerPreferences Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : ViewerPreferences Property
Gets or sets the document's viewer preferences.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ViewerPreferences As PdfViewerPreferences
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfViewerPreferences

instance.ViewerPreferences = value

value = instance.ViewerPreferences
public PdfViewerPreferences ViewerPreferences {get; set;}
public:
property PdfViewerPreferences^ ViewerPreferences {
   PdfViewerPreferences^ get();
   void set (    PdfViewerPreferences^ value);
}

Property Value

The viewer preferences for displaying the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


XmpMetadata Property (PdfFixedDocument)

Xfinium.Pdf Namespace > PdfFixedDocument Class : XmpMetadata Property
Gets or sets the XMP document metadata.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property XmpMetadata As PdfXmpMetadata
'Usage

Dim instance As PdfFixedDocument
Dim value As PdfXmpMetadata

instance.XmpMetadata = value

value = instance.XmpMetadata
public PdfXmpMetadata XmpMetadata {get; set;}
public:
property PdfXmpMetadata^ XmpMetadata {
   PdfXmpMetadata^ get();
   void set (    PdfXmpMetadata^ value);
}

Property Value

The XMP document metadata.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFixedDocument Class
PdfFixedDocument Members


%%PageItemTitle%%

PdfJavaScriptBlock Class
Members

Xfinium.Pdf Namespace : PdfJavaScriptBlock Class
Defines a block of JavaScript code.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfJavaScriptBlock
'Usage

Dim instance As PdfJavaScriptBlock
public class PdfJavaScriptBlock
public ref class PdfJavaScriptBlock
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfJavaScriptBlock

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlock Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfJavaScriptBlock Class Members
Properties

Xfinium.Pdf Namespace : PdfJavaScriptBlock Class

The following tables list the members exposed by PdfJavaScriptBlock.

Public Constructors
 | Name | Description
Public Constructor | PdfJavaScriptBlock Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name.
Public Property | SourceCode | Gets or sets the JavaScript source code.
Top
See Also

Reference

PdfJavaScriptBlock Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfJavaScriptBlock Constructor

Xfinium.Pdf Namespace > PdfJavaScriptBlock Class : PdfJavaScriptBlock Constructor
Overload List
Overload | Description
PdfJavaScriptBlock Constructor() | Initializes a new PdfJavaScriptBlock object.
PdfJavaScriptBlock Constructor(String) | Initializes a new PdfJavaScriptBlock object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlock Class
PdfJavaScriptBlock Members


%%PageItemTitle%%

PdfJavaScriptBlock Constructor()

Xfinium.Pdf Namespace > PdfJavaScriptBlock Class > PdfJavaScriptBlock Constructor : PdfJavaScriptBlock Constructor()
Initializes a new PdfJavaScriptBlock object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfJavaScriptBlock()
public PdfJavaScriptBlock()
public:
PdfJavaScriptBlock();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlock Class
PdfJavaScriptBlock Members
Overload List


%%PageItemTitle%%

PdfJavaScriptBlock Constructor(String)

Xfinium.Pdf Namespace > PdfJavaScriptBlock Class > PdfJavaScriptBlock Constructor : PdfJavaScriptBlock Constructor(String)
The JavaScript code to be included in the fragment.
Initializes a new PdfJavaScriptBlock object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal javaScript As String _
)
'Usage

Dim javaScript As String

Dim instance As New PdfJavaScriptBlock(javaScript)
public PdfJavaScriptBlock(
   string javaScript
)
public:
PdfJavaScriptBlock(
   String^ javaScript
)

Parameters

javaScript
The JavaScript code to be included in the fragment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlock Class
PdfJavaScriptBlock Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfJavaScriptBlock Class Properties

Xfinium.Pdf Namespace : PdfJavaScriptBlock Class

For a list of all members of this type, see PdfJavaScriptBlock members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name.
Public Property | SourceCode | Gets or sets the JavaScript source code.
Top
See Also

Reference

PdfJavaScriptBlock Class
Xfinium.Pdf Namespace


Name Property (PdfJavaScriptBlock)

Xfinium.Pdf Namespace > PdfJavaScriptBlock Class : Name Property
Gets or sets the name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfJavaScriptBlock
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name associated with the JavaScript block.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlock Class
PdfJavaScriptBlock Members


SourceCode Property

Xfinium.Pdf Namespace > PdfJavaScriptBlock Class : SourceCode Property
Gets or sets the JavaScript source code.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SourceCode As String
'Usage

Dim instance As PdfJavaScriptBlock
Dim value As String

instance.SourceCode = value

value = instance.SourceCode
public string SourceCode {get; set;}
public:
property String^ SourceCode {
   String^ get();
   void set (    String^ value);
}

Property Value

JavaScript source code.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlock Class
PdfJavaScriptBlock Members


%%PageItemTitle%%

PdfJavaScriptBlockCollection Class
Members

Xfinium.Pdf Namespace : PdfJavaScriptBlockCollection Class
Defines a collection of JavaScript source code blocks.
Object Model
PdfJavaScriptBlockCollection ClassPdfJavaScriptBlock Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfJavaScriptBlockCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfJavaScriptBlock)
'Usage

Dim instance As PdfJavaScriptBlockCollection
[DefaultMember("Item")]
public class PdfJavaScriptBlockCollection : System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>
[DefaultMember("Item")]
public ref class PdfJavaScriptBlockCollection : public System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfJavaScriptBlockCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlockCollection Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfJavaScriptBlockCollection Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfJavaScriptBlockCollection Class

The following tables list the members exposed by PdfJavaScriptBlockCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Property | Item | Gets the JavaScript fragment with the specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new JavaScript action to the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Top
See Also

Reference

PdfJavaScriptBlockCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Methods$$

PdfJavaScriptBlockCollection Class Methods

Xfinium.Pdf Namespace : PdfJavaScriptBlockCollection Class

For a list of all members of this type, see PdfJavaScriptBlockCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new JavaScript action to the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Top
See Also

Reference

PdfJavaScriptBlockCollection Class
Xfinium.Pdf Namespace


Add Method (PdfJavaScriptBlockCollection)

Xfinium.Pdf Namespace > PdfJavaScriptBlockCollection Class : Add Method
Adds a new JavaScript action to the collection.
Overload List
Overload | Description
Add(String) | Adds a new JavaScript action to the collection.
Add(PdfJavaScriptBlock) | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlockCollection Class
PdfJavaScriptBlockCollection Members


Add(String) Method

Xfinium.Pdf Namespace > PdfJavaScriptBlockCollection Class > Add Method : Add(String) Method
The JavaScript code.
Adds a new JavaScript action to the collection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal javaScript As String _
)
'Usage

Dim instance As PdfJavaScriptBlockCollection
Dim javaScript As String

instance.Add(javaScript)
public void Add(
   string javaScript
)
public:
void Add(
   String^ javaScript
)

Parameters

javaScript
The JavaScript code.
Remarks
This method adds a JavaScript code fragment in the collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlockCollection Class
PdfJavaScriptBlockCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfJavaScriptBlockCollection Class Properties

Xfinium.Pdf Namespace : PdfJavaScriptBlockCollection Class

For a list of all members of this type, see PdfJavaScriptBlockCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfJavaScriptBlock>)
Public Property | Item | Gets the JavaScript fragment with the specified name.
Top
See Also

Reference

PdfJavaScriptBlockCollection Class
Xfinium.Pdf Namespace


Item Property (PdfJavaScriptBlockCollection)

Xfinium.Pdf Namespace > PdfJavaScriptBlockCollection Class : Item Property
Name of the JavaScript fragment to retrieve.
Gets the JavaScript fragment with the specified name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal name As String _
) As PdfJavaScriptBlock
'Usage

Dim instance As PdfJavaScriptBlockCollection
Dim name As String
Dim value As PdfJavaScriptBlock

value = instance.Item(name)
public new PdfJavaScriptBlock this[
   string name
]; {get;}
public:
new property PdfJavaScriptBlock^ default [String^] {
   PdfJavaScriptBlock^ get(String^ name);
}

Parameters

name
Name of the JavaScript fragment to retrieve.

Property Value

The JavaScript fragment with the specified name or null if the name is not found.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptBlockCollection Class
PdfJavaScriptBlockCollection Members


%%PageItemTitle%%

PdfOutlineItem Class
Members

Xfinium.Pdf Namespace : PdfOutlineItem Class
Defines a PDF outline item.
Object Model
PdfOutlineItem ClassPdfAction ClassPdfRgbColor ClassPdfCosDictionary ClassPdfDestination ClassPdfOutlineItemCollection ClassPdfOutlineItem ClassPdfOutlineItem Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOutlineItem
'Usage

Dim instance As PdfOutlineItem
public class PdfOutlineItem
public ref class PdfOutlineItem
Remarks
An outline item defines an entry in the document outline.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfOutlineItem

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfOutlineItem Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfOutlineItem Class

The following tables list the members exposed by PdfOutlineItem.

Public Constructors
 | Name | Description
Public Constructor | PdfOutlineItem Constructor | Initializes a new PdfOutlineItem object.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the outline item action.
Public Property | Color | Gets or sets the color.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | Destination | Gets or sets the outline item destination.
Public Property | Expanded | Gets or sets a value indicating the initial state of the outline item.
Public Property | Items | Gets the collection of child outline items.
Public Property | Parent | Gets the parent of the outline item.
Public Property | Title | Gets or sets the title.
Public Property | VisualStyle | Gets or sets the visual style.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfOutlineItem Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfOutlineItem Constructor

Xfinium.Pdf Namespace > PdfOutlineItem Class : PdfOutlineItem Constructor
Initializes a new PdfOutlineItem object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfOutlineItem()
public PdfOutlineItem()
public:
PdfOutlineItem();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


%%PageItemTitle%% $$Methods$$

PdfOutlineItem Class Methods

Xfinium.Pdf Namespace : PdfOutlineItem Class

For a list of all members of this type, see PdfOutlineItem members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfOutlineItem Class
Xfinium.Pdf Namespace


ToString Method (PdfOutlineItem)

Xfinium.Pdf Namespace > PdfOutlineItem Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfOutlineItem
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


%%PageItemTitle%% $$Properties$$

PdfOutlineItem Class Properties

Xfinium.Pdf Namespace : PdfOutlineItem Class

For a list of all members of this type, see PdfOutlineItem members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the outline item action.
Public Property | Color | Gets or sets the color.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | Destination | Gets or sets the outline item destination.
Public Property | Expanded | Gets or sets a value indicating the initial state of the outline item.
Public Property | Items | Gets the collection of child outline items.
Public Property | Parent | Gets the parent of the outline item.
Public Property | Title | Gets or sets the title.
Public Property | VisualStyle | Gets or sets the visual style.
Top
See Also

Reference

PdfOutlineItem Class
Xfinium.Pdf Namespace


Action Property (PdfOutlineItem)

Xfinium.Pdf Namespace > PdfOutlineItem Class : Action Property
Gets or sets the outline item action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Action As PdfAction
'Usage

Dim instance As PdfOutlineItem
Dim value As PdfAction

instance.Action = value

value = instance.Action
public PdfAction Action {get; set;}
public:
property PdfAction^ Action {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

The action to be performed when this item is activated.
Remarks
Destination and Action properties are mutually exclusive.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


Color Property (PdfOutlineItem)

Xfinium.Pdf Namespace > PdfOutlineItem Class : Color Property
Gets or sets the color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Color As PdfRgbColor
'Usage

Dim instance As PdfOutlineItem
Dim value As PdfRgbColor

instance.Color = value

value = instance.Color
public PdfRgbColor Color {get; set;}
public:
property PdfRgbColor^ Color {
   PdfRgbColor^ get();
   void set (    PdfRgbColor^ value);
}

Property Value

The color to be used for the outline item's text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


CosDictionary Property (PdfOutlineItem)

Xfinium.Pdf Namespace > PdfOutlineItem Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfOutlineItem
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


Destination Property (PdfOutlineItem)

Xfinium.Pdf Namespace > PdfOutlineItem Class : Destination Property
Gets or sets the outline item destination.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Destination As PdfDestination
'Usage

Dim instance As PdfOutlineItem
Dim value As PdfDestination

instance.Destination = value

value = instance.Destination
public PdfDestination Destination {get; set;}
public:
property PdfDestination^ Destination {
   PdfDestination^ get();
   void set (    PdfDestination^ value);
}

Property Value

The destination to be displayed when this item is activated.
Remarks
Destination and Action properties are mutually exclusive.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


Expanded Property

Xfinium.Pdf Namespace > PdfOutlineItem Class : Expanded Property
Gets or sets a value indicating the initial state of the outline item.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Expanded As Boolean
'Usage

Dim instance As PdfOutlineItem
Dim value As Boolean

instance.Expanded = value

value = instance.Expanded
public bool Expanded {get; set;}
public:
property bool Expanded {
   bool get();
   void set (    bool value);
}

Property Value

If true, the outline item is expanded when it is displayed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


Items Property (PdfOutlineItem)

Xfinium.Pdf Namespace > PdfOutlineItem Class : Items Property
Gets the collection of child outline items.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Items As PdfOutlineItemCollection
'Usage

Dim instance As PdfOutlineItem
Dim value As PdfOutlineItemCollection

value = instance.Items
public PdfOutlineItemCollection Items {get;}
public:
property PdfOutlineItemCollection^ Items {
   PdfOutlineItemCollection^ get();
}

Property Value

A PdfOutlineItemCollection that represents the child outline items.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


Parent Property (PdfOutlineItem)

Xfinium.Pdf Namespace > PdfOutlineItem Class : Parent Property
Gets the parent of the outline item.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As PdfOutlineItem
'Usage

Dim instance As PdfOutlineItem
Dim value As PdfOutlineItem

value = instance.Parent
public PdfOutlineItem Parent {get;}
public:
property PdfOutlineItem^ Parent {
   PdfOutlineItem^ get();
}

Property Value

The parent outline item.
Remarks
This property is null (Nothing in VB.NET) for top level outline items.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


Title Property (PdfOutlineItem)

Xfinium.Pdf Namespace > PdfOutlineItem Class : Title Property
Gets or sets the title.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As PdfOutlineItem
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The text to be displayed on the screen for this item.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


VisualStyle Property

Xfinium.Pdf Namespace > PdfOutlineItem Class : VisualStyle Property
Gets or sets the visual style.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VisualStyle As PdfOutlineItemVisualStyle
'Usage

Dim instance As PdfOutlineItem
Dim value As PdfOutlineItemVisualStyle

instance.VisualStyle = value

value = instance.VisualStyle
public PdfOutlineItemVisualStyle VisualStyle {get; set;}
public:
property PdfOutlineItemVisualStyle VisualStyle {
   PdfOutlineItemVisualStyle get();
   void set (    PdfOutlineItemVisualStyle value);
}

Property Value

A PdfOutlineItemVisualStyle that represents the style for displaying the outline item's text
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


%%PageItemTitle%%

PdfOutlineItemCollection Class
Members

Xfinium.Pdf Namespace : PdfOutlineItemCollection Class
Defines a collection of outline items.
Object Model
PdfOutlineItemCollection ClassPdfOutlineItem Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOutlineItemCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfOutlineItem)
'Usage

Dim instance As PdfOutlineItemCollection
public class PdfOutlineItemCollection : System.Collections.ObjectModel.Collection<PdfOutlineItem>
public ref class PdfOutlineItemCollection : public System.Collections.ObjectModel.Collection<PdfOutlineItem>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfOutlineItemCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItemCollection Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfOutlineItemCollection Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfOutlineItemCollection Class

The following tables list the members exposed by PdfOutlineItemCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Top
See Also

Reference

PdfOutlineItemCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfOutputIntent Class
Members

Xfinium.Pdf Namespace : PdfOutputIntent Class
Defines a PDF output intent.
Object Model
PdfOutputIntent ClassPdfIccColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOutputIntent
'Usage

Dim instance As PdfOutputIntent
public class PdfOutputIntent
public ref class PdfOutputIntent
Remarks
Output intents provide a means for matching the color characteristics of a PDF document with those of a target output device or production environment in which the document will be printed.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfOutputIntent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfOutputIntent Class Members
Properties

Xfinium.Pdf Namespace : PdfOutputIntent Class

The following tables list the members exposed by PdfOutputIntent.

Public Constructors
 | Name | Description
Public Constructor | PdfOutputIntent Constructor | Initializes a new PdfOutputIntent object.
Top
Public Properties
 | Name | Description
Public Property | DestinationOutputProfile | Gets or sets the destination output profile.
Public Property | Info | Gets or sets the output intent info.
Public Property | OutputCondition | Gets or sets the output condition.
Public Property | OutputConditionIdentifier | Gets or sets the output condition identifier.
Public Property | RegistryName | Gets or sets the registry name.
Public Property | Type | Gets of sets the output intent type.
Top
See Also

Reference

PdfOutputIntent Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfOutputIntent Constructor

Xfinium.Pdf Namespace > PdfOutputIntent Class : PdfOutputIntent Constructor
Initializes a new PdfOutputIntent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfOutputIntent()
public PdfOutputIntent()
public:
PdfOutputIntent();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Class
PdfOutputIntent Members


%%PageItemTitle%% $$Properties$$

PdfOutputIntent Class Properties

Xfinium.Pdf Namespace : PdfOutputIntent Class

For a list of all members of this type, see PdfOutputIntent members.

Public Properties
 | Name | Description
Public Property | DestinationOutputProfile | Gets or sets the destination output profile.
Public Property | Info | Gets or sets the output intent info.
Public Property | OutputCondition | Gets or sets the output condition.
Public Property | OutputConditionIdentifier | Gets or sets the output condition identifier.
Public Property | RegistryName | Gets or sets the registry name.
Public Property | Type | Gets of sets the output intent type.
Top
See Also

Reference

PdfOutputIntent Class
Xfinium.Pdf Namespace


DestinationOutputProfile Property

Xfinium.Pdf Namespace > PdfOutputIntent Class : DestinationOutputProfile Property
Gets or sets the destination output profile.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DestinationOutputProfile As PdfIccColorSpace
'Usage

Dim instance As PdfOutputIntent
Dim value As PdfIccColorSpace

instance.DestinationOutputProfile = value

value = instance.DestinationOutputProfile
public PdfIccColorSpace DestinationOutputProfile {get; set;}
public:
property PdfIccColorSpace^ DestinationOutputProfile {
   PdfIccColorSpace^ get();
   void set (    PdfIccColorSpace^ value);
}

Property Value

An ICC profile stream defining the transformation from the PDF document's source colors to output device colorants.
Remarks
Required if OutputConditionIdentifier does not specify a standard production condition; optional otherwise
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Class
PdfOutputIntent Members


Info Property

Xfinium.Pdf Namespace > PdfOutputIntent Class : Info Property
Gets or sets the output intent info.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Info As String
'Usage

Dim instance As PdfOutputIntent
Dim value As String

instance.Info = value

value = instance.Info
public string Info {get; set;}
public:
property String^ Info {
   String^ get();
   void set (    String^ value);
}

Property Value

A human-readable text string containing additional information or comments about the intended target device or production condition.
Remarks
Required if OutputConditionIdentifier does not specify a standard production condition; optional otherwise)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Class
PdfOutputIntent Members


OutputCondition Property

Xfinium.Pdf Namespace > PdfOutputIntent Class : OutputCondition Property
Gets or sets the output condition.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutputCondition As String
'Usage

Dim instance As PdfOutputIntent
Dim value As String

instance.OutputCondition = value

value = instance.OutputCondition
public string OutputCondition {get; set;}
public:
property String^ OutputCondition {
   String^ get();
   void set (    String^ value);
}

Property Value

An ASCII string concisely identifying the intended output device or production condition in human-readable form.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Class
PdfOutputIntent Members


OutputConditionIdentifier Property

Xfinium.Pdf Namespace > PdfOutputIntent Class : OutputConditionIdentifier Property
Gets or sets the output condition identifier.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutputConditionIdentifier As String
'Usage

Dim instance As PdfOutputIntent
Dim value As String

instance.OutputConditionIdentifier = value

value = instance.OutputConditionIdentifier
public string OutputConditionIdentifier {get; set;}
public:
property String^ OutputConditionIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

An ASCII string identifying the intended output device or production condition in human- or machine-readable form.
Remarks
If human-readable, this string may be used in lieu of an OutputCondition string for presentation to the user.
A typical value for this entry would be the name of a production condition maintained in an industry-standard registry such as the ICC Characterization Data Registry.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Class
PdfOutputIntent Members


RegistryName Property

Xfinium.Pdf Namespace > PdfOutputIntent Class : RegistryName Property
Gets or sets the registry name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RegistryName As String
'Usage

Dim instance As PdfOutputIntent
Dim value As String

instance.RegistryName = value

value = instance.RegistryName
public string RegistryName {get; set;}
public:
property String^ RegistryName {
   String^ get();
   void set (    String^ value);
}

Property Value

An ASCII string (conventionally a uniform resource identifier, or URI) identifying the registry in which the condition designated by OutputConditionIdentifier is defined.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Class
PdfOutputIntent Members


Type Property (PdfOutputIntent)

Xfinium.Pdf Namespace > PdfOutputIntent Class : Type Property
Gets of sets the output intent type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Type As PdfOutputIntentType
'Usage

Dim instance As PdfOutputIntent
Dim value As PdfOutputIntentType

instance.Type = value

value = instance.Type
public PdfOutputIntentType Type {get; set;}
public:
property PdfOutputIntentType Type {
   PdfOutputIntentType get();
   void set (    PdfOutputIntentType value);
}

Property Value

The output intent type.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Class
PdfOutputIntent Members


%%PageItemTitle%%

PdfOutputIntentCollection Class
Members

Xfinium.Pdf Namespace : PdfOutputIntentCollection Class
Defines a collection of PDF output intents.
Object Model
PdfOutputIntentCollection ClassPdfOutputIntent Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOutputIntentCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfOutputIntent)
'Usage

Dim instance As PdfOutputIntentCollection
public class PdfOutputIntentCollection : System.Collections.ObjectModel.Collection<PdfOutputIntent>
public ref class PdfOutputIntentCollection : public System.Collections.ObjectModel.Collection<PdfOutputIntent>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfOutputIntentCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntentCollection Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfOutputIntentCollection Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfOutputIntentCollection Class

The following tables list the members exposed by PdfOutputIntentCollection.

Public Constructors
 | Name | Description
Public Constructor | PdfOutputIntentCollection Constructor | Initializes a new PdfOutputIntentCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Top
See Also

Reference

PdfOutputIntentCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfOutputIntentCollection Constructor

Xfinium.Pdf Namespace > PdfOutputIntentCollection Class : PdfOutputIntentCollection Constructor
Initializes a new PdfOutputIntentCollection object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfOutputIntentCollection()
public PdfOutputIntentCollection()
public:
PdfOutputIntentCollection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntentCollection Class
PdfOutputIntentCollection Members


%%PageItemTitle%%

PdfPage Class
Members

Xfinium.Pdf Namespace : PdfPage Class
Defines a PDF page.
Object Model
PdfPage ClassPdfAnnotationCollection ClassPdfAnnotation ClassPdfStandardRectangle ClassPdfStandardRectangle ClassPdfCosDictionary ClassPdfStandardRectangle ClassPdfFixedDocument ClassPdfFieldCollection ClassPdfField ClassPdfPageGraphics ClassPdfStandardRectangle ClassPdfOptionalContentGroupCollection ClassPdfOptionalContentGroup ClassPdfStandardRectangle ClassPdfViewportCollection ClassPdfViewport Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPage
   Inherits PdfContentStreamContainer
'Usage

Dim instance As PdfPage
public class PdfPage : PdfContentStreamContainer
public ref class PdfPage : public PdfContentStreamContainer
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfPage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfPage Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfPage Class

The following tables list the members exposed by PdfPage.

Public Constructors
 | Name | Description
Public Constructor | PdfPage Constructor | Initializes a new PdfPage object.
Top
Public Properties
 | Name | Description
Public Property | Annotations | Gets the annotations.
Public Property | ArtBox | Gets or sets the art box.
Public Property | BleedBox | Gets or sets the bleed box.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | CropBox | Gets or sets the crop box.
Public Property | Document | Gets the PDF document.
Public Property | Fields | Gets the form fields.
Public Property | Graphics | Gets the page graphics.
Public Property | Height | Gets or sets the visual page height.
Public Property | MediaBox | Gets or sets the media box.
Public Property | OptionalContentGroups | Gets the list of optional content groups included in the page content.
Public Property | Rotation | Gets or sets the rotation angle.
Public Property | TrimBox | Gets or sets the trim box.
Public Property | Viewports | Gets or sets the page viewports.
Public Property | Width | Gets or sets the visual page width.
Top
Public Methods
 | Name | Description
Public Method | ConvertStandardPointToVisualPoint | Converts a point from standard PDF coordinate system (origin of coordinate system in bottom left corner of page media box) to visual coordinate system (origin of coordinate system in top left corner of visual page area).
Public Method | ConvertVisualPointToStandardPoint | Converts a point from the visual coordinate system (origin of coordinate system in top left corner of visual page area) to standard PDF coordinate system (origin of coordinate system in bottom left corner of page media box).
Public Method | Save | Saves the Pdf page.
Public Method | SaveGraphics | Saves the page graphics.
Public Method | SaveImages | Saves the images drawn on the Pdf page.
Public Method | SetGraphicsPosition | Sets the position of the page graphics relative to existing page content.
Top
See Also

Reference

PdfPage Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfPage Constructor

Xfinium.Pdf Namespace > PdfPage Class : PdfPage Constructor
Initializes a new PdfPage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPage()
public PdfPage()
public:
PdfPage();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


%%PageItemTitle%% $$Methods$$

PdfPage Class Methods

Xfinium.Pdf Namespace : PdfPage Class

For a list of all members of this type, see PdfPage members.

Public Methods
 | Name | Description
Public Method | ConvertStandardPointToVisualPoint | Converts a point from standard PDF coordinate system (origin of coordinate system in bottom left corner of page media box) to visual coordinate system (origin of coordinate system in top left corner of visual page area).
Public Method | ConvertVisualPointToStandardPoint | Converts a point from the visual coordinate system (origin of coordinate system in top left corner of visual page area) to standard PDF coordinate system (origin of coordinate system in bottom left corner of page media box).
Public Method | Save | Saves the Pdf page.
Public Method | SaveGraphics | Saves the page graphics.
Public Method | SaveImages | Saves the images drawn on the Pdf page.
Public Method | SetGraphicsPosition | Sets the position of the page graphics relative to existing page content.
Top
See Also

Reference

PdfPage Class
Xfinium.Pdf Namespace


ConvertStandardPointToVisualPoint Method

Xfinium.Pdf Namespace > PdfPage Class : ConvertStandardPointToVisualPoint Method
The point in standard PDF coordinates.
Converts a point from standard PDF coordinate system (origin of coordinate system in bottom left corner of page media box) to visual coordinate system (origin of coordinate system in top left corner of visual page area).
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ConvertStandardPointToVisualPoint( _
   ByVal point As PdfPoint _
) As PdfPoint
'Usage

Dim instance As PdfPage
Dim point As PdfPoint
Dim value As PdfPoint

value = instance.ConvertStandardPointToVisualPoint(point)
public PdfPoint ConvertStandardPointToVisualPoint(
   PdfPoint point
)
public:
PdfPoint^ ConvertStandardPointToVisualPoint(
   PdfPoint^ point
)

Parameters

point
The point in standard PDF coordinates.

Return Value

The point in visual coodinates.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


ConvertVisualPointToStandardPoint Method

Xfinium.Pdf Namespace > PdfPage Class : ConvertVisualPointToStandardPoint Method
The point in visual coordinates.
Converts a point from the visual coordinate system (origin of coordinate system in top left corner of visual page area) to standard PDF coordinate system (origin of coordinate system in bottom left corner of page media box).
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ConvertVisualPointToStandardPoint( _
   ByVal point As PdfPoint _
) As PdfPoint
'Usage

Dim instance As PdfPage
Dim point As PdfPoint
Dim value As PdfPoint

value = instance.ConvertVisualPointToStandardPoint(point)
public PdfPoint ConvertVisualPointToStandardPoint(
   PdfPoint point
)
public:
PdfPoint^ ConvertVisualPointToStandardPoint(
   PdfPoint^ point
)

Parameters

point
The point in visual coordinates.

Return Value

The point in standard PDF coodinates.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


Save Method (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : Save Method
Saves the Pdf page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Save()
'Usage

Dim instance As PdfPage

instance.Save()
public void Save()
public:
void Save();
Remarks
The page must be included in a document and the save procedure must be already initiated by a BeginSave(Stream) call.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


SaveGraphics Method

Xfinium.Pdf Namespace > PdfPage Class : SaveGraphics Method
Saves the page graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SaveGraphics()
'Usage

Dim instance As PdfPage

instance.SaveGraphics()
public void SaveGraphics()
public:
void SaveGraphics();
Remarks
The page graphics can be composed internally of multiple fragments. If you are working with large vector graphics, such as maps, then you can split the page graphics in fragments and save each fragmment as soon as it is done in order to reduce memory consumption. A graphics fragment is automatically created when Xfinium.Pdf.Graphics.PdfPageGraphics.Compress method is called.
The page must be included in a document and the save procedure must be already initiated by a BeginSave(Stream) call.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


SaveImages Method

Xfinium.Pdf Namespace > PdfPage Class : SaveImages Method
Saves the images drawn on the Pdf page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SaveImages()
'Usage

Dim instance As PdfPage

instance.SaveImages()
public void SaveImages()
public:
void SaveImages();
Remarks
The page must be included in a document and the save procedure must be already initiated by a BeginSave(Stream) call.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


SetGraphicsPosition Method

Xfinium.Pdf Namespace > PdfPage Class : SetGraphicsPosition Method
Position of the page graphics.
Sets the position of the page graphics relative to existing page content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetGraphicsPosition( _
   ByVal graphicsPosition As PdfPageGraphicsPosition _
)
'Usage

Dim instance As PdfPage
Dim graphicsPosition As PdfPageGraphicsPosition

instance.SetGraphicsPosition(graphicsPosition)
public void SetGraphicsPosition(
   PdfPageGraphicsPosition graphicsPosition
)
public:
void SetGraphicsPosition(
   PdfPageGraphicsPosition graphicsPosition
)

Parameters

graphicsPosition
Position of the page graphics.
Remarks
If the page is newly created this method has no effect since there is no previous content. If the page has been extracted from a Pdf file or has been created by loading a Pdf file into a PdfFixedDocument then the page graphics can be under the existing page content or on top of existing page content (default).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


%%PageItemTitle%% $$Properties$$

PdfPage Class Properties

Xfinium.Pdf Namespace : PdfPage Class

For a list of all members of this type, see PdfPage members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the annotations.
Public Property | ArtBox | Gets or sets the art box.
Public Property | BleedBox | Gets or sets the bleed box.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | CropBox | Gets or sets the crop box.
Public Property | Document | Gets the PDF document.
Public Property | Fields | Gets the form fields.
Public Property | Graphics | Gets the page graphics.
Public Property | Height | Gets or sets the visual page height.
Public Property | MediaBox | Gets or sets the media box.
Public Property | OptionalContentGroups | Gets the list of optional content groups included in the page content.
Public Property | Rotation | Gets or sets the rotation angle.
Public Property | TrimBox | Gets or sets the trim box.
Public Property | Viewports | Gets or sets the page viewports.
Public Property | Width | Gets or sets the visual page width.
Top
See Also

Reference

PdfPage Class
Xfinium.Pdf Namespace


Annotations Property

Xfinium.Pdf Namespace > PdfPage Class : Annotations Property
Gets the annotations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Annotations As PdfAnnotationCollection
'Usage

Dim instance As PdfPage
Dim value As PdfAnnotationCollection

value = instance.Annotations
public PdfAnnotationCollection Annotations {get;}
public:
property PdfAnnotationCollection^ Annotations {
   PdfAnnotationCollection^ get();
}

Property Value

The list of annotations associated with the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


ArtBox Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : ArtBox Property
Gets or sets the art box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ArtBox As PdfStandardRectangle
'Usage

Dim instance As PdfPage
Dim value As PdfStandardRectangle

instance.ArtBox = value

value = instance.ArtBox
public PdfStandardRectangle ArtBox {get; set;}
public:
property PdfStandardRectangle^ ArtBox {
   PdfStandardRectangle^ get();
   void set (    PdfStandardRectangle^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the extent of the page's meaningful content (including potential white space) as intended by the page's creator
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


BleedBox Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : BleedBox Property
Gets or sets the bleed box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BleedBox As PdfStandardRectangle
'Usage

Dim instance As PdfPage
Dim value As PdfStandardRectangle

instance.BleedBox = value

value = instance.BleedBox
public PdfStandardRectangle BleedBox {get; set;}
public:
property PdfStandardRectangle^ BleedBox {
   PdfStandardRectangle^ get();
   void set (    PdfStandardRectangle^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the region to which the contents of the page should be clipped when output in a production environment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


CosDictionary Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfPage
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


CropBox Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : CropBox Property
Gets or sets the crop box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CropBox As PdfStandardRectangle
'Usage

Dim instance As PdfPage
Dim value As PdfStandardRectangle

instance.CropBox = value

value = instance.CropBox
public PdfStandardRectangle CropBox {get; set;}
public:
property PdfStandardRectangle^ CropBox {
   PdfStandardRectangle^ get();
   void set (    PdfStandardRectangle^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the visible region of default user space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


Document Property

Xfinium.Pdf Namespace > PdfPage Class : Document Property
Gets the PDF document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Document As PdfFixedDocument
'Usage

Dim instance As PdfPage
Dim value As PdfFixedDocument

value = instance.Document
public PdfFixedDocument Document {get;}
public:
property PdfFixedDocument^ Document {
   PdfFixedDocument^ get();
}

Property Value

The document in which this page is included.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


Fields Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : Fields Property
Gets the form fields.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As PdfFieldCollection
'Usage

Dim instance As PdfPage
Dim value As PdfFieldCollection

value = instance.Fields
public PdfFieldCollection Fields {get;}
public:
property PdfFieldCollection^ Fields {
   PdfFieldCollection^ get();
}

Property Value

The list of form fields associated with the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


Graphics Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : Graphics Property
Gets the page graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Graphics As PdfPageGraphics
'Usage

Dim instance As PdfPage
Dim value As PdfPageGraphics

value = instance.Graphics
public PdfPageGraphics Graphics {get;}
public:
property PdfPageGraphics^ Graphics {
   PdfPageGraphics^ get();
}

Property Value

The page graphics surface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


Height Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : Height Property
Gets or sets the visual page height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PdfPage
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The visual height of the page.
Remarks
The visual height is the height of the page as it is seen on the display. It is always measured on vertical no matter the page rotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


MediaBox Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : MediaBox Property
Gets or sets the media box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MediaBox As PdfStandardRectangle
'Usage

Dim instance As PdfPage
Dim value As PdfStandardRectangle

instance.MediaBox = value

value = instance.MediaBox
public PdfStandardRectangle MediaBox {get; set;}
public:
property PdfStandardRectangle^ MediaBox {
   PdfStandardRectangle^ get();
   void set (    PdfStandardRectangle^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the boundaries of the physical medium on which the page is intended to be displayed or printed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


OptionalContentGroups Property

Xfinium.Pdf Namespace > PdfPage Class : OptionalContentGroups Property
Gets the list of optional content groups included in the page content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OptionalContentGroups As PdfOptionalContentGroupCollection
'Usage

Dim instance As PdfPage
Dim value As PdfOptionalContentGroupCollection

value = instance.OptionalContentGroups
public PdfOptionalContentGroupCollection OptionalContentGroups {get;}
public:
property PdfOptionalContentGroupCollection^ OptionalContentGroups {
   PdfOptionalContentGroupCollection^ get();
}

Property Value

The list of optional content groups included in the page content
Remarks
This collection is filled automatically with the optional content groups drawn on the page, either when page content is created or when a page is loaded from a source file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


Rotation Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : Rotation Property
Gets or sets the rotation angle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Rotation As Integer
'Usage

Dim instance As PdfPage
Dim value As Integer

instance.Rotation = value

value = instance.Rotation
public int Rotation {get; set;}
public:
property int Rotation {
   int get();
   void set (    int value);
}

Property Value

The number of degrees by which the page should be rotated clockwise when displayed or printed.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value being set is not one of the accepted values.
Remarks
The accepted values for this property are 0, 90, 180 and 270 degrees.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


TrimBox Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : TrimBox Property
Gets or sets the trim box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TrimBox As PdfStandardRectangle
'Usage

Dim instance As PdfPage
Dim value As PdfStandardRectangle

instance.TrimBox = value

value = instance.TrimBox
public PdfStandardRectangle TrimBox {get; set;}
public:
property PdfStandardRectangle^ TrimBox {
   PdfStandardRectangle^ get();
   void set (    PdfStandardRectangle^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the intended dimensions of the finished page after trimming.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


Viewports Property

Xfinium.Pdf Namespace > PdfPage Class : Viewports Property
Gets or sets the page viewports.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Viewports As PdfViewportCollection
'Usage

Dim instance As PdfPage
Dim value As PdfViewportCollection

instance.Viewports = value

value = instance.Viewports
public PdfViewportCollection Viewports {get; set;}
public:
property PdfViewportCollection^ Viewports {
   PdfViewportCollection^ get();
   void set (    PdfViewportCollection^ value);
}

Property Value

A collection of viewports defined on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


Width Property (PdfPage)

Xfinium.Pdf Namespace > PdfPage Class : Width Property
Gets or sets the visual page width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PdfPage
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The visual width of the page.
Remarks
The visual width is the width of the page as it is seen on the display. It is always measured on horizontal no matter the page rotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


%%PageItemTitle%%

PdfPageCollection Class
Members

Xfinium.Pdf Namespace : PdfPageCollection Class
Defines a collection of PDF pages.
Object Model
PdfPageCollection ClassPdfPage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfPage)
'Usage

Dim instance As PdfPageCollection
public class PdfPageCollection : System.Collections.ObjectModel.Collection<PdfPage>
public ref class PdfPageCollection : public System.Collections.ObjectModel.Collection<PdfPage>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfPageCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageCollection Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfPageCollection Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfPageCollection Class

The following tables list the members exposed by PdfPageCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new page at the end of the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Top
See Also

Reference

PdfPageCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Methods$$

PdfPageCollection Class Methods

Xfinium.Pdf Namespace : PdfPageCollection Class

For a list of all members of this type, see PdfPageCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new page at the end of the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Top
See Also

Reference

PdfPageCollection Class
Xfinium.Pdf Namespace


Add Method (PdfPageCollection)

Xfinium.Pdf Namespace > PdfPageCollection Class : Add Method
Adds a new page at the end of the collection.
Overload List
Overload | Description
Add() | Adds a new page at the end of the collection.
Add(PdfPage) | Adds a new page at the end of the collection. (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageCollection Class
PdfPageCollection Members


Add() Method

Xfinium.Pdf Namespace > PdfPageCollection Class > Add Method : Add() Method
Adds a new page at the end of the collection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Add() As PdfPage
'Usage

Dim instance As PdfPageCollection
Dim value As PdfPage

value = instance.Add()
public PdfPage Add()
public:
PdfPage^ Add();

Return Value

The new page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageCollection Class
PdfPageCollection Members
Overload List


%%PageItemTitle%%

PdfPageLabelingRange Class
Members

Xfinium.Pdf Namespace : PdfPageLabelingRange Class
Defines a labeling range for PDF pages.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageLabelingRange
'Usage

Dim instance As PdfPageLabelingRange
public class PdfPageLabelingRange
public ref class PdfPageLabelingRange
Remarks
a document can be divided into labeling ranges, each of which is a series of consecutive pages using the same numbering system. Pages within a range are numbered sequentially in ascending order. A page's label consists of a numeric portion based on its position within its labeling range, optionally preceded by a label prefix denoting the range itself.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfPageLabelingRange

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageLabelingRange Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfPageLabelingRange Class Members
Properties

Xfinium.Pdf Namespace : PdfPageLabelingRange Class

The following tables list the members exposed by PdfPageLabelingRange.

Public Constructors
 | Name | Description
Public Constructor | PdfPageLabelingRange Constructor | Initializes a new PdfPageLabelingRange object.
Top
Public Properties
 | Name | Description
Public Property | DocumentPageNumber | Gets or sets the page number in the document where the labeling range starts.
Public Property | LabelPageNumber | Gets or sets the label page number.
Public Property | PageLabelNumberStyle | Gets or sets the numbering style.
Public Property | Prefix | Gets or sets the prefix.
Top
See Also

Reference

PdfPageLabelingRange Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfPageLabelingRange Constructor

Xfinium.Pdf Namespace > PdfPageLabelingRange Class : PdfPageLabelingRange Constructor
Initializes a new PdfPageLabelingRange object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPageLabelingRange()
public PdfPageLabelingRange()
public:
PdfPageLabelingRange();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageLabelingRange Class
PdfPageLabelingRange Members


%%PageItemTitle%% $$Properties$$

PdfPageLabelingRange Class Properties

Xfinium.Pdf Namespace : PdfPageLabelingRange Class

For a list of all members of this type, see PdfPageLabelingRange members.

Public Properties
 | Name | Description
Public Property | DocumentPageNumber | Gets or sets the page number in the document where the labeling range starts.
Public Property | LabelPageNumber | Gets or sets the label page number.
Public Property | PageLabelNumberStyle | Gets or sets the numbering style.
Public Property | Prefix | Gets or sets the prefix.
Top
See Also

Reference

PdfPageLabelingRange Class
Xfinium.Pdf Namespace


DocumentPageNumber Property

Xfinium.Pdf Namespace > PdfPageLabelingRange Class : DocumentPageNumber Property
Gets or sets the page number in the document where the labeling range starts.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DocumentPageNumber As Integer
'Usage

Dim instance As PdfPageLabelingRange
Dim value As Integer

instance.DocumentPageNumber = value

value = instance.DocumentPageNumber
public int DocumentPageNumber {get; set;}
public:
property int DocumentPageNumber {
   int get();
   void set (    int value);
}

Property Value

An index in the document's Pages collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageLabelingRange Class
PdfPageLabelingRange Members


LabelPageNumber Property

Xfinium.Pdf Namespace > PdfPageLabelingRange Class : LabelPageNumber Property
Gets or sets the label page number.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LabelPageNumber As Integer
'Usage

Dim instance As PdfPageLabelingRange
Dim value As Integer

instance.LabelPageNumber = value

value = instance.LabelPageNumber
public int LabelPageNumber {get; set;}
public:
property int LabelPageNumber {
   int get();
   void set (    int value);
}

Property Value

The value of the numeric portion for the first page label in the range.
Remarks
Subsequent pages are numbered sequentially from this value, which must be greater than or equal to 1.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageLabelingRange Class
PdfPageLabelingRange Members


PageLabelNumberStyle Property

Xfinium.Pdf Namespace > PdfPageLabelingRange Class : PageLabelNumberStyle Property
Gets or sets the numbering style.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageLabelNumberStyle As PdfPageLabelNumberStyle
'Usage

Dim instance As PdfPageLabelingRange
Dim value As PdfPageLabelNumberStyle

instance.PageLabelNumberStyle = value

value = instance.PageLabelNumberStyle
public PdfPageLabelNumberStyle PageLabelNumberStyle {get; set;}
public:
property PdfPageLabelNumberStyle PageLabelNumberStyle {
   PdfPageLabelNumberStyle get();
   void set (    PdfPageLabelNumberStyle value);
}

Property Value

A PdfPageLabelNumberStyle that represents the numbering style to be used for the numeric portion of each page label.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageLabelingRange Class
PdfPageLabelingRange Members


Prefix Property (PdfPageLabelingRange)

Xfinium.Pdf Namespace > PdfPageLabelingRange Class : Prefix Property
Gets or sets the prefix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Prefix As String
'Usage

Dim instance As PdfPageLabelingRange
Dim value As String

instance.Prefix = value

value = instance.Prefix
public string Prefix {get; set;}
public:
property String^ Prefix {
   String^ get();
   void set (    String^ value);
}

Property Value

The label prefix for page labels in this range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageLabelingRange Class
PdfPageLabelingRange Members


%%PageItemTitle%%

PdfPageLabelingRangeCollection Class
Members

Xfinium.Pdf Namespace : PdfPageLabelingRangeCollection Class
Defines a collection of page labels.
Object Model
PdfPageLabelingRangeCollection ClassPdfPageLabelingRange Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageLabelingRangeCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfPageLabelingRange)
'Usage

Dim instance As PdfPageLabelingRangeCollection
public class PdfPageLabelingRangeCollection : System.Collections.ObjectModel.Collection<PdfPageLabelingRange>
public ref class PdfPageLabelingRangeCollection : public System.Collections.ObjectModel.Collection<PdfPageLabelingRange>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfPageLabelingRangeCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageLabelingRangeCollection Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfPageLabelingRangeCollection Class Members
Properties Methods

Xfinium.Pdf Namespace : PdfPageLabelingRangeCollection Class

The following tables list the members exposed by PdfPageLabelingRangeCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Top
See Also

Reference

PdfPageLabelingRangeCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfVersionExtension Class
Members

Xfinium.Pdf Namespace : PdfVersionExtension Class
Defines an extension to an existing PDF version.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfVersionExtension
'Usage

Dim instance As PdfVersionExtension
public class PdfVersionExtension
public ref class PdfVersionExtension
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfVersionExtension

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVersionExtension Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfVersionExtension Class Members
Properties

Xfinium.Pdf Namespace : PdfVersionExtension Class

The following tables list the members exposed by PdfVersionExtension.

Public Constructors
 | Name | Description
Public Constructor | PdfVersionExtension Constructor | Initializes a new PdfVersionExtension object.
Top
Public Properties
 | Name | Description
Public Property | Level | Gets or sets the extension level.
Public Property | PdfVersion | Gets or sets the extended PDF version.
Top
See Also

Reference

PdfVersionExtension Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfVersionExtension Constructor

Xfinium.Pdf Namespace > PdfVersionExtension Class : PdfVersionExtension Constructor
Initializes a new PdfVersionExtension object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfVersionExtension()
public PdfVersionExtension()
public:
PdfVersionExtension();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVersionExtension Class
PdfVersionExtension Members


%%PageItemTitle%% $$Properties$$

PdfVersionExtension Class Properties

Xfinium.Pdf Namespace : PdfVersionExtension Class

For a list of all members of this type, see PdfVersionExtension members.

Public Properties
 | Name | Description
Public Property | Level | Gets or sets the extension level.
Public Property | PdfVersion | Gets or sets the extended PDF version.
Top
See Also

Reference

PdfVersionExtension Class
Xfinium.Pdf Namespace


Level Property (PdfVersionExtension)

Xfinium.Pdf Namespace > PdfVersionExtension Class : Level Property
Gets or sets the extension level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Level As Integer
'Usage

Dim instance As PdfVersionExtension
Dim value As Integer

instance.Level = value

value = instance.Level
public int Level {get; set;}
public:
property int Level {
   int get();
   void set (    int value);
}

Property Value

The extension level over an existing PDF specification.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVersionExtension Class
PdfVersionExtension Members


PdfVersion Property (PdfVersionExtension)

Xfinium.Pdf Namespace > PdfVersionExtension Class : PdfVersion Property
Gets or sets the extended PDF version.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PdfVersion As PdfVersion
'Usage

Dim instance As PdfVersionExtension
Dim value As PdfVersion

instance.PdfVersion = value

value = instance.PdfVersion
public PdfVersion PdfVersion {get; set;}
public:
property PdfVersion PdfVersion {
   PdfVersion get();
   void set (    PdfVersion value);
}

Property Value

A PdfVersion that specifies the extended Pdf version.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVersionExtension Class
PdfVersionExtension Members


%%PageItemTitle%%

PdfViewerPreferences Class
Members

Xfinium.Pdf Namespace : PdfViewerPreferences Class
Defines the way the document is to be presented on the screen or in print.
Object Model
PdfViewerPreferences ClassPdfCosDictionary Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfViewerPreferences
'Usage

Dim instance As PdfViewerPreferences
public class PdfViewerPreferences
public ref class PdfViewerPreferences
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfViewerPreferences

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfViewerPreferences Class Members
Properties

Xfinium.Pdf Namespace : PdfViewerPreferences Class

The following tables list the members exposed by PdfViewerPreferences.

Public Constructors
 | Name | Description
Public Constructor | PdfViewerPreferences Constructor | Initializes a new PdfViewerPreferences object.
Top
Public Properties
 | Name | Description
Public Property | CenterWindow | Gets or sets a value indicating whether to position the document's window in the center of the screen.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | DisplayDocumentTitle | Gets or sets a value indicating whether the window's title bar should display the document title taken from the PdfDocumentInformation.Title.
Public Property | DuplexPrinting | Gets of set the recommended duplex printing mode.
Public Property | FitWindow | Gets or sets a value indicating whether to resize the document's window to fit the size of the first displayed page.
Public Property | HideMenubar | Gets or sets a value indicating whether to hide the viewer application's menu bar when the document is active.
Public Property | HideToolbar | Gets or sets a value indicating whether to hide the viewer application's tool bars when the document is active.
Public Property | HideWindowUI | Gets or sets a value indicating whether to hide user interface elements.
Public Property | NonFullScreenPageMode | Gets or sets the document's page mode.
Public Property | NumberOfCopies | Gets or sets number of copies that shall be printed.
Public Property | PickTrayByPdfSize | Gets or sets a value indicating whether the PDF page size shall be used to select the input paper tray.
Public Property | PrintPageRange | Gets or sets the print page range.
Public Property | PrintScaling | Gets or sets how the print scaling.
Top
See Also

Reference

PdfViewerPreferences Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfViewerPreferences Constructor

Xfinium.Pdf Namespace > PdfViewerPreferences Class : PdfViewerPreferences Constructor
Initializes a new PdfViewerPreferences object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfViewerPreferences()
public PdfViewerPreferences()
public:
PdfViewerPreferences();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


%%PageItemTitle%% $$Properties$$

PdfViewerPreferences Class Properties

Xfinium.Pdf Namespace : PdfViewerPreferences Class

For a list of all members of this type, see PdfViewerPreferences members.

Public Properties
 | Name | Description
Public Property | CenterWindow | Gets or sets a value indicating whether to position the document's window in the center of the screen.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | DisplayDocumentTitle | Gets or sets a value indicating whether the window's title bar should display the document title taken from the PdfDocumentInformation.Title.
Public Property | DuplexPrinting | Gets of set the recommended duplex printing mode.
Public Property | FitWindow | Gets or sets a value indicating whether to resize the document's window to fit the size of the first displayed page.
Public Property | HideMenubar | Gets or sets a value indicating whether to hide the viewer application's menu bar when the document is active.
Public Property | HideToolbar | Gets or sets a value indicating whether to hide the viewer application's tool bars when the document is active.
Public Property | HideWindowUI | Gets or sets a value indicating whether to hide user interface elements.
Public Property | NonFullScreenPageMode | Gets or sets the document's page mode.
Public Property | NumberOfCopies | Gets or sets number of copies that shall be printed.
Public Property | PickTrayByPdfSize | Gets or sets a value indicating whether the PDF page size shall be used to select the input paper tray.
Public Property | PrintPageRange | Gets or sets the print page range.
Public Property | PrintScaling | Gets or sets how the print scaling.
Top
See Also

Reference

PdfViewerPreferences Class
Xfinium.Pdf Namespace


CenterWindow Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : CenterWindow Property
Gets or sets a value indicating whether to position the document's window in the center of the screen.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CenterWindow As Boolean
'Usage

Dim instance As PdfViewerPreferences
Dim value As Boolean

instance.CenterWindow = value

value = instance.CenterWindow
public bool CenterWindow {get; set;}
public:
property bool CenterWindow {
   bool get();
   void set (    bool value);
}

Property Value

If true, the document's window is position in the center of the screen.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


CosDictionary Property (PdfViewerPreferences)

Xfinium.Pdf Namespace > PdfViewerPreferences Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfViewerPreferences
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


DisplayDocumentTitle Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : DisplayDocumentTitle Property
Gets or sets a value indicating whether the window's title bar should display the document title taken from the PdfDocumentInformation.Title.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisplayDocumentTitle As Boolean
'Usage

Dim instance As PdfViewerPreferences
Dim value As Boolean

instance.DisplayDocumentTitle = value

value = instance.DisplayDocumentTitle
public bool DisplayDocumentTitle {get; set;}
public:
property bool DisplayDocumentTitle {
   bool get();
   void set (    bool value);
}

Property Value

If true, the window's title bar should display the document title taken from the PdfDocumentInformation.Title. If false, the title bar should instead display the name of the PDF file containing the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


DuplexPrinting Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : DuplexPrinting Property
Gets of set the recommended duplex printing mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DuplexPrinting As PdfDuplexPrinting
'Usage

Dim instance As PdfViewerPreferences
Dim value As PdfDuplexPrinting

instance.DuplexPrinting = value

value = instance.DuplexPrinting
public PdfDuplexPrinting DuplexPrinting {get; set;}
public:
property PdfDuplexPrinting DuplexPrinting {
   PdfDuplexPrinting get();
   void set (    PdfDuplexPrinting value);
}

Property Value

The duplex print option to be selected when a print dialog is displayed for this document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


FitWindow Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : FitWindow Property
Gets or sets a value indicating whether to resize the document's window to fit the size of the first displayed page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FitWindow As Boolean
'Usage

Dim instance As PdfViewerPreferences
Dim value As Boolean

instance.FitWindow = value

value = instance.FitWindow
public bool FitWindow {get; set;}
public:
property bool FitWindow {
   bool get();
   void set (    bool value);
}

Property Value

If true, the document window is resized.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


HideMenubar Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : HideMenubar Property
Gets or sets a value indicating whether to hide the viewer application's menu bar when the document is active.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HideMenubar As Boolean
'Usage

Dim instance As PdfViewerPreferences
Dim value As Boolean

instance.HideMenubar = value

value = instance.HideMenubar
public bool HideMenubar {get; set;}
public:
property bool HideMenubar {
   bool get();
   void set (    bool value);
}

Property Value

If true, the menubar is hidden.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


HideToolbar Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : HideToolbar Property
Gets or sets a value indicating whether to hide the viewer application's tool bars when the document is active.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HideToolbar As Boolean
'Usage

Dim instance As PdfViewerPreferences
Dim value As Boolean

instance.HideToolbar = value

value = instance.HideToolbar
public bool HideToolbar {get; set;}
public:
property bool HideToolbar {
   bool get();
   void set (    bool value);
}

Property Value

If true, the toolbar is hidden.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


HideWindowUI Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : HideWindowUI Property
Gets or sets a value indicating whether to hide user interface elements.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HideWindowUI As Boolean
'Usage

Dim instance As PdfViewerPreferences
Dim value As Boolean

instance.HideWindowUI = value

value = instance.HideWindowUI
public bool HideWindowUI {get; set;}
public:
property bool HideWindowUI {
   bool get();
   void set (    bool value);
}

Property Value

If true, user interface elements in the document’s window (such as scroll bars and navigation controls) are hidden, leaving only the document's contents displayed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


NonFullScreenPageMode Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : NonFullScreenPageMode Property
Gets or sets the document's page mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NonFullScreenPageMode As PdfDisplayMode
'Usage

Dim instance As PdfViewerPreferences
Dim value As PdfDisplayMode

instance.NonFullScreenPageMode = value

value = instance.NonFullScreenPageMode
public PdfDisplayMode NonFullScreenPageMode {get; set;}
public:
property PdfDisplayMode NonFullScreenPageMode {
   PdfDisplayMode get();
   void set (    PdfDisplayMode value);
}

Property Value

The document's page mode, specifying how to display the document on exiting full-screen mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


NumberOfCopies Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : NumberOfCopies Property
Gets or sets number of copies that shall be printed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NumberOfCopies As Integer
'Usage

Dim instance As PdfViewerPreferences
Dim value As Integer

instance.NumberOfCopies = value

value = instance.NumberOfCopies
public int NumberOfCopies {get; set;}
public:
property int NumberOfCopies {
   int get();
   void set (    int value);
}

Property Value

The number of copies that shall be printed when the print dialog is opened for this document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


PickTrayByPdfSize Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : PickTrayByPdfSize Property
Gets or sets a value indicating whether the PDF page size shall be used to select the input paper tray.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PickTrayByPdfSize As Boolean
'Usage

Dim instance As PdfViewerPreferences
Dim value As Boolean

instance.PickTrayByPdfSize = value

value = instance.PickTrayByPdfSize
public bool PickTrayByPdfSize {get; set;}
public:
property bool PickTrayByPdfSize {
   bool get();
   void set (    bool value);
}

Property Value

If true the PDF page size shall be used to select the input paper tray.
Remarks
This setting influences only the preset values used to populate the print dialogue presented by an interactive PDF processor.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


PrintPageRange Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : PrintPageRange Property
Gets or sets the print page range.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PrintPageRange As Integer()
'Usage

Dim instance As PdfViewerPreferences
Dim value() As Integer

instance.PrintPageRange = value

value = instance.PrintPageRange
public int[] PrintPageRange {get; set;}
public:
property array<int>^ PrintPageRange {
   array<int>^ get();
   void set (    array<int>^ value);
}

Property Value

The page numbers used to initialize the print dialogue box when the document is printed.
Remarks
The array shall contain an even number of integers to be interpreted in pairs, with each pair specifying the first and last pages in a sub-range of pages to be printed.The first page of the PDF file shall be denoted by 1.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


PrintScaling Property

Xfinium.Pdf Namespace > PdfViewerPreferences Class : PrintScaling Property
Gets or sets how the print scaling.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PrintScaling As PdfPrintScaling
'Usage

Dim instance As PdfViewerPreferences
Dim value As PdfPrintScaling

instance.PrintScaling = value

value = instance.PrintScaling
public PdfPrintScaling PrintScaling {get; set;}
public:
property PdfPrintScaling PrintScaling {
   PdfPrintScaling get();
   void set (    PdfPrintScaling value);
}

Property Value

The page scaling option to be selected when a print dialog is displayed for this document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


%%PageItemTitle%%

PdfXmpMetadata Class
Members

Xfinium.Pdf Namespace : PdfXmpMetadata Class
Defines the XMP metadata.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfXmpMetadata
'Usage

Dim instance As PdfXmpMetadata
public class PdfXmpMetadata
public ref class PdfXmpMetadata
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfXmpMetadata

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXmpMetadata Members
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Members$$

PdfXmpMetadata Class Members
Properties

Xfinium.Pdf Namespace : PdfXmpMetadata Class

The following tables list the members exposed by PdfXmpMetadata.

Public Constructors
 | Name | Description
Public Constructor | PdfXmpMetadata Constructor | Initializes a new PdfXmpMetadata object.
Top
Public Properties
 | Name | Description
Public Property | Metadata | Gets or sets the XMP metadata.
Top
See Also

Reference

PdfXmpMetadata Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfXmpMetadata Constructor

Xfinium.Pdf Namespace > PdfXmpMetadata Class : PdfXmpMetadata Constructor
Initializes a new PdfXmpMetadata object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfXmpMetadata()
public PdfXmpMetadata()
public:
PdfXmpMetadata();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXmpMetadata Class
PdfXmpMetadata Members


%%PageItemTitle%% $$Properties$$

PdfXmpMetadata Class Properties

Xfinium.Pdf Namespace : PdfXmpMetadata Class

For a list of all members of this type, see PdfXmpMetadata members.

Public Properties
 | Name | Description
Public Property | Metadata | Gets or sets the XMP metadata.
Top
See Also

Reference

PdfXmpMetadata Class
Xfinium.Pdf Namespace


Metadata Property

Xfinium.Pdf Namespace > PdfXmpMetadata Class : Metadata Property
Gets or sets the XMP metadata.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Metadata As String
'Usage

Dim instance As PdfXmpMetadata
Dim value As String

instance.Metadata = value

value = instance.Metadata
public string Metadata {get; set;}
public:
property String^ Metadata {
   String^ get();
   void set (    String^ value);
}

Property Value

The XMP metadata.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXmpMetadata Class
PdfXmpMetadata Members


%%PageItemTitle%%

PdfDisplayMode Enumeration

Xfinium.Pdf Namespace : PdfDisplayMode Enumeration
Supported display modes for a PDF document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfDisplayMode
   Inherits System.Enum
'Usage

Dim instance As PdfDisplayMode
public enum PdfDisplayMode : System.Enum
public enum class PdfDisplayMode : public System.Enum
Members
Member | Description
FullScreen | Full screen mode, with no menu bar, window controls, or any other window visible.
UseAttachments | Attachments panel visible.
UseNone | Neither document outline nor thumbnail images visible.
UseOC | Optional content panel visible.
UseOutlines | Document outline visible.
UseThumbs | Thumbnail images visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfDisplayMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfDuplexPrinting Enumeration

Xfinium.Pdf Namespace : PdfDuplexPrinting Enumeration
Supported values for duplex printing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfDuplexPrinting
   Inherits System.Enum
'Usage

Dim instance As PdfDuplexPrinting
public enum PdfDuplexPrinting : System.Enum
public enum class PdfDuplexPrinting : public System.Enum
Members
Member | Description
DuplexFlipLongEdge | Duplex and flip on the long edge of the sheet.
DuplexFlipShortEdge | Duplex and flip on the short edge of the sheet.
None | No option specified in the PDF file.
Simplex | Print single-sided.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfDuplexPrinting

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfFileAttachmentRelationship Enumeration

Xfinium.Pdf Namespace : PdfFileAttachmentRelationship Enumeration
Specifies the supported relationship types between a file attachment and its owner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFileAttachmentRelationship
   Inherits System.Enum
'Usage

Dim instance As PdfFileAttachmentRelationship
public enum PdfFileAttachmentRelationship : System.Enum
public enum class PdfFileAttachmentRelationship : public System.Enum
Members
Member | Description
Alternative | The file attachment is an alternative representation of content.
Data | The file attachment represents information used to derive a visual presentation.
Source | The file attachment is the original source material for the associated content.
Supplement | The file attachment represents a supplemental representation of the original source or data that may be more easily consumable.
Unspecified | Relationship is not known.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfFileAttachmentRelationship

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfOutlineItemVisualStyle Enumeration

Xfinium.Pdf Namespace : PdfOutlineItemVisualStyle Enumeration
Supported styles for outline item's text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PdfOutlineItemVisualStyle
   Inherits System.Enum
'Usage

Dim instance As PdfOutlineItemVisualStyle
[Flags()]
public enum PdfOutlineItemVisualStyle : System.Enum
[Flags()]
public enum class PdfOutlineItemVisualStyle : public System.Enum
Members
Member | Description
Bold | The outline is displayed using bold font.
Italic | The outline is displayed using italic font.
Regular | The outline is displayed using regular font.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfOutlineItemVisualStyle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfOutputIntentType Enumeration

Xfinium.Pdf Namespace : PdfOutputIntentType Enumeration
Supported output intent types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfOutputIntentType
   Inherits System.Enum
'Usage

Dim instance As PdfOutputIntentType
public enum PdfOutputIntentType : System.Enum
public enum class PdfOutputIntentType : public System.Enum
Members
Member | Description
PdfA1 | Pdf/A-1 output intent.
PdfX | Pdf/X output intent.
Unknown | Unknown output intent.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfOutputIntentType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfPageLabelNumberStyle Enumeration

Xfinium.Pdf Namespace : PdfPageLabelNumberStyle Enumeration
Supported numbering styles for page labels.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPageLabelNumberStyle
   Inherits System.Enum
'Usage

Dim instance As PdfPageLabelNumberStyle
public enum PdfPageLabelNumberStyle : System.Enum
public enum class PdfPageLabelNumberStyle : public System.Enum
Members
Member | Description
Arabic | Decimal arabic numerals.
LowercaseLetter | Lowercase letters (a to z for the first 26 pages, aa to zz for the next 26, and so on)
LowercaseRoman | Lowercase roman numerals
None | No numbering Style.
UppercaseLetter | Uppercase letters (A to Z for the first 26 pages, AA to ZZ for the next 26, and so on)
UppercaseRoman | Uppercase roman numerals.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfPageLabelNumberStyle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfPageLayout Enumeration

Xfinium.Pdf Namespace : PdfPageLayout Enumeration
Supported page layouts for PDF documents.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPageLayout
   Inherits System.Enum
'Usage

Dim instance As PdfPageLayout
public enum PdfPageLayout : System.Enum
public enum class PdfPageLayout : public System.Enum
Members
Member | Description
OneColumn | Display the pages in one column.
SinglePage | Display one page at a time.
TwoColumnLeft | Display the pages in two columns, with odd-numbered pages on the left.
TwoColumnRight | Display the pages in two columns, with odd-numbered pages on the right.
TwoPageLeft | Display the pages two at a time, with odd-numbered pages on the left.
TwoPageRight | Display the pages two at a time, with odd-numbered pages on the right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfPageLayout

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfPrintScaling Enumeration

Xfinium.Pdf Namespace : PdfPrintScaling Enumeration
Suported print scaling options.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPrintScaling
   Inherits System.Enum
'Usage

Dim instance As PdfPrintScaling
public enum PdfPrintScaling : System.Enum
public enum class PdfPrintScaling : public System.Enum
Members
Member | Description
AppDefault | The applications should use the current print scaling.
None | The applications should use no print scaling.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfPrintScaling

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfVersion Enumeration

Xfinium.Pdf Namespace : PdfVersion Enumeration
Supported PDF specification versions.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfVersion
   Inherits System.Enum
'Usage

Dim instance As PdfVersion
public enum PdfVersion : System.Enum
public enum class PdfVersion : public System.Enum
Members
Member | Description
Unknown | Unknown document version.
Version10 | Pdf 1.0 - Adobe Acrobat 1
Version11 | Pdf 1.1 - Adobe Acrobat 2
Version12 | Pdf 1.2 - Adobe Acrobat 3
Version13 | Pdf 1.3 - Adobe Acrobat 4
Version14 | Pdf 1.4 - Adobe Acrobat 5
Version15 | Pdf 1.5 - Adobe Acrobat 6
Version16 | Pdf 1.6 - Adobe Acrobat 7
Version17 | Pdf 1.7 - Adobe Acrobat 8
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfVersion

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf Namespace


Xfinium.Pdf.Actions Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfAction | Defines an abstract PDF action.
Class | PdfActionCollection | Defines a collection of Pdf actions.
Class | PdfGoTo3DViewAction | Defines a Go to 3D View action.
Class | PdfGoToAction | Defines a Go To action.
Class | PdfHideAction | Defines a Hide action.
Class | PdfJavaScriptAction | Defines a Javascript action.
Class | PdfLaunchAction | Defines Launch action.
Class | PdfNamedAction | Defines a Named action.
Class | PdfRemoteGoToAction | Defines a Remote Go-To action.
Class | PdfResetFormAction | Defines a reset form action.
Class | PdfSubmitFormAction | Defines a submit form action.
Class | PdfUriAction | Defines a URI action.
Enumerations
 | Enumeration | Description
Enumeration | PdfActionName | Predefined actions expected to be supported by any PDF viewers.
Enumeration | PdfSubmitDataFormat | Supported data formats for form data submission.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Actions Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Actions.PdfActionCollection
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfGoTo3DViewAction
Xfinium.Pdf.Actions.PdfGoToAction
Xfinium.Pdf.Actions.PdfHideAction
Xfinium.Pdf.Actions.PdfJavaScriptAction
Xfinium.Pdf.Actions.PdfLaunchAction
Xfinium.Pdf.Actions.PdfNamedAction
Xfinium.Pdf.Actions.PdfRemoteGoToAction
Xfinium.Pdf.Actions.PdfResetFormAction
Xfinium.Pdf.Actions.PdfSubmitFormAction
Xfinium.Pdf.Actions.PdfUriAction
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfAction Class
Defines an abstract PDF action.
Object Model
PdfAction ClassPdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfAction
'Usage

Dim instance As PdfAction
public abstract class PdfAction
public ref class PdfAction abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfGoTo3DViewAction
Xfinium.Pdf.Actions.PdfGoToAction
Xfinium.Pdf.Actions.PdfHideAction
Xfinium.Pdf.Actions.PdfJavaScriptAction
Xfinium.Pdf.Actions.PdfLaunchAction
Xfinium.Pdf.Actions.PdfNamedAction
Xfinium.Pdf.Actions.PdfRemoteGoToAction
Xfinium.Pdf.Actions.PdfResetFormAction
Xfinium.Pdf.Actions.PdfSubmitFormAction
Xfinium.Pdf.Actions.PdfUriAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfAction Class

The following tables list the members exposed by PdfAction.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action.
Top
See Also

Reference

PdfAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Properties$$

PdfAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfAction Class

For a list of all members of this type, see PdfAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action.
Top
See Also

Reference

PdfAction Class
Xfinium.Pdf.Actions Namespace


Actions Property

Xfinium.Pdf.Actions Namespace > PdfAction Class : Actions Property
Gets or sets the sequence of actions to be performed after this action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Actions As PdfActionCollection
'Usage

Dim instance As PdfAction
Dim value As PdfActionCollection

instance.Actions = value

value = instance.Actions
public PdfActionCollection Actions {get; set;}
public:
property PdfActionCollection^ Actions {
   PdfActionCollection^ get();
   void set (    PdfActionCollection^ value);
}

Property Value

The sequence of actions to be performed after this action.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAction Class
PdfAction Members


%%PageItemTitle%%

PdfActionCollection Class
Members

Xfinium.Pdf.Actions Namespace : PdfActionCollection Class
Defines a collection of Pdf actions.
Object Model
PdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfActionCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfAction)
'Usage

Dim instance As PdfActionCollection
public class PdfActionCollection : System.Collections.ObjectModel.Collection<PdfAction>
public ref class PdfActionCollection : public System.Collections.ObjectModel.Collection<PdfAction>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Actions.PdfActionCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfActionCollection Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfActionCollection Class Members
Properties Methods

Xfinium.Pdf.Actions Namespace : PdfActionCollection Class

The following tables list the members exposed by PdfActionCollection.

Public Constructors
 | Name | Description
Public Constructor | PdfActionCollection Constructor | Initializes a new PdfActionCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Top
See Also

Reference

PdfActionCollection Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfActionCollection Constructor

Xfinium.Pdf.Actions Namespace > PdfActionCollection Class : PdfActionCollection Constructor
Initializes a new PdfActionCollection object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfActionCollection()
public PdfActionCollection()
public:
PdfActionCollection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfActionCollection Class
PdfActionCollection Members


%%PageItemTitle%%

PdfGoTo3DViewAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfGoTo3DViewAction Class
Defines a Go to 3D View action.
Object Model
PdfGoTo3DViewAction ClassPdfActionCollection ClassPdfAction ClassPdf3DAnnotation ClassPdf3DView Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfGoTo3DViewAction
   Inherits PdfAction
'Usage

Dim instance As PdfGoTo3DViewAction
public class PdfGoTo3DViewAction : PdfAction
public ref class PdfGoTo3DViewAction : public PdfAction
Remarks
A go to 3D view action specifies a view to be used by a 3D annotation.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfGoTo3DViewAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoTo3DViewAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfGoTo3DViewAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfGoTo3DViewAction Class

The following tables list the members exposed by PdfGoTo3DViewAction.

Public Constructors
 | Name | Description
Public Constructor | PdfGoTo3DViewAction Constructor | Initializes a new PdfGoTo3DViewAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | TargetAnnotation | Gets or sets the 3D annotation that is the target of this action.
Public Property | View | Gets or sets the view to be activated in the 3D annotation when the action is executed.
Public Property | ViewIndex | Gets or sets the index of the view to be activated in the 3D annotation when the action is executed.
Public Property | ViewName | Gets or sets the name of the view to be activated in the 3D annotation when the action is executed.
Top
See Also

Reference

PdfGoTo3DViewAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfGoTo3DViewAction Constructor

Xfinium.Pdf.Actions Namespace > PdfGoTo3DViewAction Class : PdfGoTo3DViewAction Constructor
Initializes a new PdfGoTo3DViewAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfGoTo3DViewAction()
public PdfGoTo3DViewAction()
public:
PdfGoTo3DViewAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoTo3DViewAction Class
PdfGoTo3DViewAction Members


%%PageItemTitle%% $$Properties$$

PdfGoTo3DViewAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfGoTo3DViewAction Class

For a list of all members of this type, see PdfGoTo3DViewAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | TargetAnnotation | Gets or sets the 3D annotation that is the target of this action.
Public Property | View | Gets or sets the view to be activated in the 3D annotation when the action is executed.
Public Property | ViewIndex | Gets or sets the index of the view to be activated in the 3D annotation when the action is executed.
Public Property | ViewName | Gets or sets the name of the view to be activated in the 3D annotation when the action is executed.
Top
See Also

Reference

PdfGoTo3DViewAction Class
Xfinium.Pdf.Actions Namespace


TargetAnnotation Property

Xfinium.Pdf.Actions Namespace > PdfGoTo3DViewAction Class : TargetAnnotation Property
Gets or sets the 3D annotation that is the target of this action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TargetAnnotation As Pdf3DAnnotation
'Usage

Dim instance As PdfGoTo3DViewAction
Dim value As Pdf3DAnnotation

instance.TargetAnnotation = value

value = instance.TargetAnnotation
public Pdf3DAnnotation TargetAnnotation {get; set;}
public:
property Pdf3DAnnotation^ TargetAnnotation {
   Pdf3DAnnotation^ get();
   void set (    Pdf3DAnnotation^ value);
}

Property Value

The target annotation of this action.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoTo3DViewAction Class
PdfGoTo3DViewAction Members


View Property

Xfinium.Pdf.Actions Namespace > PdfGoTo3DViewAction Class : View Property
Gets or sets the view to be activated in the 3D annotation when the action is executed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property View As Pdf3DView
'Usage

Dim instance As PdfGoTo3DViewAction
Dim value As Pdf3DView

instance.View = value

value = instance.View
public Pdf3DView View {get; set;}
public:
property Pdf3DView^ View {
   Pdf3DView^ get();
   void set (    Pdf3DView^ value);
}

Property Value

A Xfinium.Pdf.Annotations.Pdf3DView object specifying the view to be displayed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoTo3DViewAction Class
PdfGoTo3DViewAction Members


ViewIndex Property

Xfinium.Pdf.Actions Namespace > PdfGoTo3DViewAction Class : ViewIndex Property
Gets or sets the index of the view to be activated in the 3D annotation when the action is executed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ViewIndex As Integer
'Usage

Dim instance As PdfGoTo3DViewAction
Dim value As Integer

instance.ViewIndex = value

value = instance.ViewIndex
public int ViewIndex {get; set;}
public:
property int ViewIndex {
   int get();
   void set (    int value);
}

Property Value

The view index in 3D stream's Views collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoTo3DViewAction Class
PdfGoTo3DViewAction Members


ViewName Property

Xfinium.Pdf.Actions Namespace > PdfGoTo3DViewAction Class : ViewName Property
Gets or sets the name of the view to be activated in the 3D annotation when the action is executed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ViewName As String
'Usage

Dim instance As PdfGoTo3DViewAction
Dim value As String

instance.ViewName = value

value = instance.ViewName
public string ViewName {get; set;}
public:
property String^ ViewName {
   String^ get();
   void set (    String^ value);
}

Property Value

The internal name of the view (Xfinium.Pdf.Annotations.Pdf3DView.InternalName property).
Remarks
The following values have special meaning: /F - first view in list of views collection, /L - last view in list of views collection, /N - next view in list of views collection relative to current view, /P - previous view in list of views collection relative to current view, /D - default view set on the 3D stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoTo3DViewAction Class
PdfGoTo3DViewAction Members


%%PageItemTitle%%

PdfGoToAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfGoToAction Class
Defines a Go To action.
Object Model
PdfGoToAction ClassPdfActionCollection ClassPdfAction ClassPdfDestination Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfGoToAction
   Inherits PdfAction
'Usage

Dim instance As PdfGoToAction
public class PdfGoToAction : PdfAction
public ref class PdfGoToAction : public PdfAction
Remarks
A go to action changes the view in the PDF viewer application to a specified destination (page, location and magnification factor).
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfGoToAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoToAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfGoToAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfGoToAction Class

The following tables list the members exposed by PdfGoToAction.

Public Constructors
 | Name | Description
Public Constructor | PdfGoToAction Constructor | Initializes a new PdfGoToAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | Destination | Gets or sets the destination of the GoTo action.
Top
See Also

Reference

PdfGoToAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfGoToAction Constructor

Xfinium.Pdf.Actions Namespace > PdfGoToAction Class : PdfGoToAction Constructor
Initializes a new PdfGoToAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfGoToAction()
public PdfGoToAction()
public:
PdfGoToAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoToAction Class
PdfGoToAction Members


%%PageItemTitle%% $$Properties$$

PdfGoToAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfGoToAction Class

For a list of all members of this type, see PdfGoToAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | Destination | Gets or sets the destination of the GoTo action.
Top
See Also

Reference

PdfGoToAction Class
Xfinium.Pdf.Actions Namespace


Destination Property (PdfGoToAction)

Xfinium.Pdf.Actions Namespace > PdfGoToAction Class : Destination Property
Gets or sets the destination of the GoTo action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Destination As PdfDestination
'Usage

Dim instance As PdfGoToAction
Dim value As PdfDestination

instance.Destination = value

value = instance.Destination
public PdfDestination Destination {get; set;}
public:
property PdfDestination^ Destination {
   PdfDestination^ get();
   void set (    PdfDestination^ value);
}

Property Value

The destination to jump to.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoToAction Class
PdfGoToAction Members


%%PageItemTitle%%

PdfHideAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfHideAction Class
Defines a Hide action.
Object Model
PdfHideAction ClassPdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfHideAction
   Inherits PdfAction
'Usage

Dim instance As PdfHideAction
public class PdfHideAction : PdfAction
public ref class PdfHideAction : public PdfAction
Remarks
A hide action hides or shows one or more annotations on the screen by setting or clearing their Hidden flags.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfHideAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfHideAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfHideAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfHideAction Class

The following tables list the members exposed by PdfHideAction.

Public Constructors
 | Name | Description
Public Constructor | PdfHideAction Constructor | Initializes a new PdfHideAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether to hide the annotations or show them.
Top
See Also

Reference

PdfHideAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfHideAction Constructor

Xfinium.Pdf.Actions Namespace > PdfHideAction Class : PdfHideAction Constructor
Initializes a new PdfHideAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfHideAction()
public PdfHideAction()
public:
PdfHideAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfHideAction Class
PdfHideAction Members


%%PageItemTitle%% $$Properties$$

PdfHideAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfHideAction Class

For a list of all members of this type, see PdfHideAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether to hide the annotations or show them.
Top
See Also

Reference

PdfHideAction Class
Xfinium.Pdf.Actions Namespace


FieldName Property

Xfinium.Pdf.Actions Namespace > PdfHideAction Class : FieldName Property
Gets or sets the name of the field that is affected by this action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FieldName As String
'Usage

Dim instance As PdfHideAction
Dim value As String

instance.FieldName = value

value = instance.FieldName
public string FieldName {get; set;}
public:
property String^ FieldName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the name of the field that is affected by this action.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfHideAction Class
PdfHideAction Members


Hide Property

Xfinium.Pdf.Actions Namespace > PdfHideAction Class : Hide Property
Gets or sets a value indicating whether to hide the annotations or show them.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Hide As Boolean
'Usage

Dim instance As PdfHideAction
Dim value As Boolean

instance.Hide = value

value = instance.Hide
public bool Hide {get; set;}
public:
property bool Hide {
   bool get();
   void set (    bool value);
}

Property Value

True for hidding the annotations, false for showing them.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfHideAction Class
PdfHideAction Members


%%PageItemTitle%%

PdfJavaScriptAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfJavaScriptAction Class
Defines a Javascript action.
Object Model
PdfJavaScriptAction ClassPdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfJavaScriptAction
   Inherits PdfAction
'Usage

Dim instance As PdfJavaScriptAction
public class PdfJavaScriptAction : PdfAction
public ref class PdfJavaScriptAction : public PdfAction
Remarks
A JavaScript action causes a script to be compiled and executed by the JavaScript interpreter.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfJavaScriptAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfJavaScriptAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfJavaScriptAction Class

The following tables list the members exposed by PdfJavaScriptAction.

Public Constructors
 | Name | Description
Public Constructor | PdfJavaScriptAction Constructor | Initializes a new PdfJavaScriptAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | Script | Gets or sets the JavaScript script to be executed.
Top
See Also

Reference

PdfJavaScriptAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfJavaScriptAction Constructor

Xfinium.Pdf.Actions Namespace > PdfJavaScriptAction Class : PdfJavaScriptAction Constructor
Initializes a new PdfJavaScriptAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfJavaScriptAction()
public PdfJavaScriptAction()
public:
PdfJavaScriptAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptAction Class
PdfJavaScriptAction Members


%%PageItemTitle%% $$Properties$$

PdfJavaScriptAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfJavaScriptAction Class

For a list of all members of this type, see PdfJavaScriptAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | Script | Gets or sets the JavaScript script to be executed.
Top
See Also

Reference

PdfJavaScriptAction Class
Xfinium.Pdf.Actions Namespace


Script Property

Xfinium.Pdf.Actions Namespace > PdfJavaScriptAction Class : Script Property
Gets or sets the JavaScript script to be executed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Script As String
'Usage

Dim instance As PdfJavaScriptAction
Dim value As String

instance.Script = value

value = instance.Script
public string Script {get; set;}
public:
property String^ Script {
   String^ get();
   void set (    String^ value);
}

Property Value

The JavaScript script to be executed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptAction Class
PdfJavaScriptAction Members


%%PageItemTitle%%

PdfLaunchAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfLaunchAction Class
Defines Launch action.
Object Model
PdfLaunchAction ClassPdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfLaunchAction
   Inherits PdfAction
'Usage

Dim instance As PdfLaunchAction
public class PdfLaunchAction : PdfAction
public ref class PdfLaunchAction : public PdfAction
Remarks
A launch action launches an application or opens or prints a document.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfLaunchAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLaunchAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfLaunchAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfLaunchAction Class

The following tables list the members exposed by PdfLaunchAction.

Public Constructors
 | Name | Description
Public Constructor | PdfLaunchAction Constructor | Initializes a new PdfLaunchAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | FileName | Gets or sets the application to be launched or the document to be opened or printed.
Public Property | NewWindow | Gets or sets a value indicating whether to open the destination document in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the application designated by the FileName property.
Top
See Also

Reference

PdfLaunchAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfLaunchAction Constructor

Xfinium.Pdf.Actions Namespace > PdfLaunchAction Class : PdfLaunchAction Constructor
Initializes a new PdfLaunchAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfLaunchAction()
public PdfLaunchAction()
public:
PdfLaunchAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLaunchAction Class
PdfLaunchAction Members


%%PageItemTitle%% $$Properties$$

PdfLaunchAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfLaunchAction Class

For a list of all members of this type, see PdfLaunchAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | FileName | Gets or sets the application to be launched or the document to be opened or printed.
Public Property | NewWindow | Gets or sets a value indicating whether to open the destination document in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the application designated by the FileName property.
Top
See Also

Reference

PdfLaunchAction Class
Xfinium.Pdf.Actions Namespace


FileName Property (PdfLaunchAction)

Xfinium.Pdf.Actions Namespace > PdfLaunchAction Class : FileName Property
Gets or sets the application to be launched or the document to be opened or printed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PdfLaunchAction
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The application to be launched or the document to be opened or printed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLaunchAction Class
PdfLaunchAction Members


NewWindow Property (PdfLaunchAction)

Xfinium.Pdf.Actions Namespace > PdfLaunchAction Class : NewWindow Property
Gets or sets a value indicating whether to open the destination document in a new window.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NewWindow As Boolean
'Usage

Dim instance As PdfLaunchAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
public bool NewWindow {get; set;}
public:
property bool NewWindow {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether to open the destination document in a new window. If this property is false, the destination document replaces the current document in the same window.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLaunchAction Class
PdfLaunchAction Members


Parameters Property

Xfinium.Pdf.Actions Namespace > PdfLaunchAction Class : Parameters Property
Gets or sets a parameter string to be passed to the application designated by the FileName property.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Parameters As String
'Usage

Dim instance As PdfLaunchAction
Dim value As String

instance.Parameters = value

value = instance.Parameters
public string Parameters {get; set;}
public:
property String^ Parameters {
   String^ get();
   void set (    String^ value);
}

Property Value

A parameter string to be passed to the application designated by the FileName property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLaunchAction Class
PdfLaunchAction Members


%%PageItemTitle%%

PdfNamedAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfNamedAction Class
Defines a Named action.
Object Model
PdfNamedAction ClassPdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfNamedAction
   Inherits PdfAction
'Usage

Dim instance As PdfNamedAction
public class PdfNamedAction : PdfAction
public ref class PdfNamedAction : public PdfAction
Remarks
A named action is a predefined action expected to be supported by any PDF viewers.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfNamedAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfNamedAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfNamedAction Class

The following tables list the members exposed by PdfNamedAction.

Public Constructors
 | Name | Description
Public Constructor | PdfNamedAction Constructor | Initializes a new PdfNamedAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | NamedAction | Gets or sets the name of the action to be performed.
Top
See Also

Reference

PdfNamedAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfNamedAction Constructor

Xfinium.Pdf.Actions Namespace > PdfNamedAction Class : PdfNamedAction Constructor
Initializes a new PdfNamedAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfNamedAction()
public PdfNamedAction()
public:
PdfNamedAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedAction Class
PdfNamedAction Members


%%PageItemTitle%% $$Properties$$

PdfNamedAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfNamedAction Class

For a list of all members of this type, see PdfNamedAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | NamedAction | Gets or sets the name of the action to be performed.
Top
See Also

Reference

PdfNamedAction Class
Xfinium.Pdf.Actions Namespace


NamedAction Property

Xfinium.Pdf.Actions Namespace > PdfNamedAction Class : NamedAction Property
Gets or sets the name of the action to be performed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NamedAction As PdfActionName
'Usage

Dim instance As PdfNamedAction
Dim value As PdfActionName

instance.NamedAction = value

value = instance.NamedAction
public PdfActionName NamedAction {get; set;}
public:
property PdfActionName NamedAction {
   PdfActionName get();
   void set (    PdfActionName value);
}

Property Value

The name of the action to be performed
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedAction Class
PdfNamedAction Members


%%PageItemTitle%%

PdfRemoteGoToAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfRemoteGoToAction Class
Defines a Remote Go-To action.
Object Model
PdfRemoteGoToAction ClassPdfActionCollection ClassPdfAction ClassPdfPageNumberDestination Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRemoteGoToAction
   Inherits PdfAction
'Usage

Dim instance As PdfRemoteGoToAction
public class PdfRemoteGoToAction : PdfAction
public ref class PdfRemoteGoToAction : public PdfAction
Remarks
A remote go-to action is similar to an ordinary go-to action but jumps to a destination in another PDF file instead of the current file.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfRemoteGoToAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRemoteGoToAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfRemoteGoToAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfRemoteGoToAction Class

The following tables list the members exposed by PdfRemoteGoToAction.

Public Constructors
 | Name | Description
Public Constructor | PdfRemoteGoToAction Constructor | Initializes a new PdfRemoteGoToAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | Destination | Gets or sets the destination to jump to.
Public Property | FileName | Gets or sets the file in which the destination is located.
Public Property | NewWindow | Gets or sets a value indicating whether to open the destination document in a new window.
Top
See Also

Reference

PdfRemoteGoToAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfRemoteGoToAction Constructor

Xfinium.Pdf.Actions Namespace > PdfRemoteGoToAction Class : PdfRemoteGoToAction Constructor
Initializes a new PdfRemoteGoToAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRemoteGoToAction()
public PdfRemoteGoToAction()
public:
PdfRemoteGoToAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRemoteGoToAction Class
PdfRemoteGoToAction Members


%%PageItemTitle%% $$Properties$$

PdfRemoteGoToAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfRemoteGoToAction Class

For a list of all members of this type, see PdfRemoteGoToAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | Destination | Gets or sets the destination to jump to.
Public Property | FileName | Gets or sets the file in which the destination is located.
Public Property | NewWindow | Gets or sets a value indicating whether to open the destination document in a new window.
Top
See Also

Reference

PdfRemoteGoToAction Class
Xfinium.Pdf.Actions Namespace


Destination Property (PdfRemoteGoToAction)

Xfinium.Pdf.Actions Namespace > PdfRemoteGoToAction Class : Destination Property
Gets or sets the destination to jump to.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Destination As PdfPageNumberDestination
'Usage

Dim instance As PdfRemoteGoToAction
Dim value As PdfPageNumberDestination

instance.Destination = value

value = instance.Destination
public PdfPageNumberDestination Destination {get; set;}
public:
property PdfPageNumberDestination^ Destination {
   PdfPageNumberDestination^ get();
   void set (    PdfPageNumberDestination^ value);
}

Property Value

The destination to jump to in the remote document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRemoteGoToAction Class
PdfRemoteGoToAction Members


FileName Property (PdfRemoteGoToAction)

Xfinium.Pdf.Actions Namespace > PdfRemoteGoToAction Class : FileName Property
Gets or sets the file in which the destination is located.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PdfRemoteGoToAction
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The file in which the destination is located.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRemoteGoToAction Class
PdfRemoteGoToAction Members


NewWindow Property (PdfRemoteGoToAction)

Xfinium.Pdf.Actions Namespace > PdfRemoteGoToAction Class : NewWindow Property
Gets or sets a value indicating whether to open the destination document in a new window.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NewWindow As Boolean
'Usage

Dim instance As PdfRemoteGoToAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
public bool NewWindow {get; set;}
public:
property bool NewWindow {
   bool get();
   void set (    bool value);
}

Property Value

A bool value specifying whether to open the destination document in a new window. If this property is false, the destination document replaces the current document in the same window.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRemoteGoToAction Class
PdfRemoteGoToAction Members


%%PageItemTitle%%

PdfResetFormAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfResetFormAction Class
Defines a reset form action.
Object Model
PdfResetFormAction ClassPdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfResetFormAction
   Inherits PdfAction
'Usage

Dim instance As PdfResetFormAction
public class PdfResetFormAction : PdfAction
public ref class PdfResetFormAction : public PdfAction
Remarks
A reset form action resets selected interactive form fields to their default values.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfResetFormAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfResetFormAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfResetFormAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfResetFormAction Class

The following tables list the members exposed by PdfResetFormAction.

Public Constructors
 | Name | Description
Public Constructor | PdfResetFormAction Constructor | Initializes a new PdfResetFormAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | Fields | Gets or sets a list identifying which fields to reset or which to exclude from resetting.
Public Property | ResetFields | Gets or sets a value indicating whether the action resets the fields in the list of excludes them.
Top
See Also

Reference

PdfResetFormAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfResetFormAction Constructor

Xfinium.Pdf.Actions Namespace > PdfResetFormAction Class : PdfResetFormAction Constructor
Initializes a new PdfResetFormAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfResetFormAction()
public PdfResetFormAction()
public:
PdfResetFormAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfResetFormAction Class
PdfResetFormAction Members


%%PageItemTitle%% $$Properties$$

PdfResetFormAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfResetFormAction Class

For a list of all members of this type, see PdfResetFormAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | Fields | Gets or sets a list identifying which fields to reset or which to exclude from resetting.
Public Property | ResetFields | Gets or sets a value indicating whether the action resets the fields in the list of excludes them.
Top
See Also

Reference

PdfResetFormAction Class
Xfinium.Pdf.Actions Namespace


Fields Property (PdfResetFormAction)

Xfinium.Pdf.Actions Namespace > PdfResetFormAction Class : Fields Property
Gets or sets a list identifying which fields to reset or which to exclude from resetting.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Fields As List(Of String)
'Usage

Dim instance As PdfResetFormAction
Dim value As List(Of String)

instance.Fields = value

value = instance.Fields
public List<string> Fields {get; set;}
public:
property List<String^>^ Fields {
   List<String^>^ get();
   void set (    List<String^>^ value);
}

Property Value

A list of strings identifying which fields to reset or which to exclude from resetting, depending on the value of ResetFields property.
Remarks
If the list is null or empty then all the form fields are reset no matter the value of ResetFields property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfResetFormAction Class
PdfResetFormAction Members


ResetFields Property

Xfinium.Pdf.Actions Namespace > PdfResetFormAction Class : ResetFields Property
Gets or sets a value indicating whether the action resets the fields in the list of excludes them.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ResetFields As Boolean
'Usage

Dim instance As PdfResetFormAction
Dim value As Boolean

instance.ResetFields = value

value = instance.ResetFields
public bool ResetFields {get; set;}
public:
property bool ResetFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the fields in the list are reset, false if they are excluded from reset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfResetFormAction Class
PdfResetFormAction Members


%%PageItemTitle%%

PdfSubmitFormAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfSubmitFormAction Class
Defines a submit form action.
Object Model
PdfSubmitFormAction ClassPdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSubmitFormAction
   Inherits PdfAction
'Usage

Dim instance As PdfSubmitFormAction
public class PdfSubmitFormAction : PdfAction
public ref class PdfSubmitFormAction : public PdfAction
Remarks
A submit form action transmits the names and values of selected interactive form fields to a specified uniform resource locator (URL).
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfSubmitFormAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfSubmitFormAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfSubmitFormAction Class

The following tables list the members exposed by PdfSubmitFormAction.

Public Constructors
 | Name | Description
Public Constructor | PdfSubmitFormAction Constructor | Initializes a new PdfSubmitFormAction object.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | DataFormat | Gets or sets the format of the submitted data.
Public Property | EmbedForm | Gets or sets a value indicating whether the Pdf file is embedded in the submitted data.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations created by the current user are submitted.
Public Property | Fields | Gets or sets the list identifying which fields to include in the submission or which to exclude.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the submitted FDF file includes all markup annotations in the underlying PDF document.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying Pdf document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value are submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields list should be submitted or not.
Public Property | Url | Gets or sets the URL the form data is submitted for processing.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates are converted to the standard PDF format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the form data is submitted using HTTP GET method.
Top
See Also

Reference

PdfSubmitFormAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfSubmitFormAction Constructor

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : PdfSubmitFormAction Constructor
Initializes a new PdfSubmitFormAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSubmitFormAction()
public PdfSubmitFormAction()
public:
PdfSubmitFormAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


%%PageItemTitle%% $$Properties$$

PdfSubmitFormAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfSubmitFormAction Class

For a list of all members of this type, see PdfSubmitFormAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | DataFormat | Gets or sets the format of the submitted data.
Public Property | EmbedForm | Gets or sets a value indicating whether the Pdf file is embedded in the submitted data.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations created by the current user are submitted.
Public Property | Fields | Gets or sets the list identifying which fields to include in the submission or which to exclude.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the submitted FDF file includes all markup annotations in the underlying PDF document.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying Pdf document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value are submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields list should be submitted or not.
Public Property | Url | Gets or sets the URL the form data is submitted for processing.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates are converted to the standard PDF format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the form data is submitted using HTTP GET method.
Top
See Also

Reference

PdfSubmitFormAction Class
Xfinium.Pdf.Actions Namespace


DataFormat Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : DataFormat Property
Gets or sets the format of the submitted data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DataFormat As PdfSubmitDataFormat
'Usage

Dim instance As PdfSubmitFormAction
Dim value As PdfSubmitDataFormat

instance.DataFormat = value

value = instance.DataFormat
public PdfSubmitDataFormat DataFormat {get; set;}
public:
property PdfSubmitDataFormat DataFormat {
   PdfSubmitDataFormat get();
   void set (    PdfSubmitDataFormat value);
}

Property Value

The format, one of the formats defined by PdfSubmitDataFormat enumeration, of the data submitted to the server.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


EmbedForm Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : EmbedForm Property
Gets or sets a value indicating whether the Pdf file is embedded in the submitted data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EmbedForm As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.EmbedForm = value

value = instance.EmbedForm
public bool EmbedForm {get; set;}
public:
property bool EmbedForm {
   bool get();
   void set (    bool value);
}

Property Value

If true, the PDF file is embedded in the submitted FDF file.
Remarks
This property is meaningful only if the submit data format is FDF.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


ExcludeNonUserAnnotations Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : ExcludeNonUserAnnotations Property
Gets or sets a value indicating whether only the annotations created by the current user are submitted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExcludeNonUserAnnotations As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.ExcludeNonUserAnnotations = value

value = instance.ExcludeNonUserAnnotations
public bool ExcludeNonUserAnnotations {get; set;}
public:
property bool ExcludeNonUserAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

If true, only the annotations created by the current are submitted.
Remarks
This property is meaningful only if the submit data format is FDF and IncludeAnnotations property is true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


Fields Property (PdfSubmitFormAction)

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : Fields Property
Gets or sets the list identifying which fields to include in the submission or which to exclude.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Fields As List(Of String)
'Usage

Dim instance As PdfSubmitFormAction
Dim value As List(Of String)

instance.Fields = value

value = instance.Fields
public List<string> Fields {get; set;}
public:
property List<String^>^ Fields {
   List<String^>^ get();
   void set (    List<String^>^ value);
}

Property Value

A list of strings identifying which fields to include in the submission or which to exclude, depending on the setting of the SubmitFields property.
Remarks
If this list is null or empty then all the form fields are submitted regardless of the SubmitFields property.
The fields with Xfinium.Pdf.Forms.PdfField.Export property set to true will not be submitted no matter if they are included in the list or not.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


IncludeAnnotations Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : IncludeAnnotations Property
Gets or sets a value indicating whether the submitted FDF file includes all markup annotations in the underlying PDF document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IncludeAnnotations As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.IncludeAnnotations = value

value = instance.IncludeAnnotations
public bool IncludeAnnotations {get; set;}
public:
property bool IncludeAnnotations {
   bool get();
   void set (    bool value);
}

Property Value

If true, the submitted FDF file includes all markup annotations in the underlying PDF document.
Remarks
This property is meaningful only if the submit data format is FDF.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


IncludeAppendSaves Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : IncludeAppendSaves Property
Gets or sets a value indicating whether the incremental updates to the underlying Pdf document are included in the submitted FDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IncludeAppendSaves As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.IncludeAppendSaves = value

value = instance.IncludeAppendSaves
public bool IncludeAppendSaves {get; set;}
public:
property bool IncludeAppendSaves {
   bool get();
   void set (    bool value);
}

Property Value

If true, the submitted FDF file includes the contents of all incremental updates to the underlying PDF document.
Remarks
This property is meaningful only when the submit data format is FDF.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


IncludeNoValueFields Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : IncludeNoValueFields Property
Gets or sets a value indicating whether the fields with no value are submitted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IncludeNoValueFields As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.IncludeNoValueFields = value

value = instance.IncludeNoValueFields
public bool IncludeNoValueFields {get; set;}
public:
property bool IncludeNoValueFields {
   bool get();
   void set (    bool value);
}

Property Value

If true, all fields designated by the Fields list and the SubmitFields property are submitted, regardless of whether they have a value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


SubmitCoordinates Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : SubmitCoordinates Property
Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SubmitCoordinates As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.SubmitCoordinates = value

value = instance.SubmitCoordinates
public bool SubmitCoordinates {get; set;}
public:
property bool SubmitCoordinates {
   bool get();
   void set (    bool value);
}

Property Value

If true, the coordinates of the mouse click that caused the submit-form action are transmitted as part of the form data.
Remarks
The coordinate values are relative to the upper-left corner of the field's widget annotation rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


SubmitFields Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : SubmitFields Property
Gets or sets a value indicating whether the fields in Fields list should be submitted or not.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SubmitFields As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.SubmitFields = value

value = instance.SubmitFields
public bool SubmitFields {get; set;}
public:
property bool SubmitFields {
   bool get();
   void set (    bool value);
}

Property Value

True if the fields in Fields list should be submitted, false if the fields in the list should be omitted.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


Url Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : Url Property
Gets or sets the URL the form data is submitted for processing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Url As String
'Usage

Dim instance As PdfSubmitFormAction
Dim value As String

instance.Url = value

value = instance.Url
public string Url {get; set;}
public:
property String^ Url {
   String^ get();
   void set (    String^ value);
}

Property Value

The URL the form data is submitted for processing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


UseCanonicalDateTimeFormat Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : UseCanonicalDateTimeFormat Property
Gets or sets a value indicating whether the field values representing dates are converted to the standard PDF format.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UseCanonicalDateTimeFormat As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.UseCanonicalDateTimeFormat = value

value = instance.UseCanonicalDateTimeFormat
public bool UseCanonicalDateTimeFormat {get; set;}
public:
property bool UseCanonicalDateTimeFormat {
   bool get();
   void set (    bool value);
}

Property Value

If true, any submitted field values representing dates are converted to the standard PDF format.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


UseHttpGet Property

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : UseHttpGet Property
Gets or sets a value indicating whether the form data is submitted using HTTP GET method.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UseHttpGet As Boolean
'Usage

Dim instance As PdfSubmitFormAction
Dim value As Boolean

instance.UseHttpGet = value

value = instance.UseHttpGet
public bool UseHttpGet {get; set;}
public:
property bool UseHttpGet {
   bool get();
   void set (    bool value);
}

Property Value

If true, form data is submitted using an HTTP GET request. If false, it is submitted using a POST request.
Remarks
This property is considered only if DataFormat property is PdfSubmitDataFormat.HTML or PdfSubmitDataFormat.Pdf.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


%%PageItemTitle%%

PdfUriAction Class
Members

Xfinium.Pdf.Actions Namespace : PdfUriAction Class
Defines a URI action.
Object Model
PdfUriAction ClassPdfActionCollection ClassPdfAction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUriAction
   Inherits PdfAction
'Usage

Dim instance As PdfUriAction
public class PdfUriAction : PdfAction
public ref class PdfUriAction : public PdfAction
Remarks
A URI action causes a URI to be resolved.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Actions.PdfAction
Xfinium.Pdf.Actions.PdfUriAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUriAction Members
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Members$$

PdfUriAction Class Members
Properties

Xfinium.Pdf.Actions Namespace : PdfUriAction Class

The following tables list the members exposed by PdfUriAction.

Public Constructors
 | Name | Description
Public Constructor | PdfUriAction Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | URI | Gets or sets the uniform resource identifier to resolve, encoded in 7-bit ASCII.
Top
See Also

Reference

PdfUriAction Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfUriAction Constructor

Xfinium.Pdf.Actions Namespace > PdfUriAction Class : PdfUriAction Constructor
Overload List
Overload | Description
PdfUriAction Constructor() | Initializes a new PdfUriAction object.
PdfUriAction Constructor(String) | Initializes a new PdfUriAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUriAction Class
PdfUriAction Members


%%PageItemTitle%%

PdfUriAction Constructor()

Xfinium.Pdf.Actions Namespace > PdfUriAction Class > PdfUriAction Constructor : PdfUriAction Constructor()
Initializes a new PdfUriAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfUriAction()
public PdfUriAction()
public:
PdfUriAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUriAction Class
PdfUriAction Members
Overload List


%%PageItemTitle%%

PdfUriAction Constructor(String)

Xfinium.Pdf.Actions Namespace > PdfUriAction Class > PdfUriAction Constructor : PdfUriAction Constructor(String)
The uniform resource identifier to resolve, encoded in 7-bit ASCII.
Initializes a new PdfUriAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As String _
)
'Usage

Dim uri As String

Dim instance As New PdfUriAction(uri)
public PdfUriAction(
   string uri
)
public:
PdfUriAction(
   String^ uri
)

Parameters

uri
The uniform resource identifier to resolve, encoded in 7-bit ASCII.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUriAction Class
PdfUriAction Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfUriAction Class Properties

Xfinium.Pdf.Actions Namespace : PdfUriAction Class

For a list of all members of this type, see PdfUriAction members.

Public Properties
 | Name | Description
Public Property | Actions | Gets or sets the sequence of actions to be performed after this action. (Inherited from Xfinium.Pdf.Actions.PdfAction)
Public Property | URI | Gets or sets the uniform resource identifier to resolve, encoded in 7-bit ASCII.
Top
See Also

Reference

PdfUriAction Class
Xfinium.Pdf.Actions Namespace


URI Property

Xfinium.Pdf.Actions Namespace > PdfUriAction Class : URI Property
Gets or sets the uniform resource identifier to resolve, encoded in 7-bit ASCII.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property URI As String
'Usage

Dim instance As PdfUriAction
Dim value As String

instance.URI = value

value = instance.URI
public string URI {get; set;}
public:
property String^ URI {
   String^ get();
   void set (    String^ value);
}

Property Value

The uniform resource identifier to resolve, encoded in 7-bit ASCII.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUriAction Class
PdfUriAction Members


%%PageItemTitle%%

PdfActionName Enumeration

Xfinium.Pdf.Actions Namespace : PdfActionName Enumeration
Predefined actions expected to be supported by any PDF viewers.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfActionName
   Inherits System.Enum
'Usage

Dim instance As PdfActionName
public enum PdfActionName : System.Enum
public enum class PdfActionName : public System.Enum
Members
Member | Description
FirstPage | Go to first page in the document.
LastPage | Go to last page in the document.
NextPage | Go to next page in the document.
PrevPage | Go to previous page in the document.
Print | Print the document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Actions.PdfActionName

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfSubmitDataFormat Enumeration

Xfinium.Pdf.Actions Namespace : PdfSubmitDataFormat Enumeration
Supported data formats for form data submission.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfSubmitDataFormat
   Inherits System.Enum
'Usage

Dim instance As PdfSubmitDataFormat
public enum PdfSubmitDataFormat : System.Enum
public enum class PdfSubmitDataFormat : public System.Enum
Members
Member | Description
FDF | Form data is submitted in FDF format.
HTML | Form data is submitted in HTML Form format.
Pdf | The entire PDF file is submitted.
XFDF | Form data is submitted in XFDF format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Actions.PdfSubmitDataFormat

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Actions Namespace


Xfinium.Pdf.Annotations Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | Pdf3DActivation | Defines the times at which the annotation should be activated and deactivated and the state of the 3D artwork instance at those times.
Class | Pdf3DAnimation | Defines the preferred method that viewer applications should use to apply timeline scaling to keyframe animations.
Class | Pdf3DAnnotation | Defines a 3D annotation.
Class | Pdf3DBackground | Defines the background over which a 3D view is to be drawn.
Class | Pdf3DCrossSection | Defines how a portion of the 3D artwork is clipped for the purpose of showing artwork cross sections.
Class | Pdf3DCrossSectionCollection | Defines a collection of 3D cross sections.
Class | Pdf3DEntity | Abstract base class for 3D objects.
Class | Pdf3DLightingScheme | Defines the lighting to apply to 3D artwork.
Class | Pdf3DNode | Defines particular areas of 3D artwork and the opacity and visibility with which individual nodes are displayed.
Class | Pdf3DNodeCollection | Defines a collection of 3D nodes.
Class | Pdf3DProjection | Defines the mapping of 3D camera coordinates onto the target coordinate system of the annotation.
Class | Pdf3DRendering | Defines the style in which the 3D artwork is rendered.
Class | Pdf3DStream | Defines a 3D stream.
Class | Pdf3DView | Defines the parameters to be applied to the virtual camera associated with a 3D annotation.
Class | Pdf3DViewCollection | Defines a collection of 3D views.
Class | PdfAnnotation | Defines an abstract PDF annotation.
Class | PdfAnnotationAppearance | Defines how an annotation is presented visually on the page.
Class | PdfAnnotationCollection | Defines a collection of PDF annotations.
Class | PdfCircleAnnotation | Defines a PDF circle annotation.
Class | PdfFileAttachmentAnnotation | Defines a PDF file attachment annotation.
Class | PdfFileAttachmentAnnotationName | Defines the standard names for a file attachment icons.
Class | PdfFreeTextAnnotation | Defines a PDF free text annotation.
Class | PdfInkAnnotation | Defines a PDF ink annotation.
Class | PdfLineAnnotation | Defines a PDF line annotation.
Class | PdfLinkAnnotation | Defines a PDF link annotation.
Class | PdfMarkupAnnotation | The base class for PDF markup annotations.
Class | PdfPolygonAnnotation | Defines a PDF polygon annotation.
Class | PdfPolylineAnnotation | Defines a PDF polyline annotation.
Class | PdfRedactionAnnotation | Defines a redaction annotation.
Class | PdfRichMediaActivation | Defines the conditions for the activation of the rich media annotation.
Class | PdfRichMediaAnnotation | Defines a PDF rich media annotation. Defines a rich media annotation in a Pdf file.
Class | PdfRichMediaAsset | Defines a rich media asset object.
Class | PdfRichMediaAssetCollection | Defines a collection rich media assets.
Class | PdfRichMediaConfigurationCollection | Defines a collection of rich media configurations.
Class | PdfRichMediaContent | Defines a rich media content object.
Class | PdfRichMediaDeactivation | Defines the conditions for the deactivation of the rich media annotation.
Class | PdfRichMediaInstanceCollection | Defines a collection of rich media instances.
Class | PdfRubberStampAnnotation | Defines a PDF rubber stamp annotation.
Class | PdfRubberStampAnnotationName | Defines the standard names for a rubber stamps.
Class | PdfScreenAnnotation | Defines a PDF movie annotation. Defines a movie annotation in a Pdf file.
Class | PdfSoundAnnotation | Defines a PDF sound annotation.
Class | PdfSoundAnnotationName | Defines the standard names for a sound annotation icons.
Class | PdfSquareAnnotation | Defines a square annotation.
Class | PdfTextAnnotation | Defines a PDF text note annotation.
Class | PdfTextAnnotationName | Defines the standard names for a text note icons.
Class | PdfTextMarkupAnnotation | Defines a PDF text markup annotation.
Enumerations
 | Enumeration | Description
Enumeration | Pdf3DActivationMode | Supported modes for 3D annotation activation.
Enumeration | Pdf3DActivationState | Supported states upon 3D annotation activation.
Enumeration | Pdf3DAnimationStyle | Supported animation styles.
Enumeration | Pdf3DDeactivationMode | Supported modes for 3D annotation deactivation.
Enumeration | Pdf3DDeactivationState | Supported states upon 3D annotation deactivation.
Enumeration | Pdf3DLightingStyle | Supported lighting styles.
Enumeration | Pdf3DProjectionClippingStyle | Supported clipping styles.
Enumeration | Pdf3DProjectionOrthoScaleStrategy | Supported orthographic scaling strategies.
Enumeration | Pdf3DProjectionType | Supported projection types.
Enumeration | Pdf3DRenderingMode | Supported modes for rendering the 3D images.
Enumeration | PdfAnnotationType | Supported annotation types.
Enumeration | PdfLineEndSymbol | Supported symbols to end a line annotation.
Enumeration | PdfLinkAnnotationHighlightStyle | Supported link highlight styles.
Enumeration | PdfRichMediaActivationCondition | Suported conditions for rich media annotation activation.
Enumeration | PdfRichMediaDeactivationCondition | Suported conditions for rich media annotation deactivation.
Enumeration | PdfRichMediaType | Specifies the supported rich media types.
Enumeration | PdfSoundAnnotationDataEncoding | Supported encoding formats for sound data.
Enumeration | PdfTextAnnotationState | Supported states for text annotations.
Enumeration | PdfTextMarkupAnnotationType | Supported text markup annotations.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Annotations Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Annotations.Pdf3DCrossSectionCollection
Xfinium.Pdf.Annotations.Pdf3DNodeCollection
Xfinium.Pdf.Annotations.Pdf3DViewCollection
Xfinium.Pdf.Annotations.PdfAnnotationCollection
Xfinium.Pdf.Annotations.PdfRichMediaAssetCollection
Xfinium.Pdf.Annotations.PdfRichMediaConfigurationCollection
Xfinium.Pdf.Annotations.PdfRichMediaInstanceCollection
Xfinium.Pdf.Annotations.Pdf3DAnimation
Xfinium.Pdf.Annotations.Pdf3DBackground
Xfinium.Pdf.Annotations.Pdf3DCrossSection
Xfinium.Pdf.Annotations.Pdf3DEntity
Xfinium.Pdf.Annotations.Pdf3DActivation
Xfinium.Pdf.Annotations.Pdf3DLightingScheme
Xfinium.Pdf.Annotations.Pdf3DNode
Xfinium.Pdf.Annotations.Pdf3DProjection
Xfinium.Pdf.Annotations.Pdf3DRendering
Xfinium.Pdf.Annotations.Pdf3DStream
Xfinium.Pdf.Annotations.Pdf3DView
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.Pdf3DAnnotation
Xfinium.Pdf.Annotations.PdfLinkAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfCircleAnnotation
Xfinium.Pdf.Annotations.PdfFileAttachmentAnnotation
Xfinium.Pdf.Annotations.PdfFreeTextAnnotation
Xfinium.Pdf.Annotations.PdfInkAnnotation
Xfinium.Pdf.Annotations.PdfLineAnnotation
Xfinium.Pdf.Annotations.PdfPolylineAnnotation
Xfinium.Pdf.Annotations.PdfPolygonAnnotation
Xfinium.Pdf.Annotations.PdfRedactionAnnotation
Xfinium.Pdf.Annotations.PdfRubberStampAnnotation
Xfinium.Pdf.Annotations.PdfSoundAnnotation
Xfinium.Pdf.Annotations.PdfSquareAnnotation
Xfinium.Pdf.Annotations.PdfTextAnnotation
Xfinium.Pdf.Annotations.PdfTextMarkupAnnotation
Xfinium.Pdf.Annotations.PdfRichMediaAnnotation
Xfinium.Pdf.Annotations.PdfScreenAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfCheckWidget
Xfinium.Pdf.Forms.PdfCheckBoxWidget
Xfinium.Pdf.Forms.PdfRadioButtonWidget
Xfinium.Pdf.Forms.PdfComboBoxWidget
Xfinium.Pdf.Forms.PdfListBoxWidget
Xfinium.Pdf.Forms.PdfPushButtonWidget
Xfinium.Pdf.Forms.PdfSignatureWidget
Xfinium.Pdf.Forms.PdfTextBoxWidget
Xfinium.Pdf.Annotations.PdfFileAttachmentAnnotationName
Xfinium.Pdf.Annotations.PdfRichMediaActivation
Xfinium.Pdf.Annotations.PdfRichMediaAsset
Xfinium.Pdf.Annotations.PdfRichMediaContent
Xfinium.Pdf.Annotations.PdfRichMediaDeactivation
Xfinium.Pdf.Annotations.PdfRubberStampAnnotationName
Xfinium.Pdf.Annotations.PdfSoundAnnotationName
Xfinium.Pdf.Annotations.PdfTextAnnotationName
Xfinium.Pdf.PdfContentStreamContainer
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Annotations.PdfAnnotationAppearance
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

Pdf3DActivation Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DActivation Class
Defines the times at which the annotation should be activated and deactivated and the state of the 3D artwork instance at those times.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DActivation
   Inherits Pdf3DEntity
'Usage

Dim instance As Pdf3DActivation
public class Pdf3DActivation : Pdf3DEntity
public ref class Pdf3DActivation : public Pdf3DEntity
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DEntity
Xfinium.Pdf.Annotations.Pdf3DActivation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DActivation Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DActivation Class

The following tables list the members exposed by Pdf3DActivation.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DActivation Constructor | Initializes a new Pdf3DActivation object.
Top
Public Properties
 | Name | Description
Public Property | ActivationMode | Gets or sets the annotation activation mode.
Public Property | ActivationState | Gets or sets the annotation activation state.
Public Property | DeactivationMode | Gets or sets the annotation deactivation mode.
Public Property | DeactivationState | Gets or sets the annotation deactivation state.
Public Property | ShowToolbar | Gets or sets a value indicating the default behavior of an interactive toolbar associated with this annotation.
Public Property | ShowUserInterface | Gets or sets a value indicating the default behavior of the user interface for viewing or managing information about the 3D artwork.
Top
See Also

Reference

Pdf3DActivation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DActivation Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DActivation Class : Pdf3DActivation Constructor
Initializes a new Pdf3DActivation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DActivation()
public Pdf3DActivation()
public:
Pdf3DActivation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Class
Pdf3DActivation Members


%%PageItemTitle%% $$Properties$$

Pdf3DActivation Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DActivation Class

For a list of all members of this type, see Pdf3DActivation members.

Public Properties
 | Name | Description
Public Property | ActivationMode | Gets or sets the annotation activation mode.
Public Property | ActivationState | Gets or sets the annotation activation state.
Public Property | DeactivationMode | Gets or sets the annotation deactivation mode.
Public Property | DeactivationState | Gets or sets the annotation deactivation state.
Public Property | ShowToolbar | Gets or sets a value indicating the default behavior of an interactive toolbar associated with this annotation.
Public Property | ShowUserInterface | Gets or sets a value indicating the default behavior of the user interface for viewing or managing information about the 3D artwork.
Top
See Also

Reference

Pdf3DActivation Class
Xfinium.Pdf.Annotations Namespace


ActivationMode Property

Xfinium.Pdf.Annotations Namespace > Pdf3DActivation Class : ActivationMode Property
Gets or sets the annotation activation mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ActivationMode As Pdf3DActivationMode
'Usage

Dim instance As Pdf3DActivation
Dim value As Pdf3DActivationMode

instance.ActivationMode = value

value = instance.ActivationMode
public Pdf3DActivationMode ActivationMode {get; set;}
public:
property Pdf3DActivationMode ActivationMode {
   Pdf3DActivationMode get();
   void set (    Pdf3DActivationMode value);
}

Property Value

A Pdf3DActivationMode specifying the circumstances under which the annotation should be activated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Class
Pdf3DActivation Members


ActivationState Property

Xfinium.Pdf.Annotations Namespace > Pdf3DActivation Class : ActivationState Property
Gets or sets the annotation activation state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ActivationState As Pdf3DActivationState
'Usage

Dim instance As Pdf3DActivation
Dim value As Pdf3DActivationState

instance.ActivationState = value

value = instance.ActivationState
public Pdf3DActivationState ActivationState {get; set;}
public:
property Pdf3DActivationState ActivationState {
   Pdf3DActivationState get();
   void set (    Pdf3DActivationState value);
}

Property Value

A Pdf3DActivationState specifying the state of the artwork instance upon activation of the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Class
Pdf3DActivation Members


DeactivationMode Property

Xfinium.Pdf.Annotations Namespace > Pdf3DActivation Class : DeactivationMode Property
Gets or sets the annotation deactivation mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DeactivationMode As Pdf3DDeactivationMode
'Usage

Dim instance As Pdf3DActivation
Dim value As Pdf3DDeactivationMode

instance.DeactivationMode = value

value = instance.DeactivationMode
public Pdf3DDeactivationMode DeactivationMode {get; set;}
public:
property Pdf3DDeactivationMode DeactivationMode {
   Pdf3DDeactivationMode get();
   void set (    Pdf3DDeactivationMode value);
}

Property Value

A Pdf3DDeactivationMode specifying the circumstances under which the annotation should be deactivated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Class
Pdf3DActivation Members


DeactivationState Property

Xfinium.Pdf.Annotations Namespace > Pdf3DActivation Class : DeactivationState Property
Gets or sets the annotation deactivation state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DeactivationState As Pdf3DDeactivationState
'Usage

Dim instance As Pdf3DActivation
Dim value As Pdf3DDeactivationState

instance.DeactivationState = value

value = instance.DeactivationState
public Pdf3DDeactivationState DeactivationState {get; set;}
public:
property Pdf3DDeactivationState DeactivationState {
   Pdf3DDeactivationState get();
   void set (    Pdf3DDeactivationState value);
}

Property Value

A Pdf3DDeactivationState specifying the state of the artwork instance upon deactivation of the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Class
Pdf3DActivation Members


ShowToolbar Property

Xfinium.Pdf.Annotations Namespace > Pdf3DActivation Class : ShowToolbar Property
Gets or sets a value indicating the default behavior of an interactive toolbar associated with this annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowToolbar As Boolean
'Usage

Dim instance As Pdf3DActivation
Dim value As Boolean

instance.ShowToolbar = value

value = instance.ShowToolbar
public bool ShowToolbar {get; set;}
public:
property bool ShowToolbar {
   bool get();
   void set (    bool value);
}

Property Value

If true, a toolbar should be displayed by default when the annotation is activated and given focus. If false, a toolbar should not be displayed by default.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Class
Pdf3DActivation Members


ShowUserInterface Property

Xfinium.Pdf.Annotations Namespace > Pdf3DActivation Class : ShowUserInterface Property
Gets or sets a value indicating the default behavior of the user interface for viewing or managing information about the 3D artwork.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowUserInterface As Boolean
'Usage

Dim instance As Pdf3DActivation
Dim value As Boolean

instance.ShowUserInterface = value

value = instance.ShowUserInterface
public bool ShowUserInterface {get; set;}
public:
property bool ShowUserInterface {
   bool get();
   void set (    bool value);
}

Property Value

If true, the user interface should be made visible when the annotation is activated. If false, the user interface should not be made visible by default.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Class
Pdf3DActivation Members


%%PageItemTitle%%

Pdf3DAnimation Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DAnimation Class
Defines the preferred method that viewer applications should use to apply timeline scaling to keyframe animations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DAnimation
'Usage

Dim instance As Pdf3DAnimation
public class Pdf3DAnimation
public ref class Pdf3DAnimation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DAnimation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnimation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DAnimation Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DAnimation Class

The following tables list the members exposed by Pdf3DAnimation.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DAnimation Constructor | Initializes a new Pdf3DAnimation object.
Top
Public Properties
 | Name | Description
Public Property | PlayCount | Gets or sets the play count.
Public Property | Style | Gets or sets the animation style.
Public Property | TimeMultiplier | Gets or sets the time multiplier.
Top
See Also

Reference

Pdf3DAnimation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DAnimation Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DAnimation Class : Pdf3DAnimation Constructor
Initializes a new Pdf3DAnimation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DAnimation()
public Pdf3DAnimation()
public:
Pdf3DAnimation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnimation Class
Pdf3DAnimation Members


%%PageItemTitle%% $$Properties$$

Pdf3DAnimation Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DAnimation Class

For a list of all members of this type, see Pdf3DAnimation members.

Public Properties
 | Name | Description
Public Property | PlayCount | Gets or sets the play count.
Public Property | Style | Gets or sets the animation style.
Public Property | TimeMultiplier | Gets or sets the time multiplier.
Top
See Also

Reference

Pdf3DAnimation Class
Xfinium.Pdf.Annotations Namespace


PlayCount Property

Xfinium.Pdf.Annotations Namespace > Pdf3DAnimation Class : PlayCount Property
Gets or sets the play count.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PlayCount As Integer
'Usage

Dim instance As Pdf3DAnimation
Dim value As Integer

instance.PlayCount = value

value = instance.PlayCount
public int PlayCount {get; set;}
public:
property int PlayCount {
   int get();
   void set (    int value);
}

Property Value

An integer specifying the play count for this animation.
Remarks
A non-negative integer represents the number of times the animation is played. A negative integer indicates that the animation is infinitely repeated. This value is ignored for animation types of Pdf3DAnimationStyle.None.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnimation Class
Pdf3DAnimation Members


Style Property (Pdf3DAnimation)

Xfinium.Pdf.Annotations Namespace > Pdf3DAnimation Class : Style Property
Gets or sets the animation style.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Style As Pdf3DAnimationStyle
'Usage

Dim instance As Pdf3DAnimation
Dim value As Pdf3DAnimationStyle

instance.Style = value

value = instance.Style
public Pdf3DAnimationStyle Style {get; set;}
public:
property Pdf3DAnimationStyle Style {
   Pdf3DAnimationStyle get();
   void set (    Pdf3DAnimationStyle value);
}

Property Value

A Pdf3DAnimationStyle specifying the style defined by this animation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnimation Class
Pdf3DAnimation Members


TimeMultiplier Property

Xfinium.Pdf.Annotations Namespace > Pdf3DAnimation Class : TimeMultiplier Property
Gets or sets the time multiplier.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TimeMultiplier As Double
'Usage

Dim instance As Pdf3DAnimation
Dim value As Double

instance.TimeMultiplier = value

value = instance.TimeMultiplier
public double TimeMultiplier {get; set;}
public:
property double TimeMultiplier {
   double get();
   void set (    double value);
}

Property Value

A positive number specifying the time multiplier to be used when running the animation.
Remarks
A value greater than one shortens the time it takes to play the animation, or effectively speeds up the animation. This value is ignored for animation types of Pdf3DAnimationStyle.None.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnimation Class
Pdf3DAnimation Members


%%PageItemTitle%%

Pdf3DAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DAnnotation Class
Defines a 3D annotation.
Object Model
Pdf3DAnnotation ClassPdf3DActivation ClassPdfCosDictionary ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdf3DStream ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DAnnotation
   Inherits PdfAnnotation
'Usage

Dim instance As Pdf3DAnnotation
public class Pdf3DAnnotation : PdfAnnotation
public ref class Pdf3DAnnotation : public PdfAnnotation
Remarks
A 3D annotation is the mean by which 3D artwork is represented in a PDF document.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.Pdf3DAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : Pdf3DAnnotation Class

The following tables list the members exposed by Pdf3DAnnotation.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DAnnotation Constructor | Initializes a new Pdf3DAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Activation | Gets or sets the annotation activation.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Stream | Gets or sets the 3D stream.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

Pdf3DAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DAnnotation Class : Pdf3DAnnotation Constructor
Initializes a new Pdf3DAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DAnnotation()
public Pdf3DAnnotation()
public:
Pdf3DAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnnotation Class
Pdf3DAnnotation Members


%%PageItemTitle%% $$Properties$$

Pdf3DAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DAnnotation Class

For a list of all members of this type, see Pdf3DAnnotation members.

Public Properties
 | Name | Description
Public Property | Activation | Gets or sets the annotation activation.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Stream | Gets or sets the 3D stream.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

Pdf3DAnnotation Class
Xfinium.Pdf.Annotations Namespace


Activation Property

Xfinium.Pdf.Annotations Namespace > Pdf3DAnnotation Class : Activation Property
Gets or sets the annotation activation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Activation As Pdf3DActivation
'Usage

Dim instance As Pdf3DAnnotation
Dim value As Pdf3DActivation

instance.Activation = value

value = instance.Activation
public Pdf3DActivation Activation {get; set;}
public:
property Pdf3DActivation^ Activation {
   Pdf3DActivation^ get();
   void set (    Pdf3DActivation^ value);
}

Property Value

A Pdf3DActivation that defines the times at which the annotation should be activated and deactivated and the state of the 3D artwork instance at those times.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnnotation Class
Pdf3DAnnotation Members


Stream Property (Pdf3DAnnotation)

Xfinium.Pdf.Annotations Namespace > Pdf3DAnnotation Class : Stream Property
Gets or sets the 3D stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Stream As Pdf3DStream
'Usage

Dim instance As Pdf3DAnnotation
Dim value As Pdf3DStream

instance.Stream = value

value = instance.Stream
public Pdf3DStream Stream {get; set;}
public:
property Pdf3DStream^ Stream {
   Pdf3DStream^ get();
   void set (    Pdf3DStream^ value);
}

Property Value

A Pdf3DStream that specifies the 3D artwork to be shown.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnnotation Class
Pdf3DAnnotation Members


%%PageItemTitle%%

Pdf3DBackground Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DBackground Class
Defines the background over which a 3D view is to be drawn.
Object Model
Pdf3DBackground ClassPdfRgbColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DBackground
'Usage

Dim instance As Pdf3DBackground
public class Pdf3DBackground
public ref class Pdf3DBackground
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DBackground

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DBackground Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DBackground Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DBackground Class

The following tables list the members exposed by Pdf3DBackground.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DBackground Constructor | Initializes a new Pdf3DBackground object.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the background color.
Public Property | Extend | Gets or sets a value indicating whether the background is extended to entire annotation area.
Top
See Also

Reference

Pdf3DBackground Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DBackground Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DBackground Class : Pdf3DBackground Constructor
Initializes a new Pdf3DBackground object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DBackground()
public Pdf3DBackground()
public:
Pdf3DBackground();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DBackground Class
Pdf3DBackground Members


%%PageItemTitle%% $$Properties$$

Pdf3DBackground Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DBackground Class

For a list of all members of this type, see Pdf3DBackground members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the background color.
Public Property | Extend | Gets or sets a value indicating whether the background is extended to entire annotation area.
Top
See Also

Reference

Pdf3DBackground Class
Xfinium.Pdf.Annotations Namespace


Color Property (Pdf3DBackground)

Xfinium.Pdf.Annotations Namespace > Pdf3DBackground Class : Color Property
Gets or sets the background color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Color As PdfRgbColor
'Usage

Dim instance As Pdf3DBackground
Dim value As PdfRgbColor

instance.Color = value

value = instance.Color
public PdfRgbColor Color {get; set;}
public:
property PdfRgbColor^ Color {
   PdfRgbColor^ get();
   void set (    PdfRgbColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfRgbColor that defines the color of the background.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DBackground Class
Pdf3DBackground Members


Extend Property

Xfinium.Pdf.Annotations Namespace > Pdf3DBackground Class : Extend Property
Gets or sets a value indicating whether the background is extended to entire annotation area.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Extend As Boolean
'Usage

Dim instance As Pdf3DBackground
Dim value As Boolean

instance.Extend = value

value = instance.Extend
public bool Extend {get; set;}
public:
property bool Extend {
   bool get();
   void set (    bool value);
}

Property Value

If true, the background should apply to the entire annotation. If false, the background should apply only to the rectangle specified by the annotation's 3D view box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DBackground Class
Pdf3DBackground Members


%%PageItemTitle%%

Pdf3DCrossSection Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DCrossSection Class
Defines how a portion of the 3D artwork is clipped for the purpose of showing artwork cross sections.
Object Model
Pdf3DCrossSection ClassPdfRgbColor ClassPdfRgbColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DCrossSection
'Usage

Dim instance As Pdf3DCrossSection
public class Pdf3DCrossSection
public ref class Pdf3DCrossSection
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DCrossSection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DCrossSection Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DCrossSection Class

The following tables list the members exposed by Pdf3DCrossSection.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DCrossSection Constructor | Initializes a new Pdf3DCrossSection object.
Top
Public Properties
 | Name | Description
Public Property | CenterOfRotation | Gets or sets the center of rotation of the cutting plane.
Public Property | Color | Gets or sets the color for the cutting plane.
Public Property | IntersectionColor | Gets or sets the color for the cutting plane's intersection with the 3D artwork.
Public Property | Opacity | Gets or sets the opacity of the cutting plane.
Public Property | Orientation | Gets or sets the orientation of the cutting plane.
Public Property | VisibleIntersection | Gets or sets a value indicating the visibility of the intersection of the cutting plane with any 3D geometry.
Top
See Also

Reference

Pdf3DCrossSection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DCrossSection Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DCrossSection Class : Pdf3DCrossSection Constructor
Initializes a new Pdf3DCrossSection object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DCrossSection()
public Pdf3DCrossSection()
public:
Pdf3DCrossSection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Class
Pdf3DCrossSection Members


%%PageItemTitle%% $$Properties$$

Pdf3DCrossSection Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DCrossSection Class

For a list of all members of this type, see Pdf3DCrossSection members.

Public Properties
 | Name | Description
Public Property | CenterOfRotation | Gets or sets the center of rotation of the cutting plane.
Public Property | Color | Gets or sets the color for the cutting plane.
Public Property | IntersectionColor | Gets or sets the color for the cutting plane's intersection with the 3D artwork.
Public Property | Opacity | Gets or sets the opacity of the cutting plane.
Public Property | Orientation | Gets or sets the orientation of the cutting plane.
Public Property | VisibleIntersection | Gets or sets a value indicating the visibility of the intersection of the cutting plane with any 3D geometry.
Top
See Also

Reference

Pdf3DCrossSection Class
Xfinium.Pdf.Annotations Namespace


CenterOfRotation Property

Xfinium.Pdf.Annotations Namespace > Pdf3DCrossSection Class : CenterOfRotation Property
Gets or sets the center of rotation of the cutting plane.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CenterOfRotation As Double()
'Usage

Dim instance As Pdf3DCrossSection
Dim value() As Double

instance.CenterOfRotation = value

value = instance.CenterOfRotation
public double[] CenterOfRotation {get; set;}
public:
property array<double>^ CenterOfRotation {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A three element array specifying the center of rotation on the cutting plane in world space coordinates.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Class
Pdf3DCrossSection Members


Color Property (Pdf3DCrossSection)

Xfinium.Pdf.Annotations Namespace > Pdf3DCrossSection Class : Color Property
Gets or sets the color for the cutting plane.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Color As PdfRgbColor
'Usage

Dim instance As Pdf3DCrossSection
Dim value As PdfRgbColor

instance.Color = value

value = instance.Color
public PdfRgbColor Color {get; set;}
public:
property PdfRgbColor^ Color {
   PdfRgbColor^ get();
   void set (    PdfRgbColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfRgbColor that defines the color of the cutting plane.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Class
Pdf3DCrossSection Members


IntersectionColor Property

Xfinium.Pdf.Annotations Namespace > Pdf3DCrossSection Class : IntersectionColor Property
Gets or sets the color for the cutting plane's intersection with the 3D artwork.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IntersectionColor As PdfRgbColor
'Usage

Dim instance As Pdf3DCrossSection
Dim value As PdfRgbColor

instance.IntersectionColor = value

value = instance.IntersectionColor
public PdfRgbColor IntersectionColor {get; set;}
public:
property PdfRgbColor^ IntersectionColor {
   PdfRgbColor^ get();
   void set (    PdfRgbColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfRgbColor that defines the color for the cutting plane's intersection with the 3D artwork.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Class
Pdf3DCrossSection Members


Opacity Property (Pdf3DCrossSection)

Xfinium.Pdf.Annotations Namespace > Pdf3DCrossSection Class : Opacity Property
Gets or sets the opacity of the cutting plane.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Opacity As Double
'Usage

Dim instance As Pdf3DCrossSection
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public double Opacity {get; set;}
public:
property double Opacity {
   double get();
   void set (    double value);
}

Property Value

A number in the range [0, 1] indicating the opacity of the cutting plane using a standard additive blend mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Class
Pdf3DCrossSection Members


Orientation Property

Xfinium.Pdf.Annotations Namespace > Pdf3DCrossSection Class : Orientation Property
Gets or sets the orientation of the cutting plane.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Orientation As Object()
'Usage

Dim instance As Pdf3DCrossSection
Dim value() As Object

instance.Orientation = value

value = instance.Orientation
public object[] Orientation {get; set;}
public:
property array<Object^>^ Orientation {
   array<Object^>^ get();
   void set (    array<Object^>^ value);
}

Property Value

A three-element array specifying the orientation of the cutting plane in world space, where each value represents the orientation in relation to the X, Y, and Z axes.
Remarks
Exactly one of the values must be null, indicating an initial state of the cutting plane that is perpendicular to the corresponding axis and clipping all geometry on the positive side of that axis. The other two values must be numbers indicating the rotation of the plane, in degrees, around their corresponding axes. The order in which these rotations are applied should match the order in which the values appear in the array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Class
Pdf3DCrossSection Members


VisibleIntersection Property

Xfinium.Pdf.Annotations Namespace > Pdf3DCrossSection Class : VisibleIntersection Property
Gets or sets a value indicating the visibility of the intersection of the cutting plane with any 3D geometry.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VisibleIntersection As Boolean
'Usage

Dim instance As Pdf3DCrossSection
Dim value As Boolean

instance.VisibleIntersection = value

value = instance.VisibleIntersection
public bool VisibleIntersection {get; set;}
public:
property bool VisibleIntersection {
   bool get();
   void set (    bool value);
}

Property Value

If true, then the intersection is visible. If false, then the intersection is not visible.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Class
Pdf3DCrossSection Members


%%PageItemTitle%%

Pdf3DCrossSectionCollection Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DCrossSectionCollection Class
Defines a collection of 3D cross sections.
Object Model
Pdf3DCrossSectionCollection ClassPdf3DCrossSection Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DCrossSectionCollection
   Inherits System.Collections.ObjectModel.Collection(Of Pdf3DCrossSection)
'Usage

Dim instance As Pdf3DCrossSectionCollection
public class Pdf3DCrossSectionCollection : System.Collections.ObjectModel.Collection<Pdf3DCrossSection>
public ref class Pdf3DCrossSectionCollection : public System.Collections.ObjectModel.Collection<Pdf3DCrossSection>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Annotations.Pdf3DCrossSectionCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSectionCollection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DCrossSectionCollection Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : Pdf3DCrossSectionCollection Class

The following tables list the members exposed by Pdf3DCrossSectionCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Top
See Also

Reference

Pdf3DCrossSectionCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DEntity Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DEntity Class
Abstract base class for 3D objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class Pdf3DEntity
'Usage

Dim instance As Pdf3DEntity
public abstract class Pdf3DEntity
public ref class Pdf3DEntity abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DEntity
Xfinium.Pdf.Annotations.Pdf3DActivation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DEntity Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DEntity Class Members

Xfinium.Pdf.Annotations Namespace : Pdf3DEntity Class

The following tables list the members exposed by Pdf3DEntity.

See Also

Reference

Pdf3DEntity Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DLightingScheme Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DLightingScheme Class
Defines the lighting to apply to 3D artwork.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DLightingScheme
'Usage

Dim instance As Pdf3DLightingScheme
public class Pdf3DLightingScheme
public ref class Pdf3DLightingScheme
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DLightingScheme

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DLightingScheme Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DLightingScheme Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DLightingScheme Class

The following tables list the members exposed by Pdf3DLightingScheme.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DLightingScheme Constructor | Initializes a new Pdf3DLightingScheme object.
Top
Public Properties
 | Name | Description
Public Property | Style | Gets or sets the style of lighting scheme.
Top
See Also

Reference

Pdf3DLightingScheme Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DLightingScheme Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DLightingScheme Class : Pdf3DLightingScheme Constructor
Initializes a new Pdf3DLightingScheme object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DLightingScheme()
public Pdf3DLightingScheme()
public:
Pdf3DLightingScheme();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DLightingScheme Class
Pdf3DLightingScheme Members


%%PageItemTitle%% $$Properties$$

Pdf3DLightingScheme Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DLightingScheme Class

For a list of all members of this type, see Pdf3DLightingScheme members.

Public Properties
 | Name | Description
Public Property | Style | Gets or sets the style of lighting scheme.
Top
See Also

Reference

Pdf3DLightingScheme Class
Xfinium.Pdf.Annotations Namespace


Style Property (Pdf3DLightingScheme)

Xfinium.Pdf.Annotations Namespace > Pdf3DLightingScheme Class : Style Property
Gets or sets the style of lighting scheme.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Style As Pdf3DLightingStyle
'Usage

Dim instance As Pdf3DLightingScheme
Dim value As Pdf3DLightingStyle

instance.Style = value

value = instance.Style
public Pdf3DLightingStyle Style {get; set;}
public:
property Pdf3DLightingStyle Style {
   Pdf3DLightingStyle get();
   void set (    Pdf3DLightingStyle value);
}

Property Value

A Pdf3DLightingStyle that represents style of lighting scheme.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DLightingScheme Class
Pdf3DLightingScheme Members


%%PageItemTitle%%

Pdf3DNode Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DNode Class
Defines particular areas of 3D artwork and the opacity and visibility with which individual nodes are displayed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DNode
'Usage

Dim instance As Pdf3DNode
public class Pdf3DNode
public ref class Pdf3DNode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DNode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DNode Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DNode Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DNode Class

The following tables list the members exposed by Pdf3DNode.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DNode Constructor | Initializes a new Pdf3DNode object.
Top
Public Properties
 | Name | Description
Public Property | Matrix | Gets or sets the 3D transformation matrix.
Public Property | Name | Gets or sets the name of the node.
Public Property | Opacity | Gets or sets the node opacity.
Public Property | Visible | Gets or sets a value indicating whether the node is visible.
Top
See Also

Reference

Pdf3DNode Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DNode Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DNode Class : Pdf3DNode Constructor
Initializes a new Pdf3DNode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DNode()
public Pdf3DNode()
public:
Pdf3DNode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DNode Class
Pdf3DNode Members


%%PageItemTitle%% $$Properties$$

Pdf3DNode Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DNode Class

For a list of all members of this type, see Pdf3DNode members.

Public Properties
 | Name | Description
Public Property | Matrix | Gets or sets the 3D transformation matrix.
Public Property | Name | Gets or sets the name of the node.
Public Property | Opacity | Gets or sets the node opacity.
Public Property | Visible | Gets or sets a value indicating whether the node is visible.
Top
See Also

Reference

Pdf3DNode Class
Xfinium.Pdf.Annotations Namespace


Matrix Property (Pdf3DNode)

Xfinium.Pdf.Annotations Namespace > Pdf3DNode Class : Matrix Property
Gets or sets the 3D transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Matrix As Double()
'Usage

Dim instance As Pdf3DNode
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
public double[] Matrix {get; set;}
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A 12-element 3D transformation matrix that specifies the position and orientation of this node, relative to its parent, in world coordinates.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DNode Class
Pdf3DNode Members


Name Property (Pdf3DNode)

Xfinium.Pdf.Annotations Namespace > Pdf3DNode Class : Name Property
Gets or sets the name of the node.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As Pdf3DNode
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the node being described by this node object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DNode Class
Pdf3DNode Members


Opacity Property (Pdf3DNode)

Xfinium.Pdf.Annotations Namespace > Pdf3DNode Class : Opacity Property
Gets or sets the node opacity.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Opacity As Double
'Usage

Dim instance As Pdf3DNode
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public double Opacity {get; set;}
public:
property double Opacity {
   double get();
   void set (    double value);
}

Property Value

A number in the range [0, 1] indicating the opacity of the geometry supplied by this node using a standard additive blend mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DNode Class
Pdf3DNode Members


Visible Property (Pdf3DNode)

Xfinium.Pdf.Annotations Namespace > Pdf3DNode Class : Visible Property
Gets or sets a value indicating whether the node is visible.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As Pdf3DNode
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

If true, then the node is visible. If false, then the node is not visible.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DNode Class
Pdf3DNode Members


%%PageItemTitle%%

Pdf3DNodeCollection Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DNodeCollection Class
Defines a collection of 3D nodes.
Object Model
Pdf3DNodeCollection ClassPdf3DNode Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DNodeCollection
   Inherits System.Collections.ObjectModel.Collection(Of Pdf3DNode)
'Usage

Dim instance As Pdf3DNodeCollection
public class Pdf3DNodeCollection : System.Collections.ObjectModel.Collection<Pdf3DNode>
public ref class Pdf3DNodeCollection : public System.Collections.ObjectModel.Collection<Pdf3DNode>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Annotations.Pdf3DNodeCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DNodeCollection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DNodeCollection Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : Pdf3DNodeCollection Class

The following tables list the members exposed by Pdf3DNodeCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Top
See Also

Reference

Pdf3DNodeCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DProjection Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DProjection Class
Defines the mapping of 3D camera coordinates onto the target coordinate system of the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DProjection
'Usage

Dim instance As Pdf3DProjection
public class Pdf3DProjection
public ref class Pdf3DProjection
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DProjection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DProjection Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DProjection Class

The following tables list the members exposed by Pdf3DProjection.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DProjection Constructor | Initializes a new Pdf3DProjection object.
Top
Public Properties
 | Name | Description
Public Property | ClippingStyle | Gets or sets the clipping style.
Public Property | FarClippingDistance | Gets or sets the far clipping distance.
Public Property | FieldOfView | Gets or sets the field of view.
Public Property | NearClippingDistance | Gets or sets the near clipping distance.
Public Property | OrthoScaleStrategy | Gets or sets the ortographic scale strategy.
Public Property | Scaling | Gets or sets the the scaling used when projecting the 3D artwork.
Public Property | Type | Gets or sets the type of projection.
Top
See Also

Reference

Pdf3DProjection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DProjection Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : Pdf3DProjection Constructor
Initializes a new Pdf3DProjection object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DProjection()
public Pdf3DProjection()
public:
Pdf3DProjection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


%%PageItemTitle%% $$Properties$$

Pdf3DProjection Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DProjection Class

For a list of all members of this type, see Pdf3DProjection members.

Public Properties
 | Name | Description
Public Property | ClippingStyle | Gets or sets the clipping style.
Public Property | FarClippingDistance | Gets or sets the far clipping distance.
Public Property | FieldOfView | Gets or sets the field of view.
Public Property | NearClippingDistance | Gets or sets the near clipping distance.
Public Property | OrthoScaleStrategy | Gets or sets the ortographic scale strategy.
Public Property | Scaling | Gets or sets the the scaling used when projecting the 3D artwork.
Public Property | Type | Gets or sets the type of projection.
Top
See Also

Reference

Pdf3DProjection Class
Xfinium.Pdf.Annotations Namespace


ClippingStyle Property

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : ClippingStyle Property
Gets or sets the clipping style.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ClippingStyle As Pdf3DProjectionClippingStyle
'Usage

Dim instance As Pdf3DProjection
Dim value As Pdf3DProjectionClippingStyle

instance.ClippingStyle = value

value = instance.ClippingStyle
public Pdf3DProjectionClippingStyle ClippingStyle {get; set;}
public:
property Pdf3DProjectionClippingStyle ClippingStyle {
   Pdf3DProjectionClippingStyle get();
   void set (    Pdf3DProjectionClippingStyle value);
}

Property Value

A Pdf3DProjectionClippingStyle that represents the clipping style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


FarClippingDistance Property

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : FarClippingDistance Property
Gets or sets the far clipping distance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FarClippingDistance As Double
'Usage

Dim instance As Pdf3DProjection
Dim value As Double

instance.FarClippingDistance = value

value = instance.FarClippingDistance
public double FarClippingDistance {get; set;}
public:
property double FarClippingDistance {
   double get();
   void set (    double value);
}

Property Value

The far clipping distance, expressed in the camera coordinate system.
Remarks
The value is meaningful only if ClippingStyle property is Pdf3DProjectionClippingStyle.ExplicitNearFar.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


FieldOfView Property

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : FieldOfView Property
Gets or sets the field of view.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FieldOfView As Double
'Usage

Dim instance As Pdf3DProjection
Dim value As Double

instance.FieldOfView = value

value = instance.FieldOfView
public double FieldOfView {get; set;}
public:
property double FieldOfView {
   double get();
   void set (    double value);
}

Property Value

A number between 0 and 180, inclusive, specifying the field of view of the virtual camera, in degrees.
Remarks
This value is meaningful only if Type property is Pdf3DProjectionType.Perspective.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


NearClippingDistance Property

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : NearClippingDistance Property
Gets or sets the near clipping distance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NearClippingDistance As Double
'Usage

Dim instance As Pdf3DProjection
Dim value As Double

instance.NearClippingDistance = value

value = instance.NearClippingDistance
public double NearClippingDistance {get; set;}
public:
property double NearClippingDistance {
   double get();
   void set (    double value);
}

Property Value

The near clipping distance, expressed in the camera coordinate system.
Remarks
This value is meaningful only if ClippingStyle property is Pdf3DProjectionClippingStyle.ExplicitNearFar or if Type is Pdf3DProjectionType.Perspective.
The value must be non-negative for orthographic projections and positive for perspective projections.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


OrthoScaleStrategy Property

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : OrthoScaleStrategy Property
Gets or sets the ortographic scale strategy.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OrthoScaleStrategy As Pdf3DProjectionOrthoScaleStrategy
'Usage

Dim instance As Pdf3DProjection
Dim value As Pdf3DProjectionOrthoScaleStrategy

instance.OrthoScaleStrategy = value

value = instance.OrthoScaleStrategy
public Pdf3DProjectionOrthoScaleStrategy OrthoScaleStrategy {get; set;}
public:
property Pdf3DProjectionOrthoScaleStrategy OrthoScaleStrategy {
   Pdf3DProjectionOrthoScaleStrategy get();
   void set (    Pdf3DProjectionOrthoScaleStrategy value);
}

Property Value

A Pdf3DProjectionOrthoScaleStrategy that represents strategy for binding (scaling to fit) the near plane's x and y coordinates onto the annotation's target coordinate system.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


Scaling Property

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : Scaling Property
Gets or sets the the scaling used when projecting the 3D artwork.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Scaling As Double
'Usage

Dim instance As Pdf3DProjection
Dim value As Double

instance.Scaling = value

value = instance.Scaling
public double Scaling {get; set;}
public:
property double Scaling {
   double get();
   void set (    double value);
}

Property Value

A positive number that specifies the scaling used when projecting the 3D artwork onto the annotation's target coordinate system.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


Type Property (Pdf3DProjection)

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : Type Property
Gets or sets the type of projection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Type As Pdf3DProjectionType
'Usage

Dim instance As Pdf3DProjection
Dim value As Pdf3DProjectionType

instance.Type = value

value = instance.Type
public Pdf3DProjectionType Type {get; set;}
public:
property Pdf3DProjectionType Type {
   Pdf3DProjectionType get();
   void set (    Pdf3DProjectionType value);
}

Property Value

A Pdf3DProjectionType that represents the type of projection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


%%PageItemTitle%%

Pdf3DRendering Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DRendering Class
Defines the style in which the 3D artwork is rendered.
Object Model
Pdf3DRendering ClassPdfRgbColor ClassPdfRgbColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DRendering
'Usage

Dim instance As Pdf3DRendering
public class Pdf3DRendering
public ref class Pdf3DRendering
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DRendering

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DRendering Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DRendering Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DRendering Class

The following tables list the members exposed by Pdf3DRendering.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DRendering Constructor | Initializes a new Pdf3DRendering object.
Top
Public Properties
 | Name | Description
Public Property | AuxiliaryColor | Gets or sets the auxiliary color.
Public Property | CreaseValue | Gets or sets the crease value.
Public Property | FaceColor | Gets or sets the face color.
Public Property | Mode | Gets or sets the rendering mode.
Public Property | Opacity | Gets or sets the opacity.
Top
See Also

Reference

Pdf3DRendering Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DRendering Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DRendering Class : Pdf3DRendering Constructor
Initializes a new Pdf3DRendering object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DRendering()
public Pdf3DRendering()
public:
Pdf3DRendering();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DRendering Class
Pdf3DRendering Members


%%PageItemTitle%% $$Properties$$

Pdf3DRendering Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DRendering Class

For a list of all members of this type, see Pdf3DRendering members.

Public Properties
 | Name | Description
Public Property | AuxiliaryColor | Gets or sets the auxiliary color.
Public Property | CreaseValue | Gets or sets the crease value.
Public Property | FaceColor | Gets or sets the face color.
Public Property | Mode | Gets or sets the rendering mode.
Public Property | Opacity | Gets or sets the opacity.
Top
See Also

Reference

Pdf3DRendering Class
Xfinium.Pdf.Annotations Namespace


AuxiliaryColor Property

Xfinium.Pdf.Annotations Namespace > Pdf3DRendering Class : AuxiliaryColor Property
Gets or sets the auxiliary color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AuxiliaryColor As PdfRgbColor
'Usage

Dim instance As Pdf3DRendering
Dim value As PdfRgbColor

instance.AuxiliaryColor = value

value = instance.AuxiliaryColor
public PdfRgbColor AuxiliaryColor {get; set;}
public:
property PdfRgbColor^ AuxiliaryColor {
   PdfRgbColor^ get();
   void set (    PdfRgbColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfRgbColor that represents the auxiliary color to be used when rendering the 3D image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DRendering Class
Pdf3DRendering Members


CreaseValue Property

Xfinium.Pdf.Annotations Namespace > Pdf3DRendering Class : CreaseValue Property
Gets or sets the crease value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CreaseValue As Double
'Usage

Dim instance As Pdf3DRendering
Dim value As Double

instance.CreaseValue = value

value = instance.CreaseValue
public double CreaseValue {get; set;}
public:
property double CreaseValue {
   double get();
   void set (    double value);
}

Property Value

A number specifying the angle, in degrees,to be used as the crease value to be used when determining silhouette edges.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DRendering Class
Pdf3DRendering Members


FaceColor Property

Xfinium.Pdf.Annotations Namespace > Pdf3DRendering Class : FaceColor Property
Gets or sets the face color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FaceColor As PdfRgbColor
'Usage

Dim instance As Pdf3DRendering
Dim value As PdfRgbColor

instance.FaceColor = value

value = instance.FaceColor
public PdfRgbColor FaceColor {get; set;}
public:
property PdfRgbColor^ FaceColor {
   PdfRgbColor^ get();
   void set (    PdfRgbColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfRgbColor that represents the face color to be used when rendering the 3D image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DRendering Class
Pdf3DRendering Members


Mode Property

Xfinium.Pdf.Annotations Namespace > Pdf3DRendering Class : Mode Property
Gets or sets the rendering mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Mode As Pdf3DRenderingMode
'Usage

Dim instance As Pdf3DRendering
Dim value As Pdf3DRenderingMode

instance.Mode = value

value = instance.Mode
public Pdf3DRenderingMode Mode {get; set;}
public:
property Pdf3DRenderingMode Mode {
   Pdf3DRenderingMode get();
   void set (    Pdf3DRenderingMode value);
}

Property Value

A Pdf3DRenderingMode that represents the mode to be used when rendering the 3D image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DRendering Class
Pdf3DRendering Members


Opacity Property (Pdf3DRendering)

Xfinium.Pdf.Annotations Namespace > Pdf3DRendering Class : Opacity Property
Gets or sets the opacity.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Opacity As Double
'Usage

Dim instance As Pdf3DRendering
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public double Opacity {get; set;}
public:
property double Opacity {
   double get();
   void set (    double value);
}

Property Value

A number specifying the opacity of the added transparency applied by some render modes, using a standard additive blend.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DRendering Class
Pdf3DRendering Members


%%PageItemTitle%%

Pdf3DStream Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DStream Class
Defines a 3D stream.
Object Model
Pdf3DStream ClassPdf3DAnimation ClassPdf3DView ClassPdfJavaScriptBlock ClassPdf3DViewCollection ClassPdf3DView Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DStream
'Usage

Dim instance As Pdf3DStream
public class Pdf3DStream
public ref class Pdf3DStream
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DStream

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DStream Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DStream Class

The following tables list the members exposed by Pdf3DStream.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DStream Constructor | Initializes a new Pdf3DStream object.
Top
Public Properties
 | Name | Description
Public Property | Animation | Gets or sets the 3D animation.
Public Property | Content | Gets or sets the 3D content.
Public Property | DefaultView | Gets or sets the default 3D view.
Public Property | DefaultViewIndex | Gets or sets the default 3D view.
Public Property | DefaultViewName | Gets or sets the name of the default 3D view.
Public Property | OnInstantiate | Gets or sets the JavaScript script that is executed when the 3D stream is instantiated.
Public Property | Views | Gets the collection of 3D views.
Top
See Also

Reference

Pdf3DStream Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DStream Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : Pdf3DStream Constructor
Initializes a new Pdf3DStream object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DStream()
public Pdf3DStream()
public:
Pdf3DStream();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


%%PageItemTitle%% $$Properties$$

Pdf3DStream Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DStream Class

For a list of all members of this type, see Pdf3DStream members.

Public Properties
 | Name | Description
Public Property | Animation | Gets or sets the 3D animation.
Public Property | Content | Gets or sets the 3D content.
Public Property | DefaultView | Gets or sets the default 3D view.
Public Property | DefaultViewIndex | Gets or sets the default 3D view.
Public Property | DefaultViewName | Gets or sets the name of the default 3D view.
Public Property | OnInstantiate | Gets or sets the JavaScript script that is executed when the 3D stream is instantiated.
Public Property | Views | Gets the collection of 3D views.
Top
See Also

Reference

Pdf3DStream Class
Xfinium.Pdf.Annotations Namespace


Animation Property

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : Animation Property
Gets or sets the 3D animation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Animation As Pdf3DAnimation
'Usage

Dim instance As Pdf3DStream
Dim value As Pdf3DAnimation

instance.Animation = value

value = instance.Animation
public Pdf3DAnimation Animation {get; set;}
public:
property Pdf3DAnimation^ Animation {
   Pdf3DAnimation^ get();
   void set (    Pdf3DAnimation^ value);
}

Property Value

A Pdf3DAnimation indicating the preferred method that viewer applications should use to drive keyframe animations present in this artwork.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


Content Property (Pdf3DStream)

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : Content Property
Gets or sets the 3D content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Content As Byte()
'Usage

Dim instance As Pdf3DStream
Dim value() As Byte

instance.Content = value

value = instance.Content
public byte[] Content {get; set;}
public:
property array<byte>^ Content {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The 3D artwork in U3D format.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


DefaultView Property

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : DefaultView Property
Gets or sets the default 3D view.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultView As Pdf3DView
'Usage

Dim instance As Pdf3DStream
Dim value As Pdf3DView

instance.DefaultView = value

value = instance.DefaultView
public Pdf3DView DefaultView {get; set;}
public:
property Pdf3DView^ DefaultView {
   Pdf3DView^ get();
   void set (    Pdf3DView^ value);
}

Property Value

A Pdf3DView that represents that default view.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


DefaultViewIndex Property

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : DefaultViewIndex Property
Gets or sets the default 3D view.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultViewIndex As Integer
'Usage

Dim instance As Pdf3DStream
Dim value As Integer

instance.DefaultViewIndex = value

value = instance.DefaultViewIndex
public int DefaultViewIndex {get; set;}
public:
property int DefaultViewIndex {
   int get();
   void set (    int value);
}

Property Value

An integer specifying an index into the Views collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


DefaultViewName Property

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : DefaultViewName Property
Gets or sets the name of the default 3D view.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultViewName As String
'Usage

Dim instance As Pdf3DStream
Dim value As String

instance.DefaultViewName = value

value = instance.DefaultViewName
public string DefaultViewName {get; set;}
public:
property String^ DefaultViewName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string matching the InternalName property in one of the views in the Views collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


OnInstantiate Property

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : OnInstantiate Property
Gets or sets the JavaScript script that is executed when the 3D stream is instantiated.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OnInstantiate As PdfJavaScriptBlock
'Usage

Dim instance As Pdf3DStream
Dim value As PdfJavaScriptBlock

instance.OnInstantiate = value

value = instance.OnInstantiate
public PdfJavaScriptBlock OnInstantiate {get; set;}
public:
property PdfJavaScriptBlock^ OnInstantiate {
   PdfJavaScriptBlock^ get();
   void set (    PdfJavaScriptBlock^ value);
}

Property Value

A JavaScript script that is executed when the 3D stream is instantiated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


Views Property

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : Views Property
Gets the collection of 3D views.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Views As Pdf3DViewCollection
'Usage

Dim instance As Pdf3DStream
Dim value As Pdf3DViewCollection

value = instance.Views
public Pdf3DViewCollection Views {get;}
public:
property Pdf3DViewCollection^ Views {
   Pdf3DViewCollection^ get();
}

Property Value

An array of Pdf3DView object, each of which specifies a named preset view of this 3D artwork.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


%%PageItemTitle%%

Pdf3DView Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DView Class
Defines the parameters to be applied to the virtual camera associated with a 3D annotation.
Object Model
Pdf3DView ClassPdf3DBackground ClassPdf3DCrossSectionCollection ClassPdf3DCrossSection ClassPdf3DLightingScheme ClassPdf3DNodeCollection ClassPdf3DNode ClassPdf3DProjection ClassPdf3DRendering Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DView
'Usage

Dim instance As Pdf3DView
public class Pdf3DView
public ref class Pdf3DView
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.Pdf3DView

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DView Class Members
Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DView Class

The following tables list the members exposed by Pdf3DView.

Public Constructors
 | Name | Description
Public Constructor | Pdf3DView Constructor | Initializes a new Pdf3DView object.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the view background.
Public Property | CameraToWorldMatrix | Gets or sets the camera to world transformation matrix.
Public Property | CenterOfOrbit | Gets or sets the center of orbit.
Public Property | CrossSections | Gets the collection of cross sections.
Public Property | ExternalName | Gets or sets the external name of the view.
Public Property | InternalName | Gets or sets the internal name of the view
Public Property | LightingScheme | Gets or sets the lighting scheme.
Public Property | Nodes | Gets the collection of 3D nodes.
Public Property | Projection | Gets or sets the view projection.
Public Property | RenderMode | Gets or sets the view rendering mode.
Public Property | ResetNodes | Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node objects.
Public Property | U3DPath | Gets or sets the path to a view node in 3D data.
Top
See Also

Reference

Pdf3DView Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DView Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : Pdf3DView Constructor
Initializes a new Pdf3DView object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf3DView()
public Pdf3DView()
public:
Pdf3DView();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


%%PageItemTitle%% $$Properties$$

Pdf3DView Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DView Class

For a list of all members of this type, see Pdf3DView members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the view background.
Public Property | CameraToWorldMatrix | Gets or sets the camera to world transformation matrix.
Public Property | CenterOfOrbit | Gets or sets the center of orbit.
Public Property | CrossSections | Gets the collection of cross sections.
Public Property | ExternalName | Gets or sets the external name of the view.
Public Property | InternalName | Gets or sets the internal name of the view
Public Property | LightingScheme | Gets or sets the lighting scheme.
Public Property | Nodes | Gets the collection of 3D nodes.
Public Property | Projection | Gets or sets the view projection.
Public Property | RenderMode | Gets or sets the view rendering mode.
Public Property | ResetNodes | Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node objects.
Public Property | U3DPath | Gets or sets the path to a view node in 3D data.
Top
See Also

Reference

Pdf3DView Class
Xfinium.Pdf.Annotations Namespace


Background Property (Pdf3DView)

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : Background Property
Gets or sets the view background.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Background As Pdf3DBackground
'Usage

Dim instance As Pdf3DView
Dim value As Pdf3DBackground

instance.Background = value

value = instance.Background
public Pdf3DBackground Background {get; set;}
public:
property Pdf3DBackground^ Background {
   Pdf3DBackground^ get();
   void set (    Pdf3DBackground^ value);
}

Property Value

A Pdf3DBackground that represents the background over which the 3D artwork is to be drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


CameraToWorldMatrix Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : CameraToWorldMatrix Property
Gets or sets the camera to world transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CameraToWorldMatrix As Double()
'Usage

Dim instance As Pdf3DView
Dim value() As Double

instance.CameraToWorldMatrix = value

value = instance.CameraToWorldMatrix
public double[] CameraToWorldMatrix {get; set;}
public:
property array<double>^ CameraToWorldMatrix {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A 12-element 3D transformation matrix that specifies a position and orientation of the camera in world coordinates.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


CenterOfOrbit Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : CenterOfOrbit Property
Gets or sets the center of orbit.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CenterOfOrbit As Double
'Usage

Dim instance As Pdf3DView
Dim value As Double

instance.CenterOfOrbit = value

value = instance.CenterOfOrbit
public double CenterOfOrbit {get; set;}
public:
property double CenterOfOrbit {
   double get();
   void set (    double value);
}

Property Value

A non-negative number indicating a distance in the camera coordinate system along the z axis to the center of orbit for this view.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


CrossSections Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : CrossSections Property
Gets the collection of cross sections.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CrossSections As Pdf3DCrossSectionCollection
'Usage

Dim instance As Pdf3DView
Dim value As Pdf3DCrossSectionCollection

value = instance.CrossSections
public Pdf3DCrossSectionCollection CrossSections {get;}
public:
property Pdf3DCrossSectionCollection^ CrossSections {
   Pdf3DCrossSectionCollection^ get();
}

Property Value

A collection of Pdf3DCrossSection.
Remarks
Each cross section provides parameters for applying a cross section to the 3D artwork when using this view.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


ExternalName Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : ExternalName Property
Gets or sets the external name of the view.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExternalName As String
'Usage

Dim instance As Pdf3DView
Dim value As String

instance.ExternalName = value

value = instance.ExternalName
public string ExternalName {get; set;}
public:
property String^ ExternalName {
   String^ get();
   void set (    String^ value);
}

Property Value

The external name of the view, suitable for presentation in a user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


InternalName Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : InternalName Property
Gets or sets the internal name of the view
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InternalName As String
'Usage

Dim instance As Pdf3DView
Dim value As String

instance.InternalName = value

value = instance.InternalName
public string InternalName {get; set;}
public:
property String^ InternalName {
   String^ get();
   void set (    String^ value);
}

Property Value

The internal name of the view, used to refer to the view from other objects, such as the go-to-3D-view actions.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


LightingScheme Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : LightingScheme Property
Gets or sets the lighting scheme.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LightingScheme As Pdf3DLightingScheme
'Usage

Dim instance As Pdf3DView
Dim value As Pdf3DLightingScheme

instance.LightingScheme = value

value = instance.LightingScheme
public Pdf3DLightingScheme LightingScheme {get; set;}
public:
property Pdf3DLightingScheme^ LightingScheme {
   Pdf3DLightingScheme^ get();
   void set (    Pdf3DLightingScheme^ value);
}

Property Value

A Pdf3DLightingScheme that represents the lighting scheme to be used when rendering 3D artwork with this view.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


Nodes Property (Pdf3DView)

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : Nodes Property
Gets the collection of 3D nodes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Nodes As Pdf3DNodeCollection
'Usage

Dim instance As Pdf3DView
Dim value As Pdf3DNodeCollection

value = instance.Nodes
public Pdf3DNodeCollection Nodes {get;}
public:
property Pdf3DNodeCollection^ Nodes {
   Pdf3DNodeCollection^ get();
}

Property Value

A collection of Pdf3DNode.
Remarks
Each 3D node may contain entries that change the node's state, including its opacity and its position in world space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


Projection Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : Projection Property
Gets or sets the view projection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Projection As Pdf3DProjection
'Usage

Dim instance As Pdf3DView
Dim value As Pdf3DProjection

instance.Projection = value

value = instance.Projection
public Pdf3DProjection Projection {get; set;}
public:
property Pdf3DProjection^ Projection {
   Pdf3DProjection^ get();
   void set (    Pdf3DProjection^ value);
}

Property Value

A Pdf3DProjection that represents the projection of coordinates in the 3D artwork (already transformed into camera coordinates) onto the target coordinate system of the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


RenderMode Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : RenderMode Property
Gets or sets the view rendering mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RenderMode As Pdf3DRendering
'Usage

Dim instance As Pdf3DView
Dim value As Pdf3DRendering

instance.RenderMode = value

value = instance.RenderMode
public Pdf3DRendering RenderMode {get; set;}
public:
property Pdf3DRendering^ RenderMode {
   Pdf3DRendering^ get();
   void set (    Pdf3DRendering^ value);
}

Property Value

A Pdf3DRendering that represents the render mode to use when rendering 3D artwork with this view.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


ResetNodes Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : ResetNodes Property
Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ResetNodes As Boolean
'Usage

Dim instance As Pdf3DView
Dim value As Boolean

instance.ResetNodes = value

value = instance.ResetNodes
public bool ResetNodes {get; set;}
public:
property bool ResetNodes {
   bool get();
   void set (    bool value);
}

Property Value

If true, the artwork's 3D node parameters are restored to their original states and then the dictionaries specified by the Nodes collection are applied. If false, the dictionaries specified by the Nodes collection are applied to the current states of the nodes.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


U3DPath Property

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : U3DPath Property
Gets or sets the path to a view node in 3D data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property U3DPath As String
'Usage

Dim instance As Pdf3DView
Dim value As String

instance.U3DPath = value

value = instance.U3DPath
public string U3DPath {get; set;}
public:
property String^ U3DPath {
   String^ get();
   void set (    String^ value);
}

Property Value

A string used to access a view node within the 3D artwork.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


%%PageItemTitle%%

Pdf3DViewCollection Class
Members

Xfinium.Pdf.Annotations Namespace : Pdf3DViewCollection Class
Defines a collection of 3D views.
Object Model
Pdf3DViewCollection ClassPdf3DView Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf3DViewCollection
   Inherits System.Collections.ObjectModel.Collection(Of Pdf3DView)
'Usage

Dim instance As Pdf3DViewCollection
public class Pdf3DViewCollection : System.Collections.ObjectModel.Collection<Pdf3DView>
public ref class Pdf3DViewCollection : public System.Collections.ObjectModel.Collection<Pdf3DView>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Annotations.Pdf3DViewCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DViewCollection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

Pdf3DViewCollection Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : Pdf3DViewCollection Class

The following tables list the members exposed by Pdf3DViewCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Top
See Also

Reference

Pdf3DViewCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfAnnotation Class
Defines an abstract PDF annotation.
Object Model
PdfAnnotation ClassPdfCosDictionary ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAnnotation
'Usage

Dim instance As PdfAnnotation
public class PdfAnnotation
public ref class PdfAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.Pdf3DAnnotation
Xfinium.Pdf.Annotations.PdfLinkAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfRichMediaAnnotation
Xfinium.Pdf.Annotations.PdfScreenAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfAnnotation Class

The following tables list the members exposed by PdfAnnotation.

Public Properties
 | Name | Description
Public Property | Contents | Gets or sets the annotation contents.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | CreationDate | Gets or sets the annotation creation date.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not.
Public Property | ID | Gets or sets the annotation ID.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified.
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified.
Public Property | ModifiedDate | Gets or sets the annotation modified date.
Public Property | MouseDown | Gets or sets the mouse down action.
Public Property | MouseEnter | Gets or sets the mouse enter action.
Public Property | MouseLeave | Gets or sets the mouse leave action.
Public Property | MouseUp | Gets or sets the mouse up action.
Public Property | NormalAppearance | Gets or sets the annotation normal appearance.
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated.
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed.
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom.
Public Property | Page | Gets the annotation page.
Public Property | PageClose | Gets or sets the page close action.
Public Property | PageInvisible | Gets or sets the page invisible action.
Public Property | PageOpen | Gets or sets the page open action.
Public Property | PageVisible | Gets or sets the page visible action.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed.
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only.
Public Property | Rotation | Gets or sets the annotation rotation angle.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed.
Public Property | Type | Gets the type of the annotation.
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object.
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream.
Top
See Also

Reference

PdfAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PdfAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfAnnotation Class

For a list of all members of this type, see PdfAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream.
Top
See Also

Reference

PdfAnnotation Class
Xfinium.Pdf.Annotations Namespace


Flatten Method (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Flatten Method
Merges the annotation appearance with the page content stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub Flatten()
'Usage

Dim instance As PdfAnnotation

instance.Flatten()
public virtual void Flatten()
public:
virtual void Flatten();
Remarks
The annotation normal appearance is merged with the page content stream and the annotation is destroyed. After calling this method the annotation object is in an invalid state and cannot be used any longer.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfAnnotation Class

For a list of all members of this type, see PdfAnnotation members.

Public Properties
 | Name | Description
Public Property | Contents | Gets or sets the annotation contents.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | CreationDate | Gets or sets the annotation creation date.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not.
Public Property | ID | Gets or sets the annotation ID.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified.
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified.
Public Property | ModifiedDate | Gets or sets the annotation modified date.
Public Property | MouseDown | Gets or sets the mouse down action.
Public Property | MouseEnter | Gets or sets the mouse enter action.
Public Property | MouseLeave | Gets or sets the mouse leave action.
Public Property | MouseUp | Gets or sets the mouse up action.
Public Property | NormalAppearance | Gets or sets the annotation normal appearance.
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated.
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed.
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom.
Public Property | Page | Gets the annotation page.
Public Property | PageClose | Gets or sets the page close action.
Public Property | PageInvisible | Gets or sets the page invisible action.
Public Property | PageOpen | Gets or sets the page open action.
Public Property | PageVisible | Gets or sets the page visible action.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed.
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only.
Public Property | Rotation | Gets or sets the annotation rotation angle.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed.
Public Property | Type | Gets the type of the annotation.
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object.
Top
See Also

Reference

PdfAnnotation Class
Xfinium.Pdf.Annotations Namespace


Contents Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Contents Property
Gets or sets the annotation contents.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Contents As String
'Usage

Dim instance As PdfAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
public virtual string Contents {get; set;}
public:
virtual property String^ Contents {
   String^ get();
   void set (    String^ value);
}

Property Value

Text to be displayed for the annotation or, if this type of annotation does not display text, an alternate description of the annotation's contents in human-readable form.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


CosDictionary Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfAnnotation
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


CreationDate Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : CreationDate Property
Gets or sets the annotation creation date.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PdfAnnotation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time when the annotation was created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


Hidden Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Hidden Property
Gets or sets a value indicating whether to display the annotation or not.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Hidden As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.Hidden = value

value = instance.Hidden
public bool Hidden {get; set;}
public:
property bool Hidden {
   bool get();
   void set (    bool value);
}

Property Value

If true, do not display or print the annotation or allow it to interact with the user.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


ID Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : ID Property
Gets or sets the annotation ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ID As String
'Usage

Dim instance As PdfAnnotation
Dim value As String

instance.ID = value

value = instance.ID
public string ID {get; set;}
public:
property String^ ID {
   String^ get();
   void set (    String^ value);
}

Property Value

A unique value representing the ID
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


Invisible Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Invisible Property
Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Invisible As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.Invisible = value

value = instance.Invisible
public bool Invisible {get; set;}
public:
property bool Invisible {
   bool get();
   void set (    bool value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


Locked Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Locked Property
Gets or sets a value indicating whether the annotation should be modified.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Locked As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.Locked = value

value = instance.Locked
public bool Locked {get; set;}
public:
property bool Locked {
   bool get();
   void set (    bool value);
}

Property Value

If true, do not allow the annotation to be deleted or its properties (including position and size) to be modified by the user. However, this flag does not restrict changes to the annotation’s contents, such as the value of a form field.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


LockedContents Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : LockedContents Property
Gets or sets a value indicating whether the annotation contents should be modified.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LockedContents As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.LockedContents = value

value = instance.LockedContents
public bool LockedContents {get; set;}
public:
property bool LockedContents {
   bool get();
   void set (    bool value);
}

Property Value

If true, do not allow the contents of the annotation to be modified by the user. This flag does not restrict deletion of the annotation or changes to other annotation properties, such as position and size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


ModifiedDate Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : ModifiedDate Property
Gets or sets the annotation modified date.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ModifiedDate As Date
'Usage

Dim instance As PdfAnnotation
Dim value As Date

instance.ModifiedDate = value

value = instance.ModifiedDate
public DateTime ModifiedDate {get; set;}
public:
property DateTime ModifiedDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time when the annotation was most recently modified.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


MouseDown Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : MouseDown Property
Gets or sets the mouse down action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MouseDown As PdfAction
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAction

instance.MouseDown = value

value = instance.MouseDown
public PdfAction MouseDown {get; set;}
public:
property PdfAction^ MouseDown {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the mouse button is pressed inside the annotation's active area.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


MouseEnter Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : MouseEnter Property
Gets or sets the mouse enter action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MouseEnter As PdfAction
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAction

instance.MouseEnter = value

value = instance.MouseEnter
public PdfAction MouseEnter {get; set;}
public:
property PdfAction^ MouseEnter {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the cursor enters the annotation's active area.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


MouseLeave Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : MouseLeave Property
Gets or sets the mouse leave action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MouseLeave As PdfAction
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAction

instance.MouseLeave = value

value = instance.MouseLeave
public PdfAction MouseLeave {get; set;}
public:
property PdfAction^ MouseLeave {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the cursor exits the annotation's active area.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


MouseUp Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : MouseUp Property
Gets or sets the mouse up action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MouseUp As PdfAction
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAction

instance.MouseUp = value

value = instance.MouseUp
public PdfAction MouseUp {get; set;}
public:
property PdfAction^ MouseUp {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the mouse button is released inside the annotation's active area.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


NormalAppearance Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : NormalAppearance Property
Gets or sets the annotation normal appearance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property NormalAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAnnotationAppearance

instance.NormalAppearance = value

value = instance.NormalAppearance
public virtual PdfAnnotationAppearance NormalAppearance {get; set;}
public:
virtual property PdfAnnotationAppearance^ NormalAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

A PdfAnnotationAppearance specifying how the annotation is presented visually on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


NoRotate Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : NoRotate Property
Gets or sets a value indicating whether the annotation should be rotated when the page is rotated.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NoRotate As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.NoRotate = value

value = instance.NoRotate
public bool NoRotate {get; set;}
public:
property bool NoRotate {
   bool get();
   void set (    bool value);
}

Property Value

If true, do not rotate the annotation's appearance to match the rotation of the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


NoView Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : NoView Property
Gets or sets a value indicating whether the annotation should be displayed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NoView As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.NoView = value

value = instance.NoView
public bool NoView {get; set;}
public:
property bool NoView {
   bool get();
   void set (    bool value);
}

Property Value

If true, do not display the annotation on the screen or allow it to interact with the user. The annotation may be printed (depending on the Print proeprty), but should be considered hidden for the purposes of onscreen display and user interaction.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


NoZoom Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : NoZoom Property
Gets or sets a value indicating whether the annotation should be scaled to current page zoom.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NoZoom As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.NoZoom = value

value = instance.NoZoom
public bool NoZoom {get; set;}
public:
property bool NoZoom {
   bool get();
   void set (    bool value);
}

Property Value

If true, do not scale the annotation's appearance to match the zoom of the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


Page Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Page Property
Gets the annotation page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PdfPage
'Usage

Dim instance As PdfAnnotation
Dim value As PdfPage

value = instance.Page
public PdfPage Page {get;}
public:
property PdfPage^ Page {
   PdfPage^ get();
}

Property Value

A Xfinium.Pdf.PdfPage that represents the page contianing the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


PageClose Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : PageClose Property
Gets or sets the page close action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageClose As PdfAction
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAction

instance.PageClose = value

value = instance.PageClose
public PdfAction PageClose {get; set;}
public:
property PdfAction^ PageClose {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the page containing the annotation is closed (for example, when the user navigates to the next or previous page, or follows a link annotation or outline item).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


PageInvisible Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : PageInvisible Property
Gets or sets the page invisible action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageInvisible As PdfAction
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAction

instance.PageInvisible = value

value = instance.PageInvisible
public PdfAction PageInvisible {get; set;}
public:
property PdfAction^ PageInvisible {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the page containing the annotation is no longer visible in the viewer application's user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


PageOpen Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : PageOpen Property
Gets or sets the page open action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageOpen As PdfAction
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAction

instance.PageOpen = value

value = instance.PageOpen
public PdfAction PageOpen {get; set;}
public:
property PdfAction^ PageOpen {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the page containing the annotation is opened (for example, when the user navigates to it from the next or previous page or by means of a link annotation or outline item).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


PageVisible Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : PageVisible Property
Gets or sets the page visible action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageVisible As PdfAction
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAction

instance.PageVisible = value

value = instance.PageVisible
public PdfAction PageVisible {get; set;}
public:
property PdfAction^ PageVisible {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the page containing the annotation becomes visible in the viewer application's user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


Print Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Print Property
Gets or sets a value indicating whether the annotation should be printed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Print As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.Print = value

value = instance.Print
public bool Print {get; set;}
public:
property bool Print {
   bool get();
   void set (    bool value);
}

Property Value

If true, print the annotation when the page is printed. If clear, never print the annotation, regardless of whether it is displayed on the screen.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


ReadOnly Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : ReadOnly Property
Gets or sets a value indicating whether the annotation is read only.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ReadOnly As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
public bool ReadOnly {get; set;}
public:
property bool ReadOnly {
   bool get();
   void set (    bool value);
}

Property Value

If true, do not allow the annotation to interact with the user.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


Rotation Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Rotation As Integer
'Usage

Dim instance As PdfAnnotation
Dim value As Integer

instance.Rotation = value

value = instance.Rotation
public virtual int Rotation {get; set;}
public:
virtual property int Rotation {
   int get();
   void set (    int value);
}

Property Value

The annotation rotation angle in degrees.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value being set is not one of the accepted values.
Remarks
The accepted values for this property are 0, 90, 180 and 270 degrees.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


ToggleNoView Property

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : ToggleNoView Property
Gets or sets a value indicating whether the interpretation of NoView property should be reversed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ToggleNoView As Boolean
'Usage

Dim instance As PdfAnnotation
Dim value As Boolean

instance.ToggleNoView = value

value = instance.ToggleNoView
public bool ToggleNoView {get; set;}
public:
property bool ToggleNoView {
   bool get();
   void set (    bool value);
}

Property Value

If true, invert the interpretation of the NoView property for certain events.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


Type Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : Type Property
Gets the type of the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PdfAnnotationType
'Usage

Dim instance As PdfAnnotation
Dim value As PdfAnnotationType

value = instance.Type
public PdfAnnotationType Type {get;}
public:
property PdfAnnotationType Type {
   PdfAnnotationType get();
}

Property Value

A PdfAnnotationType that represents the annotation type.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


VisualRectangle Property (PdfAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfAnnotation Class : VisualRectangle Property
Gets or sets the visual rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property VisualRectangle As PdfVisualRectangle
'Usage

Dim instance As PdfAnnotation
Dim value As PdfVisualRectangle

instance.VisualRectangle = value

value = instance.VisualRectangle
public virtual PdfVisualRectangle VisualRectangle {get; set;}
public:
virtual property PdfVisualRectangle^ VisualRectangle {
   PdfVisualRectangle^ get();
   void set (    PdfVisualRectangle^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfVisualRectangle that represents the position and size of the annotation.
Remarks
The visual rectangle is relative to the top left corner of the page and can be set only after the annotation has been added to the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotation Class
PdfAnnotation Members


%%PageItemTitle%%

PdfAnnotationAppearance Class
Members

Xfinium.Pdf.Annotations Namespace : PdfAnnotationAppearance Class
Defines how an annotation is presented visually on the page.
Object Model
PdfAnnotationAppearance ClassPdfCosDictionary ClassPdfGraphics ClassPdfMatrix ClassPdfMeasure ClassPdfPointData ClassPdfGroupXObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAnnotationAppearance
   Inherits Xfinium.Pdf.Graphics.PdfFormXObject
'Usage

Dim instance As PdfAnnotationAppearance
public class PdfAnnotationAppearance : Xfinium.Pdf.Graphics.PdfFormXObject
public ref class PdfAnnotationAppearance : public Xfinium.Pdf.Graphics.PdfFormXObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Annotations.PdfAnnotationAppearance

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotationAppearance Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfAnnotationAppearance Class Members
Properties

Xfinium.Pdf.Annotations Namespace : PdfAnnotationAppearance Class

The following tables list the members exposed by PdfAnnotationAppearance.

Public Constructors
 | Name | Description
Public Constructor | PdfAnnotationAppearance Constructor | Initializes a new PdfAnnotationAppearance object.
Top
Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Graphics | Gets the form XObject graphics. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Height | Gets the form XObject height. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Matrix | Gets or sets the form XObject matrix. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Width | Gets the form XObject width. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Top
See Also

Reference

PdfAnnotationAppearance Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfAnnotationAppearance Constructor

Xfinium.Pdf.Annotations Namespace > PdfAnnotationAppearance Class : PdfAnnotationAppearance Constructor
The width of the annotation appearance.
The height of the annotation appearance.
Initializes a new PdfAnnotationAppearance object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New PdfAnnotationAppearance(width, height)
public PdfAnnotationAppearance(
   double width,
   double height
)
public:
PdfAnnotationAppearance(
   double width,
   double height
)

Parameters

width
The width of the annotation appearance.
height
The height of the annotation appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotationAppearance Class
PdfAnnotationAppearance Members


%%PageItemTitle%%

PdfAnnotationCollection Class
Members

Xfinium.Pdf.Annotations Namespace : PdfAnnotationCollection Class
Defines a collection of PDF annotations.
Object Model
PdfAnnotationCollection ClassPdfAnnotation Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAnnotationCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfAnnotation)
'Usage

Dim instance As PdfAnnotationCollection
public class PdfAnnotationCollection : System.Collections.ObjectModel.Collection<PdfAnnotation>
public ref class PdfAnnotationCollection : public System.Collections.ObjectModel.Collection<PdfAnnotation>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Annotations.PdfAnnotationCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotationCollection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfAnnotationCollection Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfAnnotationCollection Class

The following tables list the members exposed by PdfAnnotationCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | MoveAnnotation | Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Top
See Also

Reference

PdfAnnotationCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PdfAnnotationCollection Class Methods

Xfinium.Pdf.Annotations Namespace : PdfAnnotationCollection Class

For a list of all members of this type, see PdfAnnotationCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | MoveAnnotation | Moves the item up or down to the beginning or end of the collection.
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Top
See Also

Reference

PdfAnnotationCollection Class
Xfinium.Pdf.Annotations Namespace


MoveAnnotation Method

Xfinium.Pdf.Annotations Namespace > PdfAnnotationCollection Class : MoveAnnotation Method
Item to move.
Number of positions to move.
Moves the item up or down to the beginning or end of the collection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function MoveAnnotation( _
   ByVal annotation As PdfAnnotation, _
   ByVal step As Integer _
) As Boolean
'Usage

Dim instance As PdfAnnotationCollection
Dim annotation As PdfAnnotation
Dim step As Integer
Dim value As Boolean

value = instance.MoveAnnotation(annotation, step)
public bool MoveAnnotation(
   PdfAnnotation annotation,
   int step
)
public:
bool MoveAnnotation(
   PdfAnnotation^ annotation,
   int step
)

Parameters

annotation
Item to move.
step
Number of positions to move.

Return Value

True if the item has been moved.
Remarks
It the new position is outside the collection, the item is not moved.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotationCollection Class
PdfAnnotationCollection Members


%%PageItemTitle%%

PdfCircleAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfCircleAnnotation Class
Defines a PDF circle annotation.
Object Model
PdfCircleAnnotation ClassPdfColor ClassPdfCosDictionary ClassPdfAnnotation ClassPdfColor ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCircleAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfCircleAnnotation
public class PdfCircleAnnotation : PdfMarkupAnnotation
public ref class PdfCircleAnnotation : public PdfMarkupAnnotation
Remarks
A circle annotation displays an ellipse on the page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfCircleAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCircleAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfCircleAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfCircleAnnotation Class

The following tables list the members exposed by PdfCircleAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfCircleAnnotation Constructor | Initializes a new PdfCircleAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BorderColor | Gets or sets the annotation border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfCircleAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfCircleAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfCircleAnnotation Class : PdfCircleAnnotation Constructor
Initializes a new PdfCircleAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCircleAnnotation()
public PdfCircleAnnotation()
public:
PdfCircleAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCircleAnnotation Class
PdfCircleAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfCircleAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfCircleAnnotation Class

For a list of all members of this type, see PdfCircleAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BorderColor | Gets or sets the annotation border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfCircleAnnotation Class
Xfinium.Pdf.Annotations Namespace


BorderColor Property (PdfCircleAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfCircleAnnotation Class : BorderColor Property
Gets or sets the annotation border color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderColor As PdfColor
'Usage

Dim instance As PdfCircleAnnotation
Dim value As PdfColor

instance.BorderColor = value

value = instance.BorderColor
public PdfColor BorderColor {get; set;}
public:
property PdfColor^ BorderColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the border color with which to stroke the annotation's ellipse.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCircleAnnotation Class
PdfCircleAnnotation Members


BorderWidth Property (PdfCircleAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfCircleAnnotation Class : BorderWidth Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PdfCircleAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the circle outline drawn in the annotation.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCircleAnnotation Class
PdfCircleAnnotation Members


InteriorColor Property (PdfCircleAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfCircleAnnotation Class : InteriorColor Property
Gets or sets the annotation interior color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InteriorColor As PdfColor
'Usage

Dim instance As PdfCircleAnnotation
Dim value As PdfColor

instance.InteriorColor = value

value = instance.InteriorColor
public PdfColor InteriorColor {get; set;}
public:
property PdfColor^ InteriorColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the interior color with which to fill the annotation's ellipse.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCircleAnnotation Class
PdfCircleAnnotation Members


%%PageItemTitle%%

PdfFileAttachmentAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfFileAttachmentAnnotation Class
Defines a PDF file attachment annotation.
Object Model
PdfFileAttachmentAnnotation ClassPdfCosDictionary ClassPdfAnnotation ClassPdfColor ClassPdfPoint ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfColor ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFileAttachmentAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfFileAttachmentAnnotation
public class PdfFileAttachmentAnnotation : PdfMarkupAnnotation
public ref class PdfFileAttachmentAnnotation : public PdfMarkupAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfFileAttachmentAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfFileAttachmentAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfFileAttachmentAnnotation Class

The following tables list the members exposed by PdfFileAttachmentAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfFileAttachmentAnnotation Constructor | Initializes a new PdfFileAttachmentAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Description | Gets or sets the file description.
Public Property | FileName | Gets or sets the name of the file attachment.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | IconName | Gets or sets the file attachment annotation icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Location | Gets or sets the annotation location on the page.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Overridden. Gets or sets the annotation normal appearance.
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | OutlineColor | Gets or sets the annotation outline color.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Payload | Gets or sets the content of the file attachment.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Size | Gets the file attachment size.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfFileAttachmentAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfFileAttachmentAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : PdfFileAttachmentAnnotation Constructor
Initializes a new PdfFileAttachmentAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFileAttachmentAnnotation()
public PdfFileAttachmentAnnotation()
public:
PdfFileAttachmentAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfFileAttachmentAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfFileAttachmentAnnotation Class

For a list of all members of this type, see PdfFileAttachmentAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Description | Gets or sets the file description.
Public Property | FileName | Gets or sets the name of the file attachment.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | IconName | Gets or sets the file attachment annotation icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Location | Gets or sets the annotation location on the page.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Overridden. Gets or sets the annotation normal appearance.
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | OutlineColor | Gets or sets the annotation outline color.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Payload | Gets or sets the content of the file attachment.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Size | Gets the file attachment size.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
See Also

Reference

PdfFileAttachmentAnnotation Class
Xfinium.Pdf.Annotations Namespace


Description Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : Description Property
Gets or sets the file description.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

The description of the file attachment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


FileName Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : FileName Property
Gets or sets the name of the file attachment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The file name associated with the content stored in Payload property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


IconName Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : IconName Property
Gets or sets the file attachment annotation icon name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the file attachment annotation icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
The icon name defines the annotation's visual appearance. The library supports a predefined set of names defined in the PdfFileAttachmentAnnotationName class for which standard appearance is created. When a custom name is used, a custom appearance must also be provided.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


InteriorColor Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : InteriorColor Property
Gets or sets the annotation interior color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InteriorColor As PdfColor
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As PdfColor

instance.InteriorColor = value

value = instance.InteriorColor
public PdfColor InteriorColor {get; set;}
public:
property PdfColor^ InteriorColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the interior color with which to fill the annotation's icon interior.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


Location Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : Location Property
Gets or sets the annotation location on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Location As PdfPoint
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As PdfPoint

instance.Location = value

value = instance.Location
public PdfPoint Location {get; set;}
public:
property PdfPoint^ Location {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The position of annotation's top left corner on the parent page.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property is set to null.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


NormalAppearance Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : NormalAppearance Property
Gets or sets the annotation normal appearance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property NormalAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As PdfAnnotationAppearance

instance.NormalAppearance = value

value = instance.NormalAppearance
public override PdfAnnotationAppearance NormalAppearance {get; set;}
public:
property PdfAnnotationAppearance^ NormalAppearance {
   PdfAnnotationAppearance^ get() override;
   void set (    PdfAnnotationAppearance^ value) override;
}

Property Value

A PdfAnnotationAppearance specifying how the annotation is presented visually on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


OutlineColor Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : OutlineColor Property
Gets or sets the annotation outline color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutlineColor As PdfColor
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As PdfColor

instance.OutlineColor = value

value = instance.OutlineColor
public PdfColor OutlineColor {get; set;}
public:
property PdfColor^ OutlineColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the outline color with which to stroke the annotation's icon outlines.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


Payload Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : Payload Property
Gets or sets the content of the file attachment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Payload As Byte()
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value() As Byte

instance.Payload = value

value = instance.Payload
public byte[] Payload {get; set;}
public:
property array<byte>^ Payload {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The content of the file attachment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


Size Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : Size Property
Gets the file attachment size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Size As Integer
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As Integer

value = instance.Size
public int Size {get;}
public:
property int Size {
   int get();
}

Property Value

The size of the file attachment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


VisualRectangle Property (PdfFileAttachmentAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : VisualRectangle Property
Gets or sets the visual rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property VisualRectangle As PdfVisualRectangle
'Usage

Dim instance As PdfFileAttachmentAnnotation
Dim value As PdfVisualRectangle

instance.VisualRectangle = value

value = instance.VisualRectangle
public override PdfVisualRectangle VisualRectangle {get; set;}
public:
property PdfVisualRectangle^ VisualRectangle {
   PdfVisualRectangle^ get() override;
   void set (    PdfVisualRectangle^ value) override;
}

Property Value

A Xfinium.Pdf.Graphics.PdfVisualRectangle that represents the position and size of the annotation.
Remarks
The visual rectangle is relative to the top left corner of the page and can be set only after the annotation has been added to the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


%%PageItemTitle%%

PdfFileAttachmentAnnotationName Class
Members

Xfinium.Pdf.Annotations Namespace : PdfFileAttachmentAnnotationName Class
Defines the standard names for a file attachment icons.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFileAttachmentAnnotationName
'Usage

Dim instance As PdfFileAttachmentAnnotationName
public class PdfFileAttachmentAnnotationName
public ref class PdfFileAttachmentAnnotationName
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfFileAttachmentAnnotationName

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotationName Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfFileAttachmentAnnotationName Class Members
Fields

Xfinium.Pdf.Annotations Namespace : PdfFileAttachmentAnnotationName Class

The following tables list the members exposed by PdfFileAttachmentAnnotationName.

Public Fields
 | Name | Description
Public Field | Graph | This name creates a Graph icon for the annotation.
Public Field | Paperclip | This name creates a Paperclip icon for the annotation.
Public Field | PushPin | This name creates a PushPin icon for the annotation.
Public Field | Tag | This name creates a Tag icon for the annotation.
Top
See Also

Reference

PdfFileAttachmentAnnotationName Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Fields$$

PdfFileAttachmentAnnotationName Class Fields

Xfinium.Pdf.Annotations Namespace : PdfFileAttachmentAnnotationName Class

For a list of all members of this type, see PdfFileAttachmentAnnotationName members.

Public Fields
 | Name | Description
Public Field | Graph | This name creates a Graph icon for the annotation.
Public Field | Paperclip | This name creates a Paperclip icon for the annotation.
Public Field | PushPin | This name creates a PushPin icon for the annotation.
Public Field | Tag | This name creates a Tag icon for the annotation.
Top
See Also

Reference

PdfFileAttachmentAnnotationName Class
Xfinium.Pdf.Annotations Namespace


Graph Field

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotationName Class : Graph Field
This name creates a Graph icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Graph As String
'Usage

Dim value As String

value = PdfFileAttachmentAnnotationName.Graph
public const string Graph
public:
const String^ Graph
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotationName Class
PdfFileAttachmentAnnotationName Members


Paperclip Field

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotationName Class : Paperclip Field
This name creates a Paperclip icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Paperclip As String
'Usage

Dim value As String

value = PdfFileAttachmentAnnotationName.Paperclip
public const string Paperclip
public:
const String^ Paperclip
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotationName Class
PdfFileAttachmentAnnotationName Members


PushPin Field (PdfFileAttachmentAnnotationName)

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotationName Class : PushPin Field
This name creates a PushPin icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const PushPin As String
'Usage

Dim value As String

value = PdfFileAttachmentAnnotationName.PushPin
public const string PushPin
public:
const String^ PushPin
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotationName Class
PdfFileAttachmentAnnotationName Members


Tag Field

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotationName Class : Tag Field
This name creates a Tag icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Tag As String
'Usage

Dim value As String

value = PdfFileAttachmentAnnotationName.Tag
public const string Tag
public:
const String^ Tag
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotationName Class
PdfFileAttachmentAnnotationName Members


%%PageItemTitle%%

PdfFreeTextAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfFreeTextAnnotation Class
Defines a PDF free text annotation.
Object Model
PdfFreeTextAnnotation ClassPdfColor ClassPdfCosDictionary ClassPdfFont ClassPdfAnnotation ClassPdfColor ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFreeTextAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfFreeTextAnnotation
public class PdfFreeTextAnnotation : PdfMarkupAnnotation
public ref class PdfFreeTextAnnotation : public PdfMarkupAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfFreeTextAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfFreeTextAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfFreeTextAnnotation Class

The following tables list the members exposed by PdfFreeTextAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfFreeTextAnnotation Constructor | Initializes a new PdfFreeTextAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BorderColor | Gets or sets the annotation border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Font | Gets or sets the annotation font.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | TextColor | Gets or sets the text color.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfFreeTextAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfFreeTextAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfFreeTextAnnotation Class : PdfFreeTextAnnotation Constructor
Initializes a new PdfFreeTextAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFreeTextAnnotation()
public PdfFreeTextAnnotation()
public:
PdfFreeTextAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Class
PdfFreeTextAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfFreeTextAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfFreeTextAnnotation Class

For a list of all members of this type, see PdfFreeTextAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BorderColor | Gets or sets the annotation border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Font | Gets or sets the annotation font.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | TextColor | Gets or sets the text color.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfFreeTextAnnotation Class
Xfinium.Pdf.Annotations Namespace


BorderColor Property (PdfFreeTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFreeTextAnnotation Class : BorderColor Property
Gets or sets the annotation border color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderColor As PdfColor
'Usage

Dim instance As PdfFreeTextAnnotation
Dim value As PdfColor

instance.BorderColor = value

value = instance.BorderColor
public PdfColor BorderColor {get; set;}
public:
property PdfColor^ BorderColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the border color with which to stroke the annotation's ellipse.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Remarks
For free text annotations the border color will always match the text color and viceversa.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Class
PdfFreeTextAnnotation Members


BorderWidth Property (PdfFreeTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFreeTextAnnotation Class : BorderWidth Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PdfFreeTextAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the square outline drawn in the annotation.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Class
PdfFreeTextAnnotation Members


Contents Property (PdfFreeTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFreeTextAnnotation Class : Contents Property
Gets or sets the annotation contents.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Contents As String
'Usage

Dim instance As PdfFreeTextAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
public override string Contents {get; set;}
public:
property String^ Contents {
   String^ get() override;
   void set (    String^ value) override;
}

Property Value

Text to be displayed for the annotation or, if this type of annotation does not display text, an alternate description of the annotation's contents in human-readable form.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Class
PdfFreeTextAnnotation Members


Font Property (PdfFreeTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFreeTextAnnotation Class : Font Property
Gets or sets the annotation font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As PdfFont
'Usage

Dim instance As PdfFreeTextAnnotation
Dim value As PdfFont

instance.Font = value

value = instance.Font
public PdfFont Font {get; set;}
public:
property PdfFont^ Font {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

The font used for displaying the annotation Contents.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Class
PdfFreeTextAnnotation Members


InteriorColor Property (PdfFreeTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFreeTextAnnotation Class : InteriorColor Property
Gets or sets the annotation interior color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InteriorColor As PdfColor
'Usage

Dim instance As PdfFreeTextAnnotation
Dim value As PdfColor

instance.InteriorColor = value

value = instance.InteriorColor
public PdfColor InteriorColor {get; set;}
public:
property PdfColor^ InteriorColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the color to fill the annotation interior.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Class
PdfFreeTextAnnotation Members


TextColor Property (PdfFreeTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfFreeTextAnnotation Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextColor As PdfColor
'Usage

Dim instance As PdfFreeTextAnnotation
Dim value As PdfColor

instance.TextColor = value

value = instance.TextColor
public PdfColor TextColor {get; set;}
public:
property PdfColor^ TextColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the color used to display the annotation content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Class
PdfFreeTextAnnotation Members


%%PageItemTitle%%

PdfInkAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfInkAnnotation Class
Defines a PDF ink annotation.
Object Model
PdfInkAnnotation ClassPdfCosDictionary ClassPdfColor ClassPdfAnnotation ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfPoint ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfInkAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfInkAnnotation
public class PdfInkAnnotation : PdfMarkupAnnotation
public ref class PdfInkAnnotation : public PdfMarkupAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfInkAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInkAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfInkAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfInkAnnotation Class

The following tables list the members exposed by PdfInkAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfInkAnnotation Constructor | Initializes a new PdfInkAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InkColor | Gets or sets the annotation ink color.
Public Property | InkWidth | Gets or sets the ink width.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Points | Gets or sets the annotation points.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfInkAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfInkAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfInkAnnotation Class : PdfInkAnnotation Constructor
Initializes a new PdfInkAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfInkAnnotation()
public PdfInkAnnotation()
public:
PdfInkAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInkAnnotation Class
PdfInkAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfInkAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfInkAnnotation Class

For a list of all members of this type, see PdfInkAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InkColor | Gets or sets the annotation ink color.
Public Property | InkWidth | Gets or sets the ink width.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Points | Gets or sets the annotation points.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
See Also

Reference

PdfInkAnnotation Class
Xfinium.Pdf.Annotations Namespace


InkColor Property

Xfinium.Pdf.Annotations Namespace > PdfInkAnnotation Class : InkColor Property
Gets or sets the annotation ink color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InkColor As PdfColor
'Usage

Dim instance As PdfInkAnnotation
Dim value As PdfColor

instance.InkColor = value

value = instance.InkColor
public PdfColor InkColor {get; set;}
public:
property PdfColor^ InkColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the ink color with which to stroke the annotation paths.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInkAnnotation Class
PdfInkAnnotation Members


InkWidth Property

Xfinium.Pdf.Annotations Namespace > PdfInkAnnotation Class : InkWidth Property
Gets or sets the ink width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InkWidth As Double
'Usage

Dim instance As PdfInkAnnotation
Dim value As Double

instance.InkWidth = value

value = instance.InkWidth
public double InkWidth {get; set;}
public:
property double InkWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the lines drawn in the annotation.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInkAnnotation Class
PdfInkAnnotation Members


Points Property (PdfInkAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfInkAnnotation Class : Points Property
Gets or sets the annotation points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Points As PdfPoint()
'Usage

Dim instance As PdfInkAnnotation
Dim value() As PdfPoint

instance.Points = value

value = instance.Points
public PdfPoint[] Points {get; set;}
public:
property array<PdfPoint^>^ Points {
   array<PdfPoint^>^ get();
   void set (    array<PdfPoint^>^ value);
}

Property Value

An array of arrays, each array defining a path.
Exceptions
Exception | Description
System.ArgumentException | Thrown when this property is set and the annotation does not belong to a page.
Remarks
The points in this array are given in page visual coordinates, relative to top left corner of the visual page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInkAnnotation Class
PdfInkAnnotation Members


VisualRectangle Property (PdfInkAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfInkAnnotation Class : VisualRectangle Property
Gets or sets the visual rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property VisualRectangle As PdfVisualRectangle
'Usage

Dim instance As PdfInkAnnotation
Dim value As PdfVisualRectangle

instance.VisualRectangle = value

value = instance.VisualRectangle
public override PdfVisualRectangle VisualRectangle {get; set;}
public:
property PdfVisualRectangle^ VisualRectangle {
   PdfVisualRectangle^ get() override;
   void set (    PdfVisualRectangle^ value) override;
}

Property Value

A Xfinium.Pdf.Graphics.PdfVisualRectangle that represents the position and size of the annotation.
Remarks
The visual rectangle is relative to the top left corner of the page and can be set only after the annotation has been added to the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInkAnnotation Class
PdfInkAnnotation Members


%%PageItemTitle%%

PdfLineAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfLineAnnotation Class
Defines a PDF line annotation.
Object Model
PdfLineAnnotation ClassPdfCosDictionary ClassPdfPoint ClassPdfAnnotation ClassPdfColor ClassPdfColor ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfPoint ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfLineAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfLineAnnotation
public class PdfLineAnnotation : PdfMarkupAnnotation
public ref class PdfLineAnnotation : public PdfMarkupAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfLineAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfLineAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfLineAnnotation Class

The following tables list the members exposed by PdfLineAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfLineAnnotation Constructor | Initializes a new PdfLineAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | EndLineSymbol | Gets or sets the symbol used for the end of the line.
Public Property | EndPoint | Gets or sets the end point.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LineColor | Gets or sets the annotation line color.
Public Property | LineWidth | Gets or sets the line width.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | StartLineSymbol | Gets or sets the symbol used for the start of the line.
Public Property | StartPoint | Gets or sets the start point.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfLineAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfLineAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : PdfLineAnnotation Constructor
Initializes a new PdfLineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfLineAnnotation()
public PdfLineAnnotation()
public:
PdfLineAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfLineAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfLineAnnotation Class

For a list of all members of this type, see PdfLineAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | EndLineSymbol | Gets or sets the symbol used for the end of the line.
Public Property | EndPoint | Gets or sets the end point.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LineColor | Gets or sets the annotation line color.
Public Property | LineWidth | Gets or sets the line width.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | StartLineSymbol | Gets or sets the symbol used for the start of the line.
Public Property | StartPoint | Gets or sets the start point.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
See Also

Reference

PdfLineAnnotation Class
Xfinium.Pdf.Annotations Namespace


EndLineSymbol Property

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : EndLineSymbol Property
Gets or sets the symbol used for the end of the line.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndLineSymbol As PdfLineEndSymbol
'Usage

Dim instance As PdfLineAnnotation
Dim value As PdfLineEndSymbol

instance.EndLineSymbol = value

value = instance.EndLineSymbol
public PdfLineEndSymbol EndLineSymbol {get; set;}
public:
property PdfLineEndSymbol EndLineSymbol {
   PdfLineEndSymbol get();
   void set (    PdfLineEndSymbol value);
}

Property Value

A PdfLineEndSymbol that represents the end of the line.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


EndPoint Property (PdfLineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : EndPoint Property
Gets or sets the end point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndPoint As PdfPoint
'Usage

Dim instance As PdfLineAnnotation
Dim value As PdfPoint

instance.EndPoint = value

value = instance.EndPoint
public PdfPoint EndPoint {get; set;}
public:
property PdfPoint^ EndPoint {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The line end point, in visual coordinates.
Remarks
Because the end point uses page visual coordinates, the annotation must be added to the page before setting the end point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


InteriorColor Property (PdfLineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : InteriorColor Property
Gets or sets the annotation interior color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InteriorColor As PdfColor
'Usage

Dim instance As PdfLineAnnotation
Dim value As PdfColor

instance.InteriorColor = value

value = instance.InteriorColor
public PdfColor InteriorColor {get; set;}
public:
property PdfColor^ InteriorColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the interior color with which to fill the annotation's interior.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


LineColor Property (PdfLineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : LineColor Property
Gets or sets the annotation line color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineColor As PdfColor
'Usage

Dim instance As PdfLineAnnotation
Dim value As PdfColor

instance.LineColor = value

value = instance.LineColor
public PdfColor LineColor {get; set;}
public:
property PdfColor^ LineColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the line color with which to stroke the annotation's line.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


LineWidth Property (PdfLineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : LineWidth Property
Gets or sets the line width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineWidth As Double
'Usage

Dim instance As PdfLineAnnotation
Dim value As Double

instance.LineWidth = value

value = instance.LineWidth
public double LineWidth {get; set;}
public:
property double LineWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the line.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


StartLineSymbol Property

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : StartLineSymbol Property
Gets or sets the symbol used for the start of the line.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartLineSymbol As PdfLineEndSymbol
'Usage

Dim instance As PdfLineAnnotation
Dim value As PdfLineEndSymbol

instance.StartLineSymbol = value

value = instance.StartLineSymbol
public PdfLineEndSymbol StartLineSymbol {get; set;}
public:
property PdfLineEndSymbol StartLineSymbol {
   PdfLineEndSymbol get();
   void set (    PdfLineEndSymbol value);
}

Property Value

A PdfLineEndSymbol that represents the start of the line.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


StartPoint Property (PdfLineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : StartPoint Property
Gets or sets the start point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartPoint As PdfPoint
'Usage

Dim instance As PdfLineAnnotation
Dim value As PdfPoint

instance.StartPoint = value

value = instance.StartPoint
public PdfPoint StartPoint {get; set;}
public:
property PdfPoint^ StartPoint {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The line start point, in visual coordinates.
Remarks
Because the start point uses page visual coordinates, the annotation must be added to the page before setting the start point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


VisualRectangle Property (PdfLineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : VisualRectangle Property
Gets or sets the visual rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property VisualRectangle As PdfVisualRectangle
'Usage

Dim instance As PdfLineAnnotation
Dim value As PdfVisualRectangle

instance.VisualRectangle = value

value = instance.VisualRectangle
public override PdfVisualRectangle VisualRectangle {get; set;}
public:
property PdfVisualRectangle^ VisualRectangle {
   PdfVisualRectangle^ get() override;
   void set (    PdfVisualRectangle^ value) override;
}

Property Value

A Xfinium.Pdf.Graphics.PdfVisualRectangle that represents the position and size of the annotation.
Remarks
The visual rectangle is relative to the top left corner of the page and can be set only after the annotation has been added to the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


%%PageItemTitle%%

PdfLinkAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfLinkAnnotation Class
Defines a PDF link annotation.
Object Model
PdfLinkAnnotation ClassPdfAction ClassPdfColor ClassPdfCosDictionary ClassPdfDestination ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfLinkAnnotation
   Inherits PdfAnnotation
'Usage

Dim instance As PdfLinkAnnotation
public class PdfLinkAnnotation : PdfAnnotation
public ref class PdfLinkAnnotation : public PdfAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfLinkAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLinkAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfLinkAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfLinkAnnotation Class

The following tables list the members exposed by PdfLinkAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfLinkAnnotation Constructor | Initializes a new PdfLinkAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the link action.
Public Property | BorderColor | Gets or sets the link border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Destination | Gets or sets the link destination.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | HighlightStyle | Gets or sets the link highlighting style.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfLinkAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfLinkAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfLinkAnnotation Class : PdfLinkAnnotation Constructor
Initializes a new PdfLinkAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfLinkAnnotation()
public PdfLinkAnnotation()
public:
PdfLinkAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLinkAnnotation Class
PdfLinkAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfLinkAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfLinkAnnotation Class

For a list of all members of this type, see PdfLinkAnnotation members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the link action.
Public Property | BorderColor | Gets or sets the link border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Destination | Gets or sets the link destination.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | HighlightStyle | Gets or sets the link highlighting style.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfLinkAnnotation Class
Xfinium.Pdf.Annotations Namespace


Action Property (PdfLinkAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLinkAnnotation Class : Action Property
Gets or sets the link action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Action As PdfAction
'Usage

Dim instance As PdfLinkAnnotation
Dim value As PdfAction

instance.Action = value

value = instance.Action
public PdfAction Action {get; set;}
public:
property PdfAction^ Action {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action to be performed when the link annotation is activated.
Remarks
Destination and Action are mutually exclusive, when one is set, the other is reset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLinkAnnotation Class
PdfLinkAnnotation Members


BorderColor Property (PdfLinkAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLinkAnnotation Class : BorderColor Property
Gets or sets the link border color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderColor As PdfColor
'Usage

Dim instance As PdfLinkAnnotation
Dim value As PdfColor

instance.BorderColor = value

value = instance.BorderColor
public PdfColor BorderColor {get; set;}
public:
property PdfColor^ BorderColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the border color with which to stroke the annotation's border.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLinkAnnotation Class
PdfLinkAnnotation Members


BorderWidth Property (PdfLinkAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLinkAnnotation Class : BorderWidth Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PdfLinkAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the square outline drawn in the annotation.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLinkAnnotation Class
PdfLinkAnnotation Members


Destination Property (PdfLinkAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfLinkAnnotation Class : Destination Property
Gets or sets the link destination.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Destination As PdfDestination
'Usage

Dim instance As PdfLinkAnnotation
Dim value As PdfDestination

instance.Destination = value

value = instance.Destination
public PdfDestination Destination {get; set;}
public:
property PdfDestination^ Destination {
   PdfDestination^ get();
   void set (    PdfDestination^ value);
}

Property Value

A destination that specifies what page should be displayed when the link is clicked.
Remarks
Destination and Action are mutually exclusive, when one is set, the other is reset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLinkAnnotation Class
PdfLinkAnnotation Members


HighlightStyle Property

Xfinium.Pdf.Annotations Namespace > PdfLinkAnnotation Class : HighlightStyle Property
Gets or sets the link highlighting style.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HighlightStyle As PdfLinkAnnotationHighlightStyle
'Usage

Dim instance As PdfLinkAnnotation
Dim value As PdfLinkAnnotationHighlightStyle

instance.HighlightStyle = value

value = instance.HighlightStyle
public PdfLinkAnnotationHighlightStyle HighlightStyle {get; set;}
public:
property PdfLinkAnnotationHighlightStyle HighlightStyle {
   PdfLinkAnnotationHighlightStyle get();
   void set (    PdfLinkAnnotationHighlightStyle value);
}

Property Value

A PdfLinkAnnotationHighlightStyle that specifies how the link is highlighted when it is activated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLinkAnnotation Class
PdfLinkAnnotation Members


%%PageItemTitle%%

PdfMarkupAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfMarkupAnnotation Class
The base class for PDF markup annotations.
Object Model
PdfMarkupAnnotation ClassPdfCosDictionary ClassPdfAnnotation ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfMarkupAnnotation
   Inherits PdfAnnotation
'Usage

Dim instance As PdfMarkupAnnotation
public class PdfMarkupAnnotation : PdfAnnotation
public ref class PdfMarkupAnnotation : public PdfAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfCircleAnnotation
Xfinium.Pdf.Annotations.PdfFileAttachmentAnnotation
Xfinium.Pdf.Annotations.PdfFreeTextAnnotation
Xfinium.Pdf.Annotations.PdfInkAnnotation
Xfinium.Pdf.Annotations.PdfLineAnnotation
Xfinium.Pdf.Annotations.PdfPolylineAnnotation
Xfinium.Pdf.Annotations.PdfRedactionAnnotation
Xfinium.Pdf.Annotations.PdfRubberStampAnnotation
Xfinium.Pdf.Annotations.PdfSoundAnnotation
Xfinium.Pdf.Annotations.PdfSquareAnnotation
Xfinium.Pdf.Annotations.PdfTextAnnotation
Xfinium.Pdf.Annotations.PdfTextMarkupAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMarkupAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfMarkupAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfMarkupAnnotation Class

The following tables list the members exposed by PdfMarkupAnnotation.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfMarkupAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PdfMarkupAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfMarkupAnnotation Class

For a list of all members of this type, see PdfMarkupAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfMarkupAnnotation Class
Xfinium.Pdf.Annotations Namespace


Author Property (PdfMarkupAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfMarkupAnnotation Class : Author Property
Gets or sets the annotation author.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Author As String
'Usage

Dim instance As PdfMarkupAnnotation
Dim value As String

instance.Author = value

value = instance.Author
public string Author {get; set;}
public:
property String^ Author {
   String^ get();
   void set (    String^ value);
}

Property Value

The user who added the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Members


InReplyTo Property

Xfinium.Pdf.Annotations Namespace > PdfMarkupAnnotation Class : InReplyTo Property
Gets or sets the annotation that this annotation is "in reply to".
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InReplyTo As PdfAnnotation
'Usage

Dim instance As PdfMarkupAnnotation
Dim value As PdfAnnotation

instance.InReplyTo = value

value = instance.InReplyTo
public PdfAnnotation InReplyTo {get; set;}
public:
property PdfAnnotation^ InReplyTo {
   PdfAnnotation^ get();
   void set (    PdfAnnotation^ value);
}

Property Value

A reference to the annotation that this annotation is "in reply to."
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Members


Opacity Property (PdfMarkupAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfMarkupAnnotation Class : Opacity Property
Gets or sets the annotation opacity.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Opacity As Double
'Usage

Dim instance As PdfMarkupAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public virtual double Opacity {get; set;}
public:
virtual property double Opacity {
   double get();
   void set (    double value);
}

Property Value

A value in the range [0, 1] that represents the constant opacity value to be used in painting the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Members


Subject Property (PdfMarkupAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfMarkupAnnotation Class : Subject Property
Gets or sets the annotation subject.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Subject As String
'Usage

Dim instance As PdfMarkupAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
public string Subject {get; set;}
public:
property String^ Subject {
   String^ get();
   void set (    String^ value);
}

Property Value

Text representing a short description of the subject being addressed by the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMarkupAnnotation Class
PdfMarkupAnnotation Members


%%PageItemTitle%%

PdfPolygonAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfPolygonAnnotation Class
Defines a PDF polygon annotation.
Object Model
PdfPolygonAnnotation ClassPdfCosDictionary ClassPdfAnnotation ClassPdfColor ClassPdfColor ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfPoint ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPolygonAnnotation
   Inherits PdfPolylineAnnotation
'Usage

Dim instance As PdfPolygonAnnotation
public class PdfPolygonAnnotation : PdfPolylineAnnotation
public ref class PdfPolygonAnnotation : public PdfPolylineAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfPolylineAnnotation
Xfinium.Pdf.Annotations.PdfPolygonAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolygonAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfPolygonAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfPolygonAnnotation Class

The following tables list the members exposed by PdfPolygonAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfPolygonAnnotation Constructor | Initializes a new PdfPolygonAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LineColor | Gets or sets the annotation line color. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Public Property | LineWidth | Gets or sets the line width. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Points | Gets or sets the polyline points. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfPolygonAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfPolygonAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfPolygonAnnotation Class : PdfPolygonAnnotation Constructor
Initializes a new PdfPolygonAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPolygonAnnotation()
public PdfPolygonAnnotation()
public:
PdfPolygonAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolygonAnnotation Class
PdfPolygonAnnotation Members


%%PageItemTitle%%

PdfPolylineAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfPolylineAnnotation Class
Defines a PDF polyline annotation.
Object Model
PdfPolylineAnnotation ClassPdfCosDictionary ClassPdfAnnotation ClassPdfColor ClassPdfColor ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfPoint ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPolylineAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfPolylineAnnotation
public class PdfPolylineAnnotation : PdfMarkupAnnotation
public ref class PdfPolylineAnnotation : public PdfMarkupAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfPolylineAnnotation
Xfinium.Pdf.Annotations.PdfPolygonAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolylineAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfPolylineAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfPolylineAnnotation Class

The following tables list the members exposed by PdfPolylineAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfPolylineAnnotation Constructor | Initializes a new PdfPolylineAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LineColor | Gets or sets the annotation line color.
Public Property | LineWidth | Gets or sets the line width.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Points | Gets or sets the polyline points.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfPolylineAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfPolylineAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfPolylineAnnotation Class : PdfPolylineAnnotation Constructor
Initializes a new PdfPolylineAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPolylineAnnotation()
public PdfPolylineAnnotation()
public:
PdfPolylineAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolylineAnnotation Class
PdfPolylineAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfPolylineAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfPolylineAnnotation Class

For a list of all members of this type, see PdfPolylineAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LineColor | Gets or sets the annotation line color.
Public Property | LineWidth | Gets or sets the line width.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Points | Gets or sets the polyline points.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
See Also

Reference

PdfPolylineAnnotation Class
Xfinium.Pdf.Annotations Namespace


InteriorColor Property (PdfPolylineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfPolylineAnnotation Class : InteriorColor Property
Gets or sets the annotation interior color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InteriorColor As PdfColor
'Usage

Dim instance As PdfPolylineAnnotation
Dim value As PdfColor

instance.InteriorColor = value

value = instance.InteriorColor
public PdfColor InteriorColor {get; set;}
public:
property PdfColor^ InteriorColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the interior color with which to fill the annotation's polyline.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolylineAnnotation Class
PdfPolylineAnnotation Members


LineColor Property (PdfPolylineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfPolylineAnnotation Class : LineColor Property
Gets or sets the annotation line color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineColor As PdfColor
'Usage

Dim instance As PdfPolylineAnnotation
Dim value As PdfColor

instance.LineColor = value

value = instance.LineColor
public PdfColor LineColor {get; set;}
public:
property PdfColor^ LineColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the line color with which to stroke the annotation's polyline.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolylineAnnotation Class
PdfPolylineAnnotation Members


LineWidth Property (PdfPolylineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfPolylineAnnotation Class : LineWidth Property
Gets or sets the line width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineWidth As Double
'Usage

Dim instance As PdfPolylineAnnotation
Dim value As Double

instance.LineWidth = value

value = instance.LineWidth
public double LineWidth {get; set;}
public:
property double LineWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the polyline.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolylineAnnotation Class
PdfPolylineAnnotation Members


Points Property (PdfPolylineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfPolylineAnnotation Class : Points Property
Gets or sets the polyline points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Points As PdfPoint()
'Usage

Dim instance As PdfPolylineAnnotation
Dim value() As PdfPoint

instance.Points = value

value = instance.Points
public PdfPoint[] Points {get; set;}
public:
property array<PdfPoint^>^ Points {
   array<PdfPoint^>^ get();
   void set (    array<PdfPoint^>^ value);
}

Property Value

An array of points that define the polyline.
Exceptions
Exception | Description
System.ArgumentException | Thrown when this property is set and the annotation does not belong to a page.
Remarks
The points in this array are given in page visual coordinates, relative to top left corner of the visual page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolylineAnnotation Class
PdfPolylineAnnotation Members


VisualRectangle Property (PdfPolylineAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfPolylineAnnotation Class : VisualRectangle Property
Gets or sets the visual rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property VisualRectangle As PdfVisualRectangle
'Usage

Dim instance As PdfPolylineAnnotation
Dim value As PdfVisualRectangle

instance.VisualRectangle = value

value = instance.VisualRectangle
public override PdfVisualRectangle VisualRectangle {get; set;}
public:
property PdfVisualRectangle^ VisualRectangle {
   PdfVisualRectangle^ get() override;
   void set (    PdfVisualRectangle^ value) override;
}

Property Value

A Xfinium.Pdf.Graphics.PdfVisualRectangle that represents the position and size of the annotation.
Remarks
The visual rectangle is relative to the top left corner of the page and can be set only after the annotation has been added to the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolylineAnnotation Class
PdfPolylineAnnotation Members


%%PageItemTitle%%

PdfRedactionAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRedactionAnnotation Class
Defines a redaction annotation.
Object Model
PdfRedactionAnnotation ClassPdfColor ClassPdfCosDictionary ClassPdfAnnotation ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfFormXObject ClassPdfRgbColor ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRedactionAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfRedactionAnnotation
public class PdfRedactionAnnotation : PdfMarkupAnnotation
public ref class PdfRedactionAnnotation : public PdfMarkupAnnotation
Remarks
A redaction annotation marks a rectangle on the page that will be redacted.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfRedactionAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRedactionAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRedactionAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfRedactionAnnotation Class

The following tables list the members exposed by PdfRedactionAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfRedactionAnnotation Constructor | Initializes a new PdfRedactionAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BorderColor | Gets or sets the annotation border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | OverlayAppearance | Gets or sets the overlay appearance.
Public Property | OverlayInteriorColor | Gets or sets the interior color of the redaction overlay.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRedactionAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRedactionAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRedactionAnnotation Class : PdfRedactionAnnotation Constructor
Initializes a new PdfRedactionAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRedactionAnnotation()
public PdfRedactionAnnotation()
public:
PdfRedactionAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRedactionAnnotation Class
PdfRedactionAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfRedactionAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRedactionAnnotation Class

For a list of all members of this type, see PdfRedactionAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BorderColor | Gets or sets the annotation border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | OverlayAppearance | Gets or sets the overlay appearance.
Public Property | OverlayInteriorColor | Gets or sets the interior color of the redaction overlay.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRedactionAnnotation Class
Xfinium.Pdf.Annotations Namespace


BorderColor Property (PdfRedactionAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfRedactionAnnotation Class : BorderColor Property
Gets or sets the annotation border color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderColor As PdfColor
'Usage

Dim instance As PdfRedactionAnnotation
Dim value As PdfColor

instance.BorderColor = value

value = instance.BorderColor
public PdfColor BorderColor {get; set;}
public:
property PdfColor^ BorderColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the border color with which to stroke the annotation's rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRedactionAnnotation Class
PdfRedactionAnnotation Members


BorderWidth Property (PdfRedactionAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfRedactionAnnotation Class : BorderWidth Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PdfRedactionAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the rectangle outline drawn in the annotation.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRedactionAnnotation Class
PdfRedactionAnnotation Members


OverlayAppearance Property

Xfinium.Pdf.Annotations Namespace > PdfRedactionAnnotation Class : OverlayAppearance Property
Gets or sets the overlay appearance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OverlayAppearance As PdfFormXObject
'Usage

Dim instance As PdfRedactionAnnotation
Dim value As PdfFormXObject

instance.OverlayAppearance = value

value = instance.OverlayAppearance
public PdfFormXObject OverlayAppearance {get; set;}
public:
property PdfFormXObject^ OverlayAppearance {
   PdfFormXObject^ get();
   void set (    PdfFormXObject^ value);
}

Property Value

A form XObject specifying the overlay appearance for this redaction annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRedactionAnnotation Class
PdfRedactionAnnotation Members


OverlayInteriorColor Property

Xfinium.Pdf.Annotations Namespace > PdfRedactionAnnotation Class : OverlayInteriorColor Property
Gets or sets the interior color of the redaction overlay.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OverlayInteriorColor As PdfRgbColor
'Usage

Dim instance As PdfRedactionAnnotation
Dim value As PdfRgbColor

instance.OverlayInteriorColor = value

value = instance.OverlayInteriorColor
public PdfRgbColor OverlayInteriorColor {get; set;}
public:
property PdfRgbColor^ OverlayInteriorColor {
   PdfRgbColor^ get();
   void set (    PdfRgbColor^ value);
}

Property Value

The interior colour with which to fill the redacted region after the affected content has been removed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRedactionAnnotation Class
PdfRedactionAnnotation Members


%%PageItemTitle%%

PdfRichMediaActivation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRichMediaActivation Class
Defines the conditions for the activation of the rich media annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRichMediaActivation
'Usage

Dim instance As PdfRichMediaActivation
public class PdfRichMediaActivation
public ref class PdfRichMediaActivation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfRichMediaActivation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaActivation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRichMediaActivation Class Members
Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaActivation Class

The following tables list the members exposed by PdfRichMediaActivation.

Public Constructors
 | Name | Description
Public Constructor | PdfRichMediaActivation Constructor | Initializes a new PdfRichMediaActivation object.
Top
Public Properties
 | Name | Description
Public Property | ActivationCondition | Gets or sets the activation condition for the rich media annotation.
Public Property | Configuration | Gets or sets the rich media configuration.
Top
See Also

Reference

PdfRichMediaActivation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaActivation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaActivation Class : PdfRichMediaActivation Constructor
Initializes a new PdfRichMediaActivation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRichMediaActivation()
public PdfRichMediaActivation()
public:
PdfRichMediaActivation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaActivation Class
PdfRichMediaActivation Members


%%PageItemTitle%% $$Properties$$

PdfRichMediaActivation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaActivation Class

For a list of all members of this type, see PdfRichMediaActivation members.

Public Properties
 | Name | Description
Public Property | ActivationCondition | Gets or sets the activation condition for the rich media annotation.
Public Property | Configuration | Gets or sets the rich media configuration.
Top
See Also

Reference

PdfRichMediaActivation Class
Xfinium.Pdf.Annotations Namespace


ActivationCondition Property (PdfRichMediaActivation)

Xfinium.Pdf.Annotations Namespace > PdfRichMediaActivation Class : ActivationCondition Property
Gets or sets the activation condition for the rich media annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ActivationCondition As PdfRichMediaActivationCondition
'Usage

Dim instance As PdfRichMediaActivation
Dim value As PdfRichMediaActivationCondition

instance.ActivationCondition = value

value = instance.ActivationCondition
public PdfRichMediaActivationCondition ActivationCondition {get; set;}
public:
property PdfRichMediaActivationCondition ActivationCondition {
   PdfRichMediaActivationCondition get();
   void set (    PdfRichMediaActivationCondition value);
}

Property Value

The condition that specifies how the rich media annotation is activated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaActivation Class
PdfRichMediaActivation Members


Configuration Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaActivation Class : Configuration Property
Gets or sets the rich media configuration.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Configuration As PdfRichMediaConfiguration
'Usage

Dim instance As PdfRichMediaActivation
Dim value As PdfRichMediaConfiguration

instance.Configuration = value

value = instance.Configuration
public PdfRichMediaConfiguration Configuration {get; set;}
public:
property PdfRichMediaConfiguration^ Configuration {
   PdfRichMediaConfiguration^ get();
   void set (    PdfRichMediaConfiguration^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaActivation Class
PdfRichMediaActivation Members


%%PageItemTitle%%

PdfRichMediaAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAnnotation Class
Defines a PDF rich media annotation. Defines a rich media annotation in a Pdf file.
Object Model
PdfRichMediaAnnotation ClassPdfCosDictionary ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfFormXObject ClassPdfRichMediaContent ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRichMediaAnnotation
   Inherits PdfAnnotation
'Usage

Dim instance As PdfRichMediaAnnotation
public class PdfRichMediaAnnotation : PdfAnnotation
public ref class PdfRichMediaAnnotation : public PdfAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfRichMediaAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRichMediaAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAnnotation Class

The following tables list the members exposed by PdfRichMediaAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfRichMediaAnnotation Constructor | Initializes a new PdfRichMediaAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | ActivationCondition | Gets or sets the activation condition.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | DeactivationCondition | Gets or sets the deactivation condition.
Public Property | FlashFile | Gets or sets the movie file associated with this annotation.
Public Property | FlashPayload | Gets or sets the Flash content.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Placeholder | Gets or sets the placeholder to be displayed on the page when the Flash is not activated.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | RichMediaContent | Gets the rich media content.
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Settings | Gets the rich media settings.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRichMediaAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : PdfRichMediaAnnotation Constructor
Initializes a new PdfRichMediaAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRichMediaAnnotation()
public PdfRichMediaAnnotation()
public:
PdfRichMediaAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfRichMediaAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAnnotation Class

For a list of all members of this type, see PdfRichMediaAnnotation members.

Public Properties
 | Name | Description
Public Property | ActivationCondition | Gets or sets the activation condition.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | DeactivationCondition | Gets or sets the deactivation condition.
Public Property | FlashFile | Gets or sets the movie file associated with this annotation.
Public Property | FlashPayload | Gets or sets the Flash content.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Placeholder | Gets or sets the placeholder to be displayed on the page when the Flash is not activated.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | RichMediaContent | Gets the rich media content.
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Settings | Gets the rich media settings.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRichMediaAnnotation Class
Xfinium.Pdf.Annotations Namespace


ActivationCondition Property (PdfRichMediaAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : ActivationCondition Property
Gets or sets the activation condition.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ActivationCondition As PdfRichMediaActivationCondition
'Usage

Dim instance As PdfRichMediaAnnotation
Dim value As PdfRichMediaActivationCondition

instance.ActivationCondition = value

value = instance.ActivationCondition
public PdfRichMediaActivationCondition ActivationCondition {get; set;}
public:
property PdfRichMediaActivationCondition ActivationCondition {
   PdfRichMediaActivationCondition get();
   void set (    PdfRichMediaActivationCondition value);
}

Property Value

A PdfRichMediaActivationCondition that specifies the circumstances under which the annotation should be activated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


DeactivationCondition Property (PdfRichMediaAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : DeactivationCondition Property
Gets or sets the deactivation condition.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DeactivationCondition As PdfRichMediaDeactivationCondition
'Usage

Dim instance As PdfRichMediaAnnotation
Dim value As PdfRichMediaDeactivationCondition

instance.DeactivationCondition = value

value = instance.DeactivationCondition
public PdfRichMediaDeactivationCondition DeactivationCondition {get; set;}
public:
property PdfRichMediaDeactivationCondition DeactivationCondition {
   PdfRichMediaDeactivationCondition get();
   void set (    PdfRichMediaDeactivationCondition value);
}

Property Value

A PdfRichMediaDeactivationCondition specifying the circumstances under which the annotation should be deactivated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


FlashFile Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : FlashFile Property
Gets or sets the movie file associated with this annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FlashFile As String
'Usage

Dim instance As PdfRichMediaAnnotation
Dim value As String

instance.FlashFile = value

value = instance.FlashFile
public string FlashFile {get; set;}
public:
property String^ FlashFile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the full path to the movie file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


FlashPayload Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : FlashPayload Property
Gets or sets the Flash content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FlashPayload As Byte()
'Usage

Dim instance As PdfRichMediaAnnotation
Dim value() As Byte

instance.FlashPayload = value

value = instance.FlashPayload
public byte[] FlashPayload {get; set;}
public:
property array<byte>^ FlashPayload {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A Flash file that represents the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


Placeholder Property (PdfRichMediaAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : Placeholder Property
Gets or sets the placeholder to be displayed on the page when the Flash is not activated.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Placeholder As PdfFormXObject
'Usage

Dim instance As PdfRichMediaAnnotation
Dim value As PdfFormXObject

instance.Placeholder = value

value = instance.Placeholder
public PdfFormXObject Placeholder {get; set;}
public:
property PdfFormXObject^ Placeholder {
   PdfFormXObject^ get();
   void set (    PdfFormXObject^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfFormXObject that represents the graphic image to be displayed when the Flash content is not active.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


RichMediaContent Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : RichMediaContent Property
Gets the rich media content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property RichMediaContent As PdfRichMediaContent
'Usage

Dim instance As PdfRichMediaAnnotation
Dim value As PdfRichMediaContent

value = instance.RichMediaContent
public PdfRichMediaContent RichMediaContent {get;}
public:
property PdfRichMediaContent^ RichMediaContent {
   PdfRichMediaContent^ get();
}

Property Value

The rich media content associated with this annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


Settings Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : Settings Property
Gets the rich media settings.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Settings As PdfRichMediaSettings
'Usage

Dim instance As PdfRichMediaAnnotation
Dim value As PdfRichMediaSettings

value = instance.Settings
public PdfRichMediaSettings Settings {get;}
public:
property PdfRichMediaSettings^ Settings {
   PdfRichMediaSettings^ get();
}

Property Value

Settings for the rich media annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


%%PageItemTitle%%

PdfRichMediaAsset Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAsset Class
Defines a rich media asset object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRichMediaAsset
'Usage

Dim instance As PdfRichMediaAsset
public class PdfRichMediaAsset
public ref class PdfRichMediaAsset
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfRichMediaAsset

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAsset Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRichMediaAsset Class Members
Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAsset Class

The following tables list the members exposed by PdfRichMediaAsset.

Public Constructors
 | Name | Description
Public Constructor | PdfRichMediaAsset Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AssetData | Gets or sets the asset data.
Public Property | AssetName | Gets or sets the file asset associated with this annotation
Public Property | MimeType | Gets or sets the MIME type for the asset content.
Top
See Also

Reference

PdfRichMediaAsset Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaAsset Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAsset Class : PdfRichMediaAsset Constructor
Overload List
Overload | Description
PdfRichMediaAsset Constructor() | Initializes a new PdfRichMediaAsset object.
PdfRichMediaAsset Constructor(String,Byte[]) | Initializes a new PdfRichMediaAsset object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAsset Class
PdfRichMediaAsset Members


%%PageItemTitle%%

PdfRichMediaAsset Constructor()

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAsset Class > PdfRichMediaAsset Constructor : PdfRichMediaAsset Constructor()
Initializes a new PdfRichMediaAsset object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRichMediaAsset()
public PdfRichMediaAsset()
public:
PdfRichMediaAsset();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAsset Class
PdfRichMediaAsset Members
Overload List


%%PageItemTitle%%

PdfRichMediaAsset Constructor(String,Byte[])

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAsset Class > PdfRichMediaAsset Constructor : PdfRichMediaAsset Constructor(String,Byte[])
The name of the asset
Asset data
Initializes a new PdfRichMediaAsset object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal assetName As String, _
   ByVal assetData() As Byte _
)
'Usage

Dim assetName As String
Dim assetData() As Byte

Dim instance As New PdfRichMediaAsset(assetName, assetData)
public PdfRichMediaAsset(
   string assetName,
   byte[] assetData
)
public:
PdfRichMediaAsset(
   String^ assetName,
   array<byte>^ assetData
)

Parameters

assetName
The name of the asset
assetData
Asset data
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAsset Class
PdfRichMediaAsset Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfRichMediaAsset Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAsset Class

For a list of all members of this type, see PdfRichMediaAsset members.

Public Properties
 | Name | Description
Public Property | AssetData | Gets or sets the asset data.
Public Property | AssetName | Gets or sets the file asset associated with this annotation
Public Property | MimeType | Gets or sets the MIME type for the asset content.
Top
See Also

Reference

PdfRichMediaAsset Class
Xfinium.Pdf.Annotations Namespace


AssetData Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAsset Class : AssetData Property
Gets or sets the asset data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AssetData As Byte()
'Usage

Dim instance As PdfRichMediaAsset
Dim value() As Byte

instance.AssetData = value

value = instance.AssetData
public byte[] AssetData {get; set;}
public:
property array<byte>^ AssetData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAsset Class
PdfRichMediaAsset Members


AssetName Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAsset Class : AssetName Property
Gets or sets the file asset associated with this annotation
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AssetName As String
'Usage

Dim instance As PdfRichMediaAsset
Dim value As String

instance.AssetName = value

value = instance.AssetName
public string AssetName {get; set;}
public:
property String^ AssetName {
   String^ get();
   void set (    String^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAsset Class
PdfRichMediaAsset Members


MimeType Property (PdfRichMediaAsset)

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAsset Class : MimeType Property
Gets or sets the MIME type for the asset content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MimeType As String
'Usage

Dim instance As PdfRichMediaAsset
Dim value As String

instance.MimeType = value

value = instance.MimeType
public string MimeType {get; set;}
public:
property String^ MimeType {
   String^ get();
   void set (    String^ value);
}

Property Value

The MIME type for the asset content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAsset Class
PdfRichMediaAsset Members


%%PageItemTitle%%

PdfRichMediaAssetCollection Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAssetCollection Class
Defines a collection rich media assets.
Object Model
PdfRichMediaAssetCollection ClassPdfRichMediaAsset Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRichMediaAssetCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfRichMediaAsset)
'Usage

Dim instance As PdfRichMediaAssetCollection
public class PdfRichMediaAssetCollection : System.Collections.ObjectModel.Collection<PdfRichMediaAsset>
public ref class PdfRichMediaAssetCollection : public System.Collections.ObjectModel.Collection<PdfRichMediaAsset>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Annotations.PdfRichMediaAssetCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAssetCollection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRichMediaAssetCollection Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAssetCollection Class

The following tables list the members exposed by PdfRichMediaAssetCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Top
See Also

Reference

PdfRichMediaAssetCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaConfigurationCollection Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRichMediaConfigurationCollection Class
Defines a collection of rich media configurations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRichMediaConfigurationCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfRichMediaConfiguration)
'Usage

Dim instance As PdfRichMediaConfigurationCollection
public class PdfRichMediaConfigurationCollection : System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>
public ref class PdfRichMediaConfigurationCollection : public System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Annotations.PdfRichMediaConfigurationCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaConfigurationCollection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRichMediaConfigurationCollection Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfRichMediaConfigurationCollection Class

The following tables list the members exposed by PdfRichMediaConfigurationCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Top
See Also

Reference

PdfRichMediaConfigurationCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaContent Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRichMediaContent Class
Defines a rich media content object.
Object Model
PdfRichMediaContent ClassPdfRichMediaAssetCollection ClassPdfRichMediaAsset ClassPdfRichMediaConfigurationCollection Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRichMediaContent
'Usage

Dim instance As PdfRichMediaContent
public class PdfRichMediaContent
public ref class PdfRichMediaContent
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfRichMediaContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaContent Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRichMediaContent Class Members
Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaContent Class

The following tables list the members exposed by PdfRichMediaContent.

Public Constructors
 | Name | Description
Public Constructor | PdfRichMediaContent Constructor | Initializes a new PdfRichMediaContent object.
Top
Public Properties
 | Name | Description
Public Property | Assets | Gets the rich media asset collection.
Public Property | Configurations | Gets the rich media configurations.
Top
See Also

Reference

PdfRichMediaContent Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaContent Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaContent Class : PdfRichMediaContent Constructor
Initializes a new PdfRichMediaContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRichMediaContent()
public PdfRichMediaContent()
public:
PdfRichMediaContent();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaContent Class
PdfRichMediaContent Members


%%PageItemTitle%% $$Properties$$

PdfRichMediaContent Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaContent Class

For a list of all members of this type, see PdfRichMediaContent members.

Public Properties
 | Name | Description
Public Property | Assets | Gets the rich media asset collection.
Public Property | Configurations | Gets the rich media configurations.
Top
See Also

Reference

PdfRichMediaContent Class
Xfinium.Pdf.Annotations Namespace


Assets Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaContent Class : Assets Property
Gets the rich media asset collection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Assets As PdfRichMediaAssetCollection
'Usage

Dim instance As PdfRichMediaContent
Dim value As PdfRichMediaAssetCollection

value = instance.Assets
public PdfRichMediaAssetCollection Assets {get;}
public:
property PdfRichMediaAssetCollection^ Assets {
   PdfRichMediaAssetCollection^ get();
}

Property Value

A collection of rich media assets.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaContent Class
PdfRichMediaContent Members


Configurations Property

Xfinium.Pdf.Annotations Namespace > PdfRichMediaContent Class : Configurations Property
Gets the rich media configurations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Configurations As PdfRichMediaConfigurationCollection
'Usage

Dim instance As PdfRichMediaContent
Dim value As PdfRichMediaConfigurationCollection

value = instance.Configurations
public PdfRichMediaConfigurationCollection Configurations {get;}
public:
property PdfRichMediaConfigurationCollection^ Configurations {
   PdfRichMediaConfigurationCollection^ get();
}

Property Value

A collection of rich media configuration objects.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaContent Class
PdfRichMediaContent Members


%%PageItemTitle%%

PdfRichMediaDeactivation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRichMediaDeactivation Class
Defines the conditions for the deactivation of the rich media annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRichMediaDeactivation
'Usage

Dim instance As PdfRichMediaDeactivation
public class PdfRichMediaDeactivation
public ref class PdfRichMediaDeactivation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfRichMediaDeactivation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaDeactivation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRichMediaDeactivation Class Members
Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaDeactivation Class

The following tables list the members exposed by PdfRichMediaDeactivation.

Public Constructors
 | Name | Description
Public Constructor | PdfRichMediaDeactivation Constructor | Initializes a new PdfRichMediaDeactivation object.
Top
Public Properties
 | Name | Description
Public Property | DeactivationCondition | Gets or sets the deactivation condition for the rich media annotation.
Top
See Also

Reference

PdfRichMediaDeactivation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaDeactivation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaDeactivation Class : PdfRichMediaDeactivation Constructor
Initializes a new PdfRichMediaDeactivation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRichMediaDeactivation()
public PdfRichMediaDeactivation()
public:
PdfRichMediaDeactivation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaDeactivation Class
PdfRichMediaDeactivation Members


%%PageItemTitle%% $$Properties$$

PdfRichMediaDeactivation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaDeactivation Class

For a list of all members of this type, see PdfRichMediaDeactivation members.

Public Properties
 | Name | Description
Public Property | DeactivationCondition | Gets or sets the deactivation condition for the rich media annotation.
Top
See Also

Reference

PdfRichMediaDeactivation Class
Xfinium.Pdf.Annotations Namespace


DeactivationCondition Property (PdfRichMediaDeactivation)

Xfinium.Pdf.Annotations Namespace > PdfRichMediaDeactivation Class : DeactivationCondition Property
Gets or sets the deactivation condition for the rich media annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DeactivationCondition As PdfRichMediaDeactivationCondition
'Usage

Dim instance As PdfRichMediaDeactivation
Dim value As PdfRichMediaDeactivationCondition

instance.DeactivationCondition = value

value = instance.DeactivationCondition
public PdfRichMediaDeactivationCondition DeactivationCondition {get; set;}
public:
property PdfRichMediaDeactivationCondition DeactivationCondition {
   PdfRichMediaDeactivationCondition get();
   void set (    PdfRichMediaDeactivationCondition value);
}

Property Value

The condition that specifies how the rich media annotation is deactivated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaDeactivation Class
PdfRichMediaDeactivation Members


%%PageItemTitle%%

PdfRichMediaInstanceCollection Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRichMediaInstanceCollection Class
Defines a collection of rich media instances.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRichMediaInstanceCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfRichMediaInstance)
'Usage

Dim instance As PdfRichMediaInstanceCollection
public class PdfRichMediaInstanceCollection : System.Collections.ObjectModel.Collection<PdfRichMediaInstance>
public ref class PdfRichMediaInstanceCollection : public System.Collections.ObjectModel.Collection<PdfRichMediaInstance>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Annotations.PdfRichMediaInstanceCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaInstanceCollection Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRichMediaInstanceCollection Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfRichMediaInstanceCollection Class

The following tables list the members exposed by PdfRichMediaInstanceCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Top
See Also

Reference

PdfRichMediaInstanceCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRubberStampAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRubberStampAnnotation Class
Defines a PDF rubber stamp annotation.
Object Model
PdfRubberStampAnnotation ClassPdfColor ClassPdfCosDictionary ClassPdfAnnotation ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRubberStampAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfRubberStampAnnotation
public class PdfRubberStampAnnotation : PdfMarkupAnnotation
public ref class PdfRubberStampAnnotation : public PdfMarkupAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfRubberStampAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRubberStampAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfRubberStampAnnotation Class

The following tables list the members exposed by PdfRubberStampAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfRubberStampAnnotation Constructor | Initializes a new PdfRubberStampAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Color | Gets or sets the stamp color.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Overridden. Gets or sets the annotation opacity.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | StampName | Gets or sets the stamp name.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRubberStampAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRubberStampAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotation Class : PdfRubberStampAnnotation Constructor
Initializes a new PdfRubberStampAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRubberStampAnnotation()
public PdfRubberStampAnnotation()
public:
PdfRubberStampAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotation Class
PdfRubberStampAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfRubberStampAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRubberStampAnnotation Class

For a list of all members of this type, see PdfRubberStampAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Color | Gets or sets the stamp color.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Overridden. Gets or sets the annotation opacity.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | StampName | Gets or sets the stamp name.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRubberStampAnnotation Class
Xfinium.Pdf.Annotations Namespace


Color Property (PdfRubberStampAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotation Class : Color Property
Gets or sets the stamp color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Color As PdfColor
'Usage

Dim instance As PdfRubberStampAnnotation
Dim value As PdfColor

instance.Color = value

value = instance.Color
public PdfColor Color {get; set;}
public:
property PdfColor^ Color {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor that represents the stamp color.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotation Class
PdfRubberStampAnnotation Members


Opacity Property (PdfRubberStampAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotation Class : Opacity Property
Gets or sets the annotation opacity.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Opacity As Double
'Usage

Dim instance As PdfRubberStampAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
public override double Opacity {get; set;}
public:
property double Opacity {
   double get() override;
   void set (    double value) override;
}

Property Value

A value in the range [0, 1] that represents the constant opacity value to be used in painting the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotation Class
PdfRubberStampAnnotation Members


StampName Property

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotation Class : StampName Property
Gets or sets the stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StampName As String
'Usage

Dim instance As PdfRubberStampAnnotation
Dim value As String

instance.StampName = value

value = instance.StampName
public string StampName {get; set;}
public:
property String^ StampName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the stamp.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
The stamp name defines the stamp's visual appearance. The library supports a predefined set of names defined in the PdfRubberStampAnnotationName class for which standard appearance is created. When a custom name is used, a custom appearance must also be provided.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotation Class
PdfRubberStampAnnotation Members


%%PageItemTitle%%

PdfRubberStampAnnotationName Class
Members

Xfinium.Pdf.Annotations Namespace : PdfRubberStampAnnotationName Class
Defines the standard names for a rubber stamps.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRubberStampAnnotationName
'Usage

Dim instance As PdfRubberStampAnnotationName
public class PdfRubberStampAnnotationName
public ref class PdfRubberStampAnnotationName
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfRubberStampAnnotationName

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfRubberStampAnnotationName Class Members
Fields

Xfinium.Pdf.Annotations Namespace : PdfRubberStampAnnotationName Class

The following tables list the members exposed by PdfRubberStampAnnotationName.

Public Fields
 | Name | Description
Public Field | Approved | Approved stamp name.
Public Field | AsIs | As Is stamp name.
Public Field | Confidential | Confidential stamp name.
Public Field | Departmental | Departmental stamp name.
Public Field | Draft | Draft stamp name.
Public Field | Experimental | Experimental stamp name.
Public Field | Expired | Expired stamp name.
Public Field | Final | Final stamp name.
Public Field | ForComment | for comment stamp name.
Public Field | ForPublicRelease | For public release stamp name.
Public Field | NotApproved | Not approved stamp name.
Public Field | NotForPublicRelease | Not for public release stamp name.
Public Field | Sold | Sold stamp name.
Public Field | TopSecret | Top secret stamp name.
Top
See Also

Reference

PdfRubberStampAnnotationName Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Fields$$

PdfRubberStampAnnotationName Class Fields

Xfinium.Pdf.Annotations Namespace : PdfRubberStampAnnotationName Class

For a list of all members of this type, see PdfRubberStampAnnotationName members.

Public Fields
 | Name | Description
Public Field | Approved | Approved stamp name.
Public Field | AsIs | As Is stamp name.
Public Field | Confidential | Confidential stamp name.
Public Field | Departmental | Departmental stamp name.
Public Field | Draft | Draft stamp name.
Public Field | Experimental | Experimental stamp name.
Public Field | Expired | Expired stamp name.
Public Field | Final | Final stamp name.
Public Field | ForComment | for comment stamp name.
Public Field | ForPublicRelease | For public release stamp name.
Public Field | NotApproved | Not approved stamp name.
Public Field | NotForPublicRelease | Not for public release stamp name.
Public Field | Sold | Sold stamp name.
Public Field | TopSecret | Top secret stamp name.
Top
See Also

Reference

PdfRubberStampAnnotationName Class
Xfinium.Pdf.Annotations Namespace


Approved Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : Approved Field
Approved stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Approved As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.Approved
public const string Approved
public:
const String^ Approved
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


AsIs Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : AsIs Field
As Is stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const AsIs As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.AsIs
public const string AsIs
public:
const String^ AsIs
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


Confidential Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : Confidential Field
Confidential stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Confidential As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.Confidential
public const string Confidential
public:
const String^ Confidential
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


Departmental Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : Departmental Field
Departmental stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Departmental As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.Departmental
public const string Departmental
public:
const String^ Departmental
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


Draft Field (PdfRubberStampAnnotationName)

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : Draft Field
Draft stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Draft As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.Draft
public const string Draft
public:
const String^ Draft
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


Experimental Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : Experimental Field
Experimental stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Experimental As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.Experimental
public const string Experimental
public:
const String^ Experimental
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


Expired Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : Expired Field
Expired stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Expired As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.Expired
public const string Expired
public:
const String^ Expired
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


Final Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : Final Field
Final stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Final As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.Final
public const string Final
public:
const String^ Final
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


ForComment Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : ForComment Field
for comment stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const ForComment As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.ForComment
public const string ForComment
public:
const String^ ForComment
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


ForPublicRelease Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : ForPublicRelease Field
For public release stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const ForPublicRelease As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.ForPublicRelease
public const string ForPublicRelease
public:
const String^ ForPublicRelease
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


NotApproved Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : NotApproved Field
Not approved stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const NotApproved As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.NotApproved
public const string NotApproved
public:
const String^ NotApproved
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


NotForPublicRelease Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : NotForPublicRelease Field
Not for public release stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const NotForPublicRelease As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.NotForPublicRelease
public const string NotForPublicRelease
public:
const String^ NotForPublicRelease
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


Sold Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : Sold Field
Sold stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Sold As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.Sold
public const string Sold
public:
const String^ Sold
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


TopSecret Field

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotationName Class : TopSecret Field
Top secret stamp name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const TopSecret As String
'Usage

Dim value As String

value = PdfRubberStampAnnotationName.TopSecret
public const string TopSecret
public:
const String^ TopSecret
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotationName Class
PdfRubberStampAnnotationName Members


%%PageItemTitle%%

PdfScreenAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfScreenAnnotation Class
Defines a PDF movie annotation. Defines a movie annotation in a Pdf file.
Object Model
PdfScreenAnnotation ClassPdfCosDictionary ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfFormXObject ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfScreenAnnotation
   Inherits PdfAnnotation
'Usage

Dim instance As PdfScreenAnnotation
public class PdfScreenAnnotation : PdfAnnotation
public ref class PdfScreenAnnotation : public PdfAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfScreenAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfScreenAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfScreenAnnotation Class

The following tables list the members exposed by PdfScreenAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfScreenAnnotation Constructor | Initializes a new PdfScreenAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Duration | Gets or sets the duration of the movie.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MimeType | Gets or sets the MIME type for the movie content.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MovieFile | Gets or sets the movie file associated with this annotation.
Public Property | MoviePayload | Gets or sets the movie content.
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Placeholder | Gets or sets the placeholder to be displayed on the page when the movie is not playing.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ShowMoviePlayerUserInterface | Gets or sets a value indicating whether to display a player-specific controller user interface (for example, play/pause/stop controls) when playing.
Public Property | Title | Gets or sets the movie title.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfScreenAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfScreenAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : PdfScreenAnnotation Constructor
Initializes a new PdfScreenAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfScreenAnnotation()
public PdfScreenAnnotation()
public:
PdfScreenAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfScreenAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfScreenAnnotation Class

For a list of all members of this type, see PdfScreenAnnotation members.

Public Properties
 | Name | Description
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Duration | Gets or sets the duration of the movie.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MimeType | Gets or sets the MIME type for the movie content.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MovieFile | Gets or sets the movie file associated with this annotation.
Public Property | MoviePayload | Gets or sets the movie content.
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Placeholder | Gets or sets the placeholder to be displayed on the page when the movie is not playing.
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ShowMoviePlayerUserInterface | Gets or sets a value indicating whether to display a player-specific controller user interface (for example, play/pause/stop controls) when playing.
Public Property | Title | Gets or sets the movie title.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfScreenAnnotation Class
Xfinium.Pdf.Annotations Namespace


Duration Property

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : Duration Property
Gets or sets the duration of the movie.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Duration As Double
'Usage

Dim instance As PdfScreenAnnotation
Dim value As Double

instance.Duration = value

value = instance.Duration
public double Duration {get; set;}
public:
property double Duration {
   double get();
   void set (    double value);
}

Property Value

The duration of the movie.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


MimeType Property (PdfScreenAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : MimeType Property
Gets or sets the MIME type for the movie content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MimeType As String
'Usage

Dim instance As PdfScreenAnnotation
Dim value As String

instance.MimeType = value

value = instance.MimeType
public string MimeType {get; set;}
public:
property String^ MimeType {
   String^ get();
   void set (    String^ value);
}

Property Value

The MIME type for the movie content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


MovieFile Property

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : MovieFile Property
Gets or sets the movie file associated with this annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MovieFile As String
'Usage

Dim instance As PdfScreenAnnotation
Dim value As String

instance.MovieFile = value

value = instance.MovieFile
public string MovieFile {get; set;}
public:
property String^ MovieFile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the full path to the movie file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


MoviePayload Property

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : MoviePayload Property
Gets or sets the movie content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MoviePayload As Byte()
'Usage

Dim instance As PdfScreenAnnotation
Dim value() As Byte

instance.MoviePayload = value

value = instance.MoviePayload
public byte[] MoviePayload {get; set;}
public:
property array<byte>^ MoviePayload {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

the content of the movie displayed in the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


Placeholder Property (PdfScreenAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : Placeholder Property
Gets or sets the placeholder to be displayed on the page when the movie is not playing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Placeholder As PdfFormXObject
'Usage

Dim instance As PdfScreenAnnotation
Dim value As PdfFormXObject

instance.Placeholder = value

value = instance.Placeholder
public PdfFormXObject Placeholder {get; set;}
public:
property PdfFormXObject^ Placeholder {
   PdfFormXObject^ get();
   void set (    PdfFormXObject^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfFormXObject that represents the graphic image to be displayed when the movie is not playing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


ShowMoviePlayerUserInterface Property

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : ShowMoviePlayerUserInterface Property
Gets or sets a value indicating whether to display a player-specific controller user interface (for example, play/pause/stop controls) when playing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowMoviePlayerUserInterface As Boolean
'Usage

Dim instance As PdfScreenAnnotation
Dim value As Boolean

instance.ShowMoviePlayerUserInterface = value

value = instance.ShowMoviePlayerUserInterface
public bool ShowMoviePlayerUserInterface {get; set;}
public:
property bool ShowMoviePlayerUserInterface {
   bool get();
   void set (    bool value);
}

Property Value

If true, the player specific user interface is displayed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


Title Property (PdfScreenAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : Title Property
Gets or sets the movie title.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Title As String
'Usage

Dim instance As PdfScreenAnnotation
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

The title of the movie.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


%%PageItemTitle%%

PdfSoundAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfSoundAnnotation Class
Defines a PDF sound annotation.
Object Model
PdfSoundAnnotation ClassPdfCosDictionary ClassPdfAnnotation ClassPdfColor ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfColor ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSoundAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfSoundAnnotation
public class PdfSoundAnnotation : PdfMarkupAnnotation
public ref class PdfSoundAnnotation : public PdfMarkupAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfSoundAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfSoundAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfSoundAnnotation Class

The following tables list the members exposed by PdfSoundAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfSoundAnnotation Constructor | Initializes a new PdfSoundAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BitsPerSample | Gets or sets the bits per sample.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | IconName | Gets or sets the sound annotation icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Overridden. Gets or sets the annotation normal appearance.
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | OutlineColor | Gets or sets the annotation outline color.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | SamplingRate | Gets or sets the sampling rate.
Public Property | SoundChannels | Gets or sets the number of sound channels.
Public Property | SoundEncoding | Gets or sets the encoding format for the sample data.
Public Property | SoundPayload | Gets or sets the sound content.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfSoundAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfSoundAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : PdfSoundAnnotation Constructor
Initializes a new PdfSoundAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSoundAnnotation()
public PdfSoundAnnotation()
public:
PdfSoundAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfSoundAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfSoundAnnotation Class

For a list of all members of this type, see PdfSoundAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BitsPerSample | Gets or sets the bits per sample.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | IconName | Gets or sets the sound annotation icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Overridden. Gets or sets the annotation normal appearance.
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | OutlineColor | Gets or sets the annotation outline color.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | SamplingRate | Gets or sets the sampling rate.
Public Property | SoundChannels | Gets or sets the number of sound channels.
Public Property | SoundEncoding | Gets or sets the encoding format for the sample data.
Public Property | SoundPayload | Gets or sets the sound content.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfSoundAnnotation Class
Xfinium.Pdf.Annotations Namespace


BitsPerSample Property (PdfSoundAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : BitsPerSample Property
Gets or sets the bits per sample.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BitsPerSample As Integer
'Usage

Dim instance As PdfSoundAnnotation
Dim value As Integer

instance.BitsPerSample = value

value = instance.BitsPerSample
public int BitsPerSample {get; set;}
public:
property int BitsPerSample {
   int get();
   void set (    int value);
}

Property Value

The number of bits per sample value per channel.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


IconName Property (PdfSoundAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : IconName Property
Gets or sets the sound annotation icon name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PdfSoundAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the sound annotation icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
The icon name defines the annotation's visual appearance. The library supports a predefined set of names defined in the PdfSoundAnnotationName class for which standard appearance is created. When a custom name is used, a custom appearance must also be provided.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


InteriorColor Property (PdfSoundAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : InteriorColor Property
Gets or sets the annotation interior color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InteriorColor As PdfColor
'Usage

Dim instance As PdfSoundAnnotation
Dim value As PdfColor

instance.InteriorColor = value

value = instance.InteriorColor
public PdfColor InteriorColor {get; set;}
public:
property PdfColor^ InteriorColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the interior color with which to fill the annotation's icon interior.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


NormalAppearance Property (PdfSoundAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : NormalAppearance Property
Gets or sets the annotation normal appearance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property NormalAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfSoundAnnotation
Dim value As PdfAnnotationAppearance

instance.NormalAppearance = value

value = instance.NormalAppearance
public override PdfAnnotationAppearance NormalAppearance {get; set;}
public:
property PdfAnnotationAppearance^ NormalAppearance {
   PdfAnnotationAppearance^ get() override;
   void set (    PdfAnnotationAppearance^ value) override;
}

Property Value

A PdfAnnotationAppearance specifying how the annotation is presented visually on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


OutlineColor Property (PdfSoundAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : OutlineColor Property
Gets or sets the annotation outline color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutlineColor As PdfColor
'Usage

Dim instance As PdfSoundAnnotation
Dim value As PdfColor

instance.OutlineColor = value

value = instance.OutlineColor
public PdfColor OutlineColor {get; set;}
public:
property PdfColor^ OutlineColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the outline color with which to stroke the annotation's icon outlines.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


SamplingRate Property

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : SamplingRate Property
Gets or sets the sampling rate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SamplingRate As Double
'Usage

Dim instance As PdfSoundAnnotation
Dim value As Double

instance.SamplingRate = value

value = instance.SamplingRate
public double SamplingRate {get; set;}
public:
property double SamplingRate {
   double get();
   void set (    double value);
}

Property Value

The sampling rate, in samples per second.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


SoundChannels Property

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : SoundChannels Property
Gets or sets the number of sound channels.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SoundChannels As Integer
'Usage

Dim instance As PdfSoundAnnotation
Dim value As Integer

instance.SoundChannels = value

value = instance.SoundChannels
public int SoundChannels {get; set;}
public:
property int SoundChannels {
   int get();
   void set (    int value);
}

Property Value

The number of sound channels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


SoundEncoding Property

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : SoundEncoding Property
Gets or sets the encoding format for the sample data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SoundEncoding As PdfSoundAnnotationDataEncoding
'Usage

Dim instance As PdfSoundAnnotation
Dim value As PdfSoundAnnotationDataEncoding

instance.SoundEncoding = value

value = instance.SoundEncoding
public PdfSoundAnnotationDataEncoding SoundEncoding {get; set;}
public:
property PdfSoundAnnotationDataEncoding SoundEncoding {
   PdfSoundAnnotationDataEncoding get();
   void set (    PdfSoundAnnotationDataEncoding value);
}

Property Value

The encoding format for the sample data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


SoundPayload Property

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : SoundPayload Property
Gets or sets the sound content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SoundPayload As Byte()
'Usage

Dim instance As PdfSoundAnnotation
Dim value() As Byte

instance.SoundPayload = value

value = instance.SoundPayload
public byte[] SoundPayload {get; set;}
public:
property array<byte>^ SoundPayload {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The content of the sound played by the annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


%%PageItemTitle%%

PdfSoundAnnotationName Class
Members

Xfinium.Pdf.Annotations Namespace : PdfSoundAnnotationName Class
Defines the standard names for a sound annotation icons.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSoundAnnotationName
'Usage

Dim instance As PdfSoundAnnotationName
public class PdfSoundAnnotationName
public ref class PdfSoundAnnotationName
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfSoundAnnotationName

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotationName Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfSoundAnnotationName Class Members
Fields

Xfinium.Pdf.Annotations Namespace : PdfSoundAnnotationName Class

The following tables list the members exposed by PdfSoundAnnotationName.

Public Constructors
 | Name | Description
Public Constructor | PdfSoundAnnotationName Constructor |
Top
Public Fields
 | Name | Description
Public Field | Microphone | This name creates a Microphone icon for the annotation.
Public Field | Speaker | This name creates a Speaker icon for the annotation.
Top
See Also

Reference

PdfSoundAnnotationName Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfSoundAnnotationName Constructor

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotationName Class : PdfSoundAnnotationName Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSoundAnnotationName()
public PdfSoundAnnotationName()
public:
PdfSoundAnnotationName();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotationName Class
PdfSoundAnnotationName Members


%%PageItemTitle%% $$Fields$$

PdfSoundAnnotationName Class Fields

Xfinium.Pdf.Annotations Namespace : PdfSoundAnnotationName Class

For a list of all members of this type, see PdfSoundAnnotationName members.

Public Fields
 | Name | Description
Public Field | Microphone | This name creates a Microphone icon for the annotation.
Public Field | Speaker | This name creates a Speaker icon for the annotation.
Top
See Also

Reference

PdfSoundAnnotationName Class
Xfinium.Pdf.Annotations Namespace


Microphone Field

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotationName Class : Microphone Field
This name creates a Microphone icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Microphone As String
'Usage

Dim value As String

value = PdfSoundAnnotationName.Microphone
public const string Microphone
public:
const String^ Microphone
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotationName Class
PdfSoundAnnotationName Members


Speaker Field

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotationName Class : Speaker Field
This name creates a Speaker icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Speaker As String
'Usage

Dim value As String

value = PdfSoundAnnotationName.Speaker
public const string Speaker
public:
const String^ Speaker
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotationName Class
PdfSoundAnnotationName Members


%%PageItemTitle%%

PdfSquareAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfSquareAnnotation Class
Defines a square annotation.
Object Model
PdfSquareAnnotation ClassPdfColor ClassPdfCosDictionary ClassPdfAnnotation ClassPdfColor ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSquareAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfSquareAnnotation
public class PdfSquareAnnotation : PdfMarkupAnnotation
public ref class PdfSquareAnnotation : public PdfMarkupAnnotation
Remarks
A square annotation displays a rectangle on the page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfSquareAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSquareAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfSquareAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfSquareAnnotation Class

The following tables list the members exposed by PdfSquareAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfSquareAnnotation Constructor | Initializes a new PdfSquareAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BorderColor | Gets or sets the annotation border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfSquareAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfSquareAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfSquareAnnotation Class : PdfSquareAnnotation Constructor
Initializes a new PdfSquareAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSquareAnnotation()
public PdfSquareAnnotation()
public:
PdfSquareAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSquareAnnotation Class
PdfSquareAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfSquareAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfSquareAnnotation Class

For a list of all members of this type, see PdfSquareAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | BorderColor | Gets or sets the annotation border color.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfSquareAnnotation Class
Xfinium.Pdf.Annotations Namespace


BorderColor Property (PdfSquareAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfSquareAnnotation Class : BorderColor Property
Gets or sets the annotation border color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderColor As PdfColor
'Usage

Dim instance As PdfSquareAnnotation
Dim value As PdfColor

instance.BorderColor = value

value = instance.BorderColor
public PdfColor BorderColor {get; set;}
public:
property PdfColor^ BorderColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the border color with which to stroke the annotation's rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSquareAnnotation Class
PdfSquareAnnotation Members


BorderWidth Property (PdfSquareAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfSquareAnnotation Class : BorderWidth Property
Gets or sets the border width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PdfSquareAnnotation
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the rectangle outline drawn in the annotation.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSquareAnnotation Class
PdfSquareAnnotation Members


InteriorColor Property (PdfSquareAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfSquareAnnotation Class : InteriorColor Property
Gets or sets the annotation interior color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InteriorColor As PdfColor
'Usage

Dim instance As PdfSquareAnnotation
Dim value As PdfColor

instance.InteriorColor = value

value = instance.InteriorColor
public PdfColor InteriorColor {get; set;}
public:
property PdfColor^ InteriorColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the interior color with which to fill the annotation's rectangle.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSquareAnnotation Class
PdfSquareAnnotation Members


%%PageItemTitle%%

PdfTextAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfTextAnnotation Class
Defines a PDF text note annotation.
Object Model
PdfTextAnnotation ClassPdfCosDictionary ClassPdfAnnotation ClassPdfColor ClassPdfPoint ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfColor ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfTextAnnotation
public class PdfTextAnnotation : PdfMarkupAnnotation
public ref class PdfTextAnnotation : public PdfMarkupAnnotation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfTextAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfTextAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfTextAnnotation Class

The following tables list the members exposed by PdfTextAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfTextAnnotation Constructor | Initializes a new PdfTextAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | IconName | Gets or sets the text annotation icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Location | Gets or sets the annotation location on the page.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Overridden. Gets or sets the annotation normal appearance.
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Open | Gets or sets a value indicating whether the annotation should initially be displayed open.
Public Property | OutlineColor | Gets or sets the annotation outline color.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | State | Gets or sets the annotation state.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfTextAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfTextAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : PdfTextAnnotation Constructor
Initializes a new PdfTextAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfTextAnnotation()
public PdfTextAnnotation()
public:
PdfTextAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfTextAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfTextAnnotation Class

For a list of all members of this type, see PdfTextAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | IconName | Gets or sets the text annotation icon name.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color.
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Location | Gets or sets the annotation location on the page.
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Overridden. Gets or sets the annotation normal appearance.
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Open | Gets or sets a value indicating whether the annotation should initially be displayed open.
Public Property | OutlineColor | Gets or sets the annotation outline color.
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | State | Gets or sets the annotation state.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Overridden. Gets or sets the visual rectangle of this annotation object.
Top
See Also

Reference

PdfTextAnnotation Class
Xfinium.Pdf.Annotations Namespace


IconName Property (PdfTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : IconName Property
Gets or sets the text annotation icon name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IconName As String
'Usage

Dim instance As PdfTextAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
public string IconName {get; set;}
public:
property String^ IconName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the text annotation icon.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property value is null or empty.
Remarks
The icon name defines the annotation's visual appearance. The library supports a predefined set of names defined in the PdfTextAnnotationName class for which standard appearance is created. When a custom name is used, a custom appearance must also be provided.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


InteriorColor Property (PdfTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : InteriorColor Property
Gets or sets the annotation interior color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InteriorColor As PdfColor
'Usage

Dim instance As PdfTextAnnotation
Dim value As PdfColor

instance.InteriorColor = value

value = instance.InteriorColor
public PdfColor InteriorColor {get; set;}
public:
property PdfColor^ InteriorColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the interior color with which to fill the annotation's icon interior.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


Location Property (PdfTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : Location Property
Gets or sets the annotation location on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Location As PdfPoint
'Usage

Dim instance As PdfTextAnnotation
Dim value As PdfPoint

instance.Location = value

value = instance.Location
public PdfPoint Location {get; set;}
public:
property PdfPoint^ Location {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The position of annotation's top left corner on the parent page.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property is set to null.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


NormalAppearance Property (PdfTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : NormalAppearance Property
Gets or sets the annotation normal appearance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property NormalAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfTextAnnotation
Dim value As PdfAnnotationAppearance

instance.NormalAppearance = value

value = instance.NormalAppearance
public override PdfAnnotationAppearance NormalAppearance {get; set;}
public:
property PdfAnnotationAppearance^ NormalAppearance {
   PdfAnnotationAppearance^ get() override;
   void set (    PdfAnnotationAppearance^ value) override;
}

Property Value

A PdfAnnotationAppearance specifying how the annotation is presented visually on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


Open Property

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : Open Property
Gets or sets a value indicating whether the annotation should initially be displayed open.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Open As Boolean
'Usage

Dim instance As PdfTextAnnotation
Dim value As Boolean

instance.Open = value

value = instance.Open
public bool Open {get; set;}
public:
property bool Open {
   bool get();
   void set (    bool value);
}

Property Value

If true, the annotation is displayed in open state.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


OutlineColor Property (PdfTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : OutlineColor Property
Gets or sets the annotation outline color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutlineColor As PdfColor
'Usage

Dim instance As PdfTextAnnotation
Dim value As PdfColor

instance.OutlineColor = value

value = instance.OutlineColor
public PdfColor OutlineColor {get; set;}
public:
property PdfColor^ OutlineColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfColor specifying the outline color with which to stroke the annotation's icon outlines.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


State Property

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : State Property
Gets or sets the annotation state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property State As PdfTextAnnotationState
'Usage

Dim instance As PdfTextAnnotation
Dim value As PdfTextAnnotationState

instance.State = value

value = instance.State
public PdfTextAnnotationState State {get; set;}
public:
property PdfTextAnnotationState State {
   PdfTextAnnotationState get();
   void set (    PdfTextAnnotationState value);
}

Property Value

The state to which the original annotation should be set.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


VisualRectangle Property (PdfTextAnnotation)

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : VisualRectangle Property
Gets or sets the visual rectangle of this annotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property VisualRectangle As PdfVisualRectangle
'Usage

Dim instance As PdfTextAnnotation
Dim value As PdfVisualRectangle

instance.VisualRectangle = value

value = instance.VisualRectangle
public override PdfVisualRectangle VisualRectangle {get; set;}
public:
property PdfVisualRectangle^ VisualRectangle {
   PdfVisualRectangle^ get() override;
   void set (    PdfVisualRectangle^ value) override;
}

Property Value

A Xfinium.Pdf.Graphics.PdfVisualRectangle that represents the position and size of the annotation.
Remarks
The visual rectangle is relative to the top left corner of the page and can be set only after the annotation has been added to the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


%%PageItemTitle%%

PdfTextAnnotationName Class
Members

Xfinium.Pdf.Annotations Namespace : PdfTextAnnotationName Class
Defines the standard names for a text note icons.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextAnnotationName
'Usage

Dim instance As PdfTextAnnotationName
public class PdfTextAnnotationName
public ref class PdfTextAnnotationName
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfTextAnnotationName

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfTextAnnotationName Class Members
Fields

Xfinium.Pdf.Annotations Namespace : PdfTextAnnotationName Class

The following tables list the members exposed by PdfTextAnnotationName.

Public Constructors
 | Name | Description
Public Constructor | PdfTextAnnotationName Constructor |
Top
Public Fields
 | Name | Description
Public Field | Check | This name creates a Checkmark icon for the annotation.
Public Field | Circle | This name creates a Circle icon for the annotation.
Public Field | Comment | This name creates a Comment icon for the annotation.
Public Field | Cross | This name creates a Cross icon for the annotation.
Public Field | Help | This name creates a Help icon for the annotation.
Public Field | Insert | This name creates an Insert icon for the annotation.
Public Field | Key | This name creates a Key icon for the annotation.
Public Field | NewParagraph | This name creates a New paragraph icon for the annotation.
Public Field | Note | This name creates a Note icon for the annotation.
Public Field | Paragraph | This name creates a Paragraph icon for the annotation.
Public Field | RightArrow | This name creates a Right arrow icon for the annotation.
Public Field | RightPointer | This name creates a Right pointer icon for the annotation.
Public Field | Star | This name creates a Star icon for the annotation.
Public Field | UpArrow | This name creates an Up arrow icon for the annotation.
Public Field | UpLeftArrow | This name creates an Up left arrow icon for the annotation.
Top
See Also

Reference

PdfTextAnnotationName Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfTextAnnotationName Constructor

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : PdfTextAnnotationName Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfTextAnnotationName()
public PdfTextAnnotationName()
public:
PdfTextAnnotationName();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


%%PageItemTitle%% $$Fields$$

PdfTextAnnotationName Class Fields

Xfinium.Pdf.Annotations Namespace : PdfTextAnnotationName Class

For a list of all members of this type, see PdfTextAnnotationName members.

Public Fields
 | Name | Description
Public Field | Check | This name creates a Checkmark icon for the annotation.
Public Field | Circle | This name creates a Circle icon for the annotation.
Public Field | Comment | This name creates a Comment icon for the annotation.
Public Field | Cross | This name creates a Cross icon for the annotation.
Public Field | Help | This name creates a Help icon for the annotation.
Public Field | Insert | This name creates an Insert icon for the annotation.
Public Field | Key | This name creates a Key icon for the annotation.
Public Field | NewParagraph | This name creates a New paragraph icon for the annotation.
Public Field | Note | This name creates a Note icon for the annotation.
Public Field | Paragraph | This name creates a Paragraph icon for the annotation.
Public Field | RightArrow | This name creates a Right arrow icon for the annotation.
Public Field | RightPointer | This name creates a Right pointer icon for the annotation.
Public Field | Star | This name creates a Star icon for the annotation.
Public Field | UpArrow | This name creates an Up arrow icon for the annotation.
Public Field | UpLeftArrow | This name creates an Up left arrow icon for the annotation.
Top
See Also

Reference

PdfTextAnnotationName Class
Xfinium.Pdf.Annotations Namespace


Check Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Check Field
This name creates a Checkmark icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Check As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Check
public const string Check
public:
const String^ Check
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Circle Field (PdfTextAnnotationName)

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Circle Field
This name creates a Circle icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Circle As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Circle
public const string Circle
public:
const String^ Circle
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Comment Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Comment Field
This name creates a Comment icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Comment As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Comment
public const string Comment
public:
const String^ Comment
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Cross Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Cross Field
This name creates a Cross icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Cross As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Cross
public const string Cross
public:
const String^ Cross
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Help Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Help Field
This name creates a Help icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Help As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Help
public const string Help
public:
const String^ Help
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Insert Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Insert Field
This name creates an Insert icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Insert As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Insert
public const string Insert
public:
const String^ Insert
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Key Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Key Field
This name creates a Key icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Key As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Key
public const string Key
public:
const String^ Key
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


NewParagraph Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : NewParagraph Field
This name creates a New paragraph icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const NewParagraph As String
'Usage

Dim value As String

value = PdfTextAnnotationName.NewParagraph
public const string NewParagraph
public:
const String^ NewParagraph
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Note Field (PdfTextAnnotationName)

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Note Field
This name creates a Note icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Note As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Note
public const string Note
public:
const String^ Note
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Paragraph Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Paragraph Field
This name creates a Paragraph icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Paragraph As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Paragraph
public const string Paragraph
public:
const String^ Paragraph
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


RightArrow Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : RightArrow Field
This name creates a Right arrow icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const RightArrow As String
'Usage

Dim value As String

value = PdfTextAnnotationName.RightArrow
public const string RightArrow
public:
const String^ RightArrow
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


RightPointer Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : RightPointer Field
This name creates a Right pointer icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const RightPointer As String
'Usage

Dim value As String

value = PdfTextAnnotationName.RightPointer
public const string RightPointer
public:
const String^ RightPointer
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


Star Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : Star Field
This name creates a Star icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const Star As String
'Usage

Dim value As String

value = PdfTextAnnotationName.Star
public const string Star
public:
const String^ Star
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


UpArrow Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : UpArrow Field
This name creates an Up arrow icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const UpArrow As String
'Usage

Dim value As String

value = PdfTextAnnotationName.UpArrow
public const string UpArrow
public:
const String^ UpArrow
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


UpLeftArrow Field

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotationName Class : UpLeftArrow Field
This name creates an Up left arrow icon for the annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const UpLeftArrow As String
'Usage

Dim value As String

value = PdfTextAnnotationName.UpLeftArrow
public const string UpLeftArrow
public:
const String^ UpLeftArrow
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotationName Class
PdfTextAnnotationName Members


%%PageItemTitle%%

PdfTextMarkupAnnotation Class
Members

Xfinium.Pdf.Annotations Namespace : PdfTextMarkupAnnotation Class
Defines a PDF text markup annotation.
Object Model
PdfTextMarkupAnnotation ClassPdfCosDictionary ClassPdfAnnotation ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextMarkupAnnotation
   Inherits PdfMarkupAnnotation
'Usage

Dim instance As PdfTextMarkupAnnotation
public class PdfTextMarkupAnnotation : PdfMarkupAnnotation
public ref class PdfTextMarkupAnnotation : public PdfMarkupAnnotation
Remarks
Text markup annotations appear as highlights, underlines, strikeouts or jagged (squiggly) underlines in the text of a document.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Annotations.PdfMarkupAnnotation
Xfinium.Pdf.Annotations.PdfTextMarkupAnnotation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextMarkupAnnotation Members
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Members$$

PdfTextMarkupAnnotation Class Members
Properties Methods

Xfinium.Pdf.Annotations Namespace : PdfTextMarkupAnnotation Class

The following tables list the members exposed by PdfTextMarkupAnnotation.

Public Constructors
 | Name | Description
Public Constructor | PdfTextMarkupAnnotation Constructor | Initializes a new PdfTextMarkupAnnotation object.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | TextMarkupColor | Gets or sets the annotation markup color.
Public Property | TextMarkupType | Gets or sets the type of the annotation markup.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfTextMarkupAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfTextMarkupAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfTextMarkupAnnotation Class : PdfTextMarkupAnnotation Constructor
Initializes a new PdfTextMarkupAnnotation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfTextMarkupAnnotation()
public PdfTextMarkupAnnotation()
public:
PdfTextMarkupAnnotation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextMarkupAnnotation Class
PdfTextMarkupAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfTextMarkupAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfTextMarkupAnnotation Class

For a list of all members of this type, see PdfTextMarkupAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | TextMarkupColor | Gets or sets the annotation markup color.
Public Property | TextMarkupType | Gets or sets the type of the annotation markup.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfTextMarkupAnnotation Class
Xfinium.Pdf.Annotations Namespace


TextMarkupColor Property

Xfinium.Pdf.Annotations Namespace > PdfTextMarkupAnnotation Class : TextMarkupColor Property
Gets or sets the annotation markup color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextMarkupColor As PdfColor
'Usage

Dim instance As PdfTextMarkupAnnotation
Dim value As PdfColor

instance.TextMarkupColor = value

value = instance.TextMarkupColor
public PdfColor TextMarkupColor {get; set;}
public:
property PdfColor^ TextMarkupColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The annotation markup color.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextMarkupAnnotation Class
PdfTextMarkupAnnotation Members


TextMarkupType Property

Xfinium.Pdf.Annotations Namespace > PdfTextMarkupAnnotation Class : TextMarkupType Property
Gets or sets the type of the annotation markup.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextMarkupType As PdfTextMarkupAnnotationType
'Usage

Dim instance As PdfTextMarkupAnnotation
Dim value As PdfTextMarkupAnnotationType

instance.TextMarkupType = value

value = instance.TextMarkupType
public PdfTextMarkupAnnotationType TextMarkupType {get; set;}
public:
property PdfTextMarkupAnnotationType TextMarkupType {
   PdfTextMarkupAnnotationType get();
   void set (    PdfTextMarkupAnnotationType value);
}

Property Value

The type of the text markup.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextMarkupAnnotation Class
PdfTextMarkupAnnotation Members


%%PageItemTitle%%

Pdf3DActivationMode Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DActivationMode Enumeration
Supported modes for 3D annotation activation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DActivationMode
   Inherits System.Enum
'Usage

Dim instance As Pdf3DActivationMode
public enum Pdf3DActivationMode : System.Enum
public enum class Pdf3DActivationMode : public System.Enum
Members
Member | Description
ExplicitActivation | The annotation should remain inactive until explicitly activated by a script or user action.
PageOpen | The annotation should be activated as soon as the page containing the annotation is opened.
PageVisible | The annotation should be activated as soon as any part of the page containing the annotation becomes visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DActivationMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DActivationState Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DActivationState Enumeration
Supported states upon 3D annotation activation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DActivationState
   Inherits System.Enum
'Usage

Dim instance As Pdf3DActivationState
public enum Pdf3DActivationState : System.Enum
public enum class Pdf3DActivationState : public System.Enum
Members
Member | Description
Instantiated | The artwork is instantiated, but real-time script-driven animations are disabled.
Live | Real-time script-driven animations are enabled if present; if not, the artwork is instantiated.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DActivationState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DAnimationStyle Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DAnimationStyle Enumeration
Supported animation styles.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DAnimationStyle
   Inherits System.Enum
'Usage

Dim instance As Pdf3DAnimationStyle
public enum Pdf3DAnimationStyle : System.Enum
public enum class Pdf3DAnimationStyle : public System.Enum
Members
Member | Description
Linear | Keyframe animations are driven linearly from beginning to end. This animation style results in a repetitive playthrough of the animation, such as in a walking motion.
None | Keyframe animations should not be driven directly by the viewer application. This value is used by documents that are intended to drive animations through an alternate means, such as JavaScript.
Oscillating | Keyframe animations should oscillate along their time range. This animation style results in a back-and-forth playing of the animation, such as exploding or collapsing parts.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DAnimationStyle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DDeactivationMode Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DDeactivationMode Enumeration
Supported modes for 3D annotation deactivation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DDeactivationMode
   Inherits System.Enum
'Usage

Dim instance As Pdf3DDeactivationMode
public enum Pdf3DDeactivationMode : System.Enum
public enum class Pdf3DDeactivationMode : public System.Enum
Members
Member | Description
ExplicitDeactivation | The annotation should remain active until explicitly deactivated by a script or user action.
PageClose | The annotation should be deactivated as soon as the page is closed.
PageInvisible | The annotation should be deactivated as soon as the page containing the annotation becomes invisible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DDeactivationMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DDeactivationState Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DDeactivationState Enumeration
Supported states upon 3D annotation deactivation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DDeactivationState
   Inherits System.Enum
'Usage

Dim instance As Pdf3DDeactivationState
public enum Pdf3DDeactivationState : System.Enum
public enum class Pdf3DDeactivationState : public System.Enum
Members
Member | Description
Instantiated | Instantiated.
Live | Live.
Uninstantiated | Uninstantiated.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DDeactivationState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DLightingStyle Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DLightingStyle Enumeration
Supported lighting styles.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DLightingStyle
   Inherits System.Enum
'Usage

Dim instance As Pdf3DLightingStyle
public enum Pdf3DLightingStyle : System.Enum
public enum class Pdf3DLightingStyle : public System.Enum
Members
Member | Description
Artwork | Lights as specified in the 3D artwork.
Blue | Three blue infinite lights, no ambient term.
CAD | Three grey infinite lights and one light attached to the camera, no ambient term.
Cube | Six grey infinite lights aligned with the major axes, no ambient term.
Day | Three light-grey infinite lights, no ambient term.
Hard | Three grey infinite lights, moderate ambient term.
Headlamp | Single infinite light attached to the camera, low ambient term.
Night | One yellow, one aqua, and one blue infinite light, no ambient term.
None | No lights are used.
Primary | One red, one green, and one blue infinite light, no ambient term.
Red | Three red infinite lights, no ambient term.
White | Three blue-grey infinite lights, no ambient term.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DLightingStyle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DProjectionClippingStyle Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DProjectionClippingStyle Enumeration
Supported clipping styles.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DProjectionClippingStyle
   Inherits System.Enum
'Usage

Dim instance As Pdf3DProjectionClippingStyle
public enum Pdf3DProjectionClippingStyle : System.Enum
public enum class Pdf3DProjectionClippingStyle : public System.Enum
Members
Member | Description
AutomaticNearFar | Automatic near/far.
ExplicitNearFar | Explicit near/far.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DProjectionClippingStyle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DProjectionOrthoScaleStrategy Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DProjectionOrthoScaleStrategy Enumeration
Supported orthographic scaling strategies.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DProjectionOrthoScaleStrategy
   Inherits System.Enum
'Usage

Dim instance As Pdf3DProjectionOrthoScaleStrategy
public enum Pdf3DProjectionOrthoScaleStrategy : System.Enum
public enum class Pdf3DProjectionOrthoScaleStrategy : public System.Enum
Members
Member | Description
Absolute | No scaling should occur due to binding.
Height | Scale to fit the height of the annotation.
Max | Scale to fit the greater of width or height of the annotation.
Min | Scale to fit the lesser of width or height of the annotation.
Width | Scale to fit the width of the annotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DProjectionOrthoScaleStrategy

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DProjectionType Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DProjectionType Enumeration
Supported projection types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DProjectionType
   Inherits System.Enum
'Usage

Dim instance As Pdf3DProjectionType
public enum Pdf3DProjectionType : System.Enum
public enum class Pdf3DProjectionType : public System.Enum
Members
Member | Description
Orthographic | Orthographic.
Perspective | Perspective.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DProjectionType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DRenderingMode Enumeration

Xfinium.Pdf.Annotations Namespace : Pdf3DRenderingMode Enumeration
Supported modes for rendering the 3D images.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf3DRenderingMode
   Inherits System.Enum
'Usage

Dim instance As Pdf3DRenderingMode
public enum Pdf3DRenderingMode : System.Enum
public enum class Pdf3DRenderingMode : public System.Enum
Members
Member | Description
BoundingBox | Displays the bounding box edges of each node. The color of the bounding box edges is determined by the auxiliary color.
HiddenWireframe | Displays edges in a single color, though removes back-facing and obscured edges. The color of these edges is determined by the auxiliary color.
Illustration | Displays silhouette edges with surfaces, removes obscured lines. The color of these edges is determined by the auxiliary color, and the color of the surfaces is determined by the face color.
ShadedIllustration | Displays silhouette edges with lit and textured surfaces and an additional emissive term to remove poorly lit areas of the artwork. The color of these edges is determined by the auxiliary color.
ShadedVertices | Displays only vertices, though uses their vertex color and applies lighting. The auxiliary color is ignored.
ShadedWireframe | Displays only edges and applies lighting. The auxiliary color is ignored.
Solid | Displays textured and lit geometric shapes. The auxiliary color is ignored.
SolidOutline | Displays silhouette edges with lit and textured surfaces, removes obscured lines. The color of these edges is determined by the auxiliary color.
SolidWireframe | Displays textured and lit geometric shapes (triangles) with single color edges on top of them. The color of these edges is determined by the auxiliary color.
Transparent | Displays textured and lit geometric shapes (triangles) with an added level of transparency. The auxiliary color is ignored.
TransparentBoundingBox | Displays bounding boxes faces of each node with an added level of transparency. The color of the bounding box faces is determined by the face color.
TransparentBoundingBoxOutline | Displays bounding boxes edges and faces of each node with an added level of transparency. The color of the bounding box edges is determined by the auxiliary color. The color of the bounding boxes faces is determined by the face color.
TransparentWireframe | Displays textured and lit geometric shapes (triangles) with an added level of transparency, with single color opaque edges on top of it. The color of these edges is determined by the auxiliary color.
Vertices | Displays only vertices in a single color. The color of these points is determined by the auxiliary color.
Wireframe | Displays only edges in a single color. The color of these edges is determined by the auxiliary color.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.Pdf3DRenderingMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfAnnotationType Enumeration

Xfinium.Pdf.Annotations Namespace : PdfAnnotationType Enumeration
Supported annotation types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfAnnotationType
   Inherits System.Enum
'Usage

Dim instance As PdfAnnotationType
public enum PdfAnnotationType : System.Enum
public enum class PdfAnnotationType : public System.Enum
Members
Member | Description
_3D | 3D annotation.
Circle | Circle annotation.
FileAttachment | File attachment annotation.
FreeText | Free text annotation.
Ink | Ink annotation.
Line | Line annotation.
Link | Link annotation.
Polygon | Polygon annotation.
Polyline | Polyline annotation.
Redaction | Redaction annotation.
RichMedia | Rich media annotation.
RubberStamp | Rubber stamp annotation.
Screen | Screen annotation.
Sound | Sound annotation.
Square | Square annotation.
Text | Text annotation.
TextMarkup | Text markup annotation (highlight, underline, strikeout or squiggly).
Unknown | Unknown annotation.
Widget | Field widget annotation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfAnnotationType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfLineEndSymbol Enumeration

Xfinium.Pdf.Annotations Namespace : PdfLineEndSymbol Enumeration
Supported symbols to end a line annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfLineEndSymbol
   Inherits System.Enum
'Usage

Dim instance As PdfLineEndSymbol
public enum PdfLineEndSymbol : System.Enum
public enum class PdfLineEndSymbol : public System.Enum
Members
Member | Description
Circle | A circle filled with annotation's interior color, if any.
ClosedArrow | Two short lines meeting in an acute angle as in the OpenArrow style, connected by a third line to form a triangular closed arrowhead filled with annotation's interior color, if any.
None | No line ending.
OpenArrow | Two short lines meeting in an acute angle, forming a open arrow head.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfLineEndSymbol

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfLinkAnnotationHighlightStyle Enumeration

Xfinium.Pdf.Annotations Namespace : PdfLinkAnnotationHighlightStyle Enumeration
Supported link highlight styles.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfLinkAnnotationHighlightStyle
   Inherits System.Enum
'Usage

Dim instance As PdfLinkAnnotationHighlightStyle
public enum PdfLinkAnnotationHighlightStyle : System.Enum
public enum class PdfLinkAnnotationHighlightStyle : public System.Enum
Members
Member | Description
Invert | Inverts the content of link's normal appearance.
None | No highlighting, the link's appearance does not change when the link is activated.
Outline | Inverts the link's border.
Push | Displays the link's down appearance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfLinkAnnotationHighlightStyle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaActivationCondition Enumeration

Xfinium.Pdf.Annotations Namespace : PdfRichMediaActivationCondition Enumeration
Suported conditions for rich media annotation activation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfRichMediaActivationCondition
   Inherits System.Enum
'Usage

Dim instance As PdfRichMediaActivationCondition
public enum PdfRichMediaActivationCondition : System.Enum
public enum class PdfRichMediaActivationCondition : public System.Enum
Members
Member | Description
ExplicitActivation | The annotation is explicitly activated by a user action or script.
PageOpen | The annotation is activated as soon as the page that contains the annotation receives focus as the current page.
PageVisible | The annotation is activated as soon as any part of the page that contains the annotation becomes visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfRichMediaActivationCondition

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaDeactivationCondition Enumeration

Xfinium.Pdf.Annotations Namespace : PdfRichMediaDeactivationCondition Enumeration
Suported conditions for rich media annotation deactivation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfRichMediaDeactivationCondition
   Inherits System.Enum
'Usage

Dim instance As PdfRichMediaDeactivationCondition
public enum PdfRichMediaDeactivationCondition : System.Enum
public enum class PdfRichMediaDeactivationCondition : public System.Enum
Members
Member | Description
ExplicitDeactivation | The annotation is explicitly deactivated by a user action or script.
PageClose | The annotation is deactivated as soon as the page that contains the annotation loses focus as the current page.
PageInvisible | The annotation is deactivated as soon as the entire page that contains the annotation is no longer visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfRichMediaDeactivationCondition

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaType Enumeration

Xfinium.Pdf.Annotations Namespace : PdfRichMediaType Enumeration
Specifies the supported rich media types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfRichMediaType
   Inherits System.Enum
'Usage

Dim instance As PdfRichMediaType
public enum PdfRichMediaType : System.Enum
public enum class PdfRichMediaType : public System.Enum
Members
Member | Description
Flash | Flash content.
Sound | Sound content.
ThreeD | 3D content.
Unknown | Unknown content type.
Video | Video content.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfRichMediaType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfSoundAnnotationDataEncoding Enumeration

Xfinium.Pdf.Annotations Namespace : PdfSoundAnnotationDataEncoding Enumeration
Supported encoding formats for sound data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfSoundAnnotationDataEncoding
   Inherits System.Enum
'Usage

Dim instance As PdfSoundAnnotationDataEncoding
public enum PdfSoundAnnotationDataEncoding : System.Enum
public enum class PdfSoundAnnotationDataEncoding : public System.Enum
Members
Member | Description
ALaw | A-law–encoded samples
MuLaw | µ-law–encoded samples
Raw | Unspecified or unsigned values in the range 0 to 2BitsPerSample − 1
Signed | Twos-complement values
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfSoundAnnotationDataEncoding

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfTextAnnotationState Enumeration

Xfinium.Pdf.Annotations Namespace : PdfTextAnnotationState Enumeration
Supported states for text annotations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfTextAnnotationState
   Inherits System.Enum
'Usage

Dim instance As PdfTextAnnotationState
public enum PdfTextAnnotationState : System.Enum
public enum class PdfTextAnnotationState : public System.Enum
Members
Member | Description
Accepted | The user agrees with the change.
Cancelled | The change has been cancelled.
Completed | The change has been completed.
Marked | The annotation has been marked by the user.
None | The user has indicated nothing about the change.
NoState | No state has been associated with the annotation.
Rejected | The user disagrees with the change.
Unmarked | The annotation has not been marked by the user.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfTextAnnotationState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfTextMarkupAnnotationType Enumeration

Xfinium.Pdf.Annotations Namespace : PdfTextMarkupAnnotationType Enumeration
Supported text markup annotations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfTextMarkupAnnotationType
   Inherits System.Enum
'Usage

Dim instance As PdfTextMarkupAnnotationType
public enum PdfTextMarkupAnnotationType : System.Enum
public enum class PdfTextMarkupAnnotationType : public System.Enum
Members
Member | Description
Highlight | Highlight.
Squiggly | Jagged underline.
StrikeOut | Strike out.
Underline | Underline.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Annotations.PdfTextMarkupAnnotationType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Annotations Namespace


Xfinium.Pdf.Content Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfBatesNumber | Handles operations related to Bates numbers.
Class | PdfBatesNumberAppearance | Defines the appearance of a Bates number that will be stamped on document's pages.
Class | PdfBatesNumberProvider | Defines a Bates number provider.
Class | PdfContentExtractionContext | Defines a context for content extraction operations.
Class | PdfContentExtractor | Defines an extractor for various type of content from Pdf pages.
Class | PdfFormXObjectVisualObject | Defines a visual object that represents a form XObject displayed on the PDF page.
Class | PdfImageVisualObject | Defines a visual object that represents an image displayed on the PDF page.
Class | PdfPageOptionalContent | Defines the graphic optional content of a PDF page.
Class | PdfPathItem | Defines an item in a PdfPathVisualObject.
Class | PdfPathItemCollection | Defines a collection of items that compose a PDF path displayed on a PDF page.
Class | PdfPathVisualObject | Defines a visual object that represents a PDF path displayed on the PDF page.
Class | PdfShadingVisualObject | Defines a visual object that represents a form XObject displayed on the PDF page.
Class | PdfTextFragment | Defines a fragment of text displayed on a Pdf page.
Class | PdfTextFragmentCollection | Defines a collection of text fragments on the Pdf page.
Class | PdfTextGlyph | Defines a glyph drawn on the Pdf page.
Class | PdfTextGlyphCollection | Defines a collection of glyphs in a text fragment.
Class | PdfTextSearchResult | Defines the result returned by a text search operation.
Class | PdfTextSearchResultCollection | Defines a collection of results returned by a text search operation.
Class | PdfTextVisualObject | Defines a visual object that represents a text fragment displayed on the PDF page.
Class | PdfTextWord | Defines the a word returned by a text extraction operation.
Class | PdfTextWordCollection | Defines a collection of words returned by a text extraction operation.
Class | PdfVisualImage | Defines an image that displayed on a PDF page.
Class | PdfVisualImageCollection | Defines a collection of images that are displayed on a PDF page.
Class | PdfVisualObject | Defines the base class for visual objects displayed on a PDF page.
Class | PdfVisualObjectCollection | Defines a collection of visual objects that are displayed on a PDF page.
Class | PdfVisualObjectGraphicsState | Defines the graphics state that is in place when the visual object is displayed on the page.
Enumerations
 | Enumeration | Description
Enumeration | PdfPathItemType | Specifies the supported types for the items in a PdfPathVisualObject.
Enumeration | PdfTextSearchOptions | Supported options when searching text in PDF pages.
Enumeration | PdfVisualImageFormat | Specifies the supported formats for images displayed on a PDF page.
Enumeration | PdfVisualImageSaveFormat | Specifies the supported formats for saving a visual image.
Enumeration | PdfVisualObjectType | Supported visual objects.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Content Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Content.PdfPathItemCollection
Xfinium.Pdf.Content.PdfTextFragmentCollection
Xfinium.Pdf.Content.PdfTextGlyphCollection
Xfinium.Pdf.Content.PdfTextSearchResultCollection
Xfinium.Pdf.Content.PdfTextWordCollection
Xfinium.Pdf.Content.PdfVisualImageCollection
Xfinium.Pdf.Content.PdfVisualObjectCollection
Xfinium.Pdf.Content.PdfBatesNumber
Xfinium.Pdf.Content.PdfBatesNumberAppearance
Xfinium.Pdf.Content.PdfBatesNumberProvider
Xfinium.Pdf.Content.PdfContentExtractionContext
Xfinium.Pdf.Content.PdfContentExtractor
Xfinium.Pdf.Content.PdfPathItem
Xfinium.Pdf.Content.PdfTextFragment
Xfinium.Pdf.Content.PdfTextGlyph
Xfinium.Pdf.Content.PdfTextSearchResult
Xfinium.Pdf.Content.PdfTextWord
Xfinium.Pdf.Content.PdfVisualImage
Xfinium.Pdf.Content.PdfVisualObject
Xfinium.Pdf.Content.PdfFormXObjectVisualObject
Xfinium.Pdf.Content.PdfImageVisualObject
Xfinium.Pdf.Content.PdfPathVisualObject
Xfinium.Pdf.Content.PdfShadingVisualObject
Xfinium.Pdf.Content.PdfTextVisualObject
Xfinium.Pdf.Content.PdfVisualObjectGraphicsState
Xfinium.Pdf.PdfContentStreamContainer
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Graphics.PdfPageContent
Xfinium.Pdf.Content.PdfPageOptionalContent
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfBatesNumber Class
Members

Xfinium.Pdf.Content Namespace : PdfBatesNumber Class
Handles operations related to Bates numbers.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBatesNumber
'Usage

Dim instance As PdfBatesNumber
public class PdfBatesNumber
public ref class PdfBatesNumber
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfBatesNumber

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumber Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfBatesNumber Class Members
Methods

Xfinium.Pdf.Content Namespace : PdfBatesNumber Class

The following tables list the members exposed by PdfBatesNumber.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ReadBatesNumber | Reads the Bates number stamped on the page.
static (Shared in Visual Basic) | RemoveBatesNumber | Removes the Bates number from the PDF page.
static (Shared in Visual Basic) | WriteBatesNumber | Stamps the document pages with Bates numbers.
Top
See Also

Reference

PdfBatesNumber Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfBatesNumber Class Methods

Xfinium.Pdf.Content Namespace : PdfBatesNumber Class

For a list of all members of this type, see PdfBatesNumber members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ReadBatesNumber | Reads the Bates number stamped on the page.
static (Shared in Visual Basic) | RemoveBatesNumber | Removes the Bates number from the PDF page.
static (Shared in Visual Basic) | WriteBatesNumber | Stamps the document pages with Bates numbers.
Top
See Also

Reference

PdfBatesNumber Class
Xfinium.Pdf.Content Namespace


ReadBatesNumber Method

Xfinium.Pdf.Content Namespace > PdfBatesNumber Class : ReadBatesNumber Method
The page to read the Bates number from.
Reads the Bates number stamped on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function ReadBatesNumber( _
   ByVal page As PdfPage _
) As String
'Usage

Dim page As PdfPage
Dim value As String

value = PdfBatesNumber.ReadBatesNumber(page)
public static string ReadBatesNumber(
   PdfPage page
)
public:
static String^ ReadBatesNumber(
   PdfPage^ page
)

Parameters

page
The page to read the Bates number from.

Return Value

The last Bates number stamped on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumber Class
PdfBatesNumber Members


RemoveBatesNumber Method

Xfinium.Pdf.Content Namespace > PdfBatesNumber Class : RemoveBatesNumber Method
The page from which the Bates number is removed.
Removes the Bates number from the PDF page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub RemoveBatesNumber( _
   ByVal page As PdfPage _
)
'Usage

Dim page As PdfPage

PdfBatesNumber.RemoveBatesNumber(page)
public static void RemoveBatesNumber(
   PdfPage page
)
public:
static void RemoveBatesNumber(
   PdfPage^ page
)

Parameters

page
The page from which the Bates number is removed.
Remarks
This method removes all the content beetween the tags that mark a Bates number. If other content is also present between these tags, it will also be removed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumber Class
PdfBatesNumber Members


WriteBatesNumber Method

Xfinium.Pdf.Content Namespace > PdfBatesNumber Class : WriteBatesNumber Method
The document to be stamped.
The provider for the Bates numbers for each page in the document.
The appearance of the Bates number on the page.
Stamps the document pages with Bates numbers.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub WriteBatesNumber( _
   ByVal document As PdfFixedDocument, _
   ByVal batesNumberProvider As PdfBatesNumberProvider, _
   ByVal batesNumberAppearance As PdfBatesNumberAppearance _
)
'Usage

Dim document As PdfFixedDocument
Dim batesNumberProvider As PdfBatesNumberProvider
Dim batesNumberAppearance As PdfBatesNumberAppearance

PdfBatesNumber.WriteBatesNumber(document, batesNumberProvider, batesNumberAppearance)
public static void WriteBatesNumber(
   PdfFixedDocument document,
   PdfBatesNumberProvider batesNumberProvider,
   PdfBatesNumberAppearance batesNumberAppearance
)
public:
static void WriteBatesNumber(
   PdfFixedDocument^ document,
   PdfBatesNumberProvider^ batesNumberProvider,
   PdfBatesNumberAppearance^ batesNumberAppearance
)

Parameters

document
The document to be stamped.
batesNumberProvider
The provider for the Bates numbers for each page in the document.
batesNumberAppearance
The appearance of the Bates number on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumber Class
PdfBatesNumber Members


%%PageItemTitle%%

PdfBatesNumberAppearance Class
Members

Xfinium.Pdf.Content Namespace : PdfBatesNumberAppearance Class
Defines the appearance of a Bates number that will be stamped on document's pages.
Object Model
PdfBatesNumberAppearance ClassPdfBrush ClassPdfFont ClassPdfPoint Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBatesNumberAppearance
'Usage

Dim instance As PdfBatesNumberAppearance
public class PdfBatesNumberAppearance
public ref class PdfBatesNumberAppearance
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfBatesNumberAppearance

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberAppearance Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfBatesNumberAppearance Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfBatesNumberAppearance Class

The following tables list the members exposed by PdfBatesNumberAppearance.

Public Constructors
 | Name | Description
Public Constructor | PdfBatesNumberAppearance Constructor | Initializes a new PdfBatesNumberAppearance object.
Top
Public Properties
 | Name | Description
Public Property | Brush | Gets or sets the brush.
Public Property | Font | Gets or sets the font.
Public Property | HorizontalAlign | Gets or sets the horizontal alignment.
Public Property | Location | Gets or sets the location.
Public Property | VerticalAlign | Gets or sets the vertical alignment.
Top
See Also

Reference

PdfBatesNumberAppearance Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfBatesNumberAppearance Constructor

Xfinium.Pdf.Content Namespace > PdfBatesNumberAppearance Class : PdfBatesNumberAppearance Constructor
Initializes a new PdfBatesNumberAppearance object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfBatesNumberAppearance()
public PdfBatesNumberAppearance()
public:
PdfBatesNumberAppearance();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberAppearance Class
PdfBatesNumberAppearance Members


%%PageItemTitle%% $$Properties$$

PdfBatesNumberAppearance Class Properties

Xfinium.Pdf.Content Namespace : PdfBatesNumberAppearance Class

For a list of all members of this type, see PdfBatesNumberAppearance members.

Public Properties
 | Name | Description
Public Property | Brush | Gets or sets the brush.
Public Property | Font | Gets or sets the font.
Public Property | HorizontalAlign | Gets or sets the horizontal alignment.
Public Property | Location | Gets or sets the location.
Public Property | VerticalAlign | Gets or sets the vertical alignment.
Top
See Also

Reference

PdfBatesNumberAppearance Class
Xfinium.Pdf.Content Namespace


Brush Property (PdfBatesNumberAppearance)

Xfinium.Pdf.Content Namespace > PdfBatesNumberAppearance Class : Brush Property
Gets or sets the brush.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Brush As PdfBrush
'Usage

Dim instance As PdfBatesNumberAppearance
Dim value As PdfBrush

instance.Brush = value

value = instance.Brush
public PdfBrush Brush {get; set;}
public:
property PdfBrush^ Brush {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

The brush used to draw the Bates number on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberAppearance Class
PdfBatesNumberAppearance Members


Font Property (PdfBatesNumberAppearance)

Xfinium.Pdf.Content Namespace > PdfBatesNumberAppearance Class : Font Property
Gets or sets the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As PdfFont
'Usage

Dim instance As PdfBatesNumberAppearance
Dim value As PdfFont

instance.Font = value

value = instance.Font
public PdfFont Font {get; set;}
public:
property PdfFont^ Font {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

The font used to draw the Bates number.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberAppearance Class
PdfBatesNumberAppearance Members


HorizontalAlign Property (PdfBatesNumberAppearance)

Xfinium.Pdf.Content Namespace > PdfBatesNumberAppearance Class : HorizontalAlign Property
Gets or sets the horizontal alignment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalAlign As PdfStringHorizontalAlign
'Usage

Dim instance As PdfBatesNumberAppearance
Dim value As PdfStringHorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
public PdfStringHorizontalAlign HorizontalAlign {get; set;}
public:
property PdfStringHorizontalAlign HorizontalAlign {
   PdfStringHorizontalAlign get();
   void set (    PdfStringHorizontalAlign value);
}

Property Value

The horizontal alignment of the Bates number.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberAppearance Class
PdfBatesNumberAppearance Members


Location Property (PdfBatesNumberAppearance)

Xfinium.Pdf.Content Namespace > PdfBatesNumberAppearance Class : Location Property
Gets or sets the location.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Location As PdfPoint
'Usage

Dim instance As PdfBatesNumberAppearance
Dim value As PdfPoint

instance.Location = value

value = instance.Location
public PdfPoint Location {get; set;}
public:
property PdfPoint^ Location {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The location of the Bates number on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberAppearance Class
PdfBatesNumberAppearance Members


VerticalAlign Property (PdfBatesNumberAppearance)

Xfinium.Pdf.Content Namespace > PdfBatesNumberAppearance Class : VerticalAlign Property
Gets or sets the vertical alignment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VerticalAlign As PdfStringVerticalAlign
'Usage

Dim instance As PdfBatesNumberAppearance
Dim value As PdfStringVerticalAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
public PdfStringVerticalAlign VerticalAlign {get; set;}
public:
property PdfStringVerticalAlign VerticalAlign {
   PdfStringVerticalAlign get();
   void set (    PdfStringVerticalAlign value);
}

Property Value

The vertical alignment of the Bates number.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberAppearance Class
PdfBatesNumberAppearance Members


%%PageItemTitle%%

PdfBatesNumberProvider Class
Members

Xfinium.Pdf.Content Namespace : PdfBatesNumberProvider Class
Defines a Bates number provider.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBatesNumberProvider
'Usage

Dim instance As PdfBatesNumberProvider
public class PdfBatesNumberProvider
public ref class PdfBatesNumberProvider
Remarks
The Bates number provider will generate an actual Bates number for each page based on its properties.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfBatesNumberProvider

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberProvider Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfBatesNumberProvider Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfBatesNumberProvider Class

The following tables list the members exposed by PdfBatesNumberProvider.

Public Constructors
 | Name | Description
Public Constructor | PdfBatesNumberProvider Constructor | Initializes a new PdfBatesNumberProvider object.
Top
Public Properties
 | Name | Description
Public Property | NumberOfDigits | Gets or sets the number of digits.
Public Property | Prefix | Gets or sets the prefix.
Public Property | StartNumber | Gets or sets the start number.
Public Property | Suffix | Gets or sets the suffix.
Top
See Also

Reference

PdfBatesNumberProvider Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfBatesNumberProvider Constructor

Xfinium.Pdf.Content Namespace > PdfBatesNumberProvider Class : PdfBatesNumberProvider Constructor
Initializes a new PdfBatesNumberProvider object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfBatesNumberProvider()
public PdfBatesNumberProvider()
public:
PdfBatesNumberProvider();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberProvider Class
PdfBatesNumberProvider Members


%%PageItemTitle%% $$Properties$$

PdfBatesNumberProvider Class Properties

Xfinium.Pdf.Content Namespace : PdfBatesNumberProvider Class

For a list of all members of this type, see PdfBatesNumberProvider members.

Public Properties
 | Name | Description
Public Property | NumberOfDigits | Gets or sets the number of digits.
Public Property | Prefix | Gets or sets the prefix.
Public Property | StartNumber | Gets or sets the start number.
Public Property | Suffix | Gets or sets the suffix.
Top
See Also

Reference

PdfBatesNumberProvider Class
Xfinium.Pdf.Content Namespace


NumberOfDigits Property

Xfinium.Pdf.Content Namespace > PdfBatesNumberProvider Class : NumberOfDigits Property
Gets or sets the number of digits.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NumberOfDigits As Integer
'Usage

Dim instance As PdfBatesNumberProvider
Dim value As Integer

instance.NumberOfDigits = value

value = instance.NumberOfDigits
public int NumberOfDigits {get; set;}
public:
property int NumberOfDigits {
   int get();
   void set (    int value);
}

Property Value

The number of digits, including the leading zeros, for representing the Bates number.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberProvider Class
PdfBatesNumberProvider Members


Prefix Property (PdfBatesNumberProvider)

Xfinium.Pdf.Content Namespace > PdfBatesNumberProvider Class : Prefix Property
Gets or sets the prefix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Prefix As String
'Usage

Dim instance As PdfBatesNumberProvider
Dim value As String

instance.Prefix = value

value = instance.Prefix
public string Prefix {get; set;}
public:
property String^ Prefix {
   String^ get();
   void set (    String^ value);
}

Property Value

An optional prefix to be displayed in front of the Bates number.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberProvider Class
PdfBatesNumberProvider Members


StartNumber Property

Xfinium.Pdf.Content Namespace > PdfBatesNumberProvider Class : StartNumber Property
Gets or sets the start number.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartNumber As Integer
'Usage

Dim instance As PdfBatesNumberProvider
Dim value As Integer

instance.StartNumber = value

value = instance.StartNumber
public int StartNumber {get; set;}
public:
property int StartNumber {
   int get();
   void set (    int value);
}

Property Value

The start number to be used on first stamped page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberProvider Class
PdfBatesNumberProvider Members


Suffix Property (PdfBatesNumberProvider)

Xfinium.Pdf.Content Namespace > PdfBatesNumberProvider Class : Suffix Property
Gets or sets the suffix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Suffix As String
'Usage

Dim instance As PdfBatesNumberProvider
Dim value As String

instance.Suffix = value

value = instance.Suffix
public string Suffix {get; set;}
public:
property String^ Suffix {
   String^ get();
   void set (    String^ value);
}

Property Value

An optional suffix to be displayed at the end of the Bates number.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBatesNumberProvider Class
PdfBatesNumberProvider Members


%%PageItemTitle%%

PdfContentExtractionContext Class
Members

Xfinium.Pdf.Content Namespace : PdfContentExtractionContext Class
Defines a context for content extraction operations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfContentExtractionContext
'Usage

Dim instance As PdfContentExtractionContext
public class PdfContentExtractionContext
public ref class PdfContentExtractionContext
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfContentExtractionContext

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractionContext Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfContentExtractionContext Class Members

Xfinium.Pdf.Content Namespace : PdfContentExtractionContext Class

The following tables list the members exposed by PdfContentExtractionContext.

Public Constructors
 | Name | Description
Public Constructor | PdfContentExtractionContext Constructor | Initializes a new PdfContentExtractionContext object.
Top
See Also

Reference

PdfContentExtractionContext Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfContentExtractionContext Constructor

Xfinium.Pdf.Content Namespace > PdfContentExtractionContext Class : PdfContentExtractionContext Constructor
Initializes a new PdfContentExtractionContext object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfContentExtractionContext()
public PdfContentExtractionContext()
public:
PdfContentExtractionContext();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractionContext Class
PdfContentExtractionContext Members


%%PageItemTitle%%

PdfContentExtractor Class
Members

Xfinium.Pdf.Content Namespace : PdfContentExtractor Class
Defines an extractor for various type of content from Pdf pages.
Object Model
PdfContentExtractor ClassPdfEncodingCollection ClassPdfEncoding Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfContentExtractor
'Usage

Dim instance As PdfContentExtractor
public class PdfContentExtractor
public ref class PdfContentExtractor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfContentExtractor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfContentExtractor Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfContentExtractor Class

The following tables list the members exposed by PdfContentExtractor.

Public Constructors
 | Name | Description
Public Constructor | PdfContentExtractor Constructor | Initializes a new PdfContentExtractor object.
Top
Public Properties
 | Name | Description
Public Property | Encodings | Gets the list of additional encodings used for extracting text from Pdf files.
Top
Public Methods
 | Name | Description
Public Method | ExtractContentStreamOperators | Extracts the page content stream as a list of graphic operators with their operands.
Public Method | ExtractImages | Extracts the information related to the images displayed on the page.
Public Method | ExtractOptionalContentGroup | Extracts the content of an optional content group.
Public Method | ExtractText | Overloaded. Extracts the text from the Pdf page.
Public Method | ExtractTextFragments | Overloaded. Extracts the text fragments from the Pdf page.
Public Method | ExtractVisualObjects | Overloaded. Extracts the page content as a list of visual objects.
Public Method | ExtractWords | Overloaded. Extracts the text from the PDF page as a collection of words.
Public Method | SearchText | Overloaded. Searches the page content for the specified text.
Top
See Also

Reference

PdfContentExtractor Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfContentExtractor Constructor

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : PdfContentExtractor Constructor
The page from which content is extracted.
Initializes a new PdfContentExtractor object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As PdfPage _
)
'Usage

Dim page As PdfPage

Dim instance As New PdfContentExtractor(page)
public PdfContentExtractor(
   PdfPage page
)
public:
PdfContentExtractor(
   PdfPage^ page
)

Parameters

page
The page from which content is extracted.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


%%PageItemTitle%% $$Methods$$

PdfContentExtractor Class Methods

Xfinium.Pdf.Content Namespace : PdfContentExtractor Class

For a list of all members of this type, see PdfContentExtractor members.

Public Methods
 | Name | Description
Public Method | ExtractContentStreamOperators | Extracts the page content stream as a list of graphic operators with their operands.
Public Method | ExtractImages | Extracts the information related to the images displayed on the page.
Public Method | ExtractOptionalContentGroup | Extracts the content of an optional content group.
Public Method | ExtractText | Overloaded. Extracts the text from the Pdf page.
Public Method | ExtractTextFragments | Overloaded. Extracts the text fragments from the Pdf page.
Public Method | ExtractVisualObjects | Overloaded. Extracts the page content as a list of visual objects.
Public Method | ExtractWords | Overloaded. Extracts the text from the PDF page as a collection of words.
Public Method | SearchText | Overloaded. Searches the page content for the specified text.
Top
See Also

Reference

PdfContentExtractor Class
Xfinium.Pdf.Content Namespace


ExtractContentStreamOperators Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : ExtractContentStreamOperators Method
Extracts the page content stream as a list of graphic operators with their operands.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractContentStreamOperators() As PdfContentStreamOperatorCollection
'Usage

Dim instance As PdfContentExtractor
Dim value As PdfContentStreamOperatorCollection

value = instance.ExtractContentStreamOperators()
public PdfContentStreamOperatorCollection ExtractContentStreamOperators()
public:
PdfContentStreamOperatorCollection^ ExtractContentStreamOperators();

Return Value

The page content stream as a list of graphic operators.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


ExtractImages Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : ExtractImages Method
True if image data should be extracted and decoded.
Extracts the information related to the images displayed on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractImages( _
   ByVal includeImageData As Boolean _
) As PdfVisualImageCollection
'Usage

Dim instance As PdfContentExtractor
Dim includeImageData As Boolean
Dim value As PdfVisualImageCollection

value = instance.ExtractImages(includeImageData)
public PdfVisualImageCollection ExtractImages(
   bool includeImageData
)
public:
PdfVisualImageCollection^ ExtractImages(
   bool includeImageData
)

Parameters

includeImageData
True if image data should be extracted and decoded.

Return Value

The list of images that are displayed on the page.
Remarks
Image data should be extracted only if the images need to be saved for later processing because this operation can take a significant amount of time, depending on the number of images and how they are encoded.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


ExtractOptionalContentGroup Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : ExtractOptionalContentGroup Method
The name of the optional content group to be extracted.
Extracts the content of an optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractOptionalContentGroup( _
   ByVal ocgName As String _
) As PdfPageOptionalContent
'Usage

Dim instance As PdfContentExtractor
Dim ocgName As String
Dim value As PdfPageOptionalContent

value = instance.ExtractOptionalContentGroup(ocgName)
public PdfPageOptionalContent ExtractOptionalContentGroup(
   string ocgName
)
public:
PdfPageOptionalContent^ ExtractOptionalContentGroup(
   String^ ocgName
)

Parameters

ocgName
The name of the optional content group to be extracted.

Return Value

The optional content group if it exists.
Remarks
The optional content group is extracted as a form XObject that can be later drawn on another page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


ExtractText Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : ExtractText Method
Extracts the text from the Pdf page.
Overload List
Overload | Description
ExtractText() | Extracts the text from the Pdf page.
ExtractText(PdfContentExtractionContext) | Extracts the text from the Pdf page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


ExtractText() Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractText Method : ExtractText() Method
Extracts the text from the Pdf page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractText() As String
'Usage

Dim instance As PdfContentExtractor
Dim value As String

value = instance.ExtractText()
public string ExtractText()
public:
String^ ExtractText();

Return Value

The text on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


ExtractText(PdfContentExtractionContext) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractText Method : ExtractText(PdfContentExtractionContext) Method
Context for text extraction.
Extracts the text from the Pdf page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractText( _
   ByVal context As PdfContentExtractionContext _
) As String
'Usage

Dim instance As PdfContentExtractor
Dim context As PdfContentExtractionContext
Dim value As String

value = instance.ExtractText(context)
public string ExtractText(
   PdfContentExtractionContext context
)
public:
String^ ExtractText(
   PdfContentExtractionContext^ context
)

Parameters

context
Context for text extraction.

Return Value

The text on the page.
Remarks
When extracting text from multiple pages of the same document the same context object should be used with all ExtractText method calls.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


ExtractTextFragments Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : ExtractTextFragments Method
Extracts the text fragments from the Pdf page.
Overload List
Overload | Description
ExtractTextFragments() | Extracts the text fragments from the Pdf page.
ExtractTextFragments(PdfContentExtractionContext) | Extracts the text fragments from the Pdf page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


ExtractTextFragments() Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractTextFragments Method : ExtractTextFragments() Method
Extracts the text fragments from the Pdf page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractTextFragments() As PdfTextFragmentCollection
'Usage

Dim instance As PdfContentExtractor
Dim value As PdfTextFragmentCollection

value = instance.ExtractTextFragments()
public PdfTextFragmentCollection ExtractTextFragments()
public:
PdfTextFragmentCollection^ ExtractTextFragments();

Return Value

The list of text fragments in the order they appear in the page content stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


ExtractTextFragments(PdfContentExtractionContext) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractTextFragments Method : ExtractTextFragments(PdfContentExtractionContext) Method
Context for text extraction.
Extracts the text fragments from the Pdf page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractTextFragments( _
   ByVal context As PdfContentExtractionContext _
) As PdfTextFragmentCollection
'Usage

Dim instance As PdfContentExtractor
Dim context As PdfContentExtractionContext
Dim value As PdfTextFragmentCollection

value = instance.ExtractTextFragments(context)
public PdfTextFragmentCollection ExtractTextFragments(
   PdfContentExtractionContext context
)
public:
PdfTextFragmentCollection^ ExtractTextFragments(
   PdfContentExtractionContext^ context
)

Parameters

context
Context for text extraction.

Return Value

The list of text fragments in the order they appear in the page content stream.
Remarks
When extracting text from multiple pages of the same document the same context object should be used with all ExtractTextFragments method calls.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


ExtractVisualObjects Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : ExtractVisualObjects Method
Extracts the page content as a list of visual objects.
Overload List
Overload | Description
ExtractVisualObjects(Boolean) | Extracts the page content as a list of visual objects.
ExtractVisualObjects(Boolean,Boolean) | Extracts the page content as a list of visual objects.
ExtractVisualObjects(Boolean,Boolean,PdfContentExtractionContext) | Extracts the page content as a list of visual objects.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


ExtractVisualObjects(Boolean) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractVisualObjects Method : ExtractVisualObjects(Boolean) Method
True if image data should be extracted and decoded.
Extracts the page content as a list of visual objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractVisualObjects( _
   ByVal includeImageData As Boolean _
) As PdfVisualObjectCollection
'Usage

Dim instance As PdfContentExtractor
Dim includeImageData As Boolean
Dim value As PdfVisualObjectCollection

value = instance.ExtractVisualObjects(includeImageData)
public PdfVisualObjectCollection ExtractVisualObjects(
   bool includeImageData
)
public:
PdfVisualObjectCollection^ ExtractVisualObjects(
   bool includeImageData
)

Parameters

includeImageData
True if image data should be extracted and decoded.

Return Value

The list of visual objects that are displayed on the page.
Remarks
Image data should be extracted only if the images need to be saved for later processing because this operation can take a significant amount of time, depending on the number of images and how they are encoded.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


ExtractVisualObjects(Boolean,Boolean) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractVisualObjects Method : ExtractVisualObjects(Boolean,Boolean) Method
True if image data should be extracted and decoded.
True if the list of objects should preserve the graphic containers such as form XObjects.
Extracts the page content as a list of visual objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractVisualObjects( _
   ByVal includeImageData As Boolean, _
   ByVal keepGraphicContainers As Boolean _
) As PdfVisualObjectCollection
'Usage

Dim instance As PdfContentExtractor
Dim includeImageData As Boolean
Dim keepGraphicContainers As Boolean
Dim value As PdfVisualObjectCollection

value = instance.ExtractVisualObjects(includeImageData, keepGraphicContainers)
public PdfVisualObjectCollection ExtractVisualObjects(
   bool includeImageData,
   bool keepGraphicContainers
)
public:
PdfVisualObjectCollection^ ExtractVisualObjects(
   bool includeImageData,
   bool keepGraphicContainers
)

Parameters

includeImageData
True if image data should be extracted and decoded.
keepGraphicContainers
True if the list of objects should preserve the graphic containers such as form XObjects.

Return Value

The list of visual objects that are displayed on the page.
Remarks
Image data should be extracted only if the images need to be saved for later processing because this operation can take a significant amount of time, depending on the number of images and how they are encoded.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


ExtractVisualObjects(Boolean,Boolean,PdfContentExtractionContext) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractVisualObjects Method : ExtractVisualObjects(Boolean,Boolean,PdfContentExtractionContext) Method
True if image data should be extracted and decoded.
True if the list of objects should preserve the graphic containers such as form XObjects.
Context for content extraction
Extracts the page content as a list of visual objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractVisualObjects( _
   ByVal includeImageData As Boolean, _
   ByVal keepGraphicContainers As Boolean, _
   ByVal context As PdfContentExtractionContext _
) As PdfVisualObjectCollection
'Usage

Dim instance As PdfContentExtractor
Dim includeImageData As Boolean
Dim keepGraphicContainers As Boolean
Dim context As PdfContentExtractionContext
Dim value As PdfVisualObjectCollection

value = instance.ExtractVisualObjects(includeImageData, keepGraphicContainers, context)
public PdfVisualObjectCollection ExtractVisualObjects(
   bool includeImageData,
   bool keepGraphicContainers,
   PdfContentExtractionContext context
)
public:
PdfVisualObjectCollection^ ExtractVisualObjects(
   bool includeImageData,
   bool keepGraphicContainers,
   PdfContentExtractionContext^ context
)

Parameters

includeImageData
True if image data should be extracted and decoded.
keepGraphicContainers
True if the list of objects should preserve the graphic containers such as form XObjects.
context
Context for content extraction

Return Value

The list of visual objects that are displayed on the page.
Remarks
Image data should be extracted only if the images need to be saved for later processing because this operation can take a significant amount of time, depending on the number of images and how they are encoded.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


ExtractWords Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : ExtractWords Method
Extracts the text from the PDF page as a collection of words.
Overload List
Overload | Description
ExtractWords() | Extracts the text from the PDF page as a collection of words.
ExtractWords(PdfContentExtractionContext) | Extracts the text from the PDF page as a collection of words.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


ExtractWords() Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractWords Method : ExtractWords() Method
Extracts the text from the PDF page as a collection of words.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractWords() As PdfTextWordCollection
'Usage

Dim instance As PdfContentExtractor
Dim value As PdfTextWordCollection

value = instance.ExtractWords()
public PdfTextWordCollection ExtractWords()
public:
PdfTextWordCollection^ ExtractWords();

Return Value

A collection of words on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


ExtractWords(PdfContentExtractionContext) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > ExtractWords Method : ExtractWords(PdfContentExtractionContext) Method
Context for text extraction.
Extracts the text from the PDF page as a collection of words.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractWords( _
   ByVal context As PdfContentExtractionContext _
) As PdfTextWordCollection
'Usage

Dim instance As PdfContentExtractor
Dim context As PdfContentExtractionContext
Dim value As PdfTextWordCollection

value = instance.ExtractWords(context)
public PdfTextWordCollection ExtractWords(
   PdfContentExtractionContext context
)
public:
PdfTextWordCollection^ ExtractWords(
   PdfContentExtractionContext^ context
)

Parameters

context
Context for text extraction.

Return Value

A collection of words on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


SearchText Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : SearchText Method
Searches the page content for the specified text.
Overload List
Overload | Description
SearchText(String) | Searches the page content for the specified text.
SearchText(String,PdfTextSearchOptions) | Searches the page content for the specified text.
SearchText(String,PdfTextSearchOptions,PdfContentExtractionContext) | Searches the page content for the specified text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


SearchText(String) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > SearchText Method : SearchText(String) Method
Text to find in page content.
Searches the page content for the specified text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal text As String _
) As PdfTextSearchResultCollection
'Usage

Dim instance As PdfContentExtractor
Dim text As String
Dim value As PdfTextSearchResultCollection

value = instance.SearchText(text)
public PdfTextSearchResultCollection SearchText(
   string text
)
public:
PdfTextSearchResultCollection^ SearchText(
   String^ text
)

Parameters

text
Text to find in page content.

Return Value

A collection of zero or more search results.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


SearchText(String,PdfTextSearchOptions) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > SearchText Method : SearchText(String,PdfTextSearchOptions) Method
Text to find in page content.
A set of options that specify how the text search should be performed.
Searches the page content for the specified text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal text As String, _
   ByVal searchOptions As PdfTextSearchOptions _
) As PdfTextSearchResultCollection
'Usage

Dim instance As PdfContentExtractor
Dim text As String
Dim searchOptions As PdfTextSearchOptions
Dim value As PdfTextSearchResultCollection

value = instance.SearchText(text, searchOptions)
public PdfTextSearchResultCollection SearchText(
   string text,
   PdfTextSearchOptions searchOptions
)
public:
PdfTextSearchResultCollection^ SearchText(
   String^ text,
   PdfTextSearchOptions searchOptions
)

Parameters

text
Text to find in page content.
searchOptions
A set of options that specify how the text search should be performed.

Return Value

A collection of zero or more search results.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


SearchText(String,PdfTextSearchOptions,PdfContentExtractionContext) Method

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class > SearchText Method : SearchText(String,PdfTextSearchOptions,PdfContentExtractionContext) Method
Text to find in page content.
A set of options that specify how the text search should be performed.
Context for text extraction.
Searches the page content for the specified text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function SearchText( _
   ByVal text As String, _
   ByVal searchOptions As PdfTextSearchOptions, _
   ByVal context As PdfContentExtractionContext _
) As PdfTextSearchResultCollection
'Usage

Dim instance As PdfContentExtractor
Dim text As String
Dim searchOptions As PdfTextSearchOptions
Dim context As PdfContentExtractionContext
Dim value As PdfTextSearchResultCollection

value = instance.SearchText(text, searchOptions, context)
public PdfTextSearchResultCollection SearchText(
   string text,
   PdfTextSearchOptions searchOptions,
   PdfContentExtractionContext context
)
public:
PdfTextSearchResultCollection^ SearchText(
   String^ text,
   PdfTextSearchOptions searchOptions,
   PdfContentExtractionContext^ context
)

Parameters

text
Text to find in page content.
searchOptions
A set of options that specify how the text search should be performed.
context
Context for text extraction.

Return Value

A collection of zero or more search results.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfContentExtractor Class Properties

Xfinium.Pdf.Content Namespace : PdfContentExtractor Class

For a list of all members of this type, see PdfContentExtractor members.

Public Properties
 | Name | Description
Public Property | Encodings | Gets the list of additional encodings used for extracting text from Pdf files.
Top
See Also

Reference

PdfContentExtractor Class
Xfinium.Pdf.Content Namespace


Encodings Property

Xfinium.Pdf.Content Namespace > PdfContentExtractor Class : Encodings Property
Gets the list of additional encodings used for extracting text from Pdf files.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Encodings As PdfEncodingCollection
'Usage

Dim instance As PdfContentExtractor
Dim value As PdfEncodingCollection

value = instance.Encodings
public PdfEncodingCollection Encodings {get;}
public:
property PdfEncodingCollection^ Encodings {
   PdfEncodingCollection^ get();
}

Property Value

List of custom encodings used for extracting text from Pdf files.
Remarks
The library supports a set of commonly used encodings for extracting text. Additional encodings can be loaded and added to this collection and they will be also used when Pdf files require them.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentExtractor Class
PdfContentExtractor Members


%%PageItemTitle%%

PdfFormXObjectVisualObject Class
Members

Xfinium.Pdf.Content Namespace : PdfFormXObjectVisualObject Class
Defines a visual object that represents a form XObject displayed on the PDF page.
Object Model
PdfFormXObjectVisualObject ClassPdfMatrix ClassPdfPoint ClassPdfVisualObjectGraphicsState ClassPdfGroupXObject ClassPdfVisualObjectCollection ClassPdfVisualObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFormXObjectVisualObject
   Inherits PdfVisualObject
'Usage

Dim instance As PdfFormXObjectVisualObject
public class PdfFormXObjectVisualObject : PdfVisualObject
public ref class PdfFormXObjectVisualObject : public PdfVisualObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfVisualObject
Xfinium.Pdf.Content.PdfFormXObjectVisualObject

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObjectVisualObject Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfFormXObjectVisualObject Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfFormXObjectVisualObject Class

The following tables list the members exposed by PdfFormXObjectVisualObject.

Public Properties
 | Name | Description
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | FormXObjectCorners | Gets the corners of the form XObject.
Public Property | FormXObjectID | Gets the form XObject ID.
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | Height | Get the form XObject height.
Public Property | TransparencyGroup | Gets the transparency group.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | VisualObjects | Gets the list of visual objects included in this form XObject.
Public Property | Width | Get the form XObject width.
Top
See Also

Reference

PdfFormXObjectVisualObject Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfFormXObjectVisualObject Class Properties

Xfinium.Pdf.Content Namespace : PdfFormXObjectVisualObject Class

For a list of all members of this type, see PdfFormXObjectVisualObject members.

Public Properties
 | Name | Description
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | FormXObjectCorners | Gets the corners of the form XObject.
Public Property | FormXObjectID | Gets the form XObject ID.
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | Height | Get the form XObject height.
Public Property | TransparencyGroup | Gets the transparency group.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | VisualObjects | Gets the list of visual objects included in this form XObject.
Public Property | Width | Get the form XObject width.
Top
See Also

Reference

PdfFormXObjectVisualObject Class
Xfinium.Pdf.Content Namespace


FormXObjectCorners Property

Xfinium.Pdf.Content Namespace > PdfFormXObjectVisualObject Class : FormXObjectCorners Property
Gets the corners of the form XObject.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FormXObjectCorners As PdfPoint()
'Usage

Dim instance As PdfFormXObjectVisualObject
Dim value() As PdfPoint

value = instance.FormXObjectCorners
public PdfPoint[] FormXObjectCorners {get;}
public:
property array<PdfPoint^>^ FormXObjectCorners {
   array<PdfPoint^>^ get();
}

Property Value

The coordinates on the page of the form XObject's corners.
Remarks
The order of the corners in the array is the following: lower left, lower right, upper right, upper left.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObjectVisualObject Class
PdfFormXObjectVisualObject Members


FormXObjectID Property (PdfFormXObjectVisualObject)

Xfinium.Pdf.Content Namespace > PdfFormXObjectVisualObject Class : FormXObjectID Property
Gets the form XObject ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FormXObjectID As String
'Usage

Dim instance As PdfFormXObjectVisualObject
Dim value As String

value = instance.FormXObjectID
public string FormXObjectID {get;}
public:
property String^ FormXObjectID {
   String^ get();
}

Property Value

The ID used to identify the form XObject in the resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObjectVisualObject Class
PdfFormXObjectVisualObject Members


Height Property (PdfFormXObjectVisualObject)

Xfinium.Pdf.Content Namespace > PdfFormXObjectVisualObject Class : Height Property
Get the form XObject height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PdfFormXObjectVisualObject
Dim value As Double

value = instance.Height
public double Height {get;}
public:
property double Height {
   double get();
}

Property Value

The height of the form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObjectVisualObject Class
PdfFormXObjectVisualObject Members


TransparencyGroup Property (PdfFormXObjectVisualObject)

Xfinium.Pdf.Content Namespace > PdfFormXObjectVisualObject Class : TransparencyGroup Property
Gets the transparency group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TransparencyGroup As PdfGroupXObject
'Usage

Dim instance As PdfFormXObjectVisualObject
Dim value As PdfGroupXObject

value = instance.TransparencyGroup
public PdfGroupXObject TransparencyGroup {get;}
public:
property PdfGroupXObject^ TransparencyGroup {
   PdfGroupXObject^ get();
}

Property Value

The transparency group defined on the form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObjectVisualObject Class
PdfFormXObjectVisualObject Members


VisualObjects Property

Xfinium.Pdf.Content Namespace > PdfFormXObjectVisualObject Class : VisualObjects Property
Gets the list of visual objects included in this form XObject.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property VisualObjects As PdfVisualObjectCollection
'Usage

Dim instance As PdfFormXObjectVisualObject
Dim value As PdfVisualObjectCollection

value = instance.VisualObjects
public PdfVisualObjectCollection VisualObjects {get;}
public:
property PdfVisualObjectCollection^ VisualObjects {
   PdfVisualObjectCollection^ get();
}

Property Value

List of visual objects that compose this form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObjectVisualObject Class
PdfFormXObjectVisualObject Members


Width Property (PdfFormXObjectVisualObject)

Xfinium.Pdf.Content Namespace > PdfFormXObjectVisualObject Class : Width Property
Get the form XObject width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PdfFormXObjectVisualObject
Dim value As Double

value = instance.Width
public double Width {get;}
public:
property double Width {
   double get();
}

Property Value

The width of the form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObjectVisualObject Class
PdfFormXObjectVisualObject Members


%%PageItemTitle%%

PdfImageVisualObject Class
Members

Xfinium.Pdf.Content Namespace : PdfImageVisualObject Class
Defines a visual object that represents an image displayed on the PDF page.
Object Model
PdfImageVisualObject ClassPdfMatrix ClassPdfVisualObjectGraphicsState ClassPdfVisualImage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfImageVisualObject
   Inherits PdfVisualObject
'Usage

Dim instance As PdfImageVisualObject
public class PdfImageVisualObject : PdfVisualObject
public ref class PdfImageVisualObject : public PdfVisualObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfVisualObject
Xfinium.Pdf.Content.PdfImageVisualObject

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImageVisualObject Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfImageVisualObject Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfImageVisualObject Class

The following tables list the members exposed by PdfImageVisualObject.

Public Properties
 | Name | Description
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | Image | Gets the image represented by this visual object.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Top
See Also

Reference

PdfImageVisualObject Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfImageVisualObject Class Properties

Xfinium.Pdf.Content Namespace : PdfImageVisualObject Class

For a list of all members of this type, see PdfImageVisualObject members.

Public Properties
 | Name | Description
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | Image | Gets the image represented by this visual object.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Top
See Also

Reference

PdfImageVisualObject Class
Xfinium.Pdf.Content Namespace


Image Property (PdfImageVisualObject)

Xfinium.Pdf.Content Namespace > PdfImageVisualObject Class : Image Property
Gets the image represented by this visual object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Image As PdfVisualImage
'Usage

Dim instance As PdfImageVisualObject
Dim value As PdfVisualImage

value = instance.Image
public PdfVisualImage Image {get;}
public:
property PdfVisualImage^ Image {
   PdfVisualImage^ get();
}

Property Value

An image displayed on the PDF page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImageVisualObject Class
PdfImageVisualObject Members


%%PageItemTitle%%

PdfPageOptionalContent Class
Members

Xfinium.Pdf.Content Namespace : PdfPageOptionalContent Class
Defines the graphic optional content of a PDF page.
Object Model
PdfPageOptionalContent ClassPdfCosDictionary ClassPdfGraphics ClassPdfMatrix ClassPdfMeasure ClassPdfPointData ClassPdfGroupXObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageOptionalContent
   Inherits Xfinium.Pdf.Graphics.PdfPageContent
'Usage

Dim instance As PdfPageOptionalContent
public class PdfPageOptionalContent : Xfinium.Pdf.Graphics.PdfPageContent
public ref class PdfPageOptionalContent : public Xfinium.Pdf.Graphics.PdfPageContent
Remarks
The graphic optional content of a PDF page is like a vector image that can be drawn on another page graphics surface.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Graphics.PdfPageContent
Xfinium.Pdf.Content.PdfPageOptionalContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageOptionalContent Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfPageOptionalContent Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfPageOptionalContent Class

The following tables list the members exposed by PdfPageOptionalContent.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Graphics | Gets the form XObject graphics. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Height | Gets the form XObject height. (Inherited from Xfinium.Pdf.Graphics.PdfPageContent)
Public Property | Matrix | Gets or sets the form XObject matrix. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Width | Gets the form XObject width. (Inherited from Xfinium.Pdf.Graphics.PdfPageContent)
Top
See Also

Reference

PdfPageOptionalContent Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfPathItem Class
Members

Xfinium.Pdf.Content Namespace : PdfPathItem Class
Defines an item in a PdfPathVisualObject.
Object Model
PdfPathItem ClassPdfPoint Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPathItem
'Usage

Dim instance As PdfPathItem
public class PdfPathItem
public ref class PdfPathItem
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfPathItem

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathItem Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfPathItem Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfPathItem Class

The following tables list the members exposed by PdfPathItem.

Public Properties
 | Name | Description
Public Property | Points | Gets the item points.
Public Property | Type | Gets the type of the path item.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfPathItem Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfPathItem Class Methods

Xfinium.Pdf.Content Namespace : PdfPathItem Class

For a list of all members of this type, see PdfPathItem members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfPathItem Class
Xfinium.Pdf.Content Namespace


ToString Method (PdfPathItem)

Xfinium.Pdf.Content Namespace > PdfPathItem Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfPathItem
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathItem Class
PdfPathItem Members


%%PageItemTitle%% $$Properties$$

PdfPathItem Class Properties

Xfinium.Pdf.Content Namespace : PdfPathItem Class

For a list of all members of this type, see PdfPathItem members.

Public Properties
 | Name | Description
Public Property | Points | Gets the item points.
Public Property | Type | Gets the type of the path item.
Top
See Also

Reference

PdfPathItem Class
Xfinium.Pdf.Content Namespace


Points Property (PdfPathItem)

Xfinium.Pdf.Content Namespace > PdfPathItem Class : Points Property
Gets the item points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Points As PdfPoint()
'Usage

Dim instance As PdfPathItem
Dim value() As PdfPoint

value = instance.Points
public PdfPoint[] Points {get;}
public:
property array<PdfPoint^>^ Points {
   array<PdfPoint^>^ get();
}

Property Value

An array of point associated with the path item.
Remarks
The number of points in the array depends on the item type. MoveTo and LineTo types have a single point, CCurveTo has 3 points, VCurveTo and YVCurveTo have 2 pointsand the CloseSubpath has no points (the array is null).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathItem Class
PdfPathItem Members


Type Property (PdfPathItem)

Xfinium.Pdf.Content Namespace > PdfPathItem Class : Type Property
Gets the type of the path item.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PdfPathItemType
'Usage

Dim instance As PdfPathItem
Dim value As PdfPathItemType

value = instance.Type
public PdfPathItemType Type {get;}
public:
property PdfPathItemType Type {
   PdfPathItemType get();
}

Property Value

A PdfPathItemType specifying the type of the path item.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathItem Class
PdfPathItem Members


%%PageItemTitle%%

PdfPathItemCollection Class
Members

Xfinium.Pdf.Content Namespace : PdfPathItemCollection Class
Defines a collection of items that compose a PDF path displayed on a PDF page.
Object Model
PdfPathItemCollection ClassPdfPathItem Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPathItemCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfPathItem)
'Usage

Dim instance As PdfPathItemCollection
public class PdfPathItemCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>
public ref class PdfPathItemCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Content.PdfPathItemCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathItemCollection Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfPathItemCollection Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfPathItemCollection Class

The following tables list the members exposed by PdfPathItemCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Top
See Also

Reference

PdfPathItemCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfPathVisualObject Class
Members

Xfinium.Pdf.Content Namespace : PdfPathVisualObject Class
Defines a visual object that represents a PDF path displayed on the PDF page.
Object Model
PdfPathVisualObject ClassPdfBrush ClassPdfMatrix ClassPdfVisualObjectGraphicsState ClassPdfPathItemCollection ClassPdfPathItem ClassPdfPen Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPathVisualObject
   Inherits PdfVisualObject
'Usage

Dim instance As PdfPathVisualObject
public class PdfPathVisualObject : PdfVisualObject
public ref class PdfPathVisualObject : public PdfVisualObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfVisualObject
Xfinium.Pdf.Content.PdfPathVisualObject

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathVisualObject Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfPathVisualObject Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfPathVisualObject Class

The following tables list the members exposed by PdfPathVisualObject.

Public Properties
 | Name | Description
Public Property | Brush | Gets or sets the brush.
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | FillMode | Gets the fill mode.
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | IsClippingPath | Gets a value indicating whether the path is used a cliping path.
Public Property | PathItems | Gets the path items.
Public Property | Pen | Gets or sets the pen.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfPathVisualObject Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfPathVisualObject Class Methods

Xfinium.Pdf.Content Namespace : PdfPathVisualObject Class

For a list of all members of this type, see PdfPathVisualObject members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfPathVisualObject Class
Xfinium.Pdf.Content Namespace


ToString Method (PdfPathVisualObject)

Xfinium.Pdf.Content Namespace > PdfPathVisualObject Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfPathVisualObject
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathVisualObject Class
PdfPathVisualObject Members


%%PageItemTitle%% $$Properties$$

PdfPathVisualObject Class Properties

Xfinium.Pdf.Content Namespace : PdfPathVisualObject Class

For a list of all members of this type, see PdfPathVisualObject members.

Public Properties
 | Name | Description
Public Property | Brush | Gets or sets the brush.
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | FillMode | Gets the fill mode.
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | IsClippingPath | Gets a value indicating whether the path is used a cliping path.
Public Property | PathItems | Gets the path items.
Public Property | Pen | Gets or sets the pen.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Top
See Also

Reference

PdfPathVisualObject Class
Xfinium.Pdf.Content Namespace


Brush Property (PdfPathVisualObject)

Xfinium.Pdf.Content Namespace > PdfPathVisualObject Class : Brush Property
Gets or sets the brush.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Brush As PdfBrush
'Usage

Dim instance As PdfPathVisualObject
Dim value As PdfBrush

value = instance.Brush
public PdfBrush Brush {get;}
public:
property PdfBrush^ Brush {
   PdfBrush^ get();
}

Property Value

The brush used to fill the path interior.
Remarks
If the brush is null (Nothing) then the path is not filled.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathVisualObject Class
PdfPathVisualObject Members


FillMode Property

Xfinium.Pdf.Content Namespace > PdfPathVisualObject Class : FillMode Property
Gets the fill mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FillMode As PdfFillMode
'Usage

Dim instance As PdfPathVisualObject
Dim value As PdfFillMode

value = instance.FillMode
public PdfFillMode FillMode {get;}
public:
property PdfFillMode FillMode {
   PdfFillMode get();
}

Property Value

The fill mode used for filling the path.
Remarks
This property has no meaning if the Brush is null (path is not filled).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathVisualObject Class
PdfPathVisualObject Members


IsClippingPath Property

Xfinium.Pdf.Content Namespace > PdfPathVisualObject Class : IsClippingPath Property
Gets a value indicating whether the path is used a cliping path.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsClippingPath As Boolean
'Usage

Dim instance As PdfPathVisualObject
Dim value As Boolean

value = instance.IsClippingPath
public bool IsClippingPath {get;}
public:
property bool IsClippingPath {
   bool get();
}

Property Value

If true, the path is used as clipping path.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathVisualObject Class
PdfPathVisualObject Members


PathItems Property

Xfinium.Pdf.Content Namespace > PdfPathVisualObject Class : PathItems Property
Gets the path items.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PathItems As PdfPathItemCollection
'Usage

Dim instance As PdfPathVisualObject
Dim value As PdfPathItemCollection

value = instance.PathItems
public PdfPathItemCollection PathItems {get;}
public:
property PdfPathItemCollection^ PathItems {
   PdfPathItemCollection^ get();
}

Property Value

A collection of path items that compose the PDF path.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathVisualObject Class
PdfPathVisualObject Members


Pen Property (PdfPathVisualObject)

Xfinium.Pdf.Content Namespace > PdfPathVisualObject Class : Pen Property
Gets or sets the pen.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Pen As PdfPen
'Usage

Dim instance As PdfPathVisualObject
Dim value As PdfPen

value = instance.Pen
public PdfPen Pen {get;}
public:
property PdfPen^ Pen {
   PdfPen^ get();
}

Property Value

The pen used to stroke the path outline.
Remarks
If the pen is null (Nothing) then the path is not stroked.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPathVisualObject Class
PdfPathVisualObject Members


%%PageItemTitle%%

PdfShadingVisualObject Class
Members

Xfinium.Pdf.Content Namespace : PdfShadingVisualObject Class
Defines a visual object that represents a form XObject displayed on the PDF page.
Object Model
PdfShadingVisualObject ClassPdfMatrix ClassPdfVisualObjectGraphicsState ClassPdfShading Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfShadingVisualObject
   Inherits PdfVisualObject
'Usage

Dim instance As PdfShadingVisualObject
public class PdfShadingVisualObject : PdfVisualObject
public ref class PdfShadingVisualObject : public PdfVisualObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfVisualObject
Xfinium.Pdf.Content.PdfShadingVisualObject

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingVisualObject Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfShadingVisualObject Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfShadingVisualObject Class

The following tables list the members exposed by PdfShadingVisualObject.

Public Properties
 | Name | Description
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | Shading | Get the shading object.
Public Property | ShadingID | Gets the shading ID.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Top
See Also

Reference

PdfShadingVisualObject Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfShadingVisualObject Class Properties

Xfinium.Pdf.Content Namespace : PdfShadingVisualObject Class

For a list of all members of this type, see PdfShadingVisualObject members.

Public Properties
 | Name | Description
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | Shading | Get the shading object.
Public Property | ShadingID | Gets the shading ID.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Top
See Also

Reference

PdfShadingVisualObject Class
Xfinium.Pdf.Content Namespace


Shading Property (PdfShadingVisualObject)

Xfinium.Pdf.Content Namespace > PdfShadingVisualObject Class : Shading Property
Get the shading object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Shading As PdfShading
'Usage

Dim instance As PdfShadingVisualObject
Dim value As PdfShading

value = instance.Shading
public PdfShading Shading {get;}
public:
property PdfShading^ Shading {
   PdfShading^ get();
}

Property Value

The shading object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingVisualObject Class
PdfShadingVisualObject Members


ShadingID Property (PdfShadingVisualObject)

Xfinium.Pdf.Content Namespace > PdfShadingVisualObject Class : ShadingID Property
Gets the shading ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ShadingID As String
'Usage

Dim instance As PdfShadingVisualObject
Dim value As String

value = instance.ShadingID
public string ShadingID {get;}
public:
property String^ ShadingID {
   String^ get();
}

Property Value

The ID used to identify the shading in the resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingVisualObject Class
PdfShadingVisualObject Members


%%PageItemTitle%%

PdfTextFragment Class
Members

Xfinium.Pdf.Content Namespace : PdfTextFragment Class
Defines a fragment of text displayed on a Pdf page.
Object Model
PdfTextFragment ClassPdfBrush ClassPdfPoint ClassPdfTextGlyphCollection ClassPdfTextGlyph ClassPdfPen Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public NotInheritable Class PdfTextFragment
'Usage

Dim instance As PdfTextFragment
public sealed class PdfTextFragment
public ref class PdfTextFragment sealed
Remarks
A text fragment is defined by a single 'show text' Pdf operator. All the glyphs in a text fragment share the same graphic attributes.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfTextFragment

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextFragment Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfTextFragment Class

The following tables list the members exposed by PdfTextFragment.

Public Properties
 | Name | Description
Public Property | Brush | Gets the brush used for filling the text interior.
Public Property | FontSize | Gets the font size.
Public Property | FragmentCorners | Gets the coordinates of the text fragment corners.
Public Property | FriendlyFontName | Gets the friendly font name.
Public Property | Glyphs | Gets the collection of glyphs that compose this fragment.
Public Property | Pen | Gets the pen used for stroking the text outline.
Public Property | PostScriptFontName | Gets the PostScript font name.
Public Property | Text | Gets the text included in the fragment.
Public Property | TransformedFontSize | Gets the transformed font size.
Top
Public Methods
 | Name | Description
Public Method | GetEmbeddedFontData | Gets the embedded font data.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfTextFragment Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfTextFragment Class Methods

Xfinium.Pdf.Content Namespace : PdfTextFragment Class

For a list of all members of this type, see PdfTextFragment members.

Public Methods
 | Name | Description
Public Method | GetEmbeddedFontData | Gets the embedded font data.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfTextFragment Class
Xfinium.Pdf.Content Namespace


GetEmbeddedFontData Method

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : GetEmbeddedFontData Method
Gets the embedded font data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetEmbeddedFontData() As Byte()
'Usage

Dim instance As PdfTextFragment
Dim value() As Byte

value = instance.GetEmbeddedFontData()
public byte[] GetEmbeddedFontData()
public:
array<byte>^ GetEmbeddedFontData();

Return Value

The embedded font data as a byte array if the font is embedded in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


ToString Method (PdfTextFragment)

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfTextFragment
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


%%PageItemTitle%% $$Properties$$

PdfTextFragment Class Properties

Xfinium.Pdf.Content Namespace : PdfTextFragment Class

For a list of all members of this type, see PdfTextFragment members.

Public Properties
 | Name | Description
Public Property | Brush | Gets the brush used for filling the text interior.
Public Property | FontSize | Gets the font size.
Public Property | FragmentCorners | Gets the coordinates of the text fragment corners.
Public Property | FriendlyFontName | Gets the friendly font name.
Public Property | Glyphs | Gets the collection of glyphs that compose this fragment.
Public Property | Pen | Gets the pen used for stroking the text outline.
Public Property | PostScriptFontName | Gets the PostScript font name.
Public Property | Text | Gets the text included in the fragment.
Public Property | TransformedFontSize | Gets the transformed font size.
Top
See Also

Reference

PdfTextFragment Class
Xfinium.Pdf.Content Namespace


Brush Property (PdfTextFragment)

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : Brush Property
Gets the brush used for filling the text interior.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Brush As PdfBrush
'Usage

Dim instance As PdfTextFragment
Dim value As PdfBrush

value = instance.Brush
public PdfBrush Brush {get;}
public:
property PdfBrush^ Brush {
   PdfBrush^ get();
}

Property Value

The brush used to fill the text interior.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


FontSize Property (PdfTextFragment)

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : FontSize Property
Gets the font size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FontSize As Double
'Usage

Dim instance As PdfTextFragment
Dim value As Double

value = instance.FontSize
public double FontSize {get;}
public:
property double FontSize {
   double get();
}

Property Value

The size of the font used to draw the text on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


FragmentCorners Property

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : FragmentCorners Property
Gets the coordinates of the text fragment corners.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FragmentCorners As PdfPoint()
'Usage

Dim instance As PdfTextFragment
Dim value() As PdfPoint

value = instance.FragmentCorners
public PdfPoint[] FragmentCorners {get;}
public:
property array<PdfPoint^>^ FragmentCorners {
   array<PdfPoint^>^ get();
}

Property Value

The coordinates on the page of the text fragment's corners.
Remarks
The order of the corners in the array is the following: lower left, lower right, upper right, upper left.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


FriendlyFontName Property

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : FriendlyFontName Property
Gets the friendly font name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FriendlyFontName As String
'Usage

Dim instance As PdfTextFragment
Dim value As String

value = instance.FriendlyFontName
public string FriendlyFontName {get;}
public:
property String^ FriendlyFontName {
   String^ get();
}

Property Value

The friendly name of the font used to draw the text on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


Glyphs Property (PdfTextFragment)

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : Glyphs Property
Gets the collection of glyphs that compose this fragment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Glyphs As PdfTextGlyphCollection
'Usage

Dim instance As PdfTextFragment
Dim value As PdfTextGlyphCollection

value = instance.Glyphs
public PdfTextGlyphCollection Glyphs {get;}
public:
property PdfTextGlyphCollection^ Glyphs {
   PdfTextGlyphCollection^ get();
}

Property Value

The glyphs included in this text fragment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


Pen Property (PdfTextFragment)

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : Pen Property
Gets the pen used for stroking the text outline.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Pen As PdfPen
'Usage

Dim instance As PdfTextFragment
Dim value As PdfPen

value = instance.Pen
public PdfPen Pen {get;}
public:
property PdfPen^ Pen {
   PdfPen^ get();
}

Property Value

The pen used to stroke the text outline.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


PostScriptFontName Property

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : PostScriptFontName Property
Gets the PostScript font name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PostScriptFontName As String
'Usage

Dim instance As PdfTextFragment
Dim value As String

value = instance.PostScriptFontName
public string PostScriptFontName {get;}
public:
property String^ PostScriptFontName {
   String^ get();
}

Property Value

The PostScript name of the font used to draw the text on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


Text Property (PdfTextFragment)

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : Text Property
Gets the text included in the fragment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PdfTextFragment
Dim value As String

value = instance.Text
public string Text {get;}
public:
property String^ Text {
   String^ get();
}

Property Value

The text displayed on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


TransformedFontSize Property

Xfinium.Pdf.Content Namespace > PdfTextFragment Class : TransformedFontSize Property
Gets the transformed font size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TransformedFontSize As Double
'Usage

Dim instance As PdfTextFragment
Dim value As Double

value = instance.TransformedFontSize
public double TransformedFontSize {get;}
public:
property double TransformedFontSize {
   double get();
}

Property Value

The actual size of the font used to draw the text on the page, it is the FontSize transformed by current text matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragment Class
PdfTextFragment Members


%%PageItemTitle%%

PdfTextFragmentCollection Class
Members

Xfinium.Pdf.Content Namespace : PdfTextFragmentCollection Class
Defines a collection of text fragments on the Pdf page.
Object Model
PdfTextFragmentCollection ClassPdfTextFragment Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public NotInheritable Class PdfTextFragmentCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfTextFragment)
'Usage

Dim instance As PdfTextFragmentCollection
public sealed class PdfTextFragmentCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>
public ref class PdfTextFragmentCollection sealed : public System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Content.PdfTextFragmentCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextFragmentCollection Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextFragmentCollection Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfTextFragmentCollection Class

The following tables list the members exposed by PdfTextFragmentCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Top
See Also

Reference

PdfTextFragmentCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfTextGlyph Class
Members

Xfinium.Pdf.Content Namespace : PdfTextGlyph Class
Defines a glyph drawn on the Pdf page.
Object Model
PdfTextGlyph ClassPdfPoint Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public NotInheritable Class PdfTextGlyph
'Usage

Dim instance As PdfTextGlyph
public sealed class PdfTextGlyph
public ref class PdfTextGlyph sealed
Remarks
A glyph is the graphic visual representation of one or more characters. Usually there is a one-to-one correspondence between glyphs and characters but in case of ligatures a glyph can represent 2 or 3 characters.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfTextGlyph

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextGlyph Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextGlyph Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfTextGlyph Class

The following tables list the members exposed by PdfTextGlyph.

Public Properties
 | Name | Description
Public Property | GlyphCorners | Gets the coordinates of the glyph corners.
Public Property | Height | Gets the glyph height.
Public Property | Text | Gets the text corresponding to the glyph.
Public Property | Width | Gets the glyph width.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfTextGlyph Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfTextGlyph Class Methods

Xfinium.Pdf.Content Namespace : PdfTextGlyph Class

For a list of all members of this type, see PdfTextGlyph members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfTextGlyph Class
Xfinium.Pdf.Content Namespace


ToString Method (PdfTextGlyph)

Xfinium.Pdf.Content Namespace > PdfTextGlyph Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfTextGlyph
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextGlyph Class
PdfTextGlyph Members


%%PageItemTitle%% $$Properties$$

PdfTextGlyph Class Properties

Xfinium.Pdf.Content Namespace : PdfTextGlyph Class

For a list of all members of this type, see PdfTextGlyph members.

Public Properties
 | Name | Description
Public Property | GlyphCorners | Gets the coordinates of the glyph corners.
Public Property | Height | Gets the glyph height.
Public Property | Text | Gets the text corresponding to the glyph.
Public Property | Width | Gets the glyph width.
Top
See Also

Reference

PdfTextGlyph Class
Xfinium.Pdf.Content Namespace


GlyphCorners Property

Xfinium.Pdf.Content Namespace > PdfTextGlyph Class : GlyphCorners Property
Gets the coordinates of the glyph corners.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property GlyphCorners As PdfPoint()
'Usage

Dim instance As PdfTextGlyph
Dim value() As PdfPoint

value = instance.GlyphCorners
public PdfPoint[] GlyphCorners {get;}
public:
property array<PdfPoint^>^ GlyphCorners {
   array<PdfPoint^>^ get();
}

Property Value

The coordinates on the page of the glyphs's corners.
Remarks
The order of the corners in the array is the following: lower left, lower right, upper right, upper left.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextGlyph Class
PdfTextGlyph Members


Height Property (PdfTextGlyph)

Xfinium.Pdf.Content Namespace > PdfTextGlyph Class : Height Property
Gets the glyph height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PdfTextGlyph
Dim value As Double

value = instance.Height
public double Height {get;}
public:
property double Height {
   double get();
}

Property Value

The height of the glyph.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextGlyph Class
PdfTextGlyph Members


Text Property (PdfTextGlyph)

Xfinium.Pdf.Content Namespace > PdfTextGlyph Class : Text Property
Gets the text corresponding to the glyph.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PdfTextGlyph
Dim value As String

value = instance.Text
public string Text {get;}
public:
property String^ Text {
   String^ get();
}

Property Value

The sequence of characters represented by the glyph.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextGlyph Class
PdfTextGlyph Members


Width Property (PdfTextGlyph)

Xfinium.Pdf.Content Namespace > PdfTextGlyph Class : Width Property
Gets the glyph width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PdfTextGlyph
Dim value As Double

value = instance.Width
public double Width {get;}
public:
property double Width {
   double get();
}

Property Value

The width of the glyph.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextGlyph Class
PdfTextGlyph Members


%%PageItemTitle%%

PdfTextGlyphCollection Class
Members

Xfinium.Pdf.Content Namespace : PdfTextGlyphCollection Class
Defines a collection of glyphs in a text fragment.
Object Model
PdfTextGlyphCollection ClassPdfTextGlyph Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public NotInheritable Class PdfTextGlyphCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfTextGlyph)
'Usage

Dim instance As PdfTextGlyphCollection
public sealed class PdfTextGlyphCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>
public ref class PdfTextGlyphCollection sealed : public System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Content.PdfTextGlyphCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextGlyphCollection Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextGlyphCollection Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfTextGlyphCollection Class

The following tables list the members exposed by PdfTextGlyphCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Top
See Also

Reference

PdfTextGlyphCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfTextSearchResult Class
Members

Xfinium.Pdf.Content Namespace : PdfTextSearchResult Class
Defines the result returned by a text search operation.
Object Model
PdfTextSearchResult ClassPdfTextFragmentCollection ClassPdfTextFragment Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextSearchResult
'Usage

Dim instance As PdfTextSearchResult
public class PdfTextSearchResult
public ref class PdfTextSearchResult
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfTextSearchResult

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextSearchResult Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextSearchResult Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfTextSearchResult Class

The following tables list the members exposed by PdfTextSearchResult.

Public Properties
 | Name | Description
Public Property | Text | Gets the result text.
Public Property | TextFragments | Gets the text fragments.
Top
See Also

Reference

PdfTextSearchResult Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfTextSearchResult Class Properties

Xfinium.Pdf.Content Namespace : PdfTextSearchResult Class

For a list of all members of this type, see PdfTextSearchResult members.

Public Properties
 | Name | Description
Public Property | Text | Gets the result text.
Public Property | TextFragments | Gets the text fragments.
Top
See Also

Reference

PdfTextSearchResult Class
Xfinium.Pdf.Content Namespace


Text Property (PdfTextSearchResult)

Xfinium.Pdf.Content Namespace > PdfTextSearchResult Class : Text Property
Gets the result text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PdfTextSearchResult
Dim value As String

value = instance.Text
public string Text {get;}
public:
property String^ Text {
   String^ get();
}

Property Value

The text associated with the result, also the text being searched.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextSearchResult Class
PdfTextSearchResult Members


TextFragments Property (PdfTextSearchResult)

Xfinium.Pdf.Content Namespace > PdfTextSearchResult Class : TextFragments Property
Gets the text fragments.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TextFragments As PdfTextFragmentCollection
'Usage

Dim instance As PdfTextSearchResult
Dim value As PdfTextFragmentCollection

value = instance.TextFragments
public PdfTextFragmentCollection TextFragments {get;}
public:
property PdfTextFragmentCollection^ TextFragments {
   PdfTextFragmentCollection^ get();
}

Property Value

The collection of text fragments that compose the search result.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextSearchResult Class
PdfTextSearchResult Members


%%PageItemTitle%%

PdfTextSearchResultCollection Class
Members

Xfinium.Pdf.Content Namespace : PdfTextSearchResultCollection Class
Defines a collection of results returned by a text search operation.
Object Model
PdfTextSearchResultCollection ClassPdfTextSearchResult Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public NotInheritable Class PdfTextSearchResultCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfTextSearchResult)
'Usage

Dim instance As PdfTextSearchResultCollection
public sealed class PdfTextSearchResultCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>
public ref class PdfTextSearchResultCollection sealed : public System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Content.PdfTextSearchResultCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextSearchResultCollection Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextSearchResultCollection Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfTextSearchResultCollection Class

The following tables list the members exposed by PdfTextSearchResultCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Top
See Also

Reference

PdfTextSearchResultCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfTextVisualObject Class
Members

Xfinium.Pdf.Content Namespace : PdfTextVisualObject Class
Defines a visual object that represents a text fragment displayed on the PDF page.
Object Model
PdfTextVisualObject ClassPdfMatrix ClassPdfVisualObjectGraphicsState ClassPdfTextFragment ClassPdfMatrix Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextVisualObject
   Inherits PdfVisualObject
'Usage

Dim instance As PdfTextVisualObject
public class PdfTextVisualObject : PdfVisualObject
public ref class PdfTextVisualObject : public PdfVisualObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfVisualObject
Xfinium.Pdf.Content.PdfTextVisualObject

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextVisualObject Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfTextVisualObject Class

The following tables list the members exposed by PdfTextVisualObject.

Public Properties
 | Name | Description
Public Property | CharacterSpacing | Get the character spacing.
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | HorizontalScaling | Gets the horizontal scaling.
Public Property | RenderingMode | Gets the text rendering mode.
Public Property | TextFragment | Gets the text fragment represented by this visual object.
Public Property | TextLeading | Gets the text leading.
Public Property | TextMatrix | Gets the text matrix.
Public Property | TextRise | Gets the text rise.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | WordSpacing | Gets the word spacing.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfTextVisualObject Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfTextVisualObject Class Methods

Xfinium.Pdf.Content Namespace : PdfTextVisualObject Class

For a list of all members of this type, see PdfTextVisualObject members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfTextVisualObject Class
Xfinium.Pdf.Content Namespace


ToString Method (PdfTextVisualObject)

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfTextVisualObject
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


%%PageItemTitle%% $$Properties$$

PdfTextVisualObject Class Properties

Xfinium.Pdf.Content Namespace : PdfTextVisualObject Class

For a list of all members of this type, see PdfTextVisualObject members.

Public Properties
 | Name | Description
Public Property | CharacterSpacing | Get the character spacing.
Public Property | CTM | Get the current transformation matrix. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | GraphicsState | Gets the current graphics state. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | HorizontalScaling | Gets the horizontal scaling.
Public Property | RenderingMode | Gets the text rendering mode.
Public Property | TextFragment | Gets the text fragment represented by this visual object.
Public Property | TextLeading | Gets the text leading.
Public Property | TextMatrix | Gets the text matrix.
Public Property | TextRise | Gets the text rise.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Content.PdfVisualObject)
Public Property | WordSpacing | Gets the word spacing.
Top
See Also

Reference

PdfTextVisualObject Class
Xfinium.Pdf.Content Namespace


CharacterSpacing Property (PdfTextVisualObject)

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : CharacterSpacing Property
Get the character spacing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CharacterSpacing As Double
'Usage

Dim instance As PdfTextVisualObject
Dim value As Double

value = instance.CharacterSpacing
public double CharacterSpacing {get;}
public:
property double CharacterSpacing {
   double get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


HorizontalScaling Property (PdfTextVisualObject)

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : HorizontalScaling Property
Gets the horizontal scaling.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property HorizontalScaling As Double
'Usage

Dim instance As PdfTextVisualObject
Dim value As Double

value = instance.HorizontalScaling
public double HorizontalScaling {get;}
public:
property double HorizontalScaling {
   double get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


RenderingMode Property

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : RenderingMode Property
Gets the text rendering mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property RenderingMode As PdfTextRenderingMode
'Usage

Dim instance As PdfTextVisualObject
Dim value As PdfTextRenderingMode

value = instance.RenderingMode
public PdfTextRenderingMode RenderingMode {get;}
public:
property PdfTextRenderingMode RenderingMode {
   PdfTextRenderingMode get();
}

Property Value

A Xfinium.Pdf.Graphics.Text.PdfTextRenderingMode that specifies how the text fragment is rendered.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


TextFragment Property

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : TextFragment Property
Gets the text fragment represented by this visual object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TextFragment As PdfTextFragment
'Usage

Dim instance As PdfTextVisualObject
Dim value As PdfTextFragment

value = instance.TextFragment
public PdfTextFragment TextFragment {get;}
public:
property PdfTextFragment^ TextFragment {
   PdfTextFragment^ get();
}

Property Value

A text fragment displayed on the PDF page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


TextLeading Property (PdfTextVisualObject)

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : TextLeading Property
Gets the text leading.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TextLeading As Double
'Usage

Dim instance As PdfTextVisualObject
Dim value As Double

value = instance.TextLeading
public double TextLeading {get;}
public:
property double TextLeading {
   double get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


TextMatrix Property

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : TextMatrix Property
Gets the text matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TextMatrix As PdfMatrix
'Usage

Dim instance As PdfTextVisualObject
Dim value As PdfMatrix

value = instance.TextMatrix
public PdfMatrix TextMatrix {get;}
public:
property PdfMatrix^ TextMatrix {
   PdfMatrix^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


TextRise Property

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : TextRise Property
Gets the text rise.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TextRise As Double
'Usage

Dim instance As PdfTextVisualObject
Dim value As Double

value = instance.TextRise
public double TextRise {get;}
public:
property double TextRise {
   double get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


WordSpacing Property (PdfTextVisualObject)

Xfinium.Pdf.Content Namespace > PdfTextVisualObject Class : WordSpacing Property
Gets the word spacing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property WordSpacing As Double
'Usage

Dim instance As PdfTextVisualObject
Dim value As Double

value = instance.WordSpacing
public double WordSpacing {get;}
public:
property double WordSpacing {
   double get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextVisualObject Class
PdfTextVisualObject Members


%%PageItemTitle%%

PdfTextWord Class
Members

Xfinium.Pdf.Content Namespace : PdfTextWord Class
Defines the a word returned by a text extraction operation.
Object Model
PdfTextWord ClassPdfTextFragmentCollection ClassPdfTextFragment Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextWord
'Usage

Dim instance As PdfTextWord
public class PdfTextWord
public ref class PdfTextWord
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfTextWord

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextWord Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextWord Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfTextWord Class

The following tables list the members exposed by PdfTextWord.

Public Properties
 | Name | Description
Public Property | Text | Gets the result text.
Public Property | TextFragments | Gets the text fragments.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfTextWord Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfTextWord Class Methods

Xfinium.Pdf.Content Namespace : PdfTextWord Class

For a list of all members of this type, see PdfTextWord members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfTextWord Class
Xfinium.Pdf.Content Namespace


ToString Method (PdfTextWord)

Xfinium.Pdf.Content Namespace > PdfTextWord Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfTextWord
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextWord Class
PdfTextWord Members


%%PageItemTitle%% $$Properties$$

PdfTextWord Class Properties

Xfinium.Pdf.Content Namespace : PdfTextWord Class

For a list of all members of this type, see PdfTextWord members.

Public Properties
 | Name | Description
Public Property | Text | Gets the result text.
Public Property | TextFragments | Gets the text fragments.
Top
See Also

Reference

PdfTextWord Class
Xfinium.Pdf.Content Namespace


Text Property (PdfTextWord)

Xfinium.Pdf.Content Namespace > PdfTextWord Class : Text Property
Gets the result text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PdfTextWord
Dim value As String

value = instance.Text
public string Text {get;}
public:
property String^ Text {
   String^ get();
}

Property Value

The text associated with the word.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextWord Class
PdfTextWord Members


TextFragments Property (PdfTextWord)

Xfinium.Pdf.Content Namespace > PdfTextWord Class : TextFragments Property
Gets the text fragments.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TextFragments As PdfTextFragmentCollection
'Usage

Dim instance As PdfTextWord
Dim value As PdfTextFragmentCollection

value = instance.TextFragments
public PdfTextFragmentCollection TextFragments {get;}
public:
property PdfTextFragmentCollection^ TextFragments {
   PdfTextFragmentCollection^ get();
}

Property Value

The collection of text fragments that compose the word.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextWord Class
PdfTextWord Members


%%PageItemTitle%%

PdfTextWordCollection Class
Members

Xfinium.Pdf.Content Namespace : PdfTextWordCollection Class
Defines a collection of words returned by a text extraction operation.
Object Model
PdfTextWordCollection ClassPdfTextWord Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public NotInheritable Class PdfTextWordCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfTextWord)
'Usage

Dim instance As PdfTextWordCollection
public sealed class PdfTextWordCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>
public ref class PdfTextWordCollection sealed : public System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Content.PdfTextWordCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextWordCollection Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfTextWordCollection Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfTextWordCollection Class

The following tables list the members exposed by PdfTextWordCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Top
See Also

Reference

PdfTextWordCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfVisualImage Class
Members

Xfinium.Pdf.Content Namespace : PdfVisualImage Class
Defines an image that displayed on a PDF page.
Object Model
PdfVisualImage ClassPdfColorSpace ClassPdfPoint ClassPdfVisualImage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfVisualImage
'Usage

Dim instance As PdfVisualImage
public class PdfVisualImage
public ref class PdfVisualImage
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfVisualImage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfVisualImage Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfVisualImage Class

The following tables list the members exposed by PdfVisualImage.

Public Properties
 | Name | Description
Public Property | BitsPerComponent | Gets the bits per component.
Public Property | ChromaKeyMask | Gets the image chroma key mask.
Public Property | ColorSpace | Gets the image colorspace.
Public Property | DisplayHeight | Gets the height of the displayed image on the page.
Public Property | DisplayWidth | Gets the width of the displayed image on the page.
Public Property | DpiX | Gets the image's horizontal resolution.
Public Property | DpiY | Gets the image's vertical resolution.
Public Property | Height | Gets the image height.
Public Property | ImageCorners | Gets the coordinates of the image corners.
Public Property | ImageFormat | Gets the format of the embedded image.
Public Property | ImageID | Gets the image ID.
Public Property | IsImageMask | Gets a value indicating whether this image is actually a mask.
Public Property | Mask | Gets the image mask.
Public Property | Width | Gets the image width.
Top
Public Methods
 | Name | Description
Public Method | Save | Saves the image to the stream.
Top
See Also

Reference

PdfVisualImage Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfVisualImage Class Methods

Xfinium.Pdf.Content Namespace : PdfVisualImage Class

For a list of all members of this type, see PdfVisualImage members.

Public Methods
 | Name | Description
Public Method | Save | Saves the image to the stream.
Top
See Also

Reference

PdfVisualImage Class
Xfinium.Pdf.Content Namespace


Save Method (PdfVisualImage)

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : Save Method
Destination stream where the image will be saved.
Format used for saving the image.
Saves the image to the stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Save( _
   ByVal stream As Stream, _
   ByVal imageSaveFormat As PdfVisualImageSaveFormat _
)
'Usage

Dim instance As PdfVisualImage
Dim stream As Stream
Dim imageSaveFormat As PdfVisualImageSaveFormat

instance.Save(stream, imageSaveFormat)
public void Save(
   Stream stream,
   PdfVisualImageSaveFormat imageSaveFormat
)
public:
void Save(
   Stream^ stream,
   PdfVisualImageSaveFormat imageSaveFormat
)

Parameters

stream
Destination stream where the image will be saved.
imageSaveFormat
Format used for saving the image.
Exceptions
Exception | Description
System.InvalidOperationException | Thrown when the Save method is called on an image that has been extracted without its data, PdfContentExtractor.ExtractImages method has been called using 'false' as its parameter. - or - when the image format is JPEG2000 and the imageSaveFormat is not PdfVisualImageSaveFormat.Native.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


%%PageItemTitle%% $$Properties$$

PdfVisualImage Class Properties

Xfinium.Pdf.Content Namespace : PdfVisualImage Class

For a list of all members of this type, see PdfVisualImage members.

Public Properties
 | Name | Description
Public Property | BitsPerComponent | Gets the bits per component.
Public Property | ChromaKeyMask | Gets the image chroma key mask.
Public Property | ColorSpace | Gets the image colorspace.
Public Property | DisplayHeight | Gets the height of the displayed image on the page.
Public Property | DisplayWidth | Gets the width of the displayed image on the page.
Public Property | DpiX | Gets the image's horizontal resolution.
Public Property | DpiY | Gets the image's vertical resolution.
Public Property | Height | Gets the image height.
Public Property | ImageCorners | Gets the coordinates of the image corners.
Public Property | ImageFormat | Gets the format of the embedded image.
Public Property | ImageID | Gets the image ID.
Public Property | IsImageMask | Gets a value indicating whether this image is actually a mask.
Public Property | Mask | Gets the image mask.
Public Property | Width | Gets the image width.
Top
See Also

Reference

PdfVisualImage Class
Xfinium.Pdf.Content Namespace


BitsPerComponent Property (PdfVisualImage)

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : BitsPerComponent Property
Gets the bits per component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property BitsPerComponent As Integer
'Usage

Dim instance As PdfVisualImage
Dim value As Integer

value = instance.BitsPerComponent
public int BitsPerComponent {get;}
public:
property int BitsPerComponent {
   int get();
}

Property Value

The number of bits used to represent a color component in the image's colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


ChromaKeyMask Property

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : ChromaKeyMask Property
Gets the image chroma key mask.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ChromaKeyMask As Integer()
'Usage

Dim instance As PdfVisualImage
Dim value() As Integer

value = instance.ChromaKeyMask
public int[] ChromaKeyMask {get;}
public:
property array<int>^ ChromaKeyMask {
   array<int>^ get();
}

Property Value

An array of color components specifying the range of colors that are considered transparent.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


ColorSpace Property (PdfVisualImage)

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : ColorSpace Property
Gets the image colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As PdfColorSpace
'Usage

Dim instance As PdfVisualImage
Dim value As PdfColorSpace

value = instance.ColorSpace
public PdfColorSpace ColorSpace {get;}
public:
property PdfColorSpace^ ColorSpace {
   PdfColorSpace^ get();
}

Property Value

The colorspace the image data is represent in.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


DisplayHeight Property

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : DisplayHeight Property
Gets the height of the displayed image on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayHeight As Double
'Usage

Dim instance As PdfVisualImage
Dim value As Double

value = instance.DisplayHeight
public double DisplayHeight {get;}
public:
property double DisplayHeight {
   double get();
}

Property Value

The height, in points, of the displayed image on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


DisplayWidth Property

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : DisplayWidth Property
Gets the width of the displayed image on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayWidth As Double
'Usage

Dim instance As PdfVisualImage
Dim value As Double

value = instance.DisplayWidth
public double DisplayWidth {get;}
public:
property double DisplayWidth {
   double get();
}

Property Value

The width, in points, of the displayed image on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


DpiX Property

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : DpiX Property
Gets the image's horizontal resolution.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DpiX As Double
'Usage

Dim instance As PdfVisualImage
Dim value As Double

value = instance.DpiX
public double DpiX {get;}
public:
property double DpiX {
   double get();
}

Property Value

The horizontal resolution of the displayed image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


DpiY Property

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : DpiY Property
Gets the image's vertical resolution.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DpiY As Double
'Usage

Dim instance As PdfVisualImage
Dim value As Double

value = instance.DpiY
public double DpiY {get;}
public:
property double DpiY {
   double get();
}

Property Value

The vertical resolution of the displayed image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


Height Property (PdfVisualImage)

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : Height Property
Gets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As PdfVisualImage
Dim value As Integer

value = instance.Height
public int Height {get;}
public:
property int Height {
   int get();
}

Property Value

The height of the image in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


ImageCorners Property

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : ImageCorners Property
Gets the coordinates of the image corners.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ImageCorners As PdfPoint()
'Usage

Dim instance As PdfVisualImage
Dim value() As PdfPoint

value = instance.ImageCorners
public PdfPoint[] ImageCorners {get;}
public:
property array<PdfPoint^>^ ImageCorners {
   array<PdfPoint^>^ get();
}

Property Value

The coordinates on the page of the image's corners.
Remarks
The order of the corners in the array is the following: lower left, lower right, upper right, upper left.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


ImageFormat Property

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : ImageFormat Property
Gets the format of the embedded image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ImageFormat As PdfVisualImageFormat
'Usage

Dim instance As PdfVisualImage
Dim value As PdfVisualImageFormat

value = instance.ImageFormat
public PdfVisualImageFormat ImageFormat {get;}
public:
property PdfVisualImageFormat ImageFormat {
   PdfVisualImageFormat get();
}

Property Value

The format the image is embedded in the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


ImageID Property (PdfVisualImage)

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : ImageID Property
Gets the image ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ImageID As String
'Usage

Dim instance As PdfVisualImage
Dim value As String

value = instance.ImageID
public string ImageID {get;}
public:
property String^ ImageID {
   String^ get();
}

Property Value

The ID of the image in the page's resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


IsImageMask Property

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : IsImageMask Property
Gets a value indicating whether this image is actually a mask.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsImageMask As Boolean
'Usage

Dim instance As PdfVisualImage
Dim value As Boolean

value = instance.IsImageMask
public bool IsImageMask {get;}
public:
property bool IsImageMask {
   bool get();
}

Property Value

True if the image represents a mask.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


Mask Property (PdfVisualImage)

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : Mask Property
Gets the image mask.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Mask As PdfVisualImage
'Usage

Dim instance As PdfVisualImage
Dim value As PdfVisualImage

value = instance.Mask
public PdfVisualImage Mask {get;}
public:
property PdfVisualImage^ Mask {
   PdfVisualImage^ get();
}

Property Value

The mask associated with this image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


Width Property (PdfVisualImage)

Xfinium.Pdf.Content Namespace > PdfVisualImage Class : Width Property
Gets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As PdfVisualImage
Dim value As Integer

value = instance.Width
public int Width {get;}
public:
property int Width {
   int get();
}

Property Value

The width of the image in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImage Class
PdfVisualImage Members


%%PageItemTitle%%

PdfVisualImageCollection Class
Members

Xfinium.Pdf.Content Namespace : PdfVisualImageCollection Class
Defines a collection of images that are displayed on a PDF page.
Object Model
PdfVisualImageCollection ClassPdfVisualImage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfVisualImageCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfVisualImage)
'Usage

Dim instance As PdfVisualImageCollection
public class PdfVisualImageCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>
public ref class PdfVisualImageCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Content.PdfVisualImageCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualImageCollection Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfVisualImageCollection Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfVisualImageCollection Class

The following tables list the members exposed by PdfVisualImageCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Top
See Also

Reference

PdfVisualImageCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfVisualObject Class
Members

Xfinium.Pdf.Content Namespace : PdfVisualObject Class
Defines the base class for visual objects displayed on a PDF page.
Object Model
PdfVisualObject ClassPdfMatrix ClassPdfVisualObjectGraphicsState Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfVisualObject
'Usage

Dim instance As PdfVisualObject
public abstract class PdfVisualObject
public ref class PdfVisualObject abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfVisualObject
Xfinium.Pdf.Content.PdfFormXObjectVisualObject
Xfinium.Pdf.Content.PdfImageVisualObject
Xfinium.Pdf.Content.PdfPathVisualObject
Xfinium.Pdf.Content.PdfShadingVisualObject
Xfinium.Pdf.Content.PdfTextVisualObject

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObject Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfVisualObject Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfVisualObject Class

The following tables list the members exposed by PdfVisualObject.

Public Properties
 | Name | Description
Public Property | CTM | Get the current transformation matrix.
Public Property | GraphicsState | Gets the current graphics state.
Public Property | Type | Gets the object type.
Top
See Also

Reference

PdfVisualObject Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfVisualObject Class Properties

Xfinium.Pdf.Content Namespace : PdfVisualObject Class

For a list of all members of this type, see PdfVisualObject members.

Public Properties
 | Name | Description
Public Property | CTM | Get the current transformation matrix.
Public Property | GraphicsState | Gets the current graphics state.
Public Property | Type | Gets the object type.
Top
See Also

Reference

PdfVisualObject Class
Xfinium.Pdf.Content Namespace


CTM Property

Xfinium.Pdf.Content Namespace > PdfVisualObject Class : CTM Property
Get the current transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CTM As PdfMatrix
'Usage

Dim instance As PdfVisualObject
Dim value As PdfMatrix

value = instance.CTM
public PdfMatrix CTM {get;}
public:
property PdfMatrix^ CTM {
   PdfMatrix^ get();
}

Property Value

The active transformation when the object is drawn on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObject Class
PdfVisualObject Members


GraphicsState Property

Xfinium.Pdf.Content Namespace > PdfVisualObject Class : GraphicsState Property
Gets the current graphics state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property GraphicsState As PdfVisualObjectGraphicsState
'Usage

Dim instance As PdfVisualObject
Dim value As PdfVisualObjectGraphicsState

value = instance.GraphicsState
public PdfVisualObjectGraphicsState GraphicsState {get;}
public:
property PdfVisualObjectGraphicsState^ GraphicsState {
   PdfVisualObjectGraphicsState^ get();
}

Property Value

The graphics state that is in place when the visual object is displayed on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObject Class
PdfVisualObject Members


Type Property (PdfVisualObject)

Xfinium.Pdf.Content Namespace > PdfVisualObject Class : Type Property
Gets the object type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PdfVisualObjectType
'Usage

Dim instance As PdfVisualObject
Dim value As PdfVisualObjectType

value = instance.Type
public PdfVisualObjectType Type {get;}
public:
property PdfVisualObjectType Type {
   PdfVisualObjectType get();
}

Property Value

The type of the visual object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObject Class
PdfVisualObject Members


%%PageItemTitle%%

PdfVisualObjectCollection Class
Members

Xfinium.Pdf.Content Namespace : PdfVisualObjectCollection Class
Defines a collection of visual objects that are displayed on a PDF page.
Object Model
PdfVisualObjectCollection ClassPdfVisualObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfVisualObjectCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfVisualObject)
'Usage

Dim instance As PdfVisualObjectCollection
public class PdfVisualObjectCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>
public ref class PdfVisualObjectCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Content.PdfVisualObjectCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObjectCollection Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfVisualObjectCollection Class Members
Properties Methods

Xfinium.Pdf.Content Namespace : PdfVisualObjectCollection Class

The following tables list the members exposed by PdfVisualObjectCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Top
See Also

Reference

PdfVisualObjectCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfVisualObjectGraphicsState Class
Members

Xfinium.Pdf.Content Namespace : PdfVisualObjectGraphicsState Class
Defines the graphics state that is in place when the visual object is displayed on the page.
Object Model
PdfVisualObjectGraphicsState ClassPdfPathVisualObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfVisualObjectGraphicsState
'Usage

Dim instance As PdfVisualObjectGraphicsState
public class PdfVisualObjectGraphicsState
public ref class PdfVisualObjectGraphicsState
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Content.PdfVisualObjectGraphicsState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObjectGraphicsState Members
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Members$$

PdfVisualObjectGraphicsState Class Members
Properties

Xfinium.Pdf.Content Namespace : PdfVisualObjectGraphicsState Class

The following tables list the members exposed by PdfVisualObjectGraphicsState.

Public Properties
 | Name | Description
Public Property | ClippingPath | Get the clipping path.
Public Property | FillAlpha | Gets the fill alpha.
Public Property | StrokeAlpha | Gets the stroke alpha.
Top
See Also

Reference

PdfVisualObjectGraphicsState Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfVisualObjectGraphicsState Class Properties

Xfinium.Pdf.Content Namespace : PdfVisualObjectGraphicsState Class

For a list of all members of this type, see PdfVisualObjectGraphicsState members.

Public Properties
 | Name | Description
Public Property | ClippingPath | Get the clipping path.
Public Property | FillAlpha | Gets the fill alpha.
Public Property | StrokeAlpha | Gets the stroke alpha.
Top
See Also

Reference

PdfVisualObjectGraphicsState Class
Xfinium.Pdf.Content Namespace


ClippingPath Property

Xfinium.Pdf.Content Namespace > PdfVisualObjectGraphicsState Class : ClippingPath Property
Get the clipping path.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ClippingPath As PdfPathVisualObject
'Usage

Dim instance As PdfVisualObjectGraphicsState
Dim value As PdfPathVisualObject

value = instance.ClippingPath
public PdfPathVisualObject ClippingPath {get;}
public:
property PdfPathVisualObject^ ClippingPath {
   PdfPathVisualObject^ get();
}

Property Value

The active clipping path in place when the visual object is displayed on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObjectGraphicsState Class
PdfVisualObjectGraphicsState Members


FillAlpha Property (PdfVisualObjectGraphicsState)

Xfinium.Pdf.Content Namespace > PdfVisualObjectGraphicsState Class : FillAlpha Property
Gets the fill alpha.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FillAlpha As Double
'Usage

Dim instance As PdfVisualObjectGraphicsState
Dim value As Double

value = instance.FillAlpha
public double FillAlpha {get;}
public:
property double FillAlpha {
   double get();
}

Property Value

The alpha value for fill operations.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObjectGraphicsState Class
PdfVisualObjectGraphicsState Members


StrokeAlpha Property (PdfVisualObjectGraphicsState)

Xfinium.Pdf.Content Namespace > PdfVisualObjectGraphicsState Class : StrokeAlpha Property
Gets the stroke alpha.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property StrokeAlpha As Double
'Usage

Dim instance As PdfVisualObjectGraphicsState
Dim value As Double

value = instance.StrokeAlpha
public double StrokeAlpha {get;}
public:
property double StrokeAlpha {
   double get();
}

Property Value

The alpha value for stroke operations.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualObjectGraphicsState Class
PdfVisualObjectGraphicsState Members


%%PageItemTitle%%

PdfPathItemType Enumeration

Xfinium.Pdf.Content Namespace : PdfPathItemType Enumeration
Specifies the supported types for the items in a PdfPathVisualObject.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPathItemType
   Inherits System.Enum
'Usage

Dim instance As PdfPathItemType
public enum PdfPathItemType : System.Enum
public enum class PdfPathItemType : public System.Enum
Members
Member | Description
CCurveTo | C-type curve to item.
CloseSubpath | Close subpath item.
LineTo | Line to item.
MoveTo | Move to item.
Rectangle | Rectangle item.
VCurveTo | V-type curve to item.
YCurveTo | Y-type curve to item.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Content.PdfPathItemType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfTextSearchOptions Enumeration

Xfinium.Pdf.Content Namespace : PdfTextSearchOptions Enumeration
Supported options when searching text in PDF pages.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PdfTextSearchOptions
   Inherits System.Enum
'Usage

Dim instance As PdfTextSearchOptions
[Flags()]
public enum PdfTextSearchOptions : System.Enum
[Flags()]
public enum class PdfTextSearchOptions : public System.Enum
Members
Member | Description
CaseInsensitiveSearch | Case insensitive search, it is the default search. Can be combined with WholeWordSearch.
CaseSensitiveSearch | Case sensitive search. Can be combined with WholeWordSearch.
RegExSearch | Regular expression search. Other flags are ignored if they are combined.
WholeWordSearch | Whole word search. Can be combined with CaseInsensitiveSearch or CaseSensitiveSearch.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Content.PdfTextSearchOptions

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfVisualImageFormat Enumeration

Xfinium.Pdf.Content Namespace : PdfVisualImageFormat Enumeration
Specifies the supported formats for images displayed on a PDF page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfVisualImageFormat
   Inherits System.Enum
'Usage

Dim instance As PdfVisualImageFormat
public enum PdfVisualImageFormat : System.Enum
public enum class PdfVisualImageFormat : public System.Enum
Members
Member | Description
Jpeg | The image is embedded in the Pdf file as a JPEG image.
Jpeg2000 | The image is embedded in the Pdf file as a JPEG2000 image.
Raw | The image is embedded in the Pdf file in RAW format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Content.PdfVisualImageFormat

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfVisualImageSaveFormat Enumeration

Xfinium.Pdf.Content Namespace : PdfVisualImageSaveFormat Enumeration
Specifies the supported formats for saving a visual image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfVisualImageSaveFormat
   Inherits System.Enum
'Usage

Dim instance As PdfVisualImageSaveFormat
public enum PdfVisualImageSaveFormat : System.Enum
public enum class PdfVisualImageSaveFormat : public System.Enum
Members
Member | Description
Native | The image is saved in the format used for storing it in the Pdf file. Note: JPEG2000 images can be saved only in native format.
Png | The image is saved in PNG format. Note: JPEG2000 images cannot be saved in PNG format.
Raw | The image is saved in RAW format. Note: JPEG2000 images cannot be saved in RAW format.
Tiff | The image is saved in TIFF format. Note: JPEG2000 images cannot be saved in TIFF format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Content.PdfVisualImageSaveFormat

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfVisualObjectType Enumeration

Xfinium.Pdf.Content Namespace : PdfVisualObjectType Enumeration
Supported visual objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfVisualObjectType
   Inherits System.Enum
'Usage

Dim instance As PdfVisualObjectType
public enum PdfVisualObjectType : System.Enum
public enum class PdfVisualObjectType : public System.Enum
Members
Member | Description
FormXObject | Form XObject visual object (a graphic container)
Image | Image visual object.
Path | Path visual object.
Shading | Shading visual object
Text | Text visual object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Content.PdfVisualObjectType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Content Namespace


Xfinium.Pdf.Core Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfFile | Defines a PDF file. Defines a PDF file.
Class | PdfNames | Standard PDF names.
Class | PdfPageInfo | Defines basic information about a PDF page.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Core Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Xfinium.Pdf.Core.PdfFile
Xfinium.Pdf.Core.PdfNames
Xfinium.Pdf.Core.PdfPageInfo
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfFile Class
Members

Xfinium.Pdf.Core Namespace : PdfFile Class
Defines a PDF file. Defines a PDF file.
Object Model
PdfFile ClassPdfSecurityHandler Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFile
'Usage

Dim instance As PdfFile
public class PdfFile
public ref class PdfFile
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.PdfFile

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Members
Xfinium.Pdf.Core Namespace


%%PageItemTitle%% $$Members$$

PdfFile Class Members
Properties Methods

Xfinium.Pdf.Core Namespace : PdfFile Class

The following tables list the members exposed by PdfFile.

Public Constructors
 | Name | Description
Public Constructor | PdfFile Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | PageCount | Gets the number of pages.
Public Property | SecurityHandler | Gets the file security handler.
Top
Public Methods
 | Name | Description
Public Method | ExtractDocumentInformation | Extracts the document information from the PDF files.
Public Method | ExtractFileAttachments | Extracts the file attachments from the PDF file.
Public Method | ExtractJavaScriptFragments | Extracts the JavaScript code from the PDF file.
Public Method | ExtractNamedDestinations | Overloaded. Extracts the named destinations from the PDF file.
Public Method | ExtractOutlines | Extracts the outlines from the PDF file.
Public Method | ExtractPage | Extracts a page from the PDF file.
Public Method | ExtractPageContent | Overloaded. Extracts the content of a PDF page.
Public Method | ExtractPageInfo | Extracts the page information from the PDF file.
Public Method | ExtractPageOptionalContentGroup | Extracts the content of an optional content group.
Public Method | ExtractPageOptionalContentGroupNames | Extracts the names of the optional content groups defined on the page.
static (Shared in Visual Basic) | GetPdfFileEncryptionAlgorithm | Gets the encryption algorithm used by the PDF file in the input stream.
static (Shared in Visual Basic) | IsPdfFileEncrypted | Verifies if the PDF file is encrypted.
static (Shared in Visual Basic) | IsPdfFileOwnerPassword | Verifies if the password matches the owner password set on the PDF file.
static (Shared in Visual Basic) | IsPdfFileUserPassword | Verifies if the password matches the user password set on the PDF file.
Top
See Also

Reference

PdfFile Class
Xfinium.Pdf.Core Namespace


%%PageItemTitle%%

PdfFile Constructor

Xfinium.Pdf.Core Namespace > PdfFile Class : PdfFile Constructor
Overload List
Overload | Description
PdfFile Constructor(Stream) | Initializes a new PdfFile object from a stream.
PdfFile Constructor(Stream,String) | Initializes a new PdfFile object from a stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


%%PageItemTitle%%

PdfFile Constructor(Stream)

Xfinium.Pdf.Core Namespace > PdfFile Class > PdfFile Constructor : PdfFile Constructor(Stream)
Stream with the PDF file.
Initializes a new PdfFile object from a stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfFile(stream)
public PdfFile(
   Stream stream
)
public:
PdfFile(
   Stream^ stream
)

Parameters

stream
Stream with the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members
Overload List


%%PageItemTitle%%

PdfFile Constructor(Stream,String)

Xfinium.Pdf.Core Namespace > PdfFile Class > PdfFile Constructor : PdfFile Constructor(Stream,String)
Stream with the PDF file.
Password for decrypting the PDF file.
Initializes a new PdfFile object from a stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal password As String _
)
'Usage

Dim stream As Stream
Dim password As String

Dim instance As New PdfFile(stream, password)
public PdfFile(
   Stream stream,
   string password
)
public:
PdfFile(
   Stream^ stream,
   String^ password
)

Parameters

stream
Stream with the PDF file.
password
Password for decrypting the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfFile Class Methods

Xfinium.Pdf.Core Namespace : PdfFile Class

For a list of all members of this type, see PdfFile members.

Public Methods
 | Name | Description
Public Method | ExtractDocumentInformation | Extracts the document information from the PDF files.
Public Method | ExtractFileAttachments | Extracts the file attachments from the PDF file.
Public Method | ExtractJavaScriptFragments | Extracts the JavaScript code from the PDF file.
Public Method | ExtractNamedDestinations | Overloaded. Extracts the named destinations from the PDF file.
Public Method | ExtractOutlines | Extracts the outlines from the PDF file.
Public Method | ExtractPage | Extracts a page from the PDF file.
Public Method | ExtractPageContent | Overloaded. Extracts the content of a PDF page.
Public Method | ExtractPageInfo | Extracts the page information from the PDF file.
Public Method | ExtractPageOptionalContentGroup | Extracts the content of an optional content group.
Public Method | ExtractPageOptionalContentGroupNames | Extracts the names of the optional content groups defined on the page.
static (Shared in Visual Basic) | GetPdfFileEncryptionAlgorithm | Gets the encryption algorithm used by the PDF file in the input stream.
static (Shared in Visual Basic) | IsPdfFileEncrypted | Verifies if the PDF file is encrypted.
static (Shared in Visual Basic) | IsPdfFileOwnerPassword | Verifies if the password matches the owner password set on the PDF file.
static (Shared in Visual Basic) | IsPdfFileUserPassword | Verifies if the password matches the user password set on the PDF file.
Top
See Also

Reference

PdfFile Class
Xfinium.Pdf.Core Namespace


ExtractDocumentInformation Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractDocumentInformation Method
Extracts the document information from the PDF files.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractDocumentInformation() As PdfDocumentInformation
'Usage

Dim instance As PdfFile
Dim value As PdfDocumentInformation

value = instance.ExtractDocumentInformation()
public PdfDocumentInformation ExtractDocumentInformation()
public:
PdfDocumentInformation^ ExtractDocumentInformation();

Return Value

The document information, if it exists in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractFileAttachments Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractFileAttachments Method
Extracts the file attachments from the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractFileAttachments() As PdfDocumentFileAttachmentCollection
'Usage

Dim instance As PdfFile
Dim value As PdfDocumentFileAttachmentCollection

value = instance.ExtractFileAttachments()
public PdfDocumentFileAttachmentCollection ExtractFileAttachments()
public:
PdfDocumentFileAttachmentCollection^ ExtractFileAttachments();

Return Value

The collection of file attachments in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractJavaScriptFragments Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractJavaScriptFragments Method
Extracts the JavaScript code from the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractJavaScriptFragments() As PdfJavaScriptBlockCollection
'Usage

Dim instance As PdfFile
Dim value As PdfJavaScriptBlockCollection

value = instance.ExtractJavaScriptFragments()
public PdfJavaScriptBlockCollection ExtractJavaScriptFragments()
public:
PdfJavaScriptBlockCollection^ ExtractJavaScriptFragments();

Return Value

The collection of JavaScript fragments in the Pdf file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractNamedDestinations Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractNamedDestinations Method
Extracts the named destinations from the PDF file.
Overload List
Overload | Description
ExtractNamedDestinations() | Extracts the named destinations from the PDF file.
ExtractNamedDestinations(Boolean) | Extracts the named destinations from the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractNamedDestinations() Method

Xfinium.Pdf.Core Namespace > PdfFile Class > ExtractNamedDestinations Method : ExtractNamedDestinations() Method
Extracts the named destinations from the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractNamedDestinations() As PdfNamedDestinationCollection
'Usage

Dim instance As PdfFile
Dim value As PdfNamedDestinationCollection

value = instance.ExtractNamedDestinations()
public PdfNamedDestinationCollection ExtractNamedDestinations()
public:
PdfNamedDestinationCollection^ ExtractNamedDestinations();

Return Value

The collection of named destinations in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members
Overload List


ExtractNamedDestinations(Boolean) Method

Xfinium.Pdf.Core Namespace > PdfFile Class > ExtractNamedDestinations Method : ExtractNamedDestinations(Boolean) Method
True if fast lookup should be enabled for the named destinations collection.
Extracts the named destinations from the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractNamedDestinations( _
   ByVal enableFastLookup As Boolean _
) As PdfNamedDestinationCollection
'Usage

Dim instance As PdfFile
Dim enableFastLookup As Boolean
Dim value As PdfNamedDestinationCollection

value = instance.ExtractNamedDestinations(enableFastLookup)
public PdfNamedDestinationCollection ExtractNamedDestinations(
   bool enableFastLookup
)
public:
PdfNamedDestinationCollection^ ExtractNamedDestinations(
   bool enableFastLookup
)

Parameters

enableFastLookup
True if fast lookup should be enabled for the named destinations collection.

Return Value

The collection of named destinations in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members
Overload List


ExtractOutlines Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractOutlines Method
Extracts the outlines from the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractOutlines() As PdfOutlineItemCollection
'Usage

Dim instance As PdfFile
Dim value As PdfOutlineItemCollection

value = instance.ExtractOutlines()
public PdfOutlineItemCollection ExtractOutlines()
public:
PdfOutlineItemCollection^ ExtractOutlines();

Return Value

The collection of outlines in the PDF file
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractPage Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractPage Method
The page to extract.
Extracts a page from the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractPage( _
   ByVal pageNumber As Integer _
) As PdfPage
'Usage

Dim instance As PdfFile
Dim pageNumber As Integer
Dim value As PdfPage

value = instance.ExtractPage(pageNumber)
public PdfPage ExtractPage(
   int pageNumber
)
public:
PdfPage^ ExtractPage(
   int pageNumber
)

Parameters

pageNumber
The page to extract.

Return Value

The PDF page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractPageContent Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractPageContent Method
Extracts the content of a PDF page.
Overload List
Overload | Description
ExtractPageContent(Int32) | Extracts the content of a PDF page.
ExtractPageContent(Int32,Int32) | Extracts the content of a PDF page set.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractPageContent(Int32) Method

Xfinium.Pdf.Core Namespace > PdfFile Class > ExtractPageContent Method : ExtractPageContent(Int32) Method
The page to extract the content from.
Extracts the content of a PDF page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractPageContent( _
   ByVal pageNumber As Integer _
) As PdfPageContent
'Usage

Dim instance As PdfFile
Dim pageNumber As Integer
Dim value As PdfPageContent

value = instance.ExtractPageContent(pageNumber)
public PdfPageContent ExtractPageContent(
   int pageNumber
)
public:
PdfPageContent^ ExtractPageContent(
   int pageNumber
)

Parameters

pageNumber
The page to extract the content from.

Return Value

The page content in vector format.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members
Overload List


ExtractPageContent(Int32,Int32) Method

Xfinium.Pdf.Core Namespace > PdfFile Class > ExtractPageContent Method : ExtractPageContent(Int32,Int32) Method
Start page to extract the content from.
End page to extract the content from.
Extracts the content of a PDF page set.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function ExtractPageContent( _
   ByVal fromPage As Integer, _
   ByVal toPage As Integer _
) As PdfPageContent()
'Usage

Dim instance As PdfFile
Dim fromPage As Integer
Dim toPage As Integer
Dim value() As PdfPageContent

value = instance.ExtractPageContent(fromPage, toPage)
public PdfPageContent[] ExtractPageContent(
   int fromPage,
   int toPage
)
public:
array<PdfPageContent^>^ ExtractPageContent(
   int fromPage,
   int toPage
)

Parameters

fromPage
Start page to extract the content from.
toPage
End page to extract the content from.

Return Value

Array of page contents in vector format.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members
Overload List


ExtractPageInfo Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractPageInfo Method
The page number for which the information is extracted.
Extracts the page information from the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractPageInfo( _
   ByVal pageNumber As Integer _
) As PdfPageInfo
'Usage

Dim instance As PdfFile
Dim pageNumber As Integer
Dim value As PdfPageInfo

value = instance.ExtractPageInfo(pageNumber)
public PdfPageInfo ExtractPageInfo(
   int pageNumber
)
public:
PdfPageInfo^ ExtractPageInfo(
   int pageNumber
)

Parameters

pageNumber
The page number for which the information is extracted.

Return Value

Information about the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractPageOptionalContentGroup Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractPageOptionalContentGroup Method
The page to extract the optional content from.
The name of the optional content group to be extracted.
Extracts the content of an optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractPageOptionalContentGroup( _
   ByVal pageNumber As Integer, _
   ByVal ocgName As String _
) As PdfPageOptionalContent
'Usage

Dim instance As PdfFile
Dim pageNumber As Integer
Dim ocgName As String
Dim value As PdfPageOptionalContent

value = instance.ExtractPageOptionalContentGroup(pageNumber, ocgName)
public PdfPageOptionalContent ExtractPageOptionalContentGroup(
   int pageNumber,
   string ocgName
)
public:
PdfPageOptionalContent^ ExtractPageOptionalContentGroup(
   int pageNumber,
   String^ ocgName
)

Parameters

pageNumber
The page to extract the optional content from.
ocgName
The name of the optional content group to be extracted.

Return Value

The page optional content group in vector format.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


ExtractPageOptionalContentGroupNames Method

Xfinium.Pdf.Core Namespace > PdfFile Class : ExtractPageOptionalContentGroupNames Method
The page to extract the optional content group names from.
Extracts the names of the optional content groups defined on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ExtractPageOptionalContentGroupNames( _
   ByVal pageNumber As Integer _
) As String()
'Usage

Dim instance As PdfFile
Dim pageNumber As Integer
Dim value() As String

value = instance.ExtractPageOptionalContentGroupNames(pageNumber)
public string[] ExtractPageOptionalContentGroupNames(
   int pageNumber
)
public:
array<String^>^ ExtractPageOptionalContentGroupNames(
   int pageNumber
)

Parameters

pageNumber
The page to extract the optional content group names from.

Return Value

An array of strings representing the optional content groups defined on the page or null if the page does not contain any optional content groups.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


GetPdfFileEncryptionAlgorithm Method

Xfinium.Pdf.Core Namespace > PdfFile Class : GetPdfFileEncryptionAlgorithm Method
Stream that contains the PDF file.
Returns the size in bits of the encryption key.
Gets the encryption algorithm used by the PDF file in the input stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function GetPdfFileEncryptionAlgorithm( _
   ByVal stream As Stream, _
   ByRef keySize As Integer _
) As PdfEncryptionAlgorithm
'Usage

Dim stream As Stream
Dim keySize As Integer
Dim value As PdfEncryptionAlgorithm

value = PdfFile.GetPdfFileEncryptionAlgorithm(stream, keySize)
public static PdfEncryptionAlgorithm GetPdfFileEncryptionAlgorithm(
   Stream stream,
   out int keySize
)
public:
static PdfEncryptionAlgorithm GetPdfFileEncryptionAlgorithm(
   Stream^ stream,
   [Out] int keySize
)

Parameters

stream
Stream that contains the PDF file.
keySize
Returns the size in bits of the encryption key.

Return Value

The encryption algorithm.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


IsPdfFileEncrypted Method

Xfinium.Pdf.Core Namespace > PdfFile Class : IsPdfFileEncrypted Method
Stream that contains the PDF file.
Verifies if the PDF file is encrypted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function IsPdfFileEncrypted( _
   ByVal stream As Stream _
) As Boolean
'Usage

Dim stream As Stream
Dim value As Boolean

value = PdfFile.IsPdfFileEncrypted(stream)
public static bool IsPdfFileEncrypted(
   Stream stream
)
public:
static bool IsPdfFileEncrypted(
   Stream^ stream
)

Parameters

stream
Stream that contains the PDF file.

Return Value

True if the PDF file is encrypted, false otherwise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


IsPdfFileOwnerPassword Method

Xfinium.Pdf.Core Namespace > PdfFile Class : IsPdfFileOwnerPassword Method
Stream that contains the PDF file.
Password to verify.
Verifies if the password matches the owner password set on the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function IsPdfFileOwnerPassword( _
   ByVal stream As Stream, _
   ByVal password As String _
) As Boolean
'Usage

Dim stream As Stream
Dim password As String
Dim value As Boolean

value = PdfFile.IsPdfFileOwnerPassword(stream, password)
public static bool IsPdfFileOwnerPassword(
   Stream stream,
   string password
)
public:
static bool IsPdfFileOwnerPassword(
   Stream^ stream,
   String^ password
)

Parameters

stream
Stream that contains the PDF file.
password
Password to verify.

Return Value

True if the password is the owner password, false if the password is not the owner password or the file is not encrypted.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


IsPdfFileUserPassword Method

Xfinium.Pdf.Core Namespace > PdfFile Class : IsPdfFileUserPassword Method
Stream that contains the PDF file.
Password to verify.
Verifies if the password matches the user password set on the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function IsPdfFileUserPassword( _
   ByVal stream As Stream, _
   ByVal password As String _
) As Boolean
'Usage

Dim stream As Stream
Dim password As String
Dim value As Boolean

value = PdfFile.IsPdfFileUserPassword(stream, password)
public static bool IsPdfFileUserPassword(
   Stream stream,
   string password
)
public:
static bool IsPdfFileUserPassword(
   Stream^ stream,
   String^ password
)

Parameters

stream
Stream that contains the PDF file.
password
Password to verify.

Return Value

True if the password is the user password, false if the password is not the user password or the file is not encrypted.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


%%PageItemTitle%% $$Properties$$

PdfFile Class Properties

Xfinium.Pdf.Core Namespace : PdfFile Class

For a list of all members of this type, see PdfFile members.

Public Properties
 | Name | Description
Public Property | PageCount | Gets the number of pages.
Public Property | SecurityHandler | Gets the file security handler.
Top
See Also

Reference

PdfFile Class
Xfinium.Pdf.Core Namespace


PageCount Property

Xfinium.Pdf.Core Namespace > PdfFile Class : PageCount Property
Gets the number of pages.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As PdfFile
Dim value As Integer

value = instance.PageCount
public int PageCount {get;}
public:
property int PageCount {
   int get();
}

Property Value

The number of pages in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


SecurityHandler Property (PdfFile)

Xfinium.Pdf.Core Namespace > PdfFile Class : SecurityHandler Property
Gets the file security handler.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SecurityHandler As PdfSecurityHandler
'Usage

Dim instance As PdfFile
Dim value As PdfSecurityHandler

value = instance.SecurityHandler
public PdfSecurityHandler SecurityHandler {get;}
public:
property PdfSecurityHandler^ SecurityHandler {
   PdfSecurityHandler^ get();
}

Property Value

The security handler that was used to encrypt the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFile Class
PdfFile Members


%%PageItemTitle%%

PdfNames Class
Members

Xfinium.Pdf.Core Namespace : PdfNames Class
Standard PDF names.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfNames
'Usage

Dim instance As PdfNames
public class PdfNames
public ref class PdfNames
Remarks
This class supports the internal library infrastructure and it should not be used by other applications.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.PdfNames

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Members
Xfinium.Pdf.Core Namespace


%%PageItemTitle%% $$Members$$

PdfNames Class Members
Fields Methods

Xfinium.Pdf.Core Namespace : PdfNames Class

The following tables list the members exposed by PdfNames.

Public Constructors
 | Name | Description
Public Constructor | PdfNames Constructor |
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | _3D | The /3D key
static (Shared in Visual Basic) | _3DA | The /3DA key
static (Shared in Visual Basic) | _3DAnimationStyle | The /3DAnimationStyle key
static (Shared in Visual Basic) | _3DBG | The /3DBG key
static (Shared in Visual Basic) | _3DD | The /3DD key
static (Shared in Visual Basic) | _3DRenderMode | The /3DRenderMode key
static (Shared in Visual Basic) | _3DView | The /3DView key
static (Shared in Visual Basic) | A | The /A key
static (Shared in Visual Basic) | AA | The /AA key
static (Shared in Visual Basic) | AbsoluteColorimetric | The /AbsoluteColorimetric key
static (Shared in Visual Basic) | AC | The /AC key
static (Shared in Visual Basic) | AcroForm | The /AcroForm key
static (Shared in Visual Basic) | Action | The /Action key
static (Shared in Visual Basic) | Activation | The /Activation key
static (Shared in Visual Basic) | ActualText | The /ActualText key
static (Shared in Visual Basic) | ADBE | The /ADBE key
static (Shared in Visual Basic) | AESV2 | The /AESV2 key
static (Shared in Visual Basic) | AIS | The /AIS key
static (Shared in Visual Basic) | All | The /All key
static (Shared in Visual Basic) | AllPages | The /AllPages key
static (Shared in Visual Basic) | Alt | The /Alt key
static (Shared in Visual Basic) | ALT | The /ALT key
static (Shared in Visual Basic) | Alternate | The /Alternate key
static (Shared in Visual Basic) | Alternates | The /Alternates key
static (Shared in Visual Basic) | AN | The /AN key
static (Shared in Visual Basic) | Animation | The /Animation key
static (Shared in Visual Basic) | Annot | The /Annot key
static (Shared in Visual Basic) | Annots | The /Annots key
static (Shared in Visual Basic) | AntiAlias | The /AntiAlias key
static (Shared in Visual Basic) | AP | The /AP key
static (Shared in Visual Basic) | AppDefault | The /AppDefault key
static (Shared in Visual Basic) | Art | The /Art key
static (Shared in Visual Basic) | ArtBox | The /ArtBox key
static (Shared in Visual Basic) | AS | The /AS key
static (Shared in Visual Basic) | Ascent | The /Ascent key
static (Shared in Visual Basic) | ASCII85Decode | The /ASCII85Decode key
static (Shared in Visual Basic) | ASCIIHexDecode | The /ASCIIHexDecode key
static (Shared in Visual Basic) | Asset | The /Asset key
static (Shared in Visual Basic) | Assets | The /Assets key
static (Shared in Visual Basic) | AuthEvent | The /AuthEvent key
static (Shared in Visual Basic) | Author | The /Author key
static (Shared in Visual Basic) | AvgWidth | The /AvgWidth key
static (Shared in Visual Basic) | B | The /B key
static (Shared in Visual Basic) | Background | The /Background key
static (Shared in Visual Basic) | BaseEncoding | The /BaseEncoding key
static (Shared in Visual Basic) | BaseFont | The /BaseFont key
static (Shared in Visual Basic) | BaseVersion | The /BaseVersion key
static (Shared in Visual Basic) | BatesN | The /BatesN key
static (Shared in Visual Basic) | BBox | The /BBox key
static (Shared in Visual Basic) | BC | The /BC key
static (Shared in Visual Basic) | BE | The /BE key
static (Shared in Visual Basic) | BG | The /BG key
static (Shared in Visual Basic) | BibEntry | The /BibEntry key
static (Shared in Visual Basic) | BigFive | The /BigFive key
static (Shared in Visual Basic) | Binding | The /Binding key
static (Shared in Visual Basic) | BindingMaterialName | The /BindingMaterialName key
static (Shared in Visual Basic) | BitsPerComponent | The /BitsPerComponent key
static (Shared in Visual Basic) | BitsPerCoordinate | The /BitsPerCoordinate key
static (Shared in Visual Basic) | BitsPerFlag | The /BitsPerFlag key
static (Shared in Visual Basic) | BitsPerSample | The /BitsPerSample key
static (Shared in Visual Basic) | Bl | The /Bl key
static (Shared in Visual Basic) | BlackIs1 | The /BlackIs1 key
static (Shared in Visual Basic) | BlackPoint | The /BlackPoint key
static (Shared in Visual Basic) | BleedBox | The /BleedBox key
static (Shared in Visual Basic) | Blinds | The /Blinds key
static (Shared in Visual Basic) | BlockQuote | The /BlockQuote key
static (Shared in Visual Basic) | BM | The /BM key
static (Shared in Visual Basic) | Border | The /Border key
static (Shared in Visual Basic) | Bounds | The /Bounds key
static (Shared in Visual Basic) | Box | The /Box key
static (Shared in Visual Basic) | BS | The /BS key
static (Shared in Visual Basic) | Btn | The /Btn key
static (Shared in Visual Basic) | ByteRange | The /ByteRange key
static (Shared in Visual Basic) | C | The /C key
static (Shared in Visual Basic) | C0 | The /C0 key
static (Shared in Visual Basic) | C1 | The /C1 key
static (Shared in Visual Basic) | C2W | The /C2W key
static (Shared in Visual Basic) | ca | The /ca key
static (Shared in Visual Basic) | CA | The /CA key
static (Shared in Visual Basic) | CalGray | The /CalGray key
static (Shared in Visual Basic) | CalRGB | The /CalRGB key
static (Shared in Visual Basic) | CapHeight | The /CapHeight key
static (Shared in Visual Basic) | Caption | The /Caption key
static (Shared in Visual Basic) | Catalog | The /Catalog key
static (Shared in Visual Basic) | Category | The /Category key
static (Shared in Visual Basic) | CCITTFaxDecode | The /CCITTFaxDecode key
static (Shared in Visual Basic) | Center | The /Center key
static (Shared in Visual Basic) | CenterWindow | The /CenterWindow key
static (Shared in Visual Basic) | Cert | The /Cert key
static (Shared in Visual Basic) | CF | The /CF key
static (Shared in Visual Basic) | CFM | The /CFM key
static (Shared in Visual Basic) | Ch | The /Ch key
static (Shared in Visual Basic) | CharProcs | The /CharProcs key
static (Shared in Visual Basic) | Child | The /Child key
static (Shared in Visual Basic) | CI | The /CI key
static (Shared in Visual Basic) | CIDFontType0 | The /CIDFontType0 key
static (Shared in Visual Basic) | CIDFontType2 | The /CIDFontType2 key
static (Shared in Visual Basic) | CIDSet | The /CIDSet key
static (Shared in Visual Basic) | CIDSystemInfo | The /CIDSystemInfo key
static (Shared in Visual Basic) | CIDToGIDMap | The /CIDToGIDMap key
static (Shared in Visual Basic) | Circle | The /Circle key
static (Shared in Visual Basic) | Cloud | The /Cloud key
static (Shared in Visual Basic) | CMapName | The /CMapName key
static (Shared in Visual Basic) | CMD | The /CMD key
static (Shared in Visual Basic) | CO | The /CO key
static (Shared in Visual Basic) | Code | The /Code key
static (Shared in Visual Basic) | Collection | The /Collection key
static (Shared in Visual Basic) | CollectionField | The /CollectionField key
static (Shared in Visual Basic) | CollectionItem | The /CollectionItem key
static (Shared in Visual Basic) | CollectionSchema | The /CollectionSchema key
static (Shared in Visual Basic) | CollectionSort | The /CollectionSort key
static (Shared in Visual Basic) | CollectionSubitem | The /CollectionSubitem key
static (Shared in Visual Basic) | Colors | The /Colors key
static (Shared in Visual Basic) | ColorSpace | The /ColorSpace key
static (Shared in Visual Basic) | Columns | The /Columns key
static (Shared in Visual Basic) | Condition | The /Condition key
static (Shared in Visual Basic) | Configuration | The /Configuration key
static (Shared in Visual Basic) | Configurations | The /Configurations key
static (Shared in Visual Basic) | ContactInfo | The /ContactInfo key
static (Shared in Visual Basic) | Content | The /Content key
static (Shared in Visual Basic) | Contents | The /Contents key
static (Shared in Visual Basic) | Coords | The /Coords key
static (Shared in Visual Basic) | Count | The /Count key
static (Shared in Visual Basic) | Courier | The /Courier key
static (Shared in Visual Basic) | CourierBold | The /Courier-Bold key
static (Shared in Visual Basic) | CourierBoldOblique | The /Courier-BoldOblique key
static (Shared in Visual Basic) | CourierOblique | The /Courier-Oblique key
static (Shared in Visual Basic) | CreationDate | The /CreationDate key
static (Shared in Visual Basic) | Creator | The /Creator key
static (Shared in Visual Basic) | CreatorInfo | The /CreatorInfo key
static (Shared in Visual Basic) | CropBox | The /CropBox key
static (Shared in Visual Basic) | Crypt | The /Crypt key
static (Shared in Visual Basic) | CS | The /CS key
static (Shared in Visual Basic) | CT | The /CT key
static (Shared in Visual Basic) | CuePoint | The /CuePoint key
static (Shared in Visual Basic) | CuePoints | The /CuePoints key
static (Shared in Visual Basic) | CV | The /CV key
static (Shared in Visual Basic) | CXY | The /CXY key
static (Shared in Visual Basic) | D | The /D key
static (Shared in Visual Basic) | DA | The /DA key
static (Shared in Visual Basic) | Data | The /Data key
static (Shared in Visual Basic) | DC | The /DC key
static (Shared in Visual Basic) | DCS | The /DCS key
static (Shared in Visual Basic) | DCTDecode | The /DCTDecode key
static (Shared in Visual Basic) | Deactivation | The /Deactivation key
static (Shared in Visual Basic) | Decode | The /Decode key
static (Shared in Visual Basic) | DecodeParms | The /DecodeParms key
static (Shared in Visual Basic) | Default | The /Default key
static (Shared in Visual Basic) | DefaultCMYK | The /DefaultCMYK key
static (Shared in Visual Basic) | DefaultCryptFilter | The /DefaultCryptFilter key
static (Shared in Visual Basic) | DefaultForPrinting | The /DefaultForPrinting key
static (Shared in Visual Basic) | DefaultGray | The /DefaultGray key
static (Shared in Visual Basic) | DefaultRGB | The /DefaultRGB key
static (Shared in Visual Basic) | DEG | The /DEG key
static (Shared in Visual Basic) | Desc | The /Desc key
static (Shared in Visual Basic) | DescendantFonts | The /DescendantFonts key
static (Shared in Visual Basic) | Descent | The /Descent key
static (Shared in Visual Basic) | Dest | The /Dest key
static (Shared in Visual Basic) | DestOutputProfile | The /DestOutputProfile key
static (Shared in Visual Basic) | Dests | The /Dests key
static (Shared in Visual Basic) | DeviceCMYK | The /DeviceCMYK key
static (Shared in Visual Basic) | DeviceGray | The /DeviceGray key
static (Shared in Visual Basic) | DeviceN | The /DeviceN key
static (Shared in Visual Basic) | DeviceRGB | The /DeviceRGB key
static (Shared in Visual Basic) | Di | The /Di key
static (Shared in Visual Basic) | Differences | The /Differences key
static (Shared in Visual Basic) | Direction | The /Direction key
static (Shared in Visual Basic) | DIS | The /DIS key
static (Shared in Visual Basic) | DisplayDocTitle | The /DisplayDocTitle key
static (Shared in Visual Basic) | Dissolve | The /Dissolve key
static (Shared in Visual Basic) | Div | The /Div key
static (Shared in Visual Basic) | DL | The /DL key
static (Shared in Visual Basic) | Dm | The /Dm key
static (Shared in Visual Basic) | DocMDP | The /DocMDP key
static (Shared in Visual Basic) | DocOpen | The /DocOpen key
static (Shared in Visual Basic) | Domain | The /Domain key
static (Shared in Visual Basic) | DP | The /DP key
static (Shared in Visual Basic) | DR | The /DR key
static (Shared in Visual Basic) | Draft | The /Draft key
static (Shared in Visual Basic) | DS | The /DS key
static (Shared in Visual Basic) | Duplex | The /Duplex key
static (Shared in Visual Basic) | DuplexFlipLongEdge | The /DuplexFlipLongEdge key
static (Shared in Visual Basic) | DuplexFlipShortEdge | The /DuplexFlipShortEdge key
static (Shared in Visual Basic) | Dur | The /Dur key
static (Shared in Visual Basic) | DV | The /DV key
static (Shared in Visual Basic) | DW | The /DW key
static (Shared in Visual Basic) | E | The /E key
static (Shared in Visual Basic) | EA | The /EA key
static (Shared in Visual Basic) | EarlyChange | The /EarlyChange key
static (Shared in Visual Basic) | EF | The /EF key
static (Shared in Visual Basic) | EFF | The /EFF key
static (Shared in Visual Basic) | EFOpen | The /EFOpen key
static (Shared in Visual Basic) | Embedded | The /Embedded key
static (Shared in Visual Basic) | EmbeddedFile | The /EmbeddedFile key
static (Shared in Visual Basic) | EmbeddedFiles | The /EmbeddedFiles key
static (Shared in Visual Basic) | Encode | The /Encode key
static (Shared in Visual Basic) | EncodedByteAlign | The /EncodedByteAlign key
static (Shared in Visual Basic) | Encoding | The /Encoding key
static (Shared in Visual Basic) | Encrypt | The /Encrypt key
static (Shared in Visual Basic) | EncryptMetadata | The /EncryptMetadata key
static (Shared in Visual Basic) | EndOfBlock | The /EndOfBlock key
static (Shared in Visual Basic) | EndOfLine | The /EndOfLine key
static (Shared in Visual Basic) | EPSG | The /EPSG key
static (Shared in Visual Basic) | Event | The /Event key
static (Shared in Visual Basic) | Export | The /Export key
static (Shared in Visual Basic) | ExportState | The /ExportState key
static (Shared in Visual Basic) | Extend | The /Extend key
static (Shared in Visual Basic) | ExtensionLevel | The /ExtensionLevel key
static (Shared in Visual Basic) | Extensions | The /Extensions key
static (Shared in Visual Basic) | ExtGState | The /ExtGState key
static (Shared in Visual Basic) | F | The /F key
static (Shared in Visual Basic) | Far | The /Far key
static (Shared in Visual Basic) | FB | The /FB key
static (Shared in Visual Basic) | FC | The /FC key
static (Shared in Visual Basic) | FD | The /FD key
static (Shared in Visual Basic) | FDecodeParms | The /FDecodeParms key
static (Shared in Visual Basic) | FDF | The /FDF key
static (Shared in Visual Basic) | Ff | The /Ff key
static (Shared in Visual Basic) | FFilter | The /FFilter key
static (Shared in Visual Basic) | Fields | The /Fields key
static (Shared in Visual Basic) | FileAttachment | The /FileAttachment key
static (Shared in Visual Basic) | Filespec | The /Filespec key
static (Shared in Visual Basic) | Filter | The /Filter key
static (Shared in Visual Basic) | First | The /First key
static (Shared in Visual Basic) | FirstChar | The /FirstChar key
static (Shared in Visual Basic) | FirstPage | The /FirstPage key
static (Shared in Visual Basic) | Fit | The /Fit key
static (Shared in Visual Basic) | FitB | The /FitB key
static (Shared in Visual Basic) | FitBH | The /FitBH key
static (Shared in Visual Basic) | FitBV | The /FitBV key
static (Shared in Visual Basic) | FitH | The /FitH key
static (Shared in Visual Basic) | FitR | The /FitR key
static (Shared in Visual Basic) | FitV | The /FitV key
static (Shared in Visual Basic) | FitWindow | The /FitWindow key
static (Shared in Visual Basic) | Flags | The /Flags key
static (Shared in Visual Basic) | Flash | The /Flash key
static (Shared in Visual Basic) | FlashVars | The /FlashVars key
static (Shared in Visual Basic) | FlateDecode | The /FlateDecode key
static (Shared in Visual Basic) | Fo | The /Fo key
static (Shared in Visual Basic) | Folder | The /Folder key
static (Shared in Visual Basic) | Folders | The /Folders key
static (Shared in Visual Basic) | Font | The /Font key
static (Shared in Visual Basic) | FontBBox | The /FontBBox key
static (Shared in Visual Basic) | FontDescriptor | The /FontDescriptor key
static (Shared in Visual Basic) | FontFile | The /FontFile key
static (Shared in Visual Basic) | FontFile2 | The /FontFile2 key
static (Shared in Visual Basic) | FontFile3 | The /FontFile3 key
static (Shared in Visual Basic) | FontMatrix | The /FontMatrix key
static (Shared in Visual Basic) | FontName | The /FontName key
static (Shared in Visual Basic) | Foreground | The /Foreground key
static (Shared in Visual Basic) | Form | The /Form key
static (Shared in Visual Basic) | FormType | The /FormType key
static (Shared in Visual Basic) | FOV | The /FOV key
static (Shared in Visual Basic) | FreeText | The /FreeText key
static (Shared in Visual Basic) | FRM | The /FRM key
static (Shared in Visual Basic) | FS | The /FS key
static (Shared in Visual Basic) | FT | The /FT key
static (Shared in Visual Basic) | FullScreen | The /FullScreen key
static (Shared in Visual Basic) | Function | The /Function key
static (Shared in Visual Basic) | Functions | The /Functions key
static (Shared in Visual Basic) | FunctionType | The /FunctionType key
static (Shared in Visual Basic) | G | The /G key
static (Shared in Visual Basic) | Gamma | The /Gamma key
static (Shared in Visual Basic) | GBK | The /GBK key
static (Shared in Visual Basic) | GCS | The /GCS key
static (Shared in Visual Basic) | GEO | The /GEO key
static (Shared in Visual Basic) | GEOGCS | The /GEOGCS key
static (Shared in Visual Basic) | Glitter | The /Glitter key
static (Shared in Visual Basic) | GoTo | The /GoTo key
static (Shared in Visual Basic) | GoTo3DView | The /GoTo3DView key
static (Shared in Visual Basic) | GoToE | The /GoToE key
static (Shared in Visual Basic) | GoToR | The /GoToR key
static (Shared in Visual Basic) | GPTS | The /GPTS key
static (Shared in Visual Basic) | GRD | The /GRD key
static (Shared in Visual Basic) | Group | The /Group key
static (Shared in Visual Basic) | GTS_PDFA1 | The /GTS_PdfA1 key
static (Shared in Visual Basic) | GTS_PDFX | The /GTS_PdfX key
static (Shared in Visual Basic) | GTS_PDFXVersion | The /GTS_PdfXVersion key
static (Shared in Visual Basic) | H | The /H key
static (Shared in Visual Basic) | H2 | The /H2 key
static (Shared in Visual Basic) | H3 | The /H3 key
static (Shared in Visual Basic) | H4 | The /H4 key
static (Shared in Visual Basic) | H5 | The /H5 key
static (Shared in Visual Basic) | H6 | The /H6 key
static (Shared in Visual Basic) | HA | The /HA key
static (Shared in Visual Basic) | HAlign | The /HAlign key
static (Shared in Visual Basic) | Height | The /Height key
static (Shared in Visual Basic) | Helv | The /Helv key
static (Shared in Visual Basic) | Helvetica | The /Helvetica key
static (Shared in Visual Basic) | HelveticaBold | The /Helvetica-Bold key
static (Shared in Visual Basic) | HelveticaBoldOblique | The /Helvetica-BoldOblique key
static (Shared in Visual Basic) | HelveticaOblique | The /Helvetica-Oblique key
static (Shared in Visual Basic) | Hid | The /Hid key
static (Shared in Visual Basic) | Hide | The /Hide key
static (Shared in Visual Basic) | HideMenubar | The /HideMenubar key
static (Shared in Visual Basic) | HideToolbar | The /HideToolbar key
static (Shared in Visual Basic) | HideWindowUI | The /HideWindowUI key
static (Shared in Visual Basic) | Highlight | The /Highlight key
static (Shared in Visual Basic) | HOffset | The /HOffset key
static (Shared in Visual Basic) | I | The /I key
static (Shared in Visual Basic) | IC | The /IC key
static (Shared in Visual Basic) | ICCBased | The /ICCBased key
static (Shared in Visual Basic) | ID | The /ID key
static (Shared in Visual Basic) | Identity | The /Identity key
static (Shared in Visual Basic) | IdentityH | The /IdentityH key
static (Shared in Visual Basic) | IdentityV | The /IdentityV key
static (Shared in Visual Basic) | IF | The /IF key
static (Shared in Visual Basic) | Image | The /Image key
static (Shared in Visual Basic) | ImageB | The /ImageB key
static (Shared in Visual Basic) | ImageC | The /ImageC key
static (Shared in Visual Basic) | ImageI | The /ImageI key
static (Shared in Visual Basic) | ImageMask | The /ImageMask key
static (Shared in Visual Basic) | ImportData | The /ImportData key
static (Shared in Visual Basic) | IN | The /IN key
static (Shared in Visual Basic) | Index | The /Index key
static (Shared in Visual Basic) | Indexed | The /Indexed key
static (Shared in Visual Basic) | Info | The /Info key
static (Shared in Visual Basic) | Ink | The /Ink key
static (Shared in Visual Basic) | InkList | The /InkList key
static (Shared in Visual Basic) | Instances | The /Instances key
static (Shared in Visual Basic) | Intent | The /Intent key
static (Shared in Visual Basic) | Interpolate | The /Interpolate key
static (Shared in Visual Basic) | IRT | The /IRT key
static (Shared in Visual Basic) | IsMap | The /IsMap key
static (Shared in Visual Basic) | ItalicAngle | The /ItalicAngle key
static (Shared in Visual Basic) | ITXT | The /ITXT key
static (Shared in Visual Basic) | IV | The /IV key
static (Shared in Visual Basic) | IX | The /IX key
static (Shared in Visual Basic) | JavaScript | The /JavaScript key
static (Shared in Visual Basic) | JBIG2Decode | The /JBIG2Decode key
static (Shared in Visual Basic) | JBIG2Globals | The /JBIG2Globals key
static (Shared in Visual Basic) | JPXDecode | The /JPXDecode key
static (Shared in Visual Basic) | JS | The /JS key
static (Shared in Visual Basic) | K | The /K key
static (Shared in Visual Basic) | Keywords | The /Keywords key
static (Shared in Visual Basic) | Kids | The /Kids key
static (Shared in Visual Basic) | KM | The /KM key
static (Shared in Visual Basic) | L | The /L key
static (Shared in Visual Basic) | L2R | The /L2R key
static (Shared in Visual Basic) | Lab | The /Lab key
static (Shared in Visual Basic) | Lang | The /Lang key
static (Shared in Visual Basic) | Language | The /Language key
static (Shared in Visual Basic) | Last | The /Last key
static (Shared in Visual Basic) | LastChar | The /LastChar key
static (Shared in Visual Basic) | LastPage | The /LastPage key
static (Shared in Visual Basic) | LAT | The /LAT key
static (Shared in Visual Basic) | Launch | The /Launch key
static (Shared in Visual Basic) | Lbl | The /Lbl key
static (Shared in Visual Basic) | LBody | The /LBody key
static (Shared in Visual Basic) | LE | The /LE key
static (Shared in Visual Basic) | Leading | The /Leading key
static (Shared in Visual Basic) | Length | The /Length key
static (Shared in Visual Basic) | Length1 | The /Length1 key
static (Shared in Visual Basic) | Length2 | The /Length2 key
static (Shared in Visual Basic) | Length3 | The /Length1 key
static (Shared in Visual Basic) | LI | The /LI key
static (Shared in Visual Basic) | Limits | The /Limits key
static (Shared in Visual Basic) | Line | The /Line key
static (Shared in Visual Basic) | Linear | The /Linear key
static (Shared in Visual Basic) | Link | The /Link key
static (Shared in Visual Basic) | ListMode | The /ListMode key
static (Shared in Visual Basic) | Location | The /Location key
static (Shared in Visual Basic) | Lock | The /Lock key
static (Shared in Visual Basic) | Locked | The /Locked key
static (Shared in Visual Basic) | LON | The /LON key
static (Shared in Visual Basic) | LPTS | The /LPTS key
static (Shared in Visual Basic) | LS | The /LS key
static (Shared in Visual Basic) | LZWDecode | The /LZWDecode key
static (Shared in Visual Basic) | M | The /M key
static (Shared in Visual Basic) | MacExpertEncoding | The /MacExpertEncoding key
static (Shared in Visual Basic) | MacRomanEncoding | The /MacRomanEncoding key
static (Shared in Visual Basic) | Marked | The /Marked key
static (Shared in Visual Basic) | MarkInfo | The /MarkInfo key
static (Shared in Visual Basic) | Mask | The /Mask key
static (Shared in Visual Basic) | Material | The /Material key
static (Shared in Visual Basic) | Matrix | The /Matrix key
static (Shared in Visual Basic) | Matte | The /Matte key
static (Shared in Visual Basic) | max | The /max key
static (Shared in Visual Basic) | Max | The /Max key
static (Shared in Visual Basic) | MaxLen | The /MaxLen key
static (Shared in Visual Basic) | MaxWidth | The /MaxWidth key
static (Shared in Visual Basic) | MCD | The /MCD key
static (Shared in Visual Basic) | MCID | The /MCID key
static (Shared in Visual Basic) | MCR | The /MCR key
static (Shared in Visual Basic) | Measure | The /Measure key
static (Shared in Visual Basic) | MediaBox | The /MediaBox key
static (Shared in Visual Basic) | Metadata | The /Metadata key
static (Shared in Visual Basic) | MI | The /MI key
static (Shared in Visual Basic) | min | The /min key
static (Shared in Visual Basic) | Min | The /Min key
static (Shared in Visual Basic) | MissingWidth | The /MissingWidth key
static (Shared in Visual Basic) | MK | The /MK key
static (Shared in Visual Basic) | MMType1 | The /MMType1 key
static (Shared in Visual Basic) | ModDate | The /ModDate key
static (Shared in Visual Basic) | MR | The /MR key
static (Shared in Visual Basic) | MS | The /MS key
static (Shared in Visual Basic) | Multiply | The /Multiply key
static (Shared in Visual Basic) | N | The /N key
static (Shared in Visual Basic) | n0 | The /n0 key
static (Shared in Visual Basic) | n1 | The /n1 key
static (Shared in Visual Basic) | n2 | The /n2 key
static (Shared in Visual Basic) | n3 | The /n3 key
static (Shared in Visual Basic) | n4 | The /n4 key
static (Shared in Visual Basic) | NA | The /NA key
static (Shared in Visual Basic) | Name | The /Name key
static (Shared in Visual Basic) | Named | The /Named key
static (Shared in Visual Basic) | Names | The /Names key
static (Shared in Visual Basic) | Navigation | The /Navigation key
static (Shared in Visual Basic) | NavigationPane | The /NavigationPane key
static (Shared in Visual Basic) | Near | The /Near key
static (Shared in Visual Basic) | NeedAppearances | The /NeedAppearances key
static (Shared in Visual Basic) | NewWindow | The /NewWindow key
static (Shared in Visual Basic) | Next | The /Next key
static (Shared in Visual Basic) | NextPage | The /NextPage key
static (Shared in Visual Basic) | NM | The /NM key
static (Shared in Visual Basic) | None | The /None key
static (Shared in Visual Basic) | NonFullScreenPageMode | The /NonFullScreenPageMode key
static (Shared in Visual Basic) | NonStruct | The /NonStruct key
static (Shared in Visual Basic) | Note | The /Note key
static (Shared in Visual Basic) | NP | The /NP key
static (Shared in Visual Basic) | NR | The /NR key
static (Shared in Visual Basic) | NumberFormat | The /NumberFormat key
static (Shared in Visual Basic) | NumCopies | The /NumCopies key
static (Shared in Visual Basic) | Nums | The /Nums key
static (Shared in Visual Basic) | O | The /O key
static (Shared in Visual Basic) | OB | The /OB key
static (Shared in Visual Basic) | Obj | The /Obj key
static (Shared in Visual Basic) | OBJR | The /OBJR key
static (Shared in Visual Basic) | ObjStm | The /ObjStm key
static (Shared in Visual Basic) | OC | The /OC key
static (Shared in Visual Basic) | OCG | The /OCG key
static (Shared in Visual Basic) | OCGs | The /OCGs key
static (Shared in Visual Basic) | OCMD | The /OCMD key
static (Shared in Visual Basic) | OCProperties | The /OCProperties key
static (Shared in Visual Basic) | Off | The /Off key
static (Shared in Visual Basic) | OFF | The /OFF key
static (Shared in Visual Basic) | ON | The /ON key
static (Shared in Visual Basic) | OneByteIdentityH | The /OneByteIdentityH key
static (Shared in Visual Basic) | OneColumn | The /OneColumn key
static (Shared in Visual Basic) | OnInstantiate | The /OnInstantiate key
static (Shared in Visual Basic) | op | The /op key
static (Shared in Visual Basic) | OP | The /OP key
static (Shared in Visual Basic) | Open | The /Open key
static (Shared in Visual Basic) | OpenAction | The /OpenAction key
static (Shared in Visual Basic) | OPI | The /OPI key
static (Shared in Visual Basic) | OPM | The /OPM key
static (Shared in Visual Basic) | Opt | The /Opt key
static (Shared in Visual Basic) | Order | The /Order key
static (Shared in Visual Basic) | Ordering | The /Ordering key
static (Shared in Visual Basic) | OS | The /OS key
static (Shared in Visual Basic) | Oscillating | The /Oscillating key
static (Shared in Visual Basic) | Outlines | The /Outlines key
static (Shared in Visual Basic) | OutputCondition | The /OutputCondition key
static (Shared in Visual Basic) | OutputConditionIdentifier | The /OutputConditionIdentifier key
static (Shared in Visual Basic) | OutputIntent | The /OutputIntent key
static (Shared in Visual Basic) | OutputIntents | The /OutputIntents key
static (Shared in Visual Basic) | OverlayText | The /OverlayText key
static (Shared in Visual Basic) | P | The /P key
static (Shared in Visual Basic) | Page | The /Page key
static (Shared in Visual Basic) | PageLabels | The /PageLabels key
static (Shared in Visual Basic) | PageLayout | The /PageLayout key
static (Shared in Visual Basic) | PageMode | The /PageMode key
static (Shared in Visual Basic) | Pages | The /Pages key
static (Shared in Visual Basic) | Pagination | The /Pagination key
static (Shared in Visual Basic) | PaintType | The /PaintType key
static (Shared in Visual Basic) | Panose | The /Panose key
static (Shared in Visual Basic) | Params | The /Params key
static (Shared in Visual Basic) | Parent | The /Parent key
static (Shared in Visual Basic) | ParentTree | The /ParentTree key
static (Shared in Visual Basic) | PassContextClick | The /PassContextClick key
static (Shared in Visual Basic) | Pattern | The /Pattern key
static (Shared in Visual Basic) | PatternType | The /PatternType key
static (Shared in Visual Basic) | PC | The /PC key
static (Shared in Visual Basic) | PDF | The /Pdf key
static (Shared in Visual Basic) | PdfDocEncoding | The /PdfDocEncoding key
static (Shared in Visual Basic) | PDU | The /PDU key
static (Shared in Visual Basic) | Perceptual | The /Perceptual key
static (Shared in Visual Basic) | Perms | The /Perms key
static (Shared in Visual Basic) | Pg | The /Pg key
static (Shared in Visual Basic) | PI | The /PI key
static (Shared in Visual Basic) | PickTrayByPdfSize | The /PickTrayByPdfSize key
static (Shared in Visual Basic) | PickTrayByPDFSize | The /PickTrayByPDFSize key
static (Shared in Visual Basic) | PieceInfo | The /PieceInfo key
static (Shared in Visual Basic) | PlayCount | The /PlayCount key
static (Shared in Visual Basic) | PO | The /PO key
static (Shared in Visual Basic) | Polygon | The /Polygon key
static (Shared in Visual Basic) | PolyLine | The /PolyLine key
static (Shared in Visual Basic) | Popup | The /Popup key
static (Shared in Visual Basic) | Position | The /Position key
static (Shared in Visual Basic) | Predictor | The /Predictor key
static (Shared in Visual Basic) | Preferred | The /Preferred key
static (Shared in Visual Basic) | Presentation | The /Presentation key
static (Shared in Visual Basic) | PreserveRB | The /PreserveRB key
static (Shared in Visual Basic) | Prev | The /Prev key
static (Shared in Visual Basic) | PrevPage | The /PrevPage key
static (Shared in Visual Basic) | Print | The /Print key
static (Shared in Visual Basic) | PrintArea | The /PrintArea key
static (Shared in Visual Basic) | PrintClip | The /PrintClip key
static (Shared in Visual Basic) | PrintPageRange | The /PrintPageRange key
static (Shared in Visual Basic) | PrintScaling | The /PrintScaling key
static (Shared in Visual Basic) | PrintState | The /PrintState key
static (Shared in Visual Basic) | Private | The /Private key
static (Shared in Visual Basic) | ProcSet | The /ProcSet key
static (Shared in Visual Basic) | Producer | The /Producer key
static (Shared in Visual Basic) | PROJCS | The /PROJCS key
static (Shared in Visual Basic) | Properties | The /Properties key
static (Shared in Visual Basic) | PS | The /PS key
static (Shared in Visual Basic) | PtData | The /PtData key
static (Shared in Visual Basic) | PushPin | The /PushPin key
static (Shared in Visual Basic) | PV | The /PV key
static (Shared in Visual Basic) | Q | The /Q key
static (Shared in Visual Basic) | QuadPoints | The /QuadPoints key
static (Shared in Visual Basic) | Quote | The /Quote key
static (Shared in Visual Basic) | R | The /R key
static (Shared in Visual Basic) | R2L | The /R2L key
static (Shared in Visual Basic) | Range | The /Range key
static (Shared in Visual Basic) | RBGroups | The /RBGroups key
static (Shared in Visual Basic) | RC | The /RC key
static (Shared in Visual Basic) | RD | The /RD key
static (Shared in Visual Basic) | Reason | The /Reason key
static (Shared in Visual Basic) | Recipients | The /Recipients key
static (Shared in Visual Basic) | Rect | The /Rect key
static (Shared in Visual Basic) | Redact | The /Redact key
static (Shared in Visual Basic) | Ref | The /Ref key
static (Shared in Visual Basic) | Reference | The /Reference key
static (Shared in Visual Basic) | Registry | The /Registry key
static (Shared in Visual Basic) | RegistryName | The /RegistryName key
static (Shared in Visual Basic) | RelativeColorimetric | The /RelativeColorimetric key
static (Shared in Visual Basic) | Rendition | The /Rendition key
static (Shared in Visual Basic) | ResetForm | The /ResetForm key
static (Shared in Visual Basic) | Resources | The /Resources key
static (Shared in Visual Basic) | RI | The /RI key
static (Shared in Visual Basic) | RichMedia | The /RichMedia key
static (Shared in Visual Basic) | RichMediaActivation | The /RichMediaActivation key
static (Shared in Visual Basic) | RichMediaAnimation | The /RichMediaAnimation key
static (Shared in Visual Basic) | RichMediaCommand | The /RichMediaCommand key
static (Shared in Visual Basic) | RichMediaConfiguration | The /RichMediaConfiguration key
static (Shared in Visual Basic) | RichMediaContent | The /RichMediaContent key
static (Shared in Visual Basic) | RichMediaDeactivation | The /RichMediaDeactivation key
static (Shared in Visual Basic) | RichMediaExecute | The /RichMediaExecute key
static (Shared in Visual Basic) | RichMediaInstance | The /RichMediaInstance key
static (Shared in Visual Basic) | RichMediaParams | The /RichMediaParams key
static (Shared in Visual Basic) | RichMediaPosition | The /RichMediaPosition key
static (Shared in Visual Basic) | RichMediaPresentation | The /RichMediaPresentation key
static (Shared in Visual Basic) | RichMediaSettings | The /RichMediaSettings key
static (Shared in Visual Basic) | RichMediaWindow | The /RichMediaWindow key
static (Shared in Visual Basic) | RL | The /RL key
static (Shared in Visual Basic) | RM | The /RM key
static (Shared in Visual Basic) | RO | The /RO key
static (Shared in Visual Basic) | RoleMap | The /RoleMap key
static (Shared in Visual Basic) | Root | The /Root key
static (Shared in Visual Basic) | Rotate | The /Rotate key
static (Shared in Visual Basic) | Rows | The /Rows key
static (Shared in Visual Basic) | RT | The /RT key
static (Shared in Visual Basic) | RunLengthDecode | The /RunLengthDecode key
static (Shared in Visual Basic) | RV | The /RV key
static (Shared in Visual Basic) | S | The /S key
static (Shared in Visual Basic) | SA | The /SA key
static (Shared in Visual Basic) | Saturation | The /Saturation key
static (Shared in Visual Basic) | SC | The /SC key
static (Shared in Visual Basic) | Schema | The /Schema key
static (Shared in Visual Basic) | Screen | The /Screen key
static (Shared in Visual Basic) | Scripts | The /Scripts key
static (Shared in Visual Basic) | Sect | The /Sect key
static (Shared in Visual Basic) | Separation | The /Separation key
static (Shared in Visual Basic) | SetOCGState | The /SetOCGState key
static (Shared in Visual Basic) | Settings | The /Settings key
static (Shared in Visual Basic) | Shading | The /Shading key
static (Shared in Visual Basic) | ShadingType | The /ShadingType key
static (Shared in Visual Basic) | ShiftJIS | The /Shift-JIS key
static (Shared in Visual Basic) | Sig | The /Sig key
static (Shared in Visual Basic) | SigFieldLock | The /SigFieldLock key
static (Shared in Visual Basic) | SigFlags | The /SigFlags key
static (Shared in Visual Basic) | SigRef | The /SigRef key
static (Shared in Visual Basic) | Simplex | The /Simplex key
static (Shared in Visual Basic) | SinglePage | The /SinglePage key
static (Shared in Visual Basic) | Size | The /Size key
static (Shared in Visual Basic) | SMask | The /SMask key
static (Shared in Visual Basic) | Sort | The /Sort key
static (Shared in Visual Basic) | Sound | The /Sound key
static (Shared in Visual Basic) | Span | The /Span key
static (Shared in Visual Basic) | Speed | The /Speed key
static (Shared in Visual Basic) | Split | The /Split key
static (Shared in Visual Basic) | SQFT | The /SQFT key
static (Shared in Visual Basic) | SQKM | The /SQKM key
static (Shared in Visual Basic) | SQM | The /SQM key
static (Shared in Visual Basic) | SQMI | The /SQMI key
static (Shared in Visual Basic) | Square | The /Square key
static (Shared in Visual Basic) | Squiggly | The /Squiggly key
static (Shared in Visual Basic) | SS | The /SS key
static (Shared in Visual Basic) | St | The /St key
static (Shared in Visual Basic) | Stamp | The /Stamp key
static (Shared in Visual Basic) | Standard | The /Standard key
static (Shared in Visual Basic) | State | The /State key
static (Shared in Visual Basic) | StateModel | The /StateModel key
static (Shared in Visual Basic) | StdCF | The /StdCF key
static (Shared in Visual Basic) | StemH | The /StemH key
static (Shared in Visual Basic) | StemV | The /StemV key
static (Shared in Visual Basic) | StmF | The /StmF key
static (Shared in Visual Basic) | StrF | The /StrF key
static (Shared in Visual Basic) | StrikeOut | The /StrikeOut key
static (Shared in Visual Basic) | StructParent | The /StructParent key
static (Shared in Visual Basic) | StructParents | The /StructParents key
static (Shared in Visual Basic) | StructTreeRoot | The /StructTreeRoot key
static (Shared in Visual Basic) | Style | The /Style key
static (Shared in Visual Basic) | SubFilter | The /SubFilter key
static (Shared in Visual Basic) | Subj | The /Subj key
static (Shared in Visual Basic) | Subject | The /Subject key
static (Shared in Visual Basic) | SubmitForm | The /SubmitForm key
static (Shared in Visual Basic) | Subtype | The /Subtype key
static (Shared in Visual Basic) | Subtype2 | The /Subtype2 key
static (Shared in Visual Basic) | Supplement | The /Supplement key
static (Shared in Visual Basic) | SV | The /SV key
static (Shared in Visual Basic) | SW | The /SW key
static (Shared in Visual Basic) | Symbol | The /Symbol key
static (Shared in Visual Basic) | T | The /T key
static (Shared in Visual Basic) | TA | The /TA key
static (Shared in Visual Basic) | Table | The /Table key
static (Shared in Visual Basic) | Tabs | The /Tabs key
static (Shared in Visual Basic) | TB | The /TB key
static (Shared in Visual Basic) | TBody | The /TBody key
static (Shared in Visual Basic) | TD | The /TD key
static (Shared in Visual Basic) | Text | The /Text key
static (Shared in Visual Basic) | TF | The /TF key
static (Shared in Visual Basic) | TFoot | The /TFoot key
static (Shared in Visual Basic) | TH | The /TH key
static (Shared in Visual Basic) | THead | The /THead key
static (Shared in Visual Basic) | Threads | The /Threads key
static (Shared in Visual Basic) | Thumb | The /Thumb key
static (Shared in Visual Basic) | TI | The /TI key
static (Shared in Visual Basic) | TilingType | The /TilingType key
static (Shared in Visual Basic) | Time | The /Time key
static (Shared in Visual Basic) | TimesBold | The /Times-Bold key
static (Shared in Visual Basic) | TimesBoldItalic | The /Times-BoldItalic key
static (Shared in Visual Basic) | TimesItalic | The /Times-Italic key
static (Shared in Visual Basic) | TimesRoman | The /Times-Roman key
static (Shared in Visual Basic) | Title | The /Title key
static (Shared in Visual Basic) | TK | The /TK key
static (Shared in Visual Basic) | TM | The /TM key
static (Shared in Visual Basic) | TOC | The /TOC key
static (Shared in Visual Basic) | TOCI | The /TOCI key
static (Shared in Visual Basic) | Toggle | The /Toggle key
static (Shared in Visual Basic) | Toolbar | The /Toolbar key
static (Shared in Visual Basic) | ToUnicode | The /ToUnicode key
static (Shared in Visual Basic) | TP | The /TP key
static (Shared in Visual Basic) | TR | The /TR key
static (Shared in Visual Basic) | TR2 | The /TR2 key
static (Shared in Visual Basic) | Trans | The /Trans key
static (Shared in Visual Basic) | TransformMethod | The /TransformMethod key
static (Shared in Visual Basic) | TransformParams | The /TransformParams key
static (Shared in Visual Basic) | Transparency | The /Transparency key
static (Shared in Visual Basic) | Transparent | The /Transparent key
static (Shared in Visual Basic) | Trapped | The /Trapped key
static (Shared in Visual Basic) | TrimBox | The /TrimBox key
static (Shared in Visual Basic) | TrueType | The /TrueType key
static (Shared in Visual Basic) | TU | The /TU key
static (Shared in Visual Basic) | TwoColumnLeft | The /TwoColumnLeft key
static (Shared in Visual Basic) | TwoColumnRight | The /TwoColumnRight key
static (Shared in Visual Basic) | TwoPageLeft | The /TwoPageLeft key
static (Shared in Visual Basic) | TwoPageRight | The /TwoPageRight key
static (Shared in Visual Basic) | Tx | The /Tx key
static (Shared in Visual Basic) | Type | The /Type key
static (Shared in Visual Basic) | Type0 | The /Type0 key
static (Shared in Visual Basic) | Type1 | The /Type1 key
static (Shared in Visual Basic) | Type3 | The /Type3 key
static (Shared in Visual Basic) | U | The /U key
static (Shared in Visual Basic) | U3D | The /U3D key
static (Shared in Visual Basic) | U3DPath | The /U3DPath key
static (Shared in Visual Basic) | UF | The /UF key
static (Shared in Visual Basic) | UHC | The /UHC key
static (Shared in Visual Basic) | Underline | The /Underline key
static (Shared in Visual Basic) | UR | The /UR key
static (Shared in Visual Basic) | UR3 | The /UR3 key
static (Shared in Visual Basic) | URI | The /URI key
static (Shared in Visual Basic) | URL | The /URL key
static (Shared in Visual Basic) | Usage | The /Usage key
static (Shared in Visual Basic) | UseAttachments | The /UseAttachments key
static (Shared in Visual Basic) | UseNone | The /UseNone key
static (Shared in Visual Basic) | UseOC | The /UseOC key
static (Shared in Visual Basic) | UseOutlines | The /UseOutlines key
static (Shared in Visual Basic) | User | The /User key
static (Shared in Visual Basic) | UserProperties | The /UserProperties key
static (Shared in Visual Basic) | UserUnit | The /UserUnit key
static (Shared in Visual Basic) | UseThumbs | The /UseThumbs key
static (Shared in Visual Basic) | USFT | The /USFT key
static (Shared in Visual Basic) | V | The /V key
static (Shared in Visual Basic) | V2 | The /V2 key
static (Shared in Visual Basic) | VA | The /VA key
static (Shared in Visual Basic) | VAlign | The /VAlign key
static (Shared in Visual Basic) | Version | The /Version key
static (Shared in Visual Basic) | Vertices | The /Vertices key
static (Shared in Visual Basic) | VerticesPerRow | The /VerticesPerRow key
static (Shared in Visual Basic) | Video | The /Video key
static (Shared in Visual Basic) | View | The /View key
static (Shared in Visual Basic) | ViewArea | The /ViewArea key
static (Shared in Visual Basic) | ViewClip | The /ViewClip key
static (Shared in Visual Basic) | ViewerPreferences | The /ViewerPreferences key
static (Shared in Visual Basic) | Viewport | The /Viewport key
static (Shared in Visual Basic) | Views | The /Views key
static (Shared in Visual Basic) | ViewState | The /ViewState key
static (Shared in Visual Basic) | VisiblePages | The /VisiblePages key
static (Shared in Visual Basic) | VOffset | The /VOffset key
static (Shared in Visual Basic) | VP | The /VP key
static (Shared in Visual Basic) | W | The /W key
static (Shared in Visual Basic) | W2 | The /W2 key
static (Shared in Visual Basic) | Warichu | The /Warichu key
static (Shared in Visual Basic) | WC | The /WC key
static (Shared in Visual Basic) | WhitePoint | The /WhitePoint key
static (Shared in Visual Basic) | Widget | The /Widget key
static (Shared in Visual Basic) | Width | The /Width key
static (Shared in Visual Basic) | Widths | The /Widths key
static (Shared in Visual Basic) | Win | The /Win key
static (Shared in Visual Basic) | WinAnsiEncoding | The /WinAnsiEncoding key
static (Shared in Visual Basic) | Window | The /Window key
static (Shared in Visual Basic) | Windowed | The /Windowed key
static (Shared in Visual Basic) | Wipe | The /Wipe key
static (Shared in Visual Basic) | WKT | The /WKT key
static (Shared in Visual Basic) | WP | The /WP key
static (Shared in Visual Basic) | WS | The /WS key
static (Shared in Visual Basic) | X | The /X key
static (Shared in Visual Basic) | XA | The /XA key
static (Shared in Visual Basic) | XD | The /XD key
static (Shared in Visual Basic) | XFA | The /XFA key
static (Shared in Visual Basic) | XHeight | The /XHeight key
static (Shared in Visual Basic) | XML | The /XML key
static (Shared in Visual Basic) | XN | The /XN key
static (Shared in Visual Basic) | XObject | The /XObject key
static (Shared in Visual Basic) | XPTS | The /XPTS key
static (Shared in Visual Basic) | XRef | The /XRef key
static (Shared in Visual Basic) | XRefStm | The /XRefStm key
static (Shared in Visual Basic) | XStep | The /XStep key
static (Shared in Visual Basic) | XYZ | The /XYZ key
static (Shared in Visual Basic) | Y | The /Y key
static (Shared in Visual Basic) | Yes | The /Yes key
static (Shared in Visual Basic) | YStep | The /YStep key
static (Shared in Visual Basic) | ZaDb | The /ZaDb key
static (Shared in Visual Basic) | ZapfDingbats | The /ZapfDingbats key
static (Shared in Visual Basic) | Zoom | The /Zoom key
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetMatchingName |
Top
See Also

Reference

PdfNames Class
Xfinium.Pdf.Core Namespace


%%PageItemTitle%%

PdfNames Constructor

Xfinium.Pdf.Core Namespace > PdfNames Class : PdfNames Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfNames()
public PdfNames()
public:
PdfNames();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


%%PageItemTitle%% $$Methods$$

PdfNames Class Methods

Xfinium.Pdf.Core Namespace : PdfNames Class

For a list of all members of this type, see PdfNames members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetMatchingName |
Top
See Also

Reference

PdfNames Class
Xfinium.Pdf.Core Namespace


GetMatchingName Method

Xfinium.Pdf.Core Namespace > PdfNames Class : GetMatchingName Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function GetMatchingName( _
   ByVal inputKey As String _
) As PdfCosName
'Usage

Dim inputKey As String
Dim value As PdfCosName

value = PdfNames.GetMatchingName(inputKey)
public static PdfCosName GetMatchingName(
   string inputKey
)
public:
static PdfCosName^ GetMatchingName(
   String^ inputKey
)

Parameters

inputKey
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


%%PageItemTitle%% $$Fields$$

PdfNames Class Fields

Xfinium.Pdf.Core Namespace : PdfNames Class

For a list of all members of this type, see PdfNames members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | _3D | The /3D key
static (Shared in Visual Basic) | _3DA | The /3DA key
static (Shared in Visual Basic) | _3DAnimationStyle | The /3DAnimationStyle key
static (Shared in Visual Basic) | _3DBG | The /3DBG key
static (Shared in Visual Basic) | _3DD | The /3DD key
static (Shared in Visual Basic) | _3DRenderMode | The /3DRenderMode key
static (Shared in Visual Basic) | _3DView | The /3DView key
static (Shared in Visual Basic) | A | The /A key
static (Shared in Visual Basic) | AA | The /AA key
static (Shared in Visual Basic) | AbsoluteColorimetric | The /AbsoluteColorimetric key
static (Shared in Visual Basic) | AC | The /AC key
static (Shared in Visual Basic) | AcroForm | The /AcroForm key
static (Shared in Visual Basic) | Action | The /Action key
static (Shared in Visual Basic) | Activation | The /Activation key
static (Shared in Visual Basic) | ActualText | The /ActualText key
static (Shared in Visual Basic) | ADBE | The /ADBE key
static (Shared in Visual Basic) | AESV2 | The /AESV2 key
static (Shared in Visual Basic) | AIS | The /AIS key
static (Shared in Visual Basic) | All | The /All key
static (Shared in Visual Basic) | AllPages | The /AllPages key
static (Shared in Visual Basic) | Alt | The /Alt key
static (Shared in Visual Basic) | ALT | The /ALT key
static (Shared in Visual Basic) | Alternate | The /Alternate key
static (Shared in Visual Basic) | Alternates | The /Alternates key
static (Shared in Visual Basic) | AN | The /AN key
static (Shared in Visual Basic) | Animation | The /Animation key
static (Shared in Visual Basic) | Annot | The /Annot key
static (Shared in Visual Basic) | Annots | The /Annots key
static (Shared in Visual Basic) | AntiAlias | The /AntiAlias key
static (Shared in Visual Basic) | AP | The /AP key
static (Shared in Visual Basic) | AppDefault | The /AppDefault key
static (Shared in Visual Basic) | Art | The /Art key
static (Shared in Visual Basic) | ArtBox | The /ArtBox key
static (Shared in Visual Basic) | AS | The /AS key
static (Shared in Visual Basic) | Ascent | The /Ascent key
static (Shared in Visual Basic) | ASCII85Decode | The /ASCII85Decode key
static (Shared in Visual Basic) | ASCIIHexDecode | The /ASCIIHexDecode key
static (Shared in Visual Basic) | Asset | The /Asset key
static (Shared in Visual Basic) | Assets | The /Assets key
static (Shared in Visual Basic) | AuthEvent | The /AuthEvent key
static (Shared in Visual Basic) | Author | The /Author key
static (Shared in Visual Basic) | AvgWidth | The /AvgWidth key
static (Shared in Visual Basic) | B | The /B key
static (Shared in Visual Basic) | Background | The /Background key
static (Shared in Visual Basic) | BaseEncoding | The /BaseEncoding key
static (Shared in Visual Basic) | BaseFont | The /BaseFont key
static (Shared in Visual Basic) | BaseVersion | The /BaseVersion key
static (Shared in Visual Basic) | BatesN | The /BatesN key
static (Shared in Visual Basic) | BBox | The /BBox key
static (Shared in Visual Basic) | BC | The /BC key
static (Shared in Visual Basic) | BE | The /BE key
static (Shared in Visual Basic) | BG | The /BG key
static (Shared in Visual Basic) | BibEntry | The /BibEntry key
static (Shared in Visual Basic) | BigFive | The /BigFive key
static (Shared in Visual Basic) | Binding | The /Binding key
static (Shared in Visual Basic) | BindingMaterialName | The /BindingMaterialName key
static (Shared in Visual Basic) | BitsPerComponent | The /BitsPerComponent key
static (Shared in Visual Basic) | BitsPerCoordinate | The /BitsPerCoordinate key
static (Shared in Visual Basic) | BitsPerFlag | The /BitsPerFlag key
static (Shared in Visual Basic) | BitsPerSample | The /BitsPerSample key
static (Shared in Visual Basic) | Bl | The /Bl key
static (Shared in Visual Basic) | BlackIs1 | The /BlackIs1 key
static (Shared in Visual Basic) | BlackPoint | The /BlackPoint key
static (Shared in Visual Basic) | BleedBox | The /BleedBox key
static (Shared in Visual Basic) | Blinds | The /Blinds key
static (Shared in Visual Basic) | BlockQuote | The /BlockQuote key
static (Shared in Visual Basic) | BM | The /BM key
static (Shared in Visual Basic) | Border | The /Border key
static (Shared in Visual Basic) | Bounds | The /Bounds key
static (Shared in Visual Basic) | Box | The /Box key
static (Shared in Visual Basic) | BS | The /BS key
static (Shared in Visual Basic) | Btn | The /Btn key
static (Shared in Visual Basic) | ByteRange | The /ByteRange key
static (Shared in Visual Basic) | C | The /C key
static (Shared in Visual Basic) | C0 | The /C0 key
static (Shared in Visual Basic) | C1 | The /C1 key
static (Shared in Visual Basic) | C2W | The /C2W key
static (Shared in Visual Basic) | ca | The /ca key
static (Shared in Visual Basic) | CA | The /CA key
static (Shared in Visual Basic) | CalGray | The /CalGray key
static (Shared in Visual Basic) | CalRGB | The /CalRGB key
static (Shared in Visual Basic) | CapHeight | The /CapHeight key
static (Shared in Visual Basic) | Caption | The /Caption key
static (Shared in Visual Basic) | Catalog | The /Catalog key
static (Shared in Visual Basic) | Category | The /Category key
static (Shared in Visual Basic) | CCITTFaxDecode | The /CCITTFaxDecode key
static (Shared in Visual Basic) | Center | The /Center key
static (Shared in Visual Basic) | CenterWindow | The /CenterWindow key
static (Shared in Visual Basic) | Cert | The /Cert key
static (Shared in Visual Basic) | CF | The /CF key
static (Shared in Visual Basic) | CFM | The /CFM key
static (Shared in Visual Basic) | Ch | The /Ch key
static (Shared in Visual Basic) | CharProcs | The /CharProcs key
static (Shared in Visual Basic) | Child | The /Child key
static (Shared in Visual Basic) | CI | The /CI key
static (Shared in Visual Basic) | CIDFontType0 | The /CIDFontType0 key
static (Shared in Visual Basic) | CIDFontType2 | The /CIDFontType2 key
static (Shared in Visual Basic) | CIDSet | The /CIDSet key
static (Shared in Visual Basic) | CIDSystemInfo | The /CIDSystemInfo key
static (Shared in Visual Basic) | CIDToGIDMap | The /CIDToGIDMap key
static (Shared in Visual Basic) | Circle | The /Circle key
static (Shared in Visual Basic) | Cloud | The /Cloud key
static (Shared in Visual Basic) | CMapName | The /CMapName key
static (Shared in Visual Basic) | CMD | The /CMD key
static (Shared in Visual Basic) | CO | The /CO key
static (Shared in Visual Basic) | Code | The /Code key
static (Shared in Visual Basic) | Collection | The /Collection key
static (Shared in Visual Basic) | CollectionField | The /CollectionField key
static (Shared in Visual Basic) | CollectionItem | The /CollectionItem key
static (Shared in Visual Basic) | CollectionSchema | The /CollectionSchema key
static (Shared in Visual Basic) | CollectionSort | The /CollectionSort key
static (Shared in Visual Basic) | CollectionSubitem | The /CollectionSubitem key
static (Shared in Visual Basic) | Colors | The /Colors key
static (Shared in Visual Basic) | ColorSpace | The /ColorSpace key
static (Shared in Visual Basic) | Columns | The /Columns key
static (Shared in Visual Basic) | Condition | The /Condition key
static (Shared in Visual Basic) | Configuration | The /Configuration key
static (Shared in Visual Basic) | Configurations | The /Configurations key
static (Shared in Visual Basic) | ContactInfo | The /ContactInfo key
static (Shared in Visual Basic) | Content | The /Content key
static (Shared in Visual Basic) | Contents | The /Contents key
static (Shared in Visual Basic) | Coords | The /Coords key
static (Shared in Visual Basic) | Count | The /Count key
static (Shared in Visual Basic) | Courier | The /Courier key
static (Shared in Visual Basic) | CourierBold | The /Courier-Bold key
static (Shared in Visual Basic) | CourierBoldOblique | The /Courier-BoldOblique key
static (Shared in Visual Basic) | CourierOblique | The /Courier-Oblique key
static (Shared in Visual Basic) | CreationDate | The /CreationDate key
static (Shared in Visual Basic) | Creator | The /Creator key
static (Shared in Visual Basic) | CreatorInfo | The /CreatorInfo key
static (Shared in Visual Basic) | CropBox | The /CropBox key
static (Shared in Visual Basic) | Crypt | The /Crypt key
static (Shared in Visual Basic) | CS | The /CS key
static (Shared in Visual Basic) | CT | The /CT key
static (Shared in Visual Basic) | CuePoint | The /CuePoint key
static (Shared in Visual Basic) | CuePoints | The /CuePoints key
static (Shared in Visual Basic) | CV | The /CV key
static (Shared in Visual Basic) | CXY | The /CXY key
static (Shared in Visual Basic) | D | The /D key
static (Shared in Visual Basic) | DA | The /DA key
static (Shared in Visual Basic) | Data | The /Data key
static (Shared in Visual Basic) | DC | The /DC key
static (Shared in Visual Basic) | DCS | The /DCS key
static (Shared in Visual Basic) | DCTDecode | The /DCTDecode key
static (Shared in Visual Basic) | Deactivation | The /Deactivation key
static (Shared in Visual Basic) | Decode | The /Decode key
static (Shared in Visual Basic) | DecodeParms | The /DecodeParms key
static (Shared in Visual Basic) | Default | The /Default key
static (Shared in Visual Basic) | DefaultCMYK | The /DefaultCMYK key
static (Shared in Visual Basic) | DefaultCryptFilter | The /DefaultCryptFilter key
static (Shared in Visual Basic) | DefaultForPrinting | The /DefaultForPrinting key
static (Shared in Visual Basic) | DefaultGray | The /DefaultGray key
static (Shared in Visual Basic) | DefaultRGB | The /DefaultRGB key
static (Shared in Visual Basic) | DEG | The /DEG key
static (Shared in Visual Basic) | Desc | The /Desc key
static (Shared in Visual Basic) | DescendantFonts | The /DescendantFonts key
static (Shared in Visual Basic) | Descent | The /Descent key
static (Shared in Visual Basic) | Dest | The /Dest key
static (Shared in Visual Basic) | DestOutputProfile | The /DestOutputProfile key
static (Shared in Visual Basic) | Dests | The /Dests key
static (Shared in Visual Basic) | DeviceCMYK | The /DeviceCMYK key
static (Shared in Visual Basic) | DeviceGray | The /DeviceGray key
static (Shared in Visual Basic) | DeviceN | The /DeviceN key
static (Shared in Visual Basic) | DeviceRGB | The /DeviceRGB key
static (Shared in Visual Basic) | Di | The /Di key
static (Shared in Visual Basic) | Differences | The /Differences key
static (Shared in Visual Basic) | Direction | The /Direction key
static (Shared in Visual Basic) | DIS | The /DIS key
static (Shared in Visual Basic) | DisplayDocTitle | The /DisplayDocTitle key
static (Shared in Visual Basic) | Dissolve | The /Dissolve key
static (Shared in Visual Basic) | Div | The /Div key
static (Shared in Visual Basic) | DL | The /DL key
static (Shared in Visual Basic) | Dm | The /Dm key
static (Shared in Visual Basic) | DocMDP | The /DocMDP key
static (Shared in Visual Basic) | DocOpen | The /DocOpen key
static (Shared in Visual Basic) | Domain | The /Domain key
static (Shared in Visual Basic) | DP | The /DP key
static (Shared in Visual Basic) | DR | The /DR key
static (Shared in Visual Basic) | Draft | The /Draft key
static (Shared in Visual Basic) | DS | The /DS key
static (Shared in Visual Basic) | Duplex | The /Duplex key
static (Shared in Visual Basic) | DuplexFlipLongEdge | The /DuplexFlipLongEdge key
static (Shared in Visual Basic) | DuplexFlipShortEdge | The /DuplexFlipShortEdge key
static (Shared in Visual Basic) | Dur | The /Dur key
static (Shared in Visual Basic) | DV | The /DV key
static (Shared in Visual Basic) | DW | The /DW key
static (Shared in Visual Basic) | E | The /E key
static (Shared in Visual Basic) | EA | The /EA key
static (Shared in Visual Basic) | EarlyChange | The /EarlyChange key
static (Shared in Visual Basic) | EF | The /EF key
static (Shared in Visual Basic) | EFF | The /EFF key
static (Shared in Visual Basic) | EFOpen | The /EFOpen key
static (Shared in Visual Basic) | Embedded | The /Embedded key
static (Shared in Visual Basic) | EmbeddedFile | The /EmbeddedFile key
static (Shared in Visual Basic) | EmbeddedFiles | The /EmbeddedFiles key
static (Shared in Visual Basic) | Encode | The /Encode key
static (Shared in Visual Basic) | EncodedByteAlign | The /EncodedByteAlign key
static (Shared in Visual Basic) | Encoding | The /Encoding key
static (Shared in Visual Basic) | Encrypt | The /Encrypt key
static (Shared in Visual Basic) | EncryptMetadata | The /EncryptMetadata key
static (Shared in Visual Basic) | EndOfBlock | The /EndOfBlock key
static (Shared in Visual Basic) | EndOfLine | The /EndOfLine key
static (Shared in Visual Basic) | EPSG | The /EPSG key
static (Shared in Visual Basic) | Event | The /Event key
static (Shared in Visual Basic) | Export | The /Export key
static (Shared in Visual Basic) | ExportState | The /ExportState key
static (Shared in Visual Basic) | Extend | The /Extend key
static (Shared in Visual Basic) | ExtensionLevel | The /ExtensionLevel key
static (Shared in Visual Basic) | Extensions | The /Extensions key
static (Shared in Visual Basic) | ExtGState | The /ExtGState key
static (Shared in Visual Basic) | F | The /F key
static (Shared in Visual Basic) | Far | The /Far key
static (Shared in Visual Basic) | FB | The /FB key
static (Shared in Visual Basic) | FC | The /FC key
static (Shared in Visual Basic) | FD | The /FD key
static (Shared in Visual Basic) | FDecodeParms | The /FDecodeParms key
static (Shared in Visual Basic) | FDF | The /FDF key
static (Shared in Visual Basic) | Ff | The /Ff key
static (Shared in Visual Basic) | FFilter | The /FFilter key
static (Shared in Visual Basic) | Fields | The /Fields key
static (Shared in Visual Basic) | FileAttachment | The /FileAttachment key
static (Shared in Visual Basic) | Filespec | The /Filespec key
static (Shared in Visual Basic) | Filter | The /Filter key
static (Shared in Visual Basic) | First | The /First key
static (Shared in Visual Basic) | FirstChar | The /FirstChar key
static (Shared in Visual Basic) | FirstPage | The /FirstPage key
static (Shared in Visual Basic) | Fit | The /Fit key
static (Shared in Visual Basic) | FitB | The /FitB key
static (Shared in Visual Basic) | FitBH | The /FitBH key
static (Shared in Visual Basic) | FitBV | The /FitBV key
static (Shared in Visual Basic) | FitH | The /FitH key
static (Shared in Visual Basic) | FitR | The /FitR key
static (Shared in Visual Basic) | FitV | The /FitV key
static (Shared in Visual Basic) | FitWindow | The /FitWindow key
static (Shared in Visual Basic) | Flags | The /Flags key
static (Shared in Visual Basic) | Flash | The /Flash key
static (Shared in Visual Basic) | FlashVars | The /FlashVars key
static (Shared in Visual Basic) | FlateDecode | The /FlateDecode key
static (Shared in Visual Basic) | Fo | The /Fo key
static (Shared in Visual Basic) | Folder | The /Folder key
static (Shared in Visual Basic) | Folders | The /Folders key
static (Shared in Visual Basic) | Font | The /Font key
static (Shared in Visual Basic) | FontBBox | The /FontBBox key
static (Shared in Visual Basic) | FontDescriptor | The /FontDescriptor key
static (Shared in Visual Basic) | FontFile | The /FontFile key
static (Shared in Visual Basic) | FontFile2 | The /FontFile2 key
static (Shared in Visual Basic) | FontFile3 | The /FontFile3 key
static (Shared in Visual Basic) | FontMatrix | The /FontMatrix key
static (Shared in Visual Basic) | FontName | The /FontName key
static (Shared in Visual Basic) | Foreground | The /Foreground key
static (Shared in Visual Basic) | Form | The /Form key
static (Shared in Visual Basic) | FormType | The /FormType key
static (Shared in Visual Basic) | FOV | The /FOV key
static (Shared in Visual Basic) | FreeText | The /FreeText key
static (Shared in Visual Basic) | FRM | The /FRM key
static (Shared in Visual Basic) | FS | The /FS key
static (Shared in Visual Basic) | FT | The /FT key
static (Shared in Visual Basic) | FullScreen | The /FullScreen key
static (Shared in Visual Basic) | Function | The /Function key
static (Shared in Visual Basic) | Functions | The /Functions key
static (Shared in Visual Basic) | FunctionType | The /FunctionType key
static (Shared in Visual Basic) | G | The /G key
static (Shared in Visual Basic) | Gamma | The /Gamma key
static (Shared in Visual Basic) | GBK | The /GBK key
static (Shared in Visual Basic) | GCS | The /GCS key
static (Shared in Visual Basic) | GEO | The /GEO key
static (Shared in Visual Basic) | GEOGCS | The /GEOGCS key
static (Shared in Visual Basic) | Glitter | The /Glitter key
static (Shared in Visual Basic) | GoTo | The /GoTo key
static (Shared in Visual Basic) | GoTo3DView | The /GoTo3DView key
static (Shared in Visual Basic) | GoToE | The /GoToE key
static (Shared in Visual Basic) | GoToR | The /GoToR key
static (Shared in Visual Basic) | GPTS | The /GPTS key
static (Shared in Visual Basic) | GRD | The /GRD key
static (Shared in Visual Basic) | Group | The /Group key
static (Shared in Visual Basic) | GTS_PDFA1 | The /GTS_PdfA1 key
static (Shared in Visual Basic) | GTS_PDFX | The /GTS_PdfX key
static (Shared in Visual Basic) | GTS_PDFXVersion | The /GTS_PdfXVersion key
static (Shared in Visual Basic) | H | The /H key
static (Shared in Visual Basic) | H2 | The /H2 key
static (Shared in Visual Basic) | H3 | The /H3 key
static (Shared in Visual Basic) | H4 | The /H4 key
static (Shared in Visual Basic) | H5 | The /H5 key
static (Shared in Visual Basic) | H6 | The /H6 key
static (Shared in Visual Basic) | HA | The /HA key
static (Shared in Visual Basic) | HAlign | The /HAlign key
static (Shared in Visual Basic) | Height | The /Height key
static (Shared in Visual Basic) | Helv | The /Helv key
static (Shared in Visual Basic) | Helvetica | The /Helvetica key
static (Shared in Visual Basic) | HelveticaBold | The /Helvetica-Bold key
static (Shared in Visual Basic) | HelveticaBoldOblique | The /Helvetica-BoldOblique key
static (Shared in Visual Basic) | HelveticaOblique | The /Helvetica-Oblique key
static (Shared in Visual Basic) | Hid | The /Hid key
static (Shared in Visual Basic) | Hide | The /Hide key
static (Shared in Visual Basic) | HideMenubar | The /HideMenubar key
static (Shared in Visual Basic) | HideToolbar | The /HideToolbar key
static (Shared in Visual Basic) | HideWindowUI | The /HideWindowUI key
static (Shared in Visual Basic) | Highlight | The /Highlight key
static (Shared in Visual Basic) | HOffset | The /HOffset key
static (Shared in Visual Basic) | I | The /I key
static (Shared in Visual Basic) | IC | The /IC key
static (Shared in Visual Basic) | ICCBased | The /ICCBased key
static (Shared in Visual Basic) | ID | The /ID key
static (Shared in Visual Basic) | Identity | The /Identity key
static (Shared in Visual Basic) | IdentityH | The /IdentityH key
static (Shared in Visual Basic) | IdentityV | The /IdentityV key
static (Shared in Visual Basic) | IF | The /IF key
static (Shared in Visual Basic) | Image | The /Image key
static (Shared in Visual Basic) | ImageB | The /ImageB key
static (Shared in Visual Basic) | ImageC | The /ImageC key
static (Shared in Visual Basic) | ImageI | The /ImageI key
static (Shared in Visual Basic) | ImageMask | The /ImageMask key
static (Shared in Visual Basic) | ImportData | The /ImportData key
static (Shared in Visual Basic) | IN | The /IN key
static (Shared in Visual Basic) | Index | The /Index key
static (Shared in Visual Basic) | Indexed | The /Indexed key
static (Shared in Visual Basic) | Info | The /Info key
static (Shared in Visual Basic) | Ink | The /Ink key
static (Shared in Visual Basic) | InkList | The /InkList key
static (Shared in Visual Basic) | Instances | The /Instances key
static (Shared in Visual Basic) | Intent | The /Intent key
static (Shared in Visual Basic) | Interpolate | The /Interpolate key
static (Shared in Visual Basic) | IRT | The /IRT key
static (Shared in Visual Basic) | IsMap | The /IsMap key
static (Shared in Visual Basic) | ItalicAngle | The /ItalicAngle key
static (Shared in Visual Basic) | ITXT | The /ITXT key
static (Shared in Visual Basic) | IV | The /IV key
static (Shared in Visual Basic) | IX | The /IX key
static (Shared in Visual Basic) | JavaScript | The /JavaScript key
static (Shared in Visual Basic) | JBIG2Decode | The /JBIG2Decode key
static (Shared in Visual Basic) | JBIG2Globals | The /JBIG2Globals key
static (Shared in Visual Basic) | JPXDecode | The /JPXDecode key
static (Shared in Visual Basic) | JS | The /JS key
static (Shared in Visual Basic) | K | The /K key
static (Shared in Visual Basic) | Keywords | The /Keywords key
static (Shared in Visual Basic) | Kids | The /Kids key
static (Shared in Visual Basic) | KM | The /KM key
static (Shared in Visual Basic) | L | The /L key
static (Shared in Visual Basic) | L2R | The /L2R key
static (Shared in Visual Basic) | Lab | The /Lab key
static (Shared in Visual Basic) | Lang | The /Lang key
static (Shared in Visual Basic) | Language | The /Language key
static (Shared in Visual Basic) | Last | The /Last key
static (Shared in Visual Basic) | LastChar | The /LastChar key
static (Shared in Visual Basic) | LastPage | The /LastPage key
static (Shared in Visual Basic) | LAT | The /LAT key
static (Shared in Visual Basic) | Launch | The /Launch key
static (Shared in Visual Basic) | Lbl | The /Lbl key
static (Shared in Visual Basic) | LBody | The /LBody key
static (Shared in Visual Basic) | LE | The /LE key
static (Shared in Visual Basic) | Leading | The /Leading key
static (Shared in Visual Basic) | Length | The /Length key
static (Shared in Visual Basic) | Length1 | The /Length1 key
static (Shared in Visual Basic) | Length2 | The /Length2 key
static (Shared in Visual Basic) | Length3 | The /Length1 key
static (Shared in Visual Basic) | LI | The /LI key
static (Shared in Visual Basic) | Limits | The /Limits key
static (Shared in Visual Basic) | Line | The /Line key
static (Shared in Visual Basic) | Linear | The /Linear key
static (Shared in Visual Basic) | Link | The /Link key
static (Shared in Visual Basic) | ListMode | The /ListMode key
static (Shared in Visual Basic) | Location | The /Location key
static (Shared in Visual Basic) | Lock | The /Lock key
static (Shared in Visual Basic) | Locked | The /Locked key
static (Shared in Visual Basic) | LON | The /LON key
static (Shared in Visual Basic) | LPTS | The /LPTS key
static (Shared in Visual Basic) | LS | The /LS key
static (Shared in Visual Basic) | LZWDecode | The /LZWDecode key
static (Shared in Visual Basic) | M | The /M key
static (Shared in Visual Basic) | MacExpertEncoding | The /MacExpertEncoding key
static (Shared in Visual Basic) | MacRomanEncoding | The /MacRomanEncoding key
static (Shared in Visual Basic) | Marked | The /Marked key
static (Shared in Visual Basic) | MarkInfo | The /MarkInfo key
static (Shared in Visual Basic) | Mask | The /Mask key
static (Shared in Visual Basic) | Material | The /Material key
static (Shared in Visual Basic) | Matrix | The /Matrix key
static (Shared in Visual Basic) | Matte | The /Matte key
static (Shared in Visual Basic) | max | The /max key
static (Shared in Visual Basic) | Max | The /Max key
static (Shared in Visual Basic) | MaxLen | The /MaxLen key
static (Shared in Visual Basic) | MaxWidth | The /MaxWidth key
static (Shared in Visual Basic) | MCD | The /MCD key
static (Shared in Visual Basic) | MCID | The /MCID key
static (Shared in Visual Basic) | MCR | The /MCR key
static (Shared in Visual Basic) | Measure | The /Measure key
static (Shared in Visual Basic) | MediaBox | The /MediaBox key
static (Shared in Visual Basic) | Metadata | The /Metadata key
static (Shared in Visual Basic) | MI | The /MI key
static (Shared in Visual Basic) | min | The /min key
static (Shared in Visual Basic) | Min | The /Min key
static (Shared in Visual Basic) | MissingWidth | The /MissingWidth key
static (Shared in Visual Basic) | MK | The /MK key
static (Shared in Visual Basic) | MMType1 | The /MMType1 key
static (Shared in Visual Basic) | ModDate | The /ModDate key
static (Shared in Visual Basic) | MR | The /MR key
static (Shared in Visual Basic) | MS | The /MS key
static (Shared in Visual Basic) | Multiply | The /Multiply key
static (Shared in Visual Basic) | N | The /N key
static (Shared in Visual Basic) | n0 | The /n0 key
static (Shared in Visual Basic) | n1 | The /n1 key
static (Shared in Visual Basic) | n2 | The /n2 key
static (Shared in Visual Basic) | n3 | The /n3 key
static (Shared in Visual Basic) | n4 | The /n4 key
static (Shared in Visual Basic) | NA | The /NA key
static (Shared in Visual Basic) | Name | The /Name key
static (Shared in Visual Basic) | Named | The /Named key
static (Shared in Visual Basic) | Names | The /Names key
static (Shared in Visual Basic) | Navigation | The /Navigation key
static (Shared in Visual Basic) | NavigationPane | The /NavigationPane key
static (Shared in Visual Basic) | Near | The /Near key
static (Shared in Visual Basic) | NeedAppearances | The /NeedAppearances key
static (Shared in Visual Basic) | NewWindow | The /NewWindow key
static (Shared in Visual Basic) | Next | The /Next key
static (Shared in Visual Basic) | NextPage | The /NextPage key
static (Shared in Visual Basic) | NM | The /NM key
static (Shared in Visual Basic) | None | The /None key
static (Shared in Visual Basic) | NonFullScreenPageMode | The /NonFullScreenPageMode key
static (Shared in Visual Basic) | NonStruct | The /NonStruct key
static (Shared in Visual Basic) | Note | The /Note key
static (Shared in Visual Basic) | NP | The /NP key
static (Shared in Visual Basic) | NR | The /NR key
static (Shared in Visual Basic) | NumberFormat | The /NumberFormat key
static (Shared in Visual Basic) | NumCopies | The /NumCopies key
static (Shared in Visual Basic) | Nums | The /Nums key
static (Shared in Visual Basic) | O | The /O key
static (Shared in Visual Basic) | OB | The /OB key
static (Shared in Visual Basic) | Obj | The /Obj key
static (Shared in Visual Basic) | OBJR | The /OBJR key
static (Shared in Visual Basic) | ObjStm | The /ObjStm key
static (Shared in Visual Basic) | OC | The /OC key
static (Shared in Visual Basic) | OCG | The /OCG key
static (Shared in Visual Basic) | OCGs | The /OCGs key
static (Shared in Visual Basic) | OCMD | The /OCMD key
static (Shared in Visual Basic) | OCProperties | The /OCProperties key
static (Shared in Visual Basic) | Off | The /Off key
static (Shared in Visual Basic) | OFF | The /OFF key
static (Shared in Visual Basic) | ON | The /ON key
static (Shared in Visual Basic) | OneByteIdentityH | The /OneByteIdentityH key
static (Shared in Visual Basic) | OneColumn | The /OneColumn key
static (Shared in Visual Basic) | OnInstantiate | The /OnInstantiate key
static (Shared in Visual Basic) | op | The /op key
static (Shared in Visual Basic) | OP | The /OP key
static (Shared in Visual Basic) | Open | The /Open key
static (Shared in Visual Basic) | OpenAction | The /OpenAction key
static (Shared in Visual Basic) | OPI | The /OPI key
static (Shared in Visual Basic) | OPM | The /OPM key
static (Shared in Visual Basic) | Opt | The /Opt key
static (Shared in Visual Basic) | Order | The /Order key
static (Shared in Visual Basic) | Ordering | The /Ordering key
static (Shared in Visual Basic) | OS | The /OS key
static (Shared in Visual Basic) | Oscillating | The /Oscillating key
static (Shared in Visual Basic) | Outlines | The /Outlines key
static (Shared in Visual Basic) | OutputCondition | The /OutputCondition key
static (Shared in Visual Basic) | OutputConditionIdentifier | The /OutputConditionIdentifier key
static (Shared in Visual Basic) | OutputIntent | The /OutputIntent key
static (Shared in Visual Basic) | OutputIntents | The /OutputIntents key
static (Shared in Visual Basic) | OverlayText | The /OverlayText key
static (Shared in Visual Basic) | P | The /P key
static (Shared in Visual Basic) | Page | The /Page key
static (Shared in Visual Basic) | PageLabels | The /PageLabels key
static (Shared in Visual Basic) | PageLayout | The /PageLayout key
static (Shared in Visual Basic) | PageMode | The /PageMode key
static (Shared in Visual Basic) | Pages | The /Pages key
static (Shared in Visual Basic) | Pagination | The /Pagination key
static (Shared in Visual Basic) | PaintType | The /PaintType key
static (Shared in Visual Basic) | Panose | The /Panose key
static (Shared in Visual Basic) | Params | The /Params key
static (Shared in Visual Basic) | Parent | The /Parent key
static (Shared in Visual Basic) | ParentTree | The /ParentTree key
static (Shared in Visual Basic) | PassContextClick | The /PassContextClick key
static (Shared in Visual Basic) | Pattern | The /Pattern key
static (Shared in Visual Basic) | PatternType | The /PatternType key
static (Shared in Visual Basic) | PC | The /PC key
static (Shared in Visual Basic) | PDF | The /Pdf key
static (Shared in Visual Basic) | PdfDocEncoding | The /PdfDocEncoding key
static (Shared in Visual Basic) | PDU | The /PDU key
static (Shared in Visual Basic) | Perceptual | The /Perceptual key
static (Shared in Visual Basic) | Perms | The /Perms key
static (Shared in Visual Basic) | Pg | The /Pg key
static (Shared in Visual Basic) | PI | The /PI key
static (Shared in Visual Basic) | PickTrayByPdfSize | The /PickTrayByPdfSize key
static (Shared in Visual Basic) | PickTrayByPDFSize | The /PickTrayByPDFSize key
static (Shared in Visual Basic) | PieceInfo | The /PieceInfo key
static (Shared in Visual Basic) | PlayCount | The /PlayCount key
static (Shared in Visual Basic) | PO | The /PO key
static (Shared in Visual Basic) | Polygon | The /Polygon key
static (Shared in Visual Basic) | PolyLine | The /PolyLine key
static (Shared in Visual Basic) | Popup | The /Popup key
static (Shared in Visual Basic) | Position | The /Position key
static (Shared in Visual Basic) | Predictor | The /Predictor key
static (Shared in Visual Basic) | Preferred | The /Preferred key
static (Shared in Visual Basic) | Presentation | The /Presentation key
static (Shared in Visual Basic) | PreserveRB | The /PreserveRB key
static (Shared in Visual Basic) | Prev | The /Prev key
static (Shared in Visual Basic) | PrevPage | The /PrevPage key
static (Shared in Visual Basic) | Print | The /Print key
static (Shared in Visual Basic) | PrintArea | The /PrintArea key
static (Shared in Visual Basic) | PrintClip | The /PrintClip key
static (Shared in Visual Basic) | PrintPageRange | The /PrintPageRange key
static (Shared in Visual Basic) | PrintScaling | The /PrintScaling key
static (Shared in Visual Basic) | PrintState | The /PrintState key
static (Shared in Visual Basic) | Private | The /Private key
static (Shared in Visual Basic) | ProcSet | The /ProcSet key
static (Shared in Visual Basic) | Producer | The /Producer key
static (Shared in Visual Basic) | PROJCS | The /PROJCS key
static (Shared in Visual Basic) | Properties | The /Properties key
static (Shared in Visual Basic) | PS | The /PS key
static (Shared in Visual Basic) | PtData | The /PtData key
static (Shared in Visual Basic) | PushPin | The /PushPin key
static (Shared in Visual Basic) | PV | The /PV key
static (Shared in Visual Basic) | Q | The /Q key
static (Shared in Visual Basic) | QuadPoints | The /QuadPoints key
static (Shared in Visual Basic) | Quote | The /Quote key
static (Shared in Visual Basic) | R | The /R key
static (Shared in Visual Basic) | R2L | The /R2L key
static (Shared in Visual Basic) | Range | The /Range key
static (Shared in Visual Basic) | RBGroups | The /RBGroups key
static (Shared in Visual Basic) | RC | The /RC key
static (Shared in Visual Basic) | RD | The /RD key
static (Shared in Visual Basic) | Reason | The /Reason key
static (Shared in Visual Basic) | Recipients | The /Recipients key
static (Shared in Visual Basic) | Rect | The /Rect key
static (Shared in Visual Basic) | Redact | The /Redact key
static (Shared in Visual Basic) | Ref | The /Ref key
static (Shared in Visual Basic) | Reference | The /Reference key
static (Shared in Visual Basic) | Registry | The /Registry key
static (Shared in Visual Basic) | RegistryName | The /RegistryName key
static (Shared in Visual Basic) | RelativeColorimetric | The /RelativeColorimetric key
static (Shared in Visual Basic) | Rendition | The /Rendition key
static (Shared in Visual Basic) | ResetForm | The /ResetForm key
static (Shared in Visual Basic) | Resources | The /Resources key
static (Shared in Visual Basic) | RI | The /RI key
static (Shared in Visual Basic) | RichMedia | The /RichMedia key
static (Shared in Visual Basic) | RichMediaActivation | The /RichMediaActivation key
static (Shared in Visual Basic) | RichMediaAnimation | The /RichMediaAnimation key
static (Shared in Visual Basic) | RichMediaCommand | The /RichMediaCommand key
static (Shared in Visual Basic) | RichMediaConfiguration | The /RichMediaConfiguration key
static (Shared in Visual Basic) | RichMediaContent | The /RichMediaContent key
static (Shared in Visual Basic) | RichMediaDeactivation | The /RichMediaDeactivation key
static (Shared in Visual Basic) | RichMediaExecute | The /RichMediaExecute key
static (Shared in Visual Basic) | RichMediaInstance | The /RichMediaInstance key
static (Shared in Visual Basic) | RichMediaParams | The /RichMediaParams key
static (Shared in Visual Basic) | RichMediaPosition | The /RichMediaPosition key
static (Shared in Visual Basic) | RichMediaPresentation | The /RichMediaPresentation key
static (Shared in Visual Basic) | RichMediaSettings | The /RichMediaSettings key
static (Shared in Visual Basic) | RichMediaWindow | The /RichMediaWindow key
static (Shared in Visual Basic) | RL | The /RL key
static (Shared in Visual Basic) | RM | The /RM key
static (Shared in Visual Basic) | RO | The /RO key
static (Shared in Visual Basic) | RoleMap | The /RoleMap key
static (Shared in Visual Basic) | Root | The /Root key
static (Shared in Visual Basic) | Rotate | The /Rotate key
static (Shared in Visual Basic) | Rows | The /Rows key
static (Shared in Visual Basic) | RT | The /RT key
static (Shared in Visual Basic) | RunLengthDecode | The /RunLengthDecode key
static (Shared in Visual Basic) | RV | The /RV key
static (Shared in Visual Basic) | S | The /S key
static (Shared in Visual Basic) | SA | The /SA key
static (Shared in Visual Basic) | Saturation | The /Saturation key
static (Shared in Visual Basic) | SC | The /SC key
static (Shared in Visual Basic) | Schema | The /Schema key
static (Shared in Visual Basic) | Screen | The /Screen key
static (Shared in Visual Basic) | Scripts | The /Scripts key
static (Shared in Visual Basic) | Sect | The /Sect key
static (Shared in Visual Basic) | Separation | The /Separation key
static (Shared in Visual Basic) | SetOCGState | The /SetOCGState key
static (Shared in Visual Basic) | Settings | The /Settings key
static (Shared in Visual Basic) | Shading | The /Shading key
static (Shared in Visual Basic) | ShadingType | The /ShadingType key
static (Shared in Visual Basic) | ShiftJIS | The /Shift-JIS key
static (Shared in Visual Basic) | Sig | The /Sig key
static (Shared in Visual Basic) | SigFieldLock | The /SigFieldLock key
static (Shared in Visual Basic) | SigFlags | The /SigFlags key
static (Shared in Visual Basic) | SigRef | The /SigRef key
static (Shared in Visual Basic) | Simplex | The /Simplex key
static (Shared in Visual Basic) | SinglePage | The /SinglePage key
static (Shared in Visual Basic) | Size | The /Size key
static (Shared in Visual Basic) | SMask | The /SMask key
static (Shared in Visual Basic) | Sort | The /Sort key
static (Shared in Visual Basic) | Sound | The /Sound key
static (Shared in Visual Basic) | Span | The /Span key
static (Shared in Visual Basic) | Speed | The /Speed key
static (Shared in Visual Basic) | Split | The /Split key
static (Shared in Visual Basic) | SQFT | The /SQFT key
static (Shared in Visual Basic) | SQKM | The /SQKM key
static (Shared in Visual Basic) | SQM | The /SQM key
static (Shared in Visual Basic) | SQMI | The /SQMI key
static (Shared in Visual Basic) | Square | The /Square key
static (Shared in Visual Basic) | Squiggly | The /Squiggly key
static (Shared in Visual Basic) | SS | The /SS key
static (Shared in Visual Basic) | St | The /St key
static (Shared in Visual Basic) | Stamp | The /Stamp key
static (Shared in Visual Basic) | Standard | The /Standard key
static (Shared in Visual Basic) | State | The /State key
static (Shared in Visual Basic) | StateModel | The /StateModel key
static (Shared in Visual Basic) | StdCF | The /StdCF key
static (Shared in Visual Basic) | StemH | The /StemH key
static (Shared in Visual Basic) | StemV | The /StemV key
static (Shared in Visual Basic) | StmF | The /StmF key
static (Shared in Visual Basic) | StrF | The /StrF key
static (Shared in Visual Basic) | StrikeOut | The /StrikeOut key
static (Shared in Visual Basic) | StructParent | The /StructParent key
static (Shared in Visual Basic) | StructParents | The /StructParents key
static (Shared in Visual Basic) | StructTreeRoot | The /StructTreeRoot key
static (Shared in Visual Basic) | Style | The /Style key
static (Shared in Visual Basic) | SubFilter | The /SubFilter key
static (Shared in Visual Basic) | Subj | The /Subj key
static (Shared in Visual Basic) | Subject | The /Subject key
static (Shared in Visual Basic) | SubmitForm | The /SubmitForm key
static (Shared in Visual Basic) | Subtype | The /Subtype key
static (Shared in Visual Basic) | Subtype2 | The /Subtype2 key
static (Shared in Visual Basic) | Supplement | The /Supplement key
static (Shared in Visual Basic) | SV | The /SV key
static (Shared in Visual Basic) | SW | The /SW key
static (Shared in Visual Basic) | Symbol | The /Symbol key
static (Shared in Visual Basic) | T | The /T key
static (Shared in Visual Basic) | TA | The /TA key
static (Shared in Visual Basic) | Table | The /Table key
static (Shared in Visual Basic) | Tabs | The /Tabs key
static (Shared in Visual Basic) | TB | The /TB key
static (Shared in Visual Basic) | TBody | The /TBody key
static (Shared in Visual Basic) | TD | The /TD key
static (Shared in Visual Basic) | Text | The /Text key
static (Shared in Visual Basic) | TF | The /TF key
static (Shared in Visual Basic) | TFoot | The /TFoot key
static (Shared in Visual Basic) | TH | The /TH key
static (Shared in Visual Basic) | THead | The /THead key
static (Shared in Visual Basic) | Threads | The /Threads key
static (Shared in Visual Basic) | Thumb | The /Thumb key
static (Shared in Visual Basic) | TI | The /TI key
static (Shared in Visual Basic) | TilingType | The /TilingType key
static (Shared in Visual Basic) | Time | The /Time key
static (Shared in Visual Basic) | TimesBold | The /Times-Bold key
static (Shared in Visual Basic) | TimesBoldItalic | The /Times-BoldItalic key
static (Shared in Visual Basic) | TimesItalic | The /Times-Italic key
static (Shared in Visual Basic) | TimesRoman | The /Times-Roman key
static (Shared in Visual Basic) | Title | The /Title key
static (Shared in Visual Basic) | TK | The /TK key
static (Shared in Visual Basic) | TM | The /TM key
static (Shared in Visual Basic) | TOC | The /TOC key
static (Shared in Visual Basic) | TOCI | The /TOCI key
static (Shared in Visual Basic) | Toggle | The /Toggle key
static (Shared in Visual Basic) | Toolbar | The /Toolbar key
static (Shared in Visual Basic) | ToUnicode | The /ToUnicode key
static (Shared in Visual Basic) | TP | The /TP key
static (Shared in Visual Basic) | TR | The /TR key
static (Shared in Visual Basic) | TR2 | The /TR2 key
static (Shared in Visual Basic) | Trans | The /Trans key
static (Shared in Visual Basic) | TransformMethod | The /TransformMethod key
static (Shared in Visual Basic) | TransformParams | The /TransformParams key
static (Shared in Visual Basic) | Transparency | The /Transparency key
static (Shared in Visual Basic) | Transparent | The /Transparent key
static (Shared in Visual Basic) | Trapped | The /Trapped key
static (Shared in Visual Basic) | TrimBox | The /TrimBox key
static (Shared in Visual Basic) | TrueType | The /TrueType key
static (Shared in Visual Basic) | TU | The /TU key
static (Shared in Visual Basic) | TwoColumnLeft | The /TwoColumnLeft key
static (Shared in Visual Basic) | TwoColumnRight | The /TwoColumnRight key
static (Shared in Visual Basic) | TwoPageLeft | The /TwoPageLeft key
static (Shared in Visual Basic) | TwoPageRight | The /TwoPageRight key
static (Shared in Visual Basic) | Tx | The /Tx key
static (Shared in Visual Basic) | Type | The /Type key
static (Shared in Visual Basic) | Type0 | The /Type0 key
static (Shared in Visual Basic) | Type1 | The /Type1 key
static (Shared in Visual Basic) | Type3 | The /Type3 key
static (Shared in Visual Basic) | U | The /U key
static (Shared in Visual Basic) | U3D | The /U3D key
static (Shared in Visual Basic) | U3DPath | The /U3DPath key
static (Shared in Visual Basic) | UF | The /UF key
static (Shared in Visual Basic) | UHC | The /UHC key
static (Shared in Visual Basic) | Underline | The /Underline key
static (Shared in Visual Basic) | UR | The /UR key
static (Shared in Visual Basic) | UR3 | The /UR3 key
static (Shared in Visual Basic) | URI | The /URI key
static (Shared in Visual Basic) | URL | The /URL key
static (Shared in Visual Basic) | Usage | The /Usage key
static (Shared in Visual Basic) | UseAttachments | The /UseAttachments key
static (Shared in Visual Basic) | UseNone | The /UseNone key
static (Shared in Visual Basic) | UseOC | The /UseOC key
static (Shared in Visual Basic) | UseOutlines | The /UseOutlines key
static (Shared in Visual Basic) | User | The /User key
static (Shared in Visual Basic) | UserProperties | The /UserProperties key
static (Shared in Visual Basic) | UserUnit | The /UserUnit key
static (Shared in Visual Basic) | UseThumbs | The /UseThumbs key
static (Shared in Visual Basic) | USFT | The /USFT key
static (Shared in Visual Basic) | V | The /V key
static (Shared in Visual Basic) | V2 | The /V2 key
static (Shared in Visual Basic) | VA | The /VA key
static (Shared in Visual Basic) | VAlign | The /VAlign key
static (Shared in Visual Basic) | Version | The /Version key
static (Shared in Visual Basic) | Vertices | The /Vertices key
static (Shared in Visual Basic) | VerticesPerRow | The /VerticesPerRow key
static (Shared in Visual Basic) | Video | The /Video key
static (Shared in Visual Basic) | View | The /View key
static (Shared in Visual Basic) | ViewArea | The /ViewArea key
static (Shared in Visual Basic) | ViewClip | The /ViewClip key
static (Shared in Visual Basic) | ViewerPreferences | The /ViewerPreferences key
static (Shared in Visual Basic) | Viewport | The /Viewport key
static (Shared in Visual Basic) | Views | The /Views key
static (Shared in Visual Basic) | ViewState | The /ViewState key
static (Shared in Visual Basic) | VisiblePages | The /VisiblePages key
static (Shared in Visual Basic) | VOffset | The /VOffset key
static (Shared in Visual Basic) | VP | The /VP key
static (Shared in Visual Basic) | W | The /W key
static (Shared in Visual Basic) | W2 | The /W2 key
static (Shared in Visual Basic) | Warichu | The /Warichu key
static (Shared in Visual Basic) | WC | The /WC key
static (Shared in Visual Basic) | WhitePoint | The /WhitePoint key
static (Shared in Visual Basic) | Widget | The /Widget key
static (Shared in Visual Basic) | Width | The /Width key
static (Shared in Visual Basic) | Widths | The /Widths key
static (Shared in Visual Basic) | Win | The /Win key
static (Shared in Visual Basic) | WinAnsiEncoding | The /WinAnsiEncoding key
static (Shared in Visual Basic) | Window | The /Window key
static (Shared in Visual Basic) | Windowed | The /Windowed key
static (Shared in Visual Basic) | Wipe | The /Wipe key
static (Shared in Visual Basic) | WKT | The /WKT key
static (Shared in Visual Basic) | WP | The /WP key
static (Shared in Visual Basic) | WS | The /WS key
static (Shared in Visual Basic) | X | The /X key
static (Shared in Visual Basic) | XA | The /XA key
static (Shared in Visual Basic) | XD | The /XD key
static (Shared in Visual Basic) | XFA | The /XFA key
static (Shared in Visual Basic) | XHeight | The /XHeight key
static (Shared in Visual Basic) | XML | The /XML key
static (Shared in Visual Basic) | XN | The /XN key
static (Shared in Visual Basic) | XObject | The /XObject key
static (Shared in Visual Basic) | XPTS | The /XPTS key
static (Shared in Visual Basic) | XRef | The /XRef key
static (Shared in Visual Basic) | XRefStm | The /XRefStm key
static (Shared in Visual Basic) | XStep | The /XStep key
static (Shared in Visual Basic) | XYZ | The /XYZ key
static (Shared in Visual Basic) | Y | The /Y key
static (Shared in Visual Basic) | Yes | The /Yes key
static (Shared in Visual Basic) | YStep | The /YStep key
static (Shared in Visual Basic) | ZaDb | The /ZaDb key
static (Shared in Visual Basic) | ZapfDingbats | The /ZapfDingbats key
static (Shared in Visual Basic) | Zoom | The /Zoom key
Top
See Also

Reference

PdfNames Class
Xfinium.Pdf.Core Namespace


_3D Field

Xfinium.Pdf.Core Namespace > PdfNames Class : _3D Field
The /3D key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared _3D As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames._3D

PdfNames._3D = value
public static PdfCosName _3D
public:
static PdfCosName^ _3D
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


_3DA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : _3DA Field
The /3DA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared _3DA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames._3DA

PdfNames._3DA = value
public static PdfCosName _3DA
public:
static PdfCosName^ _3DA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


_3DAnimationStyle Field

Xfinium.Pdf.Core Namespace > PdfNames Class : _3DAnimationStyle Field
The /3DAnimationStyle key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared _3DAnimationStyle As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames._3DAnimationStyle

PdfNames._3DAnimationStyle = value
public static PdfCosName _3DAnimationStyle
public:
static PdfCosName^ _3DAnimationStyle
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


_3DBG Field

Xfinium.Pdf.Core Namespace > PdfNames Class : _3DBG Field
The /3DBG key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared _3DBG As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames._3DBG

PdfNames._3DBG = value
public static PdfCosName _3DBG
public:
static PdfCosName^ _3DBG
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


_3DD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : _3DD Field
The /3DD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared _3DD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames._3DD

PdfNames._3DD = value
public static PdfCosName _3DD
public:
static PdfCosName^ _3DD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


_3DRenderMode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : _3DRenderMode Field
The /3DRenderMode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared _3DRenderMode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames._3DRenderMode

PdfNames._3DRenderMode = value
public static PdfCosName _3DRenderMode
public:
static PdfCosName^ _3DRenderMode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


_3DView Field

Xfinium.Pdf.Core Namespace > PdfNames Class : _3DView Field
The /3DView key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared _3DView As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames._3DView

PdfNames._3DView = value
public static PdfCosName _3DView
public:
static PdfCosName^ _3DView
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


A Field

Xfinium.Pdf.Core Namespace > PdfNames Class : A Field
The /A key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared A As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.A

PdfNames.A = value
public static PdfCosName A
public:
static PdfCosName^ A
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AA Field
The /AA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AA

PdfNames.AA = value
public static PdfCosName AA
public:
static PdfCosName^ AA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AbsoluteColorimetric Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AbsoluteColorimetric Field
The /AbsoluteColorimetric key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AbsoluteColorimetric As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AbsoluteColorimetric

PdfNames.AbsoluteColorimetric = value
public static PdfCosName AbsoluteColorimetric
public:
static PdfCosName^ AbsoluteColorimetric
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AC Field
The /AC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AC

PdfNames.AC = value
public static PdfCosName AC
public:
static PdfCosName^ AC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AcroForm Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AcroForm Field
The /AcroForm key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AcroForm As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AcroForm

PdfNames.AcroForm = value
public static PdfCosName AcroForm
public:
static PdfCosName^ AcroForm
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Action Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Action Field
The /Action key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Action As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Action

PdfNames.Action = value
public static PdfCosName Action
public:
static PdfCosName^ Action
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Activation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Activation Field
The /Activation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Activation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Activation

PdfNames.Activation = value
public static PdfCosName Activation
public:
static PdfCosName^ Activation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ActualText Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ActualText Field
The /ActualText key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ActualText As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ActualText

PdfNames.ActualText = value
public static PdfCosName ActualText
public:
static PdfCosName^ ActualText
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ADBE Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ADBE Field
The /ADBE key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ADBE As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ADBE

PdfNames.ADBE = value
public static PdfCosName ADBE
public:
static PdfCosName^ ADBE
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AESV2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AESV2 Field
The /AESV2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AESV2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AESV2

PdfNames.AESV2 = value
public static PdfCosName AESV2
public:
static PdfCosName^ AESV2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AIS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AIS Field
The /AIS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AIS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AIS

PdfNames.AIS = value
public static PdfCosName AIS
public:
static PdfCosName^ AIS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


All Field

Xfinium.Pdf.Core Namespace > PdfNames Class : All Field
The /All key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared All As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.All

PdfNames.All = value
public static PdfCosName All
public:
static PdfCosName^ All
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AllPages Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AllPages Field
The /AllPages key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AllPages As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AllPages

PdfNames.AllPages = value
public static PdfCosName AllPages
public:
static PdfCosName^ AllPages
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ALT Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : ALT Field
The /ALT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ALT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ALT

PdfNames.ALT = value
public static PdfCosName ALT
public:
static PdfCosName^ ALT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Alternate Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Alternate Field
The /Alternate key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Alternate As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Alternate

PdfNames.Alternate = value
public static PdfCosName Alternate
public:
static PdfCosName^ Alternate
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Alternates Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Alternates Field
The /Alternates key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Alternates As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Alternates

PdfNames.Alternates = value
public static PdfCosName Alternates
public:
static PdfCosName^ Alternates
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AN Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AN Field
The /AN key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AN As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AN

PdfNames.AN = value
public static PdfCosName AN
public:
static PdfCosName^ AN
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Animation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Animation Field
The /Animation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Animation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Animation

PdfNames.Animation = value
public static PdfCosName Animation
public:
static PdfCosName^ Animation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Annot Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Annot Field
The /Annot key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Annot As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Annot

PdfNames.Annot = value
public static PdfCosName Annot
public:
static PdfCosName^ Annot
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Annots Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Annots Field
The /Annots key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Annots As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Annots

PdfNames.Annots = value
public static PdfCosName Annots
public:
static PdfCosName^ Annots
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AntiAlias Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AntiAlias Field
The /AntiAlias key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AntiAlias As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AntiAlias

PdfNames.AntiAlias = value
public static PdfCosName AntiAlias
public:
static PdfCosName^ AntiAlias
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AP Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AP Field
The /AP key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AP As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AP

PdfNames.AP = value
public static PdfCosName AP
public:
static PdfCosName^ AP
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AppDefault Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AppDefault Field
The /AppDefault key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AppDefault As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AppDefault

PdfNames.AppDefault = value
public static PdfCosName AppDefault
public:
static PdfCosName^ AppDefault
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Art Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Art Field
The /Art key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Art As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Art

PdfNames.Art = value
public static PdfCosName Art
public:
static PdfCosName^ Art
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ArtBox Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ArtBox Field
The /ArtBox key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ArtBox As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ArtBox

PdfNames.ArtBox = value
public static PdfCosName ArtBox
public:
static PdfCosName^ ArtBox
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AS Field
The /AS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AS

PdfNames.AS = value
public static PdfCosName AS
public:
static PdfCosName^ AS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Ascent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Ascent Field
The /Ascent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Ascent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Ascent

PdfNames.Ascent = value
public static PdfCosName Ascent
public:
static PdfCosName^ Ascent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ASCII85Decode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ASCII85Decode Field
The /ASCII85Decode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ASCII85Decode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ASCII85Decode

PdfNames.ASCII85Decode = value
public static PdfCosName ASCII85Decode
public:
static PdfCosName^ ASCII85Decode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ASCIIHexDecode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ASCIIHexDecode Field
The /ASCIIHexDecode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ASCIIHexDecode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ASCIIHexDecode

PdfNames.ASCIIHexDecode = value
public static PdfCosName ASCIIHexDecode
public:
static PdfCosName^ ASCIIHexDecode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Asset Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Asset Field
The /Asset key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Asset As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Asset

PdfNames.Asset = value
public static PdfCosName Asset
public:
static PdfCosName^ Asset
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Assets Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Assets Field
The /Assets key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Assets As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Assets

PdfNames.Assets = value
public static PdfCosName Assets
public:
static PdfCosName^ Assets
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AuthEvent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AuthEvent Field
The /AuthEvent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AuthEvent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AuthEvent

PdfNames.AuthEvent = value
public static PdfCosName AuthEvent
public:
static PdfCosName^ AuthEvent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Author Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Author Field
The /Author key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Author As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Author

PdfNames.Author = value
public static PdfCosName Author
public:
static PdfCosName^ Author
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


AvgWidth Field

Xfinium.Pdf.Core Namespace > PdfNames Class : AvgWidth Field
The /AvgWidth key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared AvgWidth As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.AvgWidth

PdfNames.AvgWidth = value
public static PdfCosName AvgWidth
public:
static PdfCosName^ AvgWidth
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


B Field

Xfinium.Pdf.Core Namespace > PdfNames Class : B Field
The /B key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared B As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.B

PdfNames.B = value
public static PdfCosName B
public:
static PdfCosName^ B
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Background Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Background Field
The /Background key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Background As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Background

PdfNames.Background = value
public static PdfCosName Background
public:
static PdfCosName^ Background
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BaseEncoding Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BaseEncoding Field
The /BaseEncoding key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BaseEncoding As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BaseEncoding

PdfNames.BaseEncoding = value
public static PdfCosName BaseEncoding
public:
static PdfCosName^ BaseEncoding
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BaseFont Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BaseFont Field
The /BaseFont key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BaseFont As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BaseFont

PdfNames.BaseFont = value
public static PdfCosName BaseFont
public:
static PdfCosName^ BaseFont
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BaseVersion Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BaseVersion Field
The /BaseVersion key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BaseVersion As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BaseVersion

PdfNames.BaseVersion = value
public static PdfCosName BaseVersion
public:
static PdfCosName^ BaseVersion
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BatesN Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BatesN Field
The /BatesN key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BatesN As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BatesN

PdfNames.BatesN = value
public static PdfCosName BatesN
public:
static PdfCosName^ BatesN
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BBox Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BBox Field
The /BBox key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BBox As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BBox

PdfNames.BBox = value
public static PdfCosName BBox
public:
static PdfCosName^ BBox
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BC Field
The /BC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BC

PdfNames.BC = value
public static PdfCosName BC
public:
static PdfCosName^ BC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BE Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BE Field
The /BE key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BE As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BE

PdfNames.BE = value
public static PdfCosName BE
public:
static PdfCosName^ BE
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BG Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BG Field
The /BG key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BG As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BG

PdfNames.BG = value
public static PdfCosName BG
public:
static PdfCosName^ BG
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BibEntry Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BibEntry Field
The /BibEntry key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BibEntry As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BibEntry

PdfNames.BibEntry = value
public static PdfCosName BibEntry
public:
static PdfCosName^ BibEntry
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BigFive Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BigFive Field
The /BigFive key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BigFive As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BigFive

PdfNames.BigFive = value
public static PdfCosName BigFive
public:
static PdfCosName^ BigFive
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Binding Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Binding Field
The /Binding key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Binding As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Binding

PdfNames.Binding = value
public static PdfCosName Binding
public:
static PdfCosName^ Binding
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BindingMaterialName Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BindingMaterialName Field
The /BindingMaterialName key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BindingMaterialName As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BindingMaterialName

PdfNames.BindingMaterialName = value
public static PdfCosName BindingMaterialName
public:
static PdfCosName^ BindingMaterialName
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BitsPerComponent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BitsPerComponent Field
The /BitsPerComponent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BitsPerComponent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BitsPerComponent

PdfNames.BitsPerComponent = value
public static PdfCosName BitsPerComponent
public:
static PdfCosName^ BitsPerComponent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BitsPerCoordinate Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BitsPerCoordinate Field
The /BitsPerCoordinate key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BitsPerCoordinate As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BitsPerCoordinate

PdfNames.BitsPerCoordinate = value
public static PdfCosName BitsPerCoordinate
public:
static PdfCosName^ BitsPerCoordinate
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BitsPerFlag Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BitsPerFlag Field
The /BitsPerFlag key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BitsPerFlag As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BitsPerFlag

PdfNames.BitsPerFlag = value
public static PdfCosName BitsPerFlag
public:
static PdfCosName^ BitsPerFlag
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BitsPerSample Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BitsPerSample Field
The /BitsPerSample key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BitsPerSample As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BitsPerSample

PdfNames.BitsPerSample = value
public static PdfCosName BitsPerSample
public:
static PdfCosName^ BitsPerSample
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Bl Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Bl Field
The /Bl key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Bl As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Bl

PdfNames.Bl = value
public static PdfCosName Bl
public:
static PdfCosName^ Bl
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BlackIs1 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BlackIs1 Field
The /BlackIs1 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BlackIs1 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BlackIs1

PdfNames.BlackIs1 = value
public static PdfCosName BlackIs1
public:
static PdfCosName^ BlackIs1
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BlackPoint Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BlackPoint Field
The /BlackPoint key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BlackPoint As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BlackPoint

PdfNames.BlackPoint = value
public static PdfCosName BlackPoint
public:
static PdfCosName^ BlackPoint
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BleedBox Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BleedBox Field
The /BleedBox key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BleedBox As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BleedBox

PdfNames.BleedBox = value
public static PdfCosName BleedBox
public:
static PdfCosName^ BleedBox
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Blinds Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Blinds Field
The /Blinds key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Blinds As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Blinds

PdfNames.Blinds = value
public static PdfCosName Blinds
public:
static PdfCosName^ Blinds
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BlockQuote Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BlockQuote Field
The /BlockQuote key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BlockQuote As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BlockQuote

PdfNames.BlockQuote = value
public static PdfCosName BlockQuote
public:
static PdfCosName^ BlockQuote
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BM Field
The /BM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BM

PdfNames.BM = value
public static PdfCosName BM
public:
static PdfCosName^ BM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Border Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Border Field
The /Border key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Border As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Border

PdfNames.Border = value
public static PdfCosName Border
public:
static PdfCosName^ Border
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Bounds Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Bounds Field
The /Bounds key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Bounds As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Bounds

PdfNames.Bounds = value
public static PdfCosName Bounds
public:
static PdfCosName^ Bounds
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Box Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Box Field
The /Box key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Box As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Box

PdfNames.Box = value
public static PdfCosName Box
public:
static PdfCosName^ Box
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


BS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : BS Field
The /BS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared BS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.BS

PdfNames.BS = value
public static PdfCosName BS
public:
static PdfCosName^ BS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Btn Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Btn Field
The /Btn key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Btn As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Btn

PdfNames.Btn = value
public static PdfCosName Btn
public:
static PdfCosName^ Btn
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ByteRange Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ByteRange Field
The /ByteRange key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ByteRange As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ByteRange

PdfNames.ByteRange = value
public static PdfCosName ByteRange
public:
static PdfCosName^ ByteRange
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


C Field

Xfinium.Pdf.Core Namespace > PdfNames Class : C Field
The /C key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared C As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.C

PdfNames.C = value
public static PdfCosName C
public:
static PdfCosName^ C
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


C0 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : C0 Field
The /C0 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared C0 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.C0

PdfNames.C0 = value
public static PdfCosName C0
public:
static PdfCosName^ C0
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


C1 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : C1 Field
The /C1 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared C1 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.C1

PdfNames.C1 = value
public static PdfCosName C1
public:
static PdfCosName^ C1
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


C2W Field

Xfinium.Pdf.Core Namespace > PdfNames Class : C2W Field
The /C2W key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared C2W As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.C2W

PdfNames.C2W = value
public static PdfCosName C2W
public:
static PdfCosName^ C2W
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CA Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : CA Field
The /CA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CA

PdfNames.CA = value
public static PdfCosName CA
public:
static PdfCosName^ CA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CalGray Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CalGray Field
The /CalGray key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CalGray As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CalGray

PdfNames.CalGray = value
public static PdfCosName CalGray
public:
static PdfCosName^ CalGray
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CalRGB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CalRGB Field
The /CalRGB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CalRGB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CalRGB

PdfNames.CalRGB = value
public static PdfCosName CalRGB
public:
static PdfCosName^ CalRGB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CapHeight Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CapHeight Field
The /CapHeight key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CapHeight As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CapHeight

PdfNames.CapHeight = value
public static PdfCosName CapHeight
public:
static PdfCosName^ CapHeight
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Caption Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Caption Field
The /Caption key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Caption As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Caption

PdfNames.Caption = value
public static PdfCosName Caption
public:
static PdfCosName^ Caption
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Catalog Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Catalog Field
The /Catalog key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Catalog As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Catalog

PdfNames.Catalog = value
public static PdfCosName Catalog
public:
static PdfCosName^ Catalog
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Category Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Category Field
The /Category key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Category As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Category

PdfNames.Category = value
public static PdfCosName Category
public:
static PdfCosName^ Category
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CCITTFaxDecode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CCITTFaxDecode Field
The /CCITTFaxDecode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CCITTFaxDecode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CCITTFaxDecode

PdfNames.CCITTFaxDecode = value
public static PdfCosName CCITTFaxDecode
public:
static PdfCosName^ CCITTFaxDecode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Center Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Center Field
The /Center key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Center As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Center

PdfNames.Center = value
public static PdfCosName Center
public:
static PdfCosName^ Center
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CenterWindow Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CenterWindow Field
The /CenterWindow key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CenterWindow As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CenterWindow

PdfNames.CenterWindow = value
public static PdfCosName CenterWindow
public:
static PdfCosName^ CenterWindow
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Cert Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Cert Field
The /Cert key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Cert As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Cert

PdfNames.Cert = value
public static PdfCosName Cert
public:
static PdfCosName^ Cert
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CF Field
The /CF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CF

PdfNames.CF = value
public static PdfCosName CF
public:
static PdfCosName^ CF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CFM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CFM Field
The /CFM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CFM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CFM

PdfNames.CFM = value
public static PdfCosName CFM
public:
static PdfCosName^ CFM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Ch Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Ch Field
The /Ch key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Ch As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Ch

PdfNames.Ch = value
public static PdfCosName Ch
public:
static PdfCosName^ Ch
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CharProcs Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CharProcs Field
The /CharProcs key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CharProcs As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CharProcs

PdfNames.CharProcs = value
public static PdfCosName CharProcs
public:
static PdfCosName^ CharProcs
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Child Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Child Field
The /Child key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Child As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Child

PdfNames.Child = value
public static PdfCosName Child
public:
static PdfCosName^ Child
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CI Field
The /CI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CI

PdfNames.CI = value
public static PdfCosName CI
public:
static PdfCosName^ CI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CIDFontType0 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CIDFontType0 Field
The /CIDFontType0 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CIDFontType0 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CIDFontType0

PdfNames.CIDFontType0 = value
public static PdfCosName CIDFontType0
public:
static PdfCosName^ CIDFontType0
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CIDFontType2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CIDFontType2 Field
The /CIDFontType2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CIDFontType2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CIDFontType2

PdfNames.CIDFontType2 = value
public static PdfCosName CIDFontType2
public:
static PdfCosName^ CIDFontType2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CIDSet Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CIDSet Field
The /CIDSet key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CIDSet As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CIDSet

PdfNames.CIDSet = value
public static PdfCosName CIDSet
public:
static PdfCosName^ CIDSet
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CIDSystemInfo Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CIDSystemInfo Field
The /CIDSystemInfo key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CIDSystemInfo As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CIDSystemInfo

PdfNames.CIDSystemInfo = value
public static PdfCosName CIDSystemInfo
public:
static PdfCosName^ CIDSystemInfo
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CIDToGIDMap Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CIDToGIDMap Field
The /CIDToGIDMap key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CIDToGIDMap As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CIDToGIDMap

PdfNames.CIDToGIDMap = value
public static PdfCosName CIDToGIDMap
public:
static PdfCosName^ CIDToGIDMap
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Circle Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : Circle Field
The /Circle key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Circle As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Circle

PdfNames.Circle = value
public static PdfCosName Circle
public:
static PdfCosName^ Circle
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Cloud Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Cloud Field
The /Cloud key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Cloud As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Cloud

PdfNames.Cloud = value
public static PdfCosName Cloud
public:
static PdfCosName^ Cloud
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CMapName Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CMapName Field
The /CMapName key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CMapName As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CMapName

PdfNames.CMapName = value
public static PdfCosName CMapName
public:
static PdfCosName^ CMapName
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CMD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CMD Field
The /CMD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CMD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CMD

PdfNames.CMD = value
public static PdfCosName CMD
public:
static PdfCosName^ CMD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CO Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CO Field
The /CO key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CO As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CO

PdfNames.CO = value
public static PdfCosName CO
public:
static PdfCosName^ CO
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Code Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Code Field
The /Code key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Code As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Code

PdfNames.Code = value
public static PdfCosName Code
public:
static PdfCosName^ Code
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Collection Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Collection Field
The /Collection key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Collection As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Collection

PdfNames.Collection = value
public static PdfCosName Collection
public:
static PdfCosName^ Collection
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CollectionField Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CollectionField Field
The /CollectionField key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CollectionField As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CollectionField

PdfNames.CollectionField = value
public static PdfCosName CollectionField
public:
static PdfCosName^ CollectionField
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CollectionItem Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CollectionItem Field
The /CollectionItem key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CollectionItem As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CollectionItem

PdfNames.CollectionItem = value
public static PdfCosName CollectionItem
public:
static PdfCosName^ CollectionItem
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CollectionSchema Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CollectionSchema Field
The /CollectionSchema key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CollectionSchema As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CollectionSchema

PdfNames.CollectionSchema = value
public static PdfCosName CollectionSchema
public:
static PdfCosName^ CollectionSchema
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CollectionSort Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CollectionSort Field
The /CollectionSort key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CollectionSort As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CollectionSort

PdfNames.CollectionSort = value
public static PdfCosName CollectionSort
public:
static PdfCosName^ CollectionSort
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CollectionSubitem Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CollectionSubitem Field
The /CollectionSubitem key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CollectionSubitem As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CollectionSubitem

PdfNames.CollectionSubitem = value
public static PdfCosName CollectionSubitem
public:
static PdfCosName^ CollectionSubitem
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Colors Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Colors Field
The /Colors key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Colors As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Colors

PdfNames.Colors = value
public static PdfCosName Colors
public:
static PdfCosName^ Colors
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ColorSpace Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ColorSpace Field
The /ColorSpace key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ColorSpace As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ColorSpace

PdfNames.ColorSpace = value
public static PdfCosName ColorSpace
public:
static PdfCosName^ ColorSpace
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Columns Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Columns Field
The /Columns key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Columns As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Columns

PdfNames.Columns = value
public static PdfCosName Columns
public:
static PdfCosName^ Columns
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Condition Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Condition Field
The /Condition key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Condition As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Condition

PdfNames.Condition = value
public static PdfCosName Condition
public:
static PdfCosName^ Condition
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Configuration Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Configuration Field
The /Configuration key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Configuration As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Configuration

PdfNames.Configuration = value
public static PdfCosName Configuration
public:
static PdfCosName^ Configuration
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Configurations Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Configurations Field
The /Configurations key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Configurations As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Configurations

PdfNames.Configurations = value
public static PdfCosName Configurations
public:
static PdfCosName^ Configurations
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ContactInfo Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ContactInfo Field
The /ContactInfo key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ContactInfo As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ContactInfo

PdfNames.ContactInfo = value
public static PdfCosName ContactInfo
public:
static PdfCosName^ ContactInfo
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Content Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Content Field
The /Content key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Content As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Content

PdfNames.Content = value
public static PdfCosName Content
public:
static PdfCosName^ Content
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Contents Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Contents Field
The /Contents key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Contents As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Contents

PdfNames.Contents = value
public static PdfCosName Contents
public:
static PdfCosName^ Contents
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Coords Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Coords Field
The /Coords key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Coords As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Coords

PdfNames.Coords = value
public static PdfCosName Coords
public:
static PdfCosName^ Coords
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Count Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Count Field
The /Count key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Count As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Count

PdfNames.Count = value
public static PdfCosName Count
public:
static PdfCosName^ Count
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Courier Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Courier Field
The /Courier key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Courier As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Courier

PdfNames.Courier = value
public static PdfCosName Courier
public:
static PdfCosName^ Courier
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CourierBold Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CourierBold Field
The /Courier-Bold key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CourierBold As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CourierBold

PdfNames.CourierBold = value
public static PdfCosName CourierBold
public:
static PdfCosName^ CourierBold
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CourierBoldOblique Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CourierBoldOblique Field
The /Courier-BoldOblique key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CourierBoldOblique As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CourierBoldOblique

PdfNames.CourierBoldOblique = value
public static PdfCosName CourierBoldOblique
public:
static PdfCosName^ CourierBoldOblique
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CourierOblique Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CourierOblique Field
The /Courier-Oblique key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CourierOblique As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CourierOblique

PdfNames.CourierOblique = value
public static PdfCosName CourierOblique
public:
static PdfCosName^ CourierOblique
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CreationDate Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CreationDate Field
The /CreationDate key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CreationDate As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CreationDate

PdfNames.CreationDate = value
public static PdfCosName CreationDate
public:
static PdfCosName^ CreationDate
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Creator Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Creator Field
The /Creator key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Creator As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Creator

PdfNames.Creator = value
public static PdfCosName Creator
public:
static PdfCosName^ Creator
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CreatorInfo Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CreatorInfo Field
The /CreatorInfo key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CreatorInfo As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CreatorInfo

PdfNames.CreatorInfo = value
public static PdfCosName CreatorInfo
public:
static PdfCosName^ CreatorInfo
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CropBox Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CropBox Field
The /CropBox key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CropBox As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CropBox

PdfNames.CropBox = value
public static PdfCosName CropBox
public:
static PdfCosName^ CropBox
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Crypt Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Crypt Field
The /Crypt key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Crypt As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Crypt

PdfNames.Crypt = value
public static PdfCosName Crypt
public:
static PdfCosName^ Crypt
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CS Field
The /CS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CS

PdfNames.CS = value
public static PdfCosName CS
public:
static PdfCosName^ CS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CT Field
The /CT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CT

PdfNames.CT = value
public static PdfCosName CT
public:
static PdfCosName^ CT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CuePoint Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CuePoint Field
The /CuePoint key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CuePoint As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CuePoint

PdfNames.CuePoint = value
public static PdfCosName CuePoint
public:
static PdfCosName^ CuePoint
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CuePoints Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CuePoints Field
The /CuePoints key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CuePoints As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CuePoints

PdfNames.CuePoints = value
public static PdfCosName CuePoints
public:
static PdfCosName^ CuePoints
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CV Field
The /CV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CV

PdfNames.CV = value
public static PdfCosName CV
public:
static PdfCosName^ CV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


CXY Field

Xfinium.Pdf.Core Namespace > PdfNames Class : CXY Field
The /CXY key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared CXY As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.CXY

PdfNames.CXY = value
public static PdfCosName CXY
public:
static PdfCosName^ CXY
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


D Field

Xfinium.Pdf.Core Namespace > PdfNames Class : D Field
The /D key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared D As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.D

PdfNames.D = value
public static PdfCosName D
public:
static PdfCosName^ D
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DA Field
The /DA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DA

PdfNames.DA = value
public static PdfCosName DA
public:
static PdfCosName^ DA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Data Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Data Field
The /Data key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Data As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Data

PdfNames.Data = value
public static PdfCosName Data
public:
static PdfCosName^ Data
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DC Field
The /DC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DC

PdfNames.DC = value
public static PdfCosName DC
public:
static PdfCosName^ DC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DCS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DCS Field
The /DCS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DCS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DCS

PdfNames.DCS = value
public static PdfCosName DCS
public:
static PdfCosName^ DCS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DCTDecode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DCTDecode Field
The /DCTDecode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DCTDecode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DCTDecode

PdfNames.DCTDecode = value
public static PdfCosName DCTDecode
public:
static PdfCosName^ DCTDecode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Deactivation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Deactivation Field
The /Deactivation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Deactivation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Deactivation

PdfNames.Deactivation = value
public static PdfCosName Deactivation
public:
static PdfCosName^ Deactivation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Decode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Decode Field
The /Decode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Decode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Decode

PdfNames.Decode = value
public static PdfCosName Decode
public:
static PdfCosName^ Decode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DecodeParms Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DecodeParms Field
The /DecodeParms key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DecodeParms As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DecodeParms

PdfNames.DecodeParms = value
public static PdfCosName DecodeParms
public:
static PdfCosName^ DecodeParms
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Default Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Default Field
The /Default key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Default As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Default

PdfNames.Default = value
public static PdfCosName Default
public:
static PdfCosName^ Default
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DefaultCMYK Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DefaultCMYK Field
The /DefaultCMYK key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DefaultCMYK As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DefaultCMYK

PdfNames.DefaultCMYK = value
public static PdfCosName DefaultCMYK
public:
static PdfCosName^ DefaultCMYK
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DefaultCryptFilter Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DefaultCryptFilter Field
The /DefaultCryptFilter key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DefaultCryptFilter As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DefaultCryptFilter

PdfNames.DefaultCryptFilter = value
public static PdfCosName DefaultCryptFilter
public:
static PdfCosName^ DefaultCryptFilter
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DefaultForPrinting Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DefaultForPrinting Field
The /DefaultForPrinting key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DefaultForPrinting As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DefaultForPrinting

PdfNames.DefaultForPrinting = value
public static PdfCosName DefaultForPrinting
public:
static PdfCosName^ DefaultForPrinting
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DefaultGray Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DefaultGray Field
The /DefaultGray key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DefaultGray As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DefaultGray

PdfNames.DefaultGray = value
public static PdfCosName DefaultGray
public:
static PdfCosName^ DefaultGray
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DefaultRGB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DefaultRGB Field
The /DefaultRGB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DefaultRGB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DefaultRGB

PdfNames.DefaultRGB = value
public static PdfCosName DefaultRGB
public:
static PdfCosName^ DefaultRGB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DEG Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DEG Field
The /DEG key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DEG As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DEG

PdfNames.DEG = value
public static PdfCosName DEG
public:
static PdfCosName^ DEG
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Desc Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Desc Field
The /Desc key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Desc As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Desc

PdfNames.Desc = value
public static PdfCosName Desc
public:
static PdfCosName^ Desc
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DescendantFonts Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DescendantFonts Field
The /DescendantFonts key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DescendantFonts As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DescendantFonts

PdfNames.DescendantFonts = value
public static PdfCosName DescendantFonts
public:
static PdfCosName^ DescendantFonts
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Descent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Descent Field
The /Descent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Descent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Descent

PdfNames.Descent = value
public static PdfCosName Descent
public:
static PdfCosName^ Descent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Dest Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Dest Field
The /Dest key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Dest As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Dest

PdfNames.Dest = value
public static PdfCosName Dest
public:
static PdfCosName^ Dest
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DestOutputProfile Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DestOutputProfile Field
The /DestOutputProfile key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DestOutputProfile As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DestOutputProfile

PdfNames.DestOutputProfile = value
public static PdfCosName DestOutputProfile
public:
static PdfCosName^ DestOutputProfile
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Dests Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Dests Field
The /Dests key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Dests As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Dests

PdfNames.Dests = value
public static PdfCosName Dests
public:
static PdfCosName^ Dests
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DeviceCMYK Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DeviceCMYK Field
The /DeviceCMYK key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DeviceCMYK As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DeviceCMYK

PdfNames.DeviceCMYK = value
public static PdfCosName DeviceCMYK
public:
static PdfCosName^ DeviceCMYK
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DeviceGray Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DeviceGray Field
The /DeviceGray key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DeviceGray As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DeviceGray

PdfNames.DeviceGray = value
public static PdfCosName DeviceGray
public:
static PdfCosName^ DeviceGray
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DeviceN Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DeviceN Field
The /DeviceN key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DeviceN As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DeviceN

PdfNames.DeviceN = value
public static PdfCosName DeviceN
public:
static PdfCosName^ DeviceN
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DeviceRGB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DeviceRGB Field
The /DeviceRGB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DeviceRGB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DeviceRGB

PdfNames.DeviceRGB = value
public static PdfCosName DeviceRGB
public:
static PdfCosName^ DeviceRGB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Di Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Di Field
The /Di key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Di As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Di

PdfNames.Di = value
public static PdfCosName Di
public:
static PdfCosName^ Di
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Differences Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Differences Field
The /Differences key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Differences As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Differences

PdfNames.Differences = value
public static PdfCosName Differences
public:
static PdfCosName^ Differences
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Direction Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Direction Field
The /Direction key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Direction As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Direction

PdfNames.Direction = value
public static PdfCosName Direction
public:
static PdfCosName^ Direction
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DIS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DIS Field
The /DIS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DIS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DIS

PdfNames.DIS = value
public static PdfCosName DIS
public:
static PdfCosName^ DIS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DisplayDocTitle Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DisplayDocTitle Field
The /DisplayDocTitle key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DisplayDocTitle As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DisplayDocTitle

PdfNames.DisplayDocTitle = value
public static PdfCosName DisplayDocTitle
public:
static PdfCosName^ DisplayDocTitle
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Dissolve Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Dissolve Field
The /Dissolve key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Dissolve As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Dissolve

PdfNames.Dissolve = value
public static PdfCosName Dissolve
public:
static PdfCosName^ Dissolve
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Div Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Div Field
The /Div key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Div As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Div

PdfNames.Div = value
public static PdfCosName Div
public:
static PdfCosName^ Div
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DL Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DL Field
The /DL key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DL As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DL

PdfNames.DL = value
public static PdfCosName DL
public:
static PdfCosName^ DL
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Dm Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Dm Field
The /Dm key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Dm As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Dm

PdfNames.Dm = value
public static PdfCosName Dm
public:
static PdfCosName^ Dm
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DocMDP Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DocMDP Field
The /DocMDP key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DocMDP As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DocMDP

PdfNames.DocMDP = value
public static PdfCosName DocMDP
public:
static PdfCosName^ DocMDP
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DocOpen Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DocOpen Field
The /DocOpen key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DocOpen As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DocOpen

PdfNames.DocOpen = value
public static PdfCosName DocOpen
public:
static PdfCosName^ DocOpen
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Domain Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Domain Field
The /Domain key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Domain As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Domain

PdfNames.Domain = value
public static PdfCosName Domain
public:
static PdfCosName^ Domain
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DP Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DP Field
The /DP key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DP As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DP

PdfNames.DP = value
public static PdfCosName DP
public:
static PdfCosName^ DP
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DR Field
The /DR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DR

PdfNames.DR = value
public static PdfCosName DR
public:
static PdfCosName^ DR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Draft Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : Draft Field
The /Draft key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Draft As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Draft

PdfNames.Draft = value
public static PdfCosName Draft
public:
static PdfCosName^ Draft
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DS Field
The /DS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DS

PdfNames.DS = value
public static PdfCosName DS
public:
static PdfCosName^ DS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Duplex Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Duplex Field
The /Duplex key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Duplex As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Duplex

PdfNames.Duplex = value
public static PdfCosName Duplex
public:
static PdfCosName^ Duplex
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DuplexFlipLongEdge Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DuplexFlipLongEdge Field
The /DuplexFlipLongEdge key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DuplexFlipLongEdge As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DuplexFlipLongEdge

PdfNames.DuplexFlipLongEdge = value
public static PdfCosName DuplexFlipLongEdge
public:
static PdfCosName^ DuplexFlipLongEdge
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DuplexFlipShortEdge Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DuplexFlipShortEdge Field
The /DuplexFlipShortEdge key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DuplexFlipShortEdge As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DuplexFlipShortEdge

PdfNames.DuplexFlipShortEdge = value
public static PdfCosName DuplexFlipShortEdge
public:
static PdfCosName^ DuplexFlipShortEdge
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Dur Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Dur Field
The /Dur key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Dur As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Dur

PdfNames.Dur = value
public static PdfCosName Dur
public:
static PdfCosName^ Dur
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DV Field
The /DV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DV

PdfNames.DV = value
public static PdfCosName DV
public:
static PdfCosName^ DV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


DW Field

Xfinium.Pdf.Core Namespace > PdfNames Class : DW Field
The /DW key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared DW As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.DW

PdfNames.DW = value
public static PdfCosName DW
public:
static PdfCosName^ DW
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


E Field

Xfinium.Pdf.Core Namespace > PdfNames Class : E Field
The /E key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared E As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.E

PdfNames.E = value
public static PdfCosName E
public:
static PdfCosName^ E
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EA Field
The /EA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EA

PdfNames.EA = value
public static PdfCosName EA
public:
static PdfCosName^ EA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EarlyChange Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EarlyChange Field
The /EarlyChange key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EarlyChange As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EarlyChange

PdfNames.EarlyChange = value
public static PdfCosName EarlyChange
public:
static PdfCosName^ EarlyChange
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EF Field
The /EF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EF

PdfNames.EF = value
public static PdfCosName EF
public:
static PdfCosName^ EF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EFF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EFF Field
The /EFF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EFF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EFF

PdfNames.EFF = value
public static PdfCosName EFF
public:
static PdfCosName^ EFF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EFOpen Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EFOpen Field
The /EFOpen key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EFOpen As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EFOpen

PdfNames.EFOpen = value
public static PdfCosName EFOpen
public:
static PdfCosName^ EFOpen
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Embedded Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Embedded Field
The /Embedded key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Embedded As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Embedded

PdfNames.Embedded = value
public static PdfCosName Embedded
public:
static PdfCosName^ Embedded
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EmbeddedFile Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EmbeddedFile Field
The /EmbeddedFile key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EmbeddedFile As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EmbeddedFile

PdfNames.EmbeddedFile = value
public static PdfCosName EmbeddedFile
public:
static PdfCosName^ EmbeddedFile
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EmbeddedFiles Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EmbeddedFiles Field
The /EmbeddedFiles key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EmbeddedFiles As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EmbeddedFiles

PdfNames.EmbeddedFiles = value
public static PdfCosName EmbeddedFiles
public:
static PdfCosName^ EmbeddedFiles
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Encode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Encode Field
The /Encode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Encode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Encode

PdfNames.Encode = value
public static PdfCosName Encode
public:
static PdfCosName^ Encode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EncodedByteAlign Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EncodedByteAlign Field
The /EncodedByteAlign key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EncodedByteAlign As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EncodedByteAlign

PdfNames.EncodedByteAlign = value
public static PdfCosName EncodedByteAlign
public:
static PdfCosName^ EncodedByteAlign
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Encoding Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Encoding Field
The /Encoding key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Encoding As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Encoding

PdfNames.Encoding = value
public static PdfCosName Encoding
public:
static PdfCosName^ Encoding
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Encrypt Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Encrypt Field
The /Encrypt key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Encrypt As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Encrypt

PdfNames.Encrypt = value
public static PdfCosName Encrypt
public:
static PdfCosName^ Encrypt
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EncryptMetadata Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EncryptMetadata Field
The /EncryptMetadata key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EncryptMetadata As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EncryptMetadata

PdfNames.EncryptMetadata = value
public static PdfCosName EncryptMetadata
public:
static PdfCosName^ EncryptMetadata
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EndOfBlock Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EndOfBlock Field
The /EndOfBlock key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EndOfBlock As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EndOfBlock

PdfNames.EndOfBlock = value
public static PdfCosName EndOfBlock
public:
static PdfCosName^ EndOfBlock
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EndOfLine Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EndOfLine Field
The /EndOfLine key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EndOfLine As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EndOfLine

PdfNames.EndOfLine = value
public static PdfCosName EndOfLine
public:
static PdfCosName^ EndOfLine
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


EPSG Field

Xfinium.Pdf.Core Namespace > PdfNames Class : EPSG Field
The /EPSG key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared EPSG As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.EPSG

PdfNames.EPSG = value
public static PdfCosName EPSG
public:
static PdfCosName^ EPSG
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Event Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Event Field
The /Event key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Event As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Event

PdfNames.Event = value
public static PdfCosName Event
public:
static PdfCosName^ Event
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Export Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Export Field
The /Export key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Export As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Export

PdfNames.Export = value
public static PdfCosName Export
public:
static PdfCosName^ Export
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ExportState Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ExportState Field
The /ExportState key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ExportState As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ExportState

PdfNames.ExportState = value
public static PdfCosName ExportState
public:
static PdfCosName^ ExportState
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Extend Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Extend Field
The /Extend key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Extend As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Extend

PdfNames.Extend = value
public static PdfCosName Extend
public:
static PdfCosName^ Extend
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ExtensionLevel Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ExtensionLevel Field
The /ExtensionLevel key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ExtensionLevel As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ExtensionLevel

PdfNames.ExtensionLevel = value
public static PdfCosName ExtensionLevel
public:
static PdfCosName^ ExtensionLevel
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Extensions Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Extensions Field
The /Extensions key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Extensions As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Extensions

PdfNames.Extensions = value
public static PdfCosName Extensions
public:
static PdfCosName^ Extensions
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ExtGState Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ExtGState Field
The /ExtGState key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ExtGState As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ExtGState

PdfNames.ExtGState = value
public static PdfCosName ExtGState
public:
static PdfCosName^ ExtGState
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


F Field

Xfinium.Pdf.Core Namespace > PdfNames Class : F Field
The /F key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared F As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.F

PdfNames.F = value
public static PdfCosName F
public:
static PdfCosName^ F
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Far Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Far Field
The /Far key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Far As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Far

PdfNames.Far = value
public static PdfCosName Far
public:
static PdfCosName^ Far
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FB Field
The /FB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FB

PdfNames.FB = value
public static PdfCosName FB
public:
static PdfCosName^ FB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FC Field
The /FC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FC

PdfNames.FC = value
public static PdfCosName FC
public:
static PdfCosName^ FC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FD Field
The /FD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FD

PdfNames.FD = value
public static PdfCosName FD
public:
static PdfCosName^ FD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FDecodeParms Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FDecodeParms Field
The /FDecodeParms key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FDecodeParms As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FDecodeParms

PdfNames.FDecodeParms = value
public static PdfCosName FDecodeParms
public:
static PdfCosName^ FDecodeParms
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FDF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FDF Field
The /FDF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FDF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FDF

PdfNames.FDF = value
public static PdfCosName FDF
public:
static PdfCosName^ FDF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Ff Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Ff Field
The /Ff key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Ff As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Ff

PdfNames.Ff = value
public static PdfCosName Ff
public:
static PdfCosName^ Ff
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FFilter Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FFilter Field
The /FFilter key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FFilter As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FFilter

PdfNames.FFilter = value
public static PdfCosName FFilter
public:
static PdfCosName^ FFilter
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Fields Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Fields Field
The /Fields key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Fields As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Fields

PdfNames.Fields = value
public static PdfCosName Fields
public:
static PdfCosName^ Fields
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FileAttachment Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FileAttachment Field
The /FileAttachment key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FileAttachment As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FileAttachment

PdfNames.FileAttachment = value
public static PdfCosName FileAttachment
public:
static PdfCosName^ FileAttachment
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Filespec Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Filespec Field
The /Filespec key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Filespec As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Filespec

PdfNames.Filespec = value
public static PdfCosName Filespec
public:
static PdfCosName^ Filespec
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Filter Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Filter Field
The /Filter key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Filter As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Filter

PdfNames.Filter = value
public static PdfCosName Filter
public:
static PdfCosName^ Filter
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


First Field

Xfinium.Pdf.Core Namespace > PdfNames Class : First Field
The /First key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared First As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.First

PdfNames.First = value
public static PdfCosName First
public:
static PdfCosName^ First
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FirstChar Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FirstChar Field
The /FirstChar key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FirstChar As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FirstChar

PdfNames.FirstChar = value
public static PdfCosName FirstChar
public:
static PdfCosName^ FirstChar
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FirstPage Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FirstPage Field
The /FirstPage key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FirstPage As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FirstPage

PdfNames.FirstPage = value
public static PdfCosName FirstPage
public:
static PdfCosName^ FirstPage
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Fit Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Fit Field
The /Fit key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Fit As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Fit

PdfNames.Fit = value
public static PdfCosName Fit
public:
static PdfCosName^ Fit
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FitB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FitB Field
The /FitB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FitB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FitB

PdfNames.FitB = value
public static PdfCosName FitB
public:
static PdfCosName^ FitB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FitBH Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FitBH Field
The /FitBH key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FitBH As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FitBH

PdfNames.FitBH = value
public static PdfCosName FitBH
public:
static PdfCosName^ FitBH
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FitBV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FitBV Field
The /FitBV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FitBV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FitBV

PdfNames.FitBV = value
public static PdfCosName FitBV
public:
static PdfCosName^ FitBV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FitH Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FitH Field
The /FitH key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FitH As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FitH

PdfNames.FitH = value
public static PdfCosName FitH
public:
static PdfCosName^ FitH
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FitR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FitR Field
The /FitR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FitR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FitR

PdfNames.FitR = value
public static PdfCosName FitR
public:
static PdfCosName^ FitR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FitV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FitV Field
The /FitV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FitV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FitV

PdfNames.FitV = value
public static PdfCosName FitV
public:
static PdfCosName^ FitV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FitWindow Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FitWindow Field
The /FitWindow key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FitWindow As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FitWindow

PdfNames.FitWindow = value
public static PdfCosName FitWindow
public:
static PdfCosName^ FitWindow
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Flags Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Flags Field
The /Flags key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Flags As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Flags

PdfNames.Flags = value
public static PdfCosName Flags
public:
static PdfCosName^ Flags
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Flash Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Flash Field
The /Flash key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Flash As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Flash

PdfNames.Flash = value
public static PdfCosName Flash
public:
static PdfCosName^ Flash
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FlashVars Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FlashVars Field
The /FlashVars key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FlashVars As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FlashVars

PdfNames.FlashVars = value
public static PdfCosName FlashVars
public:
static PdfCosName^ FlashVars
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FlateDecode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FlateDecode Field
The /FlateDecode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FlateDecode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FlateDecode

PdfNames.FlateDecode = value
public static PdfCosName FlateDecode
public:
static PdfCosName^ FlateDecode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Fo Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Fo Field
The /Fo key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Fo As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Fo

PdfNames.Fo = value
public static PdfCosName Fo
public:
static PdfCosName^ Fo
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Folder Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Folder Field
The /Folder key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Folder As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Folder

PdfNames.Folder = value
public static PdfCosName Folder
public:
static PdfCosName^ Folder
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Folders Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Folders Field
The /Folders key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Folders As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Folders

PdfNames.Folders = value
public static PdfCosName Folders
public:
static PdfCosName^ Folders
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Font Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Font Field
The /Font key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Font As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Font

PdfNames.Font = value
public static PdfCosName Font
public:
static PdfCosName^ Font
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FontBBox Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FontBBox Field
The /FontBBox key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FontBBox As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FontBBox

PdfNames.FontBBox = value
public static PdfCosName FontBBox
public:
static PdfCosName^ FontBBox
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FontDescriptor Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FontDescriptor Field
The /FontDescriptor key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FontDescriptor As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FontDescriptor

PdfNames.FontDescriptor = value
public static PdfCosName FontDescriptor
public:
static PdfCosName^ FontDescriptor
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FontFile Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FontFile Field
The /FontFile key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FontFile As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FontFile

PdfNames.FontFile = value
public static PdfCosName FontFile
public:
static PdfCosName^ FontFile
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FontFile2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FontFile2 Field
The /FontFile2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FontFile2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FontFile2

PdfNames.FontFile2 = value
public static PdfCosName FontFile2
public:
static PdfCosName^ FontFile2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FontFile3 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FontFile3 Field
The /FontFile3 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FontFile3 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FontFile3

PdfNames.FontFile3 = value
public static PdfCosName FontFile3
public:
static PdfCosName^ FontFile3
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FontMatrix Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FontMatrix Field
The /FontMatrix key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FontMatrix As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FontMatrix

PdfNames.FontMatrix = value
public static PdfCosName FontMatrix
public:
static PdfCosName^ FontMatrix
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FontName Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FontName Field
The /FontName key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FontName As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FontName

PdfNames.FontName = value
public static PdfCosName FontName
public:
static PdfCosName^ FontName
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Foreground Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Foreground Field
The /Foreground key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Foreground As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Foreground

PdfNames.Foreground = value
public static PdfCosName Foreground
public:
static PdfCosName^ Foreground
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Form Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Form Field
The /Form key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Form As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Form

PdfNames.Form = value
public static PdfCosName Form
public:
static PdfCosName^ Form
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FormType Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FormType Field
The /FormType key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FormType As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FormType

PdfNames.FormType = value
public static PdfCosName FormType
public:
static PdfCosName^ FormType
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FOV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FOV Field
The /FOV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FOV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FOV

PdfNames.FOV = value
public static PdfCosName FOV
public:
static PdfCosName^ FOV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FreeText Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FreeText Field
The /FreeText key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FreeText As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FreeText

PdfNames.FreeText = value
public static PdfCosName FreeText
public:
static PdfCosName^ FreeText
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FRM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FRM Field
The /FRM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FRM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FRM

PdfNames.FRM = value
public static PdfCosName FRM
public:
static PdfCosName^ FRM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FS Field
The /FS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FS

PdfNames.FS = value
public static PdfCosName FS
public:
static PdfCosName^ FS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FT Field
The /FT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FT

PdfNames.FT = value
public static PdfCosName FT
public:
static PdfCosName^ FT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FullScreen Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FullScreen Field
The /FullScreen key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FullScreen As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FullScreen

PdfNames.FullScreen = value
public static PdfCosName FullScreen
public:
static PdfCosName^ FullScreen
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Function Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Function Field
The /Function key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Function

PdfNames.Function = value
public static PdfCosName Function
public:
static PdfCosName^ Function
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Functions Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Functions Field
The /Functions key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Functions As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Functions

PdfNames.Functions = value
public static PdfCosName Functions
public:
static PdfCosName^ Functions
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


FunctionType Field

Xfinium.Pdf.Core Namespace > PdfNames Class : FunctionType Field
The /FunctionType key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared FunctionType As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.FunctionType

PdfNames.FunctionType = value
public static PdfCosName FunctionType
public:
static PdfCosName^ FunctionType
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


G Field

Xfinium.Pdf.Core Namespace > PdfNames Class : G Field
The /G key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared G As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.G

PdfNames.G = value
public static PdfCosName G
public:
static PdfCosName^ G
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Gamma Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Gamma Field
The /Gamma key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Gamma As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Gamma

PdfNames.Gamma = value
public static PdfCosName Gamma
public:
static PdfCosName^ Gamma
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GBK Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GBK Field
The /GBK key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GBK As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GBK

PdfNames.GBK = value
public static PdfCosName GBK
public:
static PdfCosName^ GBK
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GCS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GCS Field
The /GCS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GCS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GCS

PdfNames.GCS = value
public static PdfCosName GCS
public:
static PdfCosName^ GCS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GEO Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GEO Field
The /GEO key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GEO As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GEO

PdfNames.GEO = value
public static PdfCosName GEO
public:
static PdfCosName^ GEO
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GEOGCS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GEOGCS Field
The /GEOGCS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GEOGCS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GEOGCS

PdfNames.GEOGCS = value
public static PdfCosName GEOGCS
public:
static PdfCosName^ GEOGCS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Glitter Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Glitter Field
The /Glitter key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Glitter As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Glitter

PdfNames.Glitter = value
public static PdfCosName Glitter
public:
static PdfCosName^ Glitter
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GoTo Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GoTo Field
The /GoTo key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GoTo As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GoTo

PdfNames.GoTo = value
public static PdfCosName GoTo
public:
static PdfCosName^ GoTo
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GoTo3DView Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GoTo3DView Field
The /GoTo3DView key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GoTo3DView As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GoTo3DView

PdfNames.GoTo3DView = value
public static PdfCosName GoTo3DView
public:
static PdfCosName^ GoTo3DView
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GoToE Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GoToE Field
The /GoToE key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GoToE As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GoToE

PdfNames.GoToE = value
public static PdfCosName GoToE
public:
static PdfCosName^ GoToE
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GoToR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GoToR Field
The /GoToR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GoToR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GoToR

PdfNames.GoToR = value
public static PdfCosName GoToR
public:
static PdfCosName^ GoToR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GPTS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GPTS Field
The /GPTS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GPTS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GPTS

PdfNames.GPTS = value
public static PdfCosName GPTS
public:
static PdfCosName^ GPTS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GRD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GRD Field
The /GRD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GRD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GRD

PdfNames.GRD = value
public static PdfCosName GRD
public:
static PdfCosName^ GRD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Group Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Group Field
The /Group key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Group As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Group

PdfNames.Group = value
public static PdfCosName Group
public:
static PdfCosName^ Group
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GTS_PDFA1 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GTS_PDFA1 Field
The /GTS_PdfA1 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GTS_PDFA1 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GTS_PDFA1

PdfNames.GTS_PDFA1 = value
public static PdfCosName GTS_PDFA1
public:
static PdfCosName^ GTS_PDFA1
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GTS_PDFX Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GTS_PDFX Field
The /GTS_PdfX key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GTS_PDFX As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GTS_PDFX

PdfNames.GTS_PDFX = value
public static PdfCosName GTS_PDFX
public:
static PdfCosName^ GTS_PDFX
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


GTS_PDFXVersion Field

Xfinium.Pdf.Core Namespace > PdfNames Class : GTS_PDFXVersion Field
The /GTS_PdfXVersion key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared GTS_PDFXVersion As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.GTS_PDFXVersion

PdfNames.GTS_PDFXVersion = value
public static PdfCosName GTS_PDFXVersion
public:
static PdfCosName^ GTS_PDFXVersion
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


H Field

Xfinium.Pdf.Core Namespace > PdfNames Class : H Field
The /H key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared H As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.H

PdfNames.H = value
public static PdfCosName H
public:
static PdfCosName^ H
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


H2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : H2 Field
The /H2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared H2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.H2

PdfNames.H2 = value
public static PdfCosName H2
public:
static PdfCosName^ H2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


H3 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : H3 Field
The /H3 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared H3 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.H3

PdfNames.H3 = value
public static PdfCosName H3
public:
static PdfCosName^ H3
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


H4 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : H4 Field
The /H4 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared H4 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.H4

PdfNames.H4 = value
public static PdfCosName H4
public:
static PdfCosName^ H4
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


H5 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : H5 Field
The /H5 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared H5 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.H5

PdfNames.H5 = value
public static PdfCosName H5
public:
static PdfCosName^ H5
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


H6 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : H6 Field
The /H6 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared H6 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.H6

PdfNames.H6 = value
public static PdfCosName H6
public:
static PdfCosName^ H6
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HA Field
The /HA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HA

PdfNames.HA = value
public static PdfCosName HA
public:
static PdfCosName^ HA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HAlign Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HAlign Field
The /HAlign key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HAlign As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HAlign

PdfNames.HAlign = value
public static PdfCosName HAlign
public:
static PdfCosName^ HAlign
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Height Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Height Field
The /Height key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Height As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Height

PdfNames.Height = value
public static PdfCosName Height
public:
static PdfCosName^ Height
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Helv Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Helv Field
The /Helv key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Helv As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Helv

PdfNames.Helv = value
public static PdfCosName Helv
public:
static PdfCosName^ Helv
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Helvetica Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Helvetica Field
The /Helvetica key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Helvetica As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Helvetica

PdfNames.Helvetica = value
public static PdfCosName Helvetica
public:
static PdfCosName^ Helvetica
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HelveticaBold Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HelveticaBold Field
The /Helvetica-Bold key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HelveticaBold As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HelveticaBold

PdfNames.HelveticaBold = value
public static PdfCosName HelveticaBold
public:
static PdfCosName^ HelveticaBold
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HelveticaBoldOblique Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HelveticaBoldOblique Field
The /Helvetica-BoldOblique key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HelveticaBoldOblique As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HelveticaBoldOblique

PdfNames.HelveticaBoldOblique = value
public static PdfCosName HelveticaBoldOblique
public:
static PdfCosName^ HelveticaBoldOblique
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HelveticaOblique Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HelveticaOblique Field
The /Helvetica-Oblique key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HelveticaOblique As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HelveticaOblique

PdfNames.HelveticaOblique = value
public static PdfCosName HelveticaOblique
public:
static PdfCosName^ HelveticaOblique
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Hid Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Hid Field
The /Hid key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Hid As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Hid

PdfNames.Hid = value
public static PdfCosName Hid
public:
static PdfCosName^ Hid
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Hide Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Hide Field
The /Hide key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Hide As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Hide

PdfNames.Hide = value
public static PdfCosName Hide
public:
static PdfCosName^ Hide
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HideMenubar Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HideMenubar Field
The /HideMenubar key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HideMenubar As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HideMenubar

PdfNames.HideMenubar = value
public static PdfCosName HideMenubar
public:
static PdfCosName^ HideMenubar
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HideToolbar Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HideToolbar Field
The /HideToolbar key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HideToolbar As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HideToolbar

PdfNames.HideToolbar = value
public static PdfCosName HideToolbar
public:
static PdfCosName^ HideToolbar
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HideWindowUI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HideWindowUI Field
The /HideWindowUI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HideWindowUI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HideWindowUI

PdfNames.HideWindowUI = value
public static PdfCosName HideWindowUI
public:
static PdfCosName^ HideWindowUI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Highlight Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Highlight Field
The /Highlight key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Highlight As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Highlight

PdfNames.Highlight = value
public static PdfCosName Highlight
public:
static PdfCosName^ Highlight
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


HOffset Field

Xfinium.Pdf.Core Namespace > PdfNames Class : HOffset Field
The /HOffset key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared HOffset As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.HOffset

PdfNames.HOffset = value
public static PdfCosName HOffset
public:
static PdfCosName^ HOffset
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


I Field

Xfinium.Pdf.Core Namespace > PdfNames Class : I Field
The /I key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared I As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.I

PdfNames.I = value
public static PdfCosName I
public:
static PdfCosName^ I
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IC Field
The /IC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IC

PdfNames.IC = value
public static PdfCosName IC
public:
static PdfCosName^ IC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ICCBased Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ICCBased Field
The /ICCBased key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ICCBased As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ICCBased

PdfNames.ICCBased = value
public static PdfCosName ICCBased
public:
static PdfCosName^ ICCBased
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ID Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ID Field
The /ID key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ID As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ID

PdfNames.ID = value
public static PdfCosName ID
public:
static PdfCosName^ ID
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Identity Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Identity Field
The /Identity key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Identity As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Identity

PdfNames.Identity = value
public static PdfCosName Identity
public:
static PdfCosName^ Identity
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IdentityH Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IdentityH Field
The /IdentityH key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IdentityH As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IdentityH

PdfNames.IdentityH = value
public static PdfCosName IdentityH
public:
static PdfCosName^ IdentityH
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IdentityV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IdentityV Field
The /IdentityV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IdentityV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IdentityV

PdfNames.IdentityV = value
public static PdfCosName IdentityV
public:
static PdfCosName^ IdentityV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IF Field
The /IF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IF

PdfNames.IF = value
public static PdfCosName IF
public:
static PdfCosName^ IF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Image Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Image Field
The /Image key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Image As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Image

PdfNames.Image = value
public static PdfCosName Image
public:
static PdfCosName^ Image
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ImageB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ImageB Field
The /ImageB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ImageB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ImageB

PdfNames.ImageB = value
public static PdfCosName ImageB
public:
static PdfCosName^ ImageB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ImageC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ImageC Field
The /ImageC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ImageC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ImageC

PdfNames.ImageC = value
public static PdfCosName ImageC
public:
static PdfCosName^ ImageC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ImageI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ImageI Field
The /ImageI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ImageI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ImageI

PdfNames.ImageI = value
public static PdfCosName ImageI
public:
static PdfCosName^ ImageI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ImageMask Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ImageMask Field
The /ImageMask key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ImageMask As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ImageMask

PdfNames.ImageMask = value
public static PdfCosName ImageMask
public:
static PdfCosName^ ImageMask
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ImportData Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ImportData Field
The /ImportData key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ImportData As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ImportData

PdfNames.ImportData = value
public static PdfCosName ImportData
public:
static PdfCosName^ ImportData
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IN Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IN Field
The /IN key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IN As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IN

PdfNames.IN = value
public static PdfCosName IN
public:
static PdfCosName^ IN
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Index Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Index Field
The /Index key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Index As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Index

PdfNames.Index = value
public static PdfCosName Index
public:
static PdfCosName^ Index
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Indexed Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Indexed Field
The /Indexed key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Indexed As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Indexed

PdfNames.Indexed = value
public static PdfCosName Indexed
public:
static PdfCosName^ Indexed
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Info Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Info Field
The /Info key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Info As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Info

PdfNames.Info = value
public static PdfCosName Info
public:
static PdfCosName^ Info
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Ink Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Ink Field
The /Ink key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Ink As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Ink

PdfNames.Ink = value
public static PdfCosName Ink
public:
static PdfCosName^ Ink
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


InkList Field

Xfinium.Pdf.Core Namespace > PdfNames Class : InkList Field
The /InkList key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared InkList As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.InkList

PdfNames.InkList = value
public static PdfCosName InkList
public:
static PdfCosName^ InkList
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Instances Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Instances Field
The /Instances key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Instances As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Instances

PdfNames.Instances = value
public static PdfCosName Instances
public:
static PdfCosName^ Instances
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Intent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Intent Field
The /Intent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Intent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Intent

PdfNames.Intent = value
public static PdfCosName Intent
public:
static PdfCosName^ Intent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Interpolate Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Interpolate Field
The /Interpolate key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Interpolate As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Interpolate

PdfNames.Interpolate = value
public static PdfCosName Interpolate
public:
static PdfCosName^ Interpolate
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IRT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IRT Field
The /IRT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IRT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IRT

PdfNames.IRT = value
public static PdfCosName IRT
public:
static PdfCosName^ IRT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IsMap Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IsMap Field
The /IsMap key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IsMap As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IsMap

PdfNames.IsMap = value
public static PdfCosName IsMap
public:
static PdfCosName^ IsMap
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ItalicAngle Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ItalicAngle Field
The /ItalicAngle key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ItalicAngle As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ItalicAngle

PdfNames.ItalicAngle = value
public static PdfCosName ItalicAngle
public:
static PdfCosName^ ItalicAngle
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ITXT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ITXT Field
The /ITXT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ITXT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ITXT

PdfNames.ITXT = value
public static PdfCosName ITXT
public:
static PdfCosName^ ITXT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IV Field
The /IV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IV

PdfNames.IV = value
public static PdfCosName IV
public:
static PdfCosName^ IV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


IX Field

Xfinium.Pdf.Core Namespace > PdfNames Class : IX Field
The /IX key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared IX As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.IX

PdfNames.IX = value
public static PdfCosName IX
public:
static PdfCosName^ IX
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


JavaScript Field

Xfinium.Pdf.Core Namespace > PdfNames Class : JavaScript Field
The /JavaScript key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared JavaScript As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.JavaScript

PdfNames.JavaScript = value
public static PdfCosName JavaScript
public:
static PdfCosName^ JavaScript
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


JBIG2Decode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : JBIG2Decode Field
The /JBIG2Decode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared JBIG2Decode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.JBIG2Decode

PdfNames.JBIG2Decode = value
public static PdfCosName JBIG2Decode
public:
static PdfCosName^ JBIG2Decode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


JBIG2Globals Field

Xfinium.Pdf.Core Namespace > PdfNames Class : JBIG2Globals Field
The /JBIG2Globals key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared JBIG2Globals As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.JBIG2Globals

PdfNames.JBIG2Globals = value
public static PdfCosName JBIG2Globals
public:
static PdfCosName^ JBIG2Globals
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


JPXDecode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : JPXDecode Field
The /JPXDecode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared JPXDecode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.JPXDecode

PdfNames.JPXDecode = value
public static PdfCosName JPXDecode
public:
static PdfCosName^ JPXDecode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


JS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : JS Field
The /JS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared JS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.JS

PdfNames.JS = value
public static PdfCosName JS
public:
static PdfCosName^ JS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


K Field

Xfinium.Pdf.Core Namespace > PdfNames Class : K Field
The /K key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared K As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.K

PdfNames.K = value
public static PdfCosName K
public:
static PdfCosName^ K
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Keywords Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Keywords Field
The /Keywords key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Keywords As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Keywords

PdfNames.Keywords = value
public static PdfCosName Keywords
public:
static PdfCosName^ Keywords
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Kids Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Kids Field
The /Kids key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Kids As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Kids

PdfNames.Kids = value
public static PdfCosName Kids
public:
static PdfCosName^ Kids
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


KM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : KM Field
The /KM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared KM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.KM

PdfNames.KM = value
public static PdfCosName KM
public:
static PdfCosName^ KM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


L Field

Xfinium.Pdf.Core Namespace > PdfNames Class : L Field
The /L key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared L As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.L

PdfNames.L = value
public static PdfCosName L
public:
static PdfCosName^ L
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


L2R Field

Xfinium.Pdf.Core Namespace > PdfNames Class : L2R Field
The /L2R key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared L2R As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.L2R

PdfNames.L2R = value
public static PdfCosName L2R
public:
static PdfCosName^ L2R
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Lab Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Lab Field
The /Lab key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Lab As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Lab

PdfNames.Lab = value
public static PdfCosName Lab
public:
static PdfCosName^ Lab
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Lang Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Lang Field
The /Lang key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Lang As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Lang

PdfNames.Lang = value
public static PdfCosName Lang
public:
static PdfCosName^ Lang
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Language Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Language Field
The /Language key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Language As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Language

PdfNames.Language = value
public static PdfCosName Language
public:
static PdfCosName^ Language
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Last Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Last Field
The /Last key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Last As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Last

PdfNames.Last = value
public static PdfCosName Last
public:
static PdfCosName^ Last
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LastChar Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LastChar Field
The /LastChar key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LastChar As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LastChar

PdfNames.LastChar = value
public static PdfCosName LastChar
public:
static PdfCosName^ LastChar
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LastPage Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LastPage Field
The /LastPage key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LastPage As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LastPage

PdfNames.LastPage = value
public static PdfCosName LastPage
public:
static PdfCosName^ LastPage
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LAT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LAT Field
The /LAT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LAT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LAT

PdfNames.LAT = value
public static PdfCosName LAT
public:
static PdfCosName^ LAT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Launch Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Launch Field
The /Launch key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Launch As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Launch

PdfNames.Launch = value
public static PdfCosName Launch
public:
static PdfCosName^ Launch
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Lbl Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Lbl Field
The /Lbl key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Lbl As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Lbl

PdfNames.Lbl = value
public static PdfCosName Lbl
public:
static PdfCosName^ Lbl
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LBody Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LBody Field
The /LBody key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LBody As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LBody

PdfNames.LBody = value
public static PdfCosName LBody
public:
static PdfCosName^ LBody
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LE Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LE Field
The /LE key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LE As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LE

PdfNames.LE = value
public static PdfCosName LE
public:
static PdfCosName^ LE
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Leading Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Leading Field
The /Leading key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Leading As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Leading

PdfNames.Leading = value
public static PdfCosName Leading
public:
static PdfCosName^ Leading
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Length Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Length Field
The /Length key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Length As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Length

PdfNames.Length = value
public static PdfCosName Length
public:
static PdfCosName^ Length
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Length1 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Length1 Field
The /Length1 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Length1 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Length1

PdfNames.Length1 = value
public static PdfCosName Length1
public:
static PdfCosName^ Length1
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Length2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Length2 Field
The /Length2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Length2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Length2

PdfNames.Length2 = value
public static PdfCosName Length2
public:
static PdfCosName^ Length2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Length3 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Length3 Field
The /Length1 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Length3 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Length3

PdfNames.Length3 = value
public static PdfCosName Length3
public:
static PdfCosName^ Length3
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LI Field
The /LI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LI

PdfNames.LI = value
public static PdfCosName LI
public:
static PdfCosName^ LI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Limits Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Limits Field
The /Limits key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Limits As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Limits

PdfNames.Limits = value
public static PdfCosName Limits
public:
static PdfCosName^ Limits
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Line Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Line Field
The /Line key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Line As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Line

PdfNames.Line = value
public static PdfCosName Line
public:
static PdfCosName^ Line
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Linear Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Linear Field
The /Linear key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Linear As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Linear

PdfNames.Linear = value
public static PdfCosName Linear
public:
static PdfCosName^ Linear
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Link Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Link Field
The /Link key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Link As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Link

PdfNames.Link = value
public static PdfCosName Link
public:
static PdfCosName^ Link
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ListMode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ListMode Field
The /ListMode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ListMode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ListMode

PdfNames.ListMode = value
public static PdfCosName ListMode
public:
static PdfCosName^ ListMode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Location Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Location Field
The /Location key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Location As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Location

PdfNames.Location = value
public static PdfCosName Location
public:
static PdfCosName^ Location
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Lock Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Lock Field
The /Lock key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Lock As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Lock

PdfNames.Lock = value
public static PdfCosName Lock
public:
static PdfCosName^ Lock
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Locked Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Locked Field
The /Locked key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Locked As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Locked

PdfNames.Locked = value
public static PdfCosName Locked
public:
static PdfCosName^ Locked
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LON Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LON Field
The /LON key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LON As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LON

PdfNames.LON = value
public static PdfCosName LON
public:
static PdfCosName^ LON
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LPTS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LPTS Field
The /LPTS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LPTS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LPTS

PdfNames.LPTS = value
public static PdfCosName LPTS
public:
static PdfCosName^ LPTS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LS Field
The /LS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LS

PdfNames.LS = value
public static PdfCosName LS
public:
static PdfCosName^ LS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


LZWDecode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : LZWDecode Field
The /LZWDecode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared LZWDecode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.LZWDecode

PdfNames.LZWDecode = value
public static PdfCosName LZWDecode
public:
static PdfCosName^ LZWDecode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


M Field

Xfinium.Pdf.Core Namespace > PdfNames Class : M Field
The /M key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared M As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.M

PdfNames.M = value
public static PdfCosName M
public:
static PdfCosName^ M
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MacExpertEncoding Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MacExpertEncoding Field
The /MacExpertEncoding key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MacExpertEncoding As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MacExpertEncoding

PdfNames.MacExpertEncoding = value
public static PdfCosName MacExpertEncoding
public:
static PdfCosName^ MacExpertEncoding
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MacRomanEncoding Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MacRomanEncoding Field
The /MacRomanEncoding key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MacRomanEncoding As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MacRomanEncoding

PdfNames.MacRomanEncoding = value
public static PdfCosName MacRomanEncoding
public:
static PdfCosName^ MacRomanEncoding
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Marked Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Marked Field
The /Marked key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Marked As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Marked

PdfNames.Marked = value
public static PdfCosName Marked
public:
static PdfCosName^ Marked
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MarkInfo Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MarkInfo Field
The /MarkInfo key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MarkInfo As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MarkInfo

PdfNames.MarkInfo = value
public static PdfCosName MarkInfo
public:
static PdfCosName^ MarkInfo
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Mask Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Mask Field
The /Mask key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Mask As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Mask

PdfNames.Mask = value
public static PdfCosName Mask
public:
static PdfCosName^ Mask
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Material Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Material Field
The /Material key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Material As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Material

PdfNames.Material = value
public static PdfCosName Material
public:
static PdfCosName^ Material
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Matrix Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Matrix Field
The /Matrix key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Matrix As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Matrix

PdfNames.Matrix = value
public static PdfCosName Matrix
public:
static PdfCosName^ Matrix
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Matte Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Matte Field
The /Matte key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Matte As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Matte

PdfNames.Matte = value
public static PdfCosName Matte
public:
static PdfCosName^ Matte
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Max Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : Max Field
The /Max key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Max As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Max

PdfNames.Max = value
public static PdfCosName Max
public:
static PdfCosName^ Max
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MaxLen Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MaxLen Field
The /MaxLen key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MaxLen As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MaxLen

PdfNames.MaxLen = value
public static PdfCosName MaxLen
public:
static PdfCosName^ MaxLen
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MaxWidth Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MaxWidth Field
The /MaxWidth key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MaxWidth As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MaxWidth

PdfNames.MaxWidth = value
public static PdfCosName MaxWidth
public:
static PdfCosName^ MaxWidth
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MCD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MCD Field
The /MCD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MCD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MCD

PdfNames.MCD = value
public static PdfCosName MCD
public:
static PdfCosName^ MCD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MCID Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MCID Field
The /MCID key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MCID As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MCID

PdfNames.MCID = value
public static PdfCosName MCID
public:
static PdfCosName^ MCID
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MCR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MCR Field
The /MCR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MCR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MCR

PdfNames.MCR = value
public static PdfCosName MCR
public:
static PdfCosName^ MCR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Measure Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Measure Field
The /Measure key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Measure As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Measure

PdfNames.Measure = value
public static PdfCosName Measure
public:
static PdfCosName^ Measure
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MediaBox Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MediaBox Field
The /MediaBox key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MediaBox As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MediaBox

PdfNames.MediaBox = value
public static PdfCosName MediaBox
public:
static PdfCosName^ MediaBox
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Metadata Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Metadata Field
The /Metadata key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Metadata As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Metadata

PdfNames.Metadata = value
public static PdfCosName Metadata
public:
static PdfCosName^ Metadata
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MI Field
The /MI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MI

PdfNames.MI = value
public static PdfCosName MI
public:
static PdfCosName^ MI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Min Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : Min Field
The /Min key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Min As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Min

PdfNames.Min = value
public static PdfCosName Min
public:
static PdfCosName^ Min
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MissingWidth Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MissingWidth Field
The /MissingWidth key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MissingWidth As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MissingWidth

PdfNames.MissingWidth = value
public static PdfCosName MissingWidth
public:
static PdfCosName^ MissingWidth
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MK Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MK Field
The /MK key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MK As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MK

PdfNames.MK = value
public static PdfCosName MK
public:
static PdfCosName^ MK
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MMType1 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MMType1 Field
The /MMType1 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MMType1 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MMType1

PdfNames.MMType1 = value
public static PdfCosName MMType1
public:
static PdfCosName^ MMType1
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ModDate Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ModDate Field
The /ModDate key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ModDate As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ModDate

PdfNames.ModDate = value
public static PdfCosName ModDate
public:
static PdfCosName^ ModDate
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MR Field
The /MR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MR

PdfNames.MR = value
public static PdfCosName MR
public:
static PdfCosName^ MR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


MS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : MS Field
The /MS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared MS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.MS

PdfNames.MS = value
public static PdfCosName MS
public:
static PdfCosName^ MS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Multiply Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Multiply Field
The /Multiply key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Multiply As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Multiply

PdfNames.Multiply = value
public static PdfCosName Multiply
public:
static PdfCosName^ Multiply
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


N Field

Xfinium.Pdf.Core Namespace > PdfNames Class : N Field
The /N key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared N As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.N

PdfNames.N = value
public static PdfCosName N
public:
static PdfCosName^ N
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


n0 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : n0 Field
The /n0 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared n0 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.n0

PdfNames.n0 = value
public static PdfCosName n0
public:
static PdfCosName^ n0
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


n1 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : n1 Field
The /n1 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared n1 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.n1

PdfNames.n1 = value
public static PdfCosName n1
public:
static PdfCosName^ n1
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


n2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : n2 Field
The /n2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared n2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.n2

PdfNames.n2 = value
public static PdfCosName n2
public:
static PdfCosName^ n2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


n3 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : n3 Field
The /n3 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared n3 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.n3

PdfNames.n3 = value
public static PdfCosName n3
public:
static PdfCosName^ n3
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


n4 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : n4 Field
The /n4 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared n4 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.n4

PdfNames.n4 = value
public static PdfCosName n4
public:
static PdfCosName^ n4
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NA Field
The /NA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NA

PdfNames.NA = value
public static PdfCosName NA
public:
static PdfCosName^ NA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Name Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Name Field
The /Name key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Name As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Name

PdfNames.Name = value
public static PdfCosName Name
public:
static PdfCosName^ Name
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Named Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Named Field
The /Named key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Named As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Named

PdfNames.Named = value
public static PdfCosName Named
public:
static PdfCosName^ Named
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Names Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Names Field
The /Names key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Names As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Names

PdfNames.Names = value
public static PdfCosName Names
public:
static PdfCosName^ Names
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Navigation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Navigation Field
The /Navigation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Navigation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Navigation

PdfNames.Navigation = value
public static PdfCosName Navigation
public:
static PdfCosName^ Navigation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NavigationPane Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NavigationPane Field
The /NavigationPane key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NavigationPane As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NavigationPane

PdfNames.NavigationPane = value
public static PdfCosName NavigationPane
public:
static PdfCosName^ NavigationPane
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Near Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Near Field
The /Near key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Near As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Near

PdfNames.Near = value
public static PdfCosName Near
public:
static PdfCosName^ Near
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NeedAppearances Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NeedAppearances Field
The /NeedAppearances key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NeedAppearances As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NeedAppearances

PdfNames.NeedAppearances = value
public static PdfCosName NeedAppearances
public:
static PdfCosName^ NeedAppearances
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NewWindow Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NewWindow Field
The /NewWindow key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NewWindow As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NewWindow

PdfNames.NewWindow = value
public static PdfCosName NewWindow
public:
static PdfCosName^ NewWindow
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Next Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Next Field
The /Next key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Next As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Next

PdfNames.Next = value
public static PdfCosName Next
public:
static PdfCosName^ Next
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NextPage Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NextPage Field
The /NextPage key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NextPage As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NextPage

PdfNames.NextPage = value
public static PdfCosName NextPage
public:
static PdfCosName^ NextPage
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NM Field
The /NM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NM

PdfNames.NM = value
public static PdfCosName NM
public:
static PdfCosName^ NM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


None Field

Xfinium.Pdf.Core Namespace > PdfNames Class : None Field
The /None key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared None As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.None

PdfNames.None = value
public static PdfCosName None
public:
static PdfCosName^ None
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NonFullScreenPageMode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NonFullScreenPageMode Field
The /NonFullScreenPageMode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NonFullScreenPageMode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NonFullScreenPageMode

PdfNames.NonFullScreenPageMode = value
public static PdfCosName NonFullScreenPageMode
public:
static PdfCosName^ NonFullScreenPageMode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NonStruct Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NonStruct Field
The /NonStruct key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NonStruct As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NonStruct

PdfNames.NonStruct = value
public static PdfCosName NonStruct
public:
static PdfCosName^ NonStruct
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Note Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : Note Field
The /Note key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Note As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Note

PdfNames.Note = value
public static PdfCosName Note
public:
static PdfCosName^ Note
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NP Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NP Field
The /NP key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NP As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NP

PdfNames.NP = value
public static PdfCosName NP
public:
static PdfCosName^ NP
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NR Field
The /NR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NR

PdfNames.NR = value
public static PdfCosName NR
public:
static PdfCosName^ NR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NumberFormat Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NumberFormat Field
The /NumberFormat key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NumberFormat As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NumberFormat

PdfNames.NumberFormat = value
public static PdfCosName NumberFormat
public:
static PdfCosName^ NumberFormat
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


NumCopies Field

Xfinium.Pdf.Core Namespace > PdfNames Class : NumCopies Field
The /NumCopies key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared NumCopies As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.NumCopies

PdfNames.NumCopies = value
public static PdfCosName NumCopies
public:
static PdfCosName^ NumCopies
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Nums Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Nums Field
The /Nums key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Nums As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Nums

PdfNames.Nums = value
public static PdfCosName Nums
public:
static PdfCosName^ Nums
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


O Field

Xfinium.Pdf.Core Namespace > PdfNames Class : O Field
The /O key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared O As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.O

PdfNames.O = value
public static PdfCosName O
public:
static PdfCosName^ O
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OB Field
The /OB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OB

PdfNames.OB = value
public static PdfCosName OB
public:
static PdfCosName^ OB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Obj Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Obj Field
The /Obj key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Obj As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Obj

PdfNames.Obj = value
public static PdfCosName Obj
public:
static PdfCosName^ Obj
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OBJR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OBJR Field
The /OBJR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OBJR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OBJR

PdfNames.OBJR = value
public static PdfCosName OBJR
public:
static PdfCosName^ OBJR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ObjStm Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ObjStm Field
The /ObjStm key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ObjStm As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ObjStm

PdfNames.ObjStm = value
public static PdfCosName ObjStm
public:
static PdfCosName^ ObjStm
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OC Field
The /OC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OC

PdfNames.OC = value
public static PdfCosName OC
public:
static PdfCosName^ OC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OCG Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OCG Field
The /OCG key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OCG As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OCG

PdfNames.OCG = value
public static PdfCosName OCG
public:
static PdfCosName^ OCG
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OCGs Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OCGs Field
The /OCGs key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OCGs As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OCGs

PdfNames.OCGs = value
public static PdfCosName OCGs
public:
static PdfCosName^ OCGs
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OCMD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OCMD Field
The /OCMD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OCMD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OCMD

PdfNames.OCMD = value
public static PdfCosName OCMD
public:
static PdfCosName^ OCMD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OCProperties Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OCProperties Field
The /OCProperties key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OCProperties As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OCProperties

PdfNames.OCProperties = value
public static PdfCosName OCProperties
public:
static PdfCosName^ OCProperties
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OFF Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : OFF Field
The /OFF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OFF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OFF

PdfNames.OFF = value
public static PdfCosName OFF
public:
static PdfCosName^ OFF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ON Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ON Field
The /ON key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ON As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ON

PdfNames.ON = value
public static PdfCosName ON
public:
static PdfCosName^ ON
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OneByteIdentityH Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OneByteIdentityH Field
The /OneByteIdentityH key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OneByteIdentityH As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OneByteIdentityH

PdfNames.OneByteIdentityH = value
public static PdfCosName OneByteIdentityH
public:
static PdfCosName^ OneByteIdentityH
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OneColumn Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OneColumn Field
The /OneColumn key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OneColumn As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OneColumn

PdfNames.OneColumn = value
public static PdfCosName OneColumn
public:
static PdfCosName^ OneColumn
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OnInstantiate Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OnInstantiate Field
The /OnInstantiate key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OnInstantiate As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OnInstantiate

PdfNames.OnInstantiate = value
public static PdfCosName OnInstantiate
public:
static PdfCosName^ OnInstantiate
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OP Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : OP Field
The /OP key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OP As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OP

PdfNames.OP = value
public static PdfCosName OP
public:
static PdfCosName^ OP
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Open Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Open Field
The /Open key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Open As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Open

PdfNames.Open = value
public static PdfCosName Open
public:
static PdfCosName^ Open
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OpenAction Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OpenAction Field
The /OpenAction key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OpenAction As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OpenAction

PdfNames.OpenAction = value
public static PdfCosName OpenAction
public:
static PdfCosName^ OpenAction
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OPI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OPI Field
The /OPI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OPI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OPI

PdfNames.OPI = value
public static PdfCosName OPI
public:
static PdfCosName^ OPI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OPM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OPM Field
The /OPM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OPM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OPM

PdfNames.OPM = value
public static PdfCosName OPM
public:
static PdfCosName^ OPM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Opt Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Opt Field
The /Opt key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Opt As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Opt

PdfNames.Opt = value
public static PdfCosName Opt
public:
static PdfCosName^ Opt
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Order Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Order Field
The /Order key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Order As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Order

PdfNames.Order = value
public static PdfCosName Order
public:
static PdfCosName^ Order
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Ordering Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Ordering Field
The /Ordering key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Ordering As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Ordering

PdfNames.Ordering = value
public static PdfCosName Ordering
public:
static PdfCosName^ Ordering
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OS Field
The /OS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OS

PdfNames.OS = value
public static PdfCosName OS
public:
static PdfCosName^ OS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Oscillating Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Oscillating Field
The /Oscillating key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Oscillating As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Oscillating

PdfNames.Oscillating = value
public static PdfCosName Oscillating
public:
static PdfCosName^ Oscillating
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Outlines Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Outlines Field
The /Outlines key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Outlines As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Outlines

PdfNames.Outlines = value
public static PdfCosName Outlines
public:
static PdfCosName^ Outlines
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OutputCondition Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OutputCondition Field
The /OutputCondition key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OutputCondition As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OutputCondition

PdfNames.OutputCondition = value
public static PdfCosName OutputCondition
public:
static PdfCosName^ OutputCondition
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OutputConditionIdentifier Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OutputConditionIdentifier Field
The /OutputConditionIdentifier key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OutputConditionIdentifier As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OutputConditionIdentifier

PdfNames.OutputConditionIdentifier = value
public static PdfCosName OutputConditionIdentifier
public:
static PdfCosName^ OutputConditionIdentifier
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OutputIntent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OutputIntent Field
The /OutputIntent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OutputIntent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OutputIntent

PdfNames.OutputIntent = value
public static PdfCosName OutputIntent
public:
static PdfCosName^ OutputIntent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OutputIntents Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OutputIntents Field
The /OutputIntents key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OutputIntents As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OutputIntents

PdfNames.OutputIntents = value
public static PdfCosName OutputIntents
public:
static PdfCosName^ OutputIntents
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


OverlayText Field

Xfinium.Pdf.Core Namespace > PdfNames Class : OverlayText Field
The /OverlayText key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared OverlayText As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.OverlayText

PdfNames.OverlayText = value
public static PdfCosName OverlayText
public:
static PdfCosName^ OverlayText
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


P Field

Xfinium.Pdf.Core Namespace > PdfNames Class : P Field
The /P key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared P As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.P

PdfNames.P = value
public static PdfCosName P
public:
static PdfCosName^ P
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Page Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Page Field
The /Page key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Page As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Page

PdfNames.Page = value
public static PdfCosName Page
public:
static PdfCosName^ Page
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PageLabels Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PageLabels Field
The /PageLabels key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PageLabels As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PageLabels

PdfNames.PageLabels = value
public static PdfCosName PageLabels
public:
static PdfCosName^ PageLabels
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PageLayout Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PageLayout Field
The /PageLayout key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PageLayout As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PageLayout

PdfNames.PageLayout = value
public static PdfCosName PageLayout
public:
static PdfCosName^ PageLayout
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PageMode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PageMode Field
The /PageMode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PageMode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PageMode

PdfNames.PageMode = value
public static PdfCosName PageMode
public:
static PdfCosName^ PageMode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Pages Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Pages Field
The /Pages key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Pages As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Pages

PdfNames.Pages = value
public static PdfCosName Pages
public:
static PdfCosName^ Pages
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Pagination Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Pagination Field
The /Pagination key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Pagination As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Pagination

PdfNames.Pagination = value
public static PdfCosName Pagination
public:
static PdfCosName^ Pagination
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PaintType Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PaintType Field
The /PaintType key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PaintType As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PaintType

PdfNames.PaintType = value
public static PdfCosName PaintType
public:
static PdfCosName^ PaintType
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Panose Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Panose Field
The /Panose key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Panose As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Panose

PdfNames.Panose = value
public static PdfCosName Panose
public:
static PdfCosName^ Panose
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Params Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Params Field
The /Params key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Params As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Params

PdfNames.Params = value
public static PdfCosName Params
public:
static PdfCosName^ Params
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Parent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Parent Field
The /Parent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Parent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Parent

PdfNames.Parent = value
public static PdfCosName Parent
public:
static PdfCosName^ Parent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ParentTree Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ParentTree Field
The /ParentTree key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ParentTree As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ParentTree

PdfNames.ParentTree = value
public static PdfCosName ParentTree
public:
static PdfCosName^ ParentTree
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PassContextClick Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PassContextClick Field
The /PassContextClick key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PassContextClick As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PassContextClick

PdfNames.PassContextClick = value
public static PdfCosName PassContextClick
public:
static PdfCosName^ PassContextClick
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Pattern Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Pattern Field
The /Pattern key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Pattern As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Pattern

PdfNames.Pattern = value
public static PdfCosName Pattern
public:
static PdfCosName^ Pattern
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PatternType Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PatternType Field
The /PatternType key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PatternType As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PatternType

PdfNames.PatternType = value
public static PdfCosName PatternType
public:
static PdfCosName^ PatternType
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PC Field
The /PC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PC

PdfNames.PC = value
public static PdfCosName PC
public:
static PdfCosName^ PC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PDF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PDF Field
The /Pdf key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PDF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PDF

PdfNames.PDF = value
public static PdfCosName PDF
public:
static PdfCosName^ PDF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PdfDocEncoding Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PdfDocEncoding Field
The /PdfDocEncoding key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PdfDocEncoding As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PdfDocEncoding

PdfNames.PdfDocEncoding = value
public static PdfCosName PdfDocEncoding
public:
static PdfCosName^ PdfDocEncoding
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PDU Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PDU Field
The /PDU key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PDU As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PDU

PdfNames.PDU = value
public static PdfCosName PDU
public:
static PdfCosName^ PDU
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Perceptual Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Perceptual Field
The /Perceptual key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Perceptual As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Perceptual

PdfNames.Perceptual = value
public static PdfCosName Perceptual
public:
static PdfCosName^ Perceptual
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Perms Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Perms Field
The /Perms key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Perms As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Perms

PdfNames.Perms = value
public static PdfCosName Perms
public:
static PdfCosName^ Perms
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Pg Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Pg Field
The /Pg key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Pg As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Pg

PdfNames.Pg = value
public static PdfCosName Pg
public:
static PdfCosName^ Pg
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PI Field
The /PI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PI

PdfNames.PI = value
public static PdfCosName PI
public:
static PdfCosName^ PI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PickTrayByPDFSize Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : PickTrayByPDFSize Field
The /PickTrayByPDFSize key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PickTrayByPDFSize As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PickTrayByPDFSize

PdfNames.PickTrayByPDFSize = value
public static PdfCosName PickTrayByPDFSize
public:
static PdfCosName^ PickTrayByPDFSize
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PieceInfo Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PieceInfo Field
The /PieceInfo key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PieceInfo As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PieceInfo

PdfNames.PieceInfo = value
public static PdfCosName PieceInfo
public:
static PdfCosName^ PieceInfo
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PlayCount Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PlayCount Field
The /PlayCount key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PlayCount As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PlayCount

PdfNames.PlayCount = value
public static PdfCosName PlayCount
public:
static PdfCosName^ PlayCount
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PO Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PO Field
The /PO key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PO As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PO

PdfNames.PO = value
public static PdfCosName PO
public:
static PdfCosName^ PO
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Polygon Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Polygon Field
The /Polygon key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Polygon As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Polygon

PdfNames.Polygon = value
public static PdfCosName Polygon
public:
static PdfCosName^ Polygon
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PolyLine Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PolyLine Field
The /PolyLine key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PolyLine As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PolyLine

PdfNames.PolyLine = value
public static PdfCosName PolyLine
public:
static PdfCosName^ PolyLine
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Popup Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Popup Field
The /Popup key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Popup As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Popup

PdfNames.Popup = value
public static PdfCosName Popup
public:
static PdfCosName^ Popup
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Position Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Position Field
The /Position key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Position As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Position

PdfNames.Position = value
public static PdfCosName Position
public:
static PdfCosName^ Position
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Predictor Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Predictor Field
The /Predictor key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Predictor As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Predictor

PdfNames.Predictor = value
public static PdfCosName Predictor
public:
static PdfCosName^ Predictor
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Preferred Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Preferred Field
The /Preferred key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Preferred As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Preferred

PdfNames.Preferred = value
public static PdfCosName Preferred
public:
static PdfCosName^ Preferred
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Presentation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Presentation Field
The /Presentation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Presentation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Presentation

PdfNames.Presentation = value
public static PdfCosName Presentation
public:
static PdfCosName^ Presentation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PreserveRB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PreserveRB Field
The /PreserveRB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PreserveRB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PreserveRB

PdfNames.PreserveRB = value
public static PdfCosName PreserveRB
public:
static PdfCosName^ PreserveRB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Prev Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Prev Field
The /Prev key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Prev As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Prev

PdfNames.Prev = value
public static PdfCosName Prev
public:
static PdfCosName^ Prev
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PrevPage Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PrevPage Field
The /PrevPage key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PrevPage As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PrevPage

PdfNames.PrevPage = value
public static PdfCosName PrevPage
public:
static PdfCosName^ PrevPage
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Print Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Print Field
The /Print key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Print As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Print

PdfNames.Print = value
public static PdfCosName Print
public:
static PdfCosName^ Print
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PrintArea Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PrintArea Field
The /PrintArea key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PrintArea As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PrintArea

PdfNames.PrintArea = value
public static PdfCosName PrintArea
public:
static PdfCosName^ PrintArea
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PrintClip Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PrintClip Field
The /PrintClip key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PrintClip As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PrintClip

PdfNames.PrintClip = value
public static PdfCosName PrintClip
public:
static PdfCosName^ PrintClip
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PrintPageRange Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PrintPageRange Field
The /PrintPageRange key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PrintPageRange As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PrintPageRange

PdfNames.PrintPageRange = value
public static PdfCosName PrintPageRange
public:
static PdfCosName^ PrintPageRange
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PrintScaling Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PrintScaling Field
The /PrintScaling key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PrintScaling As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PrintScaling

PdfNames.PrintScaling = value
public static PdfCosName PrintScaling
public:
static PdfCosName^ PrintScaling
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PrintState Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PrintState Field
The /PrintState key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PrintState As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PrintState

PdfNames.PrintState = value
public static PdfCosName PrintState
public:
static PdfCosName^ PrintState
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Private Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Private Field
The /Private key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Private As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Private

PdfNames.Private = value
public static PdfCosName Private
public:
static PdfCosName^ Private
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ProcSet Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ProcSet Field
The /ProcSet key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ProcSet As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ProcSet

PdfNames.ProcSet = value
public static PdfCosName ProcSet
public:
static PdfCosName^ ProcSet
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Producer Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Producer Field
The /Producer key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Producer As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Producer

PdfNames.Producer = value
public static PdfCosName Producer
public:
static PdfCosName^ Producer
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PROJCS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PROJCS Field
The /PROJCS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PROJCS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PROJCS

PdfNames.PROJCS = value
public static PdfCosName PROJCS
public:
static PdfCosName^ PROJCS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Properties Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Properties Field
The /Properties key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Properties As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Properties

PdfNames.Properties = value
public static PdfCosName Properties
public:
static PdfCosName^ Properties
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PS Field
The /PS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PS

PdfNames.PS = value
public static PdfCosName PS
public:
static PdfCosName^ PS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PtData Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PtData Field
The /PtData key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PtData As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PtData

PdfNames.PtData = value
public static PdfCosName PtData
public:
static PdfCosName^ PtData
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PushPin Field (PdfNames)

Xfinium.Pdf.Core Namespace > PdfNames Class : PushPin Field
The /PushPin key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PushPin As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PushPin

PdfNames.PushPin = value
public static PdfCosName PushPin
public:
static PdfCosName^ PushPin
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


PV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : PV Field
The /PV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared PV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.PV

PdfNames.PV = value
public static PdfCosName PV
public:
static PdfCosName^ PV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Q Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Q Field
The /Q key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Q As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Q

PdfNames.Q = value
public static PdfCosName Q
public:
static PdfCosName^ Q
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


QuadPoints Field

Xfinium.Pdf.Core Namespace > PdfNames Class : QuadPoints Field
The /QuadPoints key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared QuadPoints As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.QuadPoints

PdfNames.QuadPoints = value
public static PdfCosName QuadPoints
public:
static PdfCosName^ QuadPoints
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Quote Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Quote Field
The /Quote key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Quote As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Quote

PdfNames.Quote = value
public static PdfCosName Quote
public:
static PdfCosName^ Quote
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


R Field

Xfinium.Pdf.Core Namespace > PdfNames Class : R Field
The /R key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared R As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.R

PdfNames.R = value
public static PdfCosName R
public:
static PdfCosName^ R
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


R2L Field

Xfinium.Pdf.Core Namespace > PdfNames Class : R2L Field
The /R2L key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared R2L As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.R2L

PdfNames.R2L = value
public static PdfCosName R2L
public:
static PdfCosName^ R2L
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Range Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Range Field
The /Range key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Range As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Range

PdfNames.Range = value
public static PdfCosName Range
public:
static PdfCosName^ Range
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RBGroups Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RBGroups Field
The /RBGroups key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RBGroups As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RBGroups

PdfNames.RBGroups = value
public static PdfCosName RBGroups
public:
static PdfCosName^ RBGroups
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RC Field
The /RC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RC

PdfNames.RC = value
public static PdfCosName RC
public:
static PdfCosName^ RC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RD Field
The /RD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RD

PdfNames.RD = value
public static PdfCosName RD
public:
static PdfCosName^ RD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Reason Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Reason Field
The /Reason key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Reason As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Reason

PdfNames.Reason = value
public static PdfCosName Reason
public:
static PdfCosName^ Reason
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Recipients Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Recipients Field
The /Recipients key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Recipients As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Recipients

PdfNames.Recipients = value
public static PdfCosName Recipients
public:
static PdfCosName^ Recipients
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Rect Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Rect Field
The /Rect key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Rect As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Rect

PdfNames.Rect = value
public static PdfCosName Rect
public:
static PdfCosName^ Rect
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Redact Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Redact Field
The /Redact key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Redact As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Redact

PdfNames.Redact = value
public static PdfCosName Redact
public:
static PdfCosName^ Redact
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Ref Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Ref Field
The /Ref key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Ref As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Ref

PdfNames.Ref = value
public static PdfCosName Ref
public:
static PdfCosName^ Ref
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Reference Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Reference Field
The /Reference key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Reference As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Reference

PdfNames.Reference = value
public static PdfCosName Reference
public:
static PdfCosName^ Reference
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Registry Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Registry Field
The /Registry key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Registry As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Registry

PdfNames.Registry = value
public static PdfCosName Registry
public:
static PdfCosName^ Registry
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RegistryName Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RegistryName Field
The /RegistryName key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RegistryName As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RegistryName

PdfNames.RegistryName = value
public static PdfCosName RegistryName
public:
static PdfCosName^ RegistryName
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RelativeColorimetric Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RelativeColorimetric Field
The /RelativeColorimetric key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RelativeColorimetric As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RelativeColorimetric

PdfNames.RelativeColorimetric = value
public static PdfCosName RelativeColorimetric
public:
static PdfCosName^ RelativeColorimetric
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Rendition Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Rendition Field
The /Rendition key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Rendition As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Rendition

PdfNames.Rendition = value
public static PdfCosName Rendition
public:
static PdfCosName^ Rendition
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ResetForm Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ResetForm Field
The /ResetForm key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ResetForm As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ResetForm

PdfNames.ResetForm = value
public static PdfCosName ResetForm
public:
static PdfCosName^ ResetForm
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Resources Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Resources Field
The /Resources key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Resources As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Resources

PdfNames.Resources = value
public static PdfCosName Resources
public:
static PdfCosName^ Resources
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RI Field
The /RI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RI

PdfNames.RI = value
public static PdfCosName RI
public:
static PdfCosName^ RI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMedia Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMedia Field
The /RichMedia key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMedia As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMedia

PdfNames.RichMedia = value
public static PdfCosName RichMedia
public:
static PdfCosName^ RichMedia
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaActivation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaActivation Field
The /RichMediaActivation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaActivation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaActivation

PdfNames.RichMediaActivation = value
public static PdfCosName RichMediaActivation
public:
static PdfCosName^ RichMediaActivation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaAnimation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaAnimation Field
The /RichMediaAnimation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaAnimation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaAnimation

PdfNames.RichMediaAnimation = value
public static PdfCosName RichMediaAnimation
public:
static PdfCosName^ RichMediaAnimation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaCommand Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaCommand Field
The /RichMediaCommand key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaCommand As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaCommand

PdfNames.RichMediaCommand = value
public static PdfCosName RichMediaCommand
public:
static PdfCosName^ RichMediaCommand
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaConfiguration Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaConfiguration Field
The /RichMediaConfiguration key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaConfiguration As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaConfiguration

PdfNames.RichMediaConfiguration = value
public static PdfCosName RichMediaConfiguration
public:
static PdfCosName^ RichMediaConfiguration
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaContent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaContent Field
The /RichMediaContent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaContent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaContent

PdfNames.RichMediaContent = value
public static PdfCosName RichMediaContent
public:
static PdfCosName^ RichMediaContent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaDeactivation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaDeactivation Field
The /RichMediaDeactivation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaDeactivation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaDeactivation

PdfNames.RichMediaDeactivation = value
public static PdfCosName RichMediaDeactivation
public:
static PdfCosName^ RichMediaDeactivation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaExecute Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaExecute Field
The /RichMediaExecute key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaExecute As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaExecute

PdfNames.RichMediaExecute = value
public static PdfCosName RichMediaExecute
public:
static PdfCosName^ RichMediaExecute
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaInstance Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaInstance Field
The /RichMediaInstance key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaInstance As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaInstance

PdfNames.RichMediaInstance = value
public static PdfCosName RichMediaInstance
public:
static PdfCosName^ RichMediaInstance
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaParams Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaParams Field
The /RichMediaParams key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaParams As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaParams

PdfNames.RichMediaParams = value
public static PdfCosName RichMediaParams
public:
static PdfCosName^ RichMediaParams
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaPosition Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaPosition Field
The /RichMediaPosition key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaPosition As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaPosition

PdfNames.RichMediaPosition = value
public static PdfCosName RichMediaPosition
public:
static PdfCosName^ RichMediaPosition
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaPresentation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaPresentation Field
The /RichMediaPresentation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaPresentation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaPresentation

PdfNames.RichMediaPresentation = value
public static PdfCosName RichMediaPresentation
public:
static PdfCosName^ RichMediaPresentation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaSettings Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaSettings Field
The /RichMediaSettings key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaSettings As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaSettings

PdfNames.RichMediaSettings = value
public static PdfCosName RichMediaSettings
public:
static PdfCosName^ RichMediaSettings
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RichMediaWindow Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RichMediaWindow Field
The /RichMediaWindow key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RichMediaWindow As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RichMediaWindow

PdfNames.RichMediaWindow = value
public static PdfCosName RichMediaWindow
public:
static PdfCosName^ RichMediaWindow
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RL Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RL Field
The /RL key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RL As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RL

PdfNames.RL = value
public static PdfCosName RL
public:
static PdfCosName^ RL
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RM Field
The /RM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RM

PdfNames.RM = value
public static PdfCosName RM
public:
static PdfCosName^ RM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RO Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RO Field
The /RO key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RO As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RO

PdfNames.RO = value
public static PdfCosName RO
public:
static PdfCosName^ RO
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RoleMap Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RoleMap Field
The /RoleMap key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RoleMap As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RoleMap

PdfNames.RoleMap = value
public static PdfCosName RoleMap
public:
static PdfCosName^ RoleMap
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Root Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Root Field
The /Root key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Root As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Root

PdfNames.Root = value
public static PdfCosName Root
public:
static PdfCosName^ Root
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Rotate Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Rotate Field
The /Rotate key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Rotate As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Rotate

PdfNames.Rotate = value
public static PdfCosName Rotate
public:
static PdfCosName^ Rotate
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Rows Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Rows Field
The /Rows key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Rows As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Rows

PdfNames.Rows = value
public static PdfCosName Rows
public:
static PdfCosName^ Rows
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RT Field
The /RT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RT

PdfNames.RT = value
public static PdfCosName RT
public:
static PdfCosName^ RT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RunLengthDecode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RunLengthDecode Field
The /RunLengthDecode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RunLengthDecode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RunLengthDecode

PdfNames.RunLengthDecode = value
public static PdfCosName RunLengthDecode
public:
static PdfCosName^ RunLengthDecode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


RV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : RV Field
The /RV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared RV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.RV

PdfNames.RV = value
public static PdfCosName RV
public:
static PdfCosName^ RV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


S Field

Xfinium.Pdf.Core Namespace > PdfNames Class : S Field
The /S key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared S As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.S

PdfNames.S = value
public static PdfCosName S
public:
static PdfCosName^ S
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SA Field
The /SA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SA

PdfNames.SA = value
public static PdfCosName SA
public:
static PdfCosName^ SA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Saturation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Saturation Field
The /Saturation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Saturation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Saturation

PdfNames.Saturation = value
public static PdfCosName Saturation
public:
static PdfCosName^ Saturation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SC Field
The /SC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SC

PdfNames.SC = value
public static PdfCosName SC
public:
static PdfCosName^ SC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Schema Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Schema Field
The /Schema key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Schema As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Schema

PdfNames.Schema = value
public static PdfCosName Schema
public:
static PdfCosName^ Schema
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Screen Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Screen Field
The /Screen key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Screen As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Screen

PdfNames.Screen = value
public static PdfCosName Screen
public:
static PdfCosName^ Screen
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Scripts Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Scripts Field
The /Scripts key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Scripts As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Scripts

PdfNames.Scripts = value
public static PdfCosName Scripts
public:
static PdfCosName^ Scripts
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Sect Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Sect Field
The /Sect key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sect As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Sect

PdfNames.Sect = value
public static PdfCosName Sect
public:
static PdfCosName^ Sect
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Separation Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Separation Field
The /Separation key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Separation As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Separation

PdfNames.Separation = value
public static PdfCosName Separation
public:
static PdfCosName^ Separation
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SetOCGState Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SetOCGState Field
The /SetOCGState key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SetOCGState As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SetOCGState

PdfNames.SetOCGState = value
public static PdfCosName SetOCGState
public:
static PdfCosName^ SetOCGState
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Settings Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Settings Field
The /Settings key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Settings As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Settings

PdfNames.Settings = value
public static PdfCosName Settings
public:
static PdfCosName^ Settings
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Shading Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Shading Field
The /Shading key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Shading As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Shading

PdfNames.Shading = value
public static PdfCosName Shading
public:
static PdfCosName^ Shading
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ShadingType Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ShadingType Field
The /ShadingType key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ShadingType As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ShadingType

PdfNames.ShadingType = value
public static PdfCosName ShadingType
public:
static PdfCosName^ ShadingType
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ShiftJIS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ShiftJIS Field
The /Shift-JIS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ShiftJIS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ShiftJIS

PdfNames.ShiftJIS = value
public static PdfCosName ShiftJIS
public:
static PdfCosName^ ShiftJIS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Sig Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Sig Field
The /Sig key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sig As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Sig

PdfNames.Sig = value
public static PdfCosName Sig
public:
static PdfCosName^ Sig
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SigFieldLock Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SigFieldLock Field
The /SigFieldLock key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SigFieldLock As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SigFieldLock

PdfNames.SigFieldLock = value
public static PdfCosName SigFieldLock
public:
static PdfCosName^ SigFieldLock
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SigFlags Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SigFlags Field
The /SigFlags key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SigFlags As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SigFlags

PdfNames.SigFlags = value
public static PdfCosName SigFlags
public:
static PdfCosName^ SigFlags
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SigRef Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SigRef Field
The /SigRef key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SigRef As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SigRef

PdfNames.SigRef = value
public static PdfCosName SigRef
public:
static PdfCosName^ SigRef
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Simplex Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Simplex Field
The /Simplex key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Simplex As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Simplex

PdfNames.Simplex = value
public static PdfCosName Simplex
public:
static PdfCosName^ Simplex
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SinglePage Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SinglePage Field
The /SinglePage key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SinglePage As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SinglePage

PdfNames.SinglePage = value
public static PdfCosName SinglePage
public:
static PdfCosName^ SinglePage
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Size Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Size Field
The /Size key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Size As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Size

PdfNames.Size = value
public static PdfCosName Size
public:
static PdfCosName^ Size
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SMask Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SMask Field
The /SMask key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SMask As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SMask

PdfNames.SMask = value
public static PdfCosName SMask
public:
static PdfCosName^ SMask
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Sort Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Sort Field
The /Sort key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sort As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Sort

PdfNames.Sort = value
public static PdfCosName Sort
public:
static PdfCosName^ Sort
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Sound Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Sound Field
The /Sound key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sound As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Sound

PdfNames.Sound = value
public static PdfCosName Sound
public:
static PdfCosName^ Sound
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Span Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Span Field
The /Span key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Span As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Span

PdfNames.Span = value
public static PdfCosName Span
public:
static PdfCosName^ Span
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Speed Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Speed Field
The /Speed key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Speed As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Speed

PdfNames.Speed = value
public static PdfCosName Speed
public:
static PdfCosName^ Speed
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Split Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Split Field
The /Split key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Split As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Split

PdfNames.Split = value
public static PdfCosName Split
public:
static PdfCosName^ Split
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SQFT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SQFT Field
The /SQFT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SQFT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SQFT

PdfNames.SQFT = value
public static PdfCosName SQFT
public:
static PdfCosName^ SQFT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SQKM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SQKM Field
The /SQKM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SQKM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SQKM

PdfNames.SQKM = value
public static PdfCosName SQKM
public:
static PdfCosName^ SQKM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SQM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SQM Field
The /SQM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SQM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SQM

PdfNames.SQM = value
public static PdfCosName SQM
public:
static PdfCosName^ SQM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SQMI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SQMI Field
The /SQMI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SQMI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SQMI

PdfNames.SQMI = value
public static PdfCosName SQMI
public:
static PdfCosName^ SQMI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Square Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Square Field
The /Square key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Square As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Square

PdfNames.Square = value
public static PdfCosName Square
public:
static PdfCosName^ Square
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Squiggly Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Squiggly Field
The /Squiggly key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Squiggly As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Squiggly

PdfNames.Squiggly = value
public static PdfCosName Squiggly
public:
static PdfCosName^ Squiggly
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SS Field
The /SS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SS

PdfNames.SS = value
public static PdfCosName SS
public:
static PdfCosName^ SS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


St Field

Xfinium.Pdf.Core Namespace > PdfNames Class : St Field
The /St key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared St As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.St

PdfNames.St = value
public static PdfCosName St
public:
static PdfCosName^ St
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Stamp Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Stamp Field
The /Stamp key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Stamp As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Stamp

PdfNames.Stamp = value
public static PdfCosName Stamp
public:
static PdfCosName^ Stamp
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Standard Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Standard Field
The /Standard key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Standard As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Standard

PdfNames.Standard = value
public static PdfCosName Standard
public:
static PdfCosName^ Standard
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


State Field

Xfinium.Pdf.Core Namespace > PdfNames Class : State Field
The /State key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared State As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.State

PdfNames.State = value
public static PdfCosName State
public:
static PdfCosName^ State
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StateModel Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StateModel Field
The /StateModel key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StateModel As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StateModel

PdfNames.StateModel = value
public static PdfCosName StateModel
public:
static PdfCosName^ StateModel
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StdCF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StdCF Field
The /StdCF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StdCF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StdCF

PdfNames.StdCF = value
public static PdfCosName StdCF
public:
static PdfCosName^ StdCF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StemH Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StemH Field
The /StemH key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StemH As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StemH

PdfNames.StemH = value
public static PdfCosName StemH
public:
static PdfCosName^ StemH
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StemV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StemV Field
The /StemV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StemV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StemV

PdfNames.StemV = value
public static PdfCosName StemV
public:
static PdfCosName^ StemV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StmF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StmF Field
The /StmF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StmF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StmF

PdfNames.StmF = value
public static PdfCosName StmF
public:
static PdfCosName^ StmF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StrF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StrF Field
The /StrF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StrF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StrF

PdfNames.StrF = value
public static PdfCosName StrF
public:
static PdfCosName^ StrF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StrikeOut Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StrikeOut Field
The /StrikeOut key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StrikeOut As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StrikeOut

PdfNames.StrikeOut = value
public static PdfCosName StrikeOut
public:
static PdfCosName^ StrikeOut
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StructParent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StructParent Field
The /StructParent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StructParent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StructParent

PdfNames.StructParent = value
public static PdfCosName StructParent
public:
static PdfCosName^ StructParent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StructParents Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StructParents Field
The /StructParents key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StructParents As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StructParents

PdfNames.StructParents = value
public static PdfCosName StructParents
public:
static PdfCosName^ StructParents
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


StructTreeRoot Field

Xfinium.Pdf.Core Namespace > PdfNames Class : StructTreeRoot Field
The /StructTreeRoot key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared StructTreeRoot As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.StructTreeRoot

PdfNames.StructTreeRoot = value
public static PdfCosName StructTreeRoot
public:
static PdfCosName^ StructTreeRoot
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Style Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Style Field
The /Style key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Style As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Style

PdfNames.Style = value
public static PdfCosName Style
public:
static PdfCosName^ Style
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SubFilter Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SubFilter Field
The /SubFilter key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SubFilter As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SubFilter

PdfNames.SubFilter = value
public static PdfCosName SubFilter
public:
static PdfCosName^ SubFilter
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Subj Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Subj Field
The /Subj key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Subj As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Subj

PdfNames.Subj = value
public static PdfCosName Subj
public:
static PdfCosName^ Subj
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Subject Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Subject Field
The /Subject key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Subject As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Subject

PdfNames.Subject = value
public static PdfCosName Subject
public:
static PdfCosName^ Subject
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SubmitForm Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SubmitForm Field
The /SubmitForm key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SubmitForm As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SubmitForm

PdfNames.SubmitForm = value
public static PdfCosName SubmitForm
public:
static PdfCosName^ SubmitForm
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Subtype Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Subtype Field
The /Subtype key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Subtype As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Subtype

PdfNames.Subtype = value
public static PdfCosName Subtype
public:
static PdfCosName^ Subtype
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Subtype2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Subtype2 Field
The /Subtype2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Subtype2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Subtype2

PdfNames.Subtype2 = value
public static PdfCosName Subtype2
public:
static PdfCosName^ Subtype2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Supplement Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Supplement Field
The /Supplement key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Supplement As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Supplement

PdfNames.Supplement = value
public static PdfCosName Supplement
public:
static PdfCosName^ Supplement
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SV Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SV Field
The /SV key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SV As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SV

PdfNames.SV = value
public static PdfCosName SV
public:
static PdfCosName^ SV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


SW Field

Xfinium.Pdf.Core Namespace > PdfNames Class : SW Field
The /SW key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared SW As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.SW

PdfNames.SW = value
public static PdfCosName SW
public:
static PdfCosName^ SW
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Symbol Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Symbol Field
The /Symbol key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Symbol As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Symbol

PdfNames.Symbol = value
public static PdfCosName Symbol
public:
static PdfCosName^ Symbol
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


T Field

Xfinium.Pdf.Core Namespace > PdfNames Class : T Field
The /T key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared T As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.T

PdfNames.T = value
public static PdfCosName T
public:
static PdfCosName^ T
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TA Field
The /TA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TA

PdfNames.TA = value
public static PdfCosName TA
public:
static PdfCosName^ TA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Table Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Table Field
The /Table key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Table As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Table

PdfNames.Table = value
public static PdfCosName Table
public:
static PdfCosName^ Table
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Tabs Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Tabs Field
The /Tabs key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Tabs As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Tabs

PdfNames.Tabs = value
public static PdfCosName Tabs
public:
static PdfCosName^ Tabs
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TB Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TB Field
The /TB key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TB As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TB

PdfNames.TB = value
public static PdfCosName TB
public:
static PdfCosName^ TB
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TBody Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TBody Field
The /TBody key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TBody As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TBody

PdfNames.TBody = value
public static PdfCosName TBody
public:
static PdfCosName^ TBody
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TD Field
The /TD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TD

PdfNames.TD = value
public static PdfCosName TD
public:
static PdfCosName^ TD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Text Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Text Field
The /Text key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Text As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Text

PdfNames.Text = value
public static PdfCosName Text
public:
static PdfCosName^ Text
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TF Field
The /TF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TF

PdfNames.TF = value
public static PdfCosName TF
public:
static PdfCosName^ TF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TFoot Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TFoot Field
The /TFoot key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TFoot As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TFoot

PdfNames.TFoot = value
public static PdfCosName TFoot
public:
static PdfCosName^ TFoot
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TH Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TH Field
The /TH key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TH As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TH

PdfNames.TH = value
public static PdfCosName TH
public:
static PdfCosName^ TH
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


THead Field

Xfinium.Pdf.Core Namespace > PdfNames Class : THead Field
The /THead key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared THead As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.THead

PdfNames.THead = value
public static PdfCosName THead
public:
static PdfCosName^ THead
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Threads Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Threads Field
The /Threads key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Threads As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Threads

PdfNames.Threads = value
public static PdfCosName Threads
public:
static PdfCosName^ Threads
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Thumb Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Thumb Field
The /Thumb key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Thumb As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Thumb

PdfNames.Thumb = value
public static PdfCosName Thumb
public:
static PdfCosName^ Thumb
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TI Field
The /TI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TI

PdfNames.TI = value
public static PdfCosName TI
public:
static PdfCosName^ TI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TilingType Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TilingType Field
The /TilingType key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TilingType As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TilingType

PdfNames.TilingType = value
public static PdfCosName TilingType
public:
static PdfCosName^ TilingType
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Time Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Time Field
The /Time key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Time As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Time

PdfNames.Time = value
public static PdfCosName Time
public:
static PdfCosName^ Time
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TimesBold Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TimesBold Field
The /Times-Bold key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TimesBold As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TimesBold

PdfNames.TimesBold = value
public static PdfCosName TimesBold
public:
static PdfCosName^ TimesBold
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TimesBoldItalic Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TimesBoldItalic Field
The /Times-BoldItalic key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TimesBoldItalic As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TimesBoldItalic

PdfNames.TimesBoldItalic = value
public static PdfCosName TimesBoldItalic
public:
static PdfCosName^ TimesBoldItalic
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TimesItalic Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TimesItalic Field
The /Times-Italic key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TimesItalic As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TimesItalic

PdfNames.TimesItalic = value
public static PdfCosName TimesItalic
public:
static PdfCosName^ TimesItalic
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TimesRoman Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TimesRoman Field
The /Times-Roman key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TimesRoman As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TimesRoman

PdfNames.TimesRoman = value
public static PdfCosName TimesRoman
public:
static PdfCosName^ TimesRoman
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Title Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Title Field
The /Title key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Title As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Title

PdfNames.Title = value
public static PdfCosName Title
public:
static PdfCosName^ Title
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TK Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TK Field
The /TK key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TK As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TK

PdfNames.TK = value
public static PdfCosName TK
public:
static PdfCosName^ TK
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TM Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TM Field
The /TM key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TM As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TM

PdfNames.TM = value
public static PdfCosName TM
public:
static PdfCosName^ TM
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TOC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TOC Field
The /TOC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TOC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TOC

PdfNames.TOC = value
public static PdfCosName TOC
public:
static PdfCosName^ TOC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TOCI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TOCI Field
The /TOCI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TOCI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TOCI

PdfNames.TOCI = value
public static PdfCosName TOCI
public:
static PdfCosName^ TOCI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Toggle Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Toggle Field
The /Toggle key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Toggle As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Toggle

PdfNames.Toggle = value
public static PdfCosName Toggle
public:
static PdfCosName^ Toggle
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Toolbar Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Toolbar Field
The /Toolbar key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Toolbar As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Toolbar

PdfNames.Toolbar = value
public static PdfCosName Toolbar
public:
static PdfCosName^ Toolbar
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ToUnicode Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ToUnicode Field
The /ToUnicode key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ToUnicode As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ToUnicode

PdfNames.ToUnicode = value
public static PdfCosName ToUnicode
public:
static PdfCosName^ ToUnicode
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TP Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TP Field
The /TP key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TP As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TP

PdfNames.TP = value
public static PdfCosName TP
public:
static PdfCosName^ TP
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TR Field
The /TR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TR

PdfNames.TR = value
public static PdfCosName TR
public:
static PdfCosName^ TR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TR2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TR2 Field
The /TR2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TR2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TR2

PdfNames.TR2 = value
public static PdfCosName TR2
public:
static PdfCosName^ TR2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Trans Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Trans Field
The /Trans key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Trans As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Trans

PdfNames.Trans = value
public static PdfCosName Trans
public:
static PdfCosName^ Trans
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TransformMethod Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TransformMethod Field
The /TransformMethod key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TransformMethod As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TransformMethod

PdfNames.TransformMethod = value
public static PdfCosName TransformMethod
public:
static PdfCosName^ TransformMethod
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TransformParams Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TransformParams Field
The /TransformParams key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TransformParams As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TransformParams

PdfNames.TransformParams = value
public static PdfCosName TransformParams
public:
static PdfCosName^ TransformParams
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Transparency Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Transparency Field
The /Transparency key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Transparency As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Transparency

PdfNames.Transparency = value
public static PdfCosName Transparency
public:
static PdfCosName^ Transparency
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Transparent Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Transparent Field
The /Transparent key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Transparent As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Transparent

PdfNames.Transparent = value
public static PdfCosName Transparent
public:
static PdfCosName^ Transparent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Trapped Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Trapped Field
The /Trapped key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Trapped As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Trapped

PdfNames.Trapped = value
public static PdfCosName Trapped
public:
static PdfCosName^ Trapped
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TrimBox Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TrimBox Field
The /TrimBox key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TrimBox As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TrimBox

PdfNames.TrimBox = value
public static PdfCosName TrimBox
public:
static PdfCosName^ TrimBox
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TrueType Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TrueType Field
The /TrueType key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TrueType As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TrueType

PdfNames.TrueType = value
public static PdfCosName TrueType
public:
static PdfCosName^ TrueType
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TU Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TU Field
The /TU key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TU As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TU

PdfNames.TU = value
public static PdfCosName TU
public:
static PdfCosName^ TU
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TwoColumnLeft Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TwoColumnLeft Field
The /TwoColumnLeft key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TwoColumnLeft As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TwoColumnLeft

PdfNames.TwoColumnLeft = value
public static PdfCosName TwoColumnLeft
public:
static PdfCosName^ TwoColumnLeft
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TwoColumnRight Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TwoColumnRight Field
The /TwoColumnRight key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TwoColumnRight As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TwoColumnRight

PdfNames.TwoColumnRight = value
public static PdfCosName TwoColumnRight
public:
static PdfCosName^ TwoColumnRight
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TwoPageLeft Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TwoPageLeft Field
The /TwoPageLeft key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TwoPageLeft As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TwoPageLeft

PdfNames.TwoPageLeft = value
public static PdfCosName TwoPageLeft
public:
static PdfCosName^ TwoPageLeft
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


TwoPageRight Field

Xfinium.Pdf.Core Namespace > PdfNames Class : TwoPageRight Field
The /TwoPageRight key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared TwoPageRight As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.TwoPageRight

PdfNames.TwoPageRight = value
public static PdfCosName TwoPageRight
public:
static PdfCosName^ TwoPageRight
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Tx Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Tx Field
The /Tx key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Tx As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Tx

PdfNames.Tx = value
public static PdfCosName Tx
public:
static PdfCosName^ Tx
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Type Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Type Field
The /Type key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Type As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Type

PdfNames.Type = value
public static PdfCosName Type
public:
static PdfCosName^ Type
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Type0 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Type0 Field
The /Type0 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Type0 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Type0

PdfNames.Type0 = value
public static PdfCosName Type0
public:
static PdfCosName^ Type0
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Type1 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Type1 Field
The /Type1 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Type1 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Type1

PdfNames.Type1 = value
public static PdfCosName Type1
public:
static PdfCosName^ Type1
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Type3 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Type3 Field
The /Type3 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Type3 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Type3

PdfNames.Type3 = value
public static PdfCosName Type3
public:
static PdfCosName^ Type3
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


U Field

Xfinium.Pdf.Core Namespace > PdfNames Class : U Field
The /U key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared U As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.U

PdfNames.U = value
public static PdfCosName U
public:
static PdfCosName^ U
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


U3D Field

Xfinium.Pdf.Core Namespace > PdfNames Class : U3D Field
The /U3D key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared U3D As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.U3D

PdfNames.U3D = value
public static PdfCosName U3D
public:
static PdfCosName^ U3D
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


U3DPath Field

Xfinium.Pdf.Core Namespace > PdfNames Class : U3DPath Field
The /U3DPath key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared U3DPath As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.U3DPath

PdfNames.U3DPath = value
public static PdfCosName U3DPath
public:
static PdfCosName^ U3DPath
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UF Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UF Field
The /UF key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UF As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UF

PdfNames.UF = value
public static PdfCosName UF
public:
static PdfCosName^ UF
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UHC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UHC Field
The /UHC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UHC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UHC

PdfNames.UHC = value
public static PdfCosName UHC
public:
static PdfCosName^ UHC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Underline Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Underline Field
The /Underline key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Underline As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Underline

PdfNames.Underline = value
public static PdfCosName Underline
public:
static PdfCosName^ Underline
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UR Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UR Field
The /UR key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UR As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UR

PdfNames.UR = value
public static PdfCosName UR
public:
static PdfCosName^ UR
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UR3 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UR3 Field
The /UR3 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UR3 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UR3

PdfNames.UR3 = value
public static PdfCosName UR3
public:
static PdfCosName^ UR3
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


URI Field

Xfinium.Pdf.Core Namespace > PdfNames Class : URI Field
The /URI key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared URI As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.URI

PdfNames.URI = value
public static PdfCosName URI
public:
static PdfCosName^ URI
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


URL Field

Xfinium.Pdf.Core Namespace > PdfNames Class : URL Field
The /URL key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared URL As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.URL

PdfNames.URL = value
public static PdfCosName URL
public:
static PdfCosName^ URL
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Usage Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Usage Field
The /Usage key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Usage As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Usage

PdfNames.Usage = value
public static PdfCosName Usage
public:
static PdfCosName^ Usage
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UseAttachments Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UseAttachments Field
The /UseAttachments key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UseAttachments As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UseAttachments

PdfNames.UseAttachments = value
public static PdfCosName UseAttachments
public:
static PdfCosName^ UseAttachments
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UseNone Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UseNone Field
The /UseNone key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UseNone As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UseNone

PdfNames.UseNone = value
public static PdfCosName UseNone
public:
static PdfCosName^ UseNone
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UseOC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UseOC Field
The /UseOC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UseOC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UseOC

PdfNames.UseOC = value
public static PdfCosName UseOC
public:
static PdfCosName^ UseOC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UseOutlines Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UseOutlines Field
The /UseOutlines key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UseOutlines As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UseOutlines

PdfNames.UseOutlines = value
public static PdfCosName UseOutlines
public:
static PdfCosName^ UseOutlines
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


User Field

Xfinium.Pdf.Core Namespace > PdfNames Class : User Field
The /User key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared User As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.User

PdfNames.User = value
public static PdfCosName User
public:
static PdfCosName^ User
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UserProperties Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UserProperties Field
The /UserProperties key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UserProperties As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UserProperties

PdfNames.UserProperties = value
public static PdfCosName UserProperties
public:
static PdfCosName^ UserProperties
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UserUnit Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UserUnit Field
The /UserUnit key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UserUnit As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UserUnit

PdfNames.UserUnit = value
public static PdfCosName UserUnit
public:
static PdfCosName^ UserUnit
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


UseThumbs Field

Xfinium.Pdf.Core Namespace > PdfNames Class : UseThumbs Field
The /UseThumbs key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared UseThumbs As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.UseThumbs

PdfNames.UseThumbs = value
public static PdfCosName UseThumbs
public:
static PdfCosName^ UseThumbs
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


USFT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : USFT Field
The /USFT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared USFT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.USFT

PdfNames.USFT = value
public static PdfCosName USFT
public:
static PdfCosName^ USFT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


V Field

Xfinium.Pdf.Core Namespace > PdfNames Class : V Field
The /V key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared V As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.V

PdfNames.V = value
public static PdfCosName V
public:
static PdfCosName^ V
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


V2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : V2 Field
The /V2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared V2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.V2

PdfNames.V2 = value
public static PdfCosName V2
public:
static PdfCosName^ V2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


VA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : VA Field
The /VA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared VA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.VA

PdfNames.VA = value
public static PdfCosName VA
public:
static PdfCosName^ VA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


VAlign Field

Xfinium.Pdf.Core Namespace > PdfNames Class : VAlign Field
The /VAlign key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared VAlign As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.VAlign

PdfNames.VAlign = value
public static PdfCosName VAlign
public:
static PdfCosName^ VAlign
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Version Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Version Field
The /Version key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Version As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Version

PdfNames.Version = value
public static PdfCosName Version
public:
static PdfCosName^ Version
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Vertices Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Vertices Field
The /Vertices key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Vertices As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Vertices

PdfNames.Vertices = value
public static PdfCosName Vertices
public:
static PdfCosName^ Vertices
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


VerticesPerRow Field

Xfinium.Pdf.Core Namespace > PdfNames Class : VerticesPerRow Field
The /VerticesPerRow key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared VerticesPerRow As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.VerticesPerRow

PdfNames.VerticesPerRow = value
public static PdfCosName VerticesPerRow
public:
static PdfCosName^ VerticesPerRow
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Video Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Video Field
The /Video key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Video As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Video

PdfNames.Video = value
public static PdfCosName Video
public:
static PdfCosName^ Video
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


View Field

Xfinium.Pdf.Core Namespace > PdfNames Class : View Field
The /View key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared View As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.View

PdfNames.View = value
public static PdfCosName View
public:
static PdfCosName^ View
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ViewArea Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ViewArea Field
The /ViewArea key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ViewArea As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ViewArea

PdfNames.ViewArea = value
public static PdfCosName ViewArea
public:
static PdfCosName^ ViewArea
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ViewClip Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ViewClip Field
The /ViewClip key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ViewClip As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ViewClip

PdfNames.ViewClip = value
public static PdfCosName ViewClip
public:
static PdfCosName^ ViewClip
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ViewerPreferences Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ViewerPreferences Field
The /ViewerPreferences key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ViewerPreferences As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ViewerPreferences

PdfNames.ViewerPreferences = value
public static PdfCosName ViewerPreferences
public:
static PdfCosName^ ViewerPreferences
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Viewport Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Viewport Field
The /Viewport key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Viewport As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Viewport

PdfNames.Viewport = value
public static PdfCosName Viewport
public:
static PdfCosName^ Viewport
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Views Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Views Field
The /Views key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Views As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Views

PdfNames.Views = value
public static PdfCosName Views
public:
static PdfCosName^ Views
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ViewState Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ViewState Field
The /ViewState key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ViewState As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ViewState

PdfNames.ViewState = value
public static PdfCosName ViewState
public:
static PdfCosName^ ViewState
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


VisiblePages Field

Xfinium.Pdf.Core Namespace > PdfNames Class : VisiblePages Field
The /VisiblePages key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared VisiblePages As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.VisiblePages

PdfNames.VisiblePages = value
public static PdfCosName VisiblePages
public:
static PdfCosName^ VisiblePages
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


VOffset Field

Xfinium.Pdf.Core Namespace > PdfNames Class : VOffset Field
The /VOffset key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared VOffset As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.VOffset

PdfNames.VOffset = value
public static PdfCosName VOffset
public:
static PdfCosName^ VOffset
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


VP Field

Xfinium.Pdf.Core Namespace > PdfNames Class : VP Field
The /VP key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared VP As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.VP

PdfNames.VP = value
public static PdfCosName VP
public:
static PdfCosName^ VP
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


W Field

Xfinium.Pdf.Core Namespace > PdfNames Class : W Field
The /W key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared W As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.W

PdfNames.W = value
public static PdfCosName W
public:
static PdfCosName^ W
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


W2 Field

Xfinium.Pdf.Core Namespace > PdfNames Class : W2 Field
The /W2 key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared W2 As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.W2

PdfNames.W2 = value
public static PdfCosName W2
public:
static PdfCosName^ W2
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Warichu Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Warichu Field
The /Warichu key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Warichu As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Warichu

PdfNames.Warichu = value
public static PdfCosName Warichu
public:
static PdfCosName^ Warichu
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


WC Field

Xfinium.Pdf.Core Namespace > PdfNames Class : WC Field
The /WC key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared WC As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.WC

PdfNames.WC = value
public static PdfCosName WC
public:
static PdfCosName^ WC
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


WhitePoint Field

Xfinium.Pdf.Core Namespace > PdfNames Class : WhitePoint Field
The /WhitePoint key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared WhitePoint As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.WhitePoint

PdfNames.WhitePoint = value
public static PdfCosName WhitePoint
public:
static PdfCosName^ WhitePoint
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Widget Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Widget Field
The /Widget key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Widget As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Widget

PdfNames.Widget = value
public static PdfCosName Widget
public:
static PdfCosName^ Widget
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Width Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Width Field
The /Width key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Width As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Width

PdfNames.Width = value
public static PdfCosName Width
public:
static PdfCosName^ Width
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Widths Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Widths Field
The /Widths key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Widths As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Widths

PdfNames.Widths = value
public static PdfCosName Widths
public:
static PdfCosName^ Widths
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Win Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Win Field
The /Win key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Win As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Win

PdfNames.Win = value
public static PdfCosName Win
public:
static PdfCosName^ Win
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


WinAnsiEncoding Field

Xfinium.Pdf.Core Namespace > PdfNames Class : WinAnsiEncoding Field
The /WinAnsiEncoding key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared WinAnsiEncoding As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.WinAnsiEncoding

PdfNames.WinAnsiEncoding = value
public static PdfCosName WinAnsiEncoding
public:
static PdfCosName^ WinAnsiEncoding
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Window Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Window Field
The /Window key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Window As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Window

PdfNames.Window = value
public static PdfCosName Window
public:
static PdfCosName^ Window
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Windowed Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Windowed Field
The /Windowed key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Windowed As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Windowed

PdfNames.Windowed = value
public static PdfCosName Windowed
public:
static PdfCosName^ Windowed
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Wipe Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Wipe Field
The /Wipe key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Wipe As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Wipe

PdfNames.Wipe = value
public static PdfCosName Wipe
public:
static PdfCosName^ Wipe
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


WKT Field

Xfinium.Pdf.Core Namespace > PdfNames Class : WKT Field
The /WKT key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared WKT As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.WKT

PdfNames.WKT = value
public static PdfCosName WKT
public:
static PdfCosName^ WKT
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


WP Field

Xfinium.Pdf.Core Namespace > PdfNames Class : WP Field
The /WP key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared WP As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.WP

PdfNames.WP = value
public static PdfCosName WP
public:
static PdfCosName^ WP
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


WS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : WS Field
The /WS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared WS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.WS

PdfNames.WS = value
public static PdfCosName WS
public:
static PdfCosName^ WS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


X Field

Xfinium.Pdf.Core Namespace > PdfNames Class : X Field
The /X key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared X As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.X

PdfNames.X = value
public static PdfCosName X
public:
static PdfCosName^ X
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XA Field
The /XA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XA

PdfNames.XA = value
public static PdfCosName XA
public:
static PdfCosName^ XA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XD Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XD Field
The /XD key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XD As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XD

PdfNames.XD = value
public static PdfCosName XD
public:
static PdfCosName^ XD
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XFA Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XFA Field
The /XFA key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XFA As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XFA

PdfNames.XFA = value
public static PdfCosName XFA
public:
static PdfCosName^ XFA
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XHeight Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XHeight Field
The /XHeight key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XHeight As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XHeight

PdfNames.XHeight = value
public static PdfCosName XHeight
public:
static PdfCosName^ XHeight
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XML Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XML Field
The /XML key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XML As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XML

PdfNames.XML = value
public static PdfCosName XML
public:
static PdfCosName^ XML
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XN Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XN Field
The /XN key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XN As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XN

PdfNames.XN = value
public static PdfCosName XN
public:
static PdfCosName^ XN
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XObject Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XObject Field
The /XObject key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XObject As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XObject

PdfNames.XObject = value
public static PdfCosName XObject
public:
static PdfCosName^ XObject
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XPTS Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XPTS Field
The /XPTS key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XPTS As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XPTS

PdfNames.XPTS = value
public static PdfCosName XPTS
public:
static PdfCosName^ XPTS
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XRef Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XRef Field
The /XRef key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XRef As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XRef

PdfNames.XRef = value
public static PdfCosName XRef
public:
static PdfCosName^ XRef
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XRefStm Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XRefStm Field
The /XRefStm key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XRefStm As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XRefStm

PdfNames.XRefStm = value
public static PdfCosName XRefStm
public:
static PdfCosName^ XRefStm
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XStep Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XStep Field
The /XStep key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XStep As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XStep

PdfNames.XStep = value
public static PdfCosName XStep
public:
static PdfCosName^ XStep
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


XYZ Field

Xfinium.Pdf.Core Namespace > PdfNames Class : XYZ Field
The /XYZ key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared XYZ As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.XYZ

PdfNames.XYZ = value
public static PdfCosName XYZ
public:
static PdfCosName^ XYZ
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Y Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Y Field
The /Y key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Y As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Y

PdfNames.Y = value
public static PdfCosName Y
public:
static PdfCosName^ Y
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Yes Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Yes Field
The /Yes key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Yes As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Yes

PdfNames.Yes = value
public static PdfCosName Yes
public:
static PdfCosName^ Yes
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


YStep Field

Xfinium.Pdf.Core Namespace > PdfNames Class : YStep Field
The /YStep key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared YStep As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.YStep

PdfNames.YStep = value
public static PdfCosName YStep
public:
static PdfCosName^ YStep
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ZaDb Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ZaDb Field
The /ZaDb key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ZaDb As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ZaDb

PdfNames.ZaDb = value
public static PdfCosName ZaDb
public:
static PdfCosName^ ZaDb
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


ZapfDingbats Field

Xfinium.Pdf.Core Namespace > PdfNames Class : ZapfDingbats Field
The /ZapfDingbats key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ZapfDingbats As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.ZapfDingbats

PdfNames.ZapfDingbats = value
public static PdfCosName ZapfDingbats
public:
static PdfCosName^ ZapfDingbats
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


Zoom Field

Xfinium.Pdf.Core Namespace > PdfNames Class : Zoom Field
The /Zoom key
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Zoom As PdfCosName
'Usage

Dim value As PdfCosName

value = PdfNames.Zoom

PdfNames.Zoom = value
public static PdfCosName Zoom
public:
static PdfCosName^ Zoom
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNames Class
PdfNames Members


%%PageItemTitle%%

PdfPageInfo Class
Members

Xfinium.Pdf.Core Namespace : PdfPageInfo Class
Defines basic information about a PDF page.
Object Model
PdfPageInfo ClassPdfStandardRectangle ClassPdfStandardRectangle ClassPdfStandardRectangle ClassPdfStandardRectangle ClassPdfStandardRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageInfo
'Usage

Dim instance As PdfPageInfo
public class PdfPageInfo
public ref class PdfPageInfo
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.PdfPageInfo

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Members
Xfinium.Pdf.Core Namespace


%%PageItemTitle%% $$Members$$

PdfPageInfo Class Members
Properties

Xfinium.Pdf.Core Namespace : PdfPageInfo Class

The following tables list the members exposed by PdfPageInfo.

Public Properties
 | Name | Description
Public Property | ArtBox | Gets the page art box.
Public Property | BleedBox | Gets the page bleed box.
Public Property | CropBox | Gets the page crop box.
Public Property | Height | Gets the visual page height.
Public Property | MediaBox | Gets the page media box.
Public Property | Rotation | Gets the page rotation angle.
Public Property | TrimBox | Gets the page trim box.
Public Property | Width | Gets the visual page width.
Top
See Also

Reference

PdfPageInfo Class
Xfinium.Pdf.Core Namespace


%%PageItemTitle%% $$Properties$$

PdfPageInfo Class Properties

Xfinium.Pdf.Core Namespace : PdfPageInfo Class

For a list of all members of this type, see PdfPageInfo members.

Public Properties
 | Name | Description
Public Property | ArtBox | Gets the page art box.
Public Property | BleedBox | Gets the page bleed box.
Public Property | CropBox | Gets the page crop box.
Public Property | Height | Gets the visual page height.
Public Property | MediaBox | Gets the page media box.
Public Property | Rotation | Gets the page rotation angle.
Public Property | TrimBox | Gets the page trim box.
Public Property | Width | Gets the visual page width.
Top
See Also

Reference

PdfPageInfo Class
Xfinium.Pdf.Core Namespace


ArtBox Property (PdfPageInfo)

Xfinium.Pdf.Core Namespace > PdfPageInfo Class : ArtBox Property
Gets the page art box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ArtBox As PdfStandardRectangle
'Usage

Dim instance As PdfPageInfo
Dim value As PdfStandardRectangle

value = instance.ArtBox
public PdfStandardRectangle ArtBox {get;}
public:
property PdfStandardRectangle^ ArtBox {
   PdfStandardRectangle^ get();
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the extent of the page's meaningful content (including potential white space) as intended by the page's creator
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Class
PdfPageInfo Members


BleedBox Property (PdfPageInfo)

Xfinium.Pdf.Core Namespace > PdfPageInfo Class : BleedBox Property
Gets the page bleed box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property BleedBox As PdfStandardRectangle
'Usage

Dim instance As PdfPageInfo
Dim value As PdfStandardRectangle

value = instance.BleedBox
public PdfStandardRectangle BleedBox {get;}
public:
property PdfStandardRectangle^ BleedBox {
   PdfStandardRectangle^ get();
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the region to which the contents of the page should be clipped when output in a production environment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Class
PdfPageInfo Members


CropBox Property (PdfPageInfo)

Xfinium.Pdf.Core Namespace > PdfPageInfo Class : CropBox Property
Gets the page crop box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CropBox As PdfStandardRectangle
'Usage

Dim instance As PdfPageInfo
Dim value As PdfStandardRectangle

value = instance.CropBox
public PdfStandardRectangle CropBox {get;}
public:
property PdfStandardRectangle^ CropBox {
   PdfStandardRectangle^ get();
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the visible region of default user space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Class
PdfPageInfo Members


Height Property (PdfPageInfo)

Xfinium.Pdf.Core Namespace > PdfPageInfo Class : Height Property
Gets the visual page height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PdfPageInfo
Dim value As Double

value = instance.Height
public double Height {get;}
public:
property double Height {
   double get();
}

Property Value

The visual height of the page.
Remarks
The visual height is the height of the page as it is seen on the display. It is always measured on vertical no matter the page rotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Class
PdfPageInfo Members


MediaBox Property (PdfPageInfo)

Xfinium.Pdf.Core Namespace > PdfPageInfo Class : MediaBox Property
Gets the page media box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property MediaBox As PdfStandardRectangle
'Usage

Dim instance As PdfPageInfo
Dim value As PdfStandardRectangle

value = instance.MediaBox
public PdfStandardRectangle MediaBox {get;}
public:
property PdfStandardRectangle^ MediaBox {
   PdfStandardRectangle^ get();
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the boundaries of the physical medium on which the page is intended to be displayed or printed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Class
PdfPageInfo Members


Rotation Property (PdfPageInfo)

Xfinium.Pdf.Core Namespace > PdfPageInfo Class : Rotation Property
Gets the page rotation angle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Rotation As Integer
'Usage

Dim instance As PdfPageInfo
Dim value As Integer

value = instance.Rotation
public int Rotation {get;}
public:
property int Rotation {
   int get();
}

Property Value

The number of degrees by which the page should be rotated clockwise when displayed or printed.
Remarks
The accepted values for this property are 0, 90, 180 and 270 degrees.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Class
PdfPageInfo Members


TrimBox Property (PdfPageInfo)

Xfinium.Pdf.Core Namespace > PdfPageInfo Class : TrimBox Property
Gets the page trim box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TrimBox As PdfStandardRectangle
'Usage

Dim instance As PdfPageInfo
Dim value As PdfStandardRectangle

value = instance.TrimBox
public PdfStandardRectangle TrimBox {get;}
public:
property PdfStandardRectangle^ TrimBox {
   PdfStandardRectangle^ get();
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle, expressed in default user space units, defining the intended dimensions of the finished page after trimming.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Class
PdfPageInfo Members


Width Property (PdfPageInfo)

Xfinium.Pdf.Core Namespace > PdfPageInfo Class : Width Property
Gets the visual page width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PdfPageInfo
Dim value As Double

value = instance.Width
public double Width {get;}
public:
property double Width {
   double get();
}

Property Value

The visual width of the page.
Remarks
The visual width is the width of the page as it is seen on the display. It is always measured on horizontal no matter the page rotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageInfo Class
PdfPageInfo Members


Xfinium.Pdf.Core.Cos Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfCosArray | Defines a PDF COS array.
Class | PdfCosBinaryString | Defines a PDF COS string.
Class | PdfCosBoolean | Defines a PDF COS bool value.
Class | PdfCosDictionary | Defines a PDF COS dictionary. Defines a PDF COS dictionary.
Class | PdfCosDictionaryContainer | Defines a PDF COS dictionary that can exist by itself (referenced from xref) in the PDF file.
Class | PdfCosName | Defines a PDF COS name.
Class | PdfCosNull | Defines a PDF COS null object.
Class | PdfCosNumber | Defines a PDF COS number.
Class | PdfCosObject | Defines the base class for PDF COS objects.
Class | PdfCosStream | Defines a PDF COS stream.
Class | PdfCosString | Defines a PDF COS string.
Enumerations
 | Enumeration | Description
Enumeration | PdfCosObjectType | Specifies the available Pdf object types.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Core.Cos Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosArray
Xfinium.Pdf.Core.Cos.PdfCosBinaryString
Xfinium.Pdf.Core.Cos.PdfCosBoolean
Xfinium.Pdf.Core.Cos.PdfCosDictionary
Xfinium.Pdf.Core.Cos.PdfCosDictionaryContainer
Xfinium.Pdf.Core.Cos.PdfCosStream
Xfinium.Pdf.Core.Cos.PdfCosName
Xfinium.Pdf.Core.Cos.PdfCosNull
Xfinium.Pdf.Core.Cos.PdfCosNumber
Xfinium.Pdf.Core.Cos.PdfCosString
Xfinium.Pdf.Core.Security.PdfDigitalSignature
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfCosArray Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosArray Class
Defines a PDF COS array.
Object Model
PdfCosArray ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfCosArray
   Inherits PdfCosObject
'Usage

Dim instance As PdfCosArray
[DefaultMember("Item")]
public class PdfCosArray : PdfCosObject
[DefaultMember("Item")]
public ref class PdfCosArray : public PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosArray

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosArray Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosArray Class

The following tables list the members exposed by PdfCosArray.

Public Constructors
 | Name | Description
Public Constructor | PdfCosArray Constructor | Initializes a new PdfCosArray object.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets or sets the element at the specified index.
Public Property | Length | Gets the number of elements actually contained in the array.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the array.
Public Method | Clear | Removes all elements from the array.
Public Method | GetElementAsBool | Gets the element at the specified index as a boolean.
Public Method | GetElementAsNumber | Gets the element at the specified index as a double.
Public Method | GetElementAsString | Gets the element at the specified index as a string.
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire array.
Public Method | Insert | Inserts an element into the array at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the array.
Public Method | RemoveAt | Removes the element at the specified index of the array.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosArray Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosArray Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : PdfCosArray Constructor
Initializes a new PdfCosArray object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosArray()
public PdfCosArray()
public:
PdfCosArray();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


%%PageItemTitle%% $$Methods$$

PdfCosArray Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosArray Class

For a list of all members of this type, see PdfCosArray members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the array.
Public Method | Clear | Removes all elements from the array.
Public Method | GetElementAsBool | Gets the element at the specified index as a boolean.
Public Method | GetElementAsNumber | Gets the element at the specified index as a double.
Public Method | GetElementAsString | Gets the element at the specified index as a string.
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire array.
Public Method | Insert | Inserts an element into the array at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the array.
Public Method | RemoveAt | Removes the element at the specified index of the array.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosArray Class
Xfinium.Pdf.Core.Cos Namespace


Add Method (PdfCosArray)

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : Add Method
The object to be added to the end of the array.
Adds an object to the end of the array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Add( _
   ByVal item As PdfCosObject _
)
'Usage

Dim instance As PdfCosArray
Dim item As PdfCosObject

instance.Add(item)
public void Add(
   PdfCosObject item
)
public:
void Add(
   PdfCosObject^ item
)

Parameters

item
The object to be added to the end of the array.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the item is null.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


Clear Method (PdfCosArray)

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : Clear Method
Removes all elements from the array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As PdfCosArray

instance.Clear()
public void Clear()
public:
void Clear();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


GetElementAsBool Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : GetElementAsBool Method
Index of element to return.
Gets the element at the specified index as a boolean.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetElementAsBool( _
   ByVal index As Integer _
) As Boolean
'Usage

Dim instance As PdfCosArray
Dim index As Integer
Dim value As Boolean

value = instance.GetElementAsBool(index)
public bool GetElementAsBool(
   int index
)
public:
bool GetElementAsBool(
   int index
)

Parameters

index
Index of element to return.

Return Value

A bool representing the element.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the index value is invalid
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


GetElementAsNumber Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : GetElementAsNumber Method
Index of element to return.
Gets the element at the specified index as a double.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetElementAsNumber( _
   ByVal index As Integer _
) As Double
'Usage

Dim instance As PdfCosArray
Dim index As Integer
Dim value As Double

value = instance.GetElementAsNumber(index)
public double GetElementAsNumber(
   int index
)
public:
double GetElementAsNumber(
   int index
)

Parameters

index
Index of element to return.

Return Value

A double representing the element.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the index value is invalid
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


GetElementAsString Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : GetElementAsString Method
Index of element to return.
Gets the element at the specified index as a string.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetElementAsString( _
   ByVal index As Integer _
) As String
'Usage

Dim instance As PdfCosArray
Dim index As Integer
Dim value As String

value = instance.GetElementAsString(index)
public string GetElementAsString(
   int index
)
public:
String^ GetElementAsString(
   int index
)

Parameters

index
Index of element to return.

Return Value

A string representing the element.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the index value is invalid
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


IndexOf Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : IndexOf Method
The object to locate in the array.
Searches for the specified object and returns the zero-based index of the first occurrence within the entire array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal obj As PdfCosObject _
) As Integer
'Usage

Dim instance As PdfCosArray
Dim obj As PdfCosObject
Dim value As Integer

value = instance.IndexOf(obj)
public int IndexOf(
   PdfCosObject obj
)
public:
int IndexOf(
   PdfCosObject^ obj
)

Parameters

obj
The object to locate in the array.

Return Value

The zero-based index of the first occurrence of item within the entire array, if found; otherwise, –1.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


Insert Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : Insert Method
The zero-based index at which item should be inserted.
The object to insert.
Inserts an element into the array at the specified index.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As PdfCosObject _
)
'Usage

Dim instance As PdfCosArray
Dim index As Integer
Dim item As PdfCosObject

instance.Insert(index, item)
public void Insert(
   int index,
   PdfCosObject item
)
public:
void Insert(
   int index,
   PdfCosObject^ item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the item is null.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


Remove Method (PdfCosArray)

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : Remove Method
The object to remove from the array.
Removes the first occurrence of a specific object from the array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal obj As PdfCosObject _
)
'Usage

Dim instance As PdfCosArray
Dim obj As PdfCosObject

instance.Remove(obj)
public void Remove(
   PdfCosObject obj
)
public:
void Remove(
   PdfCosObject^ obj
)

Parameters

obj
The object to remove from the array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


RemoveAt Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As PdfCosArray
Dim index As Integer

instance.RemoveAt(index)
public void RemoveAt(
   int index
)
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the index is out of range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


ToString Method (PdfCosArray)

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosArray
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


%%PageItemTitle%% $$Properties$$

PdfCosArray Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosArray Class

For a list of all members of this type, see PdfCosArray members.

Public Properties
 | Name | Description
Public Property | Item | Gets or sets the element at the specified index.
Public Property | Length | Gets the number of elements actually contained in the array.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
See Also

Reference

PdfCosArray Class
Xfinium.Pdf.Core.Cos Namespace


Item Property (PdfCosArray)

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : Item Property
The zero-based index of the element to get or set.
Gets or sets the element at the specified index.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As PdfCosObject
'Usage

Dim instance As PdfCosArray
Dim index As Integer
Dim value As PdfCosObject

instance.Item(index) = value

value = instance.Item(index)
public PdfCosObject this[
   int index
]; {get; set;}
public:
property PdfCosObject^ default [int] {
   PdfCosObject^ get(int index);
   void set (int index, PdfCosObject^ value);
}

Parameters

index
The zero-based index of the element to get or set.

Property Value

The element at the specified index.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the index value is invalid
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


Length Property

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : Length Property
Gets the number of elements actually contained in the array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Length As Integer
'Usage

Dim instance As PdfCosArray
Dim value As Integer

value = instance.Length
public int Length {get;}
public:
property int Length {
   int get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


%%PageItemTitle%%

PdfCosBinaryString Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosBinaryString Class
Defines a PDF COS string.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCosBinaryString
   Inherits PdfCosObject
'Usage

Dim instance As PdfCosBinaryString
public class PdfCosBinaryString : PdfCosObject
public ref class PdfCosBinaryString : public PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosBinaryString

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBinaryString Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosBinaryString Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosBinaryString Class

The following tables list the members exposed by PdfCosBinaryString.

Public Constructors
 | Name | Description
Public Constructor | PdfCosBinaryString Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosBinaryString Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosBinaryString Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosBinaryString Class : PdfCosBinaryString Constructor
Overload List
Overload | Description
PdfCosBinaryString Constructor() | Initializes a new PdfCosBinaryString object.
PdfCosBinaryString Constructor(Byte[]) | Initializes a new PdfCosBinaryString object with a byte array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBinaryString Class
PdfCosBinaryString Members


%%PageItemTitle%%

PdfCosBinaryString Constructor()

Xfinium.Pdf.Core.Cos Namespace > PdfCosBinaryString Class > PdfCosBinaryString Constructor : PdfCosBinaryString Constructor()
Initializes a new PdfCosBinaryString object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosBinaryString()
public PdfCosBinaryString()
public:
PdfCosBinaryString();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBinaryString Class
PdfCosBinaryString Members
Overload List


%%PageItemTitle%%

PdfCosBinaryString Constructor(Byte[])

Xfinium.Pdf.Core.Cos Namespace > PdfCosBinaryString Class > PdfCosBinaryString Constructor : PdfCosBinaryString Constructor(Byte[])
Initial string value.
Initializes a new PdfCosBinaryString object with a byte array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value() As Byte _
)
'Usage

Dim value() As Byte

Dim instance As New PdfCosBinaryString(value)
public PdfCosBinaryString(
   byte[] value
)
public:
PdfCosBinaryString(
   array<byte>^ value
)

Parameters

value
Initial string value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBinaryString Class
PdfCosBinaryString Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfCosBinaryString Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosBinaryString Class

For a list of all members of this type, see PdfCosBinaryString members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosBinaryString Class
Xfinium.Pdf.Core.Cos Namespace


ToString Method (PdfCosBinaryString)

Xfinium.Pdf.Core.Cos Namespace > PdfCosBinaryString Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosBinaryString
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBinaryString Class
PdfCosBinaryString Members


%%PageItemTitle%% $$Properties$$

PdfCosBinaryString Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosBinaryString Class

For a list of all members of this type, see PdfCosBinaryString members.

Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PdfCosBinaryString Class
Xfinium.Pdf.Core.Cos Namespace


Value Property (PdfCosBinaryString)

Xfinium.Pdf.Core.Cos Namespace > PdfCosBinaryString Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As Byte()
'Usage

Dim instance As PdfCosBinaryString
Dim value() As Byte

instance.Value = value

value = instance.Value
public byte[] Value {get; set;}
public:
property array<byte>^ Value {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The byte array represented by this PDF COS string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBinaryString Class
PdfCosBinaryString Members


%%PageItemTitle%%

PdfCosBoolean Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosBoolean Class
Defines a PDF COS bool value.
Object Model
PdfCosBoolean ClassPdfCosBoolean ClassPdfCosBoolean Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCosBoolean
   Inherits PdfCosObject
'Usage

Dim instance As PdfCosBoolean
public class PdfCosBoolean : PdfCosObject
public ref class PdfCosBoolean : public PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosBoolean

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBoolean Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosBoolean Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosBoolean Class

The following tables list the members exposed by PdfCosBoolean.

Public Constructors
 | Name | Description
Public Constructor | PdfCosBoolean Constructor | Overloaded.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | False | Gets a false boolean value.
static (Shared in Visual Basic) | True | Gets a true boolean value.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosBoolean Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosBoolean Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosBoolean Class : PdfCosBoolean Constructor
Overload List
Overload | Description
PdfCosBoolean Constructor() | Initializes a new PdfCosBoolean object.
PdfCosBoolean Constructor(Boolean) | Initializes a new PdfCosBoolean object with a boolean value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBoolean Class
PdfCosBoolean Members


%%PageItemTitle%%

PdfCosBoolean Constructor()

Xfinium.Pdf.Core.Cos Namespace > PdfCosBoolean Class > PdfCosBoolean Constructor : PdfCosBoolean Constructor()
Initializes a new PdfCosBoolean object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosBoolean()
public PdfCosBoolean()
public:
PdfCosBoolean();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBoolean Class
PdfCosBoolean Members
Overload List


%%PageItemTitle%%

PdfCosBoolean Constructor(Boolean)

Xfinium.Pdf.Core.Cos Namespace > PdfCosBoolean Class > PdfCosBoolean Constructor : PdfCosBoolean Constructor(Boolean)
Initial boolean value.
Initializes a new PdfCosBoolean object with a boolean value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Boolean _
)
'Usage

Dim value As Boolean

Dim instance As New PdfCosBoolean(value)
public PdfCosBoolean(
   bool value
)
public:
PdfCosBoolean(
   bool value
)

Parameters

value
Initial boolean value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBoolean Class
PdfCosBoolean Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfCosBoolean Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosBoolean Class

For a list of all members of this type, see PdfCosBoolean members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosBoolean Class
Xfinium.Pdf.Core.Cos Namespace


ToString Method (PdfCosBoolean)

Xfinium.Pdf.Core.Cos Namespace > PdfCosBoolean Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosBoolean
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBoolean Class
PdfCosBoolean Members


%%PageItemTitle%% $$Properties$$

PdfCosBoolean Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosBoolean Class

For a list of all members of this type, see PdfCosBoolean members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | False | Gets a false boolean value.
static (Shared in Visual Basic) | True | Gets a true boolean value.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PdfCosBoolean Class
Xfinium.Pdf.Core.Cos Namespace


False Property

Xfinium.Pdf.Core.Cos Namespace > PdfCosBoolean Class : False Property
Gets a false boolean value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property False As PdfCosBoolean
'Usage

Dim value As PdfCosBoolean

value = PdfCosBoolean.False
public static PdfCosBoolean False {get;}
public:
static property PdfCosBoolean^ False {
   PdfCosBoolean^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBoolean Class
PdfCosBoolean Members


True Property

Xfinium.Pdf.Core.Cos Namespace > PdfCosBoolean Class : True Property
Gets a true boolean value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property True As PdfCosBoolean
'Usage

Dim value As PdfCosBoolean

value = PdfCosBoolean.True
public static PdfCosBoolean True {get;}
public:
static property PdfCosBoolean^ True {
   PdfCosBoolean^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBoolean Class
PdfCosBoolean Members


Value Property (PdfCosBoolean)

Xfinium.Pdf.Core.Cos Namespace > PdfCosBoolean Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As Boolean
'Usage

Dim instance As PdfCosBoolean
Dim value As Boolean

instance.Value = value

value = instance.Value
public bool Value {get; set;}
public:
property bool Value {
   bool get();
   void set (    bool value);
}

Property Value

true / false
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosBoolean Class
PdfCosBoolean Members


%%PageItemTitle%%

PdfCosDictionary Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosDictionary Class
Defines a PDF COS dictionary. Defines a PDF COS dictionary.
Object Model
PdfCosDictionary ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfCosDictionary
   Inherits PdfCosObject
'Usage

Dim instance As PdfCosDictionary
[DefaultMember("Item")]
public class PdfCosDictionary : PdfCosObject
[DefaultMember("Item")]
public ref class PdfCosDictionary : public PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosDictionary
Xfinium.Pdf.Core.Cos.PdfCosDictionaryContainer

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosDictionary Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosDictionary Class

The following tables list the members exposed by PdfCosDictionary.

Public Constructors
 | Name | Description
Public Constructor | PdfCosDictionary Constructor | Initializes a new PdfCosDictionary object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of key/value pairs contained in the Dictionary.
Public Property | Item | Overloaded. Gets or sets the value associated with the specified key.
Public Property | Keys | Gets a collection containing the keys in the Dictionary.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
Public Methods
 | Name | Description
Public Method | GetKeyValueAsBool | Gets the value of the specified key as a boolean.
Public Method | GetKeyValueAsNumber | Gets the value of the specified key as a double.
Public Method | GetKeyValueAsString | Gets the value of the specified key as a string.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosDictionary Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosDictionary Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : PdfCosDictionary Constructor
Initializes a new PdfCosDictionary object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosDictionary()
public PdfCosDictionary()
public:
PdfCosDictionary();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


%%PageItemTitle%% $$Methods$$

PdfCosDictionary Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosDictionary Class

For a list of all members of this type, see PdfCosDictionary members.

Public Methods
 | Name | Description
Public Method | GetKeyValueAsBool | Gets the value of the specified key as a boolean.
Public Method | GetKeyValueAsNumber | Gets the value of the specified key as a double.
Public Method | GetKeyValueAsString | Gets the value of the specified key as a string.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosDictionary Class
Xfinium.Pdf.Core.Cos Namespace


GetKeyValueAsBool(PdfCosName,Boolean) Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : GetKeyValueAsBool(PdfCosName,Boolean) Method
Key to return.
Default value to return if the key does not exist.
Gets the value of the specified key as a boolean.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetKeyValueAsBool( _
   ByVal key As PdfCosName, _
   ByVal defaultValue As Boolean _
) As Boolean
'Usage

Dim instance As PdfCosDictionary
Dim key As PdfCosName
Dim defaultValue As Boolean
Dim value As Boolean

value = instance.GetKeyValueAsBool(key, defaultValue)
public bool GetKeyValueAsBool(
   PdfCosName key,
   bool defaultValue
)
public:
bool GetKeyValueAsBool(
   PdfCosName^ key,
   bool defaultValue
)

Parameters

key
Key to return.
defaultValue
Default value to return if the key does not exist.

Return Value

The key value
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


GetKeyValueAsNumber Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : GetKeyValueAsNumber Method
Key to return.
Default value to return if the key does not exist.
Gets the value of the specified key as a double.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetKeyValueAsNumber( _
   ByVal key As PdfCosName, _
   ByVal defaultValue As Double _
) As Double
'Usage

Dim instance As PdfCosDictionary
Dim key As PdfCosName
Dim defaultValue As Double
Dim value As Double

value = instance.GetKeyValueAsNumber(key, defaultValue)
public double GetKeyValueAsNumber(
   PdfCosName key,
   double defaultValue
)
public:
double GetKeyValueAsNumber(
   PdfCosName^ key,
   double defaultValue
)

Parameters

key
Key to return.
defaultValue
Default value to return if the key does not exist.

Return Value

The key value
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


GetKeyValueAsString(PdfCosName,String) Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : GetKeyValueAsString(PdfCosName,String) Method
Key to return.
Default value to return if the key does not exist.
Gets the value of the specified key as a string.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetKeyValueAsString( _
   ByVal key As PdfCosName, _
   ByVal defaultValue As String _
) As String
'Usage

Dim instance As PdfCosDictionary
Dim key As PdfCosName
Dim defaultValue As String
Dim value As String

value = instance.GetKeyValueAsString(key, defaultValue)
public string GetKeyValueAsString(
   PdfCosName key,
   string defaultValue
)
public:
String^ GetKeyValueAsString(
   PdfCosName^ key,
   String^ defaultValue
)

Parameters

key
Key to return.
defaultValue
Default value to return if the key does not exist.

Return Value

The key value
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


ToString Method (PdfCosDictionary)

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosDictionary
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


%%PageItemTitle%% $$Properties$$

PdfCosDictionary Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosDictionary Class

For a list of all members of this type, see PdfCosDictionary members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of key/value pairs contained in the Dictionary.
Public Property | Item | Overloaded. Gets or sets the value associated with the specified key.
Public Property | Keys | Gets a collection containing the keys in the Dictionary.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
See Also

Reference

PdfCosDictionary Class
Xfinium.Pdf.Core.Cos Namespace


Count Property

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : Count Property
Gets the number of key/value pairs contained in the Dictionary.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Count As Integer
'Usage

Dim instance As PdfCosDictionary
Dim value As Integer

value = instance.Count
public int Count {get;}
public:
property int Count {
   int get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


Item Property (PdfCosDictionary)

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : Item Property
Gets or sets the value associated with the specified key.
Overload List
Overload | Description
Item(String) | Gets or sets the value associated with the specified key.
Item(PdfCosName) | Gets or sets the value associated with the specified key.
Remarks
If the key already exists in the dictionary, the set operation overwrites it.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


Item(String) Property

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class > Item Property : Item(String) Property
The key of the value to get or set.
Gets or sets the value associated with the specified key.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Property Item( _
   ByVal key As String _
) As PdfCosObject
'Usage

Dim instance As PdfCosDictionary
Dim key As String
Dim value As PdfCosObject

instance.Item(key) = value

value = instance.Item(key)
public PdfCosObject Item(
   string key
) {get; set;}
public:
property PdfCosObject^ Item {
   PdfCosObject^ get(String^ key);
   void set (String^ key, PdfCosObject^ value);
}

Parameters

key
The key of the value to get or set.

Property Value

The value associated with the specified key. If the specified key is not found, a get operation returns null, and a set operation creates a new element with the specified key.
Remarks
If the key already exists in the dictionary, the set operation overwrites it.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members
Overload List


Item(PdfCosName) Property

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class > Item Property : Item(PdfCosName) Property
The key of the value to get or set.
Gets or sets the value associated with the specified key.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Property Item( _
   ByVal key As PdfCosName _
) As PdfCosObject
'Usage

Dim instance As PdfCosDictionary
Dim key As PdfCosName
Dim value As PdfCosObject

instance.Item(key) = value

value = instance.Item(key)
public PdfCosObject Item(
   PdfCosName key
) {get; set;}
public:
property PdfCosObject^ Item {
   PdfCosObject^ get(PdfCosName^ key);
   void set (PdfCosName^ key, PdfCosObject^ value);
}

Parameters

key
The key of the value to get or set.

Property Value

The value associated with the specified key. If the specified key is not found, a get operation returns null, and a set operation creates a new element with the specified key.
Remarks
If the key already exists in the dictionary, the set operation overwrites it.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members
Overload List


Keys Property (PdfCosDictionary)

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : Keys Property
Gets a collection containing the keys in the Dictionary.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Keys As String()
'Usage

Dim instance As PdfCosDictionary
Dim value() As String

value = instance.Keys
public string[] Keys {get;}
public:
property array<String^>^ Keys {
   array<String^>^ get();
}

Property Value

A string array containing the keys in the Dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


%%PageItemTitle%%

PdfCosDictionaryContainer Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosDictionaryContainer Class
Defines a PDF COS dictionary that can exist by itself (referenced from xref) in the PDF file.
Object Model
PdfCosDictionaryContainer ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCosDictionaryContainer
   Inherits PdfCosDictionary
'Usage

Dim instance As PdfCosDictionaryContainer
public class PdfCosDictionaryContainer : PdfCosDictionary
public ref class PdfCosDictionaryContainer : public PdfCosDictionary
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosDictionary
Xfinium.Pdf.Core.Cos.PdfCosDictionaryContainer
Xfinium.Pdf.Core.Cos.PdfCosStream

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionaryContainer Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosDictionaryContainer Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosDictionaryContainer Class

The following tables list the members exposed by PdfCosDictionaryContainer.

Public Constructors
 | Name | Description
Public Constructor | PdfCosDictionaryContainer Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of key/value pairs contained in the Dictionary. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | Item | Overloaded. Gets or sets the value associated with the specified key. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | Keys | Gets a collection containing the keys in the Dictionary. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | ObjectNumber | Gets or sets the object number.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
Public Methods
 | Name | Description
Public Method | GetKeyValueAsBool | Gets the value of the specified key as a boolean. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | GetKeyValueAsNumber | Gets the value of the specified key as a double. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | GetKeyValueAsString | Gets the value of the specified key as a string. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | ToString | Returns a string that represents the current object. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Top
See Also

Reference

PdfCosDictionaryContainer Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosDictionaryContainer Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionaryContainer Class : PdfCosDictionaryContainer Constructor
Overload List
Overload | Description
PdfCosDictionaryContainer Constructor() | Initializes a new PdfCosDictionaryContainer object.
PdfCosDictionaryContainer Constructor(PdfCosDictionary) | Initializes a new PdfCosDictionaryContainer object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionaryContainer Class
PdfCosDictionaryContainer Members


%%PageItemTitle%%

PdfCosDictionaryContainer Constructor()

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionaryContainer Class > PdfCosDictionaryContainer Constructor : PdfCosDictionaryContainer Constructor()
Initializes a new PdfCosDictionaryContainer object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosDictionaryContainer()
public PdfCosDictionaryContainer()
public:
PdfCosDictionaryContainer();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionaryContainer Class
PdfCosDictionaryContainer Members
Overload List


%%PageItemTitle%%

PdfCosDictionaryContainer Constructor(PdfCosDictionary)

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionaryContainer Class > PdfCosDictionaryContainer Constructor : PdfCosDictionaryContainer Constructor(PdfCosDictionary)
Source dictionary.
Initializes a new PdfCosDictionaryContainer object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dictionary As PdfCosDictionary _
)
'Usage

Dim dictionary As PdfCosDictionary

Dim instance As New PdfCosDictionaryContainer(dictionary)
public PdfCosDictionaryContainer(
   PdfCosDictionary dictionary
)
public:
PdfCosDictionaryContainer(
   PdfCosDictionary^ dictionary
)

Parameters

dictionary
Source dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionaryContainer Class
PdfCosDictionaryContainer Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfCosDictionaryContainer Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosDictionaryContainer Class

For a list of all members of this type, see PdfCosDictionaryContainer members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of key/value pairs contained in the Dictionary. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | Item | Overloaded. Gets or sets the value associated with the specified key. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | Keys | Gets a collection containing the keys in the Dictionary. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | ObjectNumber | Gets or sets the object number.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
See Also

Reference

PdfCosDictionaryContainer Class
Xfinium.Pdf.Core.Cos Namespace


ObjectNumber Property

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionaryContainer Class : ObjectNumber Property
Gets or sets the object number.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ObjectNumber As Long
'Usage

Dim instance As PdfCosDictionaryContainer
Dim value As Long

value = instance.ObjectNumber
public long ObjectNumber {get;}
public:
property int64 ObjectNumber {
   int64 get();
}

Property Value

The object number identifying this object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionaryContainer Class
PdfCosDictionaryContainer Members


%%PageItemTitle%%

PdfCosName Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosName Class
Defines a PDF COS name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCosName
   Inherits PdfCosObject
'Usage

Dim instance As PdfCosName
public class PdfCosName : PdfCosObject
public ref class PdfCosName : public PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosName

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosName Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosName Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosName Class

The following tables list the members exposed by PdfCosName.

Public Constructors
 | Name | Description
Public Constructor | PdfCosName Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | Equals | Tests if this object is equal to another object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosName Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosName Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosName Class : PdfCosName Constructor
Overload List
Overload | Description
PdfCosName Constructor() | Initializes a new PdfCosName object.
PdfCosName Constructor(String) | Initializes a new PdfCosName object with a PDF name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosName Class
PdfCosName Members


%%PageItemTitle%%

PdfCosName Constructor()

Xfinium.Pdf.Core.Cos Namespace > PdfCosName Class > PdfCosName Constructor : PdfCosName Constructor()
Initializes a new PdfCosName object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosName()
public PdfCosName()
public:
PdfCosName();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosName Class
PdfCosName Members
Overload List


%%PageItemTitle%%

PdfCosName Constructor(String)

Xfinium.Pdf.Core.Cos Namespace > PdfCosName Class > PdfCosName Constructor : PdfCosName Constructor(String)
Initial name value.
Initializes a new PdfCosName object with a PDF name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As String _
)
'Usage

Dim value As String

Dim instance As New PdfCosName(value)
public PdfCosName(
   string value
)
public:
PdfCosName(
   String^ value
)

Parameters

value
Initial name value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosName Class
PdfCosName Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfCosName Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosName Class

For a list of all members of this type, see PdfCosName members.

Public Methods
 | Name | Description
Public Method | Equals | Tests if this object is equal to another object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosName Class
Xfinium.Pdf.Core.Cos Namespace


Equals Method (PdfCosName)

Xfinium.Pdf.Core.Cos Namespace > PdfCosName Class : Equals Method
Object to test.
Tests if this object is equal to another object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfCosName
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosName Class
PdfCosName Members


GetHashCode Method (PdfCosName)

Xfinium.Pdf.Core.Cos Namespace > PdfCosName Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfCosName
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosName Class
PdfCosName Members


ToString Method (PdfCosName)

Xfinium.Pdf.Core.Cos Namespace > PdfCosName Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosName
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosName Class
PdfCosName Members


%%PageItemTitle%% $$Properties$$

PdfCosName Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosName Class

For a list of all members of this type, see PdfCosName members.

Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PdfCosName Class
Xfinium.Pdf.Core.Cos Namespace


Value Property (PdfCosName)

Xfinium.Pdf.Core.Cos Namespace > PdfCosName Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As PdfCosName
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents a PDF name object, it must start with '/'
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosName Class
PdfCosName Members


%%PageItemTitle%%

PdfCosNull Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosNull Class
Defines a PDF COS null object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCosNull
   Inherits PdfCosObject
'Usage

Dim instance As PdfCosNull
public class PdfCosNull : PdfCosObject
public ref class PdfCosNull : public PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosNull

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNull Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosNull Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosNull Class

The following tables list the members exposed by PdfCosNull.

Public Constructors
 | Name | Description
Public Constructor | PdfCosNull Constructor | Initializes a new PdfCosNull object.
Top
Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosNull Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosNull Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosNull Class : PdfCosNull Constructor
Initializes a new PdfCosNull object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosNull()
public PdfCosNull()
public:
PdfCosNull();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNull Class
PdfCosNull Members


%%PageItemTitle%% $$Methods$$

PdfCosNull Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosNull Class

For a list of all members of this type, see PdfCosNull members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosNull Class
Xfinium.Pdf.Core.Cos Namespace


ToString Method (PdfCosNull)

Xfinium.Pdf.Core.Cos Namespace > PdfCosNull Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosNull
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNull Class
PdfCosNull Members


%%PageItemTitle%%

PdfCosNumber Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosNumber Class
Defines a PDF COS number.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCosNumber
   Inherits PdfCosObject
'Usage

Dim instance As PdfCosNumber
public class PdfCosNumber : PdfCosObject
public ref class PdfCosNumber : public PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosNumber

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNumber Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosNumber Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosNumber Class

The following tables list the members exposed by PdfCosNumber.

Public Constructors
 | Name | Description
Public Constructor | PdfCosNumber Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | Equals | Tests if this object is equal to another object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosNumber Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosNumber Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosNumber Class : PdfCosNumber Constructor
Overload List
Overload | Description
PdfCosNumber Constructor() | Initializes a new PdfCosNumber object.
PdfCosNumber Constructor(Double) | Initializes a new PdfCosNumber object with a number.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNumber Class
PdfCosNumber Members


%%PageItemTitle%%

PdfCosNumber Constructor()

Xfinium.Pdf.Core.Cos Namespace > PdfCosNumber Class > PdfCosNumber Constructor : PdfCosNumber Constructor()
Initializes a new PdfCosNumber object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosNumber()
public PdfCosNumber()
public:
PdfCosNumber();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNumber Class
PdfCosNumber Members
Overload List


%%PageItemTitle%%

PdfCosNumber Constructor(Double)

Xfinium.Pdf.Core.Cos Namespace > PdfCosNumber Class > PdfCosNumber Constructor : PdfCosNumber Constructor(Double)
Initial number value.
Initializes a new PdfCosNumber object with a number.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As Double _
)
'Usage

Dim value As Double

Dim instance As New PdfCosNumber(value)
public PdfCosNumber(
   double value
)
public:
PdfCosNumber(
   double value
)

Parameters

value
Initial number value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNumber Class
PdfCosNumber Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfCosNumber Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosNumber Class

For a list of all members of this type, see PdfCosNumber members.

Public Methods
 | Name | Description
Public Method | Equals | Tests if this object is equal to another object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosNumber Class
Xfinium.Pdf.Core.Cos Namespace


Equals Method (PdfCosNumber)

Xfinium.Pdf.Core.Cos Namespace > PdfCosNumber Class : Equals Method
Object to test.
Tests if this object is equal to another object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfCosNumber
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to test.

Return Value

True if the objects are equal, false otherwise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNumber Class
PdfCosNumber Members


GetHashCode Method (PdfCosNumber)

Xfinium.Pdf.Core.Cos Namespace > PdfCosNumber Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfCosNumber
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNumber Class
PdfCosNumber Members


ToString Method (PdfCosNumber)

Xfinium.Pdf.Core.Cos Namespace > PdfCosNumber Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosNumber
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNumber Class
PdfCosNumber Members


%%PageItemTitle%% $$Properties$$

PdfCosNumber Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosNumber Class

For a list of all members of this type, see PdfCosNumber members.

Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PdfCosNumber Class
Xfinium.Pdf.Core.Cos Namespace


Value Property (PdfCosNumber)

Xfinium.Pdf.Core.Cos Namespace > PdfCosNumber Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As Double
'Usage

Dim instance As PdfCosNumber
Dim value As Double

instance.Value = value

value = instance.Value
public double Value {get; set;}
public:
property double Value {
   double get();
   void set (    double value);
}

Property Value

The number represented by this COS object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosNumber Class
PdfCosNumber Members


%%PageItemTitle%%

PdfCosObject Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosObject Class
Defines the base class for PDF COS objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfCosObject
'Usage

Dim instance As PdfCosObject
public abstract class PdfCosObject
public ref class PdfCosObject abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosArray
Xfinium.Pdf.Core.Cos.PdfCosBinaryString
Xfinium.Pdf.Core.Cos.PdfCosBoolean
Xfinium.Pdf.Core.Cos.PdfCosDictionary
Xfinium.Pdf.Core.Cos.PdfCosName
Xfinium.Pdf.Core.Cos.PdfCosNull
Xfinium.Pdf.Core.Cos.PdfCosNumber
Xfinium.Pdf.Core.Cos.PdfCosString
Xfinium.Pdf.Core.Security.PdfDigitalSignature

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosObject Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosObject Class Members
Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosObject Class

The following tables list the members exposed by PdfCosObject.

Public Properties
 | Name | Description
Public Property | Type | Gets the object type.
Top
See Also

Reference

PdfCosObject Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Properties$$

PdfCosObject Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosObject Class

For a list of all members of this type, see PdfCosObject members.

Public Properties
 | Name | Description
Public Property | Type | Gets the object type.
Top
See Also

Reference

PdfCosObject Class
Xfinium.Pdf.Core.Cos Namespace


Type Property (PdfCosObject)

Xfinium.Pdf.Core.Cos Namespace > PdfCosObject Class : Type Property
Gets the object type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PdfCosObjectType
'Usage

Dim instance As PdfCosObject
Dim value As PdfCosObjectType

value = instance.Type
public PdfCosObjectType Type {get;}
public:
property PdfCosObjectType Type {
   PdfCosObjectType get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosObject Class
PdfCosObject Members


%%PageItemTitle%%

PdfCosStream Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosStream Class
Defines a PDF COS stream.
Object Model
PdfCosStream ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCosStream
   Inherits PdfCosDictionaryContainer
'Usage

Dim instance As PdfCosStream
public class PdfCosStream : PdfCosDictionaryContainer
public ref class PdfCosStream : public PdfCosDictionaryContainer
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosDictionary
Xfinium.Pdf.Core.Cos.PdfCosDictionaryContainer
Xfinium.Pdf.Core.Cos.PdfCosStream

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosStream Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosStream Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosStream Class

The following tables list the members exposed by PdfCosStream.

Public Constructors
 | Name | Description
Public Constructor | PdfCosStream Constructor | Initializes a new PdfCosStream object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of key/value pairs contained in the Dictionary. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | Item | Overloaded. Gets or sets the value associated with the specified key. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | Keys | Gets a collection containing the keys in the Dictionary. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | ObjectNumber | Gets or sets the object number. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionaryContainer)
Public Property | Stream | Gets or sets the stream content.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
Public Methods
 | Name | Description
Public Method | GetKeyValueAsBool | Gets the value of the specified key as a boolean. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | GetKeyValueAsNumber | Gets the value of the specified key as a double. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | GetKeyValueAsString | Gets the value of the specified key as a string. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosStream Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosStream Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosStream Class : PdfCosStream Constructor
Initializes a new PdfCosStream object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosStream()
public PdfCosStream()
public:
PdfCosStream();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosStream Class
PdfCosStream Members


%%PageItemTitle%% $$Methods$$

PdfCosStream Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosStream Class

For a list of all members of this type, see PdfCosStream members.

Public Methods
 | Name | Description
Public Method | GetKeyValueAsBool | Gets the value of the specified key as a boolean. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | GetKeyValueAsNumber | Gets the value of the specified key as a double. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | GetKeyValueAsString | Gets the value of the specified key as a string. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosStream Class
Xfinium.Pdf.Core.Cos Namespace


ToString Method (PdfCosStream)

Xfinium.Pdf.Core.Cos Namespace > PdfCosStream Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosStream
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosStream Class
PdfCosStream Members


%%PageItemTitle%% $$Properties$$

PdfCosStream Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosStream Class

For a list of all members of this type, see PdfCosStream members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of key/value pairs contained in the Dictionary. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | Item | Overloaded. Gets or sets the value associated with the specified key. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | Keys | Gets a collection containing the keys in the Dictionary. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Property | ObjectNumber | Gets or sets the object number. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionaryContainer)
Public Property | Stream | Gets or sets the stream content.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
See Also

Reference

PdfCosStream Class
Xfinium.Pdf.Core.Cos Namespace


Stream Property (PdfCosStream)

Xfinium.Pdf.Core.Cos Namespace > PdfCosStream Class : Stream Property
Gets or sets the stream content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Stream As Byte()
'Usage

Dim instance As PdfCosStream
Dim value() As Byte

instance.Stream = value

value = instance.Stream
public byte[] Stream {get; set;}
public:
property array<byte>^ Stream {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The stream content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosStream Class
PdfCosStream Members


%%PageItemTitle%%

PdfCosString Class
Members

Xfinium.Pdf.Core.Cos Namespace : PdfCosString Class
Defines a PDF COS string.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCosString
   Inherits PdfCosObject
'Usage

Dim instance As PdfCosString
public class PdfCosString : PdfCosObject
public ref class PdfCosString : public PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Cos.PdfCosString

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosString Members
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%% $$Members$$

PdfCosString Class Members
Properties Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosString Class

The following tables list the members exposed by PdfCosString.

Public Constructors
 | Name | Description
Public Constructor | PdfCosString Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosString Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosString Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosString Class : PdfCosString Constructor
Overload List
Overload | Description
PdfCosString Constructor() | Initializes a new PdfCosString object.
PdfCosString Constructor(String) | Initializes a new PdfCosString object with a string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosString Class
PdfCosString Members


%%PageItemTitle%%

PdfCosString Constructor()

Xfinium.Pdf.Core.Cos Namespace > PdfCosString Class > PdfCosString Constructor : PdfCosString Constructor()
Initializes a new PdfCosString object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCosString()
public PdfCosString()
public:
PdfCosString();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosString Class
PdfCosString Members
Overload List


%%PageItemTitle%%

PdfCosString Constructor(String)

Xfinium.Pdf.Core.Cos Namespace > PdfCosString Class > PdfCosString Constructor : PdfCosString Constructor(String)
Initial string value.
Initializes a new PdfCosString object with a string.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As String _
)
'Usage

Dim value As String

Dim instance As New PdfCosString(value)
public PdfCosString(
   string value
)
public:
PdfCosString(
   String^ value
)

Parameters

value
Initial string value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosString Class
PdfCosString Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfCosString Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosString Class

For a list of all members of this type, see PdfCosString members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfCosString Class
Xfinium.Pdf.Core.Cos Namespace


ToString Method (PdfCosString)

Xfinium.Pdf.Core.Cos Namespace > PdfCosString Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfCosString
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosString Class
PdfCosString Members


%%PageItemTitle%% $$Properties$$

PdfCosString Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosString Class

For a list of all members of this type, see PdfCosString members.

Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Public Property | Value | Gets or sets the object value.
Top
See Also

Reference

PdfCosString Class
Xfinium.Pdf.Core.Cos Namespace


Value Property (PdfCosString)

Xfinium.Pdf.Core.Cos Namespace > PdfCosString Class : Value Property
Gets or sets the object value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As PdfCosString
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Property Value

The string represented by this PDF COS string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosString Class
PdfCosString Members


%%PageItemTitle%%

PdfCosObjectType Enumeration

Xfinium.Pdf.Core.Cos Namespace : PdfCosObjectType Enumeration
Specifies the available Pdf object types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfCosObjectType
   Inherits System.Enum
'Usage

Dim instance As PdfCosObjectType
public enum PdfCosObjectType : System.Enum
public enum class PdfCosObjectType : public System.Enum
Members
Member | Description
Array | Array
Bool | Bool
Cos | COS object
CosContainer | Standalone COS object
Dictionary | Dictionary
IndirectReference | Indirect reference
Name | Name
Null | Null object
Number | Number
Stream | Binary stream
String | String
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Core.Cos.PdfCosObjectType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Core.Cos Namespace


Xfinium.Pdf.Core.Encodings Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfEncoding | Defines the base class for all encodings in a Pdf file.
Class | PdfEncodingCollection | Defines a collection of encodings.
Enumerations
 | Enumeration | Description
Enumeration | PdfFontEncoding | Font encodings.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Core.Encodings Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Core.Encodings.PdfEncodingCollection
Xfinium.Pdf.Core.Encodings.PdfEncoding
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfEncoding Class
Members

Xfinium.Pdf.Core.Encodings Namespace : PdfEncoding Class
Defines the base class for all encodings in a Pdf file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfEncoding
'Usage

Dim instance As PdfEncoding
public class PdfEncoding
public ref class PdfEncoding
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Encodings.PdfEncoding

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEncoding Members
Xfinium.Pdf.Core.Encodings Namespace


%%PageItemTitle%% $$Members$$

PdfEncoding Class Members
Methods

Xfinium.Pdf.Core.Encodings Namespace : PdfEncoding Class

The following tables list the members exposed by PdfEncoding.

Public Constructors
 | Name | Description
Public Constructor | PdfEncoding Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateEncoding | Creates an encoding based on an encoding file definition.
Top
See Also

Reference

PdfEncoding Class
Xfinium.Pdf.Core.Encodings Namespace


%%PageItemTitle%%

PdfEncoding Constructor

Xfinium.Pdf.Core.Encodings Namespace > PdfEncoding Class : PdfEncoding Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfEncoding()
public PdfEncoding()
public:
PdfEncoding();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEncoding Class
PdfEncoding Members


%%PageItemTitle%% $$Methods$$

PdfEncoding Class Methods

Xfinium.Pdf.Core.Encodings Namespace : PdfEncoding Class

For a list of all members of this type, see PdfEncoding members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateEncoding | Creates an encoding based on an encoding file definition.
Top
See Also

Reference

PdfEncoding Class
Xfinium.Pdf.Core.Encodings Namespace


CreateEncoding Method

Xfinium.Pdf.Core.Encodings Namespace > PdfEncoding Class : CreateEncoding Method
Stream storing the encoding definition.
Creates an encoding based on an encoding file definition.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function CreateEncoding( _
   ByVal stream As Stream _
) As PdfEncoding
'Usage

Dim stream As Stream
Dim value As PdfEncoding

value = PdfEncoding.CreateEncoding(stream)
public static PdfEncoding CreateEncoding(
   Stream stream
)
public:
static PdfEncoding^ CreateEncoding(
   Stream^ stream
)

Parameters

stream
Stream storing the encoding definition.

Return Value

The encoding object if it has been created with success.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEncoding Class
PdfEncoding Members


%%PageItemTitle%%

PdfEncodingCollection Class
Members

Xfinium.Pdf.Core.Encodings Namespace : PdfEncodingCollection Class
Defines a collection of encodings.
Object Model
PdfEncodingCollection ClassPdfEncoding Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfEncodingCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfEncoding)
'Usage

Dim instance As PdfEncodingCollection
public class PdfEncodingCollection : System.Collections.ObjectModel.Collection<PdfEncoding>
public ref class PdfEncodingCollection : public System.Collections.ObjectModel.Collection<PdfEncoding>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Core.Encodings.PdfEncodingCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEncodingCollection Members
Xfinium.Pdf.Core.Encodings Namespace


%%PageItemTitle%% $$Members$$

PdfEncodingCollection Class Members
Properties Methods

Xfinium.Pdf.Core.Encodings Namespace : PdfEncodingCollection Class

The following tables list the members exposed by PdfEncodingCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Top
See Also

Reference

PdfEncodingCollection Class
Xfinium.Pdf.Core.Encodings Namespace


%%PageItemTitle%%

PdfFontEncoding Enumeration

Xfinium.Pdf.Core.Encodings Namespace : PdfFontEncoding Enumeration
Font encodings.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFontEncoding
   Inherits System.Enum
'Usage

Dim instance As PdfFontEncoding
public enum PdfFontEncoding : System.Enum
public enum class PdfFontEncoding : public System.Enum
Members
Member | Description
AdobeCustom |
AdobeExpert |
AdobeLatin1 |
AdobeLatin2 |
AdobeStandard |
Big5 |
GB2312 |
Johab |
MacRoman |
MicrosoftSymbol |
None |
ShiftJis |
Unicode |
Wansung |
Remarks
This class supports the internal library infrastructure and it should not be used by other applications.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Core.Encodings.PdfFontEncoding

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Core.Encodings Namespace


Xfinium.Pdf.Core.Exceptions Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfException | Defines a PDF exception.
Class | PdfInvalidPageContentException | Defines the exception that is thrown when the page content is invalid and cannot be parsed.
Class | PdfUnsupportedDataException | Defines an exception that is thrown when the data format is unsupported for the current operation.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Core.Exceptions Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Core.Exceptions.PdfInvalidPageContentException
Xfinium.Pdf.Core.Exceptions.PdfUnsupportedDataException
Xfinium.Pdf.Graphics.PdfBarcodeException
Xfinium.Pdf.Imaging.Png.PngDecodeException
Xfinium.Pdf.Imaging.Tiff.TiffDecodeException
Xfinium.Pdf.Standards.PdfAException
Xfinium.Pdf.Standards.PdfAAggregateException
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfException Class
Members

Xfinium.Pdf.Core.Exceptions Namespace : PdfException Class
Defines a PDF exception.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfException
   Inherits System.Exception
'Usage

Dim instance As PdfException
public class PdfException : System.Exception
public ref class PdfException : public System.Exception
Inheritance Hierarchy

System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Core.Exceptions.PdfInvalidPageContentException
Xfinium.Pdf.Core.Exceptions.PdfUnsupportedDataException
Xfinium.Pdf.Graphics.PdfBarcodeException
Xfinium.Pdf.Imaging.Png.PngDecodeException
Xfinium.Pdf.Imaging.Tiff.TiffDecodeException
Xfinium.Pdf.Standards.PdfAException

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfException Members
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%% $$Members$$

PdfException Class Members
Properties Methods

Xfinium.Pdf.Core.Exceptions Namespace : PdfException Class

The following tables list the members exposed by PdfException.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfException Class
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%%

PdfInvalidPageContentException Class
Members

Xfinium.Pdf.Core.Exceptions Namespace : PdfInvalidPageContentException Class
Defines the exception that is thrown when the page content is invalid and cannot be parsed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfInvalidPageContentException
   Inherits PdfException
'Usage

Dim instance As PdfInvalidPageContentException
public class PdfInvalidPageContentException : PdfException
public ref class PdfInvalidPageContentException : public PdfException
Inheritance Hierarchy

System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Core.Exceptions.PdfInvalidPageContentException

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInvalidPageContentException Members
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%% $$Members$$

PdfInvalidPageContentException Class Members
Properties Methods

Xfinium.Pdf.Core.Exceptions Namespace : PdfInvalidPageContentException Class

The following tables list the members exposed by PdfInvalidPageContentException.

Public Constructors
 | Name | Description
Public Constructor | PdfInvalidPageContentException Constructor | Initializes a new PdfInvalidPageContentException object.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfInvalidPageContentException Class
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%%

PdfInvalidPageContentException Constructor

Xfinium.Pdf.Core.Exceptions Namespace > PdfInvalidPageContentException Class : PdfInvalidPageContentException Constructor
Exception message.
Initializes a new PdfInvalidPageContentException object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PdfInvalidPageContentException(message)
public PdfInvalidPageContentException(
   string message
)
public:
PdfInvalidPageContentException(
   String^ message
)

Parameters

message
Exception message.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInvalidPageContentException Class
PdfInvalidPageContentException Members


%%PageItemTitle%%

PdfUnsupportedDataException Class
Members

Xfinium.Pdf.Core.Exceptions Namespace : PdfUnsupportedDataException Class
Defines an exception that is thrown when the data format is unsupported for the current operation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUnsupportedDataException
   Inherits PdfException
'Usage

Dim instance As PdfUnsupportedDataException
public class PdfUnsupportedDataException : PdfException
public ref class PdfUnsupportedDataException : public PdfException
Inheritance Hierarchy

System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Core.Exceptions.PdfUnsupportedDataException

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUnsupportedDataException Members
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%% $$Members$$

PdfUnsupportedDataException Class Members
Properties Methods

Xfinium.Pdf.Core.Exceptions Namespace : PdfUnsupportedDataException Class

The following tables list the members exposed by PdfUnsupportedDataException.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfUnsupportedDataException Class
Xfinium.Pdf.Core.Exceptions Namespace


Xfinium.Pdf.Core.Security Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfAesSecurityHandler | Defines a PDF security handler that uses AES encryption.
Class | PdfDigitalSignature | Defines a PDF digital signature. Defines a digital signature used for signing a Pdf file.
Class | PdfRc4SecurityHandler | Defines a PDF security handler that uses RC4 encryption.
Class | PdfSecurityHandler | Defines an abstract PDF security handlers.
Class | PdfStandardSecurityHandler | Defines a base class for standard PDF security handlers.
Enumerations
 | Enumeration | Description
Enumeration | PdfEncryptionAlgorithm | The supported PDF encryption algorithms.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Core.Security Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Security.PdfDigitalSignature
Xfinium.Pdf.Core.Security.PdfSecurityHandler
Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler
Xfinium.Pdf.Core.Security.PdfAesSecurityHandler
Xfinium.Pdf.Core.Security.PdfRc4SecurityHandler
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfAesSecurityHandler Class
Members

Xfinium.Pdf.Core.Security Namespace : PdfAesSecurityHandler Class
Defines a PDF security handler that uses AES encryption.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAesSecurityHandler
   Inherits PdfStandardSecurityHandler
'Usage

Dim instance As PdfAesSecurityHandler
public class PdfAesSecurityHandler : PdfStandardSecurityHandler
public ref class PdfAesSecurityHandler : public PdfStandardSecurityHandler
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Security.PdfSecurityHandler
Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler
Xfinium.Pdf.Core.Security.PdfAesSecurityHandler

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAesSecurityHandler Members
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%% $$Members$$

PdfAesSecurityHandler Class Members
Properties

Xfinium.Pdf.Core.Security Namespace : PdfAesSecurityHandler Class

The following tables list the members exposed by PdfAesSecurityHandler.

Public Constructors
 | Name | Description
Public Constructor | PdfAesSecurityHandler Constructor | Initializes a new PdfAesSecurityHandler object.
Top
Public Properties
 | Name | Description
Public Property | EnableAnnotationsAndFieldsEdit | Gets or sets a value indicating whether the user can edit the annotations and form fields. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableContentExtraction | Gets or sets a value indicating whether the user can extract the content of the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableContentExtractionForAccessibility | Gets or sets a value indicating whether the user can extract the content of the document in support of accessibility. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableDocumentAssembly | Gets or sets a value indicating whether the user can assemble the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableDocumentChange | Gets or sets a value indicating whether the user can modify the contents of the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableFormsFill | Gets or sets a value indicating whether the user can fill in form fields. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnablePrint | Gets or sets a value indicating whether the user can print the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EncryptMetadata | Gets or sets a value indicatig whether the document-level metadata stream is to be encrypted. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | HighQualityPrint | Gets or sets a value indicating whether the document is printed in high quality. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | KeySize | Overridden. Gets or sets the size, in bits, of the secret key used by the security handler.
Public Property | OwnerPassword | Gets or sets the owner password. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | UseEnhancedPasswordValidation | Gets or sets a value indicating whether enhanced password validation is activated.
Public Property | UserPassword | Gets or sets the user password. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Top
See Also

Reference

PdfAesSecurityHandler Class
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%%

PdfAesSecurityHandler Constructor

Xfinium.Pdf.Core.Security Namespace > PdfAesSecurityHandler Class : PdfAesSecurityHandler Constructor
Initializes a new PdfAesSecurityHandler object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfAesSecurityHandler()
public PdfAesSecurityHandler()
public:
PdfAesSecurityHandler();
Remarks
Default encryption is set to AES 128bit.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAesSecurityHandler Class
PdfAesSecurityHandler Members


%%PageItemTitle%% $$Properties$$

PdfAesSecurityHandler Class Properties

Xfinium.Pdf.Core.Security Namespace : PdfAesSecurityHandler Class

For a list of all members of this type, see PdfAesSecurityHandler members.

Public Properties
 | Name | Description
Public Property | EnableAnnotationsAndFieldsEdit | Gets or sets a value indicating whether the user can edit the annotations and form fields. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableContentExtraction | Gets or sets a value indicating whether the user can extract the content of the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableContentExtractionForAccessibility | Gets or sets a value indicating whether the user can extract the content of the document in support of accessibility. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableDocumentAssembly | Gets or sets a value indicating whether the user can assemble the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableDocumentChange | Gets or sets a value indicating whether the user can modify the contents of the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableFormsFill | Gets or sets a value indicating whether the user can fill in form fields. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnablePrint | Gets or sets a value indicating whether the user can print the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EncryptMetadata | Gets or sets a value indicatig whether the document-level metadata stream is to be encrypted. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | HighQualityPrint | Gets or sets a value indicating whether the document is printed in high quality. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | KeySize | Overridden. Gets or sets the size, in bits, of the secret key used by the security handler.
Public Property | OwnerPassword | Gets or sets the owner password. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | UseEnhancedPasswordValidation | Gets or sets a value indicating whether enhanced password validation is activated.
Public Property | UserPassword | Gets or sets the user password. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Top
See Also

Reference

PdfAesSecurityHandler Class
Xfinium.Pdf.Core.Security Namespace


KeySize Property (PdfAesSecurityHandler)

Xfinium.Pdf.Core.Security Namespace > PdfAesSecurityHandler Class : KeySize Property
Gets or sets the size, in bits, of the secret key used by the security handler.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property KeySize As Integer
'Usage

Dim instance As PdfAesSecurityHandler
Dim value As Integer

instance.KeySize = value

value = instance.KeySize
public override int KeySize {get; set;}
public:
property int KeySize {
   int get() override;
   void set (    int value) override;
}

Property Value

The size, in bits, of the secret key used by the security handler.
Remarks
AES support only 128bit and 256bit key sizes.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAesSecurityHandler Class
PdfAesSecurityHandler Members


UseEnhancedPasswordValidation Property

Xfinium.Pdf.Core.Security Namespace > PdfAesSecurityHandler Class : UseEnhancedPasswordValidation Property
Gets or sets a value indicating whether enhanced password validation is activated.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UseEnhancedPasswordValidation As Boolean
'Usage

Dim instance As PdfAesSecurityHandler
Dim value As Boolean

instance.UseEnhancedPasswordValidation = value

value = instance.UseEnhancedPasswordValidation
public bool UseEnhancedPasswordValidation {get; set;}
public:
property bool UseEnhancedPasswordValidation {
   bool get();
   void set (    bool value);
}

Property Value

If true then enhanced password validation method is activated.
Remarks
PDF files encrypted with this option require Adobe Reader X or later.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAesSecurityHandler Class
PdfAesSecurityHandler Members


%%PageItemTitle%%

PdfDigitalSignature Class
Members

Xfinium.Pdf.Core.Security Namespace : PdfDigitalSignature Class
Defines a PDF digital signature. Defines a digital signature used for signing a Pdf file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDigitalSignature
   Inherits Xfinium.Pdf.Core.Cos.PdfCosObject
'Usage

Dim instance As PdfDigitalSignature
public class PdfDigitalSignature : Xfinium.Pdf.Core.Cos.PdfCosObject
public ref class PdfDigitalSignature : public Xfinium.Pdf.Core.Cos.PdfCosObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Cos.PdfCosObject
Xfinium.Pdf.Core.Security.PdfDigitalSignature

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDigitalSignature Members
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%% $$Members$$

PdfDigitalSignature Class Members
Properties

Xfinium.Pdf.Core.Security Namespace : PdfDigitalSignature Class

The following tables list the members exposed by PdfDigitalSignature.

Public Properties
 | Name | Description
Public Property | ContactInfo | Gets or sets the contact information.
Public Property | Location | Gets or sets the location.
Public Property | Name | Gets or sets the name.
Public Property | Reason | Gets or sets the sign reason.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
See Also

Reference

PdfDigitalSignature Class
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%% $$Properties$$

PdfDigitalSignature Class Properties

Xfinium.Pdf.Core.Security Namespace : PdfDigitalSignature Class

For a list of all members of this type, see PdfDigitalSignature members.

Public Properties
 | Name | Description
Public Property | ContactInfo | Gets or sets the contact information.
Public Property | Location | Gets or sets the location.
Public Property | Name | Gets or sets the name.
Public Property | Reason | Gets or sets the sign reason.
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
See Also

Reference

PdfDigitalSignature Class
Xfinium.Pdf.Core.Security Namespace


ContactInfo Property

Xfinium.Pdf.Core.Security Namespace > PdfDigitalSignature Class : ContactInfo Property
Gets or sets the contact information.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ContactInfo As String
'Usage

Dim instance As PdfDigitalSignature
Dim value As String

instance.ContactInfo = value

value = instance.ContactInfo
public string ContactInfo {get; set;}
public:
property String^ ContactInfo {
   String^ get();
   void set (    String^ value);
}

Property Value

Information provided by the signer to enable a recipient to contact the signer to verify the signature.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDigitalSignature Class
PdfDigitalSignature Members


Location Property (PdfDigitalSignature)

Xfinium.Pdf.Core.Security Namespace > PdfDigitalSignature Class : Location Property
Gets or sets the location.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Location As String
'Usage

Dim instance As PdfDigitalSignature
Dim value As String

instance.Location = value

value = instance.Location
public string Location {get; set;}
public:
property String^ Location {
   String^ get();
   void set (    String^ value);
}

Property Value

The CPU host name or physical location of the signing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDigitalSignature Class
PdfDigitalSignature Members


Name Property (PdfDigitalSignature)

Xfinium.Pdf.Core.Security Namespace > PdfDigitalSignature Class : Name Property
Gets or sets the name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfDigitalSignature
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the person or authority signing the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDigitalSignature Class
PdfDigitalSignature Members


Reason Property

Xfinium.Pdf.Core.Security Namespace > PdfDigitalSignature Class : Reason Property
Gets or sets the sign reason.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Reason As String
'Usage

Dim instance As PdfDigitalSignature
Dim value As String

instance.Reason = value

value = instance.Reason
public string Reason {get; set;}
public:
property String^ Reason {
   String^ get();
   void set (    String^ value);
}

Property Value

The reason for the signing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDigitalSignature Class
PdfDigitalSignature Members


%%PageItemTitle%%

PdfRc4SecurityHandler Class
Members

Xfinium.Pdf.Core.Security Namespace : PdfRc4SecurityHandler Class
Defines a PDF security handler that uses RC4 encryption.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRc4SecurityHandler
   Inherits PdfStandardSecurityHandler
'Usage

Dim instance As PdfRc4SecurityHandler
public class PdfRc4SecurityHandler : PdfStandardSecurityHandler
public ref class PdfRc4SecurityHandler : public PdfStandardSecurityHandler
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Security.PdfSecurityHandler
Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler
Xfinium.Pdf.Core.Security.PdfRc4SecurityHandler

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRc4SecurityHandler Members
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%% $$Members$$

PdfRc4SecurityHandler Class Members
Properties

Xfinium.Pdf.Core.Security Namespace : PdfRc4SecurityHandler Class

The following tables list the members exposed by PdfRc4SecurityHandler.

Public Constructors
 | Name | Description
Public Constructor | PdfRc4SecurityHandler Constructor | Initializes a new PdfRc4SecurityHandler object.
Top
Public Properties
 | Name | Description
Public Property | EnableAnnotationsAndFieldsEdit | Gets or sets a value indicating whether the user can edit the annotations and form fields. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableContentExtraction | Gets or sets a value indicating whether the user can extract the content of the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableContentExtractionForAccessibility | Gets or sets a value indicating whether the user can extract the content of the document in support of accessibility. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableDocumentAssembly | Gets or sets a value indicating whether the user can assemble the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableDocumentChange | Gets or sets a value indicating whether the user can modify the contents of the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableFormsFill | Gets or sets a value indicating whether the user can fill in form fields. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnablePrint | Gets or sets a value indicating whether the user can print the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EncryptMetadata | Gets or sets a value indicatig whether the document-level metadata stream is to be encrypted. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | HighQualityPrint | Gets or sets a value indicating whether the document is printed in high quality. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | KeySize | Overridden. Gets or sets the size, in bits, of the secret key used by the security handler.
Public Property | OwnerPassword | Gets or sets the owner password. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | UserPassword | Gets or sets the user password. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Top
See Also

Reference

PdfRc4SecurityHandler Class
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%%

PdfRc4SecurityHandler Constructor

Xfinium.Pdf.Core.Security Namespace > PdfRc4SecurityHandler Class : PdfRc4SecurityHandler Constructor
Initializes a new PdfRc4SecurityHandler object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRc4SecurityHandler()
public PdfRc4SecurityHandler()
public:
PdfRc4SecurityHandler();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRc4SecurityHandler Class
PdfRc4SecurityHandler Members


%%PageItemTitle%% $$Properties$$

PdfRc4SecurityHandler Class Properties

Xfinium.Pdf.Core.Security Namespace : PdfRc4SecurityHandler Class

For a list of all members of this type, see PdfRc4SecurityHandler members.

Public Properties
 | Name | Description
Public Property | EnableAnnotationsAndFieldsEdit | Gets or sets a value indicating whether the user can edit the annotations and form fields. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableContentExtraction | Gets or sets a value indicating whether the user can extract the content of the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableContentExtractionForAccessibility | Gets or sets a value indicating whether the user can extract the content of the document in support of accessibility. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableDocumentAssembly | Gets or sets a value indicating whether the user can assemble the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableDocumentChange | Gets or sets a value indicating whether the user can modify the contents of the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnableFormsFill | Gets or sets a value indicating whether the user can fill in form fields. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EnablePrint | Gets or sets a value indicating whether the user can print the document. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | EncryptMetadata | Gets or sets a value indicatig whether the document-level metadata stream is to be encrypted. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | HighQualityPrint | Gets or sets a value indicating whether the document is printed in high quality. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | KeySize | Overridden. Gets or sets the size, in bits, of the secret key used by the security handler.
Public Property | OwnerPassword | Gets or sets the owner password. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Public Property | UserPassword | Gets or sets the user password. (Inherited from Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler)
Top
See Also

Reference

PdfRc4SecurityHandler Class
Xfinium.Pdf.Core.Security Namespace


KeySize Property (PdfRc4SecurityHandler)

Xfinium.Pdf.Core.Security Namespace > PdfRc4SecurityHandler Class : KeySize Property
Gets or sets the size, in bits, of the secret key used by the security handler.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property KeySize As Integer
'Usage

Dim instance As PdfRc4SecurityHandler
Dim value As Integer

instance.KeySize = value

value = instance.KeySize
public override int KeySize {get; set;}
public:
property int KeySize {
   int get() override;
   void set (    int value) override;
}

Property Value

The size, in bits, of the secret key used by the security handler.
Remarks
RC4 support only 40bit and 256bit key sizes.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRc4SecurityHandler Class
PdfRc4SecurityHandler Members


%%PageItemTitle%%

PdfSecurityHandler Class
Members

Xfinium.Pdf.Core.Security Namespace : PdfSecurityHandler Class
Defines an abstract PDF security handlers.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfSecurityHandler
'Usage

Dim instance As PdfSecurityHandler
public abstract class PdfSecurityHandler
public ref class PdfSecurityHandler abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Security.PdfSecurityHandler
Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSecurityHandler Members
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%% $$Members$$

PdfSecurityHandler Class Members

Xfinium.Pdf.Core.Security Namespace : PdfSecurityHandler Class

The following tables list the members exposed by PdfSecurityHandler.

See Also

Reference

PdfSecurityHandler Class
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%%

PdfStandardSecurityHandler Class
Members

Xfinium.Pdf.Core.Security Namespace : PdfStandardSecurityHandler Class
Defines a base class for standard PDF security handlers.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfStandardSecurityHandler
   Inherits PdfSecurityHandler
'Usage

Dim instance As PdfStandardSecurityHandler
public abstract class PdfStandardSecurityHandler : PdfSecurityHandler
public ref class PdfStandardSecurityHandler abstract : public PdfSecurityHandler
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Core.Security.PdfSecurityHandler
Xfinium.Pdf.Core.Security.PdfStandardSecurityHandler
Xfinium.Pdf.Core.Security.PdfAesSecurityHandler
Xfinium.Pdf.Core.Security.PdfRc4SecurityHandler

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Members
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%% $$Members$$

PdfStandardSecurityHandler Class Members
Properties

Xfinium.Pdf.Core.Security Namespace : PdfStandardSecurityHandler Class

The following tables list the members exposed by PdfStandardSecurityHandler.

Public Properties
 | Name | Description
Public Property | EnableAnnotationsAndFieldsEdit | Gets or sets a value indicating whether the user can edit the annotations and form fields.
Public Property | EnableContentExtraction | Gets or sets a value indicating whether the user can extract the content of the document.
Public Property | EnableContentExtractionForAccessibility | Gets or sets a value indicating whether the user can extract the content of the document in support of accessibility.
Public Property | EnableDocumentAssembly | Gets or sets a value indicating whether the user can assemble the document.
Public Property | EnableDocumentChange | Gets or sets a value indicating whether the user can modify the contents of the document.
Public Property | EnableFormsFill | Gets or sets a value indicating whether the user can fill in form fields.
Public Property | EnablePrint | Gets or sets a value indicating whether the user can print the document.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether the document-level metadata stream is to be encrypted.
Public Property | HighQualityPrint | Gets or sets a value indicating whether the document is printed in high quality.
Public Property | KeySize | Gets or sets the size, in bits, of the secret key used by the security handler.
Public Property | OwnerPassword | Gets or sets the owner password.
Public Property | UserPassword | Gets or sets the user password.
Top
See Also

Reference

PdfStandardSecurityHandler Class
Xfinium.Pdf.Core.Security Namespace


%%PageItemTitle%% $$Properties$$

PdfStandardSecurityHandler Class Properties

Xfinium.Pdf.Core.Security Namespace : PdfStandardSecurityHandler Class

For a list of all members of this type, see PdfStandardSecurityHandler members.

Public Properties
 | Name | Description
Public Property | EnableAnnotationsAndFieldsEdit | Gets or sets a value indicating whether the user can edit the annotations and form fields.
Public Property | EnableContentExtraction | Gets or sets a value indicating whether the user can extract the content of the document.
Public Property | EnableContentExtractionForAccessibility | Gets or sets a value indicating whether the user can extract the content of the document in support of accessibility.
Public Property | EnableDocumentAssembly | Gets or sets a value indicating whether the user can assemble the document.
Public Property | EnableDocumentChange | Gets or sets a value indicating whether the user can modify the contents of the document.
Public Property | EnableFormsFill | Gets or sets a value indicating whether the user can fill in form fields.
Public Property | EnablePrint | Gets or sets a value indicating whether the user can print the document.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether the document-level metadata stream is to be encrypted.
Public Property | HighQualityPrint | Gets or sets a value indicating whether the document is printed in high quality.
Public Property | KeySize | Gets or sets the size, in bits, of the secret key used by the security handler.
Public Property | OwnerPassword | Gets or sets the owner password.
Public Property | UserPassword | Gets or sets the user password.
Top
See Also

Reference

PdfStandardSecurityHandler Class
Xfinium.Pdf.Core.Security Namespace


EnableAnnotationsAndFieldsEdit Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : EnableAnnotationsAndFieldsEdit Property
Gets or sets a value indicating whether the user can edit the annotations and form fields.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableAnnotationsAndFieldsEdit As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.EnableAnnotationsAndFieldsEdit = value

value = instance.EnableAnnotationsAndFieldsEdit
public bool EnableAnnotationsAndFieldsEdit {get; set;}
public:
property bool EnableAnnotationsAndFieldsEdit {
   bool get();
   void set (    bool value);
}

Property Value

True if the user can edit the annotations and form fields.
Remarks
If true, the user can add or modify text annotations, fill in interactive form fields, and, if property EnableDocumentChange is also set, create or modify interactive form fields (including signature fields).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


EnableContentExtraction Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : EnableContentExtraction Property
Gets or sets a value indicating whether the user can extract the content of the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableContentExtraction As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.EnableContentExtraction = value

value = instance.EnableContentExtraction
public bool EnableContentExtraction {get; set;}
public:
property bool EnableContentExtraction {
   bool get();
   void set (    bool value);
}

Property Value

If true, the user can copy or otherwise extract text and graphics from the document, including extracting text and graphics (in support of accessibility to users with disabilities or for other purposes).
Remarks
If the security handler uses a 128bit key, the user can copy or otherwise extract text and graphics from the document by operations other than that controlled by property EnableContentExtractionForAccessibility.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


EnableContentExtractionForAccessibility Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : EnableContentExtractionForAccessibility Property
Gets or sets a value indicating whether the user can extract the content of the document in support of accessibility.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableContentExtractionForAccessibility As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.EnableContentExtractionForAccessibility = value

value = instance.EnableContentExtractionForAccessibility
public bool EnableContentExtractionForAccessibility {get; set;}
public:
property bool EnableContentExtractionForAccessibility {
   bool get();
   void set (    bool value);
}

Property Value

If true, the user can extract text and graphics (in support of accessibility to users with disabilities or for other purposes).
Remarks
This property is valid only for security handlers that use 128 bit keys.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


EnableDocumentAssembly Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : EnableDocumentAssembly Property
Gets or sets a value indicating whether the user can assemble the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableDocumentAssembly As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.EnableDocumentAssembly = value

value = instance.EnableDocumentAssembly
public bool EnableDocumentAssembly {get; set;}
public:
property bool EnableDocumentAssembly {
   bool get();
   void set (    bool value);
}

Property Value

if true, the user can assemble the document (insert, rotate, or delete pages and create bookmarks or thumbnail images), even property EnableDocumentChange is not set.
Remarks
This property is valid only for security handlers that use 128 bit keys.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


EnableDocumentChange Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : EnableDocumentChange Property
Gets or sets a value indicating whether the user can modify the contents of the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableDocumentChange As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.EnableDocumentChange = value

value = instance.EnableDocumentChange
public bool EnableDocumentChange {get; set;}
public:
property bool EnableDocumentChange {
   bool get();
   void set (    bool value);
}

Property Value

True if the user can modify the document, otherwise false.
Remarks
This property controls the modification of the document contents by operations other than those controlled by properties: EnableAnnotationsAndFieldsEdit, EnableFormsFill, EnableDocumentAssembly.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


EnableFormsFill Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : EnableFormsFill Property
Gets or sets a value indicating whether the user can fill in form fields.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableFormsFill As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.EnableFormsFill = value

value = instance.EnableFormsFill
public bool EnableFormsFill {get; set;}
public:
property bool EnableFormsFill {
   bool get();
   void set (    bool value);
}

Property Value

If true, the user can fill in existing interactive form fields (including signature fields), even if property EnableAnnotationsAndFieldsEdit is not set.
Remarks
This property is valid only for security handlers that use 128 bit keys.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


EnablePrint Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : EnablePrint Property
Gets or sets a value indicating whether the user can print the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnablePrint As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.EnablePrint = value

value = instance.EnablePrint
public bool EnablePrint {get; set;}
public:
property bool EnablePrint {
   bool get();
   void set (    bool value);
}

Property Value

True if the user can print the document, otherwise false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


EncryptMetadata Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : EncryptMetadata Property
Gets or sets a value indicatig whether the document-level metadata stream is to be encrypted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EncryptMetadata As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.EncryptMetadata = value

value = instance.EncryptMetadata
public bool EncryptMetadata {get; set;}
public:
property bool EncryptMetadata {
   bool get();
   void set (    bool value);
}

Property Value

True if the metadata is encrypted, otherwise false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


HighQualityPrint Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : HighQualityPrint Property
Gets or sets a value indicating whether the document is printed in high quality.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HighQualityPrint As Boolean
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Boolean

instance.HighQualityPrint = value

value = instance.HighQualityPrint
public bool HighQualityPrint {get; set;}
public:
property bool HighQualityPrint {
   bool get();
   void set (    bool value);
}

Property Value

True if the document is printed in high quality, otherwise false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


KeySize Property (PdfStandardSecurityHandler)

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : KeySize Property
Gets or sets the size, in bits, of the secret key used by the security handler.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property KeySize As Integer
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As Integer

instance.KeySize = value

value = instance.KeySize
public virtual int KeySize {get; set;}
public:
virtual property int KeySize {
   int get();
   void set (    int value);
}

Property Value

The size, in bits, of the secret key used by the security handler.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


OwnerPassword Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : OwnerPassword Property
Gets or sets the owner password.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OwnerPassword As String
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As String

instance.OwnerPassword = value

value = instance.OwnerPassword
public string OwnerPassword {get; set;}
public:
property String^ OwnerPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

Password required to modofy the security settings of the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


UserPassword Property

Xfinium.Pdf.Core.Security Namespace > PdfStandardSecurityHandler Class : UserPassword Property
Gets or sets the user password.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UserPassword As String
'Usage

Dim instance As PdfStandardSecurityHandler
Dim value As String

instance.UserPassword = value

value = instance.UserPassword
public string UserPassword {get; set;}
public:
property String^ UserPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

Password required to open the file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardSecurityHandler Class
PdfStandardSecurityHandler Members


%%PageItemTitle%%

PdfEncryptionAlgorithm Enumeration

Xfinium.Pdf.Core.Security Namespace : PdfEncryptionAlgorithm Enumeration
The supported PDF encryption algorithms.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfEncryptionAlgorithm
   Inherits System.Enum
'Usage

Dim instance As PdfEncryptionAlgorithm
public enum PdfEncryptionAlgorithm : System.Enum
public enum class PdfEncryptionAlgorithm : public System.Enum
Members
Member | Description
AES | AES encryption.
None | No encryption is used.
RC4 | RC4 encryption.
Unknown | Unknown encryption algorithm.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Core.Security.PdfEncryptionAlgorithm

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Core.Security Namespace


Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | ObfuscationAttribute |
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Attribute
Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper.ObfuscationAttribute
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

ObfuscationAttribute Class
Members

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace : ObfuscationAttribute Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<ObfuscationAttribute()>
<AttributeUsageAttribute(ValidOn=AttributeTargets.Assembly Or  _
    AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Enum Or  _
    AttributeTargets.Method Or  _
    AttributeTargets.Property Or  _
    AttributeTargets.Field Or  _
    AttributeTargets.Event Or  _
    AttributeTargets.Interface Or  _
    AttributeTargets.Parameter Or  _
    AttributeTargets.Delegate,
   AllowMultiple=True,
   Inherited=False)>
Public Class ObfuscationAttribute
   Inherits System.Attribute
'Usage

Dim instance As ObfuscationAttribute
[Obfuscation()]
[AttributeUsage(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate,
   AllowMultiple=true,
   Inherited=false)]
public class ObfuscationAttribute : System.Attribute
[Obfuscation()]
[AttributeUsage(ValidOn=AttributeTargets.Assembly |
    AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Method |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Event |
    AttributeTargets.Interface |
    AttributeTargets.Parameter |
    AttributeTargets.Delegate,
   AllowMultiple=true,
   Inherited=false)]
public ref class ObfuscationAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper.ObfuscationAttribute

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

ObfuscationAttribute Members
Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace


%%PageItemTitle%% $$Members$$

ObfuscationAttribute Class Members
Properties Methods

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace : ObfuscationAttribute Class

The following tables list the members exposed by ObfuscationAttribute.

Public Constructors
 | Name | Description
Public Constructor | ObfuscationAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | ApplyToMembers |
Public Property | Exclude |
Public Property | Feature |
Public Property | StripAfterObfuscation |
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

ObfuscationAttribute Class
Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace


%%PageItemTitle%%

ObfuscationAttribute Constructor

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace > ObfuscationAttribute Class : ObfuscationAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ObfuscationAttribute()
public ObfuscationAttribute()
public:
ObfuscationAttribute();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

ObfuscationAttribute Class
ObfuscationAttribute Members


%%PageItemTitle%% $$Properties$$

ObfuscationAttribute Class Properties

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace : ObfuscationAttribute Class

For a list of all members of this type, see ObfuscationAttribute members.

Public Properties
 | Name | Description
Public Property | ApplyToMembers |
Public Property | Exclude |
Public Property | Feature |
Public Property | StripAfterObfuscation |
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

ObfuscationAttribute Class
Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace


ApplyToMembers Property

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace > ObfuscationAttribute Class : ApplyToMembers Property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ApplyToMembers As Boolean
'Usage

Dim instance As ObfuscationAttribute
Dim value As Boolean

instance.ApplyToMembers = value

value = instance.ApplyToMembers
public bool ApplyToMembers {get; set;}
public:
property bool ApplyToMembers {
   bool get();
   void set (    bool value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

ObfuscationAttribute Class
ObfuscationAttribute Members


Exclude Property

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace > ObfuscationAttribute Class : Exclude Property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Exclude As Boolean
'Usage

Dim instance As ObfuscationAttribute
Dim value As Boolean

instance.Exclude = value

value = instance.Exclude
public bool Exclude {get; set;}
public:
property bool Exclude {
   bool get();
   void set (    bool value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

ObfuscationAttribute Class
ObfuscationAttribute Members


Feature Property

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace > ObfuscationAttribute Class : Feature Property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Feature As String
'Usage

Dim instance As ObfuscationAttribute
Dim value As String

instance.Feature = value

value = instance.Feature
public string Feature {get; set;}
public:
property String^ Feature {
   String^ get();
   void set (    String^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

ObfuscationAttribute Class
ObfuscationAttribute Members


StripAfterObfuscation Property

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace > ObfuscationAttribute Class : StripAfterObfuscation Property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StripAfterObfuscation As Boolean
'Usage

Dim instance As ObfuscationAttribute
Dim value As Boolean

instance.StripAfterObfuscation = value

value = instance.StripAfterObfuscation
public bool StripAfterObfuscation {get; set;}
public:
property bool StripAfterObfuscation {
   bool get();
   void set (    bool value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

ObfuscationAttribute Class
ObfuscationAttribute Members


Xfinium.Pdf.Destinations Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfDestination | Defines an abstract PDF destination
Class | PdfNamedDestination | Defines a PDF named destination.
Class | PdfNamedDestinationCollection | Defines a collection of named destinations.
Class | PdfPageDestination | Defines an abstract destination to a PDF page.
Class | PdfPageDirectDestination | Defines a destination to a PDF page in the current document.
Class | PdfPageNumberDestination | Defines a destination to a PDF page identified by its page number.
Enumerations
 | Enumeration | Description
Enumeration | PdfDestinationType | Supported destination types.
Enumeration | PdfDestinationZoomMode | Supported zoom modes for a destination.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Destinations Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Destinations.PdfNamedDestinationCollection
Xfinium.Pdf.Destinations.PdfDestination
Xfinium.Pdf.Destinations.PdfNamedDestination
Xfinium.Pdf.Destinations.PdfPageDestination
Xfinium.Pdf.Destinations.PdfPageDirectDestination
Xfinium.Pdf.Destinations.PdfPageNumberDestination
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfDestination Class
Members

Xfinium.Pdf.Destinations Namespace : PdfDestination Class
Defines an abstract PDF destination
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfDestination
'Usage

Dim instance As PdfDestination
public abstract class PdfDestination
public ref class PdfDestination abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Destinations.PdfDestination
Xfinium.Pdf.Destinations.PdfNamedDestination
Xfinium.Pdf.Destinations.PdfPageDestination

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDestination Members
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Members$$

PdfDestination Class Members
Properties

Xfinium.Pdf.Destinations Namespace : PdfDestination Class

The following tables list the members exposed by PdfDestination.

Public Properties
 | Name | Description
Public Property | Type | Gets the destination type.
Top
See Also

Reference

PdfDestination Class
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Properties$$

PdfDestination Class Properties

Xfinium.Pdf.Destinations Namespace : PdfDestination Class

For a list of all members of this type, see PdfDestination members.

Public Properties
 | Name | Description
Public Property | Type | Gets the destination type.
Top
See Also

Reference

PdfDestination Class
Xfinium.Pdf.Destinations Namespace


Type Property (PdfDestination)

Xfinium.Pdf.Destinations Namespace > PdfDestination Class : Type Property
Gets the destination type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PdfDestinationType
'Usage

Dim instance As PdfDestination
Dim value As PdfDestinationType

value = instance.Type
public PdfDestinationType Type {get;}
public:
property PdfDestinationType Type {
   PdfDestinationType get();
}

Property Value

A PdfDestinationType that represents the type of the destination.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDestination Class
PdfDestination Members


%%PageItemTitle%%

PdfNamedDestination Class
Members

Xfinium.Pdf.Destinations Namespace : PdfNamedDestination Class
Defines a PDF named destination.
Object Model
PdfNamedDestination ClassPdfDestination Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfNamedDestination
   Inherits PdfDestination
'Usage

Dim instance As PdfNamedDestination
public class PdfNamedDestination : PdfDestination
public ref class PdfNamedDestination : public PdfDestination
Remarks
A named destination associates a name with a destination.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Destinations.PdfDestination
Xfinium.Pdf.Destinations.PdfNamedDestination

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedDestination Members
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Members$$

PdfNamedDestination Class Members
Properties

Xfinium.Pdf.Destinations Namespace : PdfNamedDestination Class

The following tables list the members exposed by PdfNamedDestination.

Public Constructors
 | Name | Description
Public Constructor | PdfNamedDestination Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Destination | Gets or sets the destination.
Public Property | Name | Gets or sets the destination name.
Public Property | Type | Gets the destination type. (Inherited from Xfinium.Pdf.Destinations.PdfDestination)
Top
See Also

Reference

PdfNamedDestination Class
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%%

PdfNamedDestination Constructor

Xfinium.Pdf.Destinations Namespace > PdfNamedDestination Class : PdfNamedDestination Constructor
Overload List
Overload | Description
PdfNamedDestination Constructor() | Initializes a new PdfNamedDestination object.
PdfNamedDestination Constructor(String) | Initializes a new PdfNamedDestination object with the specified name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedDestination Class
PdfNamedDestination Members


%%PageItemTitle%%

PdfNamedDestination Constructor()

Xfinium.Pdf.Destinations Namespace > PdfNamedDestination Class > PdfNamedDestination Constructor : PdfNamedDestination Constructor()
Initializes a new PdfNamedDestination object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfNamedDestination()
public PdfNamedDestination()
public:
PdfNamedDestination();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedDestination Class
PdfNamedDestination Members
Overload List


%%PageItemTitle%%

PdfNamedDestination Constructor(String)

Xfinium.Pdf.Destinations Namespace > PdfNamedDestination Class > PdfNamedDestination Constructor : PdfNamedDestination Constructor(String)
Destination name.
Initializes a new PdfNamedDestination object with the specified name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfNamedDestination(name)
public PdfNamedDestination(
   string name
)
public:
PdfNamedDestination(
   String^ name
)

Parameters

name
Destination name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedDestination Class
PdfNamedDestination Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfNamedDestination Class Properties

Xfinium.Pdf.Destinations Namespace : PdfNamedDestination Class

For a list of all members of this type, see PdfNamedDestination members.

Public Properties
 | Name | Description
Public Property | Destination | Gets or sets the destination.
Public Property | Name | Gets or sets the destination name.
Public Property | Type | Gets the destination type. (Inherited from Xfinium.Pdf.Destinations.PdfDestination)
Top
See Also

Reference

PdfNamedDestination Class
Xfinium.Pdf.Destinations Namespace


Destination Property (PdfNamedDestination)

Xfinium.Pdf.Destinations Namespace > PdfNamedDestination Class : Destination Property
Gets or sets the destination.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Destination As PdfDestination
'Usage

Dim instance As PdfNamedDestination
Dim value As PdfDestination

instance.Destination = value

value = instance.Destination
public PdfDestination Destination {get; set;}
public:
property PdfDestination^ Destination {
   PdfDestination^ get();
   void set (    PdfDestination^ value);
}

Property Value

The actual destination that corresponds to the given name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedDestination Class
PdfNamedDestination Members


Name Property (PdfNamedDestination)

Xfinium.Pdf.Destinations Namespace > PdfNamedDestination Class : Name Property
Gets or sets the destination name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfNamedDestination
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the destination.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedDestination Class
PdfNamedDestination Members


%%PageItemTitle%%

PdfNamedDestinationCollection Class
Members

Xfinium.Pdf.Destinations Namespace : PdfNamedDestinationCollection Class
Defines a collection of named destinations.
Object Model
PdfNamedDestinationCollection ClassPdfNamedDestination Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfNamedDestinationCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfNamedDestination)
'Usage

Dim instance As PdfNamedDestinationCollection
[DefaultMember("Item")]
public class PdfNamedDestinationCollection : System.Collections.ObjectModel.Collection<PdfNamedDestination>
[DefaultMember("Item")]
public ref class PdfNamedDestinationCollection : public System.Collections.ObjectModel.Collection<PdfNamedDestination>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Destinations.PdfNamedDestinationCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedDestinationCollection Members
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Members$$

PdfNamedDestinationCollection Class Members
Properties Methods

Xfinium.Pdf.Destinations Namespace : PdfNamedDestinationCollection Class

The following tables list the members exposed by PdfNamedDestinationCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Property | Item | Gets the destination with the specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Top
See Also

Reference

PdfNamedDestinationCollection Class
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Properties$$

PdfNamedDestinationCollection Class Properties

Xfinium.Pdf.Destinations Namespace : PdfNamedDestinationCollection Class

For a list of all members of this type, see PdfNamedDestinationCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Property | Item | Gets the destination with the specified name.
Top
See Also

Reference

PdfNamedDestinationCollection Class
Xfinium.Pdf.Destinations Namespace


Item Property (PdfNamedDestinationCollection)

Xfinium.Pdf.Destinations Namespace > PdfNamedDestinationCollection Class : Item Property
Name of the destination to retrieve.
Gets the destination with the specified name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal name As String _
) As PdfNamedDestination
'Usage

Dim instance As PdfNamedDestinationCollection
Dim name As String
Dim value As PdfNamedDestination

value = instance.Item(name)
public new PdfNamedDestination this[
   string name
]; {get;}
public:
new property PdfNamedDestination^ default [String^] {
   PdfNamedDestination^ get(String^ name);
}

Parameters

name
Name of the destination to retrieve.

Property Value

The destination with the specified name or null if the name is not found.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedDestinationCollection Class
PdfNamedDestinationCollection Members


%%PageItemTitle%%

PdfPageDestination Class
Members

Xfinium.Pdf.Destinations Namespace : PdfPageDestination Class
Defines an abstract destination to a PDF page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfPageDestination
   Inherits PdfDestination
'Usage

Dim instance As PdfPageDestination
public abstract class PdfPageDestination : PdfDestination
public ref class PdfPageDestination abstract : public PdfDestination
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Destinations.PdfDestination
Xfinium.Pdf.Destinations.PdfPageDestination
Xfinium.Pdf.Destinations.PdfPageDirectDestination
Xfinium.Pdf.Destinations.PdfPageNumberDestination

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDestination Members
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Members$$

PdfPageDestination Class Members
Properties

Xfinium.Pdf.Destinations Namespace : PdfPageDestination Class

The following tables list the members exposed by PdfPageDestination.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate.
Public Property | Left | Gets or sets the left coordinate.
Public Property | Right | Gets or sets the right coordinate.
Public Property | Top | Gets or sets the top coordinate.
Public Property | Type | Gets the destination type. (Inherited from Xfinium.Pdf.Destinations.PdfDestination)
Public Property | Zoom | Gets or sets the zoom.
Public Property | ZoomMode | Gets or sets the zoom mode.
Top
See Also

Reference

PdfPageDestination Class
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Properties$$

PdfPageDestination Class Properties

Xfinium.Pdf.Destinations Namespace : PdfPageDestination Class

For a list of all members of this type, see PdfPageDestination members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate.
Public Property | Left | Gets or sets the left coordinate.
Public Property | Right | Gets or sets the right coordinate.
Public Property | Top | Gets or sets the top coordinate.
Public Property | Type | Gets the destination type. (Inherited from Xfinium.Pdf.Destinations.PdfDestination)
Public Property | Zoom | Gets or sets the zoom.
Public Property | ZoomMode | Gets or sets the zoom mode.
Top
See Also

Reference

PdfPageDestination Class
Xfinium.Pdf.Destinations Namespace


Bottom Property (PdfPageDestination)

Xfinium.Pdf.Destinations Namespace > PdfPageDestination Class : Bottom Property
Gets or sets the bottom coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Bottom As Double
'Usage

Dim instance As PdfPageDestination
Dim value As Double

instance.Bottom = value

value = instance.Bottom
public double Bottom {get; set;}
public:
property double Bottom {
   double get();
   void set (    double value);
}

Property Value

Bottom coordinate of the page positioned at the bottom edge of the window.
Remarks
The bottom coordinate is used by PdfDestinationZoomMode.FitR zoom mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDestination Class
PdfPageDestination Members


Left Property (PdfPageDestination)

Xfinium.Pdf.Destinations Namespace > PdfPageDestination Class : Left Property
Gets or sets the left coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As PdfPageDestination
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

Left coordinate of the page positioned at the left edge of the window.
Remarks
These zoom modes use the left coordinate: PdfDestinationZoomMode.XYZ, PdfDestinationZoomMode.FitV, PdfDestinationZoomMode.FitR, PdfDestinationZoomMode.FitBV
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDestination Class
PdfPageDestination Members


Right Property (PdfPageDestination)

Xfinium.Pdf.Destinations Namespace > PdfPageDestination Class : Right Property
Gets or sets the right coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Right As Double
'Usage

Dim instance As PdfPageDestination
Dim value As Double

instance.Right = value

value = instance.Right
public double Right {get; set;}
public:
property double Right {
   double get();
   void set (    double value);
}

Property Value

Right coordinate of the page positioned at the right edge of the window.
Remarks
The right coordinate is used by PdfDestinationZoomMode.FitR zoom mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDestination Class
PdfPageDestination Members


Top Property (PdfPageDestination)

Xfinium.Pdf.Destinations Namespace > PdfPageDestination Class : Top Property
Gets or sets the top coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Top As Double
'Usage

Dim instance As PdfPageDestination
Dim value As Double

instance.Top = value

value = instance.Top
public virtual double Top {get; set;}
public:
virtual property double Top {
   double get();
   void set (    double value);
}

Property Value

Top coordinate of the page positioned at the top edge of the window.
Remarks
These zoom modes use the top coordinate: PdfDestinationZoomMode.XYZ, PdfDestinationZoomMode.FitH, PdfDestinationZoomMode.FitR, PdfDestinationZoomMode.FitBH
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDestination Class
PdfPageDestination Members


Zoom Property

Xfinium.Pdf.Destinations Namespace > PdfPageDestination Class : Zoom Property
Gets or sets the zoom.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Zoom As Double
'Usage

Dim instance As PdfPageDestination
Dim value As Double

instance.Zoom = value

value = instance.Zoom
public double Zoom {get; set;}
public:
property double Zoom {
   double get();
   void set (    double value);
}

Property Value

Zoom value (percentage) applied to destination page.
Remarks
A 0 zoom means the current zoom value does not change.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDestination Class
PdfPageDestination Members


ZoomMode Property

Xfinium.Pdf.Destinations Namespace > PdfPageDestination Class : ZoomMode Property
Gets or sets the zoom mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ZoomMode As PdfDestinationZoomMode
'Usage

Dim instance As PdfPageDestination
Dim value As PdfDestinationZoomMode

instance.ZoomMode = value

value = instance.ZoomMode
public PdfDestinationZoomMode ZoomMode {get; set;}
public:
property PdfDestinationZoomMode ZoomMode {
   PdfDestinationZoomMode get();
   void set (    PdfDestinationZoomMode value);
}

Property Value

A PdfDestinationZoomMode that represents how the destination page is zoomed when the destination is executed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDestination Class
PdfPageDestination Members


%%PageItemTitle%%

PdfPageDirectDestination Class
Members

Xfinium.Pdf.Destinations Namespace : PdfPageDirectDestination Class
Defines a destination to a PDF page in the current document.
Object Model
PdfPageDirectDestination ClassPdfPage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageDirectDestination
   Inherits PdfPageDestination
'Usage

Dim instance As PdfPageDirectDestination
public class PdfPageDirectDestination : PdfPageDestination
public ref class PdfPageDirectDestination : public PdfPageDestination
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Destinations.PdfDestination
Xfinium.Pdf.Destinations.PdfPageDestination
Xfinium.Pdf.Destinations.PdfPageDirectDestination

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDirectDestination Members
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Members$$

PdfPageDirectDestination Class Members
Properties

Xfinium.Pdf.Destinations Namespace : PdfPageDirectDestination Class

The following tables list the members exposed by PdfPageDirectDestination.

Public Constructors
 | Name | Description
Public Constructor | PdfPageDirectDestination Constructor | Initializes a new PdfPageDirectDestination object.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Left | Gets or sets the left coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Page | Gets or sets the page.
Public Property | Right | Gets or sets the right coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Top | Overridden. Gets or sets the top coordinate.
Public Property | Type | Gets the destination type. (Inherited from Xfinium.Pdf.Destinations.PdfDestination)
Public Property | Zoom | Gets or sets the zoom. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | ZoomMode | Gets or sets the zoom mode. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Top
See Also

Reference

PdfPageDirectDestination Class
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%%

PdfPageDirectDestination Constructor

Xfinium.Pdf.Destinations Namespace > PdfPageDirectDestination Class : PdfPageDirectDestination Constructor
Initializes a new PdfPageDirectDestination object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPageDirectDestination()
public PdfPageDirectDestination()
public:
PdfPageDirectDestination();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDirectDestination Class
PdfPageDirectDestination Members


%%PageItemTitle%% $$Properties$$

PdfPageDirectDestination Class Properties

Xfinium.Pdf.Destinations Namespace : PdfPageDirectDestination Class

For a list of all members of this type, see PdfPageDirectDestination members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Left | Gets or sets the left coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Page | Gets or sets the page.
Public Property | Right | Gets or sets the right coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Top | Overridden. Gets or sets the top coordinate.
Public Property | Type | Gets the destination type. (Inherited from Xfinium.Pdf.Destinations.PdfDestination)
Public Property | Zoom | Gets or sets the zoom. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | ZoomMode | Gets or sets the zoom mode. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Top
See Also

Reference

PdfPageDirectDestination Class
Xfinium.Pdf.Destinations Namespace


Page Property (PdfPageDirectDestination)

Xfinium.Pdf.Destinations Namespace > PdfPageDirectDestination Class : Page Property
Gets or sets the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Page As PdfPage
'Usage

Dim instance As PdfPageDirectDestination
Dim value As PdfPage

instance.Page = value

value = instance.Page
public PdfPage Page {get; set;}
public:
property PdfPage^ Page {
   PdfPage^ get();
   void set (    PdfPage^ value);
}

Property Value

A Xfinium.Pdf.PdfPage that represent the page to be displayed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDirectDestination Class
PdfPageDirectDestination Members


Top Property (PdfPageDirectDestination)

Xfinium.Pdf.Destinations Namespace > PdfPageDirectDestination Class : Top Property
Gets or sets the top coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Top As Double
'Usage

Dim instance As PdfPageDirectDestination
Dim value As Double

instance.Top = value

value = instance.Top
public override double Top {get; set;}
public:
property double Top {
   double get() override;
   void set (    double value) override;
}

Property Value

Top coordinate of the page positioned at the top edge of the window.
Remarks
These zoom modes use the top coordinate: PdfDestinationZoomMode.XYZ, PdfDestinationZoomMode.FitH, PdfDestinationZoomMode.FitR, PdfDestinationZoomMode.FitBH
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDirectDestination Class
PdfPageDirectDestination Members


%%PageItemTitle%%

PdfPageNumberDestination Class
Members

Xfinium.Pdf.Destinations Namespace : PdfPageNumberDestination Class
Defines a destination to a PDF page identified by its page number.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageNumberDestination
   Inherits PdfPageDestination
'Usage

Dim instance As PdfPageNumberDestination
public class PdfPageNumberDestination : PdfPageDestination
public ref class PdfPageNumberDestination : public PdfPageDestination
Remarks
The destination page can be located in the current document or in a remote document.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Destinations.PdfDestination
Xfinium.Pdf.Destinations.PdfPageDestination
Xfinium.Pdf.Destinations.PdfPageNumberDestination

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageNumberDestination Members
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%% $$Members$$

PdfPageNumberDestination Class Members
Properties

Xfinium.Pdf.Destinations Namespace : PdfPageNumberDestination Class

The following tables list the members exposed by PdfPageNumberDestination.

Public Constructors
 | Name | Description
Public Constructor | PdfPageNumberDestination Constructor | Initializes a new PdfPageNumberDestination object.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Left | Gets or sets the left coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | PageNumber | Gets or sets the page number.
Public Property | Right | Gets or sets the right coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Top | Gets or sets the top coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Type | Gets the destination type. (Inherited from Xfinium.Pdf.Destinations.PdfDestination)
Public Property | Zoom | Gets or sets the zoom. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | ZoomMode | Gets or sets the zoom mode. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Top
See Also

Reference

PdfPageNumberDestination Class
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%%

PdfPageNumberDestination Constructor

Xfinium.Pdf.Destinations Namespace > PdfPageNumberDestination Class : PdfPageNumberDestination Constructor
Initializes a new PdfPageNumberDestination object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPageNumberDestination()
public PdfPageNumberDestination()
public:
PdfPageNumberDestination();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageNumberDestination Class
PdfPageNumberDestination Members


%%PageItemTitle%% $$Properties$$

PdfPageNumberDestination Class Properties

Xfinium.Pdf.Destinations Namespace : PdfPageNumberDestination Class

For a list of all members of this type, see PdfPageNumberDestination members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Left | Gets or sets the left coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | PageNumber | Gets or sets the page number.
Public Property | Right | Gets or sets the right coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Top | Gets or sets the top coordinate. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | Type | Gets the destination type. (Inherited from Xfinium.Pdf.Destinations.PdfDestination)
Public Property | Zoom | Gets or sets the zoom. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Public Property | ZoomMode | Gets or sets the zoom mode. (Inherited from Xfinium.Pdf.Destinations.PdfPageDestination)
Top
See Also

Reference

PdfPageNumberDestination Class
Xfinium.Pdf.Destinations Namespace


PageNumber Property

Xfinium.Pdf.Destinations Namespace > PdfPageNumberDestination Class : PageNumber Property
Gets or sets the page number.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As PdfPageNumberDestination
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

The number identifying the PDF page in the document.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value is less than 0.
Remarks
First page in the document is 0.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageNumberDestination Class
PdfPageNumberDestination Members


%%PageItemTitle%%

PdfDestinationType Enumeration

Xfinium.Pdf.Destinations Namespace : PdfDestinationType Enumeration
Supported destination types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfDestinationType
   Inherits System.Enum
'Usage

Dim instance As PdfDestinationType
public enum PdfDestinationType : System.Enum
public enum class PdfDestinationType : public System.Enum
Members
Member | Description
NamedDestination | A named destination.
PageDestination | A destination to a page identified by a Xfinium.Pdf.PdfPage.
PageNumberDestination | A destination to a page identified by its page number.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Destinations.PdfDestinationType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%%

PdfDestinationZoomMode Enumeration

Xfinium.Pdf.Destinations Namespace : PdfDestinationZoomMode Enumeration
Supported zoom modes for a destination.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfDestinationZoomMode
   Inherits System.Enum
'Usage

Dim instance As PdfDestinationZoomMode
public enum PdfDestinationZoomMode : System.Enum
public enum class PdfDestinationZoomMode : public System.Enum
Members
Member | Description
Fit | Display the destination page, with its contents magnified just enough to fit the entire page within the window both horizontally and vertically.
FitB | Display the destination page, with its contents magnified just enough to fit its bounding box entirely within the window both horizontally and vertically.
FitBH | Display the destination page, with the vertical coordinate PdfPageDestination.Top positioned at the top edge of the window and the contents of the page magnified just enough to fit the entire width of its bounding box within the window.
FitBV | Display the destination page, with the horizontal coordinate PdfPageDestination.Left positioned at the left edge of the window and the contents of the page magnified just enough to fit the entire height of its bounding box within the window.
FitH | Display the destination page, with the vertical coordinate PdfPageDestination.Top positioned at the top edge of the window and the contents of the page magnified just enough to fit the entire width of the page within the window.
FitR | Display the destination page, with its contents magnified just enough to fit the rectangle specified by the coordinates PdfPageDestination.Left, PdfPageDestination.Bottom, PdfPageDestination.Right, and PdfPageDestination.Top entirely within the window both horizontally and vertically.
FitV | Display the destination page, with the horizontal coordinate PdfPageDestination.Left positioned at the left edge of the window and the contents of the page magnified just enough to fit the entire height of the page within the window.
XYZ | Display the destination page, with the coordinates (PdfPageDestination.Left, PdfPageDestination.Top) positioned at the upper-left corner of the window and the contents of the page magnified by the factor PdfPageDestination.Zoom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Destinations.PdfDestinationZoomMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Destinations Namespace


Xfinium.Pdf.FlowDocument Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfFlowAnnotationContent | Defines an annotation content that can be added to a flow document.
Class | PdfFlowContent | Defines the base class for all flow content types.
Class | PdfFlowContentBorders | Defines the borders (top, right, bottom, left) for a flow content element.
Class | PdfFlowContentCollection | Defines a collection of flow content in a table.
Class | PdfFlowContentDrawEventArgs | Defines the event arguments for flow content drawing related events.
Class | PdfFlowContentMargins | Defines the margins for flow content.
Class | PdfFlowDocument | Defines a PDF document that formats flow content.
Class | PdfFlowDocumentDefaults | Defines default values for a flow document.
Class | PdfFlowDocumentFooter | Defines the footer for a flow document.
Class | PdfFlowDocumentHeader | Defines the header for a flow document.
Class | PdfFlowDocumentHeadersFooters | Defines the headers and footers for a flow document.
Class | PdfFlowDocumentTOCSettings | Defines the settings for creating the table of contents in a flow document.
Class | PdfFlowFormXObjectContent | Defines a form XObject content that can be added to a flow document.
Class | PdfFlowHeadingContent | Defines a heading in a flow document.
Class | PdfFlowImageContent | Defines an image content that can be added to a flow document.
Class | PdfFlowPageCreatedEventArgs | Defines the event arguments for PdfFlowDocument.PageCreated event.
Class | PdfFlowPageDefaults | Defines default values for initializing a page in flow mode.
Class | PdfFlowPageEventArgs | Defines the event arguments for page related events.
Class | PdfFlowTableCell | Defines the base class for cells in a table.
Class | PdfFlowTableCellCollection | Defines a collection of cells in a table row.
Class | PdfFlowTableColumn | Defines a column in a PdfFlowTableContent object.
Class | PdfFlowTableCompositeCell | Defines a cell that contains variable flow content.
Class | PdfFlowTableContent | Defines a table that can be added to a flow document.
Class | PdfFlowTableFormXObjectCell | Defines a cell that contains a Xfinium.Pdf.Graphics.PdfFormXObject instance.
Class | PdfFlowTableImageCell | Defines a cell that contains an image.
Class | PdfFlowTableRow | Defines the base class for rows in a table.
Class | PdfFlowTableRowCollection | Defines a collection of rows in a table.
Class | PdfFlowTableStringCell | Defines a cell that contains a string.
Class | PdfFlowTextContent | Defines a text content that can be added to a flow document.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.FlowDocument Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.FlowDocument.PdfFlowContentCollection
Xfinium.Pdf.FlowDocument.PdfFlowTableCellCollection
Xfinium.Pdf.FlowDocument.PdfFlowTableRowCollection
System.EventArgs
Xfinium.Pdf.FlowDocument.PdfFlowContentDrawEventArgs
Xfinium.Pdf.FlowDocument.PdfFlowPageEventArgs
Xfinium.Pdf.FlowDocument.PdfFlowPageCreatedEventArgs
Xfinium.Pdf.FlowDocument.PdfFlowContent
Xfinium.Pdf.FlowDocument.PdfFlowAnnotationContent
Xfinium.Pdf.FlowDocument.PdfFlowFormXObjectContent
Xfinium.Pdf.FlowDocument.PdfFlowImageContent
Xfinium.Pdf.FlowDocument.PdfFlowTableContent
Xfinium.Pdf.FlowDocument.PdfFlowTextContent
Xfinium.Pdf.FlowDocument.PdfFlowHeadingContent
Xfinium.Pdf.FlowDocument.PdfFlowContentBorders
Xfinium.Pdf.FlowDocument.PdfFlowContentMargins
Xfinium.Pdf.FlowDocument.PdfFlowDocumentDefaults
Xfinium.Pdf.FlowDocument.PdfFlowDocumentFooter
Xfinium.Pdf.FlowDocument.PdfFlowDocumentHeader
Xfinium.Pdf.FlowDocument.PdfFlowDocumentHeadersFooters
Xfinium.Pdf.FlowDocument.PdfFlowDocumentTOCSettings
Xfinium.Pdf.FlowDocument.PdfFlowPageDefaults
Xfinium.Pdf.FlowDocument.PdfFlowTableCell
Xfinium.Pdf.FlowDocument.PdfFlowTableCompositeCell
Xfinium.Pdf.FlowDocument.PdfFlowTableFormXObjectCell
Xfinium.Pdf.FlowDocument.PdfFlowTableImageCell
Xfinium.Pdf.FlowDocument.PdfFlowTableStringCell
Xfinium.Pdf.FlowDocument.PdfFlowTableColumn
Xfinium.Pdf.FlowDocument.PdfFlowTableRow
Xfinium.Pdf.PdfDocument
Xfinium.Pdf.FlowDocument.PdfFlowDocument
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfFlowAnnotationContent Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowAnnotationContent Class
Defines an annotation content that can be added to a flow document.
Object Model
PdfFlowAnnotationContent ClassPdfBrush ClassPdfFlowContentMargins ClassPdfFlowContentMargins Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowAnnotationContent
   Inherits PdfFlowContent
'Usage

Dim instance As PdfFlowAnnotationContent
public class PdfFlowAnnotationContent : PdfFlowContent
public ref class PdfFlowAnnotationContent : public PdfFlowContent
Remarks
This type of flow content lets you insert annotations in a flow document.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContent
Xfinium.Pdf.FlowDocument.PdfFlowAnnotationContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowAnnotationContent Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowAnnotationContent Class

The following tables list the members exposed by PdfFlowAnnotationContent.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowAnnotationContent Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AnnotationHeight | Gets or sets the annotation height.
Public Property | AnnotationWidth | Gets or sets the annotation width.
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | SizeIsRelativeToAvailableSpace | Gets or sets a value indicating how the annotation size is interpreted.
Public Property | VerticalAlign | Gets or sets the vertical align.
Top
See Also

Reference

PdfFlowAnnotationContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowAnnotationContent Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowAnnotationContent Class : PdfFlowAnnotationContent Constructor
Overload List
Overload | Description
PdfFlowAnnotationContent Constructor(PdfAnnotation) | Initializes a new PdfFlowAnnotationContent object.
PdfFlowAnnotationContent Constructor(PdfAnnotation,Double,Double) | Initializes a new PdfFlowAnnotationContent object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Class
PdfFlowAnnotationContent Members


%%PageItemTitle%%

PdfFlowAnnotationContent Constructor(PdfAnnotation)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowAnnotationContent Class > PdfFlowAnnotationContent Constructor : PdfFlowAnnotationContent Constructor(PdfAnnotation)
Annotation to draw in the document.
Initializes a new PdfFlowAnnotationContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal annotation As PdfAnnotation _
)
'Usage

Dim annotation As PdfAnnotation

Dim instance As New PdfFlowAnnotationContent(annotation)
public PdfFlowAnnotationContent(
   PdfAnnotation annotation
)
public:
PdfFlowAnnotationContent(
   PdfAnnotation^ annotation
)

Parameters

annotation
Annotation to draw in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Class
PdfFlowAnnotationContent Members
Overload List


%%PageItemTitle%%

PdfFlowAnnotationContent Constructor(PdfAnnotation,Double,Double)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowAnnotationContent Class > PdfFlowAnnotationContent Constructor : PdfFlowAnnotationContent Constructor(PdfAnnotation,Double,Double)
Annotation to draw in the document.
Width of displayed annotation.
Height of displayed annotation.
Initializes a new PdfFlowAnnotationContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal annotation As PdfAnnotation, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim annotation As PdfAnnotation
Dim width As Double
Dim height As Double

Dim instance As New PdfFlowAnnotationContent(annotation, width, height)
public PdfFlowAnnotationContent(
   PdfAnnotation annotation,
   double width,
   double height
)
public:
PdfFlowAnnotationContent(
   PdfAnnotation^ annotation,
   double width,
   double height
)

Parameters

annotation
Annotation to draw in the document.
width
Width of displayed annotation.
height
Height of displayed annotation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Class
PdfFlowAnnotationContent Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowAnnotationContent Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowAnnotationContent Class

For a list of all members of this type, see PdfFlowAnnotationContent members.

Public Properties
 | Name | Description
Public Property | AnnotationHeight | Gets or sets the annotation height.
Public Property | AnnotationWidth | Gets or sets the annotation width.
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | SizeIsRelativeToAvailableSpace | Gets or sets a value indicating how the annotation size is interpreted.
Public Property | VerticalAlign | Gets or sets the vertical align.
Top
See Also

Reference

PdfFlowAnnotationContent Class
Xfinium.Pdf.FlowDocument Namespace


AnnotationHeight Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowAnnotationContent Class : AnnotationHeight Property
Gets or sets the annotation height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AnnotationHeight As Double
'Usage

Dim instance As PdfFlowAnnotationContent
Dim value As Double

instance.AnnotationHeight = value

value = instance.AnnotationHeight
public double AnnotationHeight {get; set;}
public:
property double AnnotationHeight {
   double get();
   void set (    double value);
}

Property Value

The height of the annotation drawn on the page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when Height is set to a value less than 0.
Remarks
The value of this property represents either a percentage (0 to 100) or an absolute value based on the value of SizeIsRelativeToAvailableSpace property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Class
PdfFlowAnnotationContent Members


AnnotationWidth Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowAnnotationContent Class : AnnotationWidth Property
Gets or sets the annotation width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AnnotationWidth As Double
'Usage

Dim instance As PdfFlowAnnotationContent
Dim value As Double

instance.AnnotationWidth = value

value = instance.AnnotationWidth
public double AnnotationWidth {get; set;}
public:
property double AnnotationWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the annotation drawn on the page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when Width is set to a value less than 0.
Remarks
The value of this property represents either a percentage (0 to 100) or an absolute value based on the value of SizeIsRelativeToAvailableSpace property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Class
PdfFlowAnnotationContent Members


HorizontalAlign Property (PdfFlowAnnotationContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowAnnotationContent Class : HorizontalAlign Property
Gets or sets the horizontal align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowAnnotationContent
Dim value As PdfGraphicAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
public PdfGraphicAlign HorizontalAlign {get; set;}
public:
property PdfGraphicAlign HorizontalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The annotation alignment on horizontal relative to available space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Class
PdfFlowAnnotationContent Members


SizeIsRelativeToAvailableSpace Property (PdfFlowAnnotationContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowAnnotationContent Class : SizeIsRelativeToAvailableSpace Property
Gets or sets a value indicating how the annotation size is interpreted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SizeIsRelativeToAvailableSpace As Boolean
'Usage

Dim instance As PdfFlowAnnotationContent
Dim value As Boolean

instance.SizeIsRelativeToAvailableSpace = value

value = instance.SizeIsRelativeToAvailableSpace
public bool SizeIsRelativeToAvailableSpace {get; set;}
public:
property bool SizeIsRelativeToAvailableSpace {
   bool get();
   void set (    bool value);
}

Property Value

True if the annotation size (AnnotationWidth, AnnotationHeight properties) is a percentage of the available space, false is the annotation size is given in absolute values.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Class
PdfFlowAnnotationContent Members


VerticalAlign Property (PdfFlowAnnotationContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowAnnotationContent Class : VerticalAlign Property
Gets or sets the vertical align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VerticalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowAnnotationContent
Dim value As PdfGraphicAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
public PdfGraphicAlign VerticalAlign {get; set;}
public:
property PdfGraphicAlign VerticalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The annotation alignment on vertical relative to available space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowAnnotationContent Class
PdfFlowAnnotationContent Members


%%PageItemTitle%%

PdfFlowContent Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContent Class
Defines the base class for all flow content types.
Object Model
PdfFlowContent ClassPdfBrush ClassPdfFlowContentMargins ClassPdfFlowContentMargins Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfFlowContent
'Usage

Dim instance As PdfFlowContent
public abstract class PdfFlowContent
public ref class PdfFlowContent abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContent
Xfinium.Pdf.FlowDocument.PdfFlowAnnotationContent
Xfinium.Pdf.FlowDocument.PdfFlowFormXObjectContent
Xfinium.Pdf.FlowDocument.PdfFlowImageContent
Xfinium.Pdf.FlowDocument.PdfFlowTableContent
Xfinium.Pdf.FlowDocument.PdfFlowTextContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContent Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowContent Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContent Class

The following tables list the members exposed by PdfFlowContent.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background.
Public Property | DestinationName | Gets or sets the destination name.
Public Property | InnerMargins | Gets or sets the content inner margins.
Public Property | OuterMargins | Gets or sets the content outer margins.
Top
See Also

Reference

PdfFlowContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowContent Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContent Class

For a list of all members of this type, see PdfFlowContent members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background.
Public Property | DestinationName | Gets or sets the destination name.
Public Property | InnerMargins | Gets or sets the content inner margins.
Public Property | OuterMargins | Gets or sets the content outer margins.
Top
See Also

Reference

PdfFlowContent Class
Xfinium.Pdf.FlowDocument Namespace


Background Property (PdfFlowContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContent Class : Background Property
Gets or sets the content background.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Background As PdfBrush
'Usage

Dim instance As PdfFlowContent
Dim value As PdfBrush

instance.Background = value

value = instance.Background
public PdfBrush Background {get; set;}
public:
property PdfBrush^ Background {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

The background of the flow content.
Remarks
The background that fills the flow content bounding rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContent Class
PdfFlowContent Members


DestinationName Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContent Class : DestinationName Property
Gets or sets the destination name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DestinationName As String
'Usage

Dim instance As PdfFlowContent
Dim value As String

instance.DestinationName = value

value = instance.DestinationName
public string DestinationName {get; set;}
public:
property String^ DestinationName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the destination created at the location of the flow content.
Remarks
A named destination is created at the top of flow content when this property is not null or an empty string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContent Class
PdfFlowContent Members


InnerMargins Property (PdfFlowContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContent Class : InnerMargins Property
Gets or sets the content inner margins.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InnerMargins As PdfFlowContentMargins
'Usage

Dim instance As PdfFlowContent
Dim value As PdfFlowContentMargins

instance.InnerMargins = value

value = instance.InnerMargins
public PdfFlowContentMargins InnerMargins {get; set;}
public:
property PdfFlowContentMargins^ InnerMargins {
   PdfFlowContentMargins^ get();
   void set (    PdfFlowContentMargins^ value);
}

Property Value

A PdfFlowContentMargins object specifying the content inner margins.
Remarks
The inner margins are located inside the content's bounding rectangle. The margins are applied to content as a whole and not to parts of content when content is split across pages.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContent Class
PdfFlowContent Members


OuterMargins Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContent Class : OuterMargins Property
Gets or sets the content outer margins.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OuterMargins As PdfFlowContentMargins
'Usage

Dim instance As PdfFlowContent
Dim value As PdfFlowContentMargins

instance.OuterMargins = value

value = instance.OuterMargins
public PdfFlowContentMargins OuterMargins {get; set;}
public:
property PdfFlowContentMargins^ OuterMargins {
   PdfFlowContentMargins^ get();
   void set (    PdfFlowContentMargins^ value);
}

Property Value

A PdfFlowContentMargins object specifying the content outer margins.
Remarks
The inner margins are located outside the content's bounding rectangle. The margins are applied to content as a whole and not to parts of content when content is split across pages.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContent Class
PdfFlowContent Members


%%PageItemTitle%%

PdfFlowContentBorders Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentBorders Class
Defines the borders (top, right, bottom, left) for a flow content element.
Object Model
PdfFlowContentBorders ClassPdfPen ClassPdfPen ClassPdfPen ClassPdfPen Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowContentBorders
'Usage

Dim instance As PdfFlowContentBorders
public class PdfFlowContentBorders
public ref class PdfFlowContentBorders
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContentBorders

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowContentBorders Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentBorders Class

The following tables list the members exposed by PdfFlowContentBorders.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowContentBorders Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom border.
Public Property | Left | Gets or sets the left border.
Public Property | Right | Gets or sets the right border.
Public Property | Top | Gets or sets the top border.
Top
See Also

Reference

PdfFlowContentBorders Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowContentBorders Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentBorders Class : PdfFlowContentBorders Constructor
Overload List
Overload | Description
PdfFlowContentBorders Constructor() | Initializes a new PdfFlowContentBorders object.
PdfFlowContentBorders Constructor(PdfFlowContentBorders) | Initializes a new PdfFlowContentBorders object with another border.
PdfFlowContentBorders Constructor(PdfPen) | Initializes a new PdfFlowContentBorders object with the specified border.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Class
PdfFlowContentBorders Members


%%PageItemTitle%%

PdfFlowContentBorders Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentBorders Class > PdfFlowContentBorders Constructor : PdfFlowContentBorders Constructor()
Initializes a new PdfFlowContentBorders object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowContentBorders()
public PdfFlowContentBorders()
public:
PdfFlowContentBorders();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Class
PdfFlowContentBorders Members
Overload List


%%PageItemTitle%%

PdfFlowContentBorders Constructor(PdfFlowContentBorders)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentBorders Class > PdfFlowContentBorders Constructor : PdfFlowContentBorders Constructor(PdfFlowContentBorders)
Source border to copy.
Initializes a new PdfFlowContentBorders object with another border.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFlowContentBorders _
)
'Usage

Dim source As PdfFlowContentBorders

Dim instance As New PdfFlowContentBorders(source)
public PdfFlowContentBorders(
   PdfFlowContentBorders source
)
public:
PdfFlowContentBorders(
   PdfFlowContentBorders^ source
)

Parameters

source
Source border to copy.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Class
PdfFlowContentBorders Members
Overload List


%%PageItemTitle%%

PdfFlowContentBorders Constructor(PdfPen)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentBorders Class > PdfFlowContentBorders Constructor : PdfFlowContentBorders Constructor(PdfPen)
The initial cell border.
Initializes a new PdfFlowContentBorders object with the specified border.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal border As PdfPen _
)
'Usage

Dim border As PdfPen

Dim instance As New PdfFlowContentBorders(border)
public PdfFlowContentBorders(
   PdfPen border
)
public:
PdfFlowContentBorders(
   PdfPen^ border
)

Parameters

border
The initial cell border.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Class
PdfFlowContentBorders Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowContentBorders Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentBorders Class

For a list of all members of this type, see PdfFlowContentBorders members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom border.
Public Property | Left | Gets or sets the left border.
Public Property | Right | Gets or sets the right border.
Public Property | Top | Gets or sets the top border.
Top
See Also

Reference

PdfFlowContentBorders Class
Xfinium.Pdf.FlowDocument Namespace


Bottom Property (PdfFlowContentBorders)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentBorders Class : Bottom Property
Gets or sets the bottom border.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Bottom As PdfPen
'Usage

Dim instance As PdfFlowContentBorders
Dim value As PdfPen

instance.Bottom = value

value = instance.Bottom
public PdfPen Bottom {get; set;}
public:
property PdfPen^ Bottom {
   PdfPen^ get();
   void set (    PdfPen^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfPen object that describes how the bottom border is drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Class
PdfFlowContentBorders Members


Left Property (PdfFlowContentBorders)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentBorders Class : Left Property
Gets or sets the left border.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Left As PdfPen
'Usage

Dim instance As PdfFlowContentBorders
Dim value As PdfPen

instance.Left = value

value = instance.Left
public PdfPen Left {get; set;}
public:
property PdfPen^ Left {
   PdfPen^ get();
   void set (    PdfPen^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfPen object that describes how the left border is drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Class
PdfFlowContentBorders Members


Right Property (PdfFlowContentBorders)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentBorders Class : Right Property
Gets or sets the right border.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Right As PdfPen
'Usage

Dim instance As PdfFlowContentBorders
Dim value As PdfPen

instance.Right = value

value = instance.Right
public PdfPen Right {get; set;}
public:
property PdfPen^ Right {
   PdfPen^ get();
   void set (    PdfPen^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfPen object that describes how the right border is drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Class
PdfFlowContentBorders Members


Top Property (PdfFlowContentBorders)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentBorders Class : Top Property
Gets or sets the top border.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Top As PdfPen
'Usage

Dim instance As PdfFlowContentBorders
Dim value As PdfPen

instance.Top = value

value = instance.Top
public PdfPen Top {get; set;}
public:
property PdfPen^ Top {
   PdfPen^ get();
   void set (    PdfPen^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfPen object that describes how the top border is drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentBorders Class
PdfFlowContentBorders Members


%%PageItemTitle%%

PdfFlowContentCollection Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentCollection Class
Defines a collection of flow content in a table.
Object Model
PdfFlowContentCollection ClassPdfFlowContent Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowContentCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfFlowContent)
'Usage

Dim instance As PdfFlowContentCollection
public class PdfFlowContentCollection : System.Collections.ObjectModel.Collection<PdfFlowContent>
public ref class PdfFlowContentCollection : public System.Collections.ObjectModel.Collection<PdfFlowContent>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.FlowDocument.PdfFlowContentCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentCollection Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowContentCollection Class Members
Properties Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentCollection Class

The following tables list the members exposed by PdfFlowContentCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Top
See Also

Reference

PdfFlowContentCollection Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowContentDrawEventArgs Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentDrawEventArgs Class
Defines the event arguments for flow content drawing related events.
Object Model
PdfFlowContentDrawEventArgs ClassPdfFlowContent ClassPdfVisualRectangle ClassPdfVisualRectangle ClassPdfVisualRectangle ClassPdfPage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowContentDrawEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PdfFlowContentDrawEventArgs
public class PdfFlowContentDrawEventArgs : System.EventArgs
public ref class PdfFlowContentDrawEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Xfinium.Pdf.FlowDocument.PdfFlowContentDrawEventArgs

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentDrawEventArgs Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowContentDrawEventArgs Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentDrawEventArgs Class

The following tables list the members exposed by PdfFlowContentDrawEventArgs.

Public Properties
 | Name | Description
Public Property | Content | Gets the content being drawn.
Public Property | ContentBounds | Gets the content bounds.
Public Property | ContentInnerBounds | Gets the content inner bounds.
Public Property | ContentOuterBounds | Gets the content outer bounds.
Public Property | Page | Gets the page on which the content is being drawn.
Top
See Also

Reference

PdfFlowContentDrawEventArgs Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowContentDrawEventArgs Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentDrawEventArgs Class

For a list of all members of this type, see PdfFlowContentDrawEventArgs members.

Public Properties
 | Name | Description
Public Property | Content | Gets the content being drawn.
Public Property | ContentBounds | Gets the content bounds.
Public Property | ContentInnerBounds | Gets the content inner bounds.
Public Property | ContentOuterBounds | Gets the content outer bounds.
Public Property | Page | Gets the page on which the content is being drawn.
Top
See Also

Reference

PdfFlowContentDrawEventArgs Class
Xfinium.Pdf.FlowDocument Namespace


Content Property (PdfFlowContentDrawEventArgs)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentDrawEventArgs Class : Content Property
Gets the content being drawn.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Content As PdfFlowContent
'Usage

Dim instance As PdfFlowContentDrawEventArgs
Dim value As PdfFlowContent

value = instance.Content
public PdfFlowContent Content {get;}
public:
property PdfFlowContent^ Content {
   PdfFlowContent^ get();
}

Property Value

The content that is currently drawn on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentDrawEventArgs Class
PdfFlowContentDrawEventArgs Members


ContentBounds Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentDrawEventArgs Class : ContentBounds Property
Gets the content bounds.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ContentBounds As PdfVisualRectangle
'Usage

Dim instance As PdfFlowContentDrawEventArgs
Dim value As PdfVisualRectangle

value = instance.ContentBounds
public PdfVisualRectangle ContentBounds {get;}
public:
property PdfVisualRectangle^ ContentBounds {
   PdfVisualRectangle^ get();
}

Property Value

The content bounds excluding any margins.
Remarks
This rectangle is located inside the ContentInnerBounds rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentDrawEventArgs Class
PdfFlowContentDrawEventArgs Members


ContentInnerBounds Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentDrawEventArgs Class : ContentInnerBounds Property
Gets the content inner bounds.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ContentInnerBounds As PdfVisualRectangle
'Usage

Dim instance As PdfFlowContentDrawEventArgs
Dim value As PdfVisualRectangle

value = instance.ContentInnerBounds
public PdfVisualRectangle ContentInnerBounds {get;}
public:
property PdfVisualRectangle^ ContentInnerBounds {
   PdfVisualRectangle^ get();
}

Property Value

The content bounds that include the inner margins.
Remarks
This rectangle is located inside the ContentOuterBounds rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentDrawEventArgs Class
PdfFlowContentDrawEventArgs Members


ContentOuterBounds Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentDrawEventArgs Class : ContentOuterBounds Property
Gets the content outer bounds.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ContentOuterBounds As PdfVisualRectangle
'Usage

Dim instance As PdfFlowContentDrawEventArgs
Dim value As PdfVisualRectangle

value = instance.ContentOuterBounds
public PdfVisualRectangle ContentOuterBounds {get;}
public:
property PdfVisualRectangle^ ContentOuterBounds {
   PdfVisualRectangle^ get();
}

Property Value

The content bounds that include the inner and outer margins.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentDrawEventArgs Class
PdfFlowContentDrawEventArgs Members


Page Property (PdfFlowContentDrawEventArgs)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentDrawEventArgs Class : Page Property
Gets the page on which the content is being drawn.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PdfPage
'Usage

Dim instance As PdfFlowContentDrawEventArgs
Dim value As PdfPage

value = instance.Page
public PdfPage Page {get;}
public:
property PdfPage^ Page {
   PdfPage^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentDrawEventArgs Class
PdfFlowContentDrawEventArgs Members


%%PageItemTitle%%

PdfFlowContentMargins Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentMargins Class
Defines the margins for flow content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowContentMargins
'Usage

Dim instance As PdfFlowContentMargins
public class PdfFlowContentMargins
public ref class PdfFlowContentMargins
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContentMargins

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowContentMargins Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentMargins Class

The following tables list the members exposed by PdfFlowContentMargins.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowContentMargins Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom margin.
Public Property | Left | Gets or sets the left margin.
Public Property | Right | Gets or sets the right margin.
Public Property | Top | Gets or sets the top margin.
Top
See Also

Reference

PdfFlowContentMargins Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowContentMargins Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class : PdfFlowContentMargins Constructor
Overload List
Overload | Description
PdfFlowContentMargins Constructor() | Initializes a new PdfFlowContentMargins object.
PdfFlowContentMargins Constructor(Double) | Initializes a new PdfFlowContentMargins object with the same value for all margins.
PdfFlowContentMargins Constructor(Double,Double,Double,Double) | Initializes a new PdfFlowContentMargins object with the distinct values for each margin.
PdfFlowContentMargins Constructor(PdfFlowContentMargins) | Initializes a new PdfFlowContentMargins object from another margins object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members


%%PageItemTitle%%

PdfFlowContentMargins Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class > PdfFlowContentMargins Constructor : PdfFlowContentMargins Constructor()
Initializes a new PdfFlowContentMargins object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowContentMargins()
public PdfFlowContentMargins()
public:
PdfFlowContentMargins();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members
Overload List


%%PageItemTitle%%

PdfFlowContentMargins Constructor(Double)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class > PdfFlowContentMargins Constructor : PdfFlowContentMargins Constructor(Double)
Value for all margins.
Initializes a new PdfFlowContentMargins object with the same value for all margins.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal margins As Double _
)
'Usage

Dim margins As Double

Dim instance As New PdfFlowContentMargins(margins)
public PdfFlowContentMargins(
   double margins
)
public:
PdfFlowContentMargins(
   double margins
)

Parameters

margins
Value for all margins.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members
Overload List


%%PageItemTitle%%

PdfFlowContentMargins Constructor(Double,Double,Double,Double)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class > PdfFlowContentMargins Constructor : PdfFlowContentMargins Constructor(Double,Double,Double,Double)
Left margin
Right margin
Top margin
Bottom margin
Initializes a new PdfFlowContentMargins object with the distinct values for each margin.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Double, _
   ByVal right As Double, _
   ByVal top As Double, _
   ByVal bottom As Double _
)
'Usage

Dim left As Double
Dim right As Double
Dim top As Double
Dim bottom As Double

Dim instance As New PdfFlowContentMargins(left, right, top, bottom)
public PdfFlowContentMargins(
   double left,
   double right,
   double top,
   double bottom
)
public:
PdfFlowContentMargins(
   double left,
   double right,
   double top,
   double bottom
)

Parameters

left
Left margin
right
Right margin
top
Top margin
bottom
Bottom margin
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members
Overload List


%%PageItemTitle%%

PdfFlowContentMargins Constructor(PdfFlowContentMargins)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class > PdfFlowContentMargins Constructor : PdfFlowContentMargins Constructor(PdfFlowContentMargins)
Source margins object.
Initializes a new PdfFlowContentMargins object from another margins object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal margins As PdfFlowContentMargins _
)
'Usage

Dim margins As PdfFlowContentMargins

Dim instance As New PdfFlowContentMargins(margins)
public PdfFlowContentMargins(
   PdfFlowContentMargins margins
)
public:
PdfFlowContentMargins(
   PdfFlowContentMargins^ margins
)

Parameters

margins
Source margins object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowContentMargins Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentMargins Class

For a list of all members of this type, see PdfFlowContentMargins members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom margin.
Public Property | Left | Gets or sets the left margin.
Public Property | Right | Gets or sets the right margin.
Public Property | Top | Gets or sets the top margin.
Top
See Also

Reference

PdfFlowContentMargins Class
Xfinium.Pdf.FlowDocument Namespace


Bottom Property (PdfFlowContentMargins)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class : Bottom Property
Gets or sets the bottom margin.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Bottom As Double
'Usage

Dim instance As PdfFlowContentMargins
Dim value As Double

instance.Bottom = value

value = instance.Bottom
public double Bottom {get; set;}
public:
property double Bottom {
   double get();
   void set (    double value);
}

Property Value

The bottom margin for flow content
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members


Left Property (PdfFlowContentMargins)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class : Left Property
Gets or sets the left margin.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As PdfFlowContentMargins
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

The left margin for flow content
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members


Right Property (PdfFlowContentMargins)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class : Right Property
Gets or sets the right margin.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Right As Double
'Usage

Dim instance As PdfFlowContentMargins
Dim value As Double

instance.Right = value

value = instance.Right
public double Right {get; set;}
public:
property double Right {
   double get();
   void set (    double value);
}

Property Value

The right margin for flow content
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members


Top Property (PdfFlowContentMargins)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowContentMargins Class : Top Property
Gets or sets the top margin.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Top As Double
'Usage

Dim instance As PdfFlowContentMargins
Dim value As Double

instance.Top = value

value = instance.Top
public double Top {get; set;}
public:
property double Top {
   double get();
   void set (    double value);
}

Property Value

The top margin for flow content
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowContentMargins Class
PdfFlowContentMargins Members


%%PageItemTitle%%

PdfFlowDocument Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocument Class
Defines a PDF document that formats flow content.
Object Model
PdfFlowDocument ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfCosDictionary ClassPdfDocumentInformation ClassPdfDocumentFileAttachmentCollection ClassPdfDocumentFileAttachment ClassPdfFlowDocumentHeadersFooters ClassPdfJavaScriptBlockCollection ClassPdfJavaScriptBlock ClassPdfAction ClassPdfOutlineItemCollection ClassPdfOutlineItem ClassPdfOutputIntentCollection ClassPdfOutputIntent ClassPdfPageLabelingRangeCollection ClassPdfPageLabelingRange ClassPdfSecurityHandler ClassPdfVersionExtension ClassPdfViewerPreferences ClassPdfXmpMetadata Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowDocument
   Inherits Xfinium.Pdf.PdfDocument
'Usage

Dim instance As PdfFlowDocument
public class PdfFlowDocument : Xfinium.Pdf.PdfDocument
public ref class PdfFlowDocument : public Xfinium.Pdf.PdfDocument
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfDocument
Xfinium.Pdf.FlowDocument.PdfFlowDocument

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowDocument Class Members
Properties Methods Events

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocument Class

The following tables list the members exposed by PdfFlowDocument.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowDocument Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | DisplayMode | Gets or sets how the document should be displayed when opened in the viewer.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | FileAttachments | Gets the list of file attachments embedded in this document.
Public Property | HeadersFooters | Gets the document headers and footers.
Public Property | ID | Gets the document ID. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | JavaScriptBlocks | Gets the JavaScript source code blocks.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | Outline | Gets the document outline.
Public Property | OutputIntents | Gets or sets the collection of output intents.
Public Property | PageLabelingRanges | Gets the list of page labeling ranges in the Pdf document.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | PdfVersion | Gets or sets the Pdf version of this Xfinium.Pdf.PdfDocument object.
Public Property | SecurityHandler | Gets the document security handler. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | VersionExtension | Gets or sets the version extension.
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Public Property | XmpMetadata | Gets or sets the XMP document metadata.
Top
Public Methods
 | Name | Description
Public Method | AddContent | Adds new content to the document.
Public Method | GenerateTableOfContents | Overloaded. Generates the document's table of contents.
Public Method | GetFixedDocument | Converts the flow document to a fixed document and returns it.
Public Method | Save | Overloaded. Overridden. Saves the Pdf document to the specified stream.
Public Method | StartNewPage | Starts a new page no matter how much content has been added to current page.
Top
Public Events
 | Name | Description
Public Event | AfterContentDraw | Gets or sets the event that is fired after a flow content object is drawn on the page.
Public Event | BeforeContentDraw | Gets or sets the event that is fired before a flow content object is drawn on the page.
Public Event | PageCompleted | Gets or sets the event that is fired when a page has been completed and it can be closed for adding content.
Public Event | PageCreated | Gets or sets the event that is fired when a new page has been created.
Top
See Also

Reference

PdfFlowDocument Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowDocument Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : PdfFlowDocument Constructor
Overload List
Overload | Description
PdfFlowDocument Constructor() | Initializes a new PdfFlowDocument object.
PdfFlowDocument Constructor(PdfFlowDocumentDefaults) | Initializes a new PdfFlowDocument object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


%%PageItemTitle%%

PdfFlowDocument Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class > PdfFlowDocument Constructor : PdfFlowDocument Constructor()
Initializes a new PdfFlowDocument object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowDocument()
public PdfFlowDocument()
public:
PdfFlowDocument();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members
Overload List


%%PageItemTitle%%

PdfFlowDocument Constructor(PdfFlowDocumentDefaults)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class > PdfFlowDocument Constructor : PdfFlowDocument Constructor(PdfFlowDocumentDefaults)
Default values for the document.
Initializes a new PdfFlowDocument object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal documentDefaults As PdfFlowDocumentDefaults _
)
'Usage

Dim documentDefaults As PdfFlowDocumentDefaults

Dim instance As New PdfFlowDocument(documentDefaults)
public PdfFlowDocument(
   PdfFlowDocumentDefaults documentDefaults
)
public:
PdfFlowDocument(
   PdfFlowDocumentDefaults^ documentDefaults
)

Parameters

documentDefaults
Default values for the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfFlowDocument Class Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocument Class

For a list of all members of this type, see PdfFlowDocument members.

Public Methods
 | Name | Description
Public Method | AddContent | Adds new content to the document.
Public Method | GenerateTableOfContents | Overloaded. Generates the document's table of contents.
Public Method | GetFixedDocument | Converts the flow document to a fixed document and returns it.
Public Method | Save | Overloaded. Overridden. Saves the Pdf document to the specified stream.
Public Method | StartNewPage | Starts a new page no matter how much content has been added to current page.
Top
See Also

Reference

PdfFlowDocument Class
Xfinium.Pdf.FlowDocument Namespace


AddContent Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : AddContent Method
New content to be added to the document.
Adds new content to the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddContent( _
   ByVal flowContent As PdfFlowContent _
)
'Usage

Dim instance As PdfFlowDocument
Dim flowContent As PdfFlowContent

instance.AddContent(flowContent)
public void AddContent(
   PdfFlowContent flowContent
)
public:
void AddContent(
   PdfFlowContent^ flowContent
)

Parameters

flowContent
New content to be added to the document.
Remarks
The content is laid out automatically in the available space and subsequent changes on the content have no effect.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


GenerateTableOfContents Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : GenerateTableOfContents Method
Generates the document's table of contents.
Overload List
Overload | Description
GenerateTableOfContents() | Generates the document's table of contents.
GenerateTableOfContents(PdfFlowDocumentTOCSettings) | Generates the document's table of contents.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


GenerateTableOfContents() Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class > GenerateTableOfContents Method : GenerateTableOfContents() Method
Generates the document's table of contents.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub GenerateTableOfContents()
'Usage

Dim instance As PdfFlowDocument

instance.GenerateTableOfContents()
public void GenerateTableOfContents()
public:
void GenerateTableOfContents();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members
Overload List


GenerateTableOfContents(PdfFlowDocumentTOCSettings) Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class > GenerateTableOfContents Method : GenerateTableOfContents(PdfFlowDocumentTOCSettings) Method
Settings for generating the table of contents.
Generates the document's table of contents.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub GenerateTableOfContents( _
   ByVal tocSettings As PdfFlowDocumentTOCSettings _
)
'Usage

Dim instance As PdfFlowDocument
Dim tocSettings As PdfFlowDocumentTOCSettings

instance.GenerateTableOfContents(tocSettings)
public void GenerateTableOfContents(
   PdfFlowDocumentTOCSettings tocSettings
)
public:
void GenerateTableOfContents(
   PdfFlowDocumentTOCSettings^ tocSettings
)

Parameters

tocSettings
Settings for generating the table of contents.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members
Overload List


GetFixedDocument Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : GetFixedDocument Method
Converts the flow document to a fixed document and returns it.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetFixedDocument() As PdfFixedDocument
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfFixedDocument

value = instance.GetFixedDocument()
public PdfFixedDocument GetFixedDocument()
public:
PdfFixedDocument^ GetFixedDocument();

Return Value

The fixed document that represents this document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


Save Method (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : Save Method
Saves the Pdf document to the specified stream.
Overload List
Overload | Description
Save(Stream,PdfSecurityHandler) | Saves the Pdf document to the specified stream.
Save(Stream) | Saves the Pdf document to the specified stream. (Inherited from Xfinium.Pdf.PdfDocument)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


Save(Stream,PdfSecurityHandler) Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class > Save Method : Save(Stream,PdfSecurityHandler) Method
Destination stream.
Security handler for encrypting the saved file.
Saves the Pdf document to the specified stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Save( _
   ByVal stream As Stream, _
   ByVal securityHandler As PdfSecurityHandler _
)
'Usage

Dim instance As PdfFlowDocument
Dim stream As Stream
Dim securityHandler As PdfSecurityHandler

instance.Save(stream, securityHandler)
public override void Save(
   Stream stream,
   PdfSecurityHandler securityHandler
)
public:
void Save(
   Stream^ stream,
   PdfSecurityHandler^ securityHandler
) override

Parameters

stream
Destination stream.
securityHandler
Security handler for encrypting the saved file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members
Overload List


StartNewPage Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : StartNewPage Method
Starts a new page no matter how much content has been added to current page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub StartNewPage()
'Usage

Dim instance As PdfFlowDocument

instance.StartNewPage()
public void StartNewPage()
public:
void StartNewPage();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


%%PageItemTitle%% $$Properties$$

PdfFlowDocument Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocument Class

For a list of all members of this type, see PdfFlowDocument members.

Public Properties
 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | DisplayMode | Gets or sets how the document should be displayed when opened in the viewer.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | FileAttachments | Gets the list of file attachments embedded in this document.
Public Property | HeadersFooters | Gets the document headers and footers.
Public Property | ID | Gets the document ID. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | JavaScriptBlocks | Gets the JavaScript source code blocks.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | Outline | Gets the document outline.
Public Property | OutputIntents | Gets or sets the collection of output intents.
Public Property | PageLabelingRanges | Gets the list of page labeling ranges in the Pdf document.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | PdfVersion | Gets or sets the Pdf version of this Xfinium.Pdf.PdfDocument object.
Public Property | SecurityHandler | Gets the document security handler. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | VersionExtension | Gets or sets the version extension.
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Public Property | XmpMetadata | Gets or sets the XMP document metadata.
Top
See Also

Reference

PdfFlowDocument Class
Xfinium.Pdf.FlowDocument Namespace


AfterPrintAction Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : AfterPrintAction Property
Gets or sets the javascript action to execute after the document is printed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AfterPrintAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfJavaScriptAction

instance.AfterPrintAction = value

value = instance.AfterPrintAction
public PdfJavaScriptAction AfterPrintAction {get; set;}
public:
property PdfJavaScriptAction^ AfterPrintAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed after the document is printed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


AfterSaveAction Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : AfterSaveAction Property
Gets or sets the javascript action to execute after the document is saved.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AfterSaveAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfJavaScriptAction

instance.AfterSaveAction = value

value = instance.AfterSaveAction
public PdfJavaScriptAction AfterSaveAction {get; set;}
public:
property PdfJavaScriptAction^ AfterSaveAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed after the document is saved.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


BeforeCloseAction Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : BeforeCloseAction Property
Gets or sets the javascript action to execute before the document is closed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BeforeCloseAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfJavaScriptAction

instance.BeforeCloseAction = value

value = instance.BeforeCloseAction
public PdfJavaScriptAction BeforeCloseAction {get; set;}
public:
property PdfJavaScriptAction^ BeforeCloseAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed before the document is closed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


BeforePrintAction Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : BeforePrintAction Property
Gets or sets the javascript action to execute before the document is printed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BeforePrintAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfJavaScriptAction

instance.BeforePrintAction = value

value = instance.BeforePrintAction
public PdfJavaScriptAction BeforePrintAction {get; set;}
public:
property PdfJavaScriptAction^ BeforePrintAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed before the document is printed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


BeforeSaveAction Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : BeforeSaveAction Property
Gets or sets the javascript action to execute before the document is saved.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BeforeSaveAction As PdfJavaScriptAction
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfJavaScriptAction

instance.BeforeSaveAction = value

value = instance.BeforeSaveAction
public PdfJavaScriptAction BeforeSaveAction {get; set;}
public:
property PdfJavaScriptAction^ BeforeSaveAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction object specifying the action to be executed before the document is saved.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


DisplayMode Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : DisplayMode Property
Gets or sets how the document should be displayed when opened in the viewer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisplayMode As PdfDisplayMode
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
public PdfDisplayMode DisplayMode {get; set;}
public:
property PdfDisplayMode DisplayMode {
   PdfDisplayMode get();
   void set (    PdfDisplayMode value);
}

Property Value

A Xfinium.Pdf.PdfDisplayMode enumeration member specifying how the viewer should display the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


DocumentInformation Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : DocumentInformation Property
Gets or sets the document information.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DocumentInformation As PdfDocumentInformation
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfDocumentInformation

instance.DocumentInformation = value

value = instance.DocumentInformation
public PdfDocumentInformation DocumentInformation {get; set;}
public:
property PdfDocumentInformation^ DocumentInformation {
   PdfDocumentInformation^ get();
   void set (    PdfDocumentInformation^ value);
}

Property Value

The document's metadata.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


FileAttachments Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : FileAttachments Property
Gets the list of file attachments embedded in this document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FileAttachments As PdfDocumentFileAttachmentCollection
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfDocumentFileAttachmentCollection

value = instance.FileAttachments
public PdfDocumentFileAttachmentCollection FileAttachments {get;}
public:
property PdfDocumentFileAttachmentCollection^ FileAttachments {
   PdfDocumentFileAttachmentCollection^ get();
}

Property Value

Xfinium.Pdf.PdfDocumentFileAttachmentCollection object specifying the list of document attachments.
Remarks
When a Pdf file is imported into a Xfinium.Pdf.PdfDocument object, this collection is populated automatically with the attachments in the file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


HeadersFooters Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : HeadersFooters Property
Gets the document headers and footers.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property HeadersFooters As PdfFlowDocumentHeadersFooters
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfFlowDocumentHeadersFooters

value = instance.HeadersFooters
public PdfFlowDocumentHeadersFooters HeadersFooters {get;}
public:
property PdfFlowDocumentHeadersFooters^ HeadersFooters {
   PdfFlowDocumentHeadersFooters^ get();
}

Property Value

The headers and footers defined in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


JavaScriptBlocks Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : JavaScriptBlocks Property
Gets the JavaScript source code blocks.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property JavaScriptBlocks As PdfJavaScriptBlockCollection
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfJavaScriptBlockCollection

value = instance.JavaScriptBlocks
public PdfJavaScriptBlockCollection JavaScriptBlocks {get;}
public:
property PdfJavaScriptBlockCollection^ JavaScriptBlocks {
   PdfJavaScriptBlockCollection^ get();
}

Property Value

The collection of JavaScript source code block that are embedded in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


OpenAction Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : OpenAction Property
Gets or sets the action to execute when the document is opened.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OpenAction As PdfAction
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfAction

instance.OpenAction = value

value = instance.OpenAction
public PdfAction OpenAction {get; set;}
public:
property PdfAction^ OpenAction {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfAction object specifying the action to be executed when documents opens in the viewer.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


Outline Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : Outline Property
Gets the document outline.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Outline As PdfOutlineItemCollection
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfOutlineItemCollection

value = instance.Outline
public PdfOutlineItemCollection Outline {get;}
public:
property PdfOutlineItemCollection^ Outline {
   PdfOutlineItemCollection^ get();
}

Property Value

A tree-structured hierarchy of outline items.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


OutputIntents Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : OutputIntents Property
Gets or sets the collection of output intents.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OutputIntents As PdfOutputIntentCollection
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfOutputIntentCollection

instance.OutputIntents = value

value = instance.OutputIntents
public PdfOutputIntentCollection OutputIntents {get; set;}
public:
property PdfOutputIntentCollection^ OutputIntents {
   PdfOutputIntentCollection^ get();
   void set (    PdfOutputIntentCollection^ value);
}

Property Value

A collection of Xfinium.Pdf.PdfOutputIntent objects describing the color characteristics of output devices on which the document might be rendered.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


PageLabelingRanges Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : PageLabelingRanges Property
Gets the list of page labeling ranges in the Pdf document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PageLabelingRanges As PdfPageLabelingRangeCollection
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfPageLabelingRangeCollection

value = instance.PageLabelingRanges
public PdfPageLabelingRangeCollection PageLabelingRanges {get;}
public:
property PdfPageLabelingRangeCollection^ PageLabelingRanges {
   PdfPageLabelingRangeCollection^ get();
}

Property Value

The list of page labeling ranges in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


PageLayout Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : PageLayout Property
Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageLayout As PdfPageLayout
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfPageLayout

instance.PageLayout = value

value = instance.PageLayout
public PdfPageLayout PageLayout {get; set;}
public:
property PdfPageLayout PageLayout {
   PdfPageLayout get();
   void set (    PdfPageLayout value);
}

Property Value

The document's page layout.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


PdfVersion Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : PdfVersion Property
Gets or sets the Pdf version of this Xfinium.Pdf.PdfDocument object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PdfVersion As PdfVersion
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfVersion

instance.PdfVersion = value

value = instance.PdfVersion
public PdfVersion PdfVersion {get; set;}
public:
property PdfVersion PdfVersion {
   PdfVersion get();
   void set (    PdfVersion value);
}

Property Value

A PdfVersion enumeration member specifying the Pdf version of this Xfinium.Pdf.PdfDocument object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


VersionExtension Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : VersionExtension Property
Gets or sets the version extension.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VersionExtension As PdfVersionExtension
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfVersionExtension

instance.VersionExtension = value

value = instance.VersionExtension
public PdfVersionExtension VersionExtension {get; set;}
public:
property PdfVersionExtension^ VersionExtension {
   PdfVersionExtension^ get();
   void set (    PdfVersionExtension^ value);
}

Property Value

The extended Pdf version this document implements.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


ViewerPreferences Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : ViewerPreferences Property
Gets or sets the document's viewer preferences.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ViewerPreferences As PdfViewerPreferences
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfViewerPreferences

instance.ViewerPreferences = value

value = instance.ViewerPreferences
public PdfViewerPreferences ViewerPreferences {get; set;}
public:
property PdfViewerPreferences^ ViewerPreferences {
   PdfViewerPreferences^ get();
   void set (    PdfViewerPreferences^ value);
}

Property Value

The viewer preferences for displaying the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


XmpMetadata Property (PdfFlowDocument)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : XmpMetadata Property
Gets or sets the XMP document metadata.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property XmpMetadata As PdfXmpMetadata
'Usage

Dim instance As PdfFlowDocument
Dim value As PdfXmpMetadata

instance.XmpMetadata = value

value = instance.XmpMetadata
public PdfXmpMetadata XmpMetadata {get; set;}
public:
property PdfXmpMetadata^ XmpMetadata {
   PdfXmpMetadata^ get();
   void set (    PdfXmpMetadata^ value);
}

Property Value

The XMP document metadata.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


%%PageItemTitle%% $$Events$$

PdfFlowDocument Class Events

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocument Class

For a list of all members of this type, see PdfFlowDocument members.

Public Events
 | Name | Description
Public Event | AfterContentDraw | Gets or sets the event that is fired after a flow content object is drawn on the page.
Public Event | BeforeContentDraw | Gets or sets the event that is fired before a flow content object is drawn on the page.
Public Event | PageCompleted | Gets or sets the event that is fired when a page has been completed and it can be closed for adding content.
Public Event | PageCreated | Gets or sets the event that is fired when a new page has been created.
Top
See Also

Reference

PdfFlowDocument Class
Xfinium.Pdf.FlowDocument Namespace


AfterContentDraw Event

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : AfterContentDraw Event
Gets or sets the event that is fired after a flow content object is drawn on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event AfterContentDraw As EventHandler(Of PdfFlowContentDrawEventArgs)
'Usage

Dim instance As PdfFlowDocument
Dim handler As EventHandler(Of PdfFlowContentDrawEventArgs)

AddHandler instance.AfterContentDraw, handler
public event EventHandler<PdfFlowContentDrawEventArgs> AfterContentDraw
public:
event EventHandler<PdfFlowContentDrawEventArgs^>^ AfterContentDraw
Event Data

The event handler receives an argument of type PdfFlowContentDrawEventArgs containing data related to this event. The following PdfFlowContentDrawEventArgs properties provide information specific to this event.

Property | Description
Content | Gets the content being drawn.
ContentBounds | Gets the content bounds.
ContentInnerBounds | Gets the content inner bounds.
ContentOuterBounds | Gets the content outer bounds.
Page | Gets the page on which the content is being drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


BeforeContentDraw Event

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : BeforeContentDraw Event
Gets or sets the event that is fired before a flow content object is drawn on the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event BeforeContentDraw As EventHandler(Of PdfFlowContentDrawEventArgs)
'Usage

Dim instance As PdfFlowDocument
Dim handler As EventHandler(Of PdfFlowContentDrawEventArgs)

AddHandler instance.BeforeContentDraw, handler
public event EventHandler<PdfFlowContentDrawEventArgs> BeforeContentDraw
public:
event EventHandler<PdfFlowContentDrawEventArgs^>^ BeforeContentDraw
Event Data

The event handler receives an argument of type PdfFlowContentDrawEventArgs containing data related to this event. The following PdfFlowContentDrawEventArgs properties provide information specific to this event.

Property | Description
Content | Gets the content being drawn.
ContentBounds | Gets the content bounds.
ContentInnerBounds | Gets the content inner bounds.
ContentOuterBounds | Gets the content outer bounds.
Page | Gets the page on which the content is being drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


PageCompleted Event

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : PageCompleted Event
Gets or sets the event that is fired when a page has been completed and it can be closed for adding content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event PageCompleted As EventHandler(Of PdfFlowPageEventArgs)
'Usage

Dim instance As PdfFlowDocument
Dim handler As EventHandler(Of PdfFlowPageEventArgs)

AddHandler instance.PageCompleted, handler
public event EventHandler<PdfFlowPageEventArgs> PageCompleted
public:
event EventHandler<PdfFlowPageEventArgs^>^ PageCompleted
Event Data

The event handler receives an argument of type PdfFlowPageEventArgs containing data related to this event. The following PdfFlowPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the page that has been created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


PageCreated Event

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocument Class : PageCreated Event
Gets or sets the event that is fired when a new page has been created.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event PageCreated As EventHandler(Of PdfFlowPageCreatedEventArgs)
'Usage

Dim instance As PdfFlowDocument
Dim handler As EventHandler(Of PdfFlowPageCreatedEventArgs)

AddHandler instance.PageCreated, handler
public event EventHandler<PdfFlowPageCreatedEventArgs> PageCreated
public:
event EventHandler<PdfFlowPageCreatedEventArgs^>^ PageCreated
Event Data

The event handler receives an argument of type PdfFlowPageCreatedEventArgs containing data related to this event. The following PdfFlowPageCreatedEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the page that has been created. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowPageEventArgs)
PageDefaults | Gets the default initialization values for the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocument Class
PdfFlowDocument Members


%%PageItemTitle%%

PdfFlowDocumentDefaults Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentDefaults Class
Defines default values for a flow document.
Object Model
PdfFlowDocumentDefaults ClassPdfFlowPageDefaults Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowDocumentDefaults
'Usage

Dim instance As PdfFlowDocumentDefaults
public class PdfFlowDocumentDefaults
public ref class PdfFlowDocumentDefaults
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowDocumentDefaults

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentDefaults Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowDocumentDefaults Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentDefaults Class

The following tables list the members exposed by PdfFlowDocumentDefaults.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowDocumentDefaults Constructor | Initializes a new PdfFlowDocumentDefaults object.
Top
Public Properties
 | Name | Description
Public Property | PageDefaults | Gets the page defaults.
Top
See Also

Reference

PdfFlowDocumentDefaults Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowDocumentDefaults Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentDefaults Class : PdfFlowDocumentDefaults Constructor
Initializes a new PdfFlowDocumentDefaults object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowDocumentDefaults()
public PdfFlowDocumentDefaults()
public:
PdfFlowDocumentDefaults();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentDefaults Class
PdfFlowDocumentDefaults Members


%%PageItemTitle%% $$Properties$$

PdfFlowDocumentDefaults Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentDefaults Class

For a list of all members of this type, see PdfFlowDocumentDefaults members.

Public Properties
 | Name | Description
Public Property | PageDefaults | Gets the page defaults.
Top
See Also

Reference

PdfFlowDocumentDefaults Class
Xfinium.Pdf.FlowDocument Namespace


PageDefaults Property (PdfFlowDocumentDefaults)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentDefaults Class : PageDefaults Property
Gets the page defaults.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PageDefaults As PdfFlowPageDefaults
'Usage

Dim instance As PdfFlowDocumentDefaults
Dim value As PdfFlowPageDefaults

value = instance.PageDefaults
public PdfFlowPageDefaults PageDefaults {get;}
public:
property PdfFlowPageDefaults^ PageDefaults {
   PdfFlowPageDefaults^ get();
}

Property Value

Default values for a page in a flow document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentDefaults Class
PdfFlowDocumentDefaults Members


%%PageItemTitle%%

PdfFlowDocumentFooter Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentFooter Class
Defines the footer for a flow document.
Object Model
PdfFlowDocumentFooter ClassPdfFlowContentCollection ClassPdfFlowContent Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowDocumentFooter
'Usage

Dim instance As PdfFlowDocumentFooter
public class PdfFlowDocumentFooter
public ref class PdfFlowDocumentFooter
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowDocumentFooter

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentFooter Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowDocumentFooter Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentFooter Class

The following tables list the members exposed by PdfFlowDocumentFooter.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowDocumentFooter Constructor | Initializes a new PdfFlowDocumentFooter object.
Top
Public Properties
 | Name | Description
Public Property | BottomMargin | Gets or sets the bottom margin.
Public Property | Content | Gets or sets the footer content.
Top
See Also

Reference

PdfFlowDocumentFooter Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowDocumentFooter Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentFooter Class : PdfFlowDocumentFooter Constructor
Initializes a new PdfFlowDocumentFooter object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowDocumentFooter()
public PdfFlowDocumentFooter()
public:
PdfFlowDocumentFooter();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentFooter Class
PdfFlowDocumentFooter Members


%%PageItemTitle%% $$Properties$$

PdfFlowDocumentFooter Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentFooter Class

For a list of all members of this type, see PdfFlowDocumentFooter members.

Public Properties
 | Name | Description
Public Property | BottomMargin | Gets or sets the bottom margin.
Public Property | Content | Gets or sets the footer content.
Top
See Also

Reference

PdfFlowDocumentFooter Class
Xfinium.Pdf.FlowDocument Namespace


BottomMargin Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentFooter Class : BottomMargin Property
Gets or sets the bottom margin.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BottomMargin As Double
'Usage

Dim instance As PdfFlowDocumentFooter
Dim value As Double

instance.BottomMargin = value

value = instance.BottomMargin
public double BottomMargin {get; set;}
public:
property double BottomMargin {
   double get();
   void set (    double value);
}

Property Value

Margin from bottom page border where the footer ends.
Remarks
If the footer bottom margin plus footer height are greater than page bottom margin, the page bottom margin is increased (content is moved up) in order to accomodate the footer.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentFooter Class
PdfFlowDocumentFooter Members


Content Property (PdfFlowDocumentFooter)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentFooter Class : Content Property
Gets or sets the footer content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Content As PdfFlowContentCollection
'Usage

Dim instance As PdfFlowDocumentFooter
Dim value As PdfFlowContentCollection

value = instance.Content
public PdfFlowContentCollection Content {get;}
public:
property PdfFlowContentCollection^ Content {
   PdfFlowContentCollection^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentFooter Class
PdfFlowDocumentFooter Members


%%PageItemTitle%%

PdfFlowDocumentHeader Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentHeader Class
Defines the header for a flow document.
Object Model
PdfFlowDocumentHeader ClassPdfFlowContentCollection ClassPdfFlowContent Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowDocumentHeader
'Usage

Dim instance As PdfFlowDocumentHeader
public class PdfFlowDocumentHeader
public ref class PdfFlowDocumentHeader
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowDocumentHeader

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeader Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowDocumentHeader Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentHeader Class

The following tables list the members exposed by PdfFlowDocumentHeader.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowDocumentHeader Constructor | Initializes a new PdfFlowDocumentHeader object.
Top
Public Properties
 | Name | Description
Public Property | Content | Gets or sets the header content.
Public Property | TopMargin | Gets or sets the top margin.
Top
See Also

Reference

PdfFlowDocumentHeader Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowDocumentHeader Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeader Class : PdfFlowDocumentHeader Constructor
Initializes a new PdfFlowDocumentHeader object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowDocumentHeader()
public PdfFlowDocumentHeader()
public:
PdfFlowDocumentHeader();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeader Class
PdfFlowDocumentHeader Members


%%PageItemTitle%% $$Properties$$

PdfFlowDocumentHeader Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentHeader Class

For a list of all members of this type, see PdfFlowDocumentHeader members.

Public Properties
 | Name | Description
Public Property | Content | Gets or sets the header content.
Public Property | TopMargin | Gets or sets the top margin.
Top
See Also

Reference

PdfFlowDocumentHeader Class
Xfinium.Pdf.FlowDocument Namespace


Content Property (PdfFlowDocumentHeader)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeader Class : Content Property
Gets or sets the header content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Content As PdfFlowContentCollection
'Usage

Dim instance As PdfFlowDocumentHeader
Dim value As PdfFlowContentCollection

value = instance.Content
public PdfFlowContentCollection Content {get;}
public:
property PdfFlowContentCollection^ Content {
   PdfFlowContentCollection^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeader Class
PdfFlowDocumentHeader Members


TopMargin Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeader Class : TopMargin Property
Gets or sets the top margin.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TopMargin As Double
'Usage

Dim instance As PdfFlowDocumentHeader
Dim value As Double

instance.TopMargin = value

value = instance.TopMargin
public double TopMargin {get; set;}
public:
property double TopMargin {
   double get();
   void set (    double value);
}

Property Value

Margin from top page border where the header starts.
Remarks
If the header top margin plus header height are greater than page top margin, the page top margin is increased (content is moved down) in order to accomodate the header.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeader Class
PdfFlowDocumentHeader Members


%%PageItemTitle%%

PdfFlowDocumentHeadersFooters Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentHeadersFooters Class
Defines the headers and footers for a flow document.
Object Model
PdfFlowDocumentHeadersFooters ClassPdfFlowDocumentFooter ClassPdfFlowDocumentHeader ClassPdfFlowDocumentFooter ClassPdfFlowDocumentHeader ClassPdfFlowDocumentFooter ClassPdfFlowDocumentHeader Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowDocumentHeadersFooters
'Usage

Dim instance As PdfFlowDocumentHeadersFooters
public class PdfFlowDocumentHeadersFooters
public ref class PdfFlowDocumentHeadersFooters
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowDocumentHeadersFooters

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeadersFooters Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowDocumentHeadersFooters Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentHeadersFooters Class

The following tables list the members exposed by PdfFlowDocumentHeadersFooters.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowDocumentHeadersFooters Constructor | Initializes a new PdfFlowDocumentHeadersFooters object.
Top
Public Properties
 | Name | Description
Public Property | EvenPagesFooter | Gets or sets the footer for even pages in the document.
Public Property | EvenPagesHeader | Gets or sets the header for even pages in the document.
Public Property | FirstPageFooter | Gets or sets the footer for the first page.
Public Property | FirstPageHeader | Gets or sets the header for the first page.
Public Property | MainFooter | Gets or sets the document main footer.
Public Property | MainHeader | Gets or sets the document main header.
Top
See Also

Reference

PdfFlowDocumentHeadersFooters Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowDocumentHeadersFooters Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeadersFooters Class : PdfFlowDocumentHeadersFooters Constructor
Initializes a new PdfFlowDocumentHeadersFooters object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowDocumentHeadersFooters()
public PdfFlowDocumentHeadersFooters()
public:
PdfFlowDocumentHeadersFooters();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeadersFooters Class
PdfFlowDocumentHeadersFooters Members


%%PageItemTitle%% $$Properties$$

PdfFlowDocumentHeadersFooters Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentHeadersFooters Class

For a list of all members of this type, see PdfFlowDocumentHeadersFooters members.

Public Properties
 | Name | Description
Public Property | EvenPagesFooter | Gets or sets the footer for even pages in the document.
Public Property | EvenPagesHeader | Gets or sets the header for even pages in the document.
Public Property | FirstPageFooter | Gets or sets the footer for the first page.
Public Property | FirstPageHeader | Gets or sets the header for the first page.
Public Property | MainFooter | Gets or sets the document main footer.
Public Property | MainHeader | Gets or sets the document main header.
Top
See Also

Reference

PdfFlowDocumentHeadersFooters Class
Xfinium.Pdf.FlowDocument Namespace


EvenPagesFooter Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeadersFooters Class : EvenPagesFooter Property
Gets or sets the footer for even pages in the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EvenPagesFooter As PdfFlowDocumentFooter
'Usage

Dim instance As PdfFlowDocumentHeadersFooters
Dim value As PdfFlowDocumentFooter

instance.EvenPagesFooter = value

value = instance.EvenPagesFooter
public PdfFlowDocumentFooter EvenPagesFooter {get; set;}
public:
property PdfFlowDocumentFooter^ EvenPagesFooter {
   PdfFlowDocumentFooter^ get();
   void set (    PdfFlowDocumentFooter^ value);
}

Property Value

A footer object to be displayed on document's even pages.
Remarks
If this property is set to null, no footer is displayed on even pages. When the MainFooter property is set, this property is also set to the same value. If you want a different footer for even pages, set this property after setting the MainFooter property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeadersFooters Class
PdfFlowDocumentHeadersFooters Members


EvenPagesHeader Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeadersFooters Class : EvenPagesHeader Property
Gets or sets the header for even pages in the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EvenPagesHeader As PdfFlowDocumentHeader
'Usage

Dim instance As PdfFlowDocumentHeadersFooters
Dim value As PdfFlowDocumentHeader

instance.EvenPagesHeader = value

value = instance.EvenPagesHeader
public PdfFlowDocumentHeader EvenPagesHeader {get; set;}
public:
property PdfFlowDocumentHeader^ EvenPagesHeader {
   PdfFlowDocumentHeader^ get();
   void set (    PdfFlowDocumentHeader^ value);
}

Property Value

A header object to be displayed on document's even pages.
Remarks
If this property is set to null, no header is displayed on even pages. When the MainHeader property is set, this property is also set to the same value. If you want a different header for even pages, set this property after setting the MainHeader property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeadersFooters Class
PdfFlowDocumentHeadersFooters Members


FirstPageFooter Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeadersFooters Class : FirstPageFooter Property
Gets or sets the footer for the first page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FirstPageFooter As PdfFlowDocumentFooter
'Usage

Dim instance As PdfFlowDocumentHeadersFooters
Dim value As PdfFlowDocumentFooter

instance.FirstPageFooter = value

value = instance.FirstPageFooter
public PdfFlowDocumentFooter FirstPageFooter {get; set;}
public:
property PdfFlowDocumentFooter^ FirstPageFooter {
   PdfFlowDocumentFooter^ get();
   void set (    PdfFlowDocumentFooter^ value);
}

Property Value

A footer object to be displayed on document's first page.
Remarks
If this property is set to null, no footer is displayed on the first page. When the MainFooter property is set, this property is also set to the same value. If you want a different footer for first page, set this property after setting the MainFooter property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeadersFooters Class
PdfFlowDocumentHeadersFooters Members


FirstPageHeader Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeadersFooters Class : FirstPageHeader Property
Gets or sets the header for the first page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FirstPageHeader As PdfFlowDocumentHeader
'Usage

Dim instance As PdfFlowDocumentHeadersFooters
Dim value As PdfFlowDocumentHeader

instance.FirstPageHeader = value

value = instance.FirstPageHeader
public PdfFlowDocumentHeader FirstPageHeader {get; set;}
public:
property PdfFlowDocumentHeader^ FirstPageHeader {
   PdfFlowDocumentHeader^ get();
   void set (    PdfFlowDocumentHeader^ value);
}

Property Value

A header object to be displayed on document's first page.
Remarks
If this property is set to null, no header is displayed on the first page. When the MainHeader property is set, this property is also set to the same value. If you want a different header for first page, set this property after setting the MainHeader property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeadersFooters Class
PdfFlowDocumentHeadersFooters Members


MainFooter Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeadersFooters Class : MainFooter Property
Gets or sets the document main footer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MainFooter As PdfFlowDocumentFooter
'Usage

Dim instance As PdfFlowDocumentHeadersFooters
Dim value As PdfFlowDocumentFooter

instance.MainFooter = value

value = instance.MainFooter
public PdfFlowDocumentFooter MainFooter {get; set;}
public:
property PdfFlowDocumentFooter^ MainFooter {
   PdfFlowDocumentFooter^ get();
   void set (    PdfFlowDocumentFooter^ value);
}

Property Value

A footer object to be displayed on document's pages.
Remarks
The main footer is displayed on all document pages. When this property is set, the EvenPagesFooter and FirstPageFooter properties are also set to the same value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeadersFooters Class
PdfFlowDocumentHeadersFooters Members


MainHeader Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentHeadersFooters Class : MainHeader Property
Gets or sets the document main header.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MainHeader As PdfFlowDocumentHeader
'Usage

Dim instance As PdfFlowDocumentHeadersFooters
Dim value As PdfFlowDocumentHeader

instance.MainHeader = value

value = instance.MainHeader
public PdfFlowDocumentHeader MainHeader {get; set;}
public:
property PdfFlowDocumentHeader^ MainHeader {
   PdfFlowDocumentHeader^ get();
   void set (    PdfFlowDocumentHeader^ value);
}

Property Value

A header object to be displayed on document's pages.
Remarks
The main header is displayed on all document pages. When this property is set, the EvenPagesHeader and FirstPageHeader properties are also set to the same value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentHeadersFooters Class
PdfFlowDocumentHeadersFooters Members


%%PageItemTitle%%

PdfFlowDocumentTOCSettings Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentTOCSettings Class
Defines the settings for creating the table of contents in a flow document.
Object Model
PdfFlowDocumentTOCSettings ClassPdfBrush ClassPdfFont ClassPdfFlowContent Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowDocumentTOCSettings
'Usage

Dim instance As PdfFlowDocumentTOCSettings
public class PdfFlowDocumentTOCSettings
public ref class PdfFlowDocumentTOCSettings
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowDocumentTOCSettings

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowDocumentTOCSettings Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentTOCSettings Class

The following tables list the members exposed by PdfFlowDocumentTOCSettings.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowDocumentTOCSettings Constructor | Initializes a new PdfFlowDocumentTOCSettings object.
Top
Public Properties
 | Name | Description
Public Property | ContentsEntryFiller | Gets or sets the contents entry filler.
Public Property | ContentsHeadingIndent | Gets or sets the heading indent.
Public Property | ContentsPagePosition | Gets or sets the contents page position in the document.
Public Property | ContentsTextColor | Gets or sets the table of contents color.
Public Property | ContentsTextFont | Gets or sets the font for displaying the contents text.
Public Property | ContentsTitle | Gets or sets the table of contents title.
Public Property | GenerateContentsPage | Gets or sets a value indicating whether the table of contents should be generated as separate pages in the document.
Public Property | GenerateDocumentOutline | Gets or sets a value indicating whether the table of contents should be generated as document outline (bookmarks).
Public Property | MaxHeadingLevelForContentsPage | Gets or sets the maximum heading level to be included in the contents page.
Public Property | MaxHeadingLevelForDocumentOutline | Gets or sets the maximum heading level to be included in the document outline.
Top
See Also

Reference

PdfFlowDocumentTOCSettings Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowDocumentTOCSettings Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : PdfFlowDocumentTOCSettings Constructor
Initializes a new PdfFlowDocumentTOCSettings object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowDocumentTOCSettings()
public PdfFlowDocumentTOCSettings()
public:
PdfFlowDocumentTOCSettings();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


%%PageItemTitle%% $$Properties$$

PdfFlowDocumentTOCSettings Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowDocumentTOCSettings Class

For a list of all members of this type, see PdfFlowDocumentTOCSettings members.

Public Properties
 | Name | Description
Public Property | ContentsEntryFiller | Gets or sets the contents entry filler.
Public Property | ContentsHeadingIndent | Gets or sets the heading indent.
Public Property | ContentsPagePosition | Gets or sets the contents page position in the document.
Public Property | ContentsTextColor | Gets or sets the table of contents color.
Public Property | ContentsTextFont | Gets or sets the font for displaying the contents text.
Public Property | ContentsTitle | Gets or sets the table of contents title.
Public Property | GenerateContentsPage | Gets or sets a value indicating whether the table of contents should be generated as separate pages in the document.
Public Property | GenerateDocumentOutline | Gets or sets a value indicating whether the table of contents should be generated as document outline (bookmarks).
Public Property | MaxHeadingLevelForContentsPage | Gets or sets the maximum heading level to be included in the contents page.
Public Property | MaxHeadingLevelForDocumentOutline | Gets or sets the maximum heading level to be included in the document outline.
Top
See Also

Reference

PdfFlowDocumentTOCSettings Class
Xfinium.Pdf.FlowDocument Namespace


ContentsEntryFiller Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : ContentsEntryFiller Property
Gets or sets the contents entry filler.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ContentsEntryFiller As Char
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As Char

instance.ContentsEntryFiller = value

value = instance.ContentsEntryFiller
public char ContentsEntryFiller {get; set;}
public:
property char ContentsEntryFiller {
   char get();
   void set (    char value);
}

Property Value

The character, usually a dot, used to provide a visual connection between the heading text and page number in the table of contents.
Remarks
The character is multiplied as necessary to fill the space between the heading text and the page number.
This property is used if GenerateContentsPage property is true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


ContentsHeadingIndent Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : ContentsHeadingIndent Property
Gets or sets the heading indent.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ContentsHeadingIndent As Double
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As Double

instance.ContentsHeadingIndent = value

value = instance.ContentsHeadingIndent
public double ContentsHeadingIndent {get; set;}
public:
property double ContentsHeadingIndent {
   double get();
   void set (    double value);
}

Property Value

Indentation space from left margin for headings and sub-headings.
Remarks
Level 1 headings are aligned to page's left margin. Level 2 headings are indented with ContentsHeadingIndent space, level 3 headings are indented with 2 * ContentsHeadingIndent space, and so on.
This property is used if GenerateContentsPage property is true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


ContentsPagePosition Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : ContentsPagePosition Property
Gets or sets the contents page position in the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ContentsPagePosition As Integer
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As Integer

instance.ContentsPagePosition = value

value = instance.ContentsPagePosition
public int ContentsPagePosition {get; set;}
public:
property int ContentsPagePosition {
   int get();
   void set (    int value);
}

Property Value

Position in the document where the contents page is inserted. A negative value means that the contents page is added at the end of the document.
Remarks
This property is used if GenerateContentsPage property is true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


ContentsTextColor Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : ContentsTextColor Property
Gets or sets the table of contents color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ContentsTextColor As PdfBrush
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As PdfBrush

instance.ContentsTextColor = value

value = instance.ContentsTextColor
public PdfBrush ContentsTextColor {get; set;}
public:
property PdfBrush^ ContentsTextColor {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

The brush used for displaying the entries in the table of contents.
Remarks
This property is used if GenerateContentsPage property is true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


ContentsTextFont Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : ContentsTextFont Property
Gets or sets the font for displaying the contents text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ContentsTextFont As PdfFont
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As PdfFont

instance.ContentsTextFont = value

value = instance.ContentsTextFont
public PdfFont ContentsTextFont {get; set;}
public:
property PdfFont^ ContentsTextFont {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

The font used for displaying the entries in the table of contents.
Remarks
This property is used if GenerateContentsPage property is true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


ContentsTitle Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : ContentsTitle Property
Gets or sets the table of contents title.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ContentsTitle As PdfFlowContent
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As PdfFlowContent

instance.ContentsTitle = value

value = instance.ContentsTitle
public PdfFlowContent ContentsTitle {get; set;}
public:
property PdfFlowContent^ ContentsTitle {
   PdfFlowContent^ get();
   void set (    PdfFlowContent^ value);
}

Property Value

A flow content object used as title for the table of contents.
Remarks
Usually this property is a string like "Contents" or "Table of Contents"
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


GenerateContentsPage Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : GenerateContentsPage Property
Gets or sets a value indicating whether the table of contents should be generated as separate pages in the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property GenerateContentsPage As Boolean
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As Boolean

instance.GenerateContentsPage = value

value = instance.GenerateContentsPage
public bool GenerateContentsPage {get; set;}
public:
property bool GenerateContentsPage {
   bool get();
   void set (    bool value);
}

Property Value

If true pages containing the table of contents are added to the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


GenerateDocumentOutline Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : GenerateDocumentOutline Property
Gets or sets a value indicating whether the table of contents should be generated as document outline (bookmarks).
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property GenerateDocumentOutline As Boolean
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As Boolean

instance.GenerateDocumentOutline = value

value = instance.GenerateDocumentOutline
public bool GenerateDocumentOutline {get; set;}
public:
property bool GenerateDocumentOutline {
   bool get();
   void set (    bool value);
}

Property Value

If true the document outline should be generated from the headings in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


MaxHeadingLevelForContentsPage Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : MaxHeadingLevelForContentsPage Property
Gets or sets the maximum heading level to be included in the contents page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MaxHeadingLevelForContentsPage As UInteger
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As UInteger

instance.MaxHeadingLevelForContentsPage = value

value = instance.MaxHeadingLevelForContentsPage
public uint MaxHeadingLevelForContentsPage {get; set;}
public:
property uint MaxHeadingLevelForContentsPage {
   uint get();
   void set (    uint value);
}

Property Value

Maximum heading level to be included in the contents page. 0 means all levels.
Remarks
This property is used if GenerateContentsPage property is true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


MaxHeadingLevelForDocumentOutline Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowDocumentTOCSettings Class : MaxHeadingLevelForDocumentOutline Property
Gets or sets the maximum heading level to be included in the document outline.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MaxHeadingLevelForDocumentOutline As UInteger
'Usage

Dim instance As PdfFlowDocumentTOCSettings
Dim value As UInteger

instance.MaxHeadingLevelForDocumentOutline = value

value = instance.MaxHeadingLevelForDocumentOutline
public uint MaxHeadingLevelForDocumentOutline {get; set;}
public:
property uint MaxHeadingLevelForDocumentOutline {
   uint get();
   void set (    uint value);
}

Property Value

Maximum heading level to be included in the document outline. 0 means all levels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowDocumentTOCSettings Class
PdfFlowDocumentTOCSettings Members


%%PageItemTitle%%

PdfFlowFormXObjectContent Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowFormXObjectContent Class
Defines a form XObject content that can be added to a flow document.
Object Model
PdfFlowFormXObjectContent ClassPdfBrush ClassPdfFlowContentMargins ClassPdfFlowContentMargins Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowFormXObjectContent
   Inherits PdfFlowContent
'Usage

Dim instance As PdfFlowFormXObjectContent
public class PdfFlowFormXObjectContent : PdfFlowContent
public ref class PdfFlowFormXObjectContent : public PdfFlowContent
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContent
Xfinium.Pdf.FlowDocument.PdfFlowFormXObjectContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowFormXObjectContent Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowFormXObjectContent Class

The following tables list the members exposed by PdfFlowFormXObjectContent.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowFormXObjectContent Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | FormXObjectHeight | Gets or sets the formXObject height.
Public Property | FormXObjectWidth | Gets or sets the formXObject width.
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | SizeIsRelativeToAvailableSpace | Gets or sets a value indicating how the formXObject size is interpreted.
Public Property | VerticalAlign | Gets or sets the vertical align.
Top
See Also

Reference

PdfFlowFormXObjectContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowFormXObjectContent Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowFormXObjectContent Class : PdfFlowFormXObjectContent Constructor
Overload List
Overload | Description
PdfFlowFormXObjectContent Constructor(PdfFormXObject) | Initializes a new PdfFlowFormXObjectContent object.
PdfFlowFormXObjectContent Constructor(PdfFormXObject,Double,Double) | Initializes a new PdfFlowFormXObjectContent object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Class
PdfFlowFormXObjectContent Members


%%PageItemTitle%%

PdfFlowFormXObjectContent Constructor(PdfFormXObject)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowFormXObjectContent Class > PdfFlowFormXObjectContent Constructor : PdfFlowFormXObjectContent Constructor(PdfFormXObject)
Form XObject to draw in the document.
Initializes a new PdfFlowFormXObjectContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal formXObject As PdfFormXObject _
)
'Usage

Dim formXObject As PdfFormXObject

Dim instance As New PdfFlowFormXObjectContent(formXObject)
public PdfFlowFormXObjectContent(
   PdfFormXObject formXObject
)
public:
PdfFlowFormXObjectContent(
   PdfFormXObject^ formXObject
)

Parameters

formXObject
Form XObject to draw in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Class
PdfFlowFormXObjectContent Members
Overload List


%%PageItemTitle%%

PdfFlowFormXObjectContent Constructor(PdfFormXObject,Double,Double)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowFormXObjectContent Class > PdfFlowFormXObjectContent Constructor : PdfFlowFormXObjectContent Constructor(PdfFormXObject,Double,Double)
Form XObject to draw in the document.
Width of displayed form XObject.
Height of displayed form XObject.
Initializes a new PdfFlowFormXObjectContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal formXObject As PdfFormXObject, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim formXObject As PdfFormXObject
Dim width As Double
Dim height As Double

Dim instance As New PdfFlowFormXObjectContent(formXObject, width, height)
public PdfFlowFormXObjectContent(
   PdfFormXObject formXObject,
   double width,
   double height
)
public:
PdfFlowFormXObjectContent(
   PdfFormXObject^ formXObject,
   double width,
   double height
)

Parameters

formXObject
Form XObject to draw in the document.
width
Width of displayed form XObject.
height
Height of displayed form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Class
PdfFlowFormXObjectContent Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowFormXObjectContent Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowFormXObjectContent Class

For a list of all members of this type, see PdfFlowFormXObjectContent members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | FormXObjectHeight | Gets or sets the formXObject height.
Public Property | FormXObjectWidth | Gets or sets the formXObject width.
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | SizeIsRelativeToAvailableSpace | Gets or sets a value indicating how the formXObject size is interpreted.
Public Property | VerticalAlign | Gets or sets the vertical align.
Top
See Also

Reference

PdfFlowFormXObjectContent Class
Xfinium.Pdf.FlowDocument Namespace


FormXObjectHeight Property (PdfFlowFormXObjectContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowFormXObjectContent Class : FormXObjectHeight Property
Gets or sets the formXObject height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FormXObjectHeight As Double
'Usage

Dim instance As PdfFlowFormXObjectContent
Dim value As Double

instance.FormXObjectHeight = value

value = instance.FormXObjectHeight
public double FormXObjectHeight {get; set;}
public:
property double FormXObjectHeight {
   double get();
   void set (    double value);
}

Property Value

The height of the formXObject drawn on the page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when Height is set to a value less than 0.
Remarks
The value of this property represents either a percentage (0 to 100) or an absolute value based on the value of SizeIsRelativeToAvailableSpace property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Class
PdfFlowFormXObjectContent Members


FormXObjectWidth Property (PdfFlowFormXObjectContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowFormXObjectContent Class : FormXObjectWidth Property
Gets or sets the formXObject width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FormXObjectWidth As Double
'Usage

Dim instance As PdfFlowFormXObjectContent
Dim value As Double

instance.FormXObjectWidth = value

value = instance.FormXObjectWidth
public double FormXObjectWidth {get; set;}
public:
property double FormXObjectWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the formXObject drawn on the page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when Width is set to a value less than 0.
Remarks
The value of this property represents either a percentage (0 to 100) or an absolute value based on the value of SizeIsRelativeToAvailableSpace property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Class
PdfFlowFormXObjectContent Members


HorizontalAlign Property (PdfFlowFormXObjectContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowFormXObjectContent Class : HorizontalAlign Property
Gets or sets the horizontal align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowFormXObjectContent
Dim value As PdfGraphicAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
public PdfGraphicAlign HorizontalAlign {get; set;}
public:
property PdfGraphicAlign HorizontalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The formXObject alignment on horizontal relative to available space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Class
PdfFlowFormXObjectContent Members


SizeIsRelativeToAvailableSpace Property (PdfFlowFormXObjectContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowFormXObjectContent Class : SizeIsRelativeToAvailableSpace Property
Gets or sets a value indicating how the formXObject size is interpreted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SizeIsRelativeToAvailableSpace As Boolean
'Usage

Dim instance As PdfFlowFormXObjectContent
Dim value As Boolean

instance.SizeIsRelativeToAvailableSpace = value

value = instance.SizeIsRelativeToAvailableSpace
public bool SizeIsRelativeToAvailableSpace {get; set;}
public:
property bool SizeIsRelativeToAvailableSpace {
   bool get();
   void set (    bool value);
}

Property Value

True if the form XObject size (FormXObjectWidth, FormXObjectHeight properties) is a percentage of the available space, false is the formXObject size is given in absolute values.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Class
PdfFlowFormXObjectContent Members


VerticalAlign Property (PdfFlowFormXObjectContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowFormXObjectContent Class : VerticalAlign Property
Gets or sets the vertical align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VerticalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowFormXObjectContent
Dim value As PdfGraphicAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
public PdfGraphicAlign VerticalAlign {get; set;}
public:
property PdfGraphicAlign VerticalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The formXObject alignment on vertical relative to available space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowFormXObjectContent Class
PdfFlowFormXObjectContent Members


%%PageItemTitle%%

PdfFlowHeadingContent Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowHeadingContent Class
Defines a heading in a flow document.
Object Model
PdfFlowHeadingContent ClassPdfBrush ClassPdfFlowContentMargins ClassPdfFlowContentMargins Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowHeadingContent
   Inherits PdfFlowTextContent
'Usage

Dim instance As PdfFlowHeadingContent
public class PdfFlowHeadingContent : PdfFlowTextContent
public ref class PdfFlowHeadingContent : public PdfFlowTextContent
Remarks
Headings are used for generation of document's outline tree and table of contents.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContent
Xfinium.Pdf.FlowDocument.PdfFlowTextContent
Xfinium.Pdf.FlowDocument.PdfFlowHeadingContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowHeadingContent Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowHeadingContent Class Members
Properties Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowHeadingContent Class

The following tables list the members exposed by PdfFlowHeadingContent.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowHeadingContent Constructor | Initializes a new PdfFlowHeadingContent object.
Top
Public Properties
 | Name | Description
Public Property | AutoNumber | Gets or sets a value indicating whether the headings should be numbered automatically.
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | Level | Gets or sets the heading level (1 to 8).
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTextContent)
Top
See Also

Reference

PdfFlowHeadingContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowHeadingContent Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowHeadingContent Class : PdfFlowHeadingContent Constructor
Heading content.
Initializes a new PdfFlowHeadingContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As PdfFormattedContent _
)
'Usage

Dim content As PdfFormattedContent

Dim instance As New PdfFlowHeadingContent(content)
public PdfFlowHeadingContent(
   PdfFormattedContent content
)
public:
PdfFlowHeadingContent(
   PdfFormattedContent^ content
)

Parameters

content
Heading content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowHeadingContent Class
PdfFlowHeadingContent Members


%%PageItemTitle%% $$Properties$$

PdfFlowHeadingContent Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowHeadingContent Class

For a list of all members of this type, see PdfFlowHeadingContent members.

Public Properties
 | Name | Description
Public Property | AutoNumber | Gets or sets a value indicating whether the headings should be numbered automatically.
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | Level | Gets or sets the heading level (1 to 8).
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Top
See Also

Reference

PdfFlowHeadingContent Class
Xfinium.Pdf.FlowDocument Namespace


AutoNumber Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowHeadingContent Class : AutoNumber Property
Gets or sets a value indicating whether the headings should be numbered automatically.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AutoNumber As Boolean
'Usage

Dim instance As PdfFlowHeadingContent
Dim value As Boolean

instance.AutoNumber = value

value = instance.AutoNumber
public bool AutoNumber {get; set;}
public:
property bool AutoNumber {
   bool get();
   void set (    bool value);
}

Property Value

If true the headings are numbered automatically based on their position in the document and relative to their parent heading.
Remarks
The heading number is generated in the format x.y.z, with one number for each level. Level 1 headings will have one number (x), level 2 headings will have 2 numbers (x.y) where the first number matches the number of parent level 1 heading. Level 3 headings will have 3 numbers (x.y.z) and so on.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowHeadingContent Class
PdfFlowHeadingContent Members


Level Property (PdfFlowHeadingContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowHeadingContent Class : Level Property
Gets or sets the heading level (1 to 8).
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Level As Integer
'Usage

Dim instance As PdfFlowHeadingContent
Dim value As Integer

instance.Level = value

value = instance.Level
public int Level {get; set;}
public:
property int Level {
   int get();
   void set (    int value);
}

Property Value

An integer value greater than 0 and smaller than or equal to 8.
Remarks
Level 1 is the top most heading, level 2 headings are children of level 1 and so on.
The level information is used to build the document's outline tree and to generate correctly the heading number if AutoNumber property is true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowHeadingContent Class
PdfFlowHeadingContent Members


%%PageItemTitle%%

PdfFlowImageContent Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowImageContent Class
Defines an image content that can be added to a flow document.
Object Model
PdfFlowImageContent ClassPdfBrush ClassPdfFlowContentMargins ClassPdfFlowContentMargins Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowImageContent
   Inherits PdfFlowContent
'Usage

Dim instance As PdfFlowImageContent
public class PdfFlowImageContent : PdfFlowContent
public ref class PdfFlowImageContent : public PdfFlowContent
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContent
Xfinium.Pdf.FlowDocument.PdfFlowImageContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowImageContent Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowImageContent Class

The following tables list the members exposed by PdfFlowImageContent.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowImageContent Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | ImageHeight | Gets or sets the image height.
Public Property | ImageWidth | Gets or sets the image width.
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | SizeIsRelativeToAvailableSpace | Gets or sets a value indicating how the image size is interpreted.
Public Property | VerticalAlign | Gets or sets the vertical align.
Top
See Also

Reference

PdfFlowImageContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowImageContent Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowImageContent Class : PdfFlowImageContent Constructor
Overload List
Overload | Description
PdfFlowImageContent Constructor(PdfImage) | Initializes a new PdfFlowImageContent object.
PdfFlowImageContent Constructor(PdfImage,Double,Double) | Initializes a new PdfFlowImageContent object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Class
PdfFlowImageContent Members


%%PageItemTitle%%

PdfFlowImageContent Constructor(PdfImage)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowImageContent Class > PdfFlowImageContent Constructor : PdfFlowImageContent Constructor(PdfImage)
Image to draw in the document.
Initializes a new PdfFlowImageContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As PdfImage _
)
'Usage

Dim image As PdfImage

Dim instance As New PdfFlowImageContent(image)
public PdfFlowImageContent(
   PdfImage image
)
public:
PdfFlowImageContent(
   PdfImage^ image
)

Parameters

image
Image to draw in the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Class
PdfFlowImageContent Members
Overload List


%%PageItemTitle%%

PdfFlowImageContent Constructor(PdfImage,Double,Double)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowImageContent Class > PdfFlowImageContent Constructor : PdfFlowImageContent Constructor(PdfImage,Double,Double)
Image to draw in the document.
Width of displayed image.
Height of displayed image.
Initializes a new PdfFlowImageContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As PdfImage, _
   ByVal imageWidth As Double, _
   ByVal imageHeight As Double _
)
'Usage

Dim image As PdfImage
Dim imageWidth As Double
Dim imageHeight As Double

Dim instance As New PdfFlowImageContent(image, imageWidth, imageHeight)
public PdfFlowImageContent(
   PdfImage image,
   double imageWidth,
   double imageHeight
)
public:
PdfFlowImageContent(
   PdfImage^ image,
   double imageWidth,
   double imageHeight
)

Parameters

image
Image to draw in the document.
imageWidth
Width of displayed image.
imageHeight
Height of displayed image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Class
PdfFlowImageContent Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowImageContent Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowImageContent Class

For a list of all members of this type, see PdfFlowImageContent members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | ImageHeight | Gets or sets the image height.
Public Property | ImageWidth | Gets or sets the image width.
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | SizeIsRelativeToAvailableSpace | Gets or sets a value indicating how the image size is interpreted.
Public Property | VerticalAlign | Gets or sets the vertical align.
Top
See Also

Reference

PdfFlowImageContent Class
Xfinium.Pdf.FlowDocument Namespace


HorizontalAlign Property (PdfFlowImageContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowImageContent Class : HorizontalAlign Property
Gets or sets the horizontal align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowImageContent
Dim value As PdfGraphicAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
public PdfGraphicAlign HorizontalAlign {get; set;}
public:
property PdfGraphicAlign HorizontalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The image alignment on horizontal relative to available space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Class
PdfFlowImageContent Members


ImageHeight Property (PdfFlowImageContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowImageContent Class : ImageHeight Property
Gets or sets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageHeight As Double
'Usage

Dim instance As PdfFlowImageContent
Dim value As Double

instance.ImageHeight = value

value = instance.ImageHeight
public double ImageHeight {get; set;}
public:
property double ImageHeight {
   double get();
   void set (    double value);
}

Property Value

The height of the image drawn on the page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when Height is set to a value less than 0.
Remarks
The value of this property represents either a percentage (0 to 100) or an absolute value based on the value of SizeIsRelativeToAvailableSpace property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Class
PdfFlowImageContent Members


ImageWidth Property (PdfFlowImageContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowImageContent Class : ImageWidth Property
Gets or sets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageWidth As Double
'Usage

Dim instance As PdfFlowImageContent
Dim value As Double

instance.ImageWidth = value

value = instance.ImageWidth
public double ImageWidth {get; set;}
public:
property double ImageWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the image drawn on the page.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when Width is set to a value less than 0.
Remarks
The value of this property represents either a percentage (0 to 100) or an absolute value based on the value of SizeIsRelativeToAvailableSpace property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Class
PdfFlowImageContent Members


SizeIsRelativeToAvailableSpace Property (PdfFlowImageContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowImageContent Class : SizeIsRelativeToAvailableSpace Property
Gets or sets a value indicating how the image size is interpreted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SizeIsRelativeToAvailableSpace As Boolean
'Usage

Dim instance As PdfFlowImageContent
Dim value As Boolean

instance.SizeIsRelativeToAvailableSpace = value

value = instance.SizeIsRelativeToAvailableSpace
public bool SizeIsRelativeToAvailableSpace {get; set;}
public:
property bool SizeIsRelativeToAvailableSpace {
   bool get();
   void set (    bool value);
}

Property Value

True if the image size (ImageWidth, ImageHeight properties) is a percentage of the available space, false is the image size is given in absolute values.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Class
PdfFlowImageContent Members


VerticalAlign Property (PdfFlowImageContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowImageContent Class : VerticalAlign Property
Gets or sets the vertical align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VerticalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowImageContent
Dim value As PdfGraphicAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
public PdfGraphicAlign VerticalAlign {get; set;}
public:
property PdfGraphicAlign VerticalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The image alignment on vertical relative to available space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowImageContent Class
PdfFlowImageContent Members


%%PageItemTitle%%

PdfFlowPageCreatedEventArgs Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageCreatedEventArgs Class
Defines the event arguments for PdfFlowDocument.PageCreated event.
Object Model
PdfFlowPageCreatedEventArgs ClassPdfPage ClassPdfFlowPageDefaults Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowPageCreatedEventArgs
   Inherits PdfFlowPageEventArgs
'Usage

Dim instance As PdfFlowPageCreatedEventArgs
public class PdfFlowPageCreatedEventArgs : PdfFlowPageEventArgs
public ref class PdfFlowPageCreatedEventArgs : public PdfFlowPageEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Xfinium.Pdf.FlowDocument.PdfFlowPageEventArgs
Xfinium.Pdf.FlowDocument.PdfFlowPageCreatedEventArgs

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageCreatedEventArgs Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowPageCreatedEventArgs Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageCreatedEventArgs Class

The following tables list the members exposed by PdfFlowPageCreatedEventArgs.

Public Properties
 | Name | Description
Public Property | Page | Gets the page that has been created. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowPageEventArgs)
Public Property | PageDefaults | Gets the default initialization values for the page.
Top
See Also

Reference

PdfFlowPageCreatedEventArgs Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowPageCreatedEventArgs Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageCreatedEventArgs Class

For a list of all members of this type, see PdfFlowPageCreatedEventArgs members.

Public Properties
 | Name | Description
Public Property | Page | Gets the page that has been created. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowPageEventArgs)
Public Property | PageDefaults | Gets the default initialization values for the page.
Top
See Also

Reference

PdfFlowPageCreatedEventArgs Class
Xfinium.Pdf.FlowDocument Namespace


PageDefaults Property (PdfFlowPageCreatedEventArgs)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageCreatedEventArgs Class : PageDefaults Property
Gets the default initialization values for the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PageDefaults As PdfFlowPageDefaults
'Usage

Dim instance As PdfFlowPageCreatedEventArgs
Dim value As PdfFlowPageDefaults

value = instance.PageDefaults
public PdfFlowPageDefaults PageDefaults {get;}
public:
property PdfFlowPageDefaults^ PageDefaults {
   PdfFlowPageDefaults^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageCreatedEventArgs Class
PdfFlowPageCreatedEventArgs Members


%%PageItemTitle%%

PdfFlowPageDefaults Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageDefaults Class
Defines default values for initializing a page in flow mode.
Object Model
PdfFlowPageDefaults ClassPdfFlowContentMargins Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowPageDefaults
'Usage

Dim instance As PdfFlowPageDefaults
public class PdfFlowPageDefaults
public ref class PdfFlowPageDefaults
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowPageDefaults

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowPageDefaults Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageDefaults Class

The following tables list the members exposed by PdfFlowPageDefaults.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowPageDefaults Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the default page height.
Public Property | Margins | Gets the default page margins.
Public Property | Rotation | Gets or sets the default page rotation.
Public Property | Width | Gets or sets the default page width.
Top
See Also

Reference

PdfFlowPageDefaults Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowPageDefaults Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageDefaults Class : PdfFlowPageDefaults Constructor
Overload List
Overload | Description
PdfFlowPageDefaults Constructor() | Initializes a new PdfFlowPageDefaults object;
PdfFlowPageDefaults Constructor(Double,Double) | Initializes a new PdfFlowPageDefaults object;
PdfFlowPageDefaults Constructor(PdfFlowPageDefaults) | Initializes a new PdfFlowPageDefaults object;
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Class
PdfFlowPageDefaults Members


%%PageItemTitle%%

PdfFlowPageDefaults Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageDefaults Class > PdfFlowPageDefaults Constructor : PdfFlowPageDefaults Constructor()
Initializes a new PdfFlowPageDefaults object;
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowPageDefaults()
public PdfFlowPageDefaults()
public:
PdfFlowPageDefaults();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Class
PdfFlowPageDefaults Members
Overload List


%%PageItemTitle%%

PdfFlowPageDefaults Constructor(Double,Double)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageDefaults Class > PdfFlowPageDefaults Constructor : PdfFlowPageDefaults Constructor(Double,Double)
Default page width
Default page height
Initializes a new PdfFlowPageDefaults object;
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New PdfFlowPageDefaults(width, height)
public PdfFlowPageDefaults(
   double width,
   double height
)
public:
PdfFlowPageDefaults(
   double width,
   double height
)

Parameters

width
Default page width
height
Default page height
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Class
PdfFlowPageDefaults Members
Overload List


%%PageItemTitle%%

PdfFlowPageDefaults Constructor(PdfFlowPageDefaults)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageDefaults Class > PdfFlowPageDefaults Constructor : PdfFlowPageDefaults Constructor(PdfFlowPageDefaults)
Source page defaults
Initializes a new PdfFlowPageDefaults object;
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFlowPageDefaults _
)
'Usage

Dim source As PdfFlowPageDefaults

Dim instance As New PdfFlowPageDefaults(source)
public PdfFlowPageDefaults(
   PdfFlowPageDefaults source
)
public:
PdfFlowPageDefaults(
   PdfFlowPageDefaults^ source
)

Parameters

source
Source page defaults
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Class
PdfFlowPageDefaults Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowPageDefaults Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageDefaults Class

For a list of all members of this type, see PdfFlowPageDefaults members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the default page height.
Public Property | Margins | Gets the default page margins.
Public Property | Rotation | Gets or sets the default page rotation.
Public Property | Width | Gets or sets the default page width.
Top
See Also

Reference

PdfFlowPageDefaults Class
Xfinium.Pdf.FlowDocument Namespace


Height Property (PdfFlowPageDefaults)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageDefaults Class : Height Property
Gets or sets the default page height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PdfFlowPageDefaults
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The default page height for a flow document
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Class
PdfFlowPageDefaults Members


Margins Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageDefaults Class : Margins Property
Gets the default page margins.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Margins As PdfFlowContentMargins
'Usage

Dim instance As PdfFlowPageDefaults
Dim value As PdfFlowContentMargins

value = instance.Margins
public PdfFlowContentMargins Margins {get;}
public:
property PdfFlowContentMargins^ Margins {
   PdfFlowContentMargins^ get();
}

Property Value

A PdfFlowContentMargins object specifying the default page margins.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Class
PdfFlowPageDefaults Members


Rotation Property (PdfFlowPageDefaults)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageDefaults Class : Rotation Property
Gets or sets the default page rotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Rotation As Integer
'Usage

Dim instance As PdfFlowPageDefaults
Dim value As Integer

instance.Rotation = value

value = instance.Rotation
public int Rotation {get; set;}
public:
property int Rotation {
   int get();
   void set (    int value);
}

Property Value

The default page rotation for a flow document
Remarks
The accepted values for this property are 0, 90, 180 and 270 degrees.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Class
PdfFlowPageDefaults Members


Width Property (PdfFlowPageDefaults)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageDefaults Class : Width Property
Gets or sets the default page width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PdfFlowPageDefaults
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The default page width for a flow document
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageDefaults Class
PdfFlowPageDefaults Members


%%PageItemTitle%%

PdfFlowPageEventArgs Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageEventArgs Class
Defines the event arguments for page related events.
Object Model
PdfFlowPageEventArgs ClassPdfPage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowPageEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PdfFlowPageEventArgs
public class PdfFlowPageEventArgs : System.EventArgs
public ref class PdfFlowPageEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Xfinium.Pdf.FlowDocument.PdfFlowPageEventArgs
Xfinium.Pdf.FlowDocument.PdfFlowPageCreatedEventArgs

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageEventArgs Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowPageEventArgs Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageEventArgs Class

The following tables list the members exposed by PdfFlowPageEventArgs.

Public Properties
 | Name | Description
Public Property | Page | Gets the page that has been created.
Top
See Also

Reference

PdfFlowPageEventArgs Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowPageEventArgs Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowPageEventArgs Class

For a list of all members of this type, see PdfFlowPageEventArgs members.

Public Properties
 | Name | Description
Public Property | Page | Gets the page that has been created.
Top
See Also

Reference

PdfFlowPageEventArgs Class
Xfinium.Pdf.FlowDocument Namespace


Page Property (PdfFlowPageEventArgs)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowPageEventArgs Class : Page Property
Gets the page that has been created.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Page As PdfPage
'Usage

Dim instance As PdfFlowPageEventArgs
Dim value As PdfPage

value = instance.Page
public PdfPage Page {get;}
public:
property PdfPage^ Page {
   PdfPage^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowPageEventArgs Class
PdfFlowPageEventArgs Members


%%PageItemTitle%%

PdfFlowTableCell Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCell Class
Defines the base class for cells in a table.
Object Model
PdfFlowTableCell ClassPdfBrush ClassPdfFlowContentBorders ClassPdfFlowContentMargins ClassPdfFlowTableRow Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfFlowTableCell
'Usage

Dim instance As PdfFlowTableCell
public abstract class PdfFlowTableCell
public ref class PdfFlowTableCell abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowTableCell
Xfinium.Pdf.FlowDocument.PdfFlowTableCompositeCell
Xfinium.Pdf.FlowDocument.PdfFlowTableFormXObjectCell
Xfinium.Pdf.FlowDocument.PdfFlowTableImageCell
Xfinium.Pdf.FlowDocument.PdfFlowTableStringCell

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableCell Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCell Class

The following tables list the members exposed by PdfFlowTableCell.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background.
Public Property | Borders | Gets or sets the cell borders.
Public Property | ColSpan | Gets or sets the number of columns this cell spans on.
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | InnerMargins | Gets or sets the cell inner margins.
Public Property | Row | Gets the row this cell belongs to.
Public Property | RowSpan | Gets or sets the number of rows this cell spans on.
Public Property | VerticalAlign | Gets or sets the vertical align.
Top
See Also

Reference

PdfFlowTableCell Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowTableCell Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCell Class

For a list of all members of this type, see PdfFlowTableCell members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background.
Public Property | Borders | Gets or sets the cell borders.
Public Property | ColSpan | Gets or sets the number of columns this cell spans on.
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | InnerMargins | Gets or sets the cell inner margins.
Public Property | Row | Gets the row this cell belongs to.
Public Property | RowSpan | Gets or sets the number of rows this cell spans on.
Public Property | VerticalAlign | Gets or sets the vertical align.
Top
See Also

Reference

PdfFlowTableCell Class
Xfinium.Pdf.FlowDocument Namespace


Background Property (PdfFlowTableCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCell Class : Background Property
Gets or sets the cell background.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Background As PdfBrush
'Usage

Dim instance As PdfFlowTableCell
Dim value As PdfBrush

instance.Background = value

value = instance.Background
public PdfBrush Background {get; set;}
public:
property PdfBrush^ Background {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfBrush object that specifies how the cell background is filled.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Class
PdfFlowTableCell Members


Borders Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCell Class : Borders Property
Gets or sets the cell borders.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Borders As PdfFlowContentBorders
'Usage

Dim instance As PdfFlowTableCell
Dim value As PdfFlowContentBorders

instance.Borders = value

value = instance.Borders
public PdfFlowContentBorders Borders {get; set;}
public:
property PdfFlowContentBorders^ Borders {
   PdfFlowContentBorders^ get();
   void set (    PdfFlowContentBorders^ value);
}

Property Value

A PdfFlowContentBorders object specifying how the top, right, bottom and left borders are drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Class
PdfFlowTableCell Members


ColSpan Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCell Class : ColSpan Property
Gets or sets the number of columns this cell spans on.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColSpan As UInteger
'Usage

Dim instance As PdfFlowTableCell
Dim value As UInteger

instance.ColSpan = value

value = instance.ColSpan
public uint ColSpan {get; set;}
public:
property uint ColSpan {
   uint get();
   void set (    uint value);
}

Property Value

The number of columns on which this cell spans.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Class
PdfFlowTableCell Members


HorizontalAlign Property (PdfFlowTableCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCell Class : HorizontalAlign Property
Gets or sets the horizontal align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowTableCell
Dim value As PdfGraphicAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
public PdfGraphicAlign HorizontalAlign {get; set;}
public:
property PdfGraphicAlign HorizontalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The default horizontal alignment for the cells in the column.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Class
PdfFlowTableCell Members


InnerMargins Property (PdfFlowTableCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCell Class : InnerMargins Property
Gets or sets the cell inner margins.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InnerMargins As PdfFlowContentMargins
'Usage

Dim instance As PdfFlowTableCell
Dim value As PdfFlowContentMargins

instance.InnerMargins = value

value = instance.InnerMargins
public PdfFlowContentMargins InnerMargins {get; set;}
public:
property PdfFlowContentMargins^ InnerMargins {
   PdfFlowContentMargins^ get();
   void set (    PdfFlowContentMargins^ value);
}

Property Value

A PdfFlowContentMargins object specifying the cell inner margins.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Class
PdfFlowTableCell Members


Row Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCell Class : Row Property
Gets the row this cell belongs to.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Row As PdfFlowTableRow
'Usage

Dim instance As PdfFlowTableCell
Dim value As PdfFlowTableRow

value = instance.Row
public PdfFlowTableRow Row {get;}
public:
property PdfFlowTableRow^ Row {
   PdfFlowTableRow^ get();
}

Property Value

The row that owns the cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Class
PdfFlowTableCell Members


RowSpan Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCell Class : RowSpan Property
Gets or sets the number of rows this cell spans on.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RowSpan As UInteger
'Usage

Dim instance As PdfFlowTableCell
Dim value As UInteger

instance.RowSpan = value

value = instance.RowSpan
public uint RowSpan {get; set;}
public:
property uint RowSpan {
   uint get();
   void set (    uint value);
}

Property Value

The number of rows on which this cell spans.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Class
PdfFlowTableCell Members


VerticalAlign Property (PdfFlowTableCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCell Class : VerticalAlign Property
Gets or sets the vertical align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VerticalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowTableCell
Dim value As PdfGraphicAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
public PdfGraphicAlign VerticalAlign {get; set;}
public:
property PdfGraphicAlign VerticalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The default vertical alignment for the cells in the column.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCell Class
PdfFlowTableCell Members


%%PageItemTitle%%

PdfFlowTableCellCollection Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCellCollection Class
Defines a collection of cells in a table row.
Object Model
PdfFlowTableCellCollection ClassPdfFlowTableCell Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableCellCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfFlowTableCell)
'Usage

Dim instance As PdfFlowTableCellCollection
public class PdfFlowTableCellCollection : System.Collections.ObjectModel.Collection<PdfFlowTableCell>
public ref class PdfFlowTableCellCollection : public System.Collections.ObjectModel.Collection<PdfFlowTableCell>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.FlowDocument.PdfFlowTableCellCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCellCollection Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableCellCollection Class Members
Properties Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCellCollection Class

The following tables list the members exposed by PdfFlowTableCellCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Top
See Also

Reference

PdfFlowTableCellCollection Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTableColumn Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableColumn Class
Defines a column in a PdfFlowTableContent object.
Object Model
PdfFlowTableColumn ClassPdfBrush Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableColumn
'Usage

Dim instance As PdfFlowTableColumn
public class PdfFlowTableColumn
public ref class PdfFlowTableColumn
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowTableColumn

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableColumn Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableColumn Class

The following tables list the members exposed by PdfFlowTableColumn.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowTableColumn Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the column background.
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | VerticalAlign | Gets or sets the vertical align.
Public Property | Width | Gets or sets the column width.
Public Property | WidthIsRelativeToTable | Gets or sets a flag indicating whether the Width value is absolute or percentage relative to table width.
Top
See Also

Reference

PdfFlowTableColumn Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTableColumn Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class : PdfFlowTableColumn Constructor
Overload List
Overload | Description
PdfFlowTableColumn Constructor() | Initializes a new PdfFlowTableColumn object.
PdfFlowTableColumn Constructor(PdfFlowTableColumn) | Initializes a new PdfFlowTableColumn object from another column.
PdfFlowTableColumn Constructor(Double) | Initializes a new PdfFlowTableColumn object.
PdfFlowTableColumn Constructor(Double,Boolean) | Initializes a new PdfFlowTableColumn object.
PdfFlowTableColumn Constructor(Double,PdfGraphicAlign,PdfGraphicAlign,PdfBrush) | Initializes a new PdfFlowTableColumn object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members


%%PageItemTitle%%

PdfFlowTableColumn Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class > PdfFlowTableColumn Constructor : PdfFlowTableColumn Constructor()
Initializes a new PdfFlowTableColumn object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowTableColumn()
public PdfFlowTableColumn()
public:
PdfFlowTableColumn();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members
Overload List


%%PageItemTitle%%

PdfFlowTableColumn Constructor(PdfFlowTableColumn)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class > PdfFlowTableColumn Constructor : PdfFlowTableColumn Constructor(PdfFlowTableColumn)
Source column.
Initializes a new PdfFlowTableColumn object from another column.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFlowTableColumn _
)
'Usage

Dim source As PdfFlowTableColumn

Dim instance As New PdfFlowTableColumn(source)
public PdfFlowTableColumn(
   PdfFlowTableColumn source
)
public:
PdfFlowTableColumn(
   PdfFlowTableColumn^ source
)

Parameters

source
Source column.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members
Overload List


%%PageItemTitle%%

PdfFlowTableColumn Constructor(Double)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class > PdfFlowTableColumn Constructor : PdfFlowTableColumn Constructor(Double)
Column width.
Initializes a new PdfFlowTableColumn object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double _
)
'Usage

Dim width As Double

Dim instance As New PdfFlowTableColumn(width)
public PdfFlowTableColumn(
   double width
)
public:
PdfFlowTableColumn(
   double width
)

Parameters

width
Column width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members
Overload List


%%PageItemTitle%%

PdfFlowTableColumn Constructor(Double,Boolean)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class > PdfFlowTableColumn Constructor : PdfFlowTableColumn Constructor(Double,Boolean)
Column width.
True if the width is relative to table, false if it is an absolute value.
Initializes a new PdfFlowTableColumn object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal widthIsRelativeToTable As Boolean _
)
'Usage

Dim width As Double
Dim widthIsRelativeToTable As Boolean

Dim instance As New PdfFlowTableColumn(width, widthIsRelativeToTable)
public PdfFlowTableColumn(
   double width,
   bool widthIsRelativeToTable
)
public:
PdfFlowTableColumn(
   double width,
   bool widthIsRelativeToTable
)

Parameters

width
Column width.
widthIsRelativeToTable
True if the width is relative to table, false if it is an absolute value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members
Overload List


%%PageItemTitle%%

PdfFlowTableColumn Constructor(Double,PdfGraphicAlign,PdfGraphicAlign,PdfBrush)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class > PdfFlowTableColumn Constructor : PdfFlowTableColumn Constructor(Double,PdfGraphicAlign,PdfGraphicAlign,PdfBrush)
Column width.
Horizontal align for cells in the column
Vertical align for cells in the column
Background for cells in the column.
Initializes a new PdfFlowTableColumn object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal horizontalAlign As PdfGraphicAlign, _
   ByVal verticalAlign As PdfGraphicAlign, _
   ByVal background As PdfBrush _
)
'Usage

Dim width As Double
Dim horizontalAlign As PdfGraphicAlign
Dim verticalAlign As PdfGraphicAlign
Dim background As PdfBrush

Dim instance As New PdfFlowTableColumn(width, horizontalAlign, verticalAlign, background)
public PdfFlowTableColumn(
   double width,
   PdfGraphicAlign horizontalAlign,
   PdfGraphicAlign verticalAlign,
   PdfBrush background
)
public:
PdfFlowTableColumn(
   double width,
   PdfGraphicAlign horizontalAlign,
   PdfGraphicAlign verticalAlign,
   PdfBrush^ background
)

Parameters

width
Column width.
horizontalAlign
Horizontal align for cells in the column
verticalAlign
Vertical align for cells in the column
background
Background for cells in the column.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowTableColumn Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableColumn Class

For a list of all members of this type, see PdfFlowTableColumn members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the column background.
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | VerticalAlign | Gets or sets the vertical align.
Public Property | Width | Gets or sets the column width.
Public Property | WidthIsRelativeToTable | Gets or sets a flag indicating whether the Width value is absolute or percentage relative to table width.
Top
See Also

Reference

PdfFlowTableColumn Class
Xfinium.Pdf.FlowDocument Namespace


Background Property (PdfFlowTableColumn)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class : Background Property
Gets or sets the column background.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Background As PdfBrush
'Usage

Dim instance As PdfFlowTableColumn
Dim value As PdfBrush

instance.Background = value

value = instance.Background
public PdfBrush Background {get; set;}
public:
property PdfBrush^ Background {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfBrush object that specifies how the column background is filled.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members


HorizontalAlign Property (PdfFlowTableColumn)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class : HorizontalAlign Property
Gets or sets the horizontal align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowTableColumn
Dim value As PdfGraphicAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
public PdfGraphicAlign HorizontalAlign {get; set;}
public:
property PdfGraphicAlign HorizontalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The default horizontal alignment for the cells in the column.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members


VerticalAlign Property (PdfFlowTableColumn)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class : VerticalAlign Property
Gets or sets the vertical align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VerticalAlign As PdfGraphicAlign
'Usage

Dim instance As PdfFlowTableColumn
Dim value As PdfGraphicAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
public PdfGraphicAlign VerticalAlign {get; set;}
public:
property PdfGraphicAlign VerticalAlign {
   PdfGraphicAlign get();
   void set (    PdfGraphicAlign value);
}

Property Value

The default vertical alignment for the cells in the column.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members


Width Property (PdfFlowTableColumn)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class : Width Property
Gets or sets the column width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PdfFlowTableColumn
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the column, as an absolute value or percentage relative to table width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members


WidthIsRelativeToTable Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableColumn Class : WidthIsRelativeToTable Property
Gets or sets a flag indicating whether the Width value is absolute or percentage relative to table width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WidthIsRelativeToTable As Boolean
'Usage

Dim instance As PdfFlowTableColumn
Dim value As Boolean

instance.WidthIsRelativeToTable = value

value = instance.WidthIsRelativeToTable
public bool WidthIsRelativeToTable {get; set;}
public:
property bool WidthIsRelativeToTable {
   bool get();
   void set (    bool value);
}

Property Value

True if the Width is relative, false otherwise. Default is false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableColumn Class
PdfFlowTableColumn Members


%%PageItemTitle%%

PdfFlowTableCompositeCell Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCompositeCell Class
Defines a cell that contains variable flow content.
Object Model
PdfFlowTableCompositeCell ClassPdfBrush ClassPdfFlowContentBorders ClassPdfFlowContentCollection ClassPdfFlowContent ClassPdfFlowContentMargins ClassPdfFlowTableRow Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableCompositeCell
   Inherits PdfFlowTableCell
'Usage

Dim instance As PdfFlowTableCompositeCell
public class PdfFlowTableCompositeCell : PdfFlowTableCell
public ref class PdfFlowTableCompositeCell : public PdfFlowTableCell
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowTableCell
Xfinium.Pdf.FlowDocument.PdfFlowTableCompositeCell

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCompositeCell Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableCompositeCell Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCompositeCell Class

The following tables list the members exposed by PdfFlowTableCompositeCell.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowTableCompositeCell Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Borders | Gets or sets the cell borders. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | ColSpan | Gets or sets the number of columns this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Content | Gets the cell content.
Public Property | HorizontalAlign | Gets or sets the horizontal align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | InnerMargins | Gets or sets the cell inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Row | Gets the row this cell belongs to. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | RowSpan | Gets or sets the number of rows this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | VerticalAlign | Gets or sets the vertical align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Top
See Also

Reference

PdfFlowTableCompositeCell Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTableCompositeCell Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCompositeCell Class : PdfFlowTableCompositeCell Constructor
Overload List
Overload | Description
PdfFlowTableCompositeCell Constructor() | Initializes a new PdfFlowTableCompositeCell object.
PdfFlowTableCompositeCell Constructor(PdfFlowTableCompositeCell) | Initializes a new PdfFlowTableCompositeCell object with a copy of another cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCompositeCell Class
PdfFlowTableCompositeCell Members


%%PageItemTitle%%

PdfFlowTableCompositeCell Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCompositeCell Class > PdfFlowTableCompositeCell Constructor : PdfFlowTableCompositeCell Constructor()
Initializes a new PdfFlowTableCompositeCell object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowTableCompositeCell()
public PdfFlowTableCompositeCell()
public:
PdfFlowTableCompositeCell();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCompositeCell Class
PdfFlowTableCompositeCell Members
Overload List


%%PageItemTitle%%

PdfFlowTableCompositeCell Constructor(PdfFlowTableCompositeCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCompositeCell Class > PdfFlowTableCompositeCell Constructor : PdfFlowTableCompositeCell Constructor(PdfFlowTableCompositeCell)
Source cell.
Initializes a new PdfFlowTableCompositeCell object with a copy of another cell.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFlowTableCompositeCell _
)
'Usage

Dim source As PdfFlowTableCompositeCell

Dim instance As New PdfFlowTableCompositeCell(source)
public PdfFlowTableCompositeCell(
   PdfFlowTableCompositeCell source
)
public:
PdfFlowTableCompositeCell(
   PdfFlowTableCompositeCell^ source
)

Parameters

source
Source cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCompositeCell Class
PdfFlowTableCompositeCell Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowTableCompositeCell Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCompositeCell Class

For a list of all members of this type, see PdfFlowTableCompositeCell members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Borders | Gets or sets the cell borders. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | ColSpan | Gets or sets the number of columns this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Content | Gets the cell content.
Public Property | HorizontalAlign | Gets or sets the horizontal align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | InnerMargins | Gets or sets the cell inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Row | Gets the row this cell belongs to. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | RowSpan | Gets or sets the number of rows this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | VerticalAlign | Gets or sets the vertical align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Top
See Also

Reference

PdfFlowTableCompositeCell Class
Xfinium.Pdf.FlowDocument Namespace


Content Property (PdfFlowTableCompositeCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableCompositeCell Class : Content Property
Gets the cell content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Content As PdfFlowContentCollection
'Usage

Dim instance As PdfFlowTableCompositeCell
Dim value As PdfFlowContentCollection

value = instance.Content
public PdfFlowContentCollection Content {get;}
public:
property PdfFlowContentCollection^ Content {
   PdfFlowContentCollection^ get();
}

Property Value

A collection of PdfFlowContent object representing the cell content.
Remarks
The content of this cell consists of multiple flow content objects added to this collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableCompositeCell Class
PdfFlowTableCompositeCell Members


%%PageItemTitle%%

PdfFlowTableContent Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableContent Class
Defines a table that can be added to a flow document.
Object Model
PdfFlowTableContent ClassPdfBrush ClassPdfPen ClassPdfFlowTableColumn ClassPdfFlowTableCell ClassPdfFlowTableRowCollection ClassPdfFlowTableRow ClassPdfFlowContentMargins ClassPdfFlowContentMargins ClassPdfFlowTableRowCollection ClassPdfFlowTableRow Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableContent
   Inherits PdfFlowContent
'Usage

Dim instance As PdfFlowTableContent
public class PdfFlowTableContent : PdfFlowContent
public ref class PdfFlowTableContent : public PdfFlowContent
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContent
Xfinium.Pdf.FlowDocument.PdfFlowTableContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableContent Class Members
Properties Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableContent Class

The following tables list the members exposed by PdfFlowTableContent.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowTableContent Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | Border | Gets or sets the table border.
Public Property | Columns | Gets the table columns.
Public Property | DefaultCell | Gets or sets the default cell model.
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | HeaderRows | Gets the header rows.
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | MinRowHeight | Minimum height for table rows.
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | Rows | Gets the table rows.
Top
Public Methods
 | Name | Description
Public Method | CreateCell | Creates a new cell based on the DefaultCell property.
Top
See Also

Reference

PdfFlowTableContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTableContent Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class : PdfFlowTableContent Constructor
Overload List
Overload | Description
PdfFlowTableContent Constructor(Int32) | Initializes a new PdfFlowTableContent object with the specified number of columns.
PdfFlowTableContent Constructor(PdfFlowTableColumn[]) | Initializes a new PdfFlowTableContent object with the specified columns.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members


%%PageItemTitle%%

PdfFlowTableContent Constructor(Int32)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class > PdfFlowTableContent Constructor : PdfFlowTableContent Constructor(Int32)
The number of columns in the table.
Initializes a new PdfFlowTableContent object with the specified number of columns.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal columnCount As Integer _
)
'Usage

Dim columnCount As Integer

Dim instance As New PdfFlowTableContent(columnCount)
public PdfFlowTableContent(
   int columnCount
)
public:
PdfFlowTableContent(
   int columnCount
)

Parameters

columnCount
The number of columns in the table.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when columnCount is less than or equal to zero.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members
Overload List


%%PageItemTitle%%

PdfFlowTableContent Constructor(PdfFlowTableColumn[])

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class > PdfFlowTableContent Constructor : PdfFlowTableContent Constructor(PdfFlowTableColumn[])
The array of columns in the table.
Initializes a new PdfFlowTableContent object with the specified columns.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal columns() As PdfFlowTableColumn _
)
'Usage

Dim columns() As PdfFlowTableColumn

Dim instance As New PdfFlowTableContent(columns)
public PdfFlowTableContent(
   PdfFlowTableColumn[] columns
)
public:
PdfFlowTableContent(
   array<PdfFlowTableColumn^>^ columns
)

Parameters

columns
The array of columns in the table.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when columns is null.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfFlowTableContent Class Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableContent Class

For a list of all members of this type, see PdfFlowTableContent members.

Public Methods
 | Name | Description
Public Method | CreateCell | Creates a new cell based on the DefaultCell property.
Top
See Also

Reference

PdfFlowTableContent Class
Xfinium.Pdf.FlowDocument Namespace


CreateCell Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class : CreateCell Method
The cell content, it depends on the cell being created. If the cell is a string cell, then the object is converted to string and set as cell content.
Creates a new cell based on the DefaultCell property.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CreateCell( _
   ByVal cellContent As Object _
) As PdfFlowTableCell
'Usage

Dim instance As PdfFlowTableContent
Dim cellContent As Object
Dim value As PdfFlowTableCell

value = instance.CreateCell(cellContent)
public PdfFlowTableCell CreateCell(
   object cellContent
)
public:
PdfFlowTableCell^ CreateCell(
   Object^ cellContent
)

Parameters

cellContent
The cell content, it depends on the cell being created. If the cell is a string cell, then the object is converted to string and set as cell content.

Return Value

A new cell object with the properties set by default to the values defined by the DefaultCell object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members


%%PageItemTitle%% $$Properties$$

PdfFlowTableContent Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableContent Class

For a list of all members of this type, see PdfFlowTableContent members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | Border | Gets or sets the table border.
Public Property | Columns | Gets the table columns.
Public Property | DefaultCell | Gets or sets the default cell model.
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | HeaderRows | Gets the header rows.
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | MinRowHeight | Minimum height for table rows.
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | Rows | Gets the table rows.
Top
See Also

Reference

PdfFlowTableContent Class
Xfinium.Pdf.FlowDocument Namespace


Border Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class : Border Property
Gets or sets the table border.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Border As PdfPen
'Usage

Dim instance As PdfFlowTableContent
Dim value As PdfPen

instance.Border = value

value = instance.Border
public PdfPen Border {get; set;}
public:
property PdfPen^ Border {
   PdfPen^ get();
   void set (    PdfPen^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfPen object that describes how the table border is drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members


Columns Property (PdfFlowTableContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class : Columns Property
Gets the table columns.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Columns As PdfFlowTableColumn()
'Usage

Dim instance As PdfFlowTableContent
Dim value() As PdfFlowTableColumn

value = instance.Columns
public PdfFlowTableColumn[] Columns {get;}
public:
property array<PdfFlowTableColumn^>^ Columns {
   array<PdfFlowTableColumn^>^ get();
}

Property Value

The list of columns in the table.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members


DefaultCell Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class : DefaultCell Property
Gets or sets the default cell model.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultCell As PdfFlowTableCell
'Usage

Dim instance As PdfFlowTableContent
Dim value As PdfFlowTableCell

instance.DefaultCell = value

value = instance.DefaultCell
public PdfFlowTableCell DefaultCell {get; set;}
public:
property PdfFlowTableCell^ DefaultCell {
   PdfFlowTableCell^ get();
   void set (    PdfFlowTableCell^ value);
}

Property Value

A cell object that serves as model for cells created by CreateCell method.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members


HeaderRows Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class : HeaderRows Property
Gets the header rows.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property HeaderRows As PdfFlowTableRowCollection
'Usage

Dim instance As PdfFlowTableContent
Dim value As PdfFlowTableRowCollection

value = instance.HeaderRows
public PdfFlowTableRowCollection HeaderRows {get;}
public:
property PdfFlowTableRowCollection^ HeaderRows {
   PdfFlowTableRowCollection^ get();
}

Property Value

The collection of rows in the table header.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members


MinRowHeight Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class : MinRowHeight Property
Minimum height for table rows.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MinRowHeight As Double
'Usage

Dim instance As PdfFlowTableContent
Dim value As Double

instance.MinRowHeight = value

value = instance.MinRowHeight
public double MinRowHeight {get; set;}
public:
property double MinRowHeight {
   double get();
   void set (    double value);
}

Property Value

The minimum height for the rows in the table.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members


Rows Property (PdfFlowTableContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableContent Class : Rows Property
Gets the table rows.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Rows As PdfFlowTableRowCollection
'Usage

Dim instance As PdfFlowTableContent
Dim value As PdfFlowTableRowCollection

value = instance.Rows
public PdfFlowTableRowCollection Rows {get;}
public:
property PdfFlowTableRowCollection^ Rows {
   PdfFlowTableRowCollection^ get();
}

Property Value

The collection of rows in the table.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableContent Class
PdfFlowTableContent Members


%%PageItemTitle%%

PdfFlowTableFormXObjectCell Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableFormXObjectCell Class
Defines a cell that contains a Xfinium.Pdf.Graphics.PdfFormXObject instance.
Object Model
PdfFlowTableFormXObjectCell ClassPdfBrush ClassPdfFlowContentBorders ClassPdfFormXObject ClassPdfFlowContentMargins ClassPdfFlowTableRow Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableFormXObjectCell
   Inherits PdfFlowTableCell
'Usage

Dim instance As PdfFlowTableFormXObjectCell
public class PdfFlowTableFormXObjectCell : PdfFlowTableCell
public ref class PdfFlowTableFormXObjectCell : public PdfFlowTableCell
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowTableCell
Xfinium.Pdf.FlowDocument.PdfFlowTableFormXObjectCell

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableFormXObjectCell Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableFormXObjectCell Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableFormXObjectCell Class

The following tables list the members exposed by PdfFlowTableFormXObjectCell.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowTableFormXObjectCell Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Borders | Gets or sets the cell borders. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | ColSpan | Gets or sets the number of columns this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Content | Gets or sets the cell content.
Public Property | FormXObjectHeight | Gets or sets the form XObject height.
Public Property | FormXObjectWidth | Gets or sets the form XObject width.
Public Property | HorizontalAlign | Gets or sets the horizontal align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | InnerMargins | Gets or sets the cell inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Row | Gets the row this cell belongs to. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | RowSpan | Gets or sets the number of rows this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | VerticalAlign | Gets or sets the vertical align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Top
See Also

Reference

PdfFlowTableFormXObjectCell Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTableFormXObjectCell Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableFormXObjectCell Class : PdfFlowTableFormXObjectCell Constructor
Overload List
Overload | Description
PdfFlowTableFormXObjectCell Constructor() | Initializes a new PdfFlowTableFormXObjectCell object.
PdfFlowTableFormXObjectCell Constructor(PdfFormXObject) | Initializes a new PdfFlowTableFormXObjectCell object.
PdfFlowTableFormXObjectCell Constructor(PdfFlowTableFormXObjectCell) | Initializes a new PdfFlowTableFormXObjectCell object with a copy of another cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableFormXObjectCell Class
PdfFlowTableFormXObjectCell Members


%%PageItemTitle%%

PdfFlowTableFormXObjectCell Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableFormXObjectCell Class > PdfFlowTableFormXObjectCell Constructor : PdfFlowTableFormXObjectCell Constructor()
Initializes a new PdfFlowTableFormXObjectCell object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowTableFormXObjectCell()
public PdfFlowTableFormXObjectCell()
public:
PdfFlowTableFormXObjectCell();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableFormXObjectCell Class
PdfFlowTableFormXObjectCell Members
Overload List


%%PageItemTitle%%

PdfFlowTableFormXObjectCell Constructor(PdfFormXObject)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableFormXObjectCell Class > PdfFlowTableFormXObjectCell Constructor : PdfFlowTableFormXObjectCell Constructor(PdfFormXObject)
The cell content.
Initializes a new PdfFlowTableFormXObjectCell object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As PdfFormXObject _
)
'Usage

Dim content As PdfFormXObject

Dim instance As New PdfFlowTableFormXObjectCell(content)
public PdfFlowTableFormXObjectCell(
   PdfFormXObject content
)
public:
PdfFlowTableFormXObjectCell(
   PdfFormXObject^ content
)

Parameters

content
The cell content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableFormXObjectCell Class
PdfFlowTableFormXObjectCell Members
Overload List


%%PageItemTitle%%

PdfFlowTableFormXObjectCell Constructor(PdfFlowTableFormXObjectCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableFormXObjectCell Class > PdfFlowTableFormXObjectCell Constructor : PdfFlowTableFormXObjectCell Constructor(PdfFlowTableFormXObjectCell)
Source cell.
Initializes a new PdfFlowTableFormXObjectCell object with a copy of another cell.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFlowTableFormXObjectCell _
)
'Usage

Dim source As PdfFlowTableFormXObjectCell

Dim instance As New PdfFlowTableFormXObjectCell(source)
public PdfFlowTableFormXObjectCell(
   PdfFlowTableFormXObjectCell source
)
public:
PdfFlowTableFormXObjectCell(
   PdfFlowTableFormXObjectCell^ source
)

Parameters

source
Source cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableFormXObjectCell Class
PdfFlowTableFormXObjectCell Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowTableFormXObjectCell Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableFormXObjectCell Class

For a list of all members of this type, see PdfFlowTableFormXObjectCell members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Borders | Gets or sets the cell borders. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | ColSpan | Gets or sets the number of columns this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Content | Gets or sets the cell content.
Public Property | FormXObjectHeight | Gets or sets the form XObject height.
Public Property | FormXObjectWidth | Gets or sets the form XObject width.
Public Property | HorizontalAlign | Gets or sets the horizontal align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | InnerMargins | Gets or sets the cell inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Row | Gets the row this cell belongs to. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | RowSpan | Gets or sets the number of rows this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | VerticalAlign | Gets or sets the vertical align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Top
See Also

Reference

PdfFlowTableFormXObjectCell Class
Xfinium.Pdf.FlowDocument Namespace


Content Property (PdfFlowTableFormXObjectCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableFormXObjectCell Class : Content Property
Gets or sets the cell content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Content As PdfFormXObject
'Usage

Dim instance As PdfFlowTableFormXObjectCell
Dim value As PdfFormXObject

instance.Content = value

value = instance.Content
public PdfFormXObject Content {get; set;}
public:
property PdfFormXObject^ Content {
   PdfFormXObject^ get();
   void set (    PdfFormXObject^ value);
}

Property Value

The form XObject displayed in the cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableFormXObjectCell Class
PdfFlowTableFormXObjectCell Members


FormXObjectHeight Property (PdfFlowTableFormXObjectCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableFormXObjectCell Class : FormXObjectHeight Property
Gets or sets the form XObject height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FormXObjectHeight As Double
'Usage

Dim instance As PdfFlowTableFormXObjectCell
Dim value As Double

instance.FormXObjectHeight = value

value = instance.FormXObjectHeight
public double FormXObjectHeight {get; set;}
public:
property double FormXObjectHeight {
   double get();
   void set (    double value);
}

Property Value

The height of the form XObject displayed in the cell.
Remarks
If this value is 0, the height is computed automatically based on form XObject width in order to keep the original form XObject aspect ratio.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableFormXObjectCell Class
PdfFlowTableFormXObjectCell Members


FormXObjectWidth Property (PdfFlowTableFormXObjectCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableFormXObjectCell Class : FormXObjectWidth Property
Gets or sets the form XObject width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FormXObjectWidth As Double
'Usage

Dim instance As PdfFlowTableFormXObjectCell
Dim value As Double

instance.FormXObjectWidth = value

value = instance.FormXObjectWidth
public double FormXObjectWidth {get; set;}
public:
property double FormXObjectWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the form XObject displayed in the cell.
Remarks
If this value is 0, the width is computed automatically based on form XObject height in order to keep the original form XObject aspect ratio.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableFormXObjectCell Class
PdfFlowTableFormXObjectCell Members


%%PageItemTitle%%

PdfFlowTableImageCell Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableImageCell Class
Defines a cell that contains an image.
Object Model
PdfFlowTableImageCell ClassPdfBrush ClassPdfFlowContentBorders ClassPdfImage ClassPdfFlowContentMargins ClassPdfFlowTableRow Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableImageCell
   Inherits PdfFlowTableCell
'Usage

Dim instance As PdfFlowTableImageCell
public class PdfFlowTableImageCell : PdfFlowTableCell
public ref class PdfFlowTableImageCell : public PdfFlowTableCell
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowTableCell
Xfinium.Pdf.FlowDocument.PdfFlowTableImageCell

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableImageCell Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableImageCell Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableImageCell Class

The following tables list the members exposed by PdfFlowTableImageCell.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowTableImageCell Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Borders | Gets or sets the cell borders. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | ColSpan | Gets or sets the number of columns this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Content | Gets or sets the cell content.
Public Property | HorizontalAlign | Gets or sets the horizontal align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | ImageHeight | Gets or sets the image height.
Public Property | ImageWidth | Gets or sets the image width.
Public Property | InnerMargins | Gets or sets the cell inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Row | Gets the row this cell belongs to. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | RowSpan | Gets or sets the number of rows this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | VerticalAlign | Gets or sets the vertical align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Top
See Also

Reference

PdfFlowTableImageCell Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTableImageCell Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableImageCell Class : PdfFlowTableImageCell Constructor
Overload List
Overload | Description
PdfFlowTableImageCell Constructor() | Initializes a new PdfFlowTableImageCell object.
PdfFlowTableImageCell Constructor(PdfImage) | Initializes a new PdfFlowTableImageCell object.
PdfFlowTableImageCell Constructor(PdfFlowTableImageCell) | Initializes a new PdfFlowTableImageCell object with a copy of another cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableImageCell Class
PdfFlowTableImageCell Members


%%PageItemTitle%%

PdfFlowTableImageCell Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableImageCell Class > PdfFlowTableImageCell Constructor : PdfFlowTableImageCell Constructor()
Initializes a new PdfFlowTableImageCell object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowTableImageCell()
public PdfFlowTableImageCell()
public:
PdfFlowTableImageCell();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableImageCell Class
PdfFlowTableImageCell Members
Overload List


%%PageItemTitle%%

PdfFlowTableImageCell Constructor(PdfImage)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableImageCell Class > PdfFlowTableImageCell Constructor : PdfFlowTableImageCell Constructor(PdfImage)
The cell content.
Initializes a new PdfFlowTableImageCell object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As PdfImage _
)
'Usage

Dim content As PdfImage

Dim instance As New PdfFlowTableImageCell(content)
public PdfFlowTableImageCell(
   PdfImage content
)
public:
PdfFlowTableImageCell(
   PdfImage^ content
)

Parameters

content
The cell content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableImageCell Class
PdfFlowTableImageCell Members
Overload List


%%PageItemTitle%%

PdfFlowTableImageCell Constructor(PdfFlowTableImageCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableImageCell Class > PdfFlowTableImageCell Constructor : PdfFlowTableImageCell Constructor(PdfFlowTableImageCell)
Source cell.
Initializes a new PdfFlowTableImageCell object with a copy of another cell.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFlowTableImageCell _
)
'Usage

Dim source As PdfFlowTableImageCell

Dim instance As New PdfFlowTableImageCell(source)
public PdfFlowTableImageCell(
   PdfFlowTableImageCell source
)
public:
PdfFlowTableImageCell(
   PdfFlowTableImageCell^ source
)

Parameters

source
Source cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableImageCell Class
PdfFlowTableImageCell Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowTableImageCell Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableImageCell Class

For a list of all members of this type, see PdfFlowTableImageCell members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Borders | Gets or sets the cell borders. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | ColSpan | Gets or sets the number of columns this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Content | Gets or sets the cell content.
Public Property | HorizontalAlign | Gets or sets the horizontal align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | ImageHeight | Gets or sets the image height.
Public Property | ImageWidth | Gets or sets the image width.
Public Property | InnerMargins | Gets or sets the cell inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Row | Gets the row this cell belongs to. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | RowSpan | Gets or sets the number of rows this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | VerticalAlign | Gets or sets the vertical align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Top
See Also

Reference

PdfFlowTableImageCell Class
Xfinium.Pdf.FlowDocument Namespace


Content Property (PdfFlowTableImageCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableImageCell Class : Content Property
Gets or sets the cell content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Content As PdfImage
'Usage

Dim instance As PdfFlowTableImageCell
Dim value As PdfImage

instance.Content = value

value = instance.Content
public PdfImage Content {get; set;}
public:
property PdfImage^ Content {
   PdfImage^ get();
   void set (    PdfImage^ value);
}

Property Value

The image displayed in the cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableImageCell Class
PdfFlowTableImageCell Members


ImageHeight Property (PdfFlowTableImageCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableImageCell Class : ImageHeight Property
Gets or sets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageHeight As Double
'Usage

Dim instance As PdfFlowTableImageCell
Dim value As Double

instance.ImageHeight = value

value = instance.ImageHeight
public double ImageHeight {get; set;}
public:
property double ImageHeight {
   double get();
   void set (    double value);
}

Property Value

The height of the image displayed in the cell.
Remarks
If this value is 0, the height is computed automatically based on image width in order to keep the original image aspect ratio.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableImageCell Class
PdfFlowTableImageCell Members


ImageWidth Property (PdfFlowTableImageCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableImageCell Class : ImageWidth Property
Gets or sets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageWidth As Double
'Usage

Dim instance As PdfFlowTableImageCell
Dim value As Double

instance.ImageWidth = value

value = instance.ImageWidth
public double ImageWidth {get; set;}
public:
property double ImageWidth {
   double get();
   void set (    double value);
}

Property Value

The width of the image displayed in the cell.
Remarks
If this value is 0, the width is computed automatically based on image height in order to keep the original image aspect ratio.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableImageCell Class
PdfFlowTableImageCell Members


%%PageItemTitle%%

PdfFlowTableRow Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableRow Class
Defines the base class for rows in a table.
Object Model
PdfFlowTableRow ClassPdfBrush ClassPdfFlowTableCellCollection ClassPdfFlowTableCell ClassPdfFlowTableContent Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableRow
'Usage

Dim instance As PdfFlowTableRow
public class PdfFlowTableRow
public ref class PdfFlowTableRow
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowTableRow

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableRow Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableRow Class

The following tables list the members exposed by PdfFlowTableRow.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowTableRow Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the row background.
Public Property | Cells | Gets the row cells.
Public Property | EnableRowSplit | Gets or sets a value indicating whether the row may be split if the space at the bottom cannot accomodate the full row.
Public Property | MinHeight | Gets or sets the minimum row height.
Public Property | Table | Gets the table this row belongs to.
Top
See Also

Reference

PdfFlowTableRow Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTableRow Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRow Class : PdfFlowTableRow Constructor
Overload List
Overload | Description
PdfFlowTableRow Constructor() | Initializes a new PdfFlowTableRow object.
PdfFlowTableRow Constructor(Object[]) | Initializes a new PdfFlowTableRow object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Class
PdfFlowTableRow Members


%%PageItemTitle%%

PdfFlowTableRow Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRow Class > PdfFlowTableRow Constructor : PdfFlowTableRow Constructor()
Initializes a new PdfFlowTableRow object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowTableRow()
public PdfFlowTableRow()
public:
PdfFlowTableRow();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Class
PdfFlowTableRow Members
Overload List


%%PageItemTitle%%

PdfFlowTableRow Constructor(Object[])

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRow Class > PdfFlowTableRow Constructor : PdfFlowTableRow Constructor(Object[])
A variable number of strings
Initializes a new PdfFlowTableRow object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ParamArray cellContents() As Object _
)
'Usage

Dim cellContents() As Object

Dim instance As New PdfFlowTableRow(cellContents)
public PdfFlowTableRow(
   params object[] cellContents
)
public:
PdfFlowTableRow(
   ... array<Object^>^ cellContents
)

Parameters

cellContents
A variable number of strings
Remarks
This constructor creates a row object and populates it with PdfFlowTableStringCell objects, one for each object passed as parameter.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Class
PdfFlowTableRow Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowTableRow Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableRow Class

For a list of all members of this type, see PdfFlowTableRow members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the row background.
Public Property | Cells | Gets the row cells.
Public Property | EnableRowSplit | Gets or sets a value indicating whether the row may be split if the space at the bottom cannot accomodate the full row.
Public Property | MinHeight | Gets or sets the minimum row height.
Public Property | Table | Gets the table this row belongs to.
Top
See Also

Reference

PdfFlowTableRow Class
Xfinium.Pdf.FlowDocument Namespace


Background Property (PdfFlowTableRow)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRow Class : Background Property
Gets or sets the row background.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Background As PdfBrush
'Usage

Dim instance As PdfFlowTableRow
Dim value As PdfBrush

instance.Background = value

value = instance.Background
public PdfBrush Background {get; set;}
public:
property PdfBrush^ Background {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfBrush object that specifies how the row background is filled.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Class
PdfFlowTableRow Members


Cells Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRow Class : Cells Property
Gets the row cells.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Cells As PdfFlowTableCellCollection
'Usage

Dim instance As PdfFlowTableRow
Dim value As PdfFlowTableCellCollection

value = instance.Cells
public PdfFlowTableCellCollection Cells {get;}
public:
property PdfFlowTableCellCollection^ Cells {
   PdfFlowTableCellCollection^ get();
}

Property Value

The collection of cells included in the row.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Class
PdfFlowTableRow Members


EnableRowSplit Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRow Class : EnableRowSplit Property
Gets or sets a value indicating whether the row may be split if the space at the bottom cannot accomodate the full row.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableRowSplit As Boolean
'Usage

Dim instance As PdfFlowTableRow
Dim value As Boolean

instance.EnableRowSplit = value

value = instance.EnableRowSplit
public bool EnableRowSplit {get; set;}
public:
property bool EnableRowSplit {
   bool get();
   void set (    bool value);
}

Property Value

Default true, the row may be split if its content supports spliting. If false the row will not be split.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Class
PdfFlowTableRow Members


MinHeight Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRow Class : MinHeight Property
Gets or sets the minimum row height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MinHeight As Double
'Usage

Dim instance As PdfFlowTableRow
Dim value As Double

instance.MinHeight = value

value = instance.MinHeight
public double MinHeight {get; set;}
public:
property double MinHeight {
   double get();
   void set (    double value);
}

Property Value

The minimum row height.
Remarks
The minimum row height sets the row height when the cells maximum height is less than this value. If this property is 0 then the row height is given by the maximum cell height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Class
PdfFlowTableRow Members


Table Property

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRow Class : Table Property
Gets the table this row belongs to.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Table As PdfFlowTableContent
'Usage

Dim instance As PdfFlowTableRow
Dim value As PdfFlowTableContent

value = instance.Table
public PdfFlowTableContent Table {get;}
public:
property PdfFlowTableContent^ Table {
   PdfFlowTableContent^ get();
}

Property Value

the table that includes this row.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRow Class
PdfFlowTableRow Members


%%PageItemTitle%%

PdfFlowTableRowCollection Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableRowCollection Class
Defines a collection of rows in a table.
Object Model
PdfFlowTableRowCollection ClassPdfFlowTableRow Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableRowCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfFlowTableRow)
'Usage

Dim instance As PdfFlowTableRowCollection
public class PdfFlowTableRowCollection : System.Collections.ObjectModel.Collection<PdfFlowTableRow>
public ref class PdfFlowTableRowCollection : public System.Collections.ObjectModel.Collection<PdfFlowTableRow>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.FlowDocument.PdfFlowTableRowCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRowCollection Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableRowCollection Class Members
Properties Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableRowCollection Class

The following tables list the members exposed by PdfFlowTableRowCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Add a new empty row in the collection.
Public Method | AddRowWithCells | Adds a new row in the collection and creates a string cell for each value in the array.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Top
See Also

Reference

PdfFlowTableRowCollection Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Methods$$

PdfFlowTableRowCollection Class Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableRowCollection Class

For a list of all members of this type, see PdfFlowTableRowCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Add a new empty row in the collection.
Public Method | AddRowWithCells | Adds a new row in the collection and creates a string cell for each value in the array.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Top
See Also

Reference

PdfFlowTableRowCollection Class
Xfinium.Pdf.FlowDocument Namespace


Add Method (PdfFlowTableRowCollection)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRowCollection Class : Add Method
Add a new empty row in the collection.
Overload List
Overload | Description
Add() | Add a new empty row in the collection.
Add(PdfFlowTableRow) | Add a new empty row in the collection. (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRowCollection Class
PdfFlowTableRowCollection Members


Add() Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRowCollection Class > Add Method : Add() Method
Add a new empty row in the collection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Add() As PdfFlowTableRow
'Usage

Dim instance As PdfFlowTableRowCollection
Dim value As PdfFlowTableRow

value = instance.Add()
public PdfFlowTableRow Add()
public:
PdfFlowTableRow^ Add();

Return Value

The row that has been added.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRowCollection Class
PdfFlowTableRowCollection Members
Overload List


AddRowWithCells Method

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableRowCollection Class : AddRowWithCells Method
Initial content for the row's cells.
Adds a new row in the collection and creates a string cell for each value in the array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function AddRowWithCells( _
   ByVal ParamArray cellContents() As Object _
) As PdfFlowTableRow
'Usage

Dim instance As PdfFlowTableRowCollection
Dim cellContents() As Object
Dim value As PdfFlowTableRow

value = instance.AddRowWithCells(cellContents)
public PdfFlowTableRow AddRowWithCells(
   params object[] cellContents
)
public:
PdfFlowTableRow^ AddRowWithCells(
   ... array<Object^>^ cellContents
)

Parameters

cellContents
Initial content for the row's cells.

Return Value

The newly created row.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableRowCollection Class
PdfFlowTableRowCollection Members


%%PageItemTitle%%

PdfFlowTableStringCell Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableStringCell Class
Defines a cell that contains a string.
Object Model
PdfFlowTableStringCell ClassPdfBrush ClassPdfFlowContentBorders ClassPdfBrush ClassPdfFont ClassPdfFlowContentMargins ClassPdfFlowTableRow Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTableStringCell
   Inherits PdfFlowTableCell
'Usage

Dim instance As PdfFlowTableStringCell
public class PdfFlowTableStringCell : PdfFlowTableCell
public ref class PdfFlowTableStringCell : public PdfFlowTableCell
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowTableCell
Xfinium.Pdf.FlowDocument.PdfFlowTableStringCell

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTableStringCell Class Members
Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableStringCell Class

The following tables list the members exposed by PdfFlowTableStringCell.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowTableStringCell Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Borders | Gets or sets the cell borders. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Color | Gets or sets the content color.
Public Property | ColSpan | Gets or sets the number of columns this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Content | Gets or sets the cell content.
Public Property | Font | Gets or sets the content font.
Public Property | HorizontalAlign | Gets or sets the horizontal align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | InnerMargins | Gets or sets the cell inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Multiline | Gets or sets a value indicating whether the cell content should be wrapped on multiple lines.
Public Property | Row | Gets the row this cell belongs to. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | RowSpan | Gets or sets the number of rows this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | VerticalAlign | Gets or sets the vertical align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Top
See Also

Reference

PdfFlowTableStringCell Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTableStringCell Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class : PdfFlowTableStringCell Constructor
Overload List
Overload | Description
PdfFlowTableStringCell Constructor() | Initializes a new PdfFlowTableStringCell object.
PdfFlowTableStringCell Constructor(String) | Initializes a new PdfFlowTableStringCell object.
PdfFlowTableStringCell Constructor(String,Boolean) | Initializes a new PdfFlowTableStringCell object.
PdfFlowTableStringCell Constructor(PdfFlowTableStringCell) | Initializes a new PdfFlowTableStringCell object with a copy of another cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members


%%PageItemTitle%%

PdfFlowTableStringCell Constructor()

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class > PdfFlowTableStringCell Constructor : PdfFlowTableStringCell Constructor()
Initializes a new PdfFlowTableStringCell object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFlowTableStringCell()
public PdfFlowTableStringCell()
public:
PdfFlowTableStringCell();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members
Overload List


%%PageItemTitle%%

PdfFlowTableStringCell Constructor(String)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class > PdfFlowTableStringCell Constructor : PdfFlowTableStringCell Constructor(String)
The cell content.
Initializes a new PdfFlowTableStringCell object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As String _
)
'Usage

Dim content As String

Dim instance As New PdfFlowTableStringCell(content)
public PdfFlowTableStringCell(
   string content
)
public:
PdfFlowTableStringCell(
   String^ content
)

Parameters

content
The cell content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members
Overload List


%%PageItemTitle%%

PdfFlowTableStringCell Constructor(String,Boolean)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class > PdfFlowTableStringCell Constructor : PdfFlowTableStringCell Constructor(String,Boolean)
The cell content.
True if the cell content should be wrapped on multiple lines.
Initializes a new PdfFlowTableStringCell object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As String, _
   ByVal multiline As Boolean _
)
'Usage

Dim content As String
Dim multiline As Boolean

Dim instance As New PdfFlowTableStringCell(content, multiline)
public PdfFlowTableStringCell(
   string content,
   bool multiline
)
public:
PdfFlowTableStringCell(
   String^ content,
   bool multiline
)

Parameters

content
The cell content.
multiline
True if the cell content should be wrapped on multiple lines.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members
Overload List


%%PageItemTitle%%

PdfFlowTableStringCell Constructor(PdfFlowTableStringCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class > PdfFlowTableStringCell Constructor : PdfFlowTableStringCell Constructor(PdfFlowTableStringCell)
Source cell.
Initializes a new PdfFlowTableStringCell object with a copy of another cell.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFlowTableStringCell _
)
'Usage

Dim source As PdfFlowTableStringCell

Dim instance As New PdfFlowTableStringCell(source)
public PdfFlowTableStringCell(
   PdfFlowTableStringCell source
)
public:
PdfFlowTableStringCell(
   PdfFlowTableStringCell^ source
)

Parameters

source
Source cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFlowTableStringCell Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableStringCell Class

For a list of all members of this type, see PdfFlowTableStringCell members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the cell background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Borders | Gets or sets the cell borders. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Color | Gets or sets the content color.
Public Property | ColSpan | Gets or sets the number of columns this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Content | Gets or sets the cell content.
Public Property | Font | Gets or sets the content font.
Public Property | HorizontalAlign | Gets or sets the horizontal align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | InnerMargins | Gets or sets the cell inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | Multiline | Gets or sets a value indicating whether the cell content should be wrapped on multiple lines.
Public Property | Row | Gets the row this cell belongs to. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | RowSpan | Gets or sets the number of rows this cell spans on. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Public Property | VerticalAlign | Gets or sets the vertical align. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTableCell)
Top
See Also

Reference

PdfFlowTableStringCell Class
Xfinium.Pdf.FlowDocument Namespace


Color Property (PdfFlowTableStringCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class : Color Property
Gets or sets the content color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Color As PdfBrush
'Usage

Dim instance As PdfFlowTableStringCell
Dim value As PdfBrush

instance.Color = value

value = instance.Color
public PdfBrush Color {get; set;}
public:
property PdfBrush^ Color {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

The color used to display the cell content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members


Content Property (PdfFlowTableStringCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class : Content Property
Gets or sets the cell content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Content As String
'Usage

Dim instance As PdfFlowTableStringCell
Dim value As String

instance.Content = value

value = instance.Content
public string Content {get; set;}
public:
property String^ Content {
   String^ get();
   void set (    String^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members


Font Property (PdfFlowTableStringCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class : Font Property
Gets or sets the content font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As PdfFont
'Usage

Dim instance As PdfFlowTableStringCell
Dim value As PdfFont

instance.Font = value

value = instance.Font
public PdfFont Font {get; set;}
public:
property PdfFont^ Font {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

The font used to display the cell content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members


Multiline Property (PdfFlowTableStringCell)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTableStringCell Class : Multiline Property
Gets or sets a value indicating whether the cell content should be wrapped on multiple lines.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Multiline As Boolean
'Usage

Dim instance As PdfFlowTableStringCell
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
public bool Multiline {get; set;}
public:
property bool Multiline {
   bool get();
   void set (    bool value);
}

Property Value

If true the cell content is wrapped on multiple lines, otherwise it is displayed on a single line even if it is clipped. Default is false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTableStringCell Class
PdfFlowTableStringCell Members


%%PageItemTitle%%

PdfFlowTextContent Class
Members

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTextContent Class
Defines a text content that can be added to a flow document.
Object Model
PdfFlowTextContent ClassPdfBrush ClassPdfFlowContentMargins ClassPdfFlowContentMargins Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFlowTextContent
   Inherits PdfFlowContent
'Usage

Dim instance As PdfFlowTextContent
public class PdfFlowTextContent : PdfFlowContent
public ref class PdfFlowTextContent : public PdfFlowContent
Inheritance Hierarchy

System.Object
Xfinium.Pdf.FlowDocument.PdfFlowContent
Xfinium.Pdf.FlowDocument.PdfFlowTextContent
Xfinium.Pdf.FlowDocument.PdfFlowHeadingContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTextContent Members
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Members$$

PdfFlowTextContent Class Members
Properties Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTextContent Class

The following tables list the members exposed by PdfFlowTextContent.

Public Constructors
 | Name | Description
Public Constructor | PdfFlowTextContent Constructor | Initializes a new PdfFlowTextContent object.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfFlowTextContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowTextContent Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTextContent Class : PdfFlowTextContent Constructor
Formatted content to be displayed.
Initializes a new PdfFlowTextContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal formattedContent As PdfFormattedContent _
)
'Usage

Dim formattedContent As PdfFormattedContent

Dim instance As New PdfFlowTextContent(formattedContent)
public PdfFlowTextContent(
   PdfFormattedContent formattedContent
)
public:
PdfFlowTextContent(
   PdfFormattedContent^ formattedContent
)

Parameters

formattedContent
Formatted content to be displayed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTextContent Class
PdfFlowTextContent Members


%%PageItemTitle%% $$Methods$$

PdfFlowTextContent Class Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTextContent Class

For a list of all members of this type, see PdfFlowTextContent members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfFlowTextContent Class
Xfinium.Pdf.FlowDocument Namespace


ToString Method (PdfFlowTextContent)

Xfinium.Pdf.FlowDocument Namespace > PdfFlowTextContent Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfFlowTextContent
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowTextContent Class
PdfFlowTextContent Members


Xfinium.Pdf.Forms Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfCalculatedFieldCollection | Defines a collection of calculated Acrobat form fields.
Class | PdfCheckBoxField | Defines an interactive Acrobat check box field.
Class | PdfCheckBoxWidget | Defines an interactive check box widget.
Class | PdfCheckWidget | Defines the base class for all check style widgets.
Class | PdfComboBoxField | Defines an interactive Acrobat combo box field.
Class | PdfComboBoxWidget | Defines an interactive combo box widget.
Class | PdfField | Defines the base class for all interactive form fields in an Acrobat PDF form.
Class | PdfFieldCollection | Defines a collection of interactive form fields.
Class | PdfFieldWidget | Defines an interactive field widget.
Class | PdfFieldWidgetCollection | Defines a collection of field widgets.
Class | PdfForm | Defines an interactive Acrobat form.
Class | PdfListBoxField | Defines an interactive Acrobat list box field.
Class | PdfListBoxWidget | Defines an interactive list box widget.
Class | PdfListField | Defines the base class for interactive choice fields, comboboxes and listboxes.
Class | PdfListItem | Defines an item in a list field.
Class | PdfListItemCollection | Defines a collection of list items.
Class | PdfPushButtonField | Defines an interactive Acrobat pushbutton field.
Class | PdfPushButtonWidget | Defines an interactive pushbutton widget.
Class | PdfRadioButtonField | Defines an interactive Acrobat radiobutton field.
Class | PdfRadioButtonWidget | Defines an interactive radiobutton widget.
Class | PdfSignatureField | Defines an interactive Acrobat signature field.
Class | PdfSignatureLockFieldAction | Defines a signature field lock action.
Class | PdfSignatureWidget | Defines an interactive signature widget.
Class | PdfTextBoxField | Defines an interactive Acrobat textbox field.
Class | PdfTextBoxWidget | Defines an interactive textbox widget.
Enumerations
 | Enumeration | Description
Enumeration | PdfCheckStyle | Supported visual styles for check boxes and radio buttons.
Enumeration | PdfFieldType | Suported field types.
Enumeration | PdfFieldWidgetVisibility | Supported field widget visibilities.
Enumeration | PdfFormDataFormat | Supported data formats for import/export form actions.
Enumeration | PdfPushButtonHighlightMode | Supported highlight modes for pushbuttons.
Enumeration | PdfPushButtonIconLayout | Supported layouts for displaying the icon on a pushbutton.
Enumeration | PdfSignatureLockType | Supported lock types for signed forms.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Forms Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Forms.PdfCalculatedFieldCollection
Xfinium.Pdf.Forms.PdfFieldCollection
Xfinium.Pdf.Forms.PdfFieldWidgetCollection
Xfinium.Pdf.Forms.PdfListItemCollection
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfCheckWidget
Xfinium.Pdf.Forms.PdfCheckBoxWidget
Xfinium.Pdf.Forms.PdfRadioButtonWidget
Xfinium.Pdf.Forms.PdfComboBoxWidget
Xfinium.Pdf.Forms.PdfListBoxWidget
Xfinium.Pdf.Forms.PdfPushButtonWidget
Xfinium.Pdf.Forms.PdfSignatureWidget
Xfinium.Pdf.Forms.PdfTextBoxWidget
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfCheckBoxField
Xfinium.Pdf.Forms.PdfListField
Xfinium.Pdf.Forms.PdfComboBoxField
Xfinium.Pdf.Forms.PdfListBoxField
Xfinium.Pdf.Forms.PdfPushButtonField
Xfinium.Pdf.Forms.PdfRadioButtonField
Xfinium.Pdf.Forms.PdfSignatureField
Xfinium.Pdf.Forms.PdfTextBoxField
Xfinium.Pdf.Forms.PdfForm
Xfinium.Pdf.Forms.PdfListItem
Xfinium.Pdf.Forms.PdfSignatureLockFieldAction
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfCalculatedFieldCollection Class
Members

Xfinium.Pdf.Forms Namespace : PdfCalculatedFieldCollection Class
Defines a collection of calculated Acrobat form fields.
Object Model
PdfCalculatedFieldCollection ClassPdfField Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCalculatedFieldCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfField)
'Usage

Dim instance As PdfCalculatedFieldCollection
public class PdfCalculatedFieldCollection : System.Collections.ObjectModel.Collection<PdfField>
public ref class PdfCalculatedFieldCollection : public System.Collections.ObjectModel.Collection<PdfField>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Forms.PdfCalculatedFieldCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalculatedFieldCollection Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfCalculatedFieldCollection Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfCalculatedFieldCollection Class

The following tables list the members exposed by PdfCalculatedFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Top
See Also

Reference

PdfCalculatedFieldCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfCheckBoxField Class
Members

Xfinium.Pdf.Forms Namespace : PdfCheckBoxField Class
Defines an interactive Acrobat check box field.
Object Model
PdfCheckBoxField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCheckBoxField
   Inherits PdfField
'Usage

Dim instance As PdfCheckBoxField
public class PdfCheckBoxField : PdfField
public ref class PdfCheckBoxField : public PdfField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfCheckBoxField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckBoxField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfCheckBoxField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfCheckBoxField Class

The following tables list the members exposed by PdfCheckBoxField.

Public Constructors
 | Name | Description
Public Constructor | PdfCheckBoxField Constructor | Initializes a new PdfCheckBoxField object.
Top
Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Checked | Gets or set a value indicating whether the CheckBox is in the checked state.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfCheckBoxField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfCheckBoxField Constructor

Xfinium.Pdf.Forms Namespace > PdfCheckBoxField Class : PdfCheckBoxField Constructor
The field name.
Initializes a new PdfCheckBoxField object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfCheckBoxField(name)
public PdfCheckBoxField(
   string name
)
public:
PdfCheckBoxField(
   String^ name
)

Parameters

name
The field name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckBoxField Class
PdfCheckBoxField Members


%%PageItemTitle%% $$Properties$$

PdfCheckBoxField Class Properties

Xfinium.Pdf.Forms Namespace : PdfCheckBoxField Class

For a list of all members of this type, see PdfCheckBoxField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Checked | Gets or set a value indicating whether the CheckBox is in the checked state.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfCheckBoxField Class
Xfinium.Pdf.Forms Namespace


Checked Property (PdfCheckBoxField)

Xfinium.Pdf.Forms Namespace > PdfCheckBoxField Class : Checked Property
Gets or set a value indicating whether the CheckBox is in the checked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PdfCheckBoxField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if the CheckBox is in the checked state; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckBoxField Class
PdfCheckBoxField Members


%%PageItemTitle%%

PdfCheckBoxWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfCheckBoxWidget Class
Defines an interactive check box widget.
Object Model
PdfCheckBoxWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfCosDictionary ClassPdfField ClassPdfAction ClassPdfFont ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCheckBoxWidget
   Inherits PdfCheckWidget
'Usage

Dim instance As PdfCheckBoxWidget
public class PdfCheckBoxWidget : PdfCheckWidget
public ref class PdfCheckBoxWidget : public PdfCheckWidget
Remarks
The check box widget is the visual representation of a check box field on a PDF page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfCheckWidget
Xfinium.Pdf.Forms.PdfCheckBoxWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckBoxWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfCheckBoxWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfCheckBoxWidget Class

The following tables list the members exposed by PdfCheckBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PdfCheckBoxWidget Constructor | Initializes a new PdfCheckBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Checked | Gets or set a value indicating whether the check widget is in the checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckStyle | Gets or sets the style of the checked widget. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ExportValue | Gets or sets the widget's export value. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | UncheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | UncheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | UncheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfCheckBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfCheckBoxWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfCheckBoxWidget Class : PdfCheckBoxWidget Constructor
Initializes a new PdfCheckBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCheckBoxWidget()
public PdfCheckBoxWidget()
public:
PdfCheckBoxWidget();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckBoxWidget Class
PdfCheckBoxWidget Members


%%PageItemTitle%%

PdfCheckWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfCheckWidget Class
Defines the base class for all check style widgets.
Object Model
PdfCheckWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfCosDictionary ClassPdfField ClassPdfAction ClassPdfFont ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCheckWidget
   Inherits PdfFieldWidget
'Usage

Dim instance As PdfCheckWidget
public class PdfCheckWidget : PdfFieldWidget
public ref class PdfCheckWidget : public PdfFieldWidget
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfCheckWidget
Xfinium.Pdf.Forms.PdfCheckBoxWidget
Xfinium.Pdf.Forms.PdfRadioButtonWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfCheckWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfCheckWidget Class

The following tables list the members exposed by PdfCheckWidget.

Public Constructors
 | Name | Description
Public Constructor | PdfCheckWidget Constructor | Initializes a new PdfCheckWidget object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Checked | Gets or set a value indicating whether the check widget is in the checked state.
Public Property | CheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in checked state.
Public Property | CheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in checked state.
Public Property | CheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in checked state.
Public Property | CheckStyle | Gets or sets the style of the checked widget.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ExportValue | Gets or sets the widget's export value.
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | UncheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in unchecked state.
Public Property | UncheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in unchecked state.
Public Property | UncheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in unchecked state.
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfCheckWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfCheckWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : PdfCheckWidget Constructor
Initializes a new PdfCheckWidget object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCheckWidget()
public PdfCheckWidget()
public:
PdfCheckWidget();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


%%PageItemTitle%% $$Properties$$

PdfCheckWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfCheckWidget Class

For a list of all members of this type, see PdfCheckWidget members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Checked | Gets or set a value indicating whether the check widget is in the checked state.
Public Property | CheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in checked state.
Public Property | CheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in checked state.
Public Property | CheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in checked state.
Public Property | CheckStyle | Gets or sets the style of the checked widget.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ExportValue | Gets or sets the widget's export value.
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | UncheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in unchecked state.
Public Property | UncheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in unchecked state.
Public Property | UncheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in unchecked state.
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfCheckWidget Class
Xfinium.Pdf.Forms Namespace


Checked Property (PdfCheckWidget)

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : Checked Property
Gets or set a value indicating whether the check widget is in the checked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PdfCheckWidget
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if the check widget is in the checked state; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


CheckedStateDownAppearance Property

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : CheckedStateDownAppearance Property
Gets or sets the pressed visual appearance for the widget in checked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CheckedStateDownAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfCheckWidget
Dim value As PdfAnnotationAppearance

instance.CheckedStateDownAppearance = value

value = instance.CheckedStateDownAppearance
public PdfAnnotationAppearance CheckedStateDownAppearance {get; set;}
public:
property PdfAnnotationAppearance^ CheckedStateDownAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

The pressed visual appearance of the widget in checked state.
Remarks
The visual appearance of the widget in checked state when the user presses the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


CheckedStateNormalAppearance Property

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : CheckedStateNormalAppearance Property
Gets or sets the normal visual appearance for the widget in checked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CheckedStateNormalAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfCheckWidget
Dim value As PdfAnnotationAppearance

instance.CheckedStateNormalAppearance = value

value = instance.CheckedStateNormalAppearance
public PdfAnnotationAppearance CheckedStateNormalAppearance {get; set;}
public:
property PdfAnnotationAppearance^ CheckedStateNormalAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

The normal visual appearance of the widget in checked state.
Remarks
The visual appearance of the widget in checked state when the user does not interact with the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


CheckedStateRolloverAppearance Property

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : CheckedStateRolloverAppearance Property
Gets or sets the rollover visual appearance for the widget in checked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CheckedStateRolloverAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfCheckWidget
Dim value As PdfAnnotationAppearance

instance.CheckedStateRolloverAppearance = value

value = instance.CheckedStateRolloverAppearance
public PdfAnnotationAppearance CheckedStateRolloverAppearance {get; set;}
public:
property PdfAnnotationAppearance^ CheckedStateRolloverAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

The rollover visual appearance of the widget in checked state.
Remarks
The visual appearance of the widget in checked state when the user hovers the mouse over the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


CheckStyle Property

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : CheckStyle Property
Gets or sets the style of the checked widget.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CheckStyle As PdfCheckStyle
'Usage

Dim instance As PdfCheckWidget
Dim value As PdfCheckStyle

instance.CheckStyle = value

value = instance.CheckStyle
public PdfCheckStyle CheckStyle {get; set;}
public:
property PdfCheckStyle CheckStyle {
   PdfCheckStyle get();
   void set (    PdfCheckStyle value);
}

Property Value

A PdfCheckStyle that represents the style of the checked widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


ExportValue Property

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : ExportValue Property
Gets or sets the widget's export value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExportValue As String
'Usage

Dim instance As PdfCheckWidget
Dim value As String

instance.ExportValue = value

value = instance.ExportValue
public string ExportValue {get; set;}
public:
property String^ ExportValue {
   String^ get();
   void set (    String^ value);
}

Property Value

The symbolic value associated with the check widget.
Remarks
When the form data is exported as FDF/XFDF/HTML or XML and the check widget is checked then this value is written to exported data stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


UncheckedStateDownAppearance Property

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : UncheckedStateDownAppearance Property
Gets or sets the pressed visual appearance for the widget in unchecked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UncheckedStateDownAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfCheckWidget
Dim value As PdfAnnotationAppearance

instance.UncheckedStateDownAppearance = value

value = instance.UncheckedStateDownAppearance
public PdfAnnotationAppearance UncheckedStateDownAppearance {get; set;}
public:
property PdfAnnotationAppearance^ UncheckedStateDownAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

The pressed visual appearance of the widget in unchecked state.
Remarks
The visual appearance of the widget in unchecked state when the user presses the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


UncheckedStateNormalAppearance Property

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : UncheckedStateNormalAppearance Property
Gets or sets the normal visual appearance for the widget in unchecked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UncheckedStateNormalAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfCheckWidget
Dim value As PdfAnnotationAppearance

instance.UncheckedStateNormalAppearance = value

value = instance.UncheckedStateNormalAppearance
public PdfAnnotationAppearance UncheckedStateNormalAppearance {get; set;}
public:
property PdfAnnotationAppearance^ UncheckedStateNormalAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

The normal visual appearance of the widget in unchecked state.
Remarks
The visual appearance of the widget in unchecked state when the user does not interact with the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


UncheckedStateRolloverAppearance Property

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : UncheckedStateRolloverAppearance Property
Gets or sets the rollover visual appearance for the widget in unchecked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UncheckedStateRolloverAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfCheckWidget
Dim value As PdfAnnotationAppearance

instance.UncheckedStateRolloverAppearance = value

value = instance.UncheckedStateRolloverAppearance
public PdfAnnotationAppearance UncheckedStateRolloverAppearance {get; set;}
public:
property PdfAnnotationAppearance^ UncheckedStateRolloverAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

The rollover visual appearance of the widget in unchecked state.
Remarks
The visual appearance of the widget in unchecked state when the user hovers the mouse over the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


%%PageItemTitle%%

PdfComboBoxField Class
Members

Xfinium.Pdf.Forms Namespace : PdfComboBoxField Class
Defines an interactive Acrobat combo box field.
Object Model
PdfComboBoxField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfListItemCollection ClassPdfListItem ClassPdfJavaScriptAction ClassPdfListItem ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfComboBoxField
   Inherits PdfListField
'Usage

Dim instance As PdfComboBoxField
public class PdfComboBoxField : PdfListField
public ref class PdfComboBoxField : public PdfListField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfListField
Xfinium.Pdf.Forms.PdfComboBoxField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfComboBoxField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfComboBoxField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfComboBoxField Class

The following tables list the members exposed by PdfComboBoxField.

Public Constructors
 | Name | Description
Public Constructor | PdfComboBoxField Constructor | Initializes a new PdfComboBoxField object.
Top
Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CommitOnSelectionChange | Gets or sets a value indicating whether the new value shall be committed as soon as a selection is made. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Editable | Gets or sets a value indicating whether the value in combo box is editable by the user.
Public Property | EnableSpellCheck | Gets or sets a value indicating whether the field value should be spell-checked.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Items | Gets the items in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Sort | Gets or sets a value indicating whether the field's option items shall be sorted alphabetically. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfComboBoxField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfComboBoxField Constructor

Xfinium.Pdf.Forms Namespace > PdfComboBoxField Class : PdfComboBoxField Constructor
The field name.
Initializes a new PdfComboBoxField object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfComboBoxField(name)
public PdfComboBoxField(
   string name
)
public:
PdfComboBoxField(
   String^ name
)

Parameters

name
The field name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfComboBoxField Class
PdfComboBoxField Members


%%PageItemTitle%% $$Properties$$

PdfComboBoxField Class Properties

Xfinium.Pdf.Forms Namespace : PdfComboBoxField Class

For a list of all members of this type, see PdfComboBoxField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CommitOnSelectionChange | Gets or sets a value indicating whether the new value shall be committed as soon as a selection is made. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Editable | Gets or sets a value indicating whether the value in combo box is editable by the user.
Public Property | EnableSpellCheck | Gets or sets a value indicating whether the field value should be spell-checked.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Items | Gets the items in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Sort | Gets or sets a value indicating whether the field's option items shall be sorted alphabetically. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfComboBoxField Class
Xfinium.Pdf.Forms Namespace


Editable Property (PdfComboBoxField)

Xfinium.Pdf.Forms Namespace > PdfComboBoxField Class : Editable Property
Gets or sets a value indicating whether the value in combo box is editable by the user.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Editable As Boolean
'Usage

Dim instance As PdfComboBoxField
Dim value As Boolean

instance.Editable = value

value = instance.Editable
public bool Editable {get; set;}
public:
property bool Editable {
   bool get();
   void set (    bool value);
}

Property Value

True if the user can edit the value selected in the combo box; otherwise false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfComboBoxField Class
PdfComboBoxField Members


EnableSpellCheck Property

Xfinium.Pdf.Forms Namespace > PdfComboBoxField Class : EnableSpellCheck Property
Gets or sets a value indicating whether the field value should be spell-checked.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableSpellCheck As Boolean
'Usage

Dim instance As PdfComboBoxField
Dim value As Boolean

instance.EnableSpellCheck = value

value = instance.EnableSpellCheck
public bool EnableSpellCheck {get; set;}
public:
property bool EnableSpellCheck {
   bool get();
   void set (    bool value);
}

Property Value

If true the text entered in the field shall be spell-checked.
Remarks
This property should be set to true only if Editable is also true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfComboBoxField Class
PdfComboBoxField Members


%%PageItemTitle%%

PdfComboBoxWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfComboBoxWidget Class
Defines an interactive combo box widget.
Object Model
PdfComboBoxWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfCosDictionary ClassPdfField ClassPdfAction ClassPdfFont ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfComboBoxWidget
   Inherits PdfFieldWidget
'Usage

Dim instance As PdfComboBoxWidget
public class PdfComboBoxWidget : PdfFieldWidget
public ref class PdfComboBoxWidget : public PdfFieldWidget
Remarks
The combo box widget is the visual representation of a combo box field on a PDF page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfComboBoxWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfComboBoxWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfComboBoxWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfComboBoxWidget Class

The following tables list the members exposed by PdfComboBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PdfComboBoxWidget Constructor | Initializes a new PdfComboBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfComboBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfComboBoxWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfComboBoxWidget Class : PdfComboBoxWidget Constructor
Initializes a new PdfComboBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfComboBoxWidget()
public PdfComboBoxWidget()
public:
PdfComboBoxWidget();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfComboBoxWidget Class
PdfComboBoxWidget Members


%%PageItemTitle%%

PdfField Class
Members

Xfinium.Pdf.Forms Namespace : PdfField Class
Defines the base class for all interactive form fields in an Acrobat PDF form.
Object Model
PdfField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfField
'Usage

Dim instance As PdfField
public class PdfField
public ref class PdfField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfCheckBoxField
Xfinium.Pdf.Forms.PdfListField
Xfinium.Pdf.Forms.PdfPushButtonField
Xfinium.Pdf.Forms.PdfRadioButtonField
Xfinium.Pdf.Forms.PdfSignatureField
Xfinium.Pdf.Forms.PdfTextBoxField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfField Class

The following tables list the members exposed by PdfField.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name.
Public Property | CalculateAction | Gets or sets the calculate action.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not.
Public Property | Form | Gets the Acrobat form this field belongs to.
Public Property | FormatAction | Gets or sets the format action.
Public Property | KeyPressAction | Gets or sets the keypress action.
Public Property | MappingName | Gets or sets the field mapping name.
Public Property | Name | Gets or sets the field name.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Type | Gets the field type.
Public Property | ValidateAction | Gets or sets the validate action.
Public Property | Value | Gets or sets the field value.
Public Property | Widgets | Gets the list of field widgets.
Top
See Also

Reference

PdfField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfField Class Properties

Xfinium.Pdf.Forms Namespace : PdfField Class

For a list of all members of this type, see PdfField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name.
Public Property | CalculateAction | Gets or sets the calculate action.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not.
Public Property | Form | Gets the Acrobat form this field belongs to.
Public Property | FormatAction | Gets or sets the format action.
Public Property | KeyPressAction | Gets or sets the keypress action.
Public Property | MappingName | Gets or sets the field mapping name.
Public Property | Name | Gets or sets the field name.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Type | Gets the field type.
Public Property | ValidateAction | Gets or sets the validate action.
Public Property | Value | Gets or sets the field value.
Public Property | Widgets | Gets the list of field widgets.
Top
See Also

Reference

PdfField Class
Xfinium.Pdf.Forms Namespace


AlternateName Property (PdfField)

Xfinium.Pdf.Forms Namespace > PdfField Class : AlternateName Property
Gets or sets the field alternate name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property AlternateName As String
'Usage

Dim instance As PdfField
Dim value As String

instance.AlternateName = value

value = instance.AlternateName
public virtual string AlternateName {get; set;}
public:
virtual property String^ AlternateName {
   String^ get();
   void set (    String^ value);
}

Property Value

An alternate field name that shall be used in place of the actual field name wherever the field shall be identified in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


CalculateAction Property

Xfinium.Pdf.Forms Namespace > PdfField Class : CalculateAction Property
Gets or sets the calculate action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CalculateAction As PdfJavaScriptAction
'Usage

Dim instance As PdfField
Dim value As PdfJavaScriptAction

instance.CalculateAction = value

value = instance.CalculateAction
public PdfJavaScriptAction CalculateAction {get; set;}
public:
property PdfJavaScriptAction^ CalculateAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction that shall be performed to recalculate the value of this field when that of another field changes.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


Export Property

Xfinium.Pdf.Forms Namespace > PdfField Class : Export Property
Gets or sets a value indicating whether the field can be exported or not.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Export As Boolean
'Usage

Dim instance As PdfField
Dim value As Boolean

instance.Export = value

value = instance.Export
public bool Export {get; set;}
public:
property bool Export {
   bool get();
   void set (    bool value);
}

Property Value

If true, the field shall be exported by a submit-form action.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


Form Property (PdfField)

Xfinium.Pdf.Forms Namespace > PdfField Class : Form Property
Gets the Acrobat form this field belongs to.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Form As PdfForm
'Usage

Dim instance As PdfField
Dim value As PdfForm

value = instance.Form
public PdfForm Form {get;}
public:
property PdfForm^ Form {
   PdfForm^ get();
}

Property Value

The parent form of the field.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


FormatAction Property

Xfinium.Pdf.Forms Namespace > PdfField Class : FormatAction Property
Gets or sets the format action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FormatAction As PdfJavaScriptAction
'Usage

Dim instance As PdfField
Dim value As PdfJavaScriptAction

instance.FormatAction = value

value = instance.FormatAction
public PdfJavaScriptAction FormatAction {get; set;}
public:
property PdfJavaScriptAction^ FormatAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction that shall be performed before the field is formatted to display its value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


KeyPressAction Property

Xfinium.Pdf.Forms Namespace > PdfField Class : KeyPressAction Property
Gets or sets the keypress action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property KeyPressAction As PdfJavaScriptAction
'Usage

Dim instance As PdfField
Dim value As PdfJavaScriptAction

instance.KeyPressAction = value

value = instance.KeyPressAction
public PdfJavaScriptAction KeyPressAction {get; set;}
public:
property PdfJavaScriptAction^ KeyPressAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction that shall be performed when the user modifies a character in a text field or combo box or modifies the selection in a scrollable list box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


MappingName Property

Xfinium.Pdf.Forms Namespace > PdfField Class : MappingName Property
Gets or sets the field mapping name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MappingName As String
'Usage

Dim instance As PdfField
Dim value As String

instance.MappingName = value

value = instance.MappingName
public string MappingName {get; set;}
public:
property String^ MappingName {
   String^ get();
   void set (    String^ value);
}

Property Value

The mapping name that shall be used when exporting interactive form field data from the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


Name Property (PdfField)

Xfinium.Pdf.Forms Namespace > PdfField Class : Name Property
Gets or sets the field name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfField
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the field.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the name is not valid (null, empty, unsupported characters).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


ReadOnly Property (PdfField)

Xfinium.Pdf.Forms Namespace > PdfField Class : ReadOnly Property
Gets or sets a value indicating whether the field is read-only.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ReadOnly As Boolean
'Usage

Dim instance As PdfField
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
public bool ReadOnly {get; set;}
public:
property bool ReadOnly {
   bool get();
   void set (    bool value);
}

Property Value

If true, the user may not change the value of the field. Any associated widget annotations will not interact with the user; that is, they will not respond to mouse clicks or change their appearance in response to mouse motions.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


Required Property

Xfinium.Pdf.Forms Namespace > PdfField Class : Required Property
Gets or sets a value indicating whether the field is required.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Required As Boolean
'Usage

Dim instance As PdfField
Dim value As Boolean

instance.Required = value

value = instance.Required
public bool Required {get; set;}
public:
property bool Required {
   bool get();
   void set (    bool value);
}

Property Value

If true, the field shall have a value at the time it is exported by a submit-form action
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


Type Property (PdfField)

Xfinium.Pdf.Forms Namespace > PdfField Class : Type Property
Gets the field type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PdfFieldType
'Usage

Dim instance As PdfField
Dim value As PdfFieldType

value = instance.Type
public PdfFieldType Type {get;}
public:
property PdfFieldType Type {
   PdfFieldType get();
}

Property Value

The field type.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


ValidateAction Property

Xfinium.Pdf.Forms Namespace > PdfField Class : ValidateAction Property
Gets or sets the validate action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ValidateAction As PdfJavaScriptAction
'Usage

Dim instance As PdfField
Dim value As PdfJavaScriptAction

instance.ValidateAction = value

value = instance.ValidateAction
public PdfJavaScriptAction ValidateAction {get; set;}
public:
property PdfJavaScriptAction^ ValidateAction {
   PdfJavaScriptAction^ get();
   void set (    PdfJavaScriptAction^ value);
}

Property Value

A Xfinium.Pdf.Actions.PdfJavaScriptAction that shall be performed when the field's value is changed. This action may check the new value for validity.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


Value Property (PdfField)

Xfinium.Pdf.Forms Namespace > PdfField Class : Value Property
Gets or sets the field value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As Object
'Usage

Dim instance As PdfField
Dim value As Object

instance.Value = value

value = instance.Value
public object Value {get; set;}
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The field value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


Widgets Property

Xfinium.Pdf.Forms Namespace > PdfField Class : Widgets Property
Gets the list of field widgets.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Widgets As PdfFieldWidgetCollection
'Usage

Dim instance As PdfField
Dim value As PdfFieldWidgetCollection

value = instance.Widgets
public PdfFieldWidgetCollection Widgets {get;}
public:
property PdfFieldWidgetCollection^ Widgets {
   PdfFieldWidgetCollection^ get();
}

Property Value

The list of widgets that represent the field on PDF pages.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfField Class
PdfField Members


%%PageItemTitle%%

PdfFieldCollection Class
Members

Xfinium.Pdf.Forms Namespace : PdfFieldCollection Class
Defines a collection of interactive form fields.
Object Model
PdfFieldCollection ClassPdfField Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfFieldCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfField)
'Usage

Dim instance As PdfFieldCollection
[DefaultMember("Item")]
public class PdfFieldCollection : System.Collections.ObjectModel.Collection<PdfField>
[DefaultMember("Item")]
public ref class PdfFieldCollection : public System.Collections.ObjectModel.Collection<PdfField>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Forms.PdfFieldCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldCollection Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfFieldCollection Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfFieldCollection Class

The following tables list the members exposed by PdfFieldCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Property | Item | Gets the field with the specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Remove | Overloaded. Removes the field with the specified name from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Top
See Also

Reference

PdfFieldCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Methods$$

PdfFieldCollection Class Methods

Xfinium.Pdf.Forms Namespace : PdfFieldCollection Class

For a list of all members of this type, see PdfFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Remove | Overloaded. Removes the field with the specified name from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Top
See Also

Reference

PdfFieldCollection Class
Xfinium.Pdf.Forms Namespace


Remove Method (PdfFieldCollection)

Xfinium.Pdf.Forms Namespace > PdfFieldCollection Class : Remove Method
Removes the field with the specified name from the collection.
Overload List
Overload | Description
Remove(String) | Removes the field with the specified name from the collection.
Remove(PdfField) | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldCollection Class
PdfFieldCollection Members


Remove(String) Method

Xfinium.Pdf.Forms Namespace > PdfFieldCollection Class > Remove Method : Remove(String) Method
The name of the field to remove.
Removes the field with the specified name from the collection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Remove( _
   ByVal name As String _
)
'Usage

Dim instance As PdfFieldCollection
Dim name As String

instance.Remove(name)
public void Remove(
   string name
)
public:
void Remove(
   String^ name
)

Parameters

name
The name of the field to remove.
Remarks
If the field with the specified name does not exist in the collection nothing happens.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldCollection Class
PdfFieldCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFieldCollection Class Properties

Xfinium.Pdf.Forms Namespace : PdfFieldCollection Class

For a list of all members of this type, see PdfFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Property | Item | Gets the field with the specified name.
Top
See Also

Reference

PdfFieldCollection Class
Xfinium.Pdf.Forms Namespace


Item Property (PdfFieldCollection)

Xfinium.Pdf.Forms Namespace > PdfFieldCollection Class : Item Property
The name of the field to lookup in the collection.
Gets the field with the specified name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal name As String _
) As PdfField
'Usage

Dim instance As PdfFieldCollection
Dim name As String
Dim value As PdfField

value = instance.Item(name)
public new PdfField this[
   string name
]; {get;}
public:
new property PdfField^ default [String^] {
   PdfField^ get(String^ name);
}

Parameters

name
The name of the field to lookup in the collection.

Property Value

The field if exists, otherwise null.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldCollection Class
PdfFieldCollection Members


%%PageItemTitle%%

PdfFieldWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfFieldWidget Class
Defines an interactive field widget.
Object Model
PdfFieldWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfCosDictionary ClassPdfField ClassPdfAction ClassPdfFont ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFieldWidget
   Inherits Xfinium.Pdf.Annotations.PdfAnnotation
'Usage

Dim instance As PdfFieldWidget
public class PdfFieldWidget : Xfinium.Pdf.Annotations.PdfAnnotation
public ref class PdfFieldWidget : public Xfinium.Pdf.Annotations.PdfAnnotation
Remarks
The field widget is the visual representation of a field on a PDF page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfCheckWidget
Xfinium.Pdf.Forms.PdfComboBoxWidget
Xfinium.Pdf.Forms.PdfListBoxWidget
Xfinium.Pdf.Forms.PdfPushButtonWidget
Xfinium.Pdf.Forms.PdfSignatureWidget
Xfinium.Pdf.Forms.PdfTextBoxWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfFieldWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfFieldWidget Class

The following tables list the members exposed by PdfFieldWidget.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color.
Public Property | Blur | Gets or sets the blur action.
Public Property | BorderColor | Gets or sets the widget border color.
Public Property | BorderWidth | Gets or sets the widget border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field.
Public Property | Focus | Gets or sets the focus action.
Public Property | Font | Gets or sets the widget font.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | TextColor | Gets or sets the widget text color.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility.
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Overridden. Merges the annotation appearance with the page content stream.
Top
See Also

Reference

PdfFieldWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Methods$$

PdfFieldWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfFieldWidget Class

For a list of all members of this type, see PdfFieldWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Overridden. Merges the annotation appearance with the page content stream.
Top
See Also

Reference

PdfFieldWidget Class
Xfinium.Pdf.Forms Namespace


Flatten Method (PdfFieldWidget)

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : Flatten Method
Merges the annotation appearance with the page content stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Sub Flatten()
'Usage

Dim instance As PdfFieldWidget

instance.Flatten()
public override void Flatten()
public:
void Flatten(); override
Remarks
The annotation normal appearance is merged with the page content stream and the annotation is destroyed. After calling this method the annotation object is in an invalid state and cannot be used any longer.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


%%PageItemTitle%% $$Properties$$

PdfFieldWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfFieldWidget Class

For a list of all members of this type, see PdfFieldWidget members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color.
Public Property | Blur | Gets or sets the blur action.
Public Property | BorderColor | Gets or sets the widget border color.
Public Property | BorderWidth | Gets or sets the widget border width.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field.
Public Property | Focus | Gets or sets the focus action.
Public Property | Font | Gets or sets the widget font.
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Overridden. Gets or sets the annotation rotation angle.
Public Property | TextColor | Gets or sets the widget text color.
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility.
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfFieldWidget Class
Xfinium.Pdf.Forms Namespace


BackgroundColor Property (PdfFieldWidget)

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : BackgroundColor Property
Gets or sets the widget background color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BackgroundColor As PdfColor
'Usage

Dim instance As PdfFieldWidget
Dim value As PdfColor

instance.BackgroundColor = value

value = instance.BackgroundColor
public PdfColor BackgroundColor {get; set;}
public:
property PdfColor^ BackgroundColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The widget background color.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


Blur Property

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : Blur Property
Gets or sets the blur action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Blur As PdfAction
'Usage

Dim instance As PdfFieldWidget
Dim value As PdfAction

instance.Blur = value

value = instance.Blur
public PdfAction Blur {get; set;}
public:
property PdfAction^ Blur {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action that shall be performed when the widget loses the input focus.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


BorderColor Property (PdfFieldWidget)

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : BorderColor Property
Gets or sets the widget border color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderColor As PdfColor
'Usage

Dim instance As PdfFieldWidget
Dim value As PdfColor

instance.BorderColor = value

value = instance.BorderColor
public PdfColor BorderColor {get; set;}
public:
property PdfColor^ BorderColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The widget border color.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


BorderWidth Property (PdfFieldWidget)

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : BorderWidth Property
Gets or sets the widget border width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderWidth As Double
'Usage

Dim instance As PdfFieldWidget
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
public double BorderWidth {get; set;}
public:
property double BorderWidth {
   double get();
   void set (    double value);
}

Property Value

The width of widget border.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when this property is set to a negative value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


Field Property

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : Field Property
Gets the parent field.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Field As PdfField
'Usage

Dim instance As PdfFieldWidget
Dim value As PdfField

value = instance.Field
public PdfField Field {get;}
public:
property PdfField^ Field {
   PdfField^ get();
}

Property Value

The parent field of the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


Focus Property

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : Focus Property
Gets or sets the focus action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Focus As PdfAction
'Usage

Dim instance As PdfFieldWidget
Dim value As PdfAction

instance.Focus = value

value = instance.Focus
public PdfAction Focus {get; set;}
public:
property PdfAction^ Focus {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

An action that shall be performed when the widget receives the input focus.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


Font Property (PdfFieldWidget)

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : Font Property
Gets or sets the widget font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As PdfFont
'Usage

Dim instance As PdfFieldWidget
Dim value As PdfFont

instance.Font = value

value = instance.Font
public PdfFont Font {get; set;}
public:
property PdfFont^ Font {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

The font used for showing the widget text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


Rotation Property (PdfFieldWidget)

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : Rotation Property
Gets or sets the annotation rotation angle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Rotation As Integer
'Usage

Dim instance As PdfFieldWidget
Dim value As Integer

instance.Rotation = value

value = instance.Rotation
public override int Rotation {get; set;}
public:
property int Rotation {
   int get() override;
   void set (    int value) override;
}

Property Value

The annotation rotation angle in degrees.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the value being set is not one of the accepted values.
Remarks
The accepted values for this property are 0, 90, 180 and 270 degrees.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


TextColor Property (PdfFieldWidget)

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : TextColor Property
Gets or sets the widget text color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextColor As PdfColor
'Usage

Dim instance As PdfFieldWidget
Dim value As PdfColor

instance.TextColor = value

value = instance.TextColor
public PdfColor TextColor {get; set;}
public:
property PdfColor^ TextColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The widget text color.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the property is set to a color other than Gray, RGB or CMYK.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


Visibility Property

Xfinium.Pdf.Forms Namespace > PdfFieldWidget Class : Visibility Property
Gets or sets the field widget visibility.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Visibility As PdfFieldWidgetVisibility
'Usage

Dim instance As PdfFieldWidget
Dim value As PdfFieldWidgetVisibility

instance.Visibility = value

value = instance.Visibility
public PdfFieldWidgetVisibility Visibility {get; set;}
public:
property PdfFieldWidgetVisibility Visibility {
   PdfFieldWidgetVisibility get();
   void set (    PdfFieldWidgetVisibility value);
}

Property Value

A PdfFieldWidgetVisibility that represents the visibility of the field widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidget Class
PdfFieldWidget Members


%%PageItemTitle%%

PdfFieldWidgetCollection Class
Members

Xfinium.Pdf.Forms Namespace : PdfFieldWidgetCollection Class
Defines a collection of field widgets.
Object Model
PdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFieldWidgetCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfFieldWidget)
'Usage

Dim instance As PdfFieldWidgetCollection
public class PdfFieldWidgetCollection : System.Collections.ObjectModel.Collection<PdfFieldWidget>
public ref class PdfFieldWidgetCollection : public System.Collections.ObjectModel.Collection<PdfFieldWidget>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Forms.PdfFieldWidgetCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFieldWidgetCollection Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfFieldWidgetCollection Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfFieldWidgetCollection Class

The following tables list the members exposed by PdfFieldWidgetCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Top
See Also

Reference

PdfFieldWidgetCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfForm Class
Members

Xfinium.Pdf.Forms Namespace : PdfForm Class
Defines an interactive Acrobat form.
Object Model
PdfForm ClassPdfCalculatedFieldCollection ClassPdfField ClassPdfFieldCollection ClassPdfField Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfForm
'Usage

Dim instance As PdfForm
public class PdfForm
public ref class PdfForm
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfForm

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfForm Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfForm Class

The following tables list the members exposed by PdfForm.

Public Properties
 | Name | Description
Public Property | CalculatedFields | Gets the calculated fields.
Public Property | Fields | Gets the form fields.
Public Property | NeedAppearances | Gets or sets a value indicating whether to construct visual appearances for all field widgets in the document.
Top
Public Methods
 | Name | Description
Public Method | ExportData | Exports the form data to a stream.
Public Method | FlattenField | Flattens the specified form field.
Public Method | FlattenFields | Flattens all the form fields.
Public Method | ImportData | Imports data from a stream.
Top
See Also

Reference

PdfForm Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Methods$$

PdfForm Class Methods

Xfinium.Pdf.Forms Namespace : PdfForm Class

For a list of all members of this type, see PdfForm members.

Public Methods
 | Name | Description
Public Method | ExportData | Exports the form data to a stream.
Public Method | FlattenField | Flattens the specified form field.
Public Method | FlattenFields | Flattens all the form fields.
Public Method | ImportData | Imports data from a stream.
Top
See Also

Reference

PdfForm Class
Xfinium.Pdf.Forms Namespace


ExportData Method

Xfinium.Pdf.Forms Namespace > PdfForm Class : ExportData Method
The output stream for form data.
The data format for export.
The PDF file name the data is exported from.
Exports the form data to a stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ExportData( _
   ByVal stream As Stream, _
   ByVal format As PdfFormDataFormat, _
   ByVal pdfFileName As String _
)
'Usage

Dim instance As PdfForm
Dim stream As Stream
Dim format As PdfFormDataFormat
Dim pdfFileName As String

instance.ExportData(stream, format, pdfFileName)
public void ExportData(
   Stream stream,
   PdfFormDataFormat format,
   string pdfFileName
)
public:
void ExportData(
   Stream^ stream,
   PdfFormDataFormat format,
   String^ pdfFileName
)

Parameters

stream
The output stream for form data.
format
The data format for export.
pdfFileName
The PDF file name the data is exported from.
Remarks
The FDF/XFDF data files require a reference to a PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Class
PdfForm Members


FlattenField Method

Xfinium.Pdf.Forms Namespace > PdfForm Class : FlattenField Method
The field to flatten.
Flattens the specified form field.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub FlattenField( _
   ByVal field As PdfField _
)
'Usage

Dim instance As PdfForm
Dim field As PdfField

instance.FlattenField(field)
public void FlattenField(
   PdfField field
)
public:
void FlattenField(
   PdfField^ field
)

Parameters

field
The field to flatten.
Remarks
The field can no longer be edited after it has been flattened.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Class
PdfForm Members


FlattenFields Method

Xfinium.Pdf.Forms Namespace > PdfForm Class : FlattenFields Method
Flattens all the form fields.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub FlattenFields()
'Usage

Dim instance As PdfForm

instance.FlattenFields()
public void FlattenFields()
public:
void FlattenFields();
Remarks
After flattening the field the form is no longer editable.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Class
PdfForm Members


ImportData(Stream,PdfFormDataFormat) Method

Xfinium.Pdf.Forms Namespace > PdfForm Class : ImportData(Stream,PdfFormDataFormat) Method
The input stream for data import.
The format of data in input stream.
Imports data from a stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As PdfFormDataFormat _
)
'Usage

Dim instance As PdfForm
Dim stream As Stream
Dim dataFormat As PdfFormDataFormat

instance.ImportData(stream, dataFormat)
public void ImportData(
   Stream stream,
   PdfFormDataFormat dataFormat
)
public:
void ImportData(
   Stream^ stream,
   PdfFormDataFormat dataFormat
)

Parameters

stream
The input stream for data import.
dataFormat
The format of data in input stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Class
PdfForm Members


%%PageItemTitle%% $$Properties$$

PdfForm Class Properties

Xfinium.Pdf.Forms Namespace : PdfForm Class

For a list of all members of this type, see PdfForm members.

Public Properties
 | Name | Description
Public Property | CalculatedFields | Gets the calculated fields.
Public Property | Fields | Gets the form fields.
Public Property | NeedAppearances | Gets or sets a value indicating whether to construct visual appearances for all field widgets in the document.
Top
See Also

Reference

PdfForm Class
Xfinium.Pdf.Forms Namespace


CalculatedFields Property

Xfinium.Pdf.Forms Namespace > PdfForm Class : CalculatedFields Property
Gets the calculated fields.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CalculatedFields As PdfCalculatedFieldCollection
'Usage

Dim instance As PdfForm
Dim value As PdfCalculatedFieldCollection

value = instance.CalculatedFields
public PdfCalculatedFieldCollection CalculatedFields {get;}
public:
property PdfCalculatedFieldCollection^ CalculatedFields {
   PdfCalculatedFieldCollection^ get();
}

Property Value

The list of calculated fields in this form.
Remarks
The fields are calculated in the order they appear in this collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Class
PdfForm Members


Fields Property (PdfForm)

Xfinium.Pdf.Forms Namespace > PdfForm Class : Fields Property
Gets the form fields.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Fields As PdfFieldCollection
'Usage

Dim instance As PdfForm
Dim value As PdfFieldCollection

value = instance.Fields
public PdfFieldCollection Fields {get;}
public:
property PdfFieldCollection^ Fields {
   PdfFieldCollection^ get();
}

Property Value

The collection of fields that compose this form.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Class
PdfForm Members


NeedAppearances Property

Xfinium.Pdf.Forms Namespace > PdfForm Class : NeedAppearances Property
Gets or sets a value indicating whether to construct visual appearances for all field widgets in the document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NeedAppearances As Boolean
'Usage

Dim instance As PdfForm
Dim value As Boolean

instance.NeedAppearances = value

value = instance.NeedAppearances
public bool NeedAppearances {get; set;}
public:
property bool NeedAppearances {
   bool get();
   void set (    bool value);
}

Property Value

If true, visual appearances should be constructed for all field widgets.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Class
PdfForm Members


%%PageItemTitle%%

PdfListBoxField Class
Members

Xfinium.Pdf.Forms Namespace : PdfListBoxField Class
Defines an interactive Acrobat list box field.
Object Model
PdfListBoxField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfListItemCollection ClassPdfListItem ClassPdfJavaScriptAction ClassPdfListItem ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfListBoxField
   Inherits PdfListField
'Usage

Dim instance As PdfListBoxField
public class PdfListBoxField : PdfListField
public ref class PdfListBoxField : public PdfListField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfListField
Xfinium.Pdf.Forms.PdfListBoxField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListBoxField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfListBoxField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfListBoxField Class

The following tables list the members exposed by PdfListBoxField.

Public Constructors
 | Name | Description
Public Constructor | PdfListBoxField Constructor | Initializes a new PdfListBoxField object.
Top
Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CommitOnSelectionChange | Gets or sets a value indicating whether the new value shall be committed as soon as a selection is made. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Items | Gets the items in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Sort | Gets or sets a value indicating whether the field's option items shall be sorted alphabetically. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfListBoxField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfListBoxField Constructor

Xfinium.Pdf.Forms Namespace > PdfListBoxField Class : PdfListBoxField Constructor
The field name.
Initializes a new PdfListBoxField object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfListBoxField(name)
public PdfListBoxField(
   string name
)
public:
PdfListBoxField(
   String^ name
)

Parameters

name
The field name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListBoxField Class
PdfListBoxField Members


%%PageItemTitle%%

PdfListBoxWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfListBoxWidget Class
Defines an interactive list box widget.
Object Model
PdfListBoxWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfCosDictionary ClassPdfField ClassPdfAction ClassPdfFont ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfListBoxWidget
   Inherits PdfFieldWidget
'Usage

Dim instance As PdfListBoxWidget
public class PdfListBoxWidget : PdfFieldWidget
public ref class PdfListBoxWidget : public PdfFieldWidget
Remarks
The list box widget is the visual representation of a list box field on a PDF page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfListBoxWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListBoxWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfListBoxWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfListBoxWidget Class

The following tables list the members exposed by PdfListBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PdfListBoxWidget Constructor | Initializes a new PdfListBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfListBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfListBoxWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfListBoxWidget Class : PdfListBoxWidget Constructor
Initializes a new PdfListBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfListBoxWidget()
public PdfListBoxWidget()
public:
PdfListBoxWidget();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListBoxWidget Class
PdfListBoxWidget Members


%%PageItemTitle%%

PdfListField Class
Members

Xfinium.Pdf.Forms Namespace : PdfListField Class
Defines the base class for interactive choice fields, comboboxes and listboxes.
Object Model
PdfListField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfListItemCollection ClassPdfListItem ClassPdfJavaScriptAction ClassPdfListItem ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfListField
   Inherits PdfField
'Usage

Dim instance As PdfListField
public abstract class PdfListField : PdfField
public ref class PdfListField abstract : public PdfField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfListField
Xfinium.Pdf.Forms.PdfComboBoxField
Xfinium.Pdf.Forms.PdfListBoxField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfListField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfListField Class

The following tables list the members exposed by PdfListField.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CommitOnSelectionChange | Gets or sets a value indicating whether the new value shall be committed as soon as a selection is made.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Items | Gets the items in the list.
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | Sort | Gets or sets a value indicating whether the field's option items shall be sorted alphabetically.
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfListField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfListField Class Properties

Xfinium.Pdf.Forms Namespace : PdfListField Class

For a list of all members of this type, see PdfListField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CommitOnSelectionChange | Gets or sets a value indicating whether the new value shall be committed as soon as a selection is made.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Items | Gets the items in the list.
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | Sort | Gets or sets a value indicating whether the field's option items shall be sorted alphabetically.
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfListField Class
Xfinium.Pdf.Forms Namespace


CommitOnSelectionChange Property

Xfinium.Pdf.Forms Namespace > PdfListField Class : CommitOnSelectionChange Property
Gets or sets a value indicating whether the new value shall be committed as soon as a selection is made.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CommitOnSelectionChange As Boolean
'Usage

Dim instance As PdfListField
Dim value As Boolean

instance.CommitOnSelectionChange = value

value = instance.CommitOnSelectionChange
public bool CommitOnSelectionChange {get; set;}
public:
property bool CommitOnSelectionChange {
   bool get();
   void set (    bool value);
}

Property Value

If true, the new value shall be committed as soon as a selection is made (commonly with the pointing device).
Remarks
This option enables applications to perform an action once a selection is made, without requiring the user to exit the field. If clear, the new value is not committed until the user exits the field.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListField Class
PdfListField Members


Items Property (PdfListField)

Xfinium.Pdf.Forms Namespace > PdfListField Class : Items Property
Gets the items in the list.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Items As PdfListItemCollection
'Usage

Dim instance As PdfListField
Dim value As PdfListItemCollection

value = instance.Items
public PdfListItemCollection Items {get;}
public:
property PdfListItemCollection^ Items {
   PdfListItemCollection^ get();
}

Property Value

A list of items that define the possible values for the field.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListField Class
PdfListField Members


SelectedIndex Property (PdfListField)

Xfinium.Pdf.Forms Namespace > PdfListField Class : SelectedIndex Property
Gets or sets the lowest ordinal index of the selected items in the list.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SelectedIndex As Integer
'Usage

Dim instance As PdfListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
public int SelectedIndex {get; set;}
public:
property int SelectedIndex {
   int get();
   void set (    int value);
}

Property Value

The lowest ordinal index of the selected items in the list. The default is -1, which indicates that nothing is selected.
Remarks
Use this property to determine the index of the currently selected item in the list if the list control allows only one selection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListField Class
PdfListField Members


SelectedItem Property

Xfinium.Pdf.Forms Namespace > PdfListField Class : SelectedItem Property
Gets or sets the first selected item in the list.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SelectedItem As PdfListItem
'Usage

Dim instance As PdfListField
Dim value As PdfListItem

instance.SelectedItem = value

value = instance.SelectedItem
public PdfListItem SelectedItem {get; set;}
public:
property PdfListItem^ SelectedItem {
   PdfListItem^ get();
   void set (    PdfListItem^ value);
}

Property Value

A PdfListItem that represents the selected item.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListField Class
PdfListField Members


Sort Property

Xfinium.Pdf.Forms Namespace > PdfListField Class : Sort Property
Gets or sets a value indicating whether the field's option items shall be sorted alphabetically.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Sort As Boolean
'Usage

Dim instance As PdfListField
Dim value As Boolean

instance.Sort = value

value = instance.Sort
public bool Sort {get; set;}
public:
property bool Sort {
   bool get();
   void set (    bool value);
}

Property Value

If true, the field's option items shall be sorted alphabetically.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListField Class
PdfListField Members


%%PageItemTitle%%

PdfListItem Class
Members

Xfinium.Pdf.Forms Namespace : PdfListItem Class
Defines an item in a list field.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfListItem
'Usage

Dim instance As PdfListItem
public class PdfListItem
public ref class PdfListItem
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfListItem

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListItem Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfListItem Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfListItem Class

The following tables list the members exposed by PdfListItem.

Public Constructors
 | Name | Description
Public Constructor | PdfListItem Constructor | Initialzies a new PdfListItem object.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the item name.
Public Property | Value | Gets or sets the item value.
Top
See Also

Reference

PdfListItem Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfListItem Constructor

Xfinium.Pdf.Forms Namespace > PdfListItem Class : PdfListItem Constructor
The item name that is displayed in the list.
The item value used for export operations.
Initialzies a new PdfListItem object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal value As String _
)
'Usage

Dim name As String
Dim value As String

Dim instance As New PdfListItem(name, value)
public PdfListItem(
   string name,
   string value
)
public:
PdfListItem(
   String^ name,
   String^ value
)

Parameters

name
The item name that is displayed in the list.
value
The item value used for export operations.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the item value is null or empty.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListItem Class
PdfListItem Members


%%PageItemTitle%% $$Properties$$

PdfListItem Class Properties

Xfinium.Pdf.Forms Namespace : PdfListItem Class

For a list of all members of this type, see PdfListItem members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the item name.
Public Property | Value | Gets or sets the item value.
Top
See Also

Reference

PdfListItem Class
Xfinium.Pdf.Forms Namespace


Name Property (PdfListItem)

Xfinium.Pdf.Forms Namespace > PdfListItem Class : Name Property
Gets or sets the item name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfListItem
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The item name displayed in the list.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListItem Class
PdfListItem Members


Value Property (PdfListItem)

Xfinium.Pdf.Forms Namespace > PdfListItem Class : Value Property
Gets or sets the item value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As PdfListItem
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Property Value

The item value used in export operations.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListItem Class
PdfListItem Members


%%PageItemTitle%%

PdfListItemCollection Class
Members

Xfinium.Pdf.Forms Namespace : PdfListItemCollection Class
Defines a collection of list items.
Object Model
PdfListItemCollection ClassPdfListItem Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfListItemCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfListItem)
'Usage

Dim instance As PdfListItemCollection
public class PdfListItemCollection : System.Collections.ObjectModel.Collection<PdfListItem>
public ref class PdfListItemCollection : public System.Collections.ObjectModel.Collection<PdfListItem>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Forms.PdfListItemCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListItemCollection Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfListItemCollection Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfListItemCollection Class

The following tables list the members exposed by PdfListItemCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Top
See Also

Reference

PdfListItemCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfPushButtonField Class
Members

Xfinium.Pdf.Forms Namespace : PdfPushButtonField Class
Defines an interactive Acrobat pushbutton field.
Object Model
PdfPushButtonField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPushButtonField
   Inherits PdfField
'Usage

Dim instance As PdfPushButtonField
public class PdfPushButtonField : PdfField
public ref class PdfPushButtonField : public PdfField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfPushButtonField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfPushButtonField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfPushButtonField Class

The following tables list the members exposed by PdfPushButtonField.

Public Constructors
 | Name | Description
Public Constructor | PdfPushButtonField Constructor | Initializes a new PdfPushButtonField object.
Top
Public Properties
 | Name | Description
Public Property | AlternateName | Overridden. Gets or sets the field alternate name.
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Caption | Gets or sets the button caption.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfPushButtonField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfPushButtonField Constructor

Xfinium.Pdf.Forms Namespace > PdfPushButtonField Class : PdfPushButtonField Constructor
The field name.
Initializes a new PdfPushButtonField object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfPushButtonField(name)
public PdfPushButtonField(
   string name
)
public:
PdfPushButtonField(
   String^ name
)

Parameters

name
The field name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonField Class
PdfPushButtonField Members


%%PageItemTitle%% $$Properties$$

PdfPushButtonField Class Properties

Xfinium.Pdf.Forms Namespace : PdfPushButtonField Class

For a list of all members of this type, see PdfPushButtonField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Overridden. Gets or sets the field alternate name.
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Caption | Gets or sets the button caption.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfPushButtonField Class
Xfinium.Pdf.Forms Namespace


AlternateName Property (PdfPushButtonField)

Xfinium.Pdf.Forms Namespace > PdfPushButtonField Class : AlternateName Property
Gets or sets the field alternate name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property AlternateName As String
'Usage

Dim instance As PdfPushButtonField
Dim value As String

instance.AlternateName = value

value = instance.AlternateName
public override string AlternateName {get; set;}
public:
property String^ AlternateName {
   String^ get() override;
   void set (    String^ value) override;
}

Property Value

An alternate field name that shall be used in place of the actual field name wherever the field shall be identified in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonField Class
PdfPushButtonField Members


Caption Property (PdfPushButtonField)

Xfinium.Pdf.Forms Namespace > PdfPushButtonField Class : Caption Property
Gets or sets the button caption.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Caption As String
'Usage

Dim instance As PdfPushButtonField
Dim value As String

instance.Caption = value

value = instance.Caption
public string Caption {get; set;}
public:
property String^ Caption {
   String^ get();
   void set (    String^ value);
}

Property Value

The text displayed on the button.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonField Class
PdfPushButtonField Members


%%PageItemTitle%%

PdfPushButtonWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfPushButtonWidget Class
Defines an interactive pushbutton widget.
Object Model
PdfPushButtonWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfCosDictionary ClassPdfAnnotationAppearance ClassPdfField ClassPdfAction ClassPdfFont ClassPdfFormXObject ClassPdfSize ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfColor ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPushButtonWidget
   Inherits PdfFieldWidget
'Usage

Dim instance As PdfPushButtonWidget
public class PdfPushButtonWidget : PdfFieldWidget
public ref class PdfPushButtonWidget : public PdfFieldWidget
Remarks
The pushbutton widget is the visual representation of a pushbutton field on a PDF page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfPushButtonWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfPushButtonWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfPushButtonWidget Class

The following tables list the members exposed by PdfPushButtonWidget.

Public Constructors
 | Name | Description
Public Constructor | PdfPushButtonWidget Constructor | Initializes a new PdfPushButtonWidget object.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the caption alignment.
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Caption | Gets or sets the widget caption.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | DownAppearance | Gets or sets the pressed visual appearance for the widget.
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | HighlightMode | Gets or sets the highlighting of the button widget.
Public Property | Icon | Gets or sets the widget icon.
Public Property | IconLayout | Gets or sets the layout for the widget icon.
Public Property | IconSize | Gets or sets the display size of the widget icon.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | RolloverAppearance | Gets or sets the rollover visual appearance for the widget.
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfPushButtonWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfPushButtonWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : PdfPushButtonWidget Constructor
Initializes a new PdfPushButtonWidget object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPushButtonWidget()
public PdfPushButtonWidget()
public:
PdfPushButtonWidget();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


%%PageItemTitle%% $$Properties$$

PdfPushButtonWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfPushButtonWidget Class

For a list of all members of this type, see PdfPushButtonWidget members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the caption alignment.
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Caption | Gets or sets the widget caption.
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | DownAppearance | Gets or sets the pressed visual appearance for the widget.
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | HighlightMode | Gets or sets the highlighting of the button widget.
Public Property | Icon | Gets or sets the widget icon.
Public Property | IconLayout | Gets or sets the layout for the widget icon.
Public Property | IconSize | Gets or sets the display size of the widget icon.
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | RolloverAppearance | Gets or sets the rollover visual appearance for the widget.
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfPushButtonWidget Class
Xfinium.Pdf.Forms Namespace


Align Property (PdfPushButtonWidget)

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : Align Property
Gets or sets the caption alignment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Align As PdfStringHorizontalAlign
'Usage

Dim instance As PdfPushButtonWidget
Dim value As PdfStringHorizontalAlign

instance.Align = value

value = instance.Align
public PdfStringHorizontalAlign Align {get; set;}
public:
property PdfStringHorizontalAlign Align {
   PdfStringHorizontalAlign get();
   void set (    PdfStringHorizontalAlign value);
}

Property Value

The aligment of the widget caption.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


Caption Property (PdfPushButtonWidget)

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : Caption Property
Gets or sets the widget caption.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Caption As String
'Usage

Dim instance As PdfPushButtonWidget
Dim value As String

instance.Caption = value

value = instance.Caption
public string Caption {get; set;}
public:
property String^ Caption {
   String^ get();
   void set (    String^ value);
}

Property Value

The text displayed on the pushbutton widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


DownAppearance Property

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : DownAppearance Property
Gets or sets the pressed visual appearance for the widget.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DownAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfPushButtonWidget
Dim value As PdfAnnotationAppearance

instance.DownAppearance = value

value = instance.DownAppearance
public PdfAnnotationAppearance DownAppearance {get; set;}
public:
property PdfAnnotationAppearance^ DownAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

The pressed visual appearance of the widget.
Remarks
The visual appearance of the widget when the user presses the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


HighlightMode Property

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : HighlightMode Property
Gets or sets the highlighting of the button widget.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HighlightMode As PdfPushButtonHighlightMode
'Usage

Dim instance As PdfPushButtonWidget
Dim value As PdfPushButtonHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
public PdfPushButtonHighlightMode HighlightMode {get; set;}
public:
property PdfPushButtonHighlightMode HighlightMode {
   PdfPushButtonHighlightMode get();
   void set (    PdfPushButtonHighlightMode value);
}

Property Value

A PdfPushButtonHighlightMode that specifies how the pushbutton widget is highlighted when it is clicked.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


Icon Property

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : Icon Property
Gets or sets the widget icon.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Icon As PdfFormXObject
'Usage

Dim instance As PdfPushButtonWidget
Dim value As PdfFormXObject

instance.Icon = value

value = instance.Icon
public PdfFormXObject Icon {get; set;}
public:
property PdfFormXObject^ Icon {
   PdfFormXObject^ get();
   void set (    PdfFormXObject^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfFormXObject that represents the widget icon.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


IconLayout Property

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : IconLayout Property
Gets or sets the layout for the widget icon.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IconLayout As PdfPushButtonIconLayout
'Usage

Dim instance As PdfPushButtonWidget
Dim value As PdfPushButtonIconLayout

instance.IconLayout = value

value = instance.IconLayout
public PdfPushButtonIconLayout IconLayout {get; set;}
public:
property PdfPushButtonIconLayout IconLayout {
   PdfPushButtonIconLayout get();
   void set (    PdfPushButtonIconLayout value);
}

Property Value

A PdfPushButtonIconLayout that specifies the layout of the icon within the widget appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


IconSize Property

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : IconSize Property
Gets or sets the display size of the widget icon.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IconSize As PdfSize
'Usage

Dim instance As PdfPushButtonWidget
Dim value As PdfSize

instance.IconSize = value

value = instance.IconSize
public PdfSize IconSize {get; set;}
public:
property PdfSize^ IconSize {
   PdfSize^ get();
   void set (    PdfSize^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfSize that represents the size used to draw the icon on the widget.
Remarks
The icon is scaled to fit the display size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


RolloverAppearance Property

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : RolloverAppearance Property
Gets or sets the rollover visual appearance for the widget.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RolloverAppearance As PdfAnnotationAppearance
'Usage

Dim instance As PdfPushButtonWidget
Dim value As PdfAnnotationAppearance

instance.RolloverAppearance = value

value = instance.RolloverAppearance
public PdfAnnotationAppearance RolloverAppearance {get; set;}
public:
property PdfAnnotationAppearance^ RolloverAppearance {
   PdfAnnotationAppearance^ get();
   void set (    PdfAnnotationAppearance^ value);
}

Property Value

The rollover visual appearance of the widget.
Remarks
The visual appearance of the widget when the user hovers the mouse over the widget.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


%%PageItemTitle%%

PdfRadioButtonField Class
Members

Xfinium.Pdf.Forms Namespace : PdfRadioButtonField Class
Defines an interactive Acrobat radiobutton field.
Object Model
PdfRadioButtonField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRadioButtonField
   Inherits PdfField
'Usage

Dim instance As PdfRadioButtonField
public class PdfRadioButtonField : PdfField
public ref class PdfRadioButtonField : public PdfField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfRadioButtonField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfRadioButtonField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfRadioButtonField Class

The following tables list the members exposed by PdfRadioButtonField.

Public Constructors
 | Name | Description
Public Constructor | PdfRadioButtonField Constructor | Initializes a new PdfRadioButtonField object.
Top
Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Checked | Gets or set a value indicating whether the radio button is in the checked state.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radio button shall be selected at all times.
Public Property | RadiosInUnison | Gets or sets a value indicating whether all the widgets the same export value in the same radio button group should be selected.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected widgets in the field.
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfRadioButtonField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfRadioButtonField Constructor

Xfinium.Pdf.Forms Namespace > PdfRadioButtonField Class : PdfRadioButtonField Constructor
The field name.
Initializes a new PdfRadioButtonField object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfRadioButtonField(name)
public PdfRadioButtonField(
   string name
)
public:
PdfRadioButtonField(
   String^ name
)

Parameters

name
The field name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonField Class
PdfRadioButtonField Members


%%PageItemTitle%% $$Properties$$

PdfRadioButtonField Class Properties

Xfinium.Pdf.Forms Namespace : PdfRadioButtonField Class

For a list of all members of this type, see PdfRadioButtonField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Checked | Gets or set a value indicating whether the radio button is in the checked state.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radio button shall be selected at all times.
Public Property | RadiosInUnison | Gets or sets a value indicating whether all the widgets the same export value in the same radio button group should be selected.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected widgets in the field.
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfRadioButtonField Class
Xfinium.Pdf.Forms Namespace


Checked Property (PdfRadioButtonField)

Xfinium.Pdf.Forms Namespace > PdfRadioButtonField Class : Checked Property
Gets or set a value indicating whether the radio button is in the checked state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Checked As Boolean
'Usage

Dim instance As PdfRadioButtonField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
public bool Checked {get; set;}
public:
property bool Checked {
   bool get();
   void set (    bool value);
}

Property Value

True if the radio button is in the checked state; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonField Class
PdfRadioButtonField Members


NoToggleToOff Property

Xfinium.Pdf.Forms Namespace > PdfRadioButtonField Class : NoToggleToOff Property
Gets or sets a value indicating whether a radio button shall be selected at all times.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NoToggleToOff As Boolean
'Usage

Dim instance As PdfRadioButtonField
Dim value As Boolean

instance.NoToggleToOff = value

value = instance.NoToggleToOff
public bool NoToggleToOff {get; set;}
public:
property bool NoToggleToOff {
   bool get();
   void set (    bool value);
}

Property Value

If true, exactly one radio button shall be selected at all times.
Remarks
If set, exactly one radio button shall be selected at all times; selecting the currently selected button has no effect. If clear, clicking the selected button deselects it, leaving no button selected.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonField Class
PdfRadioButtonField Members


RadiosInUnison Property

Xfinium.Pdf.Forms Namespace > PdfRadioButtonField Class : RadiosInUnison Property
Gets or sets a value indicating whether all the widgets the same export value in the same radio button group should be selected.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RadiosInUnison As Boolean
'Usage

Dim instance As PdfRadioButtonField
Dim value As Boolean

instance.RadiosInUnison = value

value = instance.RadiosInUnison
public bool RadiosInUnison {get; set;}
public:
property bool RadiosInUnison {
   bool get();
   void set (    bool value);
}

Property Value

If true, a group of radio buttons widgets within a radio button field that use the same export value will turn on and off in unison.
Remarks
If set, a group of radio buttons within a radio button field that use the same export value will turn on and off in unison; that is if one is checked, they are all checked. If clear, the buttons are mutually exclusive.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonField Class
PdfRadioButtonField Members


SelectedIndex Property (PdfRadioButtonField)

Xfinium.Pdf.Forms Namespace > PdfRadioButtonField Class : SelectedIndex Property
Gets or sets the lowest ordinal index of the selected widgets in the field.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SelectedIndex As Integer
'Usage

Dim instance As PdfRadioButtonField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
public int SelectedIndex {get; set;}
public:
property int SelectedIndex {
   int get();
   void set (    int value);
}

Property Value

The lowest ordinal index of the selected widgets in the field. The default is -1, which indicates that nothing is selected.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonField Class
PdfRadioButtonField Members


%%PageItemTitle%%

PdfRadioButtonWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfRadioButtonWidget Class
Defines an interactive radiobutton widget.
Object Model
PdfRadioButtonWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfCosDictionary ClassPdfField ClassPdfAction ClassPdfFont ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfAnnotationAppearance ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRadioButtonWidget
   Inherits PdfCheckWidget
'Usage

Dim instance As PdfRadioButtonWidget
public class PdfRadioButtonWidget : PdfCheckWidget
public ref class PdfRadioButtonWidget : public PdfCheckWidget
Remarks
The radiobutton widget is the visual representation of a radiobutton field on a PDF page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfCheckWidget
Xfinium.Pdf.Forms.PdfRadioButtonWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfRadioButtonWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfRadioButtonWidget Class

The following tables list the members exposed by PdfRadioButtonWidget.

Public Constructors
 | Name | Description
Public Constructor | PdfRadioButtonWidget Constructor | Initializes a new PdfRadioButtonWidget object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Checked | Gets or set a value indicating whether the check widget is in the checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckStyle | Gets or sets the style of the checked widget. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ExportValue | Gets or sets the widget's export value. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | UncheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | UncheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | UncheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfRadioButtonWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfRadioButtonWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfRadioButtonWidget Class : PdfRadioButtonWidget Constructor
Initializes a new PdfRadioButtonWidget object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRadioButtonWidget()
public PdfRadioButtonWidget()
public:
PdfRadioButtonWidget();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonWidget Class
PdfRadioButtonWidget Members


%%PageItemTitle%%

PdfSignatureField Class
Members

Xfinium.Pdf.Forms Namespace : PdfSignatureField Class
Defines an interactive Acrobat signature field.
Object Model
PdfSignatureField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfSignatureLockFieldAction ClassPdfDigitalSignature ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSignatureField
   Inherits PdfField
'Usage

Dim instance As PdfSignatureField
public class PdfSignatureField : PdfField
public ref class PdfSignatureField : public PdfField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfSignatureField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfSignatureField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfSignatureField Class

The following tables list the members exposed by PdfSignatureField.

Public Constructors
 | Name | Description
Public Constructor | PdfSignatureField Constructor | Initializes a new PdfSignatureField object.
Top
Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | LockFieldAction | Gets or sets the lock field action.
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Signature | Gets or sets the digital signature.
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfSignatureField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfSignatureField Constructor

Xfinium.Pdf.Forms Namespace > PdfSignatureField Class : PdfSignatureField Constructor
The field name.
Initializes a new PdfSignatureField object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfSignatureField(name)
public PdfSignatureField(
   string name
)
public:
PdfSignatureField(
   String^ name
)

Parameters

name
The field name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureField Class
PdfSignatureField Members


%%PageItemTitle%% $$Properties$$

PdfSignatureField Class Properties

Xfinium.Pdf.Forms Namespace : PdfSignatureField Class

For a list of all members of this type, see PdfSignatureField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | LockFieldAction | Gets or sets the lock field action.
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Signature | Gets or sets the digital signature.
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfSignatureField Class
Xfinium.Pdf.Forms Namespace


LockFieldAction Property

Xfinium.Pdf.Forms Namespace > PdfSignatureField Class : LockFieldAction Property
Gets or sets the lock field action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LockFieldAction As PdfSignatureLockFieldAction
'Usage

Dim instance As PdfSignatureField
Dim value As PdfSignatureLockFieldAction

instance.LockFieldAction = value

value = instance.LockFieldAction
public PdfSignatureLockFieldAction LockFieldAction {get; set;}
public:
property PdfSignatureLockFieldAction^ LockFieldAction {
   PdfSignatureLockFieldAction^ get();
   void set (    PdfSignatureLockFieldAction^ value);
}

Property Value

The lock field action that is executed when the signature field is signed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureField Class
PdfSignatureField Members


Signature Property

Xfinium.Pdf.Forms Namespace > PdfSignatureField Class : Signature Property
Gets or sets the digital signature.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Signature As PdfDigitalSignature
'Usage

Dim instance As PdfSignatureField
Dim value As PdfDigitalSignature

instance.Signature = value

value = instance.Signature
public PdfDigitalSignature Signature {get; set;}
public:
property PdfDigitalSignature^ Signature {
   PdfDigitalSignature^ get();
   void set (    PdfDigitalSignature^ value);
}

Property Value

The digital signature that signs the document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureField Class
PdfSignatureField Members


%%PageItemTitle%%

PdfSignatureLockFieldAction Class
Members

Xfinium.Pdf.Forms Namespace : PdfSignatureLockFieldAction Class
Defines a signature field lock action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSignatureLockFieldAction
'Usage

Dim instance As PdfSignatureLockFieldAction
public class PdfSignatureLockFieldAction
public ref class PdfSignatureLockFieldAction
Remarks
A signature field lock action specifies a set of form fields that shall be locked when signature field is signed.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfSignatureLockFieldAction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureLockFieldAction Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfSignatureLockFieldAction Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfSignatureLockFieldAction Class

The following tables list the members exposed by PdfSignatureLockFieldAction.

Public Constructors
 | Name | Description
Public Constructor | PdfSignatureLockFieldAction Constructor | Initializes a new PdfSignatureLockFieldAction object.
Top
Public Properties
 | Name | Description
Public Property | Fields | Gets or sets the fields this action acts upon.
Public Property | SignatureLockType | Gets or sets the lock type.
Top
See Also

Reference

PdfSignatureLockFieldAction Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfSignatureLockFieldAction Constructor

Xfinium.Pdf.Forms Namespace > PdfSignatureLockFieldAction Class : PdfSignatureLockFieldAction Constructor
Initializes a new PdfSignatureLockFieldAction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSignatureLockFieldAction()
public PdfSignatureLockFieldAction()
public:
PdfSignatureLockFieldAction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureLockFieldAction Class
PdfSignatureLockFieldAction Members


%%PageItemTitle%% $$Properties$$

PdfSignatureLockFieldAction Class Properties

Xfinium.Pdf.Forms Namespace : PdfSignatureLockFieldAction Class

For a list of all members of this type, see PdfSignatureLockFieldAction members.

Public Properties
 | Name | Description
Public Property | Fields | Gets or sets the fields this action acts upon.
Public Property | SignatureLockType | Gets or sets the lock type.
Top
See Also

Reference

PdfSignatureLockFieldAction Class
Xfinium.Pdf.Forms Namespace


Fields Property (PdfSignatureLockFieldAction)

Xfinium.Pdf.Forms Namespace > PdfSignatureLockFieldAction Class : Fields Property
Gets or sets the fields this action acts upon.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Fields As String()
'Usage

Dim instance As PdfSignatureLockFieldAction
Dim value() As String

instance.Fields = value

value = instance.Fields
public string[] Fields {get; set;}
public:
property array<String^>^ Fields {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

An array of text strings containing field names.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureLockFieldAction Class
PdfSignatureLockFieldAction Members


SignatureLockType Property

Xfinium.Pdf.Forms Namespace > PdfSignatureLockFieldAction Class : SignatureLockType Property
Gets or sets the lock type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SignatureLockType As PdfSignatureLockType
'Usage

Dim instance As PdfSignatureLockFieldAction
Dim value As PdfSignatureLockType

instance.SignatureLockType = value

value = instance.SignatureLockType
public PdfSignatureLockType SignatureLockType {get; set;}
public:
property PdfSignatureLockType SignatureLockType {
   PdfSignatureLockType get();
   void set (    PdfSignatureLockType value);
}

Property Value

A PdfSignatureLockType which, in conjunction with Fields, indicates the set of fields that should be locked.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureLockFieldAction Class
PdfSignatureLockFieldAction Members


%%PageItemTitle%%

PdfSignatureWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfSignatureWidget Class
Defines an interactive signature widget.
Object Model
PdfSignatureWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfCosDictionary ClassPdfField ClassPdfAction ClassPdfFont ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSignatureWidget
   Inherits PdfFieldWidget
'Usage

Dim instance As PdfSignatureWidget
public class PdfSignatureWidget : PdfFieldWidget
public ref class PdfSignatureWidget : public PdfFieldWidget
Remarks
The signature widget is the visual representation of a signature field on a PDF page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfSignatureWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfSignatureWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfSignatureWidget Class

The following tables list the members exposed by PdfSignatureWidget.

Public Constructors
 | Name | Description
Public Constructor | PdfSignatureWidget Constructor | Initializes a new PdfSignatureWidget object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfSignatureWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfSignatureWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfSignatureWidget Class : PdfSignatureWidget Constructor
Initializes a new PdfSignatureWidget object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSignatureWidget()
public PdfSignatureWidget()
public:
PdfSignatureWidget();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureWidget Class
PdfSignatureWidget Members


%%PageItemTitle%%

PdfTextBoxField Class
Members

Xfinium.Pdf.Forms Namespace : PdfTextBoxField Class
Defines an interactive Acrobat textbox field.
Object Model
PdfTextBoxField ClassPdfJavaScriptAction ClassPdfForm ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfJavaScriptAction ClassPdfFieldWidgetCollection ClassPdfFieldWidget Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextBoxField
   Inherits PdfField
'Usage

Dim instance As PdfTextBoxField
public class PdfTextBoxField : PdfField
public ref class PdfTextBoxField : public PdfField
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Forms.PdfField
Xfinium.Pdf.Forms.PdfTextBoxField

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfTextBoxField Class Members
Properties

Xfinium.Pdf.Forms Namespace : PdfTextBoxField Class

The following tables list the members exposed by PdfTextBoxField.

Public Constructors
 | Name | Description
Public Constructor | PdfTextBoxField Constructor | Initializes a new PdfTextBoxField object.
Top
Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Comb | Gets or sets a value indicating whether the field is a comb.
Public Property | DefaultValue | Gets or sets the default value of the field.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FileSelect | Gets or sets a value indicating whether the field acts as a file selector.
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MaxLength | Gets or sets the maximum length of the field text.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Password | Gets or sets a value indicating whether the field is intended for entering a secure password.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Scroll | Gets or sets a value indicating whether the field text supports scrolling.
Public Property | SpellCheck | Gets or sets a value indicating whether the field text shall be spell-checked.
Public Property | Text | Gets or sets the field value.
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfTextBoxField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfTextBoxField Constructor

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : PdfTextBoxField Constructor
The field name.
Initializes a new PdfTextBoxField object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfTextBoxField(name)
public PdfTextBoxField(
   string name
)
public:
PdfTextBoxField(
   String^ name
)

Parameters

name
The field name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


%%PageItemTitle%% $$Properties$$

PdfTextBoxField Class Properties

Xfinium.Pdf.Forms Namespace : PdfTextBoxField Class

For a list of all members of this type, see PdfTextBoxField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Comb | Gets or sets a value indicating whether the field is a comb.
Public Property | DefaultValue | Gets or sets the default value of the field.
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FileSelect | Gets or sets a value indicating whether the field acts as a file selector.
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MaxLength | Gets or sets the maximum length of the field text.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Password | Gets or sets a value indicating whether the field is intended for entering a secure password.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Scroll | Gets or sets a value indicating whether the field text supports scrolling.
Public Property | SpellCheck | Gets or sets a value indicating whether the field text shall be spell-checked.
Public Property | Text | Gets or sets the field value.
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfTextBoxField Class
Xfinium.Pdf.Forms Namespace


Comb Property

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : Comb Property
Gets or sets a value indicating whether the field is a comb.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Comb As Boolean
'Usage

Dim instance As PdfTextBoxField
Dim value As Boolean

instance.Comb = value

value = instance.Comb
public bool Comb {get; set;}
public:
property bool Comb {
   bool get();
   void set (    bool value);
}

Property Value

If true, the field shall be automatically divided into as many equally spaced positions, or combs, as the value of MaxLength, and the text is laid out into those combs.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


DefaultValue Property

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : DefaultValue Property
Gets or sets the default value of the field.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultValue As String
'Usage

Dim instance As PdfTextBoxField
Dim value As String

instance.DefaultValue = value

value = instance.DefaultValue
public string DefaultValue {get; set;}
public:
property String^ DefaultValue {
   String^ get();
   void set (    String^ value);
}

Property Value

The field default value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


FileSelect Property

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : FileSelect Property
Gets or sets a value indicating whether the field acts as a file selector.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FileSelect As Boolean
'Usage

Dim instance As PdfTextBoxField
Dim value As Boolean

instance.FileSelect = value

value = instance.FileSelect
public bool FileSelect {get; set;}
public:
property bool FileSelect {
   bool get();
   void set (    bool value);
}

Property Value

If true, the text entered in the field represents the pathname of a file whose contents shall be submitted as the value of the field.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


MaxLength Property

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : MaxLength Property
Gets or sets the maximum length of the field text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MaxLength As Integer
'Usage

Dim instance As PdfTextBoxField
Dim value As Integer

instance.MaxLength = value

value = instance.MaxLength
public int MaxLength {get; set;}
public:
property int MaxLength {
   int get();
   void set (    int value);
}

Property Value

The maximum length of the field's text, in characters.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


Multiline Property (PdfTextBoxField)

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : Multiline Property
Gets or sets a value indicating whether the field is multiline.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Multiline As Boolean
'Usage

Dim instance As PdfTextBoxField
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
public bool Multiline {get; set;}
public:
property bool Multiline {
   bool get();
   void set (    bool value);
}

Property Value

If true, the field may contain multiple lines of text; if false, the field's text shall be restricted to a single line.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


Password Property

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : Password Property
Gets or sets a value indicating whether the field is intended for entering a secure password.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Password As Boolean
'Usage

Dim instance As PdfTextBoxField
Dim value As Boolean

instance.Password = value

value = instance.Password
public bool Password {get; set;}
public:
property bool Password {
   bool get();
   void set (    bool value);
}

Property Value

If true, the field is intended for entering a secure password that should not be echoed visibly to the screen. Characters typed from the keyboard shall instead be echoed in some unreadable form, such as asterisks or bullet characters.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


Scroll Property

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : Scroll Property
Gets or sets a value indicating whether the field text supports scrolling.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Scroll As Boolean
'Usage

Dim instance As PdfTextBoxField
Dim value As Boolean

instance.Scroll = value

value = instance.Scroll
public bool Scroll {get; set;}
public:
property bool Scroll {
   bool get();
   void set (    bool value);
}

Property Value

If false, the field shall not scroll (horizontally for single-line fields, vertically for multiple-line fields) to accommodate more text than fits within its annotation rectangle. Once the field is full, no further text shall be accepted for interactive form filling; for non-interactive form filling, the filler should take care not to add more character than will visibly fit in the defined area.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


SpellCheck Property

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : SpellCheck Property
Gets or sets a value indicating whether the field text shall be spell-checked.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SpellCheck As Boolean
'Usage

Dim instance As PdfTextBoxField
Dim value As Boolean

instance.SpellCheck = value

value = instance.SpellCheck
public bool SpellCheck {get; set;}
public:
property bool SpellCheck {
   bool get();
   void set (    bool value);
}

Property Value

If true, text entered in the field shall be spell-checked.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


Text Property (PdfTextBoxField)

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : Text Property
Gets or sets the field value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As PdfTextBoxField
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the field content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


%%PageItemTitle%%

PdfTextBoxWidget Class
Members

Xfinium.Pdf.Forms Namespace : PdfTextBoxWidget Class
Defines an interactive textbox widget.
Object Model
PdfTextBoxWidget ClassPdfColor ClassPdfAction ClassPdfColor ClassPdfCosDictionary ClassPdfField ClassPdfAction ClassPdfFont ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAnnotationAppearance ClassPdfPage ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfAction ClassPdfColor ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextBoxWidget
   Inherits PdfFieldWidget
'Usage

Dim instance As PdfTextBoxWidget
public class PdfTextBoxWidget : PdfFieldWidget
public ref class PdfTextBoxWidget : public PdfFieldWidget
Remarks
The textbox widget is the visual representation of a textbox field on a PDF page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Annotations.PdfAnnotation
Xfinium.Pdf.Forms.PdfFieldWidget
Xfinium.Pdf.Forms.PdfTextBoxWidget

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxWidget Members
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Members$$

PdfTextBoxWidget Class Members
Properties Methods

Xfinium.Pdf.Forms Namespace : PdfTextBoxWidget Class

The following tables list the members exposed by PdfTextBoxWidget.

Public Constructors
 | Name | Description
Public Constructor | PdfTextBoxWidget Constructor | Initializes a new PdfTextBoxWidget object.
Top
Public Properties
 | Name | Description
Public Property | Align | Gets or sets the field text alignment.
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfTextBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfTextBoxWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfTextBoxWidget Class : PdfTextBoxWidget Constructor
Initializes a new PdfTextBoxWidget object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfTextBoxWidget()
public PdfTextBoxWidget()
public:
PdfTextBoxWidget();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxWidget Class
PdfTextBoxWidget Members


%%PageItemTitle%% $$Properties$$

PdfTextBoxWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfTextBoxWidget Class

For a list of all members of this type, see PdfTextBoxWidget members.

Public Properties
 | Name | Description
Public Property | Align | Gets or sets the field text alignment.
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfTextBoxWidget Class
Xfinium.Pdf.Forms Namespace


Align Property (PdfTextBoxWidget)

Xfinium.Pdf.Forms Namespace > PdfTextBoxWidget Class : Align Property
Gets or sets the field text alignment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Align As PdfStringHorizontalAlign
'Usage

Dim instance As PdfTextBoxWidget
Dim value As PdfStringHorizontalAlign

instance.Align = value

value = instance.Align
public PdfStringHorizontalAlign Align {get; set;}
public:
property PdfStringHorizontalAlign Align {
   PdfStringHorizontalAlign get();
   void set (    PdfStringHorizontalAlign value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfStringHorizontalAlign that specifies how the text is aligned on horizontal in the field.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxWidget Class
PdfTextBoxWidget Members


%%PageItemTitle%%

PdfCheckStyle Enumeration

Xfinium.Pdf.Forms Namespace : PdfCheckStyle Enumeration
Supported visual styles for check boxes and radio buttons.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfCheckStyle
   Inherits System.Enum
'Usage

Dim instance As PdfCheckStyle
public enum PdfCheckStyle : System.Enum
public enum class PdfCheckStyle : public System.Enum
Members
Member | Description
Check | Standard appearance represented by a checkmark.
Circle | Standard appearance represented by a circle.
Cross | Standard appearance represented by a cross.
Diamond | Standard appearance represented by a diamond.
Square | Standard appearance represented by a square.
Star | Standard appearance represented by a star.
Unknown | The check box appearance is custom defined.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Forms.PdfCheckStyle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfFieldType Enumeration

Xfinium.Pdf.Forms Namespace : PdfFieldType Enumeration
Suported field types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFieldType
   Inherits System.Enum
'Usage

Dim instance As PdfFieldType
public enum PdfFieldType : System.Enum
public enum class PdfFieldType : public System.Enum
Members
Member | Description
CheckBox | Check box.
ComboBox | Combo box.
ListBox | List box.
PushButton | Push button.
RadioButton | Radio button.
Signature | Signature.
TextBox | Text box.
Unknown | Unknown.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Forms.PdfFieldType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfFieldWidgetVisibility Enumeration

Xfinium.Pdf.Forms Namespace : PdfFieldWidgetVisibility Enumeration
Supported field widget visibilities.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFieldWidgetVisibility
   Inherits System.Enum
'Usage

Dim instance As PdfFieldWidgetVisibility
public enum PdfFieldWidgetVisibility : System.Enum
public enum class PdfFieldWidgetVisibility : public System.Enum
Members
Member | Description
Hidden | The field widget is not visible on the page.
HiddenPrintable | The field widget is not visible on the page but it prints.
Visible | The field widget is visible on the page.
VisibleNonPrintable | The field widget is visible on the page but it does not print.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Forms.PdfFieldWidgetVisibility

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfFormDataFormat Enumeration

Xfinium.Pdf.Forms Namespace : PdfFormDataFormat Enumeration
Supported data formats for import/export form actions.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFormDataFormat
   Inherits System.Enum
'Usage

Dim instance As PdfFormDataFormat
public enum PdfFormDataFormat : System.Enum
public enum class PdfFormDataFormat : public System.Enum
Members
Member | Description
FDF | FDF format.
XFDF | XFDF format.
XML | XML format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Forms.PdfFormDataFormat

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfPushButtonHighlightMode Enumeration

Xfinium.Pdf.Forms Namespace : PdfPushButtonHighlightMode Enumeration
Supported highlight modes for pushbuttons.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPushButtonHighlightMode
   Inherits System.Enum
'Usage

Dim instance As PdfPushButtonHighlightMode
public enum PdfPushButtonHighlightMode : System.Enum
public enum class PdfPushButtonHighlightMode : public System.Enum
Members
Member | Description
Invert | Inverts the content of button's normal appearance. Rollover and down button appearances are ignored.
None | No highlighting, the button's appearance does not change when the button is pressed. Rollover and down button appearances are ignored.
Outline | Inverts the button's border. Rollover and down button appearances are ignored.
Push | Displays the button's down appearance. Rollover appearance has also effect on this mode. When this mode is used, both rollover and down appearances must be constructed from code.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Forms.PdfPushButtonHighlightMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfPushButtonIconLayout Enumeration

Xfinium.Pdf.Forms Namespace : PdfPushButtonIconLayout Enumeration
Supported layouts for displaying the icon on a pushbutton.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPushButtonIconLayout
   Inherits System.Enum
'Usage

Dim instance As PdfPushButtonIconLayout
public enum PdfPushButtonIconLayout : System.Enum
public enum class PdfPushButtonIconLayout : public System.Enum
Members
Member | Description
IconBottom | The caption is displayed above the icon.
IconLeft | The icon is displayed to the left of the caption.
IconOnly | Only the icon is displayed, the caption is not displayed.
IconOverlay | The caption is overlaid directly on the icon.
IconRight | The icon is displayed to the right of the caption.
IconTop | The caption is displayed below the icon.
NoIcon | The icon is not displayed, only the caption is displayed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Forms.PdfPushButtonIconLayout

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfSignatureLockType Enumeration

Xfinium.Pdf.Forms Namespace : PdfSignatureLockType Enumeration
Supported lock types for signed forms.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfSignatureLockType
   Inherits System.Enum
'Usage

Dim instance As PdfSignatureLockType
public enum PdfSignatureLockType : System.Enum
public enum class PdfSignatureLockType : public System.Enum
Members
Member | Description
All | All fields in the document.
Exclude | All fields except those specified in PdfSignatureLockFieldAction.Fields array.
Include | All fields specified in the PdfSignatureLockFieldAction.Fields array.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Forms.PdfSignatureLockType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Forms Namespace


Xfinium.Pdf.Graphics Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | Pdf1DBarcode | Defines the base class for 1D barcodes.
Class | Pdf2DBarcode | Base class for 2D barcodes.
Class | Pdf417Barcode | Defines the base class for PDF 417 family of barcodes.
Class | Pdf417MicroBarcode | Defines a Micro PDF 417 barcode.
Class | Pdf417RegularBarcode | Defines a regular PDF 417 barcode.
Class | PdfAlternateImage | Defines an alternate image.
Class | PdfAlternateImageCollection | Defines a collection of alternate images.
Class | PdfAnsiTrueTypeFont | Defines an ANSI TrueType font.
Class | PdfAxialShading | Defines an axial (type 2) shading.
Class | PdfBarcode | Defines the base barcode class.
Class | PdfBarcodeException | Defines a barcode related exception.
Class | PdfBarcodeQuietZones | Defines the quiet zones for a barcode.
Class | PdfBrush | Defines PDF brush.
Class | PdfCalGrayColor | Defines a gray color based on a calibrated gray colorspace.
Class | PdfCalGrayColorSpace | Defines a calibrated gray colorspace.
Class | PdfCalRgbColor | Defines a RGB color based on a calibrated RGB colorspace.
Class | PdfCalRgbColorSpace | Defines a calibrated RGB colorspace.
Class | PdfCmykColor | Defines a device dependent CMYK color.
Class | PdfCmykColorSpace | Defines a device CMYK colorspace.
Class | PdfCodabarBarcode | Defines a Codabar barcode.
Class | PdfCodablockFBarcode | Defines a CODABLOCK F barcode.
Class | PdfCode11Barcode | Defines a Code 11 barcode.
Class | PdfCode128ABarcode | Defines a Code 128 barcode using the A character set.
Class | PdfCode128Barcode | Defines a Code 128 barcode using a mixed character set.
Class | PdfCode128BBarcode | Defines a Code 128 barcode using the B character set.
Class | PdfCode128CBarcode | Defines a Code 128 barcode using the C character set.
Class | PdfCode16KBarcode | Defines a Code 16K barcode.
Class | PdfCode25Barcode | Defines a Code 2 of 5 barcode.
Class | PdfCode25InterleavedBarcode | Defines an interleaved Code 2 of 5 barcode.
Class | PdfCode32Barcode | Defines a Code 32 barcode.
Class | PdfCode39Barcode | Defines a Code 39 barcode.
Class | PdfCode39ExtendedBarcode | Defines an extended Code 39 barcode.
Class | PdfCode93Barcode | Defines a Code 93 barcode.
Class | PdfCode93ExtendedBarcode | Defines an extended Code 93 barcode.
Class | PdfColor | Defines the base class for PDF colors.
Class | PdfColoredTilingPattern | Defines a colored PDF pattern.
Class | PdfColorMask | Defines a color mask.
Class | PdfColorSpace | Defines the base class for PDF colorspaces.
Class | PdfContentStream | Defines a low level graphics interface for drawing content on PDF pages.
Class | PdfCoop25Barcode | Defines a COOP 2 of 5 barcode.
Class | PdfDataMatrixBarcode | Defines a DataMatrix barcode.
Class | PdfDeviceNAttributes | Defines the attributes of a PdfDeviceNColorSpace.
Class | PdfDeviceNColor | Defines a DeviceN color based on a DeviceN colorspace.
Class | PdfDeviceNColorantNameCollection | Defines a collection of DeviceN colorant names.
Class | PdfDeviceNColorSpace | Defines a DeviceN colorspace.
Class | PdfEan128Barcode | Defines an EAN 128 barcode.
Class | PdfEan13Barcode | Defines an EAN 13 barcode.
Class | PdfEan8Barcode | Defines an EAN 8 barcode.
Class | PdfEanBarcode | Defines an EAN barcode.
Class | PdfExtendedGraphicState | Defines the current graphic state in a PDF content stream.
Class | PdfFedExGround96Barcode | Defines a FedEx Ground 96 barcode.
Class | PdfFont | Defines the base class for PDF fonts.
Class | PdfFontMetrics | Provides the metrics for a font object.
Class | PdfFormXObject | Defines a PDF form XObject.
Class | PdfFunctionShading | Defines a function based (type 1) shading.
Class | PdfGraphics | Defines a graphic surface.
Class | PdfGrayColor | Defines a device gray color.
Class | PdfGrayColorSpace | Defines a device gray colorspace.
Class | PdfGroupXObject | Defines a group associated with a PdfFormXObject.
Class | PdfIata25Barcode | Defines an IATA 2 of 5 barcode.
Class | PdfIccColor | Defines an ICC color based on an ICC colorspace.
Class | PdfIccColorSpace | Defines a colorspace based on an ICC profile.
Class | PdfIdentcodeBarcode | Defines an Identcode barcode.
Class | PdfImage | Defines a PDF image. Defines a PDF image.
Class | PdfImageMask | Defines an image mask.
Class | PdfIndexedColor | Defines a color based on an indexed colorspace.
Class | PdfIndexedColorSpace | Defines an indexed colorspace based on a finite set of color samples.
Class | PdfIsbnBarcode | Defines an ISBN barcode.
Class | PdfIsmnBarcode | Defines an ISMN barcode.
Class | PdfIssnBarcode | Defines an ISSN barcode.
Class | PdfJan13Barcode | Defines a JAN13 barcode.
Class | PdfJpeg2000Image | Defines a JPEG2000 image.
Class | PdfJpegImage | Defines a JPEG image.
Class | PdfKixBarcode | Defines a Kix barcode.
Class | PdfLabColor | Defines a Lab color based on a Lab colorspace.
Class | PdfLabColorSpace | Defines a CIE Lab colorspace.
Class | PdfLeitcodeBarcode | Defines a Leitcode barcode.
Class | PdfMatrix | Defines a PDF transformation matrix.
Class | PdfMatrix25Barcode | Defines a Matrix 2 of 5 barcode.
Class | PdfMsiPlesseyBarcode | Defines a MSI/Plessey barcode.
Class | PdfPageContent | Defines the graphic content of a PDF page.
Class | PdfPageGraphics | Defines the graphics surface of a PDF page.
Class | PdfPantoneColor | Defines a set of separation colors known as Pantone colors.
Class | PdfPath | Defines a PDF path.
Class | PdfPattern | Defines the base class for PDF patterns.
Class | PdfPatternBrush | Defines a brush that uses a pattern to fill the path interior.
Class | PdfPatternColor | Defines a color based on a pattern colorspace.
Class | PdfPatternColorSpace | Defines a colorspace based on a PDF pattern.
Class | PdfPatternPen | Defines a pen that uses a pattern based color for stroking a path.
Class | PdfPen | Defines a PDF pen.
Class | PdfPharmacodeBarcode | Defines a Pharmacode barcode.
Class | PdfPlanetBarcode | Defines a Planet barcode.
Class | PdfPngImage | Defines a PNG image.
Class | PdfPoint | Defines a PDF point.
Class | PdfPostalBarcode | Defines the base class for postal related barcodes.
Class | PdfPostNetBarcode | Defines a PostNet barcode.
Class | PdfPznBarcode | Defines a PZN barcode.
Class | PdfQrBarcode | Defines a QR barcode.
Class | PdfRadialShading | Defines a radial (type 3) shading.
Class | PdfRawImage | Defines a RAW image.
Class | PdfRgbColor | Defines a device RGB color.
Class | PdfRgbColorSpace | Defines a device RGB colorspace.
Class | PdfRm4sccBarcode | Defines a RM4SCC barcode.
Class | PdfScc14Barcode | Defines a SCC-14 (Shipping Container Code) barcode.
Class | PdfSeparationColor | Defines a color based on a separation colorspace.
Class | PdfSeparationColorSpace | Defines a separation colorspace.
Class | PdfShading | Defines the base class for PDF shadings.
Class | PdfShadingPattern | Defines a shading based pattern.
Class | PdfSingaporePostBarcode | Defines a Singapore Post barcode.
Class | PdfSize | Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.
Class | PdfSoftMask | Defines a soft mask.
Class | PdfSscc18Barcode | Defines a SSCC-18 (Serial Shipping Container Code) barcode.
Class | PdfStandardFont | Defines a standard Pdf font.
Class | PdfStandardRectangle | Defines a rectangle in PDF coordinate system.
Class | PdfStencilMask | Defines a stencil mask.
Class | PdfStringAppearanceOptions | Defines various appearance options for displaying text on page graphics.
Class | PdfStringLayoutOptions | Defines various layout options for displaying text on page graphics.
Class | PdfTiffImage | Defines a TIFF image.
Class | PdfTilingPattern | Defines the base class for all tiling patterns.
Class | PdfTransparencyGroup | Defines a transparency group.
Class | PdfTrueTypeFont | Defines the base class for TrueType fonts.
Class | PdfType1Font | Defines a Type1 PDF font.
Class | PdfType3Font | Defines a Type3 font.
Class | PdfType3Glyph | Defines a Type3 glyph.
Class | PdfType3GlyphCollection | Defines a collection of PDF functions.
Class | PdfUncoloredTilingPattern | Defines an uncolored PDF pattern.
Class | PdfUnicodeTrueTypeFont | Defines an Unicode TrueType font.
Class | PdfUpcaBarcode | Defines an UPC-A barcode.
Class | PdfUpceBarcode | Defines an UPC-E barcode.
Class | PdfUspsFimBarcode | Defines an USPS FIM barcode.
Class | PdfUspsHorizontalBarcode | Defines a USPS horizontal barcode.
Class | PdfUspsPicBarcode | Defines an USPS Package Identification Code barcode.
Class | PdfVisualRectangle | Defines a rectangle relative to top left corner of the page.
Class | PdfXLJpegImage | Defines an extra large JPEG image.
Enumerations
 | Enumeration | Description
Enumeration | DataMatrixBarcodeSize | Supported DataMatrix barcode sizes.
Enumeration | DataMatrixEncoding | Supported encoding modes for DataMatrix barcodes.
Enumeration | Pdf417DataCompactionMode | Supported data compaction modes for PDF417 barcodes.
Enumeration | Pdf417ErrorCorrectionLevel | Supported error correction levels for PDF417 barcodes.
Enumeration | Pdf417MicroBarcodeSize | Supported Micro PDF417 barcode sizes.
Enumeration | PdfBarcodeTextPosition | Supported position for barcode text relative to barcode graphics.
Enumeration | PdfBlendMode | Supported PDF blend modes.
Enumeration | PdfColorSpaceType | Supported PDF colorspaces.
Enumeration | PdfFillMode | Support fill modes for Pdf paths.
Enumeration | PdfFlipDirection | Supported flip directions.
Enumeration | PdfGraphicAlign | Specifies the available align modes for content relative to a parent container.
Enumeration | PdfLineCap | Supported line cap styles.
Enumeration | PdfLineJoin | Supported line join styles.
Enumeration | PdfPageGraphicsPosition | Supported positions for page graphics.
Enumeration | PdfQrBarcodeCharacterSet | Character sets supported in QR barcode.
Enumeration | PdfQrBarcodeErrorCorrectionLevel | Error correction levels defined by QR barcode specification.
Enumeration | PdfStandardFontFace | Supported standard PDF fonts.
Enumeration | PdfStringHorizontalAlign | Supported horizontal align modes for text.
Enumeration | PdfStringVerticalAlign | Supported vertical align modes for text.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Graphics Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.PdfAlternateImageCollection
Xfinium.Pdf.Graphics.PdfDeviceNColorantNameCollection
Xfinium.Pdf.Graphics.PdfType3GlyphCollection
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Graphics.PdfBarcodeException
Xfinium.Pdf.Graphics.PdfAlternateImage
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCodabarBarcode
Xfinium.Pdf.Graphics.PdfCode11Barcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128ABarcode
Xfinium.Pdf.Graphics.PdfCode128BBarcode
Xfinium.Pdf.Graphics.PdfCode128CBarcode
Xfinium.Pdf.Graphics.PdfFedExGround96Barcode
Xfinium.Pdf.Graphics.PdfScc14Barcode
Xfinium.Pdf.Graphics.PdfSscc18Barcode
Xfinium.Pdf.Graphics.PdfUspsPicBarcode
Xfinium.Pdf.Graphics.PdfEan128Barcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfCode25InterleavedBarcode
Xfinium.Pdf.Graphics.PdfIdentcodeBarcode
Xfinium.Pdf.Graphics.PdfLeitcodeBarcode
Xfinium.Pdf.Graphics.PdfCoop25Barcode
Xfinium.Pdf.Graphics.PdfIata25Barcode
Xfinium.Pdf.Graphics.PdfMatrix25Barcode
Xfinium.Pdf.Graphics.PdfCode39Barcode
Xfinium.Pdf.Graphics.PdfCode32Barcode
Xfinium.Pdf.Graphics.PdfCode39ExtendedBarcode
Xfinium.Pdf.Graphics.PdfPznBarcode
Xfinium.Pdf.Graphics.PdfCode93Barcode
Xfinium.Pdf.Graphics.PdfCode93ExtendedBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfEan13Barcode
Xfinium.Pdf.Graphics.PdfEan8Barcode
Xfinium.Pdf.Graphics.PdfIsbnBarcode
Xfinium.Pdf.Graphics.PdfIsmnBarcode
Xfinium.Pdf.Graphics.PdfIssnBarcode
Xfinium.Pdf.Graphics.PdfJan13Barcode
Xfinium.Pdf.Graphics.PdfUpcaBarcode
Xfinium.Pdf.Graphics.PdfUpceBarcode
Xfinium.Pdf.Graphics.PdfMsiPlesseyBarcode
Xfinium.Pdf.Graphics.PdfPharmacodeBarcode
Xfinium.Pdf.Graphics.PdfPostalBarcode
Xfinium.Pdf.Graphics.PdfPlanetBarcode
Xfinium.Pdf.Graphics.PdfPostNetBarcode
Xfinium.Pdf.Graphics.PdfRm4sccBarcode
Xfinium.Pdf.Graphics.PdfKixBarcode
Xfinium.Pdf.Graphics.PdfSingaporePostBarcode
Xfinium.Pdf.Graphics.PdfUspsFimBarcode
Xfinium.Pdf.Graphics.PdfUspsHorizontalBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.Pdf417Barcode
Xfinium.Pdf.Graphics.Pdf417MicroBarcode
Xfinium.Pdf.Graphics.Pdf417RegularBarcode
Xfinium.Pdf.Graphics.PdfCodablockFBarcode
Xfinium.Pdf.Graphics.PdfCode16KBarcode
Xfinium.Pdf.Graphics.PdfDataMatrixBarcode
Xfinium.Pdf.Graphics.PdfQrBarcode
Xfinium.Pdf.Graphics.PdfBarcodeQuietZones
Xfinium.Pdf.Graphics.PdfBrush
Xfinium.Pdf.Graphics.PdfPatternBrush
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfCalGrayColor
Xfinium.Pdf.Graphics.PdfCalRgbColor
Xfinium.Pdf.Graphics.PdfCmykColor
Xfinium.Pdf.Graphics.PdfDeviceNColor
Xfinium.Pdf.Graphics.PdfGrayColor
Xfinium.Pdf.Graphics.PdfIccColor
Xfinium.Pdf.Graphics.PdfIndexedColor
Xfinium.Pdf.Graphics.PdfLabColor
Xfinium.Pdf.Graphics.PdfPatternColor
Xfinium.Pdf.Graphics.PdfRgbColor
Xfinium.Pdf.Graphics.PdfSeparationColor
Xfinium.Pdf.Graphics.PdfPantoneColor
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfCalGrayColorSpace
Xfinium.Pdf.Graphics.PdfCalRgbColorSpace
Xfinium.Pdf.Graphics.PdfCmykColorSpace
Xfinium.Pdf.Graphics.PdfDeviceNColorSpace
Xfinium.Pdf.Graphics.PdfGrayColorSpace
Xfinium.Pdf.Graphics.PdfIccColorSpace
Xfinium.Pdf.Graphics.PdfIndexedColorSpace
Xfinium.Pdf.Graphics.PdfLabColorSpace
Xfinium.Pdf.Graphics.PdfPatternColorSpace
Xfinium.Pdf.Graphics.PdfRgbColorSpace
Xfinium.Pdf.Graphics.PdfSeparationColorSpace
Xfinium.Pdf.Graphics.PdfContentStream
Xfinium.Pdf.Graphics.PdfDeviceNAttributes
Xfinium.Pdf.Graphics.PdfExtendedGraphicState
Xfinium.Pdf.Graphics.PdfFont
Xfinium.Pdf.Graphics.PdfStandardFont
Xfinium.Pdf.Graphics.PdfTrueTypeFont
Xfinium.Pdf.Graphics.PdfAnsiTrueTypeFont
Xfinium.Pdf.Graphics.PdfUnicodeTrueTypeFont
Xfinium.Pdf.Graphics.PdfType1Font
Xfinium.Pdf.Graphics.PdfType3Font
Xfinium.Pdf.Graphics.PdfFontMetrics
Xfinium.Pdf.Graphics.PdfGraphics
Xfinium.Pdf.Graphics.PdfPageGraphics
Xfinium.Pdf.Graphics.PdfGroupXObject
Xfinium.Pdf.Graphics.PdfTransparencyGroup
Xfinium.Pdf.Graphics.PdfImage
Xfinium.Pdf.Graphics.PdfJpeg2000Image
Xfinium.Pdf.Graphics.PdfJpegImage
Xfinium.Pdf.Graphics.PdfPngImage
Xfinium.Pdf.Graphics.PdfRawImage
Xfinium.Pdf.Graphics.PdfTiffImage
Xfinium.Pdf.Graphics.PdfXLJpegImage
Xfinium.Pdf.Graphics.PdfImageMask
Xfinium.Pdf.Graphics.PdfColorMask
Xfinium.Pdf.Graphics.PdfStencilMask
Xfinium.Pdf.Graphics.PdfSoftMask
Xfinium.Pdf.Graphics.PdfMatrix
Xfinium.Pdf.Graphics.PdfPath
Xfinium.Pdf.Graphics.PdfPattern
Xfinium.Pdf.Graphics.PdfShadingPattern
Xfinium.Pdf.Graphics.PdfTilingPattern
Xfinium.Pdf.Graphics.PdfColoredTilingPattern
Xfinium.Pdf.Graphics.PdfUncoloredTilingPattern
Xfinium.Pdf.Graphics.PdfPen
Xfinium.Pdf.Graphics.PdfPatternPen
Xfinium.Pdf.Graphics.PdfPoint
Xfinium.Pdf.Graphics.PdfShading
Xfinium.Pdf.Graphics.PdfAxialShading
Xfinium.Pdf.Graphics.PdfFunctionShading
Xfinium.Pdf.Graphics.PdfRadialShading
Xfinium.Pdf.Graphics.PdfSize
Xfinium.Pdf.Graphics.PdfStandardRectangle
Xfinium.Pdf.Graphics.PdfStringAppearanceOptions
Xfinium.Pdf.Graphics.PdfStringLayoutOptions
Xfinium.Pdf.Graphics.PdfVisualRectangle
Xfinium.Pdf.PdfContentStreamContainer
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Annotations.PdfAnnotationAppearance
Xfinium.Pdf.Graphics.PdfPageContent
Xfinium.Pdf.Content.PdfPageOptionalContent
Xfinium.Pdf.Graphics.Svg.PdfSvgDrawing
Xfinium.Pdf.Graphics.PdfType3Glyph
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

Pdf1DBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : Pdf1DBarcode Class
Defines the base class for 1D barcodes.
Object Model
Pdf1DBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class Pdf1DBarcode
   Inherits PdfBarcode
'Usage

Dim instance As Pdf1DBarcode
public abstract class Pdf1DBarcode : PdfBarcode
public ref class Pdf1DBarcode abstract : public PdfBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCodabarBarcode
Xfinium.Pdf.Graphics.PdfCode11Barcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfCode39Barcode
Xfinium.Pdf.Graphics.PdfCode93Barcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfMsiPlesseyBarcode
Xfinium.Pdf.Graphics.PdfPharmacodeBarcode
Xfinium.Pdf.Graphics.PdfPostalBarcode
Xfinium.Pdf.Graphics.PdfUspsFimBarcode
Xfinium.Pdf.Graphics.PdfUspsHorizontalBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf1DBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

Pdf1DBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : Pdf1DBarcode Class

The following tables list the members exposed by Pdf1DBarcode.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position.
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed.
Public Property | Font | Gets or sets the barcode text font.
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

Pdf1DBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

Pdf1DBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : Pdf1DBarcode Class

For a list of all members of this type, see Pdf1DBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position.
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed.
Public Property | Font | Gets or sets the barcode text font.
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

Pdf1DBarcode Class
Xfinium.Pdf.Graphics Namespace


BarcodeTextPosition Property

Xfinium.Pdf.Graphics Namespace > Pdf1DBarcode Class : BarcodeTextPosition Property
Gets or sets the barcode text position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BarcodeTextPosition As PdfBarcodeTextPosition
'Usage

Dim instance As Pdf1DBarcode
Dim value As PdfBarcodeTextPosition

instance.BarcodeTextPosition = value

value = instance.BarcodeTextPosition
public PdfBarcodeTextPosition BarcodeTextPosition {get; set;}
public:
property PdfBarcodeTextPosition BarcodeTextPosition {
   PdfBarcodeTextPosition get();
   void set (    PdfBarcodeTextPosition value);
}

Property Value

A PdfBarcodeTextPosition that represents the position where the barcode text is displayed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf1DBarcode Class
Pdf1DBarcode Members


EnableCheckSum Property

Xfinium.Pdf.Graphics Namespace > Pdf1DBarcode Class : EnableCheckSum Property
Gets or sets a value indicating whether a checksum should be computed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableCheckSum As Boolean
'Usage

Dim instance As Pdf1DBarcode
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
public bool EnableCheckSum {get; set;}
public:
property bool EnableCheckSum {
   bool get();
   void set (    bool value);
}

Property Value

If true, a checksum is computed automatically for the barcode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf1DBarcode Class
Pdf1DBarcode Members


Font Property (Pdf1DBarcode)

Xfinium.Pdf.Graphics Namespace > Pdf1DBarcode Class : Font Property
Gets or sets the barcode text font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As PdfFont
'Usage

Dim instance As Pdf1DBarcode
Dim value As PdfFont

instance.Font = value

value = instance.Font
public PdfFont Font {get; set;}
public:
property PdfFont^ Font {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

A PdfFont that is used to draw the barcode text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf1DBarcode Class
Pdf1DBarcode Members


ShowCheckSum Property

Xfinium.Pdf.Graphics Namespace > Pdf1DBarcode Class : ShowCheckSum Property
Gets or sets indicating whether the computed checksum should be shown.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowCheckSum As Boolean
'Usage

Dim instance As Pdf1DBarcode
Dim value As Boolean

instance.ShowCheckSum = value

value = instance.ShowCheckSum
public bool ShowCheckSum {get; set;}
public:
property bool ShowCheckSum {
   bool get();
   void set (    bool value);
}

Property Value

If true the checksum is shown together with the barcode text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf1DBarcode Class
Pdf1DBarcode Members


%%PageItemTitle%%

Pdf2DBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : Pdf2DBarcode Class
Base class for 2D barcodes.
Object Model
Pdf2DBarcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class Pdf2DBarcode
   Inherits PdfBarcode
'Usage

Dim instance As Pdf2DBarcode
public abstract class Pdf2DBarcode : PdfBarcode
public ref class Pdf2DBarcode abstract : public PdfBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.Pdf417Barcode
Xfinium.Pdf.Graphics.PdfCodablockFBarcode
Xfinium.Pdf.Graphics.PdfCode16KBarcode
Xfinium.Pdf.Graphics.PdfDataMatrixBarcode
Xfinium.Pdf.Graphics.PdfQrBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf2DBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

Pdf2DBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : Pdf2DBarcode Class

The following tables list the members exposed by Pdf2DBarcode.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

Pdf2DBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

Pdf2DBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : Pdf2DBarcode Class

For a list of all members of this type, see Pdf2DBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

Pdf2DBarcode Class
Xfinium.Pdf.Graphics Namespace


BinaryData Property

Xfinium.Pdf.Graphics Namespace > Pdf2DBarcode Class : BinaryData Property
Gets or sets the binary data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BinaryData As Byte()
'Usage

Dim instance As Pdf2DBarcode
Dim value() As Byte

instance.BinaryData = value

value = instance.BinaryData
public byte[] BinaryData {get; set;}
public:
property array<byte>^ BinaryData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

An array of bytes representing the data to be encoded.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf2DBarcode Class
Pdf2DBarcode Members


%%PageItemTitle%%

Pdf417Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : Pdf417Barcode Class
Defines the base class for PDF 417 family of barcodes.
Object Model
Pdf417Barcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class Pdf417Barcode
   Inherits Pdf2DBarcode
'Usage

Dim instance As Pdf417Barcode
public abstract class Pdf417Barcode : Pdf2DBarcode
public ref class Pdf417Barcode abstract : public Pdf2DBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.Pdf417Barcode
Xfinium.Pdf.Graphics.Pdf417MicroBarcode
Xfinium.Pdf.Graphics.Pdf417RegularBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

Pdf417Barcode Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : Pdf417Barcode Class

The following tables list the members exposed by Pdf417Barcode.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top
See Also

Reference

Pdf417Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

Pdf417Barcode Class Methods

Xfinium.Pdf.Graphics Namespace : Pdf417Barcode Class

For a list of all members of this type, see Pdf417Barcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top
See Also

Reference

Pdf417Barcode Class
Xfinium.Pdf.Graphics Namespace


GetMaxDataLength Method

Xfinium.Pdf.Graphics Namespace > Pdf417Barcode Class : GetMaxDataLength Method
Calculates the length of the maximum data section that can be encoded in the barcode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetMaxDataLength() As Integer
'Usage

Dim instance As Pdf417Barcode
Dim value As Integer

value = instance.GetMaxDataLength()
public int GetMaxDataLength()
public:
int GetMaxDataLength();

Return Value

The maximum length of encoded data.
Remarks
This method calculates how much of the barcode data can be actually encoded in the barcode. The encoded data is considered to start at the beginning of barcode data. The maximum length is calculated based on barcode data, error correction level and barcode rows and columns.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417Barcode Class
Pdf417Barcode Members


%%PageItemTitle%% $$Properties$$

Pdf417Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : Pdf417Barcode Class

For a list of all members of this type, see Pdf417Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

Pdf417Barcode Class
Xfinium.Pdf.Graphics Namespace


CompactionMode Property

Xfinium.Pdf.Graphics Namespace > Pdf417Barcode Class : CompactionMode Property
Gets or sets the data compaction mode for this barcode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CompactionMode As Pdf417DataCompactionMode
'Usage

Dim instance As Pdf417Barcode
Dim value As Pdf417DataCompactionMode

instance.CompactionMode = value

value = instance.CompactionMode
public Pdf417DataCompactionMode CompactionMode {get; set;}
public:
property Pdf417DataCompactionMode CompactionMode {
   Pdf417DataCompactionMode get();
   void set (    Pdf417DataCompactionMode value);
}

Property Value

A Pdf417DataCompactionMode enumeration member specifying the data compaction mode used in this barcode.
Remarks
The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417Barcode Class
Pdf417Barcode Members


IsValid Property

Xfinium.Pdf.Graphics Namespace > Pdf417Barcode Class : IsValid Property
Gets a value indicating whether a valid barcode can be built.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsValid As Boolean
'Usage

Dim instance As Pdf417Barcode
Dim value As Boolean

value = instance.IsValid
public bool IsValid {get;}
public:
property bool IsValid {
   bool get();
}

Property Value

True if the barcode can be built, false otherwise.
Remarks
The following items are considered when building the barcode: barcode data, rows, columns and error correction level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417Barcode Class
Pdf417Barcode Members


%%PageItemTitle%%

Pdf417MicroBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : Pdf417MicroBarcode Class
Defines a Micro PDF 417 barcode.
Object Model
Pdf417MicroBarcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf417MicroBarcode
   Inherits Pdf417Barcode
'Usage

Dim instance As Pdf417MicroBarcode
public class Pdf417MicroBarcode : Pdf417Barcode
public ref class Pdf417MicroBarcode : public Pdf417Barcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.Pdf417Barcode
Xfinium.Pdf.Graphics.Pdf417MicroBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417MicroBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

Pdf417MicroBarcode Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : Pdf417MicroBarcode Class

The following tables list the members exposed by Pdf417MicroBarcode.

Public Constructors
 | Name | Description
Public Constructor | Pdf417MicroBarcode Constructor | Initializes a new Pdf417MicroBarcode object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeSize | Gets or sets the barcode size.
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Top
See Also

Reference

Pdf417MicroBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

Pdf417MicroBarcode Constructor

Xfinium.Pdf.Graphics Namespace > Pdf417MicroBarcode Class : Pdf417MicroBarcode Constructor
Initializes a new Pdf417MicroBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf417MicroBarcode()
public Pdf417MicroBarcode()
public:
Pdf417MicroBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417MicroBarcode Class
Pdf417MicroBarcode Members


%%PageItemTitle%% $$Properties$$

Pdf417MicroBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : Pdf417MicroBarcode Class

For a list of all members of this type, see Pdf417MicroBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeSize | Gets or sets the barcode size.
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

Pdf417MicroBarcode Class
Xfinium.Pdf.Graphics Namespace


BarcodeSize Property (Pdf417MicroBarcode)

Xfinium.Pdf.Graphics Namespace > Pdf417MicroBarcode Class : BarcodeSize Property
Gets or sets the barcode size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BarcodeSize As Pdf417MicroBarcodeSize
'Usage

Dim instance As Pdf417MicroBarcode
Dim value As Pdf417MicroBarcodeSize

instance.BarcodeSize = value

value = instance.BarcodeSize
public Pdf417MicroBarcodeSize BarcodeSize {get; set;}
public:
property Pdf417MicroBarcodeSize BarcodeSize {
   Pdf417MicroBarcodeSize get();
   void set (    Pdf417MicroBarcodeSize value);
}

Property Value

A Pdf417MicroBarcodeSize that represents the barcode size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417MicroBarcode Class
Pdf417MicroBarcode Members


%%PageItemTitle%%

Pdf417RegularBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : Pdf417RegularBarcode Class
Defines a regular PDF 417 barcode.
Object Model
Pdf417RegularBarcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Pdf417RegularBarcode
   Inherits Pdf417Barcode
'Usage

Dim instance As Pdf417RegularBarcode
public class Pdf417RegularBarcode : Pdf417Barcode
public ref class Pdf417RegularBarcode : public Pdf417Barcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.Pdf417Barcode
Xfinium.Pdf.Graphics.Pdf417RegularBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417RegularBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

Pdf417RegularBarcode Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : Pdf417RegularBarcode Class

The following tables list the members exposed by Pdf417RegularBarcode.

Public Constructors
 | Name | Description
Public Constructor | Pdf417RegularBarcode Constructor | Initializes a new Pdf417RegularBarcode object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | Columns | Gets or sets the barcode columns.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level.
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Rows | Gets or sets the barcode rows.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Top
See Also

Reference

Pdf417RegularBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

Pdf417RegularBarcode Constructor

Xfinium.Pdf.Graphics Namespace > Pdf417RegularBarcode Class : Pdf417RegularBarcode Constructor
Initializes a new Pdf417RegularBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Pdf417RegularBarcode()
public Pdf417RegularBarcode()
public:
Pdf417RegularBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417RegularBarcode Class
Pdf417RegularBarcode Members


%%PageItemTitle%% $$Properties$$

Pdf417RegularBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : Pdf417RegularBarcode Class

For a list of all members of this type, see Pdf417RegularBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | Columns | Gets or sets the barcode columns.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level.
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Rows | Gets or sets the barcode rows.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

Pdf417RegularBarcode Class
Xfinium.Pdf.Graphics Namespace


Columns Property (Pdf417RegularBarcode)

Xfinium.Pdf.Graphics Namespace > Pdf417RegularBarcode Class : Columns Property
Gets or sets the barcode columns.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Columns As Integer
'Usage

Dim instance As Pdf417RegularBarcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
public int Columns {get; set;}
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

The number of data columns.
Remarks
PDF 417 barcodes support 1 to 30 columns. 0 columns means that the number of columns is computed automatically.
Note: Rows and Columns cannot be both 0.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417RegularBarcode Class
Pdf417RegularBarcode Members


ErrorCorrectionLevel Property (Pdf417RegularBarcode)

Xfinium.Pdf.Graphics Namespace > Pdf417RegularBarcode Class : ErrorCorrectionLevel Property
Gets or sets the error correction level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ErrorCorrectionLevel As Pdf417ErrorCorrectionLevel
'Usage

Dim instance As Pdf417RegularBarcode
Dim value As Pdf417ErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
public Pdf417ErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
public:
property Pdf417ErrorCorrectionLevel ErrorCorrectionLevel {
   Pdf417ErrorCorrectionLevel get();
   void set (    Pdf417ErrorCorrectionLevel value);
}

Property Value

A Pdf417ErrorCorrectionLevel that represents the error correction level.
Remarks
The higher the error correction level is the more resilient the barcode is. But a higher error correction level means a larger barcode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417RegularBarcode Class
Pdf417RegularBarcode Members


Rows Property (Pdf417RegularBarcode)

Xfinium.Pdf.Graphics Namespace > Pdf417RegularBarcode Class : Rows Property
Gets or sets the barcode rows.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As Pdf417RegularBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

The number of data rows.
Remarks
PDF 417 barcodes support 3 to 90 rows. 0 rows means that the number of rows is computed automatically.
Note: Rows and Columns cannot be both 0.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf417RegularBarcode Class
Pdf417RegularBarcode Members


%%PageItemTitle%%

PdfAlternateImage Class
Members

Xfinium.Pdf.Graphics Namespace : PdfAlternateImage Class
Defines an alternate image.
Object Model
PdfAlternateImage ClassPdfImage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAlternateImage
'Usage

Dim instance As PdfAlternateImage
public class PdfAlternateImage
public ref class PdfAlternateImage
Remarks
Alternate images are used to display different views of an image.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfAlternateImage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAlternateImage Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfAlternateImage Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfAlternateImage Class

The following tables list the members exposed by PdfAlternateImage.

Public Constructors
 | Name | Description
Public Constructor | PdfAlternateImage Constructor | Initializes a new PdfAlternateImage object.
Top
Public Properties
 | Name | Description
Public Property | DefaultForPrinting | Gets or sets a value indicating whether this alternate image is the default version to be used for printing.
Public Property | Image | Gets or sets the image.
Top
See Also

Reference

PdfAlternateImage Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfAlternateImage Constructor

Xfinium.Pdf.Graphics Namespace > PdfAlternateImage Class : PdfAlternateImage Constructor
The image that serves as alternate image.
Initializes a new PdfAlternateImage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal image As PdfImage _
)
'Usage

Dim image As PdfImage

Dim instance As New PdfAlternateImage(image)
public PdfAlternateImage(
   PdfImage image
)
public:
PdfAlternateImage(
   PdfImage^ image
)

Parameters

image
The image that serves as alternate image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAlternateImage Class
PdfAlternateImage Members


%%PageItemTitle%% $$Properties$$

PdfAlternateImage Class Properties

Xfinium.Pdf.Graphics Namespace : PdfAlternateImage Class

For a list of all members of this type, see PdfAlternateImage members.

Public Properties
 | Name | Description
Public Property | DefaultForPrinting | Gets or sets a value indicating whether this alternate image is the default version to be used for printing.
Public Property | Image | Gets or sets the image.
Top
See Also

Reference

PdfAlternateImage Class
Xfinium.Pdf.Graphics Namespace


DefaultForPrinting Property

Xfinium.Pdf.Graphics Namespace > PdfAlternateImage Class : DefaultForPrinting Property
Gets or sets a value indicating whether this alternate image is the default version to be used for printing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultForPrinting As Boolean
'Usage

Dim instance As PdfAlternateImage
Dim value As Boolean

instance.DefaultForPrinting = value

value = instance.DefaultForPrinting
public bool DefaultForPrinting {get; set;}
public:
property bool DefaultForPrinting {
   bool get();
   void set (    bool value);
}

Property Value

A flag indicating whether this alternate image is the default version to be used for printing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAlternateImage Class
PdfAlternateImage Members


Image Property (PdfAlternateImage)

Xfinium.Pdf.Graphics Namespace > PdfAlternateImage Class : Image Property
Gets or sets the image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Image As PdfImage
'Usage

Dim instance As PdfAlternateImage
Dim value As PdfImage

instance.Image = value

value = instance.Image
public PdfImage Image {get; set;}
public:
property PdfImage^ Image {
   PdfImage^ get();
   void set (    PdfImage^ value);
}

Property Value

The image object represented by this alternate image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAlternateImage Class
PdfAlternateImage Members


%%PageItemTitle%%

PdfAlternateImageCollection Class
Members

Xfinium.Pdf.Graphics Namespace : PdfAlternateImageCollection Class
Defines a collection of alternate images.
Object Model
PdfAlternateImageCollection ClassPdfAlternateImage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAlternateImageCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfAlternateImage)
'Usage

Dim instance As PdfAlternateImageCollection
public class PdfAlternateImageCollection : System.Collections.ObjectModel.Collection<PdfAlternateImage>
public ref class PdfAlternateImageCollection : public System.Collections.ObjectModel.Collection<PdfAlternateImage>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.PdfAlternateImageCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAlternateImageCollection Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfAlternateImageCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfAlternateImageCollection Class

The following tables list the members exposed by PdfAlternateImageCollection.

Public Constructors
 | Name | Description
Public Constructor | PdfAlternateImageCollection Constructor | Initializes a new PdfAlternateImageCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Top
See Also

Reference

PdfAlternateImageCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfAlternateImageCollection Constructor

Xfinium.Pdf.Graphics Namespace > PdfAlternateImageCollection Class : PdfAlternateImageCollection Constructor
Initializes a new PdfAlternateImageCollection object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfAlternateImageCollection()
public PdfAlternateImageCollection()
public:
PdfAlternateImageCollection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAlternateImageCollection Class
PdfAlternateImageCollection Members


%%PageItemTitle%%

PdfAnsiTrueTypeFont Class
Members

Xfinium.Pdf.Graphics Namespace : PdfAnsiTrueTypeFont Class
Defines an ANSI TrueType font.
Object Model
PdfAnsiTrueTypeFont ClassPdfFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAnsiTrueTypeFont
   Inherits PdfTrueTypeFont
'Usage

Dim instance As PdfAnsiTrueTypeFont
public class PdfAnsiTrueTypeFont : PdfTrueTypeFont
public ref class PdfAnsiTrueTypeFont : public PdfTrueTypeFont
Remarks
An ANSI TrueType font supports only the Windows 1252 encoding, Unicode characters cannot be displayed.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFont
Xfinium.Pdf.Graphics.PdfTrueTypeFont
Xfinium.Pdf.Graphics.PdfAnsiTrueTypeFont

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnsiTrueTypeFont Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfAnsiTrueTypeFont Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfAnsiTrueTypeFont Class

The following tables list the members exposed by PdfAnsiTrueTypeFont.

Public Constructors
 | Name | Description
Public Constructor | PdfAnsiTrueTypeFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Name | Gets the name of this font. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | GetGlyphEmWidth | Gets the Em width of the given glyph when drawn with this font object. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | UpdateCharsSubset | Updates the set of characters that must be subset in the final font data. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | UpdateGlyphsSubset | Updates the set of glyphs that must be subset in the final font data. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Top
See Also

Reference

PdfAnsiTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfAnsiTrueTypeFont Constructor

Xfinium.Pdf.Graphics Namespace > PdfAnsiTrueTypeFont Class : PdfAnsiTrueTypeFont Constructor
Overload List
Overload | Description
PdfAnsiTrueTypeFont Constructor(Stream,Double,Boolean) | Initializes a new PdfTrueTypeFont object.
PdfAnsiTrueTypeFont Constructor(Stream,Int32,Double,Boolean) | Initializes a new PdfTrueTypeFont object.
PdfAnsiTrueTypeFont Constructor(PdfAnsiTrueTypeFont) | Initializes a new PdfAnsiTrueTypeFont object.
PdfAnsiTrueTypeFont Constructor(PdfAnsiTrueTypeFont,Double) | Initializes a new PdfAnsiTrueTypeFont object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnsiTrueTypeFont Class
PdfAnsiTrueTypeFont Members


%%PageItemTitle%%

PdfAnsiTrueTypeFont Constructor(Stream,Double,Boolean)

Xfinium.Pdf.Graphics Namespace > PdfAnsiTrueTypeFont Class > PdfAnsiTrueTypeFont Constructor : PdfAnsiTrueTypeFont Constructor(Stream,Double,Boolean)
TrueType font stream
Font size.
If true, the font will be embedded in the PDF file.
Initializes a new PdfTrueTypeFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim stream As Stream
Dim size As Double
Dim embed As Boolean

Dim instance As New PdfAnsiTrueTypeFont(stream, size, embed)
public PdfAnsiTrueTypeFont(
   Stream stream,
   double size,
   bool embed
)
public:
PdfAnsiTrueTypeFont(
   Stream^ stream,
   double size,
   bool embed
)

Parameters

stream
TrueType font stream
size
Font size.
embed
If true, the font will be embedded in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnsiTrueTypeFont Class
PdfAnsiTrueTypeFont Members
Overload List


%%PageItemTitle%%

PdfAnsiTrueTypeFont Constructor(Stream,Int32,Double,Boolean)

Xfinium.Pdf.Graphics Namespace > PdfAnsiTrueTypeFont Class > PdfAnsiTrueTypeFont Constructor : PdfAnsiTrueTypeFont Constructor(Stream,Int32,Double,Boolean)
TrueType collection stream.
TrueType font index in the collection.
Font size.
If true, the font will be embedded in the PDF file.
Initializes a new PdfTrueTypeFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal index As Integer, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim stream As Stream
Dim index As Integer
Dim size As Double
Dim embed As Boolean

Dim instance As New PdfAnsiTrueTypeFont(stream, index, size, embed)
public PdfAnsiTrueTypeFont(
   Stream stream,
   int index,
   double size,
   bool embed
)
public:
PdfAnsiTrueTypeFont(
   Stream^ stream,
   int index,
   double size,
   bool embed
)

Parameters

stream
TrueType collection stream.
index
TrueType font index in the collection.
size
Font size.
embed
If true, the font will be embedded in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnsiTrueTypeFont Class
PdfAnsiTrueTypeFont Members
Overload List


%%PageItemTitle%%

PdfAnsiTrueTypeFont Constructor(PdfAnsiTrueTypeFont)

Xfinium.Pdf.Graphics Namespace > PdfAnsiTrueTypeFont Class > PdfAnsiTrueTypeFont Constructor : PdfAnsiTrueTypeFont Constructor(PdfAnsiTrueTypeFont)
Source TrueType font.
Initializes a new PdfAnsiTrueTypeFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PdfAnsiTrueTypeFont _
)
'Usage

Dim font As PdfAnsiTrueTypeFont

Dim instance As New PdfAnsiTrueTypeFont(font)
public PdfAnsiTrueTypeFont(
   PdfAnsiTrueTypeFont font
)
public:
PdfAnsiTrueTypeFont(
   PdfAnsiTrueTypeFont^ font
)

Parameters

font
Source TrueType font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnsiTrueTypeFont Class
PdfAnsiTrueTypeFont Members
Overload List


%%PageItemTitle%%

PdfAnsiTrueTypeFont Constructor(PdfAnsiTrueTypeFont,Double)

Xfinium.Pdf.Graphics Namespace > PdfAnsiTrueTypeFont Class > PdfAnsiTrueTypeFont Constructor : PdfAnsiTrueTypeFont Constructor(PdfAnsiTrueTypeFont,Double)
Source TrueType font.
Size of the new font.
Initializes a new PdfAnsiTrueTypeFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PdfAnsiTrueTypeFont, _
   ByVal size As Double _
)
'Usage

Dim font As PdfAnsiTrueTypeFont
Dim size As Double

Dim instance As New PdfAnsiTrueTypeFont(font, size)
public PdfAnsiTrueTypeFont(
   PdfAnsiTrueTypeFont font,
   double size
)
public:
PdfAnsiTrueTypeFont(
   PdfAnsiTrueTypeFont^ font,
   double size
)

Parameters

font
Source TrueType font.
size
Size of the new font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnsiTrueTypeFont Class
PdfAnsiTrueTypeFont Members
Overload List


%%PageItemTitle%%

PdfAxialShading Class
Members

Xfinium.Pdf.Graphics Namespace : PdfAxialShading Class
Defines an axial (type 2) shading.
Object Model
PdfAxialShading ClassPdfColorSpace ClassPdfColor ClassPdfPoint ClassPdfFunction ClassPdfColor ClassPdfPoint Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAxialShading
   Inherits PdfShading
'Usage

Dim instance As PdfAxialShading
public class PdfAxialShading : PdfShading
public ref class PdfAxialShading : public PdfShading
Remarks
Axial shadings define a color blend that varies along a linear axis between two endpoints and extends indefinitely perpendicular to that axis.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfShading
Xfinium.Pdf.Graphics.PdfAxialShading

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfAxialShading Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfAxialShading Class

The following tables list the members exposed by PdfAxialShading.

Public Constructors
 | Name | Description
Public Constructor | PdfAxialShading Constructor | Initializes a new PdfAxialShading object.
Top
Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | ColorSpace | Gets or sets the shading color space. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | Domain | Gets or sets the shading domain.
Public Property | EndColor | Gets or sets the shading end color.
Public Property | EndPoint | Gets or sets the shading end point.
Public Property | ExtendEnd | Gets or sets a value indicating whether to extend shading beyond the ending point.
Public Property | ExtendStart | Gets or sets a value indicating whether to extend shading beyond the starting point.
Public Property | Function | Gets or sets the shading function.
Public Property | StartColor | Gets or sets the shading start color.
Public Property | StartPoint | Gets or sets the shading start point.
Top
See Also

Reference

PdfAxialShading Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfAxialShading Constructor

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : PdfAxialShading Constructor
Initializes a new PdfAxialShading object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfAxialShading()
public PdfAxialShading()
public:
PdfAxialShading();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


%%PageItemTitle%% $$Properties$$

PdfAxialShading Class Properties

Xfinium.Pdf.Graphics Namespace : PdfAxialShading Class

For a list of all members of this type, see PdfAxialShading members.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | ColorSpace | Gets or sets the shading color space. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | Domain | Gets or sets the shading domain.
Public Property | EndColor | Gets or sets the shading end color.
Public Property | EndPoint | Gets or sets the shading end point.
Public Property | ExtendEnd | Gets or sets a value indicating whether to extend shading beyond the ending point.
Public Property | ExtendStart | Gets or sets a value indicating whether to extend shading beyond the starting point.
Public Property | Function | Gets or sets the shading function.
Public Property | StartColor | Gets or sets the shading start color.
Public Property | StartPoint | Gets or sets the shading start point.
Top
See Also

Reference

PdfAxialShading Class
Xfinium.Pdf.Graphics Namespace


Domain Property (PdfAxialShading)

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : Domain Property
Gets or sets the shading domain.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Domain As Double()
'Usage

Dim instance As PdfAxialShading
Dim value() As Double

instance.Domain = value

value = instance.Domain
public double[] Domain {get; set;}
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of two numbers [t0 t1] specifying the limiting values of a parametric variable t.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | Thrown when the domain array length is not equal to 2.
Remarks
The variable is considered to vary linearly between these two values as the color gradient varies between the starting and ending points of the axis. The variable t becomes the input argument to the shading function.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


EndColor Property (PdfAxialShading)

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : EndColor Property
Gets or sets the shading end color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndColor As PdfColor
'Usage

Dim instance As PdfAxialShading
Dim value As PdfColor

instance.EndColor = value

value = instance.EndColor
public PdfColor EndColor {get; set;}
public:
property PdfColor^ EndColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The shading end color.
Remarks
The StartColor and EndColor can be set only when the shading uses an exponential function (Xfinium.Pdf.PdfFunctions.PdfExponentialFunction).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


EndPoint Property (PdfAxialShading)

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : EndPoint Property
Gets or sets the shading end point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndPoint As PdfPoint
'Usage

Dim instance As PdfAxialShading
Dim value As PdfPoint

instance.EndPoint = value

value = instance.EndPoint
public PdfPoint EndPoint {get; set;}
public:
property PdfPoint^ EndPoint {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The end point of the shading axis.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


ExtendEnd Property (PdfAxialShading)

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : ExtendEnd Property
Gets or sets a value indicating whether to extend shading beyond the ending point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExtendEnd As Boolean
'Usage

Dim instance As PdfAxialShading
Dim value As Boolean

instance.ExtendEnd = value

value = instance.ExtendEnd
public bool ExtendEnd {get; set;}
public:
property bool ExtendEnd {
   bool get();
   void set (    bool value);
}

Property Value

If true, the shading will be extended beyond the ending point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


ExtendStart Property (PdfAxialShading)

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : ExtendStart Property
Gets or sets a value indicating whether to extend shading beyond the starting point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExtendStart As Boolean
'Usage

Dim instance As PdfAxialShading
Dim value As Boolean

instance.ExtendStart = value

value = instance.ExtendStart
public bool ExtendStart {get; set;}
public:
property bool ExtendStart {
   bool get();
   void set (    bool value);
}

Property Value

If true, the shading will be extended beyond the starting point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


Function Property (PdfAxialShading)

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : Function Property
Gets or sets the shading function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Function As PdfFunction
'Usage

Dim instance As PdfAxialShading
Dim value As PdfFunction

instance.Function = value

value = instance.Function
public PdfFunction Function {get; set;}
public:
property PdfFunction^ Function {
   PdfFunction^ get();
   void set (    PdfFunction^ value);
}

Property Value

A 1-in, n-out function, where n is the number of color components in the shadins's color space
Remarks
The function is called with values of the parametric variable t in the domain defined by the Domain property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


StartColor Property (PdfAxialShading)

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : StartColor Property
Gets or sets the shading start color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartColor As PdfColor
'Usage

Dim instance As PdfAxialShading
Dim value As PdfColor

instance.StartColor = value

value = instance.StartColor
public PdfColor StartColor {get; set;}
public:
property PdfColor^ StartColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The shading start color.
Remarks
The StartColor and EndColor can be set only when the shading uses an exponential function (Xfinium.Pdf.PdfFunctions.PdfExponentialFunction).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


StartPoint Property (PdfAxialShading)

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : StartPoint Property
Gets or sets the shading start point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartPoint As PdfPoint
'Usage

Dim instance As PdfAxialShading
Dim value As PdfPoint

instance.StartPoint = value

value = instance.StartPoint
public PdfPoint StartPoint {get; set;}
public:
property PdfPoint^ StartPoint {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The start point of the shading axis.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


%%PageItemTitle%%

PdfBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfBarcode Class
Defines the base barcode class.
Object Model
PdfBarcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfBarcode
'Usage

Dim instance As PdfBarcode
public abstract class PdfBarcode
public ref class PdfBarcode abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfBarcode Class

The following tables list the members exposed by PdfBarcode.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color.
Public Property | BarColor | Gets or sets the barcode bar color.
Public Property | Data | Gets or sets the barcode data.
Public Property | Height | Gets the barcode height.
Public Property | QuietZones | Gets the barcode quiet zones.
Public Property | TextColor | Gets or sets the barcode text color.
Public Property | Width | Gets the barcode width.
Public Property | XDimension | Gets or sets the X dimension.
Public Property | YDimension | Gets or sets the Y dimension.
Top
See Also

Reference

PdfBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfBarcode Class

For a list of all members of this type, see PdfBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color.
Public Property | BarColor | Gets or sets the barcode bar color.
Public Property | Data | Gets or sets the barcode data.
Public Property | Height | Gets the barcode height.
Public Property | QuietZones | Gets the barcode quiet zones.
Public Property | TextColor | Gets or sets the barcode text color.
Public Property | Width | Gets the barcode width.
Public Property | XDimension | Gets or sets the X dimension.
Public Property | YDimension | Gets or sets the Y dimension.
Top
See Also

Reference

PdfBarcode Class
Xfinium.Pdf.Graphics Namespace


BackgroundColor Property (PdfBarcode)

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : BackgroundColor Property
Gets or sets the barcode background color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BackgroundColor As PdfColor
'Usage

Dim instance As PdfBarcode
Dim value As PdfColor

instance.BackgroundColor = value

value = instance.BackgroundColor
public PdfColor BackgroundColor {get; set;}
public:
property PdfColor^ BackgroundColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A PdfColor that represents the color used to fill the barcode background.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


BarColor Property

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : BarColor Property
Gets or sets the barcode bar color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BarColor As PdfColor
'Usage

Dim instance As PdfBarcode
Dim value As PdfColor

instance.BarColor = value

value = instance.BarColor
public PdfColor BarColor {get; set;}
public:
property PdfColor^ BarColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A PdfColor that represents the color used to draw the barcode bars.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


Data Property

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : Data Property
Gets or sets the barcode data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Data As String
'Usage

Dim instance As PdfBarcode
Dim value As String

instance.Data = value

value = instance.Data
public string Data {get; set;}
public:
property String^ Data {
   String^ get();
   void set (    String^ value);
}

Property Value

A string of characters that represents the data to be encoded as a barcode.
Remarks
Each barcode type specifies the characters it supports.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


Height Property (PdfBarcode)

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : Height Property
Gets the barcode height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PdfBarcode
Dim value As Double

value = instance.Height
public double Height {get;}
public:
property double Height {
   double get();
}

Property Value

The height of the barcode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


QuietZones Property

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : QuietZones Property
Gets the barcode quiet zones.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property QuietZones As PdfBarcodeQuietZones
'Usage

Dim instance As PdfBarcode
Dim value As PdfBarcodeQuietZones

value = instance.QuietZones
public PdfBarcodeQuietZones QuietZones {get;}
public:
property PdfBarcodeQuietZones^ QuietZones {
   PdfBarcodeQuietZones^ get();
}

Property Value

Left, right, top and bottom quiet zones.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


TextColor Property (PdfBarcode)

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : TextColor Property
Gets or sets the barcode text color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextColor As PdfColor
'Usage

Dim instance As PdfBarcode
Dim value As PdfColor

instance.TextColor = value

value = instance.TextColor
public PdfColor TextColor {get; set;}
public:
property PdfColor^ TextColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A PdfColor that represents the color used to display the barcode text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


Width Property (PdfBarcode)

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : Width Property
Gets the barcode width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PdfBarcode
Dim value As Double

value = instance.Width
public double Width {get;}
public:
property double Width {
   double get();
}

Property Value

The width of the barcode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


XDimension Property

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : XDimension Property
Gets or sets the X dimension.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property XDimension As Double
'Usage

Dim instance As PdfBarcode
Dim value As Double

instance.XDimension = value

value = instance.XDimension
public double XDimension {get; set;}
public:
property double XDimension {
   double get();
   void set (    double value);
}

Property Value

The width of a narrow barcode bar.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


YDimension Property (PdfBarcode)

Xfinium.Pdf.Graphics Namespace > PdfBarcode Class : YDimension Property
Gets or sets the Y dimension.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property YDimension As Double
'Usage

Dim instance As PdfBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public virtual double YDimension {get; set;}
public:
virtual property double YDimension {
   double get();
   void set (    double value);
}

Property Value

The height of a barcode bar.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcode Class
PdfBarcode Members


%%PageItemTitle%%

PdfBarcodeException Class
Members

Xfinium.Pdf.Graphics Namespace : PdfBarcodeException Class
Defines a barcode related exception.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBarcodeException
   Inherits Xfinium.Pdf.Core.Exceptions.PdfException
'Usage

Dim instance As PdfBarcodeException
public class PdfBarcodeException : Xfinium.Pdf.Core.Exceptions.PdfException
public ref class PdfBarcodeException : public Xfinium.Pdf.Core.Exceptions.PdfException
Inheritance Hierarchy

System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Graphics.PdfBarcodeException

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcodeException Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfBarcodeException Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfBarcodeException Class

The following tables list the members exposed by PdfBarcodeException.

Public Constructors
 | Name | Description
Public Constructor | PdfBarcodeException Constructor | Initializes a new PdfBarcodeException object with the specified message.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfBarcodeException Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfBarcodeException Constructor

Xfinium.Pdf.Graphics Namespace > PdfBarcodeException Class : PdfBarcodeException Constructor
The exception message.
Initializes a new PdfBarcodeException object with the specified message.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PdfBarcodeException(message)
public PdfBarcodeException(
   string message
)
public:
PdfBarcodeException(
   String^ message
)

Parameters

message
The exception message.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcodeException Class
PdfBarcodeException Members


%%PageItemTitle%%

PdfBarcodeQuietZones Class
Members

Xfinium.Pdf.Graphics Namespace : PdfBarcodeQuietZones Class
Defines the quiet zones for a barcode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBarcodeQuietZones
'Usage

Dim instance As PdfBarcodeQuietZones
public class PdfBarcodeQuietZones
public ref class PdfBarcodeQuietZones
Remarks
The quiet zone is a blank area around the barcode that delimitates the barcode graphics from the other printed content.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcodeQuietZones

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcodeQuietZones Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfBarcodeQuietZones Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfBarcodeQuietZones Class

The following tables list the members exposed by PdfBarcodeQuietZones.

Public Constructors
 | Name | Description
Public Constructor | PdfBarcodeQuietZones Constructor | Initializes a new PdfBarcodeQuietZones object.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom quiet zone.
Public Property | Left | Gets or sets the left quiet zone.
Public Property | Right | Gets or sets the right quiet zone.
Public Property | Top | Gets or sets the top quiet zone.
Top
See Also

Reference

PdfBarcodeQuietZones Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfBarcodeQuietZones Constructor

Xfinium.Pdf.Graphics Namespace > PdfBarcodeQuietZones Class : PdfBarcodeQuietZones Constructor
Initializes a new PdfBarcodeQuietZones object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfBarcodeQuietZones()
public PdfBarcodeQuietZones()
public:
PdfBarcodeQuietZones();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcodeQuietZones Class
PdfBarcodeQuietZones Members


%%PageItemTitle%% $$Properties$$

PdfBarcodeQuietZones Class Properties

Xfinium.Pdf.Graphics Namespace : PdfBarcodeQuietZones Class

For a list of all members of this type, see PdfBarcodeQuietZones members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom quiet zone.
Public Property | Left | Gets or sets the left quiet zone.
Public Property | Right | Gets or sets the right quiet zone.
Public Property | Top | Gets or sets the top quiet zone.
Top
See Also

Reference

PdfBarcodeQuietZones Class
Xfinium.Pdf.Graphics Namespace


Bottom Property (PdfBarcodeQuietZones)

Xfinium.Pdf.Graphics Namespace > PdfBarcodeQuietZones Class : Bottom Property
Gets or sets the bottom quiet zone.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Bottom As Double
'Usage

Dim instance As PdfBarcodeQuietZones
Dim value As Double

instance.Bottom = value

value = instance.Bottom
public double Bottom {get; set;}
public:
property double Bottom {
   double get();
   void set (    double value);
}

Property Value

The width of the quiet zone at the bottom of the barcode.
Remarks
The quiet zone is measured as a multiple of PdfBarcode.XDimension.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcodeQuietZones Class
PdfBarcodeQuietZones Members


Left Property (PdfBarcodeQuietZones)

Xfinium.Pdf.Graphics Namespace > PdfBarcodeQuietZones Class : Left Property
Gets or sets the left quiet zone.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As PdfBarcodeQuietZones
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

The width of the quiet zone at the left of the barcode.
Remarks
The quiet zone is measured as a multiple of PdfBarcode.XDimension.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcodeQuietZones Class
PdfBarcodeQuietZones Members


Right Property (PdfBarcodeQuietZones)

Xfinium.Pdf.Graphics Namespace > PdfBarcodeQuietZones Class : Right Property
Gets or sets the right quiet zone.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Right As Double
'Usage

Dim instance As PdfBarcodeQuietZones
Dim value As Double

instance.Right = value

value = instance.Right
public double Right {get; set;}
public:
property double Right {
   double get();
   void set (    double value);
}

Property Value

The width of the quiet zone at the right of the barcode.
Remarks
The quiet zone is measured as a multiple of PdfBarcode.XDimension.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcodeQuietZones Class
PdfBarcodeQuietZones Members


Top Property (PdfBarcodeQuietZones)

Xfinium.Pdf.Graphics Namespace > PdfBarcodeQuietZones Class : Top Property
Gets or sets the top quiet zone.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Top As Double
'Usage

Dim instance As PdfBarcodeQuietZones
Dim value As Double

instance.Top = value

value = instance.Top
public double Top {get; set;}
public:
property double Top {
   double get();
   void set (    double value);
}

Property Value

The width of the quiet zone at the top of the barcode.
Remarks
The quiet zone is measured as a multiple of PdfBarcode.XDimension.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBarcodeQuietZones Class
PdfBarcodeQuietZones Members


%%PageItemTitle%%

PdfBrush Class
Members

Xfinium.Pdf.Graphics Namespace : PdfBrush Class
Defines PDF brush.
Object Model
PdfBrush ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBrush
'Usage

Dim instance As PdfBrush
public class PdfBrush
public ref class PdfBrush
Remarks
The brush is used to fill a path with a color.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBrush
Xfinium.Pdf.Graphics.PdfPatternBrush

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBrush Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfBrush Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfBrush Class

The following tables list the members exposed by PdfBrush.

Public Constructors
 | Name | Description
Public Constructor | PdfBrush Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color.
Top
See Also

Reference

PdfBrush Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfBrush Constructor

Xfinium.Pdf.Graphics Namespace > PdfBrush Class : PdfBrush Constructor
Overload List
Overload | Description
PdfBrush Constructor() | Initializes a new PdfBrush object.
PdfBrush Constructor(PdfColor) | Initializes a new PdfBrush object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBrush Class
PdfBrush Members


%%PageItemTitle%%

PdfBrush Constructor()

Xfinium.Pdf.Graphics Namespace > PdfBrush Class > PdfBrush Constructor : PdfBrush Constructor()
Initializes a new PdfBrush object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfBrush()
public PdfBrush()
public:
PdfBrush();
Remarks
The brush is initialized with a default RGB black color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBrush Class
PdfBrush Members
Overload List


%%PageItemTitle%%

PdfBrush Constructor(PdfColor)

Xfinium.Pdf.Graphics Namespace > PdfBrush Class > PdfBrush Constructor : PdfBrush Constructor(PdfColor)
The brush color.
Initializes a new PdfBrush object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As PdfColor _
)
'Usage

Dim color As PdfColor

Dim instance As New PdfBrush(color)
public PdfBrush(
   PdfColor color
)
public:
PdfBrush(
   PdfColor^ color
)

Parameters

color
The brush color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBrush Class
PdfBrush Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfBrush Class Properties

Xfinium.Pdf.Graphics Namespace : PdfBrush Class

For a list of all members of this type, see PdfBrush members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color.
Top
See Also

Reference

PdfBrush Class
Xfinium.Pdf.Graphics Namespace


Color Property (PdfBrush)

Xfinium.Pdf.Graphics Namespace > PdfBrush Class : Color Property
Gets or sets the color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Color As PdfColor
'Usage

Dim instance As PdfBrush
Dim value As PdfColor

instance.Color = value

value = instance.Color
public virtual PdfColor Color {get; set;}
public:
virtual property PdfColor^ Color {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The brush color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBrush Class
PdfBrush Members


%%PageItemTitle%%

PdfCalGrayColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCalGrayColor Class
Defines a gray color based on a calibrated gray colorspace.
Object Model
PdfCalGrayColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCalGrayColor
   Inherits PdfColor
'Usage

Dim instance As PdfCalGrayColor
public class PdfCalGrayColor : PdfColor
public ref class PdfCalGrayColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfCalGrayColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCalGrayColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfCalGrayColor Class

The following tables list the members exposed by PdfCalGrayColor.

Public Constructors
 | Name | Description
Public Constructor | PdfCalGrayColor Constructor | Initializes a new PdfCalGrayColor object with a calibrated gray colorspace.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | Gray | Gets or sets the gray component.
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfCalGrayColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCalGrayColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColor Class : PdfCalGrayColor Constructor
A calibrated gray colorspace.
Initializes a new PdfCalGrayColor object with a calibrated gray colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PdfCalGrayColorSpace _
)
'Usage

Dim colorSpace As PdfCalGrayColorSpace

Dim instance As New PdfCalGrayColor(colorSpace)
public PdfCalGrayColor(
   PdfCalGrayColorSpace colorSpace
)
public:
PdfCalGrayColor(
   PdfCalGrayColorSpace^ colorSpace
)

Parameters

colorSpace
A calibrated gray colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColor Class
PdfCalGrayColor Members


%%PageItemTitle%% $$Methods$$

PdfCalGrayColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfCalGrayColor Class

For a list of all members of this type, see PdfCalGrayColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfCalGrayColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfCalGrayColor)

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfCalGrayColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColor Class
PdfCalGrayColor Members


Equals Method (PdfCalGrayColor)

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfCalGrayColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColor Class
PdfCalGrayColor Members


GetHashCode Method (PdfCalGrayColor)

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfCalGrayColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColor Class
PdfCalGrayColor Members


%%PageItemTitle%% $$Properties$$

PdfCalGrayColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCalGrayColor Class

For a list of all members of this type, see PdfCalGrayColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | Gray | Gets or sets the gray component.
Top
See Also

Reference

PdfCalGrayColor Class
Xfinium.Pdf.Graphics Namespace


Gray Property (PdfCalGrayColor)

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColor Class : Gray Property
Gets or sets the gray component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Gray As Double
'Usage

Dim instance As PdfCalGrayColor
Dim value As Double

instance.Gray = value

value = instance.Gray
public double Gray {get; set;}
public:
property double Gray {
   double get();
   void set (    double value);
}

Property Value

The gray component of this color in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColor Class
PdfCalGrayColor Members


%%PageItemTitle%%

PdfCalGrayColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCalGrayColorSpace Class
Defines a calibrated gray colorspace.
Object Model
PdfCalGrayColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCalGrayColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfCalGrayColorSpace
public class PdfCalGrayColorSpace : PdfColorSpace
public ref class PdfCalGrayColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfCalGrayColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCalGrayColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCalGrayColorSpace Class

The following tables list the members exposed by PdfCalGrayColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfCalGrayColorSpace Constructor | Initializes a new PdfCalGrayColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Gamma | Gets or sets the gamma.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PdfCalGrayColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCalGrayColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColorSpace Class : PdfCalGrayColorSpace Constructor
Initializes a new PdfCalGrayColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCalGrayColorSpace()
public PdfCalGrayColorSpace()
public:
PdfCalGrayColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColorSpace Class
PdfCalGrayColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfCalGrayColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCalGrayColorSpace Class

For a list of all members of this type, see PdfCalGrayColorSpace members.

Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Gamma | Gets or sets the gamma.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PdfCalGrayColorSpace Class
Xfinium.Pdf.Graphics Namespace


BlackPoint Property (PdfCalGrayColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColorSpace Class : BlackPoint Property
Gets or sets the black point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BlackPoint As Double()
'Usage

Dim instance As PdfCalGrayColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
public double[] BlackPoint {get; set;}
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColorSpace Class
PdfCalGrayColorSpace Members


ColorComponentCount Property (PdfCalGrayColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfCalGrayColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColorSpace Class
PdfCalGrayColorSpace Members


Gamma Property (PdfCalGrayColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColorSpace Class : Gamma Property
Gets or sets the gamma.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Gamma As Double
'Usage

Dim instance As PdfCalGrayColorSpace
Dim value As Double

instance.Gamma = value

value = instance.Gamma
public double Gamma {get; set;}
public:
property double Gamma {
   double get();
   void set (    double value);
}

Property Value

A number defining the gamma for the gray component.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColorSpace Class
PdfCalGrayColorSpace Members


WhitePoint Property (PdfCalGrayColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColorSpace Class : WhitePoint Property
Gets or sets the white point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WhitePoint As Double()
'Usage

Dim instance As PdfCalGrayColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
public double[] WhitePoint {get; set;}
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColorSpace Class
PdfCalGrayColorSpace Members


%%PageItemTitle%%

PdfCalRgbColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCalRgbColor Class
Defines a RGB color based on a calibrated RGB colorspace.
Object Model
PdfCalRgbColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCalRgbColor
   Inherits PdfColor
'Usage

Dim instance As PdfCalRgbColor
public class PdfCalRgbColor : PdfColor
public ref class PdfCalRgbColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfCalRgbColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCalRgbColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfCalRgbColor Class

The following tables list the members exposed by PdfCalRgbColor.

Public Constructors
 | Name | Description
Public Constructor | PdfCalRgbColor Constructor | Initializes a new PdfCalRgbColor object with a calibrated RGB colorspace.
Top
Public Properties
 | Name | Description
Public Property | Blue | Gets or sets the blue component.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | Green | Gets or sets the green component.
Public Property | Red | Gets or sets the red component.
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfCalRgbColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCalRgbColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColor Class : PdfCalRgbColor Constructor
A calibrated RGB colorspace.
Initializes a new PdfCalRgbColor object with a calibrated RGB colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PdfCalRgbColorSpace _
)
'Usage

Dim colorSpace As PdfCalRgbColorSpace

Dim instance As New PdfCalRgbColor(colorSpace)
public PdfCalRgbColor(
   PdfCalRgbColorSpace colorSpace
)
public:
PdfCalRgbColor(
   PdfCalRgbColorSpace^ colorSpace
)

Parameters

colorSpace
A calibrated RGB colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColor Class
PdfCalRgbColor Members


%%PageItemTitle%% $$Methods$$

PdfCalRgbColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfCalRgbColor Class

For a list of all members of this type, see PdfCalRgbColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfCalRgbColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfCalRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfCalRgbColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColor Class
PdfCalRgbColor Members


Equals Method (PdfCalRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfCalRgbColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColor Class
PdfCalRgbColor Members


GetHashCode Method (PdfCalRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfCalRgbColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColor Class
PdfCalRgbColor Members


%%PageItemTitle%% $$Properties$$

PdfCalRgbColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCalRgbColor Class

For a list of all members of this type, see PdfCalRgbColor members.

Public Properties
 | Name | Description
Public Property | Blue | Gets or sets the blue component.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | Green | Gets or sets the green component.
Public Property | Red | Gets or sets the red component.
Top
See Also

Reference

PdfCalRgbColor Class
Xfinium.Pdf.Graphics Namespace


Blue Property (PdfCalRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColor Class : Blue Property
Gets or sets the blue component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Blue As Double
'Usage

Dim instance As PdfCalRgbColor
Dim value As Double

instance.Blue = value

value = instance.Blue
public double Blue {get; set;}
public:
property double Blue {
   double get();
   void set (    double value);
}

Property Value

The blue component in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColor Class
PdfCalRgbColor Members


Green Property (PdfCalRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColor Class : Green Property
Gets or sets the green component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Green As Double
'Usage

Dim instance As PdfCalRgbColor
Dim value As Double

instance.Green = value

value = instance.Green
public double Green {get; set;}
public:
property double Green {
   double get();
   void set (    double value);
}

Property Value

The green component in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColor Class
PdfCalRgbColor Members


Red Property (PdfCalRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColor Class : Red Property
Gets or sets the red component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Red As Double
'Usage

Dim instance As PdfCalRgbColor
Dim value As Double

instance.Red = value

value = instance.Red
public double Red {get; set;}
public:
property double Red {
   double get();
   void set (    double value);
}

Property Value

The red component in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColor Class
PdfCalRgbColor Members


%%PageItemTitle%%

PdfCalRgbColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCalRgbColorSpace Class
Defines a calibrated RGB colorspace.
Object Model
PdfCalRgbColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCalRgbColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfCalRgbColorSpace
public class PdfCalRgbColorSpace : PdfColorSpace
public ref class PdfCalRgbColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfCalRgbColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCalRgbColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCalRgbColorSpace Class

The following tables list the members exposed by PdfCalRgbColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfCalRgbColorSpace Constructor | Initializes a new PdfCalRgbColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Gamma | Gets or sets the gamma.
Public Property | Matrix | Gets or sets the colorspace transformation matrix.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PdfCalRgbColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCalRgbColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColorSpace Class : PdfCalRgbColorSpace Constructor
Initializes a new PdfCalRgbColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCalRgbColorSpace()
public PdfCalRgbColorSpace()
public:
PdfCalRgbColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColorSpace Class
PdfCalRgbColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfCalRgbColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCalRgbColorSpace Class

For a list of all members of this type, see PdfCalRgbColorSpace members.

Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Gamma | Gets or sets the gamma.
Public Property | Matrix | Gets or sets the colorspace transformation matrix.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PdfCalRgbColorSpace Class
Xfinium.Pdf.Graphics Namespace


BlackPoint Property (PdfCalRgbColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColorSpace Class : BlackPoint Property
Gets or sets the black point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BlackPoint As Double()
'Usage

Dim instance As PdfCalRgbColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
public double[] BlackPoint {get; set;}
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColorSpace Class
PdfCalRgbColorSpace Members


ColorComponentCount Property (PdfCalRgbColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfCalRgbColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColorSpace Class
PdfCalRgbColorSpace Members


Gamma Property (PdfCalRgbColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColorSpace Class : Gamma Property
Gets or sets the gamma.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Gamma As Double()
'Usage

Dim instance As PdfCalRgbColorSpace
Dim value() As Double

instance.Gamma = value

value = instance.Gamma
public double[] Gamma {get; set;}
public:
property array<double>^ Gamma {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [GR GG GB] specifying the gamma for the red, green, and blue components of the color space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColorSpace Class
PdfCalRgbColorSpace Members


Matrix Property (PdfCalRgbColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColorSpace Class : Matrix Property
Gets or sets the colorspace transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Matrix As Double()
'Usage

Dim instance As PdfCalRgbColorSpace
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
public double[] Matrix {get; set;}
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of nine numbers [XA YA ZA XB YB ZB XC YC ZC] specifying the linear interpretation of the decoded A, B, and C components of the color space with respect to the final XYZ representation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColorSpace Class
PdfCalRgbColorSpace Members


WhitePoint Property (PdfCalRgbColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColorSpace Class : WhitePoint Property
Gets or sets the white point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WhitePoint As Double()
'Usage

Dim instance As PdfCalRgbColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
public double[] WhitePoint {get; set;}
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColorSpace Class
PdfCalRgbColorSpace Members


%%PageItemTitle%%

PdfCmykColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCmykColor Class
Defines a device dependent CMYK color.
Object Model
PdfCmykColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCmykColor
   Inherits PdfColor
'Usage

Dim instance As PdfCmykColor
public class PdfCmykColor : PdfColor
public ref class PdfCmykColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfCmykColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCmykColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfCmykColor Class

The following tables list the members exposed by PdfCmykColor.

Public Constructors
 | Name | Description
Public Constructor | PdfCmykColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan component.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | K | Gets or sets the black component.
Public Property | M | Gets or sets the magenta component.
Public Property | Y | Gets or sets the yellow component.
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfCmykColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCmykColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class : PdfCmykColor Constructor
Overload List
Overload | Description
PdfCmykColor Constructor() | Initializes a new PdfCmykColor object.
PdfCmykColor Constructor(Double,Double,Double,Double) | Initializes a new PdfCmykColor object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members


%%PageItemTitle%%

PdfCmykColor Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class > PdfCmykColor Constructor : PdfCmykColor Constructor()
Initializes a new PdfCmykColor object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCmykColor()
public PdfCmykColor()
public:
PdfCmykColor();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members
Overload List


%%PageItemTitle%%

PdfCmykColor Constructor(Double,Double,Double,Double)

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class > PdfCmykColor Constructor : PdfCmykColor Constructor(Double,Double,Double,Double)
Cyan component.
Magenta component.
Yellow component.
Black component.
Initializes a new PdfCmykColor object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
'Usage

Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

Dim instance As New PdfCmykColor(c, m, y, k)
public PdfCmykColor(
   double c,
   double m,
   double y,
   double k
)
public:
PdfCmykColor(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
Cyan component.
m
Magenta component.
y
Yellow component.
k
Black component.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfCmykColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfCmykColor Class

For a list of all members of this type, see PdfCmykColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfCmykColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfCmykColor)

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfCmykColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members


Equals Method (PdfCmykColor)

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfCmykColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members


GetHashCode Method (PdfCmykColor)

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfCmykColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members


%%PageItemTitle%% $$Properties$$

PdfCmykColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCmykColor Class

For a list of all members of this type, see PdfCmykColor members.

Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan component.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | K | Gets or sets the black component.
Public Property | M | Gets or sets the magenta component.
Public Property | Y | Gets or sets the yellow component.
Top
See Also

Reference

PdfCmykColor Class
Xfinium.Pdf.Graphics Namespace


C Property (PdfCmykColor)

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class : C Property
Gets or sets the cyan component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property C As Double
'Usage

Dim instance As PdfCmykColor
Dim value As Double

instance.C = value

value = instance.C
public double C {get; set;}
public:
property double C {
   double get();
   void set (    double value);
}

Property Value

The cyan component in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members


K Property (PdfCmykColor)

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class : K Property
Gets or sets the black component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property K As Double
'Usage

Dim instance As PdfCmykColor
Dim value As Double

instance.K = value

value = instance.K
public double K {get; set;}
public:
property double K {
   double get();
   void set (    double value);
}

Property Value

The black component in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members


M Property (PdfCmykColor)

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class : M Property
Gets or sets the magenta component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M As Double
'Usage

Dim instance As PdfCmykColor
Dim value As Double

instance.M = value

value = instance.M
public double M {get; set;}
public:
property double M {
   double get();
   void set (    double value);
}

Property Value

The magenta component in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members


Y Property (PdfCmykColor)

Xfinium.Pdf.Graphics Namespace > PdfCmykColor Class : Y Property
Gets or sets the yellow component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PdfCmykColor
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

The yellow component in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColor Class
PdfCmykColor Members


%%PageItemTitle%%

PdfCmykColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCmykColorSpace Class
Defines a device CMYK colorspace.
Object Model
PdfCmykColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCmykColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfCmykColorSpace
public class PdfCmykColorSpace : PdfColorSpace
public ref class PdfCmykColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfCmykColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCmykColorSpace Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfCmykColorSpace Class

The following tables list the members exposed by PdfCmykColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfCmykColorSpace Constructor | Initializes a new PdfCmykColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Top
See Also

Reference

PdfCmykColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCmykColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfCmykColorSpace Class : PdfCmykColorSpace Constructor
Initializes a new PdfCmykColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCmykColorSpace()
public PdfCmykColorSpace()
public:
PdfCmykColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColorSpace Class
PdfCmykColorSpace Members


%%PageItemTitle%% $$Methods$$

PdfCmykColorSpace Class Methods

Xfinium.Pdf.Graphics Namespace : PdfCmykColorSpace Class

For a list of all members of this type, see PdfCmykColorSpace members.

Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Top
See Also

Reference

PdfCmykColorSpace Class
Xfinium.Pdf.Graphics Namespace


Equals Method (PdfCmykColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCmykColorSpace Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfCmykColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColorSpace Class
PdfCmykColorSpace Members


GetHashCode Method (PdfCmykColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCmykColorSpace Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfCmykColorSpace
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColorSpace Class
PdfCmykColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfCmykColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCmykColorSpace Class

For a list of all members of this type, see PdfCmykColorSpace members.

Public Properties
 | Name | Description
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfCmykColorSpace Class
Xfinium.Pdf.Graphics Namespace


ColorComponentCount Property (PdfCmykColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfCmykColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfCmykColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCmykColorSpace Class
PdfCmykColorSpace Members


%%PageItemTitle%%

PdfCodabarBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCodabarBarcode Class
Defines a Codabar barcode.
Object Model
PdfCodabarBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCodabarBarcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfCodabarBarcode
public class PdfCodabarBarcode : Pdf1DBarcode
public ref class PdfCodabarBarcode : public Pdf1DBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9 + - . / : $
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCodabarBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodabarBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCodabarBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCodabarBarcode Class

The following tables list the members exposed by PdfCodabarBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCodabarBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCodabarBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCodabarBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCodabarBarcode Class : PdfCodabarBarcode Constructor
Overload List
Overload | Description
PdfCodabarBarcode Constructor() | Initializes a new PdfCodabarBarcode object.
PdfCodabarBarcode Constructor(String) | Initializes a new PdfCodabarBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodabarBarcode Class
PdfCodabarBarcode Members


%%PageItemTitle%%

PdfCodabarBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCodabarBarcode Class > PdfCodabarBarcode Constructor : PdfCodabarBarcode Constructor()
Initializes a new PdfCodabarBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCodabarBarcode()
public PdfCodabarBarcode()
public:
PdfCodabarBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodabarBarcode Class
PdfCodabarBarcode Members
Overload List


%%PageItemTitle%%

PdfCodabarBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCodabarBarcode Class > PdfCodabarBarcode Constructor : PdfCodabarBarcode Constructor(String)
The barcode data.
Initializes a new PdfCodabarBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCodabarBarcode(data)
public PdfCodabarBarcode(
   string data
)
public:
PdfCodabarBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodabarBarcode Class
PdfCodabarBarcode Members
Overload List


%%PageItemTitle%%

PdfCodablockFBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCodablockFBarcode Class
Defines a CODABLOCK F barcode.
Object Model
PdfCodablockFBarcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCodablockFBarcode
   Inherits Pdf2DBarcode
'Usage

Dim instance As PdfCodablockFBarcode
public class PdfCodablockFBarcode : Pdf2DBarcode
public ref class PdfCodablockFBarcode : public Pdf2DBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.PdfCodablockFBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodablockFBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCodablockFBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCodablockFBarcode Class

The following tables list the members exposed by PdfCodablockFBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCodablockFBarcode Constructor | Initializes a new PdfCodablockFBarcode object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | Columns | Gets or sets the barcode columns.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Rows | Gets or sets the barcode rows.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension.
Top
See Also

Reference

PdfCodablockFBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCodablockFBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCodablockFBarcode Class : PdfCodablockFBarcode Constructor
Initializes a new PdfCodablockFBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCodablockFBarcode()
public PdfCodablockFBarcode()
public:
PdfCodablockFBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodablockFBarcode Class
PdfCodablockFBarcode Members


%%PageItemTitle%% $$Properties$$

PdfCodablockFBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCodablockFBarcode Class

For a list of all members of this type, see PdfCodablockFBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | Columns | Gets or sets the barcode columns.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Rows | Gets or sets the barcode rows.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension.
Top
See Also

Reference

PdfCodablockFBarcode Class
Xfinium.Pdf.Graphics Namespace


Columns Property (PdfCodablockFBarcode)

Xfinium.Pdf.Graphics Namespace > PdfCodablockFBarcode Class : Columns Property
Gets or sets the barcode columns.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Columns As Integer
'Usage

Dim instance As PdfCodablockFBarcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
public int Columns {get; set;}
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

The number of data columns.
Remarks
Codablock F barcodes support 7 to 65 columns.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodablockFBarcode Class
PdfCodablockFBarcode Members


Rows Property (PdfCodablockFBarcode)

Xfinium.Pdf.Graphics Namespace > PdfCodablockFBarcode Class : Rows Property
Gets or sets the barcode rows.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PdfCodablockFBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

The number of data rows.
Remarks
Codablock F barcodes support 2 to 44 rows.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodablockFBarcode Class
PdfCodablockFBarcode Members


YDimension Property (PdfCodablockFBarcode)

Xfinium.Pdf.Graphics Namespace > PdfCodablockFBarcode Class : YDimension Property
Gets or sets the Y dimension.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows Property YDimension As Double
'Usage

Dim instance As PdfCodablockFBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public new double YDimension {get; set;}
public:
new property double YDimension {
   double get();
   void set (    double value);
}

Property Value

The height of a barcode row.
Remarks
Minimum recommended value is Max(8 * PdfBarcode.XDimension, 0.55 * Columns + 3).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCodablockFBarcode Class
PdfCodablockFBarcode Members


%%PageItemTitle%%

PdfCode11Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode11Barcode Class
Defines a Code 11 barcode.
Object Model
PdfCode11Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode11Barcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfCode11Barcode
public class PdfCode11Barcode : Pdf1DBarcode
public ref class PdfCode11Barcode : public Pdf1DBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9 -
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode11Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode11Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode11Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode11Barcode Class

The following tables list the members exposed by PdfCode11Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode11Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode11Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode11Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode11Barcode Class : PdfCode11Barcode Constructor
Overload List
Overload | Description
PdfCode11Barcode Constructor() | Initializes a new PdfCode11Barcode object.
PdfCode11Barcode Constructor(String) | Initializes a new PdfCode11Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode11Barcode Class
PdfCode11Barcode Members


%%PageItemTitle%%

PdfCode11Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode11Barcode Class > PdfCode11Barcode Constructor : PdfCode11Barcode Constructor()
Initializes a new PdfCode11Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode11Barcode()
public PdfCode11Barcode()
public:
PdfCode11Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode11Barcode Class
PdfCode11Barcode Members
Overload List


%%PageItemTitle%%

PdfCode11Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode11Barcode Class > PdfCode11Barcode Constructor : PdfCode11Barcode Constructor(String)
The barcode data.
Initializes a new PdfCode11Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode11Barcode(data)
public PdfCode11Barcode(
   string data
)
public:
PdfCode11Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode11Barcode Class
PdfCode11Barcode Members
Overload List


%%PageItemTitle%%

PdfCode128ABarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode128ABarcode Class
Defines a Code 128 barcode using the A character set.
Object Model
PdfCode128ABarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode128ABarcode
   Inherits PdfCode128Barcode
'Usage

Dim instance As PdfCode128ABarcode
public class PdfCode128ABarcode : PdfCode128Barcode
public ref class PdfCode128ABarcode : public PdfCode128Barcode
Remarks
Supported characters: 0x00 to 0x1F SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ] ^ _
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128ABarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128ABarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode128ABarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode128ABarcode Class

The following tables list the members exposed by PdfCode128ABarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode128ABarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode128ABarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode128ABarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode128ABarcode Class : PdfCode128ABarcode Constructor
Overload List
Overload | Description
PdfCode128ABarcode Constructor() | Initializes a new PdfCode128ABarcode object.
PdfCode128ABarcode Constructor(String) | Initializes a new PdfCode128ABarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128ABarcode Class
PdfCode128ABarcode Members


%%PageItemTitle%%

PdfCode128ABarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode128ABarcode Class > PdfCode128ABarcode Constructor : PdfCode128ABarcode Constructor()
Initializes a new PdfCode128ABarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode128ABarcode()
public PdfCode128ABarcode()
public:
PdfCode128ABarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128ABarcode Class
PdfCode128ABarcode Members
Overload List


%%PageItemTitle%%

PdfCode128ABarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode128ABarcode Class > PdfCode128ABarcode Constructor : PdfCode128ABarcode Constructor(String)
The barcode data.
Initializes a new PdfCode128ABarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode128ABarcode(data)
public PdfCode128ABarcode(
   string data
)
public:
PdfCode128ABarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128ABarcode Class
PdfCode128ABarcode Members
Overload List


%%PageItemTitle%%

PdfCode128Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode128Barcode Class
Defines a Code 128 barcode using a mixed character set.
Object Model
PdfCode128Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode128Barcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfCode128Barcode
public class PdfCode128Barcode : Pdf1DBarcode
public ref class PdfCode128Barcode : public Pdf1DBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128ABarcode
Xfinium.Pdf.Graphics.PdfCode128BBarcode
Xfinium.Pdf.Graphics.PdfCode128CBarcode
Xfinium.Pdf.Graphics.PdfEan128Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode128Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode128Barcode Class

The following tables list the members exposed by PdfCode128Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode128Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode128Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode128Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode128Barcode Class : PdfCode128Barcode Constructor
Overload List
Overload | Description
PdfCode128Barcode Constructor() | Initializes a new PdfCode128Barcode object.
PdfCode128Barcode Constructor(String) | Initializes a new PdfCode128Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128Barcode Class
PdfCode128Barcode Members


%%PageItemTitle%%

PdfCode128Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode128Barcode Class > PdfCode128Barcode Constructor : PdfCode128Barcode Constructor()
Initializes a new PdfCode128Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode128Barcode()
public PdfCode128Barcode()
public:
PdfCode128Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128Barcode Class
PdfCode128Barcode Members
Overload List


%%PageItemTitle%%

PdfCode128Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode128Barcode Class > PdfCode128Barcode Constructor : PdfCode128Barcode Constructor(String)
The barcode data.
Initializes a new PdfCode128Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode128Barcode(data)
public PdfCode128Barcode(
   string data
)
public:
PdfCode128Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128Barcode Class
PdfCode128Barcode Members
Overload List


%%PageItemTitle%%

PdfCode128BBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode128BBarcode Class
Defines a Code 128 barcode using the B character set.
Object Model
PdfCode128BBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode128BBarcode
   Inherits PdfCode128Barcode
'Usage

Dim instance As PdfCode128BBarcode
public class PdfCode128BBarcode : PdfCode128Barcode
public ref class PdfCode128BBarcode : public PdfCode128Barcode
Remarks
Supported characters: SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ 0x7F
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128BBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128BBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode128BBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode128BBarcode Class

The following tables list the members exposed by PdfCode128BBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode128BBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode128BBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode128BBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode128BBarcode Class : PdfCode128BBarcode Constructor
Overload List
Overload | Description
PdfCode128BBarcode Constructor() | Initializes a new PdfCode128BBarcode object.
PdfCode128BBarcode Constructor(String) | Initializes a new PdfCode128BBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128BBarcode Class
PdfCode128BBarcode Members


%%PageItemTitle%%

PdfCode128BBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode128BBarcode Class > PdfCode128BBarcode Constructor : PdfCode128BBarcode Constructor()
Initializes a new PdfCode128BBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode128BBarcode()
public PdfCode128BBarcode()
public:
PdfCode128BBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128BBarcode Class
PdfCode128BBarcode Members
Overload List


%%PageItemTitle%%

PdfCode128BBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode128BBarcode Class > PdfCode128BBarcode Constructor : PdfCode128BBarcode Constructor(String)
The barcode data.
Initializes a new PdfCode128BBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode128BBarcode(data)
public PdfCode128BBarcode(
   string data
)
public:
PdfCode128BBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128BBarcode Class
PdfCode128BBarcode Members
Overload List


%%PageItemTitle%%

PdfCode128CBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode128CBarcode Class
Defines a Code 128 barcode using the C character set.
Object Model
PdfCode128CBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode128CBarcode
   Inherits PdfCode128Barcode
'Usage

Dim instance As PdfCode128CBarcode
public class PdfCode128CBarcode : PdfCode128Barcode
public ref class PdfCode128CBarcode : public PdfCode128Barcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128CBarcode
Xfinium.Pdf.Graphics.PdfFedExGround96Barcode
Xfinium.Pdf.Graphics.PdfScc14Barcode
Xfinium.Pdf.Graphics.PdfSscc18Barcode
Xfinium.Pdf.Graphics.PdfUspsPicBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128CBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode128CBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode128CBarcode Class

The following tables list the members exposed by PdfCode128CBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode128CBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode128CBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode128CBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode128CBarcode Class : PdfCode128CBarcode Constructor
Overload List
Overload | Description
PdfCode128CBarcode Constructor() | Initializes a new PdfCode128CBarcode object.
PdfCode128CBarcode Constructor(String) | Initializes a new PdfCode128CBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128CBarcode Class
PdfCode128CBarcode Members


%%PageItemTitle%%

PdfCode128CBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode128CBarcode Class > PdfCode128CBarcode Constructor : PdfCode128CBarcode Constructor()
Initializes a new PdfCode128CBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode128CBarcode()
public PdfCode128CBarcode()
public:
PdfCode128CBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128CBarcode Class
PdfCode128CBarcode Members
Overload List


%%PageItemTitle%%

PdfCode128CBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode128CBarcode Class > PdfCode128CBarcode Constructor : PdfCode128CBarcode Constructor(String)
The barcode data.
Initializes a new PdfCode128CBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode128CBarcode(data)
public PdfCode128CBarcode(
   string data
)
public:
PdfCode128CBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode128CBarcode Class
PdfCode128CBarcode Members
Overload List


%%PageItemTitle%%

PdfCode16KBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode16KBarcode Class
Defines a Code 16K barcode.
Object Model
PdfCode16KBarcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode16KBarcode
   Inherits Pdf2DBarcode
'Usage

Dim instance As PdfCode16KBarcode
public class PdfCode16KBarcode : Pdf2DBarcode
public ref class PdfCode16KBarcode : public Pdf2DBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.PdfCode16KBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode16KBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode16KBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode16KBarcode Class

The following tables list the members exposed by PdfCode16KBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode16KBarcode Constructor | Initializes a new PdfCode16KBarcode object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | Columns | Gets the barcode columns.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Rows | Gets or sets the barcode rows.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension.
Top
See Also

Reference

PdfCode16KBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode16KBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode16KBarcode Class : PdfCode16KBarcode Constructor
Initializes a new PdfCode16KBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode16KBarcode()
public PdfCode16KBarcode()
public:
PdfCode16KBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode16KBarcode Class
PdfCode16KBarcode Members


%%PageItemTitle%% $$Properties$$

PdfCode16KBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode16KBarcode Class

For a list of all members of this type, see PdfCode16KBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | Columns | Gets the barcode columns.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Rows | Gets or sets the barcode rows.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension.
Top
See Also

Reference

PdfCode16KBarcode Class
Xfinium.Pdf.Graphics Namespace


Columns Property (PdfCode16KBarcode)

Xfinium.Pdf.Graphics Namespace > PdfCode16KBarcode Class : Columns Property
Gets the barcode columns.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Columns As Integer
'Usage

Dim instance As PdfCode16KBarcode
Dim value As Integer

value = instance.Columns
public int Columns {get;}
public:
property int Columns {
   int get();
}

Property Value

The data columns in the barcode.
Remarks
Code 16K barcodes have always 5 columns.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode16KBarcode Class
PdfCode16KBarcode Members


Rows Property (PdfCode16KBarcode)

Xfinium.Pdf.Graphics Namespace > PdfCode16KBarcode Class : Rows Property
Gets or sets the barcode rows.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Rows As Integer
'Usage

Dim instance As PdfCode16KBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
public int Rows {get; set;}
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

The number of data rows.
Remarks
Code 16K barcodes support 2 to 16 rows. 0 rows means that the number of rows is computed automatically.
Note: Rows and Columns cannot be both 0.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode16KBarcode Class
PdfCode16KBarcode Members


YDimension Property (PdfCode16KBarcode)

Xfinium.Pdf.Graphics Namespace > PdfCode16KBarcode Class : YDimension Property
Gets or sets the Y dimension.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows Property YDimension As Double
'Usage

Dim instance As PdfCode16KBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
public new double YDimension {get; set;}
public:
new property double YDimension {
   double get();
   void set (    double value);
}

Property Value

The height of a barcode row.
Remarks
Minimum recommended value is 8 * PdfBarcode.XDimension.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode16KBarcode Class
PdfCode16KBarcode Members


%%PageItemTitle%%

PdfCode25Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode25Barcode Class
Defines a Code 2 of 5 barcode.
Object Model
PdfCode25Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode25Barcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfCode25Barcode
public class PdfCode25Barcode : Pdf1DBarcode
public ref class PdfCode25Barcode : public Pdf1DBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfCode25InterleavedBarcode
Xfinium.Pdf.Graphics.PdfCoop25Barcode
Xfinium.Pdf.Graphics.PdfIata25Barcode
Xfinium.Pdf.Graphics.PdfMatrix25Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode25Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode25Barcode Class

The following tables list the members exposed by PdfCode25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio.
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode25Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode25Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode25Barcode Class : PdfCode25Barcode Constructor
Overload List
Overload | Description
PdfCode25Barcode Constructor() | Initializes a new PdfCode25Barcode object.
PdfCode25Barcode Constructor(String) | Initializes a new PdfCode25Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25Barcode Class
PdfCode25Barcode Members


%%PageItemTitle%%

PdfCode25Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode25Barcode Class > PdfCode25Barcode Constructor : PdfCode25Barcode Constructor()
Initializes a new PdfCode25Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode25Barcode()
public PdfCode25Barcode()
public:
PdfCode25Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25Barcode Class
PdfCode25Barcode Members
Overload List


%%PageItemTitle%%

PdfCode25Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode25Barcode Class > PdfCode25Barcode Constructor : PdfCode25Barcode Constructor(String)
The barcode data.
Initializes a new PdfCode25Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode25Barcode(data)
public PdfCode25Barcode(
   string data
)
public:
PdfCode25Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25Barcode Class
PdfCode25Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfCode25Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode25Barcode Class

For a list of all members of this type, see PdfCode25Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio.
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode25Barcode Class
Xfinium.Pdf.Graphics Namespace


WideToNarrowRatio Property (PdfCode25Barcode)

Xfinium.Pdf.Graphics Namespace > PdfCode25Barcode Class : WideToNarrowRatio Property
Gets or sets the wide to narrow ratio.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PdfCode25Barcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

The ratio between wide and narrow bars.
Remarks
Recommended ratio: 2.2:1 to 3:1.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25Barcode Class
PdfCode25Barcode Members


%%PageItemTitle%%

PdfCode25InterleavedBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode25InterleavedBarcode Class
Defines an interleaved Code 2 of 5 barcode.
Object Model
PdfCode25InterleavedBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode25InterleavedBarcode
   Inherits PdfCode25Barcode
'Usage

Dim instance As PdfCode25InterleavedBarcode
public class PdfCode25InterleavedBarcode : PdfCode25Barcode
public ref class PdfCode25InterleavedBarcode : public PdfCode25Barcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfCode25InterleavedBarcode
Xfinium.Pdf.Graphics.PdfIdentcodeBarcode
Xfinium.Pdf.Graphics.PdfLeitcodeBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25InterleavedBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode25InterleavedBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode25InterleavedBarcode Class

The following tables list the members exposed by PdfCode25InterleavedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode25InterleavedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode25InterleavedBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode25InterleavedBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode25InterleavedBarcode Class : PdfCode25InterleavedBarcode Constructor
Overload List
Overload | Description
PdfCode25InterleavedBarcode Constructor() | Initializes a new PdfCode25InterleavedBarcode object.
PdfCode25InterleavedBarcode Constructor(String) | Initializes a new PdfCode25InterleavedBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25InterleavedBarcode Class
PdfCode25InterleavedBarcode Members


%%PageItemTitle%%

PdfCode25InterleavedBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode25InterleavedBarcode Class > PdfCode25InterleavedBarcode Constructor : PdfCode25InterleavedBarcode Constructor()
Initializes a new PdfCode25InterleavedBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode25InterleavedBarcode()
public PdfCode25InterleavedBarcode()
public:
PdfCode25InterleavedBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25InterleavedBarcode Class
PdfCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PdfCode25InterleavedBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode25InterleavedBarcode Class > PdfCode25InterleavedBarcode Constructor : PdfCode25InterleavedBarcode Constructor(String)
The barcode data.
Initializes a new PdfCode25InterleavedBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode25InterleavedBarcode(data)
public PdfCode25InterleavedBarcode(
   string data
)
public:
PdfCode25InterleavedBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode25InterleavedBarcode Class
PdfCode25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

PdfCode32Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode32Barcode Class
Defines a Code 32 barcode.
Object Model
PdfCode32Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode32Barcode
   Inherits PdfCode39Barcode
'Usage

Dim instance As PdfCode32Barcode
public class PdfCode32Barcode : PdfCode39Barcode
public ref class PdfCode32Barcode : public PdfCode39Barcode
Remarks
Supported characters: 1 2 3 4 5 6 7 8 9 0.
Data length: 8 digits.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode39Barcode
Xfinium.Pdf.Graphics.PdfCode32Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode32Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode32Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode32Barcode Class

The following tables list the members exposed by PdfCode32Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode32Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode39Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode32Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode32Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode32Barcode Class : PdfCode32Barcode Constructor
Overload List
Overload | Description
PdfCode32Barcode Constructor() | Initializes a new PdfCode32Barcode object.
PdfCode32Barcode Constructor(String) | Initializes a new PdfCode32Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode32Barcode Class
PdfCode32Barcode Members


%%PageItemTitle%%

PdfCode32Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode32Barcode Class > PdfCode32Barcode Constructor : PdfCode32Barcode Constructor()
Initializes a new PdfCode32Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode32Barcode()
public PdfCode32Barcode()
public:
PdfCode32Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode32Barcode Class
PdfCode32Barcode Members
Overload List


%%PageItemTitle%%

PdfCode32Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode32Barcode Class > PdfCode32Barcode Constructor : PdfCode32Barcode Constructor(String)
The barcode data.
Initializes a new PdfCode32Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode32Barcode(data)
public PdfCode32Barcode(
   string data
)
public:
PdfCode32Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode32Barcode Class
PdfCode32Barcode Members
Overload List


%%PageItemTitle%%

PdfCode39Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode39Barcode Class
Defines a Code 39 barcode.
Object Model
PdfCode39Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode39Barcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfCode39Barcode
public class PdfCode39Barcode : Pdf1DBarcode
public ref class PdfCode39Barcode : public Pdf1DBarcode
Remarks
Supported characters: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode39Barcode
Xfinium.Pdf.Graphics.PdfCode32Barcode
Xfinium.Pdf.Graphics.PdfCode39ExtendedBarcode
Xfinium.Pdf.Graphics.PdfPznBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode39Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode39Barcode Class

The following tables list the members exposed by PdfCode39Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode39Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio.
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode39Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode39Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode39Barcode Class : PdfCode39Barcode Constructor
Overload List
Overload | Description
PdfCode39Barcode Constructor() | Initializes a new PdfCode39Barcode object.
PdfCode39Barcode Constructor(String) | Initializes a new PdfCode39Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39Barcode Class
PdfCode39Barcode Members


%%PageItemTitle%%

PdfCode39Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode39Barcode Class > PdfCode39Barcode Constructor : PdfCode39Barcode Constructor()
Initializes a new PdfCode39Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode39Barcode()
public PdfCode39Barcode()
public:
PdfCode39Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39Barcode Class
PdfCode39Barcode Members
Overload List


%%PageItemTitle%%

PdfCode39Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode39Barcode Class > PdfCode39Barcode Constructor : PdfCode39Barcode Constructor(String)
The barcode data.
Initializes a new PdfCode39Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode39Barcode(data)
public PdfCode39Barcode(
   string data
)
public:
PdfCode39Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39Barcode Class
PdfCode39Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfCode39Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode39Barcode Class

For a list of all members of this type, see PdfCode39Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio.
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode39Barcode Class
Xfinium.Pdf.Graphics Namespace


WideToNarrowRatio Property (PdfCode39Barcode)

Xfinium.Pdf.Graphics Namespace > PdfCode39Barcode Class : WideToNarrowRatio Property
Gets or sets the wide to narrow ratio.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PdfCode39Barcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

The ratio between wide and narrow bars.
Remarks
Recommended ratio: 2.2:1 to 3:1.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39Barcode Class
PdfCode39Barcode Members


%%PageItemTitle%%

PdfCode39ExtendedBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode39ExtendedBarcode Class
Defines an extended Code 39 barcode.
Object Model
PdfCode39ExtendedBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode39ExtendedBarcode
   Inherits PdfCode39Barcode
'Usage

Dim instance As PdfCode39ExtendedBarcode
public class PdfCode39ExtendedBarcode : PdfCode39Barcode
public ref class PdfCode39ExtendedBarcode : public PdfCode39Barcode
Remarks
Supported characters: all 128 ASCII characters.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode39Barcode
Xfinium.Pdf.Graphics.PdfCode39ExtendedBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39ExtendedBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode39ExtendedBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode39ExtendedBarcode Class

The following tables list the members exposed by PdfCode39ExtendedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode39ExtendedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode39Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode39ExtendedBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode39ExtendedBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode39ExtendedBarcode Class : PdfCode39ExtendedBarcode Constructor
Overload List
Overload | Description
PdfCode39ExtendedBarcode Constructor() | Initializes a new PdfCode39ExtendedBarcode object.
PdfCode39ExtendedBarcode Constructor(String) | Initializes a new PdfCode39ExtendedBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39ExtendedBarcode Class
PdfCode39ExtendedBarcode Members


%%PageItemTitle%%

PdfCode39ExtendedBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode39ExtendedBarcode Class > PdfCode39ExtendedBarcode Constructor : PdfCode39ExtendedBarcode Constructor()
Initializes a new PdfCode39ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode39ExtendedBarcode()
public PdfCode39ExtendedBarcode()
public:
PdfCode39ExtendedBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39ExtendedBarcode Class
PdfCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PdfCode39ExtendedBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode39ExtendedBarcode Class > PdfCode39ExtendedBarcode Constructor : PdfCode39ExtendedBarcode Constructor(String)
The barcode data.
Initializes a new PdfCode39ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode39ExtendedBarcode(data)
public PdfCode39ExtendedBarcode(
   string data
)
public:
PdfCode39ExtendedBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode39ExtendedBarcode Class
PdfCode39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PdfCode93Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode93Barcode Class
Defines a Code 93 barcode.
Object Model
PdfCode93Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode93Barcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfCode93Barcode
public class PdfCode93Barcode : Pdf1DBarcode
public ref class PdfCode93Barcode : public Pdf1DBarcode
Remarks
Supported characters: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode93Barcode
Xfinium.Pdf.Graphics.PdfCode93ExtendedBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode93Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode93Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode93Barcode Class

The following tables list the members exposed by PdfCode93Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode93Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode93Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode93Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode93Barcode Class : PdfCode93Barcode Constructor
Overload List
Overload | Description
PdfCode93Barcode Constructor() | Initializes a new PdfCode93Barcode object.
PdfCode93Barcode Constructor(String) | Initializes a new PdfCode93Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode93Barcode Class
PdfCode93Barcode Members


%%PageItemTitle%%

PdfCode93Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode93Barcode Class > PdfCode93Barcode Constructor : PdfCode93Barcode Constructor()
Initializes a new PdfCode93Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode93Barcode()
public PdfCode93Barcode()
public:
PdfCode93Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode93Barcode Class
PdfCode93Barcode Members
Overload List


%%PageItemTitle%%

PdfCode93Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode93Barcode Class > PdfCode93Barcode Constructor : PdfCode93Barcode Constructor(String)
The barcode data.
Initializes a new PdfCode93Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode93Barcode(data)
public PdfCode93Barcode(
   string data
)
public:
PdfCode93Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode93Barcode Class
PdfCode93Barcode Members
Overload List


%%PageItemTitle%%

PdfCode93ExtendedBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCode93ExtendedBarcode Class
Defines an extended Code 93 barcode.
Object Model
PdfCode93ExtendedBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCode93ExtendedBarcode
   Inherits PdfCode93Barcode
'Usage

Dim instance As PdfCode93ExtendedBarcode
public class PdfCode93ExtendedBarcode : PdfCode93Barcode
public ref class PdfCode93ExtendedBarcode : public PdfCode93Barcode
Remarks
Supported characters: all 128 ASCII characters.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode93Barcode
Xfinium.Pdf.Graphics.PdfCode93ExtendedBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode93ExtendedBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCode93ExtendedBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCode93ExtendedBarcode Class

The following tables list the members exposed by PdfCode93ExtendedBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCode93ExtendedBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode93ExtendedBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCode93ExtendedBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCode93ExtendedBarcode Class : PdfCode93ExtendedBarcode Constructor
Overload List
Overload | Description
PdfCode93ExtendedBarcode Constructor() | Initializes a new PdfCode93ExtendedBarcode object.
PdfCode93ExtendedBarcode Constructor(String) | Initializes a new PdfCode93ExtendedBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode93ExtendedBarcode Class
PdfCode93ExtendedBarcode Members


%%PageItemTitle%%

PdfCode93ExtendedBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCode93ExtendedBarcode Class > PdfCode93ExtendedBarcode Constructor : PdfCode93ExtendedBarcode Constructor()
Initializes a new PdfCode93ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCode93ExtendedBarcode()
public PdfCode93ExtendedBarcode()
public:
PdfCode93ExtendedBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode93ExtendedBarcode Class
PdfCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PdfCode93ExtendedBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCode93ExtendedBarcode Class > PdfCode93ExtendedBarcode Constructor : PdfCode93ExtendedBarcode Constructor(String)
The barcode data.
Initializes a new PdfCode93ExtendedBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCode93ExtendedBarcode(data)
public PdfCode93ExtendedBarcode(
   string data
)
public:
PdfCode93ExtendedBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCode93ExtendedBarcode Class
PdfCode93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

PdfColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfColor Class
Defines the base class for PDF colors.
Object Model
PdfColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfColor
'Usage

Dim instance As PdfColor
public abstract class PdfColor
public ref class PdfColor abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfCalGrayColor
Xfinium.Pdf.Graphics.PdfCalRgbColor
Xfinium.Pdf.Graphics.PdfCmykColor
Xfinium.Pdf.Graphics.PdfDeviceNColor
Xfinium.Pdf.Graphics.PdfGrayColor
Xfinium.Pdf.Graphics.PdfIccColor
Xfinium.Pdf.Graphics.PdfIndexedColor
Xfinium.Pdf.Graphics.PdfLabColor
Xfinium.Pdf.Graphics.PdfPatternColor
Xfinium.Pdf.Graphics.PdfRgbColor
Xfinium.Pdf.Graphics.PdfSeparationColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfColor Class

The following tables list the members exposed by PdfColor.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace.
Top
Public Methods
 | Name | Description
Public Method | Copy | Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB.
Top
See Also

Reference

PdfColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfColor Class

For a list of all members of this type, see PdfColor members.

Public Methods
 | Name | Description
Public Method | Copy | Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB.
Top
See Also

Reference

PdfColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfColor)

Xfinium.Pdf.Graphics Namespace > PdfColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function Copy() As PdfColor
'Usage

Dim instance As PdfColor
Dim value As PdfColor

value = instance.Copy()
public virtual PdfColor Copy()
public:
virtual PdfColor^ Copy();

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColor Class
PdfColor Members


Equals Method (PdfColor)

Xfinium.Pdf.Graphics Namespace > PdfColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColor Class
PdfColor Members


GetHashCode Method (PdfColor)

Xfinium.Pdf.Graphics Namespace > PdfColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColor Class
PdfColor Members


ToRgbColor Method (PdfColor)

Xfinium.Pdf.Graphics Namespace > PdfColor Class : ToRgbColor Method
Converts this color to RGB.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function ToRgbColor() As PdfRgbColor
'Usage

Dim instance As PdfColor
Dim value As PdfRgbColor

value = instance.ToRgbColor()
public virtual PdfRgbColor ToRgbColor()
public:
virtual PdfRgbColor^ ToRgbColor();

Return Value

The color in RGB format.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColor Class
PdfColor Members


%%PageItemTitle%% $$Properties$$

PdfColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfColor Class

For a list of all members of this type, see PdfColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace.
Top
See Also

Reference

PdfColor Class
Xfinium.Pdf.Graphics Namespace


ColorSpace Property (PdfColor)

Xfinium.Pdf.Graphics Namespace > PdfColor Class : ColorSpace Property
Gets the colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As PdfColorSpace
'Usage

Dim instance As PdfColor
Dim value As PdfColorSpace

value = instance.ColorSpace
public PdfColorSpace ColorSpace {get;}
public:
property PdfColorSpace^ ColorSpace {
   PdfColorSpace^ get();
}

Property Value

A PdfColorSpace that represents the colorspace of the color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColor Class
PdfColor Members


%%PageItemTitle%%

PdfColoredTilingPattern Class
Members

Xfinium.Pdf.Graphics Namespace : PdfColoredTilingPattern Class
Defines a colored PDF pattern.
Object Model
PdfColoredTilingPattern ClassPdfGraphics ClassPdfMatrix Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfColoredTilingPattern
   Inherits PdfTilingPattern
'Usage

Dim instance As PdfColoredTilingPattern
public class PdfColoredTilingPattern : PdfTilingPattern
public ref class PdfColoredTilingPattern : public PdfTilingPattern
Remarks
A colored tiling pattern is one whose color is self-contained.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPattern
Xfinium.Pdf.Graphics.PdfTilingPattern
Xfinium.Pdf.Graphics.PdfColoredTilingPattern

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColoredTilingPattern Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfColoredTilingPattern Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfColoredTilingPattern Class

The following tables list the members exposed by PdfColoredTilingPattern.

Public Constructors
 | Name | Description
Public Constructor | PdfColoredTilingPattern Constructor | Initializes a new PdfColoredTilingPattern object.
Top
Public Properties
 | Name | Description
Public Property | Graphics | Gets the pattern graphics. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Height | Gets the pattern height. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Matrix | Gets or sets the pattern matrix. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Width | Gets the pattern width. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | XStep | Gets the x step. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | YStep | Gets the y step. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Top
See Also

Reference

PdfColoredTilingPattern Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfColoredTilingPattern Constructor

Xfinium.Pdf.Graphics Namespace > PdfColoredTilingPattern Class : PdfColoredTilingPattern Constructor
The width of the pattern cell.
The height of the pattern cell.
Initializes a new PdfColoredTilingPattern object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New PdfColoredTilingPattern(width, height)
public PdfColoredTilingPattern(
   double width,
   double height
)
public:
PdfColoredTilingPattern(
   double width,
   double height
)

Parameters

width
The width of the pattern cell.
height
The height of the pattern cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColoredTilingPattern Class
PdfColoredTilingPattern Members


%%PageItemTitle%%

PdfColorMask Class
Members

Xfinium.Pdf.Graphics Namespace : PdfColorMask Class
Defines a color mask.
Object Model
PdfColorMask ClassPdfColor ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfColorMask
   Inherits PdfImageMask
'Usage

Dim instance As PdfColorMask
public class PdfColorMask : PdfImageMask
public ref class PdfColorMask : public PdfImageMask
Remarks
A color mask specifies a range of colors to be masked out.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImageMask
Xfinium.Pdf.Graphics.PdfColorMask

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorMask Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfColorMask Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfColorMask Class

The following tables list the members exposed by PdfColorMask.

Public Constructors
 | Name | Description
Public Constructor | PdfColorMask Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | EndColor | Gets or sets the end of the colors range.
Public Property | StartColor | Gets or sets the start of the colors range.
Top
See Also

Reference

PdfColorMask Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfColorMask Constructor

Xfinium.Pdf.Graphics Namespace > PdfColorMask Class : PdfColorMask Constructor
Overload List
Overload | Description
PdfColorMask Constructor() | Initializes a new PdfColorMask object.
PdfColorMask Constructor(PdfColor,PdfColor) | Initializes a new PdfColorMask object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorMask Class
PdfColorMask Members


%%PageItemTitle%%

PdfColorMask Constructor()

Xfinium.Pdf.Graphics Namespace > PdfColorMask Class > PdfColorMask Constructor : PdfColorMask Constructor()
Initializes a new PdfColorMask object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfColorMask()
public PdfColorMask()
public:
PdfColorMask();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorMask Class
PdfColorMask Members
Overload List


%%PageItemTitle%%

PdfColorMask Constructor(PdfColor,PdfColor)

Xfinium.Pdf.Graphics Namespace > PdfColorMask Class > PdfColorMask Constructor : PdfColorMask Constructor(PdfColor,PdfColor)
The start of the colors range to be masked out.
The start of the colors range to be masked out.
Initializes a new PdfColorMask object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startColor As PdfColor, _
   ByVal endColor As PdfColor _
)
'Usage

Dim startColor As PdfColor
Dim endColor As PdfColor

Dim instance As New PdfColorMask(startColor, endColor)
public PdfColorMask(
   PdfColor startColor,
   PdfColor endColor
)
public:
PdfColorMask(
   PdfColor^ startColor,
   PdfColor^ endColor
)

Parameters

startColor
The start of the colors range to be masked out.
endColor
The start of the colors range to be masked out.
Remarks
Both colors must have the same colorspace that also must match the image's colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorMask Class
PdfColorMask Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfColorMask Class Properties

Xfinium.Pdf.Graphics Namespace : PdfColorMask Class

For a list of all members of this type, see PdfColorMask members.

Public Properties
 | Name | Description
Public Property | EndColor | Gets or sets the end of the colors range.
Public Property | StartColor | Gets or sets the start of the colors range.
Top
See Also

Reference

PdfColorMask Class
Xfinium.Pdf.Graphics Namespace


EndColor Property (PdfColorMask)

Xfinium.Pdf.Graphics Namespace > PdfColorMask Class : EndColor Property
Gets or sets the end of the colors range.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndColor As PdfColor
'Usage

Dim instance As PdfColorMask
Dim value As PdfColor

instance.EndColor = value

value = instance.EndColor
public PdfColor EndColor {get; set;}
public:
property PdfColor^ EndColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A PdfColor that represents the end of the colors range.
Remarks
The StartColor.ColorSpace must match the EndColor.ColorSpace and also the image's ColorSpace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorMask Class
PdfColorMask Members


StartColor Property (PdfColorMask)

Xfinium.Pdf.Graphics Namespace > PdfColorMask Class : StartColor Property
Gets or sets the start of the colors range.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartColor As PdfColor
'Usage

Dim instance As PdfColorMask
Dim value As PdfColor

instance.StartColor = value

value = instance.StartColor
public PdfColor StartColor {get; set;}
public:
property PdfColor^ StartColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

A PdfColor that represents the start of the colors range.
Remarks
The StartColor.ColorSpace must match the EndColor.ColorSpace and also the image's ColorSpace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorMask Class
PdfColorMask Members


%%PageItemTitle%%

PdfColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfColorSpace Class
Defines the base class for PDF colorspaces.
Object Model
PdfColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfColorSpace
'Usage

Dim instance As PdfColorSpace
public class PdfColorSpace
public ref class PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfCalGrayColorSpace
Xfinium.Pdf.Graphics.PdfCalRgbColorSpace
Xfinium.Pdf.Graphics.PdfCmykColorSpace
Xfinium.Pdf.Graphics.PdfDeviceNColorSpace
Xfinium.Pdf.Graphics.PdfGrayColorSpace
Xfinium.Pdf.Graphics.PdfIccColorSpace
Xfinium.Pdf.Graphics.PdfIndexedColorSpace
Xfinium.Pdf.Graphics.PdfLabColorSpace
Xfinium.Pdf.Graphics.PdfPatternColorSpace
Xfinium.Pdf.Graphics.PdfRgbColorSpace
Xfinium.Pdf.Graphics.PdfSeparationColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfColorSpace Class

The following tables list the members exposed by PdfColorSpace.

Public Properties
 | Name | Description
Public Property | ColorComponentCount | Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object.
Public Property | Type | Gets the colorspace type.
Top
See Also

Reference

PdfColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfColorSpace Class

For a list of all members of this type, see PdfColorSpace members.

Public Properties
 | Name | Description
Public Property | ColorComponentCount | Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object.
Public Property | Type | Gets the colorspace type.
Top
See Also

Reference

PdfColorSpace Class
Xfinium.Pdf.Graphics Namespace


ColorComponentCount Property (PdfColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public virtual int ColorComponentCount {get;}
public:
virtual property int ColorComponentCount {
   int get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorSpace Class
PdfColorSpace Members


CosObject Property

Xfinium.Pdf.Graphics Namespace > PdfColorSpace Class : CosObject Property
Gets the raw colorspace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosObject As PdfCosObject
'Usage

Dim instance As PdfColorSpace
Dim value As PdfCosObject

value = instance.CosObject
public PdfCosObject CosObject {get;}
public:
property PdfCosObject^ CosObject {
   PdfCosObject^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorSpace Class
PdfColorSpace Members


Type Property (PdfColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfColorSpace Class : Type Property
Gets the colorspace type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Type As PdfColorSpaceType
'Usage

Dim instance As PdfColorSpace
Dim value As PdfColorSpaceType

value = instance.Type
public PdfColorSpaceType Type {get;}
public:
property PdfColorSpaceType Type {
   PdfColorSpaceType get();
}

Property Value

A PdfColorSpaceType that represents the colorspace type.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfColorSpace Class
PdfColorSpace Members


%%PageItemTitle%%

PdfContentStream Class
Members

Xfinium.Pdf.Graphics Namespace : PdfContentStream Class
Defines a low level graphics interface for drawing content on PDF pages.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfContentStream
'Usage

Dim instance As PdfContentStream
public class PdfContentStream
public ref class PdfContentStream
Remarks
The methods in this class match the PDF operators defined in the PDF specification.
A PdfContentStream object is created from a PdfGraphics object and lets you inject specific PDF operators in the PdfGraphics object, operators that are not available through the public API.
This class gives you full control over the generated page content but it requires good knowledge of PDF specification.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfContentStream

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfContentStream Class Members
Methods

Xfinium.Pdf.Graphics Namespace : PdfContentStream Class

The following tables list the members exposed by PdfContentStream.

Public Constructors
 | Name | Description
Public Constructor | PdfContentStream Constructor | Initializes a new PdfContentStream object.
Top
Public Methods
 | Name | Description
Public Method | AddOperator | Adds the given operator to the content stream.
Public Method | BeginCompatibilitySection | Begins a compatibility section. Operator: BX.
Public Method | BeginInlineImage | Begins an inline image. Operator: BI.
Public Method | BeginInlineImageData | Begins the data section of an inline image. Operator: ID.
Public Method | BeginMarkedContent | Begins a marked-content sequence.
Public Method | BeginMarkedContentWithPropertyList | Begins a marked-content sequence with an associated property list.
Public Method | BeginText | Begins a text section. Operator: BT.
Public Method | CCurveTo | Append a cubic Bézier curve to the current path. Operator: c
Public Method | Clear | Clears the entire content stream.
Public Method | CloseAndStrokePath | Closes and strokes the current path. Operator: s.
Public Method | CloseFillNonZeroStroke | Closes the current path, fills the path using the fillMode and then strokes the path. Operator: b for PdfFillMode.NonZeroWinding or b* for PdfFillMode.EvenOdd.
Public Method | CloseSubpath | Closes the current path. Operator: h.
Public Method | ConcatenateMatrix | Concatenates the given matrix with the current transformation matrix. Operator: cm
Public Method | DefineMarkedContentPoint | Defines a marked-content point.
Public Method | DefineMarkedContentPointWithPropertyList | Defines a marked-content point with an associated property list.
Public Method | EndCompatibilitySection | Ends a compatibility section. Operator: EX.
Public Method | EndInlineImage | Ends an inline image. Operator: EI.
Public Method | EndMarkedContent | Ends a marked content section. Operator: EMC.
Public Method | EndPath | Ends the current path. Operator: n.
Public Method | EndText | Ends a text section. Operator: ET.
Public Method | FillNonZeroStroke | Fills the current path using the fillMode and then strokes the path. Operator: B for PdfFillMode.NonZeroWinding or B* for PdfFillMode.EvenOdd.
Public Method | FillPath | Fills the current path using the fillMode. Operator: f for PdfFillMode.NonZeroWinding or f* for PdfFillMode.EvenOdd.
Public Method | LineTo | Appends a line segment to current path from current point to (x, y). Operator: l
Public Method | MoveTextPosition | Moves the text position. Operator: Td
Public Method | MoveTextPositionAndSetLeading | Moves the text position. Operator: TD
Public Method | MoveTo | Begins a new subpath at (x, y). Operator: m
Public Method | MoveToStartOfNextTextLine | Moves to the start of the next line. Operator: T*
Public Method | Rectangle | Appends a rectangle to current path. Operator: re
Public Method | ResetPdfCoordinateSystem | Resets the coordinate system to default PDF coordinate system.
Public Method | RestoreGraphicsState | Restores the current graphics state. Operator: Q.
Public Method | RestoreVisualCoordinateSystem | Restores the coordinate system as it has been setup initially by PdfGraphics class.
Public Method | SaveGraphicsState | Saves the current graphics state. Operator: q.
Public Method | SetCharacterSpacing | Sets the character spacing. Operator: Tc
Public Method | SetClipPath | Sets the current path as clipping path. Operator: W for PdfFillMode.NonZeroWinding or W* for PdfFillMode.EvenOdd.
Public Method | SetCmykFillColor | Sets the current colorspace for fill operations to DeviceCMYK and sets the current CMYK color. Operator: k
Public Method | SetCmykStrokeColor | Sets the current colorspace for stroke operations to DeviceCMYK and sets the current CMYK color. Operator: K
Public Method | SetExtendedGraphicsState | Sets the current graphics state in the content stream. Operator: gs
Public Method | SetFillColor | Sets the current fill color. Operator: sc
Public Method | SetFillColorN | Overloaded. Sets the current fill color. Operator: scn
Public Method | SetFillColorSpace | Sets the fill colorspace. Operator: cs
Public Method | SetFlatnessTolerance | Set the flatness tolerance in the graphics state. Operator: i
Public Method | SetGrayFillColor | Sets the current colorspace for fill operations to DeviceGray and sets the gray level. Operator: g
Public Method | SetGrayStrokeColor | Sets the current colorspace for stroke operations to DeviceGray and sets the gray level. Operator: g
Public Method | SetLineCap | Set the line cap style in the graphics state. Operator: J
Public Method | SetLineDashPattern | Sets the dash offset and pattern for stroke operations. Operator: d
Public Method | SetLineJoin | Set the line join style in the graphics state. Operator: j
Public Method | SetLineWidth | Sets the line width in the graphics state.
Public Method | SetMiterLimit | Set the miter limit in the graphics state. Operator: M
Public Method | SetRgbFillColor | Sets the current colorspace for fill operations to DeviceRGB and sets the current RGB color. Operator: rg
Public Method | SetRgbStrokeColor | Sets the current colorspace for stroke operations to DeviceRGB and sets the current RGB color. Operator: RG
Public Method | SetStrokeColor | Sets the current stroke color. Operator: SC
Public Method | SetStrokeColorN | Overloaded. Sets the current stroke color. Operator: SCN
Public Method | SetStrokeColorSpace | Sets the stroke colorspace. Operator: CS
Public Method | SetTextFontAndSize | Sets the current font and size for text show operators. Operator: Tf
Public Method | SetTextHorizontalScaling | Sets the text horizontal scaling. Operator: Tz
Public Method | SetTextLeading | Sets the text leading. Operator: TL
Public Method | SetTextMatrix | Sets the current text matrix and text line matrix. Operator: Tm
Public Method | SetTextRendering | Sets the text rendering mode. Operator: Tr
Public Method | SetTextRise | Sets the text rise. Operator: Ts
Public Method | SetWordSpacing | Sets the word spacing. Operator: Tw
Public Method | ShowFormXObject | Shows a form XObject on the page. Operator: Do
Public Method | ShowImage | Shows an image on the page. Operator: Do
Public Method | ShowShading | Shows a shading on the page. Operator: sh
Public Method | ShowText | Shows the specified text on the page. Operator: Tj
Public Method | ShowTextArray | Shows one or more text strings, allowing individual glyph positioning.
Public Method | StrokePath | Strokes the current path. Operator: S.
Public Method | VCurveTo | Append a cubic Bézier curve to the current path. Operator: v
Public Method | WriteByte | Writes the specified byte to the content stream.
Public Method | WriteBytes | Overloaded. Writes the specified bytes to the content stream.
Public Method | YCurveTo | Append a cubic Bézier curve to the current path. Operator: y
Top
See Also

Reference

PdfContentStream Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfContentStream Constructor

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : PdfContentStream Constructor
The PdfGraphics object associated with the content stream.
Initializes a new PdfContentStream object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal graphics As PdfGraphics _
)
'Usage

Dim graphics As PdfGraphics

Dim instance As New PdfContentStream(graphics)
public PdfContentStream(
   PdfGraphics graphics
)
public:
PdfContentStream(
   PdfGraphics^ graphics
)

Parameters

graphics
The PdfGraphics object associated with the content stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


%%PageItemTitle%% $$Methods$$

PdfContentStream Class Methods

Xfinium.Pdf.Graphics Namespace : PdfContentStream Class

For a list of all members of this type, see PdfContentStream members.

Public Methods
 | Name | Description
Public Method | AddOperator | Adds the given operator to the content stream.
Public Method | BeginCompatibilitySection | Begins a compatibility section. Operator: BX.
Public Method | BeginInlineImage | Begins an inline image. Operator: BI.
Public Method | BeginInlineImageData | Begins the data section of an inline image. Operator: ID.
Public Method | BeginMarkedContent | Begins a marked-content sequence.
Public Method | BeginMarkedContentWithPropertyList | Begins a marked-content sequence with an associated property list.
Public Method | BeginText | Begins a text section. Operator: BT.
Public Method | CCurveTo | Append a cubic Bézier curve to the current path. Operator: c
Public Method | Clear | Clears the entire content stream.
Public Method | CloseAndStrokePath | Closes and strokes the current path. Operator: s.
Public Method | CloseFillNonZeroStroke | Closes the current path, fills the path using the fillMode and then strokes the path. Operator: b for PdfFillMode.NonZeroWinding or b* for PdfFillMode.EvenOdd.
Public Method | CloseSubpath | Closes the current path. Operator: h.
Public Method | ConcatenateMatrix | Concatenates the given matrix with the current transformation matrix. Operator: cm
Public Method | DefineMarkedContentPoint | Defines a marked-content point.
Public Method | DefineMarkedContentPointWithPropertyList | Defines a marked-content point with an associated property list.
Public Method | EndCompatibilitySection | Ends a compatibility section. Operator: EX.
Public Method | EndInlineImage | Ends an inline image. Operator: EI.
Public Method | EndMarkedContent | Ends a marked content section. Operator: EMC.
Public Method | EndPath | Ends the current path. Operator: n.
Public Method | EndText | Ends a text section. Operator: ET.
Public Method | FillNonZeroStroke | Fills the current path using the fillMode and then strokes the path. Operator: B for PdfFillMode.NonZeroWinding or B* for PdfFillMode.EvenOdd.
Public Method | FillPath | Fills the current path using the fillMode. Operator: f for PdfFillMode.NonZeroWinding or f* for PdfFillMode.EvenOdd.
Public Method | LineTo | Appends a line segment to current path from current point to (x, y). Operator: l
Public Method | MoveTextPosition | Moves the text position. Operator: Td
Public Method | MoveTextPositionAndSetLeading | Moves the text position. Operator: TD
Public Method | MoveTo | Begins a new subpath at (x, y). Operator: m
Public Method | MoveToStartOfNextTextLine | Moves to the start of the next line. Operator: T*
Public Method | Rectangle | Appends a rectangle to current path. Operator: re
Public Method | ResetPdfCoordinateSystem | Resets the coordinate system to default PDF coordinate system.
Public Method | RestoreGraphicsState | Restores the current graphics state. Operator: Q.
Public Method | RestoreVisualCoordinateSystem | Restores the coordinate system as it has been setup initially by PdfGraphics class.
Public Method | SaveGraphicsState | Saves the current graphics state. Operator: q.
Public Method | SetCharacterSpacing | Sets the character spacing. Operator: Tc
Public Method | SetClipPath | Sets the current path as clipping path. Operator: W for PdfFillMode.NonZeroWinding or W* for PdfFillMode.EvenOdd.
Public Method | SetCmykFillColor | Sets the current colorspace for fill operations to DeviceCMYK and sets the current CMYK color. Operator: k
Public Method | SetCmykStrokeColor | Sets the current colorspace for stroke operations to DeviceCMYK and sets the current CMYK color. Operator: K
Public Method | SetExtendedGraphicsState | Sets the current graphics state in the content stream. Operator: gs
Public Method | SetFillColor | Sets the current fill color. Operator: sc
Public Method | SetFillColorN | Overloaded. Sets the current fill color. Operator: scn
Public Method | SetFillColorSpace | Sets the fill colorspace. Operator: cs
Public Method | SetFlatnessTolerance | Set the flatness tolerance in the graphics state. Operator: i
Public Method | SetGrayFillColor | Sets the current colorspace for fill operations to DeviceGray and sets the gray level. Operator: g
Public Method | SetGrayStrokeColor | Sets the current colorspace for stroke operations to DeviceGray and sets the gray level. Operator: g
Public Method | SetLineCap | Set the line cap style in the graphics state. Operator: J
Public Method | SetLineDashPattern | Sets the dash offset and pattern for stroke operations. Operator: d
Public Method | SetLineJoin | Set the line join style in the graphics state. Operator: j
Public Method | SetLineWidth | Sets the line width in the graphics state.
Public Method | SetMiterLimit | Set the miter limit in the graphics state. Operator: M
Public Method | SetRgbFillColor | Sets the current colorspace for fill operations to DeviceRGB and sets the current RGB color. Operator: rg
Public Method | SetRgbStrokeColor | Sets the current colorspace for stroke operations to DeviceRGB and sets the current RGB color. Operator: RG
Public Method | SetStrokeColor | Sets the current stroke color. Operator: SC
Public Method | SetStrokeColorN | Overloaded. Sets the current stroke color. Operator: SCN
Public Method | SetStrokeColorSpace | Sets the stroke colorspace. Operator: CS
Public Method | SetTextFontAndSize | Sets the current font and size for text show operators. Operator: Tf
Public Method | SetTextHorizontalScaling | Sets the text horizontal scaling. Operator: Tz
Public Method | SetTextLeading | Sets the text leading. Operator: TL
Public Method | SetTextMatrix | Sets the current text matrix and text line matrix. Operator: Tm
Public Method | SetTextRendering | Sets the text rendering mode. Operator: Tr
Public Method | SetTextRise | Sets the text rise. Operator: Ts
Public Method | SetWordSpacing | Sets the word spacing. Operator: Tw
Public Method | ShowFormXObject | Shows a form XObject on the page. Operator: Do
Public Method | ShowImage | Shows an image on the page. Operator: Do
Public Method | ShowShading | Shows a shading on the page. Operator: sh
Public Method | ShowText | Shows the specified text on the page. Operator: Tj
Public Method | ShowTextArray | Shows one or more text strings, allowing individual glyph positioning.
Public Method | StrokePath | Strokes the current path. Operator: S.
Public Method | VCurveTo | Append a cubic Bézier curve to the current path. Operator: v
Public Method | WriteByte | Writes the specified byte to the content stream.
Public Method | WriteBytes | Overloaded. Writes the specified bytes to the content stream.
Public Method | YCurveTo | Append a cubic Bézier curve to the current path. Operator: y
Top
See Also

Reference

PdfContentStream Class
Xfinium.Pdf.Graphics Namespace


AddOperator Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : AddOperator Method
Operator to add to the content stream.
Adds the given operator to the content stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddOperator( _
   ByVal op As PdfContentStreamOperator _
)
'Usage

Dim instance As PdfContentStream
Dim op As PdfContentStreamOperator

instance.AddOperator(op)
public void AddOperator(
   PdfContentStreamOperator op
)
public:
void AddOperator(
   PdfContentStreamOperator^ op
)

Parameters

op
Operator to add to the content stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


BeginCompatibilitySection Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : BeginCompatibilitySection Method
Begins a compatibility section.
Operator: BX.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BeginCompatibilitySection()
'Usage

Dim instance As PdfContentStream

instance.BeginCompatibilitySection()
public void BeginCompatibilitySection()
public:
void BeginCompatibilitySection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


BeginInlineImage Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : BeginInlineImage Method
Begins an inline image.
Operator: BI.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BeginInlineImage()
'Usage

Dim instance As PdfContentStream

instance.BeginInlineImage()
public void BeginInlineImage()
public:
void BeginInlineImage();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


BeginInlineImageData Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : BeginInlineImageData Method
Begins the data section of an inline image.
Operator: ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BeginInlineImageData()
'Usage

Dim instance As PdfContentStream

instance.BeginInlineImageData()
public void BeginInlineImageData()
public:
void BeginInlineImageData();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


BeginMarkedContent Method (PdfContentStream)

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : BeginMarkedContent Method
A name object indicating the role or significance of the sequence.
Begins a marked-content sequence.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BeginMarkedContent( _
   ByVal tag As PdfCosName _
)
'Usage

Dim instance As PdfContentStream
Dim tag As PdfCosName

instance.BeginMarkedContent(tag)
public void BeginMarkedContent(
   PdfCosName tag
)
public:
void BeginMarkedContent(
   PdfCosName^ tag
)

Parameters

tag
A name object indicating the role or significance of the sequence.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


BeginMarkedContentWithPropertyList Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : BeginMarkedContentWithPropertyList Method
A name object indicating the role or significance of the sequence.
Either an inline dictionary containing the property list or a name object associated with it in the Properties subdictionary of the current resource dictionary
Begins a marked-content sequence with an associated property list.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BeginMarkedContentWithPropertyList( _
   ByVal tag As PdfCosName, _
   ByVal properties As PdfCosObject _
)
'Usage

Dim instance As PdfContentStream
Dim tag As PdfCosName
Dim properties As PdfCosObject

instance.BeginMarkedContentWithPropertyList(tag, properties)
public void BeginMarkedContentWithPropertyList(
   PdfCosName tag,
   PdfCosObject properties
)
public:
void BeginMarkedContentWithPropertyList(
   PdfCosName^ tag,
   PdfCosObject^ properties
)

Parameters

tag
A name object indicating the role or significance of the sequence.
properties
Either an inline dictionary containing the property list or a name object associated with it in the Properties subdictionary of the current resource dictionary
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


BeginText Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : BeginText Method
Begins a text section.
Operator: BT.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BeginText()
'Usage

Dim instance As PdfContentStream

instance.BeginText()
public void BeginText()
public:
void BeginText();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


CCurveTo Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : CCurveTo Method
X coordinate of the first control point.
Y coordinate of the first control point.
X coordinate of the second control point.
Y coordinate of the second control point.
X coordinate of the third control point.
Y coordinate of the third control point.
Append a cubic Bézier curve to the current path.
Operator: c
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub CCurveTo( _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
'Usage

Dim instance As PdfContentStream
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double

instance.CCurveTo(x1, y1, x2, y2, x3, y3)
public void CCurveTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)
public:
void CCurveTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)

Parameters

x1
X coordinate of the first control point.
y1
Y coordinate of the first control point.
x2
X coordinate of the second control point.
y2
Y coordinate of the second control point.
x3
X coordinate of the third control point.
y3
Y coordinate of the third control point.
Remarks
The curve extends from the current point to the point (x3, y3), using the (x1, y1) and (x2, y2) as the Bézier control points. The new current point is (x3, y3).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


Clear Method (PdfContentStream)

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : Clear Method
Clears the entire content stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As PdfContentStream

instance.Clear()
public void Clear()
public:
void Clear();
Remarks
This method clears the graphic content stream including any markers inserted by XFINIUM.PDF library that are required by the graphics API. After this method has been called only the methods in this class should be used to build the graphic content. Using the API in the PdfGraphics class will lead to undefined results.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


CloseAndStrokePath Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : CloseAndStrokePath Method
Closes and strokes the current path.
Operator: s.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub CloseAndStrokePath()
'Usage

Dim instance As PdfContentStream

instance.CloseAndStrokePath()
public void CloseAndStrokePath()
public:
void CloseAndStrokePath();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


CloseFillNonZeroStroke Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : CloseFillNonZeroStroke Method
Path fill style.
Closes the current path, fills the path using the fillMode and then strokes the path.
Operator: b for PdfFillMode.NonZeroWinding or b* for PdfFillMode.EvenOdd.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub CloseFillNonZeroStroke( _
   ByVal fillMode As PdfFillMode _
)
'Usage

Dim instance As PdfContentStream
Dim fillMode As PdfFillMode

instance.CloseFillNonZeroStroke(fillMode)
public void CloseFillNonZeroStroke(
   PdfFillMode fillMode
)
public:
void CloseFillNonZeroStroke(
   PdfFillMode fillMode
)

Parameters

fillMode
Path fill style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


CloseSubpath Method (PdfContentStream)

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : CloseSubpath Method
Closes the current path.
Operator: h.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub CloseSubpath()
'Usage

Dim instance As PdfContentStream

instance.CloseSubpath()
public void CloseSubpath()
public:
void CloseSubpath();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


ConcatenateMatrix Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : ConcatenateMatrix Method
First matrix element.
Second matrix element.
Third matrix element.
Fourth matrix element.
Fifth matrix element.
Sixth matrix element.
Concatenates the given matrix with the current transformation matrix.
Operator: cm
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ConcatenateMatrix( _
   ByVal a As Double, _
   ByVal b As Double, _
   ByVal c As Double, _
   ByVal d As Double, _
   ByVal e As Double, _
   ByVal f As Double _
)
'Usage

Dim instance As PdfContentStream
Dim a As Double
Dim b As Double
Dim c As Double
Dim d As Double
Dim e As Double
Dim f As Double

instance.ConcatenateMatrix(a, b, c, d, e, f)
public void ConcatenateMatrix(
   double a,
   double b,
   double c,
   double d,
   double e,
   double f
)
public:
void ConcatenateMatrix(
   double a,
   double b,
   double c,
   double d,
   double e,
   double f
)

Parameters

a
First matrix element.
b
Second matrix element.
c
Third matrix element.
d
Fourth matrix element.
e
Fifth matrix element.
f
Sixth matrix element.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


DefineMarkedContentPoint Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : DefineMarkedContentPoint Method
A name object indicating the role or significance of the point.
Defines a marked-content point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub DefineMarkedContentPoint( _
   ByVal tag As PdfCosName _
)
'Usage

Dim instance As PdfContentStream
Dim tag As PdfCosName

instance.DefineMarkedContentPoint(tag)
public void DefineMarkedContentPoint(
   PdfCosName tag
)
public:
void DefineMarkedContentPoint(
   PdfCosName^ tag
)

Parameters

tag
A name object indicating the role or significance of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


DefineMarkedContentPointWithPropertyList Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : DefineMarkedContentPointWithPropertyList Method
A name object indicating the role or significance of the point.
Either an inline dictionary containing the property list or a name object associated with it in the Properties subdictionary of the current resource dictionary
Defines a marked-content point with an associated property list.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub DefineMarkedContentPointWithPropertyList( _
   ByVal tag As PdfCosName, _
   ByVal properties As PdfCosObject _
)
'Usage

Dim instance As PdfContentStream
Dim tag As PdfCosName
Dim properties As PdfCosObject

instance.DefineMarkedContentPointWithPropertyList(tag, properties)
public void DefineMarkedContentPointWithPropertyList(
   PdfCosName tag,
   PdfCosObject properties
)
public:
void DefineMarkedContentPointWithPropertyList(
   PdfCosName^ tag,
   PdfCosObject^ properties
)

Parameters

tag
A name object indicating the role or significance of the point.
properties
Either an inline dictionary containing the property list or a name object associated with it in the Properties subdictionary of the current resource dictionary
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


EndCompatibilitySection Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : EndCompatibilitySection Method
Ends a compatibility section.
Operator: EX.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub EndCompatibilitySection()
'Usage

Dim instance As PdfContentStream

instance.EndCompatibilitySection()
public void EndCompatibilitySection()
public:
void EndCompatibilitySection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


EndInlineImage Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : EndInlineImage Method
Ends an inline image.
Operator: EI.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub EndInlineImage()
'Usage

Dim instance As PdfContentStream

instance.EndInlineImage()
public void EndInlineImage()
public:
void EndInlineImage();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


EndMarkedContent Method (PdfContentStream)

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : EndMarkedContent Method
Ends a marked content section.
Operator: EMC.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub EndMarkedContent()
'Usage

Dim instance As PdfContentStream

instance.EndMarkedContent()
public void EndMarkedContent()
public:
void EndMarkedContent();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


EndPath Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : EndPath Method
Ends the current path.
Operator: n.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub EndPath()
'Usage

Dim instance As PdfContentStream

instance.EndPath()
public void EndPath()
public:
void EndPath();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


EndText Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : EndText Method
Ends a text section.
Operator: ET.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub EndText()
'Usage

Dim instance As PdfContentStream

instance.EndText()
public void EndText()
public:
void EndText();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


FillNonZeroStroke Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : FillNonZeroStroke Method
Path fill style.
Fills the current path using the fillMode and then strokes the path.
Operator: B for PdfFillMode.NonZeroWinding or B* for PdfFillMode.EvenOdd.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub FillNonZeroStroke( _
   ByVal fillMode As PdfFillMode _
)
'Usage

Dim instance As PdfContentStream
Dim fillMode As PdfFillMode

instance.FillNonZeroStroke(fillMode)
public void FillNonZeroStroke(
   PdfFillMode fillMode
)
public:
void FillNonZeroStroke(
   PdfFillMode fillMode
)

Parameters

fillMode
Path fill style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


FillPath Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : FillPath Method
Path fill style.
Fills the current path using the fillMode.
Operator: f for PdfFillMode.NonZeroWinding or f* for PdfFillMode.EvenOdd.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub FillPath( _
   ByVal fillMode As PdfFillMode _
)
'Usage

Dim instance As PdfContentStream
Dim fillMode As PdfFillMode

instance.FillPath(fillMode)
public void FillPath(
   PdfFillMode fillMode
)
public:
void FillPath(
   PdfFillMode fillMode
)

Parameters

fillMode
Path fill style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


LineTo Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : LineTo Method
X coordinate of line end.
Y coordinate of line end.
Appends a line segment to current path from current point to (x, y).
Operator: l
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub LineTo( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PdfContentStream
Dim x As Double
Dim y As Double

instance.LineTo(x, y)
public void LineTo(
   double x,
   double y
)
public:
void LineTo(
   double x,
   double y
)

Parameters

x
X coordinate of line end.
y
Y coordinate of line end.
Remarks
The (x, y) becomes the current point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


MoveTextPosition Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : MoveTextPosition Method
X offset.
Y offset.
Moves the text position.
Operator: Td
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub MoveTextPosition( _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim instance As PdfContentStream
Dim tx As Double
Dim ty As Double

instance.MoveTextPosition(tx, ty)
public void MoveTextPosition(
   double tx,
   double ty
)
public:
void MoveTextPosition(
   double tx,
   double ty
)

Parameters

tx
X offset.
ty
Y offset.
Remarks
Moves to the start of the next line, offset from the start of the current line by (tx, ty).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


MoveTextPositionAndSetLeading Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : MoveTextPositionAndSetLeading Method
X offset.
Y offset.
Moves the text position.
Operator: TD
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub MoveTextPositionAndSetLeading( _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim instance As PdfContentStream
Dim tx As Double
Dim ty As Double

instance.MoveTextPositionAndSetLeading(tx, ty)
public void MoveTextPositionAndSetLeading(
   double tx,
   double ty
)
public:
void MoveTextPositionAndSetLeading(
   double tx,
   double ty
)

Parameters

tx
X offset.
ty
Y offset.
Remarks
Moves to the start of the next line, offset from the start of the current line by (tx, ty). Also sets the text leading to ty.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


MoveTo Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : MoveTo Method
X coordinate of path start.
Y coordinate of path start.
Begins a new subpath at (x, y).
Operator: m
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub MoveTo( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PdfContentStream
Dim x As Double
Dim y As Double

instance.MoveTo(x, y)
public void MoveTo(
   double x,
   double y
)
public:
void MoveTo(
   double x,
   double y
)

Parameters

x
X coordinate of path start.
y
Y coordinate of path start.
Remarks
The (x, y) becomes the current point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


MoveToStartOfNextTextLine Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : MoveToStartOfNextTextLine Method
Moves to the start of the next line.
Operator: T*
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub MoveToStartOfNextTextLine()
'Usage

Dim instance As PdfContentStream

instance.MoveToStartOfNextTextLine()
public void MoveToStartOfNextTextLine()
public:
void MoveToStartOfNextTextLine();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


Rectangle Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : Rectangle Method
X coordinate of the rectangle's bottom left corner.
Y coordinate of the rectangle's bottom left corner.
The rectangle width.
The rectangle height.
Appends a rectangle to current path.
Operator: re
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Rectangle( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfContentStream
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.Rectangle(x, y, width, height)
public void Rectangle(
   double x,
   double y,
   double width,
   double height
)
public:
void Rectangle(
   double x,
   double y,
   double width,
   double height
)

Parameters

x
X coordinate of the rectangle's bottom left corner.
y
Y coordinate of the rectangle's bottom left corner.
width
The rectangle width.
height
The rectangle height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


ResetPdfCoordinateSystem Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : ResetPdfCoordinateSystem Method
Resets the coordinate system to default PDF coordinate system.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ResetPdfCoordinateSystem()
'Usage

Dim instance As PdfContentStream

instance.ResetPdfCoordinateSystem()
public void ResetPdfCoordinateSystem()
public:
void ResetPdfCoordinateSystem();
Remarks
The PDF coordinate system is located in the bottom left corner of the page, the X axis grows from left to right, the Y axis grow from bottom to top.
The call to this method must be paired with a call to RestoreVisualCoordinateSystem.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


RestoreGraphicsState Method (PdfContentStream)

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : RestoreGraphicsState Method
Restores the current graphics state.
Operator: Q.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RestoreGraphicsState()
'Usage

Dim instance As PdfContentStream

instance.RestoreGraphicsState()
public void RestoreGraphicsState()
public:
void RestoreGraphicsState();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


RestoreVisualCoordinateSystem Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : RestoreVisualCoordinateSystem Method
Restores the coordinate system as it has been setup initially by PdfGraphics class.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RestoreVisualCoordinateSystem()
'Usage

Dim instance As PdfContentStream

instance.RestoreVisualCoordinateSystem()
public void RestoreVisualCoordinateSystem()
public:
void RestoreVisualCoordinateSystem();
Remarks
The visual coordinate system is located in the top left corner of the page, the X axis grows from left to right, the Y axis grow from top to bottom.
This method must be called only if ResetPdfCoordinateSystem or Clear methods have been called before.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SaveGraphicsState Method (PdfContentStream)

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SaveGraphicsState Method
Saves the current graphics state.
Operator: q.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SaveGraphicsState()
'Usage

Dim instance As PdfContentStream

instance.SaveGraphicsState()
public void SaveGraphicsState()
public:
void SaveGraphicsState();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetCharacterSpacing Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetCharacterSpacing Method
The character spacing expressed in unscaled text space units.
Sets the character spacing.
Operator: Tc
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetCharacterSpacing( _
   ByVal characterSpacing As Double _
)
'Usage

Dim instance As PdfContentStream
Dim characterSpacing As Double

instance.SetCharacterSpacing(characterSpacing)
public void SetCharacterSpacing(
   double characterSpacing
)
public:
void SetCharacterSpacing(
   double characterSpacing
)

Parameters

characterSpacing
The character spacing expressed in unscaled text space units.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetClipPath Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetClipPath Method
Path fill style.
Sets the current path as clipping path.
Operator: W for PdfFillMode.NonZeroWinding or W* for PdfFillMode.EvenOdd.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetClipPath( _
   ByVal fillMode As PdfFillMode _
)
'Usage

Dim instance As PdfContentStream
Dim fillMode As PdfFillMode

instance.SetClipPath(fillMode)
public void SetClipPath(
   PdfFillMode fillMode
)
public:
void SetClipPath(
   PdfFillMode fillMode
)

Parameters

fillMode
Path fill style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetCmykFillColor Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetCmykFillColor Method
Cyan level.
Magenta level
Yellow level
Black level
Sets the current colorspace for fill operations to DeviceCMYK and sets the current CMYK color.
Operator: k
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetCmykFillColor( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
'Usage

Dim instance As PdfContentStream
Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

instance.SetCmykFillColor(c, m, y, k)
public void SetCmykFillColor(
   double c,
   double m,
   double y,
   double k
)
public:
void SetCmykFillColor(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
Cyan level.
m
Magenta level
y
Yellow level
k
Black level
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetCmykStrokeColor Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetCmykStrokeColor Method
Cyan level.
Magenta level
Yellow level
Black level
Sets the current colorspace for stroke operations to DeviceCMYK and sets the current CMYK color.
Operator: K
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetCmykStrokeColor( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
'Usage

Dim instance As PdfContentStream
Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

instance.SetCmykStrokeColor(c, m, y, k)
public void SetCmykStrokeColor(
   double c,
   double m,
   double y,
   double k
)
public:
void SetCmykStrokeColor(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
Cyan level.
m
Magenta level
y
Yellow level
k
Black level
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetExtendedGraphicsState Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetExtendedGraphicsState Method
The new graphics state.
Sets the current graphics state in the content stream.
Operator: gs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetExtendedGraphicsState( _
   ByVal gs As PdfExtendedGraphicState _
)
'Usage

Dim instance As PdfContentStream
Dim gs As PdfExtendedGraphicState

instance.SetExtendedGraphicsState(gs)
public void SetExtendedGraphicsState(
   PdfExtendedGraphicState gs
)
public:
void SetExtendedGraphicsState(
   PdfExtendedGraphicState^ gs
)

Parameters

gs
The new graphics state.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetFillColor Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetFillColor Method
The color components.
Sets the current fill color.
Operator: sc
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetFillColor( _
   ByVal color() As Double _
)
'Usage

Dim instance As PdfContentStream
Dim color() As Double

instance.SetFillColor(color)
public void SetFillColor(
   double[] color
)
public:
void SetFillColor(
   array<double>^ color
)

Parameters

color
The color components.
Remarks
The number of color components in the array must match the number of color components expected by the active colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetFillColorN Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetFillColorN Method
Sets the current fill color.
Operator: scn
Overload List
Overload | Description
SetFillColorN(Double[]) | Sets the current fill color. Operator: scn
SetFillColorN(PdfPattern) | Sets the current fill color. Operator: scn
SetFillColorN(Double[],PdfPattern) | Sets the current fill color and pattern. Operator: scn
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetFillColorN(Double[]) Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class > SetFillColorN Method : SetFillColorN(Double[]) Method
The color components.
Sets the current fill color.
Operator: scn
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetFillColorN( _
   ByVal color() As Double _
)
'Usage

Dim instance As PdfContentStream
Dim color() As Double

instance.SetFillColorN(color)
public void SetFillColorN(
   double[] color
)
public:
void SetFillColorN(
   array<double>^ color
)

Parameters

color
The color components.
Remarks
The number of color components in the array must match the number of color components expected by the active colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members
Overload List


SetFillColorN(PdfPattern) Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class > SetFillColorN Method : SetFillColorN(PdfPattern) Method
The pattern used as fill color.
Sets the current fill color.
Operator: scn
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetFillColorN( _
   ByVal pattern As PdfPattern _
)
'Usage

Dim instance As PdfContentStream
Dim pattern As PdfPattern

instance.SetFillColorN(pattern)
public void SetFillColorN(
   PdfPattern pattern
)
public:
void SetFillColorN(
   PdfPattern^ pattern
)

Parameters

pattern
The pattern used as fill color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members
Overload List


SetFillColorN(Double[],PdfPattern) Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class > SetFillColorN Method : SetFillColorN(Double[],PdfPattern) Method
The color components.
The pattern used as fill color.
Sets the current fill color and pattern.
Operator: scn
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetFillColorN( _
   ByVal color() As Double, _
   ByVal pattern As PdfPattern _
)
'Usage

Dim instance As PdfContentStream
Dim color() As Double
Dim pattern As PdfPattern

instance.SetFillColorN(color, pattern)
public void SetFillColorN(
   double[] color,
   PdfPattern pattern
)
public:
void SetFillColorN(
   array<double>^ color,
   PdfPattern^ pattern
)

Parameters

color
The color components.
pattern
The pattern used as fill color.
Remarks
The number of color components in the array must match the number of color components expected by the active colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members
Overload List


SetFillColorSpace Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetFillColorSpace Method
The active colorspace used for fill operations
Sets the fill colorspace.
Operator: cs
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetFillColorSpace( _
   ByVal colorSpace As PdfColorSpace _
)
'Usage

Dim instance As PdfContentStream
Dim colorSpace As PdfColorSpace

instance.SetFillColorSpace(colorSpace)
public void SetFillColorSpace(
   PdfColorSpace colorSpace
)
public:
void SetFillColorSpace(
   PdfColorSpace^ colorSpace
)

Parameters

colorSpace
The active colorspace used for fill operations
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetFlatnessTolerance Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetFlatnessTolerance Method
The flatness tolerance.
Set the flatness tolerance in the graphics state.
Operator: i
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetFlatnessTolerance( _
   ByVal flatness As Double _
)
'Usage

Dim instance As PdfContentStream
Dim flatness As Double

instance.SetFlatnessTolerance(flatness)
public void SetFlatnessTolerance(
   double flatness
)
public:
void SetFlatnessTolerance(
   double flatness
)

Parameters

flatness
The flatness tolerance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetGrayFillColor Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetGrayFillColor Method
The gray level.
Sets the current colorspace for fill operations to DeviceGray and sets the gray level.
Operator: g
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetGrayFillColor( _
   ByVal g As Double _
)
'Usage

Dim instance As PdfContentStream
Dim g As Double

instance.SetGrayFillColor(g)
public void SetGrayFillColor(
   double g
)
public:
void SetGrayFillColor(
   double g
)

Parameters

g
The gray level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetGrayStrokeColor Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetGrayStrokeColor Method
The gray level.
Sets the current colorspace for stroke operations to DeviceGray and sets the gray level.
Operator: g
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetGrayStrokeColor( _
   ByVal g As Double _
)
'Usage

Dim instance As PdfContentStream
Dim g As Double

instance.SetGrayStrokeColor(g)
public void SetGrayStrokeColor(
   double g
)
public:
void SetGrayStrokeColor(
   double g
)

Parameters

g
The gray level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetLineCap Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetLineCap Method
The line cap style.
Set the line cap style in the graphics state.
Operator: J
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetLineCap( _
   ByVal lineCap As PdfLineCap _
)
'Usage

Dim instance As PdfContentStream
Dim lineCap As PdfLineCap

instance.SetLineCap(lineCap)
public void SetLineCap(
   PdfLineCap lineCap
)
public:
void SetLineCap(
   PdfLineCap lineCap
)

Parameters

lineCap
The line cap style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetLineDashPattern Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetLineDashPattern Method
Dash phase.
Dash pattern.
Sets the dash offset and pattern for stroke operations.
Operator: d
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetLineDashPattern( _
   ByVal dashPhase As Double, _
   ByVal dashPattern() As Double _
)
'Usage

Dim instance As PdfContentStream
Dim dashPhase As Double
Dim dashPattern() As Double

instance.SetLineDashPattern(dashPhase, dashPattern)
public void SetLineDashPattern(
   double dashPhase,
   double[] dashPattern
)
public:
void SetLineDashPattern(
   double dashPhase,
   array<double>^ dashPattern
)

Parameters

dashPhase
Dash phase.
dashPattern
Dash pattern.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetLineJoin Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetLineJoin Method
The line join style.
Set the line join style in the graphics state.
Operator: j
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetLineJoin( _
   ByVal lineJoin As PdfLineJoin _
)
'Usage

Dim instance As PdfContentStream
Dim lineJoin As PdfLineJoin

instance.SetLineJoin(lineJoin)
public void SetLineJoin(
   PdfLineJoin lineJoin
)
public:
void SetLineJoin(
   PdfLineJoin lineJoin
)

Parameters

lineJoin
The line join style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetLineWidth Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetLineWidth Method
The line width
Sets the line width in the graphics state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetLineWidth( _
   ByVal lineWidth As Double _
)
'Usage

Dim instance As PdfContentStream
Dim lineWidth As Double

instance.SetLineWidth(lineWidth)
public void SetLineWidth(
   double lineWidth
)
public:
void SetLineWidth(
   double lineWidth
)

Parameters

lineWidth
The line width
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetMiterLimit Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetMiterLimit Method
The miter limit.
Set the miter limit in the graphics state.
Operator: M
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetMiterLimit( _
   ByVal miterLimit As Double _
)
'Usage

Dim instance As PdfContentStream
Dim miterLimit As Double

instance.SetMiterLimit(miterLimit)
public void SetMiterLimit(
   double miterLimit
)
public:
void SetMiterLimit(
   double miterLimit
)

Parameters

miterLimit
The miter limit.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetRgbFillColor Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetRgbFillColor Method
Red level.
Green level
Blue level
Sets the current colorspace for fill operations to DeviceRGB and sets the current RGB color.
Operator: rg
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetRgbFillColor( _
   ByVal r As Double, _
   ByVal g As Double, _
   ByVal b As Double _
)
'Usage

Dim instance As PdfContentStream
Dim r As Double
Dim g As Double
Dim b As Double

instance.SetRgbFillColor(r, g, b)
public void SetRgbFillColor(
   double r,
   double g,
   double b
)
public:
void SetRgbFillColor(
   double r,
   double g,
   double b
)

Parameters

r
Red level.
g
Green level
b
Blue level
Remarks
The r, g, b values are in (0, 1) range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetRgbStrokeColor Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetRgbStrokeColor Method
Red level.
Green level
Blue level
Sets the current colorspace for stroke operations to DeviceRGB and sets the current RGB color.
Operator: RG
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetRgbStrokeColor( _
   ByVal r As Double, _
   ByVal g As Double, _
   ByVal b As Double _
)
'Usage

Dim instance As PdfContentStream
Dim r As Double
Dim g As Double
Dim b As Double

instance.SetRgbStrokeColor(r, g, b)
public void SetRgbStrokeColor(
   double r,
   double g,
   double b
)
public:
void SetRgbStrokeColor(
   double r,
   double g,
   double b
)

Parameters

r
Red level.
g
Green level
b
Blue level
Remarks
The r, g, b values are in (0, 1) range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetStrokeColor Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetStrokeColor Method
The color components.
Sets the current stroke color.
Operator: SC
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetStrokeColor( _
   ByVal color() As Double _
)
'Usage

Dim instance As PdfContentStream
Dim color() As Double

instance.SetStrokeColor(color)
public void SetStrokeColor(
   double[] color
)
public:
void SetStrokeColor(
   array<double>^ color
)

Parameters

color
The color components.
Remarks
The number of color components in the array must match the number of color components expected by the active colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetStrokeColorN Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetStrokeColorN Method
Sets the current stroke color.
Operator: SCN
Overload List
Overload | Description
SetStrokeColorN(Double[]) | Sets the current stroke color. Operator: SCN
SetStrokeColorN(PdfPattern) | Sets the current stroke color. Operator: scn
SetStrokeColorN(Double[],PdfPattern) | Sets the current stroke color and pattern. Operator: SCN
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetStrokeColorN(Double[]) Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class > SetStrokeColorN Method : SetStrokeColorN(Double[]) Method
The color components.
Sets the current stroke color.
Operator: SCN
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetStrokeColorN( _
   ByVal color() As Double _
)
'Usage

Dim instance As PdfContentStream
Dim color() As Double

instance.SetStrokeColorN(color)
public void SetStrokeColorN(
   double[] color
)
public:
void SetStrokeColorN(
   array<double>^ color
)

Parameters

color
The color components.
Remarks
The number of color components in the array must match the number of color components expected by the active colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members
Overload List


SetStrokeColorN(PdfPattern) Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class > SetStrokeColorN Method : SetStrokeColorN(PdfPattern) Method
The pattern used as stroke color.
Sets the current stroke color.
Operator: scn
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetStrokeColorN( _
   ByVal pattern As PdfPattern _
)
'Usage

Dim instance As PdfContentStream
Dim pattern As PdfPattern

instance.SetStrokeColorN(pattern)
public void SetStrokeColorN(
   PdfPattern pattern
)
public:
void SetStrokeColorN(
   PdfPattern^ pattern
)

Parameters

pattern
The pattern used as stroke color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members
Overload List


SetStrokeColorN(Double[],PdfPattern) Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class > SetStrokeColorN Method : SetStrokeColorN(Double[],PdfPattern) Method
The color components.
The pattern used as fill color.
Sets the current stroke color and pattern.
Operator: SCN
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetStrokeColorN( _
   ByVal color() As Double, _
   ByVal pattern As PdfPattern _
)
'Usage

Dim instance As PdfContentStream
Dim color() As Double
Dim pattern As PdfPattern

instance.SetStrokeColorN(color, pattern)
public void SetStrokeColorN(
   double[] color,
   PdfPattern pattern
)
public:
void SetStrokeColorN(
   array<double>^ color,
   PdfPattern^ pattern
)

Parameters

color
The color components.
pattern
The pattern used as fill color.
Remarks
The number of color components in the array must match the number of color components expected by the active colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members
Overload List


SetStrokeColorSpace Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetStrokeColorSpace Method
The active colorspace used for stroke operations
Sets the stroke colorspace.
Operator: CS
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetStrokeColorSpace( _
   ByVal colorSpace As PdfColorSpace _
)
'Usage

Dim instance As PdfContentStream
Dim colorSpace As PdfColorSpace

instance.SetStrokeColorSpace(colorSpace)
public void SetStrokeColorSpace(
   PdfColorSpace colorSpace
)
public:
void SetStrokeColorSpace(
   PdfColorSpace^ colorSpace
)

Parameters

colorSpace
The active colorspace used for stroke operations
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetTextFontAndSize Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetTextFontAndSize Method
Current font.
Current font size.
Sets the current font and size for text show operators.
Operator: Tf
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetTextFontAndSize( _
   ByVal font As PdfFont, _
   ByVal size As Double _
)
'Usage

Dim instance As PdfContentStream
Dim font As PdfFont
Dim size As Double

instance.SetTextFontAndSize(font, size)
public void SetTextFontAndSize(
   PdfFont font,
   double size
)
public:
void SetTextFontAndSize(
   PdfFont^ font,
   double size
)

Parameters

font
Current font.
size
Current font size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetTextHorizontalScaling Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetTextHorizontalScaling Method
Horizontal scaling specified as a percentage of normal width.
Sets the text horizontal scaling.
Operator: Tz
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetTextHorizontalScaling( _
   ByVal horizontalScaling As Double _
)
'Usage

Dim instance As PdfContentStream
Dim horizontalScaling As Double

instance.SetTextHorizontalScaling(horizontalScaling)
public void SetTextHorizontalScaling(
   double horizontalScaling
)
public:
void SetTextHorizontalScaling(
   double horizontalScaling
)

Parameters

horizontalScaling
Horizontal scaling specified as a percentage of normal width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetTextLeading Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetTextLeading Method
The text leading expressed in unscaled text space units.
Sets the text leading.
Operator: TL
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetTextLeading( _
   ByVal textLeading As Double _
)
'Usage

Dim instance As PdfContentStream
Dim textLeading As Double

instance.SetTextLeading(textLeading)
public void SetTextLeading(
   double textLeading
)
public:
void SetTextLeading(
   double textLeading
)

Parameters

textLeading
The text leading expressed in unscaled text space units.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetTextMatrix Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetTextMatrix Method
First matrix element.
Second matrix element.
Third matrix element.
Fourth matrix element.
Fifth matrix element.
Sixth matrix element.
Sets the current text matrix and text line matrix.
Operator: Tm
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetTextMatrix( _
   ByVal a As Double, _
   ByVal b As Double, _
   ByVal c As Double, _
   ByVal d As Double, _
   ByVal e As Double, _
   ByVal f As Double _
)
'Usage

Dim instance As PdfContentStream
Dim a As Double
Dim b As Double
Dim c As Double
Dim d As Double
Dim e As Double
Dim f As Double

instance.SetTextMatrix(a, b, c, d, e, f)
public void SetTextMatrix(
   double a,
   double b,
   double c,
   double d,
   double e,
   double f
)
public:
void SetTextMatrix(
   double a,
   double b,
   double c,
   double d,
   double e,
   double f
)

Parameters

a
First matrix element.
b
Second matrix element.
c
Third matrix element.
d
Fourth matrix element.
e
Fifth matrix element.
f
Sixth matrix element.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetTextRendering Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetTextRendering Method
Text rendering mode.
Sets the text rendering mode.
Operator: Tr
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetTextRendering( _
   ByVal textRenderingMode As PdfTextRenderingMode _
)
'Usage

Dim instance As PdfContentStream
Dim textRenderingMode As PdfTextRenderingMode

instance.SetTextRendering(textRenderingMode)
public void SetTextRendering(
   PdfTextRenderingMode textRenderingMode
)
public:
void SetTextRendering(
   PdfTextRenderingMode textRenderingMode
)

Parameters

textRenderingMode
Text rendering mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetTextRise Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetTextRise Method
The text rise expressed in unscaled text space units.
Sets the text rise.
Operator: Ts
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetTextRise( _
   ByVal textRise As Double _
)
'Usage

Dim instance As PdfContentStream
Dim textRise As Double

instance.SetTextRise(textRise)
public void SetTextRise(
   double textRise
)
public:
void SetTextRise(
   double textRise
)

Parameters

textRise
The text rise expressed in unscaled text space units.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


SetWordSpacing Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : SetWordSpacing Method
The word spacing expressed in unscaled text space units.
Sets the word spacing.
Operator: Tw
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetWordSpacing( _
   ByVal wordSpacing As Double _
)
'Usage

Dim instance As PdfContentStream
Dim wordSpacing As Double

instance.SetWordSpacing(wordSpacing)
public void SetWordSpacing(
   double wordSpacing
)
public:
void SetWordSpacing(
   double wordSpacing
)

Parameters

wordSpacing
The word spacing expressed in unscaled text space units.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


ShowFormXObject Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : ShowFormXObject Method
Form XObject to display.
Shows a form XObject on the page.
Operator: Do
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ShowFormXObject( _
   ByVal xObject As PdfFormXObject _
)
'Usage

Dim instance As PdfContentStream
Dim xObject As PdfFormXObject

instance.ShowFormXObject(xObject)
public void ShowFormXObject(
   PdfFormXObject xObject
)
public:
void ShowFormXObject(
   PdfFormXObject^ xObject
)

Parameters

xObject
Form XObject to display.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


ShowImage Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : ShowImage Method
Image to display.
Shows an image on the page.
Operator: Do
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ShowImage( _
   ByVal image As PdfImage _
)
'Usage

Dim instance As PdfContentStream
Dim image As PdfImage

instance.ShowImage(image)
public void ShowImage(
   PdfImage image
)
public:
void ShowImage(
   PdfImage^ image
)

Parameters

image
Image to display.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


ShowShading Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : ShowShading Method
Shading to display.
Shows a shading on the page.
Operator: sh
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ShowShading( _
   ByVal sh As PdfShading _
)
'Usage

Dim instance As PdfContentStream
Dim sh As PdfShading

instance.ShowShading(sh)
public void ShowShading(
   PdfShading sh
)
public:
void ShowShading(
   PdfShading^ sh
)

Parameters

sh
Shading to display.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


ShowText Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : ShowText Method
Text to show on the page.
Shows the specified text on the page.
Operator: Tj
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ShowText( _
   ByVal text As PdfCosBinaryString _
)
'Usage

Dim instance As PdfContentStream
Dim text As PdfCosBinaryString

instance.ShowText(text)
public void ShowText(
   PdfCosBinaryString text
)
public:
void ShowText(
   PdfCosBinaryString^ text
)

Parameters

text
Text to show on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


ShowTextArray Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : ShowTextArray Method
Array of text strings.
Shows one or more text strings, allowing individual glyph positioning.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ShowTextArray( _
   ByVal textArray As PdfCosArray _
)
'Usage

Dim instance As PdfContentStream
Dim textArray As PdfCosArray

instance.ShowTextArray(textArray)
public void ShowTextArray(
   PdfCosArray textArray
)
public:
void ShowTextArray(
   PdfCosArray^ textArray
)

Parameters

textArray
Array of text strings.
Remarks
Each element of textArray can be a string or a number. If the element is a string, this operator shows the string. If it is a number, the operator adjusts the text position by that amount.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


StrokePath Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : StrokePath Method
Strokes the current path.
Operator: S.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub StrokePath()
'Usage

Dim instance As PdfContentStream

instance.StrokePath()
public void StrokePath()
public:
void StrokePath();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


VCurveTo Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : VCurveTo Method
X coordinate of second control point.
Y coordinate of second control point.
X coordinate of curve end point.
Y coordinate of curve end point.
Append a cubic Bézier curve to the current path.
Operator: v
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub VCurveTo( _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
'Usage

Dim instance As PdfContentStream
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double

instance.VCurveTo(x2, y2, x3, y3)
public void VCurveTo(
   double x2,
   double y2,
   double x3,
   double y3
)
public:
void VCurveTo(
   double x2,
   double y2,
   double x3,
   double y3
)

Parameters

x2
X coordinate of second control point.
y2
Y coordinate of second control point.
x3
X coordinate of curve end point.
y3
Y coordinate of curve end point.
Remarks
The curve extends from the current point to the point (x3, y3), using the current point and (x2, y2) as the Bézier control points. The new current point is (x3, y3).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


WriteByte Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : WriteByte Method
Byte to write.
Writes the specified byte to the content stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub WriteByte( _
   ByVal b As Byte _
)
'Usage

Dim instance As PdfContentStream
Dim b As Byte

instance.WriteByte(b)
public void WriteByte(
   byte b
)
public:
void WriteByte(
   byte b
)

Parameters

b
Byte to write.
Remarks
This method is usefull to create new lines in the content stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


WriteBytes Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : WriteBytes Method
Writes the specified bytes to the content stream.
Overload List
Overload | Description
WriteBytes(Byte[]) | Writes the specified bytes to the content stream.
WriteBytes(Byte[],Int32,Int32) | Writes the specified bytes to the content stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


WriteBytes(Byte[]) Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class > WriteBytes Method : WriteBytes(Byte[]) Method
Bytes to write.
Writes the specified bytes to the content stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub WriteBytes( _
   ByVal buffer() As Byte _
)
'Usage

Dim instance As PdfContentStream
Dim buffer() As Byte

instance.WriteBytes(buffer)
public void WriteBytes(
   byte[] buffer
)
public:
void WriteBytes(
   array<byte>^ buffer
)

Parameters

buffer
Bytes to write.
Remarks
This method is usefull to write the data of an inline image to the content stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members
Overload List


WriteBytes(Byte[],Int32,Int32) Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class > WriteBytes Method : WriteBytes(Byte[],Int32,Int32) Method
Bytes to write.
Offset in the buffer were the bytes to write start.
Number of bytes to write.
Writes the specified bytes to the content stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub WriteBytes( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
'Usage

Dim instance As PdfContentStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.WriteBytes(buffer, offset, count)
public void WriteBytes(
   byte[] buffer,
   int offset,
   int count
)
public:
void WriteBytes(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
Bytes to write.
offset
Offset in the buffer were the bytes to write start.
count
Number of bytes to write.
Remarks
This method is usefull to write the data of an inline image to the content stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members
Overload List


YCurveTo Method

Xfinium.Pdf.Graphics Namespace > PdfContentStream Class : YCurveTo Method
X coordinate of first control point.
Y coordinate of first control point.
X coordinate of curve end point.
Y coordinate of curve end point.
Append a cubic Bézier curve to the current path.
Operator: y
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub YCurveTo( _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
'Usage

Dim instance As PdfContentStream
Dim x1 As Double
Dim y1 As Double
Dim x3 As Double
Dim y3 As Double

instance.YCurveTo(x1, y1, x3, y3)
public void YCurveTo(
   double x1,
   double y1,
   double x3,
   double y3
)
public:
void YCurveTo(
   double x1,
   double y1,
   double x3,
   double y3
)

Parameters

x1
X coordinate of first control point.
y1
Y coordinate of first control point.
x3
X coordinate of curve end point.
y3
Y coordinate of curve end point.
Remarks
The curve extends from the current point to the point (x3, y3), using (x1, y1) and (x3, y3) as the Bézier control points. The new current point is (x3, y3).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStream Class
PdfContentStream Members


%%PageItemTitle%%

PdfCoop25Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfCoop25Barcode Class
Defines a COOP 2 of 5 barcode.
Object Model
PdfCoop25Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCoop25Barcode
   Inherits PdfCode25Barcode
'Usage

Dim instance As PdfCoop25Barcode
public class PdfCoop25Barcode : PdfCode25Barcode
public ref class PdfCoop25Barcode : public PdfCode25Barcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfCoop25Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCoop25Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfCoop25Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfCoop25Barcode Class

The following tables list the members exposed by PdfCoop25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfCoop25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCoop25Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCoop25Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfCoop25Barcode Class : PdfCoop25Barcode Constructor
Overload List
Overload | Description
PdfCoop25Barcode Constructor() | Initializes a new PdfCoop25Barcode object.
PdfCoop25Barcode Constructor(String) | Initializes a new PdfCoop25Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCoop25Barcode Class
PdfCoop25Barcode Members


%%PageItemTitle%%

PdfCoop25Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfCoop25Barcode Class > PdfCoop25Barcode Constructor : PdfCoop25Barcode Constructor()
Initializes a new PdfCoop25Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCoop25Barcode()
public PdfCoop25Barcode()
public:
PdfCoop25Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCoop25Barcode Class
PdfCoop25Barcode Members
Overload List


%%PageItemTitle%%

PdfCoop25Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfCoop25Barcode Class > PdfCoop25Barcode Constructor : PdfCoop25Barcode Constructor(String)
The barcode data.
Initializes a new PdfCoop25Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfCoop25Barcode(data)
public PdfCoop25Barcode(
   string data
)
public:
PdfCoop25Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCoop25Barcode Class
PdfCoop25Barcode Members
Overload List


%%PageItemTitle%%

PdfDataMatrixBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfDataMatrixBarcode Class
Defines a DataMatrix barcode.
Object Model
PdfDataMatrixBarcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDataMatrixBarcode
   Inherits Pdf2DBarcode
'Usage

Dim instance As PdfDataMatrixBarcode
public class PdfDataMatrixBarcode : Pdf2DBarcode
public ref class PdfDataMatrixBarcode : public Pdf2DBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.PdfDataMatrixBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDataMatrixBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfDataMatrixBarcode Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfDataMatrixBarcode Class

The following tables list the members exposed by PdfDataMatrixBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfDataMatrixBarcode Constructor | Initializes a new PdfDataMatrixBarcode object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeSize | Gets or sets the barcode size.
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | DataEncoding | Gets or sets the data encoding.
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
Public Methods
 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top
See Also

Reference

PdfDataMatrixBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfDataMatrixBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfDataMatrixBarcode Class : PdfDataMatrixBarcode Constructor
Initializes a new PdfDataMatrixBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDataMatrixBarcode()
public PdfDataMatrixBarcode()
public:
PdfDataMatrixBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDataMatrixBarcode Class
PdfDataMatrixBarcode Members


%%PageItemTitle%% $$Methods$$

PdfDataMatrixBarcode Class Methods

Xfinium.Pdf.Graphics Namespace : PdfDataMatrixBarcode Class

For a list of all members of this type, see PdfDataMatrixBarcode members.

Public Methods
 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top
See Also

Reference

PdfDataMatrixBarcode Class
Xfinium.Pdf.Graphics Namespace


Randomize253State Method

Xfinium.Pdf.Graphics Namespace > PdfDataMatrixBarcode Class : Randomize253State Method
The padding codeword, usually 129.
The position of the padding codeword (0 based index).
Applies the 253-state randomizing algorithm on padding values.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Randomize253State( _
   ByVal padCodeword As Integer, _
   ByVal position As Integer _
) As Byte
'Usage

Dim instance As PdfDataMatrixBarcode
Dim padCodeword As Integer
Dim position As Integer
Dim value As Byte

value = instance.Randomize253State(padCodeword, position)
public byte Randomize253State(
   int padCodeword,
   int position
)
public:
byte Randomize253State(
   int padCodeword,
   int position
)

Parameters

padCodeword
The padding codeword, usually 129.
position
The position of the padding codeword (0 based index).

Return Value

The randomized value.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDataMatrixBarcode Class
PdfDataMatrixBarcode Members


%%PageItemTitle%% $$Properties$$

PdfDataMatrixBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfDataMatrixBarcode Class

For a list of all members of this type, see PdfDataMatrixBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeSize | Gets or sets the barcode size.
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | DataEncoding | Gets or sets the data encoding.
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfDataMatrixBarcode Class
Xfinium.Pdf.Graphics Namespace


BarcodeSize Property (PdfDataMatrixBarcode)

Xfinium.Pdf.Graphics Namespace > PdfDataMatrixBarcode Class : BarcodeSize Property
Gets or sets the barcode size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BarcodeSize As DataMatrixBarcodeSize
'Usage

Dim instance As PdfDataMatrixBarcode
Dim value As DataMatrixBarcodeSize

instance.BarcodeSize = value

value = instance.BarcodeSize
public DataMatrixBarcodeSize BarcodeSize {get; set;}
public:
property DataMatrixBarcodeSize BarcodeSize {
   DataMatrixBarcodeSize get();
   void set (    DataMatrixBarcodeSize value);
}

Property Value

A DataMatrixBarcodeSize that represents the barcode size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDataMatrixBarcode Class
PdfDataMatrixBarcode Members


DataEncoding Property

Xfinium.Pdf.Graphics Namespace > PdfDataMatrixBarcode Class : DataEncoding Property
Gets or sets the data encoding.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DataEncoding As DataMatrixEncoding
'Usage

Dim instance As PdfDataMatrixBarcode
Dim value As DataMatrixEncoding

instance.DataEncoding = value

value = instance.DataEncoding
public DataMatrixEncoding DataEncoding {get; set;}
public:
property DataMatrixEncoding DataEncoding {
   DataMatrixEncoding get();
   void set (    DataMatrixEncoding value);
}

Property Value

A DataMatrixEncoding that specifies how that data is encoded in the barcode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDataMatrixBarcode Class
PdfDataMatrixBarcode Members


%%PageItemTitle%%

PdfDeviceNAttributes Class
Members

Xfinium.Pdf.Graphics Namespace : PdfDeviceNAttributes Class
Defines the attributes of a PdfDeviceNColorSpace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDeviceNAttributes
'Usage

Dim instance As PdfDeviceNAttributes
public class PdfDeviceNAttributes
public ref class PdfDeviceNAttributes
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfDeviceNAttributes

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNAttributes Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfDeviceNAttributes Class Members

Xfinium.Pdf.Graphics Namespace : PdfDeviceNAttributes Class

The following tables list the members exposed by PdfDeviceNAttributes.

Public Constructors
 | Name | Description
Public Constructor | PdfDeviceNAttributes Constructor | Initilizes a new PdfDeviceNAttributes object.
Top
See Also

Reference

PdfDeviceNAttributes Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfDeviceNAttributes Constructor

Xfinium.Pdf.Graphics Namespace > PdfDeviceNAttributes Class : PdfDeviceNAttributes Constructor
Initilizes a new PdfDeviceNAttributes object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDeviceNAttributes()
public PdfDeviceNAttributes()
public:
PdfDeviceNAttributes();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNAttributes Class
PdfDeviceNAttributes Members


%%PageItemTitle%%

PdfDeviceNColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColor Class
Defines a DeviceN color based on a DeviceN colorspace.
Object Model
PdfDeviceNColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDeviceNColor
   Inherits PdfColor
'Usage

Dim instance As PdfDeviceNColor
public class PdfDeviceNColor : PdfColor
public ref class PdfDeviceNColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfDeviceNColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfDeviceNColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColor Class

The following tables list the members exposed by PdfDeviceNColor.

Public Constructors
 | Name | Description
Public Constructor | PdfDeviceNColor Constructor | Initializes a new PdfDeviceNColor object with a DeviceN colorspace.
Top
Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfDeviceNColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfDeviceNColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColor Class : PdfDeviceNColor Constructor
A DeviceN colorspace.
Initializes a new PdfDeviceNColor object with a DeviceN colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PdfDeviceNColorSpace _
)
'Usage

Dim colorSpace As PdfDeviceNColorSpace

Dim instance As New PdfDeviceNColor(colorSpace)
public PdfDeviceNColor(
   PdfDeviceNColorSpace colorSpace
)
public:
PdfDeviceNColor(
   PdfDeviceNColorSpace^ colorSpace
)

Parameters

colorSpace
A DeviceN colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColor Class
PdfDeviceNColor Members


%%PageItemTitle%% $$Methods$$

PdfDeviceNColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColor Class

For a list of all members of this type, see PdfDeviceNColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfDeviceNColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfDeviceNColor)

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfDeviceNColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColor Class
PdfDeviceNColor Members


Equals Method (PdfDeviceNColor)

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfDeviceNColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColor Class
PdfDeviceNColor Members


GetHashCode Method (PdfDeviceNColor)

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfDeviceNColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColor Class
PdfDeviceNColor Members


%%PageItemTitle%% $$Properties$$

PdfDeviceNColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColor Class

For a list of all members of this type, see PdfDeviceNColor members.

Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfDeviceNColor Class
Xfinium.Pdf.Graphics Namespace


ColorComponents Property (PdfDeviceNColor)

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColor Class : ColorComponents Property
Gets or sets the color components.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows Property ColorComponents As Double()
'Usage

Dim instance As PdfDeviceNColor
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
public new double[] ColorComponents {get; set;}
public:
new property array<double>^ ColorComponents {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of numbers, one for each color component.
Remarks
The number of color components must be equal to the number of PdfDeviceNColorSpace.ColorantNames that are defined on the DeviceN colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColor Class
PdfDeviceNColor Members


%%PageItemTitle%%

PdfDeviceNColorantNameCollection Class
Members

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColorantNameCollection Class
Defines a collection of DeviceN colorant names.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDeviceNColorantNameCollection
   Inherits System.Collections.ObjectModel.Collection(Of String)
'Usage

Dim instance As PdfDeviceNColorantNameCollection
public class PdfDeviceNColorantNameCollection : System.Collections.ObjectModel.Collection<string>
public ref class PdfDeviceNColorantNameCollection : public System.Collections.ObjectModel.Collection<String>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.PdfDeviceNColorantNameCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorantNameCollection Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfDeviceNColorantNameCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColorantNameCollection Class

The following tables list the members exposed by PdfDeviceNColorantNameCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<string>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<string>)
Top
See Also

Reference

PdfDeviceNColorantNameCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfDeviceNColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColorSpace Class
Defines a DeviceN colorspace.
Object Model
PdfDeviceNColorSpace ClassPdfColorSpace ClassPdfDeviceNAttributes ClassPdfDeviceNColorantNameCollection ClassPdfCosObject ClassPdfFunction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDeviceNColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfDeviceNColorSpace
public class PdfDeviceNColorSpace : PdfColorSpace
public ref class PdfDeviceNColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfDeviceNColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfDeviceNColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColorSpace Class

The following tables list the members exposed by PdfDeviceNColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfDeviceNColorSpace Constructor | Initializes a new PdfDeviceNColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Attributes | Gets the colorspace attributes.
Public Property | ColorantNames | Gets the collection of colorant names.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | TintTransform | Gets or sets the tint transform.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfDeviceNColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfDeviceNColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColorSpace Class : PdfDeviceNColorSpace Constructor
Initializes a new PdfDeviceNColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDeviceNColorSpace()
public PdfDeviceNColorSpace()
public:
PdfDeviceNColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorSpace Class
PdfDeviceNColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfDeviceNColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColorSpace Class

For a list of all members of this type, see PdfDeviceNColorSpace members.

Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Attributes | Gets the colorspace attributes.
Public Property | ColorantNames | Gets the collection of colorant names.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | TintTransform | Gets or sets the tint transform.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfDeviceNColorSpace Class
Xfinium.Pdf.Graphics Namespace


AlternateColorSpace Property (PdfDeviceNColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColorSpace Class : AlternateColorSpace Property
Gets or sets the alternate colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AlternateColorSpace As PdfColorSpace
'Usage

Dim instance As PdfDeviceNColorSpace
Dim value As PdfColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
public PdfColorSpace AlternateColorSpace {get; set;}
public:
property PdfColorSpace^ AlternateColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

The alternate color space that is used when one or more of the colorants are not supported by the destination device.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorSpace Class
PdfDeviceNColorSpace Members


Attributes Property (PdfDeviceNColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColorSpace Class : Attributes Property
Gets the colorspace attributes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Attributes As PdfDeviceNAttributes
'Usage

Dim instance As PdfDeviceNColorSpace
Dim value As PdfDeviceNAttributes

instance.Attributes = value

value = instance.Attributes
public PdfDeviceNAttributes Attributes {get; set;}
public:
property PdfDeviceNAttributes^ Attributes {
   PdfDeviceNAttributes^ get();
   void set (    PdfDeviceNAttributes^ value);
}

Property Value

The colorspace attributes.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorSpace Class
PdfDeviceNColorSpace Members


ColorantNames Property

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColorSpace Class : ColorantNames Property
Gets the collection of colorant names.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ColorantNames As PdfDeviceNColorantNameCollection
'Usage

Dim instance As PdfDeviceNColorSpace
Dim value As PdfDeviceNColorantNameCollection

value = instance.ColorantNames
public PdfDeviceNColorantNameCollection ColorantNames {get;}
public:
property PdfDeviceNColorantNameCollection^ ColorantNames {
   PdfDeviceNColorantNameCollection^ get();
}

Property Value

A list of names specifying the individual color components.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorSpace Class
PdfDeviceNColorSpace Members


ColorComponentCount Property (PdfDeviceNColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfDeviceNColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorSpace Class
PdfDeviceNColorSpace Members


TintTransform Property (PdfDeviceNColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColorSpace Class : TintTransform Property
Gets or sets the tint transform.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TintTransform As PdfFunction
'Usage

Dim instance As PdfDeviceNColorSpace
Dim value As PdfFunction

instance.TintTransform = value

value = instance.TintTransform
public PdfFunction TintTransform {get; set;}
public:
property PdfFunction^ TintTransform {
   PdfFunction^ get();
   void set (    PdfFunction^ value);
}

Property Value

A function that is used to transform the tint values into the alternate color space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorSpace Class
PdfDeviceNColorSpace Members


%%PageItemTitle%%

PdfEan128Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfEan128Barcode Class
Defines an EAN 128 barcode.
Object Model
PdfEan128Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfEan128Barcode
   Inherits PdfCode128Barcode
'Usage

Dim instance As PdfEan128Barcode
public class PdfEan128Barcode : PdfCode128Barcode
public ref class PdfEan128Barcode : public PdfCode128Barcode
Remarks
Supported characters: all characters supported by Code 128 barcodes.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfEan128Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan128Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfEan128Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfEan128Barcode Class

The following tables list the members exposed by PdfEan128Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfEan128Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfEan128Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfEan128Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfEan128Barcode Class : PdfEan128Barcode Constructor
Overload List
Overload | Description
PdfEan128Barcode Constructor() | Initializes a new PdfEan128Barcode object.
PdfEan128Barcode Constructor(String) | Initializes a new PdfEan128Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan128Barcode Class
PdfEan128Barcode Members


%%PageItemTitle%%

PdfEan128Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfEan128Barcode Class > PdfEan128Barcode Constructor : PdfEan128Barcode Constructor()
Initializes a new PdfEan128Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfEan128Barcode()
public PdfEan128Barcode()
public:
PdfEan128Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan128Barcode Class
PdfEan128Barcode Members
Overload List


%%PageItemTitle%%

PdfEan128Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfEan128Barcode Class > PdfEan128Barcode Constructor : PdfEan128Barcode Constructor(String)
The barcode data.
Initializes a new PdfEan128Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfEan128Barcode(data)
public PdfEan128Barcode(
   string data
)
public:
PdfEan128Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan128Barcode Class
PdfEan128Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfEan128Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfEan128Barcode Class

For a list of all members of this type, see PdfEan128Barcode members.

Public Properties
 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfEan128Barcode Class
Xfinium.Pdf.Graphics Namespace


ApplicationIdentifier Property

Xfinium.Pdf.Graphics Namespace > PdfEan128Barcode Class : ApplicationIdentifier Property
Gets or sets the application identifier.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ApplicationIdentifier As String
'Usage

Dim instance As PdfEan128Barcode
Dim value As String

instance.ApplicationIdentifier = value

value = instance.ApplicationIdentifier
public string ApplicationIdentifier {get; set;}
public:
property String^ ApplicationIdentifier {
   String^ get();
   void set (    String^ value);
}

Property Value

The application identifier that specifies how the barcode data is interpreted.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan128Barcode Class
PdfEan128Barcode Members


%%PageItemTitle%%

PdfEan13Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfEan13Barcode Class
Defines an EAN 13 barcode.
Object Model
PdfEan13Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfEan13Barcode
   Inherits PdfEanBarcode
'Usage

Dim instance As PdfEan13Barcode
public class PdfEan13Barcode : PdfEanBarcode
public ref class PdfEan13Barcode : public PdfEanBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
. Data length: 12 digits.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfEan13Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan13Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfEan13Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfEan13Barcode Class

The following tables list the members exposed by PdfEan13Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfEan13Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfEan13Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfEan13Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfEan13Barcode Class : PdfEan13Barcode Constructor
Overload List
Overload | Description
PdfEan13Barcode Constructor() | Initializes a new PdfEan13Barcode object.
PdfEan13Barcode Constructor(String) | Initializes a new PdfEan13Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan13Barcode Class
PdfEan13Barcode Members


%%PageItemTitle%%

PdfEan13Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfEan13Barcode Class > PdfEan13Barcode Constructor : PdfEan13Barcode Constructor()
Initializes a new PdfEan13Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfEan13Barcode()
public PdfEan13Barcode()
public:
PdfEan13Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan13Barcode Class
PdfEan13Barcode Members
Overload List


%%PageItemTitle%%

PdfEan13Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfEan13Barcode Class > PdfEan13Barcode Constructor : PdfEan13Barcode Constructor(String)
The barcode data.
Initializes a new PdfEan13Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfEan13Barcode(data)
public PdfEan13Barcode(
   string data
)
public:
PdfEan13Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan13Barcode Class
PdfEan13Barcode Members
Overload List


%%PageItemTitle%%

PdfEan8Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfEan8Barcode Class
Defines an EAN 8 barcode.
Object Model
PdfEan8Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfEan8Barcode
   Inherits PdfEanBarcode
'Usage

Dim instance As PdfEan8Barcode
public class PdfEan8Barcode : PdfEanBarcode
public ref class PdfEan8Barcode : public PdfEanBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
. Data length: 7 digits.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfEan8Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan8Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfEan8Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfEan8Barcode Class

The following tables list the members exposed by PdfEan8Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfEan8Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfEan8Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfEan8Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfEan8Barcode Class : PdfEan8Barcode Constructor
Overload List
Overload | Description
PdfEan8Barcode Constructor() | Initializes a new PdfEan8Barcode object.
PdfEan8Barcode Constructor(String) | Initializes a new PdfEan8Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan8Barcode Class
PdfEan8Barcode Members


%%PageItemTitle%%

PdfEan8Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfEan8Barcode Class > PdfEan8Barcode Constructor : PdfEan8Barcode Constructor()
Initializes a new PdfEan8Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfEan8Barcode()
public PdfEan8Barcode()
public:
PdfEan8Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan8Barcode Class
PdfEan8Barcode Members
Overload List


%%PageItemTitle%%

PdfEan8Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfEan8Barcode Class > PdfEan8Barcode Constructor : PdfEan8Barcode Constructor(String)
The barcode data.
Initializes a new PdfEan8Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfEan8Barcode(data)
public PdfEan8Barcode(
   string data
)
public:
PdfEan8Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEan8Barcode Class
PdfEan8Barcode Members
Overload List


%%PageItemTitle%%

PdfEanBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfEanBarcode Class
Defines an EAN barcode.
Object Model
PdfEanBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfEanBarcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfEanBarcode
public abstract class PdfEanBarcode : Pdf1DBarcode
public ref class PdfEanBarcode abstract : public Pdf1DBarcode
Remarks
EAN based barcodes can encode only numeric data.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfEan13Barcode
Xfinium.Pdf.Graphics.PdfEan8Barcode
Xfinium.Pdf.Graphics.PdfIsbnBarcode
Xfinium.Pdf.Graphics.PdfIsmnBarcode
Xfinium.Pdf.Graphics.PdfIssnBarcode
Xfinium.Pdf.Graphics.PdfJan13Barcode
Xfinium.Pdf.Graphics.PdfUpcaBarcode
Xfinium.Pdf.Graphics.PdfUpceBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEanBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfEanBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfEanBarcode Class

The following tables list the members exposed by PdfEanBarcode.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement.
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text.
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfEanBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfEanBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfEanBarcode Class

For a list of all members of this type, see PdfEanBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement.
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text.
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode.
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfEanBarcode Class
Xfinium.Pdf.Graphics Namespace


Supplement Property

Xfinium.Pdf.Graphics Namespace > PdfEanBarcode Class : Supplement Property
Gets or sets the data supplement.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Supplement As String
'Usage

Dim instance As PdfEanBarcode
Dim value As String

instance.Supplement = value

value = instance.Supplement
public string Supplement {get; set;}
public:
property String^ Supplement {
   String^ get();
   void set (    String^ value);
}

Property Value

2 or 5 digits for data supplement.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEanBarcode Class
PdfEanBarcode Members


SupplementTextPosition Property

Xfinium.Pdf.Graphics Namespace > PdfEanBarcode Class : SupplementTextPosition Property
Gets or sets the position of the supplement text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SupplementTextPosition As PdfBarcodeTextPosition
'Usage

Dim instance As PdfEanBarcode
Dim value As PdfBarcodeTextPosition

instance.SupplementTextPosition = value

value = instance.SupplementTextPosition
public PdfBarcodeTextPosition SupplementTextPosition {get; set;}
public:
property PdfBarcodeTextPosition SupplementTextPosition {
   PdfBarcodeTextPosition get();
   void set (    PdfBarcodeTextPosition value);
}

Property Value

A PdfBarcodeTextPosition that represents the position where the supplement text is displayed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEanBarcode Class
PdfEanBarcode Members


SupplementYDimension Property

Xfinium.Pdf.Graphics Namespace > PdfEanBarcode Class : SupplementYDimension Property
Gets or sets the Y dimension for the supplement barcode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SupplementYDimension As Double
'Usage

Dim instance As PdfEanBarcode
Dim value As Double

instance.SupplementYDimension = value

value = instance.SupplementYDimension
public double SupplementYDimension {get; set;}
public:
property double SupplementYDimension {
   double get();
   void set (    double value);
}

Property Value

The height of a bar in the supplement barcode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfEanBarcode Class
PdfEanBarcode Members


%%PageItemTitle%%

PdfExtendedGraphicState Class
Members

Xfinium.Pdf.Graphics Namespace : PdfExtendedGraphicState Class
Defines the current graphic state in a PDF content stream.
Object Model
PdfExtendedGraphicState ClassPdfCosDictionary Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfExtendedGraphicState
'Usage

Dim instance As PdfExtendedGraphicState
public class PdfExtendedGraphicState
public ref class PdfExtendedGraphicState
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfExtendedGraphicState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfExtendedGraphicState Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfExtendedGraphicState Class

The following tables list the members exposed by PdfExtendedGraphicState.

Public Constructors
 | Name | Description
Public Constructor | PdfExtendedGraphicState Constructor | Initializes a new PdfExtendedGraphicState object.
Top
Public Properties
 | Name | Description
Public Property | BlendMode | Gets or sets the blend mode.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | FillAlpha | Gets or sets the fill alpha.
Public Property | FillOverprint | Gets or sets a flag specifying whether to apply overprint for filling.
Public Property | OverprintMode | Gets or sets the overprint mode.
Public Property | StrokeAlpha | Gets or sets the stroke alpha.
Public Property | StrokeOverprint | Gets or sets a flag specifying whether to apply overprint for stroking.
Top
See Also

Reference

PdfExtendedGraphicState Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfExtendedGraphicState Constructor

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : PdfExtendedGraphicState Constructor
Initializes a new PdfExtendedGraphicState object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfExtendedGraphicState()
public PdfExtendedGraphicState()
public:
PdfExtendedGraphicState();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


%%PageItemTitle%% $$Properties$$

PdfExtendedGraphicState Class Properties

Xfinium.Pdf.Graphics Namespace : PdfExtendedGraphicState Class

For a list of all members of this type, see PdfExtendedGraphicState members.

Public Properties
 | Name | Description
Public Property | BlendMode | Gets or sets the blend mode.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | FillAlpha | Gets or sets the fill alpha.
Public Property | FillOverprint | Gets or sets a flag specifying whether to apply overprint for filling.
Public Property | OverprintMode | Gets or sets the overprint mode.
Public Property | StrokeAlpha | Gets or sets the stroke alpha.
Public Property | StrokeOverprint | Gets or sets a flag specifying whether to apply overprint for stroking.
Top
See Also

Reference

PdfExtendedGraphicState Class
Xfinium.Pdf.Graphics Namespace


BlendMode Property

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : BlendMode Property
Gets or sets the blend mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BlendMode As PdfBlendMode
'Usage

Dim instance As PdfExtendedGraphicState
Dim value As PdfBlendMode

instance.BlendMode = value

value = instance.BlendMode
public PdfBlendMode BlendMode {get; set;}
public:
property PdfBlendMode BlendMode {
   PdfBlendMode get();
   void set (    PdfBlendMode value);
}

Property Value

The current blend mode to be used in the transparent imaging model.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


CosDictionary Property (PdfExtendedGraphicState)

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfExtendedGraphicState
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


FillAlpha Property (PdfExtendedGraphicState)

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : FillAlpha Property
Gets or sets the fill alpha.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FillAlpha As Double
'Usage

Dim instance As PdfExtendedGraphicState
Dim value As Double

instance.FillAlpha = value

value = instance.FillAlpha
public double FillAlpha {get; set;}
public:
property double FillAlpha {
   double get();
   void set (    double value);
}

Property Value

A value between 0 and 1 specifying constant opacity value to be used for filling operations in the transparent imaging model.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


FillOverprint Property

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : FillOverprint Property
Gets or sets a flag specifying whether to apply overprint for filling.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FillOverprint As Boolean
'Usage

Dim instance As PdfExtendedGraphicState
Dim value As Boolean

instance.FillOverprint = value

value = instance.FillOverprint
public bool FillOverprint {get; set;}
public:
property bool FillOverprint {
   bool get();
   void set (    bool value);
}

Property Value

If true, overprint is applied for filling.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


OverprintMode Property

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : OverprintMode Property
Gets or sets the overprint mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OverprintMode As Integer
'Usage

Dim instance As PdfExtendedGraphicState
Dim value As Integer

instance.OverprintMode = value

value = instance.OverprintMode
public int OverprintMode {get; set;}
public:
property int OverprintMode {
   int get();
   void set (    int value);
}

Property Value

0 or 1 specifying the overprint mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


StrokeAlpha Property (PdfExtendedGraphicState)

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : StrokeAlpha Property
Gets or sets the stroke alpha.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StrokeAlpha As Double
'Usage

Dim instance As PdfExtendedGraphicState
Dim value As Double

instance.StrokeAlpha = value

value = instance.StrokeAlpha
public double StrokeAlpha {get; set;}
public:
property double StrokeAlpha {
   double get();
   void set (    double value);
}

Property Value

A value between 0 and 1 specifying constant opacity value to be used for stroking operations in the transparent imaging model.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


StrokeOverprint Property

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : StrokeOverprint Property
Gets or sets a flag specifying whether to apply overprint for stroking.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StrokeOverprint As Boolean
'Usage

Dim instance As PdfExtendedGraphicState
Dim value As Boolean

instance.StrokeOverprint = value

value = instance.StrokeOverprint
public bool StrokeOverprint {get; set;}
public:
property bool StrokeOverprint {
   bool get();
   void set (    bool value);
}

Property Value

If true, overprint is applied for stroking.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


%%PageItemTitle%%

PdfFedExGround96Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfFedExGround96Barcode Class
Defines a FedEx Ground 96 barcode.
Object Model
PdfFedExGround96Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFedExGround96Barcode
   Inherits PdfCode128CBarcode
'Usage

Dim instance As PdfFedExGround96Barcode
public class PdfFedExGround96Barcode : PdfCode128CBarcode
public ref class PdfFedExGround96Barcode : public PdfCode128CBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9.
Data length: 21 digits (first 2 digits must be 96).
FedEx Ground 96 barcode structure:
1 - 2 - Application Identifier (must be 96)
3 - 4 - Two digit "Serial Container Numeric Code" - "11, 12, 13" identifies the carrier as "FedEx Ground".
5 - 7 - Class of Service - Three-digit number used to identify the FedEx Ground class of service.
8 - 14 - FedEx Ground Shipper ID - Seven-digit unique shipper identification number.
15 - 21 - Package Number - Seven-digit package serial number.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128CBarcode
Xfinium.Pdf.Graphics.PdfFedExGround96Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFedExGround96Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfFedExGround96Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfFedExGround96Barcode Class

The following tables list the members exposed by PdfFedExGround96Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfFedExGround96Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfFedExGround96Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfFedExGround96Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfFedExGround96Barcode Class : PdfFedExGround96Barcode Constructor
Overload List
Overload | Description
PdfFedExGround96Barcode Constructor() | Initializes a new PdfFedExGround96Barcode object.
PdfFedExGround96Barcode Constructor(String) | Initializes a new PdfFedExGround96Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFedExGround96Barcode Class
PdfFedExGround96Barcode Members


%%PageItemTitle%%

PdfFedExGround96Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfFedExGround96Barcode Class > PdfFedExGround96Barcode Constructor : PdfFedExGround96Barcode Constructor()
Initializes a new PdfFedExGround96Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFedExGround96Barcode()
public PdfFedExGround96Barcode()
public:
PdfFedExGround96Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFedExGround96Barcode Class
PdfFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PdfFedExGround96Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfFedExGround96Barcode Class > PdfFedExGround96Barcode Constructor : PdfFedExGround96Barcode Constructor(String)
The barcode data.
Initializes a new PdfFedExGround96Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfFedExGround96Barcode(data)
public PdfFedExGround96Barcode(
   string data
)
public:
PdfFedExGround96Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFedExGround96Barcode Class
PdfFedExGround96Barcode Members
Overload List


%%PageItemTitle%%

PdfFont Class
Members

Xfinium.Pdf.Graphics Namespace : PdfFont Class
Defines the base class for PDF fonts.
Object Model
PdfFont ClassPdfFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfFont
'Usage

Dim instance As PdfFont
public abstract class PdfFont
public ref class PdfFont abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFont
Xfinium.Pdf.Graphics.PdfStandardFont
Xfinium.Pdf.Graphics.PdfTrueTypeFont
Xfinium.Pdf.Graphics.PdfType1Font
Xfinium.Pdf.Graphics.PdfType3Font

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfFont Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfFont Class

The following tables list the members exposed by PdfFont.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold.
Public Property | Italic | Gets or sets a value indicating whether the font is italic.
Public Property | Metrics | Gets the font metrics.
Public Property | Size | Gets or sets the font size.
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough.
Public Property | TextRenderingMode | Gets or sets the text rendering mode.
Public Property | Underline | Gets or sets a value indicating whether the font is underlined.
Top
Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding.
Top
See Also

Reference

PdfFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfFont Class Methods

Xfinium.Pdf.Graphics Namespace : PdfFont Class

For a list of all members of this type, see PdfFont members.

Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding.
Top
See Also

Reference

PdfFont Class
Xfinium.Pdf.Graphics Namespace


EncodeString Method (PdfFont)

Xfinium.Pdf.Graphics Namespace > PdfFont Class : EncodeString Method
String to convert.
Encodes the given text to a byte array based on font's encoding.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function EncodeString( _
   ByVal text As String _
) As Byte()
'Usage

Dim instance As PdfFont
Dim text As String
Dim value() As Byte

value = instance.EncodeString(text)
public virtual byte[] EncodeString(
   string text
)
public:
virtual array<byte>^ EncodeString(
   String^ text
)

Parameters

text
String to convert.

Return Value

An array of bytes representing the string according to font encoding.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Class
PdfFont Members


%%PageItemTitle%% $$Properties$$

PdfFont Class Properties

Xfinium.Pdf.Graphics Namespace : PdfFont Class

For a list of all members of this type, see PdfFont members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold.
Public Property | Italic | Gets or sets a value indicating whether the font is italic.
Public Property | Metrics | Gets the font metrics.
Public Property | Size | Gets or sets the font size.
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough.
Public Property | TextRenderingMode | Gets or sets the text rendering mode.
Public Property | Underline | Gets or sets a value indicating whether the font is underlined.
Top
See Also

Reference

PdfFont Class
Xfinium.Pdf.Graphics Namespace


Bold Property (PdfFont)

Xfinium.Pdf.Graphics Namespace > PdfFont Class : Bold Property
Gets or sets a value indicating whether the font is bold.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Bold As Boolean
'Usage

Dim instance As PdfFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public virtual bool Bold {get; set;}
public:
virtual property bool Bold {
   bool get();
   void set (    bool value);
}

Property Value

If true, then the font has a bold appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Class
PdfFont Members


Italic Property (PdfFont)

Xfinium.Pdf.Graphics Namespace > PdfFont Class : Italic Property
Gets or sets a value indicating whether the font is italic.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Italic As Boolean
'Usage

Dim instance As PdfFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public virtual bool Italic {get; set;}
public:
virtual property bool Italic {
   bool get();
   void set (    bool value);
}

Property Value

If true, then the font has an italic appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Class
PdfFont Members


Metrics Property

Xfinium.Pdf.Graphics Namespace > PdfFont Class : Metrics Property
Gets the font metrics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Metrics As PdfFontMetrics
'Usage

Dim instance As PdfFont
Dim value As PdfFontMetrics

value = instance.Metrics
public PdfFontMetrics Metrics {get;}
public:
property PdfFontMetrics^ Metrics {
   PdfFontMetrics^ get();
}

Property Value

A PdfFontMetrics that represents the metrics of the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Class
PdfFont Members


Size Property (PdfFont)

Xfinium.Pdf.Graphics Namespace > PdfFont Class : Size Property
Gets or sets the font size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Size As Double
'Usage

Dim instance As PdfFont
Dim value As Double

instance.Size = value

value = instance.Size
public double Size {get; set;}
public:
property double Size {
   double get();
   void set (    double value);
}

Property Value

The font size in PDF points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Class
PdfFont Members


Strikethrough Property

Xfinium.Pdf.Graphics Namespace > PdfFont Class : Strikethrough Property
Gets or sets a value indicating whether the font is strikethrough.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Strikethrough As Boolean
'Usage

Dim instance As PdfFont
Dim value As Boolean

instance.Strikethrough = value

value = instance.Strikethrough
public bool Strikethrough {get; set;}
public:
property bool Strikethrough {
   bool get();
   void set (    bool value);
}

Property Value

If true, then the font has a strikethrough appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Class
PdfFont Members


TextRenderingMode Property

Xfinium.Pdf.Graphics Namespace > PdfFont Class : TextRenderingMode Property
Gets or sets the text rendering mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextRenderingMode As PdfTextRenderingMode
'Usage

Dim instance As PdfFont
Dim value As PdfTextRenderingMode

instance.TextRenderingMode = value

value = instance.TextRenderingMode
public PdfTextRenderingMode TextRenderingMode {get; set;}
public:
property PdfTextRenderingMode TextRenderingMode {
   PdfTextRenderingMode get();
   void set (    PdfTextRenderingMode value);
}

Property Value

A Xfinium.Pdf.Graphics.Text.PdfTextRenderingMode specifying how the text is rendered using this font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Class
PdfFont Members


Underline Property

Xfinium.Pdf.Graphics Namespace > PdfFont Class : Underline Property
Gets or sets a value indicating whether the font is underlined.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Underline As Boolean
'Usage

Dim instance As PdfFont
Dim value As Boolean

instance.Underline = value

value = instance.Underline
public bool Underline {get; set;}
public:
property bool Underline {
   bool get();
   void set (    bool value);
}

Property Value

If true, then the font has an underlined appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFont Class
PdfFont Members


%%PageItemTitle%%

PdfFontMetrics Class
Members

Xfinium.Pdf.Graphics Namespace : PdfFontMetrics Class
Provides the metrics for a font object.
Object Model
PdfFontMetrics ClassPdfStandardRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFontMetrics
'Usage

Dim instance As PdfFontMetrics
public class PdfFontMetrics
public ref class PdfFontMetrics
Remarks
The font metrics are provided in unscaled glyph units.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFontMetrics

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfFontMetrics Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfFontMetrics Class

The following tables list the members exposed by PdfFontMetrics.

Public Properties
 | Name | Description
Public Property | Ascent | Gets the ascent of the font.
Public Property | AverageWidth | Gets the average width of glyphs in the font.
Public Property | BoundingBox | Gets the font's bounding box.
Public Property | CapHeight | Gets the capHeight of the font.
Public Property | Descent | Gets the descent of the font.
Public Property | Leading | Gets the leading of the font.
Public Property | MaxWidth | Gets the maximum width of glyphs in the font.
Public Property | Name | Gets the Postscript name of the font.
Public Property | StemH | Gets the horizontal stem of the font.
Public Property | StemV | Gets the vertical stem of the font.
Public Property | XHeight | Gets the x height of the font.
Top
See Also

Reference

PdfFontMetrics Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfFontMetrics Class Properties

Xfinium.Pdf.Graphics Namespace : PdfFontMetrics Class

For a list of all members of this type, see PdfFontMetrics members.

Public Properties
 | Name | Description
Public Property | Ascent | Gets the ascent of the font.
Public Property | AverageWidth | Gets the average width of glyphs in the font.
Public Property | BoundingBox | Gets the font's bounding box.
Public Property | CapHeight | Gets the capHeight of the font.
Public Property | Descent | Gets the descent of the font.
Public Property | Leading | Gets the leading of the font.
Public Property | MaxWidth | Gets the maximum width of glyphs in the font.
Public Property | Name | Gets the Postscript name of the font.
Public Property | StemH | Gets the horizontal stem of the font.
Public Property | StemV | Gets the vertical stem of the font.
Public Property | XHeight | Gets the x height of the font.
Top
See Also

Reference

PdfFontMetrics Class
Xfinium.Pdf.Graphics Namespace


Ascent Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : Ascent Property
Gets the ascent of the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Ascent As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.Ascent
public double Ascent {get;}
public:
property double Ascent {
   double get();
}

Property Value

A double value specifying the maximum height above the baseline reached by glyphs in this font, excluding the height of glyphs for accented characters.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


AverageWidth Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : AverageWidth Property
Gets the average width of glyphs in the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AverageWidth As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.AverageWidth
public double AverageWidth {get;}
public:
property double AverageWidth {
   double get();
}

Property Value

A double value specifying the average width of glyphs in the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


BoundingBox Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : BoundingBox Property
Gets the font's bounding box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property BoundingBox As PdfStandardRectangle
'Usage

Dim instance As PdfFontMetrics
Dim value As PdfStandardRectangle

value = instance.BoundingBox
public PdfStandardRectangle BoundingBox {get;}
public:
property PdfStandardRectangle^ BoundingBox {
   PdfStandardRectangle^ get();
}

Property Value

The font bounding box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


CapHeight Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : CapHeight Property
Gets the capHeight of the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CapHeight As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.CapHeight
public double CapHeight {get;}
public:
property double CapHeight {
   double get();
}

Property Value

A double value specifying the vertical coordinate of the top of flat capital letters, measured from the baseline.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


Descent Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : Descent Property
Gets the descent of the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Descent As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.Descent
public double Descent {get;}
public:
property double Descent {
   double get();
}

Property Value

A double value specifying the maximum depth below the baseline reached by glyphs in this font. This value is a negative number.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


Leading Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : Leading Property
Gets the leading of the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Leading As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.Leading
public double Leading {get;}
public:
property double Leading {
   double get();
}

Property Value

A double value specifying the desired spacing between baselines of consecutives lines of text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


MaxWidth Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : MaxWidth Property
Gets the maximum width of glyphs in the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property MaxWidth As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.MaxWidth
public double MaxWidth {get;}
public:
property double MaxWidth {
   double get();
}

Property Value

A double value specifying the maximum width of glyphs in the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


Name Property (PdfFontMetrics)

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : Name Property
Gets the Postscript name of the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As PdfFontMetrics
Dim value As String

value = instance.Name
public string Name {get;}
public:
property String^ Name {
   String^ get();
}

Property Value

The name of the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


StemH Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : StemH Property
Gets the horizontal stem of the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property StemH As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.StemH
public double StemH {get;}
public:
property double StemH {
   double get();
}

Property Value

A double value specifying the thickness, measured invertically, of the dominant horizontal stems of glyphs in the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


StemV Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : StemV Property
Gets the vertical stem of the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property StemV As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.StemV
public double StemV {get;}
public:
property double StemV {
   double get();
}

Property Value

A double value specifying the thickness, measure horizontally, of the dominant vertical stems of glyphs in the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


XHeight Property

Xfinium.Pdf.Graphics Namespace > PdfFontMetrics Class : XHeight Property
Gets the x height of the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property XHeight As Double
'Usage

Dim instance As PdfFontMetrics
Dim value As Double

value = instance.XHeight
public double XHeight {get;}
public:
property double XHeight {
   double get();
}

Property Value

A double value specifying the vertical coordinate of the top of flat non-ascending lowercase letters (like letter x), measured from the baseline.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFontMetrics Class
PdfFontMetrics Members


%%PageItemTitle%%

PdfFormXObject Class
Members

Xfinium.Pdf.Graphics Namespace : PdfFormXObject Class
Defines a PDF form XObject.
Object Model
PdfFormXObject ClassPdfCosDictionary ClassPdfGraphics ClassPdfMatrix ClassPdfMeasure ClassPdfPointData ClassPdfGroupXObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFormXObject
   Inherits Xfinium.Pdf.PdfContentStreamContainer
'Usage

Dim instance As PdfFormXObject
public class PdfFormXObject : Xfinium.Pdf.PdfContentStreamContainer
public ref class PdfFormXObject : public Xfinium.Pdf.PdfContentStreamContainer
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Annotations.PdfAnnotationAppearance
Xfinium.Pdf.Graphics.PdfPageContent
Xfinium.Pdf.Graphics.Svg.PdfSvgDrawing

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfFormXObject Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfFormXObject Class

The following tables list the members exposed by PdfFormXObject.

Public Constructors
 | Name | Description
Public Constructor | PdfFormXObject Constructor | Initializes a new PdfFormXObject object.
Top
Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | Graphics | Gets the form XObject graphics.
Public Property | Height | Gets the form XObject height.
Public Property | Matrix | Gets or sets the form XObject matrix.
Public Property | Measure | Gets or sets the image measure.
Public Property | PointData | Gets or sets the point data.
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object.
Public Property | Width | Gets the form XObject width.
Top
See Also

Reference

PdfFormXObject Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfFormXObject Constructor(Double,Double)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class > PdfFormXObject Constructor : PdfFormXObject Constructor(Double,Double)
The width of the form XObject in points.
The height of the form XObject in points.
Initializes a new PdfFormXObject object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New PdfFormXObject(width, height)
public PdfFormXObject(
   double width,
   double height
)
public:
PdfFormXObject(
   double width,
   double height
)

Parameters

width
The width of the form XObject in points.
height
The height of the form XObject in points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfFormXObject Class Properties

Xfinium.Pdf.Graphics Namespace : PdfFormXObject Class

For a list of all members of this type, see PdfFormXObject members.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | Graphics | Gets the form XObject graphics.
Public Property | Height | Gets the form XObject height.
Public Property | Matrix | Gets or sets the form XObject matrix.
Public Property | Measure | Gets or sets the image measure.
Public Property | PointData | Gets or sets the point data.
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object.
Public Property | Width | Gets the form XObject width.
Top
See Also

Reference

PdfFormXObject Class
Xfinium.Pdf.Graphics Namespace


CosDictionary Property (PdfFormXObject)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfFormXObject
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


Graphics Property (PdfFormXObject)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : Graphics Property
Gets the form XObject graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Graphics As PdfGraphics
'Usage

Dim instance As PdfFormXObject
Dim value As PdfGraphics

value = instance.Graphics
public PdfGraphics Graphics {get;}
public:
property PdfGraphics^ Graphics {
   PdfGraphics^ get();
}

Property Value

The form XObject graphics surface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


Height Property (PdfFormXObject)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : Height Property
Gets the form XObject height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Height As Double
'Usage

Dim instance As PdfFormXObject
Dim value As Double

value = instance.Height
public virtual double Height {get;}
public:
virtual property double Height {
   double get();
}

Property Value

The form XObject height in points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


Matrix Property (PdfFormXObject)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : Matrix Property
Gets or sets the form XObject matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Matrix As PdfMatrix
'Usage

Dim instance As PdfFormXObject
Dim value As PdfMatrix

instance.Matrix = value

value = instance.Matrix
public PdfMatrix Matrix {get; set;}
public:
property PdfMatrix^ Matrix {
   PdfMatrix^ get();
   void set (    PdfMatrix^ value);
}

Property Value

The matrix applied to form XObject content before it is rendered.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


Measure Property (PdfFormXObject)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : Measure Property
Gets or sets the image measure.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Measure As PdfMeasure
'Usage

Dim instance As PdfFormXObject
Dim value As PdfMeasure

instance.Measure = value

value = instance.Measure
public PdfMeasure Measure {get; set;}
public:
property PdfMeasure^ Measure {
   PdfMeasure^ get();
   void set (    PdfMeasure^ value);
}

Property Value

A Xfinium.Pdf.Spatial.PdfMeasure descendant object that specifies the scale and units which shall apply to the image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


PointData Property (PdfFormXObject)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : PointData Property
Gets or sets the point data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PointData As PdfPointData
'Usage

Dim instance As PdfFormXObject
Dim value As PdfPointData

instance.PointData = value

value = instance.PointData
public PdfPointData PointData {get; set;}
public:
property PdfPointData^ PointData {
   PdfPointData^ get();
   void set (    PdfPointData^ value);
}

Property Value

A Xfinium.Pdf.Spatial.PdfPointData object that specifies the extended geospatial data that shall apply to the image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


TransparencyGroup Property (PdfFormXObject)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : TransparencyGroup Property
Gets or sets the transparency group associated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TransparencyGroup As PdfGroupXObject
'Usage

Dim instance As PdfFormXObject
Dim value As PdfGroupXObject

instance.TransparencyGroup = value

value = instance.TransparencyGroup
public PdfGroupXObject TransparencyGroup {get; set;}
public:
property PdfGroupXObject^ TransparencyGroup {
   PdfGroupXObject^ get();
   void set (    PdfGroupXObject^ value);
}

Property Value

The transparency group associated with this object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


Width Property (PdfFormXObject)

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : Width Property
Gets the form XObject width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Width As Double
'Usage

Dim instance As PdfFormXObject
Dim value As Double

value = instance.Width
public virtual double Width {get;}
public:
virtual property double Width {
   double get();
}

Property Value

The form XObject width in points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


%%PageItemTitle%%

PdfFunctionShading Class
Members

Xfinium.Pdf.Graphics Namespace : PdfFunctionShading Class
Defines a function based (type 1) shading.
Object Model
PdfFunctionShading ClassPdfColorSpace ClassPdfFunction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFunctionShading
   Inherits PdfShading
'Usage

Dim instance As PdfFunctionShading
public class PdfFunctionShading : PdfShading
public ref class PdfFunctionShading : public PdfShading
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfShading
Xfinium.Pdf.Graphics.PdfFunctionShading

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunctionShading Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfFunctionShading Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfFunctionShading Class

The following tables list the members exposed by PdfFunctionShading.

Public Constructors
 | Name | Description
Public Constructor | PdfFunctionShading Constructor | Initializes a new PdfFunctionShading object.
Top
Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | ColorSpace | Gets or sets the shading color space. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | Domain | Gets or sets the shading domain.
Public Property | Function | Gets or sets the shading function.
Public Property | Matrix | Gets or sets the shading matrix.
Top
See Also

Reference

PdfFunctionShading Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfFunctionShading Constructor

Xfinium.Pdf.Graphics Namespace > PdfFunctionShading Class : PdfFunctionShading Constructor
Initializes a new PdfFunctionShading object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFunctionShading()
public PdfFunctionShading()
public:
PdfFunctionShading();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunctionShading Class
PdfFunctionShading Members


%%PageItemTitle%% $$Properties$$

PdfFunctionShading Class Properties

Xfinium.Pdf.Graphics Namespace : PdfFunctionShading Class

For a list of all members of this type, see PdfFunctionShading members.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | ColorSpace | Gets or sets the shading color space. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | Domain | Gets or sets the shading domain.
Public Property | Function | Gets or sets the shading function.
Public Property | Matrix | Gets or sets the shading matrix.
Top
See Also

Reference

PdfFunctionShading Class
Xfinium.Pdf.Graphics Namespace


Domain Property (PdfFunctionShading)

Xfinium.Pdf.Graphics Namespace > PdfFunctionShading Class : Domain Property
Gets or sets the shading domain.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Domain As Double()
'Usage

Dim instance As PdfFunctionShading
Dim value() As Double

instance.Domain = value

value = instance.Domain
public double[] Domain {get; set;}
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of four numbers [xmin xmax ymin ymax] specifying the rectangular domain of coordinates over which the shading function are defined
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunctionShading Class
PdfFunctionShading Members


Function Property (PdfFunctionShading)

Xfinium.Pdf.Graphics Namespace > PdfFunctionShading Class : Function Property
Gets or sets the shading function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Function As PdfFunction
'Usage

Dim instance As PdfFunctionShading
Dim value As PdfFunction

instance.Function = value

value = instance.Function
public PdfFunction Function {get; set;}
public:
property PdfFunction^ Function {
   PdfFunction^ get();
   void set (    PdfFunction^ value);
}

Property Value

A 2-in, n-out function, where n is the number of color components in the shading dictionary's color space
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunctionShading Class
PdfFunctionShading Members


Matrix Property (PdfFunctionShading)

Xfinium.Pdf.Graphics Namespace > PdfFunctionShading Class : Matrix Property
Gets or sets the shading matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Matrix As Double()
'Usage

Dim instance As PdfFunctionShading
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
public double[] Matrix {get; set;}
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of six numbers specifying a transformation matrix mapping the coordinate space specified by the Domain entry into the shading's target coordinate space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunctionShading Class
PdfFunctionShading Members


%%PageItemTitle%%

PdfGraphics Class
Members

Xfinium.Pdf.Graphics Namespace : PdfGraphics Class
Defines a graphic surface.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfGraphics
'Usage

Dim instance As PdfGraphics
public class PdfGraphics
public ref class PdfGraphics
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfGraphics
Xfinium.Pdf.Graphics.PdfPageGraphics

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfGraphics Class Members
Methods

Xfinium.Pdf.Graphics Namespace : PdfGraphics Class

The following tables list the members exposed by PdfGraphics.

Public Methods
 | Name | Description
Public Method | BeginMarkedContent | Overloaded. Begins marked content sequence.
Public Method | CompressAndClose | Compresses the graphic content and closes the graphics surface.
Public Method | DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Public Method | DrawBarcode | Draws a barcode at the specified position.
Public Method | DrawBezier | Overloaded. Draws a Bézier spline specified by four PdfPoint objects.
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Public Method | DrawFormattedContent | Overloaded. Draws the formatted content on the graphics surface at the specified position.
Public Method | DrawFormXObject | Overloaded. Draws the specified PdfFormXObject at the specified location and with the specified size.
Public Method | DrawImage | Overloaded. Draws the specified PdfImage at the specified location and with the specified size.
Public Method | DrawLine | Overloaded. Draws a line connecting the two points specified by the coordinate pairs.
Public Method | DrawPath | Overloaded. Draws a PdfPath.
Public Method | DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a coordinate pair, a width, and a height.
Public Method | DrawShading | Draws a PDF shading.
Public Method | DrawStencilMask | Overloaded. Draws the specified PdfStencilMask at the specified location and with the specified size.
Public Method | DrawString | Overloaded. Draws the specified text string at the specified location with the specified PdfBrush and PdfFont objects.
Public Method | EndMarkedContent | Ends a marked content sequence.
Public Method | MultiplyTransform | Multiplies the current transformation of this graphics and specified the matrix.
Public Method | RestoreGraphicsState | Restores the current state of this graphics.
Public Method | RotateTransform | Applies the specified rotation to the transformation matrix of this graphics.
Public Method | SaveGraphicsState | Saves the current state of this graphics
Public Method | ScaleTransform | Applies the specified scaling operation to the transformation matrix of this graphics by prepending it to the object's transformation matrix.
Public Method | SetClip | Overloaded. Sets the clipping region of this graphics to the specified PdfPath.
Public Method | SetExtendedGraphicState | Sets a new graphics state in this graphics object.
Public Method | TranslateTransform | Changes the origin of the coordinate system by prepending the specified translation to the transformation matrix of this graphics.
Top
See Also

Reference

PdfGraphics Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfGraphics Class Methods

Xfinium.Pdf.Graphics Namespace : PdfGraphics Class

For a list of all members of this type, see PdfGraphics members.

Public Methods
 | Name | Description
Public Method | BeginMarkedContent | Overloaded. Begins marked content sequence.
Public Method | CompressAndClose | Compresses the graphic content and closes the graphics surface.
Public Method | DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Public Method | DrawBarcode | Draws a barcode at the specified position.
Public Method | DrawBezier | Overloaded. Draws a Bézier spline specified by four PdfPoint objects.
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Public Method | DrawFormattedContent | Overloaded. Draws the formatted content on the graphics surface at the specified position.
Public Method | DrawFormXObject | Overloaded. Draws the specified PdfFormXObject at the specified location and with the specified size.
Public Method | DrawImage | Overloaded. Draws the specified PdfImage at the specified location and with the specified size.
Public Method | DrawLine | Overloaded. Draws a line connecting the two points specified by the coordinate pairs.
Public Method | DrawPath | Overloaded. Draws a PdfPath.
Public Method | DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height.
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a coordinate pair, a width, and a height.
Public Method | DrawShading | Draws a PDF shading.
Public Method | DrawStencilMask | Overloaded. Draws the specified PdfStencilMask at the specified location and with the specified size.
Public Method | DrawString | Overloaded. Draws the specified text string at the specified location with the specified PdfBrush and PdfFont objects.
Public Method | EndMarkedContent | Ends a marked content sequence.
Public Method | MultiplyTransform | Multiplies the current transformation of this graphics and specified the matrix.
Public Method | RestoreGraphicsState | Restores the current state of this graphics.
Public Method | RotateTransform | Applies the specified rotation to the transformation matrix of this graphics.
Public Method | SaveGraphicsState | Saves the current state of this graphics
Public Method | ScaleTransform | Applies the specified scaling operation to the transformation matrix of this graphics by prepending it to the object's transformation matrix.
Public Method | SetClip | Overloaded. Sets the clipping region of this graphics to the specified PdfPath.
Public Method | SetExtendedGraphicState | Sets a new graphics state in this graphics object.
Public Method | TranslateTransform | Changes the origin of the coordinate system by prepending the specified translation to the transformation matrix of this graphics.
Top
See Also

Reference

PdfGraphics Class
Xfinium.Pdf.Graphics Namespace


BeginMarkedContent Method (PdfGraphics)

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : BeginMarkedContent Method
Begins marked content sequence.
Overload List
Overload | Description
BeginMarkedContent(String) | Begins marked content sequence.
BeginMarkedContent(String,PdfCosDictionary) | Begins marked content sequence.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


BeginMarkedContent(String) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > BeginMarkedContent Method : BeginMarkedContent(String) Method
A name indicating the role or significance of the sequence.
Begins marked content sequence.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub BeginMarkedContent( _
   ByVal tag As String _
)
'Usage

Dim instance As PdfGraphics
Dim tag As String

instance.BeginMarkedContent(tag)
public void BeginMarkedContent(
   string tag
)
public:
void BeginMarkedContent(
   String^ tag
)

Parameters

tag
A name indicating the role or significance of the sequence.
Remarks
Each BeginMarkedContent call must be paired with a EndMarkedContent call.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


BeginMarkedContent(String,PdfCosDictionary) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > BeginMarkedContent Method : BeginMarkedContent(String,PdfCosDictionary) Method
A name indicating the role or significance of the sequence.
A property list.
Begins marked content sequence.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub BeginMarkedContent( _
   ByVal tag As String, _
   ByVal inlineDictionary As PdfCosDictionary _
)
'Usage

Dim instance As PdfGraphics
Dim tag As String
Dim inlineDictionary As PdfCosDictionary

instance.BeginMarkedContent(tag, inlineDictionary)
public void BeginMarkedContent(
   string tag,
   PdfCosDictionary inlineDictionary
)
public:
void BeginMarkedContent(
   String^ tag,
   PdfCosDictionary^ inlineDictionary
)

Parameters

tag
A name indicating the role or significance of the sequence.
inlineDictionary
A property list.
Remarks
Each BeginMarkedContent call must be paired with a EndMarkedContent call.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


CompressAndClose Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : CompressAndClose Method
Compresses the graphic content and closes the graphics surface.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub CompressAndClose()
'Usage

Dim instance As PdfGraphics

instance.CompressAndClose()
public void CompressAndClose()
public:
void CompressAndClose();
Remarks
Call this method to compress the graphic content and reduce memory usage. If this method is not called, the graphic content is stored uncompressed in the Pdf file. After calling this method no more drawing is allowed on the graphics.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawArc Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawArc Method
Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Overload List
Overload | Description
DrawArc(PdfPen,Double,Double,Double,Double,Double,Double) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawArc(PdfPen,Double,Double,Double,Double,Double,Double,Double) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawArc(PdfBrush,Double,Double,Double,Double,Double,Double) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawArc(PdfBrush,Double,Double,Double,Double,Double,Double,Double) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawArc(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
DrawArc(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawArc(PdfPen,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawArc Method : DrawArc(PdfPen,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the arc.
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
Width of the rectangle that defines the ellipse.
Height of the rectangle that defines the ellipse.
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawArc( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawArc(pen, x, y, width, height, startAngle, sweepAngle)
public void DrawArc(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawArc(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
PdfPen that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
Width of the rectangle that defines the ellipse.
height
Height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawArc(PdfPen,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawArc Method : DrawArc(PdfPen,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the arc.
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
Width of the rectangle that defines the ellipse.
Height of the rectangle that defines the ellipse.
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Rotation angle of the bounding rectangle that defines the arc.
Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawArc( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawArc(pen, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawArc(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawArc(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the arc.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
Width of the rectangle that defines the ellipse.
height
Height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
rotation
Rotation angle of the bounding rectangle that defines the arc.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawArc(PdfBrush,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawArc Method : DrawArc(PdfBrush,Double,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
Width of the rectangle that defines the ellipse.
Height of the rectangle that defines the ellipse.
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawArc( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawArc(brush, x, y, width, height, startAngle, sweepAngle)
public void DrawArc(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawArc(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
Width of the rectangle that defines the ellipse.
height
Height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawArc(PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawArc Method : DrawArc(PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
Width of the rectangle that defines the ellipse.
Height of the rectangle that defines the ellipse.
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Rotation angle of the bounding rectangle that defines the arc.
Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawArc( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawArc(brush, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawArc(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawArc(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
Width of the rectangle that defines the ellipse.
height
Height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
rotation
Rotation angle of the bounding rectangle that defines the arc.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawArc(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawArc Method : DrawArc(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the arc.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
Width of the rectangle that defines the ellipse.
Height of the rectangle that defines the ellipse.
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawArc( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawArc(pen, brush, x, y, width, height, startAngle, sweepAngle)
public void DrawArc(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawArc(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
PdfPen that determines the color, width, and style of the arc.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
Width of the rectangle that defines the ellipse.
height
Height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawArc(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawArc Method : DrawArc(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the arc.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
Width of the rectangle that defines the ellipse.
Height of the rectangle that defines the ellipse.
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Rotation angle of the bounding rectangle that defines the arc.
Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawArc( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawArc(pen, brush, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawArc(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawArc(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the arc.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.
width
Width of the rectangle that defines the ellipse.
height
Height of the rectangle that defines the ellipse.
startAngle
Angle in degrees measured clockwise from the x-axis to the starting point of the arc.
sweepAngle
Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
rotation
Rotation angle of the bounding rectangle that defines the arc.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawBarcode Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawBarcode Method
PdfBarcode to draw.
The x-coordinate of the upper-left corner of the drawn barcode.
The y-coordinate of the upper-left corner of the drawn barcode.
Draws a barcode at the specified position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub DrawBarcode( _
   ByVal barcode As PdfBarcode, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PdfGraphics
Dim barcode As PdfBarcode
Dim x As Double
Dim y As Double

instance.DrawBarcode(barcode, x, y)
public void DrawBarcode(
   PdfBarcode barcode,
   double x,
   double y
)
public:
void DrawBarcode(
   PdfBarcode^ barcode,
   double x,
   double y
)

Parameters

barcode
PdfBarcode to draw.
x
The x-coordinate of the upper-left corner of the drawn barcode.
y
The y-coordinate of the upper-left corner of the drawn barcode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawBezier Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawBezier Method
Draws a Bézier spline specified by four PdfPoint objects.
Overload List
Overload | Description
DrawBezier(PdfPen,PdfPoint,PdfPoint,PdfPoint,PdfPoint) | Draws a Bézier spline specified by four PdfPoint objects.
DrawBezier(PdfPen,Double,Double,Double,Double,Double,Double,Double,Double) | Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawBezier(PdfPen,PdfPoint,PdfPoint,PdfPoint,PdfPoint) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawBezier Method : DrawBezier(PdfPen,PdfPoint,PdfPoint,PdfPoint,PdfPoint) Method
PdfPen object that determines the color, width, and style of the curve.
PdfPoint object that represents the starting point of the curve.
PdfPoint object that represents the first control point for the curve.
PdfPoint object that represents the second control point for the curve.
PdfPoint object that represents the ending point of the curve.
Draws a Bézier spline specified by four PdfPoint objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawBezier( _
   ByVal pen As PdfPen, _
   ByVal pt1 As PdfPoint, _
   ByVal pt2 As PdfPoint, _
   ByVal pt3 As PdfPoint, _
   ByVal pt4 As PdfPoint _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim pt1 As PdfPoint
Dim pt2 As PdfPoint
Dim pt3 As PdfPoint
Dim pt4 As PdfPoint

instance.DrawBezier(pen, pt1, pt2, pt3, pt4)
public void DrawBezier(
   PdfPen pen,
   PdfPoint pt1,
   PdfPoint pt2,
   PdfPoint pt3,
   PdfPoint pt4
)
public:
void DrawBezier(
   PdfPen^ pen,
   PdfPoint^ pt1,
   PdfPoint^ pt2,
   PdfPoint^ pt3,
   PdfPoint^ pt4
)

Parameters

pen
PdfPen object that determines the color, width, and style of the curve.
pt1
PdfPoint object that represents the starting point of the curve.
pt2
PdfPoint object that represents the first control point for the curve.
pt3
PdfPoint object that represents the second control point for the curve.
pt4
PdfPoint object that represents the ending point of the curve.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawBezier(PdfPen,Double,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawBezier Method : DrawBezier(PdfPen,Double,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen object that determines the color, width, and style of the curve.
The x-coordinate of the starting point of the curve.
The y-coordinate of the starting point of the curve.
The x-coordinate of the first control point of the curve.
The y-coordinate of the first control point of the curve.
The x-coordinate of the second control point of the curve.
The y-coordinate of the second control point of the curve.
The x-coordinate of the ending point of the curve.
The y-coordinate of the ending point of the curve.
Draws a Bézier spline defined by four ordered pairs of coordinates that represent points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawBezier( _
   ByVal pen As PdfPen, _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double, _
   ByVal x4 As Double, _
   ByVal y4 As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double
Dim x4 As Double
Dim y4 As Double

instance.DrawBezier(pen, x1, y1, x2, y2, x3, y3, x4, y4)
public void DrawBezier(
   PdfPen pen,
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3,
   double x4,
   double y4
)
public:
void DrawBezier(
   PdfPen^ pen,
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3,
   double x4,
   double y4
)

Parameters

pen
PdfPen object that determines the color, width, and style of the curve.
x1
The x-coordinate of the starting point of the curve.
y1
The y-coordinate of the starting point of the curve.
x2
The x-coordinate of the first control point of the curve.
y2
The y-coordinate of the first control point of the curve.
x3
The x-coordinate of the second control point of the curve.
y3
The y-coordinate of the second control point of the curve.
x4
The x-coordinate of the ending point of the curve.
y4
The y-coordinate of the ending point of the curve.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawChord Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawChord Method
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Overload List
Overload | Description
DrawChord(PdfPen,Double,Double,Double,Double,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PdfPen,Double,Double,Double,Double,Double,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PdfBrush,Double,Double,Double,Double,Double,Double) | Fills the interior of a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PdfBrush,Double,Double,Double,Double,Double,Double,Double) | Fills the interior of a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) | Draws and fills the interior of a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) | Draws and fills the interior of a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawChord(PdfPen,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawChord Method : DrawChord(PdfPen,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the pie shape.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, x, y, width, height, startAngle, sweepAngle)
public void DrawChord(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
PdfPen that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawChord(PdfPen,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawChord Method : DrawChord(PdfPen,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the pie shape.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Rotation angle of the bounding rectangle that defines the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawChord(pen, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawChord(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawChord(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
rotation
Rotation angle of the bounding rectangle that defines the chord.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawChord(PdfBrush,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawChord Method : DrawChord(PdfBrush,Double,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Fills the interior of a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(brush, x, y, width, height, startAngle, sweepAngle)
public void DrawChord(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawChord(PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawChord Method : DrawChord(PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Rotation angle of the bounding rectangle that defines the chord.
Fills the interior of a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawChord(brush, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawChord(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawChord(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
rotation
Rotation angle of the bounding rectangle that defines the chord.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawChord(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawChord Method : DrawChord(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the pie shape.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Draws and fills the interior of a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, brush, x, y, width, height, startAngle, sweepAngle)
public void DrawChord(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawChord(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
PdfPen that determines the color, width, and style of the pie shape.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawChord(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawChord Method : DrawChord(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the pie shape.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Rotation angle of the bounding rectangle that defines the chord.
Draws and fills the interior of a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawChord( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawChord(pen, brush, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawChord(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawChord(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the pie shape.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
rotation
Rotation angle of the bounding rectangle that defines the chord.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawEllipse Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawEllipse Method
Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Overload List
Overload | Description
DrawEllipse(PdfPen,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
DrawEllipse(PdfPen,Double,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
DrawEllipse(PdfBrush,Double,Double,Double,Double) | Fills the interior of an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
DrawEllipse(PdfBrush,Double,Double,Double,Double,Double) | Fills the interior of an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
DrawEllipse(PdfPen,PdfBrush,Double,Double,Double,Double) | Draws and fills the interior of an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
DrawEllipse(PdfPen,PdfBrush,Double,Double,Double,Double,Double) | Draws and fills the interior of an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawEllipse(PdfPen,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawEllipse Method : DrawEllipse(PdfPen,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the ellipse.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
Width of the bounding rectangle that defines the ellipse.
Height of the bounding rectangle that defines the ellipse.
Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(pen, x, y, width, height)
public void DrawEllipse(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height
)
public:
void DrawEllipse(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height
)

Parameters

pen
PdfPen that determines the color, width, and style of the ellipse.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawEllipse(PdfPen,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawEllipse Method : DrawEllipse(PdfPen,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the ellipse.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
Width of the bounding rectangle that defines the ellipse.
Height of the bounding rectangle that defines the ellipse.
Rotation angle of the bounding rectangle that defines the ellipse.
Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double

instance.DrawEllipse(pen, x, y, width, height, rotation)
public void DrawEllipse(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
void DrawEllipse(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the ellipse.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.
rotation
Rotation angle of the bounding rectangle that defines the ellipse.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawEllipse(PdfBrush,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawEllipse Method : DrawEllipse(PdfBrush,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
Width of the bounding rectangle that defines the ellipse.
Height of the bounding rectangle that defines the ellipse.
Fills the interior of an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(brush, x, y, width, height)
public void DrawEllipse(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height
)
public:
void DrawEllipse(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawEllipse(PdfBrush,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawEllipse Method : DrawEllipse(PdfBrush,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
Width of the bounding rectangle that defines the ellipse.
Height of the bounding rectangle that defines the ellipse.
Rotation angle of the bounding rectangle that defines the ellipse.
Fills the interior of an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double

instance.DrawEllipse(brush, x, y, width, height, rotation)
public void DrawEllipse(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
void DrawEllipse(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.
rotation
Rotation angle of the bounding rectangle that defines the ellipse.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawEllipse(PdfPen,PdfBrush,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawEllipse Method : DrawEllipse(PdfPen,PdfBrush,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the ellipse.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
Width of the bounding rectangle that defines the ellipse.
Height of the bounding rectangle that defines the ellipse.
Draws and fills the interior of an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(pen, brush, x, y, width, height)
public void DrawEllipse(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height
)
public:
void DrawEllipse(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height
)

Parameters

pen
PdfPen that determines the color, width, and style of the ellipse.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawEllipse(PdfPen,PdfBrush,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawEllipse Method : DrawEllipse(PdfPen,PdfBrush,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the ellipse.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
Width of the bounding rectangle that defines the ellipse.
Height of the bounding rectangle that defines the ellipse.
Rotation angle of the bounding rectangle that defines the ellipse.
Draws and fills the interior of an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawEllipse( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double

instance.DrawEllipse(pen, brush, x, y, width, height, rotation)
public void DrawEllipse(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
void DrawEllipse(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the ellipse.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.
rotation
Rotation angle of the bounding rectangle that defines the ellipse.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawFormattedContent Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawFormattedContent Method
Draws the formatted content on the graphics surface at the specified position.
Overload List
Overload | Description
DrawFormattedContent(PdfFormattedContent,Double,Double) | Draws the formatted content on the graphics surface at the specified position.
DrawFormattedContent(PdfFormattedContent,Double,Double,Double) | Draws the formatted content on the graphics surface at the specified position.
DrawFormattedContent(PdfFormattedContent,Double,Double,Double,Double) | Draws the formatted content on the graphics surface in the specified box.
DrawFormattedContent(PdfFormattedContent,Double,Double,Double,Double,Double) | Draws the formatted content on the graphics surface in the specified box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawFormattedContent(PdfFormattedContent,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawFormattedContent Method : DrawFormattedContent(PdfFormattedContent,Double,Double) Method
The formatted content.
X coordinate of the content left margin.
Y coordinate of the content top margin.
Draws the formatted content on the graphics surface at the specified position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormattedContent( _
   ByVal formattedContent As PdfFormattedContent, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PdfGraphics
Dim formattedContent As PdfFormattedContent
Dim x As Double
Dim y As Double

instance.DrawFormattedContent(formattedContent, x, y)
public void DrawFormattedContent(
   PdfFormattedContent formattedContent,
   double x,
   double y
)
public:
void DrawFormattedContent(
   PdfFormattedContent^ formattedContent,
   double x,
   double y
)

Parameters

formattedContent
The formatted content.
x
X coordinate of the content left margin.
y
Y coordinate of the content top margin.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawFormattedContent(PdfFormattedContent,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawFormattedContent Method : DrawFormattedContent(PdfFormattedContent,Double,Double,Double) Method
The formatted content.
X coordinate of the content left margin.
Y coordinate of the content top margin.
Rotation angle for drawing the formatted content
Draws the formatted content on the graphics surface at the specified position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormattedContent( _
   ByVal formattedContent As PdfFormattedContent, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim formattedContent As PdfFormattedContent
Dim x As Double
Dim y As Double
Dim rotation As Double

instance.DrawFormattedContent(formattedContent, x, y, rotation)
public void DrawFormattedContent(
   PdfFormattedContent formattedContent,
   double x,
   double y,
   double rotation
)
public:
void DrawFormattedContent(
   PdfFormattedContent^ formattedContent,
   double x,
   double y,
   double rotation
)

Parameters

formattedContent
The formatted content.
x
X coordinate of the content left margin.
y
Y coordinate of the content top margin.
rotation
Rotation angle for drawing the formatted content
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawFormattedContent(PdfFormattedContent,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawFormattedContent Method : DrawFormattedContent(PdfFormattedContent,Double,Double,Double,Double) Method
The formatted content.
X coordinate of the box left margin.
Y coordinate of the box top margin.
Box width
Box height
Draws the formatted content on the graphics surface in the specified box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormattedContent( _
   ByVal formattedContent As PdfFormattedContent, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfGraphics
Dim formattedContent As PdfFormattedContent
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.DrawFormattedContent(formattedContent, x, y, width, height)
public void DrawFormattedContent(
   PdfFormattedContent formattedContent,
   double x,
   double y,
   double width,
   double height
)
public:
void DrawFormattedContent(
   PdfFormattedContent^ formattedContent,
   double x,
   double y,
   double width,
   double height
)

Parameters

formattedContent
The formatted content.
x
X coordinate of the box left margin.
y
Y coordinate of the box top margin.
width
Box width
height
Box height
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawFormattedContent(PdfFormattedContent,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawFormattedContent Method : DrawFormattedContent(PdfFormattedContent,Double,Double,Double,Double,Double) Method
The formatted content.
X coordinate of the box left margin.
Y coordinate of the box top margin.
Box width
Box height
Rotation angle.
Draws the formatted content on the graphics surface in the specified box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormattedContent( _
   ByVal formattedContent As PdfFormattedContent, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim formattedContent As PdfFormattedContent
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double

instance.DrawFormattedContent(formattedContent, x, y, width, height, rotation)
public void DrawFormattedContent(
   PdfFormattedContent formattedContent,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
void DrawFormattedContent(
   PdfFormattedContent^ formattedContent,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

formattedContent
The formatted content.
x
X coordinate of the box left margin.
y
Y coordinate of the box top margin.
width
Box width
height
Box height
rotation
Rotation angle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawFormXObject Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawFormXObject Method
Draws the specified PdfFormXObject at the specified location and with the specified size.
Overload List
Overload | Description
DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,Double) | Draws the specified PdfFormXObject at the specified location and with the specified size.
DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,PdfFlipDirection) | Draws the specified PdfFormXObject at the specified location and with the specified size.
DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,Double,PdfFlipDirection) | Draws the specified PdfFormXObject at the specified location and with the specified size.
DrawFormXObject(PdfFormXObject,Double,Double,Double,Double) | Draws the specified PdfFormXObject at the specified location and with the specified size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawFormXObject Method : DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,Double) Method
PdfFormXObject to draw.
The x-coordinate of the upper-left corner of the drawn form XObject.
The y-coordinate of the upper-left corner of the drawn form XObject.
Width of the drawn form XObject.
Height of the drawn form XObject.
Rotation angle of the drawn form XObject.
Draws the specified PdfFormXObject at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormXObject( _
   ByVal formXObject As PdfFormXObject, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim formXObject As PdfFormXObject
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double

instance.DrawFormXObject(formXObject, x, y, width, height, rotation)
public void DrawFormXObject(
   PdfFormXObject formXObject,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
void DrawFormXObject(
   PdfFormXObject^ formXObject,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

formXObject
PdfFormXObject to draw.
x
The x-coordinate of the upper-left corner of the drawn form XObject.
y
The y-coordinate of the upper-left corner of the drawn form XObject.
width
Width of the drawn form XObject.
height
Height of the drawn form XObject.
rotation
Rotation angle of the drawn form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,PdfFlipDirection) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawFormXObject Method : DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,PdfFlipDirection) Method
PdfFormXObject to draw.
The x-coordinate of the upper-left corner of the drawn form XObject.
The y-coordinate of the upper-left corner of the drawn form XObject.
Width of the drawn form XObject.
Height of the drawn form XObject.
Direction for flipping the drawn form XObject.
Draws the specified PdfFormXObject at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormXObject( _
   ByVal formXObject As PdfFormXObject, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal flipDirection As PdfFlipDirection _
)
'Usage

Dim instance As PdfGraphics
Dim formXObject As PdfFormXObject
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim flipDirection As PdfFlipDirection

instance.DrawFormXObject(formXObject, x, y, width, height, flipDirection)
public void DrawFormXObject(
   PdfFormXObject formXObject,
   double x,
   double y,
   double width,
   double height,
   PdfFlipDirection flipDirection
)
public:
void DrawFormXObject(
   PdfFormXObject^ formXObject,
   double x,
   double y,
   double width,
   double height,
   PdfFlipDirection flipDirection
)

Parameters

formXObject
PdfFormXObject to draw.
x
The x-coordinate of the upper-left corner of the drawn form XObject.
y
The y-coordinate of the upper-left corner of the drawn form XObject.
width
Width of the drawn form XObject.
height
Height of the drawn form XObject.
flipDirection
Direction for flipping the drawn form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,Double,PdfFlipDirection) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawFormXObject Method : DrawFormXObject(PdfFormXObject,Double,Double,Double,Double,Double,PdfFlipDirection) Method
PdfFormXObject to draw.
The x-coordinate of the upper-left corner of the drawn form XObject.
The y-coordinate of the upper-left corner of the drawn form XObject.
Width of the drawn form XObject.
Height of the drawn form XObject.
Rotation angle of the drawn form XObject.
Direction for flipping the drawn form XObject.
Draws the specified PdfFormXObject at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormXObject( _
   ByVal formXObject As PdfFormXObject, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double, _
   ByVal flipDirection As PdfFlipDirection _
)
'Usage

Dim instance As PdfGraphics
Dim formXObject As PdfFormXObject
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double
Dim flipDirection As PdfFlipDirection

instance.DrawFormXObject(formXObject, x, y, width, height, rotation, flipDirection)
public void DrawFormXObject(
   PdfFormXObject formXObject,
   double x,
   double y,
   double width,
   double height,
   double rotation,
   PdfFlipDirection flipDirection
)
public:
void DrawFormXObject(
   PdfFormXObject^ formXObject,
   double x,
   double y,
   double width,
   double height,
   double rotation,
   PdfFlipDirection flipDirection
)

Parameters

formXObject
PdfFormXObject to draw.
x
The x-coordinate of the upper-left corner of the drawn form XObject.
y
The y-coordinate of the upper-left corner of the drawn form XObject.
width
Width of the drawn form XObject.
height
Height of the drawn form XObject.
rotation
Rotation angle of the drawn form XObject.
flipDirection
Direction for flipping the drawn form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawFormXObject(PdfFormXObject,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawFormXObject Method : DrawFormXObject(PdfFormXObject,Double,Double,Double,Double) Method
PdfFormXObject to draw.
The x-coordinate of the upper-left corner of the drawn form XObject.
The y-coordinate of the upper-left corner of the drawn form XObject.
Width of the drawn form XObject.
Height of the drawn form XObject.
Draws the specified PdfFormXObject at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawFormXObject( _
   ByVal formXObject As PdfFormXObject, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfGraphics
Dim formXObject As PdfFormXObject
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.DrawFormXObject(formXObject, x, y, width, height)
public void DrawFormXObject(
   PdfFormXObject formXObject,
   double x,
   double y,
   double width,
   double height
)
public:
void DrawFormXObject(
   PdfFormXObject^ formXObject,
   double x,
   double y,
   double width,
   double height
)

Parameters

formXObject
PdfFormXObject to draw.
x
The x-coordinate of the upper-left corner of the drawn form XObject.
y
The y-coordinate of the upper-left corner of the drawn form XObject.
width
Width of the drawn form XObject.
height
Height of the drawn form XObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawImage Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawImage Method
Draws the specified PdfImage at the specified location and with the specified size.
Overload List
Overload | Description
DrawImage(PdfImage,Double,Double,Double,Double) | Draws the specified PdfImage at the specified location and with the specified size.
DrawImage(PdfImage,Double,Double,Double,Double,Double) | Draws the specified PdfImage at the specified location and with the specified size.
DrawImage(PdfImage,Double,Double,Double,Double,Double,PdfFlipDirection) | Draws the specified PdfImage at the specified location and with the specified size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawImage(PdfImage,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawImage Method : DrawImage(PdfImage,Double,Double,Double,Double) Method
PdfImage to draw.
The x-coordinate of the upper-left corner of the drawn image.
The y-coordinate of the upper-left corner of the drawn image.
Width of the drawn image.
Height of the drawn image.
Draws the specified PdfImage at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal image As PdfImage, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
) As PdfSize
'Usage

Dim instance As PdfGraphics
Dim image As PdfImage
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim value As PdfSize

value = instance.DrawImage(image, x, y, width, height)
public PdfSize DrawImage(
   PdfImage image,
   double x,
   double y,
   double width,
   double height
)
public:
PdfSize^ DrawImage(
   PdfImage^ image,
   double x,
   double y,
   double width,
   double height
)

Parameters

image
PdfImage to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Width of the drawn image.
height
Height of the drawn image.

Return Value

The size of the drawn image.
Remarks
If width is zero or negative then width is automatically computed in order to keep the original aspect ratio. If height is zero or negative then height is automatically computed in order to keep the original aspect ratio. If both width and height are negative then the image is scaled automatically to fit the given area and the original aspect ratio is kept.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawImage(PdfImage,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawImage Method : DrawImage(PdfImage,Double,Double,Double,Double,Double) Method
PdfImage to draw.
The x-coordinate of the upper-left corner of the drawn image.
The y-coordinate of the upper-left corner of the drawn image.
Width of the drawn image.
Height of the drawn image.
Rotation angle of the drawn image.
Draws the specified PdfImage at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal image As PdfImage, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
) As PdfSize
'Usage

Dim instance As PdfGraphics
Dim image As PdfImage
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double
Dim value As PdfSize

value = instance.DrawImage(image, x, y, width, height, rotation)
public PdfSize DrawImage(
   PdfImage image,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
PdfSize^ DrawImage(
   PdfImage^ image,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

image
PdfImage to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Width of the drawn image.
height
Height of the drawn image.
rotation
Rotation angle of the drawn image.

Return Value

The size of the drawn image.
Remarks
If width is zero or negative then width is automatically computed in order to keep the original aspect ratio. If height is zero or negative then height is automatically computed in order to keep the original aspect ratio. If both width and height are negative then the image is scaled automatically to fit the given area and the original aspect ratio is kept.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawImage(PdfImage,Double,Double,Double,Double,Double,PdfFlipDirection) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawImage Method : DrawImage(PdfImage,Double,Double,Double,Double,Double,PdfFlipDirection) Method
PdfImage to draw.
The x-coordinate of the upper-left corner of the drawn image.
The y-coordinate of the upper-left corner of the drawn image.
Width of the drawn image.
Height of the drawn image.
Rotation angle of the drawn image.
Direction for flipping the drawn image.
Draws the specified PdfImage at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DrawImage( _
   ByVal image As PdfImage, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double, _
   ByVal flipDirection As PdfFlipDirection _
) As PdfSize
'Usage

Dim instance As PdfGraphics
Dim image As PdfImage
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double
Dim flipDirection As PdfFlipDirection
Dim value As PdfSize

value = instance.DrawImage(image, x, y, width, height, rotation, flipDirection)
public PdfSize DrawImage(
   PdfImage image,
   double x,
   double y,
   double width,
   double height,
   double rotation,
   PdfFlipDirection flipDirection
)
public:
PdfSize^ DrawImage(
   PdfImage^ image,
   double x,
   double y,
   double width,
   double height,
   double rotation,
   PdfFlipDirection flipDirection
)

Parameters

image
PdfImage to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Width of the drawn image.
height
Height of the drawn image.
rotation
Rotation angle of the drawn image.
flipDirection
Direction for flipping the drawn image.

Return Value

The size of the drawn image.
Remarks
If width is zero or negative then width is automatically computed in order to keep the original aspect ratio. If height is zero or negative then height is automatically computed in order to keep the original aspect ratio. If both width and height are negative then the image is scaled automatically to fit the given area and the original aspect ratio is kept.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawLine Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawLine Method
Draws a line connecting the two points specified by the coordinate pairs.
Overload List
Overload | Description
DrawLine(PdfPen,Double,Double,Double,Double) | Draws a line connecting the two points specified by the coordinate pairs.
DrawLine(PdfPen,PdfPoint,PdfPoint) | Draws a line connecting two PdfPoint objects.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawLine(PdfPen,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawLine Method : DrawLine(PdfPen,Double,Double,Double,Double) Method
PdfPen Pen that determines the color, width, and style of the line.
The x-coordinate of the first point.
The y-coordinate of the first point.
The x-coordinate of the second point.
The y-coordinate of the second point.
Draws a line connecting the two points specified by the coordinate pairs.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawLine( _
   ByVal pen As PdfPen, _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double

instance.DrawLine(pen, x1, y1, x2, y2)
public void DrawLine(
   PdfPen pen,
   double x1,
   double y1,
   double x2,
   double y2
)
public:
void DrawLine(
   PdfPen^ pen,
   double x1,
   double y1,
   double x2,
   double y2
)

Parameters

pen
PdfPen Pen that determines the color, width, and style of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawLine(PdfPen,PdfPoint,PdfPoint) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawLine Method : DrawLine(PdfPen,PdfPoint,PdfPoint) Method
PdfPen Pen that determines the color, width, and style of the line.
PdfPoint object that represents the first point to connect.
PdfPoint object that represents the second point to connect.
Draws a line connecting two PdfPoint objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawLine( _
   ByVal pen As PdfPen, _
   ByVal pt1 As PdfPoint, _
   ByVal pt2 As PdfPoint _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim pt1 As PdfPoint
Dim pt2 As PdfPoint

instance.DrawLine(pen, pt1, pt2)
public void DrawLine(
   PdfPen pen,
   PdfPoint pt1,
   PdfPoint pt2
)
public:
void DrawLine(
   PdfPen^ pen,
   PdfPoint^ pt1,
   PdfPoint^ pt2
)

Parameters

pen
PdfPen Pen that determines the color, width, and style of the line.
pt1
PdfPoint object that represents the first point to connect.
pt2
PdfPoint object that represents the second point to connect.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPath Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawPath Method
Draws a PdfPath.
Overload List
Overload | Description
DrawPath(PdfPen,PdfPath) | Draws a PdfPath.
DrawPath(PdfBrush,PdfPath) | Fills a PdfPath.
DrawPath(PdfBrush,PdfPath,PdfFillMode) | Fills a PdfPath.
DrawPath(PdfPen,PdfBrush,PdfPath) | Draws and fills a PdfPath.
DrawPath(PdfPen,PdfBrush,PdfPath,PdfFillMode) | Draws and fills a PdfPath.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawPath(PdfPen,PdfPath) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPath Method : DrawPath(PdfPen,PdfPath) Method
PdfPen that determines the color, width, and style of the path.
PdfPath to draw.
Draws a PdfPath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal pen As PdfPen, _
   ByVal path As PdfPath _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim path As PdfPath

instance.DrawPath(pen, path)
public void DrawPath(
   PdfPen pen,
   PdfPath path
)
public:
void DrawPath(
   PdfPen^ pen,
   PdfPath^ path
)

Parameters

pen
PdfPen that determines the color, width, and style of the path.
path
PdfPath to draw.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPath(PdfBrush,PdfPath) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPath Method : DrawPath(PdfBrush,PdfPath) Method
PdfBrush that determines the characteristics of the fill.
PdfPath to fill.
Fills a PdfPath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal brush As PdfBrush, _
   ByVal path As PdfPath _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim path As PdfPath

instance.DrawPath(brush, path)
public void DrawPath(
   PdfBrush brush,
   PdfPath path
)
public:
void DrawPath(
   PdfBrush^ brush,
   PdfPath^ path
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
path
PdfPath to fill.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPath(PdfBrush,PdfPath,PdfFillMode) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPath Method : DrawPath(PdfBrush,PdfPath,PdfFillMode) Method
PdfBrush that determines the characteristics of the fill.
PdfPath to fill.
Path fill mode.
Fills a PdfPath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal brush As PdfBrush, _
   ByVal path As PdfPath, _
   ByVal fillMode As PdfFillMode _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim path As PdfPath
Dim fillMode As PdfFillMode

instance.DrawPath(brush, path, fillMode)
public void DrawPath(
   PdfBrush brush,
   PdfPath path,
   PdfFillMode fillMode
)
public:
void DrawPath(
   PdfBrush^ brush,
   PdfPath^ path,
   PdfFillMode fillMode
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
path
PdfPath to fill.
fillMode
Path fill mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPath(PdfPen,PdfBrush,PdfPath) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPath Method : DrawPath(PdfPen,PdfBrush,PdfPath) Method
PdfPen that determines the color, width, and style of the path.
PdfBrush that determines the characteristics of the fill.
PdfPath to draw and fill.
Draws and fills a PdfPath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal path As PdfPath _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim path As PdfPath

instance.DrawPath(pen, brush, path)
public void DrawPath(
   PdfPen pen,
   PdfBrush brush,
   PdfPath path
)
public:
void DrawPath(
   PdfPen^ pen,
   PdfBrush^ brush,
   PdfPath^ path
)

Parameters

pen
PdfPen that determines the color, width, and style of the path.
brush
PdfBrush that determines the characteristics of the fill.
path
PdfPath to draw and fill.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPath(PdfPen,PdfBrush,PdfPath,PdfFillMode) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPath Method : DrawPath(PdfPen,PdfBrush,PdfPath,PdfFillMode) Method
PdfPen that determines the color, width, and style of the path.
PdfBrush that determines the characteristics of the fill.
PdfPath to draw and fill.
Path fill mode.
Draws and fills a PdfPath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPath( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal path As PdfPath, _
   ByVal fillMode As PdfFillMode _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim path As PdfPath
Dim fillMode As PdfFillMode

instance.DrawPath(pen, brush, path, fillMode)
public void DrawPath(
   PdfPen pen,
   PdfBrush brush,
   PdfPath path,
   PdfFillMode fillMode
)
public:
void DrawPath(
   PdfPen^ pen,
   PdfBrush^ brush,
   PdfPath^ path,
   PdfFillMode fillMode
)

Parameters

pen
PdfPen that determines the color, width, and style of the path.
brush
PdfBrush that determines the characteristics of the fill.
path
PdfPath to draw and fill.
fillMode
Path fill mode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPie Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawPie Method
Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Overload List
Overload | Description
DrawPie(PdfPen,Double,Double,Double,Double,Double,Double) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
DrawPie(PdfPen,Double,Double,Double,Double,Double,Double,Double) | Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
DrawPie(PdfBrush,Double,Double,Double,Double,Double,Double) | Fills the interior of a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
DrawPie(PdfBrush,Double,Double,Double,Double,Double,Double,Double) | Fills the interior of a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
DrawPie(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) | Draws and fills the interior of a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
DrawPie(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) | Draws and fills the interior of a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawPie(PdfPen,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPie Method : DrawPie(PdfPen,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the pie shape.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, x, y, width, height, startAngle, sweepAngle)
public void DrawPie(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
PdfPen that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPie(PdfPen,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPie Method : DrawPie(PdfPen,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the pie shape.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Rotation angle of the bounding rectangle that defines the pie.
Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawPie(pen, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawPie(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawPie(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the pie shape.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
rotation
Rotation angle of the bounding rectangle that defines the pie.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPie(PdfBrush,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPie Method : DrawPie(PdfBrush,Double,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Fills the interior of a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(brush, x, y, width, height, startAngle, sweepAngle)
public void DrawPie(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPie(PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPie Method : DrawPie(PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Rotation angle of the bounding rectangle that defines the pie.
Fills the interior of a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawPie(brush, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawPie(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawPie(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
rotation
Rotation angle of the bounding rectangle that defines the pie.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPie(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPie Method : DrawPie(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the pie shape.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Draws and fills the interior of a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, brush, x, y, width, height, startAngle, sweepAngle)
public void DrawPie(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
public:
void DrawPie(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
PdfPen that determines the color, width, and style of the pie shape.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawPie(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawPie Method : DrawPie(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the pie shape.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
Rotation angle of the bounding rectangle that defines the pie.
Draws and fills the interior of a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawPie( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double
Dim rotation As Double

instance.DrawPie(pen, brush, x, y, width, height, startAngle, sweepAngle, rotation)
public void DrawPie(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)
public:
void DrawPie(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double startAngle,
   double sweepAngle,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the pie shape.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse from which the pie shape comes.
width
Width of the bounding rectangle that defines the ellipse from which the pie shape comes.
height
Height of the bounding rectangle that defines the ellipse from which the pie shape comes.
startAngle
Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
sweepAngle
Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.
rotation
Rotation angle of the bounding rectangle that defines the pie.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRectangle Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawRectangle Method
Draws a rectangle specified by a coordinate pair, a width, and a height.
Overload List
Overload | Description
DrawRectangle(PdfPen,Double,Double,Double,Double) | Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangle(PdfPen,Double,Double,Double,Double,Double) | Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangle(PdfBrush,Double,Double,Double,Double) | Fills the interior of a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangle(PdfBrush,Double,Double,Double,Double,Double) | Fills the interior of a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangle(PdfPen,PdfBrush,Double,Double,Double,Double) | Draws and fills the interior of a rectangle specified by a coordinate pair, a width, and a height.
DrawRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double) | Draws and fills the interior of a rectangle specified by a coordinate pair, a width, and a height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawRectangle(PdfPen,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRectangle Method : DrawRectangle(PdfPen,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the rectangle.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Draws a rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(pen, x, y, width, height)
public void DrawRectangle(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height
)
public:
void DrawRectangle(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height
)

Parameters

pen
PdfPen that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRectangle(PdfPen,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRectangle Method : DrawRectangle(PdfPen,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the rectangle.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Rotation of the rectangle around the upper-left corner.
Draws a rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double

instance.DrawRectangle(pen, x, y, width, height, rotation)
public void DrawRectangle(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
void DrawRectangle(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
rotation
Rotation of the rectangle around the upper-left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRectangle(PdfBrush,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRectangle Method : DrawRectangle(PdfBrush,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Fills the interior of a rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(brush, x, y, width, height)
public void DrawRectangle(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height
)
public:
void DrawRectangle(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRectangle(PdfBrush,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRectangle Method : DrawRectangle(PdfBrush,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Rotation of the rectangle around the upper-left corner.
Fills the interior of a rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double

instance.DrawRectangle(brush, x, y, width, height, rotation)
public void DrawRectangle(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
void DrawRectangle(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
rotation
Rotation of the rectangle around the upper-left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRectangle(PdfPen,PdfBrush,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRectangle Method : DrawRectangle(PdfPen,PdfBrush,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the rectangle.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Draws and fills the interior of a rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(pen, brush, x, y, width, height)
public void DrawRectangle(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height
)
public:
void DrawRectangle(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height
)

Parameters

pen
PdfPen that determines the color, width, and style of the rectangle.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRectangle Method : DrawRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the rectangle.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Rotation of the rectangle around the upper-left corner.
Draws and fills the interior of a rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRectangle( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double

instance.DrawRectangle(pen, brush, x, y, width, height, rotation)
public void DrawRectangle(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
void DrawRectangle(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the rectangle.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
rotation
Rotation of the rectangle around the upper-left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRoundRectangle Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawRoundRectangle Method
Draws a rounded rectangle specified by a coordinate pair, a width, and a height.
Overload List
Overload | Description
DrawRoundRectangle(PdfPen,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a coordinate pair, a width, and a height.
DrawRoundRectangle(PdfPen,Double,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a coordinate pair, a width, and a height.
DrawRoundRectangle(PdfBrush,Double,Double,Double,Double,Double,Double) | Fills the interior of rounded rectangle specified by a coordinate pair, a width, and a height.
DrawRoundRectangle(PdfBrush,Double,Double,Double,Double,Double,Double,Double) | Fills the interior of rounded rectangle specified by a coordinate pair, a width, and a height.
DrawRoundRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) | Draws and fills the interior of a rounded rectangle specified by a coordinate pair, a width, and a height.
DrawRoundRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) | Draws and fills the interior of rounded rectangle specified by a coordinate pair, a width, and a height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawRoundRectangle(PdfPen,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRoundRectangle Method : DrawRoundRectangle(PdfPen,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the rectangle.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Width of the ellipse that defines the rounded corners.
Height of the ellipse that defines the rounded corners.
Draws a rounded rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(pen, x, y, width, height, ellipseWidth, ellipseHeight)
public void DrawRoundRectangle(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public:
void DrawRoundRectangle(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

pen
PdfPen that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
ellipseWidth
Width of the ellipse that defines the rounded corners.
ellipseHeight
Height of the ellipse that defines the rounded corners.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRoundRectangle(PdfPen,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRoundRectangle Method : DrawRoundRectangle(PdfPen,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the rectangle.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Width of the ellipse that defines the rounded corners.
Height of the ellipse that defines the rounded corners.
Rotation of the rectangle around the upper-left corner.
Draws a rounded rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal pen As PdfPen, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim rotation As Double

instance.DrawRoundRectangle(pen, x, y, width, height, ellipseWidth, ellipseHeight, rotation)
public void DrawRoundRectangle(
   PdfPen pen,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double rotation
)
public:
void DrawRoundRectangle(
   PdfPen^ pen,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
ellipseWidth
Width of the ellipse that defines the rounded corners.
ellipseHeight
Height of the ellipse that defines the rounded corners.
rotation
Rotation of the rectangle around the upper-left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRoundRectangle(PdfBrush,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRoundRectangle Method : DrawRoundRectangle(PdfBrush,Double,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Width of the ellipse that defines the rounded corners.
Height of the ellipse that defines the rounded corners.
Fills the interior of rounded rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(brush, x, y, width, height, ellipseWidth, ellipseHeight)
public void DrawRoundRectangle(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public:
void DrawRoundRectangle(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
ellipseWidth
Width of the ellipse that defines the rounded corners.
ellipseHeight
Height of the ellipse that defines the rounded corners.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRoundRectangle(PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRoundRectangle Method : DrawRoundRectangle(PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Width of the ellipse that defines the rounded corners.
Height of the ellipse that defines the rounded corners.
Rotation of the rectangle around the upper-left corner.
Fills the interior of rounded rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim rotation As Double

instance.DrawRoundRectangle(brush, x, y, width, height, ellipseWidth, ellipseHeight, rotation)
public void DrawRoundRectangle(
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double rotation
)
public:
void DrawRoundRectangle(
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double rotation
)

Parameters

brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
ellipseWidth
Width of the ellipse that defines the rounded corners.
ellipseHeight
Height of the ellipse that defines the rounded corners.
rotation
Rotation of the rectangle around the upper-left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRoundRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRoundRectangle Method : DrawRoundRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the rectangle.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Width of the ellipse that defines the rounded corners.
Height of the ellipse that defines the rounded corners.
Draws and fills the interior of a rounded rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(pen, brush, x, y, width, height, ellipseWidth, ellipseHeight)
public void DrawRoundRectangle(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public:
void DrawRoundRectangle(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

pen
PdfPen that determines the color, width, and style of the rectangle.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
ellipseWidth
Width of the ellipse that defines the rounded corners.
ellipseHeight
Height of the ellipse that defines the rounded corners.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawRoundRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawRoundRectangle Method : DrawRoundRectangle(PdfPen,PdfBrush,Double,Double,Double,Double,Double,Double,Double) Method
PdfPen that determines the color, width, and style of the rectangle.
PdfBrush that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the rectangle to draw.
The y-coordinate of the upper-left corner of the rectangle to draw.
Width of the rectangle to draw.
Height of the rectangle to draw.
Width of the ellipse that defines the rounded corners.
Height of the ellipse that defines the rounded corners.
Rotation of the rectangle around the upper-left corner.
Draws and fills the interior of rounded rectangle specified by a coordinate pair, a width, and a height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawRoundRectangle( _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal rotation As Double _
)
'Usage

Dim instance As PdfGraphics
Dim pen As PdfPen
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim rotation As Double

instance.DrawRoundRectangle(pen, brush, x, y, width, height, ellipseWidth, ellipseHeight, rotation)
public void DrawRoundRectangle(
   PdfPen pen,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double rotation
)
public:
void DrawRoundRectangle(
   PdfPen^ pen,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double rotation
)

Parameters

pen
PdfPen that determines the color, width, and style of the rectangle.
brush
PdfBrush that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
Width of the rectangle to draw.
height
Height of the rectangle to draw.
ellipseWidth
Width of the ellipse that defines the rounded corners.
ellipseHeight
Height of the ellipse that defines the rounded corners.
rotation
Rotation of the rectangle around the upper-left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawShading Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawShading Method
The shading to draw on the PDF page.
Draws a PDF shading.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub DrawShading( _
   ByVal shading As PdfShading _
)
'Usage

Dim instance As PdfGraphics
Dim shading As PdfShading

instance.DrawShading(shading)
public void DrawShading(
   PdfShading shading
)
public:
void DrawShading(
   PdfShading^ shading
)

Parameters

shading
The shading to draw on the PDF page.
Remarks
The position of the shading is defined on the PdfShading object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawStencilMask Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawStencilMask Method
Draws the specified PdfStencilMask at the specified location and with the specified size.
Overload List
Overload | Description
DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double) | Draws the specified PdfStencilMask at the specified location and with the specified size.
DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double,Double) | Draws the specified PdfStencilMask at the specified location and with the specified size.
DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double,Double,PdfFlipDirection) | Draws the specified PdfStencilMask at the specified location and with the specified size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawStencilMask Method : DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double) Method
PdfStencilMask to draw.
PdfBrush that defines the characteristics of the stencil mask fill.
The x-coordinate of the upper-left corner of the drawn stencil mask.
The y-coordinate of the upper-left corner of the drawn stencil mask.
Width of the drawn stencil mask.
Height of the drawn stencil mask.
Draws the specified PdfStencilMask at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DrawStencilMask( _
   ByVal stencilMask As PdfStencilMask, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
) As PdfSize
'Usage

Dim instance As PdfGraphics
Dim stencilMask As PdfStencilMask
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim value As PdfSize

value = instance.DrawStencilMask(stencilMask, brush, x, y, width, height)
public PdfSize DrawStencilMask(
   PdfStencilMask stencilMask,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height
)
public:
PdfSize^ DrawStencilMask(
   PdfStencilMask^ stencilMask,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height
)

Parameters

stencilMask
PdfStencilMask to draw.
brush
PdfBrush that defines the characteristics of the stencil mask fill.
x
The x-coordinate of the upper-left corner of the drawn stencil mask.
y
The y-coordinate of the upper-left corner of the drawn stencil mask.
width
Width of the drawn stencil mask.
height
Height of the drawn stencil mask.

Return Value

The size of the drawn stencil mask.
Remarks
A stencil mask is a B/W image where the 1 pixels are left transparent and 0 pixels are filled with the brush.
If width is zero or negative then width is automatically computed in order to keep the original aspect ratio. If height is zero or negative then height is automatically computed in order to keep the original aspect ratio. If both width and height are negative then the stencil mask is scaled automatically to fit the given area and the original aspect ratio is kept.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawStencilMask Method : DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double,Double) Method
PdfStencilMask to draw.
PdfBrush that defines the characteristics of the stencil mask fill.
The x-coordinate of the upper-left corner of the drawn stencil mask.
The y-coordinate of the upper-left corner of the drawn stencil mask.
Width of the drawn stencil mask.
Height of the drawn stencil mask.
Rotation angle of the drawn stencil mask.
Draws the specified PdfStencilMask at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DrawStencilMask( _
   ByVal stencilMask As PdfStencilMask, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double _
) As PdfSize
'Usage

Dim instance As PdfGraphics
Dim stencilMask As PdfStencilMask
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double
Dim value As PdfSize

value = instance.DrawStencilMask(stencilMask, brush, x, y, width, height, rotation)
public PdfSize DrawStencilMask(
   PdfStencilMask stencilMask,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)
public:
PdfSize^ DrawStencilMask(
   PdfStencilMask^ stencilMask,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double rotation
)

Parameters

stencilMask
PdfStencilMask to draw.
brush
PdfBrush that defines the characteristics of the stencil mask fill.
x
The x-coordinate of the upper-left corner of the drawn stencil mask.
y
The y-coordinate of the upper-left corner of the drawn stencil mask.
width
Width of the drawn stencil mask.
height
Height of the drawn stencil mask.
rotation
Rotation angle of the drawn stencil mask.

Return Value

The size of the drawn stencil mask.
Remarks
A stencil mask is a B/W image where the 1 pixels are left transparent and 0 pixels are filled with the brush.
If width is zero or negative then width is automatically computed in order to keep the original aspect ratio. If height is zero or negative then height is automatically computed in order to keep the original aspect ratio. If both width and height are negative then the stencil mask is scaled automatically to fit the given area and the original aspect ratio is kept.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double,Double,PdfFlipDirection) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawStencilMask Method : DrawStencilMask(PdfStencilMask,PdfBrush,Double,Double,Double,Double,Double,PdfFlipDirection) Method
PdfStencilMask to draw.
PdfBrush that defines the characteristics of the stencil mask fill.
The x-coordinate of the upper-left corner of the drawn stencil mask.
The y-coordinate of the upper-left corner of the drawn stencil mask.
Width of the drawn stencil mask.
Height of the drawn stencil mask.
Rotation angle of the drawn stencil mask.
Direction for flipping the drawn stencil mask.
Draws the specified PdfStencilMask at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function DrawStencilMask( _
   ByVal stencilMask As PdfStencilMask, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal rotation As Double, _
   ByVal flipDirection As PdfFlipDirection _
) As PdfSize
'Usage

Dim instance As PdfGraphics
Dim stencilMask As PdfStencilMask
Dim brush As PdfBrush
Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double
Dim rotation As Double
Dim flipDirection As PdfFlipDirection
Dim value As PdfSize

value = instance.DrawStencilMask(stencilMask, brush, x, y, width, height, rotation, flipDirection)
public PdfSize DrawStencilMask(
   PdfStencilMask stencilMask,
   PdfBrush brush,
   double x,
   double y,
   double width,
   double height,
   double rotation,
   PdfFlipDirection flipDirection
)
public:
PdfSize^ DrawStencilMask(
   PdfStencilMask^ stencilMask,
   PdfBrush^ brush,
   double x,
   double y,
   double width,
   double height,
   double rotation,
   PdfFlipDirection flipDirection
)

Parameters

stencilMask
PdfStencilMask to draw.
brush
PdfBrush that defines the characteristics of the stencil mask fill.
x
The x-coordinate of the upper-left corner of the drawn stencil mask.
y
The y-coordinate of the upper-left corner of the drawn stencil mask.
width
Width of the drawn stencil mask.
height
Height of the drawn stencil mask.
rotation
Rotation angle of the drawn stencil mask.
flipDirection
Direction for flipping the drawn stencil mask.

Return Value

The size of the drawn stencil mask.
Remarks
A stencil mask is a B/W image where the 1 pixels are left transparent and 0 pixels are filled with the brush.
If width is zero or negative then width is automatically computed in order to keep the original aspect ratio. If height is zero or negative then height is automatically computed in order to keep the original aspect ratio. If both width and height are negative then the stencil mask is scaled automatically to fit the given area and the original aspect ratio is kept.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawString Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : DrawString Method
Draws the specified text string at the specified location with the specified PdfBrush and PdfFont objects.
Overload List
Overload | Description
DrawString(String,PdfFont,PdfBrush,Double,Double) | Draws the specified text string at the specified location with the specified PdfBrush and PdfFont objects.
DrawString(String,PdfFont,PdfBrush,PdfVisualRectangle) | Draws the specified text string in the specified rectangle with the specified PdfBrush and PdfFont objects.
DrawString(String,PdfStringAppearanceOptions,PdfStringLayoutOptions) | Draws the specified text string with the specified appearance and layout options.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


DrawString(String,PdfFont,PdfBrush,Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawString Method : DrawString(String,PdfFont,PdfBrush,Double,Double) Method
String to draw.
PdfFont that defines the text format of the string.
PdfBrush that determines the color and texture of the drawn text.
The x-coordinate of the upper-left corner of the drawn text.
The y-coordinate of the upper-left corner of the drawn text.
Draws the specified text string at the specified location with the specified PdfBrush and PdfFont objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawString( _
   ByVal s As String, _
   ByVal font As PdfFont, _
   ByVal brush As PdfBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PdfGraphics
Dim s As String
Dim font As PdfFont
Dim brush As PdfBrush
Dim x As Double
Dim y As Double

instance.DrawString(s, font, brush, x, y)
public void DrawString(
   string s,
   PdfFont font,
   PdfBrush brush,
   double x,
   double y
)
public:
void DrawString(
   String^ s,
   PdfFont^ font,
   PdfBrush^ brush,
   double x,
   double y
)

Parameters

s
String to draw.
font
PdfFont that defines the text format of the string.
brush
PdfBrush that determines the color and texture of the drawn text.
x
The x-coordinate of the upper-left corner of the drawn text.
y
The y-coordinate of the upper-left corner of the drawn text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawString(String,PdfFont,PdfBrush,PdfVisualRectangle) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawString Method : DrawString(String,PdfFont,PdfBrush,PdfVisualRectangle) Method
String to draw.
PdfFont that defines the text format of the string.
PdfBrush that determines the color and texture of the drawn text.
PdfVisualRectangle object that specifies the location of the drawn text.
Draws the specified text string in the specified rectangle with the specified PdfBrush and PdfFont objects.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawString( _
   ByVal s As String, _
   ByVal font As PdfFont, _
   ByVal brush As PdfBrush, _
   ByVal rectangle As PdfVisualRectangle _
)
'Usage

Dim instance As PdfGraphics
Dim s As String
Dim font As PdfFont
Dim brush As PdfBrush
Dim rectangle As PdfVisualRectangle

instance.DrawString(s, font, brush, rectangle)
public void DrawString(
   string s,
   PdfFont font,
   PdfBrush brush,
   PdfVisualRectangle rectangle
)
public:
void DrawString(
   String^ s,
   PdfFont^ font,
   PdfBrush^ brush,
   PdfVisualRectangle^ rectangle
)

Parameters

s
String to draw.
font
PdfFont that defines the text format of the string.
brush
PdfBrush that determines the color and texture of the drawn text.
rectangle
PdfVisualRectangle object that specifies the location of the drawn text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


DrawString(String,PdfStringAppearanceOptions,PdfStringLayoutOptions) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > DrawString Method : DrawString(String,PdfStringAppearanceOptions,PdfStringLayoutOptions) Method
String to draw.
Options that determine the string visual appearance.
Options that determine the text layout.
Draws the specified text string with the specified appearance and layout options.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub DrawString( _
   ByVal s As String, _
   ByVal stringAppearanceOptions As PdfStringAppearanceOptions, _
   ByVal stringLayoutOptions As PdfStringLayoutOptions _
)
'Usage

Dim instance As PdfGraphics
Dim s As String
Dim stringAppearanceOptions As PdfStringAppearanceOptions
Dim stringLayoutOptions As PdfStringLayoutOptions

instance.DrawString(s, stringAppearanceOptions, stringLayoutOptions)
public void DrawString(
   string s,
   PdfStringAppearanceOptions stringAppearanceOptions,
   PdfStringLayoutOptions stringLayoutOptions
)
public:
void DrawString(
   String^ s,
   PdfStringAppearanceOptions^ stringAppearanceOptions,
   PdfStringLayoutOptions^ stringLayoutOptions
)

Parameters

s
String to draw.
stringAppearanceOptions
Options that determine the string visual appearance.
stringLayoutOptions
Options that determine the text layout.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


EndMarkedContent Method (PdfGraphics)

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : EndMarkedContent Method
Ends a marked content sequence.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub EndMarkedContent()
'Usage

Dim instance As PdfGraphics

instance.EndMarkedContent()
public void EndMarkedContent()
public:
void EndMarkedContent();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


MultiplyTransform Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : MultiplyTransform Method
The m11 component of the matrix.
The m12 component of the matrix.
The m21 component of the matrix.
The m22 component of the matrix.
The x-translation component of the matrix.
The y-translation component of the matrix.
Multiplies the current transformation of this graphics and specified the matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub MultiplyTransform( _
   ByVal m11 As Double, _
   ByVal m12 As Double, _
   ByVal m21 As Double, _
   ByVal m22 As Double, _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim instance As PdfGraphics
Dim m11 As Double
Dim m12 As Double
Dim m21 As Double
Dim m22 As Double
Dim tx As Double
Dim ty As Double

instance.MultiplyTransform(m11, m12, m21, m22, tx, ty)
public void MultiplyTransform(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)
public:
void MultiplyTransform(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)

Parameters

m11
The m11 component of the matrix.
m12
The m12 component of the matrix.
m21
The m21 component of the matrix.
m22
The m22 component of the matrix.
tx
The x-translation component of the matrix.
ty
The y-translation component of the matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


RestoreGraphicsState Method (PdfGraphics)

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : RestoreGraphicsState Method
Restores the current state of this graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RestoreGraphicsState()
'Usage

Dim instance As PdfGraphics

instance.RestoreGraphicsState()
public void RestoreGraphicsState()
public:
void RestoreGraphicsState();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


RotateTransform Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : RotateTransform Method
Angle of rotation in degrees.
Applies the specified rotation to the transformation matrix of this graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RotateTransform( _
   ByVal rotate As Double _
)
'Usage

Dim instance As PdfGraphics
Dim rotate As Double

instance.RotateTransform(rotate)
public void RotateTransform(
   double rotate
)
public:
void RotateTransform(
   double rotate
)

Parameters

rotate
Angle of rotation in degrees.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


SaveGraphicsState Method (PdfGraphics)

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : SaveGraphicsState Method
Saves the current state of this graphics
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SaveGraphicsState()
'Usage

Dim instance As PdfGraphics

instance.SaveGraphicsState()
public void SaveGraphicsState()
public:
void SaveGraphicsState();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


ScaleTransform Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : ScaleTransform Method
Scale factor in the x direction.
Scale factor in the y direction.
Applies the specified scaling operation to the transformation matrix of this graphics by prepending it to the object's transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ScaleTransform( _
   ByVal sx As Double, _
   ByVal sy As Double _
)
'Usage

Dim instance As PdfGraphics
Dim sx As Double
Dim sy As Double

instance.ScaleTransform(sx, sy)
public void ScaleTransform(
   double sx,
   double sy
)
public:
void ScaleTransform(
   double sx,
   double sy
)

Parameters

sx
Scale factor in the x direction.
sy
Scale factor in the y direction.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


SetClip Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : SetClip Method
Sets the clipping region of this graphics to the specified PdfPath.
Overload List
Overload | Description
SetClip(PdfPath) | Sets the clipping region of this graphics to the specified PdfPath.
SetClip(PdfPath,PdfFillMode) | Sets the clipping region of this graphics to the specified PdfPath.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


SetClip(PdfPath) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > SetClip Method : SetClip(PdfPath) Method
PdfPath that represents the new clip region.
Sets the clipping region of this graphics to the specified PdfPath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetClip( _
   ByVal path As PdfPath _
)
'Usage

Dim instance As PdfGraphics
Dim path As PdfPath

instance.SetClip(path)
public void SetClip(
   PdfPath path
)
public:
void SetClip(
   PdfPath^ path
)

Parameters

path
PdfPath that represents the new clip region.
Remarks
The actual clipping path is the intersection of the previous clipping path with this new clipping path. It is recommended to save the graphics state (see SaveGraphicsState method) before setting a clipping path and restore the graphics state (see RestoreGraphicsState method) after the clipping path is no longer needed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


SetClip(PdfPath,PdfFillMode) Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class > SetClip Method : SetClip(PdfPath,PdfFillMode) Method
PdfPath that represents the new clip region.
Path fill mode.
Sets the clipping region of this graphics to the specified PdfPath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub SetClip( _
   ByVal path As PdfPath, _
   ByVal fillMode As PdfFillMode _
)
'Usage

Dim instance As PdfGraphics
Dim path As PdfPath
Dim fillMode As PdfFillMode

instance.SetClip(path, fillMode)
public void SetClip(
   PdfPath path,
   PdfFillMode fillMode
)
public:
void SetClip(
   PdfPath^ path,
   PdfFillMode fillMode
)

Parameters

path
PdfPath that represents the new clip region.
fillMode
Path fill mode.
Remarks
The actual clipping path is the intersection of the previous clipping path with this new clipping path. It is recommended to save the graphics state (see SaveGraphicsState method) before setting a clipping path and restore the graphics state (see RestoreGraphicsState method) after the clipping path is no longer needed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members
Overload List


SetExtendedGraphicState Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : SetExtendedGraphicState Method
The new graphics state.
Sets a new graphics state in this graphics object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub SetExtendedGraphicState( _
   ByVal extendedGraphicState As PdfExtendedGraphicState _
)
'Usage

Dim instance As PdfGraphics
Dim extendedGraphicState As PdfExtendedGraphicState

instance.SetExtendedGraphicState(extendedGraphicState)
public void SetExtendedGraphicState(
   PdfExtendedGraphicState extendedGraphicState
)
public:
void SetExtendedGraphicState(
   PdfExtendedGraphicState^ extendedGraphicState
)

Parameters

extendedGraphicState
The new graphics state.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


TranslateTransform Method

Xfinium.Pdf.Graphics Namespace > PdfGraphics Class : TranslateTransform Method
The x-coordinate of the translation.
The y-coordinate of the translation.
Changes the origin of the coordinate system by prepending the specified translation to the transformation matrix of this graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub TranslateTransform( _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim instance As PdfGraphics
Dim tx As Double
Dim ty As Double

instance.TranslateTransform(tx, ty)
public void TranslateTransform(
   double tx,
   double ty
)
public:
void TranslateTransform(
   double tx,
   double ty
)

Parameters

tx
The x-coordinate of the translation.
ty
The y-coordinate of the translation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGraphics Class
PdfGraphics Members


%%PageItemTitle%%

PdfGrayColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfGrayColor Class
Defines a device gray color.
Object Model
PdfGrayColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfGrayColor
   Inherits PdfColor
'Usage

Dim instance As PdfGrayColor
public class PdfGrayColor : PdfColor
public ref class PdfGrayColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfGrayColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfGrayColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfGrayColor Class

The following tables list the members exposed by PdfGrayColor.

Public Constructors
 | Name | Description
Public Constructor | PdfGrayColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | G | Gets or sets the gray component.
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfGrayColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfGrayColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfGrayColor Class : PdfGrayColor Constructor
Overload List
Overload | Description
PdfGrayColor Constructor() | Initializes a new PdfGrayColor object.
PdfGrayColor Constructor(Double) | Initializes a new PdfGrayColor object with the gray component.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColor Class
PdfGrayColor Members


%%PageItemTitle%%

PdfGrayColor Constructor()

Xfinium.Pdf.Graphics Namespace > PdfGrayColor Class > PdfGrayColor Constructor : PdfGrayColor Constructor()
Initializes a new PdfGrayColor object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfGrayColor()
public PdfGrayColor()
public:
PdfGrayColor();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColor Class
PdfGrayColor Members
Overload List


%%PageItemTitle%%

PdfGrayColor Constructor(Double)

Xfinium.Pdf.Graphics Namespace > PdfGrayColor Class > PdfGrayColor Constructor : PdfGrayColor Constructor(Double)
Gray component.
Initializes a new PdfGrayColor object with the gray component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal g As Double _
)
'Usage

Dim g As Double

Dim instance As New PdfGrayColor(g)
public PdfGrayColor(
   double g
)
public:
PdfGrayColor(
   double g
)

Parameters

g
Gray component.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColor Class
PdfGrayColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfGrayColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfGrayColor Class

For a list of all members of this type, see PdfGrayColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfGrayColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfGrayColor)

Xfinium.Pdf.Graphics Namespace > PdfGrayColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfGrayColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColor Class
PdfGrayColor Members


Equals Method (PdfGrayColor)

Xfinium.Pdf.Graphics Namespace > PdfGrayColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfGrayColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColor Class
PdfGrayColor Members


GetHashCode Method (PdfGrayColor)

Xfinium.Pdf.Graphics Namespace > PdfGrayColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfGrayColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColor Class
PdfGrayColor Members


%%PageItemTitle%% $$Properties$$

PdfGrayColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfGrayColor Class

For a list of all members of this type, see PdfGrayColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | G | Gets or sets the gray component.
Top
See Also

Reference

PdfGrayColor Class
Xfinium.Pdf.Graphics Namespace


G Property (PdfGrayColor)

Xfinium.Pdf.Graphics Namespace > PdfGrayColor Class : G Property
Gets or sets the gray component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property G As Double
'Usage

Dim instance As PdfGrayColor
Dim value As Double

instance.G = value

value = instance.G
public double G {get; set;}
public:
property double G {
   double get();
   void set (    double value);
}

Property Value

The gray component in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColor Class
PdfGrayColor Members


%%PageItemTitle%%

PdfGrayColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfGrayColorSpace Class
Defines a device gray colorspace.
Object Model
PdfGrayColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfGrayColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfGrayColorSpace
public class PdfGrayColorSpace : PdfColorSpace
public ref class PdfGrayColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfGrayColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfGrayColorSpace Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfGrayColorSpace Class

The following tables list the members exposed by PdfGrayColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfGrayColorSpace Constructor | Initializes a new PdfGrayColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Top
See Also

Reference

PdfGrayColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfGrayColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfGrayColorSpace Class : PdfGrayColorSpace Constructor
Initializes a new PdfGrayColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfGrayColorSpace()
public PdfGrayColorSpace()
public:
PdfGrayColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColorSpace Class
PdfGrayColorSpace Members


%%PageItemTitle%% $$Methods$$

PdfGrayColorSpace Class Methods

Xfinium.Pdf.Graphics Namespace : PdfGrayColorSpace Class

For a list of all members of this type, see PdfGrayColorSpace members.

Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Top
See Also

Reference

PdfGrayColorSpace Class
Xfinium.Pdf.Graphics Namespace


Equals Method (PdfGrayColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfGrayColorSpace Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfGrayColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColorSpace Class
PdfGrayColorSpace Members


GetHashCode Method (PdfGrayColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfGrayColorSpace Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfGrayColorSpace
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColorSpace Class
PdfGrayColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfGrayColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfGrayColorSpace Class

For a list of all members of this type, see PdfGrayColorSpace members.

Public Properties
 | Name | Description
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfGrayColorSpace Class
Xfinium.Pdf.Graphics Namespace


ColorComponentCount Property (PdfGrayColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfGrayColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfGrayColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGrayColorSpace Class
PdfGrayColorSpace Members


%%PageItemTitle%%

PdfGroupXObject Class
Members

Xfinium.Pdf.Graphics Namespace : PdfGroupXObject Class
Defines a group associated with a PdfFormXObject.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfGroupXObject
'Usage

Dim instance As PdfGroupXObject
public class PdfGroupXObject
public ref class PdfGroupXObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfGroupXObject
Xfinium.Pdf.Graphics.PdfTransparencyGroup

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGroupXObject Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfGroupXObject Class Members

Xfinium.Pdf.Graphics Namespace : PdfGroupXObject Class

The following tables list the members exposed by PdfGroupXObject.

See Also

Reference

PdfGroupXObject Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIata25Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIata25Barcode Class
Defines an IATA 2 of 5 barcode.
Object Model
PdfIata25Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIata25Barcode
   Inherits PdfCode25Barcode
'Usage

Dim instance As PdfIata25Barcode
public class PdfIata25Barcode : PdfCode25Barcode
public ref class PdfIata25Barcode : public PdfCode25Barcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfIata25Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIata25Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIata25Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfIata25Barcode Class

The following tables list the members exposed by PdfIata25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfIata25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIata25Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIata25Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfIata25Barcode Class : PdfIata25Barcode Constructor
Overload List
Overload | Description
PdfIata25Barcode Constructor() | Initializes a new PdfIata25Barcode object.
PdfIata25Barcode Constructor(String) | Initializes a new PdfIata25Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIata25Barcode Class
PdfIata25Barcode Members


%%PageItemTitle%%

PdfIata25Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfIata25Barcode Class > PdfIata25Barcode Constructor : PdfIata25Barcode Constructor()
Initializes a new PdfIata25Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfIata25Barcode()
public PdfIata25Barcode()
public:
PdfIata25Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIata25Barcode Class
PdfIata25Barcode Members
Overload List


%%PageItemTitle%%

PdfIata25Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfIata25Barcode Class > PdfIata25Barcode Constructor : PdfIata25Barcode Constructor(String)
The barcode data.
Initializes a new PdfIata25Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfIata25Barcode(data)
public PdfIata25Barcode(
   string data
)
public:
PdfIata25Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIata25Barcode Class
PdfIata25Barcode Members
Overload List


%%PageItemTitle%%

PdfIccColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIccColor Class
Defines an ICC color based on an ICC colorspace.
Object Model
PdfIccColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIccColor
   Inherits PdfColor
'Usage

Dim instance As PdfIccColor
public class PdfIccColor : PdfColor
public ref class PdfIccColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfIccColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIccColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfIccColor Class

The following tables list the members exposed by PdfIccColor.

Public Constructors
 | Name | Description
Public Constructor | PdfIccColor Constructor | Initializes a new PdfIccColor object with an ICC colorspace.
Top
Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfIccColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIccColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfIccColor Class : PdfIccColor Constructor
The ICC colorspace.
Initializes a new PdfIccColor object with an ICC colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PdfIccColorSpace _
)
'Usage

Dim colorSpace As PdfIccColorSpace

Dim instance As New PdfIccColor(colorSpace)
public PdfIccColor(
   PdfIccColorSpace colorSpace
)
public:
PdfIccColor(
   PdfIccColorSpace^ colorSpace
)

Parameters

colorSpace
The ICC colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColor Class
PdfIccColor Members


%%PageItemTitle%% $$Methods$$

PdfIccColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfIccColor Class

For a list of all members of this type, see PdfIccColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfIccColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfIccColor)

Xfinium.Pdf.Graphics Namespace > PdfIccColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfIccColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColor Class
PdfIccColor Members


Equals Method (PdfIccColor)

Xfinium.Pdf.Graphics Namespace > PdfIccColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfIccColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColor Class
PdfIccColor Members


GetHashCode Method (PdfIccColor)

Xfinium.Pdf.Graphics Namespace > PdfIccColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfIccColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColor Class
PdfIccColor Members


%%PageItemTitle%% $$Properties$$

PdfIccColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIccColor Class

For a list of all members of this type, see PdfIccColor members.

Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfIccColor Class
Xfinium.Pdf.Graphics Namespace


ColorComponents Property (PdfIccColor)

Xfinium.Pdf.Graphics Namespace > PdfIccColor Class : ColorComponents Property
Gets or sets the color components.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows Property ColorComponents As Double()
'Usage

Dim instance As PdfIccColor
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
public new double[] ColorComponents {get; set;}
public:
new property array<double>^ ColorComponents {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of numbers, one for each color component.
Remarks
The number of color components must be equal to the value of PdfIccColorSpace.ColorComponents property on the ICC colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColor Class
PdfIccColor Members


%%PageItemTitle%%

PdfIccColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIccColorSpace Class
Defines a colorspace based on an ICC profile.
Object Model
PdfIccColorSpace ClassPdfColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIccColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfIccColorSpace
public class PdfIccColorSpace : PdfColorSpace
public ref class PdfIccColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfIccColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIccColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfIccColorSpace Class

The following tables list the members exposed by PdfIccColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfIccColorSpace Constructor | Initializes a new PdfIccColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | ColorComponents | Gets or sets the number of color components.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | IccProfile | Gets or sets the content of the ICC profile.
Public Property | Range | Gets or sets the range of color components.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfIccColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIccColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfIccColorSpace Class : PdfIccColorSpace Constructor
Initializes a new PdfIccColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfIccColorSpace()
public PdfIccColorSpace()
public:
PdfIccColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColorSpace Class
PdfIccColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfIccColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIccColorSpace Class

For a list of all members of this type, see PdfIccColorSpace members.

Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | ColorComponents | Gets or sets the number of color components.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | IccProfile | Gets or sets the content of the ICC profile.
Public Property | Range | Gets or sets the range of color components.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfIccColorSpace Class
Xfinium.Pdf.Graphics Namespace


AlternateColorSpace Property (PdfIccColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfIccColorSpace Class : AlternateColorSpace Property
Gets or sets the alternate colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AlternateColorSpace As PdfColorSpace
'Usage

Dim instance As PdfIccColorSpace
Dim value As PdfColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
public PdfColorSpace AlternateColorSpace {get; set;}
public:
property PdfColorSpace^ AlternateColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

An alternate color space to be used in case the one specified in the stream data is not supported.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColorSpace Class
PdfIccColorSpace Members


ColorComponentCount Property (PdfIccColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfIccColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfIccColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColorSpace Class
PdfIccColorSpace Members


ColorComponents Property (PdfIccColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfIccColorSpace Class : ColorComponents Property
Gets or sets the number of color components.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorComponents As Integer
'Usage

Dim instance As PdfIccColorSpace
Dim value As Integer

instance.ColorComponents = value

value = instance.ColorComponents
public int ColorComponents {get; set;}
public:
property int ColorComponents {
   int get();
   void set (    int value);
}

Property Value

The number of color components in the color space described by the ICC profile data.
Remarks
This number must match the number of components actually in the ICC profile. As of PDF 1.4, this value must be 1, 3 or 4.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColorSpace Class
PdfIccColorSpace Members


IccProfile Property

Xfinium.Pdf.Graphics Namespace > PdfIccColorSpace Class : IccProfile Property
Gets or sets the content of the ICC profile.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IccProfile As Byte()
'Usage

Dim instance As PdfIccColorSpace
Dim value() As Byte

instance.IccProfile = value

value = instance.IccProfile
public byte[] IccProfile {get; set;}
public:
property array<byte>^ IccProfile {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The ICC profile content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColorSpace Class
PdfIccColorSpace Members


Range Property (PdfIccColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfIccColorSpace Class : Range Property
Gets or sets the range of color components.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Range As Double()
'Usage

Dim instance As PdfIccColorSpace
Dim value() As Double

instance.Range = value

value = instance.Range
public double[] Range {get; set;}
public:
property array<double>^ Range {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of 2 * ColorComponents numbers [ min0 max0 min1 max1 ... ] specifying the minimum and maximum valid values of the corresponding color components. These values must match the information in the ICC profile.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColorSpace Class
PdfIccColorSpace Members


%%PageItemTitle%%

PdfIdentcodeBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIdentcodeBarcode Class
Defines an Identcode barcode.
Object Model
PdfIdentcodeBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIdentcodeBarcode
   Inherits PdfCode25InterleavedBarcode
'Usage

Dim instance As PdfIdentcodeBarcode
public class PdfIdentcodeBarcode : PdfCode25InterleavedBarcode
public ref class PdfIdentcodeBarcode : public PdfCode25InterleavedBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 11 digits
Identcode barcode structure:
1 - 2 - Mail center (outgoing)
3 - 5 - Customer code
6 - 11 - Delivery number
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfCode25InterleavedBarcode
Xfinium.Pdf.Graphics.PdfIdentcodeBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIdentcodeBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIdentcodeBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfIdentcodeBarcode Class

The following tables list the members exposed by PdfIdentcodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfIdentcodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIdentcodeBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIdentcodeBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfIdentcodeBarcode Class : PdfIdentcodeBarcode Constructor
Overload List
Overload | Description
PdfIdentcodeBarcode Constructor() | Initializes a new PdfIdentcodeBarcode object.
PdfIdentcodeBarcode Constructor(String) | Initializes a new PdfIdentcodeBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIdentcodeBarcode Class
PdfIdentcodeBarcode Members


%%PageItemTitle%%

PdfIdentcodeBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfIdentcodeBarcode Class > PdfIdentcodeBarcode Constructor : PdfIdentcodeBarcode Constructor()
Initializes a new PdfIdentcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfIdentcodeBarcode()
public PdfIdentcodeBarcode()
public:
PdfIdentcodeBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIdentcodeBarcode Class
PdfIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PdfIdentcodeBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfIdentcodeBarcode Class > PdfIdentcodeBarcode Constructor : PdfIdentcodeBarcode Constructor(String)
The barcode data.
Initializes a new PdfIdentcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfIdentcodeBarcode(data)
public PdfIdentcodeBarcode(
   string data
)
public:
PdfIdentcodeBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIdentcodeBarcode Class
PdfIdentcodeBarcode Members
Overload List


%%PageItemTitle%%

PdfImage Class
Members

Xfinium.Pdf.Graphics Namespace : PdfImage Class
Defines a PDF image. Defines a PDF image.
Object Model
PdfImage ClassPdfAlternateImageCollection ClassPdfAlternateImage ClassPdfColorSpace ClassPdfCosDictionary ClassPdfImageMask ClassPdfMeasure ClassPdfPointData Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfImage
'Usage

Dim instance As PdfImage
public class PdfImage
public ref class PdfImage
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImage
Xfinium.Pdf.Graphics.PdfJpeg2000Image
Xfinium.Pdf.Graphics.PdfJpegImage
Xfinium.Pdf.Graphics.PdfPngImage
Xfinium.Pdf.Graphics.PdfRawImage
Xfinium.Pdf.Graphics.PdfTiffImage
Xfinium.Pdf.Graphics.PdfXLJpegImage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfImage Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfImage Class

The following tables list the members exposed by PdfImage.

Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images.
Public Property | BitsPerComponent | Gets or sets the bits per component.
Public Property | ColorSpace | Gets or sets the color space.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | Height | Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed.
Public Property | Mask | Gets or sets the image mask.
Public Property | Measure | Gets or sets the image measure.
Public Property | PointData | Gets or sets the point data.
Public Property | Width | Gets the image width.
Top
See Also

Reference

PdfImage Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfImage Class Properties

Xfinium.Pdf.Graphics Namespace : PdfImage Class

For a list of all members of this type, see PdfImage members.

Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images.
Public Property | BitsPerComponent | Gets or sets the bits per component.
Public Property | ColorSpace | Gets or sets the color space.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object.
Public Property | Height | Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed.
Public Property | Mask | Gets or sets the image mask.
Public Property | Measure | Gets or sets the image measure.
Public Property | PointData | Gets or sets the point data.
Public Property | Width | Gets the image width.
Top
See Also

Reference

PdfImage Class
Xfinium.Pdf.Graphics Namespace


AlternateImages Property

Xfinium.Pdf.Graphics Namespace > PdfImage Class : AlternateImages Property
Gets or sets the alternate images.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AlternateImages As PdfAlternateImageCollection
'Usage

Dim instance As PdfImage
Dim value As PdfAlternateImageCollection

instance.AlternateImages = value

value = instance.AlternateImages
public PdfAlternateImageCollection AlternateImages {get; set;}
public:
property PdfAlternateImageCollection^ AlternateImages {
   PdfAlternateImageCollection^ get();
   void set (    PdfAlternateImageCollection^ value);
}

Property Value

A collection of alternate images to be used instead of this image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


BitsPerComponent Property (PdfImage)

Xfinium.Pdf.Graphics Namespace > PdfImage Class : BitsPerComponent Property
Gets or sets the bits per component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BitsPerComponent As Integer
'Usage

Dim instance As PdfImage
Dim value As Integer

instance.BitsPerComponent = value

value = instance.BitsPerComponent
public int BitsPerComponent {get; set;}
public:
property int BitsPerComponent {
   int get();
   void set (    int value);
}

Property Value

The number of bits used to represent each color component.
Remarks
Valid values are 1, 2, 4, 8, and (in Pdf 1.5) 16
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


ColorSpace Property (PdfImage)

Xfinium.Pdf.Graphics Namespace > PdfImage Class : ColorSpace Property
Gets or sets the color space.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorSpace As PdfColorSpace
'Usage

Dim instance As PdfImage
Dim value As PdfColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PdfColorSpace ColorSpace {get; set;}
public:
property PdfColorSpace^ ColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

The color space in which image samples are specified.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


CosDictionary Property (PdfImage)

Xfinium.Pdf.Graphics Namespace > PdfImage Class : CosDictionary Property
Gets the COS dictionary asssociated with this object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property CosDictionary As PdfCosDictionary
'Usage

Dim instance As PdfImage
Dim value As PdfCosDictionary

value = instance.CosDictionary
public PdfCosDictionary CosDictionary {get;}
public:
property PdfCosDictionary^ CosDictionary {
   PdfCosDictionary^ get();
}

Property Value

The internal COS dictionary.
Remarks
Incorrect manipulation of the information in the COS dictionary can lead to invalid PDF files.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


Height Property (PdfImage)

Xfinium.Pdf.Graphics Namespace > PdfImage Class : Height Property
Gets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Height As Integer
'Usage

Dim instance As PdfImage
Dim value As Integer

instance.Height = value

value = instance.Height
public virtual int Height {get; set;}
public:
virtual property int Height {
   int get();
   void set (    int value);
}

Property Value

The image height in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


Interpolate Property

Xfinium.Pdf.Graphics Namespace > PdfImage Class : Interpolate Property
Gets or sets a value indicating whether image interpolation is to be performed.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Interpolate As Boolean
'Usage

Dim instance As PdfImage
Dim value As Boolean

instance.Interpolate = value

value = instance.Interpolate
public bool Interpolate {get; set;}
public:
property bool Interpolate {
   bool get();
   void set (    bool value);
}

Property Value

If true, the image is interpolated when displayed on the output device.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


Mask Property (PdfImage)

Xfinium.Pdf.Graphics Namespace > PdfImage Class : Mask Property
Gets or sets the image mask.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Mask As PdfImageMask
'Usage

Dim instance As PdfImage
Dim value As PdfImageMask

instance.Mask = value

value = instance.Mask
public PdfImageMask Mask {get; set;}
public:
property PdfImageMask^ Mask {
   PdfImageMask^ get();
   void set (    PdfImageMask^ value);
}

Property Value

An image mask to be applied to this image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


Measure Property (PdfImage)

Xfinium.Pdf.Graphics Namespace > PdfImage Class : Measure Property
Gets or sets the image measure.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Measure As PdfMeasure
'Usage

Dim instance As PdfImage
Dim value As PdfMeasure

instance.Measure = value

value = instance.Measure
public PdfMeasure Measure {get; set;}
public:
property PdfMeasure^ Measure {
   PdfMeasure^ get();
   void set (    PdfMeasure^ value);
}

Property Value

A Xfinium.Pdf.Spatial.PdfMeasure descendant object that specifies the scale and units which shall apply to the image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


PointData Property (PdfImage)

Xfinium.Pdf.Graphics Namespace > PdfImage Class : PointData Property
Gets or sets the point data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PointData As PdfPointData
'Usage

Dim instance As PdfImage
Dim value As PdfPointData

instance.PointData = value

value = instance.PointData
public PdfPointData PointData {get; set;}
public:
property PdfPointData^ PointData {
   PdfPointData^ get();
   void set (    PdfPointData^ value);
}

Property Value

A Xfinium.Pdf.Spatial.PdfPointData object that specifies the extended geospatial data that shall apply to the image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


Width Property (PdfImage)

Xfinium.Pdf.Graphics Namespace > PdfImage Class : Width Property
Gets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Width As Integer
'Usage

Dim instance As PdfImage
Dim value As Integer

instance.Width = value

value = instance.Width
public virtual int Width {get; set;}
public:
virtual property int Width {
   int get();
   void set (    int value);
}

Property Value

The image width in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImage Class
PdfImage Members


%%PageItemTitle%%

PdfImageMask Class
Members

Xfinium.Pdf.Graphics Namespace : PdfImageMask Class
Defines an image mask.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfImageMask
'Usage

Dim instance As PdfImageMask
public abstract class PdfImageMask
public ref class PdfImageMask abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImageMask
Xfinium.Pdf.Graphics.PdfColorMask
Xfinium.Pdf.Graphics.PdfStencilMask

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfImageMask Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfImageMask Class Members

Xfinium.Pdf.Graphics Namespace : PdfImageMask Class

The following tables list the members exposed by PdfImageMask.

See Also

Reference

PdfImageMask Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIndexedColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIndexedColor Class
Defines a color based on an indexed colorspace.
Object Model
PdfIndexedColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIndexedColor
   Inherits PdfColor
'Usage

Dim instance As PdfIndexedColor
public class PdfIndexedColor : PdfColor
public ref class PdfIndexedColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfIndexedColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIndexedColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfIndexedColor Class

The following tables list the members exposed by PdfIndexedColor.

Public Constructors
 | Name | Description
Public Constructor | PdfIndexedColor Constructor | Initializes a new PdfIndexedColor object with an indexed colorspace.
Top
Public Properties
 | Name | Description
Public Property | ColorIndex | Gets or sets the color index.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfIndexedColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIndexedColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfIndexedColor Class : PdfIndexedColor Constructor
The indexed colorspace.
Initializes a new PdfIndexedColor object with an indexed colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PdfIndexedColorSpace _
)
'Usage

Dim colorSpace As PdfIndexedColorSpace

Dim instance As New PdfIndexedColor(colorSpace)
public PdfIndexedColor(
   PdfIndexedColorSpace colorSpace
)
public:
PdfIndexedColor(
   PdfIndexedColorSpace^ colorSpace
)

Parameters

colorSpace
The indexed colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColor Class
PdfIndexedColor Members


%%PageItemTitle%% $$Methods$$

PdfIndexedColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfIndexedColor Class

For a list of all members of this type, see PdfIndexedColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfIndexedColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfIndexedColor)

Xfinium.Pdf.Graphics Namespace > PdfIndexedColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfIndexedColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColor Class
PdfIndexedColor Members


Equals Method (PdfIndexedColor)

Xfinium.Pdf.Graphics Namespace > PdfIndexedColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfIndexedColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColor Class
PdfIndexedColor Members


GetHashCode Method (PdfIndexedColor)

Xfinium.Pdf.Graphics Namespace > PdfIndexedColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfIndexedColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColor Class
PdfIndexedColor Members


%%PageItemTitle%% $$Properties$$

PdfIndexedColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIndexedColor Class

For a list of all members of this type, see PdfIndexedColor members.

Public Properties
 | Name | Description
Public Property | ColorIndex | Gets or sets the color index.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfIndexedColor Class
Xfinium.Pdf.Graphics Namespace


ColorIndex Property

Xfinium.Pdf.Graphics Namespace > PdfIndexedColor Class : ColorIndex Property
Gets or sets the color index.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorIndex As Integer
'Usage

Dim instance As PdfIndexedColor
Dim value As Integer

instance.ColorIndex = value

value = instance.ColorIndex
public int ColorIndex {get; set;}
public:
property int ColorIndex {
   int get();
   void set (    int value);
}

Property Value

The color index in the colorspace samples in the range [0 - PdfIndexedColorSpace.ColorCount].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColor Class
PdfIndexedColor Members


%%PageItemTitle%%

PdfIndexedColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIndexedColorSpace Class
Defines an indexed colorspace based on a finite set of color samples.
Object Model
PdfIndexedColorSpace ClassPdfColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIndexedColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfIndexedColorSpace
public class PdfIndexedColorSpace : PdfColorSpace
public ref class PdfIndexedColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfIndexedColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIndexedColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfIndexedColorSpace Class

The following tables list the members exposed by PdfIndexedColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfIndexedColorSpace Constructor | Initializes a new PdfIndexedColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | BaseColorSpace | Gets or sets the base colorspace.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | ColorCount | Gets or sets the number of colors in the color table.
Public Property | ColorTable | Gets or sets the color table.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfIndexedColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIndexedColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfIndexedColorSpace Class : PdfIndexedColorSpace Constructor
Initializes a new PdfIndexedColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfIndexedColorSpace()
public PdfIndexedColorSpace()
public:
PdfIndexedColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColorSpace Class
PdfIndexedColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfIndexedColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIndexedColorSpace Class

For a list of all members of this type, see PdfIndexedColorSpace members.

Public Properties
 | Name | Description
Public Property | BaseColorSpace | Gets or sets the base colorspace.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | ColorCount | Gets or sets the number of colors in the color table.
Public Property | ColorTable | Gets or sets the color table.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfIndexedColorSpace Class
Xfinium.Pdf.Graphics Namespace


BaseColorSpace Property

Xfinium.Pdf.Graphics Namespace > PdfIndexedColorSpace Class : BaseColorSpace Property
Gets or sets the base colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BaseColorSpace As PdfColorSpace
'Usage

Dim instance As PdfIndexedColorSpace
Dim value As PdfColorSpace

instance.BaseColorSpace = value

value = instance.BaseColorSpace
public PdfColorSpace BaseColorSpace {get; set;}
public:
property PdfColorSpace^ BaseColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

The base color space in which the values in the color table are to be interpreted.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColorSpace Class
PdfIndexedColorSpace Members


ColorComponentCount Property (PdfIndexedColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfIndexedColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfIndexedColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColorSpace Class
PdfIndexedColorSpace Members


ColorCount Property

Xfinium.Pdf.Graphics Namespace > PdfIndexedColorSpace Class : ColorCount Property
Gets or sets the number of colors in the color table.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorCount As Integer
'Usage

Dim instance As PdfIndexedColorSpace
Dim value As Integer

instance.ColorCount = value

value = instance.ColorCount
public int ColorCount {get; set;}
public:
property int ColorCount {
   int get();
   void set (    int value);
}

Property Value

The number of colors in the color table.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColorSpace Class
PdfIndexedColorSpace Members


ColorTable Property

Xfinium.Pdf.Graphics Namespace > PdfIndexedColorSpace Class : ColorTable Property
Gets or sets the color table.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorTable As Byte()
'Usage

Dim instance As PdfIndexedColorSpace
Dim value() As Byte

instance.ColorTable = value

value = instance.ColorTable
public byte[] ColorTable {get; set;}
public:
property array<byte>^ ColorTable {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The table of color components.
Remarks
The color table data must be m * ColorCount bytes long, where m is the number of color components in the base color space. Each byte is an unsigned integer in the range 0 to 255 that is scaled to the range of the corresponding color component in the base color space; that is, 0 corresponds to the minimum value in the range for that component, and 255 corresponds to the maximum.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColorSpace Class
PdfIndexedColorSpace Members


%%PageItemTitle%%

PdfIsbnBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIsbnBarcode Class
Defines an ISBN barcode.
Object Model
PdfIsbnBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIsbnBarcode
   Inherits PdfEanBarcode
'Usage

Dim instance As PdfIsbnBarcode
public class PdfIsbnBarcode : PdfEanBarcode
public ref class PdfIsbnBarcode : public PdfEanBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 9 digits
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfIsbnBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIsbnBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIsbnBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfIsbnBarcode Class

The following tables list the members exposed by PdfIsbnBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfIsbnBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIsbnBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIsbnBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfIsbnBarcode Class : PdfIsbnBarcode Constructor
Overload List
Overload | Description
PdfIsbnBarcode Constructor() | Initializes a new PdfIsbnBarcode object.
PdfIsbnBarcode Constructor(String) | Initializes a new PdfIsbnBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIsbnBarcode Class
PdfIsbnBarcode Members


%%PageItemTitle%%

PdfIsbnBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfIsbnBarcode Class > PdfIsbnBarcode Constructor : PdfIsbnBarcode Constructor()
Initializes a new PdfIsbnBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfIsbnBarcode()
public PdfIsbnBarcode()
public:
PdfIsbnBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIsbnBarcode Class
PdfIsbnBarcode Members
Overload List


%%PageItemTitle%%

PdfIsbnBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfIsbnBarcode Class > PdfIsbnBarcode Constructor : PdfIsbnBarcode Constructor(String)
The barcode data.
Initializes a new PdfIsbnBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfIsbnBarcode(data)
public PdfIsbnBarcode(
   string data
)
public:
PdfIsbnBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIsbnBarcode Class
PdfIsbnBarcode Members
Overload List


%%PageItemTitle%%

PdfIsmnBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIsmnBarcode Class
Defines an ISMN barcode.
Object Model
PdfIsmnBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIsmnBarcode
   Inherits PdfEanBarcode
'Usage

Dim instance As PdfIsmnBarcode
public class PdfIsmnBarcode : PdfEanBarcode
public ref class PdfIsmnBarcode : public PdfEanBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 9 digits
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfIsmnBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIsmnBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIsmnBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfIsmnBarcode Class

The following tables list the members exposed by PdfIsmnBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfIsmnBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIsmnBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIsmnBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfIsmnBarcode Class : PdfIsmnBarcode Constructor
Overload List
Overload | Description
PdfIsmnBarcode Constructor() | Initializes a new PdfIsmnBarcode object.
PdfIsmnBarcode Constructor(String) | Initializes a new PdfIsmnBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIsmnBarcode Class
PdfIsmnBarcode Members


%%PageItemTitle%%

PdfIsmnBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfIsmnBarcode Class > PdfIsmnBarcode Constructor : PdfIsmnBarcode Constructor()
Initializes a new PdfIsmnBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfIsmnBarcode()
public PdfIsmnBarcode()
public:
PdfIsmnBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIsmnBarcode Class
PdfIsmnBarcode Members
Overload List


%%PageItemTitle%%

PdfIsmnBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfIsmnBarcode Class > PdfIsmnBarcode Constructor : PdfIsmnBarcode Constructor(String)
The barcode data.
Initializes a new PdfIsmnBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfIsmnBarcode(data)
public PdfIsmnBarcode(
   string data
)
public:
PdfIsmnBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIsmnBarcode Class
PdfIsmnBarcode Members
Overload List


%%PageItemTitle%%

PdfIssnBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfIssnBarcode Class
Defines an ISSN barcode.
Object Model
PdfIssnBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfIssnBarcode
   Inherits PdfEanBarcode
'Usage

Dim instance As PdfIssnBarcode
public class PdfIssnBarcode : PdfEanBarcode
public ref class PdfIssnBarcode : public PdfEanBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 9 digits
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfIssnBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIssnBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfIssnBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfIssnBarcode Class

The following tables list the members exposed by PdfIssnBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfIssnBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIssnBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIssnBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfIssnBarcode Class : PdfIssnBarcode Constructor
Overload List
Overload | Description
PdfIssnBarcode Constructor() | Initializes a new PdfIssnBarcode object.
PdfIssnBarcode Constructor(String) | Initializes a new PdfIssnBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIssnBarcode Class
PdfIssnBarcode Members


%%PageItemTitle%%

PdfIssnBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfIssnBarcode Class > PdfIssnBarcode Constructor : PdfIssnBarcode Constructor()
Initializes a new PdfIssnBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfIssnBarcode()
public PdfIssnBarcode()
public:
PdfIssnBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIssnBarcode Class
PdfIssnBarcode Members
Overload List


%%PageItemTitle%%

PdfIssnBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfIssnBarcode Class > PdfIssnBarcode Constructor : PdfIssnBarcode Constructor(String)
The barcode data.
Initializes a new PdfIssnBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfIssnBarcode(data)
public PdfIssnBarcode(
   string data
)
public:
PdfIssnBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIssnBarcode Class
PdfIssnBarcode Members
Overload List


%%PageItemTitle%%

PdfJan13Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfJan13Barcode Class
Defines a JAN13 barcode.
Object Model
PdfJan13Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfJan13Barcode
   Inherits PdfEanBarcode
'Usage

Dim instance As PdfJan13Barcode
public class PdfJan13Barcode : PdfEanBarcode
public ref class PdfJan13Barcode : public PdfEanBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 10 digits.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfJan13Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJan13Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfJan13Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfJan13Barcode Class

The following tables list the members exposed by PdfJan13Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfJan13Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfJan13Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfJan13Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfJan13Barcode Class : PdfJan13Barcode Constructor
Overload List
Overload | Description
PdfJan13Barcode Constructor() | Initializes a new PdfJan13Barcode object.
PdfJan13Barcode Constructor(String) | Initializes a new PdfJan13Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJan13Barcode Class
PdfJan13Barcode Members


%%PageItemTitle%%

PdfJan13Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfJan13Barcode Class > PdfJan13Barcode Constructor : PdfJan13Barcode Constructor()
Initializes a new PdfJan13Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfJan13Barcode()
public PdfJan13Barcode()
public:
PdfJan13Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJan13Barcode Class
PdfJan13Barcode Members
Overload List


%%PageItemTitle%%

PdfJan13Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfJan13Barcode Class > PdfJan13Barcode Constructor : PdfJan13Barcode Constructor(String)
The barcode data.
Initializes a new PdfJan13Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfJan13Barcode(data)
public PdfJan13Barcode(
   string data
)
public:
PdfJan13Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJan13Barcode Class
PdfJan13Barcode Members
Overload List


%%PageItemTitle%%

PdfJpeg2000Image Class
Members

Xfinium.Pdf.Graphics Namespace : PdfJpeg2000Image Class
Defines a JPEG2000 image.
Object Model
PdfJpeg2000Image ClassPdfAlternateImageCollection ClassPdfAlternateImage ClassPdfColorSpace ClassPdfCosDictionary ClassPdfImageMask ClassPdfMeasure ClassPdfPointData Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfJpeg2000Image
   Inherits PdfImage
'Usage

Dim instance As PdfJpeg2000Image
public class PdfJpeg2000Image : PdfImage
public ref class PdfJpeg2000Image : public PdfImage
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImage
Xfinium.Pdf.Graphics.PdfJpeg2000Image

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJpeg2000Image Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfJpeg2000Image Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfJpeg2000Image Class

The following tables list the members exposed by PdfJpeg2000Image.

Public Constructors
 | Name | Description
Public Constructor | PdfJpeg2000Image Constructor | Initializes a new PdfJpeg2000Image object.
Top
Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfJpeg2000Image Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfJpeg2000Image Constructor

Xfinium.Pdf.Graphics Namespace > PdfJpeg2000Image Class : PdfJpeg2000Image Constructor
JPEG2000 stream.
Initializes a new PdfJpeg2000Image object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfJpeg2000Image(stream)
public PdfJpeg2000Image(
   Stream stream
)
public:
PdfJpeg2000Image(
   Stream^ stream
)

Parameters

stream
JPEG2000 stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJpeg2000Image Class
PdfJpeg2000Image Members


%%PageItemTitle%% $$Properties$$

PdfJpeg2000Image Class Properties

Xfinium.Pdf.Graphics Namespace : PdfJpeg2000Image Class

For a list of all members of this type, see PdfJpeg2000Image members.

Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfJpeg2000Image Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfJpeg2000Image)

Xfinium.Pdf.Graphics Namespace > PdfJpeg2000Image Class : Height Property
Gets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PdfJpeg2000Image
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The image height in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJpeg2000Image Class
PdfJpeg2000Image Members


Width Property (PdfJpeg2000Image)

Xfinium.Pdf.Graphics Namespace > PdfJpeg2000Image Class : Width Property
Gets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PdfJpeg2000Image
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The image width in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJpeg2000Image Class
PdfJpeg2000Image Members


%%PageItemTitle%%

PdfJpegImage Class
Members

Xfinium.Pdf.Graphics Namespace : PdfJpegImage Class
Defines a JPEG image.
Object Model
PdfJpegImage ClassPdfAlternateImageCollection ClassPdfAlternateImage ClassPdfColorSpace ClassPdfCosDictionary ClassPdfImageMask ClassPdfMeasure ClassPdfPointData Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfJpegImage
   Inherits PdfImage
'Usage

Dim instance As PdfJpegImage
public class PdfJpegImage : PdfImage
public ref class PdfJpegImage : public PdfImage
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImage
Xfinium.Pdf.Graphics.PdfJpegImage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJpegImage Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfJpegImage Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfJpegImage Class

The following tables list the members exposed by PdfJpegImage.

Public Constructors
 | Name | Description
Public Constructor | PdfJpegImage Constructor | Initializes a new PdfJpegImage object.
Top
Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfJpegImage Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfJpegImage Constructor

Xfinium.Pdf.Graphics Namespace > PdfJpegImage Class : PdfJpegImage Constructor
JPEG stream.
Initializes a new PdfJpegImage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfJpegImage(stream)
public PdfJpegImage(
   Stream stream
)
public:
PdfJpegImage(
   Stream^ stream
)

Parameters

stream
JPEG stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJpegImage Class
PdfJpegImage Members


%%PageItemTitle%% $$Properties$$

PdfJpegImage Class Properties

Xfinium.Pdf.Graphics Namespace : PdfJpegImage Class

For a list of all members of this type, see PdfJpegImage members.

Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfJpegImage Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfJpegImage)

Xfinium.Pdf.Graphics Namespace > PdfJpegImage Class : Height Property
Gets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PdfJpegImage
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The image height in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJpegImage Class
PdfJpegImage Members


Width Property (PdfJpegImage)

Xfinium.Pdf.Graphics Namespace > PdfJpegImage Class : Width Property
Gets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PdfJpegImage
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The image width in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJpegImage Class
PdfJpegImage Members


%%PageItemTitle%%

PdfKixBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfKixBarcode Class
Defines a Kix barcode.
Object Model
PdfKixBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfKixBarcode
   Inherits PdfRm4sccBarcode
'Usage

Dim instance As PdfKixBarcode
public class PdfKixBarcode : PdfRm4sccBarcode
public ref class PdfKixBarcode : public PdfRm4sccBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfPostalBarcode
Xfinium.Pdf.Graphics.PdfRm4sccBarcode
Xfinium.Pdf.Graphics.PdfKixBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfKixBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfKixBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfKixBarcode Class

The following tables list the members exposed by PdfKixBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfKixBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfKixBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfKixBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfKixBarcode Class : PdfKixBarcode Constructor
Overload List
Overload | Description
PdfKixBarcode Constructor() | Initializes a new PdfKixBarcode object.
PdfKixBarcode Constructor(String) | Initializes a new PdfKixBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfKixBarcode Class
PdfKixBarcode Members


%%PageItemTitle%%

PdfKixBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfKixBarcode Class > PdfKixBarcode Constructor : PdfKixBarcode Constructor()
Initializes a new PdfKixBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfKixBarcode()
public PdfKixBarcode()
public:
PdfKixBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfKixBarcode Class
PdfKixBarcode Members
Overload List


%%PageItemTitle%%

PdfKixBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfKixBarcode Class > PdfKixBarcode Constructor : PdfKixBarcode Constructor(String)
The barcode data.
Initializes a new PdfKixBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfKixBarcode(data)
public PdfKixBarcode(
   string data
)
public:
PdfKixBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfKixBarcode Class
PdfKixBarcode Members
Overload List


%%PageItemTitle%%

PdfLabColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfLabColor Class
Defines a Lab color based on a Lab colorspace.
Object Model
PdfLabColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfLabColor
   Inherits PdfColor
'Usage

Dim instance As PdfLabColor
public class PdfLabColor : PdfColor
public ref class PdfLabColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfLabColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfLabColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfLabColor Class

The following tables list the members exposed by PdfLabColor.

Public Constructors
 | Name | Description
Public Constructor | PdfLabColor Constructor | Initializes a new PdfLabColor object.
Top
Public Properties
 | Name | Description
Public Property | A | Gets or sets the a* component.
Public Property | B | Gets or sets the b* component.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | L | Gets or sets the L component.
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfLabColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfLabColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfLabColor Class : PdfLabColor Constructor
a PdfLabColorSpace object the color is based on.
Initializes a new PdfLabColor object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PdfLabColorSpace _
)
'Usage

Dim colorSpace As PdfLabColorSpace

Dim instance As New PdfLabColor(colorSpace)
public PdfLabColor(
   PdfLabColorSpace colorSpace
)
public:
PdfLabColor(
   PdfLabColorSpace^ colorSpace
)

Parameters

colorSpace
a PdfLabColorSpace object the color is based on.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColor Class
PdfLabColor Members


%%PageItemTitle%% $$Methods$$

PdfLabColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfLabColor Class

For a list of all members of this type, see PdfLabColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfLabColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfLabColor)

Xfinium.Pdf.Graphics Namespace > PdfLabColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfLabColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColor Class
PdfLabColor Members


Equals Method (PdfLabColor)

Xfinium.Pdf.Graphics Namespace > PdfLabColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfLabColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColor Class
PdfLabColor Members


GetHashCode Method (PdfLabColor)

Xfinium.Pdf.Graphics Namespace > PdfLabColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfLabColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColor Class
PdfLabColor Members


%%PageItemTitle%% $$Properties$$

PdfLabColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfLabColor Class

For a list of all members of this type, see PdfLabColor members.

Public Properties
 | Name | Description
Public Property | A | Gets or sets the a* component.
Public Property | B | Gets or sets the b* component.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | L | Gets or sets the L component.
Top
See Also

Reference

PdfLabColor Class
Xfinium.Pdf.Graphics Namespace


A Property

Xfinium.Pdf.Graphics Namespace > PdfLabColor Class : A Property
Gets or sets the a* component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property A As Double
'Usage

Dim instance As PdfLabColor
Dim value As Double

instance.A = value

value = instance.A
public double A {get; set;}
public:
property double A {
   double get();
   void set (    double value);
}

Property Value

The a* component in the range defined by PdfLabColorSpace.Range property of the Lab colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColor Class
PdfLabColor Members


B Property (PdfLabColor)

Xfinium.Pdf.Graphics Namespace > PdfLabColor Class : B Property
Gets or sets the b* component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property B As Double
'Usage

Dim instance As PdfLabColor
Dim value As Double

instance.B = value

value = instance.B
public double B {get; set;}
public:
property double B {
   double get();
   void set (    double value);
}

Property Value

The b* component in the range defined by PdfLabColorSpace.Range property of the Lab colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColor Class
PdfLabColor Members


L Property

Xfinium.Pdf.Graphics Namespace > PdfLabColor Class : L Property
Gets or sets the L component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property L As Double
'Usage

Dim instance As PdfLabColor
Dim value As Double

instance.L = value

value = instance.L
public double L {get; set;}
public:
property double L {
   double get();
   void set (    double value);
}

Property Value

The L component in the range [0 100].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColor Class
PdfLabColor Members


%%PageItemTitle%%

PdfLabColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfLabColorSpace Class
Defines a CIE Lab colorspace.
Object Model
PdfLabColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfLabColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfLabColorSpace
public class PdfLabColorSpace : PdfColorSpace
public ref class PdfLabColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfLabColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfLabColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfLabColorSpace Class

The following tables list the members exposed by PdfLabColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfLabColorSpace Constructor | Initializes a new PdfLabColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Range | Gets or sets the range.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PdfLabColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfLabColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfLabColorSpace Class : PdfLabColorSpace Constructor
Initializes a new PdfLabColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfLabColorSpace()
public PdfLabColorSpace()
public:
PdfLabColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColorSpace Class
PdfLabColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfLabColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfLabColorSpace Class

For a list of all members of this type, see PdfLabColorSpace members.

Public Properties
 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Range | Gets or sets the range.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top
See Also

Reference

PdfLabColorSpace Class
Xfinium.Pdf.Graphics Namespace


BlackPoint Property (PdfLabColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfLabColorSpace Class : BlackPoint Property
Gets or sets the black point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BlackPoint As Double()
'Usage

Dim instance As PdfLabColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
public double[] BlackPoint {get; set;}
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColorSpace Class
PdfLabColorSpace Members


ColorComponentCount Property (PdfLabColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfLabColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfLabColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColorSpace Class
PdfLabColorSpace Members


Range Property (PdfLabColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfLabColorSpace Class : Range Property
Gets or sets the range.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Range As Double()
'Usage

Dim instance As PdfLabColorSpace
Dim value() As Double

instance.Range = value

value = instance.Range
public double[] Range {get; set;}
public:
property array<double>^ Range {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of four numbers [amin amax bmin bmax] specifying the range of valid values for the a* and b* (B and C) components of the color space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColorSpace Class
PdfLabColorSpace Members


WhitePoint Property (PdfLabColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfLabColorSpace Class : WhitePoint Property
Gets or sets the white point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WhitePoint As Double()
'Usage

Dim instance As PdfLabColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
public double[] WhitePoint {get; set;}
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColorSpace Class
PdfLabColorSpace Members


%%PageItemTitle%%

PdfLeitcodeBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfLeitcodeBarcode Class
Defines a Leitcode barcode.
Object Model
PdfLeitcodeBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfLeitcodeBarcode
   Inherits PdfCode25InterleavedBarcode
'Usage

Dim instance As PdfLeitcodeBarcode
public class PdfLeitcodeBarcode : PdfCode25InterleavedBarcode
public ref class PdfLeitcodeBarcode : public PdfCode25InterleavedBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9.
Data length: 13 digits.
Leitcode barcode structure:
1 - 5 - ZIP code
6 - 8 - Street code number
9 - 11 - House number
12 - 13 - Product code
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfCode25InterleavedBarcode
Xfinium.Pdf.Graphics.PdfLeitcodeBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLeitcodeBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfLeitcodeBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfLeitcodeBarcode Class

The following tables list the members exposed by PdfLeitcodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfLeitcodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfLeitcodeBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfLeitcodeBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfLeitcodeBarcode Class : PdfLeitcodeBarcode Constructor
Overload List
Overload | Description
PdfLeitcodeBarcode Constructor() | Initializes a new PdfLeitcodeBarcode object.
PdfLeitcodeBarcode Constructor(String) | Initializes a new PdfLeitcodeBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLeitcodeBarcode Class
PdfLeitcodeBarcode Members


%%PageItemTitle%%

PdfLeitcodeBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfLeitcodeBarcode Class > PdfLeitcodeBarcode Constructor : PdfLeitcodeBarcode Constructor()
Initializes a new PdfLeitcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfLeitcodeBarcode()
public PdfLeitcodeBarcode()
public:
PdfLeitcodeBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLeitcodeBarcode Class
PdfLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PdfLeitcodeBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfLeitcodeBarcode Class > PdfLeitcodeBarcode Constructor : PdfLeitcodeBarcode Constructor(String)
The barcode data.
Initializes a new PdfLeitcodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfLeitcodeBarcode(data)
public PdfLeitcodeBarcode(
   string data
)
public:
PdfLeitcodeBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLeitcodeBarcode Class
PdfLeitcodeBarcode Members
Overload List


%%PageItemTitle%%

PdfMatrix Class
Members

Xfinium.Pdf.Graphics Namespace : PdfMatrix Class
Defines a PDF transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfMatrix
'Usage

Dim instance As PdfMatrix
public class PdfMatrix
public ref class PdfMatrix
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfMatrix

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfMatrix Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfMatrix Class

The following tables list the members exposed by PdfMatrix.

Public Constructors
 | Name | Description
Public Constructor | PdfMatrix Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | M11 | Gets or sets the m11 element.
Public Property | M12 | Gets or sets the m12 element.
Public Property | M21 | Gets or sets the m21 element.
Public Property | M22 | Gets or sets the m22 element.
Public Property | TX | Gets or sets the tx element.
Public Property | TY | Gets or sets the ty element.
Top
Public Methods
 | Name | Description
Public Method | InverseTransformPoint | Overloaded. Applies the geometric transform represented by the inverse of this matrix to a specified point.
Public Method | InverseTransformPoints | Applies the geometric transform represented by the inverse of this matrix to the specified array of points.
Public Method | Invert | Inverts this matrix object.
Public Method | Multiply | Overloaded. Multiplies this matrix by the matrix specified in the matrix parameter.
Public Method | Rotate | Prepend to this matrix a clockwise rotation, around the origin and by the specified angle.
static (Shared in Visual Basic) | RotatedMatrix | Creates a matrix with a rotation as the initial value.
Public Method | Scale | Applies the specified scale vector to this Matrix by prepending the scale vector.
static (Shared in Visual Basic) | ScaledMatrix | Creates a matrix with a scaling as the initial value.
Public Method | TransformPoint | Overloaded. Applies the geometric transform represented by this matrix to a specified point.
Public Method | TransformPoints | Overloaded. Applies the geometric transform represented by this matrix to a specified array of points.
Public Method | TransformVector | Overloaded. Applies only the scale and rotate components of this matrix to the specified point.
Public Method | TransformVectors | Applies only the scale and rotate components of this matrix to the specified array of points.
Public Method | Translate | Applies the specified translation vector (tx and ty) to this matrix by prepending the translation vector.
static (Shared in Visual Basic) | TranslatedMatrix | Creates a matrix with a translation as the initial value.
Top
See Also

Reference

PdfMatrix Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfMatrix Constructor

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : PdfMatrix Constructor
Overload List
Overload | Description
PdfMatrix Constructor() | Initializes a new PdfMatrix object.
PdfMatrix Constructor(Double,Double,Double,Double,Double,Double) | Initializes a new PdfMatrix object.
PdfMatrix Constructor(PdfMatrix) | Initializes a new PdfMatrix object with an existing matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


%%PageItemTitle%%

PdfMatrix Constructor()

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > PdfMatrix Constructor : PdfMatrix Constructor()
Initializes a new PdfMatrix object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfMatrix()
public PdfMatrix()
public:
PdfMatrix();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


%%PageItemTitle%%

PdfMatrix Constructor(Double,Double,Double,Double,Double,Double)

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > PdfMatrix Constructor : PdfMatrix Constructor(Double,Double,Double,Double,Double,Double)
The element located at row 1, column 1.
The element located at row 1, column 2.
The element located at row 2, column 1.
The element located at row 2, column 2.
The X translation offset.
The Y translation offset.
Initializes a new PdfMatrix object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal m11 As Double, _
   ByVal m12 As Double, _
   ByVal m21 As Double, _
   ByVal m22 As Double, _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim m11 As Double
Dim m12 As Double
Dim m21 As Double
Dim m22 As Double
Dim tx As Double
Dim ty As Double

Dim instance As New PdfMatrix(m11, m12, m21, m22, tx, ty)
public PdfMatrix(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)
public:
PdfMatrix(
   double m11,
   double m12,
   double m21,
   double m22,
   double tx,
   double ty
)

Parameters

m11
The element located at row 1, column 1.
m12
The element located at row 1, column 2.
m21
The element located at row 2, column 1.
m22
The element located at row 2, column 2.
tx
The X translation offset.
ty
The Y translation offset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


%%PageItemTitle%%

PdfMatrix Constructor(PdfMatrix)

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > PdfMatrix Constructor : PdfMatrix Constructor(PdfMatrix)
Source matrix.
Initializes a new PdfMatrix object with an existing matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal matrix As PdfMatrix _
)
'Usage

Dim matrix As PdfMatrix

Dim instance As New PdfMatrix(matrix)
public PdfMatrix(
   PdfMatrix matrix
)
public:
PdfMatrix(
   PdfMatrix^ matrix
)

Parameters

matrix
Source matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfMatrix Class Methods

Xfinium.Pdf.Graphics Namespace : PdfMatrix Class

For a list of all members of this type, see PdfMatrix members.

Public Methods
 | Name | Description
Public Method | InverseTransformPoint | Overloaded. Applies the geometric transform represented by the inverse of this matrix to a specified point.
Public Method | InverseTransformPoints | Applies the geometric transform represented by the inverse of this matrix to the specified array of points.
Public Method | Invert | Inverts this matrix object.
Public Method | Multiply | Overloaded. Multiplies this matrix by the matrix specified in the matrix parameter.
Public Method | Rotate | Prepend to this matrix a clockwise rotation, around the origin and by the specified angle.
static (Shared in Visual Basic) | RotatedMatrix | Creates a matrix with a rotation as the initial value.
Public Method | Scale | Applies the specified scale vector to this Matrix by prepending the scale vector.
static (Shared in Visual Basic) | ScaledMatrix | Creates a matrix with a scaling as the initial value.
Public Method | TransformPoint | Overloaded. Applies the geometric transform represented by this matrix to a specified point.
Public Method | TransformPoints | Overloaded. Applies the geometric transform represented by this matrix to a specified array of points.
Public Method | TransformVector | Overloaded. Applies only the scale and rotate components of this matrix to the specified point.
Public Method | TransformVectors | Applies only the scale and rotate components of this matrix to the specified array of points.
Public Method | Translate | Applies the specified translation vector (tx and ty) to this matrix by prepending the translation vector.
static (Shared in Visual Basic) | TranslatedMatrix | Creates a matrix with a translation as the initial value.
Top
See Also

Reference

PdfMatrix Class
Xfinium.Pdf.Graphics Namespace


InverseTransformPoint Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : InverseTransformPoint Method
Applies the geometric transform represented by the inverse of this matrix to a specified point.
Overload List
Overload | Description
InverseTransformPoint(PdfPoint) | Applies the geometric transform represented by the inverse of this matrix to a specified point.
InverseTransformPoint(Double,Double) | Applies the geometric transform represented by the inverse of this matrix to a specified point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


InverseTransformPoint(PdfPoint) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > InverseTransformPoint Method : InverseTransformPoint(PdfPoint) Method
Point to transform.
Applies the geometric transform represented by the inverse of this matrix to a specified point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function InverseTransformPoint( _
   ByVal point As PdfPoint _
) As PdfPoint
'Usage

Dim instance As PdfMatrix
Dim point As PdfPoint
Dim value As PdfPoint

value = instance.InverseTransformPoint(point)
public PdfPoint InverseTransformPoint(
   PdfPoint point
)
public:
PdfPoint^ InverseTransformPoint(
   PdfPoint^ point
)

Parameters

point
Point to transform.

Return Value

Transformed point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


InverseTransformPoint(Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > InverseTransformPoint Method : InverseTransformPoint(Double,Double) Method
X coordinate of the point.
Y coordinate of the point.
Applies the geometric transform represented by the inverse of this matrix to a specified point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function InverseTransformPoint( _
   ByVal x As Double, _
   ByVal y As Double _
) As PdfPoint
'Usage

Dim instance As PdfMatrix
Dim x As Double
Dim y As Double
Dim value As PdfPoint

value = instance.InverseTransformPoint(x, y)
public PdfPoint InverseTransformPoint(
   double x,
   double y
)
public:
PdfPoint^ InverseTransformPoint(
   double x,
   double y
)

Parameters

x
X coordinate of the point.
y
Y coordinate of the point.

Return Value

Transformed point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


InverseTransformPoints Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : InverseTransformPoints Method
An array of PdfPoint objects that represents the points to transform.
Applies the geometric transform represented by the inverse of this matrix to the specified array of points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub InverseTransformPoints( _
   ByVal points() As PdfPoint _
)
'Usage

Dim instance As PdfMatrix
Dim points() As PdfPoint

instance.InverseTransformPoints(points)
public void InverseTransformPoints(
   PdfPoint[] points
)
public:
void InverseTransformPoints(
   array<PdfPoint^>^ points
)

Parameters

points
An array of PdfPoint objects that represents the points to transform.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


Invert Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : Invert Method
Inverts this matrix object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Invert()
'Usage

Dim instance As PdfMatrix

instance.Invert()
public void Invert()
public:
void Invert();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


Multiply Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : Multiply Method
Multiplies this matrix by the matrix specified in the matrix parameter.
Overload List
Overload | Description
Multiply(PdfMatrix) | Multiplies this matrix by the matrix specified in the matrix parameter.
Multiply(PdfMatrix,Boolean) | Multiplies this matrix by the matrix specified in the matrix parameter.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


Multiply(PdfMatrix) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > Multiply Method : Multiply(PdfMatrix) Method
The matrix by which this matrix is to be multiplied.
Multiplies this matrix by the matrix specified in the matrix parameter.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Multiply( _
   ByVal matrix As PdfMatrix _
)
'Usage

Dim instance As PdfMatrix
Dim matrix As PdfMatrix

instance.Multiply(matrix)
public void Multiply(
   PdfMatrix matrix
)
public:
void Multiply(
   PdfMatrix^ matrix
)

Parameters

matrix
The matrix by which this matrix is to be multiplied.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


Multiply(PdfMatrix,Boolean) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > Multiply Method : Multiply(PdfMatrix,Boolean) Method
The matrix by which this matrix is to be multiplied.
True if the new operation is appended, otherwise it is prepended.
Multiplies this matrix by the matrix specified in the matrix parameter.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub Multiply( _
   ByVal matrix As PdfMatrix, _
   ByVal append As Boolean _
)
'Usage

Dim instance As PdfMatrix
Dim matrix As PdfMatrix
Dim append As Boolean

instance.Multiply(matrix, append)
public void Multiply(
   PdfMatrix matrix,
   bool append
)
public:
void Multiply(
   PdfMatrix^ matrix,
   bool append
)

Parameters

matrix
The matrix by which this matrix is to be multiplied.
append
True if the new operation is appended, otherwise it is prepended.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


Rotate Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : Rotate Method
The angle of the rotation, in degrees.
Prepend to this matrix a clockwise rotation, around the origin and by the specified angle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal angle As Double _
)
'Usage

Dim instance As PdfMatrix
Dim angle As Double

instance.Rotate(angle)
public void Rotate(
   double angle
)
public:
void Rotate(
   double angle
)

Parameters

angle
The angle of the rotation, in degrees.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


RotatedMatrix Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : RotatedMatrix Method
Rotation angle in degrees.
Creates a matrix with a rotation as the initial value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function RotatedMatrix( _
   ByVal angle As Double _
) As PdfMatrix
'Usage

Dim angle As Double
Dim value As PdfMatrix

value = PdfMatrix.RotatedMatrix(angle)
public static PdfMatrix RotatedMatrix(
   double angle
)
public:
static PdfMatrix^ RotatedMatrix(
   double angle
)

Parameters

angle
Rotation angle in degrees.

Return Value

The matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


Scale Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : Scale Method
The value by which to scale this matrix in the x-axis direction.
The value by which to scale this matrix in the y-axis direction.
Applies the specified scale vector to this Matrix by prepending the scale vector.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Scale( _
   ByVal sx As Double, _
   ByVal sy As Double _
)
'Usage

Dim instance As PdfMatrix
Dim sx As Double
Dim sy As Double

instance.Scale(sx, sy)
public void Scale(
   double sx,
   double sy
)
public:
void Scale(
   double sx,
   double sy
)

Parameters

sx
The value by which to scale this matrix in the x-axis direction.
sy
The value by which to scale this matrix in the y-axis direction.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


ScaledMatrix Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : ScaledMatrix Method
Scaling on X axis.
Scaling on Y axis.
Creates a matrix with a scaling as the initial value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function ScaledMatrix( _
   ByVal sx As Double, _
   ByVal sy As Double _
) As PdfMatrix
'Usage

Dim sx As Double
Dim sy As Double
Dim value As PdfMatrix

value = PdfMatrix.ScaledMatrix(sx, sy)
public static PdfMatrix ScaledMatrix(
   double sx,
   double sy
)
public:
static PdfMatrix^ ScaledMatrix(
   double sx,
   double sy
)

Parameters

sx
Scaling on X axis.
sy
Scaling on Y axis.

Return Value

The matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


TransformPoint Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : TransformPoint Method
Applies the geometric transform represented by this matrix to a specified point.
Overload List
Overload | Description
TransformPoint(Double,Double) | Applies the geometric transform represented by this matrix to a specified point.
TransformPoint(PdfPoint) | Applies the geometric transform represented by this matrix to a specified point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


TransformPoint(Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > TransformPoint Method : TransformPoint(Double,Double) Method
X coordinate of the point.
Y coordinate of the point.
Applies the geometric transform represented by this matrix to a specified point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function TransformPoint( _
   ByVal x As Double, _
   ByVal y As Double _
) As PdfPoint
'Usage

Dim instance As PdfMatrix
Dim x As Double
Dim y As Double
Dim value As PdfPoint

value = instance.TransformPoint(x, y)
public PdfPoint TransformPoint(
   double x,
   double y
)
public:
PdfPoint^ TransformPoint(
   double x,
   double y
)

Parameters

x
X coordinate of the point.
y
Y coordinate of the point.

Return Value

Transformed point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


TransformPoint(PdfPoint) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > TransformPoint Method : TransformPoint(PdfPoint) Method
Point to transform.
Applies the geometric transform represented by this matrix to a specified point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function TransformPoint( _
   ByVal point As PdfPoint _
) As PdfPoint
'Usage

Dim instance As PdfMatrix
Dim point As PdfPoint
Dim value As PdfPoint

value = instance.TransformPoint(point)
public PdfPoint TransformPoint(
   PdfPoint point
)
public:
PdfPoint^ TransformPoint(
   PdfPoint^ point
)

Parameters

point
Point to transform.

Return Value

Transformed point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


TransformPoints Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : TransformPoints Method
Applies the geometric transform represented by this matrix to a specified array of points.
Overload List
Overload | Description
TransformPoints(PdfPoint[]) | Applies the geometric transform represented by this matrix to a specified array of points.
TransformPoints(Double[]) | Applies the geometric transform represented by this matrix to a specified array of points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


TransformPoints(PdfPoint[]) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > TransformPoints Method : TransformPoints(PdfPoint[]) Method
An array of PdfPoint objects that represents the points to transform.
Applies the geometric transform represented by this matrix to a specified array of points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub TransformPoints( _
   ByVal points() As PdfPoint _
)
'Usage

Dim instance As PdfMatrix
Dim points() As PdfPoint

instance.TransformPoints(points)
public void TransformPoints(
   PdfPoint[] points
)
public:
void TransformPoints(
   array<PdfPoint^>^ points
)

Parameters

points
An array of PdfPoint objects that represents the points to transform.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


TransformPoints(Double[]) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > TransformPoints Method : TransformPoints(Double[]) Method
An array of double pairs (x, y) that represents the points to transform.
Applies the geometric transform represented by this matrix to a specified array of points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub TransformPoints( _
   ByVal points() As Double _
)
'Usage

Dim instance As PdfMatrix
Dim points() As Double

instance.TransformPoints(points)
public void TransformPoints(
   double[] points
)
public:
void TransformPoints(
   array<double>^ points
)

Parameters

points
An array of double pairs (x, y) that represents the points to transform.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


TransformVector Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : TransformVector Method
Applies only the scale and rotate components of this matrix to the specified point.
Overload List
Overload | Description
TransformVector(Double,Double) | Applies only the scale and rotate components of this matrix to the specified point.
TransformVector(PdfPoint) | Applies only the scale and rotate components of this matrix to the specified point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


TransformVector(Double,Double) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > TransformVector Method : TransformVector(Double,Double) Method
X coordinate of the point.
Y coordinate of the point.
Applies only the scale and rotate components of this matrix to the specified point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function TransformVector( _
   ByVal x As Double, _
   ByVal y As Double _
) As PdfPoint
'Usage

Dim instance As PdfMatrix
Dim x As Double
Dim y As Double
Dim value As PdfPoint

value = instance.TransformVector(x, y)
public PdfPoint TransformVector(
   double x,
   double y
)
public:
PdfPoint^ TransformVector(
   double x,
   double y
)

Parameters

x
X coordinate of the point.
y
Y coordinate of the point.

Return Value

Transformed point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


TransformVector(PdfPoint) Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class > TransformVector Method : TransformVector(PdfPoint) Method
Point to transform.
Applies only the scale and rotate components of this matrix to the specified point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function TransformVector( _
   ByVal point As PdfPoint _
) As PdfPoint
'Usage

Dim instance As PdfMatrix
Dim point As PdfPoint
Dim value As PdfPoint

value = instance.TransformVector(point)
public PdfPoint TransformVector(
   PdfPoint point
)
public:
PdfPoint^ TransformVector(
   PdfPoint^ point
)

Parameters

point
Point to transform.

Return Value

Transformed point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members
Overload List


TransformVectors Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : TransformVectors Method
An array of PdfPoint objects that represents the points to transform.
Applies only the scale and rotate components of this matrix to the specified array of points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub TransformVectors( _
   ByVal points() As PdfPoint _
)
'Usage

Dim instance As PdfMatrix
Dim points() As PdfPoint

instance.TransformVectors(points)
public void TransformVectors(
   PdfPoint[] points
)
public:
void TransformVectors(
   array<PdfPoint^>^ points
)

Parameters

points
An array of PdfPoint objects that represents the points to transform.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


Translate Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : Translate Method
The x value by which to translate this matrix.
The y value by which to translate this matrix.
Applies the specified translation vector (tx and ty) to this matrix by prepending the translation vector.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Translate( _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim instance As PdfMatrix
Dim tx As Double
Dim ty As Double

instance.Translate(tx, ty)
public void Translate(
   double tx,
   double ty
)
public:
void Translate(
   double tx,
   double ty
)

Parameters

tx
The x value by which to translate this matrix.
ty
The y value by which to translate this matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


TranslatedMatrix Method

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : TranslatedMatrix Method
Translation on X axis.
Translation on Y axis.
Creates a matrix with a translation as the initial value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function TranslatedMatrix( _
   ByVal tx As Double, _
   ByVal ty As Double _
) As PdfMatrix
'Usage

Dim tx As Double
Dim ty As Double
Dim value As PdfMatrix

value = PdfMatrix.TranslatedMatrix(tx, ty)
public static PdfMatrix TranslatedMatrix(
   double tx,
   double ty
)
public:
static PdfMatrix^ TranslatedMatrix(
   double tx,
   double ty
)

Parameters

tx
Translation on X axis.
ty
Translation on Y axis.

Return Value

The matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


%%PageItemTitle%% $$Properties$$

PdfMatrix Class Properties

Xfinium.Pdf.Graphics Namespace : PdfMatrix Class

For a list of all members of this type, see PdfMatrix members.

Public Properties
 | Name | Description
Public Property | M11 | Gets or sets the m11 element.
Public Property | M12 | Gets or sets the m12 element.
Public Property | M21 | Gets or sets the m21 element.
Public Property | M22 | Gets or sets the m22 element.
Public Property | TX | Gets or sets the tx element.
Public Property | TY | Gets or sets the ty element.
Top
See Also

Reference

PdfMatrix Class
Xfinium.Pdf.Graphics Namespace


M11 Property (PdfMatrix)

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : M11 Property
Gets or sets the m11 element.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M11 As Double
'Usage

Dim instance As PdfMatrix
Dim value As Double

instance.M11 = value

value = instance.M11
public double M11 {get; set;}
public:
property double M11 {
   double get();
   void set (    double value);
}

Property Value

The m11 element
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


M12 Property (PdfMatrix)

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : M12 Property
Gets or sets the m12 element.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M12 As Double
'Usage

Dim instance As PdfMatrix
Dim value As Double

instance.M12 = value

value = instance.M12
public double M12 {get; set;}
public:
property double M12 {
   double get();
   void set (    double value);
}

Property Value

The m12 element
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


M21 Property (PdfMatrix)

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : M21 Property
Gets or sets the m21 element.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M21 As Double
'Usage

Dim instance As PdfMatrix
Dim value As Double

instance.M21 = value

value = instance.M21
public double M21 {get; set;}
public:
property double M21 {
   double get();
   void set (    double value);
}

Property Value

The m21 element
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


M22 Property (PdfMatrix)

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : M22 Property
Gets or sets the m22 element.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M22 As Double
'Usage

Dim instance As PdfMatrix
Dim value As Double

instance.M22 = value

value = instance.M22
public double M22 {get; set;}
public:
property double M22 {
   double get();
   void set (    double value);
}

Property Value

The m22 element
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


TX Property (PdfMatrix)

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : TX Property
Gets or sets the tx element.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TX As Double
'Usage

Dim instance As PdfMatrix
Dim value As Double

instance.TX = value

value = instance.TX
public double TX {get; set;}
public:
property double TX {
   double get();
   void set (    double value);
}

Property Value

The x translation element
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


TY Property (PdfMatrix)

Xfinium.Pdf.Graphics Namespace > PdfMatrix Class : TY Property
Gets or sets the ty element.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TY As Double
'Usage

Dim instance As PdfMatrix
Dim value As Double

instance.TY = value

value = instance.TY
public double TY {get; set;}
public:
property double TY {
   double get();
   void set (    double value);
}

Property Value

The y translation element
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix Class
PdfMatrix Members


%%PageItemTitle%%

PdfMatrix25Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfMatrix25Barcode Class
Defines a Matrix 2 of 5 barcode.
Object Model
PdfMatrix25Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfMatrix25Barcode
   Inherits PdfCode25Barcode
'Usage

Dim instance As PdfMatrix25Barcode
public class PdfMatrix25Barcode : PdfCode25Barcode
public ref class PdfMatrix25Barcode : public PdfCode25Barcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode25Barcode
Xfinium.Pdf.Graphics.PdfMatrix25Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix25Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfMatrix25Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfMatrix25Barcode Class

The following tables list the members exposed by PdfMatrix25Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfMatrix25Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfMatrix25Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfMatrix25Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfMatrix25Barcode Class : PdfMatrix25Barcode Constructor
Overload List
Overload | Description
PdfMatrix25Barcode Constructor() | Initializes a new PdfMatrix25Barcode object.
PdfMatrix25Barcode Constructor(String) | Initializes a new PdfMatrix25Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix25Barcode Class
PdfMatrix25Barcode Members


%%PageItemTitle%%

PdfMatrix25Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfMatrix25Barcode Class > PdfMatrix25Barcode Constructor : PdfMatrix25Barcode Constructor()
Initializes a new PdfMatrix25Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfMatrix25Barcode()
public PdfMatrix25Barcode()
public:
PdfMatrix25Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix25Barcode Class
PdfMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PdfMatrix25Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfMatrix25Barcode Class > PdfMatrix25Barcode Constructor : PdfMatrix25Barcode Constructor(String)
The barcode data.
Initializes a new PdfMatrix25Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfMatrix25Barcode(data)
public PdfMatrix25Barcode(
   string data
)
public:
PdfMatrix25Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMatrix25Barcode Class
PdfMatrix25Barcode Members
Overload List


%%PageItemTitle%%

PdfMsiPlesseyBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfMsiPlesseyBarcode Class
Defines a MSI/Plessey barcode.
Object Model
PdfMsiPlesseyBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfMsiPlesseyBarcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfMsiPlesseyBarcode
public class PdfMsiPlesseyBarcode : Pdf1DBarcode
public ref class PdfMsiPlesseyBarcode : public Pdf1DBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfMsiPlesseyBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMsiPlesseyBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfMsiPlesseyBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfMsiPlesseyBarcode Class

The following tables list the members exposed by PdfMsiPlesseyBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfMsiPlesseyBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfMsiPlesseyBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfMsiPlesseyBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfMsiPlesseyBarcode Class : PdfMsiPlesseyBarcode Constructor
Overload List
Overload | Description
PdfMsiPlesseyBarcode Constructor() | Initializes a new PdfMsiPlesseyBarcode object.
PdfMsiPlesseyBarcode Constructor(String) | Initializes a new PdfMsiPlesseyBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMsiPlesseyBarcode Class
PdfMsiPlesseyBarcode Members


%%PageItemTitle%%

PdfMsiPlesseyBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfMsiPlesseyBarcode Class > PdfMsiPlesseyBarcode Constructor : PdfMsiPlesseyBarcode Constructor()
Initializes a new PdfMsiPlesseyBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfMsiPlesseyBarcode()
public PdfMsiPlesseyBarcode()
public:
PdfMsiPlesseyBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMsiPlesseyBarcode Class
PdfMsiPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PdfMsiPlesseyBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfMsiPlesseyBarcode Class > PdfMsiPlesseyBarcode Constructor : PdfMsiPlesseyBarcode Constructor(String)
The barcode data.
Initializes a new PdfMsiPlesseyBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfMsiPlesseyBarcode(data)
public PdfMsiPlesseyBarcode(
   string data
)
public:
PdfMsiPlesseyBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMsiPlesseyBarcode Class
PdfMsiPlesseyBarcode Members
Overload List


%%PageItemTitle%%

PdfPageContent Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPageContent Class
Defines the graphic content of a PDF page.
Object Model
PdfPageContent ClassPdfCosDictionary ClassPdfGraphics ClassPdfMatrix ClassPdfMeasure ClassPdfPointData ClassPdfGroupXObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageContent
   Inherits PdfFormXObject
'Usage

Dim instance As PdfPageContent
public class PdfPageContent : PdfFormXObject
public ref class PdfPageContent : public PdfFormXObject
Remarks
The graphic content of a PDF page is like a vector image that can be drawn on another page graphics surface.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Graphics.PdfPageContent
Xfinium.Pdf.Content.PdfPageOptionalContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageContent Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPageContent Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPageContent Class

The following tables list the members exposed by PdfPageContent.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Graphics | Gets the form XObject graphics. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Height | Overridden. Gets the form XObject height.
Public Property | Matrix | Gets or sets the form XObject matrix. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Width | Overridden. Gets the form XObject width.
Top
See Also

Reference

PdfPageContent Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfPageContent Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPageContent Class

For a list of all members of this type, see PdfPageContent members.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Graphics | Gets the form XObject graphics. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Height | Overridden. Gets the form XObject height.
Public Property | Matrix | Gets or sets the form XObject matrix. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Width | Overridden. Gets the form XObject width.
Top
See Also

Reference

PdfPageContent Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfPageContent)

Xfinium.Pdf.Graphics Namespace > PdfPageContent Class : Height Property
Gets the form XObject height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Height As Double
'Usage

Dim instance As PdfPageContent
Dim value As Double

value = instance.Height
public override double Height {get;}
public:
property double Height {
   double get() override;
}

Property Value

The form XObject height in points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageContent Class
PdfPageContent Members


Width Property (PdfPageContent)

Xfinium.Pdf.Graphics Namespace > PdfPageContent Class : Width Property
Gets the form XObject width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Width As Double
'Usage

Dim instance As PdfPageContent
Dim value As Double

value = instance.Width
public override double Width {get;}
public:
property double Width {
   double get() override;
}

Property Value

The form XObject width in points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageContent Class
PdfPageContent Members


%%PageItemTitle%%

PdfPageGraphics Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPageGraphics Class
Defines the graphics surface of a PDF page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageGraphics
   Inherits PdfGraphics
'Usage

Dim instance As PdfPageGraphics
public class PdfPageGraphics : PdfGraphics
public ref class PdfPageGraphics : public PdfGraphics
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfGraphics
Xfinium.Pdf.Graphics.PdfPageGraphics

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageGraphics Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPageGraphics Class Members
Methods

Xfinium.Pdf.Graphics Namespace : PdfPageGraphics Class

The following tables list the members exposed by PdfPageGraphics.

Public Methods
 | Name | Description
Public Method | BeginMarkedContent | Overloaded. Begins marked content sequence. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | BeginOptionalContentGroup | Begins an optional content group in the page graphics.
Public Method | Compress | Compresses the page graphic content.
Public Method | CompressAndClose | Compresses the graphic content and closes the graphics surface. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawBarcode | Draws a barcode at the specified position. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawBezier | Overloaded. Draws a Bézier spline specified by four PdfPoint objects. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawFormattedContent | Overloaded. Draws the formatted content on the graphics surface at the specified position. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawFormXObject | Overloaded. Draws the specified PdfFormXObject at the specified location and with the specified size. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawImage | Overloaded. Draws the specified PdfImage at the specified location and with the specified size. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawLine | Overloaded. Draws a line connecting the two points specified by the coordinate pairs. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawPath | Overloaded. Draws a PdfPath. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a coordinate pair, a width, and a height. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawShading | Draws a PDF shading. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawStencilMask | Overloaded. Draws the specified PdfStencilMask at the specified location and with the specified size. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawString | Overloaded. Draws the specified text string at the specified location with the specified PdfBrush and PdfFont objects. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | EndMarkedContent | Ends a marked content sequence. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | EndOptionalContentGroup | Ends the active optional content group in the page graphics.
Public Method | MultiplyTransform | Multiplies the current transformation of this graphics and specified the matrix. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | RestoreGraphicsState | Restores the current state of this graphics. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | RotateTransform | Applies the specified rotation to the transformation matrix of this graphics. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | SaveGraphicsState | Saves the current state of this graphics (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | ScaleTransform | Applies the specified scaling operation to the transformation matrix of this graphics by prepending it to the object's transformation matrix. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | SetClip | Overloaded. Sets the clipping region of this graphics to the specified PdfPath. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | SetExtendedGraphicState | Sets a new graphics state in this graphics object. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | TranslateTransform | Changes the origin of the coordinate system by prepending the specified translation to the transformation matrix of this graphics. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Top
See Also

Reference

PdfPageGraphics Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfPageGraphics Class Methods

Xfinium.Pdf.Graphics Namespace : PdfPageGraphics Class

For a list of all members of this type, see PdfPageGraphics members.

Public Methods
 | Name | Description
Public Method | BeginMarkedContent | Overloaded. Begins marked content sequence. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | BeginOptionalContentGroup | Begins an optional content group in the page graphics.
Public Method | Compress | Compresses the page graphic content.
Public Method | CompressAndClose | Compresses the graphic content and closes the graphics surface. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawArc | Overloaded. Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawBarcode | Draws a barcode at the specified position. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawBezier | Overloaded. Draws a Bézier spline specified by four PdfPoint objects. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by coordinates for the upper-left corner of the rectangle, a height, and a width. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawFormattedContent | Overloaded. Draws the formatted content on the graphics surface at the specified position. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawFormXObject | Overloaded. Draws the specified PdfFormXObject at the specified location and with the specified size. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawImage | Overloaded. Draws the specified PdfImage at the specified location and with the specified size. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawLine | Overloaded. Draws a line connecting the two points specified by the coordinate pairs. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawPath | Overloaded. Draws a PdfPath. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawPie | Overloaded. Draws a pie shape defined by an ellipse specified by a coordinate pair, a width, a height, and two radial lines. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a coordinate pair, a width, and a height. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a coordinate pair, a width, and a height. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawShading | Draws a PDF shading. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawStencilMask | Overloaded. Draws the specified PdfStencilMask at the specified location and with the specified size. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | DrawString | Overloaded. Draws the specified text string at the specified location with the specified PdfBrush and PdfFont objects. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | EndMarkedContent | Ends a marked content sequence. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | EndOptionalContentGroup | Ends the active optional content group in the page graphics.
Public Method | MultiplyTransform | Multiplies the current transformation of this graphics and specified the matrix. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | RestoreGraphicsState | Restores the current state of this graphics. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | RotateTransform | Applies the specified rotation to the transformation matrix of this graphics. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | SaveGraphicsState | Saves the current state of this graphics (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | ScaleTransform | Applies the specified scaling operation to the transformation matrix of this graphics by prepending it to the object's transformation matrix. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | SetClip | Overloaded. Sets the clipping region of this graphics to the specified PdfPath. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | SetExtendedGraphicState | Sets a new graphics state in this graphics object. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Public Method | TranslateTransform | Changes the origin of the coordinate system by prepending the specified translation to the transformation matrix of this graphics. (Inherited from Xfinium.Pdf.Graphics.PdfGraphics)
Top
See Also

Reference

PdfPageGraphics Class
Xfinium.Pdf.Graphics Namespace


BeginOptionalContentGroup Method

Xfinium.Pdf.Graphics Namespace > PdfPageGraphics Class : BeginOptionalContentGroup Method
The group object associated with the graphics.
Begins an optional content group in the page graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BeginOptionalContentGroup( _
   ByVal ocg As PdfOptionalContentGroup _
)
'Usage

Dim instance As PdfPageGraphics
Dim ocg As PdfOptionalContentGroup

instance.BeginOptionalContentGroup(ocg)
public void BeginOptionalContentGroup(
   PdfOptionalContentGroup ocg
)
public:
void BeginOptionalContentGroup(
   PdfOptionalContentGroup^ ocg
)

Parameters

ocg
The group object associated with the graphics.
Remarks
Each call to BeginOptionalContentGroup must be paired with a call to EndOptionalContentGroup.
The page must be included in a document before creating optional content on it.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageGraphics Class
PdfPageGraphics Members


Compress Method

Xfinium.Pdf.Graphics Namespace > PdfPageGraphics Class : Compress Method
Compresses the page graphic content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Compress()
'Usage

Dim instance As PdfPageGraphics

instance.Compress()
public void Compress()
public:
void Compress();
Remarks
Call this method to compress the graphic content and reduce memory usage. This method compresses the current graphic content but it leaves the graphics open so new content can be still added. If you are creating pages with heavy vector graphics, such as maps, you can call this method multiple times, after fragments of the page have been drawn in order to reduce the in-memory size of the graphic content. What the page content has been fully created call the PdfGraphics.CompressAndClose method to compress the last fragment and close the page content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageGraphics Class
PdfPageGraphics Members


EndOptionalContentGroup Method

Xfinium.Pdf.Graphics Namespace > PdfPageGraphics Class : EndOptionalContentGroup Method
Ends the active optional content group in the page graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub EndOptionalContentGroup()
'Usage

Dim instance As PdfPageGraphics

instance.EndOptionalContentGroup()
public void EndOptionalContentGroup()
public:
void EndOptionalContentGroup();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageGraphics Class
PdfPageGraphics Members


%%PageItemTitle%%

PdfPantoneColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPantoneColor Class
Defines a set of separation colors known as Pantone colors.
Object Model
PdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfColorSpace ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor ClassPdfPantoneColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPantoneColor
   Inherits PdfSeparationColor
'Usage

Dim instance As PdfPantoneColor
public class PdfPantoneColor : PdfSeparationColor
public ref class PdfPantoneColor : public PdfSeparationColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfSeparationColor
Xfinium.Pdf.Graphics.PdfPantoneColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPantoneColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfPantoneColor Class

The following tables list the members exposed by PdfPantoneColor.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Black | Gets the Pantone Black color.
static (Shared in Visual Basic) | Black2 | Gets the Pantone Black 2 color.
static (Shared in Visual Basic) | Black3 | Gets the Pantone Black 3 color.
static (Shared in Visual Basic) | Black4 | Gets the Pantone Black 4 color.
static (Shared in Visual Basic) | Black5 | Gets the Pantone Black 5 color.
static (Shared in Visual Basic) | Black6 | Gets the Pantone Black 6 color.
static (Shared in Visual Basic) | Black7 | Gets the Pantone Black 7 color.
static (Shared in Visual Basic) | Blue072 | Gets the Pantone Blue 072 color.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
static (Shared in Visual Basic) | CoolGray1 | Gets the Pantone Cool Gray 1 color.
static (Shared in Visual Basic) | CoolGray10 | Gets the Pantone Cool Gray 10 color.
static (Shared in Visual Basic) | CoolGray11 | Gets the Pantone Cool Gray 11 color.
static (Shared in Visual Basic) | CoolGray2 | Gets the Pantone Cool Gray 2 color.
static (Shared in Visual Basic) | CoolGray3 | Gets the Pantone Cool Gray 3 color.
static (Shared in Visual Basic) | CoolGray4 | Gets the Pantone Cool Gray 4 color.
static (Shared in Visual Basic) | CoolGray5 | Gets the Pantone Cool Gray 5 color.
static (Shared in Visual Basic) | CoolGray6 | Gets the Pantone Cool Gray 6 color.
static (Shared in Visual Basic) | CoolGray7 | Gets the Pantone Cool Gray 7 color.
static (Shared in Visual Basic) | CoolGray8 | Gets the Pantone Cool Gray 8 color.
static (Shared in Visual Basic) | CoolGray9 | Gets the Pantone Cool Gray 9 color.
static (Shared in Visual Basic) | Green | Gets the Pantone Green color.
static (Shared in Visual Basic) | HexachromeBlack | Gets the Pantone Hexachrome Black color.
static (Shared in Visual Basic) | HexachromeCyan | Gets the Pantone Hexachrome Cyan color.
static (Shared in Visual Basic) | HexachromeGreen | Gets the Pantone Hexachrome Green color.
static (Shared in Visual Basic) | HexachromeMagenta | Gets the Pantone Hexachrome Magenta color.
static (Shared in Visual Basic) | HexachromeOrange | Gets the Pantone Hexachrome Orange color.
static (Shared in Visual Basic) | HexachromeYellow | Gets the Pantone Hexachrome Yellow color.
static (Shared in Visual Basic) | Orange021 | Gets the Pantone Orange 021 color.
static (Shared in Visual Basic) | PANTONE100 | Gets the Pantone 100 color.
static (Shared in Visual Basic) | PANTONE101 | Gets the Pantone 101 color.
static (Shared in Visual Basic) | PANTONE102 | Gets the Pantone 102 color.
static (Shared in Visual Basic) | PANTONE103 | Gets the Pantone 103 color.
static (Shared in Visual Basic) | PANTONE104 | Gets the Pantone 104 color.
static (Shared in Visual Basic) | PANTONE105 | Gets the Pantone 105 color.
static (Shared in Visual Basic) | PANTONE106 | Gets the Pantone 106 color.
static (Shared in Visual Basic) | PANTONE107 | Gets the Pantone 107 color.
static (Shared in Visual Basic) | PANTONE108 | Gets the Pantone 108 color.
static (Shared in Visual Basic) | PANTONE109 | Gets the Pantone 109 color.
static (Shared in Visual Basic) | PANTONE110 | Gets the Pantone 110 color.
static (Shared in Visual Basic) | PANTONE111 | Gets the Pantone 111 color.
static (Shared in Visual Basic) | PANTONE112 | Gets the Pantone 112 color.
static (Shared in Visual Basic) | PANTONE113 | Gets the Pantone 113 color.
static (Shared in Visual Basic) | PANTONE114 | Gets the Pantone 114 color.
static (Shared in Visual Basic) | PANTONE115 | Gets the Pantone 115 color.
static (Shared in Visual Basic) | PANTONE116 | Gets the Pantone 116 color.
static (Shared in Visual Basic) | PANTONE117 | Gets the Pantone 117 color.
static (Shared in Visual Basic) | PANTONE118 | Gets the Pantone 118 color.
static (Shared in Visual Basic) | PANTONE119 | Gets the Pantone 119 color.
static (Shared in Visual Basic) | PANTONE120 | Gets the Pantone 120 color.
static (Shared in Visual Basic) | PANTONE1205 | Gets the Pantone 1205 color.
static (Shared in Visual Basic) | PANTONE121 | Gets the Pantone 121 color.
static (Shared in Visual Basic) | PANTONE1215 | Gets the Pantone 1215 color.
static (Shared in Visual Basic) | PANTONE122 | Gets the Pantone 122 color.
static (Shared in Visual Basic) | PANTONE1225 | Gets the Pantone 1225 color.
static (Shared in Visual Basic) | PANTONE123 | Gets the Pantone 123 color.
static (Shared in Visual Basic) | PANTONE1235 | Gets the Pantone 1235 color.
static (Shared in Visual Basic) | PANTONE124 | Gets the Pantone 124 color.
static (Shared in Visual Basic) | PANTONE1245 | Gets the Pantone 1245 color.
static (Shared in Visual Basic) | PANTONE125 | Gets the Pantone 125 color.
static (Shared in Visual Basic) | PANTONE1255 | Gets the Pantone 1255 color.
static (Shared in Visual Basic) | PANTONE126 | Gets the Pantone 126 color.
static (Shared in Visual Basic) | PANTONE1265 | Gets the Pantone 1265 color.
static (Shared in Visual Basic) | PANTONE127 | Gets the Pantone 127 color.
static (Shared in Visual Basic) | PANTONE128 | Gets the Pantone 128 color.
static (Shared in Visual Basic) | PANTONE129 | Gets the Pantone 129 color.
static (Shared in Visual Basic) | PANTONE130 | Gets the Pantone 130 color.
static (Shared in Visual Basic) | PANTONE131 | Gets the Pantone 131 color.
static (Shared in Visual Basic) | PANTONE132 | Gets the Pantone 132 color.
static (Shared in Visual Basic) | PANTONE133 | Gets the Pantone 133 color.
static (Shared in Visual Basic) | PANTONE134 | Gets the Pantone 134 color.
static (Shared in Visual Basic) | PANTONE1345 | Gets the Pantone 1345 color.
static (Shared in Visual Basic) | PANTONE135 | Gets the Pantone 135 color.
static (Shared in Visual Basic) | PANTONE1355 | Gets the Pantone 1355 color.
static (Shared in Visual Basic) | PANTONE136 | Gets the Pantone 136 color.
static (Shared in Visual Basic) | PANTONE1365 | Gets the Pantone 1365 color.
static (Shared in Visual Basic) | PANTONE137 | Gets the Pantone 137 color.
static (Shared in Visual Basic) | PANTONE1375 | Gets the Pantone 1375 color.
static (Shared in Visual Basic) | PANTONE138 | Gets the Pantone 138 color.
static (Shared in Visual Basic) | PANTONE1385 | Gets the Pantone 1385 color.
static (Shared in Visual Basic) | PANTONE139 | Gets the Pantone 139 color.
static (Shared in Visual Basic) | PANTONE1395 | Gets the Pantone 1395 color.
static (Shared in Visual Basic) | PANTONE140 | Gets the Pantone 140 color.
static (Shared in Visual Basic) | PANTONE1405 | Gets the Pantone 1405 color.
static (Shared in Visual Basic) | PANTONE141 | Gets the Pantone 141 color.
static (Shared in Visual Basic) | PANTONE142 | Gets the Pantone 142 color.
static (Shared in Visual Basic) | PANTONE143 | Gets the Pantone 143 color.
static (Shared in Visual Basic) | PANTONE144 | Gets the Pantone 144 color.
static (Shared in Visual Basic) | PANTONE145 | Gets the Pantone 145 color.
static (Shared in Visual Basic) | PANTONE146 | Gets the Pantone 146 color.
static (Shared in Visual Basic) | PANTONE147 | Gets the Pantone 147 color.
static (Shared in Visual Basic) | PANTONE148 | Gets the Pantone 148 color.
static (Shared in Visual Basic) | PANTONE1485 | Gets the Pantone 1485 color.
static (Shared in Visual Basic) | PANTONE149 | Gets the Pantone 149 color.
static (Shared in Visual Basic) | PANTONE1495 | Gets the Pantone 1495 color.
static (Shared in Visual Basic) | PANTONE150 | Gets the Pantone 150 color.
static (Shared in Visual Basic) | PANTONE1505 | Gets the Pantone 1505 color.
static (Shared in Visual Basic) | PANTONE151 | Gets the Pantone 151 color.
static (Shared in Visual Basic) | PANTONE152 | Gets the Pantone 152 color.
static (Shared in Visual Basic) | PANTONE1525 | Gets the Pantone 1525 color.
static (Shared in Visual Basic) | PANTONE153 | Gets the Pantone 153 color.
static (Shared in Visual Basic) | PANTONE1535 | Gets the Pantone 1535 color.
static (Shared in Visual Basic) | PANTONE154 | Gets the Pantone 154 color.
static (Shared in Visual Basic) | PANTONE1545 | Gets the Pantone 1545 color.
static (Shared in Visual Basic) | PANTONE155 | Gets the Pantone 155 color.
static (Shared in Visual Basic) | PANTONE1555 | Gets the Pantone 1555 color.
static (Shared in Visual Basic) | PANTONE156 | Gets the Pantone 156 color.
static (Shared in Visual Basic) | PANTONE1565 | Gets the Pantone 1565 color.
static (Shared in Visual Basic) | PANTONE157 | Gets the Pantone 157 color.
static (Shared in Visual Basic) | PANTONE1575 | Gets the Pantone 1575 color.
static (Shared in Visual Basic) | PANTONE158 | Gets the Pantone 158 color.
static (Shared in Visual Basic) | PANTONE1585 | Gets the Pantone 1585 color.
static (Shared in Visual Basic) | PANTONE159 | Gets the Pantone 159 color.
static (Shared in Visual Basic) | PANTONE1595 | Gets the Pantone 1595 color.
static (Shared in Visual Basic) | PANTONE160 | Gets the Pantone 160 color.
static (Shared in Visual Basic) | PANTONE1605 | Gets the Pantone 1605 color.
static (Shared in Visual Basic) | PANTONE161 | Gets the Pantone 161 color.
static (Shared in Visual Basic) | PANTONE1615 | Gets the Pantone 1615 color.
static (Shared in Visual Basic) | PANTONE162 | Gets the Pantone 162 color.
static (Shared in Visual Basic) | PANTONE1625 | Gets the Pantone 1625 color.
static (Shared in Visual Basic) | PANTONE163 | Gets the Pantone 163 color.
static (Shared in Visual Basic) | PANTONE1635 | Gets the Pantone 1635 color.
static (Shared in Visual Basic) | PANTONE164 | Gets the Pantone 164 color.
static (Shared in Visual Basic) | PANTONE1645 | Gets the Pantone 1645 color.
static (Shared in Visual Basic) | PANTONE165 | Gets the Pantone 165 color.
static (Shared in Visual Basic) | PANTONE1655 | Gets the Pantone 1655 color.
static (Shared in Visual Basic) | PANTONE166 | Gets the Pantone 166 color.
static (Shared in Visual Basic) | PANTONE1665 | Gets the Pantone 1665 color.
static (Shared in Visual Basic) | PANTONE167 | Gets the Pantone 167 color.
static (Shared in Visual Basic) | PANTONE1675 | Gets the Pantone 1675 color.
static (Shared in Visual Basic) | PANTONE168 | Gets the Pantone 168 color.
static (Shared in Visual Basic) | PANTONE1685 | Gets the Pantone 1685 color.
static (Shared in Visual Basic) | PANTONE169 | Gets the Pantone 169 color.
static (Shared in Visual Basic) | PANTONE170 | Gets the Pantone 170 color.
static (Shared in Visual Basic) | PANTONE171 | Gets the Pantone 171 color.
static (Shared in Visual Basic) | PANTONE172 | Gets the Pantone 172 color.
static (Shared in Visual Basic) | PANTONE173 | Gets the Pantone 173 color.
static (Shared in Visual Basic) | PANTONE174 | Gets the Pantone 174 color.
static (Shared in Visual Basic) | PANTONE175 | Gets the Pantone 175 color.
static (Shared in Visual Basic) | PANTONE176 | Gets the Pantone 176 color.
static (Shared in Visual Basic) | PANTONE1765 | Gets the Pantone 1765 color.
static (Shared in Visual Basic) | PANTONE1767 | Gets the Pantone 1767 color.
static (Shared in Visual Basic) | PANTONE177 | Gets the Pantone 177 color.
static (Shared in Visual Basic) | PANTONE1775 | Gets the Pantone 1775 color.
static (Shared in Visual Basic) | PANTONE1777 | Gets the Pantone 1777 color.
static (Shared in Visual Basic) | PANTONE178 | Gets the Pantone 178 color.
static (Shared in Visual Basic) | PANTONE1785 | Gets the Pantone 1785 color.
static (Shared in Visual Basic) | PANTONE1787 | Gets the Pantone 1787 color.
static (Shared in Visual Basic) | PANTONE1788 | Gets the Pantone 1788 color.
static (Shared in Visual Basic) | PANTONE179 | Gets the Pantone 179 color.
static (Shared in Visual Basic) | PANTONE1795 | Gets the Pantone 1795 color.
static (Shared in Visual Basic) | PANTONE1797 | Gets the Pantone 1797 color.
static (Shared in Visual Basic) | PANTONE180 | Gets the Pantone 180 color.
static (Shared in Visual Basic) | PANTONE1805 | Gets the Pantone 1805 color.
static (Shared in Visual Basic) | PANTONE1807 | Gets the Pantone 1807 color.
static (Shared in Visual Basic) | PANTONE181 | Gets the Pantone 181 color.
static (Shared in Visual Basic) | PANTONE1815 | Gets the Pantone 1815 color.
static (Shared in Visual Basic) | PANTONE1817 | Gets the Pantone 1817 color.
static (Shared in Visual Basic) | PANTONE182 | Gets the Pantone 182 color.
static (Shared in Visual Basic) | PANTONE183 | Gets the Pantone 183 color.
static (Shared in Visual Basic) | PANTONE184 | Gets the Pantone 184 color.
static (Shared in Visual Basic) | PANTONE185 | Gets the Pantone 185 color.
static (Shared in Visual Basic) | PANTONE186 | Gets the Pantone 186 color.
static (Shared in Visual Basic) | PANTONE187 | Gets the Pantone 187 color.
static (Shared in Visual Basic) | PANTONE188 | Gets the Pantone 188 color.
static (Shared in Visual Basic) | PANTONE189 | Gets the Pantone 189 color.
static (Shared in Visual Basic) | PANTONE1895 | Gets the Pantone 1895 color.
static (Shared in Visual Basic) | PANTONE190 | Gets the Pantone 190 color.
static (Shared in Visual Basic) | PANTONE1905 | Gets the Pantone 1905 color.
static (Shared in Visual Basic) | PANTONE191 | Gets the Pantone 191 color.
static (Shared in Visual Basic) | PANTONE1915 | Gets the Pantone 1915 color.
static (Shared in Visual Basic) | PANTONE192 | Gets the Pantone 192 color.
static (Shared in Visual Basic) | PANTONE1925 | Gets the Pantone 1925 color.
static (Shared in Visual Basic) | PANTONE193 | Gets the Pantone 193 color.
static (Shared in Visual Basic) | PANTONE1935 | Gets the Pantone 1935 color.
static (Shared in Visual Basic) | PANTONE194 | Gets the Pantone 194 color.
static (Shared in Visual Basic) | PANTONE1945 | Gets the Pantone 1945 color.
static (Shared in Visual Basic) | PANTONE195 | Gets the Pantone 195 color.
static (Shared in Visual Basic) | PANTONE1955 | Gets the Pantone 1955 color.
static (Shared in Visual Basic) | PANTONE196 | Gets the Pantone 196 color.
static (Shared in Visual Basic) | PANTONE197 | Gets the Pantone 197 color.
static (Shared in Visual Basic) | PANTONE198 | Gets the Pantone 198 color.
static (Shared in Visual Basic) | PANTONE199 | Gets the Pantone 199 color.
static (Shared in Visual Basic) | PANTONE200 | Gets the Pantone 200 color.
static (Shared in Visual Basic) | PANTONE201 | Gets the Pantone 201 color.
static (Shared in Visual Basic) | PANTONE202 | Gets the Pantone 202 color.
static (Shared in Visual Basic) | PANTONE203 | Gets the Pantone 203 color.
static (Shared in Visual Basic) | PANTONE204 | Gets the Pantone 204 color.
static (Shared in Visual Basic) | PANTONE205 | Gets the Pantone 205 color.
static (Shared in Visual Basic) | PANTONE206 | Gets the Pantone 206 color.
static (Shared in Visual Basic) | PANTONE207 | Gets the Pantone 207 color.
static (Shared in Visual Basic) | PANTONE208 | Gets the Pantone 208 color.
static (Shared in Visual Basic) | PANTONE209 | Gets the Pantone 209 color.
static (Shared in Visual Basic) | PANTONE210 | Gets the Pantone 210 color.
static (Shared in Visual Basic) | PANTONE211 | Gets the Pantone 211 color.
static (Shared in Visual Basic) | PANTONE212 | Gets the Pantone 212 color.
static (Shared in Visual Basic) | PANTONE213 | Gets the Pantone 213 color.
static (Shared in Visual Basic) | PANTONE214 | Gets the Pantone 214 color.
static (Shared in Visual Basic) | PANTONE215 | Gets the Pantone 215 color.
static (Shared in Visual Basic) | PANTONE216 | Gets the Pantone 216 color.
static (Shared in Visual Basic) | PANTONE217 | Gets the Pantone 217 color.
static (Shared in Visual Basic) | PANTONE218 | Gets the Pantone 218 color.
static (Shared in Visual Basic) | PANTONE219 | Gets the Pantone 219 color.
static (Shared in Visual Basic) | PANTONE220 | Gets the Pantone 220 color.
static (Shared in Visual Basic) | PANTONE221 | Gets the Pantone 221 color.
static (Shared in Visual Basic) | PANTONE222 | Gets the Pantone 222 color.
static (Shared in Visual Basic) | PANTONE223 | Gets the Pantone 223 color.
static (Shared in Visual Basic) | PANTONE224 | Gets the Pantone 224 color.
static (Shared in Visual Basic) | PANTONE225 | Gets the Pantone 225 color.
static (Shared in Visual Basic) | PANTONE226 | Gets the Pantone 226 color.
static (Shared in Visual Basic) | PANTONE227 | Gets the Pantone 227 color.
static (Shared in Visual Basic) | PANTONE228 | Gets the Pantone 228 color.
static (Shared in Visual Basic) | PANTONE229 | Gets the Pantone 229 color.
static (Shared in Visual Basic) | PANTONE230 | Gets the Pantone 230 color.
static (Shared in Visual Basic) | PANTONE231 | Gets the Pantone 231 color.
static (Shared in Visual Basic) | PANTONE232 | Gets the Pantone 232 color.
static (Shared in Visual Basic) | PANTONE233 | Gets the Pantone 233 color.
static (Shared in Visual Basic) | PANTONE234 | Gets the Pantone 234 color.
static (Shared in Visual Basic) | PANTONE235 | Gets the Pantone 235 color.
static (Shared in Visual Basic) | PANTONE236 | Gets the Pantone 236 color.
static (Shared in Visual Basic) | PANTONE2365 | Gets the Pantone 2365 color.
static (Shared in Visual Basic) | PANTONE237 | Gets the Pantone 237 color.
static (Shared in Visual Basic) | PANTONE2375 | Gets the Pantone 2375 color.
static (Shared in Visual Basic) | PANTONE238 | Gets the Pantone 238 color.
static (Shared in Visual Basic) | PANTONE2385 | Gets the Pantone 2385 color.
static (Shared in Visual Basic) | PANTONE239 | Gets the Pantone 239 color.
static (Shared in Visual Basic) | PANTONE2395 | Gets the Pantone 2395 color.
static (Shared in Visual Basic) | PANTONE240 | Gets the Pantone 240 color.
static (Shared in Visual Basic) | PANTONE2405 | Gets the Pantone 2405 color.
static (Shared in Visual Basic) | PANTONE241 | Gets the Pantone 241 color.
static (Shared in Visual Basic) | PANTONE2415 | Gets the Pantone 2415 color.
static (Shared in Visual Basic) | PANTONE242 | Gets the Pantone 242 color.
static (Shared in Visual Basic) | PANTONE2425 | Gets the Pantone 2425 color.
static (Shared in Visual Basic) | PANTONE243 | Gets the Pantone 243 color.
static (Shared in Visual Basic) | PANTONE244 | Gets the Pantone 244 color.
static (Shared in Visual Basic) | PANTONE245 | Gets the Pantone 245 color.
static (Shared in Visual Basic) | PANTONE246 | Gets the Pantone 246 color.
static (Shared in Visual Basic) | PANTONE247 | Gets the Pantone 247 color.
static (Shared in Visual Basic) | PANTONE248 | Gets the Pantone 248 color.
static (Shared in Visual Basic) | PANTONE249 | Gets the Pantone 249 color.
static (Shared in Visual Basic) | PANTONE250 | Gets the Pantone 250 color.
static (Shared in Visual Basic) | PANTONE251 | Gets the Pantone 251 color.
static (Shared in Visual Basic) | PANTONE252 | Gets the Pantone 252 color.
static (Shared in Visual Basic) | PANTONE253 | Gets the Pantone 253 color.
static (Shared in Visual Basic) | PANTONE254 | Gets the Pantone 254 color.
static (Shared in Visual Basic) | PANTONE255 | Gets the Pantone 255 color.
static (Shared in Visual Basic) | PANTONE256 | Gets the Pantone 256 color.
static (Shared in Visual Basic) | PANTONE2562 | Gets the Pantone 2562 color.
static (Shared in Visual Basic) | PANTONE2563 | Gets the Pantone 2563 color.
static (Shared in Visual Basic) | PANTONE2567 | Gets the Pantone 2567 color.
static (Shared in Visual Basic) | PANTONE257 | Gets the Pantone 257 color.
static (Shared in Visual Basic) | PANTONE2572 | Gets the Pantone 2572 color.
static (Shared in Visual Basic) | PANTONE2573 | Gets the Pantone 2573 color.
static (Shared in Visual Basic) | PANTONE2577 | Gets the Pantone 2577 color.
static (Shared in Visual Basic) | PANTONE258 | Gets the Pantone 258 color.
static (Shared in Visual Basic) | PANTONE2582 | Gets the Pantone 2582 color.
static (Shared in Visual Basic) | PANTONE2583 | Gets the Pantone 2583 color.
static (Shared in Visual Basic) | PANTONE2587 | Gets the Pantone 2587 color.
static (Shared in Visual Basic) | PANTONE259 | Gets the Pantone 259 color.
static (Shared in Visual Basic) | PANTONE2592 | Gets the Pantone 2592 color.
static (Shared in Visual Basic) | PANTONE2593 | Gets the Pantone 2593 color.
static (Shared in Visual Basic) | PANTONE2597 | Gets the Pantone 2597 color.
static (Shared in Visual Basic) | PANTONE260 | Gets the Pantone 260 color.
static (Shared in Visual Basic) | PANTONE2602 | Gets the Pantone 2602 color.
static (Shared in Visual Basic) | PANTONE2603 | Gets the Pantone 2603 color.
static (Shared in Visual Basic) | PANTONE2607 | Gets the Pantone 2607 color.
static (Shared in Visual Basic) | PANTONE261 | Gets the Pantone 261 color.
static (Shared in Visual Basic) | PANTONE2612 | Gets the Pantone 2612 color.
static (Shared in Visual Basic) | PANTONE2613 | Gets the Pantone 2613 color.
static (Shared in Visual Basic) | PANTONE2617 | Gets the Pantone 2617 color.
static (Shared in Visual Basic) | PANTONE262 | Gets the Pantone 262 color.
static (Shared in Visual Basic) | PANTONE2622 | Gets the Pantone 2622 color.
static (Shared in Visual Basic) | PANTONE2623 | Gets the Pantone 2623 color.
static (Shared in Visual Basic) | PANTONE2627 | Gets the Pantone 2627 color.
static (Shared in Visual Basic) | PANTONE263 | Gets the Pantone 263 color.
static (Shared in Visual Basic) | PANTONE2635 | Gets the Pantone 2635 color.
static (Shared in Visual Basic) | PANTONE264 | Gets the Pantone 264 color.
static (Shared in Visual Basic) | PANTONE2645 | Gets the Pantone 2645 color.
static (Shared in Visual Basic) | PANTONE265 | Gets the Pantone 265 color.
static (Shared in Visual Basic) | PANTONE2655 | Gets the Pantone 2655 color.
static (Shared in Visual Basic) | PANTONE266 | Gets the Pantone 266 color.
static (Shared in Visual Basic) | PANTONE2665 | Gets the Pantone 2665 color.
static (Shared in Visual Basic) | PANTONE267 | Gets the Pantone 267 color.
static (Shared in Visual Basic) | PANTONE268 | Gets the Pantone 268 color.
static (Shared in Visual Basic) | PANTONE2685 | Gets the Pantone 2685 color.
static (Shared in Visual Basic) | PANTONE269 | Gets the Pantone 269 color.
static (Shared in Visual Basic) | PANTONE2695 | Gets the Pantone 2695 color.
static (Shared in Visual Basic) | PANTONE270 | Gets the Pantone 270 color.
static (Shared in Visual Basic) | PANTONE2705 | Gets the Pantone 2705 color.
static (Shared in Visual Basic) | PANTONE2706 | Gets the Pantone 2706 color.
static (Shared in Visual Basic) | PANTONE2707 | Gets the Pantone 2707 color.
static (Shared in Visual Basic) | PANTONE2708 | Gets the Pantone 2708 color.
static (Shared in Visual Basic) | PANTONE271 | Gets the Pantone 271 color.
static (Shared in Visual Basic) | PANTONE2715 | Gets the Pantone 2715 color.
static (Shared in Visual Basic) | PANTONE2716 | Gets the Pantone 2716 color.
static (Shared in Visual Basic) | PANTONE2717 | Gets the Pantone 2717 color.
static (Shared in Visual Basic) | PANTONE2718 | Gets the Pantone 2718 color.
static (Shared in Visual Basic) | PANTONE272 | Gets the Pantone 272 color.
static (Shared in Visual Basic) | PANTONE2725 | Gets the Pantone 2725 color.
static (Shared in Visual Basic) | PANTONE2726 | Gets the Pantone 2726 color.
static (Shared in Visual Basic) | PANTONE2727 | Gets the Pantone 2727 color.
static (Shared in Visual Basic) | PANTONE2728 | Gets the Pantone 2728 color.
static (Shared in Visual Basic) | PANTONE273 | Gets the Pantone 273 color.
static (Shared in Visual Basic) | PANTONE2735 | Gets the Pantone 2735 color.
static (Shared in Visual Basic) | PANTONE2736 | Gets the Pantone 2736 color.
static (Shared in Visual Basic) | PANTONE2738 | Gets the Pantone 2738 color.
static (Shared in Visual Basic) | PANTONE274 | Gets the Pantone 274 color.
static (Shared in Visual Basic) | PANTONE2745 | Gets the Pantone 2745 color.
static (Shared in Visual Basic) | PANTONE2746 | Gets the Pantone 2746 color.
static (Shared in Visual Basic) | PANTONE2747 | Gets the Pantone 2747 color.
static (Shared in Visual Basic) | PANTONE2748 | Gets the Pantone 2748 color.
static (Shared in Visual Basic) | PANTONE275 | Gets the Pantone 275 color.
static (Shared in Visual Basic) | PANTONE2755 | Gets the Pantone 2755 color.
static (Shared in Visual Basic) | PANTONE2756 | Gets the Pantone 2756 color.
static (Shared in Visual Basic) | PANTONE2757 | Gets the Pantone 2757 color.
static (Shared in Visual Basic) | PANTONE2758 | Gets the Pantone 2758 color.
static (Shared in Visual Basic) | PANTONE276 | Gets the Pantone 276 color.
static (Shared in Visual Basic) | PANTONE2765 | Gets the Pantone 2765 color.
static (Shared in Visual Basic) | PANTONE2766 | Gets the Pantone 2766 color.
static (Shared in Visual Basic) | PANTONE2767 | Gets the Pantone 2767 color.
static (Shared in Visual Basic) | PANTONE2768 | Gets the Pantone 2768 color.
static (Shared in Visual Basic) | PANTONE277 | Gets the Pantone 277 color.
static (Shared in Visual Basic) | PANTONE278 | Gets the Pantone 278 color.
static (Shared in Visual Basic) | PANTONE279 | Gets the Pantone 279 color.
static (Shared in Visual Basic) | PANTONE280 | Gets the Pantone 280 color.
static (Shared in Visual Basic) | PANTONE281 | Gets the Pantone 281 color.
static (Shared in Visual Basic) | PANTONE282 | Gets the Pantone 282 color.
static (Shared in Visual Basic) | PANTONE283 | Gets the Pantone 283 color.
static (Shared in Visual Basic) | PANTONE284 | Gets the Pantone 284 color.
static (Shared in Visual Basic) | PANTONE285 | Gets the Pantone 285 color.
static (Shared in Visual Basic) | PANTONE286 | Gets the Pantone 286 color.
static (Shared in Visual Basic) | PANTONE287 | Gets the Pantone 287 color.
static (Shared in Visual Basic) | PANTONE288 | Gets the Pantone 288 color.
static (Shared in Visual Basic) | PANTONE289 | Gets the Pantone 289 color.
static (Shared in Visual Basic) | PANTONE290 | Gets the Pantone 290 color.
static (Shared in Visual Basic) | PANTONE2905 | Gets the Pantone 2905 color.
static (Shared in Visual Basic) | PANTONE291 | Gets the Pantone 291 color.
static (Shared in Visual Basic) | PANTONE2915 | Gets the Pantone 2915 color.
static (Shared in Visual Basic) | PANTONE292 | Gets the Pantone 292 color.
static (Shared in Visual Basic) | PANTONE2925 | Gets the Pantone 2925 color.
static (Shared in Visual Basic) | PANTONE293 | Gets the Pantone 293 color.
static (Shared in Visual Basic) | PANTONE2935 | Gets the Pantone 2935 color.
static (Shared in Visual Basic) | PANTONE294 | Gets the Pantone 294 color.
static (Shared in Visual Basic) | PANTONE2945 | Gets the Pantone 2945 color.
static (Shared in Visual Basic) | PANTONE295 | Gets the Pantone 295 color.
static (Shared in Visual Basic) | PANTONE2955 | Gets the Pantone 2955 color.
static (Shared in Visual Basic) | PANTONE296 | Gets the Pantone 296 color.
static (Shared in Visual Basic) | PANTONE2965 | Gets the Pantone 2965 color.
static (Shared in Visual Basic) | PANTONE297 | Gets the Pantone 297 color.
static (Shared in Visual Basic) | PANTONE2975 | Gets the Pantone 2975 color.
static (Shared in Visual Basic) | PANTONE298 | Gets the Pantone 298 color.
static (Shared in Visual Basic) | PANTONE2985 | Gets the Pantone 2985 color.
static (Shared in Visual Basic) | PANTONE299 | Gets the Pantone 299 color.
static (Shared in Visual Basic) | PANTONE2995 | Gets the Pantone 2995 color.
static (Shared in Visual Basic) | PANTONE300 | Gets the Pantone 300 color.
static (Shared in Visual Basic) | PANTONE3005 | Gets the Pantone 3005 color.
static (Shared in Visual Basic) | PANTONE301 | Gets the Pantone 301 color.
static (Shared in Visual Basic) | PANTONE3015 | Gets the Pantone 3015 color.
static (Shared in Visual Basic) | PANTONE302 | Gets the Pantone 302 color.
static (Shared in Visual Basic) | PANTONE3025 | Gets the Pantone 3025 color.
static (Shared in Visual Basic) | PANTONE303 | Gets the Pantone 303 color.
static (Shared in Visual Basic) | PANTONE3035 | Gets the Pantone 3035 color.
static (Shared in Visual Basic) | PANTONE304 | Gets the Pantone 304 color.
static (Shared in Visual Basic) | PANTONE305 | Gets the Pantone 305 color.
static (Shared in Visual Basic) | PANTONE306 | Gets the Pantone 306 color.
static (Shared in Visual Basic) | PANTONE307 | Gets the Pantone 307 color.
static (Shared in Visual Basic) | PANTONE308 | Gets the Pantone 308 color.
static (Shared in Visual Basic) | PANTONE309 | Gets the Pantone 309 color.
static (Shared in Visual Basic) | PANTONE310 | Gets the Pantone 310 color.
static (Shared in Visual Basic) | PANTONE3105 | Gets the Pantone 3105 color.
static (Shared in Visual Basic) | PANTONE311 | Gets the Pantone 311 color.
static (Shared in Visual Basic) | PANTONE3115 | Gets the Pantone 3115 color.
static (Shared in Visual Basic) | PANTONE312 | Gets the Pantone 312 color.
static (Shared in Visual Basic) | PANTONE3125 | Gets the Pantone 3125 color.
static (Shared in Visual Basic) | PANTONE313 | Gets the Pantone 313 color.
static (Shared in Visual Basic) | PANTONE3135 | Gets the Pantone 3135 color.
static (Shared in Visual Basic) | PANTONE314 | Gets the Pantone 314 color.
static (Shared in Visual Basic) | PANTONE3145 | Gets the Pantone 3145 color.
static (Shared in Visual Basic) | PANTONE315 | Gets the Pantone 315 color.
static (Shared in Visual Basic) | PANTONE3155 | Gets the Pantone 3155 color.
static (Shared in Visual Basic) | PANTONE316 | Gets the Pantone 316 color.
static (Shared in Visual Basic) | PANTONE3165 | Gets the Pantone 3165 color.
static (Shared in Visual Basic) | PANTONE317 | Gets the Pantone 317 color.
static (Shared in Visual Basic) | PANTONE318 | Gets the Pantone 318 color.
static (Shared in Visual Basic) | PANTONE319 | Gets the Pantone 319 color.
static (Shared in Visual Basic) | PANTONE320 | Gets the Pantone 320 color.
static (Shared in Visual Basic) | PANTONE321 | Gets the Pantone 321 color.
static (Shared in Visual Basic) | PANTONE322 | Gets the Pantone 322 color.
static (Shared in Visual Basic) | PANTONE323 | Gets the Pantone 323 color.
static (Shared in Visual Basic) | PANTONE324 | Gets the Pantone 324 color.
static (Shared in Visual Basic) | PANTONE3242 | Gets the Pantone 3242 color.
static (Shared in Visual Basic) | PANTONE3245 | Gets the Pantone 3245 color.
static (Shared in Visual Basic) | PANTONE3248 | Gets the Pantone 3248 color.
static (Shared in Visual Basic) | PANTONE325 | Gets the Pantone 325 color.
static (Shared in Visual Basic) | PANTONE3252 | Gets the Pantone 3252 color.
static (Shared in Visual Basic) | PANTONE3255 | Gets the Pantone 3255 color.
static (Shared in Visual Basic) | PANTONE3258 | Gets the Pantone 3258 color.
static (Shared in Visual Basic) | PANTONE326 | Gets the Pantone 326 color.
static (Shared in Visual Basic) | PANTONE3262 | Gets the Pantone 3262 color.
static (Shared in Visual Basic) | PANTONE3265 | Gets the Pantone 3265 color.
static (Shared in Visual Basic) | PANTONE3268 | Gets the Pantone 3268 color.
static (Shared in Visual Basic) | PANTONE327 | Gets the Pantone 327 color.
static (Shared in Visual Basic) | PANTONE3272 | Gets the Pantone 3272 color.
static (Shared in Visual Basic) | PANTONE3275 | Gets the Pantone 3275 color.
static (Shared in Visual Basic) | PANTONE3278 | Gets the Pantone 3278 color.
static (Shared in Visual Basic) | PANTONE328 | Gets the Pantone 328 color.
static (Shared in Visual Basic) | PANTONE3282 | Gets the Pantone 3282 color.
static (Shared in Visual Basic) | PANTONE3285 | Gets the Pantone 3285 color.
static (Shared in Visual Basic) | PANTONE3288 | Gets the Pantone 3288 color.
static (Shared in Visual Basic) | PANTONE329 | Gets the Pantone 329 color.
static (Shared in Visual Basic) | PANTONE3292 | Gets the Pantone 3292 color.
static (Shared in Visual Basic) | PANTONE3295 | Gets the Pantone 3295 color.
static (Shared in Visual Basic) | PANTONE3298 | Gets the Pantone 3298 color.
static (Shared in Visual Basic) | PANTONE330 | Gets the Pantone 330 color.
static (Shared in Visual Basic) | PANTONE3302 | Gets the Pantone 3302 color.
static (Shared in Visual Basic) | PANTONE3305 | Gets the Pantone 3305 color.
static (Shared in Visual Basic) | PANTONE3308 | Gets the Pantone 3308 color.
static (Shared in Visual Basic) | PANTONE331 | Gets the Pantone 331 color.
static (Shared in Visual Basic) | PANTONE332 | Gets the Pantone 332 color.
static (Shared in Visual Basic) | PANTONE333 | Gets the Pantone 333 color.
static (Shared in Visual Basic) | PANTONE334 | Gets the Pantone 334 color.
static (Shared in Visual Basic) | PANTONE335 | Gets the Pantone 335 color.
static (Shared in Visual Basic) | PANTONE336 | Gets the Pantone 336 color.
static (Shared in Visual Basic) | PANTONE337 | Gets the Pantone 337 color.
static (Shared in Visual Basic) | PANTONE3375 | Gets the Pantone 3375 color.
static (Shared in Visual Basic) | PANTONE338 | Gets the Pantone 338 color.
static (Shared in Visual Basic) | PANTONE3385 | Gets the Pantone 3385 color.
static (Shared in Visual Basic) | PANTONE339 | Gets the Pantone 339 color.
static (Shared in Visual Basic) | PANTONE3395 | Gets the Pantone 3395 color.
static (Shared in Visual Basic) | PANTONE340 | Gets the Pantone 340 color.
static (Shared in Visual Basic) | PANTONE3405 | Gets the Pantone 3405 color.
static (Shared in Visual Basic) | PANTONE341 | Gets the Pantone 341 color.
static (Shared in Visual Basic) | PANTONE3415 | Gets the Pantone 3415 color.
static (Shared in Visual Basic) | PANTONE342 | Gets the Pantone 342 color.
static (Shared in Visual Basic) | PANTONE3425 | Gets the Pantone 3425 color.
static (Shared in Visual Basic) | PANTONE343 | Gets the Pantone 343 color.
static (Shared in Visual Basic) | PANTONE3435 | Gets the Pantone 3435 color.
static (Shared in Visual Basic) | PANTONE344 | Gets the Pantone 344 color.
static (Shared in Visual Basic) | PANTONE345 | Gets the Pantone 345 color.
static (Shared in Visual Basic) | PANTONE346 | Gets the Pantone 346 color.
static (Shared in Visual Basic) | PANTONE347 | Gets the Pantone 347 color.
static (Shared in Visual Basic) | PANTONE348 | Gets the Pantone 348 color.
static (Shared in Visual Basic) | PANTONE349 | Gets the Pantone 349 color.
static (Shared in Visual Basic) | PANTONE350 | Gets the Pantone 350 color.
static (Shared in Visual Basic) | PANTONE351 | Gets the Pantone 351 color.
static (Shared in Visual Basic) | PANTONE352 | Gets the Pantone 352 color.
static (Shared in Visual Basic) | PANTONE353 | Gets the Pantone 353 color.
static (Shared in Visual Basic) | PANTONE354 | Gets the Pantone 354 color.
static (Shared in Visual Basic) | PANTONE355 | Gets the Pantone 355 color.
static (Shared in Visual Basic) | PANTONE356 | Gets the Pantone 356 color.
static (Shared in Visual Basic) | PANTONE357 | Gets the Pantone 357 color.
static (Shared in Visual Basic) | PANTONE358 | Gets the Pantone 358 color.
static (Shared in Visual Basic) | PANTONE359 | Gets the Pantone 359 color.
static (Shared in Visual Basic) | PANTONE360 | Gets the Pantone 360 color.
static (Shared in Visual Basic) | PANTONE361 | Gets the Pantone 361 color.
static (Shared in Visual Basic) | PANTONE362 | Gets the Pantone 362 color.
static (Shared in Visual Basic) | PANTONE363 | Gets the Pantone 363 color.
static (Shared in Visual Basic) | PANTONE364 | Gets the Pantone 364 color.
static (Shared in Visual Basic) | PANTONE365 | Gets the Pantone 365 color.
static (Shared in Visual Basic) | PANTONE366 | Gets the Pantone 366 color.
static (Shared in Visual Basic) | PANTONE367 | Gets the Pantone 367 color.
static (Shared in Visual Basic) | PANTONE368 | Gets the Pantone 368 color.
static (Shared in Visual Basic) | PANTONE369 | Gets the Pantone 369 color.
static (Shared in Visual Basic) | PANTONE370 | Gets the Pantone 370 color.
static (Shared in Visual Basic) | PANTONE371 | Gets the Pantone 371 color.
static (Shared in Visual Basic) | PANTONE372 | Gets the Pantone 372 color.
static (Shared in Visual Basic) | PANTONE373 | Gets the Pantone 373 color.
static (Shared in Visual Basic) | PANTONE374 | Gets the Pantone 374 color.
static (Shared in Visual Basic) | PANTONE375 | Gets the Pantone 375 color.
static (Shared in Visual Basic) | PANTONE376 | Gets the Pantone 376 color.
static (Shared in Visual Basic) | PANTONE377 | Gets the Pantone 377 color.
static (Shared in Visual Basic) | PANTONE378 | Gets the Pantone 378 color.
static (Shared in Visual Basic) | PANTONE379 | Gets the Pantone 379 color.
static (Shared in Visual Basic) | PANTONE380 | Gets the Pantone 380 color.
static (Shared in Visual Basic) | PANTONE381 | Gets the Pantone 381 color.
static (Shared in Visual Basic) | PANTONE382 | Gets the Pantone 382 color.
static (Shared in Visual Basic) | PANTONE383 | Gets the Pantone 383 color.
static (Shared in Visual Basic) | PANTONE384 | Gets the Pantone 384 color.
static (Shared in Visual Basic) | PANTONE385 | Gets the Pantone 385 color.
static (Shared in Visual Basic) | PANTONE386 | Gets the Pantone 386 color.
static (Shared in Visual Basic) | PANTONE387 | Gets the Pantone 387 color.
static (Shared in Visual Basic) | PANTONE388 | Gets the Pantone 388 color.
static (Shared in Visual Basic) | PANTONE389 | Gets the Pantone 389 color.
static (Shared in Visual Basic) | PANTONE390 | Gets the Pantone 390 color.
static (Shared in Visual Basic) | PANTONE391 | Gets the Pantone 391 color.
static (Shared in Visual Basic) | PANTONE392 | Gets the Pantone 392 color.
static (Shared in Visual Basic) | PANTONE393 | Gets the Pantone 393 color.
static (Shared in Visual Basic) | PANTONE3935 | Gets the Pantone 3935 color.
static (Shared in Visual Basic) | PANTONE394 | Gets the Pantone 394 color.
static (Shared in Visual Basic) | PANTONE3945 | Gets the Pantone 3945 color.
static (Shared in Visual Basic) | PANTONE395 | Gets the Pantone 395 color.
static (Shared in Visual Basic) | PANTONE3955 | Gets the Pantone 3955 color.
static (Shared in Visual Basic) | PANTONE396 | Gets the Pantone 396 color.
static (Shared in Visual Basic) | PANTONE3965 | Gets the Pantone 3965 color.
static (Shared in Visual Basic) | PANTONE397 | Gets the Pantone 397 color.
static (Shared in Visual Basic) | PANTONE3975 | Gets the Pantone 3975 color.
static (Shared in Visual Basic) | PANTONE398 | Gets the Pantone 398 color.
static (Shared in Visual Basic) | PANTONE3985 | Gets the Pantone 3985 color.
static (Shared in Visual Basic) | PANTONE399 | Gets the Pantone 399 color.
static (Shared in Visual Basic) | PANTONE3995 | Gets the Pantone 3995 color.
static (Shared in Visual Basic) | PANTONE400 | Gets the Pantone 400 color.
static (Shared in Visual Basic) | PANTONE401 | Gets the Pantone 401 color.
static (Shared in Visual Basic) | PANTONE402 | Gets the Pantone 402 color.
static (Shared in Visual Basic) | PANTONE403 | Gets the Pantone 403 color.
static (Shared in Visual Basic) | PANTONE404 | Gets the Pantone 404 color.
static (Shared in Visual Basic) | PANTONE405 | Gets the Pantone 405 color.
static (Shared in Visual Basic) | PANTONE406 | Gets the Pantone 406 color.
static (Shared in Visual Basic) | PANTONE407 | Gets the Pantone 407 color.
static (Shared in Visual Basic) | PANTONE408 | Gets the Pantone 408 color.
static (Shared in Visual Basic) | PANTONE409 | Gets the Pantone 409 color.
static (Shared in Visual Basic) | PANTONE410 | Gets the Pantone 410 color.
static (Shared in Visual Basic) | PANTONE411 | Gets the Pantone 411 color.
static (Shared in Visual Basic) | PANTONE412 | Gets the Pantone 412 color.
static (Shared in Visual Basic) | PANTONE413 | Gets the Pantone 413 color.
static (Shared in Visual Basic) | PANTONE414 | Gets the Pantone 414 color.
static (Shared in Visual Basic) | PANTONE415 | Gets the Pantone 415 color.
static (Shared in Visual Basic) | PANTONE416 | Gets the Pantone 416 color.
static (Shared in Visual Basic) | PANTONE417 | Gets the Pantone 417 color.
static (Shared in Visual Basic) | PANTONE418 | Gets the Pantone 418 color.
static (Shared in Visual Basic) | PANTONE419 | Gets the Pantone 419 color.
static (Shared in Visual Basic) | PANTONE420 | Gets the Pantone 420 color.
static (Shared in Visual Basic) | PANTONE421 | Gets the Pantone 421 color.
static (Shared in Visual Basic) | PANTONE422 | Gets the Pantone 422 color.
static (Shared in Visual Basic) | PANTONE423 | Gets the Pantone 423 color.
static (Shared in Visual Basic) | PANTONE424 | Gets the Pantone 424 color.
static (Shared in Visual Basic) | PANTONE425 | Gets the Pantone 425 color.
static (Shared in Visual Basic) | PANTONE426 | Gets the Pantone 426 color.
static (Shared in Visual Basic) | PANTONE427 | Gets the Pantone 427 color.
static (Shared in Visual Basic) | PANTONE428 | Gets the Pantone 428 color.
static (Shared in Visual Basic) | PANTONE429 | Gets the Pantone 429 color.
static (Shared in Visual Basic) | PANTONE430 | Gets the Pantone 430 color.
static (Shared in Visual Basic) | PANTONE431 | Gets the Pantone 431 color.
static (Shared in Visual Basic) | PANTONE432 | Gets the Pantone 432 color.
static (Shared in Visual Basic) | PANTONE433 | Gets the Pantone 433 color.
static (Shared in Visual Basic) | PANTONE434 | Gets the Pantone 434 color.
static (Shared in Visual Basic) | PANTONE435 | Gets the Pantone 435 color.
static (Shared in Visual Basic) | PANTONE436 | Gets the Pantone 436 color.
static (Shared in Visual Basic) | PANTONE437 | Gets the Pantone 437 color.
static (Shared in Visual Basic) | PANTONE438 | Gets the Pantone 438 color.
static (Shared in Visual Basic) | PANTONE439 | Gets the Pantone 439 color.
static (Shared in Visual Basic) | PANTONE440 | Gets the Pantone 440 color.
static (Shared in Visual Basic) | PANTONE441 | Gets the Pantone 441 color.
static (Shared in Visual Basic) | PANTONE442 | Gets the Pantone 442 color.
static (Shared in Visual Basic) | PANTONE443 | Gets the Pantone 443 color.
static (Shared in Visual Basic) | PANTONE444 | Gets the Pantone 444 color.
static (Shared in Visual Basic) | PANTONE445 | Gets the Pantone 445 color.
static (Shared in Visual Basic) | PANTONE446 | Gets the Pantone 446 color.
static (Shared in Visual Basic) | PANTONE447 | Gets the Pantone 447 color.
static (Shared in Visual Basic) | PANTONE448 | Gets the Pantone 448 color.
static (Shared in Visual Basic) | PANTONE4485 | Gets the Pantone 4485 color.
static (Shared in Visual Basic) | PANTONE449 | Gets the Pantone 449 color.
static (Shared in Visual Basic) | PANTONE4495 | Gets the Pantone 4495 color.
static (Shared in Visual Basic) | PANTONE450 | Gets the Pantone 450 color.
static (Shared in Visual Basic) | PANTONE4505 | Gets the Pantone 4505 color.
static (Shared in Visual Basic) | PANTONE451 | Gets the Pantone 451 color.
static (Shared in Visual Basic) | PANTONE4515 | Gets the Pantone 4515 color.
static (Shared in Visual Basic) | PANTONE452 | Gets the Pantone 452 color.
static (Shared in Visual Basic) | PANTONE4525 | Gets the Pantone 4525 color.
static (Shared in Visual Basic) | PANTONE453 | Gets the Pantone 453 color.
static (Shared in Visual Basic) | PANTONE4535 | Gets the Pantone 4535 color.
static (Shared in Visual Basic) | PANTONE454 | Gets the Pantone 454 color.
static (Shared in Visual Basic) | PANTONE4545 | Gets the Pantone 4545 color.
static (Shared in Visual Basic) | PANTONE455 | Gets the Pantone 455 color.
static (Shared in Visual Basic) | PANTONE456 | Gets the Pantone 456 color.
static (Shared in Visual Basic) | PANTONE457 | Gets the Pantone 457 color.
static (Shared in Visual Basic) | PANTONE458 | Gets the Pantone 458 color.
static (Shared in Visual Basic) | PANTONE459 | Gets the Pantone 459 color.
static (Shared in Visual Basic) | PANTONE460 | Gets the Pantone 460 color.
static (Shared in Visual Basic) | PANTONE461 | Gets the Pantone 461 color.
static (Shared in Visual Basic) | PANTONE462 | Gets the Pantone 462 color.
static (Shared in Visual Basic) | PANTONE4625 | Gets the Pantone 4625 color.
static (Shared in Visual Basic) | PANTONE463 | Gets the Pantone 463 color.
static (Shared in Visual Basic) | PANTONE4635 | Gets the Pantone 4635 color.
static (Shared in Visual Basic) | PANTONE464 | Gets the Pantone 464 color.
static (Shared in Visual Basic) | PANTONE4645 | Gets the Pantone 4645 color.
static (Shared in Visual Basic) | PANTONE465 | Gets the Pantone 465 color.
static (Shared in Visual Basic) | PANTONE4655 | Gets the Pantone 4655 color.
static (Shared in Visual Basic) | PANTONE466 | Gets the Pantone 466 color.
static (Shared in Visual Basic) | PANTONE4665 | Gets the Pantone 4665 color.
static (Shared in Visual Basic) | PANTONE467 | Gets the Pantone 467 color.
static (Shared in Visual Basic) | PANTONE4675 | Gets the Pantone 4675 color.
static (Shared in Visual Basic) | PANTONE468 | Gets the Pantone 468 color.
static (Shared in Visual Basic) | PANTONE4685 | Gets the Pantone 4685 color.
static (Shared in Visual Basic) | PANTONE469 | Gets the Pantone 469 color.
static (Shared in Visual Basic) | PANTONE4695 | Gets the Pantone 4695 color.
static (Shared in Visual Basic) | PANTONE470 | Gets the Pantone 470 color.
static (Shared in Visual Basic) | PANTONE4705 | Gets the Pantone 4705 color.
static (Shared in Visual Basic) | PANTONE471 | Gets the Pantone 471 color.
static (Shared in Visual Basic) | PANTONE4715 | Gets the Pantone 4715 color.
static (Shared in Visual Basic) | PANTONE472 | Gets the Pantone 472 color.
static (Shared in Visual Basic) | PANTONE4725 | Gets the Pantone 4725 color.
static (Shared in Visual Basic) | PANTONE473 | Gets the Pantone 473 color.
static (Shared in Visual Basic) | PANTONE4735 | Gets the Pantone 4735 color.
static (Shared in Visual Basic) | PANTONE474 | Gets the Pantone 474 color.
static (Shared in Visual Basic) | PANTONE4745 | Gets the Pantone 4745 color.
static (Shared in Visual Basic) | PANTONE475 | Gets the Pantone 475 color.
static (Shared in Visual Basic) | PANTONE4755 | Gets the Pantone 4755 color.
static (Shared in Visual Basic) | PANTONE476 | Gets the Pantone 476 color.
static (Shared in Visual Basic) | PANTONE477 | Gets the Pantone 477 color.
static (Shared in Visual Basic) | PANTONE478 | Gets the Pantone 478 color.
static (Shared in Visual Basic) | PANTONE479 | Gets the Pantone 479 color.
static (Shared in Visual Basic) | PANTONE480 | Gets the Pantone 480 color.
static (Shared in Visual Basic) | PANTONE481 | Gets the Pantone 481 color.
static (Shared in Visual Basic) | PANTONE482 | Gets the Pantone 482 color.
static (Shared in Visual Basic) | PANTONE483 | Gets the Pantone 483 color.
static (Shared in Visual Basic) | PANTONE484 | Gets the Pantone 484 color.
static (Shared in Visual Basic) | PANTONE485 | Gets the Pantone 485 color.
static (Shared in Visual Basic) | PANTONE486 | Gets the Pantone 486 color.
static (Shared in Visual Basic) | PANTONE487 | Gets the Pantone 487 color.
static (Shared in Visual Basic) | PANTONE488 | Gets the Pantone 488 color.
static (Shared in Visual Basic) | PANTONE489 | Gets the Pantone 489 color.
static (Shared in Visual Basic) | PANTONE490 | Gets the Pantone 490 color.
static (Shared in Visual Basic) | PANTONE491 | Gets the Pantone 491 color.
static (Shared in Visual Basic) | PANTONE492 | Gets the Pantone 492 color.
static (Shared in Visual Basic) | PANTONE493 | Gets the Pantone 493 color.
static (Shared in Visual Basic) | PANTONE494 | Gets the Pantone 494 color.
static (Shared in Visual Basic) | PANTONE495 | Gets the Pantone 495 color.
static (Shared in Visual Basic) | PANTONE496 | Gets the Pantone 496 color.
static (Shared in Visual Basic) | PANTONE497 | Gets the Pantone 497 color.
static (Shared in Visual Basic) | PANTONE4975 | Gets the Pantone 4975 color.
static (Shared in Visual Basic) | PANTONE498 | Gets the Pantone 498 color.
static (Shared in Visual Basic) | PANTONE4985 | Gets the Pantone 4985 color.
static (Shared in Visual Basic) | PANTONE499 | Gets the Pantone 499 color.
static (Shared in Visual Basic) | PANTONE4995 | Gets the Pantone 4995 color.
static (Shared in Visual Basic) | PANTONE500 | Gets the Pantone 500 color.
static (Shared in Visual Basic) | PANTONE5005 | Gets the Pantone 5005 color.
static (Shared in Visual Basic) | PANTONE501 | Gets the Pantone 501 color.
static (Shared in Visual Basic) | PANTONE5015 | Gets the Pantone 5015 color.
static (Shared in Visual Basic) | PANTONE502 | Gets the Pantone 502 color.
static (Shared in Visual Basic) | PANTONE5025 | Gets the Pantone 5025 color.
static (Shared in Visual Basic) | PANTONE503 | Gets the Pantone 503 color.
static (Shared in Visual Basic) | PANTONE5035 | Gets the Pantone 5035 color.
static (Shared in Visual Basic) | PANTONE504 | Gets the Pantone 504 color.
static (Shared in Visual Basic) | PANTONE505 | Gets the Pantone 505 color.
static (Shared in Visual Basic) | PANTONE506 | Gets the Pantone 506 color.
static (Shared in Visual Basic) | PANTONE507 | Gets the Pantone 507 color.
static (Shared in Visual Basic) | PANTONE508 | Gets the Pantone 508 color.
static (Shared in Visual Basic) | PANTONE509 | Gets the Pantone 509 color.
static (Shared in Visual Basic) | PANTONE510 | Gets the Pantone 510 color.
static (Shared in Visual Basic) | PANTONE511 | Gets the Pantone 511 color.
static (Shared in Visual Basic) | PANTONE5115 | Gets the Pantone 5115 color.
static (Shared in Visual Basic) | PANTONE512 | Gets the Pantone 512 color.
static (Shared in Visual Basic) | PANTONE5125 | Gets the Pantone 5125 color.
static (Shared in Visual Basic) | PANTONE513 | Gets the Pantone 513 color.
static (Shared in Visual Basic) | PANTONE5135 | Gets the Pantone 5135 color.
static (Shared in Visual Basic) | PANTONE514 | Gets the Pantone 514 color.
static (Shared in Visual Basic) | PANTONE5145 | Gets the Pantone 5145 color.
static (Shared in Visual Basic) | PANTONE515 | Gets the Pantone 515 color.
static (Shared in Visual Basic) | PANTONE5155 | Gets the Pantone 5155 color.
static (Shared in Visual Basic) | PANTONE516 | Gets the Pantone 516 color.
static (Shared in Visual Basic) | PANTONE5165 | Gets the Pantone 5165 color.
static (Shared in Visual Basic) | PANTONE517 | Gets the Pantone 517 color.
static (Shared in Visual Basic) | PANTONE5175 | Gets the Pantone 5175 color.
static (Shared in Visual Basic) | PANTONE518 | Gets the Pantone 518 color.
static (Shared in Visual Basic) | PANTONE5185 | Gets the Pantone 5185 color.
static (Shared in Visual Basic) | PANTONE519 | Gets the Pantone 519 color.
static (Shared in Visual Basic) | PANTONE5195 | Gets the Pantone 5195 color.
static (Shared in Visual Basic) | PANTONE520 | Gets the Pantone 520 color.
static (Shared in Visual Basic) | PANTONE5205 | Gets the Pantone 5205 color.
static (Shared in Visual Basic) | PANTONE521 | Gets the Pantone 521 color.
static (Shared in Visual Basic) | PANTONE5215 | Gets the Pantone 5215 color.
static (Shared in Visual Basic) | PANTONE522 | Gets the Pantone 522 color.
static (Shared in Visual Basic) | PANTONE5225 | Gets the Pantone 5225 color.
static (Shared in Visual Basic) | PANTONE523 | Gets the Pantone 523 color.
static (Shared in Visual Basic) | PANTONE5235 | Gets the Pantone 5235 color.
static (Shared in Visual Basic) | PANTONE524 | Gets the Pantone 524 color.
static (Shared in Visual Basic) | PANTONE5245 | Gets the Pantone 5245 color.
static (Shared in Visual Basic) | PANTONE525 | Gets the Pantone 525 color.
static (Shared in Visual Basic) | PANTONE5255 | Gets the Pantone 5255 color.
static (Shared in Visual Basic) | PANTONE526 | Gets the Pantone 526 color.
static (Shared in Visual Basic) | PANTONE5265 | Gets the Pantone 5265 color.
static (Shared in Visual Basic) | PANTONE527 | Gets the Pantone 527 color.
static (Shared in Visual Basic) | PANTONE5275 | Gets the Pantone 5275 color.
static (Shared in Visual Basic) | PANTONE528 | Gets the Pantone 528 color.
static (Shared in Visual Basic) | PANTONE5285 | Gets the Pantone 5285 color.
static (Shared in Visual Basic) | PANTONE529 | Gets the Pantone 529 color.
static (Shared in Visual Basic) | PANTONE5295 | Gets the Pantone 5295 color.
static (Shared in Visual Basic) | PANTONE530 | Gets the Pantone 530 color.
static (Shared in Visual Basic) | PANTONE5305 | Gets the Pantone 5305 color.
static (Shared in Visual Basic) | PANTONE531 | Gets the Pantone 531 color.
static (Shared in Visual Basic) | PANTONE5315 | Gets the Pantone 5315 color.
static (Shared in Visual Basic) | PANTONE532 | Gets the Pantone 532 color.
static (Shared in Visual Basic) | PANTONE533 | Gets the Pantone 533 color.
static (Shared in Visual Basic) | PANTONE534 | Gets the Pantone 534 color.
static (Shared in Visual Basic) | PANTONE535 | Gets the Pantone 535 color.
static (Shared in Visual Basic) | PANTONE536 | Gets the Pantone 536 color.
static (Shared in Visual Basic) | PANTONE537 | Gets the Pantone 537 color.
static (Shared in Visual Basic) | PANTONE538 | Gets the Pantone 538 color.
static (Shared in Visual Basic) | PANTONE539 | Gets the Pantone 539 color.
static (Shared in Visual Basic) | PANTONE5395 | Gets the Pantone 5395 color.
static (Shared in Visual Basic) | PANTONE540 | Gets the Pantone 540 color.
static (Shared in Visual Basic) | PANTONE5405 | Gets the Pantone 5405 color.
static (Shared in Visual Basic) | PANTONE541 | Gets the Pantone 541 color.
static (Shared in Visual Basic) | PANTONE5415 | Gets the Pantone 5415 color.
static (Shared in Visual Basic) | PANTONE542 | Gets the Pantone 542 color.
static (Shared in Visual Basic) | PANTONE5425 | Gets the Pantone 5425 color.
static (Shared in Visual Basic) | PANTONE543 | Gets the Pantone 543 color.
static (Shared in Visual Basic) | PANTONE5435 | Gets the Pantone 5435 color.
static (Shared in Visual Basic) | PANTONE544 | Gets the Pantone 544 color.
static (Shared in Visual Basic) | PANTONE5445 | Gets the Pantone 5445 color.
static (Shared in Visual Basic) | PANTONE545 | Gets the Pantone 545 color.
static (Shared in Visual Basic) | PANTONE5455 | Gets the Pantone 5455 color.
static (Shared in Visual Basic) | PANTONE546 | Gets the Pantone 546 color.
static (Shared in Visual Basic) | PANTONE5463 | Gets the Pantone 5463 color.
static (Shared in Visual Basic) | PANTONE5467 | Gets the Pantone 5467 color.
static (Shared in Visual Basic) | PANTONE547 | Gets the Pantone 547 color.
static (Shared in Visual Basic) | PANTONE5473 | Gets the Pantone 5473 color.
static (Shared in Visual Basic) | PANTONE5477 | Gets the Pantone 5477 color.
static (Shared in Visual Basic) | PANTONE548 | Gets the Pantone 548 color.
static (Shared in Visual Basic) | PANTONE5483 | Gets the Pantone 5483 color.
static (Shared in Visual Basic) | PANTONE5487 | Gets the Pantone 5487 color.
static (Shared in Visual Basic) | PANTONE549 | Gets the Pantone 549 color.
static (Shared in Visual Basic) | PANTONE5493 | Gets the Pantone 5493 color.
static (Shared in Visual Basic) | PANTONE5497 | Gets the Pantone 5497 color.
static (Shared in Visual Basic) | PANTONE550 | Gets the Pantone 550 color.
static (Shared in Visual Basic) | PANTONE5503 | Gets the Pantone 5503 color.
static (Shared in Visual Basic) | PANTONE5507 | Gets the Pantone 5507 color.
static (Shared in Visual Basic) | PANTONE551 | Gets the Pantone 551 color.
static (Shared in Visual Basic) | PANTONE5513 | Gets the Pantone 5513 color.
static (Shared in Visual Basic) | PANTONE5517 | Gets the Pantone 5517 color.
static (Shared in Visual Basic) | PANTONE552 | Gets the Pantone 552 color.
static (Shared in Visual Basic) | PANTONE5523 | Gets the Pantone 5523 color.
static (Shared in Visual Basic) | PANTONE5527 | Gets the Pantone 5527 color.
static (Shared in Visual Basic) | PANTONE553 | Gets the Pantone 553 color.
static (Shared in Visual Basic) | PANTONE5535 | Gets the Pantone 5535 color.
static (Shared in Visual Basic) | PANTONE554 | Gets the Pantone 554 color.
static (Shared in Visual Basic) | PANTONE5545 | Gets the Pantone 5545 color.
static (Shared in Visual Basic) | PANTONE555 | Gets the Pantone 555 color.
static (Shared in Visual Basic) | PANTONE5555 | Gets the Pantone 5555 color.
static (Shared in Visual Basic) | PANTONE556 | Gets the Pantone 556 color.
static (Shared in Visual Basic) | PANTONE5565 | Gets the Pantone 5565 color.
static (Shared in Visual Basic) | PANTONE557 | Gets the Pantone 557 color.
static (Shared in Visual Basic) | PANTONE5575 | Gets the Pantone 5575 color.
static (Shared in Visual Basic) | PANTONE558 | Gets the Pantone 558 color.
static (Shared in Visual Basic) | PANTONE5585 | Gets the Pantone 5585 color.
static (Shared in Visual Basic) | PANTONE559 | Gets the Pantone 559 color.
static (Shared in Visual Basic) | PANTONE5595 | Gets the Pantone 5595 color.
static (Shared in Visual Basic) | PANTONE560 | Gets the Pantone 560 color.
static (Shared in Visual Basic) | PANTONE5605 | Gets the Pantone 5605 color.
static (Shared in Visual Basic) | PANTONE561 | Gets the Pantone 561 color.
static (Shared in Visual Basic) | PANTONE5615 | Gets the Pantone 5615 color.
static (Shared in Visual Basic) | PANTONE562 | Gets the Pantone 562 color.
static (Shared in Visual Basic) | PANTONE5625 | Gets the Pantone 5625 color.
static (Shared in Visual Basic) | PANTONE563 | Gets the Pantone 563 color.
static (Shared in Visual Basic) | PANTONE5635 | Gets the Pantone 5635 color.
static (Shared in Visual Basic) | PANTONE564 | Gets the Pantone 564 color.
static (Shared in Visual Basic) | PANTONE5645 | Gets the Pantone 5645 color.
static (Shared in Visual Basic) | PANTONE565 | Gets the Pantone 565 color.
static (Shared in Visual Basic) | PANTONE5655 | Gets the Pantone 5655 color.
static (Shared in Visual Basic) | PANTONE566 | Gets the Pantone 566 color.
static (Shared in Visual Basic) | PANTONE5665 | Gets the Pantone 5665 color.
static (Shared in Visual Basic) | PANTONE567 | Gets the Pantone 567 color.
static (Shared in Visual Basic) | PANTONE568 | Gets the Pantone 568 color.
static (Shared in Visual Basic) | PANTONE569 | Gets the Pantone 569 color.
static (Shared in Visual Basic) | PANTONE570 | Gets the Pantone 570 color.
static (Shared in Visual Basic) | PANTONE571 | Gets the Pantone 571 color.
static (Shared in Visual Basic) | PANTONE572 | Gets the Pantone 572 color.
static (Shared in Visual Basic) | PANTONE573 | Gets the Pantone 573 color.
static (Shared in Visual Basic) | PANTONE574 | Gets the Pantone 574 color.
static (Shared in Visual Basic) | PANTONE5743 | Gets the Pantone 5743 color.
static (Shared in Visual Basic) | PANTONE5747 | Gets the Pantone 5747 color.
static (Shared in Visual Basic) | PANTONE575 | Gets the Pantone 575 color.
static (Shared in Visual Basic) | PANTONE5753 | Gets the Pantone 5753 color.
static (Shared in Visual Basic) | PANTONE5757 | Gets the Pantone 5757 color.
static (Shared in Visual Basic) | PANTONE576 | Gets the Pantone 576 color.
static (Shared in Visual Basic) | PANTONE5763 | Gets the Pantone 5763 color.
static (Shared in Visual Basic) | PANTONE5767 | Gets the Pantone 5767 color.
static (Shared in Visual Basic) | PANTONE577 | Gets the Pantone 577 color.
static (Shared in Visual Basic) | PANTONE5773 | Gets the Pantone 5773 color.
static (Shared in Visual Basic) | PANTONE5777 | Gets the Pantone 5777 color.
static (Shared in Visual Basic) | PANTONE578 | Gets the Pantone 578 color.
static (Shared in Visual Basic) | PANTONE5783 | Gets the Pantone 5783 color.
static (Shared in Visual Basic) | PANTONE5787 | Gets the Pantone 5787 color.
static (Shared in Visual Basic) | PANTONE579 | Gets the Pantone 579 color.
static (Shared in Visual Basic) | PANTONE5793 | Gets the Pantone 5793 color.
static (Shared in Visual Basic) | PANTONE5797 | Gets the Pantone 5797 color.
static (Shared in Visual Basic) | PANTONE580 | Gets the Pantone 580 color.
static (Shared in Visual Basic) | PANTONE5803 | Gets the Pantone 5803 color.
static (Shared in Visual Basic) | PANTONE5807 | Gets the Pantone 5807 color.
static (Shared in Visual Basic) | PANTONE581 | Gets the Pantone 581 color.
static (Shared in Visual Basic) | PANTONE5815 | Gets the Pantone 5815 color.
static (Shared in Visual Basic) | PANTONE582 | Gets the Pantone 582 color.
static (Shared in Visual Basic) | PANTONE5825 | Gets the Pantone 5825 color.
static (Shared in Visual Basic) | PANTONE583 | Gets the Pantone 583 color.
static (Shared in Visual Basic) | PANTONE5835 | Gets the Pantone 5835 color.
static (Shared in Visual Basic) | PANTONE584 | Gets the Pantone 584 color.
static (Shared in Visual Basic) | PANTONE5845 | Gets the Pantone 5845 color.
static (Shared in Visual Basic) | PANTONE585 | Gets the Pantone 585 color.
static (Shared in Visual Basic) | PANTONE5855 | Gets the Pantone 5855 color.
static (Shared in Visual Basic) | PANTONE586 | Gets the Pantone 586 color.
static (Shared in Visual Basic) | PANTONE5865 | Gets the Pantone 5865 color.
static (Shared in Visual Basic) | PANTONE587 | Gets the Pantone 587 color.
static (Shared in Visual Basic) | PANTONE5875 | Gets the Pantone 5875 color.
static (Shared in Visual Basic) | PANTONE600 | Gets the Pantone 600 color.
static (Shared in Visual Basic) | PANTONE601 | Gets the Pantone 601 color.
static (Shared in Visual Basic) | PANTONE602 | Gets the Pantone 602 color.
static (Shared in Visual Basic) | PANTONE603 | Gets the Pantone 603 color.
static (Shared in Visual Basic) | PANTONE604 | Gets the Pantone 604 color.
static (Shared in Visual Basic) | PANTONE605 | Gets the Pantone 605 color.
static (Shared in Visual Basic) | PANTONE606 | Gets the Pantone 606 color.
static (Shared in Visual Basic) | PANTONE607 | Gets the Pantone 607 color.
static (Shared in Visual Basic) | PANTONE608 | Gets the Pantone 608 color.
static (Shared in Visual Basic) | PANTONE609 | Gets the Pantone 609 color.
static (Shared in Visual Basic) | PANTONE610 | Gets the Pantone 610 color.
static (Shared in Visual Basic) | PANTONE611 | Gets the Pantone 611 color.
static (Shared in Visual Basic) | PANTONE612 | Gets the Pantone 612 color.
static (Shared in Visual Basic) | PANTONE613 | Gets the Pantone 613 color.
static (Shared in Visual Basic) | PANTONE614 | Gets the Pantone 614 color.
static (Shared in Visual Basic) | PANTONE615 | Gets the Pantone 615 color.
static (Shared in Visual Basic) | PANTONE616 | Gets the Pantone 616 color.
static (Shared in Visual Basic) | PANTONE617 | Gets the Pantone 617 color.
static (Shared in Visual Basic) | PANTONE618 | Gets the Pantone 618 color.
static (Shared in Visual Basic) | PANTONE619 | Gets the Pantone 619 color.
static (Shared in Visual Basic) | PANTONE620 | Gets the Pantone 620 color.
static (Shared in Visual Basic) | PANTONE621 | Gets the Pantone 621 color.
static (Shared in Visual Basic) | PANTONE622 | Gets the Pantone 622 color.
static (Shared in Visual Basic) | PANTONE623 | Gets the Pantone 623 color.
static (Shared in Visual Basic) | PANTONE624 | Gets the Pantone 624 color.
static (Shared in Visual Basic) | PANTONE625 | Gets the Pantone 625 color.
static (Shared in Visual Basic) | PANTONE626 | Gets the Pantone 626 color.
static (Shared in Visual Basic) | PANTONE627 | Gets the Pantone 627 color.
static (Shared in Visual Basic) | PANTONE628 | Gets the Pantone 628 color.
static (Shared in Visual Basic) | PANTONE629 | Gets the Pantone 629 color.
static (Shared in Visual Basic) | PANTONE630 | Gets the Pantone 630 color.
static (Shared in Visual Basic) | PANTONE631 | Gets the Pantone 631 color.
static (Shared in Visual Basic) | PANTONE632 | Gets the Pantone 632 color.
static (Shared in Visual Basic) | PANTONE633 | Gets the Pantone 633 color.
static (Shared in Visual Basic) | PANTONE634 | Gets the Pantone 634 color.
static (Shared in Visual Basic) | PANTONE635 | Gets the Pantone 635 color.
static (Shared in Visual Basic) | PANTONE636 | Gets the Pantone 636 color.
static (Shared in Visual Basic) | PANTONE637 | Gets the Pantone 637 color.
static (Shared in Visual Basic) | PANTONE638 | Gets the Pantone 638 color.
static (Shared in Visual Basic) | PANTONE639 | Gets the Pantone 639 color.
static (Shared in Visual Basic) | PANTONE640 | Gets the Pantone 640 color.
static (Shared in Visual Basic) | PANTONE641 | Gets the Pantone 641 color.
static (Shared in Visual Basic) | PANTONE642 | Gets the Pantone 642 color.
static (Shared in Visual Basic) | PANTONE643 | Gets the Pantone 643 color.
static (Shared in Visual Basic) | PANTONE644 | Gets the Pantone 644 color.
static (Shared in Visual Basic) | PANTONE645 | Gets the Pantone 645 color.
static (Shared in Visual Basic) | PANTONE646 | Gets the Pantone 646 color.
static (Shared in Visual Basic) | PANTONE647 | Gets the Pantone 647 color.
static (Shared in Visual Basic) | PANTONE648 | Gets the Pantone 648 color.
static (Shared in Visual Basic) | PANTONE649 | Gets the Pantone 649 color.
static (Shared in Visual Basic) | PANTONE650 | Gets the Pantone 650 color.
static (Shared in Visual Basic) | PANTONE651 | Gets the Pantone 651 color.
static (Shared in Visual Basic) | PANTONE652 | Gets the Pantone 652 color.
static (Shared in Visual Basic) | PANTONE653 | Gets the Pantone 653 color.
static (Shared in Visual Basic) | PANTONE654 | Gets the Pantone 654 color.
static (Shared in Visual Basic) | PANTONE655 | Gets the Pantone 655 color.
static (Shared in Visual Basic) | PANTONE656 | Gets the Pantone 656 color.
static (Shared in Visual Basic) | PANTONE657 | Gets the Pantone 657 color.
static (Shared in Visual Basic) | PANTONE658 | Gets the Pantone 658 color.
static (Shared in Visual Basic) | PANTONE659 | Gets the Pantone 659 color.
static (Shared in Visual Basic) | PANTONE660 | Gets the Pantone 660 color.
static (Shared in Visual Basic) | PANTONE661 | Gets the Pantone 661 color.
static (Shared in Visual Basic) | PANTONE662 | Gets the Pantone 662 color.
static (Shared in Visual Basic) | PANTONE663 | Gets the Pantone 663 color.
static (Shared in Visual Basic) | PANTONE664 | Gets the Pantone 664 color.
static (Shared in Visual Basic) | PANTONE665 | Gets the Pantone 665 color.
static (Shared in Visual Basic) | PANTONE666 | Gets the Pantone 666 color.
static (Shared in Visual Basic) | PANTONE667 | Gets the Pantone 667 color.
static (Shared in Visual Basic) | PANTONE668 | Gets the Pantone 668 color.
static (Shared in Visual Basic) | PANTONE669 | Gets the Pantone 669 color.
static (Shared in Visual Basic) | PANTONE670 | Gets the Pantone 670 color.
static (Shared in Visual Basic) | PANTONE671 | Gets the Pantone 671 color.
static (Shared in Visual Basic) | PANTONE672 | Gets the Pantone 672 color.
static (Shared in Visual Basic) | PANTONE673 | Gets the Pantone 673 color.
static (Shared in Visual Basic) | PANTONE674 | Gets the Pantone 674 color.
static (Shared in Visual Basic) | PANTONE675 | Gets the Pantone 675 color.
static (Shared in Visual Basic) | PANTONE676 | Gets the Pantone 676 color.
static (Shared in Visual Basic) | PANTONE677 | Gets the Pantone 677 color.
static (Shared in Visual Basic) | PANTONE678 | Gets the Pantone 678 color.
static (Shared in Visual Basic) | PANTONE679 | Gets the Pantone 679 color.
static (Shared in Visual Basic) | PANTONE680 | Gets the Pantone 680 color.
static (Shared in Visual Basic) | PANTONE681 | Gets the Pantone 681 color.
static (Shared in Visual Basic) | PANTONE682 | Gets the Pantone 682 color.
static (Shared in Visual Basic) | PANTONE683 | Gets the Pantone 683 color.
static (Shared in Visual Basic) | PANTONE684 | Gets the Pantone 684 color.
static (Shared in Visual Basic) | PANTONE685 | Gets the Pantone 685 color.
static (Shared in Visual Basic) | PANTONE686 | Gets the Pantone 686 color.
static (Shared in Visual Basic) | PANTONE687 | Gets the Pantone 687 color.
static (Shared in Visual Basic) | PANTONE688 | Gets the Pantone 688 color.
static (Shared in Visual Basic) | PANTONE689 | Gets the Pantone 689 color.
static (Shared in Visual Basic) | PANTONE690 | Gets the Pantone 690 color.
static (Shared in Visual Basic) | PANTONE691 | Gets the Pantone 691 color.
static (Shared in Visual Basic) | PANTONE692 | Gets the Pantone 692 color.
static (Shared in Visual Basic) | PANTONE693 | Gets the Pantone 693 color.
static (Shared in Visual Basic) | PANTONE694 | Gets the Pantone 694 color.
static (Shared in Visual Basic) | PANTONE695 | Gets the Pantone 695 color.
static (Shared in Visual Basic) | PANTONE696 | Gets the Pantone 696 color.
static (Shared in Visual Basic) | PANTONE697 | Gets the Pantone 697 color.
static (Shared in Visual Basic) | PANTONE698 | Gets the Pantone 698 color.
static (Shared in Visual Basic) | PANTONE699 | Gets the Pantone 699 color.
static (Shared in Visual Basic) | PANTONE700 | Gets the Pantone 700 color.
static (Shared in Visual Basic) | PANTONE701 | Gets the Pantone 701 color.
static (Shared in Visual Basic) | PANTONE702 | Gets the Pantone 702 color.
static (Shared in Visual Basic) | PANTONE703 | Gets the Pantone 703 color.
static (Shared in Visual Basic) | PANTONE704 | Gets the Pantone 704 color.
static (Shared in Visual Basic) | PANTONE705 | Gets the Pantone 705 color.
static (Shared in Visual Basic) | PANTONE706 | Gets the Pantone 706 color.
static (Shared in Visual Basic) | PANTONE707 | Gets the Pantone 707 color.
static (Shared in Visual Basic) | PANTONE708 | Gets the Pantone 708 color.
static (Shared in Visual Basic) | PANTONE709 | Gets the Pantone 709 color.
static (Shared in Visual Basic) | PANTONE710 | Gets the Pantone 710 color.
static (Shared in Visual Basic) | PANTONE711 | Gets the Pantone 711 color.
static (Shared in Visual Basic) | PANTONE712 | Gets the Pantone 712 color.
static (Shared in Visual Basic) | PANTONE713 | Gets the Pantone 713 color.
static (Shared in Visual Basic) | PANTONE714 | Gets the Pantone 714 color.
static (Shared in Visual Basic) | PANTONE715 | Gets the Pantone 715 color.
static (Shared in Visual Basic) | PANTONE716 | Gets the Pantone 716 color.
static (Shared in Visual Basic) | PANTONE717 | Gets the Pantone 717 color.
static (Shared in Visual Basic) | PANTONE718 | Gets the Pantone 718 color.
static (Shared in Visual Basic) | PANTONE719 | Gets the Pantone 719 color.
static (Shared in Visual Basic) | PANTONE720 | Gets the Pantone 720 color.
static (Shared in Visual Basic) | PANTONE721 | Gets the Pantone 721 color.
static (Shared in Visual Basic) | PANTONE722 | Gets the Pantone 722 color.
static (Shared in Visual Basic) | PANTONE723 | Gets the Pantone 723 color.
static (Shared in Visual Basic) | PANTONE724 | Gets the Pantone 724 color.
static (Shared in Visual Basic) | PANTONE725 | Gets the Pantone 725 color.
static (Shared in Visual Basic) | PANTONE726 | Gets the Pantone 726 color.
static (Shared in Visual Basic) | PANTONE727 | Gets the Pantone 727 color.
static (Shared in Visual Basic) | PANTONE728 | Gets the Pantone 728 color.
static (Shared in Visual Basic) | PANTONE729 | Gets the Pantone 729 color.
static (Shared in Visual Basic) | PANTONE730 | Gets the Pantone 730 color.
static (Shared in Visual Basic) | PANTONE731 | Gets the Pantone 731 color.
static (Shared in Visual Basic) | PANTONE732 | Gets the Pantone 732 color.
static (Shared in Visual Basic) | PANTONE7401 | Gets the Pantone 7401 color.
static (Shared in Visual Basic) | PANTONE7402 | Gets the Pantone 7402 color.
static (Shared in Visual Basic) | PANTONE7403 | Gets the Pantone 7403 color.
static (Shared in Visual Basic) | PANTONE7404 | Gets the Pantone 7404 color.
static (Shared in Visual Basic) | PANTONE7405 | Gets the Pantone 7405 color.
static (Shared in Visual Basic) | PANTONE7406 | Gets the Pantone 7406 color.
static (Shared in Visual Basic) | PANTONE7407 | Gets the Pantone 7407 color.
static (Shared in Visual Basic) | PANTONE7408 | Gets the Pantone 7408 color.
static (Shared in Visual Basic) | PANTONE7409 | Gets the Pantone 7409 color.
static (Shared in Visual Basic) | PANTONE7410 | Gets the Pantone 7410 color.
static (Shared in Visual Basic) | PANTONE7411 | Gets the Pantone 7411 color.
static (Shared in Visual Basic) | PANTONE7412 | Gets the Pantone 7412 color.
static (Shared in Visual Basic) | PANTONE7413 | Gets the Pantone 7413 color.
static (Shared in Visual Basic) | PANTONE7414 | Gets the Pantone 7414 color.
static (Shared in Visual Basic) | PANTONE7415 | Gets the Pantone 7415 color.
static (Shared in Visual Basic) | PANTONE7416 | Gets the Pantone 7416 color.
static (Shared in Visual Basic) | PANTONE7417 | Gets the Pantone 7417 color.
static (Shared in Visual Basic) | PANTONE7418 | Gets the Pantone 7418 color.
static (Shared in Visual Basic) | PANTONE7419 | Gets the Pantone 7419 color.
static (Shared in Visual Basic) | PANTONE7420 | Gets the Pantone 7420 color.
static (Shared in Visual Basic) | PANTONE7421 | Gets the Pantone 7421 color.
static (Shared in Visual Basic) | PANTONE7422 | Gets the Pantone 7422 color.
static (Shared in Visual Basic) | PANTONE7423 | Gets the Pantone 7423 color.
static (Shared in Visual Basic) | PANTONE7424 | Gets the Pantone 7424 color.
static (Shared in Visual Basic) | PANTONE7425 | Gets the Pantone 7425 color.
static (Shared in Visual Basic) | PANTONE7426 | Gets the Pantone 7426 color.
static (Shared in Visual Basic) | PANTONE7427 | Gets the Pantone 7427 color.
static (Shared in Visual Basic) | PANTONE7428 | Gets the Pantone 7428 color.
static (Shared in Visual Basic) | PANTONE7429 | Gets the Pantone 7429 color.
static (Shared in Visual Basic) | PANTONE7430 | Gets the Pantone 7430 color.
static (Shared in Visual Basic) | PANTONE7431 | Gets the Pantone 7431 color.
static (Shared in Visual Basic) | PANTONE7432 | Gets the Pantone 7432 color.
static (Shared in Visual Basic) | PANTONE7433 | Gets the Pantone 7433 color.
static (Shared in Visual Basic) | PANTONE7434 | Gets the Pantone 7434 color.
static (Shared in Visual Basic) | PANTONE7435 | Gets the Pantone 7435 color.
static (Shared in Visual Basic) | PANTONE7436 | Gets the Pantone 7436 color.
static (Shared in Visual Basic) | PANTONE7437 | Gets the Pantone 7437 color.
static (Shared in Visual Basic) | PANTONE7438 | Gets the Pantone 7438 color.
static (Shared in Visual Basic) | PANTONE7439 | Gets the Pantone 7439 color.
static (Shared in Visual Basic) | PANTONE7440 | Gets the Pantone 7440 color.
static (Shared in Visual Basic) | PANTONE7441 | Gets the Pantone 7441 color.
static (Shared in Visual Basic) | PANTONE7442 | Gets the Pantone 7442 color.
static (Shared in Visual Basic) | PANTONE7443 | Gets the Pantone 7443 color.
static (Shared in Visual Basic) | PANTONE7444 | Gets the Pantone 7444 color.
static (Shared in Visual Basic) | PANTONE7445 | Gets the Pantone 7445 color.
static (Shared in Visual Basic) | PANTONE7446 | Gets the Pantone 7446 color.
static (Shared in Visual Basic) | PANTONE7447 | Gets the Pantone 7447 color.
static (Shared in Visual Basic) | PANTONE7448 | Gets the Pantone 7448 color.
static (Shared in Visual Basic) | PANTONE7449 | Gets the Pantone 7449 color.
static (Shared in Visual Basic) | PANTONE7450 | Gets the Pantone 7450 color.
static (Shared in Visual Basic) | PANTONE7451 | Gets the Pantone 7451 color.
static (Shared in Visual Basic) | PANTONE7452 | Gets the Pantone 7452 color.
static (Shared in Visual Basic) | PANTONE7453 | Gets the Pantone 7453 color.
static (Shared in Visual Basic) | PANTONE7454 | Gets the Pantone 7454 color.
static (Shared in Visual Basic) | PANTONE7455 | Gets the Pantone 7455 color.
static (Shared in Visual Basic) | PANTONE7456 | Gets the Pantone 7456 color.
static (Shared in Visual Basic) | PANTONE7457 | Gets the Pantone 7457 color.
static (Shared in Visual Basic) | PANTONE7458 | Gets the Pantone 7458 color.
static (Shared in Visual Basic) | PANTONE7459 | Gets the Pantone 7459 color.
static (Shared in Visual Basic) | PANTONE7460 | Gets the Pantone 7460 color.
static (Shared in Visual Basic) | PANTONE7461 | Gets the Pantone 7461 color.
static (Shared in Visual Basic) | PANTONE7462 | Gets the Pantone 7462 color.
static (Shared in Visual Basic) | PANTONE7463 | Gets the Pantone 7463 color.
static (Shared in Visual Basic) | PANTONE7464 | Gets the Pantone 7464 color.
static (Shared in Visual Basic) | PANTONE7465 | Gets the Pantone 7465 color.
static (Shared in Visual Basic) | PANTONE7466 | Gets the Pantone 7466 color.
static (Shared in Visual Basic) | PANTONE7467 | Gets the Pantone 7467 color.
static (Shared in Visual Basic) | PANTONE7468 | Gets the Pantone 7468 color.
static (Shared in Visual Basic) | PANTONE7469 | Gets the Pantone 7469 color.
static (Shared in Visual Basic) | PANTONE7470 | Gets the Pantone 7470 color.
static (Shared in Visual Basic) | PANTONE7471 | Gets the Pantone 7471 color.
static (Shared in Visual Basic) | PANTONE7472 | Gets the Pantone 7472 color.
static (Shared in Visual Basic) | PANTONE7473 | Gets the Pantone 7473 color.
static (Shared in Visual Basic) | PANTONE7474 | Gets the Pantone 7474 color.
static (Shared in Visual Basic) | PANTONE7475 | Gets the Pantone 7475 color.
static (Shared in Visual Basic) | PANTONE7476 | Gets the Pantone 7476 color.
static (Shared in Visual Basic) | PANTONE7477 | Gets the Pantone 7477 color.
static (Shared in Visual Basic) | PANTONE7478 | Gets the Pantone 7478 color.
static (Shared in Visual Basic) | PANTONE7479 | Gets the Pantone 7479 color.
static (Shared in Visual Basic) | PANTONE7480 | Gets the Pantone 7480 color.
static (Shared in Visual Basic) | PANTONE7481 | Gets the Pantone 7481 color.
static (Shared in Visual Basic) | PANTONE7482 | Gets the Pantone 7482 color.
static (Shared in Visual Basic) | PANTONE7483 | Gets the Pantone 7483 color.
static (Shared in Visual Basic) | PANTONE7484 | Gets the Pantone 7484 color.
static (Shared in Visual Basic) | PANTONE7485 | Gets the Pantone 7485 color.
static (Shared in Visual Basic) | PANTONE7486 | Gets the Pantone 7486 color.
static (Shared in Visual Basic) | PANTONE7487 | Gets the Pantone 7487 color.
static (Shared in Visual Basic) | PANTONE7488 | Gets the Pantone 7488 color.
static (Shared in Visual Basic) | PANTONE7489 | Gets the Pantone 7489 color.
static (Shared in Visual Basic) | PANTONE7490 | Gets the Pantone 7490 color.
static (Shared in Visual Basic) | PANTONE7491 | Gets the Pantone 7491 color.
static (Shared in Visual Basic) | PANTONE7492 | Gets the Pantone 7492 color.
static (Shared in Visual Basic) | PANTONE7493 | Gets the Pantone 7493 color.
static (Shared in Visual Basic) | PANTONE7494 | Gets the Pantone 7494 color.
static (Shared in Visual Basic) | PANTONE7495 | Gets the Pantone 7495 color.
static (Shared in Visual Basic) | PANTONE7496 | Gets the Pantone 7496 color.
static (Shared in Visual Basic) | PANTONE7497 | Gets the Pantone 7497 color.
static (Shared in Visual Basic) | PANTONE7498 | Gets the Pantone 7498 color.
static (Shared in Visual Basic) | PANTONE7499 | Gets the Pantone 7499 color.
static (Shared in Visual Basic) | PANTONE7500 | Gets the Pantone 7500 color.
static (Shared in Visual Basic) | PANTONE7501 | Gets the Pantone 7501 color.
static (Shared in Visual Basic) | PANTONE7502 | Gets the Pantone 7502 color.
static (Shared in Visual Basic) | PANTONE7503 | Gets the Pantone 7503 color.
static (Shared in Visual Basic) | PANTONE7504 | Gets the Pantone 7504 color.
static (Shared in Visual Basic) | PANTONE7505 | Gets the Pantone 7505 color.
static (Shared in Visual Basic) | PANTONE7506 | Gets the Pantone 7506 color.
static (Shared in Visual Basic) | PANTONE7507 | Gets the Pantone 7507 color.
static (Shared in Visual Basic) | PANTONE7508 | Gets the Pantone 7508 color.
static (Shared in Visual Basic) | PANTONE7509 | Gets the Pantone 7509 color.
static (Shared in Visual Basic) | PANTONE7510 | Gets the Pantone 7510 color.
static (Shared in Visual Basic) | PANTONE7511 | Gets the Pantone 7511 color.
static (Shared in Visual Basic) | PANTONE7512 | Gets the Pantone 7512 color.
static (Shared in Visual Basic) | PANTONE7513 | Gets the Pantone 7513 color.
static (Shared in Visual Basic) | PANTONE7514 | Gets the Pantone 7514 color.
static (Shared in Visual Basic) | PANTONE7515 | Gets the Pantone 7515 color.
static (Shared in Visual Basic) | PANTONE7516 | Gets the Pantone 7516 color.
static (Shared in Visual Basic) | PANTONE7517 | Gets the Pantone 7517 color.
static (Shared in Visual Basic) | PANTONE7518 | Gets the Pantone 7518 color.
static (Shared in Visual Basic) | PANTONE7519 | Gets the Pantone 7519 color.
static (Shared in Visual Basic) | PANTONE7520 | Gets the Pantone 7520 color.
static (Shared in Visual Basic) | PANTONE7521 | Gets the Pantone 7521 color.
static (Shared in Visual Basic) | PANTONE7522 | Gets the Pantone 7522 color.
static (Shared in Visual Basic) | PANTONE7523 | Gets the Pantone 7523 color.
static (Shared in Visual Basic) | PANTONE7524 | Gets the Pantone 7524 color.
static (Shared in Visual Basic) | PANTONE7525 | Gets the Pantone 7525 color.
static (Shared in Visual Basic) | PANTONE7526 | Gets the Pantone 7526 color.
static (Shared in Visual Basic) | PANTONE7527 | Gets the Pantone 7527 color.
static (Shared in Visual Basic) | PANTONE7528 | Gets the Pantone 7528 color.
static (Shared in Visual Basic) | PANTONE7529 | Gets the Pantone 7529 color.
static (Shared in Visual Basic) | PANTONE7530 | Gets the Pantone 7530 color.
static (Shared in Visual Basic) | PANTONE7531 | Gets the Pantone 7531 color.
static (Shared in Visual Basic) | PANTONE7532 | Gets the Pantone 7532 color.
static (Shared in Visual Basic) | PANTONE7533 | Gets the Pantone 7533 color.
static (Shared in Visual Basic) | PANTONE7534 | Gets the Pantone 7534 color.
static (Shared in Visual Basic) | PANTONE7535 | Gets the Pantone 7535 color.
static (Shared in Visual Basic) | PANTONE7536 | Gets the Pantone 7536 color.
static (Shared in Visual Basic) | PANTONE7537 | Gets the Pantone 7537 color.
static (Shared in Visual Basic) | PANTONE7538 | Gets the Pantone 7538 color.
static (Shared in Visual Basic) | PANTONE7539 | Gets the Pantone 7539 color.
static (Shared in Visual Basic) | PANTONE7540 | Gets the Pantone 7540 color.
static (Shared in Visual Basic) | PANTONE7541 | Gets the Pantone 7541 color.
static (Shared in Visual Basic) | PANTONE7542 | Gets the Pantone 7542 color.
static (Shared in Visual Basic) | PANTONE7543 | Gets the Pantone 7543 color.
static (Shared in Visual Basic) | PANTONE7544 | Gets the Pantone 7544 color.
static (Shared in Visual Basic) | PANTONE7545 | Gets the Pantone 7545 color.
static (Shared in Visual Basic) | PANTONE7546 | Gets the Pantone 7546 color.
static (Shared in Visual Basic) | PANTONE7547 | Gets the Pantone 7547 color.
static (Shared in Visual Basic) | PANTONE8003 | Gets the Pantone 8003 color.
static (Shared in Visual Basic) | PANTONE801 | Gets the Pantone 801 color.
static (Shared in Visual Basic) | PANTONE802 | Gets the Pantone 802 color.
static (Shared in Visual Basic) | PANTONE8021 | Gets the Pantone 8021 color.
static (Shared in Visual Basic) | PANTONE803 | Gets the Pantone 803 color.
static (Shared in Visual Basic) | PANTONE804 | Gets the Pantone 804 color.
static (Shared in Visual Basic) | PANTONE805 | Gets the Pantone 805 color.
static (Shared in Visual Basic) | PANTONE806 | Gets the Pantone 806 color.
static (Shared in Visual Basic) | PANTONE8062 | Gets the Pantone 8062 color.
static (Shared in Visual Basic) | PANTONE807 | Gets the Pantone 807 color.
static (Shared in Visual Basic) | PANTONE808 | Gets the Pantone 808 color.
static (Shared in Visual Basic) | PANTONE809 | Gets the Pantone 809 color.
static (Shared in Visual Basic) | PANTONE810 | Gets the Pantone 810 color.
static (Shared in Visual Basic) | PANTONE8100 | Gets the Pantone 8100 color.
static (Shared in Visual Basic) | PANTONE811 | Gets the Pantone 811 color.
static (Shared in Visual Basic) | PANTONE812 | Gets the Pantone 812 color.
static (Shared in Visual Basic) | PANTONE813 | Gets the Pantone 813 color.
static (Shared in Visual Basic) | PANTONE814 | Gets the Pantone 814 color.
static (Shared in Visual Basic) | PANTONE8201 | Gets the Pantone 8201 color.
static (Shared in Visual Basic) | PANTONE8281 | Gets the Pantone 8281 color.
static (Shared in Visual Basic) | PANTONE8321 | Gets the Pantone 8321 color.
static (Shared in Visual Basic) | PANTONE871 | Gets the Pantone 871 color.
static (Shared in Visual Basic) | PANTONE872 | Gets the Pantone 872 color.
static (Shared in Visual Basic) | PANTONE873 | Gets the Pantone 873 color.
static (Shared in Visual Basic) | PANTONE874 | Gets the Pantone 874 color.
static (Shared in Visual Basic) | PANTONE875 | Gets the Pantone 875 color.
static (Shared in Visual Basic) | PANTONE876 | Gets the Pantone 876 color.
static (Shared in Visual Basic) | PANTONE877 | Gets the Pantone 877 color.
static (Shared in Visual Basic) | ProcessBlack | Gets the Pantone Process Black color.
static (Shared in Visual Basic) | ProcessBlue | Gets the Pantone Process Blue color.
static (Shared in Visual Basic) | ProcessCyan | Gets the Pantone Process Cyan color.
static (Shared in Visual Basic) | ProcessMagenta | Gets the Pantone Process Magenta color.
static (Shared in Visual Basic) | ProcessYellow | Gets the Pantone Process Yellow color.
static (Shared in Visual Basic) | Purple | Gets the Pantone Purple color.
static (Shared in Visual Basic) | Red032 | Gets the Pantone Red 032 color.
static (Shared in Visual Basic) | ReflexBlue | Gets the Pantone Reflex Blue color.
static (Shared in Visual Basic) | RhodamineRed | Gets the Pantone Rhodamine Red color.
static (Shared in Visual Basic) | RubineRed | Gets the Pantone Rubine Red color.
Public Property | Tint | Gets or sets the tint component. (Inherited from Xfinium.Pdf.Graphics.PdfSeparationColor)
static (Shared in Visual Basic) | Violet | Gets the Pantone Violet color.
static (Shared in Visual Basic) | WarmGray1 | Gets the Pantone Warm Gray 1 color.
static (Shared in Visual Basic) | WarmGray10 | Gets the Pantone Warm Gray 10 color.
static (Shared in Visual Basic) | WarmGray11 | Gets the Pantone Warm Gray 11 color.
static (Shared in Visual Basic) | WarmGray2 | Gets the Pantone Warm Gray 2 color.
static (Shared in Visual Basic) | WarmGray3 | Gets the Pantone Warm Gray 3 color.
static (Shared in Visual Basic) | WarmGray4 | Gets the Pantone Warm Gray 4 color.
static (Shared in Visual Basic) | WarmGray5 | Gets the Pantone Warm Gray 5 color.
static (Shared in Visual Basic) | WarmGray6 | Gets the Pantone Warm Gray 6 color.
static (Shared in Visual Basic) | WarmGray7 | Gets the Pantone Warm Gray 7 color.
static (Shared in Visual Basic) | WarmGray8 | Gets the Pantone Warm Gray 8 color.
static (Shared in Visual Basic) | WarmGray9 | Gets the Pantone Warm Gray 9 color.
static (Shared in Visual Basic) | WarmRed | Gets the Pantone Warm Red color.
static (Shared in Visual Basic) | Yellow | Gets the Pantone Yellow color.
static (Shared in Visual Basic) | Yellow012 | Gets the Pantone Yellow 012 color.
Top
Public Methods
 | Name | Description
Public Method | Copy | Copies this color. (Inherited from Xfinium.Pdf.Graphics.PdfSeparationColor)
Public Method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Xfinium.Pdf.Graphics.PdfSeparationColor)
Public Method | GetHashCode | Serves as the default hash function. (Inherited from Xfinium.Pdf.Graphics.PdfSeparationColor)
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfPantoneColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfPantoneColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPantoneColor Class

For a list of all members of this type, see PdfPantoneColor members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Black | Gets the Pantone Black color.
static (Shared in Visual Basic) | Black2 | Gets the Pantone Black 2 color.
static (Shared in Visual Basic) | Black3 | Gets the Pantone Black 3 color.
static (Shared in Visual Basic) | Black4 | Gets the Pantone Black 4 color.
static (Shared in Visual Basic) | Black5 | Gets the Pantone Black 5 color.
static (Shared in Visual Basic) | Black6 | Gets the Pantone Black 6 color.
static (Shared in Visual Basic) | Black7 | Gets the Pantone Black 7 color.
static (Shared in Visual Basic) | Blue072 | Gets the Pantone Blue 072 color.
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
static (Shared in Visual Basic) | CoolGray1 | Gets the Pantone Cool Gray 1 color.
static (Shared in Visual Basic) | CoolGray10 | Gets the Pantone Cool Gray 10 color.
static (Shared in Visual Basic) | CoolGray11 | Gets the Pantone Cool Gray 11 color.
static (Shared in Visual Basic) | CoolGray2 | Gets the Pantone Cool Gray 2 color.
static (Shared in Visual Basic) | CoolGray3 | Gets the Pantone Cool Gray 3 color.
static (Shared in Visual Basic) | CoolGray4 | Gets the Pantone Cool Gray 4 color.
static (Shared in Visual Basic) | CoolGray5 | Gets the Pantone Cool Gray 5 color.
static (Shared in Visual Basic) | CoolGray6 | Gets the Pantone Cool Gray 6 color.
static (Shared in Visual Basic) | CoolGray7 | Gets the Pantone Cool Gray 7 color.
static (Shared in Visual Basic) | CoolGray8 | Gets the Pantone Cool Gray 8 color.
static (Shared in Visual Basic) | CoolGray9 | Gets the Pantone Cool Gray 9 color.
static (Shared in Visual Basic) | Green | Gets the Pantone Green color.
static (Shared in Visual Basic) | HexachromeBlack | Gets the Pantone Hexachrome Black color.
static (Shared in Visual Basic) | HexachromeCyan | Gets the Pantone Hexachrome Cyan color.
static (Shared in Visual Basic) | HexachromeGreen | Gets the Pantone Hexachrome Green color.
static (Shared in Visual Basic) | HexachromeMagenta | Gets the Pantone Hexachrome Magenta color.
static (Shared in Visual Basic) | HexachromeOrange | Gets the Pantone Hexachrome Orange color.
static (Shared in Visual Basic) | HexachromeYellow | Gets the Pantone Hexachrome Yellow color.
static (Shared in Visual Basic) | Orange021 | Gets the Pantone Orange 021 color.
static (Shared in Visual Basic) | PANTONE100 | Gets the Pantone 100 color.
static (Shared in Visual Basic) | PANTONE101 | Gets the Pantone 101 color.
static (Shared in Visual Basic) | PANTONE102 | Gets the Pantone 102 color.
static (Shared in Visual Basic) | PANTONE103 | Gets the Pantone 103 color.
static (Shared in Visual Basic) | PANTONE104 | Gets the Pantone 104 color.
static (Shared in Visual Basic) | PANTONE105 | Gets the Pantone 105 color.
static (Shared in Visual Basic) | PANTONE106 | Gets the Pantone 106 color.
static (Shared in Visual Basic) | PANTONE107 | Gets the Pantone 107 color.
static (Shared in Visual Basic) | PANTONE108 | Gets the Pantone 108 color.
static (Shared in Visual Basic) | PANTONE109 | Gets the Pantone 109 color.
static (Shared in Visual Basic) | PANTONE110 | Gets the Pantone 110 color.
static (Shared in Visual Basic) | PANTONE111 | Gets the Pantone 111 color.
static (Shared in Visual Basic) | PANTONE112 | Gets the Pantone 112 color.
static (Shared in Visual Basic) | PANTONE113 | Gets the Pantone 113 color.
static (Shared in Visual Basic) | PANTONE114 | Gets the Pantone 114 color.
static (Shared in Visual Basic) | PANTONE115 | Gets the Pantone 115 color.
static (Shared in Visual Basic) | PANTONE116 | Gets the Pantone 116 color.
static (Shared in Visual Basic) | PANTONE117 | Gets the Pantone 117 color.
static (Shared in Visual Basic) | PANTONE118 | Gets the Pantone 118 color.
static (Shared in Visual Basic) | PANTONE119 | Gets the Pantone 119 color.
static (Shared in Visual Basic) | PANTONE120 | Gets the Pantone 120 color.
static (Shared in Visual Basic) | PANTONE1205 | Gets the Pantone 1205 color.
static (Shared in Visual Basic) | PANTONE121 | Gets the Pantone 121 color.
static (Shared in Visual Basic) | PANTONE1215 | Gets the Pantone 1215 color.
static (Shared in Visual Basic) | PANTONE122 | Gets the Pantone 122 color.
static (Shared in Visual Basic) | PANTONE1225 | Gets the Pantone 1225 color.
static (Shared in Visual Basic) | PANTONE123 | Gets the Pantone 123 color.
static (Shared in Visual Basic) | PANTONE1235 | Gets the Pantone 1235 color.
static (Shared in Visual Basic) | PANTONE124 | Gets the Pantone 124 color.
static (Shared in Visual Basic) | PANTONE1245 | Gets the Pantone 1245 color.
static (Shared in Visual Basic) | PANTONE125 | Gets the Pantone 125 color.
static (Shared in Visual Basic) | PANTONE1255 | Gets the Pantone 1255 color.
static (Shared in Visual Basic) | PANTONE126 | Gets the Pantone 126 color.
static (Shared in Visual Basic) | PANTONE1265 | Gets the Pantone 1265 color.
static (Shared in Visual Basic) | PANTONE127 | Gets the Pantone 127 color.
static (Shared in Visual Basic) | PANTONE128 | Gets the Pantone 128 color.
static (Shared in Visual Basic) | PANTONE129 | Gets the Pantone 129 color.
static (Shared in Visual Basic) | PANTONE130 | Gets the Pantone 130 color.
static (Shared in Visual Basic) | PANTONE131 | Gets the Pantone 131 color.
static (Shared in Visual Basic) | PANTONE132 | Gets the Pantone 132 color.
static (Shared in Visual Basic) | PANTONE133 | Gets the Pantone 133 color.
static (Shared in Visual Basic) | PANTONE134 | Gets the Pantone 134 color.
static (Shared in Visual Basic) | PANTONE1345 | Gets the Pantone 1345 color.
static (Shared in Visual Basic) | PANTONE135 | Gets the Pantone 135 color.
static (Shared in Visual Basic) | PANTONE1355 | Gets the Pantone 1355 color.
static (Shared in Visual Basic) | PANTONE136 | Gets the Pantone 136 color.
static (Shared in Visual Basic) | PANTONE1365 | Gets the Pantone 1365 color.
static (Shared in Visual Basic) | PANTONE137 | Gets the Pantone 137 color.
static (Shared in Visual Basic) | PANTONE1375 | Gets the Pantone 1375 color.
static (Shared in Visual Basic) | PANTONE138 | Gets the Pantone 138 color.
static (Shared in Visual Basic) | PANTONE1385 | Gets the Pantone 1385 color.
static (Shared in Visual Basic) | PANTONE139 | Gets the Pantone 139 color.
static (Shared in Visual Basic) | PANTONE1395 | Gets the Pantone 1395 color.
static (Shared in Visual Basic) | PANTONE140 | Gets the Pantone 140 color.
static (Shared in Visual Basic) | PANTONE1405 | Gets the Pantone 1405 color.
static (Shared in Visual Basic) | PANTONE141 | Gets the Pantone 141 color.
static (Shared in Visual Basic) | PANTONE142 | Gets the Pantone 142 color.
static (Shared in Visual Basic) | PANTONE143 | Gets the Pantone 143 color.
static (Shared in Visual Basic) | PANTONE144 | Gets the Pantone 144 color.
static (Shared in Visual Basic) | PANTONE145 | Gets the Pantone 145 color.
static (Shared in Visual Basic) | PANTONE146 | Gets the Pantone 146 color.
static (Shared in Visual Basic) | PANTONE147 | Gets the Pantone 147 color.
static (Shared in Visual Basic) | PANTONE148 | Gets the Pantone 148 color.
static (Shared in Visual Basic) | PANTONE1485 | Gets the Pantone 1485 color.
static (Shared in Visual Basic) | PANTONE149 | Gets the Pantone 149 color.
static (Shared in Visual Basic) | PANTONE1495 | Gets the Pantone 1495 color.
static (Shared in Visual Basic) | PANTONE150 | Gets the Pantone 150 color.
static (Shared in Visual Basic) | PANTONE1505 | Gets the Pantone 1505 color.
static (Shared in Visual Basic) | PANTONE151 | Gets the Pantone 151 color.
static (Shared in Visual Basic) | PANTONE152 | Gets the Pantone 152 color.
static (Shared in Visual Basic) | PANTONE1525 | Gets the Pantone 1525 color.
static (Shared in Visual Basic) | PANTONE153 | Gets the Pantone 153 color.
static (Shared in Visual Basic) | PANTONE1535 | Gets the Pantone 1535 color.
static (Shared in Visual Basic) | PANTONE154 | Gets the Pantone 154 color.
static (Shared in Visual Basic) | PANTONE1545 | Gets the Pantone 1545 color.
static (Shared in Visual Basic) | PANTONE155 | Gets the Pantone 155 color.
static (Shared in Visual Basic) | PANTONE1555 | Gets the Pantone 1555 color.
static (Shared in Visual Basic) | PANTONE156 | Gets the Pantone 156 color.
static (Shared in Visual Basic) | PANTONE1565 | Gets the Pantone 1565 color.
static (Shared in Visual Basic) | PANTONE157 | Gets the Pantone 157 color.
static (Shared in Visual Basic) | PANTONE1575 | Gets the Pantone 1575 color.
static (Shared in Visual Basic) | PANTONE158 | Gets the Pantone 158 color.
static (Shared in Visual Basic) | PANTONE1585 | Gets the Pantone 1585 color.
static (Shared in Visual Basic) | PANTONE159 | Gets the Pantone 159 color.
static (Shared in Visual Basic) | PANTONE1595 | Gets the Pantone 1595 color.
static (Shared in Visual Basic) | PANTONE160 | Gets the Pantone 160 color.
static (Shared in Visual Basic) | PANTONE1605 | Gets the Pantone 1605 color.
static (Shared in Visual Basic) | PANTONE161 | Gets the Pantone 161 color.
static (Shared in Visual Basic) | PANTONE1615 | Gets the Pantone 1615 color.
static (Shared in Visual Basic) | PANTONE162 | Gets the Pantone 162 color.
static (Shared in Visual Basic) | PANTONE1625 | Gets the Pantone 1625 color.
static (Shared in Visual Basic) | PANTONE163 | Gets the Pantone 163 color.
static (Shared in Visual Basic) | PANTONE1635 | Gets the Pantone 1635 color.
static (Shared in Visual Basic) | PANTONE164 | Gets the Pantone 164 color.
static (Shared in Visual Basic) | PANTONE1645 | Gets the Pantone 1645 color.
static (Shared in Visual Basic) | PANTONE165 | Gets the Pantone 165 color.
static (Shared in Visual Basic) | PANTONE1655 | Gets the Pantone 1655 color.
static (Shared in Visual Basic) | PANTONE166 | Gets the Pantone 166 color.
static (Shared in Visual Basic) | PANTONE1665 | Gets the Pantone 1665 color.
static (Shared in Visual Basic) | PANTONE167 | Gets the Pantone 167 color.
static (Shared in Visual Basic) | PANTONE1675 | Gets the Pantone 1675 color.
static (Shared in Visual Basic) | PANTONE168 | Gets the Pantone 168 color.
static (Shared in Visual Basic) | PANTONE1685 | Gets the Pantone 1685 color.
static (Shared in Visual Basic) | PANTONE169 | Gets the Pantone 169 color.
static (Shared in Visual Basic) | PANTONE170 | Gets the Pantone 170 color.
static (Shared in Visual Basic) | PANTONE171 | Gets the Pantone 171 color.
static (Shared in Visual Basic) | PANTONE172 | Gets the Pantone 172 color.
static (Shared in Visual Basic) | PANTONE173 | Gets the Pantone 173 color.
static (Shared in Visual Basic) | PANTONE174 | Gets the Pantone 174 color.
static (Shared in Visual Basic) | PANTONE175 | Gets the Pantone 175 color.
static (Shared in Visual Basic) | PANTONE176 | Gets the Pantone 176 color.
static (Shared in Visual Basic) | PANTONE1765 | Gets the Pantone 1765 color.
static (Shared in Visual Basic) | PANTONE1767 | Gets the Pantone 1767 color.
static (Shared in Visual Basic) | PANTONE177 | Gets the Pantone 177 color.
static (Shared in Visual Basic) | PANTONE1775 | Gets the Pantone 1775 color.
static (Shared in Visual Basic) | PANTONE1777 | Gets the Pantone 1777 color.
static (Shared in Visual Basic) | PANTONE178 | Gets the Pantone 178 color.
static (Shared in Visual Basic) | PANTONE1785 | Gets the Pantone 1785 color.
static (Shared in Visual Basic) | PANTONE1787 | Gets the Pantone 1787 color.
static (Shared in Visual Basic) | PANTONE1788 | Gets the Pantone 1788 color.
static (Shared in Visual Basic) | PANTONE179 | Gets the Pantone 179 color.
static (Shared in Visual Basic) | PANTONE1795 | Gets the Pantone 1795 color.
static (Shared in Visual Basic) | PANTONE1797 | Gets the Pantone 1797 color.
static (Shared in Visual Basic) | PANTONE180 | Gets the Pantone 180 color.
static (Shared in Visual Basic) | PANTONE1805 | Gets the Pantone 1805 color.
static (Shared in Visual Basic) | PANTONE1807 | Gets the Pantone 1807 color.
static (Shared in Visual Basic) | PANTONE181 | Gets the Pantone 181 color.
static (Shared in Visual Basic) | PANTONE1815 | Gets the Pantone 1815 color.
static (Shared in Visual Basic) | PANTONE1817 | Gets the Pantone 1817 color.
static (Shared in Visual Basic) | PANTONE182 | Gets the Pantone 182 color.
static (Shared in Visual Basic) | PANTONE183 | Gets the Pantone 183 color.
static (Shared in Visual Basic) | PANTONE184 | Gets the Pantone 184 color.
static (Shared in Visual Basic) | PANTONE185 | Gets the Pantone 185 color.
static (Shared in Visual Basic) | PANTONE186 | Gets the Pantone 186 color.
static (Shared in Visual Basic) | PANTONE187 | Gets the Pantone 187 color.
static (Shared in Visual Basic) | PANTONE188 | Gets the Pantone 188 color.
static (Shared in Visual Basic) | PANTONE189 | Gets the Pantone 189 color.
static (Shared in Visual Basic) | PANTONE1895 | Gets the Pantone 1895 color.
static (Shared in Visual Basic) | PANTONE190 | Gets the Pantone 190 color.
static (Shared in Visual Basic) | PANTONE1905 | Gets the Pantone 1905 color.
static (Shared in Visual Basic) | PANTONE191 | Gets the Pantone 191 color.
static (Shared in Visual Basic) | PANTONE1915 | Gets the Pantone 1915 color.
static (Shared in Visual Basic) | PANTONE192 | Gets the Pantone 192 color.
static (Shared in Visual Basic) | PANTONE1925 | Gets the Pantone 1925 color.
static (Shared in Visual Basic) | PANTONE193 | Gets the Pantone 193 color.
static (Shared in Visual Basic) | PANTONE1935 | Gets the Pantone 1935 color.
static (Shared in Visual Basic) | PANTONE194 | Gets the Pantone 194 color.
static (Shared in Visual Basic) | PANTONE1945 | Gets the Pantone 1945 color.
static (Shared in Visual Basic) | PANTONE195 | Gets the Pantone 195 color.
static (Shared in Visual Basic) | PANTONE1955 | Gets the Pantone 1955 color.
static (Shared in Visual Basic) | PANTONE196 | Gets the Pantone 196 color.
static (Shared in Visual Basic) | PANTONE197 | Gets the Pantone 197 color.
static (Shared in Visual Basic) | PANTONE198 | Gets the Pantone 198 color.
static (Shared in Visual Basic) | PANTONE199 | Gets the Pantone 199 color.
static (Shared in Visual Basic) | PANTONE200 | Gets the Pantone 200 color.
static (Shared in Visual Basic) | PANTONE201 | Gets the Pantone 201 color.
static (Shared in Visual Basic) | PANTONE202 | Gets the Pantone 202 color.
static (Shared in Visual Basic) | PANTONE203 | Gets the Pantone 203 color.
static (Shared in Visual Basic) | PANTONE204 | Gets the Pantone 204 color.
static (Shared in Visual Basic) | PANTONE205 | Gets the Pantone 205 color.
static (Shared in Visual Basic) | PANTONE206 | Gets the Pantone 206 color.
static (Shared in Visual Basic) | PANTONE207 | Gets the Pantone 207 color.
static (Shared in Visual Basic) | PANTONE208 | Gets the Pantone 208 color.
static (Shared in Visual Basic) | PANTONE209 | Gets the Pantone 209 color.
static (Shared in Visual Basic) | PANTONE210 | Gets the Pantone 210 color.
static (Shared in Visual Basic) | PANTONE211 | Gets the Pantone 211 color.
static (Shared in Visual Basic) | PANTONE212 | Gets the Pantone 212 color.
static (Shared in Visual Basic) | PANTONE213 | Gets the Pantone 213 color.
static (Shared in Visual Basic) | PANTONE214 | Gets the Pantone 214 color.
static (Shared in Visual Basic) | PANTONE215 | Gets the Pantone 215 color.
static (Shared in Visual Basic) | PANTONE216 | Gets the Pantone 216 color.
static (Shared in Visual Basic) | PANTONE217 | Gets the Pantone 217 color.
static (Shared in Visual Basic) | PANTONE218 | Gets the Pantone 218 color.
static (Shared in Visual Basic) | PANTONE219 | Gets the Pantone 219 color.
static (Shared in Visual Basic) | PANTONE220 | Gets the Pantone 220 color.
static (Shared in Visual Basic) | PANTONE221 | Gets the Pantone 221 color.
static (Shared in Visual Basic) | PANTONE222 | Gets the Pantone 222 color.
static (Shared in Visual Basic) | PANTONE223 | Gets the Pantone 223 color.
static (Shared in Visual Basic) | PANTONE224 | Gets the Pantone 224 color.
static (Shared in Visual Basic) | PANTONE225 | Gets the Pantone 225 color.
static (Shared in Visual Basic) | PANTONE226 | Gets the Pantone 226 color.
static (Shared in Visual Basic) | PANTONE227 | Gets the Pantone 227 color.
static (Shared in Visual Basic) | PANTONE228 | Gets the Pantone 228 color.
static (Shared in Visual Basic) | PANTONE229 | Gets the Pantone 229 color.
static (Shared in Visual Basic) | PANTONE230 | Gets the Pantone 230 color.
static (Shared in Visual Basic) | PANTONE231 | Gets the Pantone 231 color.
static (Shared in Visual Basic) | PANTONE232 | Gets the Pantone 232 color.
static (Shared in Visual Basic) | PANTONE233 | Gets the Pantone 233 color.
static (Shared in Visual Basic) | PANTONE234 | Gets the Pantone 234 color.
static (Shared in Visual Basic) | PANTONE235 | Gets the Pantone 235 color.
static (Shared in Visual Basic) | PANTONE236 | Gets the Pantone 236 color.
static (Shared in Visual Basic) | PANTONE2365 | Gets the Pantone 2365 color.
static (Shared in Visual Basic) | PANTONE237 | Gets the Pantone 237 color.
static (Shared in Visual Basic) | PANTONE2375 | Gets the Pantone 2375 color.
static (Shared in Visual Basic) | PANTONE238 | Gets the Pantone 238 color.
static (Shared in Visual Basic) | PANTONE2385 | Gets the Pantone 2385 color.
static (Shared in Visual Basic) | PANTONE239 | Gets the Pantone 239 color.
static (Shared in Visual Basic) | PANTONE2395 | Gets the Pantone 2395 color.
static (Shared in Visual Basic) | PANTONE240 | Gets the Pantone 240 color.
static (Shared in Visual Basic) | PANTONE2405 | Gets the Pantone 2405 color.
static (Shared in Visual Basic) | PANTONE241 | Gets the Pantone 241 color.
static (Shared in Visual Basic) | PANTONE2415 | Gets the Pantone 2415 color.
static (Shared in Visual Basic) | PANTONE242 | Gets the Pantone 242 color.
static (Shared in Visual Basic) | PANTONE2425 | Gets the Pantone 2425 color.
static (Shared in Visual Basic) | PANTONE243 | Gets the Pantone 243 color.
static (Shared in Visual Basic) | PANTONE244 | Gets the Pantone 244 color.
static (Shared in Visual Basic) | PANTONE245 | Gets the Pantone 245 color.
static (Shared in Visual Basic) | PANTONE246 | Gets the Pantone 246 color.
static (Shared in Visual Basic) | PANTONE247 | Gets the Pantone 247 color.
static (Shared in Visual Basic) | PANTONE248 | Gets the Pantone 248 color.
static (Shared in Visual Basic) | PANTONE249 | Gets the Pantone 249 color.
static (Shared in Visual Basic) | PANTONE250 | Gets the Pantone 250 color.
static (Shared in Visual Basic) | PANTONE251 | Gets the Pantone 251 color.
static (Shared in Visual Basic) | PANTONE252 | Gets the Pantone 252 color.
static (Shared in Visual Basic) | PANTONE253 | Gets the Pantone 253 color.
static (Shared in Visual Basic) | PANTONE254 | Gets the Pantone 254 color.
static (Shared in Visual Basic) | PANTONE255 | Gets the Pantone 255 color.
static (Shared in Visual Basic) | PANTONE256 | Gets the Pantone 256 color.
static (Shared in Visual Basic) | PANTONE2562 | Gets the Pantone 2562 color.
static (Shared in Visual Basic) | PANTONE2563 | Gets the Pantone 2563 color.
static (Shared in Visual Basic) | PANTONE2567 | Gets the Pantone 2567 color.
static (Shared in Visual Basic) | PANTONE257 | Gets the Pantone 257 color.
static (Shared in Visual Basic) | PANTONE2572 | Gets the Pantone 2572 color.
static (Shared in Visual Basic) | PANTONE2573 | Gets the Pantone 2573 color.
static (Shared in Visual Basic) | PANTONE2577 | Gets the Pantone 2577 color.
static (Shared in Visual Basic) | PANTONE258 | Gets the Pantone 258 color.
static (Shared in Visual Basic) | PANTONE2582 | Gets the Pantone 2582 color.
static (Shared in Visual Basic) | PANTONE2583 | Gets the Pantone 2583 color.
static (Shared in Visual Basic) | PANTONE2587 | Gets the Pantone 2587 color.
static (Shared in Visual Basic) | PANTONE259 | Gets the Pantone 259 color.
static (Shared in Visual Basic) | PANTONE2592 | Gets the Pantone 2592 color.
static (Shared in Visual Basic) | PANTONE2593 | Gets the Pantone 2593 color.
static (Shared in Visual Basic) | PANTONE2597 | Gets the Pantone 2597 color.
static (Shared in Visual Basic) | PANTONE260 | Gets the Pantone 260 color.
static (Shared in Visual Basic) | PANTONE2602 | Gets the Pantone 2602 color.
static (Shared in Visual Basic) | PANTONE2603 | Gets the Pantone 2603 color.
static (Shared in Visual Basic) | PANTONE2607 | Gets the Pantone 2607 color.
static (Shared in Visual Basic) | PANTONE261 | Gets the Pantone 261 color.
static (Shared in Visual Basic) | PANTONE2612 | Gets the Pantone 2612 color.
static (Shared in Visual Basic) | PANTONE2613 | Gets the Pantone 2613 color.
static (Shared in Visual Basic) | PANTONE2617 | Gets the Pantone 2617 color.
static (Shared in Visual Basic) | PANTONE262 | Gets the Pantone 262 color.
static (Shared in Visual Basic) | PANTONE2622 | Gets the Pantone 2622 color.
static (Shared in Visual Basic) | PANTONE2623 | Gets the Pantone 2623 color.
static (Shared in Visual Basic) | PANTONE2627 | Gets the Pantone 2627 color.
static (Shared in Visual Basic) | PANTONE263 | Gets the Pantone 263 color.
static (Shared in Visual Basic) | PANTONE2635 | Gets the Pantone 2635 color.
static (Shared in Visual Basic) | PANTONE264 | Gets the Pantone 264 color.
static (Shared in Visual Basic) | PANTONE2645 | Gets the Pantone 2645 color.
static (Shared in Visual Basic) | PANTONE265 | Gets the Pantone 265 color.
static (Shared in Visual Basic) | PANTONE2655 | Gets the Pantone 2655 color.
static (Shared in Visual Basic) | PANTONE266 | Gets the Pantone 266 color.
static (Shared in Visual Basic) | PANTONE2665 | Gets the Pantone 2665 color.
static (Shared in Visual Basic) | PANTONE267 | Gets the Pantone 267 color.
static (Shared in Visual Basic) | PANTONE268 | Gets the Pantone 268 color.
static (Shared in Visual Basic) | PANTONE2685 | Gets the Pantone 2685 color.
static (Shared in Visual Basic) | PANTONE269 | Gets the Pantone 269 color.
static (Shared in Visual Basic) | PANTONE2695 | Gets the Pantone 2695 color.
static (Shared in Visual Basic) | PANTONE270 | Gets the Pantone 270 color.
static (Shared in Visual Basic) | PANTONE2705 | Gets the Pantone 2705 color.
static (Shared in Visual Basic) | PANTONE2706 | Gets the Pantone 2706 color.
static (Shared in Visual Basic) | PANTONE2707 | Gets the Pantone 2707 color.
static (Shared in Visual Basic) | PANTONE2708 | Gets the Pantone 2708 color.
static (Shared in Visual Basic) | PANTONE271 | Gets the Pantone 271 color.
static (Shared in Visual Basic) | PANTONE2715 | Gets the Pantone 2715 color.
static (Shared in Visual Basic) | PANTONE2716 | Gets the Pantone 2716 color.
static (Shared in Visual Basic) | PANTONE2717 | Gets the Pantone 2717 color.
static (Shared in Visual Basic) | PANTONE2718 | Gets the Pantone 2718 color.
static (Shared in Visual Basic) | PANTONE272 | Gets the Pantone 272 color.
static (Shared in Visual Basic) | PANTONE2725 | Gets the Pantone 2725 color.
static (Shared in Visual Basic) | PANTONE2726 | Gets the Pantone 2726 color.
static (Shared in Visual Basic) | PANTONE2727 | Gets the Pantone 2727 color.
static (Shared in Visual Basic) | PANTONE2728 | Gets the Pantone 2728 color.
static (Shared in Visual Basic) | PANTONE273 | Gets the Pantone 273 color.
static (Shared in Visual Basic) | PANTONE2735 | Gets the Pantone 2735 color.
static (Shared in Visual Basic) | PANTONE2736 | Gets the Pantone 2736 color.
static (Shared in Visual Basic) | PANTONE2738 | Gets the Pantone 2738 color.
static (Shared in Visual Basic) | PANTONE274 | Gets the Pantone 274 color.
static (Shared in Visual Basic) | PANTONE2745 | Gets the Pantone 2745 color.
static (Shared in Visual Basic) | PANTONE2746 | Gets the Pantone 2746 color.
static (Shared in Visual Basic) | PANTONE2747 | Gets the Pantone 2747 color.
static (Shared in Visual Basic) | PANTONE2748 | Gets the Pantone 2748 color.
static (Shared in Visual Basic) | PANTONE275 | Gets the Pantone 275 color.
static (Shared in Visual Basic) | PANTONE2755 | Gets the Pantone 2755 color.
static (Shared in Visual Basic) | PANTONE2756 | Gets the Pantone 2756 color.
static (Shared in Visual Basic) | PANTONE2757 | Gets the Pantone 2757 color.
static (Shared in Visual Basic) | PANTONE2758 | Gets the Pantone 2758 color.
static (Shared in Visual Basic) | PANTONE276 | Gets the Pantone 276 color.
static (Shared in Visual Basic) | PANTONE2765 | Gets the Pantone 2765 color.
static (Shared in Visual Basic) | PANTONE2766 | Gets the Pantone 2766 color.
static (Shared in Visual Basic) | PANTONE2767 | Gets the Pantone 2767 color.
static (Shared in Visual Basic) | PANTONE2768 | Gets the Pantone 2768 color.
static (Shared in Visual Basic) | PANTONE277 | Gets the Pantone 277 color.
static (Shared in Visual Basic) | PANTONE278 | Gets the Pantone 278 color.
static (Shared in Visual Basic) | PANTONE279 | Gets the Pantone 279 color.
static (Shared in Visual Basic) | PANTONE280 | Gets the Pantone 280 color.
static (Shared in Visual Basic) | PANTONE281 | Gets the Pantone 281 color.
static (Shared in Visual Basic) | PANTONE282 | Gets the Pantone 282 color.
static (Shared in Visual Basic) | PANTONE283 | Gets the Pantone 283 color.
static (Shared in Visual Basic) | PANTONE284 | Gets the Pantone 284 color.
static (Shared in Visual Basic) | PANTONE285 | Gets the Pantone 285 color.
static (Shared in Visual Basic) | PANTONE286 | Gets the Pantone 286 color.
static (Shared in Visual Basic) | PANTONE287 | Gets the Pantone 287 color.
static (Shared in Visual Basic) | PANTONE288 | Gets the Pantone 288 color.
static (Shared in Visual Basic) | PANTONE289 | Gets the Pantone 289 color.
static (Shared in Visual Basic) | PANTONE290 | Gets the Pantone 290 color.
static (Shared in Visual Basic) | PANTONE2905 | Gets the Pantone 2905 color.
static (Shared in Visual Basic) | PANTONE291 | Gets the Pantone 291 color.
static (Shared in Visual Basic) | PANTONE2915 | Gets the Pantone 2915 color.
static (Shared in Visual Basic) | PANTONE292 | Gets the Pantone 292 color.
static (Shared in Visual Basic) | PANTONE2925 | Gets the Pantone 2925 color.
static (Shared in Visual Basic) | PANTONE293 | Gets the Pantone 293 color.
static (Shared in Visual Basic) | PANTONE2935 | Gets the Pantone 2935 color.
static (Shared in Visual Basic) | PANTONE294 | Gets the Pantone 294 color.
static (Shared in Visual Basic) | PANTONE2945 | Gets the Pantone 2945 color.
static (Shared in Visual Basic) | PANTONE295 | Gets the Pantone 295 color.
static (Shared in Visual Basic) | PANTONE2955 | Gets the Pantone 2955 color.
static (Shared in Visual Basic) | PANTONE296 | Gets the Pantone 296 color.
static (Shared in Visual Basic) | PANTONE2965 | Gets the Pantone 2965 color.
static (Shared in Visual Basic) | PANTONE297 | Gets the Pantone 297 color.
static (Shared in Visual Basic) | PANTONE2975 | Gets the Pantone 2975 color.
static (Shared in Visual Basic) | PANTONE298 | Gets the Pantone 298 color.
static (Shared in Visual Basic) | PANTONE2985 | Gets the Pantone 2985 color.
static (Shared in Visual Basic) | PANTONE299 | Gets the Pantone 299 color.
static (Shared in Visual Basic) | PANTONE2995 | Gets the Pantone 2995 color.
static (Shared in Visual Basic) | PANTONE300 | Gets the Pantone 300 color.
static (Shared in Visual Basic) | PANTONE3005 | Gets the Pantone 3005 color.
static (Shared in Visual Basic) | PANTONE301 | Gets the Pantone 301 color.
static (Shared in Visual Basic) | PANTONE3015 | Gets the Pantone 3015 color.
static (Shared in Visual Basic) | PANTONE302 | Gets the Pantone 302 color.
static (Shared in Visual Basic) | PANTONE3025 | Gets the Pantone 3025 color.
static (Shared in Visual Basic) | PANTONE303 | Gets the Pantone 303 color.
static (Shared in Visual Basic) | PANTONE3035 | Gets the Pantone 3035 color.
static (Shared in Visual Basic) | PANTONE304 | Gets the Pantone 304 color.
static (Shared in Visual Basic) | PANTONE305 | Gets the Pantone 305 color.
static (Shared in Visual Basic) | PANTONE306 | Gets the Pantone 306 color.
static (Shared in Visual Basic) | PANTONE307 | Gets the Pantone 307 color.
static (Shared in Visual Basic) | PANTONE308 | Gets the Pantone 308 color.
static (Shared in Visual Basic) | PANTONE309 | Gets the Pantone 309 color.
static (Shared in Visual Basic) | PANTONE310 | Gets the Pantone 310 color.
static (Shared in Visual Basic) | PANTONE3105 | Gets the Pantone 3105 color.
static (Shared in Visual Basic) | PANTONE311 | Gets the Pantone 311 color.
static (Shared in Visual Basic) | PANTONE3115 | Gets the Pantone 3115 color.
static (Shared in Visual Basic) | PANTONE312 | Gets the Pantone 312 color.
static (Shared in Visual Basic) | PANTONE3125 | Gets the Pantone 3125 color.
static (Shared in Visual Basic) | PANTONE313 | Gets the Pantone 313 color.
static (Shared in Visual Basic) | PANTONE3135 | Gets the Pantone 3135 color.
static (Shared in Visual Basic) | PANTONE314 | Gets the Pantone 314 color.
static (Shared in Visual Basic) | PANTONE3145 | Gets the Pantone 3145 color.
static (Shared in Visual Basic) | PANTONE315 | Gets the Pantone 315 color.
static (Shared in Visual Basic) | PANTONE3155 | Gets the Pantone 3155 color.
static (Shared in Visual Basic) | PANTONE316 | Gets the Pantone 316 color.
static (Shared in Visual Basic) | PANTONE3165 | Gets the Pantone 3165 color.
static (Shared in Visual Basic) | PANTONE317 | Gets the Pantone 317 color.
static (Shared in Visual Basic) | PANTONE318 | Gets the Pantone 318 color.
static (Shared in Visual Basic) | PANTONE319 | Gets the Pantone 319 color.
static (Shared in Visual Basic) | PANTONE320 | Gets the Pantone 320 color.
static (Shared in Visual Basic) | PANTONE321 | Gets the Pantone 321 color.
static (Shared in Visual Basic) | PANTONE322 | Gets the Pantone 322 color.
static (Shared in Visual Basic) | PANTONE323 | Gets the Pantone 323 color.
static (Shared in Visual Basic) | PANTONE324 | Gets the Pantone 324 color.
static (Shared in Visual Basic) | PANTONE3242 | Gets the Pantone 3242 color.
static (Shared in Visual Basic) | PANTONE3245 | Gets the Pantone 3245 color.
static (Shared in Visual Basic) | PANTONE3248 | Gets the Pantone 3248 color.
static (Shared in Visual Basic) | PANTONE325 | Gets the Pantone 325 color.
static (Shared in Visual Basic) | PANTONE3252 | Gets the Pantone 3252 color.
static (Shared in Visual Basic) | PANTONE3255 | Gets the Pantone 3255 color.
static (Shared in Visual Basic) | PANTONE3258 | Gets the Pantone 3258 color.
static (Shared in Visual Basic) | PANTONE326 | Gets the Pantone 326 color.
static (Shared in Visual Basic) | PANTONE3262 | Gets the Pantone 3262 color.
static (Shared in Visual Basic) | PANTONE3265 | Gets the Pantone 3265 color.
static (Shared in Visual Basic) | PANTONE3268 | Gets the Pantone 3268 color.
static (Shared in Visual Basic) | PANTONE327 | Gets the Pantone 327 color.
static (Shared in Visual Basic) | PANTONE3272 | Gets the Pantone 3272 color.
static (Shared in Visual Basic) | PANTONE3275 | Gets the Pantone 3275 color.
static (Shared in Visual Basic) | PANTONE3278 | Gets the Pantone 3278 color.
static (Shared in Visual Basic) | PANTONE328 | Gets the Pantone 328 color.
static (Shared in Visual Basic) | PANTONE3282 | Gets the Pantone 3282 color.
static (Shared in Visual Basic) | PANTONE3285 | Gets the Pantone 3285 color.
static (Shared in Visual Basic) | PANTONE3288 | Gets the Pantone 3288 color.
static (Shared in Visual Basic) | PANTONE329 | Gets the Pantone 329 color.
static (Shared in Visual Basic) | PANTONE3292 | Gets the Pantone 3292 color.
static (Shared in Visual Basic) | PANTONE3295 | Gets the Pantone 3295 color.
static (Shared in Visual Basic) | PANTONE3298 | Gets the Pantone 3298 color.
static (Shared in Visual Basic) | PANTONE330 | Gets the Pantone 330 color.
static (Shared in Visual Basic) | PANTONE3302 | Gets the Pantone 3302 color.
static (Shared in Visual Basic) | PANTONE3305 | Gets the Pantone 3305 color.
static (Shared in Visual Basic) | PANTONE3308 | Gets the Pantone 3308 color.
static (Shared in Visual Basic) | PANTONE331 | Gets the Pantone 331 color.
static (Shared in Visual Basic) | PANTONE332 | Gets the Pantone 332 color.
static (Shared in Visual Basic) | PANTONE333 | Gets the Pantone 333 color.
static (Shared in Visual Basic) | PANTONE334 | Gets the Pantone 334 color.
static (Shared in Visual Basic) | PANTONE335 | Gets the Pantone 335 color.
static (Shared in Visual Basic) | PANTONE336 | Gets the Pantone 336 color.
static (Shared in Visual Basic) | PANTONE337 | Gets the Pantone 337 color.
static (Shared in Visual Basic) | PANTONE3375 | Gets the Pantone 3375 color.
static (Shared in Visual Basic) | PANTONE338 | Gets the Pantone 338 color.
static (Shared in Visual Basic) | PANTONE3385 | Gets the Pantone 3385 color.
static (Shared in Visual Basic) | PANTONE339 | Gets the Pantone 339 color.
static (Shared in Visual Basic) | PANTONE3395 | Gets the Pantone 3395 color.
static (Shared in Visual Basic) | PANTONE340 | Gets the Pantone 340 color.
static (Shared in Visual Basic) | PANTONE3405 | Gets the Pantone 3405 color.
static (Shared in Visual Basic) | PANTONE341 | Gets the Pantone 341 color.
static (Shared in Visual Basic) | PANTONE3415 | Gets the Pantone 3415 color.
static (Shared in Visual Basic) | PANTONE342 | Gets the Pantone 342 color.
static (Shared in Visual Basic) | PANTONE3425 | Gets the Pantone 3425 color.
static (Shared in Visual Basic) | PANTONE343 | Gets the Pantone 343 color.
static (Shared in Visual Basic) | PANTONE3435 | Gets the Pantone 3435 color.
static (Shared in Visual Basic) | PANTONE344 | Gets the Pantone 344 color.
static (Shared in Visual Basic) | PANTONE345 | Gets the Pantone 345 color.
static (Shared in Visual Basic) | PANTONE346 | Gets the Pantone 346 color.
static (Shared in Visual Basic) | PANTONE347 | Gets the Pantone 347 color.
static (Shared in Visual Basic) | PANTONE348 | Gets the Pantone 348 color.
static (Shared in Visual Basic) | PANTONE349 | Gets the Pantone 349 color.
static (Shared in Visual Basic) | PANTONE350 | Gets the Pantone 350 color.
static (Shared in Visual Basic) | PANTONE351 | Gets the Pantone 351 color.
static (Shared in Visual Basic) | PANTONE352 | Gets the Pantone 352 color.
static (Shared in Visual Basic) | PANTONE353 | Gets the Pantone 353 color.
static (Shared in Visual Basic) | PANTONE354 | Gets the Pantone 354 color.
static (Shared in Visual Basic) | PANTONE355 | Gets the Pantone 355 color.
static (Shared in Visual Basic) | PANTONE356 | Gets the Pantone 356 color.
static (Shared in Visual Basic) | PANTONE357 | Gets the Pantone 357 color.
static (Shared in Visual Basic) | PANTONE358 | Gets the Pantone 358 color.
static (Shared in Visual Basic) | PANTONE359 | Gets the Pantone 359 color.
static (Shared in Visual Basic) | PANTONE360 | Gets the Pantone 360 color.
static (Shared in Visual Basic) | PANTONE361 | Gets the Pantone 361 color.
static (Shared in Visual Basic) | PANTONE362 | Gets the Pantone 362 color.
static (Shared in Visual Basic) | PANTONE363 | Gets the Pantone 363 color.
static (Shared in Visual Basic) | PANTONE364 | Gets the Pantone 364 color.
static (Shared in Visual Basic) | PANTONE365 | Gets the Pantone 365 color.
static (Shared in Visual Basic) | PANTONE366 | Gets the Pantone 366 color.
static (Shared in Visual Basic) | PANTONE367 | Gets the Pantone 367 color.
static (Shared in Visual Basic) | PANTONE368 | Gets the Pantone 368 color.
static (Shared in Visual Basic) | PANTONE369 | Gets the Pantone 369 color.
static (Shared in Visual Basic) | PANTONE370 | Gets the Pantone 370 color.
static (Shared in Visual Basic) | PANTONE371 | Gets the Pantone 371 color.
static (Shared in Visual Basic) | PANTONE372 | Gets the Pantone 372 color.
static (Shared in Visual Basic) | PANTONE373 | Gets the Pantone 373 color.
static (Shared in Visual Basic) | PANTONE374 | Gets the Pantone 374 color.
static (Shared in Visual Basic) | PANTONE375 | Gets the Pantone 375 color.
static (Shared in Visual Basic) | PANTONE376 | Gets the Pantone 376 color.
static (Shared in Visual Basic) | PANTONE377 | Gets the Pantone 377 color.
static (Shared in Visual Basic) | PANTONE378 | Gets the Pantone 378 color.
static (Shared in Visual Basic) | PANTONE379 | Gets the Pantone 379 color.
static (Shared in Visual Basic) | PANTONE380 | Gets the Pantone 380 color.
static (Shared in Visual Basic) | PANTONE381 | Gets the Pantone 381 color.
static (Shared in Visual Basic) | PANTONE382 | Gets the Pantone 382 color.
static (Shared in Visual Basic) | PANTONE383 | Gets the Pantone 383 color.
static (Shared in Visual Basic) | PANTONE384 | Gets the Pantone 384 color.
static (Shared in Visual Basic) | PANTONE385 | Gets the Pantone 385 color.
static (Shared in Visual Basic) | PANTONE386 | Gets the Pantone 386 color.
static (Shared in Visual Basic) | PANTONE387 | Gets the Pantone 387 color.
static (Shared in Visual Basic) | PANTONE388 | Gets the Pantone 388 color.
static (Shared in Visual Basic) | PANTONE389 | Gets the Pantone 389 color.
static (Shared in Visual Basic) | PANTONE390 | Gets the Pantone 390 color.
static (Shared in Visual Basic) | PANTONE391 | Gets the Pantone 391 color.
static (Shared in Visual Basic) | PANTONE392 | Gets the Pantone 392 color.
static (Shared in Visual Basic) | PANTONE393 | Gets the Pantone 393 color.
static (Shared in Visual Basic) | PANTONE3935 | Gets the Pantone 3935 color.
static (Shared in Visual Basic) | PANTONE394 | Gets the Pantone 394 color.
static (Shared in Visual Basic) | PANTONE3945 | Gets the Pantone 3945 color.
static (Shared in Visual Basic) | PANTONE395 | Gets the Pantone 395 color.
static (Shared in Visual Basic) | PANTONE3955 | Gets the Pantone 3955 color.
static (Shared in Visual Basic) | PANTONE396 | Gets the Pantone 396 color.
static (Shared in Visual Basic) | PANTONE3965 | Gets the Pantone 3965 color.
static (Shared in Visual Basic) | PANTONE397 | Gets the Pantone 397 color.
static (Shared in Visual Basic) | PANTONE3975 | Gets the Pantone 3975 color.
static (Shared in Visual Basic) | PANTONE398 | Gets the Pantone 398 color.
static (Shared in Visual Basic) | PANTONE3985 | Gets the Pantone 3985 color.
static (Shared in Visual Basic) | PANTONE399 | Gets the Pantone 399 color.
static (Shared in Visual Basic) | PANTONE3995 | Gets the Pantone 3995 color.
static (Shared in Visual Basic) | PANTONE400 | Gets the Pantone 400 color.
static (Shared in Visual Basic) | PANTONE401 | Gets the Pantone 401 color.
static (Shared in Visual Basic) | PANTONE402 | Gets the Pantone 402 color.
static (Shared in Visual Basic) | PANTONE403 | Gets the Pantone 403 color.
static (Shared in Visual Basic) | PANTONE404 | Gets the Pantone 404 color.
static (Shared in Visual Basic) | PANTONE405 | Gets the Pantone 405 color.
static (Shared in Visual Basic) | PANTONE406 | Gets the Pantone 406 color.
static (Shared in Visual Basic) | PANTONE407 | Gets the Pantone 407 color.
static (Shared in Visual Basic) | PANTONE408 | Gets the Pantone 408 color.
static (Shared in Visual Basic) | PANTONE409 | Gets the Pantone 409 color.
static (Shared in Visual Basic) | PANTONE410 | Gets the Pantone 410 color.
static (Shared in Visual Basic) | PANTONE411 | Gets the Pantone 411 color.
static (Shared in Visual Basic) | PANTONE412 | Gets the Pantone 412 color.
static (Shared in Visual Basic) | PANTONE413 | Gets the Pantone 413 color.
static (Shared in Visual Basic) | PANTONE414 | Gets the Pantone 414 color.
static (Shared in Visual Basic) | PANTONE415 | Gets the Pantone 415 color.
static (Shared in Visual Basic) | PANTONE416 | Gets the Pantone 416 color.
static (Shared in Visual Basic) | PANTONE417 | Gets the Pantone 417 color.
static (Shared in Visual Basic) | PANTONE418 | Gets the Pantone 418 color.
static (Shared in Visual Basic) | PANTONE419 | Gets the Pantone 419 color.
static (Shared in Visual Basic) | PANTONE420 | Gets the Pantone 420 color.
static (Shared in Visual Basic) | PANTONE421 | Gets the Pantone 421 color.
static (Shared in Visual Basic) | PANTONE422 | Gets the Pantone 422 color.
static (Shared in Visual Basic) | PANTONE423 | Gets the Pantone 423 color.
static (Shared in Visual Basic) | PANTONE424 | Gets the Pantone 424 color.
static (Shared in Visual Basic) | PANTONE425 | Gets the Pantone 425 color.
static (Shared in Visual Basic) | PANTONE426 | Gets the Pantone 426 color.
static (Shared in Visual Basic) | PANTONE427 | Gets the Pantone 427 color.
static (Shared in Visual Basic) | PANTONE428 | Gets the Pantone 428 color.
static (Shared in Visual Basic) | PANTONE429 | Gets the Pantone 429 color.
static (Shared in Visual Basic) | PANTONE430 | Gets the Pantone 430 color.
static (Shared in Visual Basic) | PANTONE431 | Gets the Pantone 431 color.
static (Shared in Visual Basic) | PANTONE432 | Gets the Pantone 432 color.
static (Shared in Visual Basic) | PANTONE433 | Gets the Pantone 433 color.
static (Shared in Visual Basic) | PANTONE434 | Gets the Pantone 434 color.
static (Shared in Visual Basic) | PANTONE435 | Gets the Pantone 435 color.
static (Shared in Visual Basic) | PANTONE436 | Gets the Pantone 436 color.
static (Shared in Visual Basic) | PANTONE437 | Gets the Pantone 437 color.
static (Shared in Visual Basic) | PANTONE438 | Gets the Pantone 438 color.
static (Shared in Visual Basic) | PANTONE439 | Gets the Pantone 439 color.
static (Shared in Visual Basic) | PANTONE440 | Gets the Pantone 440 color.
static (Shared in Visual Basic) | PANTONE441 | Gets the Pantone 441 color.
static (Shared in Visual Basic) | PANTONE442 | Gets the Pantone 442 color.
static (Shared in Visual Basic) | PANTONE443 | Gets the Pantone 443 color.
static (Shared in Visual Basic) | PANTONE444 | Gets the Pantone 444 color.
static (Shared in Visual Basic) | PANTONE445 | Gets the Pantone 445 color.
static (Shared in Visual Basic) | PANTONE446 | Gets the Pantone 446 color.
static (Shared in Visual Basic) | PANTONE447 | Gets the Pantone 447 color.
static (Shared in Visual Basic) | PANTONE448 | Gets the Pantone 448 color.
static (Shared in Visual Basic) | PANTONE4485 | Gets the Pantone 4485 color.
static (Shared in Visual Basic) | PANTONE449 | Gets the Pantone 449 color.
static (Shared in Visual Basic) | PANTONE4495 | Gets the Pantone 4495 color.
static (Shared in Visual Basic) | PANTONE450 | Gets the Pantone 450 color.
static (Shared in Visual Basic) | PANTONE4505 | Gets the Pantone 4505 color.
static (Shared in Visual Basic) | PANTONE451 | Gets the Pantone 451 color.
static (Shared in Visual Basic) | PANTONE4515 | Gets the Pantone 4515 color.
static (Shared in Visual Basic) | PANTONE452 | Gets the Pantone 452 color.
static (Shared in Visual Basic) | PANTONE4525 | Gets the Pantone 4525 color.
static (Shared in Visual Basic) | PANTONE453 | Gets the Pantone 453 color.
static (Shared in Visual Basic) | PANTONE4535 | Gets the Pantone 4535 color.
static (Shared in Visual Basic) | PANTONE454 | Gets the Pantone 454 color.
static (Shared in Visual Basic) | PANTONE4545 | Gets the Pantone 4545 color.
static (Shared in Visual Basic) | PANTONE455 | Gets the Pantone 455 color.
static (Shared in Visual Basic) | PANTONE456 | Gets the Pantone 456 color.
static (Shared in Visual Basic) | PANTONE457 | Gets the Pantone 457 color.
static (Shared in Visual Basic) | PANTONE458 | Gets the Pantone 458 color.
static (Shared in Visual Basic) | PANTONE459 | Gets the Pantone 459 color.
static (Shared in Visual Basic) | PANTONE460 | Gets the Pantone 460 color.
static (Shared in Visual Basic) | PANTONE461 | Gets the Pantone 461 color.
static (Shared in Visual Basic) | PANTONE462 | Gets the Pantone 462 color.
static (Shared in Visual Basic) | PANTONE4625 | Gets the Pantone 4625 color.
static (Shared in Visual Basic) | PANTONE463 | Gets the Pantone 463 color.
static (Shared in Visual Basic) | PANTONE4635 | Gets the Pantone 4635 color.
static (Shared in Visual Basic) | PANTONE464 | Gets the Pantone 464 color.
static (Shared in Visual Basic) | PANTONE4645 | Gets the Pantone 4645 color.
static (Shared in Visual Basic) | PANTONE465 | Gets the Pantone 465 color.
static (Shared in Visual Basic) | PANTONE4655 | Gets the Pantone 4655 color.
static (Shared in Visual Basic) | PANTONE466 | Gets the Pantone 466 color.
static (Shared in Visual Basic) | PANTONE4665 | Gets the Pantone 4665 color.
static (Shared in Visual Basic) | PANTONE467 | Gets the Pantone 467 color.
static (Shared in Visual Basic) | PANTONE4675 | Gets the Pantone 4675 color.
static (Shared in Visual Basic) | PANTONE468 | Gets the Pantone 468 color.
static (Shared in Visual Basic) | PANTONE4685 | Gets the Pantone 4685 color.
static (Shared in Visual Basic) | PANTONE469 | Gets the Pantone 469 color.
static (Shared in Visual Basic) | PANTONE4695 | Gets the Pantone 4695 color.
static (Shared in Visual Basic) | PANTONE470 | Gets the Pantone 470 color.
static (Shared in Visual Basic) | PANTONE4705 | Gets the Pantone 4705 color.
static (Shared in Visual Basic) | PANTONE471 | Gets the Pantone 471 color.
static (Shared in Visual Basic) | PANTONE4715 | Gets the Pantone 4715 color.
static (Shared in Visual Basic) | PANTONE472 | Gets the Pantone 472 color.
static (Shared in Visual Basic) | PANTONE4725 | Gets the Pantone 4725 color.
static (Shared in Visual Basic) | PANTONE473 | Gets the Pantone 473 color.
static (Shared in Visual Basic) | PANTONE4735 | Gets the Pantone 4735 color.
static (Shared in Visual Basic) | PANTONE474 | Gets the Pantone 474 color.
static (Shared in Visual Basic) | PANTONE4745 | Gets the Pantone 4745 color.
static (Shared in Visual Basic) | PANTONE475 | Gets the Pantone 475 color.
static (Shared in Visual Basic) | PANTONE4755 | Gets the Pantone 4755 color.
static (Shared in Visual Basic) | PANTONE476 | Gets the Pantone 476 color.
static (Shared in Visual Basic) | PANTONE477 | Gets the Pantone 477 color.
static (Shared in Visual Basic) | PANTONE478 | Gets the Pantone 478 color.
static (Shared in Visual Basic) | PANTONE479 | Gets the Pantone 479 color.
static (Shared in Visual Basic) | PANTONE480 | Gets the Pantone 480 color.
static (Shared in Visual Basic) | PANTONE481 | Gets the Pantone 481 color.
static (Shared in Visual Basic) | PANTONE482 | Gets the Pantone 482 color.
static (Shared in Visual Basic) | PANTONE483 | Gets the Pantone 483 color.
static (Shared in Visual Basic) | PANTONE484 | Gets the Pantone 484 color.
static (Shared in Visual Basic) | PANTONE485 | Gets the Pantone 485 color.
static (Shared in Visual Basic) | PANTONE486 | Gets the Pantone 486 color.
static (Shared in Visual Basic) | PANTONE487 | Gets the Pantone 487 color.
static (Shared in Visual Basic) | PANTONE488 | Gets the Pantone 488 color.
static (Shared in Visual Basic) | PANTONE489 | Gets the Pantone 489 color.
static (Shared in Visual Basic) | PANTONE490 | Gets the Pantone 490 color.
static (Shared in Visual Basic) | PANTONE491 | Gets the Pantone 491 color.
static (Shared in Visual Basic) | PANTONE492 | Gets the Pantone 492 color.
static (Shared in Visual Basic) | PANTONE493 | Gets the Pantone 493 color.
static (Shared in Visual Basic) | PANTONE494 | Gets the Pantone 494 color.
static (Shared in Visual Basic) | PANTONE495 | Gets the Pantone 495 color.
static (Shared in Visual Basic) | PANTONE496 | Gets the Pantone 496 color.
static (Shared in Visual Basic) | PANTONE497 | Gets the Pantone 497 color.
static (Shared in Visual Basic) | PANTONE4975 | Gets the Pantone 4975 color.
static (Shared in Visual Basic) | PANTONE498 | Gets the Pantone 498 color.
static (Shared in Visual Basic) | PANTONE4985 | Gets the Pantone 4985 color.
static (Shared in Visual Basic) | PANTONE499 | Gets the Pantone 499 color.
static (Shared in Visual Basic) | PANTONE4995 | Gets the Pantone 4995 color.
static (Shared in Visual Basic) | PANTONE500 | Gets the Pantone 500 color.
static (Shared in Visual Basic) | PANTONE5005 | Gets the Pantone 5005 color.
static (Shared in Visual Basic) | PANTONE501 | Gets the Pantone 501 color.
static (Shared in Visual Basic) | PANTONE5015 | Gets the Pantone 5015 color.
static (Shared in Visual Basic) | PANTONE502 | Gets the Pantone 502 color.
static (Shared in Visual Basic) | PANTONE5025 | Gets the Pantone 5025 color.
static (Shared in Visual Basic) | PANTONE503 | Gets the Pantone 503 color.
static (Shared in Visual Basic) | PANTONE5035 | Gets the Pantone 5035 color.
static (Shared in Visual Basic) | PANTONE504 | Gets the Pantone 504 color.
static (Shared in Visual Basic) | PANTONE505 | Gets the Pantone 505 color.
static (Shared in Visual Basic) | PANTONE506 | Gets the Pantone 506 color.
static (Shared in Visual Basic) | PANTONE507 | Gets the Pantone 507 color.
static (Shared in Visual Basic) | PANTONE508 | Gets the Pantone 508 color.
static (Shared in Visual Basic) | PANTONE509 | Gets the Pantone 509 color.
static (Shared in Visual Basic) | PANTONE510 | Gets the Pantone 510 color.
static (Shared in Visual Basic) | PANTONE511 | Gets the Pantone 511 color.
static (Shared in Visual Basic) | PANTONE5115 | Gets the Pantone 5115 color.
static (Shared in Visual Basic) | PANTONE512 | Gets the Pantone 512 color.
static (Shared in Visual Basic) | PANTONE5125 | Gets the Pantone 5125 color.
static (Shared in Visual Basic) | PANTONE513 | Gets the Pantone 513 color.
static (Shared in Visual Basic) | PANTONE5135 | Gets the Pantone 5135 color.
static (Shared in Visual Basic) | PANTONE514 | Gets the Pantone 514 color.
static (Shared in Visual Basic) | PANTONE5145 | Gets the Pantone 5145 color.
static (Shared in Visual Basic) | PANTONE515 | Gets the Pantone 515 color.
static (Shared in Visual Basic) | PANTONE5155 | Gets the Pantone 5155 color.
static (Shared in Visual Basic) | PANTONE516 | Gets the Pantone 516 color.
static (Shared in Visual Basic) | PANTONE5165 | Gets the Pantone 5165 color.
static (Shared in Visual Basic) | PANTONE517 | Gets the Pantone 517 color.
static (Shared in Visual Basic) | PANTONE5175 | Gets the Pantone 5175 color.
static (Shared in Visual Basic) | PANTONE518 | Gets the Pantone 518 color.
static (Shared in Visual Basic) | PANTONE5185 | Gets the Pantone 5185 color.
static (Shared in Visual Basic) | PANTONE519 | Gets the Pantone 519 color.
static (Shared in Visual Basic) | PANTONE5195 | Gets the Pantone 5195 color.
static (Shared in Visual Basic) | PANTONE520 | Gets the Pantone 520 color.
static (Shared in Visual Basic) | PANTONE5205 | Gets the Pantone 5205 color.
static (Shared in Visual Basic) | PANTONE521 | Gets the Pantone 521 color.
static (Shared in Visual Basic) | PANTONE5215 | Gets the Pantone 5215 color.
static (Shared in Visual Basic) | PANTONE522 | Gets the Pantone 522 color.
static (Shared in Visual Basic) | PANTONE5225 | Gets the Pantone 5225 color.
static (Shared in Visual Basic) | PANTONE523 | Gets the Pantone 523 color.
static (Shared in Visual Basic) | PANTONE5235 | Gets the Pantone 5235 color.
static (Shared in Visual Basic) | PANTONE524 | Gets the Pantone 524 color.
static (Shared in Visual Basic) | PANTONE5245 | Gets the Pantone 5245 color.
static (Shared in Visual Basic) | PANTONE525 | Gets the Pantone 525 color.
static (Shared in Visual Basic) | PANTONE5255 | Gets the Pantone 5255 color.
static (Shared in Visual Basic) | PANTONE526 | Gets the Pantone 526 color.
static (Shared in Visual Basic) | PANTONE5265 | Gets the Pantone 5265 color.
static (Shared in Visual Basic) | PANTONE527 | Gets the Pantone 527 color.
static (Shared in Visual Basic) | PANTONE5275 | Gets the Pantone 5275 color.
static (Shared in Visual Basic) | PANTONE528 | Gets the Pantone 528 color.
static (Shared in Visual Basic) | PANTONE5285 | Gets the Pantone 5285 color.
static (Shared in Visual Basic) | PANTONE529 | Gets the Pantone 529 color.
static (Shared in Visual Basic) | PANTONE5295 | Gets the Pantone 5295 color.
static (Shared in Visual Basic) | PANTONE530 | Gets the Pantone 530 color.
static (Shared in Visual Basic) | PANTONE5305 | Gets the Pantone 5305 color.
static (Shared in Visual Basic) | PANTONE531 | Gets the Pantone 531 color.
static (Shared in Visual Basic) | PANTONE5315 | Gets the Pantone 5315 color.
static (Shared in Visual Basic) | PANTONE532 | Gets the Pantone 532 color.
static (Shared in Visual Basic) | PANTONE533 | Gets the Pantone 533 color.
static (Shared in Visual Basic) | PANTONE534 | Gets the Pantone 534 color.
static (Shared in Visual Basic) | PANTONE535 | Gets the Pantone 535 color.
static (Shared in Visual Basic) | PANTONE536 | Gets the Pantone 536 color.
static (Shared in Visual Basic) | PANTONE537 | Gets the Pantone 537 color.
static (Shared in Visual Basic) | PANTONE538 | Gets the Pantone 538 color.
static (Shared in Visual Basic) | PANTONE539 | Gets the Pantone 539 color.
static (Shared in Visual Basic) | PANTONE5395 | Gets the Pantone 5395 color.
static (Shared in Visual Basic) | PANTONE540 | Gets the Pantone 540 color.
static (Shared in Visual Basic) | PANTONE5405 | Gets the Pantone 5405 color.
static (Shared in Visual Basic) | PANTONE541 | Gets the Pantone 541 color.
static (Shared in Visual Basic) | PANTONE5415 | Gets the Pantone 5415 color.
static (Shared in Visual Basic) | PANTONE542 | Gets the Pantone 542 color.
static (Shared in Visual Basic) | PANTONE5425 | Gets the Pantone 5425 color.
static (Shared in Visual Basic) | PANTONE543 | Gets the Pantone 543 color.
static (Shared in Visual Basic) | PANTONE5435 | Gets the Pantone 5435 color.
static (Shared in Visual Basic) | PANTONE544 | Gets the Pantone 544 color.
static (Shared in Visual Basic) | PANTONE5445 | Gets the Pantone 5445 color.
static (Shared in Visual Basic) | PANTONE545 | Gets the Pantone 545 color.
static (Shared in Visual Basic) | PANTONE5455 | Gets the Pantone 5455 color.
static (Shared in Visual Basic) | PANTONE546 | Gets the Pantone 546 color.
static (Shared in Visual Basic) | PANTONE5463 | Gets the Pantone 5463 color.
static (Shared in Visual Basic) | PANTONE5467 | Gets the Pantone 5467 color.
static (Shared in Visual Basic) | PANTONE547 | Gets the Pantone 547 color.
static (Shared in Visual Basic) | PANTONE5473 | Gets the Pantone 5473 color.
static (Shared in Visual Basic) | PANTONE5477 | Gets the Pantone 5477 color.
static (Shared in Visual Basic) | PANTONE548 | Gets the Pantone 548 color.
static (Shared in Visual Basic) | PANTONE5483 | Gets the Pantone 5483 color.
static (Shared in Visual Basic) | PANTONE5487 | Gets the Pantone 5487 color.
static (Shared in Visual Basic) | PANTONE549 | Gets the Pantone 549 color.
static (Shared in Visual Basic) | PANTONE5493 | Gets the Pantone 5493 color.
static (Shared in Visual Basic) | PANTONE5497 | Gets the Pantone 5497 color.
static (Shared in Visual Basic) | PANTONE550 | Gets the Pantone 550 color.
static (Shared in Visual Basic) | PANTONE5503 | Gets the Pantone 5503 color.
static (Shared in Visual Basic) | PANTONE5507 | Gets the Pantone 5507 color.
static (Shared in Visual Basic) | PANTONE551 | Gets the Pantone 551 color.
static (Shared in Visual Basic) | PANTONE5513 | Gets the Pantone 5513 color.
static (Shared in Visual Basic) | PANTONE5517 | Gets the Pantone 5517 color.
static (Shared in Visual Basic) | PANTONE552 | Gets the Pantone 552 color.
static (Shared in Visual Basic) | PANTONE5523 | Gets the Pantone 5523 color.
static (Shared in Visual Basic) | PANTONE5527 | Gets the Pantone 5527 color.
static (Shared in Visual Basic) | PANTONE553 | Gets the Pantone 553 color.
static (Shared in Visual Basic) | PANTONE5535 | Gets the Pantone 5535 color.
static (Shared in Visual Basic) | PANTONE554 | Gets the Pantone 554 color.
static (Shared in Visual Basic) | PANTONE5545 | Gets the Pantone 5545 color.
static (Shared in Visual Basic) | PANTONE555 | Gets the Pantone 555 color.
static (Shared in Visual Basic) | PANTONE5555 | Gets the Pantone 5555 color.
static (Shared in Visual Basic) | PANTONE556 | Gets the Pantone 556 color.
static (Shared in Visual Basic) | PANTONE5565 | Gets the Pantone 5565 color.
static (Shared in Visual Basic) | PANTONE557 | Gets the Pantone 557 color.
static (Shared in Visual Basic) | PANTONE5575 | Gets the Pantone 5575 color.
static (Shared in Visual Basic) | PANTONE558 | Gets the Pantone 558 color.
static (Shared in Visual Basic) | PANTONE5585 | Gets the Pantone 5585 color.
static (Shared in Visual Basic) | PANTONE559 | Gets the Pantone 559 color.
static (Shared in Visual Basic) | PANTONE5595 | Gets the Pantone 5595 color.
static (Shared in Visual Basic) | PANTONE560 | Gets the Pantone 560 color.
static (Shared in Visual Basic) | PANTONE5605 | Gets the Pantone 5605 color.
static (Shared in Visual Basic) | PANTONE561 | Gets the Pantone 561 color.
static (Shared in Visual Basic) | PANTONE5615 | Gets the Pantone 5615 color.
static (Shared in Visual Basic) | PANTONE562 | Gets the Pantone 562 color.
static (Shared in Visual Basic) | PANTONE5625 | Gets the Pantone 5625 color.
static (Shared in Visual Basic) | PANTONE563 | Gets the Pantone 563 color.
static (Shared in Visual Basic) | PANTONE5635 | Gets the Pantone 5635 color.
static (Shared in Visual Basic) | PANTONE564 | Gets the Pantone 564 color.
static (Shared in Visual Basic) | PANTONE5645 | Gets the Pantone 5645 color.
static (Shared in Visual Basic) | PANTONE565 | Gets the Pantone 565 color.
static (Shared in Visual Basic) | PANTONE5655 | Gets the Pantone 5655 color.
static (Shared in Visual Basic) | PANTONE566 | Gets the Pantone 566 color.
static (Shared in Visual Basic) | PANTONE5665 | Gets the Pantone 5665 color.
static (Shared in Visual Basic) | PANTONE567 | Gets the Pantone 567 color.
static (Shared in Visual Basic) | PANTONE568 | Gets the Pantone 568 color.
static (Shared in Visual Basic) | PANTONE569 | Gets the Pantone 569 color.
static (Shared in Visual Basic) | PANTONE570 | Gets the Pantone 570 color.
static (Shared in Visual Basic) | PANTONE571 | Gets the Pantone 571 color.
static (Shared in Visual Basic) | PANTONE572 | Gets the Pantone 572 color.
static (Shared in Visual Basic) | PANTONE573 | Gets the Pantone 573 color.
static (Shared in Visual Basic) | PANTONE574 | Gets the Pantone 574 color.
static (Shared in Visual Basic) | PANTONE5743 | Gets the Pantone 5743 color.
static (Shared in Visual Basic) | PANTONE5747 | Gets the Pantone 5747 color.
static (Shared in Visual Basic) | PANTONE575 | Gets the Pantone 575 color.
static (Shared in Visual Basic) | PANTONE5753 | Gets the Pantone 5753 color.
static (Shared in Visual Basic) | PANTONE5757 | Gets the Pantone 5757 color.
static (Shared in Visual Basic) | PANTONE576 | Gets the Pantone 576 color.
static (Shared in Visual Basic) | PANTONE5763 | Gets the Pantone 5763 color.
static (Shared in Visual Basic) | PANTONE5767 | Gets the Pantone 5767 color.
static (Shared in Visual Basic) | PANTONE577 | Gets the Pantone 577 color.
static (Shared in Visual Basic) | PANTONE5773 | Gets the Pantone 5773 color.
static (Shared in Visual Basic) | PANTONE5777 | Gets the Pantone 5777 color.
static (Shared in Visual Basic) | PANTONE578 | Gets the Pantone 578 color.
static (Shared in Visual Basic) | PANTONE5783 | Gets the Pantone 5783 color.
static (Shared in Visual Basic) | PANTONE5787 | Gets the Pantone 5787 color.
static (Shared in Visual Basic) | PANTONE579 | Gets the Pantone 579 color.
static (Shared in Visual Basic) | PANTONE5793 | Gets the Pantone 5793 color.
static (Shared in Visual Basic) | PANTONE5797 | Gets the Pantone 5797 color.
static (Shared in Visual Basic) | PANTONE580 | Gets the Pantone 580 color.
static (Shared in Visual Basic) | PANTONE5803 | Gets the Pantone 5803 color.
static (Shared in Visual Basic) | PANTONE5807 | Gets the Pantone 5807 color.
static (Shared in Visual Basic) | PANTONE581 | Gets the Pantone 581 color.
static (Shared in Visual Basic) | PANTONE5815 | Gets the Pantone 5815 color.
static (Shared in Visual Basic) | PANTONE582 | Gets the Pantone 582 color.
static (Shared in Visual Basic) | PANTONE5825 | Gets the Pantone 5825 color.
static (Shared in Visual Basic) | PANTONE583 | Gets the Pantone 583 color.
static (Shared in Visual Basic) | PANTONE5835 | Gets the Pantone 5835 color.
static (Shared in Visual Basic) | PANTONE584 | Gets the Pantone 584 color.
static (Shared in Visual Basic) | PANTONE5845 | Gets the Pantone 5845 color.
static (Shared in Visual Basic) | PANTONE585 | Gets the Pantone 585 color.
static (Shared in Visual Basic) | PANTONE5855 | Gets the Pantone 5855 color.
static (Shared in Visual Basic) | PANTONE586 | Gets the Pantone 586 color.
static (Shared in Visual Basic) | PANTONE5865 | Gets the Pantone 5865 color.
static (Shared in Visual Basic) | PANTONE587 | Gets the Pantone 587 color.
static (Shared in Visual Basic) | PANTONE5875 | Gets the Pantone 5875 color.
static (Shared in Visual Basic) | PANTONE600 | Gets the Pantone 600 color.
static (Shared in Visual Basic) | PANTONE601 | Gets the Pantone 601 color.
static (Shared in Visual Basic) | PANTONE602 | Gets the Pantone 602 color.
static (Shared in Visual Basic) | PANTONE603 | Gets the Pantone 603 color.
static (Shared in Visual Basic) | PANTONE604 | Gets the Pantone 604 color.
static (Shared in Visual Basic) | PANTONE605 | Gets the Pantone 605 color.
static (Shared in Visual Basic) | PANTONE606 | Gets the Pantone 606 color.
static (Shared in Visual Basic) | PANTONE607 | Gets the Pantone 607 color.
static (Shared in Visual Basic) | PANTONE608 | Gets the Pantone 608 color.
static (Shared in Visual Basic) | PANTONE609 | Gets the Pantone 609 color.
static (Shared in Visual Basic) | PANTONE610 | Gets the Pantone 610 color.
static (Shared in Visual Basic) | PANTONE611 | Gets the Pantone 611 color.
static (Shared in Visual Basic) | PANTONE612 | Gets the Pantone 612 color.
static (Shared in Visual Basic) | PANTONE613 | Gets the Pantone 613 color.
static (Shared in Visual Basic) | PANTONE614 | Gets the Pantone 614 color.
static (Shared in Visual Basic) | PANTONE615 | Gets the Pantone 615 color.
static (Shared in Visual Basic) | PANTONE616 | Gets the Pantone 616 color.
static (Shared in Visual Basic) | PANTONE617 | Gets the Pantone 617 color.
static (Shared in Visual Basic) | PANTONE618 | Gets the Pantone 618 color.
static (Shared in Visual Basic) | PANTONE619 | Gets the Pantone 619 color.
static (Shared in Visual Basic) | PANTONE620 | Gets the Pantone 620 color.
static (Shared in Visual Basic) | PANTONE621 | Gets the Pantone 621 color.
static (Shared in Visual Basic) | PANTONE622 | Gets the Pantone 622 color.
static (Shared in Visual Basic) | PANTONE623 | Gets the Pantone 623 color.
static (Shared in Visual Basic) | PANTONE624 | Gets the Pantone 624 color.
static (Shared in Visual Basic) | PANTONE625 | Gets the Pantone 625 color.
static (Shared in Visual Basic) | PANTONE626 | Gets the Pantone 626 color.
static (Shared in Visual Basic) | PANTONE627 | Gets the Pantone 627 color.
static (Shared in Visual Basic) | PANTONE628 | Gets the Pantone 628 color.
static (Shared in Visual Basic) | PANTONE629 | Gets the Pantone 629 color.
static (Shared in Visual Basic) | PANTONE630 | Gets the Pantone 630 color.
static (Shared in Visual Basic) | PANTONE631 | Gets the Pantone 631 color.
static (Shared in Visual Basic) | PANTONE632 | Gets the Pantone 632 color.
static (Shared in Visual Basic) | PANTONE633 | Gets the Pantone 633 color.
static (Shared in Visual Basic) | PANTONE634 | Gets the Pantone 634 color.
static (Shared in Visual Basic) | PANTONE635 | Gets the Pantone 635 color.
static (Shared in Visual Basic) | PANTONE636 | Gets the Pantone 636 color.
static (Shared in Visual Basic) | PANTONE637 | Gets the Pantone 637 color.
static (Shared in Visual Basic) | PANTONE638 | Gets the Pantone 638 color.
static (Shared in Visual Basic) | PANTONE639 | Gets the Pantone 639 color.
static (Shared in Visual Basic) | PANTONE640 | Gets the Pantone 640 color.
static (Shared in Visual Basic) | PANTONE641 | Gets the Pantone 641 color.
static (Shared in Visual Basic) | PANTONE642 | Gets the Pantone 642 color.
static (Shared in Visual Basic) | PANTONE643 | Gets the Pantone 643 color.
static (Shared in Visual Basic) | PANTONE644 | Gets the Pantone 644 color.
static (Shared in Visual Basic) | PANTONE645 | Gets the Pantone 645 color.
static (Shared in Visual Basic) | PANTONE646 | Gets the Pantone 646 color.
static (Shared in Visual Basic) | PANTONE647 | Gets the Pantone 647 color.
static (Shared in Visual Basic) | PANTONE648 | Gets the Pantone 648 color.
static (Shared in Visual Basic) | PANTONE649 | Gets the Pantone 649 color.
static (Shared in Visual Basic) | PANTONE650 | Gets the Pantone 650 color.
static (Shared in Visual Basic) | PANTONE651 | Gets the Pantone 651 color.
static (Shared in Visual Basic) | PANTONE652 | Gets the Pantone 652 color.
static (Shared in Visual Basic) | PANTONE653 | Gets the Pantone 653 color.
static (Shared in Visual Basic) | PANTONE654 | Gets the Pantone 654 color.
static (Shared in Visual Basic) | PANTONE655 | Gets the Pantone 655 color.
static (Shared in Visual Basic) | PANTONE656 | Gets the Pantone 656 color.
static (Shared in Visual Basic) | PANTONE657 | Gets the Pantone 657 color.
static (Shared in Visual Basic) | PANTONE658 | Gets the Pantone 658 color.
static (Shared in Visual Basic) | PANTONE659 | Gets the Pantone 659 color.
static (Shared in Visual Basic) | PANTONE660 | Gets the Pantone 660 color.
static (Shared in Visual Basic) | PANTONE661 | Gets the Pantone 661 color.
static (Shared in Visual Basic) | PANTONE662 | Gets the Pantone 662 color.
static (Shared in Visual Basic) | PANTONE663 | Gets the Pantone 663 color.
static (Shared in Visual Basic) | PANTONE664 | Gets the Pantone 664 color.
static (Shared in Visual Basic) | PANTONE665 | Gets the Pantone 665 color.
static (Shared in Visual Basic) | PANTONE666 | Gets the Pantone 666 color.
static (Shared in Visual Basic) | PANTONE667 | Gets the Pantone 667 color.
static (Shared in Visual Basic) | PANTONE668 | Gets the Pantone 668 color.
static (Shared in Visual Basic) | PANTONE669 | Gets the Pantone 669 color.
static (Shared in Visual Basic) | PANTONE670 | Gets the Pantone 670 color.
static (Shared in Visual Basic) | PANTONE671 | Gets the Pantone 671 color.
static (Shared in Visual Basic) | PANTONE672 | Gets the Pantone 672 color.
static (Shared in Visual Basic) | PANTONE673 | Gets the Pantone 673 color.
static (Shared in Visual Basic) | PANTONE674 | Gets the Pantone 674 color.
static (Shared in Visual Basic) | PANTONE675 | Gets the Pantone 675 color.
static (Shared in Visual Basic) | PANTONE676 | Gets the Pantone 676 color.
static (Shared in Visual Basic) | PANTONE677 | Gets the Pantone 677 color.
static (Shared in Visual Basic) | PANTONE678 | Gets the Pantone 678 color.
static (Shared in Visual Basic) | PANTONE679 | Gets the Pantone 679 color.
static (Shared in Visual Basic) | PANTONE680 | Gets the Pantone 680 color.
static (Shared in Visual Basic) | PANTONE681 | Gets the Pantone 681 color.
static (Shared in Visual Basic) | PANTONE682 | Gets the Pantone 682 color.
static (Shared in Visual Basic) | PANTONE683 | Gets the Pantone 683 color.
static (Shared in Visual Basic) | PANTONE684 | Gets the Pantone 684 color.
static (Shared in Visual Basic) | PANTONE685 | Gets the Pantone 685 color.
static (Shared in Visual Basic) | PANTONE686 | Gets the Pantone 686 color.
static (Shared in Visual Basic) | PANTONE687 | Gets the Pantone 687 color.
static (Shared in Visual Basic) | PANTONE688 | Gets the Pantone 688 color.
static (Shared in Visual Basic) | PANTONE689 | Gets the Pantone 689 color.
static (Shared in Visual Basic) | PANTONE690 | Gets the Pantone 690 color.
static (Shared in Visual Basic) | PANTONE691 | Gets the Pantone 691 color.
static (Shared in Visual Basic) | PANTONE692 | Gets the Pantone 692 color.
static (Shared in Visual Basic) | PANTONE693 | Gets the Pantone 693 color.
static (Shared in Visual Basic) | PANTONE694 | Gets the Pantone 694 color.
static (Shared in Visual Basic) | PANTONE695 | Gets the Pantone 695 color.
static (Shared in Visual Basic) | PANTONE696 | Gets the Pantone 696 color.
static (Shared in Visual Basic) | PANTONE697 | Gets the Pantone 697 color.
static (Shared in Visual Basic) | PANTONE698 | Gets the Pantone 698 color.
static (Shared in Visual Basic) | PANTONE699 | Gets the Pantone 699 color.
static (Shared in Visual Basic) | PANTONE700 | Gets the Pantone 700 color.
static (Shared in Visual Basic) | PANTONE701 | Gets the Pantone 701 color.
static (Shared in Visual Basic) | PANTONE702 | Gets the Pantone 702 color.
static (Shared in Visual Basic) | PANTONE703 | Gets the Pantone 703 color.
static (Shared in Visual Basic) | PANTONE704 | Gets the Pantone 704 color.
static (Shared in Visual Basic) | PANTONE705 | Gets the Pantone 705 color.
static (Shared in Visual Basic) | PANTONE706 | Gets the Pantone 706 color.
static (Shared in Visual Basic) | PANTONE707 | Gets the Pantone 707 color.
static (Shared in Visual Basic) | PANTONE708 | Gets the Pantone 708 color.
static (Shared in Visual Basic) | PANTONE709 | Gets the Pantone 709 color.
static (Shared in Visual Basic) | PANTONE710 | Gets the Pantone 710 color.
static (Shared in Visual Basic) | PANTONE711 | Gets the Pantone 711 color.
static (Shared in Visual Basic) | PANTONE712 | Gets the Pantone 712 color.
static (Shared in Visual Basic) | PANTONE713 | Gets the Pantone 713 color.
static (Shared in Visual Basic) | PANTONE714 | Gets the Pantone 714 color.
static (Shared in Visual Basic) | PANTONE715 | Gets the Pantone 715 color.
static (Shared in Visual Basic) | PANTONE716 | Gets the Pantone 716 color.
static (Shared in Visual Basic) | PANTONE717 | Gets the Pantone 717 color.
static (Shared in Visual Basic) | PANTONE718 | Gets the Pantone 718 color.
static (Shared in Visual Basic) | PANTONE719 | Gets the Pantone 719 color.
static (Shared in Visual Basic) | PANTONE720 | Gets the Pantone 720 color.
static (Shared in Visual Basic) | PANTONE721 | Gets the Pantone 721 color.
static (Shared in Visual Basic) | PANTONE722 | Gets the Pantone 722 color.
static (Shared in Visual Basic) | PANTONE723 | Gets the Pantone 723 color.
static (Shared in Visual Basic) | PANTONE724 | Gets the Pantone 724 color.
static (Shared in Visual Basic) | PANTONE725 | Gets the Pantone 725 color.
static (Shared in Visual Basic) | PANTONE726 | Gets the Pantone 726 color.
static (Shared in Visual Basic) | PANTONE727 | Gets the Pantone 727 color.
static (Shared in Visual Basic) | PANTONE728 | Gets the Pantone 728 color.
static (Shared in Visual Basic) | PANTONE729 | Gets the Pantone 729 color.
static (Shared in Visual Basic) | PANTONE730 | Gets the Pantone 730 color.
static (Shared in Visual Basic) | PANTONE731 | Gets the Pantone 731 color.
static (Shared in Visual Basic) | PANTONE732 | Gets the Pantone 732 color.
static (Shared in Visual Basic) | PANTONE7401 | Gets the Pantone 7401 color.
static (Shared in Visual Basic) | PANTONE7402 | Gets the Pantone 7402 color.
static (Shared in Visual Basic) | PANTONE7403 | Gets the Pantone 7403 color.
static (Shared in Visual Basic) | PANTONE7404 | Gets the Pantone 7404 color.
static (Shared in Visual Basic) | PANTONE7405 | Gets the Pantone 7405 color.
static (Shared in Visual Basic) | PANTONE7406 | Gets the Pantone 7406 color.
static (Shared in Visual Basic) | PANTONE7407 | Gets the Pantone 7407 color.
static (Shared in Visual Basic) | PANTONE7408 | Gets the Pantone 7408 color.
static (Shared in Visual Basic) | PANTONE7409 | Gets the Pantone 7409 color.
static (Shared in Visual Basic) | PANTONE7410 | Gets the Pantone 7410 color.
static (Shared in Visual Basic) | PANTONE7411 | Gets the Pantone 7411 color.
static (Shared in Visual Basic) | PANTONE7412 | Gets the Pantone 7412 color.
static (Shared in Visual Basic) | PANTONE7413 | Gets the Pantone 7413 color.
static (Shared in Visual Basic) | PANTONE7414 | Gets the Pantone 7414 color.
static (Shared in Visual Basic) | PANTONE7415 | Gets the Pantone 7415 color.
static (Shared in Visual Basic) | PANTONE7416 | Gets the Pantone 7416 color.
static (Shared in Visual Basic) | PANTONE7417 | Gets the Pantone 7417 color.
static (Shared in Visual Basic) | PANTONE7418 | Gets the Pantone 7418 color.
static (Shared in Visual Basic) | PANTONE7419 | Gets the Pantone 7419 color.
static (Shared in Visual Basic) | PANTONE7420 | Gets the Pantone 7420 color.
static (Shared in Visual Basic) | PANTONE7421 | Gets the Pantone 7421 color.
static (Shared in Visual Basic) | PANTONE7422 | Gets the Pantone 7422 color.
static (Shared in Visual Basic) | PANTONE7423 | Gets the Pantone 7423 color.
static (Shared in Visual Basic) | PANTONE7424 | Gets the Pantone 7424 color.
static (Shared in Visual Basic) | PANTONE7425 | Gets the Pantone 7425 color.
static (Shared in Visual Basic) | PANTONE7426 | Gets the Pantone 7426 color.
static (Shared in Visual Basic) | PANTONE7427 | Gets the Pantone 7427 color.
static (Shared in Visual Basic) | PANTONE7428 | Gets the Pantone 7428 color.
static (Shared in Visual Basic) | PANTONE7429 | Gets the Pantone 7429 color.
static (Shared in Visual Basic) | PANTONE7430 | Gets the Pantone 7430 color.
static (Shared in Visual Basic) | PANTONE7431 | Gets the Pantone 7431 color.
static (Shared in Visual Basic) | PANTONE7432 | Gets the Pantone 7432 color.
static (Shared in Visual Basic) | PANTONE7433 | Gets the Pantone 7433 color.
static (Shared in Visual Basic) | PANTONE7434 | Gets the Pantone 7434 color.
static (Shared in Visual Basic) | PANTONE7435 | Gets the Pantone 7435 color.
static (Shared in Visual Basic) | PANTONE7436 | Gets the Pantone 7436 color.
static (Shared in Visual Basic) | PANTONE7437 | Gets the Pantone 7437 color.
static (Shared in Visual Basic) | PANTONE7438 | Gets the Pantone 7438 color.
static (Shared in Visual Basic) | PANTONE7439 | Gets the Pantone 7439 color.
static (Shared in Visual Basic) | PANTONE7440 | Gets the Pantone 7440 color.
static (Shared in Visual Basic) | PANTONE7441 | Gets the Pantone 7441 color.
static (Shared in Visual Basic) | PANTONE7442 | Gets the Pantone 7442 color.
static (Shared in Visual Basic) | PANTONE7443 | Gets the Pantone 7443 color.
static (Shared in Visual Basic) | PANTONE7444 | Gets the Pantone 7444 color.
static (Shared in Visual Basic) | PANTONE7445 | Gets the Pantone 7445 color.
static (Shared in Visual Basic) | PANTONE7446 | Gets the Pantone 7446 color.
static (Shared in Visual Basic) | PANTONE7447 | Gets the Pantone 7447 color.
static (Shared in Visual Basic) | PANTONE7448 | Gets the Pantone 7448 color.
static (Shared in Visual Basic) | PANTONE7449 | Gets the Pantone 7449 color.
static (Shared in Visual Basic) | PANTONE7450 | Gets the Pantone 7450 color.
static (Shared in Visual Basic) | PANTONE7451 | Gets the Pantone 7451 color.
static (Shared in Visual Basic) | PANTONE7452 | Gets the Pantone 7452 color.
static (Shared in Visual Basic) | PANTONE7453 | Gets the Pantone 7453 color.
static (Shared in Visual Basic) | PANTONE7454 | Gets the Pantone 7454 color.
static (Shared in Visual Basic) | PANTONE7455 | Gets the Pantone 7455 color.
static (Shared in Visual Basic) | PANTONE7456 | Gets the Pantone 7456 color.
static (Shared in Visual Basic) | PANTONE7457 | Gets the Pantone 7457 color.
static (Shared in Visual Basic) | PANTONE7458 | Gets the Pantone 7458 color.
static (Shared in Visual Basic) | PANTONE7459 | Gets the Pantone 7459 color.
static (Shared in Visual Basic) | PANTONE7460 | Gets the Pantone 7460 color.
static (Shared in Visual Basic) | PANTONE7461 | Gets the Pantone 7461 color.
static (Shared in Visual Basic) | PANTONE7462 | Gets the Pantone 7462 color.
static (Shared in Visual Basic) | PANTONE7463 | Gets the Pantone 7463 color.
static (Shared in Visual Basic) | PANTONE7464 | Gets the Pantone 7464 color.
static (Shared in Visual Basic) | PANTONE7465 | Gets the Pantone 7465 color.
static (Shared in Visual Basic) | PANTONE7466 | Gets the Pantone 7466 color.
static (Shared in Visual Basic) | PANTONE7467 | Gets the Pantone 7467 color.
static (Shared in Visual Basic) | PANTONE7468 | Gets the Pantone 7468 color.
static (Shared in Visual Basic) | PANTONE7469 | Gets the Pantone 7469 color.
static (Shared in Visual Basic) | PANTONE7470 | Gets the Pantone 7470 color.
static (Shared in Visual Basic) | PANTONE7471 | Gets the Pantone 7471 color.
static (Shared in Visual Basic) | PANTONE7472 | Gets the Pantone 7472 color.
static (Shared in Visual Basic) | PANTONE7473 | Gets the Pantone 7473 color.
static (Shared in Visual Basic) | PANTONE7474 | Gets the Pantone 7474 color.
static (Shared in Visual Basic) | PANTONE7475 | Gets the Pantone 7475 color.
static (Shared in Visual Basic) | PANTONE7476 | Gets the Pantone 7476 color.
static (Shared in Visual Basic) | PANTONE7477 | Gets the Pantone 7477 color.
static (Shared in Visual Basic) | PANTONE7478 | Gets the Pantone 7478 color.
static (Shared in Visual Basic) | PANTONE7479 | Gets the Pantone 7479 color.
static (Shared in Visual Basic) | PANTONE7480 | Gets the Pantone 7480 color.
static (Shared in Visual Basic) | PANTONE7481 | Gets the Pantone 7481 color.
static (Shared in Visual Basic) | PANTONE7482 | Gets the Pantone 7482 color.
static (Shared in Visual Basic) | PANTONE7483 | Gets the Pantone 7483 color.
static (Shared in Visual Basic) | PANTONE7484 | Gets the Pantone 7484 color.
static (Shared in Visual Basic) | PANTONE7485 | Gets the Pantone 7485 color.
static (Shared in Visual Basic) | PANTONE7486 | Gets the Pantone 7486 color.
static (Shared in Visual Basic) | PANTONE7487 | Gets the Pantone 7487 color.
static (Shared in Visual Basic) | PANTONE7488 | Gets the Pantone 7488 color.
static (Shared in Visual Basic) | PANTONE7489 | Gets the Pantone 7489 color.
static (Shared in Visual Basic) | PANTONE7490 | Gets the Pantone 7490 color.
static (Shared in Visual Basic) | PANTONE7491 | Gets the Pantone 7491 color.
static (Shared in Visual Basic) | PANTONE7492 | Gets the Pantone 7492 color.
static (Shared in Visual Basic) | PANTONE7493 | Gets the Pantone 7493 color.
static (Shared in Visual Basic) | PANTONE7494 | Gets the Pantone 7494 color.
static (Shared in Visual Basic) | PANTONE7495 | Gets the Pantone 7495 color.
static (Shared in Visual Basic) | PANTONE7496 | Gets the Pantone 7496 color.
static (Shared in Visual Basic) | PANTONE7497 | Gets the Pantone 7497 color.
static (Shared in Visual Basic) | PANTONE7498 | Gets the Pantone 7498 color.
static (Shared in Visual Basic) | PANTONE7499 | Gets the Pantone 7499 color.
static (Shared in Visual Basic) | PANTONE7500 | Gets the Pantone 7500 color.
static (Shared in Visual Basic) | PANTONE7501 | Gets the Pantone 7501 color.
static (Shared in Visual Basic) | PANTONE7502 | Gets the Pantone 7502 color.
static (Shared in Visual Basic) | PANTONE7503 | Gets the Pantone 7503 color.
static (Shared in Visual Basic) | PANTONE7504 | Gets the Pantone 7504 color.
static (Shared in Visual Basic) | PANTONE7505 | Gets the Pantone 7505 color.
static (Shared in Visual Basic) | PANTONE7506 | Gets the Pantone 7506 color.
static (Shared in Visual Basic) | PANTONE7507 | Gets the Pantone 7507 color.
static (Shared in Visual Basic) | PANTONE7508 | Gets the Pantone 7508 color.
static (Shared in Visual Basic) | PANTONE7509 | Gets the Pantone 7509 color.
static (Shared in Visual Basic) | PANTONE7510 | Gets the Pantone 7510 color.
static (Shared in Visual Basic) | PANTONE7511 | Gets the Pantone 7511 color.
static (Shared in Visual Basic) | PANTONE7512 | Gets the Pantone 7512 color.
static (Shared in Visual Basic) | PANTONE7513 | Gets the Pantone 7513 color.
static (Shared in Visual Basic) | PANTONE7514 | Gets the Pantone 7514 color.
static (Shared in Visual Basic) | PANTONE7515 | Gets the Pantone 7515 color.
static (Shared in Visual Basic) | PANTONE7516 | Gets the Pantone 7516 color.
static (Shared in Visual Basic) | PANTONE7517 | Gets the Pantone 7517 color.
static (Shared in Visual Basic) | PANTONE7518 | Gets the Pantone 7518 color.
static (Shared in Visual Basic) | PANTONE7519 | Gets the Pantone 7519 color.
static (Shared in Visual Basic) | PANTONE7520 | Gets the Pantone 7520 color.
static (Shared in Visual Basic) | PANTONE7521 | Gets the Pantone 7521 color.
static (Shared in Visual Basic) | PANTONE7522 | Gets the Pantone 7522 color.
static (Shared in Visual Basic) | PANTONE7523 | Gets the Pantone 7523 color.
static (Shared in Visual Basic) | PANTONE7524 | Gets the Pantone 7524 color.
static (Shared in Visual Basic) | PANTONE7525 | Gets the Pantone 7525 color.
static (Shared in Visual Basic) | PANTONE7526 | Gets the Pantone 7526 color.
static (Shared in Visual Basic) | PANTONE7527 | Gets the Pantone 7527 color.
static (Shared in Visual Basic) | PANTONE7528 | Gets the Pantone 7528 color.
static (Shared in Visual Basic) | PANTONE7529 | Gets the Pantone 7529 color.
static (Shared in Visual Basic) | PANTONE7530 | Gets the Pantone 7530 color.
static (Shared in Visual Basic) | PANTONE7531 | Gets the Pantone 7531 color.
static (Shared in Visual Basic) | PANTONE7532 | Gets the Pantone 7532 color.
static (Shared in Visual Basic) | PANTONE7533 | Gets the Pantone 7533 color.
static (Shared in Visual Basic) | PANTONE7534 | Gets the Pantone 7534 color.
static (Shared in Visual Basic) | PANTONE7535 | Gets the Pantone 7535 color.
static (Shared in Visual Basic) | PANTONE7536 | Gets the Pantone 7536 color.
static (Shared in Visual Basic) | PANTONE7537 | Gets the Pantone 7537 color.
static (Shared in Visual Basic) | PANTONE7538 | Gets the Pantone 7538 color.
static (Shared in Visual Basic) | PANTONE7539 | Gets the Pantone 7539 color.
static (Shared in Visual Basic) | PANTONE7540 | Gets the Pantone 7540 color.
static (Shared in Visual Basic) | PANTONE7541 | Gets the Pantone 7541 color.
static (Shared in Visual Basic) | PANTONE7542 | Gets the Pantone 7542 color.
static (Shared in Visual Basic) | PANTONE7543 | Gets the Pantone 7543 color.
static (Shared in Visual Basic) | PANTONE7544 | Gets the Pantone 7544 color.
static (Shared in Visual Basic) | PANTONE7545 | Gets the Pantone 7545 color.
static (Shared in Visual Basic) | PANTONE7546 | Gets the Pantone 7546 color.
static (Shared in Visual Basic) | PANTONE7547 | Gets the Pantone 7547 color.
static (Shared in Visual Basic) | PANTONE8003 | Gets the Pantone 8003 color.
static (Shared in Visual Basic) | PANTONE801 | Gets the Pantone 801 color.
static (Shared in Visual Basic) | PANTONE802 | Gets the Pantone 802 color.
static (Shared in Visual Basic) | PANTONE8021 | Gets the Pantone 8021 color.
static (Shared in Visual Basic) | PANTONE803 | Gets the Pantone 803 color.
static (Shared in Visual Basic) | PANTONE804 | Gets the Pantone 804 color.
static (Shared in Visual Basic) | PANTONE805 | Gets the Pantone 805 color.
static (Shared in Visual Basic) | PANTONE806 | Gets the Pantone 806 color.
static (Shared in Visual Basic) | PANTONE8062 | Gets the Pantone 8062 color.
static (Shared in Visual Basic) | PANTONE807 | Gets the Pantone 807 color.
static (Shared in Visual Basic) | PANTONE808 | Gets the Pantone 808 color.
static (Shared in Visual Basic) | PANTONE809 | Gets the Pantone 809 color.
static (Shared in Visual Basic) | PANTONE810 | Gets the Pantone 810 color.
static (Shared in Visual Basic) | PANTONE8100 | Gets the Pantone 8100 color.
static (Shared in Visual Basic) | PANTONE811 | Gets the Pantone 811 color.
static (Shared in Visual Basic) | PANTONE812 | Gets the Pantone 812 color.
static (Shared in Visual Basic) | PANTONE813 | Gets the Pantone 813 color.
static (Shared in Visual Basic) | PANTONE814 | Gets the Pantone 814 color.
static (Shared in Visual Basic) | PANTONE8201 | Gets the Pantone 8201 color.
static (Shared in Visual Basic) | PANTONE8281 | Gets the Pantone 8281 color.
static (Shared in Visual Basic) | PANTONE8321 | Gets the Pantone 8321 color.
static (Shared in Visual Basic) | PANTONE871 | Gets the Pantone 871 color.
static (Shared in Visual Basic) | PANTONE872 | Gets the Pantone 872 color.
static (Shared in Visual Basic) | PANTONE873 | Gets the Pantone 873 color.
static (Shared in Visual Basic) | PANTONE874 | Gets the Pantone 874 color.
static (Shared in Visual Basic) | PANTONE875 | Gets the Pantone 875 color.
static (Shared in Visual Basic) | PANTONE876 | Gets the Pantone 876 color.
static (Shared in Visual Basic) | PANTONE877 | Gets the Pantone 877 color.
static (Shared in Visual Basic) | ProcessBlack | Gets the Pantone Process Black color.
static (Shared in Visual Basic) | ProcessBlue | Gets the Pantone Process Blue color.
static (Shared in Visual Basic) | ProcessCyan | Gets the Pantone Process Cyan color.
static (Shared in Visual Basic) | ProcessMagenta | Gets the Pantone Process Magenta color.
static (Shared in Visual Basic) | ProcessYellow | Gets the Pantone Process Yellow color.
static (Shared in Visual Basic) | Purple | Gets the Pantone Purple color.
static (Shared in Visual Basic) | Red032 | Gets the Pantone Red 032 color.
static (Shared in Visual Basic) | ReflexBlue | Gets the Pantone Reflex Blue color.
static (Shared in Visual Basic) | RhodamineRed | Gets the Pantone Rhodamine Red color.
static (Shared in Visual Basic) | RubineRed | Gets the Pantone Rubine Red color.
Public Property | Tint | Gets or sets the tint component. (Inherited from Xfinium.Pdf.Graphics.PdfSeparationColor)
static (Shared in Visual Basic) | Violet | Gets the Pantone Violet color.
static (Shared in Visual Basic) | WarmGray1 | Gets the Pantone Warm Gray 1 color.
static (Shared in Visual Basic) | WarmGray10 | Gets the Pantone Warm Gray 10 color.
static (Shared in Visual Basic) | WarmGray11 | Gets the Pantone Warm Gray 11 color.
static (Shared in Visual Basic) | WarmGray2 | Gets the Pantone Warm Gray 2 color.
static (Shared in Visual Basic) | WarmGray3 | Gets the Pantone Warm Gray 3 color.
static (Shared in Visual Basic) | WarmGray4 | Gets the Pantone Warm Gray 4 color.
static (Shared in Visual Basic) | WarmGray5 | Gets the Pantone Warm Gray 5 color.
static (Shared in Visual Basic) | WarmGray6 | Gets the Pantone Warm Gray 6 color.
static (Shared in Visual Basic) | WarmGray7 | Gets the Pantone Warm Gray 7 color.
static (Shared in Visual Basic) | WarmGray8 | Gets the Pantone Warm Gray 8 color.
static (Shared in Visual Basic) | WarmGray9 | Gets the Pantone Warm Gray 9 color.
static (Shared in Visual Basic) | WarmRed | Gets the Pantone Warm Red color.
static (Shared in Visual Basic) | Yellow | Gets the Pantone Yellow color.
static (Shared in Visual Basic) | Yellow012 | Gets the Pantone Yellow 012 color.
Top
See Also

Reference

PdfPantoneColor Class
Xfinium.Pdf.Graphics Namespace


Black Property (PdfPantoneColor)

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Black Property
Gets the Pantone Black color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Black
public static PdfPantoneColor Black {get;}
public:
static property PdfPantoneColor^ Black {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Black color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Black2 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Black2 Property
Gets the Pantone Black 2 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black2 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Black2
public static PdfPantoneColor Black2 {get;}
public:
static property PdfPantoneColor^ Black2 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Black 2 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Black3 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Black3 Property
Gets the Pantone Black 3 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black3 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Black3
public static PdfPantoneColor Black3 {get;}
public:
static property PdfPantoneColor^ Black3 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Black 3 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Black4 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Black4 Property
Gets the Pantone Black 4 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black4 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Black4
public static PdfPantoneColor Black4 {get;}
public:
static property PdfPantoneColor^ Black4 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Black 4 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Black5 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Black5 Property
Gets the Pantone Black 5 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black5 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Black5
public static PdfPantoneColor Black5 {get;}
public:
static property PdfPantoneColor^ Black5 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Black 5 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Black6 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Black6 Property
Gets the Pantone Black 6 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black6 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Black6
public static PdfPantoneColor Black6 {get;}
public:
static property PdfPantoneColor^ Black6 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Black 6 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Black7 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Black7 Property
Gets the Pantone Black 7 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black7 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Black7
public static PdfPantoneColor Black7 {get;}
public:
static property PdfPantoneColor^ Black7 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Black 7 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Blue072 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Blue072 Property
Gets the Pantone Blue 072 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Blue072 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Blue072
public static PdfPantoneColor Blue072 {get;}
public:
static property PdfPantoneColor^ Blue072 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Blue 072 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray1 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray1 Property
Gets the Pantone Cool Gray 1 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray1 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray1
public static PdfPantoneColor CoolGray1 {get;}
public:
static property PdfPantoneColor^ CoolGray1 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 1 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray10 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray10 Property
Gets the Pantone Cool Gray 10 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray10 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray10
public static PdfPantoneColor CoolGray10 {get;}
public:
static property PdfPantoneColor^ CoolGray10 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 10 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray11 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray11 Property
Gets the Pantone Cool Gray 11 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray11 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray11
public static PdfPantoneColor CoolGray11 {get;}
public:
static property PdfPantoneColor^ CoolGray11 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 11 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray2 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray2 Property
Gets the Pantone Cool Gray 2 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray2 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray2
public static PdfPantoneColor CoolGray2 {get;}
public:
static property PdfPantoneColor^ CoolGray2 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 2 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray3 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray3 Property
Gets the Pantone Cool Gray 3 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray3 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray3
public static PdfPantoneColor CoolGray3 {get;}
public:
static property PdfPantoneColor^ CoolGray3 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 3 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray4 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray4 Property
Gets the Pantone Cool Gray 4 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray4 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray4
public static PdfPantoneColor CoolGray4 {get;}
public:
static property PdfPantoneColor^ CoolGray4 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 4 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray5 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray5 Property
Gets the Pantone Cool Gray 5 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray5 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray5
public static PdfPantoneColor CoolGray5 {get;}
public:
static property PdfPantoneColor^ CoolGray5 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 5 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray6 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray6 Property
Gets the Pantone Cool Gray 6 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray6 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray6
public static PdfPantoneColor CoolGray6 {get;}
public:
static property PdfPantoneColor^ CoolGray6 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 6 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray7 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray7 Property
Gets the Pantone Cool Gray 7 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray7 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray7
public static PdfPantoneColor CoolGray7 {get;}
public:
static property PdfPantoneColor^ CoolGray7 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 7 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray8 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray8 Property
Gets the Pantone Cool Gray 8 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray8 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray8
public static PdfPantoneColor CoolGray8 {get;}
public:
static property PdfPantoneColor^ CoolGray8 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 8 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


CoolGray9 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : CoolGray9 Property
Gets the Pantone Cool Gray 9 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CoolGray9 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.CoolGray9
public static PdfPantoneColor CoolGray9 {get;}
public:
static property PdfPantoneColor^ CoolGray9 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Cool Gray 9 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Green Property (PdfPantoneColor)

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Green Property
Gets the Pantone Green color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Green As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Green
public static PdfPantoneColor Green {get;}
public:
static property PdfPantoneColor^ Green {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Green color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


HexachromeBlack Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : HexachromeBlack Property
Gets the Pantone Hexachrome Black color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeBlack As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.HexachromeBlack
public static PdfPantoneColor HexachromeBlack {get;}
public:
static property PdfPantoneColor^ HexachromeBlack {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Hexachrome Black color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


HexachromeCyan Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : HexachromeCyan Property
Gets the Pantone Hexachrome Cyan color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeCyan As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.HexachromeCyan
public static PdfPantoneColor HexachromeCyan {get;}
public:
static property PdfPantoneColor^ HexachromeCyan {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Hexachrome Cyan color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


HexachromeGreen Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : HexachromeGreen Property
Gets the Pantone Hexachrome Green color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeGreen As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.HexachromeGreen
public static PdfPantoneColor HexachromeGreen {get;}
public:
static property PdfPantoneColor^ HexachromeGreen {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Hexachrome Green color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


HexachromeMagenta Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : HexachromeMagenta Property
Gets the Pantone Hexachrome Magenta color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeMagenta As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.HexachromeMagenta
public static PdfPantoneColor HexachromeMagenta {get;}
public:
static property PdfPantoneColor^ HexachromeMagenta {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Hexachrome Magenta color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


HexachromeOrange Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : HexachromeOrange Property
Gets the Pantone Hexachrome Orange color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeOrange As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.HexachromeOrange
public static PdfPantoneColor HexachromeOrange {get;}
public:
static property PdfPantoneColor^ HexachromeOrange {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Hexachrome Orange color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


HexachromeYellow Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : HexachromeYellow Property
Gets the Pantone Hexachrome Yellow color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HexachromeYellow As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.HexachromeYellow
public static PdfPantoneColor HexachromeYellow {get;}
public:
static property PdfPantoneColor^ HexachromeYellow {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Hexachrome Yellow color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Orange021 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Orange021 Property
Gets the Pantone Orange 021 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Orange021 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Orange021
public static PdfPantoneColor Orange021 {get;}
public:
static property PdfPantoneColor^ Orange021 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Orange 021 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE100 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE100 Property
Gets the Pantone 100 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE100 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE100
public static PdfPantoneColor PANTONE100 {get;}
public:
static property PdfPantoneColor^ PANTONE100 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 100 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE101 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE101 Property
Gets the Pantone 101 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE101 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE101
public static PdfPantoneColor PANTONE101 {get;}
public:
static property PdfPantoneColor^ PANTONE101 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 101 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE102 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE102 Property
Gets the Pantone 102 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE102 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE102
public static PdfPantoneColor PANTONE102 {get;}
public:
static property PdfPantoneColor^ PANTONE102 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 102 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE103 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE103 Property
Gets the Pantone 103 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE103 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE103
public static PdfPantoneColor PANTONE103 {get;}
public:
static property PdfPantoneColor^ PANTONE103 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 103 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE104 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE104 Property
Gets the Pantone 104 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE104 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE104
public static PdfPantoneColor PANTONE104 {get;}
public:
static property PdfPantoneColor^ PANTONE104 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 104 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE105 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE105 Property
Gets the Pantone 105 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE105 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE105
public static PdfPantoneColor PANTONE105 {get;}
public:
static property PdfPantoneColor^ PANTONE105 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 105 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE106 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE106 Property
Gets the Pantone 106 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE106 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE106
public static PdfPantoneColor PANTONE106 {get;}
public:
static property PdfPantoneColor^ PANTONE106 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 106 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE107 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE107 Property
Gets the Pantone 107 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE107 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE107
public static PdfPantoneColor PANTONE107 {get;}
public:
static property PdfPantoneColor^ PANTONE107 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 107 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE108 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE108 Property
Gets the Pantone 108 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE108 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE108
public static PdfPantoneColor PANTONE108 {get;}
public:
static property PdfPantoneColor^ PANTONE108 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 108 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE109 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE109 Property
Gets the Pantone 109 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE109 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE109
public static PdfPantoneColor PANTONE109 {get;}
public:
static property PdfPantoneColor^ PANTONE109 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 109 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE110 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE110 Property
Gets the Pantone 110 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE110 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE110
public static PdfPantoneColor PANTONE110 {get;}
public:
static property PdfPantoneColor^ PANTONE110 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 110 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE111 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE111 Property
Gets the Pantone 111 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE111 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE111
public static PdfPantoneColor PANTONE111 {get;}
public:
static property PdfPantoneColor^ PANTONE111 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 111 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE112 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE112 Property
Gets the Pantone 112 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE112 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE112
public static PdfPantoneColor PANTONE112 {get;}
public:
static property PdfPantoneColor^ PANTONE112 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 112 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE113 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE113 Property
Gets the Pantone 113 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE113 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE113
public static PdfPantoneColor PANTONE113 {get;}
public:
static property PdfPantoneColor^ PANTONE113 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 113 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE114 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE114 Property
Gets the Pantone 114 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE114 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE114
public static PdfPantoneColor PANTONE114 {get;}
public:
static property PdfPantoneColor^ PANTONE114 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 114 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE115 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE115 Property
Gets the Pantone 115 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE115 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE115
public static PdfPantoneColor PANTONE115 {get;}
public:
static property PdfPantoneColor^ PANTONE115 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 115 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE116 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE116 Property
Gets the Pantone 116 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE116 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE116
public static PdfPantoneColor PANTONE116 {get;}
public:
static property PdfPantoneColor^ PANTONE116 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 116 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE117 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE117 Property
Gets the Pantone 117 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE117 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE117
public static PdfPantoneColor PANTONE117 {get;}
public:
static property PdfPantoneColor^ PANTONE117 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 117 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE118 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE118 Property
Gets the Pantone 118 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE118 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE118
public static PdfPantoneColor PANTONE118 {get;}
public:
static property PdfPantoneColor^ PANTONE118 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 118 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE119 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE119 Property
Gets the Pantone 119 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE119 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE119
public static PdfPantoneColor PANTONE119 {get;}
public:
static property PdfPantoneColor^ PANTONE119 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 119 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE120 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE120 Property
Gets the Pantone 120 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE120 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE120
public static PdfPantoneColor PANTONE120 {get;}
public:
static property PdfPantoneColor^ PANTONE120 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 120 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1205 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1205 Property
Gets the Pantone 1205 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1205 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1205
public static PdfPantoneColor PANTONE1205 {get;}
public:
static property PdfPantoneColor^ PANTONE1205 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1205 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE121 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE121 Property
Gets the Pantone 121 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE121 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE121
public static PdfPantoneColor PANTONE121 {get;}
public:
static property PdfPantoneColor^ PANTONE121 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 121 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1215 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1215 Property
Gets the Pantone 1215 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1215 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1215
public static PdfPantoneColor PANTONE1215 {get;}
public:
static property PdfPantoneColor^ PANTONE1215 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1215 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE122 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE122 Property
Gets the Pantone 122 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE122 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE122
public static PdfPantoneColor PANTONE122 {get;}
public:
static property PdfPantoneColor^ PANTONE122 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 122 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1225 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1225 Property
Gets the Pantone 1225 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1225 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1225
public static PdfPantoneColor PANTONE1225 {get;}
public:
static property PdfPantoneColor^ PANTONE1225 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1225 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE123 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE123 Property
Gets the Pantone 123 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE123 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE123
public static PdfPantoneColor PANTONE123 {get;}
public:
static property PdfPantoneColor^ PANTONE123 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 123 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1235 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1235 Property
Gets the Pantone 1235 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1235 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1235
public static PdfPantoneColor PANTONE1235 {get;}
public:
static property PdfPantoneColor^ PANTONE1235 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1235 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE124 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE124 Property
Gets the Pantone 124 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE124 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE124
public static PdfPantoneColor PANTONE124 {get;}
public:
static property PdfPantoneColor^ PANTONE124 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 124 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1245 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1245 Property
Gets the Pantone 1245 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1245 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1245
public static PdfPantoneColor PANTONE1245 {get;}
public:
static property PdfPantoneColor^ PANTONE1245 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1245 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE125 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE125 Property
Gets the Pantone 125 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE125 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE125
public static PdfPantoneColor PANTONE125 {get;}
public:
static property PdfPantoneColor^ PANTONE125 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 125 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1255 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1255 Property
Gets the Pantone 1255 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1255 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1255
public static PdfPantoneColor PANTONE1255 {get;}
public:
static property PdfPantoneColor^ PANTONE1255 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1255 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE126 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE126 Property
Gets the Pantone 126 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE126 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE126
public static PdfPantoneColor PANTONE126 {get;}
public:
static property PdfPantoneColor^ PANTONE126 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 126 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1265 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1265 Property
Gets the Pantone 1265 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1265 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1265
public static PdfPantoneColor PANTONE1265 {get;}
public:
static property PdfPantoneColor^ PANTONE1265 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1265 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE127 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE127 Property
Gets the Pantone 127 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE127 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE127
public static PdfPantoneColor PANTONE127 {get;}
public:
static property PdfPantoneColor^ PANTONE127 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 127 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE128 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE128 Property
Gets the Pantone 128 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE128 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE128
public static PdfPantoneColor PANTONE128 {get;}
public:
static property PdfPantoneColor^ PANTONE128 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 128 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE129 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE129 Property
Gets the Pantone 129 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE129 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE129
public static PdfPantoneColor PANTONE129 {get;}
public:
static property PdfPantoneColor^ PANTONE129 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 129 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE130 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE130 Property
Gets the Pantone 130 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE130 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE130
public static PdfPantoneColor PANTONE130 {get;}
public:
static property PdfPantoneColor^ PANTONE130 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 130 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE131 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE131 Property
Gets the Pantone 131 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE131 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE131
public static PdfPantoneColor PANTONE131 {get;}
public:
static property PdfPantoneColor^ PANTONE131 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 131 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE132 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE132 Property
Gets the Pantone 132 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE132 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE132
public static PdfPantoneColor PANTONE132 {get;}
public:
static property PdfPantoneColor^ PANTONE132 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 132 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE133 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE133 Property
Gets the Pantone 133 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE133 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE133
public static PdfPantoneColor PANTONE133 {get;}
public:
static property PdfPantoneColor^ PANTONE133 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 133 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE134 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE134 Property
Gets the Pantone 134 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE134 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE134
public static PdfPantoneColor PANTONE134 {get;}
public:
static property PdfPantoneColor^ PANTONE134 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 134 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1345 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1345 Property
Gets the Pantone 1345 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1345 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1345
public static PdfPantoneColor PANTONE1345 {get;}
public:
static property PdfPantoneColor^ PANTONE1345 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1345 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE135 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE135 Property
Gets the Pantone 135 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE135 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE135
public static PdfPantoneColor PANTONE135 {get;}
public:
static property PdfPantoneColor^ PANTONE135 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 135 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1355 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1355 Property
Gets the Pantone 1355 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1355 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1355
public static PdfPantoneColor PANTONE1355 {get;}
public:
static property PdfPantoneColor^ PANTONE1355 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1355 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE136 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE136 Property
Gets the Pantone 136 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE136 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE136
public static PdfPantoneColor PANTONE136 {get;}
public:
static property PdfPantoneColor^ PANTONE136 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 136 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1365 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1365 Property
Gets the Pantone 1365 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1365 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1365
public static PdfPantoneColor PANTONE1365 {get;}
public:
static property PdfPantoneColor^ PANTONE1365 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1365 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE137 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE137 Property
Gets the Pantone 137 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE137 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE137
public static PdfPantoneColor PANTONE137 {get;}
public:
static property PdfPantoneColor^ PANTONE137 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 137 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1375 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1375 Property
Gets the Pantone 1375 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1375 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1375
public static PdfPantoneColor PANTONE1375 {get;}
public:
static property PdfPantoneColor^ PANTONE1375 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1375 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE138 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE138 Property
Gets the Pantone 138 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE138 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE138
public static PdfPantoneColor PANTONE138 {get;}
public:
static property PdfPantoneColor^ PANTONE138 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 138 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1385 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1385 Property
Gets the Pantone 1385 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1385 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1385
public static PdfPantoneColor PANTONE1385 {get;}
public:
static property PdfPantoneColor^ PANTONE1385 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1385 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE139 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE139 Property
Gets the Pantone 139 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE139 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE139
public static PdfPantoneColor PANTONE139 {get;}
public:
static property PdfPantoneColor^ PANTONE139 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 139 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1395 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1395 Property
Gets the Pantone 1395 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1395 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1395
public static PdfPantoneColor PANTONE1395 {get;}
public:
static property PdfPantoneColor^ PANTONE1395 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1395 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE140 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE140 Property
Gets the Pantone 140 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE140 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE140
public static PdfPantoneColor PANTONE140 {get;}
public:
static property PdfPantoneColor^ PANTONE140 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 140 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1405 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1405 Property
Gets the Pantone 1405 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1405 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1405
public static PdfPantoneColor PANTONE1405 {get;}
public:
static property PdfPantoneColor^ PANTONE1405 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1405 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE141 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE141 Property
Gets the Pantone 141 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE141 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE141
public static PdfPantoneColor PANTONE141 {get;}
public:
static property PdfPantoneColor^ PANTONE141 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 141 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE142 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE142 Property
Gets the Pantone 142 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE142 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE142
public static PdfPantoneColor PANTONE142 {get;}
public:
static property PdfPantoneColor^ PANTONE142 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 142 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE143 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE143 Property
Gets the Pantone 143 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE143 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE143
public static PdfPantoneColor PANTONE143 {get;}
public:
static property PdfPantoneColor^ PANTONE143 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 143 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE144 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE144 Property
Gets the Pantone 144 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE144 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE144
public static PdfPantoneColor PANTONE144 {get;}
public:
static property PdfPantoneColor^ PANTONE144 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 144 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE145 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE145 Property
Gets the Pantone 145 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE145 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE145
public static PdfPantoneColor PANTONE145 {get;}
public:
static property PdfPantoneColor^ PANTONE145 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 145 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE146 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE146 Property
Gets the Pantone 146 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE146 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE146
public static PdfPantoneColor PANTONE146 {get;}
public:
static property PdfPantoneColor^ PANTONE146 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 146 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE147 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE147 Property
Gets the Pantone 147 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE147 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE147
public static PdfPantoneColor PANTONE147 {get;}
public:
static property PdfPantoneColor^ PANTONE147 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 147 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE148 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE148 Property
Gets the Pantone 148 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE148 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE148
public static PdfPantoneColor PANTONE148 {get;}
public:
static property PdfPantoneColor^ PANTONE148 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 148 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1485 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1485 Property
Gets the Pantone 1485 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1485 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1485
public static PdfPantoneColor PANTONE1485 {get;}
public:
static property PdfPantoneColor^ PANTONE1485 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1485 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE149 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE149 Property
Gets the Pantone 149 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE149 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE149
public static PdfPantoneColor PANTONE149 {get;}
public:
static property PdfPantoneColor^ PANTONE149 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 149 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1495 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1495 Property
Gets the Pantone 1495 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1495 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1495
public static PdfPantoneColor PANTONE1495 {get;}
public:
static property PdfPantoneColor^ PANTONE1495 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1495 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE150 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE150 Property
Gets the Pantone 150 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE150 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE150
public static PdfPantoneColor PANTONE150 {get;}
public:
static property PdfPantoneColor^ PANTONE150 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 150 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1505 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1505 Property
Gets the Pantone 1505 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1505 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1505
public static PdfPantoneColor PANTONE1505 {get;}
public:
static property PdfPantoneColor^ PANTONE1505 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1505 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE151 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE151 Property
Gets the Pantone 151 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE151 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE151
public static PdfPantoneColor PANTONE151 {get;}
public:
static property PdfPantoneColor^ PANTONE151 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 151 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE152 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE152 Property
Gets the Pantone 152 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE152 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE152
public static PdfPantoneColor PANTONE152 {get;}
public:
static property PdfPantoneColor^ PANTONE152 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 152 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1525 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1525 Property
Gets the Pantone 1525 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1525 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1525
public static PdfPantoneColor PANTONE1525 {get;}
public:
static property PdfPantoneColor^ PANTONE1525 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1525 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE153 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE153 Property
Gets the Pantone 153 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE153 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE153
public static PdfPantoneColor PANTONE153 {get;}
public:
static property PdfPantoneColor^ PANTONE153 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 153 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1535 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1535 Property
Gets the Pantone 1535 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1535 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1535
public static PdfPantoneColor PANTONE1535 {get;}
public:
static property PdfPantoneColor^ PANTONE1535 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1535 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE154 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE154 Property
Gets the Pantone 154 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE154 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE154
public static PdfPantoneColor PANTONE154 {get;}
public:
static property PdfPantoneColor^ PANTONE154 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 154 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1545 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1545 Property
Gets the Pantone 1545 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1545 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1545
public static PdfPantoneColor PANTONE1545 {get;}
public:
static property PdfPantoneColor^ PANTONE1545 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1545 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE155 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE155 Property
Gets the Pantone 155 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE155 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE155
public static PdfPantoneColor PANTONE155 {get;}
public:
static property PdfPantoneColor^ PANTONE155 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 155 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1555 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1555 Property
Gets the Pantone 1555 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1555 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1555
public static PdfPantoneColor PANTONE1555 {get;}
public:
static property PdfPantoneColor^ PANTONE1555 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1555 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE156 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE156 Property
Gets the Pantone 156 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE156 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE156
public static PdfPantoneColor PANTONE156 {get;}
public:
static property PdfPantoneColor^ PANTONE156 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 156 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1565 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1565 Property
Gets the Pantone 1565 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1565 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1565
public static PdfPantoneColor PANTONE1565 {get;}
public:
static property PdfPantoneColor^ PANTONE1565 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1565 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE157 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE157 Property
Gets the Pantone 157 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE157 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE157
public static PdfPantoneColor PANTONE157 {get;}
public:
static property PdfPantoneColor^ PANTONE157 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 157 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1575 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1575 Property
Gets the Pantone 1575 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1575 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1575
public static PdfPantoneColor PANTONE1575 {get;}
public:
static property PdfPantoneColor^ PANTONE1575 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1575 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE158 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE158 Property
Gets the Pantone 158 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE158 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE158
public static PdfPantoneColor PANTONE158 {get;}
public:
static property PdfPantoneColor^ PANTONE158 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 158 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1585 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1585 Property
Gets the Pantone 1585 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1585 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1585
public static PdfPantoneColor PANTONE1585 {get;}
public:
static property PdfPantoneColor^ PANTONE1585 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1585 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE159 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE159 Property
Gets the Pantone 159 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE159 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE159
public static PdfPantoneColor PANTONE159 {get;}
public:
static property PdfPantoneColor^ PANTONE159 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 159 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1595 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1595 Property
Gets the Pantone 1595 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1595 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1595
public static PdfPantoneColor PANTONE1595 {get;}
public:
static property PdfPantoneColor^ PANTONE1595 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1595 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE160 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE160 Property
Gets the Pantone 160 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE160 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE160
public static PdfPantoneColor PANTONE160 {get;}
public:
static property PdfPantoneColor^ PANTONE160 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 160 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1605 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1605 Property
Gets the Pantone 1605 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1605 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1605
public static PdfPantoneColor PANTONE1605 {get;}
public:
static property PdfPantoneColor^ PANTONE1605 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1605 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE161 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE161 Property
Gets the Pantone 161 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE161 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE161
public static PdfPantoneColor PANTONE161 {get;}
public:
static property PdfPantoneColor^ PANTONE161 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 161 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1615 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1615 Property
Gets the Pantone 1615 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1615 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1615
public static PdfPantoneColor PANTONE1615 {get;}
public:
static property PdfPantoneColor^ PANTONE1615 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1615 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE162 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE162 Property
Gets the Pantone 162 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE162 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE162
public static PdfPantoneColor PANTONE162 {get;}
public:
static property PdfPantoneColor^ PANTONE162 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 162 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1625 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1625 Property
Gets the Pantone 1625 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1625 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1625
public static PdfPantoneColor PANTONE1625 {get;}
public:
static property PdfPantoneColor^ PANTONE1625 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1625 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE163 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE163 Property
Gets the Pantone 163 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE163 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE163
public static PdfPantoneColor PANTONE163 {get;}
public:
static property PdfPantoneColor^ PANTONE163 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 163 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1635 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1635 Property
Gets the Pantone 1635 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1635 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1635
public static PdfPantoneColor PANTONE1635 {get;}
public:
static property PdfPantoneColor^ PANTONE1635 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1635 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE164 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE164 Property
Gets the Pantone 164 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE164 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE164
public static PdfPantoneColor PANTONE164 {get;}
public:
static property PdfPantoneColor^ PANTONE164 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 164 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1645 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1645 Property
Gets the Pantone 1645 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1645 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1645
public static PdfPantoneColor PANTONE1645 {get;}
public:
static property PdfPantoneColor^ PANTONE1645 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1645 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE165 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE165 Property
Gets the Pantone 165 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE165 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE165
public static PdfPantoneColor PANTONE165 {get;}
public:
static property PdfPantoneColor^ PANTONE165 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 165 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1655 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1655 Property
Gets the Pantone 1655 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1655 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1655
public static PdfPantoneColor PANTONE1655 {get;}
public:
static property PdfPantoneColor^ PANTONE1655 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1655 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE166 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE166 Property
Gets the Pantone 166 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE166 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE166
public static PdfPantoneColor PANTONE166 {get;}
public:
static property PdfPantoneColor^ PANTONE166 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 166 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1665 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1665 Property
Gets the Pantone 1665 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1665 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1665
public static PdfPantoneColor PANTONE1665 {get;}
public:
static property PdfPantoneColor^ PANTONE1665 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1665 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE167 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE167 Property
Gets the Pantone 167 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE167 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE167
public static PdfPantoneColor PANTONE167 {get;}
public:
static property PdfPantoneColor^ PANTONE167 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 167 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1675 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1675 Property
Gets the Pantone 1675 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1675 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1675
public static PdfPantoneColor PANTONE1675 {get;}
public:
static property PdfPantoneColor^ PANTONE1675 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1675 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE168 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE168 Property
Gets the Pantone 168 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE168 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE168
public static PdfPantoneColor PANTONE168 {get;}
public:
static property PdfPantoneColor^ PANTONE168 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 168 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1685 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1685 Property
Gets the Pantone 1685 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1685 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1685
public static PdfPantoneColor PANTONE1685 {get;}
public:
static property PdfPantoneColor^ PANTONE1685 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1685 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE169 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE169 Property
Gets the Pantone 169 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE169 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE169
public static PdfPantoneColor PANTONE169 {get;}
public:
static property PdfPantoneColor^ PANTONE169 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 169 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE170 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE170 Property
Gets the Pantone 170 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE170 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE170
public static PdfPantoneColor PANTONE170 {get;}
public:
static property PdfPantoneColor^ PANTONE170 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 170 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE171 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE171 Property
Gets the Pantone 171 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE171 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE171
public static PdfPantoneColor PANTONE171 {get;}
public:
static property PdfPantoneColor^ PANTONE171 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 171 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE172 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE172 Property
Gets the Pantone 172 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE172 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE172
public static PdfPantoneColor PANTONE172 {get;}
public:
static property PdfPantoneColor^ PANTONE172 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 172 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE173 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE173 Property
Gets the Pantone 173 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE173 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE173
public static PdfPantoneColor PANTONE173 {get;}
public:
static property PdfPantoneColor^ PANTONE173 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 173 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE174 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE174 Property
Gets the Pantone 174 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE174 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE174
public static PdfPantoneColor PANTONE174 {get;}
public:
static property PdfPantoneColor^ PANTONE174 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 174 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE175 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE175 Property
Gets the Pantone 175 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE175 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE175
public static PdfPantoneColor PANTONE175 {get;}
public:
static property PdfPantoneColor^ PANTONE175 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 175 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE176 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE176 Property
Gets the Pantone 176 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE176 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE176
public static PdfPantoneColor PANTONE176 {get;}
public:
static property PdfPantoneColor^ PANTONE176 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 176 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1765 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1765 Property
Gets the Pantone 1765 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1765 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1765
public static PdfPantoneColor PANTONE1765 {get;}
public:
static property PdfPantoneColor^ PANTONE1765 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1765 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1767 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1767 Property
Gets the Pantone 1767 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1767 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1767
public static PdfPantoneColor PANTONE1767 {get;}
public:
static property PdfPantoneColor^ PANTONE1767 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1767 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE177 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE177 Property
Gets the Pantone 177 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE177 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE177
public static PdfPantoneColor PANTONE177 {get;}
public:
static property PdfPantoneColor^ PANTONE177 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 177 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1775 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1775 Property
Gets the Pantone 1775 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1775 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1775
public static PdfPantoneColor PANTONE1775 {get;}
public:
static property PdfPantoneColor^ PANTONE1775 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1775 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1777 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1777 Property
Gets the Pantone 1777 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1777 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1777
public static PdfPantoneColor PANTONE1777 {get;}
public:
static property PdfPantoneColor^ PANTONE1777 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1777 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE178 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE178 Property
Gets the Pantone 178 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE178 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE178
public static PdfPantoneColor PANTONE178 {get;}
public:
static property PdfPantoneColor^ PANTONE178 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 178 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1785 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1785 Property
Gets the Pantone 1785 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1785 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1785
public static PdfPantoneColor PANTONE1785 {get;}
public:
static property PdfPantoneColor^ PANTONE1785 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1785 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1787 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1787 Property
Gets the Pantone 1787 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1787 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1787
public static PdfPantoneColor PANTONE1787 {get;}
public:
static property PdfPantoneColor^ PANTONE1787 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1787 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1788 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1788 Property
Gets the Pantone 1788 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1788 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1788
public static PdfPantoneColor PANTONE1788 {get;}
public:
static property PdfPantoneColor^ PANTONE1788 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1788 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE179 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE179 Property
Gets the Pantone 179 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE179 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE179
public static PdfPantoneColor PANTONE179 {get;}
public:
static property PdfPantoneColor^ PANTONE179 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 179 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1795 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1795 Property
Gets the Pantone 1795 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1795 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1795
public static PdfPantoneColor PANTONE1795 {get;}
public:
static property PdfPantoneColor^ PANTONE1795 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1795 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1797 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1797 Property
Gets the Pantone 1797 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1797 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1797
public static PdfPantoneColor PANTONE1797 {get;}
public:
static property PdfPantoneColor^ PANTONE1797 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1797 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE180 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE180 Property
Gets the Pantone 180 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE180 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE180
public static PdfPantoneColor PANTONE180 {get;}
public:
static property PdfPantoneColor^ PANTONE180 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 180 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1805 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1805 Property
Gets the Pantone 1805 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1805 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1805
public static PdfPantoneColor PANTONE1805 {get;}
public:
static property PdfPantoneColor^ PANTONE1805 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1805 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1807 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1807 Property
Gets the Pantone 1807 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1807 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1807
public static PdfPantoneColor PANTONE1807 {get;}
public:
static property PdfPantoneColor^ PANTONE1807 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1807 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE181 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE181 Property
Gets the Pantone 181 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE181 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE181
public static PdfPantoneColor PANTONE181 {get;}
public:
static property PdfPantoneColor^ PANTONE181 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 181 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1815 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1815 Property
Gets the Pantone 1815 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1815 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1815
public static PdfPantoneColor PANTONE1815 {get;}
public:
static property PdfPantoneColor^ PANTONE1815 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1815 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1817 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1817 Property
Gets the Pantone 1817 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1817 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1817
public static PdfPantoneColor PANTONE1817 {get;}
public:
static property PdfPantoneColor^ PANTONE1817 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1817 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE182 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE182 Property
Gets the Pantone 182 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE182 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE182
public static PdfPantoneColor PANTONE182 {get;}
public:
static property PdfPantoneColor^ PANTONE182 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 182 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE183 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE183 Property
Gets the Pantone 183 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE183 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE183
public static PdfPantoneColor PANTONE183 {get;}
public:
static property PdfPantoneColor^ PANTONE183 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 183 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE184 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE184 Property
Gets the Pantone 184 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE184 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE184
public static PdfPantoneColor PANTONE184 {get;}
public:
static property PdfPantoneColor^ PANTONE184 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 184 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE185 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE185 Property
Gets the Pantone 185 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE185 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE185
public static PdfPantoneColor PANTONE185 {get;}
public:
static property PdfPantoneColor^ PANTONE185 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 185 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE186 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE186 Property
Gets the Pantone 186 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE186 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE186
public static PdfPantoneColor PANTONE186 {get;}
public:
static property PdfPantoneColor^ PANTONE186 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 186 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE187 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE187 Property
Gets the Pantone 187 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE187 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE187
public static PdfPantoneColor PANTONE187 {get;}
public:
static property PdfPantoneColor^ PANTONE187 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 187 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE188 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE188 Property
Gets the Pantone 188 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE188 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE188
public static PdfPantoneColor PANTONE188 {get;}
public:
static property PdfPantoneColor^ PANTONE188 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 188 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE189 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE189 Property
Gets the Pantone 189 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE189 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE189
public static PdfPantoneColor PANTONE189 {get;}
public:
static property PdfPantoneColor^ PANTONE189 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 189 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1895 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1895 Property
Gets the Pantone 1895 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1895 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1895
public static PdfPantoneColor PANTONE1895 {get;}
public:
static property PdfPantoneColor^ PANTONE1895 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1895 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE190 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE190 Property
Gets the Pantone 190 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE190 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE190
public static PdfPantoneColor PANTONE190 {get;}
public:
static property PdfPantoneColor^ PANTONE190 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 190 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1905 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1905 Property
Gets the Pantone 1905 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1905 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1905
public static PdfPantoneColor PANTONE1905 {get;}
public:
static property PdfPantoneColor^ PANTONE1905 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1905 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE191 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE191 Property
Gets the Pantone 191 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE191 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE191
public static PdfPantoneColor PANTONE191 {get;}
public:
static property PdfPantoneColor^ PANTONE191 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 191 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1915 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1915 Property
Gets the Pantone 1915 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1915 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1915
public static PdfPantoneColor PANTONE1915 {get;}
public:
static property PdfPantoneColor^ PANTONE1915 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1915 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE192 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE192 Property
Gets the Pantone 192 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE192 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE192
public static PdfPantoneColor PANTONE192 {get;}
public:
static property PdfPantoneColor^ PANTONE192 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 192 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1925 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1925 Property
Gets the Pantone 1925 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1925 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1925
public static PdfPantoneColor PANTONE1925 {get;}
public:
static property PdfPantoneColor^ PANTONE1925 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1925 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE193 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE193 Property
Gets the Pantone 193 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE193 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE193
public static PdfPantoneColor PANTONE193 {get;}
public:
static property PdfPantoneColor^ PANTONE193 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 193 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1935 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1935 Property
Gets the Pantone 1935 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1935 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1935
public static PdfPantoneColor PANTONE1935 {get;}
public:
static property PdfPantoneColor^ PANTONE1935 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1935 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE194 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE194 Property
Gets the Pantone 194 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE194 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE194
public static PdfPantoneColor PANTONE194 {get;}
public:
static property PdfPantoneColor^ PANTONE194 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 194 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1945 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1945 Property
Gets the Pantone 1945 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1945 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1945
public static PdfPantoneColor PANTONE1945 {get;}
public:
static property PdfPantoneColor^ PANTONE1945 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1945 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE195 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE195 Property
Gets the Pantone 195 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE195 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE195
public static PdfPantoneColor PANTONE195 {get;}
public:
static property PdfPantoneColor^ PANTONE195 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 195 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE1955 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE1955 Property
Gets the Pantone 1955 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE1955 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE1955
public static PdfPantoneColor PANTONE1955 {get;}
public:
static property PdfPantoneColor^ PANTONE1955 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 1955 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE196 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE196 Property
Gets the Pantone 196 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE196 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE196
public static PdfPantoneColor PANTONE196 {get;}
public:
static property PdfPantoneColor^ PANTONE196 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 196 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE197 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE197 Property
Gets the Pantone 197 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE197 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE197
public static PdfPantoneColor PANTONE197 {get;}
public:
static property PdfPantoneColor^ PANTONE197 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 197 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE198 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE198 Property
Gets the Pantone 198 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE198 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE198
public static PdfPantoneColor PANTONE198 {get;}
public:
static property PdfPantoneColor^ PANTONE198 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 198 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE199 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE199 Property
Gets the Pantone 199 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE199 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE199
public static PdfPantoneColor PANTONE199 {get;}
public:
static property PdfPantoneColor^ PANTONE199 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 199 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE200 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE200 Property
Gets the Pantone 200 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE200 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE200
public static PdfPantoneColor PANTONE200 {get;}
public:
static property PdfPantoneColor^ PANTONE200 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 200 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE201 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE201 Property
Gets the Pantone 201 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE201 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE201
public static PdfPantoneColor PANTONE201 {get;}
public:
static property PdfPantoneColor^ PANTONE201 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 201 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE202 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE202 Property
Gets the Pantone 202 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE202 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE202
public static PdfPantoneColor PANTONE202 {get;}
public:
static property PdfPantoneColor^ PANTONE202 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 202 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE203 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE203 Property
Gets the Pantone 203 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE203 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE203
public static PdfPantoneColor PANTONE203 {get;}
public:
static property PdfPantoneColor^ PANTONE203 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 203 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE204 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE204 Property
Gets the Pantone 204 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE204 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE204
public static PdfPantoneColor PANTONE204 {get;}
public:
static property PdfPantoneColor^ PANTONE204 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 204 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE205 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE205 Property
Gets the Pantone 205 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE205 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE205
public static PdfPantoneColor PANTONE205 {get;}
public:
static property PdfPantoneColor^ PANTONE205 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 205 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE206 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE206 Property
Gets the Pantone 206 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE206 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE206
public static PdfPantoneColor PANTONE206 {get;}
public:
static property PdfPantoneColor^ PANTONE206 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 206 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE207 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE207 Property
Gets the Pantone 207 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE207 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE207
public static PdfPantoneColor PANTONE207 {get;}
public:
static property PdfPantoneColor^ PANTONE207 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 207 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE208 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE208 Property
Gets the Pantone 208 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE208 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE208
public static PdfPantoneColor PANTONE208 {get;}
public:
static property PdfPantoneColor^ PANTONE208 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 208 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE209 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE209 Property
Gets the Pantone 209 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE209 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE209
public static PdfPantoneColor PANTONE209 {get;}
public:
static property PdfPantoneColor^ PANTONE209 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 209 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE210 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE210 Property
Gets the Pantone 210 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE210 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE210
public static PdfPantoneColor PANTONE210 {get;}
public:
static property PdfPantoneColor^ PANTONE210 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 210 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE211 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE211 Property
Gets the Pantone 211 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE211 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE211
public static PdfPantoneColor PANTONE211 {get;}
public:
static property PdfPantoneColor^ PANTONE211 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 211 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE212 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE212 Property
Gets the Pantone 212 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE212 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE212
public static PdfPantoneColor PANTONE212 {get;}
public:
static property PdfPantoneColor^ PANTONE212 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 212 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE213 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE213 Property
Gets the Pantone 213 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE213 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE213
public static PdfPantoneColor PANTONE213 {get;}
public:
static property PdfPantoneColor^ PANTONE213 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 213 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE214 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE214 Property
Gets the Pantone 214 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE214 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE214
public static PdfPantoneColor PANTONE214 {get;}
public:
static property PdfPantoneColor^ PANTONE214 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 214 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE215 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE215 Property
Gets the Pantone 215 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE215 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE215
public static PdfPantoneColor PANTONE215 {get;}
public:
static property PdfPantoneColor^ PANTONE215 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 215 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE216 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE216 Property
Gets the Pantone 216 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE216 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE216
public static PdfPantoneColor PANTONE216 {get;}
public:
static property PdfPantoneColor^ PANTONE216 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 216 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE217 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE217 Property
Gets the Pantone 217 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE217 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE217
public static PdfPantoneColor PANTONE217 {get;}
public:
static property PdfPantoneColor^ PANTONE217 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 217 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE218 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE218 Property
Gets the Pantone 218 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE218 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE218
public static PdfPantoneColor PANTONE218 {get;}
public:
static property PdfPantoneColor^ PANTONE218 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 218 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE219 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE219 Property
Gets the Pantone 219 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE219 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE219
public static PdfPantoneColor PANTONE219 {get;}
public:
static property PdfPantoneColor^ PANTONE219 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 219 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE220 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE220 Property
Gets the Pantone 220 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE220 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE220
public static PdfPantoneColor PANTONE220 {get;}
public:
static property PdfPantoneColor^ PANTONE220 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 220 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE221 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE221 Property
Gets the Pantone 221 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE221 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE221
public static PdfPantoneColor PANTONE221 {get;}
public:
static property PdfPantoneColor^ PANTONE221 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 221 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE222 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE222 Property
Gets the Pantone 222 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE222 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE222
public static PdfPantoneColor PANTONE222 {get;}
public:
static property PdfPantoneColor^ PANTONE222 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 222 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE223 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE223 Property
Gets the Pantone 223 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE223 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE223
public static PdfPantoneColor PANTONE223 {get;}
public:
static property PdfPantoneColor^ PANTONE223 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 223 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE224 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE224 Property
Gets the Pantone 224 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE224 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE224
public static PdfPantoneColor PANTONE224 {get;}
public:
static property PdfPantoneColor^ PANTONE224 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 224 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE225 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE225 Property
Gets the Pantone 225 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE225 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE225
public static PdfPantoneColor PANTONE225 {get;}
public:
static property PdfPantoneColor^ PANTONE225 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 225 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE226 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE226 Property
Gets the Pantone 226 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE226 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE226
public static PdfPantoneColor PANTONE226 {get;}
public:
static property PdfPantoneColor^ PANTONE226 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 226 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE227 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE227 Property
Gets the Pantone 227 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE227 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE227
public static PdfPantoneColor PANTONE227 {get;}
public:
static property PdfPantoneColor^ PANTONE227 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 227 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE228 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE228 Property
Gets the Pantone 228 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE228 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE228
public static PdfPantoneColor PANTONE228 {get;}
public:
static property PdfPantoneColor^ PANTONE228 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 228 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE229 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE229 Property
Gets the Pantone 229 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE229 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE229
public static PdfPantoneColor PANTONE229 {get;}
public:
static property PdfPantoneColor^ PANTONE229 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 229 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE230 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE230 Property
Gets the Pantone 230 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE230 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE230
public static PdfPantoneColor PANTONE230 {get;}
public:
static property PdfPantoneColor^ PANTONE230 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 230 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE231 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE231 Property
Gets the Pantone 231 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE231 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE231
public static PdfPantoneColor PANTONE231 {get;}
public:
static property PdfPantoneColor^ PANTONE231 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 231 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE232 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE232 Property
Gets the Pantone 232 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE232 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE232
public static PdfPantoneColor PANTONE232 {get;}
public:
static property PdfPantoneColor^ PANTONE232 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 232 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE233 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE233 Property
Gets the Pantone 233 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE233 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE233
public static PdfPantoneColor PANTONE233 {get;}
public:
static property PdfPantoneColor^ PANTONE233 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 233 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE234 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE234 Property
Gets the Pantone 234 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE234 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE234
public static PdfPantoneColor PANTONE234 {get;}
public:
static property PdfPantoneColor^ PANTONE234 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 234 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE235 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE235 Property
Gets the Pantone 235 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE235 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE235
public static PdfPantoneColor PANTONE235 {get;}
public:
static property PdfPantoneColor^ PANTONE235 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 235 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE236 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE236 Property
Gets the Pantone 236 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE236 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE236
public static PdfPantoneColor PANTONE236 {get;}
public:
static property PdfPantoneColor^ PANTONE236 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 236 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2365 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2365 Property
Gets the Pantone 2365 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2365 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2365
public static PdfPantoneColor PANTONE2365 {get;}
public:
static property PdfPantoneColor^ PANTONE2365 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2365 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE237 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE237 Property
Gets the Pantone 237 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE237 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE237
public static PdfPantoneColor PANTONE237 {get;}
public:
static property PdfPantoneColor^ PANTONE237 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 237 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2375 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2375 Property
Gets the Pantone 2375 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2375 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2375
public static PdfPantoneColor PANTONE2375 {get;}
public:
static property PdfPantoneColor^ PANTONE2375 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2375 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE238 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE238 Property
Gets the Pantone 238 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE238 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE238
public static PdfPantoneColor PANTONE238 {get;}
public:
static property PdfPantoneColor^ PANTONE238 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 238 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2385 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2385 Property
Gets the Pantone 2385 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2385 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2385
public static PdfPantoneColor PANTONE2385 {get;}
public:
static property PdfPantoneColor^ PANTONE2385 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2385 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE239 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE239 Property
Gets the Pantone 239 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE239 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE239
public static PdfPantoneColor PANTONE239 {get;}
public:
static property PdfPantoneColor^ PANTONE239 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 239 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2395 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2395 Property
Gets the Pantone 2395 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2395 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2395
public static PdfPantoneColor PANTONE2395 {get;}
public:
static property PdfPantoneColor^ PANTONE2395 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2395 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE240 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE240 Property
Gets the Pantone 240 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE240 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE240
public static PdfPantoneColor PANTONE240 {get;}
public:
static property PdfPantoneColor^ PANTONE240 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 240 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2405 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2405 Property
Gets the Pantone 2405 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2405 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2405
public static PdfPantoneColor PANTONE2405 {get;}
public:
static property PdfPantoneColor^ PANTONE2405 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2405 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE241 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE241 Property
Gets the Pantone 241 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE241 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE241
public static PdfPantoneColor PANTONE241 {get;}
public:
static property PdfPantoneColor^ PANTONE241 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 241 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2415 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2415 Property
Gets the Pantone 2415 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2415 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2415
public static PdfPantoneColor PANTONE2415 {get;}
public:
static property PdfPantoneColor^ PANTONE2415 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2415 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE242 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE242 Property
Gets the Pantone 242 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE242 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE242
public static PdfPantoneColor PANTONE242 {get;}
public:
static property PdfPantoneColor^ PANTONE242 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 242 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2425 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2425 Property
Gets the Pantone 2425 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2425 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2425
public static PdfPantoneColor PANTONE2425 {get;}
public:
static property PdfPantoneColor^ PANTONE2425 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2425 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE243 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE243 Property
Gets the Pantone 243 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE243 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE243
public static PdfPantoneColor PANTONE243 {get;}
public:
static property PdfPantoneColor^ PANTONE243 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 243 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE244 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE244 Property
Gets the Pantone 244 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE244 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE244
public static PdfPantoneColor PANTONE244 {get;}
public:
static property PdfPantoneColor^ PANTONE244 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 244 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE245 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE245 Property
Gets the Pantone 245 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE245 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE245
public static PdfPantoneColor PANTONE245 {get;}
public:
static property PdfPantoneColor^ PANTONE245 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 245 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE246 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE246 Property
Gets the Pantone 246 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE246 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE246
public static PdfPantoneColor PANTONE246 {get;}
public:
static property PdfPantoneColor^ PANTONE246 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 246 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE247 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE247 Property
Gets the Pantone 247 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE247 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE247
public static PdfPantoneColor PANTONE247 {get;}
public:
static property PdfPantoneColor^ PANTONE247 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 247 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE248 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE248 Property
Gets the Pantone 248 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE248 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE248
public static PdfPantoneColor PANTONE248 {get;}
public:
static property PdfPantoneColor^ PANTONE248 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 248 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE249 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE249 Property
Gets the Pantone 249 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE249 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE249
public static PdfPantoneColor PANTONE249 {get;}
public:
static property PdfPantoneColor^ PANTONE249 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 249 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE250 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE250 Property
Gets the Pantone 250 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE250 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE250
public static PdfPantoneColor PANTONE250 {get;}
public:
static property PdfPantoneColor^ PANTONE250 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 250 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE251 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE251 Property
Gets the Pantone 251 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE251 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE251
public static PdfPantoneColor PANTONE251 {get;}
public:
static property PdfPantoneColor^ PANTONE251 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 251 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE252 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE252 Property
Gets the Pantone 252 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE252 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE252
public static PdfPantoneColor PANTONE252 {get;}
public:
static property PdfPantoneColor^ PANTONE252 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 252 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE253 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE253 Property
Gets the Pantone 253 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE253 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE253
public static PdfPantoneColor PANTONE253 {get;}
public:
static property PdfPantoneColor^ PANTONE253 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 253 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE254 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE254 Property
Gets the Pantone 254 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE254 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE254
public static PdfPantoneColor PANTONE254 {get;}
public:
static property PdfPantoneColor^ PANTONE254 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 254 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE255 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE255 Property
Gets the Pantone 255 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE255 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE255
public static PdfPantoneColor PANTONE255 {get;}
public:
static property PdfPantoneColor^ PANTONE255 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 255 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE256 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE256 Property
Gets the Pantone 256 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE256 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE256
public static PdfPantoneColor PANTONE256 {get;}
public:
static property PdfPantoneColor^ PANTONE256 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 256 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2562 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2562 Property
Gets the Pantone 2562 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2562 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2562
public static PdfPantoneColor PANTONE2562 {get;}
public:
static property PdfPantoneColor^ PANTONE2562 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2562 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2563 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2563 Property
Gets the Pantone 2563 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2563 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2563
public static PdfPantoneColor PANTONE2563 {get;}
public:
static property PdfPantoneColor^ PANTONE2563 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2563 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2567 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2567 Property
Gets the Pantone 2567 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2567 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2567
public static PdfPantoneColor PANTONE2567 {get;}
public:
static property PdfPantoneColor^ PANTONE2567 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2567 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE257 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE257 Property
Gets the Pantone 257 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE257 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE257
public static PdfPantoneColor PANTONE257 {get;}
public:
static property PdfPantoneColor^ PANTONE257 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 257 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2572 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2572 Property
Gets the Pantone 2572 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2572 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2572
public static PdfPantoneColor PANTONE2572 {get;}
public:
static property PdfPantoneColor^ PANTONE2572 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2572 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2573 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2573 Property
Gets the Pantone 2573 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2573 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2573
public static PdfPantoneColor PANTONE2573 {get;}
public:
static property PdfPantoneColor^ PANTONE2573 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2573 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2577 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2577 Property
Gets the Pantone 2577 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2577 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2577
public static PdfPantoneColor PANTONE2577 {get;}
public:
static property PdfPantoneColor^ PANTONE2577 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2577 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE258 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE258 Property
Gets the Pantone 258 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE258 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE258
public static PdfPantoneColor PANTONE258 {get;}
public:
static property PdfPantoneColor^ PANTONE258 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 258 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2582 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2582 Property
Gets the Pantone 2582 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2582 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2582
public static PdfPantoneColor PANTONE2582 {get;}
public:
static property PdfPantoneColor^ PANTONE2582 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2582 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2583 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2583 Property
Gets the Pantone 2583 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2583 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2583
public static PdfPantoneColor PANTONE2583 {get;}
public:
static property PdfPantoneColor^ PANTONE2583 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2583 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2587 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2587 Property
Gets the Pantone 2587 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2587 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2587
public static PdfPantoneColor PANTONE2587 {get;}
public:
static property PdfPantoneColor^ PANTONE2587 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2587 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE259 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE259 Property
Gets the Pantone 259 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE259 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE259
public static PdfPantoneColor PANTONE259 {get;}
public:
static property PdfPantoneColor^ PANTONE259 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 259 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2592 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2592 Property
Gets the Pantone 2592 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2592 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2592
public static PdfPantoneColor PANTONE2592 {get;}
public:
static property PdfPantoneColor^ PANTONE2592 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2592 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2593 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2593 Property
Gets the Pantone 2593 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2593 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2593
public static PdfPantoneColor PANTONE2593 {get;}
public:
static property PdfPantoneColor^ PANTONE2593 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2593 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2597 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2597 Property
Gets the Pantone 2597 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2597 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2597
public static PdfPantoneColor PANTONE2597 {get;}
public:
static property PdfPantoneColor^ PANTONE2597 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2597 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE260 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE260 Property
Gets the Pantone 260 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE260 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE260
public static PdfPantoneColor PANTONE260 {get;}
public:
static property PdfPantoneColor^ PANTONE260 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 260 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2602 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2602 Property
Gets the Pantone 2602 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2602 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2602
public static PdfPantoneColor PANTONE2602 {get;}
public:
static property PdfPantoneColor^ PANTONE2602 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2602 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2603 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2603 Property
Gets the Pantone 2603 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2603 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2603
public static PdfPantoneColor PANTONE2603 {get;}
public:
static property PdfPantoneColor^ PANTONE2603 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2603 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2607 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2607 Property
Gets the Pantone 2607 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2607 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2607
public static PdfPantoneColor PANTONE2607 {get;}
public:
static property PdfPantoneColor^ PANTONE2607 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2607 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE261 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE261 Property
Gets the Pantone 261 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE261 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE261
public static PdfPantoneColor PANTONE261 {get;}
public:
static property PdfPantoneColor^ PANTONE261 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 261 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2612 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2612 Property
Gets the Pantone 2612 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2612 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2612
public static PdfPantoneColor PANTONE2612 {get;}
public:
static property PdfPantoneColor^ PANTONE2612 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2612 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2613 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2613 Property
Gets the Pantone 2613 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2613 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2613
public static PdfPantoneColor PANTONE2613 {get;}
public:
static property PdfPantoneColor^ PANTONE2613 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2613 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2617 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2617 Property
Gets the Pantone 2617 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2617 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2617
public static PdfPantoneColor PANTONE2617 {get;}
public:
static property PdfPantoneColor^ PANTONE2617 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2617 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE262 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE262 Property
Gets the Pantone 262 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE262 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE262
public static PdfPantoneColor PANTONE262 {get;}
public:
static property PdfPantoneColor^ PANTONE262 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 262 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2622 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2622 Property
Gets the Pantone 2622 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2622 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2622
public static PdfPantoneColor PANTONE2622 {get;}
public:
static property PdfPantoneColor^ PANTONE2622 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2622 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2623 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2623 Property
Gets the Pantone 2623 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2623 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2623
public static PdfPantoneColor PANTONE2623 {get;}
public:
static property PdfPantoneColor^ PANTONE2623 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2623 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2627 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2627 Property
Gets the Pantone 2627 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2627 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2627
public static PdfPantoneColor PANTONE2627 {get;}
public:
static property PdfPantoneColor^ PANTONE2627 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2627 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE263 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE263 Property
Gets the Pantone 263 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE263 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE263
public static PdfPantoneColor PANTONE263 {get;}
public:
static property PdfPantoneColor^ PANTONE263 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 263 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2635 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2635 Property
Gets the Pantone 2635 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2635 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2635
public static PdfPantoneColor PANTONE2635 {get;}
public:
static property PdfPantoneColor^ PANTONE2635 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2635 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE264 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE264 Property
Gets the Pantone 264 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE264 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE264
public static PdfPantoneColor PANTONE264 {get;}
public:
static property PdfPantoneColor^ PANTONE264 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 264 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2645 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2645 Property
Gets the Pantone 2645 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2645 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2645
public static PdfPantoneColor PANTONE2645 {get;}
public:
static property PdfPantoneColor^ PANTONE2645 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2645 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE265 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE265 Property
Gets the Pantone 265 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE265 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE265
public static PdfPantoneColor PANTONE265 {get;}
public:
static property PdfPantoneColor^ PANTONE265 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 265 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2655 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2655 Property
Gets the Pantone 2655 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2655 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2655
public static PdfPantoneColor PANTONE2655 {get;}
public:
static property PdfPantoneColor^ PANTONE2655 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2655 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE266 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE266 Property
Gets the Pantone 266 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE266 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE266
public static PdfPantoneColor PANTONE266 {get;}
public:
static property PdfPantoneColor^ PANTONE266 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 266 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2665 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2665 Property
Gets the Pantone 2665 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2665 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2665
public static PdfPantoneColor PANTONE2665 {get;}
public:
static property PdfPantoneColor^ PANTONE2665 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2665 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE267 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE267 Property
Gets the Pantone 267 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE267 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE267
public static PdfPantoneColor PANTONE267 {get;}
public:
static property PdfPantoneColor^ PANTONE267 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 267 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE268 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE268 Property
Gets the Pantone 268 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE268 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE268
public static PdfPantoneColor PANTONE268 {get;}
public:
static property PdfPantoneColor^ PANTONE268 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 268 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2685 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2685 Property
Gets the Pantone 2685 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2685 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2685
public static PdfPantoneColor PANTONE2685 {get;}
public:
static property PdfPantoneColor^ PANTONE2685 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2685 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE269 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE269 Property
Gets the Pantone 269 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE269 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE269
public static PdfPantoneColor PANTONE269 {get;}
public:
static property PdfPantoneColor^ PANTONE269 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 269 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2695 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2695 Property
Gets the Pantone 2695 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2695 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2695
public static PdfPantoneColor PANTONE2695 {get;}
public:
static property PdfPantoneColor^ PANTONE2695 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2695 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE270 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE270 Property
Gets the Pantone 270 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE270 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE270
public static PdfPantoneColor PANTONE270 {get;}
public:
static property PdfPantoneColor^ PANTONE270 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 270 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2705 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2705 Property
Gets the Pantone 2705 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2705 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2705
public static PdfPantoneColor PANTONE2705 {get;}
public:
static property PdfPantoneColor^ PANTONE2705 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2705 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2706 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2706 Property
Gets the Pantone 2706 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2706 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2706
public static PdfPantoneColor PANTONE2706 {get;}
public:
static property PdfPantoneColor^ PANTONE2706 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2706 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2707 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2707 Property
Gets the Pantone 2707 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2707 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2707
public static PdfPantoneColor PANTONE2707 {get;}
public:
static property PdfPantoneColor^ PANTONE2707 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2707 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2708 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2708 Property
Gets the Pantone 2708 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2708 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2708
public static PdfPantoneColor PANTONE2708 {get;}
public:
static property PdfPantoneColor^ PANTONE2708 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2708 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE271 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE271 Property
Gets the Pantone 271 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE271 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE271
public static PdfPantoneColor PANTONE271 {get;}
public:
static property PdfPantoneColor^ PANTONE271 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 271 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2715 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2715 Property
Gets the Pantone 2715 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2715 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2715
public static PdfPantoneColor PANTONE2715 {get;}
public:
static property PdfPantoneColor^ PANTONE2715 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2715 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2716 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2716 Property
Gets the Pantone 2716 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2716 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2716
public static PdfPantoneColor PANTONE2716 {get;}
public:
static property PdfPantoneColor^ PANTONE2716 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2716 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2717 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2717 Property
Gets the Pantone 2717 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2717 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2717
public static PdfPantoneColor PANTONE2717 {get;}
public:
static property PdfPantoneColor^ PANTONE2717 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2717 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2718 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2718 Property
Gets the Pantone 2718 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2718 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2718
public static PdfPantoneColor PANTONE2718 {get;}
public:
static property PdfPantoneColor^ PANTONE2718 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2718 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE272 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE272 Property
Gets the Pantone 272 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE272 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE272
public static PdfPantoneColor PANTONE272 {get;}
public:
static property PdfPantoneColor^ PANTONE272 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 272 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2725 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2725 Property
Gets the Pantone 2725 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2725 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2725
public static PdfPantoneColor PANTONE2725 {get;}
public:
static property PdfPantoneColor^ PANTONE2725 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2725 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2726 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2726 Property
Gets the Pantone 2726 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2726 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2726
public static PdfPantoneColor PANTONE2726 {get;}
public:
static property PdfPantoneColor^ PANTONE2726 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2726 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2727 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2727 Property
Gets the Pantone 2727 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2727 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2727
public static PdfPantoneColor PANTONE2727 {get;}
public:
static property PdfPantoneColor^ PANTONE2727 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2727 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2728 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2728 Property
Gets the Pantone 2728 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2728 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2728
public static PdfPantoneColor PANTONE2728 {get;}
public:
static property PdfPantoneColor^ PANTONE2728 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2728 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE273 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE273 Property
Gets the Pantone 273 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE273 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE273
public static PdfPantoneColor PANTONE273 {get;}
public:
static property PdfPantoneColor^ PANTONE273 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 273 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2735 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2735 Property
Gets the Pantone 2735 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2735 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2735
public static PdfPantoneColor PANTONE2735 {get;}
public:
static property PdfPantoneColor^ PANTONE2735 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2735 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2736 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2736 Property
Gets the Pantone 2736 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2736 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2736
public static PdfPantoneColor PANTONE2736 {get;}
public:
static property PdfPantoneColor^ PANTONE2736 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2736 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2738 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2738 Property
Gets the Pantone 2738 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2738 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2738
public static PdfPantoneColor PANTONE2738 {get;}
public:
static property PdfPantoneColor^ PANTONE2738 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2738 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE274 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE274 Property
Gets the Pantone 274 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE274 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE274
public static PdfPantoneColor PANTONE274 {get;}
public:
static property PdfPantoneColor^ PANTONE274 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 274 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2745 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2745 Property
Gets the Pantone 2745 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2745 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2745
public static PdfPantoneColor PANTONE2745 {get;}
public:
static property PdfPantoneColor^ PANTONE2745 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2745 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2746 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2746 Property
Gets the Pantone 2746 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2746 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2746
public static PdfPantoneColor PANTONE2746 {get;}
public:
static property PdfPantoneColor^ PANTONE2746 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2746 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2747 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2747 Property
Gets the Pantone 2747 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2747 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2747
public static PdfPantoneColor PANTONE2747 {get;}
public:
static property PdfPantoneColor^ PANTONE2747 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2747 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2748 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2748 Property
Gets the Pantone 2748 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2748 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2748
public static PdfPantoneColor PANTONE2748 {get;}
public:
static property PdfPantoneColor^ PANTONE2748 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2748 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE275 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE275 Property
Gets the Pantone 275 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE275 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE275
public static PdfPantoneColor PANTONE275 {get;}
public:
static property PdfPantoneColor^ PANTONE275 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 275 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2755 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2755 Property
Gets the Pantone 2755 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2755 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2755
public static PdfPantoneColor PANTONE2755 {get;}
public:
static property PdfPantoneColor^ PANTONE2755 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2755 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2756 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2756 Property
Gets the Pantone 2756 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2756 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2756
public static PdfPantoneColor PANTONE2756 {get;}
public:
static property PdfPantoneColor^ PANTONE2756 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2756 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2757 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2757 Property
Gets the Pantone 2757 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2757 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2757
public static PdfPantoneColor PANTONE2757 {get;}
public:
static property PdfPantoneColor^ PANTONE2757 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2757 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2758 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2758 Property
Gets the Pantone 2758 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2758 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2758
public static PdfPantoneColor PANTONE2758 {get;}
public:
static property PdfPantoneColor^ PANTONE2758 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2758 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE276 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE276 Property
Gets the Pantone 276 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE276 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE276
public static PdfPantoneColor PANTONE276 {get;}
public:
static property PdfPantoneColor^ PANTONE276 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 276 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2765 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2765 Property
Gets the Pantone 2765 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2765 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2765
public static PdfPantoneColor PANTONE2765 {get;}
public:
static property PdfPantoneColor^ PANTONE2765 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2765 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2766 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2766 Property
Gets the Pantone 2766 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2766 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2766
public static PdfPantoneColor PANTONE2766 {get;}
public:
static property PdfPantoneColor^ PANTONE2766 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2766 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2767 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2767 Property
Gets the Pantone 2767 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2767 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2767
public static PdfPantoneColor PANTONE2767 {get;}
public:
static property PdfPantoneColor^ PANTONE2767 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2767 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2768 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2768 Property
Gets the Pantone 2768 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2768 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2768
public static PdfPantoneColor PANTONE2768 {get;}
public:
static property PdfPantoneColor^ PANTONE2768 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2768 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE277 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE277 Property
Gets the Pantone 277 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE277 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE277
public static PdfPantoneColor PANTONE277 {get;}
public:
static property PdfPantoneColor^ PANTONE277 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 277 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE278 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE278 Property
Gets the Pantone 278 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE278 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE278
public static PdfPantoneColor PANTONE278 {get;}
public:
static property PdfPantoneColor^ PANTONE278 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 278 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE279 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE279 Property
Gets the Pantone 279 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE279 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE279
public static PdfPantoneColor PANTONE279 {get;}
public:
static property PdfPantoneColor^ PANTONE279 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 279 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE280 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE280 Property
Gets the Pantone 280 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE280 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE280
public static PdfPantoneColor PANTONE280 {get;}
public:
static property PdfPantoneColor^ PANTONE280 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 280 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE281 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE281 Property
Gets the Pantone 281 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE281 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE281
public static PdfPantoneColor PANTONE281 {get;}
public:
static property PdfPantoneColor^ PANTONE281 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 281 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE282 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE282 Property
Gets the Pantone 282 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE282 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE282
public static PdfPantoneColor PANTONE282 {get;}
public:
static property PdfPantoneColor^ PANTONE282 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 282 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE283 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE283 Property
Gets the Pantone 283 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE283 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE283
public static PdfPantoneColor PANTONE283 {get;}
public:
static property PdfPantoneColor^ PANTONE283 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 283 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE284 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE284 Property
Gets the Pantone 284 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE284 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE284
public static PdfPantoneColor PANTONE284 {get;}
public:
static property PdfPantoneColor^ PANTONE284 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 284 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE285 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE285 Property
Gets the Pantone 285 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE285 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE285
public static PdfPantoneColor PANTONE285 {get;}
public:
static property PdfPantoneColor^ PANTONE285 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 285 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE286 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE286 Property
Gets the Pantone 286 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE286 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE286
public static PdfPantoneColor PANTONE286 {get;}
public:
static property PdfPantoneColor^ PANTONE286 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 286 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE287 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE287 Property
Gets the Pantone 287 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE287 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE287
public static PdfPantoneColor PANTONE287 {get;}
public:
static property PdfPantoneColor^ PANTONE287 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 287 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE288 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE288 Property
Gets the Pantone 288 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE288 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE288
public static PdfPantoneColor PANTONE288 {get;}
public:
static property PdfPantoneColor^ PANTONE288 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 288 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE289 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE289 Property
Gets the Pantone 289 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE289 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE289
public static PdfPantoneColor PANTONE289 {get;}
public:
static property PdfPantoneColor^ PANTONE289 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 289 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE290 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE290 Property
Gets the Pantone 290 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE290 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE290
public static PdfPantoneColor PANTONE290 {get;}
public:
static property PdfPantoneColor^ PANTONE290 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 290 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2905 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2905 Property
Gets the Pantone 2905 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2905 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2905
public static PdfPantoneColor PANTONE2905 {get;}
public:
static property PdfPantoneColor^ PANTONE2905 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2905 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE291 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE291 Property
Gets the Pantone 291 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE291 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE291
public static PdfPantoneColor PANTONE291 {get;}
public:
static property PdfPantoneColor^ PANTONE291 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 291 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2915 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2915 Property
Gets the Pantone 2915 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2915 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2915
public static PdfPantoneColor PANTONE2915 {get;}
public:
static property PdfPantoneColor^ PANTONE2915 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2915 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE292 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE292 Property
Gets the Pantone 292 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE292 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE292
public static PdfPantoneColor PANTONE292 {get;}
public:
static property PdfPantoneColor^ PANTONE292 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 292 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2925 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2925 Property
Gets the Pantone 2925 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2925 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2925
public static PdfPantoneColor PANTONE2925 {get;}
public:
static property PdfPantoneColor^ PANTONE2925 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2925 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE293 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE293 Property
Gets the Pantone 293 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE293 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE293
public static PdfPantoneColor PANTONE293 {get;}
public:
static property PdfPantoneColor^ PANTONE293 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 293 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2935 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2935 Property
Gets the Pantone 2935 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2935 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2935
public static PdfPantoneColor PANTONE2935 {get;}
public:
static property PdfPantoneColor^ PANTONE2935 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2935 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE294 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE294 Property
Gets the Pantone 294 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE294 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE294
public static PdfPantoneColor PANTONE294 {get;}
public:
static property PdfPantoneColor^ PANTONE294 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 294 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2945 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2945 Property
Gets the Pantone 2945 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2945 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2945
public static PdfPantoneColor PANTONE2945 {get;}
public:
static property PdfPantoneColor^ PANTONE2945 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2945 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE295 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE295 Property
Gets the Pantone 295 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE295 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE295
public static PdfPantoneColor PANTONE295 {get;}
public:
static property PdfPantoneColor^ PANTONE295 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 295 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2955 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2955 Property
Gets the Pantone 2955 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2955 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2955
public static PdfPantoneColor PANTONE2955 {get;}
public:
static property PdfPantoneColor^ PANTONE2955 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2955 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE296 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE296 Property
Gets the Pantone 296 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE296 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE296
public static PdfPantoneColor PANTONE296 {get;}
public:
static property PdfPantoneColor^ PANTONE296 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 296 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2965 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2965 Property
Gets the Pantone 2965 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2965 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2965
public static PdfPantoneColor PANTONE2965 {get;}
public:
static property PdfPantoneColor^ PANTONE2965 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2965 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE297 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE297 Property
Gets the Pantone 297 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE297 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE297
public static PdfPantoneColor PANTONE297 {get;}
public:
static property PdfPantoneColor^ PANTONE297 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 297 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2975 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2975 Property
Gets the Pantone 2975 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2975 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2975
public static PdfPantoneColor PANTONE2975 {get;}
public:
static property PdfPantoneColor^ PANTONE2975 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2975 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE298 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE298 Property
Gets the Pantone 298 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE298 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE298
public static PdfPantoneColor PANTONE298 {get;}
public:
static property PdfPantoneColor^ PANTONE298 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 298 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2985 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2985 Property
Gets the Pantone 2985 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2985 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2985
public static PdfPantoneColor PANTONE2985 {get;}
public:
static property PdfPantoneColor^ PANTONE2985 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2985 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE299 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE299 Property
Gets the Pantone 299 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE299 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE299
public static PdfPantoneColor PANTONE299 {get;}
public:
static property PdfPantoneColor^ PANTONE299 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 299 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE2995 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE2995 Property
Gets the Pantone 2995 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE2995 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE2995
public static PdfPantoneColor PANTONE2995 {get;}
public:
static property PdfPantoneColor^ PANTONE2995 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 2995 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE300 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE300 Property
Gets the Pantone 300 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE300 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE300
public static PdfPantoneColor PANTONE300 {get;}
public:
static property PdfPantoneColor^ PANTONE300 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 300 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3005 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3005 Property
Gets the Pantone 3005 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3005 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3005
public static PdfPantoneColor PANTONE3005 {get;}
public:
static property PdfPantoneColor^ PANTONE3005 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3005 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE301 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE301 Property
Gets the Pantone 301 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE301 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE301
public static PdfPantoneColor PANTONE301 {get;}
public:
static property PdfPantoneColor^ PANTONE301 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 301 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3015 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3015 Property
Gets the Pantone 3015 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3015 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3015
public static PdfPantoneColor PANTONE3015 {get;}
public:
static property PdfPantoneColor^ PANTONE3015 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3015 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE302 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE302 Property
Gets the Pantone 302 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE302 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE302
public static PdfPantoneColor PANTONE302 {get;}
public:
static property PdfPantoneColor^ PANTONE302 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 302 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3025 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3025 Property
Gets the Pantone 3025 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3025 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3025
public static PdfPantoneColor PANTONE3025 {get;}
public:
static property PdfPantoneColor^ PANTONE3025 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3025 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE303 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE303 Property
Gets the Pantone 303 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE303 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE303
public static PdfPantoneColor PANTONE303 {get;}
public:
static property PdfPantoneColor^ PANTONE303 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 303 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3035 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3035 Property
Gets the Pantone 3035 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3035 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3035
public static PdfPantoneColor PANTONE3035 {get;}
public:
static property PdfPantoneColor^ PANTONE3035 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3035 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE304 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE304 Property
Gets the Pantone 304 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE304 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE304
public static PdfPantoneColor PANTONE304 {get;}
public:
static property PdfPantoneColor^ PANTONE304 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 304 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE305 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE305 Property
Gets the Pantone 305 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE305 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE305
public static PdfPantoneColor PANTONE305 {get;}
public:
static property PdfPantoneColor^ PANTONE305 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 305 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE306 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE306 Property
Gets the Pantone 306 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE306 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE306
public static PdfPantoneColor PANTONE306 {get;}
public:
static property PdfPantoneColor^ PANTONE306 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 306 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE307 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE307 Property
Gets the Pantone 307 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE307 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE307
public static PdfPantoneColor PANTONE307 {get;}
public:
static property PdfPantoneColor^ PANTONE307 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 307 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE308 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE308 Property
Gets the Pantone 308 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE308 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE308
public static PdfPantoneColor PANTONE308 {get;}
public:
static property PdfPantoneColor^ PANTONE308 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 308 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE309 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE309 Property
Gets the Pantone 309 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE309 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE309
public static PdfPantoneColor PANTONE309 {get;}
public:
static property PdfPantoneColor^ PANTONE309 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 309 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE310 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE310 Property
Gets the Pantone 310 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE310 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE310
public static PdfPantoneColor PANTONE310 {get;}
public:
static property PdfPantoneColor^ PANTONE310 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 310 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3105 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3105 Property
Gets the Pantone 3105 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3105 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3105
public static PdfPantoneColor PANTONE3105 {get;}
public:
static property PdfPantoneColor^ PANTONE3105 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3105 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE311 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE311 Property
Gets the Pantone 311 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE311 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE311
public static PdfPantoneColor PANTONE311 {get;}
public:
static property PdfPantoneColor^ PANTONE311 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 311 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3115 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3115 Property
Gets the Pantone 3115 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3115 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3115
public static PdfPantoneColor PANTONE3115 {get;}
public:
static property PdfPantoneColor^ PANTONE3115 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3115 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE312 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE312 Property
Gets the Pantone 312 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE312 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE312
public static PdfPantoneColor PANTONE312 {get;}
public:
static property PdfPantoneColor^ PANTONE312 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 312 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3125 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3125 Property
Gets the Pantone 3125 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3125 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3125
public static PdfPantoneColor PANTONE3125 {get;}
public:
static property PdfPantoneColor^ PANTONE3125 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3125 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE313 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE313 Property
Gets the Pantone 313 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE313 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE313
public static PdfPantoneColor PANTONE313 {get;}
public:
static property PdfPantoneColor^ PANTONE313 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 313 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3135 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3135 Property
Gets the Pantone 3135 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3135 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3135
public static PdfPantoneColor PANTONE3135 {get;}
public:
static property PdfPantoneColor^ PANTONE3135 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3135 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE314 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE314 Property
Gets the Pantone 314 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE314 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE314
public static PdfPantoneColor PANTONE314 {get;}
public:
static property PdfPantoneColor^ PANTONE314 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 314 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3145 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3145 Property
Gets the Pantone 3145 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3145 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3145
public static PdfPantoneColor PANTONE3145 {get;}
public:
static property PdfPantoneColor^ PANTONE3145 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3145 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE315 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE315 Property
Gets the Pantone 315 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE315 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE315
public static PdfPantoneColor PANTONE315 {get;}
public:
static property PdfPantoneColor^ PANTONE315 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 315 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3155 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3155 Property
Gets the Pantone 3155 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3155 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3155
public static PdfPantoneColor PANTONE3155 {get;}
public:
static property PdfPantoneColor^ PANTONE3155 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3155 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE316 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE316 Property
Gets the Pantone 316 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE316 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE316
public static PdfPantoneColor PANTONE316 {get;}
public:
static property PdfPantoneColor^ PANTONE316 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 316 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3165 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3165 Property
Gets the Pantone 3165 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3165 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3165
public static PdfPantoneColor PANTONE3165 {get;}
public:
static property PdfPantoneColor^ PANTONE3165 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3165 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE317 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE317 Property
Gets the Pantone 317 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE317 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE317
public static PdfPantoneColor PANTONE317 {get;}
public:
static property PdfPantoneColor^ PANTONE317 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 317 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE318 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE318 Property
Gets the Pantone 318 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE318 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE318
public static PdfPantoneColor PANTONE318 {get;}
public:
static property PdfPantoneColor^ PANTONE318 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 318 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE319 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE319 Property
Gets the Pantone 319 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE319 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE319
public static PdfPantoneColor PANTONE319 {get;}
public:
static property PdfPantoneColor^ PANTONE319 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 319 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE320 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE320 Property
Gets the Pantone 320 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE320 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE320
public static PdfPantoneColor PANTONE320 {get;}
public:
static property PdfPantoneColor^ PANTONE320 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 320 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE321 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE321 Property
Gets the Pantone 321 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE321 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE321
public static PdfPantoneColor PANTONE321 {get;}
public:
static property PdfPantoneColor^ PANTONE321 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 321 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE322 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE322 Property
Gets the Pantone 322 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE322 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE322
public static PdfPantoneColor PANTONE322 {get;}
public:
static property PdfPantoneColor^ PANTONE322 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 322 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE323 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE323 Property
Gets the Pantone 323 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE323 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE323
public static PdfPantoneColor PANTONE323 {get;}
public:
static property PdfPantoneColor^ PANTONE323 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 323 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE324 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE324 Property
Gets the Pantone 324 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE324 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE324
public static PdfPantoneColor PANTONE324 {get;}
public:
static property PdfPantoneColor^ PANTONE324 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 324 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3242 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3242 Property
Gets the Pantone 3242 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3242 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3242
public static PdfPantoneColor PANTONE3242 {get;}
public:
static property PdfPantoneColor^ PANTONE3242 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3242 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3245 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3245 Property
Gets the Pantone 3245 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3245 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3245
public static PdfPantoneColor PANTONE3245 {get;}
public:
static property PdfPantoneColor^ PANTONE3245 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3245 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3248 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3248 Property
Gets the Pantone 3248 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3248 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3248
public static PdfPantoneColor PANTONE3248 {get;}
public:
static property PdfPantoneColor^ PANTONE3248 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3248 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE325 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE325 Property
Gets the Pantone 325 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE325 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE325
public static PdfPantoneColor PANTONE325 {get;}
public:
static property PdfPantoneColor^ PANTONE325 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 325 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3252 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3252 Property
Gets the Pantone 3252 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3252 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3252
public static PdfPantoneColor PANTONE3252 {get;}
public:
static property PdfPantoneColor^ PANTONE3252 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3252 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3255 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3255 Property
Gets the Pantone 3255 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3255 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3255
public static PdfPantoneColor PANTONE3255 {get;}
public:
static property PdfPantoneColor^ PANTONE3255 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3255 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3258 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3258 Property
Gets the Pantone 3258 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3258 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3258
public static PdfPantoneColor PANTONE3258 {get;}
public:
static property PdfPantoneColor^ PANTONE3258 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3258 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE326 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE326 Property
Gets the Pantone 326 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE326 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE326
public static PdfPantoneColor PANTONE326 {get;}
public:
static property PdfPantoneColor^ PANTONE326 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 326 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3262 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3262 Property
Gets the Pantone 3262 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3262 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3262
public static PdfPantoneColor PANTONE3262 {get;}
public:
static property PdfPantoneColor^ PANTONE3262 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3262 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3265 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3265 Property
Gets the Pantone 3265 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3265 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3265
public static PdfPantoneColor PANTONE3265 {get;}
public:
static property PdfPantoneColor^ PANTONE3265 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3265 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3268 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3268 Property
Gets the Pantone 3268 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3268 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3268
public static PdfPantoneColor PANTONE3268 {get;}
public:
static property PdfPantoneColor^ PANTONE3268 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3268 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE327 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE327 Property
Gets the Pantone 327 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE327 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE327
public static PdfPantoneColor PANTONE327 {get;}
public:
static property PdfPantoneColor^ PANTONE327 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 327 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3272 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3272 Property
Gets the Pantone 3272 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3272 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3272
public static PdfPantoneColor PANTONE3272 {get;}
public:
static property PdfPantoneColor^ PANTONE3272 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3272 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3275 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3275 Property
Gets the Pantone 3275 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3275 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3275
public static PdfPantoneColor PANTONE3275 {get;}
public:
static property PdfPantoneColor^ PANTONE3275 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3275 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3278 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3278 Property
Gets the Pantone 3278 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3278 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3278
public static PdfPantoneColor PANTONE3278 {get;}
public:
static property PdfPantoneColor^ PANTONE3278 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3278 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE328 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE328 Property
Gets the Pantone 328 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE328 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE328
public static PdfPantoneColor PANTONE328 {get;}
public:
static property PdfPantoneColor^ PANTONE328 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 328 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3282 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3282 Property
Gets the Pantone 3282 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3282 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3282
public static PdfPantoneColor PANTONE3282 {get;}
public:
static property PdfPantoneColor^ PANTONE3282 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3282 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3285 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3285 Property
Gets the Pantone 3285 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3285 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3285
public static PdfPantoneColor PANTONE3285 {get;}
public:
static property PdfPantoneColor^ PANTONE3285 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3285 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3288 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3288 Property
Gets the Pantone 3288 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3288 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3288
public static PdfPantoneColor PANTONE3288 {get;}
public:
static property PdfPantoneColor^ PANTONE3288 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3288 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE329 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE329 Property
Gets the Pantone 329 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE329 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE329
public static PdfPantoneColor PANTONE329 {get;}
public:
static property PdfPantoneColor^ PANTONE329 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 329 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3292 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3292 Property
Gets the Pantone 3292 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3292 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3292
public static PdfPantoneColor PANTONE3292 {get;}
public:
static property PdfPantoneColor^ PANTONE3292 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3292 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3295 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3295 Property
Gets the Pantone 3295 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3295 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3295
public static PdfPantoneColor PANTONE3295 {get;}
public:
static property PdfPantoneColor^ PANTONE3295 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3295 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3298 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3298 Property
Gets the Pantone 3298 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3298 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3298
public static PdfPantoneColor PANTONE3298 {get;}
public:
static property PdfPantoneColor^ PANTONE3298 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3298 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE330 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE330 Property
Gets the Pantone 330 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE330 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE330
public static PdfPantoneColor PANTONE330 {get;}
public:
static property PdfPantoneColor^ PANTONE330 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 330 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3302 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3302 Property
Gets the Pantone 3302 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3302 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3302
public static PdfPantoneColor PANTONE3302 {get;}
public:
static property PdfPantoneColor^ PANTONE3302 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3302 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3305 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3305 Property
Gets the Pantone 3305 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3305 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3305
public static PdfPantoneColor PANTONE3305 {get;}
public:
static property PdfPantoneColor^ PANTONE3305 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3305 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3308 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3308 Property
Gets the Pantone 3308 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3308 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3308
public static PdfPantoneColor PANTONE3308 {get;}
public:
static property PdfPantoneColor^ PANTONE3308 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3308 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE331 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE331 Property
Gets the Pantone 331 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE331 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE331
public static PdfPantoneColor PANTONE331 {get;}
public:
static property PdfPantoneColor^ PANTONE331 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 331 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE332 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE332 Property
Gets the Pantone 332 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE332 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE332
public static PdfPantoneColor PANTONE332 {get;}
public:
static property PdfPantoneColor^ PANTONE332 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 332 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE333 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE333 Property
Gets the Pantone 333 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE333 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE333
public static PdfPantoneColor PANTONE333 {get;}
public:
static property PdfPantoneColor^ PANTONE333 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 333 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE334 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE334 Property
Gets the Pantone 334 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE334 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE334
public static PdfPantoneColor PANTONE334 {get;}
public:
static property PdfPantoneColor^ PANTONE334 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 334 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE335 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE335 Property
Gets the Pantone 335 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE335 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE335
public static PdfPantoneColor PANTONE335 {get;}
public:
static property PdfPantoneColor^ PANTONE335 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 335 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE336 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE336 Property
Gets the Pantone 336 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE336 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE336
public static PdfPantoneColor PANTONE336 {get;}
public:
static property PdfPantoneColor^ PANTONE336 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 336 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE337 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE337 Property
Gets the Pantone 337 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE337 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE337
public static PdfPantoneColor PANTONE337 {get;}
public:
static property PdfPantoneColor^ PANTONE337 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 337 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3375 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3375 Property
Gets the Pantone 3375 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3375 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3375
public static PdfPantoneColor PANTONE3375 {get;}
public:
static property PdfPantoneColor^ PANTONE3375 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3375 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE338 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE338 Property
Gets the Pantone 338 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE338 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE338
public static PdfPantoneColor PANTONE338 {get;}
public:
static property PdfPantoneColor^ PANTONE338 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 338 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3385 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3385 Property
Gets the Pantone 3385 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3385 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3385
public static PdfPantoneColor PANTONE3385 {get;}
public:
static property PdfPantoneColor^ PANTONE3385 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3385 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE339 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE339 Property
Gets the Pantone 339 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE339 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE339
public static PdfPantoneColor PANTONE339 {get;}
public:
static property PdfPantoneColor^ PANTONE339 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 339 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3395 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3395 Property
Gets the Pantone 3395 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3395 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3395
public static PdfPantoneColor PANTONE3395 {get;}
public:
static property PdfPantoneColor^ PANTONE3395 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3395 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE340 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE340 Property
Gets the Pantone 340 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE340 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE340
public static PdfPantoneColor PANTONE340 {get;}
public:
static property PdfPantoneColor^ PANTONE340 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 340 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3405 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3405 Property
Gets the Pantone 3405 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3405 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3405
public static PdfPantoneColor PANTONE3405 {get;}
public:
static property PdfPantoneColor^ PANTONE3405 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3405 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE341 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE341 Property
Gets the Pantone 341 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE341 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE341
public static PdfPantoneColor PANTONE341 {get;}
public:
static property PdfPantoneColor^ PANTONE341 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 341 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3415 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3415 Property
Gets the Pantone 3415 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3415 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3415
public static PdfPantoneColor PANTONE3415 {get;}
public:
static property PdfPantoneColor^ PANTONE3415 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3415 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE342 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE342 Property
Gets the Pantone 342 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE342 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE342
public static PdfPantoneColor PANTONE342 {get;}
public:
static property PdfPantoneColor^ PANTONE342 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 342 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3425 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3425 Property
Gets the Pantone 3425 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3425 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3425
public static PdfPantoneColor PANTONE3425 {get;}
public:
static property PdfPantoneColor^ PANTONE3425 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3425 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE343 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE343 Property
Gets the Pantone 343 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE343 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE343
public static PdfPantoneColor PANTONE343 {get;}
public:
static property PdfPantoneColor^ PANTONE343 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 343 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3435 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3435 Property
Gets the Pantone 3435 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3435 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3435
public static PdfPantoneColor PANTONE3435 {get;}
public:
static property PdfPantoneColor^ PANTONE3435 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3435 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE344 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE344 Property
Gets the Pantone 344 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE344 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE344
public static PdfPantoneColor PANTONE344 {get;}
public:
static property PdfPantoneColor^ PANTONE344 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 344 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE345 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE345 Property
Gets the Pantone 345 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE345 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE345
public static PdfPantoneColor PANTONE345 {get;}
public:
static property PdfPantoneColor^ PANTONE345 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 345 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE346 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE346 Property
Gets the Pantone 346 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE346 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE346
public static PdfPantoneColor PANTONE346 {get;}
public:
static property PdfPantoneColor^ PANTONE346 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 346 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE347 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE347 Property
Gets the Pantone 347 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE347 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE347
public static PdfPantoneColor PANTONE347 {get;}
public:
static property PdfPantoneColor^ PANTONE347 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 347 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE348 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE348 Property
Gets the Pantone 348 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE348 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE348
public static PdfPantoneColor PANTONE348 {get;}
public:
static property PdfPantoneColor^ PANTONE348 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 348 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE349 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE349 Property
Gets the Pantone 349 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE349 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE349
public static PdfPantoneColor PANTONE349 {get;}
public:
static property PdfPantoneColor^ PANTONE349 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 349 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE350 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE350 Property
Gets the Pantone 350 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE350 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE350
public static PdfPantoneColor PANTONE350 {get;}
public:
static property PdfPantoneColor^ PANTONE350 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 350 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE351 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE351 Property
Gets the Pantone 351 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE351 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE351
public static PdfPantoneColor PANTONE351 {get;}
public:
static property PdfPantoneColor^ PANTONE351 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 351 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE352 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE352 Property
Gets the Pantone 352 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE352 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE352
public static PdfPantoneColor PANTONE352 {get;}
public:
static property PdfPantoneColor^ PANTONE352 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 352 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE353 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE353 Property
Gets the Pantone 353 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE353 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE353
public static PdfPantoneColor PANTONE353 {get;}
public:
static property PdfPantoneColor^ PANTONE353 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 353 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE354 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE354 Property
Gets the Pantone 354 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE354 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE354
public static PdfPantoneColor PANTONE354 {get;}
public:
static property PdfPantoneColor^ PANTONE354 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 354 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE355 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE355 Property
Gets the Pantone 355 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE355 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE355
public static PdfPantoneColor PANTONE355 {get;}
public:
static property PdfPantoneColor^ PANTONE355 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 355 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE356 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE356 Property
Gets the Pantone 356 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE356 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE356
public static PdfPantoneColor PANTONE356 {get;}
public:
static property PdfPantoneColor^ PANTONE356 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 356 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE357 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE357 Property
Gets the Pantone 357 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE357 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE357
public static PdfPantoneColor PANTONE357 {get;}
public:
static property PdfPantoneColor^ PANTONE357 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 357 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE358 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE358 Property
Gets the Pantone 358 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE358 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE358
public static PdfPantoneColor PANTONE358 {get;}
public:
static property PdfPantoneColor^ PANTONE358 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 358 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE359 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE359 Property
Gets the Pantone 359 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE359 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE359
public static PdfPantoneColor PANTONE359 {get;}
public:
static property PdfPantoneColor^ PANTONE359 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 359 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE360 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE360 Property
Gets the Pantone 360 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE360 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE360
public static PdfPantoneColor PANTONE360 {get;}
public:
static property PdfPantoneColor^ PANTONE360 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 360 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE361 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE361 Property
Gets the Pantone 361 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE361 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE361
public static PdfPantoneColor PANTONE361 {get;}
public:
static property PdfPantoneColor^ PANTONE361 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 361 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE362 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE362 Property
Gets the Pantone 362 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE362 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE362
public static PdfPantoneColor PANTONE362 {get;}
public:
static property PdfPantoneColor^ PANTONE362 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 362 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE363 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE363 Property
Gets the Pantone 363 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE363 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE363
public static PdfPantoneColor PANTONE363 {get;}
public:
static property PdfPantoneColor^ PANTONE363 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 363 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE364 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE364 Property
Gets the Pantone 364 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE364 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE364
public static PdfPantoneColor PANTONE364 {get;}
public:
static property PdfPantoneColor^ PANTONE364 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 364 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE365 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE365 Property
Gets the Pantone 365 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE365 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE365
public static PdfPantoneColor PANTONE365 {get;}
public:
static property PdfPantoneColor^ PANTONE365 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 365 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE366 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE366 Property
Gets the Pantone 366 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE366 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE366
public static PdfPantoneColor PANTONE366 {get;}
public:
static property PdfPantoneColor^ PANTONE366 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 366 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE367 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE367 Property
Gets the Pantone 367 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE367 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE367
public static PdfPantoneColor PANTONE367 {get;}
public:
static property PdfPantoneColor^ PANTONE367 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 367 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE368 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE368 Property
Gets the Pantone 368 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE368 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE368
public static PdfPantoneColor PANTONE368 {get;}
public:
static property PdfPantoneColor^ PANTONE368 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 368 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE369 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE369 Property
Gets the Pantone 369 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE369 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE369
public static PdfPantoneColor PANTONE369 {get;}
public:
static property PdfPantoneColor^ PANTONE369 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 369 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE370 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE370 Property
Gets the Pantone 370 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE370 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE370
public static PdfPantoneColor PANTONE370 {get;}
public:
static property PdfPantoneColor^ PANTONE370 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 370 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE371 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE371 Property
Gets the Pantone 371 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE371 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE371
public static PdfPantoneColor PANTONE371 {get;}
public:
static property PdfPantoneColor^ PANTONE371 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 371 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE372 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE372 Property
Gets the Pantone 372 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE372 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE372
public static PdfPantoneColor PANTONE372 {get;}
public:
static property PdfPantoneColor^ PANTONE372 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 372 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE373 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE373 Property
Gets the Pantone 373 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE373 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE373
public static PdfPantoneColor PANTONE373 {get;}
public:
static property PdfPantoneColor^ PANTONE373 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 373 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE374 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE374 Property
Gets the Pantone 374 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE374 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE374
public static PdfPantoneColor PANTONE374 {get;}
public:
static property PdfPantoneColor^ PANTONE374 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 374 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE375 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE375 Property
Gets the Pantone 375 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE375 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE375
public static PdfPantoneColor PANTONE375 {get;}
public:
static property PdfPantoneColor^ PANTONE375 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 375 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE376 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE376 Property
Gets the Pantone 376 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE376 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE376
public static PdfPantoneColor PANTONE376 {get;}
public:
static property PdfPantoneColor^ PANTONE376 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 376 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE377 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE377 Property
Gets the Pantone 377 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE377 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE377
public static PdfPantoneColor PANTONE377 {get;}
public:
static property PdfPantoneColor^ PANTONE377 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 377 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE378 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE378 Property
Gets the Pantone 378 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE378 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE378
public static PdfPantoneColor PANTONE378 {get;}
public:
static property PdfPantoneColor^ PANTONE378 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 378 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE379 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE379 Property
Gets the Pantone 379 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE379 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE379
public static PdfPantoneColor PANTONE379 {get;}
public:
static property PdfPantoneColor^ PANTONE379 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 379 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE380 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE380 Property
Gets the Pantone 380 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE380 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE380
public static PdfPantoneColor PANTONE380 {get;}
public:
static property PdfPantoneColor^ PANTONE380 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 380 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE381 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE381 Property
Gets the Pantone 381 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE381 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE381
public static PdfPantoneColor PANTONE381 {get;}
public:
static property PdfPantoneColor^ PANTONE381 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 381 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE382 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE382 Property
Gets the Pantone 382 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE382 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE382
public static PdfPantoneColor PANTONE382 {get;}
public:
static property PdfPantoneColor^ PANTONE382 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 382 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE383 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE383 Property
Gets the Pantone 383 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE383 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE383
public static PdfPantoneColor PANTONE383 {get;}
public:
static property PdfPantoneColor^ PANTONE383 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 383 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE384 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE384 Property
Gets the Pantone 384 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE384 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE384
public static PdfPantoneColor PANTONE384 {get;}
public:
static property PdfPantoneColor^ PANTONE384 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 384 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE385 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE385 Property
Gets the Pantone 385 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE385 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE385
public static PdfPantoneColor PANTONE385 {get;}
public:
static property PdfPantoneColor^ PANTONE385 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 385 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE386 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE386 Property
Gets the Pantone 386 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE386 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE386
public static PdfPantoneColor PANTONE386 {get;}
public:
static property PdfPantoneColor^ PANTONE386 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 386 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE387 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE387 Property
Gets the Pantone 387 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE387 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE387
public static PdfPantoneColor PANTONE387 {get;}
public:
static property PdfPantoneColor^ PANTONE387 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 387 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE388 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE388 Property
Gets the Pantone 388 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE388 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE388
public static PdfPantoneColor PANTONE388 {get;}
public:
static property PdfPantoneColor^ PANTONE388 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 388 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE389 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE389 Property
Gets the Pantone 389 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE389 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE389
public static PdfPantoneColor PANTONE389 {get;}
public:
static property PdfPantoneColor^ PANTONE389 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 389 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE390 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE390 Property
Gets the Pantone 390 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE390 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE390
public static PdfPantoneColor PANTONE390 {get;}
public:
static property PdfPantoneColor^ PANTONE390 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 390 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE391 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE391 Property
Gets the Pantone 391 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE391 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE391
public static PdfPantoneColor PANTONE391 {get;}
public:
static property PdfPantoneColor^ PANTONE391 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 391 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE392 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE392 Property
Gets the Pantone 392 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE392 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE392
public static PdfPantoneColor PANTONE392 {get;}
public:
static property PdfPantoneColor^ PANTONE392 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 392 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE393 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE393 Property
Gets the Pantone 393 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE393 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE393
public static PdfPantoneColor PANTONE393 {get;}
public:
static property PdfPantoneColor^ PANTONE393 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 393 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3935 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3935 Property
Gets the Pantone 3935 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3935 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3935
public static PdfPantoneColor PANTONE3935 {get;}
public:
static property PdfPantoneColor^ PANTONE3935 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3935 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE394 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE394 Property
Gets the Pantone 394 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE394 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE394
public static PdfPantoneColor PANTONE394 {get;}
public:
static property PdfPantoneColor^ PANTONE394 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 394 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3945 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3945 Property
Gets the Pantone 3945 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3945 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3945
public static PdfPantoneColor PANTONE3945 {get;}
public:
static property PdfPantoneColor^ PANTONE3945 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3945 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE395 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE395 Property
Gets the Pantone 395 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE395 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE395
public static PdfPantoneColor PANTONE395 {get;}
public:
static property PdfPantoneColor^ PANTONE395 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 395 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3955 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3955 Property
Gets the Pantone 3955 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3955 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3955
public static PdfPantoneColor PANTONE3955 {get;}
public:
static property PdfPantoneColor^ PANTONE3955 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3955 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE396 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE396 Property
Gets the Pantone 396 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE396 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE396
public static PdfPantoneColor PANTONE396 {get;}
public:
static property PdfPantoneColor^ PANTONE396 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 396 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3965 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3965 Property
Gets the Pantone 3965 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3965 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3965
public static PdfPantoneColor PANTONE3965 {get;}
public:
static property PdfPantoneColor^ PANTONE3965 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3965 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE397 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE397 Property
Gets the Pantone 397 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE397 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE397
public static PdfPantoneColor PANTONE397 {get;}
public:
static property PdfPantoneColor^ PANTONE397 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 397 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3975 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3975 Property
Gets the Pantone 3975 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3975 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3975
public static PdfPantoneColor PANTONE3975 {get;}
public:
static property PdfPantoneColor^ PANTONE3975 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3975 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE398 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE398 Property
Gets the Pantone 398 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE398 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE398
public static PdfPantoneColor PANTONE398 {get;}
public:
static property PdfPantoneColor^ PANTONE398 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 398 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3985 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3985 Property
Gets the Pantone 3985 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3985 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3985
public static PdfPantoneColor PANTONE3985 {get;}
public:
static property PdfPantoneColor^ PANTONE3985 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3985 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE399 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE399 Property
Gets the Pantone 399 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE399 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE399
public static PdfPantoneColor PANTONE399 {get;}
public:
static property PdfPantoneColor^ PANTONE399 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 399 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE3995 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE3995 Property
Gets the Pantone 3995 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE3995 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE3995
public static PdfPantoneColor PANTONE3995 {get;}
public:
static property PdfPantoneColor^ PANTONE3995 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 3995 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE400 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE400 Property
Gets the Pantone 400 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE400 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE400
public static PdfPantoneColor PANTONE400 {get;}
public:
static property PdfPantoneColor^ PANTONE400 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 400 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE401 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE401 Property
Gets the Pantone 401 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE401 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE401
public static PdfPantoneColor PANTONE401 {get;}
public:
static property PdfPantoneColor^ PANTONE401 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 401 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE402 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE402 Property
Gets the Pantone 402 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE402 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE402
public static PdfPantoneColor PANTONE402 {get;}
public:
static property PdfPantoneColor^ PANTONE402 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 402 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE403 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE403 Property
Gets the Pantone 403 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE403 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE403
public static PdfPantoneColor PANTONE403 {get;}
public:
static property PdfPantoneColor^ PANTONE403 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 403 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE404 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE404 Property
Gets the Pantone 404 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE404 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE404
public static PdfPantoneColor PANTONE404 {get;}
public:
static property PdfPantoneColor^ PANTONE404 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 404 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE405 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE405 Property
Gets the Pantone 405 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE405 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE405
public static PdfPantoneColor PANTONE405 {get;}
public:
static property PdfPantoneColor^ PANTONE405 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 405 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE406 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE406 Property
Gets the Pantone 406 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE406 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE406
public static PdfPantoneColor PANTONE406 {get;}
public:
static property PdfPantoneColor^ PANTONE406 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 406 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE407 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE407 Property
Gets the Pantone 407 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE407 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE407
public static PdfPantoneColor PANTONE407 {get;}
public:
static property PdfPantoneColor^ PANTONE407 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 407 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE408 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE408 Property
Gets the Pantone 408 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE408 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE408
public static PdfPantoneColor PANTONE408 {get;}
public:
static property PdfPantoneColor^ PANTONE408 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 408 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE409 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE409 Property
Gets the Pantone 409 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE409 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE409
public static PdfPantoneColor PANTONE409 {get;}
public:
static property PdfPantoneColor^ PANTONE409 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 409 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE410 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE410 Property
Gets the Pantone 410 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE410 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE410
public static PdfPantoneColor PANTONE410 {get;}
public:
static property PdfPantoneColor^ PANTONE410 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 410 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE411 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE411 Property
Gets the Pantone 411 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE411 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE411
public static PdfPantoneColor PANTONE411 {get;}
public:
static property PdfPantoneColor^ PANTONE411 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 411 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE412 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE412 Property
Gets the Pantone 412 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE412 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE412
public static PdfPantoneColor PANTONE412 {get;}
public:
static property PdfPantoneColor^ PANTONE412 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 412 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE413 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE413 Property
Gets the Pantone 413 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE413 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE413
public static PdfPantoneColor PANTONE413 {get;}
public:
static property PdfPantoneColor^ PANTONE413 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 413 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE414 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE414 Property
Gets the Pantone 414 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE414 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE414
public static PdfPantoneColor PANTONE414 {get;}
public:
static property PdfPantoneColor^ PANTONE414 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 414 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE415 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE415 Property
Gets the Pantone 415 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE415 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE415
public static PdfPantoneColor PANTONE415 {get;}
public:
static property PdfPantoneColor^ PANTONE415 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 415 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE416 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE416 Property
Gets the Pantone 416 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE416 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE416
public static PdfPantoneColor PANTONE416 {get;}
public:
static property PdfPantoneColor^ PANTONE416 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 416 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE417 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE417 Property
Gets the Pantone 417 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE417 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE417
public static PdfPantoneColor PANTONE417 {get;}
public:
static property PdfPantoneColor^ PANTONE417 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 417 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE418 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE418 Property
Gets the Pantone 418 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE418 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE418
public static PdfPantoneColor PANTONE418 {get;}
public:
static property PdfPantoneColor^ PANTONE418 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 418 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE419 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE419 Property
Gets the Pantone 419 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE419 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE419
public static PdfPantoneColor PANTONE419 {get;}
public:
static property PdfPantoneColor^ PANTONE419 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 419 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE420 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE420 Property
Gets the Pantone 420 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE420 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE420
public static PdfPantoneColor PANTONE420 {get;}
public:
static property PdfPantoneColor^ PANTONE420 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 420 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE421 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE421 Property
Gets the Pantone 421 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE421 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE421
public static PdfPantoneColor PANTONE421 {get;}
public:
static property PdfPantoneColor^ PANTONE421 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 421 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE422 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE422 Property
Gets the Pantone 422 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE422 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE422
public static PdfPantoneColor PANTONE422 {get;}
public:
static property PdfPantoneColor^ PANTONE422 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 422 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE423 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE423 Property
Gets the Pantone 423 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE423 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE423
public static PdfPantoneColor PANTONE423 {get;}
public:
static property PdfPantoneColor^ PANTONE423 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 423 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE424 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE424 Property
Gets the Pantone 424 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE424 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE424
public static PdfPantoneColor PANTONE424 {get;}
public:
static property PdfPantoneColor^ PANTONE424 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 424 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE425 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE425 Property
Gets the Pantone 425 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE425 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE425
public static PdfPantoneColor PANTONE425 {get;}
public:
static property PdfPantoneColor^ PANTONE425 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 425 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE426 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE426 Property
Gets the Pantone 426 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE426 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE426
public static PdfPantoneColor PANTONE426 {get;}
public:
static property PdfPantoneColor^ PANTONE426 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 426 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE427 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE427 Property
Gets the Pantone 427 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE427 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE427
public static PdfPantoneColor PANTONE427 {get;}
public:
static property PdfPantoneColor^ PANTONE427 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 427 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE428 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE428 Property
Gets the Pantone 428 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE428 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE428
public static PdfPantoneColor PANTONE428 {get;}
public:
static property PdfPantoneColor^ PANTONE428 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 428 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE429 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE429 Property
Gets the Pantone 429 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE429 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE429
public static PdfPantoneColor PANTONE429 {get;}
public:
static property PdfPantoneColor^ PANTONE429 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 429 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE430 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE430 Property
Gets the Pantone 430 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE430 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE430
public static PdfPantoneColor PANTONE430 {get;}
public:
static property PdfPantoneColor^ PANTONE430 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 430 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE431 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE431 Property
Gets the Pantone 431 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE431 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE431
public static PdfPantoneColor PANTONE431 {get;}
public:
static property PdfPantoneColor^ PANTONE431 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 431 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE432 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE432 Property
Gets the Pantone 432 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE432 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE432
public static PdfPantoneColor PANTONE432 {get;}
public:
static property PdfPantoneColor^ PANTONE432 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 432 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE433 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE433 Property
Gets the Pantone 433 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE433 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE433
public static PdfPantoneColor PANTONE433 {get;}
public:
static property PdfPantoneColor^ PANTONE433 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 433 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE434 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE434 Property
Gets the Pantone 434 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE434 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE434
public static PdfPantoneColor PANTONE434 {get;}
public:
static property PdfPantoneColor^ PANTONE434 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 434 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE435 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE435 Property
Gets the Pantone 435 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE435 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE435
public static PdfPantoneColor PANTONE435 {get;}
public:
static property PdfPantoneColor^ PANTONE435 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 435 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE436 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE436 Property
Gets the Pantone 436 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE436 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE436
public static PdfPantoneColor PANTONE436 {get;}
public:
static property PdfPantoneColor^ PANTONE436 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 436 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE437 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE437 Property
Gets the Pantone 437 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE437 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE437
public static PdfPantoneColor PANTONE437 {get;}
public:
static property PdfPantoneColor^ PANTONE437 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 437 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE438 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE438 Property
Gets the Pantone 438 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE438 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE438
public static PdfPantoneColor PANTONE438 {get;}
public:
static property PdfPantoneColor^ PANTONE438 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 438 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE439 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE439 Property
Gets the Pantone 439 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE439 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE439
public static PdfPantoneColor PANTONE439 {get;}
public:
static property PdfPantoneColor^ PANTONE439 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 439 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE440 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE440 Property
Gets the Pantone 440 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE440 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE440
public static PdfPantoneColor PANTONE440 {get;}
public:
static property PdfPantoneColor^ PANTONE440 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 440 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE441 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE441 Property
Gets the Pantone 441 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE441 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE441
public static PdfPantoneColor PANTONE441 {get;}
public:
static property PdfPantoneColor^ PANTONE441 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 441 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE442 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE442 Property
Gets the Pantone 442 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE442 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE442
public static PdfPantoneColor PANTONE442 {get;}
public:
static property PdfPantoneColor^ PANTONE442 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 442 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE443 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE443 Property
Gets the Pantone 443 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE443 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE443
public static PdfPantoneColor PANTONE443 {get;}
public:
static property PdfPantoneColor^ PANTONE443 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 443 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE444 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE444 Property
Gets the Pantone 444 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE444 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE444
public static PdfPantoneColor PANTONE444 {get;}
public:
static property PdfPantoneColor^ PANTONE444 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 444 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE445 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE445 Property
Gets the Pantone 445 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE445 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE445
public static PdfPantoneColor PANTONE445 {get;}
public:
static property PdfPantoneColor^ PANTONE445 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 445 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE446 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE446 Property
Gets the Pantone 446 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE446 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE446
public static PdfPantoneColor PANTONE446 {get;}
public:
static property PdfPantoneColor^ PANTONE446 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 446 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE447 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE447 Property
Gets the Pantone 447 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE447 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE447
public static PdfPantoneColor PANTONE447 {get;}
public:
static property PdfPantoneColor^ PANTONE447 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 447 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE448 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE448 Property
Gets the Pantone 448 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE448 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE448
public static PdfPantoneColor PANTONE448 {get;}
public:
static property PdfPantoneColor^ PANTONE448 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 448 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4485 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4485 Property
Gets the Pantone 4485 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4485 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4485
public static PdfPantoneColor PANTONE4485 {get;}
public:
static property PdfPantoneColor^ PANTONE4485 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4485 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE449 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE449 Property
Gets the Pantone 449 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE449 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE449
public static PdfPantoneColor PANTONE449 {get;}
public:
static property PdfPantoneColor^ PANTONE449 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 449 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4495 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4495 Property
Gets the Pantone 4495 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4495 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4495
public static PdfPantoneColor PANTONE4495 {get;}
public:
static property PdfPantoneColor^ PANTONE4495 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4495 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE450 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE450 Property
Gets the Pantone 450 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE450 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE450
public static PdfPantoneColor PANTONE450 {get;}
public:
static property PdfPantoneColor^ PANTONE450 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 450 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4505 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4505 Property
Gets the Pantone 4505 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4505 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4505
public static PdfPantoneColor PANTONE4505 {get;}
public:
static property PdfPantoneColor^ PANTONE4505 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4505 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE451 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE451 Property
Gets the Pantone 451 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE451 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE451
public static PdfPantoneColor PANTONE451 {get;}
public:
static property PdfPantoneColor^ PANTONE451 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 451 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4515 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4515 Property
Gets the Pantone 4515 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4515 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4515
public static PdfPantoneColor PANTONE4515 {get;}
public:
static property PdfPantoneColor^ PANTONE4515 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4515 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE452 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE452 Property
Gets the Pantone 452 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE452 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE452
public static PdfPantoneColor PANTONE452 {get;}
public:
static property PdfPantoneColor^ PANTONE452 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 452 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4525 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4525 Property
Gets the Pantone 4525 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4525 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4525
public static PdfPantoneColor PANTONE4525 {get;}
public:
static property PdfPantoneColor^ PANTONE4525 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4525 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE453 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE453 Property
Gets the Pantone 453 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE453 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE453
public static PdfPantoneColor PANTONE453 {get;}
public:
static property PdfPantoneColor^ PANTONE453 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 453 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4535 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4535 Property
Gets the Pantone 4535 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4535 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4535
public static PdfPantoneColor PANTONE4535 {get;}
public:
static property PdfPantoneColor^ PANTONE4535 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4535 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE454 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE454 Property
Gets the Pantone 454 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE454 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE454
public static PdfPantoneColor PANTONE454 {get;}
public:
static property PdfPantoneColor^ PANTONE454 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 454 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4545 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4545 Property
Gets the Pantone 4545 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4545 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4545
public static PdfPantoneColor PANTONE4545 {get;}
public:
static property PdfPantoneColor^ PANTONE4545 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4545 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE455 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE455 Property
Gets the Pantone 455 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE455 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE455
public static PdfPantoneColor PANTONE455 {get;}
public:
static property PdfPantoneColor^ PANTONE455 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 455 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE456 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE456 Property
Gets the Pantone 456 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE456 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE456
public static PdfPantoneColor PANTONE456 {get;}
public:
static property PdfPantoneColor^ PANTONE456 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 456 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE457 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE457 Property
Gets the Pantone 457 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE457 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE457
public static PdfPantoneColor PANTONE457 {get;}
public:
static property PdfPantoneColor^ PANTONE457 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 457 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE458 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE458 Property
Gets the Pantone 458 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE458 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE458
public static PdfPantoneColor PANTONE458 {get;}
public:
static property PdfPantoneColor^ PANTONE458 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 458 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE459 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE459 Property
Gets the Pantone 459 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE459 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE459
public static PdfPantoneColor PANTONE459 {get;}
public:
static property PdfPantoneColor^ PANTONE459 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 459 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE460 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE460 Property
Gets the Pantone 460 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE460 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE460
public static PdfPantoneColor PANTONE460 {get;}
public:
static property PdfPantoneColor^ PANTONE460 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 460 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE461 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE461 Property
Gets the Pantone 461 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE461 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE461
public static PdfPantoneColor PANTONE461 {get;}
public:
static property PdfPantoneColor^ PANTONE461 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 461 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE462 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE462 Property
Gets the Pantone 462 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE462 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE462
public static PdfPantoneColor PANTONE462 {get;}
public:
static property PdfPantoneColor^ PANTONE462 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 462 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4625 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4625 Property
Gets the Pantone 4625 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4625 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4625
public static PdfPantoneColor PANTONE4625 {get;}
public:
static property PdfPantoneColor^ PANTONE4625 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4625 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE463 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE463 Property
Gets the Pantone 463 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE463 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE463
public static PdfPantoneColor PANTONE463 {get;}
public:
static property PdfPantoneColor^ PANTONE463 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 463 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4635 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4635 Property
Gets the Pantone 4635 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4635 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4635
public static PdfPantoneColor PANTONE4635 {get;}
public:
static property PdfPantoneColor^ PANTONE4635 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4635 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE464 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE464 Property
Gets the Pantone 464 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE464 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE464
public static PdfPantoneColor PANTONE464 {get;}
public:
static property PdfPantoneColor^ PANTONE464 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 464 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4645 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4645 Property
Gets the Pantone 4645 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4645 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4645
public static PdfPantoneColor PANTONE4645 {get;}
public:
static property PdfPantoneColor^ PANTONE4645 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4645 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE465 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE465 Property
Gets the Pantone 465 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE465 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE465
public static PdfPantoneColor PANTONE465 {get;}
public:
static property PdfPantoneColor^ PANTONE465 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 465 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4655 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4655 Property
Gets the Pantone 4655 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4655 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4655
public static PdfPantoneColor PANTONE4655 {get;}
public:
static property PdfPantoneColor^ PANTONE4655 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4655 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE466 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE466 Property
Gets the Pantone 466 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE466 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE466
public static PdfPantoneColor PANTONE466 {get;}
public:
static property PdfPantoneColor^ PANTONE466 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 466 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4665 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4665 Property
Gets the Pantone 4665 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4665 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4665
public static PdfPantoneColor PANTONE4665 {get;}
public:
static property PdfPantoneColor^ PANTONE4665 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4665 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE467 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE467 Property
Gets the Pantone 467 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE467 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE467
public static PdfPantoneColor PANTONE467 {get;}
public:
static property PdfPantoneColor^ PANTONE467 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 467 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4675 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4675 Property
Gets the Pantone 4675 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4675 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4675
public static PdfPantoneColor PANTONE4675 {get;}
public:
static property PdfPantoneColor^ PANTONE4675 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4675 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE468 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE468 Property
Gets the Pantone 468 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE468 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE468
public static PdfPantoneColor PANTONE468 {get;}
public:
static property PdfPantoneColor^ PANTONE468 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 468 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4685 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4685 Property
Gets the Pantone 4685 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4685 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4685
public static PdfPantoneColor PANTONE4685 {get;}
public:
static property PdfPantoneColor^ PANTONE4685 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4685 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE469 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE469 Property
Gets the Pantone 469 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE469 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE469
public static PdfPantoneColor PANTONE469 {get;}
public:
static property PdfPantoneColor^ PANTONE469 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 469 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4695 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4695 Property
Gets the Pantone 4695 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4695 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4695
public static PdfPantoneColor PANTONE4695 {get;}
public:
static property PdfPantoneColor^ PANTONE4695 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4695 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE470 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE470 Property
Gets the Pantone 470 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE470 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE470
public static PdfPantoneColor PANTONE470 {get;}
public:
static property PdfPantoneColor^ PANTONE470 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 470 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4705 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4705 Property
Gets the Pantone 4705 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4705 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4705
public static PdfPantoneColor PANTONE4705 {get;}
public:
static property PdfPantoneColor^ PANTONE4705 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4705 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE471 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE471 Property
Gets the Pantone 471 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE471 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE471
public static PdfPantoneColor PANTONE471 {get;}
public:
static property PdfPantoneColor^ PANTONE471 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 471 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4715 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4715 Property
Gets the Pantone 4715 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4715 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4715
public static PdfPantoneColor PANTONE4715 {get;}
public:
static property PdfPantoneColor^ PANTONE4715 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4715 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE472 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE472 Property
Gets the Pantone 472 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE472 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE472
public static PdfPantoneColor PANTONE472 {get;}
public:
static property PdfPantoneColor^ PANTONE472 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 472 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4725 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4725 Property
Gets the Pantone 4725 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4725 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4725
public static PdfPantoneColor PANTONE4725 {get;}
public:
static property PdfPantoneColor^ PANTONE4725 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4725 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE473 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE473 Property
Gets the Pantone 473 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE473 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE473
public static PdfPantoneColor PANTONE473 {get;}
public:
static property PdfPantoneColor^ PANTONE473 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 473 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4735 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4735 Property
Gets the Pantone 4735 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4735 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4735
public static PdfPantoneColor PANTONE4735 {get;}
public:
static property PdfPantoneColor^ PANTONE4735 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4735 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE474 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE474 Property
Gets the Pantone 474 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE474 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE474
public static PdfPantoneColor PANTONE474 {get;}
public:
static property PdfPantoneColor^ PANTONE474 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 474 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4745 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4745 Property
Gets the Pantone 4745 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4745 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4745
public static PdfPantoneColor PANTONE4745 {get;}
public:
static property PdfPantoneColor^ PANTONE4745 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4745 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE475 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE475 Property
Gets the Pantone 475 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE475 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE475
public static PdfPantoneColor PANTONE475 {get;}
public:
static property PdfPantoneColor^ PANTONE475 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 475 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4755 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4755 Property
Gets the Pantone 4755 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4755 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4755
public static PdfPantoneColor PANTONE4755 {get;}
public:
static property PdfPantoneColor^ PANTONE4755 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4755 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE476 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE476 Property
Gets the Pantone 476 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE476 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE476
public static PdfPantoneColor PANTONE476 {get;}
public:
static property PdfPantoneColor^ PANTONE476 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 476 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE477 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE477 Property
Gets the Pantone 477 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE477 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE477
public static PdfPantoneColor PANTONE477 {get;}
public:
static property PdfPantoneColor^ PANTONE477 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 477 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE478 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE478 Property
Gets the Pantone 478 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE478 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE478
public static PdfPantoneColor PANTONE478 {get;}
public:
static property PdfPantoneColor^ PANTONE478 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 478 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE479 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE479 Property
Gets the Pantone 479 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE479 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE479
public static PdfPantoneColor PANTONE479 {get;}
public:
static property PdfPantoneColor^ PANTONE479 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 479 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE480 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE480 Property
Gets the Pantone 480 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE480 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE480
public static PdfPantoneColor PANTONE480 {get;}
public:
static property PdfPantoneColor^ PANTONE480 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 480 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE481 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE481 Property
Gets the Pantone 481 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE481 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE481
public static PdfPantoneColor PANTONE481 {get;}
public:
static property PdfPantoneColor^ PANTONE481 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 481 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE482 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE482 Property
Gets the Pantone 482 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE482 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE482
public static PdfPantoneColor PANTONE482 {get;}
public:
static property PdfPantoneColor^ PANTONE482 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 482 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE483 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE483 Property
Gets the Pantone 483 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE483 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE483
public static PdfPantoneColor PANTONE483 {get;}
public:
static property PdfPantoneColor^ PANTONE483 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 483 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE484 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE484 Property
Gets the Pantone 484 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE484 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE484
public static PdfPantoneColor PANTONE484 {get;}
public:
static property PdfPantoneColor^ PANTONE484 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 484 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE485 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE485 Property
Gets the Pantone 485 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE485 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE485
public static PdfPantoneColor PANTONE485 {get;}
public:
static property PdfPantoneColor^ PANTONE485 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 485 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE486 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE486 Property
Gets the Pantone 486 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE486 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE486
public static PdfPantoneColor PANTONE486 {get;}
public:
static property PdfPantoneColor^ PANTONE486 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 486 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE487 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE487 Property
Gets the Pantone 487 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE487 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE487
public static PdfPantoneColor PANTONE487 {get;}
public:
static property PdfPantoneColor^ PANTONE487 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 487 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE488 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE488 Property
Gets the Pantone 488 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE488 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE488
public static PdfPantoneColor PANTONE488 {get;}
public:
static property PdfPantoneColor^ PANTONE488 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 488 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE489 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE489 Property
Gets the Pantone 489 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE489 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE489
public static PdfPantoneColor PANTONE489 {get;}
public:
static property PdfPantoneColor^ PANTONE489 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 489 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE490 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE490 Property
Gets the Pantone 490 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE490 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE490
public static PdfPantoneColor PANTONE490 {get;}
public:
static property PdfPantoneColor^ PANTONE490 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 490 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE491 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE491 Property
Gets the Pantone 491 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE491 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE491
public static PdfPantoneColor PANTONE491 {get;}
public:
static property PdfPantoneColor^ PANTONE491 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 491 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE492 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE492 Property
Gets the Pantone 492 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE492 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE492
public static PdfPantoneColor PANTONE492 {get;}
public:
static property PdfPantoneColor^ PANTONE492 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 492 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE493 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE493 Property
Gets the Pantone 493 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE493 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE493
public static PdfPantoneColor PANTONE493 {get;}
public:
static property PdfPantoneColor^ PANTONE493 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 493 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE494 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE494 Property
Gets the Pantone 494 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE494 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE494
public static PdfPantoneColor PANTONE494 {get;}
public:
static property PdfPantoneColor^ PANTONE494 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 494 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE495 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE495 Property
Gets the Pantone 495 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE495 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE495
public static PdfPantoneColor PANTONE495 {get;}
public:
static property PdfPantoneColor^ PANTONE495 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 495 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE496 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE496 Property
Gets the Pantone 496 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE496 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE496
public static PdfPantoneColor PANTONE496 {get;}
public:
static property PdfPantoneColor^ PANTONE496 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 496 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE497 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE497 Property
Gets the Pantone 497 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE497 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE497
public static PdfPantoneColor PANTONE497 {get;}
public:
static property PdfPantoneColor^ PANTONE497 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 497 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4975 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4975 Property
Gets the Pantone 4975 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4975 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4975
public static PdfPantoneColor PANTONE4975 {get;}
public:
static property PdfPantoneColor^ PANTONE4975 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4975 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE498 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE498 Property
Gets the Pantone 498 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE498 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE498
public static PdfPantoneColor PANTONE498 {get;}
public:
static property PdfPantoneColor^ PANTONE498 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 498 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4985 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4985 Property
Gets the Pantone 4985 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4985 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4985
public static PdfPantoneColor PANTONE4985 {get;}
public:
static property PdfPantoneColor^ PANTONE4985 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4985 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE499 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE499 Property
Gets the Pantone 499 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE499 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE499
public static PdfPantoneColor PANTONE499 {get;}
public:
static property PdfPantoneColor^ PANTONE499 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 499 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE4995 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE4995 Property
Gets the Pantone 4995 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE4995 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE4995
public static PdfPantoneColor PANTONE4995 {get;}
public:
static property PdfPantoneColor^ PANTONE4995 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 4995 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE500 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE500 Property
Gets the Pantone 500 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE500 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE500
public static PdfPantoneColor PANTONE500 {get;}
public:
static property PdfPantoneColor^ PANTONE500 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 500 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5005 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5005 Property
Gets the Pantone 5005 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5005 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5005
public static PdfPantoneColor PANTONE5005 {get;}
public:
static property PdfPantoneColor^ PANTONE5005 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5005 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE501 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE501 Property
Gets the Pantone 501 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE501 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE501
public static PdfPantoneColor PANTONE501 {get;}
public:
static property PdfPantoneColor^ PANTONE501 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 501 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5015 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5015 Property
Gets the Pantone 5015 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5015 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5015
public static PdfPantoneColor PANTONE5015 {get;}
public:
static property PdfPantoneColor^ PANTONE5015 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5015 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE502 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE502 Property
Gets the Pantone 502 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE502 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE502
public static PdfPantoneColor PANTONE502 {get;}
public:
static property PdfPantoneColor^ PANTONE502 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 502 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5025 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5025 Property
Gets the Pantone 5025 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5025 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5025
public static PdfPantoneColor PANTONE5025 {get;}
public:
static property PdfPantoneColor^ PANTONE5025 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5025 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE503 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE503 Property
Gets the Pantone 503 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE503 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE503
public static PdfPantoneColor PANTONE503 {get;}
public:
static property PdfPantoneColor^ PANTONE503 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 503 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5035 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5035 Property
Gets the Pantone 5035 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5035 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5035
public static PdfPantoneColor PANTONE5035 {get;}
public:
static property PdfPantoneColor^ PANTONE5035 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5035 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE504 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE504 Property
Gets the Pantone 504 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE504 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE504
public static PdfPantoneColor PANTONE504 {get;}
public:
static property PdfPantoneColor^ PANTONE504 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 504 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE505 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE505 Property
Gets the Pantone 505 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE505 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE505
public static PdfPantoneColor PANTONE505 {get;}
public:
static property PdfPantoneColor^ PANTONE505 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 505 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE506 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE506 Property
Gets the Pantone 506 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE506 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE506
public static PdfPantoneColor PANTONE506 {get;}
public:
static property PdfPantoneColor^ PANTONE506 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 506 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE507 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE507 Property
Gets the Pantone 507 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE507 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE507
public static PdfPantoneColor PANTONE507 {get;}
public:
static property PdfPantoneColor^ PANTONE507 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 507 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE508 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE508 Property
Gets the Pantone 508 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE508 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE508
public static PdfPantoneColor PANTONE508 {get;}
public:
static property PdfPantoneColor^ PANTONE508 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 508 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE509 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE509 Property
Gets the Pantone 509 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE509 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE509
public static PdfPantoneColor PANTONE509 {get;}
public:
static property PdfPantoneColor^ PANTONE509 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 509 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE510 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE510 Property
Gets the Pantone 510 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE510 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE510
public static PdfPantoneColor PANTONE510 {get;}
public:
static property PdfPantoneColor^ PANTONE510 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 510 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE511 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE511 Property
Gets the Pantone 511 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE511 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE511
public static PdfPantoneColor PANTONE511 {get;}
public:
static property PdfPantoneColor^ PANTONE511 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 511 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5115 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5115 Property
Gets the Pantone 5115 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5115 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5115
public static PdfPantoneColor PANTONE5115 {get;}
public:
static property PdfPantoneColor^ PANTONE5115 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5115 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE512 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE512 Property
Gets the Pantone 512 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE512 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE512
public static PdfPantoneColor PANTONE512 {get;}
public:
static property PdfPantoneColor^ PANTONE512 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 512 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5125 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5125 Property
Gets the Pantone 5125 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5125 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5125
public static PdfPantoneColor PANTONE5125 {get;}
public:
static property PdfPantoneColor^ PANTONE5125 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5125 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE513 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE513 Property
Gets the Pantone 513 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE513 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE513
public static PdfPantoneColor PANTONE513 {get;}
public:
static property PdfPantoneColor^ PANTONE513 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 513 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5135 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5135 Property
Gets the Pantone 5135 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5135 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5135
public static PdfPantoneColor PANTONE5135 {get;}
public:
static property PdfPantoneColor^ PANTONE5135 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5135 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE514 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE514 Property
Gets the Pantone 514 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE514 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE514
public static PdfPantoneColor PANTONE514 {get;}
public:
static property PdfPantoneColor^ PANTONE514 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 514 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5145 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5145 Property
Gets the Pantone 5145 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5145 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5145
public static PdfPantoneColor PANTONE5145 {get;}
public:
static property PdfPantoneColor^ PANTONE5145 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5145 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE515 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE515 Property
Gets the Pantone 515 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE515 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE515
public static PdfPantoneColor PANTONE515 {get;}
public:
static property PdfPantoneColor^ PANTONE515 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 515 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5155 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5155 Property
Gets the Pantone 5155 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5155 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5155
public static PdfPantoneColor PANTONE5155 {get;}
public:
static property PdfPantoneColor^ PANTONE5155 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5155 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE516 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE516 Property
Gets the Pantone 516 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE516 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE516
public static PdfPantoneColor PANTONE516 {get;}
public:
static property PdfPantoneColor^ PANTONE516 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 516 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5165 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5165 Property
Gets the Pantone 5165 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5165 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5165
public static PdfPantoneColor PANTONE5165 {get;}
public:
static property PdfPantoneColor^ PANTONE5165 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5165 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE517 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE517 Property
Gets the Pantone 517 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE517 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE517
public static PdfPantoneColor PANTONE517 {get;}
public:
static property PdfPantoneColor^ PANTONE517 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 517 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5175 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5175 Property
Gets the Pantone 5175 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5175 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5175
public static PdfPantoneColor PANTONE5175 {get;}
public:
static property PdfPantoneColor^ PANTONE5175 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5175 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE518 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE518 Property
Gets the Pantone 518 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE518 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE518
public static PdfPantoneColor PANTONE518 {get;}
public:
static property PdfPantoneColor^ PANTONE518 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 518 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5185 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5185 Property
Gets the Pantone 5185 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5185 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5185
public static PdfPantoneColor PANTONE5185 {get;}
public:
static property PdfPantoneColor^ PANTONE5185 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5185 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE519 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE519 Property
Gets the Pantone 519 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE519 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE519
public static PdfPantoneColor PANTONE519 {get;}
public:
static property PdfPantoneColor^ PANTONE519 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 519 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5195 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5195 Property
Gets the Pantone 5195 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5195 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5195
public static PdfPantoneColor PANTONE5195 {get;}
public:
static property PdfPantoneColor^ PANTONE5195 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5195 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE520 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE520 Property
Gets the Pantone 520 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE520 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE520
public static PdfPantoneColor PANTONE520 {get;}
public:
static property PdfPantoneColor^ PANTONE520 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 520 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5205 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5205 Property
Gets the Pantone 5205 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5205 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5205
public static PdfPantoneColor PANTONE5205 {get;}
public:
static property PdfPantoneColor^ PANTONE5205 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5205 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE521 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE521 Property
Gets the Pantone 521 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE521 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE521
public static PdfPantoneColor PANTONE521 {get;}
public:
static property PdfPantoneColor^ PANTONE521 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 521 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5215 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5215 Property
Gets the Pantone 5215 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5215 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5215
public static PdfPantoneColor PANTONE5215 {get;}
public:
static property PdfPantoneColor^ PANTONE5215 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5215 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE522 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE522 Property
Gets the Pantone 522 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE522 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE522
public static PdfPantoneColor PANTONE522 {get;}
public:
static property PdfPantoneColor^ PANTONE522 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 522 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5225 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5225 Property
Gets the Pantone 5225 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5225 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5225
public static PdfPantoneColor PANTONE5225 {get;}
public:
static property PdfPantoneColor^ PANTONE5225 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5225 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE523 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE523 Property
Gets the Pantone 523 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE523 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE523
public static PdfPantoneColor PANTONE523 {get;}
public:
static property PdfPantoneColor^ PANTONE523 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 523 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5235 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5235 Property
Gets the Pantone 5235 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5235 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5235
public static PdfPantoneColor PANTONE5235 {get;}
public:
static property PdfPantoneColor^ PANTONE5235 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5235 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE524 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE524 Property
Gets the Pantone 524 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE524 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE524
public static PdfPantoneColor PANTONE524 {get;}
public:
static property PdfPantoneColor^ PANTONE524 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 524 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5245 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5245 Property
Gets the Pantone 5245 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5245 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5245
public static PdfPantoneColor PANTONE5245 {get;}
public:
static property PdfPantoneColor^ PANTONE5245 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5245 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE525 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE525 Property
Gets the Pantone 525 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE525 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE525
public static PdfPantoneColor PANTONE525 {get;}
public:
static property PdfPantoneColor^ PANTONE525 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 525 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5255 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5255 Property
Gets the Pantone 5255 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5255 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5255
public static PdfPantoneColor PANTONE5255 {get;}
public:
static property PdfPantoneColor^ PANTONE5255 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5255 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE526 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE526 Property
Gets the Pantone 526 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE526 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE526
public static PdfPantoneColor PANTONE526 {get;}
public:
static property PdfPantoneColor^ PANTONE526 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 526 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5265 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5265 Property
Gets the Pantone 5265 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5265 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5265
public static PdfPantoneColor PANTONE5265 {get;}
public:
static property PdfPantoneColor^ PANTONE5265 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5265 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE527 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE527 Property
Gets the Pantone 527 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE527 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE527
public static PdfPantoneColor PANTONE527 {get;}
public:
static property PdfPantoneColor^ PANTONE527 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 527 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5275 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5275 Property
Gets the Pantone 5275 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5275 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5275
public static PdfPantoneColor PANTONE5275 {get;}
public:
static property PdfPantoneColor^ PANTONE5275 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5275 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE528 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE528 Property
Gets the Pantone 528 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE528 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE528
public static PdfPantoneColor PANTONE528 {get;}
public:
static property PdfPantoneColor^ PANTONE528 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 528 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5285 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5285 Property
Gets the Pantone 5285 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5285 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5285
public static PdfPantoneColor PANTONE5285 {get;}
public:
static property PdfPantoneColor^ PANTONE5285 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5285 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE529 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE529 Property
Gets the Pantone 529 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE529 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE529
public static PdfPantoneColor PANTONE529 {get;}
public:
static property PdfPantoneColor^ PANTONE529 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 529 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5295 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5295 Property
Gets the Pantone 5295 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5295 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5295
public static PdfPantoneColor PANTONE5295 {get;}
public:
static property PdfPantoneColor^ PANTONE5295 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5295 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE530 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE530 Property
Gets the Pantone 530 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE530 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE530
public static PdfPantoneColor PANTONE530 {get;}
public:
static property PdfPantoneColor^ PANTONE530 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 530 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5305 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5305 Property
Gets the Pantone 5305 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5305 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5305
public static PdfPantoneColor PANTONE5305 {get;}
public:
static property PdfPantoneColor^ PANTONE5305 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5305 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE531 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE531 Property
Gets the Pantone 531 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE531 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE531
public static PdfPantoneColor PANTONE531 {get;}
public:
static property PdfPantoneColor^ PANTONE531 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 531 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5315 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5315 Property
Gets the Pantone 5315 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5315 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5315
public static PdfPantoneColor PANTONE5315 {get;}
public:
static property PdfPantoneColor^ PANTONE5315 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5315 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE532 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE532 Property
Gets the Pantone 532 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE532 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE532
public static PdfPantoneColor PANTONE532 {get;}
public:
static property PdfPantoneColor^ PANTONE532 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 532 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE533 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE533 Property
Gets the Pantone 533 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE533 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE533
public static PdfPantoneColor PANTONE533 {get;}
public:
static property PdfPantoneColor^ PANTONE533 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 533 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE534 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE534 Property
Gets the Pantone 534 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE534 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE534
public static PdfPantoneColor PANTONE534 {get;}
public:
static property PdfPantoneColor^ PANTONE534 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 534 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE535 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE535 Property
Gets the Pantone 535 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE535 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE535
public static PdfPantoneColor PANTONE535 {get;}
public:
static property PdfPantoneColor^ PANTONE535 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 535 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE536 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE536 Property
Gets the Pantone 536 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE536 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE536
public static PdfPantoneColor PANTONE536 {get;}
public:
static property PdfPantoneColor^ PANTONE536 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 536 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE537 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE537 Property
Gets the Pantone 537 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE537 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE537
public static PdfPantoneColor PANTONE537 {get;}
public:
static property PdfPantoneColor^ PANTONE537 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 537 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE538 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE538 Property
Gets the Pantone 538 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE538 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE538
public static PdfPantoneColor PANTONE538 {get;}
public:
static property PdfPantoneColor^ PANTONE538 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 538 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE539 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE539 Property
Gets the Pantone 539 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE539 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE539
public static PdfPantoneColor PANTONE539 {get;}
public:
static property PdfPantoneColor^ PANTONE539 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 539 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5395 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5395 Property
Gets the Pantone 5395 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5395 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5395
public static PdfPantoneColor PANTONE5395 {get;}
public:
static property PdfPantoneColor^ PANTONE5395 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5395 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE540 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE540 Property
Gets the Pantone 540 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE540 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE540
public static PdfPantoneColor PANTONE540 {get;}
public:
static property PdfPantoneColor^ PANTONE540 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 540 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5405 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5405 Property
Gets the Pantone 5405 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5405 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5405
public static PdfPantoneColor PANTONE5405 {get;}
public:
static property PdfPantoneColor^ PANTONE5405 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5405 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE541 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE541 Property
Gets the Pantone 541 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE541 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE541
public static PdfPantoneColor PANTONE541 {get;}
public:
static property PdfPantoneColor^ PANTONE541 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 541 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5415 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5415 Property
Gets the Pantone 5415 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5415 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5415
public static PdfPantoneColor PANTONE5415 {get;}
public:
static property PdfPantoneColor^ PANTONE5415 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5415 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE542 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE542 Property
Gets the Pantone 542 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE542 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE542
public static PdfPantoneColor PANTONE542 {get;}
public:
static property PdfPantoneColor^ PANTONE542 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 542 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5425 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5425 Property
Gets the Pantone 5425 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5425 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5425
public static PdfPantoneColor PANTONE5425 {get;}
public:
static property PdfPantoneColor^ PANTONE5425 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5425 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE543 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE543 Property
Gets the Pantone 543 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE543 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE543
public static PdfPantoneColor PANTONE543 {get;}
public:
static property PdfPantoneColor^ PANTONE543 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 543 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5435 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5435 Property
Gets the Pantone 5435 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5435 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5435
public static PdfPantoneColor PANTONE5435 {get;}
public:
static property PdfPantoneColor^ PANTONE5435 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5435 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE544 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE544 Property
Gets the Pantone 544 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE544 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE544
public static PdfPantoneColor PANTONE544 {get;}
public:
static property PdfPantoneColor^ PANTONE544 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 544 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5445 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5445 Property
Gets the Pantone 5445 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5445 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5445
public static PdfPantoneColor PANTONE5445 {get;}
public:
static property PdfPantoneColor^ PANTONE5445 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5445 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE545 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE545 Property
Gets the Pantone 545 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE545 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE545
public static PdfPantoneColor PANTONE545 {get;}
public:
static property PdfPantoneColor^ PANTONE545 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 545 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5455 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5455 Property
Gets the Pantone 5455 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5455 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5455
public static PdfPantoneColor PANTONE5455 {get;}
public:
static property PdfPantoneColor^ PANTONE5455 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5455 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE546 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE546 Property
Gets the Pantone 546 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE546 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE546
public static PdfPantoneColor PANTONE546 {get;}
public:
static property PdfPantoneColor^ PANTONE546 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 546 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5463 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5463 Property
Gets the Pantone 5463 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5463 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5463
public static PdfPantoneColor PANTONE5463 {get;}
public:
static property PdfPantoneColor^ PANTONE5463 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5463 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5467 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5467 Property
Gets the Pantone 5467 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5467 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5467
public static PdfPantoneColor PANTONE5467 {get;}
public:
static property PdfPantoneColor^ PANTONE5467 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5467 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE547 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE547 Property
Gets the Pantone 547 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE547 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE547
public static PdfPantoneColor PANTONE547 {get;}
public:
static property PdfPantoneColor^ PANTONE547 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 547 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5473 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5473 Property
Gets the Pantone 5473 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5473 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5473
public static PdfPantoneColor PANTONE5473 {get;}
public:
static property PdfPantoneColor^ PANTONE5473 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5473 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5477 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5477 Property
Gets the Pantone 5477 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5477 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5477
public static PdfPantoneColor PANTONE5477 {get;}
public:
static property PdfPantoneColor^ PANTONE5477 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5477 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE548 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE548 Property
Gets the Pantone 548 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE548 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE548
public static PdfPantoneColor PANTONE548 {get;}
public:
static property PdfPantoneColor^ PANTONE548 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 548 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5483 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5483 Property
Gets the Pantone 5483 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5483 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5483
public static PdfPantoneColor PANTONE5483 {get;}
public:
static property PdfPantoneColor^ PANTONE5483 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5483 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5487 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5487 Property
Gets the Pantone 5487 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5487 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5487
public static PdfPantoneColor PANTONE5487 {get;}
public:
static property PdfPantoneColor^ PANTONE5487 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5487 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE549 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE549 Property
Gets the Pantone 549 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE549 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE549
public static PdfPantoneColor PANTONE549 {get;}
public:
static property PdfPantoneColor^ PANTONE549 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 549 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5493 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5493 Property
Gets the Pantone 5493 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5493 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5493
public static PdfPantoneColor PANTONE5493 {get;}
public:
static property PdfPantoneColor^ PANTONE5493 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5493 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5497 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5497 Property
Gets the Pantone 5497 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5497 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5497
public static PdfPantoneColor PANTONE5497 {get;}
public:
static property PdfPantoneColor^ PANTONE5497 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5497 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE550 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE550 Property
Gets the Pantone 550 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE550 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE550
public static PdfPantoneColor PANTONE550 {get;}
public:
static property PdfPantoneColor^ PANTONE550 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 550 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5503 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5503 Property
Gets the Pantone 5503 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5503 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5503
public static PdfPantoneColor PANTONE5503 {get;}
public:
static property PdfPantoneColor^ PANTONE5503 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5503 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5507 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5507 Property
Gets the Pantone 5507 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5507 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5507
public static PdfPantoneColor PANTONE5507 {get;}
public:
static property PdfPantoneColor^ PANTONE5507 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5507 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE551 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE551 Property
Gets the Pantone 551 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE551 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE551
public static PdfPantoneColor PANTONE551 {get;}
public:
static property PdfPantoneColor^ PANTONE551 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 551 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5513 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5513 Property
Gets the Pantone 5513 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5513 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5513
public static PdfPantoneColor PANTONE5513 {get;}
public:
static property PdfPantoneColor^ PANTONE5513 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5513 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5517 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5517 Property
Gets the Pantone 5517 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5517 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5517
public static PdfPantoneColor PANTONE5517 {get;}
public:
static property PdfPantoneColor^ PANTONE5517 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5517 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE552 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE552 Property
Gets the Pantone 552 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE552 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE552
public static PdfPantoneColor PANTONE552 {get;}
public:
static property PdfPantoneColor^ PANTONE552 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 552 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5523 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5523 Property
Gets the Pantone 5523 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5523 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5523
public static PdfPantoneColor PANTONE5523 {get;}
public:
static property PdfPantoneColor^ PANTONE5523 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5523 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5527 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5527 Property
Gets the Pantone 5527 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5527 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5527
public static PdfPantoneColor PANTONE5527 {get;}
public:
static property PdfPantoneColor^ PANTONE5527 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5527 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE553 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE553 Property
Gets the Pantone 553 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE553 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE553
public static PdfPantoneColor PANTONE553 {get;}
public:
static property PdfPantoneColor^ PANTONE553 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 553 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5535 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5535 Property
Gets the Pantone 5535 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5535 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5535
public static PdfPantoneColor PANTONE5535 {get;}
public:
static property PdfPantoneColor^ PANTONE5535 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5535 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE554 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE554 Property
Gets the Pantone 554 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE554 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE554
public static PdfPantoneColor PANTONE554 {get;}
public:
static property PdfPantoneColor^ PANTONE554 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 554 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5545 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5545 Property
Gets the Pantone 5545 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5545 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5545
public static PdfPantoneColor PANTONE5545 {get;}
public:
static property PdfPantoneColor^ PANTONE5545 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5545 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE555 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE555 Property
Gets the Pantone 555 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE555 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE555
public static PdfPantoneColor PANTONE555 {get;}
public:
static property PdfPantoneColor^ PANTONE555 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 555 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5555 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5555 Property
Gets the Pantone 5555 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5555 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5555
public static PdfPantoneColor PANTONE5555 {get;}
public:
static property PdfPantoneColor^ PANTONE5555 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5555 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE556 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE556 Property
Gets the Pantone 556 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE556 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE556
public static PdfPantoneColor PANTONE556 {get;}
public:
static property PdfPantoneColor^ PANTONE556 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 556 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5565 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5565 Property
Gets the Pantone 5565 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5565 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5565
public static PdfPantoneColor PANTONE5565 {get;}
public:
static property PdfPantoneColor^ PANTONE5565 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5565 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE557 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE557 Property
Gets the Pantone 557 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE557 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE557
public static PdfPantoneColor PANTONE557 {get;}
public:
static property PdfPantoneColor^ PANTONE557 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 557 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5575 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5575 Property
Gets the Pantone 5575 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5575 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5575
public static PdfPantoneColor PANTONE5575 {get;}
public:
static property PdfPantoneColor^ PANTONE5575 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5575 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE558 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE558 Property
Gets the Pantone 558 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE558 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE558
public static PdfPantoneColor PANTONE558 {get;}
public:
static property PdfPantoneColor^ PANTONE558 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 558 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5585 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5585 Property
Gets the Pantone 5585 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5585 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5585
public static PdfPantoneColor PANTONE5585 {get;}
public:
static property PdfPantoneColor^ PANTONE5585 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5585 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE559 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE559 Property
Gets the Pantone 559 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE559 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE559
public static PdfPantoneColor PANTONE559 {get;}
public:
static property PdfPantoneColor^ PANTONE559 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 559 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5595 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5595 Property
Gets the Pantone 5595 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5595 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5595
public static PdfPantoneColor PANTONE5595 {get;}
public:
static property PdfPantoneColor^ PANTONE5595 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5595 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE560 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE560 Property
Gets the Pantone 560 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE560 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE560
public static PdfPantoneColor PANTONE560 {get;}
public:
static property PdfPantoneColor^ PANTONE560 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 560 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5605 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5605 Property
Gets the Pantone 5605 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5605 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5605
public static PdfPantoneColor PANTONE5605 {get;}
public:
static property PdfPantoneColor^ PANTONE5605 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5605 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE561 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE561 Property
Gets the Pantone 561 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE561 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE561
public static PdfPantoneColor PANTONE561 {get;}
public:
static property PdfPantoneColor^ PANTONE561 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 561 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5615 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5615 Property
Gets the Pantone 5615 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5615 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5615
public static PdfPantoneColor PANTONE5615 {get;}
public:
static property PdfPantoneColor^ PANTONE5615 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5615 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE562 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE562 Property
Gets the Pantone 562 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE562 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE562
public static PdfPantoneColor PANTONE562 {get;}
public:
static property PdfPantoneColor^ PANTONE562 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 562 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5625 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5625 Property
Gets the Pantone 5625 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5625 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5625
public static PdfPantoneColor PANTONE5625 {get;}
public:
static property PdfPantoneColor^ PANTONE5625 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5625 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE563 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE563 Property
Gets the Pantone 563 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE563 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE563
public static PdfPantoneColor PANTONE563 {get;}
public:
static property PdfPantoneColor^ PANTONE563 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 563 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5635 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5635 Property
Gets the Pantone 5635 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5635 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5635
public static PdfPantoneColor PANTONE5635 {get;}
public:
static property PdfPantoneColor^ PANTONE5635 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5635 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE564 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE564 Property
Gets the Pantone 564 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE564 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE564
public static PdfPantoneColor PANTONE564 {get;}
public:
static property PdfPantoneColor^ PANTONE564 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 564 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5645 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5645 Property
Gets the Pantone 5645 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5645 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5645
public static PdfPantoneColor PANTONE5645 {get;}
public:
static property PdfPantoneColor^ PANTONE5645 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5645 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE565 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE565 Property
Gets the Pantone 565 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE565 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE565
public static PdfPantoneColor PANTONE565 {get;}
public:
static property PdfPantoneColor^ PANTONE565 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 565 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5655 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5655 Property
Gets the Pantone 5655 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5655 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5655
public static PdfPantoneColor PANTONE5655 {get;}
public:
static property PdfPantoneColor^ PANTONE5655 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5655 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE566 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE566 Property
Gets the Pantone 566 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE566 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE566
public static PdfPantoneColor PANTONE566 {get;}
public:
static property PdfPantoneColor^ PANTONE566 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 566 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5665 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5665 Property
Gets the Pantone 5665 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5665 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5665
public static PdfPantoneColor PANTONE5665 {get;}
public:
static property PdfPantoneColor^ PANTONE5665 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5665 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE567 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE567 Property
Gets the Pantone 567 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE567 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE567
public static PdfPantoneColor PANTONE567 {get;}
public:
static property PdfPantoneColor^ PANTONE567 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 567 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE568 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE568 Property
Gets the Pantone 568 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE568 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE568
public static PdfPantoneColor PANTONE568 {get;}
public:
static property PdfPantoneColor^ PANTONE568 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 568 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE569 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE569 Property
Gets the Pantone 569 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE569 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE569
public static PdfPantoneColor PANTONE569 {get;}
public:
static property PdfPantoneColor^ PANTONE569 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 569 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE570 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE570 Property
Gets the Pantone 570 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE570 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE570
public static PdfPantoneColor PANTONE570 {get;}
public:
static property PdfPantoneColor^ PANTONE570 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 570 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE571 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE571 Property
Gets the Pantone 571 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE571 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE571
public static PdfPantoneColor PANTONE571 {get;}
public:
static property PdfPantoneColor^ PANTONE571 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 571 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE572 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE572 Property
Gets the Pantone 572 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE572 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE572
public static PdfPantoneColor PANTONE572 {get;}
public:
static property PdfPantoneColor^ PANTONE572 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 572 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE573 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE573 Property
Gets the Pantone 573 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE573 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE573
public static PdfPantoneColor PANTONE573 {get;}
public:
static property PdfPantoneColor^ PANTONE573 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 573 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE574 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE574 Property
Gets the Pantone 574 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE574 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE574
public static PdfPantoneColor PANTONE574 {get;}
public:
static property PdfPantoneColor^ PANTONE574 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 574 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5743 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5743 Property
Gets the Pantone 5743 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5743 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5743
public static PdfPantoneColor PANTONE5743 {get;}
public:
static property PdfPantoneColor^ PANTONE5743 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5743 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5747 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5747 Property
Gets the Pantone 5747 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5747 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5747
public static PdfPantoneColor PANTONE5747 {get;}
public:
static property PdfPantoneColor^ PANTONE5747 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5747 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE575 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE575 Property
Gets the Pantone 575 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE575 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE575
public static PdfPantoneColor PANTONE575 {get;}
public:
static property PdfPantoneColor^ PANTONE575 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 575 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5753 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5753 Property
Gets the Pantone 5753 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5753 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5753
public static PdfPantoneColor PANTONE5753 {get;}
public:
static property PdfPantoneColor^ PANTONE5753 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5753 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5757 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5757 Property
Gets the Pantone 5757 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5757 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5757
public static PdfPantoneColor PANTONE5757 {get;}
public:
static property PdfPantoneColor^ PANTONE5757 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5757 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE576 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE576 Property
Gets the Pantone 576 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE576 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE576
public static PdfPantoneColor PANTONE576 {get;}
public:
static property PdfPantoneColor^ PANTONE576 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 576 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5763 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5763 Property
Gets the Pantone 5763 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5763 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5763
public static PdfPantoneColor PANTONE5763 {get;}
public:
static property PdfPantoneColor^ PANTONE5763 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5763 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5767 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5767 Property
Gets the Pantone 5767 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5767 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5767
public static PdfPantoneColor PANTONE5767 {get;}
public:
static property PdfPantoneColor^ PANTONE5767 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5767 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE577 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE577 Property
Gets the Pantone 577 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE577 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE577
public static PdfPantoneColor PANTONE577 {get;}
public:
static property PdfPantoneColor^ PANTONE577 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 577 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5773 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5773 Property
Gets the Pantone 5773 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5773 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5773
public static PdfPantoneColor PANTONE5773 {get;}
public:
static property PdfPantoneColor^ PANTONE5773 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5773 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5777 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5777 Property
Gets the Pantone 5777 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5777 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5777
public static PdfPantoneColor PANTONE5777 {get;}
public:
static property PdfPantoneColor^ PANTONE5777 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5777 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE578 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE578 Property
Gets the Pantone 578 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE578 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE578
public static PdfPantoneColor PANTONE578 {get;}
public:
static property PdfPantoneColor^ PANTONE578 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 578 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5783 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5783 Property
Gets the Pantone 5783 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5783 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5783
public static PdfPantoneColor PANTONE5783 {get;}
public:
static property PdfPantoneColor^ PANTONE5783 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5783 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5787 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5787 Property
Gets the Pantone 5787 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5787 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5787
public static PdfPantoneColor PANTONE5787 {get;}
public:
static property PdfPantoneColor^ PANTONE5787 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5787 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE579 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE579 Property
Gets the Pantone 579 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE579 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE579
public static PdfPantoneColor PANTONE579 {get;}
public:
static property PdfPantoneColor^ PANTONE579 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 579 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5793 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5793 Property
Gets the Pantone 5793 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5793 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5793
public static PdfPantoneColor PANTONE5793 {get;}
public:
static property PdfPantoneColor^ PANTONE5793 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5793 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5797 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5797 Property
Gets the Pantone 5797 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5797 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5797
public static PdfPantoneColor PANTONE5797 {get;}
public:
static property PdfPantoneColor^ PANTONE5797 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5797 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE580 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE580 Property
Gets the Pantone 580 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE580 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE580
public static PdfPantoneColor PANTONE580 {get;}
public:
static property PdfPantoneColor^ PANTONE580 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 580 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5803 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5803 Property
Gets the Pantone 5803 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5803 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5803
public static PdfPantoneColor PANTONE5803 {get;}
public:
static property PdfPantoneColor^ PANTONE5803 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5803 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5807 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5807 Property
Gets the Pantone 5807 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5807 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5807
public static PdfPantoneColor PANTONE5807 {get;}
public:
static property PdfPantoneColor^ PANTONE5807 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5807 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE581 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE581 Property
Gets the Pantone 581 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE581 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE581
public static PdfPantoneColor PANTONE581 {get;}
public:
static property PdfPantoneColor^ PANTONE581 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 581 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5815 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5815 Property
Gets the Pantone 5815 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5815 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5815
public static PdfPantoneColor PANTONE5815 {get;}
public:
static property PdfPantoneColor^ PANTONE5815 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5815 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE582 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE582 Property
Gets the Pantone 582 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE582 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE582
public static PdfPantoneColor PANTONE582 {get;}
public:
static property PdfPantoneColor^ PANTONE582 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 582 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5825 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5825 Property
Gets the Pantone 5825 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5825 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5825
public static PdfPantoneColor PANTONE5825 {get;}
public:
static property PdfPantoneColor^ PANTONE5825 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5825 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE583 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE583 Property
Gets the Pantone 583 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE583 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE583
public static PdfPantoneColor PANTONE583 {get;}
public:
static property PdfPantoneColor^ PANTONE583 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 583 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5835 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5835 Property
Gets the Pantone 5835 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5835 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5835
public static PdfPantoneColor PANTONE5835 {get;}
public:
static property PdfPantoneColor^ PANTONE5835 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5835 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE584 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE584 Property
Gets the Pantone 584 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE584 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE584
public static PdfPantoneColor PANTONE584 {get;}
public:
static property PdfPantoneColor^ PANTONE584 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 584 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5845 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5845 Property
Gets the Pantone 5845 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5845 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5845
public static PdfPantoneColor PANTONE5845 {get;}
public:
static property PdfPantoneColor^ PANTONE5845 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5845 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE585 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE585 Property
Gets the Pantone 585 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE585 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE585
public static PdfPantoneColor PANTONE585 {get;}
public:
static property PdfPantoneColor^ PANTONE585 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 585 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5855 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5855 Property
Gets the Pantone 5855 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5855 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5855
public static PdfPantoneColor PANTONE5855 {get;}
public:
static property PdfPantoneColor^ PANTONE5855 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5855 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE586 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE586 Property
Gets the Pantone 586 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE586 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE586
public static PdfPantoneColor PANTONE586 {get;}
public:
static property PdfPantoneColor^ PANTONE586 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 586 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5865 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5865 Property
Gets the Pantone 5865 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5865 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5865
public static PdfPantoneColor PANTONE5865 {get;}
public:
static property PdfPantoneColor^ PANTONE5865 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5865 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE587 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE587 Property
Gets the Pantone 587 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE587 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE587
public static PdfPantoneColor PANTONE587 {get;}
public:
static property PdfPantoneColor^ PANTONE587 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 587 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE5875 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE5875 Property
Gets the Pantone 5875 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE5875 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE5875
public static PdfPantoneColor PANTONE5875 {get;}
public:
static property PdfPantoneColor^ PANTONE5875 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 5875 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE600 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE600 Property
Gets the Pantone 600 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE600 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE600
public static PdfPantoneColor PANTONE600 {get;}
public:
static property PdfPantoneColor^ PANTONE600 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 600 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE601 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE601 Property
Gets the Pantone 601 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE601 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE601
public static PdfPantoneColor PANTONE601 {get;}
public:
static property PdfPantoneColor^ PANTONE601 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 601 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE602 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE602 Property
Gets the Pantone 602 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE602 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE602
public static PdfPantoneColor PANTONE602 {get;}
public:
static property PdfPantoneColor^ PANTONE602 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 602 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE603 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE603 Property
Gets the Pantone 603 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE603 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE603
public static PdfPantoneColor PANTONE603 {get;}
public:
static property PdfPantoneColor^ PANTONE603 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 603 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE604 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE604 Property
Gets the Pantone 604 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE604 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE604
public static PdfPantoneColor PANTONE604 {get;}
public:
static property PdfPantoneColor^ PANTONE604 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 604 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE605 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE605 Property
Gets the Pantone 605 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE605 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE605
public static PdfPantoneColor PANTONE605 {get;}
public:
static property PdfPantoneColor^ PANTONE605 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 605 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE606 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE606 Property
Gets the Pantone 606 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE606 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE606
public static PdfPantoneColor PANTONE606 {get;}
public:
static property PdfPantoneColor^ PANTONE606 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 606 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE607 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE607 Property
Gets the Pantone 607 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE607 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE607
public static PdfPantoneColor PANTONE607 {get;}
public:
static property PdfPantoneColor^ PANTONE607 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 607 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE608 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE608 Property
Gets the Pantone 608 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE608 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE608
public static PdfPantoneColor PANTONE608 {get;}
public:
static property PdfPantoneColor^ PANTONE608 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 608 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE609 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE609 Property
Gets the Pantone 609 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE609 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE609
public static PdfPantoneColor PANTONE609 {get;}
public:
static property PdfPantoneColor^ PANTONE609 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 609 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE610 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE610 Property
Gets the Pantone 610 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE610 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE610
public static PdfPantoneColor PANTONE610 {get;}
public:
static property PdfPantoneColor^ PANTONE610 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 610 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE611 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE611 Property
Gets the Pantone 611 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE611 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE611
public static PdfPantoneColor PANTONE611 {get;}
public:
static property PdfPantoneColor^ PANTONE611 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 611 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE612 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE612 Property
Gets the Pantone 612 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE612 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE612
public static PdfPantoneColor PANTONE612 {get;}
public:
static property PdfPantoneColor^ PANTONE612 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 612 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE613 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE613 Property
Gets the Pantone 613 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE613 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE613
public static PdfPantoneColor PANTONE613 {get;}
public:
static property PdfPantoneColor^ PANTONE613 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 613 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE614 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE614 Property
Gets the Pantone 614 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE614 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE614
public static PdfPantoneColor PANTONE614 {get;}
public:
static property PdfPantoneColor^ PANTONE614 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 614 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE615 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE615 Property
Gets the Pantone 615 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE615 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE615
public static PdfPantoneColor PANTONE615 {get;}
public:
static property PdfPantoneColor^ PANTONE615 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 615 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE616 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE616 Property
Gets the Pantone 616 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE616 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE616
public static PdfPantoneColor PANTONE616 {get;}
public:
static property PdfPantoneColor^ PANTONE616 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 616 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE617 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE617 Property
Gets the Pantone 617 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE617 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE617
public static PdfPantoneColor PANTONE617 {get;}
public:
static property PdfPantoneColor^ PANTONE617 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 617 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE618 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE618 Property
Gets the Pantone 618 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE618 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE618
public static PdfPantoneColor PANTONE618 {get;}
public:
static property PdfPantoneColor^ PANTONE618 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 618 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE619 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE619 Property
Gets the Pantone 619 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE619 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE619
public static PdfPantoneColor PANTONE619 {get;}
public:
static property PdfPantoneColor^ PANTONE619 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 619 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE620 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE620 Property
Gets the Pantone 620 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE620 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE620
public static PdfPantoneColor PANTONE620 {get;}
public:
static property PdfPantoneColor^ PANTONE620 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 620 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE621 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE621 Property
Gets the Pantone 621 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE621 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE621
public static PdfPantoneColor PANTONE621 {get;}
public:
static property PdfPantoneColor^ PANTONE621 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 621 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE622 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE622 Property
Gets the Pantone 622 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE622 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE622
public static PdfPantoneColor PANTONE622 {get;}
public:
static property PdfPantoneColor^ PANTONE622 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 622 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE623 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE623 Property
Gets the Pantone 623 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE623 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE623
public static PdfPantoneColor PANTONE623 {get;}
public:
static property PdfPantoneColor^ PANTONE623 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 623 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE624 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE624 Property
Gets the Pantone 624 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE624 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE624
public static PdfPantoneColor PANTONE624 {get;}
public:
static property PdfPantoneColor^ PANTONE624 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 624 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE625 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE625 Property
Gets the Pantone 625 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE625 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE625
public static PdfPantoneColor PANTONE625 {get;}
public:
static property PdfPantoneColor^ PANTONE625 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 625 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE626 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE626 Property
Gets the Pantone 626 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE626 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE626
public static PdfPantoneColor PANTONE626 {get;}
public:
static property PdfPantoneColor^ PANTONE626 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 626 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE627 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE627 Property
Gets the Pantone 627 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE627 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE627
public static PdfPantoneColor PANTONE627 {get;}
public:
static property PdfPantoneColor^ PANTONE627 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 627 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE628 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE628 Property
Gets the Pantone 628 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE628 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE628
public static PdfPantoneColor PANTONE628 {get;}
public:
static property PdfPantoneColor^ PANTONE628 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 628 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE629 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE629 Property
Gets the Pantone 629 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE629 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE629
public static PdfPantoneColor PANTONE629 {get;}
public:
static property PdfPantoneColor^ PANTONE629 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 629 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE630 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE630 Property
Gets the Pantone 630 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE630 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE630
public static PdfPantoneColor PANTONE630 {get;}
public:
static property PdfPantoneColor^ PANTONE630 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 630 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE631 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE631 Property
Gets the Pantone 631 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE631 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE631
public static PdfPantoneColor PANTONE631 {get;}
public:
static property PdfPantoneColor^ PANTONE631 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 631 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE632 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE632 Property
Gets the Pantone 632 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE632 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE632
public static PdfPantoneColor PANTONE632 {get;}
public:
static property PdfPantoneColor^ PANTONE632 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 632 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE633 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE633 Property
Gets the Pantone 633 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE633 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE633
public static PdfPantoneColor PANTONE633 {get;}
public:
static property PdfPantoneColor^ PANTONE633 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 633 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE634 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE634 Property
Gets the Pantone 634 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE634 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE634
public static PdfPantoneColor PANTONE634 {get;}
public:
static property PdfPantoneColor^ PANTONE634 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 634 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE635 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE635 Property
Gets the Pantone 635 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE635 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE635
public static PdfPantoneColor PANTONE635 {get;}
public:
static property PdfPantoneColor^ PANTONE635 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 635 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE636 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE636 Property
Gets the Pantone 636 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE636 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE636
public static PdfPantoneColor PANTONE636 {get;}
public:
static property PdfPantoneColor^ PANTONE636 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 636 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE637 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE637 Property
Gets the Pantone 637 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE637 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE637
public static PdfPantoneColor PANTONE637 {get;}
public:
static property PdfPantoneColor^ PANTONE637 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 637 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE638 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE638 Property
Gets the Pantone 638 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE638 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE638
public static PdfPantoneColor PANTONE638 {get;}
public:
static property PdfPantoneColor^ PANTONE638 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 638 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE639 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE639 Property
Gets the Pantone 639 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE639 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE639
public static PdfPantoneColor PANTONE639 {get;}
public:
static property PdfPantoneColor^ PANTONE639 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 639 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE640 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE640 Property
Gets the Pantone 640 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE640 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE640
public static PdfPantoneColor PANTONE640 {get;}
public:
static property PdfPantoneColor^ PANTONE640 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 640 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE641 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE641 Property
Gets the Pantone 641 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE641 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE641
public static PdfPantoneColor PANTONE641 {get;}
public:
static property PdfPantoneColor^ PANTONE641 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 641 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE642 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE642 Property
Gets the Pantone 642 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE642 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE642
public static PdfPantoneColor PANTONE642 {get;}
public:
static property PdfPantoneColor^ PANTONE642 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 642 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE643 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE643 Property
Gets the Pantone 643 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE643 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE643
public static PdfPantoneColor PANTONE643 {get;}
public:
static property PdfPantoneColor^ PANTONE643 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 643 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE644 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE644 Property
Gets the Pantone 644 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE644 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE644
public static PdfPantoneColor PANTONE644 {get;}
public:
static property PdfPantoneColor^ PANTONE644 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 644 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE645 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE645 Property
Gets the Pantone 645 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE645 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE645
public static PdfPantoneColor PANTONE645 {get;}
public:
static property PdfPantoneColor^ PANTONE645 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 645 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE646 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE646 Property
Gets the Pantone 646 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE646 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE646
public static PdfPantoneColor PANTONE646 {get;}
public:
static property PdfPantoneColor^ PANTONE646 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 646 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE647 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE647 Property
Gets the Pantone 647 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE647 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE647
public static PdfPantoneColor PANTONE647 {get;}
public:
static property PdfPantoneColor^ PANTONE647 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 647 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE648 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE648 Property
Gets the Pantone 648 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE648 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE648
public static PdfPantoneColor PANTONE648 {get;}
public:
static property PdfPantoneColor^ PANTONE648 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 648 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE649 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE649 Property
Gets the Pantone 649 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE649 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE649
public static PdfPantoneColor PANTONE649 {get;}
public:
static property PdfPantoneColor^ PANTONE649 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 649 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE650 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE650 Property
Gets the Pantone 650 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE650 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE650
public static PdfPantoneColor PANTONE650 {get;}
public:
static property PdfPantoneColor^ PANTONE650 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 650 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE651 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE651 Property
Gets the Pantone 651 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE651 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE651
public static PdfPantoneColor PANTONE651 {get;}
public:
static property PdfPantoneColor^ PANTONE651 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 651 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE652 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE652 Property
Gets the Pantone 652 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE652 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE652
public static PdfPantoneColor PANTONE652 {get;}
public:
static property PdfPantoneColor^ PANTONE652 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 652 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE653 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE653 Property
Gets the Pantone 653 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE653 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE653
public static PdfPantoneColor PANTONE653 {get;}
public:
static property PdfPantoneColor^ PANTONE653 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 653 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE654 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE654 Property
Gets the Pantone 654 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE654 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE654
public static PdfPantoneColor PANTONE654 {get;}
public:
static property PdfPantoneColor^ PANTONE654 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 654 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE655 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE655 Property
Gets the Pantone 655 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE655 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE655
public static PdfPantoneColor PANTONE655 {get;}
public:
static property PdfPantoneColor^ PANTONE655 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 655 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE656 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE656 Property
Gets the Pantone 656 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE656 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE656
public static PdfPantoneColor PANTONE656 {get;}
public:
static property PdfPantoneColor^ PANTONE656 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 656 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE657 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE657 Property
Gets the Pantone 657 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE657 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE657
public static PdfPantoneColor PANTONE657 {get;}
public:
static property PdfPantoneColor^ PANTONE657 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 657 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE658 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE658 Property
Gets the Pantone 658 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE658 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE658
public static PdfPantoneColor PANTONE658 {get;}
public:
static property PdfPantoneColor^ PANTONE658 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 658 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE659 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE659 Property
Gets the Pantone 659 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE659 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE659
public static PdfPantoneColor PANTONE659 {get;}
public:
static property PdfPantoneColor^ PANTONE659 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 659 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE660 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE660 Property
Gets the Pantone 660 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE660 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE660
public static PdfPantoneColor PANTONE660 {get;}
public:
static property PdfPantoneColor^ PANTONE660 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 660 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE661 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE661 Property
Gets the Pantone 661 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE661 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE661
public static PdfPantoneColor PANTONE661 {get;}
public:
static property PdfPantoneColor^ PANTONE661 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 661 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE662 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE662 Property
Gets the Pantone 662 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE662 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE662
public static PdfPantoneColor PANTONE662 {get;}
public:
static property PdfPantoneColor^ PANTONE662 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 662 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE663 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE663 Property
Gets the Pantone 663 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE663 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE663
public static PdfPantoneColor PANTONE663 {get;}
public:
static property PdfPantoneColor^ PANTONE663 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 663 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE664 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE664 Property
Gets the Pantone 664 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE664 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE664
public static PdfPantoneColor PANTONE664 {get;}
public:
static property PdfPantoneColor^ PANTONE664 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 664 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE665 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE665 Property
Gets the Pantone 665 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE665 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE665
public static PdfPantoneColor PANTONE665 {get;}
public:
static property PdfPantoneColor^ PANTONE665 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 665 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE666 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE666 Property
Gets the Pantone 666 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE666 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE666
public static PdfPantoneColor PANTONE666 {get;}
public:
static property PdfPantoneColor^ PANTONE666 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 666 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE667 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE667 Property
Gets the Pantone 667 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE667 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE667
public static PdfPantoneColor PANTONE667 {get;}
public:
static property PdfPantoneColor^ PANTONE667 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 667 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE668 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE668 Property
Gets the Pantone 668 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE668 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE668
public static PdfPantoneColor PANTONE668 {get;}
public:
static property PdfPantoneColor^ PANTONE668 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 668 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE669 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE669 Property
Gets the Pantone 669 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE669 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE669
public static PdfPantoneColor PANTONE669 {get;}
public:
static property PdfPantoneColor^ PANTONE669 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 669 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE670 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE670 Property
Gets the Pantone 670 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE670 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE670
public static PdfPantoneColor PANTONE670 {get;}
public:
static property PdfPantoneColor^ PANTONE670 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 670 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE671 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE671 Property
Gets the Pantone 671 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE671 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE671
public static PdfPantoneColor PANTONE671 {get;}
public:
static property PdfPantoneColor^ PANTONE671 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 671 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE672 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE672 Property
Gets the Pantone 672 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE672 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE672
public static PdfPantoneColor PANTONE672 {get;}
public:
static property PdfPantoneColor^ PANTONE672 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 672 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE673 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE673 Property
Gets the Pantone 673 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE673 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE673
public static PdfPantoneColor PANTONE673 {get;}
public:
static property PdfPantoneColor^ PANTONE673 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 673 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE674 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE674 Property
Gets the Pantone 674 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE674 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE674
public static PdfPantoneColor PANTONE674 {get;}
public:
static property PdfPantoneColor^ PANTONE674 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 674 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE675 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE675 Property
Gets the Pantone 675 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE675 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE675
public static PdfPantoneColor PANTONE675 {get;}
public:
static property PdfPantoneColor^ PANTONE675 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 675 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE676 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE676 Property
Gets the Pantone 676 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE676 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE676
public static PdfPantoneColor PANTONE676 {get;}
public:
static property PdfPantoneColor^ PANTONE676 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 676 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE677 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE677 Property
Gets the Pantone 677 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE677 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE677
public static PdfPantoneColor PANTONE677 {get;}
public:
static property PdfPantoneColor^ PANTONE677 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 677 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE678 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE678 Property
Gets the Pantone 678 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE678 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE678
public static PdfPantoneColor PANTONE678 {get;}
public:
static property PdfPantoneColor^ PANTONE678 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 678 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE679 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE679 Property
Gets the Pantone 679 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE679 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE679
public static PdfPantoneColor PANTONE679 {get;}
public:
static property PdfPantoneColor^ PANTONE679 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 679 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE680 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE680 Property
Gets the Pantone 680 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE680 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE680
public static PdfPantoneColor PANTONE680 {get;}
public:
static property PdfPantoneColor^ PANTONE680 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 680 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE681 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE681 Property
Gets the Pantone 681 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE681 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE681
public static PdfPantoneColor PANTONE681 {get;}
public:
static property PdfPantoneColor^ PANTONE681 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 681 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE682 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE682 Property
Gets the Pantone 682 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE682 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE682
public static PdfPantoneColor PANTONE682 {get;}
public:
static property PdfPantoneColor^ PANTONE682 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 682 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE683 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE683 Property
Gets the Pantone 683 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE683 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE683
public static PdfPantoneColor PANTONE683 {get;}
public:
static property PdfPantoneColor^ PANTONE683 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 683 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE684 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE684 Property
Gets the Pantone 684 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE684 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE684
public static PdfPantoneColor PANTONE684 {get;}
public:
static property PdfPantoneColor^ PANTONE684 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 684 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE685 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE685 Property
Gets the Pantone 685 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE685 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE685
public static PdfPantoneColor PANTONE685 {get;}
public:
static property PdfPantoneColor^ PANTONE685 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 685 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE686 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE686 Property
Gets the Pantone 686 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE686 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE686
public static PdfPantoneColor PANTONE686 {get;}
public:
static property PdfPantoneColor^ PANTONE686 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 686 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE687 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE687 Property
Gets the Pantone 687 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE687 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE687
public static PdfPantoneColor PANTONE687 {get;}
public:
static property PdfPantoneColor^ PANTONE687 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 687 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE688 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE688 Property
Gets the Pantone 688 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE688 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE688
public static PdfPantoneColor PANTONE688 {get;}
public:
static property PdfPantoneColor^ PANTONE688 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 688 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE689 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE689 Property
Gets the Pantone 689 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE689 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE689
public static PdfPantoneColor PANTONE689 {get;}
public:
static property PdfPantoneColor^ PANTONE689 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 689 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE690 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE690 Property
Gets the Pantone 690 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE690 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE690
public static PdfPantoneColor PANTONE690 {get;}
public:
static property PdfPantoneColor^ PANTONE690 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 690 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE691 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE691 Property
Gets the Pantone 691 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE691 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE691
public static PdfPantoneColor PANTONE691 {get;}
public:
static property PdfPantoneColor^ PANTONE691 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 691 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE692 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE692 Property
Gets the Pantone 692 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE692 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE692
public static PdfPantoneColor PANTONE692 {get;}
public:
static property PdfPantoneColor^ PANTONE692 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 692 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE693 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE693 Property
Gets the Pantone 693 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE693 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE693
public static PdfPantoneColor PANTONE693 {get;}
public:
static property PdfPantoneColor^ PANTONE693 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 693 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE694 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE694 Property
Gets the Pantone 694 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE694 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE694
public static PdfPantoneColor PANTONE694 {get;}
public:
static property PdfPantoneColor^ PANTONE694 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 694 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE695 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE695 Property
Gets the Pantone 695 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE695 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE695
public static PdfPantoneColor PANTONE695 {get;}
public:
static property PdfPantoneColor^ PANTONE695 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 695 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE696 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE696 Property
Gets the Pantone 696 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE696 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE696
public static PdfPantoneColor PANTONE696 {get;}
public:
static property PdfPantoneColor^ PANTONE696 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 696 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE697 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE697 Property
Gets the Pantone 697 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE697 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE697
public static PdfPantoneColor PANTONE697 {get;}
public:
static property PdfPantoneColor^ PANTONE697 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 697 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE698 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE698 Property
Gets the Pantone 698 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE698 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE698
public static PdfPantoneColor PANTONE698 {get;}
public:
static property PdfPantoneColor^ PANTONE698 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 698 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE699 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE699 Property
Gets the Pantone 699 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE699 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE699
public static PdfPantoneColor PANTONE699 {get;}
public:
static property PdfPantoneColor^ PANTONE699 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 699 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE700 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE700 Property
Gets the Pantone 700 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE700 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE700
public static PdfPantoneColor PANTONE700 {get;}
public:
static property PdfPantoneColor^ PANTONE700 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 700 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE701 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE701 Property
Gets the Pantone 701 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE701 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE701
public static PdfPantoneColor PANTONE701 {get;}
public:
static property PdfPantoneColor^ PANTONE701 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 701 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE702 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE702 Property
Gets the Pantone 702 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE702 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE702
public static PdfPantoneColor PANTONE702 {get;}
public:
static property PdfPantoneColor^ PANTONE702 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 702 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE703 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE703 Property
Gets the Pantone 703 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE703 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE703
public static PdfPantoneColor PANTONE703 {get;}
public:
static property PdfPantoneColor^ PANTONE703 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 703 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE704 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE704 Property
Gets the Pantone 704 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE704 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE704
public static PdfPantoneColor PANTONE704 {get;}
public:
static property PdfPantoneColor^ PANTONE704 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 704 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE705 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE705 Property
Gets the Pantone 705 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE705 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE705
public static PdfPantoneColor PANTONE705 {get;}
public:
static property PdfPantoneColor^ PANTONE705 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 705 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE706 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE706 Property
Gets the Pantone 706 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE706 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE706
public static PdfPantoneColor PANTONE706 {get;}
public:
static property PdfPantoneColor^ PANTONE706 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 706 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE707 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE707 Property
Gets the Pantone 707 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE707 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE707
public static PdfPantoneColor PANTONE707 {get;}
public:
static property PdfPantoneColor^ PANTONE707 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 707 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE708 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE708 Property
Gets the Pantone 708 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE708 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE708
public static PdfPantoneColor PANTONE708 {get;}
public:
static property PdfPantoneColor^ PANTONE708 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 708 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE709 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE709 Property
Gets the Pantone 709 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE709 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE709
public static PdfPantoneColor PANTONE709 {get;}
public:
static property PdfPantoneColor^ PANTONE709 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 709 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE710 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE710 Property
Gets the Pantone 710 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE710 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE710
public static PdfPantoneColor PANTONE710 {get;}
public:
static property PdfPantoneColor^ PANTONE710 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 710 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE711 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE711 Property
Gets the Pantone 711 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE711 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE711
public static PdfPantoneColor PANTONE711 {get;}
public:
static property PdfPantoneColor^ PANTONE711 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 711 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE712 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE712 Property
Gets the Pantone 712 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE712 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE712
public static PdfPantoneColor PANTONE712 {get;}
public:
static property PdfPantoneColor^ PANTONE712 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 712 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE713 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE713 Property
Gets the Pantone 713 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE713 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE713
public static PdfPantoneColor PANTONE713 {get;}
public:
static property PdfPantoneColor^ PANTONE713 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 713 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE714 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE714 Property
Gets the Pantone 714 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE714 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE714
public static PdfPantoneColor PANTONE714 {get;}
public:
static property PdfPantoneColor^ PANTONE714 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 714 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE715 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE715 Property
Gets the Pantone 715 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE715 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE715
public static PdfPantoneColor PANTONE715 {get;}
public:
static property PdfPantoneColor^ PANTONE715 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 715 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE716 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE716 Property
Gets the Pantone 716 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE716 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE716
public static PdfPantoneColor PANTONE716 {get;}
public:
static property PdfPantoneColor^ PANTONE716 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 716 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE717 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE717 Property
Gets the Pantone 717 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE717 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE717
public static PdfPantoneColor PANTONE717 {get;}
public:
static property PdfPantoneColor^ PANTONE717 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 717 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE718 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE718 Property
Gets the Pantone 718 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE718 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE718
public static PdfPantoneColor PANTONE718 {get;}
public:
static property PdfPantoneColor^ PANTONE718 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 718 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE719 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE719 Property
Gets the Pantone 719 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE719 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE719
public static PdfPantoneColor PANTONE719 {get;}
public:
static property PdfPantoneColor^ PANTONE719 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 719 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE720 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE720 Property
Gets the Pantone 720 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE720 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE720
public static PdfPantoneColor PANTONE720 {get;}
public:
static property PdfPantoneColor^ PANTONE720 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 720 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE721 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE721 Property
Gets the Pantone 721 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE721 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE721
public static PdfPantoneColor PANTONE721 {get;}
public:
static property PdfPantoneColor^ PANTONE721 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 721 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE722 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE722 Property
Gets the Pantone 722 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE722 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE722
public static PdfPantoneColor PANTONE722 {get;}
public:
static property PdfPantoneColor^ PANTONE722 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 722 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE723 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE723 Property
Gets the Pantone 723 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE723 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE723
public static PdfPantoneColor PANTONE723 {get;}
public:
static property PdfPantoneColor^ PANTONE723 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 723 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE724 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE724 Property
Gets the Pantone 724 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE724 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE724
public static PdfPantoneColor PANTONE724 {get;}
public:
static property PdfPantoneColor^ PANTONE724 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 724 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE725 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE725 Property
Gets the Pantone 725 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE725 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE725
public static PdfPantoneColor PANTONE725 {get;}
public:
static property PdfPantoneColor^ PANTONE725 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 725 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE726 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE726 Property
Gets the Pantone 726 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE726 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE726
public static PdfPantoneColor PANTONE726 {get;}
public:
static property PdfPantoneColor^ PANTONE726 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 726 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE727 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE727 Property
Gets the Pantone 727 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE727 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE727
public static PdfPantoneColor PANTONE727 {get;}
public:
static property PdfPantoneColor^ PANTONE727 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 727 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE728 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE728 Property
Gets the Pantone 728 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE728 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE728
public static PdfPantoneColor PANTONE728 {get;}
public:
static property PdfPantoneColor^ PANTONE728 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 728 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE729 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE729 Property
Gets the Pantone 729 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE729 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE729
public static PdfPantoneColor PANTONE729 {get;}
public:
static property PdfPantoneColor^ PANTONE729 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 729 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE730 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE730 Property
Gets the Pantone 730 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE730 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE730
public static PdfPantoneColor PANTONE730 {get;}
public:
static property PdfPantoneColor^ PANTONE730 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 730 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE731 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE731 Property
Gets the Pantone 731 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE731 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE731
public static PdfPantoneColor PANTONE731 {get;}
public:
static property PdfPantoneColor^ PANTONE731 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 731 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE732 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE732 Property
Gets the Pantone 732 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE732 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE732
public static PdfPantoneColor PANTONE732 {get;}
public:
static property PdfPantoneColor^ PANTONE732 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 732 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7401 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7401 Property
Gets the Pantone 7401 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7401 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7401
public static PdfPantoneColor PANTONE7401 {get;}
public:
static property PdfPantoneColor^ PANTONE7401 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7401 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7402 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7402 Property
Gets the Pantone 7402 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7402 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7402
public static PdfPantoneColor PANTONE7402 {get;}
public:
static property PdfPantoneColor^ PANTONE7402 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7402 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7403 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7403 Property
Gets the Pantone 7403 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7403 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7403
public static PdfPantoneColor PANTONE7403 {get;}
public:
static property PdfPantoneColor^ PANTONE7403 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7403 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7404 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7404 Property
Gets the Pantone 7404 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7404 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7404
public static PdfPantoneColor PANTONE7404 {get;}
public:
static property PdfPantoneColor^ PANTONE7404 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7404 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7405 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7405 Property
Gets the Pantone 7405 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7405 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7405
public static PdfPantoneColor PANTONE7405 {get;}
public:
static property PdfPantoneColor^ PANTONE7405 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7405 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7406 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7406 Property
Gets the Pantone 7406 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7406 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7406
public static PdfPantoneColor PANTONE7406 {get;}
public:
static property PdfPantoneColor^ PANTONE7406 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7406 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7407 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7407 Property
Gets the Pantone 7407 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7407 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7407
public static PdfPantoneColor PANTONE7407 {get;}
public:
static property PdfPantoneColor^ PANTONE7407 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7407 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7408 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7408 Property
Gets the Pantone 7408 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7408 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7408
public static PdfPantoneColor PANTONE7408 {get;}
public:
static property PdfPantoneColor^ PANTONE7408 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7408 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7409 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7409 Property
Gets the Pantone 7409 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7409 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7409
public static PdfPantoneColor PANTONE7409 {get;}
public:
static property PdfPantoneColor^ PANTONE7409 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7409 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7410 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7410 Property
Gets the Pantone 7410 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7410 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7410
public static PdfPantoneColor PANTONE7410 {get;}
public:
static property PdfPantoneColor^ PANTONE7410 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7410 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7411 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7411 Property
Gets the Pantone 7411 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7411 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7411
public static PdfPantoneColor PANTONE7411 {get;}
public:
static property PdfPantoneColor^ PANTONE7411 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7411 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7412 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7412 Property
Gets the Pantone 7412 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7412 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7412
public static PdfPantoneColor PANTONE7412 {get;}
public:
static property PdfPantoneColor^ PANTONE7412 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7412 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7413 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7413 Property
Gets the Pantone 7413 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7413 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7413
public static PdfPantoneColor PANTONE7413 {get;}
public:
static property PdfPantoneColor^ PANTONE7413 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7413 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7414 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7414 Property
Gets the Pantone 7414 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7414 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7414
public static PdfPantoneColor PANTONE7414 {get;}
public:
static property PdfPantoneColor^ PANTONE7414 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7414 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7415 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7415 Property
Gets the Pantone 7415 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7415 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7415
public static PdfPantoneColor PANTONE7415 {get;}
public:
static property PdfPantoneColor^ PANTONE7415 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7415 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7416 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7416 Property
Gets the Pantone 7416 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7416 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7416
public static PdfPantoneColor PANTONE7416 {get;}
public:
static property PdfPantoneColor^ PANTONE7416 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7416 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7417 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7417 Property
Gets the Pantone 7417 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7417 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7417
public static PdfPantoneColor PANTONE7417 {get;}
public:
static property PdfPantoneColor^ PANTONE7417 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7417 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7418 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7418 Property
Gets the Pantone 7418 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7418 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7418
public static PdfPantoneColor PANTONE7418 {get;}
public:
static property PdfPantoneColor^ PANTONE7418 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7418 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7419 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7419 Property
Gets the Pantone 7419 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7419 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7419
public static PdfPantoneColor PANTONE7419 {get;}
public:
static property PdfPantoneColor^ PANTONE7419 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7419 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7420 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7420 Property
Gets the Pantone 7420 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7420 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7420
public static PdfPantoneColor PANTONE7420 {get;}
public:
static property PdfPantoneColor^ PANTONE7420 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7420 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7421 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7421 Property
Gets the Pantone 7421 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7421 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7421
public static PdfPantoneColor PANTONE7421 {get;}
public:
static property PdfPantoneColor^ PANTONE7421 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7421 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7422 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7422 Property
Gets the Pantone 7422 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7422 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7422
public static PdfPantoneColor PANTONE7422 {get;}
public:
static property PdfPantoneColor^ PANTONE7422 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7422 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7423 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7423 Property
Gets the Pantone 7423 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7423 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7423
public static PdfPantoneColor PANTONE7423 {get;}
public:
static property PdfPantoneColor^ PANTONE7423 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7423 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7424 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7424 Property
Gets the Pantone 7424 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7424 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7424
public static PdfPantoneColor PANTONE7424 {get;}
public:
static property PdfPantoneColor^ PANTONE7424 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7424 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7425 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7425 Property
Gets the Pantone 7425 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7425 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7425
public static PdfPantoneColor PANTONE7425 {get;}
public:
static property PdfPantoneColor^ PANTONE7425 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7425 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7426 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7426 Property
Gets the Pantone 7426 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7426 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7426
public static PdfPantoneColor PANTONE7426 {get;}
public:
static property PdfPantoneColor^ PANTONE7426 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7426 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7427 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7427 Property
Gets the Pantone 7427 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7427 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7427
public static PdfPantoneColor PANTONE7427 {get;}
public:
static property PdfPantoneColor^ PANTONE7427 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7427 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7428 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7428 Property
Gets the Pantone 7428 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7428 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7428
public static PdfPantoneColor PANTONE7428 {get;}
public:
static property PdfPantoneColor^ PANTONE7428 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7428 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7429 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7429 Property
Gets the Pantone 7429 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7429 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7429
public static PdfPantoneColor PANTONE7429 {get;}
public:
static property PdfPantoneColor^ PANTONE7429 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7429 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7430 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7430 Property
Gets the Pantone 7430 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7430 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7430
public static PdfPantoneColor PANTONE7430 {get;}
public:
static property PdfPantoneColor^ PANTONE7430 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7430 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7431 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7431 Property
Gets the Pantone 7431 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7431 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7431
public static PdfPantoneColor PANTONE7431 {get;}
public:
static property PdfPantoneColor^ PANTONE7431 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7431 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7432 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7432 Property
Gets the Pantone 7432 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7432 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7432
public static PdfPantoneColor PANTONE7432 {get;}
public:
static property PdfPantoneColor^ PANTONE7432 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7432 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7433 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7433 Property
Gets the Pantone 7433 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7433 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7433
public static PdfPantoneColor PANTONE7433 {get;}
public:
static property PdfPantoneColor^ PANTONE7433 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7433 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7434 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7434 Property
Gets the Pantone 7434 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7434 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7434
public static PdfPantoneColor PANTONE7434 {get;}
public:
static property PdfPantoneColor^ PANTONE7434 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7434 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7435 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7435 Property
Gets the Pantone 7435 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7435 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7435
public static PdfPantoneColor PANTONE7435 {get;}
public:
static property PdfPantoneColor^ PANTONE7435 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7435 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7436 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7436 Property
Gets the Pantone 7436 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7436 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7436
public static PdfPantoneColor PANTONE7436 {get;}
public:
static property PdfPantoneColor^ PANTONE7436 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7436 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7437 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7437 Property
Gets the Pantone 7437 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7437 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7437
public static PdfPantoneColor PANTONE7437 {get;}
public:
static property PdfPantoneColor^ PANTONE7437 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7437 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7438 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7438 Property
Gets the Pantone 7438 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7438 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7438
public static PdfPantoneColor PANTONE7438 {get;}
public:
static property PdfPantoneColor^ PANTONE7438 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7438 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7439 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7439 Property
Gets the Pantone 7439 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7439 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7439
public static PdfPantoneColor PANTONE7439 {get;}
public:
static property PdfPantoneColor^ PANTONE7439 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7439 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7440 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7440 Property
Gets the Pantone 7440 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7440 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7440
public static PdfPantoneColor PANTONE7440 {get;}
public:
static property PdfPantoneColor^ PANTONE7440 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7440 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7441 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7441 Property
Gets the Pantone 7441 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7441 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7441
public static PdfPantoneColor PANTONE7441 {get;}
public:
static property PdfPantoneColor^ PANTONE7441 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7441 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7442 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7442 Property
Gets the Pantone 7442 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7442 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7442
public static PdfPantoneColor PANTONE7442 {get;}
public:
static property PdfPantoneColor^ PANTONE7442 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7442 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7443 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7443 Property
Gets the Pantone 7443 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7443 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7443
public static PdfPantoneColor PANTONE7443 {get;}
public:
static property PdfPantoneColor^ PANTONE7443 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7443 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7444 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7444 Property
Gets the Pantone 7444 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7444 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7444
public static PdfPantoneColor PANTONE7444 {get;}
public:
static property PdfPantoneColor^ PANTONE7444 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7444 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7445 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7445 Property
Gets the Pantone 7445 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7445 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7445
public static PdfPantoneColor PANTONE7445 {get;}
public:
static property PdfPantoneColor^ PANTONE7445 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7445 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7446 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7446 Property
Gets the Pantone 7446 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7446 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7446
public static PdfPantoneColor PANTONE7446 {get;}
public:
static property PdfPantoneColor^ PANTONE7446 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7446 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7447 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7447 Property
Gets the Pantone 7447 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7447 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7447
public static PdfPantoneColor PANTONE7447 {get;}
public:
static property PdfPantoneColor^ PANTONE7447 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7447 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7448 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7448 Property
Gets the Pantone 7448 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7448 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7448
public static PdfPantoneColor PANTONE7448 {get;}
public:
static property PdfPantoneColor^ PANTONE7448 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7448 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7449 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7449 Property
Gets the Pantone 7449 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7449 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7449
public static PdfPantoneColor PANTONE7449 {get;}
public:
static property PdfPantoneColor^ PANTONE7449 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7449 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7450 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7450 Property
Gets the Pantone 7450 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7450 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7450
public static PdfPantoneColor PANTONE7450 {get;}
public:
static property PdfPantoneColor^ PANTONE7450 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7450 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7451 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7451 Property
Gets the Pantone 7451 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7451 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7451
public static PdfPantoneColor PANTONE7451 {get;}
public:
static property PdfPantoneColor^ PANTONE7451 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7451 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7452 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7452 Property
Gets the Pantone 7452 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7452 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7452
public static PdfPantoneColor PANTONE7452 {get;}
public:
static property PdfPantoneColor^ PANTONE7452 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7452 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7453 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7453 Property
Gets the Pantone 7453 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7453 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7453
public static PdfPantoneColor PANTONE7453 {get;}
public:
static property PdfPantoneColor^ PANTONE7453 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7453 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7454 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7454 Property
Gets the Pantone 7454 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7454 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7454
public static PdfPantoneColor PANTONE7454 {get;}
public:
static property PdfPantoneColor^ PANTONE7454 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7454 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7455 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7455 Property
Gets the Pantone 7455 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7455 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7455
public static PdfPantoneColor PANTONE7455 {get;}
public:
static property PdfPantoneColor^ PANTONE7455 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7455 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7456 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7456 Property
Gets the Pantone 7456 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7456 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7456
public static PdfPantoneColor PANTONE7456 {get;}
public:
static property PdfPantoneColor^ PANTONE7456 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7456 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7457 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7457 Property
Gets the Pantone 7457 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7457 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7457
public static PdfPantoneColor PANTONE7457 {get;}
public:
static property PdfPantoneColor^ PANTONE7457 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7457 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7458 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7458 Property
Gets the Pantone 7458 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7458 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7458
public static PdfPantoneColor PANTONE7458 {get;}
public:
static property PdfPantoneColor^ PANTONE7458 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7458 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7459 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7459 Property
Gets the Pantone 7459 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7459 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7459
public static PdfPantoneColor PANTONE7459 {get;}
public:
static property PdfPantoneColor^ PANTONE7459 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7459 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7460 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7460 Property
Gets the Pantone 7460 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7460 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7460
public static PdfPantoneColor PANTONE7460 {get;}
public:
static property PdfPantoneColor^ PANTONE7460 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7460 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7461 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7461 Property
Gets the Pantone 7461 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7461 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7461
public static PdfPantoneColor PANTONE7461 {get;}
public:
static property PdfPantoneColor^ PANTONE7461 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7461 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7462 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7462 Property
Gets the Pantone 7462 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7462 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7462
public static PdfPantoneColor PANTONE7462 {get;}
public:
static property PdfPantoneColor^ PANTONE7462 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7462 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7463 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7463 Property
Gets the Pantone 7463 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7463 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7463
public static PdfPantoneColor PANTONE7463 {get;}
public:
static property PdfPantoneColor^ PANTONE7463 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7463 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7464 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7464 Property
Gets the Pantone 7464 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7464 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7464
public static PdfPantoneColor PANTONE7464 {get;}
public:
static property PdfPantoneColor^ PANTONE7464 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7464 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7465 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7465 Property
Gets the Pantone 7465 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7465 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7465
public static PdfPantoneColor PANTONE7465 {get;}
public:
static property PdfPantoneColor^ PANTONE7465 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7465 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7466 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7466 Property
Gets the Pantone 7466 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7466 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7466
public static PdfPantoneColor PANTONE7466 {get;}
public:
static property PdfPantoneColor^ PANTONE7466 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7466 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7467 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7467 Property
Gets the Pantone 7467 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7467 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7467
public static PdfPantoneColor PANTONE7467 {get;}
public:
static property PdfPantoneColor^ PANTONE7467 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7467 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7468 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7468 Property
Gets the Pantone 7468 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7468 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7468
public static PdfPantoneColor PANTONE7468 {get;}
public:
static property PdfPantoneColor^ PANTONE7468 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7468 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7469 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7469 Property
Gets the Pantone 7469 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7469 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7469
public static PdfPantoneColor PANTONE7469 {get;}
public:
static property PdfPantoneColor^ PANTONE7469 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7469 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7470 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7470 Property
Gets the Pantone 7470 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7470 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7470
public static PdfPantoneColor PANTONE7470 {get;}
public:
static property PdfPantoneColor^ PANTONE7470 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7470 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7471 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7471 Property
Gets the Pantone 7471 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7471 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7471
public static PdfPantoneColor PANTONE7471 {get;}
public:
static property PdfPantoneColor^ PANTONE7471 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7471 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7472 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7472 Property
Gets the Pantone 7472 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7472 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7472
public static PdfPantoneColor PANTONE7472 {get;}
public:
static property PdfPantoneColor^ PANTONE7472 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7472 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7473 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7473 Property
Gets the Pantone 7473 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7473 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7473
public static PdfPantoneColor PANTONE7473 {get;}
public:
static property PdfPantoneColor^ PANTONE7473 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7473 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7474 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7474 Property
Gets the Pantone 7474 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7474 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7474
public static PdfPantoneColor PANTONE7474 {get;}
public:
static property PdfPantoneColor^ PANTONE7474 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7474 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7475 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7475 Property
Gets the Pantone 7475 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7475 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7475
public static PdfPantoneColor PANTONE7475 {get;}
public:
static property PdfPantoneColor^ PANTONE7475 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7475 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7476 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7476 Property
Gets the Pantone 7476 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7476 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7476
public static PdfPantoneColor PANTONE7476 {get;}
public:
static property PdfPantoneColor^ PANTONE7476 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7476 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7477 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7477 Property
Gets the Pantone 7477 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7477 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7477
public static PdfPantoneColor PANTONE7477 {get;}
public:
static property PdfPantoneColor^ PANTONE7477 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7477 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7478 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7478 Property
Gets the Pantone 7478 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7478 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7478
public static PdfPantoneColor PANTONE7478 {get;}
public:
static property PdfPantoneColor^ PANTONE7478 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7478 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7479 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7479 Property
Gets the Pantone 7479 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7479 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7479
public static PdfPantoneColor PANTONE7479 {get;}
public:
static property PdfPantoneColor^ PANTONE7479 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7479 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7480 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7480 Property
Gets the Pantone 7480 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7480 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7480
public static PdfPantoneColor PANTONE7480 {get;}
public:
static property PdfPantoneColor^ PANTONE7480 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7480 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7481 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7481 Property
Gets the Pantone 7481 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7481 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7481
public static PdfPantoneColor PANTONE7481 {get;}
public:
static property PdfPantoneColor^ PANTONE7481 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7481 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7482 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7482 Property
Gets the Pantone 7482 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7482 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7482
public static PdfPantoneColor PANTONE7482 {get;}
public:
static property PdfPantoneColor^ PANTONE7482 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7482 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7483 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7483 Property
Gets the Pantone 7483 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7483 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7483
public static PdfPantoneColor PANTONE7483 {get;}
public:
static property PdfPantoneColor^ PANTONE7483 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7483 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7484 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7484 Property
Gets the Pantone 7484 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7484 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7484
public static PdfPantoneColor PANTONE7484 {get;}
public:
static property PdfPantoneColor^ PANTONE7484 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7484 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7485 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7485 Property
Gets the Pantone 7485 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7485 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7485
public static PdfPantoneColor PANTONE7485 {get;}
public:
static property PdfPantoneColor^ PANTONE7485 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7485 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7486 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7486 Property
Gets the Pantone 7486 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7486 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7486
public static PdfPantoneColor PANTONE7486 {get;}
public:
static property PdfPantoneColor^ PANTONE7486 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7486 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7487 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7487 Property
Gets the Pantone 7487 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7487 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7487
public static PdfPantoneColor PANTONE7487 {get;}
public:
static property PdfPantoneColor^ PANTONE7487 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7487 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7488 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7488 Property
Gets the Pantone 7488 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7488 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7488
public static PdfPantoneColor PANTONE7488 {get;}
public:
static property PdfPantoneColor^ PANTONE7488 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7488 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7489 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7489 Property
Gets the Pantone 7489 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7489 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7489
public static PdfPantoneColor PANTONE7489 {get;}
public:
static property PdfPantoneColor^ PANTONE7489 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7489 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7490 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7490 Property
Gets the Pantone 7490 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7490 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7490
public static PdfPantoneColor PANTONE7490 {get;}
public:
static property PdfPantoneColor^ PANTONE7490 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7490 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7491 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7491 Property
Gets the Pantone 7491 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7491 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7491
public static PdfPantoneColor PANTONE7491 {get;}
public:
static property PdfPantoneColor^ PANTONE7491 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7491 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7492 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7492 Property
Gets the Pantone 7492 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7492 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7492
public static PdfPantoneColor PANTONE7492 {get;}
public:
static property PdfPantoneColor^ PANTONE7492 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7492 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7493 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7493 Property
Gets the Pantone 7493 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7493 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7493
public static PdfPantoneColor PANTONE7493 {get;}
public:
static property PdfPantoneColor^ PANTONE7493 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7493 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7494 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7494 Property
Gets the Pantone 7494 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7494 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7494
public static PdfPantoneColor PANTONE7494 {get;}
public:
static property PdfPantoneColor^ PANTONE7494 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7494 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7495 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7495 Property
Gets the Pantone 7495 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7495 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7495
public static PdfPantoneColor PANTONE7495 {get;}
public:
static property PdfPantoneColor^ PANTONE7495 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7495 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7496 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7496 Property
Gets the Pantone 7496 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7496 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7496
public static PdfPantoneColor PANTONE7496 {get;}
public:
static property PdfPantoneColor^ PANTONE7496 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7496 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7497 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7497 Property
Gets the Pantone 7497 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7497 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7497
public static PdfPantoneColor PANTONE7497 {get;}
public:
static property PdfPantoneColor^ PANTONE7497 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7497 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7498 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7498 Property
Gets the Pantone 7498 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7498 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7498
public static PdfPantoneColor PANTONE7498 {get;}
public:
static property PdfPantoneColor^ PANTONE7498 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7498 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7499 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7499 Property
Gets the Pantone 7499 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7499 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7499
public static PdfPantoneColor PANTONE7499 {get;}
public:
static property PdfPantoneColor^ PANTONE7499 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7499 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7500 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7500 Property
Gets the Pantone 7500 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7500 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7500
public static PdfPantoneColor PANTONE7500 {get;}
public:
static property PdfPantoneColor^ PANTONE7500 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7500 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7501 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7501 Property
Gets the Pantone 7501 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7501 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7501
public static PdfPantoneColor PANTONE7501 {get;}
public:
static property PdfPantoneColor^ PANTONE7501 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7501 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7502 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7502 Property
Gets the Pantone 7502 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7502 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7502
public static PdfPantoneColor PANTONE7502 {get;}
public:
static property PdfPantoneColor^ PANTONE7502 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7502 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7503 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7503 Property
Gets the Pantone 7503 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7503 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7503
public static PdfPantoneColor PANTONE7503 {get;}
public:
static property PdfPantoneColor^ PANTONE7503 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7503 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7504 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7504 Property
Gets the Pantone 7504 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7504 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7504
public static PdfPantoneColor PANTONE7504 {get;}
public:
static property PdfPantoneColor^ PANTONE7504 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7504 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7505 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7505 Property
Gets the Pantone 7505 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7505 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7505
public static PdfPantoneColor PANTONE7505 {get;}
public:
static property PdfPantoneColor^ PANTONE7505 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7505 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7506 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7506 Property
Gets the Pantone 7506 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7506 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7506
public static PdfPantoneColor PANTONE7506 {get;}
public:
static property PdfPantoneColor^ PANTONE7506 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7506 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7507 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7507 Property
Gets the Pantone 7507 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7507 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7507
public static PdfPantoneColor PANTONE7507 {get;}
public:
static property PdfPantoneColor^ PANTONE7507 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7507 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7508 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7508 Property
Gets the Pantone 7508 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7508 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7508
public static PdfPantoneColor PANTONE7508 {get;}
public:
static property PdfPantoneColor^ PANTONE7508 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7508 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7509 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7509 Property
Gets the Pantone 7509 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7509 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7509
public static PdfPantoneColor PANTONE7509 {get;}
public:
static property PdfPantoneColor^ PANTONE7509 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7509 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7510 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7510 Property
Gets the Pantone 7510 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7510 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7510
public static PdfPantoneColor PANTONE7510 {get;}
public:
static property PdfPantoneColor^ PANTONE7510 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7510 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7511 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7511 Property
Gets the Pantone 7511 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7511 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7511
public static PdfPantoneColor PANTONE7511 {get;}
public:
static property PdfPantoneColor^ PANTONE7511 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7511 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7512 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7512 Property
Gets the Pantone 7512 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7512 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7512
public static PdfPantoneColor PANTONE7512 {get;}
public:
static property PdfPantoneColor^ PANTONE7512 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7512 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7513 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7513 Property
Gets the Pantone 7513 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7513 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7513
public static PdfPantoneColor PANTONE7513 {get;}
public:
static property PdfPantoneColor^ PANTONE7513 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7513 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7514 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7514 Property
Gets the Pantone 7514 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7514 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7514
public static PdfPantoneColor PANTONE7514 {get;}
public:
static property PdfPantoneColor^ PANTONE7514 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7514 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7515 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7515 Property
Gets the Pantone 7515 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7515 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7515
public static PdfPantoneColor PANTONE7515 {get;}
public:
static property PdfPantoneColor^ PANTONE7515 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7515 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7516 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7516 Property
Gets the Pantone 7516 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7516 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7516
public static PdfPantoneColor PANTONE7516 {get;}
public:
static property PdfPantoneColor^ PANTONE7516 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7516 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7517 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7517 Property
Gets the Pantone 7517 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7517 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7517
public static PdfPantoneColor PANTONE7517 {get;}
public:
static property PdfPantoneColor^ PANTONE7517 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7517 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7518 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7518 Property
Gets the Pantone 7518 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7518 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7518
public static PdfPantoneColor PANTONE7518 {get;}
public:
static property PdfPantoneColor^ PANTONE7518 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7518 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7519 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7519 Property
Gets the Pantone 7519 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7519 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7519
public static PdfPantoneColor PANTONE7519 {get;}
public:
static property PdfPantoneColor^ PANTONE7519 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7519 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7520 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7520 Property
Gets the Pantone 7520 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7520 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7520
public static PdfPantoneColor PANTONE7520 {get;}
public:
static property PdfPantoneColor^ PANTONE7520 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7520 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7521 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7521 Property
Gets the Pantone 7521 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7521 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7521
public static PdfPantoneColor PANTONE7521 {get;}
public:
static property PdfPantoneColor^ PANTONE7521 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7521 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7522 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7522 Property
Gets the Pantone 7522 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7522 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7522
public static PdfPantoneColor PANTONE7522 {get;}
public:
static property PdfPantoneColor^ PANTONE7522 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7522 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7523 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7523 Property
Gets the Pantone 7523 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7523 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7523
public static PdfPantoneColor PANTONE7523 {get;}
public:
static property PdfPantoneColor^ PANTONE7523 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7523 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7524 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7524 Property
Gets the Pantone 7524 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7524 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7524
public static PdfPantoneColor PANTONE7524 {get;}
public:
static property PdfPantoneColor^ PANTONE7524 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7524 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7525 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7525 Property
Gets the Pantone 7525 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7525 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7525
public static PdfPantoneColor PANTONE7525 {get;}
public:
static property PdfPantoneColor^ PANTONE7525 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7525 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7526 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7526 Property
Gets the Pantone 7526 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7526 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7526
public static PdfPantoneColor PANTONE7526 {get;}
public:
static property PdfPantoneColor^ PANTONE7526 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7526 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7527 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7527 Property
Gets the Pantone 7527 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7527 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7527
public static PdfPantoneColor PANTONE7527 {get;}
public:
static property PdfPantoneColor^ PANTONE7527 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7527 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7528 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7528 Property
Gets the Pantone 7528 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7528 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7528
public static PdfPantoneColor PANTONE7528 {get;}
public:
static property PdfPantoneColor^ PANTONE7528 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7528 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7529 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7529 Property
Gets the Pantone 7529 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7529 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7529
public static PdfPantoneColor PANTONE7529 {get;}
public:
static property PdfPantoneColor^ PANTONE7529 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7529 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7530 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7530 Property
Gets the Pantone 7530 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7530 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7530
public static PdfPantoneColor PANTONE7530 {get;}
public:
static property PdfPantoneColor^ PANTONE7530 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7530 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7531 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7531 Property
Gets the Pantone 7531 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7531 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7531
public static PdfPantoneColor PANTONE7531 {get;}
public:
static property PdfPantoneColor^ PANTONE7531 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7531 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7532 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7532 Property
Gets the Pantone 7532 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7532 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7532
public static PdfPantoneColor PANTONE7532 {get;}
public:
static property PdfPantoneColor^ PANTONE7532 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7532 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7533 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7533 Property
Gets the Pantone 7533 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7533 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7533
public static PdfPantoneColor PANTONE7533 {get;}
public:
static property PdfPantoneColor^ PANTONE7533 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7533 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7534 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7534 Property
Gets the Pantone 7534 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7534 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7534
public static PdfPantoneColor PANTONE7534 {get;}
public:
static property PdfPantoneColor^ PANTONE7534 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7534 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7535 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7535 Property
Gets the Pantone 7535 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7535 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7535
public static PdfPantoneColor PANTONE7535 {get;}
public:
static property PdfPantoneColor^ PANTONE7535 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7535 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7536 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7536 Property
Gets the Pantone 7536 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7536 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7536
public static PdfPantoneColor PANTONE7536 {get;}
public:
static property PdfPantoneColor^ PANTONE7536 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7536 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7537 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7537 Property
Gets the Pantone 7537 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7537 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7537
public static PdfPantoneColor PANTONE7537 {get;}
public:
static property PdfPantoneColor^ PANTONE7537 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7537 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7538 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7538 Property
Gets the Pantone 7538 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7538 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7538
public static PdfPantoneColor PANTONE7538 {get;}
public:
static property PdfPantoneColor^ PANTONE7538 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7538 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7539 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7539 Property
Gets the Pantone 7539 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7539 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7539
public static PdfPantoneColor PANTONE7539 {get;}
public:
static property PdfPantoneColor^ PANTONE7539 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7539 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7540 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7540 Property
Gets the Pantone 7540 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7540 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7540
public static PdfPantoneColor PANTONE7540 {get;}
public:
static property PdfPantoneColor^ PANTONE7540 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7540 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7541 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7541 Property
Gets the Pantone 7541 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7541 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7541
public static PdfPantoneColor PANTONE7541 {get;}
public:
static property PdfPantoneColor^ PANTONE7541 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7541 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7542 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7542 Property
Gets the Pantone 7542 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7542 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7542
public static PdfPantoneColor PANTONE7542 {get;}
public:
static property PdfPantoneColor^ PANTONE7542 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7542 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7543 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7543 Property
Gets the Pantone 7543 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7543 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7543
public static PdfPantoneColor PANTONE7543 {get;}
public:
static property PdfPantoneColor^ PANTONE7543 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7543 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7544 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7544 Property
Gets the Pantone 7544 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7544 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7544
public static PdfPantoneColor PANTONE7544 {get;}
public:
static property PdfPantoneColor^ PANTONE7544 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7544 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7545 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7545 Property
Gets the Pantone 7545 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7545 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7545
public static PdfPantoneColor PANTONE7545 {get;}
public:
static property PdfPantoneColor^ PANTONE7545 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7545 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7546 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7546 Property
Gets the Pantone 7546 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7546 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7546
public static PdfPantoneColor PANTONE7546 {get;}
public:
static property PdfPantoneColor^ PANTONE7546 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7546 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE7547 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE7547 Property
Gets the Pantone 7547 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE7547 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE7547
public static PdfPantoneColor PANTONE7547 {get;}
public:
static property PdfPantoneColor^ PANTONE7547 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 7547 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE8003 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE8003 Property
Gets the Pantone 8003 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8003 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE8003
public static PdfPantoneColor PANTONE8003 {get;}
public:
static property PdfPantoneColor^ PANTONE8003 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 8003 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE801 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE801 Property
Gets the Pantone 801 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE801 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE801
public static PdfPantoneColor PANTONE801 {get;}
public:
static property PdfPantoneColor^ PANTONE801 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 801 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE802 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE802 Property
Gets the Pantone 802 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE802 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE802
public static PdfPantoneColor PANTONE802 {get;}
public:
static property PdfPantoneColor^ PANTONE802 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 802 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE8021 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE8021 Property
Gets the Pantone 8021 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8021 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE8021
public static PdfPantoneColor PANTONE8021 {get;}
public:
static property PdfPantoneColor^ PANTONE8021 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 8021 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE803 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE803 Property
Gets the Pantone 803 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE803 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE803
public static PdfPantoneColor PANTONE803 {get;}
public:
static property PdfPantoneColor^ PANTONE803 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 803 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE804 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE804 Property
Gets the Pantone 804 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE804 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE804
public static PdfPantoneColor PANTONE804 {get;}
public:
static property PdfPantoneColor^ PANTONE804 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 804 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE805 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE805 Property
Gets the Pantone 805 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE805 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE805
public static PdfPantoneColor PANTONE805 {get;}
public:
static property PdfPantoneColor^ PANTONE805 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 805 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE806 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE806 Property
Gets the Pantone 806 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE806 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE806
public static PdfPantoneColor PANTONE806 {get;}
public:
static property PdfPantoneColor^ PANTONE806 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 806 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE8062 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE8062 Property
Gets the Pantone 8062 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8062 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE8062
public static PdfPantoneColor PANTONE8062 {get;}
public:
static property PdfPantoneColor^ PANTONE8062 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 8062 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE807 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE807 Property
Gets the Pantone 807 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE807 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE807
public static PdfPantoneColor PANTONE807 {get;}
public:
static property PdfPantoneColor^ PANTONE807 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 807 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE808 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE808 Property
Gets the Pantone 808 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE808 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE808
public static PdfPantoneColor PANTONE808 {get;}
public:
static property PdfPantoneColor^ PANTONE808 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 808 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE809 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE809 Property
Gets the Pantone 809 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE809 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE809
public static PdfPantoneColor PANTONE809 {get;}
public:
static property PdfPantoneColor^ PANTONE809 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 809 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE810 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE810 Property
Gets the Pantone 810 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE810 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE810
public static PdfPantoneColor PANTONE810 {get;}
public:
static property PdfPantoneColor^ PANTONE810 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 810 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE8100 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE8100 Property
Gets the Pantone 8100 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8100 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE8100
public static PdfPantoneColor PANTONE8100 {get;}
public:
static property PdfPantoneColor^ PANTONE8100 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 8100 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE811 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE811 Property
Gets the Pantone 811 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE811 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE811
public static PdfPantoneColor PANTONE811 {get;}
public:
static property PdfPantoneColor^ PANTONE811 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 811 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE812 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE812 Property
Gets the Pantone 812 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE812 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE812
public static PdfPantoneColor PANTONE812 {get;}
public:
static property PdfPantoneColor^ PANTONE812 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 812 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE813 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE813 Property
Gets the Pantone 813 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE813 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE813
public static PdfPantoneColor PANTONE813 {get;}
public:
static property PdfPantoneColor^ PANTONE813 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 813 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE814 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE814 Property
Gets the Pantone 814 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE814 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE814
public static PdfPantoneColor PANTONE814 {get;}
public:
static property PdfPantoneColor^ PANTONE814 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 814 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE8201 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE8201 Property
Gets the Pantone 8201 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8201 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE8201
public static PdfPantoneColor PANTONE8201 {get;}
public:
static property PdfPantoneColor^ PANTONE8201 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 8201 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE8281 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE8281 Property
Gets the Pantone 8281 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8281 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE8281
public static PdfPantoneColor PANTONE8281 {get;}
public:
static property PdfPantoneColor^ PANTONE8281 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 8281 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE8321 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE8321 Property
Gets the Pantone 8321 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE8321 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE8321
public static PdfPantoneColor PANTONE8321 {get;}
public:
static property PdfPantoneColor^ PANTONE8321 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 8321 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE871 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE871 Property
Gets the Pantone 871 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE871 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE871
public static PdfPantoneColor PANTONE871 {get;}
public:
static property PdfPantoneColor^ PANTONE871 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 871 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE872 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE872 Property
Gets the Pantone 872 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE872 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE872
public static PdfPantoneColor PANTONE872 {get;}
public:
static property PdfPantoneColor^ PANTONE872 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 872 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE873 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE873 Property
Gets the Pantone 873 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE873 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE873
public static PdfPantoneColor PANTONE873 {get;}
public:
static property PdfPantoneColor^ PANTONE873 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 873 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE874 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE874 Property
Gets the Pantone 874 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE874 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE874
public static PdfPantoneColor PANTONE874 {get;}
public:
static property PdfPantoneColor^ PANTONE874 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 874 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE875 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE875 Property
Gets the Pantone 875 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE875 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE875
public static PdfPantoneColor PANTONE875 {get;}
public:
static property PdfPantoneColor^ PANTONE875 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 875 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE876 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE876 Property
Gets the Pantone 876 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE876 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE876
public static PdfPantoneColor PANTONE876 {get;}
public:
static property PdfPantoneColor^ PANTONE876 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 876 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


PANTONE877 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : PANTONE877 Property
Gets the Pantone 877 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PANTONE877 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.PANTONE877
public static PdfPantoneColor PANTONE877 {get;}
public:
static property PdfPantoneColor^ PANTONE877 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone 877 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


ProcessBlack Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : ProcessBlack Property
Gets the Pantone Process Black color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessBlack As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.ProcessBlack
public static PdfPantoneColor ProcessBlack {get;}
public:
static property PdfPantoneColor^ ProcessBlack {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Process Black color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


ProcessBlue Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : ProcessBlue Property
Gets the Pantone Process Blue color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessBlue As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.ProcessBlue
public static PdfPantoneColor ProcessBlue {get;}
public:
static property PdfPantoneColor^ ProcessBlue {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Process Blue color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


ProcessCyan Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : ProcessCyan Property
Gets the Pantone Process Cyan color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessCyan As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.ProcessCyan
public static PdfPantoneColor ProcessCyan {get;}
public:
static property PdfPantoneColor^ ProcessCyan {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Process Cyan color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


ProcessMagenta Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : ProcessMagenta Property
Gets the Pantone Process Magenta color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessMagenta As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.ProcessMagenta
public static PdfPantoneColor ProcessMagenta {get;}
public:
static property PdfPantoneColor^ ProcessMagenta {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Process Magenta color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


ProcessYellow Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : ProcessYellow Property
Gets the Pantone Process Yellow color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ProcessYellow As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.ProcessYellow
public static PdfPantoneColor ProcessYellow {get;}
public:
static property PdfPantoneColor^ ProcessYellow {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Process Yellow color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Purple Property (PdfPantoneColor)

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Purple Property
Gets the Pantone Purple color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Purple As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Purple
public static PdfPantoneColor Purple {get;}
public:
static property PdfPantoneColor^ Purple {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Purple color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Red032 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Red032 Property
Gets the Pantone Red 032 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Red032 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Red032
public static PdfPantoneColor Red032 {get;}
public:
static property PdfPantoneColor^ Red032 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Red 032 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


ReflexBlue Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : ReflexBlue Property
Gets the Pantone Reflex Blue color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ReflexBlue As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.ReflexBlue
public static PdfPantoneColor ReflexBlue {get;}
public:
static property PdfPantoneColor^ ReflexBlue {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Reflex Blue color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


RhodamineRed Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : RhodamineRed Property
Gets the Pantone Rhodamine Red color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property RhodamineRed As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.RhodamineRed
public static PdfPantoneColor RhodamineRed {get;}
public:
static property PdfPantoneColor^ RhodamineRed {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Rhodamine Red color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


RubineRed Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : RubineRed Property
Gets the Pantone Rubine Red color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property RubineRed As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.RubineRed
public static PdfPantoneColor RubineRed {get;}
public:
static property PdfPantoneColor^ RubineRed {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Rubine Red color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Violet Property (PdfPantoneColor)

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Violet Property
Gets the Pantone Violet color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Violet As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Violet
public static PdfPantoneColor Violet {get;}
public:
static property PdfPantoneColor^ Violet {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Violet color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray1 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray1 Property
Gets the Pantone Warm Gray 1 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray1 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray1
public static PdfPantoneColor WarmGray1 {get;}
public:
static property PdfPantoneColor^ WarmGray1 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 1 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray10 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray10 Property
Gets the Pantone Warm Gray 10 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray10 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray10
public static PdfPantoneColor WarmGray10 {get;}
public:
static property PdfPantoneColor^ WarmGray10 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 10 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray11 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray11 Property
Gets the Pantone Warm Gray 11 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray11 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray11
public static PdfPantoneColor WarmGray11 {get;}
public:
static property PdfPantoneColor^ WarmGray11 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 11 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray2 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray2 Property
Gets the Pantone Warm Gray 2 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray2 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray2
public static PdfPantoneColor WarmGray2 {get;}
public:
static property PdfPantoneColor^ WarmGray2 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 2 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray3 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray3 Property
Gets the Pantone Warm Gray 3 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray3 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray3
public static PdfPantoneColor WarmGray3 {get;}
public:
static property PdfPantoneColor^ WarmGray3 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 3 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray4 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray4 Property
Gets the Pantone Warm Gray 4 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray4 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray4
public static PdfPantoneColor WarmGray4 {get;}
public:
static property PdfPantoneColor^ WarmGray4 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 4 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray5 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray5 Property
Gets the Pantone Warm Gray 5 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray5 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray5
public static PdfPantoneColor WarmGray5 {get;}
public:
static property PdfPantoneColor^ WarmGray5 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 5 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray6 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray6 Property
Gets the Pantone Warm Gray 6 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray6 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray6
public static PdfPantoneColor WarmGray6 {get;}
public:
static property PdfPantoneColor^ WarmGray6 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 6 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray7 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray7 Property
Gets the Pantone Warm Gray 7 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray7 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray7
public static PdfPantoneColor WarmGray7 {get;}
public:
static property PdfPantoneColor^ WarmGray7 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 7 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray8 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray8 Property
Gets the Pantone Warm Gray 8 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray8 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray8
public static PdfPantoneColor WarmGray8 {get;}
public:
static property PdfPantoneColor^ WarmGray8 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 8 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmGray9 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmGray9 Property
Gets the Pantone Warm Gray 9 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmGray9 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmGray9
public static PdfPantoneColor WarmGray9 {get;}
public:
static property PdfPantoneColor^ WarmGray9 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Gray 9 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


WarmRed Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : WarmRed Property
Gets the Pantone Warm Red color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WarmRed As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.WarmRed
public static PdfPantoneColor WarmRed {get;}
public:
static property PdfPantoneColor^ WarmRed {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Warm Red color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Yellow Property (PdfPantoneColor)

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Yellow Property
Gets the Pantone Yellow color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Yellow As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Yellow
public static PdfPantoneColor Yellow {get;}
public:
static property PdfPantoneColor^ Yellow {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Yellow color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


Yellow012 Property

Xfinium.Pdf.Graphics Namespace > PdfPantoneColor Class : Yellow012 Property
Gets the Pantone Yellow 012 color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Yellow012 As PdfPantoneColor
'Usage

Dim value As PdfPantoneColor

value = PdfPantoneColor.Yellow012
public static PdfPantoneColor Yellow012 {get;}
public:
static property PdfPantoneColor^ Yellow012 {
   PdfPantoneColor^ get();
}

Property Value

The Pantone Yellow 012 color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPantoneColor Class
PdfPantoneColor Members


%%PageItemTitle%%

PdfPath Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPath Class
Defines a PDF path.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPath
'Usage

Dim instance As PdfPath
public class PdfPath
public ref class PdfPath
Remarks
A path represents a series of connected lines and curves.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPath

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPath Class Members
Methods

Xfinium.Pdf.Graphics Namespace : PdfPath Class

The following tables list the members exposed by PdfPath.

Public Constructors
 | Name | Description
Public Constructor | PdfPath Constructor | Initializes a new PdfPath object.
Top
Public Methods
 | Name | Description
Public Method | AddBezierTo | Adds a cubic Berzier curve to current subpath.
Public Method | AddEllipse | Adds an ellipse to path.
Public Method | AddLineTo | Adds a line at the end of current subpath.
Public Method | AddPolyBezierTo | Adds a series of connected Bezier curves to current subpath.
Public Method | AddPolygon | Adds a polygon to path.
Public Method | AddPolyLineTo | Adds a series of connected lines at the end of current subpath.
Public Method | AddRectangle | Adds a rectangle to path.
Public Method | AddRoundRectangle | Adds a rounded rectangle to path.
Public Method | CloseSubpath | Closes the current subpath.
Public Method | StartSubpath | Creates a new subpath at the given position.
Top
See Also

Reference

PdfPath Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPath Constructor

Xfinium.Pdf.Graphics Namespace > PdfPath Class : PdfPath Constructor
Initializes a new PdfPath object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPath()
public PdfPath()
public:
PdfPath();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


%%PageItemTitle%% $$Methods$$

PdfPath Class Methods

Xfinium.Pdf.Graphics Namespace : PdfPath Class

For a list of all members of this type, see PdfPath members.

Public Methods
 | Name | Description
Public Method | AddBezierTo | Adds a cubic Berzier curve to current subpath.
Public Method | AddEllipse | Adds an ellipse to path.
Public Method | AddLineTo | Adds a line at the end of current subpath.
Public Method | AddPolyBezierTo | Adds a series of connected Bezier curves to current subpath.
Public Method | AddPolygon | Adds a polygon to path.
Public Method | AddPolyLineTo | Adds a series of connected lines at the end of current subpath.
Public Method | AddRectangle | Adds a rectangle to path.
Public Method | AddRoundRectangle | Adds a rounded rectangle to path.
Public Method | CloseSubpath | Closes the current subpath.
Public Method | StartSubpath | Creates a new subpath at the given position.
Top
See Also

Reference

PdfPath Class
Xfinium.Pdf.Graphics Namespace


AddBezierTo Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : AddBezierTo Method
x position of 1st point.
y position of 1st point.
x position of 2nd point.
y position of 2nd point.
x position of 3rd point.
y position of 3rd point.
Adds a cubic Berzier curve to current subpath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddBezierTo( _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
'Usage

Dim instance As PdfPath
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double

instance.AddBezierTo(x1, y1, x2, y2, x3, y3)
public void AddBezierTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)
public:
void AddBezierTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)

Parameters

x1
x position of 1st point.
y1
y position of 1st point.
x2
x position of 2nd point.
y2
y position of 2nd point.
x3
x position of 3rd point.
y3
y position of 3rd point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


AddEllipse Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : AddEllipse Method
x position of ellipse's top left corner.
y position of ellipse's top left corner.
The ellipse width.
The ellipse height.
Adds an ellipse to path.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddEllipse( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.AddEllipse(left, top, width, height)
public void AddEllipse(
   double left,
   double top,
   double width,
   double height
)
public:
void AddEllipse(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
x position of ellipse's top left corner.
top
y position of ellipse's top left corner.
width
The ellipse width.
height
The ellipse height.
Remarks
The ellipse defines a closed subpath.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


AddLineTo Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : AddLineTo Method
x position of the line ending point.
y position of the line ending point.
Adds a line at the end of current subpath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddLineTo( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PdfPath
Dim x As Double
Dim y As Double

instance.AddLineTo(x, y)
public void AddLineTo(
   double x,
   double y
)
public:
void AddLineTo(
   double x,
   double y
)

Parameters

x
x position of the line ending point.
y
y position of the line ending point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


AddPolyBezierTo Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : AddPolyBezierTo Method
An array of points that define the Bezier curves.
Adds a series of connected Bezier curves to current subpath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddPolyBezierTo( _
   ByVal points() As PdfPoint _
)
'Usage

Dim instance As PdfPath
Dim points() As PdfPoint

instance.AddPolyBezierTo(points)
public void AddPolyBezierTo(
   PdfPoint[] points
)
public:
void AddPolyBezierTo(
   array<PdfPoint^>^ points
)

Parameters

points
An array of points that define the Bezier curves.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when points parameter is null.
Remarks
Each Bezier curve is defined by 4 points. The first curve uses the current point as its first control point and each following curve uses the last point of the previous curve as its first control point.
The last point in the array becomes the new current point in the path.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


AddPolygon Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : AddPolygon Method
An array of points that define the polygon vertices.
Adds a polygon to path.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddPolygon( _
   ByVal points() As PdfPoint _
)
'Usage

Dim instance As PdfPath
Dim points() As PdfPoint

instance.AddPolygon(points)
public void AddPolygon(
   PdfPoint[] points
)
public:
void AddPolygon(
   array<PdfPoint^>^ points
)

Parameters

points
An array of points that define the polygon vertices.
Remarks
The polygon defines a closed subpath.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


AddPolyLineTo Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : AddPolyLineTo Method
An array of points that define the lines.
Adds a series of connected lines at the end of current subpath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddPolyLineTo( _
   ByVal points() As PdfPoint _
)
'Usage

Dim instance As PdfPath
Dim points() As PdfPoint

instance.AddPolyLineTo(points)
public void AddPolyLineTo(
   PdfPoint[] points
)
public:
void AddPolyLineTo(
   array<PdfPoint^>^ points
)

Parameters

points
An array of points that define the lines.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


AddRectangle Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : AddRectangle Method
x position of rectangle's top left corner.
y position of rectangle's top left corner.
The rectangle width.
The rectangle height.
Adds a rectangle to path.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddRectangle( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim instance As PdfPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.AddRectangle(left, top, width, height)
public void AddRectangle(
   double left,
   double top,
   double width,
   double height
)
public:
void AddRectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
x position of rectangle's top left corner.
top
y position of rectangle's top left corner.
width
The rectangle width.
height
The rectangle height.
Remarks
The rectangle defines a closed subpath.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


AddRoundRectangle Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : AddRoundRectangle Method
x position of rectangle's top left corner.
y position of rectangle's top left corner.
The rectangle width.
The rectangle height.
The width of the ellipse that defines the rectangle corners.
The height of the ellipse that defines the rectangle corners.
Adds a rounded rectangle to path.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddRoundRectangle( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
'Usage

Dim instance As PdfPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.AddRoundRectangle(left, top, width, height, ellipseWidth, ellipseHeight)
public void AddRoundRectangle(
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
public:
void AddRoundRectangle(
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

left
x position of rectangle's top left corner.
top
y position of rectangle's top left corner.
width
The rectangle width.
height
The rectangle height.
ellipseWidth
The width of the ellipse that defines the rectangle corners.
ellipseHeight
The height of the ellipse that defines the rectangle corners.
Remarks
The round rectangle defines a closed subpath.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


CloseSubpath Method (PdfPath)

Xfinium.Pdf.Graphics Namespace > PdfPath Class : CloseSubpath Method
Closes the current subpath.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub CloseSubpath()
'Usage

Dim instance As PdfPath

instance.CloseSubpath()
public void CloseSubpath()
public:
void CloseSubpath();
Remarks
A new subpath can be started using StartSubpath method.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


StartSubpath Method

Xfinium.Pdf.Graphics Namespace > PdfPath Class : StartSubpath Method
x position of the new subpath.
y position of the new subpath.
Creates a new subpath at the given position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub StartSubpath( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim instance As PdfPath
Dim x As Double
Dim y As Double

instance.StartSubpath(x, y)
public void StartSubpath(
   double x,
   double y
)
public:
void StartSubpath(
   double x,
   double y
)

Parameters

x
x position of the new subpath.
y
y position of the new subpath.
Remarks
This method ends the previous subpath..
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPath Class
PdfPath Members


%%PageItemTitle%%

PdfPattern Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPattern Class
Defines the base class for PDF patterns.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfPattern
'Usage

Dim instance As PdfPattern
public abstract class PdfPattern
public ref class PdfPattern abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPattern
Xfinium.Pdf.Graphics.PdfShadingPattern
Xfinium.Pdf.Graphics.PdfTilingPattern

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPattern Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPattern Class Members

Xfinium.Pdf.Graphics Namespace : PdfPattern Class

The following tables list the members exposed by PdfPattern.

See Also

Reference

PdfPattern Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPatternBrush Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPatternBrush Class
Defines a brush that uses a pattern to fill the path interior.
Object Model
PdfPatternBrush ClassPdfColor ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPatternBrush
   Inherits PdfBrush
'Usage

Dim instance As PdfPatternBrush
public class PdfPatternBrush : PdfBrush
public ref class PdfPatternBrush : public PdfBrush
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBrush
Xfinium.Pdf.Graphics.PdfPatternBrush

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternBrush Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPatternBrush Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPatternBrush Class

The following tables list the members exposed by PdfPatternBrush.

Public Constructors
 | Name | Description
Public Constructor | PdfPatternBrush Constructor | Initializes a new PdfPatternBrush object.
Top
Public Properties
 | Name | Description
Public Property | Color | Overridden. Gets or sets the color.
Public Property | UncoloredPatternPaintColor | Gets or sets the uncolored pattern paint color.
Top
See Also

Reference

PdfPatternBrush Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPatternBrush Constructor

Xfinium.Pdf.Graphics Namespace > PdfPatternBrush Class : PdfPatternBrush Constructor
The brush color.
Initializes a new PdfPatternBrush object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As PdfPatternColor _
)
'Usage

Dim color As PdfPatternColor

Dim instance As New PdfPatternBrush(color)
public PdfPatternBrush(
   PdfPatternColor color
)
public:
PdfPatternBrush(
   PdfPatternColor^ color
)

Parameters

color
The brush color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternBrush Class
PdfPatternBrush Members


%%PageItemTitle%% $$Properties$$

PdfPatternBrush Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPatternBrush Class

For a list of all members of this type, see PdfPatternBrush members.

Public Properties
 | Name | Description
Public Property | Color | Overridden. Gets or sets the color.
Public Property | UncoloredPatternPaintColor | Gets or sets the uncolored pattern paint color.
Top
See Also

Reference

PdfPatternBrush Class
Xfinium.Pdf.Graphics Namespace


Color Property (PdfPatternBrush)

Xfinium.Pdf.Graphics Namespace > PdfPatternBrush Class : Color Property
Gets or sets the color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Color As PdfColor
'Usage

Dim instance As PdfPatternBrush
Dim value As PdfColor

instance.Color = value

value = instance.Color
public override PdfColor Color {get; set;}
public:
property PdfColor^ Color {
   PdfColor^ get() override;
   void set (    PdfColor^ value) override;
}

Property Value

The brush color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternBrush Class
PdfPatternBrush Members


UncoloredPatternPaintColor Property (PdfPatternBrush)

Xfinium.Pdf.Graphics Namespace > PdfPatternBrush Class : UncoloredPatternPaintColor Property
Gets or sets the uncolored pattern paint color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UncoloredPatternPaintColor As PdfColor
'Usage

Dim instance As PdfPatternBrush
Dim value As PdfColor

instance.UncoloredPatternPaintColor = value

value = instance.UncoloredPatternPaintColor
public PdfColor UncoloredPatternPaintColor {get; set;}
public:
property PdfColor^ UncoloredPatternPaintColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The color used to paint an uncolored pattern.
Remarks
If the pattern colorspace associated with this pen's color contains an uncolored tiling pattern then the pattern will be painted using the color specified in this property.
Note: This property cannot be set to another pattern color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternBrush Class
PdfPatternBrush Members


%%PageItemTitle%%

PdfPatternColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPatternColor Class
Defines a color based on a pattern colorspace.
Object Model
PdfPatternColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPatternColor
   Inherits PdfColor
'Usage

Dim instance As PdfPatternColor
public class PdfPatternColor : PdfColor
public ref class PdfPatternColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfPatternColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPatternColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfPatternColor Class

The following tables list the members exposed by PdfPatternColor.

Public Constructors
 | Name | Description
Public Constructor | PdfPatternColor Constructor | Initializes a new PdfPatternColor object with a pattern colorspace.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfPatternColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPatternColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfPatternColor Class : PdfPatternColor Constructor
The pattern colorspace.
Initializes a new PdfPatternColor object with a pattern colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PdfPatternColorSpace _
)
'Usage

Dim colorSpace As PdfPatternColorSpace

Dim instance As New PdfPatternColor(colorSpace)
public PdfPatternColor(
   PdfPatternColorSpace colorSpace
)
public:
PdfPatternColor(
   PdfPatternColorSpace^ colorSpace
)

Parameters

colorSpace
The pattern colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternColor Class
PdfPatternColor Members


%%PageItemTitle%% $$Methods$$

PdfPatternColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfPatternColor Class

For a list of all members of this type, see PdfPatternColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfPatternColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfPatternColor)

Xfinium.Pdf.Graphics Namespace > PdfPatternColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfPatternColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternColor Class
PdfPatternColor Members


Equals Method (PdfPatternColor)

Xfinium.Pdf.Graphics Namespace > PdfPatternColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfPatternColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternColor Class
PdfPatternColor Members


GetHashCode Method (PdfPatternColor)

Xfinium.Pdf.Graphics Namespace > PdfPatternColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfPatternColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternColor Class
PdfPatternColor Members


%%PageItemTitle%%

PdfPatternColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPatternColorSpace Class
Defines a colorspace based on a PDF pattern.
Object Model
PdfPatternColorSpace ClassPdfCosObject ClassPdfPattern Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPatternColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfPatternColorSpace
public class PdfPatternColorSpace : PdfColorSpace
public ref class PdfPatternColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfPatternColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPatternColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPatternColorSpace Class

The following tables list the members exposed by PdfPatternColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfPatternColorSpace Constructor | Initializes a new PdfPatternColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | ColorComponentCount | Gets the number of components used by a color in this colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Pattern | Gets the PDF pattern.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfPatternColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPatternColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfPatternColorSpace Class : PdfPatternColorSpace Constructor
The pattern associated with this colorspace.
Initializes a new PdfPatternColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pattern As PdfPattern _
)
'Usage

Dim pattern As PdfPattern

Dim instance As New PdfPatternColorSpace(pattern)
public PdfPatternColorSpace(
   PdfPattern pattern
)
public:
PdfPatternColorSpace(
   PdfPattern^ pattern
)

Parameters

pattern
The pattern associated with this colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternColorSpace Class
PdfPatternColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfPatternColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPatternColorSpace Class

For a list of all members of this type, see PdfPatternColorSpace members.

Public Properties
 | Name | Description
Public Property | ColorComponentCount | Gets the number of components used by a color in this colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Pattern | Gets the PDF pattern.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfPatternColorSpace Class
Xfinium.Pdf.Graphics Namespace


Pattern Property

Xfinium.Pdf.Graphics Namespace > PdfPatternColorSpace Class : Pattern Property
Gets the PDF pattern.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Pattern As PdfPattern
'Usage

Dim instance As PdfPatternColorSpace
Dim value As PdfPattern

value = instance.Pattern
public PdfPattern Pattern {get;}
public:
property PdfPattern^ Pattern {
   PdfPattern^ get();
}

Property Value

The pattern associated with this colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternColorSpace Class
PdfPatternColorSpace Members


%%PageItemTitle%%

PdfPatternPen Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPatternPen Class
Defines a pen that uses a pattern based color for stroking a path.
Object Model
PdfPatternPen ClassPdfColor ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPatternPen
   Inherits PdfPen
'Usage

Dim instance As PdfPatternPen
public class PdfPatternPen : PdfPen
public ref class PdfPatternPen : public PdfPen
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPen
Xfinium.Pdf.Graphics.PdfPatternPen

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternPen Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPatternPen Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPatternPen Class

The following tables list the members exposed by PdfPatternPen.

Public Constructors
 | Name | Description
Public Constructor | PdfPatternPen Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Overridden. Gets or sets the pen color.
Public Property | DashOffset | Gets or sets the dash offset. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Public Property | DashPattern | Gets or sets the dash pattern. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Public Property | LineCap | Gets or sets the line cap style. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Public Property | LineJoin | Gets or sets the line join style. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Public Property | UncoloredPatternPaintColor | Gets or sets the uncolored pattern paint color.
Public Property | Width | Gets or sets the pen width. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Top
See Also

Reference

PdfPatternPen Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPatternPen Constructor

Xfinium.Pdf.Graphics Namespace > PdfPatternPen Class : PdfPatternPen Constructor
Overload List
Overload | Description
PdfPatternPen Constructor(PdfPatternColor,Double) | Initializes a new PdfPatternPen object.
PdfPatternPen Constructor(PdfPatternPen) | Initializes a new PdfPen object with another pen.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternPen Class
PdfPatternPen Members


%%PageItemTitle%%

PdfPatternPen Constructor(PdfPatternColor,Double)

Xfinium.Pdf.Graphics Namespace > PdfPatternPen Class > PdfPatternPen Constructor : PdfPatternPen Constructor(PdfPatternColor,Double)
Pen color.
Pen width.
Initializes a new PdfPatternPen object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As PdfPatternColor, _
   ByVal width As Double _
)
'Usage

Dim color As PdfPatternColor
Dim width As Double

Dim instance As New PdfPatternPen(color, width)
public PdfPatternPen(
   PdfPatternColor color,
   double width
)
public:
PdfPatternPen(
   PdfPatternColor^ color,
   double width
)

Parameters

color
Pen color.
width
Pen width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternPen Class
PdfPatternPen Members
Overload List


%%PageItemTitle%%

PdfPatternPen Constructor(PdfPatternPen)

Xfinium.Pdf.Graphics Namespace > PdfPatternPen Class > PdfPatternPen Constructor : PdfPatternPen Constructor(PdfPatternPen)
Source pen.
Initializes a new PdfPen object with another pen.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pen As PdfPatternPen _
)
'Usage

Dim pen As PdfPatternPen

Dim instance As New PdfPatternPen(pen)
public PdfPatternPen(
   PdfPatternPen pen
)
public:
PdfPatternPen(
   PdfPatternPen^ pen
)

Parameters

pen
Source pen.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternPen Class
PdfPatternPen Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfPatternPen Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPatternPen Class

For a list of all members of this type, see PdfPatternPen members.

Public Properties
 | Name | Description
Public Property | Color | Overridden. Gets or sets the pen color.
Public Property | DashOffset | Gets or sets the dash offset. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Public Property | DashPattern | Gets or sets the dash pattern. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Public Property | LineCap | Gets or sets the line cap style. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Public Property | LineJoin | Gets or sets the line join style. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Public Property | UncoloredPatternPaintColor | Gets or sets the uncolored pattern paint color.
Public Property | Width | Gets or sets the pen width. (Inherited from Xfinium.Pdf.Graphics.PdfPen)
Top
See Also

Reference

PdfPatternPen Class
Xfinium.Pdf.Graphics Namespace


Color Property (PdfPatternPen)

Xfinium.Pdf.Graphics Namespace > PdfPatternPen Class : Color Property
Gets or sets the pen color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Color As PdfColor
'Usage

Dim instance As PdfPatternPen
Dim value As PdfColor

instance.Color = value

value = instance.Color
public override PdfColor Color {get; set;}
public:
property PdfColor^ Color {
   PdfColor^ get() override;
   void set (    PdfColor^ value) override;
}

Property Value

The pen color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternPen Class
PdfPatternPen Members


UncoloredPatternPaintColor Property (PdfPatternPen)

Xfinium.Pdf.Graphics Namespace > PdfPatternPen Class : UncoloredPatternPaintColor Property
Gets or sets the uncolored pattern paint color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UncoloredPatternPaintColor As PdfColor
'Usage

Dim instance As PdfPatternPen
Dim value As PdfColor

instance.UncoloredPatternPaintColor = value

value = instance.UncoloredPatternPaintColor
public PdfColor UncoloredPatternPaintColor {get; set;}
public:
property PdfColor^ UncoloredPatternPaintColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The color used to paint an uncolored pattern.
Remarks
If the pattern colorspace associated with this pen's color contains an uncolored tiling pattern then the pattern will be painted using the color specified in this property.
Note: This property cannot be set to another pattern color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPatternPen Class
PdfPatternPen Members


%%PageItemTitle%%

PdfPen Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPen Class
Defines a PDF pen.
Object Model
PdfPen ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPen
'Usage

Dim instance As PdfPen
public class PdfPen
public ref class PdfPen
Remarks
The pen is used to stroke a path with a color.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPen
Xfinium.Pdf.Graphics.PdfPatternPen

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPen Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPen Class

The following tables list the members exposed by PdfPen.

Public Constructors
 | Name | Description
Public Constructor | PdfPen Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the pen color.
Public Property | DashOffset | Gets or sets the dash offset.
Public Property | DashPattern | Gets or sets the dash pattern.
Public Property | LineCap | Gets or sets the line cap style.
Public Property | LineJoin | Gets or sets the line join style.
Public Property | Width | Gets or sets the pen width.
Top
See Also

Reference

PdfPen Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPen Constructor

Xfinium.Pdf.Graphics Namespace > PdfPen Class : PdfPen Constructor
Overload List
Overload | Description
PdfPen Constructor(PdfColor,Double) | Initializes a new PdfPen object.
PdfPen Constructor() | Initializes a new PdfPen object with a default RGB black color and a width of 1 point.
PdfPen Constructor(PdfPen) | Initializes a new PdfPen object with another pen.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members


%%PageItemTitle%%

PdfPen Constructor(PdfColor,Double)

Xfinium.Pdf.Graphics Namespace > PdfPen Class > PdfPen Constructor : PdfPen Constructor(PdfColor,Double)
Pen color.
Pen width.
Initializes a new PdfPen object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal color As PdfColor, _
   ByVal width As Double _
)
'Usage

Dim color As PdfColor
Dim width As Double

Dim instance As New PdfPen(color, width)
public PdfPen(
   PdfColor color,
   double width
)
public:
PdfPen(
   PdfColor^ color,
   double width
)

Parameters

color
Pen color.
width
Pen width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members
Overload List


%%PageItemTitle%%

PdfPen Constructor()

Xfinium.Pdf.Graphics Namespace > PdfPen Class > PdfPen Constructor : PdfPen Constructor()
Initializes a new PdfPen object with a default RGB black color and a width of 1 point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPen()
public PdfPen()
public:
PdfPen();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members
Overload List


%%PageItemTitle%%

PdfPen Constructor(PdfPen)

Xfinium.Pdf.Graphics Namespace > PdfPen Class > PdfPen Constructor : PdfPen Constructor(PdfPen)
Source pen.
Initializes a new PdfPen object with another pen.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pen As PdfPen _
)
'Usage

Dim pen As PdfPen

Dim instance As New PdfPen(pen)
public PdfPen(
   PdfPen pen
)
public:
PdfPen(
   PdfPen^ pen
)

Parameters

pen
Source pen.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfPen Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPen Class

For a list of all members of this type, see PdfPen members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the pen color.
Public Property | DashOffset | Gets or sets the dash offset.
Public Property | DashPattern | Gets or sets the dash pattern.
Public Property | LineCap | Gets or sets the line cap style.
Public Property | LineJoin | Gets or sets the line join style.
Public Property | Width | Gets or sets the pen width.
Top
See Also

Reference

PdfPen Class
Xfinium.Pdf.Graphics Namespace


Color Property (PdfPen)

Xfinium.Pdf.Graphics Namespace > PdfPen Class : Color Property
Gets or sets the pen color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property Color As PdfColor
'Usage

Dim instance As PdfPen
Dim value As PdfColor

instance.Color = value

value = instance.Color
public virtual PdfColor Color {get; set;}
public:
virtual property PdfColor^ Color {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The pen color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members


DashOffset Property

Xfinium.Pdf.Graphics Namespace > PdfPen Class : DashOffset Property
Gets or sets the dash offset.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DashOffset As Double
'Usage

Dim instance As PdfPen
Dim value As Double

instance.DashOffset = value

value = instance.DashOffset
public double DashOffset {get; set;}
public:
property double DashOffset {
   double get();
   void set (    double value);
}

Property Value

The distance from the start of a line to the beginning of a dash pattern.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members


DashPattern Property

Xfinium.Pdf.Graphics Namespace > PdfPen Class : DashPattern Property
Gets or sets the dash pattern.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DashPattern As Double()
'Usage

Dim instance As PdfPen
Dim value() As Double

instance.DashPattern = value

value = instance.DashPattern
public double[] DashPattern {get; set;}
public:
property array<double>^ DashPattern {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of custom dashes and spaces.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members


LineCap Property (PdfPen)

Xfinium.Pdf.Graphics Namespace > PdfPen Class : LineCap Property
Gets or sets the line cap style.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineCap As PdfLineCap
'Usage

Dim instance As PdfPen
Dim value As PdfLineCap

instance.LineCap = value

value = instance.LineCap
public PdfLineCap LineCap {get; set;}
public:
property PdfLineCap LineCap {
   PdfLineCap get();
   void set (    PdfLineCap value);
}

Property Value

The line cap style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members


LineJoin Property (PdfPen)

Xfinium.Pdf.Graphics Namespace > PdfPen Class : LineJoin Property
Gets or sets the line join style.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineJoin As PdfLineJoin
'Usage

Dim instance As PdfPen
Dim value As PdfLineJoin

instance.LineJoin = value

value = instance.LineJoin
public PdfLineJoin LineJoin {get; set;}
public:
property PdfLineJoin LineJoin {
   PdfLineJoin get();
   void set (    PdfLineJoin value);
}

Property Value

The line join style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members


Width Property (PdfPen)

Xfinium.Pdf.Graphics Namespace > PdfPen Class : Width Property
Gets or sets the pen width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PdfPen
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of the pen.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPen Class
PdfPen Members


%%PageItemTitle%%

PdfPharmacodeBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPharmacodeBarcode Class
Defines a Pharmacode barcode.
Object Model
PdfPharmacodeBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPharmacodeBarcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfPharmacodeBarcode
public class PdfPharmacodeBarcode : Pdf1DBarcode
public ref class PdfPharmacodeBarcode : public Pdf1DBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data must represent a number between 3 and 131070.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfPharmacodeBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPharmacodeBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPharmacodeBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPharmacodeBarcode Class

The following tables list the members exposed by PdfPharmacodeBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfPharmacodeBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | IntercharacterSpaceSize | Gets or sets the space between encoded characters.
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio.
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPharmacodeBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPharmacodeBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfPharmacodeBarcode Class : PdfPharmacodeBarcode Constructor
Overload List
Overload | Description
PdfPharmacodeBarcode Constructor() | Initializes a new PdfPharmacodeBarcode object.
PdfPharmacodeBarcode Constructor(String) | Initializes a new PdfPharmacodeBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPharmacodeBarcode Class
PdfPharmacodeBarcode Members


%%PageItemTitle%%

PdfPharmacodeBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfPharmacodeBarcode Class > PdfPharmacodeBarcode Constructor : PdfPharmacodeBarcode Constructor()
Initializes a new PdfPharmacodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPharmacodeBarcode()
public PdfPharmacodeBarcode()
public:
PdfPharmacodeBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPharmacodeBarcode Class
PdfPharmacodeBarcode Members
Overload List


%%PageItemTitle%%

PdfPharmacodeBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfPharmacodeBarcode Class > PdfPharmacodeBarcode Constructor : PdfPharmacodeBarcode Constructor(String)
The barcode data.
Initializes a new PdfPharmacodeBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfPharmacodeBarcode(data)
public PdfPharmacodeBarcode(
   string data
)
public:
PdfPharmacodeBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPharmacodeBarcode Class
PdfPharmacodeBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfPharmacodeBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPharmacodeBarcode Class

For a list of all members of this type, see PdfPharmacodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | IntercharacterSpaceSize | Gets or sets the space between encoded characters.
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio.
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPharmacodeBarcode Class
Xfinium.Pdf.Graphics Namespace


IntercharacterSpaceSize Property

Xfinium.Pdf.Graphics Namespace > PdfPharmacodeBarcode Class : IntercharacterSpaceSize Property
Gets or sets the space between encoded characters.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IntercharacterSpaceSize As Double
'Usage

Dim instance As PdfPharmacodeBarcode
Dim value As Double

instance.IntercharacterSpaceSize = value

value = instance.IntercharacterSpaceSize
public double IntercharacterSpaceSize {get; set;}
public:
property double IntercharacterSpaceSize {
   double get();
   void set (    double value);
}

Property Value

The space between the encoded characters.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPharmacodeBarcode Class
PdfPharmacodeBarcode Members


WideToNarrowRatio Property (PdfPharmacodeBarcode)

Xfinium.Pdf.Graphics Namespace > PdfPharmacodeBarcode Class : WideToNarrowRatio Property
Gets or sets the wide to narrow ratio.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WideToNarrowRatio As Double
'Usage

Dim instance As PdfPharmacodeBarcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
public double WideToNarrowRatio {get; set;}
public:
property double WideToNarrowRatio {
   double get();
   void set (    double value);
}

Property Value

The ratio between wide and narrow bars.
Remarks
Recommended ratio: 2.2:1 to 3:1.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPharmacodeBarcode Class
PdfPharmacodeBarcode Members


%%PageItemTitle%%

PdfPlanetBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPlanetBarcode Class
Defines a Planet barcode.
Object Model
PdfPlanetBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPlanetBarcode
   Inherits PdfPostalBarcode
'Usage

Dim instance As PdfPlanetBarcode
public class PdfPlanetBarcode : PdfPostalBarcode
public ref class PdfPlanetBarcode : public PdfPostalBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfPostalBarcode
Xfinium.Pdf.Graphics.PdfPlanetBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPlanetBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPlanetBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPlanetBarcode Class

The following tables list the members exposed by PdfPlanetBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfPlanetBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPlanetBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPlanetBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfPlanetBarcode Class : PdfPlanetBarcode Constructor
Overload List
Overload | Description
PdfPlanetBarcode Constructor() | Initializes a new PdfPlanetBarcode object.
PdfPlanetBarcode Constructor(String) | Initializes a new PdfPlanetBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPlanetBarcode Class
PdfPlanetBarcode Members


%%PageItemTitle%%

PdfPlanetBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfPlanetBarcode Class > PdfPlanetBarcode Constructor : PdfPlanetBarcode Constructor()
Initializes a new PdfPlanetBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPlanetBarcode()
public PdfPlanetBarcode()
public:
PdfPlanetBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPlanetBarcode Class
PdfPlanetBarcode Members
Overload List


%%PageItemTitle%%

PdfPlanetBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfPlanetBarcode Class > PdfPlanetBarcode Constructor : PdfPlanetBarcode Constructor(String)
The barcode data.
Initializes a new PdfPlanetBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfPlanetBarcode(data)
public PdfPlanetBarcode(
   string data
)
public:
PdfPlanetBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPlanetBarcode Class
PdfPlanetBarcode Members
Overload List


%%PageItemTitle%%

PdfPngImage Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPngImage Class
Defines a PNG image.
Object Model
PdfPngImage ClassPdfAlternateImageCollection ClassPdfAlternateImage ClassPdfColorSpace ClassPdfCosDictionary ClassPdfImageMask ClassPdfMeasure ClassPdfPointData Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPngImage
   Inherits PdfImage
'Usage

Dim instance As PdfPngImage
public class PdfPngImage : PdfImage
public ref class PdfPngImage : public PdfImage
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImage
Xfinium.Pdf.Graphics.PdfPngImage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPngImage Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPngImage Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPngImage Class

The following tables list the members exposed by PdfPngImage.

Public Constructors
 | Name | Description
Public Constructor | PdfPngImage Constructor | Initializes a new PdfPngImage object.
Top
Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfPngImage Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPngImage Constructor

Xfinium.Pdf.Graphics Namespace > PdfPngImage Class : PdfPngImage Constructor
PNG stream.
Initializes a new PdfPngImage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfPngImage(stream)
public PdfPngImage(
   Stream stream
)
public:
PdfPngImage(
   Stream^ stream
)

Parameters

stream
PNG stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPngImage Class
PdfPngImage Members


%%PageItemTitle%% $$Properties$$

PdfPngImage Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPngImage Class

For a list of all members of this type, see PdfPngImage members.

Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfPngImage Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfPngImage)

Xfinium.Pdf.Graphics Namespace > PdfPngImage Class : Height Property
Gets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PdfPngImage
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The image height in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPngImage Class
PdfPngImage Members


Width Property (PdfPngImage)

Xfinium.Pdf.Graphics Namespace > PdfPngImage Class : Width Property
Gets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PdfPngImage
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The image width in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPngImage Class
PdfPngImage Members


%%PageItemTitle%%

PdfPoint Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPoint Class
Defines a PDF point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPoint
'Usage

Dim instance As PdfPoint
public class PdfPoint
public ref class PdfPoint
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPoint

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPoint Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPoint Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfPoint Class

The following tables list the members exposed by PdfPoint.

Public Constructors
 | Name | Description
Public Constructor | PdfPoint Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | X | Gets or set the x position.
Public Property | Y | Gets or set the y position.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfPoint Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPoint Constructor

Xfinium.Pdf.Graphics Namespace > PdfPoint Class : PdfPoint Constructor
Overload List
Overload | Description
PdfPoint Constructor() | Initializes a new PdfPoint object.
PdfPoint Constructor(Double,Double) | Initializes a new PdfPoint object with the specified position.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPoint Class
PdfPoint Members


%%PageItemTitle%%

PdfPoint Constructor()

Xfinium.Pdf.Graphics Namespace > PdfPoint Class > PdfPoint Constructor : PdfPoint Constructor()
Initializes a new PdfPoint object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPoint()
public PdfPoint()
public:
PdfPoint();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPoint Class
PdfPoint Members
Overload List


%%PageItemTitle%%

PdfPoint Constructor(Double,Double)

Xfinium.Pdf.Graphics Namespace > PdfPoint Class > PdfPoint Constructor : PdfPoint Constructor(Double,Double)
The x position.
The y position.
Initializes a new PdfPoint object with the specified position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim x As Double
Dim y As Double

Dim instance As New PdfPoint(x, y)
public PdfPoint(
   double x,
   double y
)
public:
PdfPoint(
   double x,
   double y
)

Parameters

x
The x position.
y
The y position.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPoint Class
PdfPoint Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfPoint Class Methods

Xfinium.Pdf.Graphics Namespace : PdfPoint Class

For a list of all members of this type, see PdfPoint members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfPoint Class
Xfinium.Pdf.Graphics Namespace


ToString Method (PdfPoint)

Xfinium.Pdf.Graphics Namespace > PdfPoint Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfPoint
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPoint Class
PdfPoint Members


%%PageItemTitle%% $$Properties$$

PdfPoint Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPoint Class

For a list of all members of this type, see PdfPoint members.

Public Properties
 | Name | Description
Public Property | X | Gets or set the x position.
Public Property | Y | Gets or set the y position.
Top
See Also

Reference

PdfPoint Class
Xfinium.Pdf.Graphics Namespace


X Property (PdfPoint)

Xfinium.Pdf.Graphics Namespace > PdfPoint Class : X Property
Gets or set the x position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X As Double
'Usage

Dim instance As PdfPoint
Dim value As Double

instance.X = value

value = instance.X
public double X {get; set;}
public:
property double X {
   double get();
   void set (    double value);
}

Property Value

The x coodinate of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPoint Class
PdfPoint Members


Y Property (PdfPoint)

Xfinium.Pdf.Graphics Namespace > PdfPoint Class : Y Property
Gets or set the y position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PdfPoint
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

The y coodinate of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPoint Class
PdfPoint Members


%%PageItemTitle%%

PdfPostalBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPostalBarcode Class
Defines the base class for postal related barcodes.
Object Model
PdfPostalBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfPostalBarcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfPostalBarcode
public abstract class PdfPostalBarcode : Pdf1DBarcode
public ref class PdfPostalBarcode abstract : public Pdf1DBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfPostalBarcode
Xfinium.Pdf.Graphics.PdfPlanetBarcode
Xfinium.Pdf.Graphics.PdfPostNetBarcode
Xfinium.Pdf.Graphics.PdfRm4sccBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostalBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPostalBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPostalBarcode Class

The following tables list the members exposed by PdfPostalBarcode.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPostalBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPostNetBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPostNetBarcode Class
Defines a PostNet barcode.
Object Model
PdfPostNetBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPostNetBarcode
   Inherits PdfPostalBarcode
'Usage

Dim instance As PdfPostNetBarcode
public class PdfPostNetBarcode : PdfPostalBarcode
public ref class PdfPostNetBarcode : public PdfPostalBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfPostalBarcode
Xfinium.Pdf.Graphics.PdfPostNetBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostNetBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPostNetBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPostNetBarcode Class

The following tables list the members exposed by PdfPostNetBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfPostNetBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPostNetBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPostNetBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfPostNetBarcode Class : PdfPostNetBarcode Constructor
Overload List
Overload | Description
PdfPostNetBarcode Constructor() | Initializes a new PdfPostNetBarcode object.
PdfPostNetBarcode Constructor(String) | Initializes a new PdfPostNetBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostNetBarcode Class
PdfPostNetBarcode Members


%%PageItemTitle%%

PdfPostNetBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfPostNetBarcode Class > PdfPostNetBarcode Constructor : PdfPostNetBarcode Constructor()
Initializes a new PdfPostNetBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPostNetBarcode()
public PdfPostNetBarcode()
public:
PdfPostNetBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostNetBarcode Class
PdfPostNetBarcode Members
Overload List


%%PageItemTitle%%

PdfPostNetBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfPostNetBarcode Class > PdfPostNetBarcode Constructor : PdfPostNetBarcode Constructor(String)
The barcode data.
Initializes a new PdfPostNetBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfPostNetBarcode(data)
public PdfPostNetBarcode(
   string data
)
public:
PdfPostNetBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostNetBarcode Class
PdfPostNetBarcode Members
Overload List


%%PageItemTitle%%

PdfPznBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfPznBarcode Class
Defines a PZN barcode.
Object Model
PdfPznBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPznBarcode
   Inherits PdfCode39Barcode
'Usage

Dim instance As PdfPznBarcode
public class PdfPznBarcode : PdfCode39Barcode
public ref class PdfPznBarcode : public PdfCode39Barcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 6 digits
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode39Barcode
Xfinium.Pdf.Graphics.PdfPznBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPznBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfPznBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfPznBarcode Class

The following tables list the members exposed by PdfPznBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfPznBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode39Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPznBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPznBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfPznBarcode Class : PdfPznBarcode Constructor
Overload List
Overload | Description
PdfPznBarcode Constructor() | Initializes a new PdfPznBarcode object.
PdfPznBarcode Constructor(String) | Initializes a new PdfPznBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPznBarcode Class
PdfPznBarcode Members


%%PageItemTitle%%

PdfPznBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfPznBarcode Class > PdfPznBarcode Constructor : PdfPznBarcode Constructor()
Initializes a new PdfPznBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPznBarcode()
public PdfPznBarcode()
public:
PdfPznBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPznBarcode Class
PdfPznBarcode Members
Overload List


%%PageItemTitle%%

PdfPznBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfPznBarcode Class > PdfPznBarcode Constructor : PdfPznBarcode Constructor(String)
The barcode data.
Initializes a new PdfPznBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfPznBarcode(data)
public PdfPznBarcode(
   string data
)
public:
PdfPznBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPznBarcode Class
PdfPznBarcode Members
Overload List


%%PageItemTitle%%

PdfQrBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfQrBarcode Class
Defines a QR barcode.
Object Model
PdfQrBarcode ClassPdfColor ClassPdfColor ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfQrBarcode
   Inherits Pdf2DBarcode
'Usage

Dim instance As PdfQrBarcode
public class PdfQrBarcode : Pdf2DBarcode
public ref class PdfQrBarcode : public Pdf2DBarcode
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf2DBarcode
Xfinium.Pdf.Graphics.PdfQrBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfQrBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfQrBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfQrBarcode Class

The following tables list the members exposed by PdfQrBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfQrBarcode Constructor | Iniitalizes a new PdfQrBarcode object.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | CharacterSet | Gets or sets the character set.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level.
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfQrBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfQrBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfQrBarcode Class : PdfQrBarcode Constructor
Iniitalizes a new PdfQrBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfQrBarcode()
public PdfQrBarcode()
public:
PdfQrBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfQrBarcode Class
PdfQrBarcode Members


%%PageItemTitle%% $$Properties$$

PdfQrBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfQrBarcode Class

For a list of all members of this type, see PdfQrBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BinaryData | Gets or sets the binary data. (Inherited from Xfinium.Pdf.Graphics.Pdf2DBarcode)
Public Property | CharacterSet | Gets or sets the character set.
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the error correction level.
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfQrBarcode Class
Xfinium.Pdf.Graphics Namespace


CharacterSet Property

Xfinium.Pdf.Graphics Namespace > PdfQrBarcode Class : CharacterSet Property
Gets or sets the character set.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CharacterSet As PdfQrBarcodeCharacterSet
'Usage

Dim instance As PdfQrBarcode
Dim value As PdfQrBarcodeCharacterSet

instance.CharacterSet = value

value = instance.CharacterSet
public PdfQrBarcodeCharacterSet CharacterSet {get; set;}
public:
property PdfQrBarcodeCharacterSet CharacterSet {
   PdfQrBarcodeCharacterSet get();
   void set (    PdfQrBarcodeCharacterSet value);
}

Property Value

The character set used to encode the barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfQrBarcode Class
PdfQrBarcode Members


ErrorCorrectionLevel Property (PdfQrBarcode)

Xfinium.Pdf.Graphics Namespace > PdfQrBarcode Class : ErrorCorrectionLevel Property
Gets or sets the error correction level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ErrorCorrectionLevel As PdfQrBarcodeErrorCorrectionLevel
'Usage

Dim instance As PdfQrBarcode
Dim value As PdfQrBarcodeErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
public PdfQrBarcodeErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
public:
property PdfQrBarcodeErrorCorrectionLevel ErrorCorrectionLevel {
   PdfQrBarcodeErrorCorrectionLevel get();
   void set (    PdfQrBarcodeErrorCorrectionLevel value);
}

Property Value

The error correction level for the barcode.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfQrBarcode Class
PdfQrBarcode Members


%%PageItemTitle%%

PdfRadialShading Class
Members

Xfinium.Pdf.Graphics Namespace : PdfRadialShading Class
Defines a radial (type 3) shading.
Object Model
PdfRadialShading ClassPdfColorSpace ClassPdfPoint ClassPdfColor ClassPdfFunction ClassPdfPoint ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRadialShading
   Inherits PdfShading
'Usage

Dim instance As PdfRadialShading
public class PdfRadialShading : PdfShading
public ref class PdfRadialShading : public PdfShading
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfShading
Xfinium.Pdf.Graphics.PdfRadialShading

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfRadialShading Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfRadialShading Class

The following tables list the members exposed by PdfRadialShading.

Public Constructors
 | Name | Description
Public Constructor | PdfRadialShading Constructor | Initializes a new PdfRadialShading object.
Top
Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | ColorSpace | Gets or sets the shading color space. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | Domain | Gets or sets the shading domain.
Public Property | EndCircleCenter | Gets or sets the position of the ending circle.
Public Property | EndCircleRadius | Gets or sets the radius of the ending circle.
Public Property | EndColor | Gets or sets the shading end color.
Public Property | ExtendEnd | Gets or sets a value indicating whether to extend shading beyond the ending circle.
Public Property | ExtendStart | Gets or sets a value indicating whether to extend shading beyond the starting circle.
Public Property | Function | Gets or sets the shading function.
Public Property | StartCircleCenter | Gets or sets the position of the starting circle.
Public Property | StartCircleRadius | Gets or sets the radius of the starting circle.
Public Property | StartColor | Gets or sets the shading start color.
Top
See Also

Reference

PdfRadialShading Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfRadialShading Constructor

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : PdfRadialShading Constructor
Initializes a new PdfRadialShading object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRadialShading()
public PdfRadialShading()
public:
PdfRadialShading();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


%%PageItemTitle%% $$Properties$$

PdfRadialShading Class Properties

Xfinium.Pdf.Graphics Namespace : PdfRadialShading Class

For a list of all members of this type, see PdfRadialShading members.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | ColorSpace | Gets or sets the shading color space. (Inherited from Xfinium.Pdf.Graphics.PdfShading)
Public Property | Domain | Gets or sets the shading domain.
Public Property | EndCircleCenter | Gets or sets the position of the ending circle.
Public Property | EndCircleRadius | Gets or sets the radius of the ending circle.
Public Property | EndColor | Gets or sets the shading end color.
Public Property | ExtendEnd | Gets or sets a value indicating whether to extend shading beyond the ending circle.
Public Property | ExtendStart | Gets or sets a value indicating whether to extend shading beyond the starting circle.
Public Property | Function | Gets or sets the shading function.
Public Property | StartCircleCenter | Gets or sets the position of the starting circle.
Public Property | StartCircleRadius | Gets or sets the radius of the starting circle.
Public Property | StartColor | Gets or sets the shading start color.
Top
See Also

Reference

PdfRadialShading Class
Xfinium.Pdf.Graphics Namespace


Domain Property (PdfRadialShading)

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : Domain Property
Gets or sets the shading domain.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Domain As Double()
'Usage

Dim instance As PdfRadialShading
Dim value() As Double

instance.Domain = value

value = instance.Domain
public double[] Domain {get; set;}
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of two numbers [t0 t1] specifying the limiting values of a parametric variable t.
Remarks
The variable is considered to vary linearly between these two values as the color gradient varies between the starting and ending circles. The variable t becomes the input argument to the shading function.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


EndCircleCenter Property

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : EndCircleCenter Property
Gets or sets the position of the ending circle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndCircleCenter As PdfPoint
'Usage

Dim instance As PdfRadialShading
Dim value As PdfPoint

instance.EndCircleCenter = value

value = instance.EndCircleCenter
public PdfPoint EndCircleCenter {get; set;}
public:
property PdfPoint^ EndCircleCenter {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The position in shading's target coordinate system of the ending circle center.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


EndCircleRadius Property

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : EndCircleRadius Property
Gets or sets the radius of the ending circle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndCircleRadius As Double
'Usage

Dim instance As PdfRadialShading
Dim value As Double

instance.EndCircleRadius = value

value = instance.EndCircleRadius
public double EndCircleRadius {get; set;}
public:
property double EndCircleRadius {
   double get();
   void set (    double value);
}

Property Value

The radius of the ending circle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


EndColor Property (PdfRadialShading)

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : EndColor Property
Gets or sets the shading end color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EndColor As PdfColor
'Usage

Dim instance As PdfRadialShading
Dim value As PdfColor

instance.EndColor = value

value = instance.EndColor
public PdfColor EndColor {get; set;}
public:
property PdfColor^ EndColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The shading end color.
Remarks
The StartColor and EndColor can be set only when the shading uses an exponential function (Xfinium.Pdf.PdfFunctions.PdfExponentialFunction).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


ExtendEnd Property (PdfRadialShading)

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : ExtendEnd Property
Gets or sets a value indicating whether to extend shading beyond the ending circle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExtendEnd As Boolean
'Usage

Dim instance As PdfRadialShading
Dim value As Boolean

instance.ExtendEnd = value

value = instance.ExtendEnd
public bool ExtendEnd {get; set;}
public:
property bool ExtendEnd {
   bool get();
   void set (    bool value);
}

Property Value

If true, the shading will be extended beyond the ending circle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


ExtendStart Property (PdfRadialShading)

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : ExtendStart Property
Gets or sets a value indicating whether to extend shading beyond the starting circle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExtendStart As Boolean
'Usage

Dim instance As PdfRadialShading
Dim value As Boolean

instance.ExtendStart = value

value = instance.ExtendStart
public bool ExtendStart {get; set;}
public:
property bool ExtendStart {
   bool get();
   void set (    bool value);
}

Property Value

If true, the shading will be extended beyond the starting circle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


Function Property (PdfRadialShading)

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : Function Property
Gets or sets the shading function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Function As PdfFunction
'Usage

Dim instance As PdfRadialShading
Dim value As PdfFunction

instance.Function = value

value = instance.Function
public PdfFunction Function {get; set;}
public:
property PdfFunction^ Function {
   PdfFunction^ get();
   void set (    PdfFunction^ value);
}

Property Value

A 1-in, n-out function, where n is the number of color components in the shading dictionary's color space
Remarks
The function is called with values of the parametric variable t in the domain defined by the Domain property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


StartCircleCenter Property

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : StartCircleCenter Property
Gets or sets the position of the starting circle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartCircleCenter As PdfPoint
'Usage

Dim instance As PdfRadialShading
Dim value As PdfPoint

instance.StartCircleCenter = value

value = instance.StartCircleCenter
public PdfPoint StartCircleCenter {get; set;}
public:
property PdfPoint^ StartCircleCenter {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The position in shading's target coordinate system of the starting circle center.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


StartCircleRadius Property

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : StartCircleRadius Property
Gets or sets the radius of the starting circle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartCircleRadius As Double
'Usage

Dim instance As PdfRadialShading
Dim value As Double

instance.StartCircleRadius = value

value = instance.StartCircleRadius
public double StartCircleRadius {get; set;}
public:
property double StartCircleRadius {
   double get();
   void set (    double value);
}

Property Value

The radius of the starting circle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


StartColor Property (PdfRadialShading)

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : StartColor Property
Gets or sets the shading start color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartColor As PdfColor
'Usage

Dim instance As PdfRadialShading
Dim value As PdfColor

instance.StartColor = value

value = instance.StartColor
public PdfColor StartColor {get; set;}
public:
property PdfColor^ StartColor {
   PdfColor^ get();
   void set (    PdfColor^ value);
}

Property Value

The shading start color.
Remarks
The StartColor and EndColor can be set only when the shading uses an exponential function (Xfinium.Pdf.PdfFunctions.PdfExponentialFunction).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


%%PageItemTitle%%

PdfRawImage Class
Members

Xfinium.Pdf.Graphics Namespace : PdfRawImage Class
Defines a RAW image.
Object Model
PdfRawImage ClassPdfAlternateImageCollection ClassPdfAlternateImage ClassPdfColorSpace ClassPdfCosDictionary ClassPdfImageMask ClassPdfMeasure ClassPdfPointData Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRawImage
   Inherits PdfImage
'Usage

Dim instance As PdfRawImage
public class PdfRawImage : PdfImage
public ref class PdfRawImage : public PdfImage
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImage
Xfinium.Pdf.Graphics.PdfRawImage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRawImage Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfRawImage Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfRawImage Class

The following tables list the members exposed by PdfRawImage.

Public Constructors
 | Name | Description
Public Constructor | PdfRawImage Constructor | Initializes a new PdfRawImage object.
Top
Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfRawImage Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfRawImage Constructor

Xfinium.Pdf.Graphics Namespace > PdfRawImage Class : PdfRawImage Constructor
Raw image stream.
Initializes a new PdfRawImage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfRawImage(stream)
public PdfRawImage(
   Stream stream
)
public:
PdfRawImage(
   Stream^ stream
)

Parameters

stream
Raw image stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRawImage Class
PdfRawImage Members


%%PageItemTitle%% $$Properties$$

PdfRawImage Class Properties

Xfinium.Pdf.Graphics Namespace : PdfRawImage Class

For a list of all members of this type, see PdfRawImage members.

Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfRawImage Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfRawImage)

Xfinium.Pdf.Graphics Namespace > PdfRawImage Class : Height Property
Gets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PdfRawImage
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The image height in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRawImage Class
PdfRawImage Members


Width Property (PdfRawImage)

Xfinium.Pdf.Graphics Namespace > PdfRawImage Class : Width Property
Gets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PdfRawImage
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The image width in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRawImage Class
PdfRawImage Members


%%PageItemTitle%%

PdfRgbColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfRgbColor Class
Defines a device RGB color.
Object Model
PdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfColorSpace ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor ClassPdfRgbColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRgbColor
   Inherits PdfColor
'Usage

Dim instance As PdfRgbColor
public class PdfRgbColor : PdfColor
public ref class PdfRgbColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfRgbColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfRgbColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfRgbColor Class

The following tables list the members exposed by PdfRgbColor.

Public Constructors
 | Name | Description
Public Constructor | PdfRgbColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | AliceBlue | Gets a predefined color with a RGB value of #F0F8FF
static (Shared in Visual Basic) | AntiqueWhite | Gets a predefined color with a RGB value of #FAEBD7
static (Shared in Visual Basic) | Aqua | Gets a predefined color with a RGB value of #00FFFF
static (Shared in Visual Basic) | Aquamarine | Gets a predefined color with a RGB value of #7FFFD4
static (Shared in Visual Basic) | Azure | Gets a predefined color with a RGB value of #F0FFFF
Public Property | B | Gets or sets the blue component.
static (Shared in Visual Basic) | Beige | Gets a predefined color with a RGB value of #F5F5DC
static (Shared in Visual Basic) | Bisque | Gets a predefined color with a RGB value of #FFE4C4
static (Shared in Visual Basic) | Black | Gets a predefined color with a RGB value of #000000
static (Shared in Visual Basic) | BlanchedAlmond | Gets a predefined color with a RGB value of #FFEBCD
static (Shared in Visual Basic) | Blue | Gets a predefined color with a RGB value of #0000FF
static (Shared in Visual Basic) | BlueViolet | Gets a predefined color with a RGB value of #8A2BE2
static (Shared in Visual Basic) | Brown | Gets a predefined color with a RGB value of #A52A2A
static (Shared in Visual Basic) | BurlyWood | Gets a predefined color with a RGB value of #DEB887
static (Shared in Visual Basic) | CadetBlue | Gets a predefined color with a RGB value of #5F9EA0
static (Shared in Visual Basic) | Chartreuse | Gets a predefined color with a RGB value of #7FFF00
static (Shared in Visual Basic) | Chocolate | Gets a predefined color with a RGB value of #D2691E
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
static (Shared in Visual Basic) | Coral | Gets a predefined color with a RGB value of #FF7F50
static (Shared in Visual Basic) | CornflowerBlue | Gets a predefined color with a RGB value of #6495ED
static (Shared in Visual Basic) | Cornsilk | Gets a predefined color with a RGB value of #FFF8DC
static (Shared in Visual Basic) | Crimson | Gets a predefined color with a RGB value of #DC143C
static (Shared in Visual Basic) | Cyan | Gets a predefined color with a RGB value of #00FFFF
static (Shared in Visual Basic) | DarkBlue | Gets a predefined color with a RGB value of #00008B
static (Shared in Visual Basic) | DarkCyan | Gets a predefined color with a RGB value of #008B8B
static (Shared in Visual Basic) | DarkGoldenrod | Gets a predefined color with a RGB value of #B8860B
static (Shared in Visual Basic) | DarkGray | Gets a predefined color with a RGB value of #A9A9A9
static (Shared in Visual Basic) | DarkGreen | Gets a predefined color with a RGB value of #006400
static (Shared in Visual Basic) | DarkKhaki | Gets a predefined color with a RGB value of #BDB76B
static (Shared in Visual Basic) | DarkMagenta | Gets a predefined color with a RGB value of #8B008B
static (Shared in Visual Basic) | DarkOliveGreen | Gets a predefined color with a RGB value of #556B2F
static (Shared in Visual Basic) | DarkOrange | Gets a predefined color with a RGB value of #FF8C00
static (Shared in Visual Basic) | DarkOrchid | Gets a predefined color with a RGB value of #9932CC
static (Shared in Visual Basic) | DarkRed | Gets a predefined color with a RGB value of #8B0000
static (Shared in Visual Basic) | DarkSalmon | Gets a predefined color with a RGB value of #E9967A
static (Shared in Visual Basic) | DarkSeaGreen | Gets a predefined color with a RGB value of #8FBC8B
static (Shared in Visual Basic) | DarkSlateBlue | Gets a predefined color with a RGB value of #483D8B
static (Shared in Visual Basic) | DarkSlateGray | Gets a predefined color with a RGB value of #2F4F4F
static (Shared in Visual Basic) | DarkTurquoise | Gets a predefined color with a RGB value of #00CED1
static (Shared in Visual Basic) | DarkViolet | Gets a predefined color with a RGB value of #9400D3
static (Shared in Visual Basic) | DeepPink | Gets a predefined color with a RGB value of #FF1493
static (Shared in Visual Basic) | DeepSkyBlue | Gets a predefined color with a RGB value of #00BFFF
static (Shared in Visual Basic) | DimGray | Gets a predefined color with a RGB value of #696969
static (Shared in Visual Basic) | DodgerBlue | Gets a predefined color with a RGB value of #1E90FF
static (Shared in Visual Basic) | Firebrick | Gets a predefined color with a RGB value of #B22222
static (Shared in Visual Basic) | FloralWhite | Gets a predefined color with a RGB value of #FFFAF0
static (Shared in Visual Basic) | ForestGreen | Gets a predefined color with a RGB value of #228B22
static (Shared in Visual Basic) | Fuchsia | Gets a predefined color with a RGB value of #FF00FF
Public Property | G | Gets or sets the green component.
static (Shared in Visual Basic) | Gainsboro | Gets a predefined color with a RGB value of #DCDCDC
static (Shared in Visual Basic) | GhostWhite | Gets a predefined color with a RGB value of #F8F8FF
static (Shared in Visual Basic) | Gold | Gets a predefined color with a RGB value of #FFD700
static (Shared in Visual Basic) | Goldenrod | Gets a predefined color with a RGB value of #DAA520
static (Shared in Visual Basic) | Gray | Gets a predefined color with a RGB value of #808080
static (Shared in Visual Basic) | Green | Gets a predefined color with a RGB value of #008000
static (Shared in Visual Basic) | GreenYellow | Gets a predefined color with a RGB value of #ADFF2F
static (Shared in Visual Basic) | Honeydew | Gets a predefined color with a RGB value of #F0FFF0
static (Shared in Visual Basic) | HotPink | Gets a predefined color with a RGB value of #FF69B4
static (Shared in Visual Basic) | IndianRed | Gets a predefined color with a RGB value of #CD5C5C
static (Shared in Visual Basic) | Indigo | Gets a predefined color with a RGB value of #4B0082
static (Shared in Visual Basic) | Ivory | Gets a predefined color with a RGB value of #FFFFF0
static (Shared in Visual Basic) | Khaki | Gets a predefined color with a RGB value of #F0E68C
static (Shared in Visual Basic) | Lavender | Gets a predefined color with a RGB value of #E6E6FA
static (Shared in Visual Basic) | LavenderBlush | Gets a predefined color with a RGB value of #FFF0F5
static (Shared in Visual Basic) | LawnGreen | Gets a predefined color with a RGB value of #7CFC00
static (Shared in Visual Basic) | LemonChiffon | Gets a predefined color with a RGB value of #FFFACD
static (Shared in Visual Basic) | LightBlue | Gets a predefined color with a RGB value of #ADD8E6
static (Shared in Visual Basic) | LightCoral | Gets a predefined color with a RGB value of #F08080
static (Shared in Visual Basic) | LightCyan | Gets a predefined color with a RGB value of #E0FFFF
static (Shared in Visual Basic) | LightGoldenrodYellow | Gets a predefined color with a RGB value of #FAFAD2
static (Shared in Visual Basic) | LightGray | Gets a predefined color with a RGB value of #D3D3D3
static (Shared in Visual Basic) | LightGreen | Gets a predefined color with a RGB value of #90EE90
static (Shared in Visual Basic) | LightPink | Gets a predefined color with a RGB value of #FFB6C1
static (Shared in Visual Basic) | LightSalmon | Gets a predefined color with a RGB value of #FFA07A
static (Shared in Visual Basic) | LightSeaGreen | Gets a predefined color with a RGB value of #20B2AA
static (Shared in Visual Basic) | LightSkyBlue | Gets a predefined color with a RGB value of #87CEFA
static (Shared in Visual Basic) | LightSlateGray | Gets a predefined color with a RGB value of #778899
static (Shared in Visual Basic) | LightSteelBlue | Gets a predefined color with a RGB value of #B0C4DE
static (Shared in Visual Basic) | LightYellow | Gets a predefined color with a RGB value of #FFFFE0
static (Shared in Visual Basic) | Lime | Gets a predefined color with a RGB value of #00FF00
static (Shared in Visual Basic) | LimeGreen | Gets a predefined color with a RGB value of #32CD32
static (Shared in Visual Basic) | Linen | Gets a predefined color with a RGB value of #FAF0E6
static (Shared in Visual Basic) | Magenta | Gets a predefined color with a RGB value of #FF00FF
static (Shared in Visual Basic) | Maroon | Gets a predefined color with a RGB value of #800000
static (Shared in Visual Basic) | MediumAquamarine | Gets a predefined color with a RGB value of #66CDAA
static (Shared in Visual Basic) | MediumBlue | Gets a predefined color with a RGB value of #0000CD
static (Shared in Visual Basic) | MediumOrchid | Gets a predefined color with a RGB value of #BA55D3
static (Shared in Visual Basic) | MediumPurple | Gets a predefined color with a RGB value of #9370DB
static (Shared in Visual Basic) | MediumSeaGreen | Gets a predefined color with a RGB value of #3CB371
static (Shared in Visual Basic) | MediumSlateBlue | Gets a predefined color with a RGB value of #7B68EE
static (Shared in Visual Basic) | MediumSpringGreen | Gets a predefined color with a RGB value of #00FA9A
static (Shared in Visual Basic) | MediumTurquoise | Gets a predefined color with a RGB value of #48D1CC
static (Shared in Visual Basic) | MediumVioletRed | Gets a predefined color with a RGB value of #C71585
static (Shared in Visual Basic) | MidnightBlue | Gets a predefined color with a RGB value of #191970
static (Shared in Visual Basic) | MintCream | Gets a predefined color with a RGB value of #F5FFFA
static (Shared in Visual Basic) | MistyRose | Gets a predefined color with a RGB value of #FFE4E1
static (Shared in Visual Basic) | Moccasin | Gets a predefined color with a RGB value of #FFE4B5
static (Shared in Visual Basic) | NavajoWhite | Gets a predefined color with a RGB value of #FFDEAD
static (Shared in Visual Basic) | Navy | Gets a predefined color with a RGB value of #000080
static (Shared in Visual Basic) | OldLace | Gets a predefined color with a RGB value of #FDF5E6
static (Shared in Visual Basic) | Olive | Gets a predefined color with a RGB value of #808000
static (Shared in Visual Basic) | OliveDrab | Gets a predefined color with a RGB value of #6B8E23
static (Shared in Visual Basic) | Orange | Gets a predefined color with a RGB value of #FFA500
static (Shared in Visual Basic) | OrangeRed | Gets a predefined color with a RGB value of #FF4500
static (Shared in Visual Basic) | Orchid | Gets a predefined color with a RGB value of #DA70D6
static (Shared in Visual Basic) | PaleGoldenrod | Gets a predefined color with a RGB value of #EEE8AA
static (Shared in Visual Basic) | PaleGreen | Gets a predefined color with a RGB value of #98FB98
static (Shared in Visual Basic) | PaleTurquoise | Gets a predefined color with a RGB value of #AFEEEE
static (Shared in Visual Basic) | PaleVioletRed | Gets a predefined color with a RGB value of #DB7093
static (Shared in Visual Basic) | PapayaWhip | Gets a predefined color with a RGB value of #FFEFD5
static (Shared in Visual Basic) | PeachPuff | Gets a predefined color with a RGB value of #FFDAB9
static (Shared in Visual Basic) | Peru | Gets a predefined color with a RGB value of #CD853F
static (Shared in Visual Basic) | Pink | Gets a predefined color with a RGB value of #FFC0CB
static (Shared in Visual Basic) | Plum | Gets a predefined color with a RGB value of #DDA0DD
static (Shared in Visual Basic) | PowderBlue | Gets a predefined color with a RGB value of #B0E0E6
static (Shared in Visual Basic) | Purple | Gets a predefined color with a RGB value of #800080
Public Property | R | Gets or sets the red component.
static (Shared in Visual Basic) | Red | Gets a predefined color with a RGB value of #FF0000
static (Shared in Visual Basic) | RosyBrown | Gets a predefined color with a RGB value of #BC8F8F
static (Shared in Visual Basic) | RoyalBlue | Gets a predefined color with a RGB value of #4169E1
static (Shared in Visual Basic) | SaddleBrown | Gets a predefined color with a RGB value of #8B4513
static (Shared in Visual Basic) | Salmon | Gets a predefined color with a RGB value of #FA8072
static (Shared in Visual Basic) | SandyBrown | Gets a predefined color with a RGB value of #F4A460
static (Shared in Visual Basic) | SeaGreen | Gets a predefined color with a RGB value of #2E8B57
static (Shared in Visual Basic) | SeaShell | Gets a predefined color with a RGB value of #FFF5EE
static (Shared in Visual Basic) | Sienna | Gets a predefined color with a RGB value of #A0522D
static (Shared in Visual Basic) | Silver | Gets a predefined color with a RGB value of #C0C0C0
static (Shared in Visual Basic) | SkyBlue | Gets a predefined color with a RGB value of #87CEEB
static (Shared in Visual Basic) | SlateBlue | Gets a predefined color with a RGB value of #6A5ACD
static (Shared in Visual Basic) | SlateGray | Gets a predefined color with a RGB value of #708090
static (Shared in Visual Basic) | Snow | Gets a predefined color with a RGB value of #FFFAFA
static (Shared in Visual Basic) | SpringGreen | Gets a predefined color with a RGB value of #00FF7F
static (Shared in Visual Basic) | SteelBlue | Gets a predefined color with a RGB value of #4682B4
static (Shared in Visual Basic) | Tan | Gets a predefined color with a RGB value of #D2B48C
static (Shared in Visual Basic) | Teal | Gets a predefined color with a RGB value of #008080
static (Shared in Visual Basic) | Thistle | Gets a predefined color with a RGB value of #D8BFD8
static (Shared in Visual Basic) | Tomato | Gets a predefined color with a RGB value of #FF6347
static (Shared in Visual Basic) | Turquoise | Gets a predefined color with a RGB value of #40E0D0
static (Shared in Visual Basic) | Violet | Gets a predefined color with a RGB value of #EE82EE
static (Shared in Visual Basic) | Wheat | Gets a predefined color with a RGB value of #F5DEB3
static (Shared in Visual Basic) | White | Gets a predefined color with a RGB value of #FFFFFF
static (Shared in Visual Basic) | WhiteSmoke | Gets a predefined color with a RGB value of #F5F5F5
static (Shared in Visual Basic) | Yellow | Gets a predefined color with a RGB value of #FFFF00
static (Shared in Visual Basic) | YellowGreen | Gets a predefined color with a RGB value of #9ACD32
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Overridden. Converts this color to RGB.
Top
See Also

Reference

PdfRgbColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfRgbColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : PdfRgbColor Constructor
Overload List
Overload | Description
PdfRgbColor Constructor() | Initializes a new PdfRgbColor object.
PdfRgbColor Constructor(Byte,Byte,Byte) | Initializes a new PdfRgbColor object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


%%PageItemTitle%%

PdfRgbColor Constructor()

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class > PdfRgbColor Constructor : PdfRgbColor Constructor()
Initializes a new PdfRgbColor object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRgbColor()
public PdfRgbColor()
public:
PdfRgbColor();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members
Overload List


%%PageItemTitle%%

PdfRgbColor Constructor(Byte,Byte,Byte)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class > PdfRgbColor Constructor : PdfRgbColor Constructor(Byte,Byte,Byte)
Red component.
Green component.
Blue component.
Initializes a new PdfRgbColor object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal r As Byte, _
   ByVal g As Byte, _
   ByVal b As Byte _
)
'Usage

Dim r As Byte
Dim g As Byte
Dim b As Byte

Dim instance As New PdfRgbColor(r, g, b)
public PdfRgbColor(
   byte r,
   byte g,
   byte b
)
public:
PdfRgbColor(
   byte r,
   byte g,
   byte b
)

Parameters

r
Red component.
g
Green component.
b
Blue component.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfRgbColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfRgbColor Class

For a list of all members of this type, see PdfRgbColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Overridden. Converts this color to RGB.
Top
See Also

Reference

PdfRgbColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfRgbColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Equals Method (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfRgbColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


GetHashCode Method (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfRgbColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


ToRgbColor Method (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : ToRgbColor Method
Converts this color to RGB.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToRgbColor() As PdfRgbColor
'Usage

Dim instance As PdfRgbColor
Dim value As PdfRgbColor

value = instance.ToRgbColor()
public override PdfRgbColor ToRgbColor()
public:
PdfRgbColor^ ToRgbColor(); override

Return Value

The color in RGB format.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


%%PageItemTitle%% $$Properties$$

PdfRgbColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfRgbColor Class

For a list of all members of this type, see PdfRgbColor members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | AliceBlue | Gets a predefined color with a RGB value of #F0F8FF
static (Shared in Visual Basic) | AntiqueWhite | Gets a predefined color with a RGB value of #FAEBD7
static (Shared in Visual Basic) | Aqua | Gets a predefined color with a RGB value of #00FFFF
static (Shared in Visual Basic) | Aquamarine | Gets a predefined color with a RGB value of #7FFFD4
static (Shared in Visual Basic) | Azure | Gets a predefined color with a RGB value of #F0FFFF
Public Property | B | Gets or sets the blue component.
static (Shared in Visual Basic) | Beige | Gets a predefined color with a RGB value of #F5F5DC
static (Shared in Visual Basic) | Bisque | Gets a predefined color with a RGB value of #FFE4C4
static (Shared in Visual Basic) | Black | Gets a predefined color with a RGB value of #000000
static (Shared in Visual Basic) | BlanchedAlmond | Gets a predefined color with a RGB value of #FFEBCD
static (Shared in Visual Basic) | Blue | Gets a predefined color with a RGB value of #0000FF
static (Shared in Visual Basic) | BlueViolet | Gets a predefined color with a RGB value of #8A2BE2
static (Shared in Visual Basic) | Brown | Gets a predefined color with a RGB value of #A52A2A
static (Shared in Visual Basic) | BurlyWood | Gets a predefined color with a RGB value of #DEB887
static (Shared in Visual Basic) | CadetBlue | Gets a predefined color with a RGB value of #5F9EA0
static (Shared in Visual Basic) | Chartreuse | Gets a predefined color with a RGB value of #7FFF00
static (Shared in Visual Basic) | Chocolate | Gets a predefined color with a RGB value of #D2691E
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
static (Shared in Visual Basic) | Coral | Gets a predefined color with a RGB value of #FF7F50
static (Shared in Visual Basic) | CornflowerBlue | Gets a predefined color with a RGB value of #6495ED
static (Shared in Visual Basic) | Cornsilk | Gets a predefined color with a RGB value of #FFF8DC
static (Shared in Visual Basic) | Crimson | Gets a predefined color with a RGB value of #DC143C
static (Shared in Visual Basic) | Cyan | Gets a predefined color with a RGB value of #00FFFF
static (Shared in Visual Basic) | DarkBlue | Gets a predefined color with a RGB value of #00008B
static (Shared in Visual Basic) | DarkCyan | Gets a predefined color with a RGB value of #008B8B
static (Shared in Visual Basic) | DarkGoldenrod | Gets a predefined color with a RGB value of #B8860B
static (Shared in Visual Basic) | DarkGray | Gets a predefined color with a RGB value of #A9A9A9
static (Shared in Visual Basic) | DarkGreen | Gets a predefined color with a RGB value of #006400
static (Shared in Visual Basic) | DarkKhaki | Gets a predefined color with a RGB value of #BDB76B
static (Shared in Visual Basic) | DarkMagenta | Gets a predefined color with a RGB value of #8B008B
static (Shared in Visual Basic) | DarkOliveGreen | Gets a predefined color with a RGB value of #556B2F
static (Shared in Visual Basic) | DarkOrange | Gets a predefined color with a RGB value of #FF8C00
static (Shared in Visual Basic) | DarkOrchid | Gets a predefined color with a RGB value of #9932CC
static (Shared in Visual Basic) | DarkRed | Gets a predefined color with a RGB value of #8B0000
static (Shared in Visual Basic) | DarkSalmon | Gets a predefined color with a RGB value of #E9967A
static (Shared in Visual Basic) | DarkSeaGreen | Gets a predefined color with a RGB value of #8FBC8B
static (Shared in Visual Basic) | DarkSlateBlue | Gets a predefined color with a RGB value of #483D8B
static (Shared in Visual Basic) | DarkSlateGray | Gets a predefined color with a RGB value of #2F4F4F
static (Shared in Visual Basic) | DarkTurquoise | Gets a predefined color with a RGB value of #00CED1
static (Shared in Visual Basic) | DarkViolet | Gets a predefined color with a RGB value of #9400D3
static (Shared in Visual Basic) | DeepPink | Gets a predefined color with a RGB value of #FF1493
static (Shared in Visual Basic) | DeepSkyBlue | Gets a predefined color with a RGB value of #00BFFF
static (Shared in Visual Basic) | DimGray | Gets a predefined color with a RGB value of #696969
static (Shared in Visual Basic) | DodgerBlue | Gets a predefined color with a RGB value of #1E90FF
static (Shared in Visual Basic) | Firebrick | Gets a predefined color with a RGB value of #B22222
static (Shared in Visual Basic) | FloralWhite | Gets a predefined color with a RGB value of #FFFAF0
static (Shared in Visual Basic) | ForestGreen | Gets a predefined color with a RGB value of #228B22
static (Shared in Visual Basic) | Fuchsia | Gets a predefined color with a RGB value of #FF00FF
Public Property | G | Gets or sets the green component.
static (Shared in Visual Basic) | Gainsboro | Gets a predefined color with a RGB value of #DCDCDC
static (Shared in Visual Basic) | GhostWhite | Gets a predefined color with a RGB value of #F8F8FF
static (Shared in Visual Basic) | Gold | Gets a predefined color with a RGB value of #FFD700
static (Shared in Visual Basic) | Goldenrod | Gets a predefined color with a RGB value of #DAA520
static (Shared in Visual Basic) | Gray | Gets a predefined color with a RGB value of #808080
static (Shared in Visual Basic) | Green | Gets a predefined color with a RGB value of #008000
static (Shared in Visual Basic) | GreenYellow | Gets a predefined color with a RGB value of #ADFF2F
static (Shared in Visual Basic) | Honeydew | Gets a predefined color with a RGB value of #F0FFF0
static (Shared in Visual Basic) | HotPink | Gets a predefined color with a RGB value of #FF69B4
static (Shared in Visual Basic) | IndianRed | Gets a predefined color with a RGB value of #CD5C5C
static (Shared in Visual Basic) | Indigo | Gets a predefined color with a RGB value of #4B0082
static (Shared in Visual Basic) | Ivory | Gets a predefined color with a RGB value of #FFFFF0
static (Shared in Visual Basic) | Khaki | Gets a predefined color with a RGB value of #F0E68C
static (Shared in Visual Basic) | Lavender | Gets a predefined color with a RGB value of #E6E6FA
static (Shared in Visual Basic) | LavenderBlush | Gets a predefined color with a RGB value of #FFF0F5
static (Shared in Visual Basic) | LawnGreen | Gets a predefined color with a RGB value of #7CFC00
static (Shared in Visual Basic) | LemonChiffon | Gets a predefined color with a RGB value of #FFFACD
static (Shared in Visual Basic) | LightBlue | Gets a predefined color with a RGB value of #ADD8E6
static (Shared in Visual Basic) | LightCoral | Gets a predefined color with a RGB value of #F08080
static (Shared in Visual Basic) | LightCyan | Gets a predefined color with a RGB value of #E0FFFF
static (Shared in Visual Basic) | LightGoldenrodYellow | Gets a predefined color with a RGB value of #FAFAD2
static (Shared in Visual Basic) | LightGray | Gets a predefined color with a RGB value of #D3D3D3
static (Shared in Visual Basic) | LightGreen | Gets a predefined color with a RGB value of #90EE90
static (Shared in Visual Basic) | LightPink | Gets a predefined color with a RGB value of #FFB6C1
static (Shared in Visual Basic) | LightSalmon | Gets a predefined color with a RGB value of #FFA07A
static (Shared in Visual Basic) | LightSeaGreen | Gets a predefined color with a RGB value of #20B2AA
static (Shared in Visual Basic) | LightSkyBlue | Gets a predefined color with a RGB value of #87CEFA
static (Shared in Visual Basic) | LightSlateGray | Gets a predefined color with a RGB value of #778899
static (Shared in Visual Basic) | LightSteelBlue | Gets a predefined color with a RGB value of #B0C4DE
static (Shared in Visual Basic) | LightYellow | Gets a predefined color with a RGB value of #FFFFE0
static (Shared in Visual Basic) | Lime | Gets a predefined color with a RGB value of #00FF00
static (Shared in Visual Basic) | LimeGreen | Gets a predefined color with a RGB value of #32CD32
static (Shared in Visual Basic) | Linen | Gets a predefined color with a RGB value of #FAF0E6
static (Shared in Visual Basic) | Magenta | Gets a predefined color with a RGB value of #FF00FF
static (Shared in Visual Basic) | Maroon | Gets a predefined color with a RGB value of #800000
static (Shared in Visual Basic) | MediumAquamarine | Gets a predefined color with a RGB value of #66CDAA
static (Shared in Visual Basic) | MediumBlue | Gets a predefined color with a RGB value of #0000CD
static (Shared in Visual Basic) | MediumOrchid | Gets a predefined color with a RGB value of #BA55D3
static (Shared in Visual Basic) | MediumPurple | Gets a predefined color with a RGB value of #9370DB
static (Shared in Visual Basic) | MediumSeaGreen | Gets a predefined color with a RGB value of #3CB371
static (Shared in Visual Basic) | MediumSlateBlue | Gets a predefined color with a RGB value of #7B68EE
static (Shared in Visual Basic) | MediumSpringGreen | Gets a predefined color with a RGB value of #00FA9A
static (Shared in Visual Basic) | MediumTurquoise | Gets a predefined color with a RGB value of #48D1CC
static (Shared in Visual Basic) | MediumVioletRed | Gets a predefined color with a RGB value of #C71585
static (Shared in Visual Basic) | MidnightBlue | Gets a predefined color with a RGB value of #191970
static (Shared in Visual Basic) | MintCream | Gets a predefined color with a RGB value of #F5FFFA
static (Shared in Visual Basic) | MistyRose | Gets a predefined color with a RGB value of #FFE4E1
static (Shared in Visual Basic) | Moccasin | Gets a predefined color with a RGB value of #FFE4B5
static (Shared in Visual Basic) | NavajoWhite | Gets a predefined color with a RGB value of #FFDEAD
static (Shared in Visual Basic) | Navy | Gets a predefined color with a RGB value of #000080
static (Shared in Visual Basic) | OldLace | Gets a predefined color with a RGB value of #FDF5E6
static (Shared in Visual Basic) | Olive | Gets a predefined color with a RGB value of #808000
static (Shared in Visual Basic) | OliveDrab | Gets a predefined color with a RGB value of #6B8E23
static (Shared in Visual Basic) | Orange | Gets a predefined color with a RGB value of #FFA500
static (Shared in Visual Basic) | OrangeRed | Gets a predefined color with a RGB value of #FF4500
static (Shared in Visual Basic) | Orchid | Gets a predefined color with a RGB value of #DA70D6
static (Shared in Visual Basic) | PaleGoldenrod | Gets a predefined color with a RGB value of #EEE8AA
static (Shared in Visual Basic) | PaleGreen | Gets a predefined color with a RGB value of #98FB98
static (Shared in Visual Basic) | PaleTurquoise | Gets a predefined color with a RGB value of #AFEEEE
static (Shared in Visual Basic) | PaleVioletRed | Gets a predefined color with a RGB value of #DB7093
static (Shared in Visual Basic) | PapayaWhip | Gets a predefined color with a RGB value of #FFEFD5
static (Shared in Visual Basic) | PeachPuff | Gets a predefined color with a RGB value of #FFDAB9
static (Shared in Visual Basic) | Peru | Gets a predefined color with a RGB value of #CD853F
static (Shared in Visual Basic) | Pink | Gets a predefined color with a RGB value of #FFC0CB
static (Shared in Visual Basic) | Plum | Gets a predefined color with a RGB value of #DDA0DD
static (Shared in Visual Basic) | PowderBlue | Gets a predefined color with a RGB value of #B0E0E6
static (Shared in Visual Basic) | Purple | Gets a predefined color with a RGB value of #800080
Public Property | R | Gets or sets the red component.
static (Shared in Visual Basic) | Red | Gets a predefined color with a RGB value of #FF0000
static (Shared in Visual Basic) | RosyBrown | Gets a predefined color with a RGB value of #BC8F8F
static (Shared in Visual Basic) | RoyalBlue | Gets a predefined color with a RGB value of #4169E1
static (Shared in Visual Basic) | SaddleBrown | Gets a predefined color with a RGB value of #8B4513
static (Shared in Visual Basic) | Salmon | Gets a predefined color with a RGB value of #FA8072
static (Shared in Visual Basic) | SandyBrown | Gets a predefined color with a RGB value of #F4A460
static (Shared in Visual Basic) | SeaGreen | Gets a predefined color with a RGB value of #2E8B57
static (Shared in Visual Basic) | SeaShell | Gets a predefined color with a RGB value of #FFF5EE
static (Shared in Visual Basic) | Sienna | Gets a predefined color with a RGB value of #A0522D
static (Shared in Visual Basic) | Silver | Gets a predefined color with a RGB value of #C0C0C0
static (Shared in Visual Basic) | SkyBlue | Gets a predefined color with a RGB value of #87CEEB
static (Shared in Visual Basic) | SlateBlue | Gets a predefined color with a RGB value of #6A5ACD
static (Shared in Visual Basic) | SlateGray | Gets a predefined color with a RGB value of #708090
static (Shared in Visual Basic) | Snow | Gets a predefined color with a RGB value of #FFFAFA
static (Shared in Visual Basic) | SpringGreen | Gets a predefined color with a RGB value of #00FF7F
static (Shared in Visual Basic) | SteelBlue | Gets a predefined color with a RGB value of #4682B4
static (Shared in Visual Basic) | Tan | Gets a predefined color with a RGB value of #D2B48C
static (Shared in Visual Basic) | Teal | Gets a predefined color with a RGB value of #008080
static (Shared in Visual Basic) | Thistle | Gets a predefined color with a RGB value of #D8BFD8
static (Shared in Visual Basic) | Tomato | Gets a predefined color with a RGB value of #FF6347
static (Shared in Visual Basic) | Turquoise | Gets a predefined color with a RGB value of #40E0D0
static (Shared in Visual Basic) | Violet | Gets a predefined color with a RGB value of #EE82EE
static (Shared in Visual Basic) | Wheat | Gets a predefined color with a RGB value of #F5DEB3
static (Shared in Visual Basic) | White | Gets a predefined color with a RGB value of #FFFFFF
static (Shared in Visual Basic) | WhiteSmoke | Gets a predefined color with a RGB value of #F5F5F5
static (Shared in Visual Basic) | Yellow | Gets a predefined color with a RGB value of #FFFF00
static (Shared in Visual Basic) | YellowGreen | Gets a predefined color with a RGB value of #9ACD32
Top
See Also

Reference

PdfRgbColor Class
Xfinium.Pdf.Graphics Namespace


AliceBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : AliceBlue Property
Gets a predefined color with a RGB value of #F0F8FF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property AliceBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.AliceBlue
public static PdfRgbColor AliceBlue {get;}
public:
static property PdfRgbColor^ AliceBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


AntiqueWhite Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : AntiqueWhite Property
Gets a predefined color with a RGB value of #FAEBD7
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property AntiqueWhite As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.AntiqueWhite
public static PdfRgbColor AntiqueWhite {get;}
public:
static property PdfRgbColor^ AntiqueWhite {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Aqua Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Aqua Property
Gets a predefined color with a RGB value of #00FFFF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Aqua As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Aqua
public static PdfRgbColor Aqua {get;}
public:
static property PdfRgbColor^ Aqua {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Aquamarine Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Aquamarine Property
Gets a predefined color with a RGB value of #7FFFD4
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Aquamarine As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Aquamarine
public static PdfRgbColor Aquamarine {get;}
public:
static property PdfRgbColor^ Aquamarine {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Azure Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Azure Property
Gets a predefined color with a RGB value of #F0FFFF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Azure As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Azure
public static PdfRgbColor Azure {get;}
public:
static property PdfRgbColor^ Azure {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


B Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : B Property
Gets or sets the blue component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property B As Byte
'Usage

Dim instance As PdfRgbColor
Dim value As Byte

instance.B = value

value = instance.B
public byte B {get; set;}
public:
property byte B {
   byte get();
   void set (    byte value);
}

Property Value

The blue component in the range [0 255].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Beige Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Beige Property
Gets a predefined color with a RGB value of #F5F5DC
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Beige As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Beige
public static PdfRgbColor Beige {get;}
public:
static property PdfRgbColor^ Beige {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Bisque Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Bisque Property
Gets a predefined color with a RGB value of #FFE4C4
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Bisque As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Bisque
public static PdfRgbColor Bisque {get;}
public:
static property PdfRgbColor^ Bisque {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Black Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Black Property
Gets a predefined color with a RGB value of #000000
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Black As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Black
public static PdfRgbColor Black {get;}
public:
static property PdfRgbColor^ Black {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


BlanchedAlmond Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : BlanchedAlmond Property
Gets a predefined color with a RGB value of #FFEBCD
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property BlanchedAlmond As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.BlanchedAlmond
public static PdfRgbColor BlanchedAlmond {get;}
public:
static property PdfRgbColor^ BlanchedAlmond {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Blue Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Blue Property
Gets a predefined color with a RGB value of #0000FF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Blue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Blue
public static PdfRgbColor Blue {get;}
public:
static property PdfRgbColor^ Blue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


BlueViolet Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : BlueViolet Property
Gets a predefined color with a RGB value of #8A2BE2
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property BlueViolet As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.BlueViolet
public static PdfRgbColor BlueViolet {get;}
public:
static property PdfRgbColor^ BlueViolet {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Brown Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Brown Property
Gets a predefined color with a RGB value of #A52A2A
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Brown As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Brown
public static PdfRgbColor Brown {get;}
public:
static property PdfRgbColor^ Brown {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


BurlyWood Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : BurlyWood Property
Gets a predefined color with a RGB value of #DEB887
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property BurlyWood As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.BurlyWood
public static PdfRgbColor BurlyWood {get;}
public:
static property PdfRgbColor^ BurlyWood {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


CadetBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : CadetBlue Property
Gets a predefined color with a RGB value of #5F9EA0
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CadetBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.CadetBlue
public static PdfRgbColor CadetBlue {get;}
public:
static property PdfRgbColor^ CadetBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Chartreuse Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Chartreuse Property
Gets a predefined color with a RGB value of #7FFF00
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Chartreuse As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Chartreuse
public static PdfRgbColor Chartreuse {get;}
public:
static property PdfRgbColor^ Chartreuse {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Chocolate Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Chocolate Property
Gets a predefined color with a RGB value of #D2691E
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Chocolate As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Chocolate
public static PdfRgbColor Chocolate {get;}
public:
static property PdfRgbColor^ Chocolate {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Coral Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Coral Property
Gets a predefined color with a RGB value of #FF7F50
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Coral As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Coral
public static PdfRgbColor Coral {get;}
public:
static property PdfRgbColor^ Coral {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


CornflowerBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : CornflowerBlue Property
Gets a predefined color with a RGB value of #6495ED
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property CornflowerBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.CornflowerBlue
public static PdfRgbColor CornflowerBlue {get;}
public:
static property PdfRgbColor^ CornflowerBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Cornsilk Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Cornsilk Property
Gets a predefined color with a RGB value of #FFF8DC
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Cornsilk As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Cornsilk
public static PdfRgbColor Cornsilk {get;}
public:
static property PdfRgbColor^ Cornsilk {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Crimson Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Crimson Property
Gets a predefined color with a RGB value of #DC143C
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Crimson As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Crimson
public static PdfRgbColor Crimson {get;}
public:
static property PdfRgbColor^ Crimson {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Cyan Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Cyan Property
Gets a predefined color with a RGB value of #00FFFF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Cyan As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Cyan
public static PdfRgbColor Cyan {get;}
public:
static property PdfRgbColor^ Cyan {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkBlue Property
Gets a predefined color with a RGB value of #00008B
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkBlue
public static PdfRgbColor DarkBlue {get;}
public:
static property PdfRgbColor^ DarkBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkCyan Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkCyan Property
Gets a predefined color with a RGB value of #008B8B
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkCyan As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkCyan
public static PdfRgbColor DarkCyan {get;}
public:
static property PdfRgbColor^ DarkCyan {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkGoldenrod Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkGoldenrod Property
Gets a predefined color with a RGB value of #B8860B
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkGoldenrod As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkGoldenrod
public static PdfRgbColor DarkGoldenrod {get;}
public:
static property PdfRgbColor^ DarkGoldenrod {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkGray Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkGray Property
Gets a predefined color with a RGB value of #A9A9A9
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkGray As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkGray
public static PdfRgbColor DarkGray {get;}
public:
static property PdfRgbColor^ DarkGray {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkGreen Property
Gets a predefined color with a RGB value of #006400
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkGreen
public static PdfRgbColor DarkGreen {get;}
public:
static property PdfRgbColor^ DarkGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkKhaki Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkKhaki Property
Gets a predefined color with a RGB value of #BDB76B
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkKhaki As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkKhaki
public static PdfRgbColor DarkKhaki {get;}
public:
static property PdfRgbColor^ DarkKhaki {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkMagenta Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkMagenta Property
Gets a predefined color with a RGB value of #8B008B
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkMagenta As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkMagenta
public static PdfRgbColor DarkMagenta {get;}
public:
static property PdfRgbColor^ DarkMagenta {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkOliveGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkOliveGreen Property
Gets a predefined color with a RGB value of #556B2F
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkOliveGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkOliveGreen
public static PdfRgbColor DarkOliveGreen {get;}
public:
static property PdfRgbColor^ DarkOliveGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkOrange Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkOrange Property
Gets a predefined color with a RGB value of #FF8C00
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkOrange As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkOrange
public static PdfRgbColor DarkOrange {get;}
public:
static property PdfRgbColor^ DarkOrange {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkOrchid Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkOrchid Property
Gets a predefined color with a RGB value of #9932CC
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkOrchid As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkOrchid
public static PdfRgbColor DarkOrchid {get;}
public:
static property PdfRgbColor^ DarkOrchid {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkRed Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkRed Property
Gets a predefined color with a RGB value of #8B0000
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkRed As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkRed
public static PdfRgbColor DarkRed {get;}
public:
static property PdfRgbColor^ DarkRed {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkSalmon Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkSalmon Property
Gets a predefined color with a RGB value of #E9967A
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkSalmon As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkSalmon
public static PdfRgbColor DarkSalmon {get;}
public:
static property PdfRgbColor^ DarkSalmon {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkSeaGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkSeaGreen Property
Gets a predefined color with a RGB value of #8FBC8B
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkSeaGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkSeaGreen
public static PdfRgbColor DarkSeaGreen {get;}
public:
static property PdfRgbColor^ DarkSeaGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkSlateBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkSlateBlue Property
Gets a predefined color with a RGB value of #483D8B
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkSlateBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkSlateBlue
public static PdfRgbColor DarkSlateBlue {get;}
public:
static property PdfRgbColor^ DarkSlateBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkSlateGray Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkSlateGray Property
Gets a predefined color with a RGB value of #2F4F4F
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkSlateGray As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkSlateGray
public static PdfRgbColor DarkSlateGray {get;}
public:
static property PdfRgbColor^ DarkSlateGray {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkTurquoise Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkTurquoise Property
Gets a predefined color with a RGB value of #00CED1
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkTurquoise As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkTurquoise
public static PdfRgbColor DarkTurquoise {get;}
public:
static property PdfRgbColor^ DarkTurquoise {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DarkViolet Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DarkViolet Property
Gets a predefined color with a RGB value of #9400D3
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DarkViolet As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DarkViolet
public static PdfRgbColor DarkViolet {get;}
public:
static property PdfRgbColor^ DarkViolet {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DeepPink Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DeepPink Property
Gets a predefined color with a RGB value of #FF1493
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DeepPink As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DeepPink
public static PdfRgbColor DeepPink {get;}
public:
static property PdfRgbColor^ DeepPink {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DeepSkyBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DeepSkyBlue Property
Gets a predefined color with a RGB value of #00BFFF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DeepSkyBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DeepSkyBlue
public static PdfRgbColor DeepSkyBlue {get;}
public:
static property PdfRgbColor^ DeepSkyBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DimGray Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DimGray Property
Gets a predefined color with a RGB value of #696969
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DimGray As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DimGray
public static PdfRgbColor DimGray {get;}
public:
static property PdfRgbColor^ DimGray {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


DodgerBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : DodgerBlue Property
Gets a predefined color with a RGB value of #1E90FF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property DodgerBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.DodgerBlue
public static PdfRgbColor DodgerBlue {get;}
public:
static property PdfRgbColor^ DodgerBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Firebrick Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Firebrick Property
Gets a predefined color with a RGB value of #B22222
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Firebrick As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Firebrick
public static PdfRgbColor Firebrick {get;}
public:
static property PdfRgbColor^ Firebrick {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


FloralWhite Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : FloralWhite Property
Gets a predefined color with a RGB value of #FFFAF0
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property FloralWhite As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.FloralWhite
public static PdfRgbColor FloralWhite {get;}
public:
static property PdfRgbColor^ FloralWhite {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


ForestGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : ForestGreen Property
Gets a predefined color with a RGB value of #228B22
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property ForestGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.ForestGreen
public static PdfRgbColor ForestGreen {get;}
public:
static property PdfRgbColor^ ForestGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Fuchsia Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Fuchsia Property
Gets a predefined color with a RGB value of #FF00FF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Fuchsia As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Fuchsia
public static PdfRgbColor Fuchsia {get;}
public:
static property PdfRgbColor^ Fuchsia {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


G Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : G Property
Gets or sets the green component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property G As Byte
'Usage

Dim instance As PdfRgbColor
Dim value As Byte

instance.G = value

value = instance.G
public byte G {get; set;}
public:
property byte G {
   byte get();
   void set (    byte value);
}

Property Value

The green component in the range [0 255].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Gainsboro Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Gainsboro Property
Gets a predefined color with a RGB value of #DCDCDC
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Gainsboro As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Gainsboro
public static PdfRgbColor Gainsboro {get;}
public:
static property PdfRgbColor^ Gainsboro {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


GhostWhite Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : GhostWhite Property
Gets a predefined color with a RGB value of #F8F8FF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property GhostWhite As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.GhostWhite
public static PdfRgbColor GhostWhite {get;}
public:
static property PdfRgbColor^ GhostWhite {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Gold Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Gold Property
Gets a predefined color with a RGB value of #FFD700
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Gold As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Gold
public static PdfRgbColor Gold {get;}
public:
static property PdfRgbColor^ Gold {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Goldenrod Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Goldenrod Property
Gets a predefined color with a RGB value of #DAA520
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Goldenrod As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Goldenrod
public static PdfRgbColor Goldenrod {get;}
public:
static property PdfRgbColor^ Goldenrod {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Gray Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Gray Property
Gets a predefined color with a RGB value of #808080
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Gray As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Gray
public static PdfRgbColor Gray {get;}
public:
static property PdfRgbColor^ Gray {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Green Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Green Property
Gets a predefined color with a RGB value of #008000
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Green As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Green
public static PdfRgbColor Green {get;}
public:
static property PdfRgbColor^ Green {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


GreenYellow Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : GreenYellow Property
Gets a predefined color with a RGB value of #ADFF2F
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property GreenYellow As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.GreenYellow
public static PdfRgbColor GreenYellow {get;}
public:
static property PdfRgbColor^ GreenYellow {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Honeydew Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Honeydew Property
Gets a predefined color with a RGB value of #F0FFF0
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Honeydew As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Honeydew
public static PdfRgbColor Honeydew {get;}
public:
static property PdfRgbColor^ Honeydew {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


HotPink Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : HotPink Property
Gets a predefined color with a RGB value of #FF69B4
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property HotPink As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.HotPink
public static PdfRgbColor HotPink {get;}
public:
static property PdfRgbColor^ HotPink {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


IndianRed Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : IndianRed Property
Gets a predefined color with a RGB value of #CD5C5C
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property IndianRed As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.IndianRed
public static PdfRgbColor IndianRed {get;}
public:
static property PdfRgbColor^ IndianRed {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Indigo Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Indigo Property
Gets a predefined color with a RGB value of #4B0082
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Indigo As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Indigo
public static PdfRgbColor Indigo {get;}
public:
static property PdfRgbColor^ Indigo {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Ivory Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Ivory Property
Gets a predefined color with a RGB value of #FFFFF0
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Ivory As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Ivory
public static PdfRgbColor Ivory {get;}
public:
static property PdfRgbColor^ Ivory {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Khaki Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Khaki Property
Gets a predefined color with a RGB value of #F0E68C
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Khaki As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Khaki
public static PdfRgbColor Khaki {get;}
public:
static property PdfRgbColor^ Khaki {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Lavender Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Lavender Property
Gets a predefined color with a RGB value of #E6E6FA
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Lavender As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Lavender
public static PdfRgbColor Lavender {get;}
public:
static property PdfRgbColor^ Lavender {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LavenderBlush Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LavenderBlush Property
Gets a predefined color with a RGB value of #FFF0F5
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LavenderBlush As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LavenderBlush
public static PdfRgbColor LavenderBlush {get;}
public:
static property PdfRgbColor^ LavenderBlush {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LawnGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LawnGreen Property
Gets a predefined color with a RGB value of #7CFC00
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LawnGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LawnGreen
public static PdfRgbColor LawnGreen {get;}
public:
static property PdfRgbColor^ LawnGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LemonChiffon Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LemonChiffon Property
Gets a predefined color with a RGB value of #FFFACD
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LemonChiffon As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LemonChiffon
public static PdfRgbColor LemonChiffon {get;}
public:
static property PdfRgbColor^ LemonChiffon {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightBlue Property
Gets a predefined color with a RGB value of #ADD8E6
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightBlue
public static PdfRgbColor LightBlue {get;}
public:
static property PdfRgbColor^ LightBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightCoral Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightCoral Property
Gets a predefined color with a RGB value of #F08080
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightCoral As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightCoral
public static PdfRgbColor LightCoral {get;}
public:
static property PdfRgbColor^ LightCoral {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightCyan Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightCyan Property
Gets a predefined color with a RGB value of #E0FFFF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightCyan As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightCyan
public static PdfRgbColor LightCyan {get;}
public:
static property PdfRgbColor^ LightCyan {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightGoldenrodYellow Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightGoldenrodYellow Property
Gets a predefined color with a RGB value of #FAFAD2
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightGoldenrodYellow As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightGoldenrodYellow
public static PdfRgbColor LightGoldenrodYellow {get;}
public:
static property PdfRgbColor^ LightGoldenrodYellow {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightGray Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightGray Property
Gets a predefined color with a RGB value of #D3D3D3
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightGray As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightGray
public static PdfRgbColor LightGray {get;}
public:
static property PdfRgbColor^ LightGray {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightGreen Property
Gets a predefined color with a RGB value of #90EE90
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightGreen
public static PdfRgbColor LightGreen {get;}
public:
static property PdfRgbColor^ LightGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightPink Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightPink Property
Gets a predefined color with a RGB value of #FFB6C1
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightPink As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightPink
public static PdfRgbColor LightPink {get;}
public:
static property PdfRgbColor^ LightPink {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightSalmon Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightSalmon Property
Gets a predefined color with a RGB value of #FFA07A
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightSalmon As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightSalmon
public static PdfRgbColor LightSalmon {get;}
public:
static property PdfRgbColor^ LightSalmon {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightSeaGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightSeaGreen Property
Gets a predefined color with a RGB value of #20B2AA
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightSeaGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightSeaGreen
public static PdfRgbColor LightSeaGreen {get;}
public:
static property PdfRgbColor^ LightSeaGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightSkyBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightSkyBlue Property
Gets a predefined color with a RGB value of #87CEFA
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightSkyBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightSkyBlue
public static PdfRgbColor LightSkyBlue {get;}
public:
static property PdfRgbColor^ LightSkyBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightSlateGray Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightSlateGray Property
Gets a predefined color with a RGB value of #778899
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightSlateGray As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightSlateGray
public static PdfRgbColor LightSlateGray {get;}
public:
static property PdfRgbColor^ LightSlateGray {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightSteelBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightSteelBlue Property
Gets a predefined color with a RGB value of #B0C4DE
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightSteelBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightSteelBlue
public static PdfRgbColor LightSteelBlue {get;}
public:
static property PdfRgbColor^ LightSteelBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LightYellow Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LightYellow Property
Gets a predefined color with a RGB value of #FFFFE0
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LightYellow As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LightYellow
public static PdfRgbColor LightYellow {get;}
public:
static property PdfRgbColor^ LightYellow {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Lime Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Lime Property
Gets a predefined color with a RGB value of #00FF00
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Lime As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Lime
public static PdfRgbColor Lime {get;}
public:
static property PdfRgbColor^ Lime {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


LimeGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : LimeGreen Property
Gets a predefined color with a RGB value of #32CD32
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property LimeGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.LimeGreen
public static PdfRgbColor LimeGreen {get;}
public:
static property PdfRgbColor^ LimeGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Linen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Linen Property
Gets a predefined color with a RGB value of #FAF0E6
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Linen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Linen
public static PdfRgbColor Linen {get;}
public:
static property PdfRgbColor^ Linen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Magenta Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Magenta Property
Gets a predefined color with a RGB value of #FF00FF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Magenta As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Magenta
public static PdfRgbColor Magenta {get;}
public:
static property PdfRgbColor^ Magenta {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Maroon Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Maroon Property
Gets a predefined color with a RGB value of #800000
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Maroon As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Maroon
public static PdfRgbColor Maroon {get;}
public:
static property PdfRgbColor^ Maroon {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumAquamarine Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumAquamarine Property
Gets a predefined color with a RGB value of #66CDAA
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumAquamarine As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumAquamarine
public static PdfRgbColor MediumAquamarine {get;}
public:
static property PdfRgbColor^ MediumAquamarine {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumBlue Property
Gets a predefined color with a RGB value of #0000CD
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumBlue
public static PdfRgbColor MediumBlue {get;}
public:
static property PdfRgbColor^ MediumBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumOrchid Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumOrchid Property
Gets a predefined color with a RGB value of #BA55D3
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumOrchid As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumOrchid
public static PdfRgbColor MediumOrchid {get;}
public:
static property PdfRgbColor^ MediumOrchid {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumPurple Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumPurple Property
Gets a predefined color with a RGB value of #9370DB
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumPurple As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumPurple
public static PdfRgbColor MediumPurple {get;}
public:
static property PdfRgbColor^ MediumPurple {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumSeaGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumSeaGreen Property
Gets a predefined color with a RGB value of #3CB371
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumSeaGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumSeaGreen
public static PdfRgbColor MediumSeaGreen {get;}
public:
static property PdfRgbColor^ MediumSeaGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumSlateBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumSlateBlue Property
Gets a predefined color with a RGB value of #7B68EE
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumSlateBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumSlateBlue
public static PdfRgbColor MediumSlateBlue {get;}
public:
static property PdfRgbColor^ MediumSlateBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumSpringGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumSpringGreen Property
Gets a predefined color with a RGB value of #00FA9A
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumSpringGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumSpringGreen
public static PdfRgbColor MediumSpringGreen {get;}
public:
static property PdfRgbColor^ MediumSpringGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumTurquoise Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumTurquoise Property
Gets a predefined color with a RGB value of #48D1CC
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumTurquoise As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumTurquoise
public static PdfRgbColor MediumTurquoise {get;}
public:
static property PdfRgbColor^ MediumTurquoise {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MediumVioletRed Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MediumVioletRed Property
Gets a predefined color with a RGB value of #C71585
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MediumVioletRed As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MediumVioletRed
public static PdfRgbColor MediumVioletRed {get;}
public:
static property PdfRgbColor^ MediumVioletRed {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MidnightBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MidnightBlue Property
Gets a predefined color with a RGB value of #191970
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MidnightBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MidnightBlue
public static PdfRgbColor MidnightBlue {get;}
public:
static property PdfRgbColor^ MidnightBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MintCream Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MintCream Property
Gets a predefined color with a RGB value of #F5FFFA
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MintCream As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MintCream
public static PdfRgbColor MintCream {get;}
public:
static property PdfRgbColor^ MintCream {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


MistyRose Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : MistyRose Property
Gets a predefined color with a RGB value of #FFE4E1
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property MistyRose As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.MistyRose
public static PdfRgbColor MistyRose {get;}
public:
static property PdfRgbColor^ MistyRose {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Moccasin Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Moccasin Property
Gets a predefined color with a RGB value of #FFE4B5
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Moccasin As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Moccasin
public static PdfRgbColor Moccasin {get;}
public:
static property PdfRgbColor^ Moccasin {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


NavajoWhite Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : NavajoWhite Property
Gets a predefined color with a RGB value of #FFDEAD
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property NavajoWhite As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.NavajoWhite
public static PdfRgbColor NavajoWhite {get;}
public:
static property PdfRgbColor^ NavajoWhite {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Navy Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Navy Property
Gets a predefined color with a RGB value of #000080
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Navy As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Navy
public static PdfRgbColor Navy {get;}
public:
static property PdfRgbColor^ Navy {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


OldLace Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : OldLace Property
Gets a predefined color with a RGB value of #FDF5E6
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property OldLace As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.OldLace
public static PdfRgbColor OldLace {get;}
public:
static property PdfRgbColor^ OldLace {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Olive Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Olive Property
Gets a predefined color with a RGB value of #808000
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Olive As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Olive
public static PdfRgbColor Olive {get;}
public:
static property PdfRgbColor^ Olive {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


OliveDrab Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : OliveDrab Property
Gets a predefined color with a RGB value of #6B8E23
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property OliveDrab As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.OliveDrab
public static PdfRgbColor OliveDrab {get;}
public:
static property PdfRgbColor^ OliveDrab {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Orange Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Orange Property
Gets a predefined color with a RGB value of #FFA500
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Orange As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Orange
public static PdfRgbColor Orange {get;}
public:
static property PdfRgbColor^ Orange {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


OrangeRed Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : OrangeRed Property
Gets a predefined color with a RGB value of #FF4500
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property OrangeRed As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.OrangeRed
public static PdfRgbColor OrangeRed {get;}
public:
static property PdfRgbColor^ OrangeRed {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Orchid Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Orchid Property
Gets a predefined color with a RGB value of #DA70D6
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Orchid As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Orchid
public static PdfRgbColor Orchid {get;}
public:
static property PdfRgbColor^ Orchid {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


PaleGoldenrod Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : PaleGoldenrod Property
Gets a predefined color with a RGB value of #EEE8AA
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PaleGoldenrod As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.PaleGoldenrod
public static PdfRgbColor PaleGoldenrod {get;}
public:
static property PdfRgbColor^ PaleGoldenrod {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


PaleGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : PaleGreen Property
Gets a predefined color with a RGB value of #98FB98
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PaleGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.PaleGreen
public static PdfRgbColor PaleGreen {get;}
public:
static property PdfRgbColor^ PaleGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


PaleTurquoise Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : PaleTurquoise Property
Gets a predefined color with a RGB value of #AFEEEE
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PaleTurquoise As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.PaleTurquoise
public static PdfRgbColor PaleTurquoise {get;}
public:
static property PdfRgbColor^ PaleTurquoise {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


PaleVioletRed Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : PaleVioletRed Property
Gets a predefined color with a RGB value of #DB7093
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PaleVioletRed As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.PaleVioletRed
public static PdfRgbColor PaleVioletRed {get;}
public:
static property PdfRgbColor^ PaleVioletRed {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


PapayaWhip Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : PapayaWhip Property
Gets a predefined color with a RGB value of #FFEFD5
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PapayaWhip As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.PapayaWhip
public static PdfRgbColor PapayaWhip {get;}
public:
static property PdfRgbColor^ PapayaWhip {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


PeachPuff Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : PeachPuff Property
Gets a predefined color with a RGB value of #FFDAB9
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PeachPuff As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.PeachPuff
public static PdfRgbColor PeachPuff {get;}
public:
static property PdfRgbColor^ PeachPuff {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Peru Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Peru Property
Gets a predefined color with a RGB value of #CD853F
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Peru As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Peru
public static PdfRgbColor Peru {get;}
public:
static property PdfRgbColor^ Peru {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Pink Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Pink Property
Gets a predefined color with a RGB value of #FFC0CB
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Pink As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Pink
public static PdfRgbColor Pink {get;}
public:
static property PdfRgbColor^ Pink {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Plum Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Plum Property
Gets a predefined color with a RGB value of #DDA0DD
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Plum As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Plum
public static PdfRgbColor Plum {get;}
public:
static property PdfRgbColor^ Plum {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


PowderBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : PowderBlue Property
Gets a predefined color with a RGB value of #B0E0E6
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property PowderBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.PowderBlue
public static PdfRgbColor PowderBlue {get;}
public:
static property PdfRgbColor^ PowderBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Purple Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Purple Property
Gets a predefined color with a RGB value of #800080
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Purple As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Purple
public static PdfRgbColor Purple {get;}
public:
static property PdfRgbColor^ Purple {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


R Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : R Property
Gets or sets the red component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property R As Byte
'Usage

Dim instance As PdfRgbColor
Dim value As Byte

instance.R = value

value = instance.R
public byte R {get; set;}
public:
property byte R {
   byte get();
   void set (    byte value);
}

Property Value

The red component in the range [0 255].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Red Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Red Property
Gets a predefined color with a RGB value of #FF0000
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Red As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Red
public static PdfRgbColor Red {get;}
public:
static property PdfRgbColor^ Red {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


RosyBrown Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : RosyBrown Property
Gets a predefined color with a RGB value of #BC8F8F
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property RosyBrown As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.RosyBrown
public static PdfRgbColor RosyBrown {get;}
public:
static property PdfRgbColor^ RosyBrown {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


RoyalBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : RoyalBlue Property
Gets a predefined color with a RGB value of #4169E1
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property RoyalBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.RoyalBlue
public static PdfRgbColor RoyalBlue {get;}
public:
static property PdfRgbColor^ RoyalBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SaddleBrown Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SaddleBrown Property
Gets a predefined color with a RGB value of #8B4513
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SaddleBrown As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SaddleBrown
public static PdfRgbColor SaddleBrown {get;}
public:
static property PdfRgbColor^ SaddleBrown {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Salmon Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Salmon Property
Gets a predefined color with a RGB value of #FA8072
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Salmon As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Salmon
public static PdfRgbColor Salmon {get;}
public:
static property PdfRgbColor^ Salmon {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SandyBrown Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SandyBrown Property
Gets a predefined color with a RGB value of #F4A460
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SandyBrown As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SandyBrown
public static PdfRgbColor SandyBrown {get;}
public:
static property PdfRgbColor^ SandyBrown {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SeaGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SeaGreen Property
Gets a predefined color with a RGB value of #2E8B57
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SeaGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SeaGreen
public static PdfRgbColor SeaGreen {get;}
public:
static property PdfRgbColor^ SeaGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SeaShell Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SeaShell Property
Gets a predefined color with a RGB value of #FFF5EE
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SeaShell As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SeaShell
public static PdfRgbColor SeaShell {get;}
public:
static property PdfRgbColor^ SeaShell {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Sienna Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Sienna Property
Gets a predefined color with a RGB value of #A0522D
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Sienna As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Sienna
public static PdfRgbColor Sienna {get;}
public:
static property PdfRgbColor^ Sienna {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Silver Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Silver Property
Gets a predefined color with a RGB value of #C0C0C0
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Silver As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Silver
public static PdfRgbColor Silver {get;}
public:
static property PdfRgbColor^ Silver {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SkyBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SkyBlue Property
Gets a predefined color with a RGB value of #87CEEB
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SkyBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SkyBlue
public static PdfRgbColor SkyBlue {get;}
public:
static property PdfRgbColor^ SkyBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SlateBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SlateBlue Property
Gets a predefined color with a RGB value of #6A5ACD
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SlateBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SlateBlue
public static PdfRgbColor SlateBlue {get;}
public:
static property PdfRgbColor^ SlateBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SlateGray Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SlateGray Property
Gets a predefined color with a RGB value of #708090
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SlateGray As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SlateGray
public static PdfRgbColor SlateGray {get;}
public:
static property PdfRgbColor^ SlateGray {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Snow Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Snow Property
Gets a predefined color with a RGB value of #FFFAFA
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Snow As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Snow
public static PdfRgbColor Snow {get;}
public:
static property PdfRgbColor^ Snow {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SpringGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SpringGreen Property
Gets a predefined color with a RGB value of #00FF7F
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SpringGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SpringGreen
public static PdfRgbColor SpringGreen {get;}
public:
static property PdfRgbColor^ SpringGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


SteelBlue Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : SteelBlue Property
Gets a predefined color with a RGB value of #4682B4
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property SteelBlue As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.SteelBlue
public static PdfRgbColor SteelBlue {get;}
public:
static property PdfRgbColor^ SteelBlue {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Tan Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Tan Property
Gets a predefined color with a RGB value of #D2B48C
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Tan As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Tan
public static PdfRgbColor Tan {get;}
public:
static property PdfRgbColor^ Tan {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Teal Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Teal Property
Gets a predefined color with a RGB value of #008080
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Teal As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Teal
public static PdfRgbColor Teal {get;}
public:
static property PdfRgbColor^ Teal {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Thistle Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Thistle Property
Gets a predefined color with a RGB value of #D8BFD8
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Thistle As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Thistle
public static PdfRgbColor Thistle {get;}
public:
static property PdfRgbColor^ Thistle {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Tomato Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Tomato Property
Gets a predefined color with a RGB value of #FF6347
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Tomato As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Tomato
public static PdfRgbColor Tomato {get;}
public:
static property PdfRgbColor^ Tomato {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Turquoise Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Turquoise Property
Gets a predefined color with a RGB value of #40E0D0
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Turquoise As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Turquoise
public static PdfRgbColor Turquoise {get;}
public:
static property PdfRgbColor^ Turquoise {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Violet Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Violet Property
Gets a predefined color with a RGB value of #EE82EE
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Violet As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Violet
public static PdfRgbColor Violet {get;}
public:
static property PdfRgbColor^ Violet {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Wheat Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Wheat Property
Gets a predefined color with a RGB value of #F5DEB3
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Wheat As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Wheat
public static PdfRgbColor Wheat {get;}
public:
static property PdfRgbColor^ Wheat {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


White Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : White Property
Gets a predefined color with a RGB value of #FFFFFF
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property White As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.White
public static PdfRgbColor White {get;}
public:
static property PdfRgbColor^ White {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


WhiteSmoke Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : WhiteSmoke Property
Gets a predefined color with a RGB value of #F5F5F5
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property WhiteSmoke As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.WhiteSmoke
public static PdfRgbColor WhiteSmoke {get;}
public:
static property PdfRgbColor^ WhiteSmoke {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


Yellow Property (PdfRgbColor)

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : Yellow Property
Gets a predefined color with a RGB value of #FFFF00
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property Yellow As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.Yellow
public static PdfRgbColor Yellow {get;}
public:
static property PdfRgbColor^ Yellow {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


YellowGreen Property

Xfinium.Pdf.Graphics Namespace > PdfRgbColor Class : YellowGreen Property
Gets a predefined color with a RGB value of #9ACD32
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Property YellowGreen As PdfRgbColor
'Usage

Dim value As PdfRgbColor

value = PdfRgbColor.YellowGreen
public static PdfRgbColor YellowGreen {get;}
public:
static property PdfRgbColor^ YellowGreen {
   PdfRgbColor^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColor Class
PdfRgbColor Members


%%PageItemTitle%%

PdfRgbColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfRgbColorSpace Class
Defines a device RGB colorspace.
Object Model
PdfRgbColorSpace ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRgbColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfRgbColorSpace
public class PdfRgbColorSpace : PdfColorSpace
public ref class PdfRgbColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfRgbColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfRgbColorSpace Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfRgbColorSpace Class

The following tables list the members exposed by PdfRgbColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfRgbColorSpace Constructor | Initializes a new PdfRgbColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Top
See Also

Reference

PdfRgbColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfRgbColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfRgbColorSpace Class : PdfRgbColorSpace Constructor
Initializes a new PdfRgbColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRgbColorSpace()
public PdfRgbColorSpace()
public:
PdfRgbColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColorSpace Class
PdfRgbColorSpace Members


%%PageItemTitle%% $$Methods$$

PdfRgbColorSpace Class Methods

Xfinium.Pdf.Graphics Namespace : PdfRgbColorSpace Class

For a list of all members of this type, see PdfRgbColorSpace members.

Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Top
See Also

Reference

PdfRgbColorSpace Class
Xfinium.Pdf.Graphics Namespace


Equals Method (PdfRgbColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfRgbColorSpace Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfRgbColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColorSpace Class
PdfRgbColorSpace Members


GetHashCode Method (PdfRgbColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfRgbColorSpace Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfRgbColorSpace
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColorSpace Class
PdfRgbColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfRgbColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfRgbColorSpace Class

For a list of all members of this type, see PdfRgbColorSpace members.

Public Properties
 | Name | Description
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfRgbColorSpace Class
Xfinium.Pdf.Graphics Namespace


ColorComponentCount Property (PdfRgbColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfRgbColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfRgbColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRgbColorSpace Class
PdfRgbColorSpace Members


%%PageItemTitle%%

PdfRm4sccBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfRm4sccBarcode Class
Defines a RM4SCC barcode.
Object Model
PdfRm4sccBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRm4sccBarcode
   Inherits PdfPostalBarcode
'Usage

Dim instance As PdfRm4sccBarcode
public class PdfRm4sccBarcode : PdfPostalBarcode
public ref class PdfRm4sccBarcode : public PdfPostalBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfPostalBarcode
Xfinium.Pdf.Graphics.PdfRm4sccBarcode
Xfinium.Pdf.Graphics.PdfKixBarcode
Xfinium.Pdf.Graphics.PdfSingaporePostBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRm4sccBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfRm4sccBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfRm4sccBarcode Class

The following tables list the members exposed by PdfRm4sccBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfRm4sccBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfRm4sccBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfRm4sccBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfRm4sccBarcode Class : PdfRm4sccBarcode Constructor
Overload List
Overload | Description
PdfRm4sccBarcode Constructor() | Initializes a new PdfRm4sccBarcode object.
PdfRm4sccBarcode Constructor(String) | Initializes a new PdfRm4sccBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRm4sccBarcode Class
PdfRm4sccBarcode Members


%%PageItemTitle%%

PdfRm4sccBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfRm4sccBarcode Class > PdfRm4sccBarcode Constructor : PdfRm4sccBarcode Constructor()
Initializes a new PdfRm4sccBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRm4sccBarcode()
public PdfRm4sccBarcode()
public:
PdfRm4sccBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRm4sccBarcode Class
PdfRm4sccBarcode Members
Overload List


%%PageItemTitle%%

PdfRm4sccBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfRm4sccBarcode Class > PdfRm4sccBarcode Constructor : PdfRm4sccBarcode Constructor(String)
The barcode data.
Initializes a new PdfRm4sccBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfRm4sccBarcode(data)
public PdfRm4sccBarcode(
   string data
)
public:
PdfRm4sccBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRm4sccBarcode Class
PdfRm4sccBarcode Members
Overload List


%%PageItemTitle%%

PdfScc14Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfScc14Barcode Class
Defines a SCC-14 (Shipping Container Code) barcode.
Object Model
PdfScc14Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfScc14Barcode
   Inherits PdfCode128CBarcode
'Usage

Dim instance As PdfScc14Barcode
public class PdfScc14Barcode : PdfCode128CBarcode
public ref class PdfScc14Barcode : public PdfCode128CBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 13 digits
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128CBarcode
Xfinium.Pdf.Graphics.PdfScc14Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScc14Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfScc14Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfScc14Barcode Class

The following tables list the members exposed by PdfScc14Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfScc14Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfScc14Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfScc14Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfScc14Barcode Class : PdfScc14Barcode Constructor
Overload List
Overload | Description
PdfScc14Barcode Constructor() | Initializes a new PdfScc14Barcode object.
PdfScc14Barcode Constructor(String) | Initializes a new PdfScc14Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScc14Barcode Class
PdfScc14Barcode Members


%%PageItemTitle%%

PdfScc14Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfScc14Barcode Class > PdfScc14Barcode Constructor : PdfScc14Barcode Constructor()
Initializes a new PdfScc14Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfScc14Barcode()
public PdfScc14Barcode()
public:
PdfScc14Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScc14Barcode Class
PdfScc14Barcode Members
Overload List


%%PageItemTitle%%

PdfScc14Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfScc14Barcode Class > PdfScc14Barcode Constructor : PdfScc14Barcode Constructor(String)
The barcode data.
Initializes a new PdfScc14Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfScc14Barcode(data)
public PdfScc14Barcode(
   string data
)
public:
PdfScc14Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScc14Barcode Class
PdfScc14Barcode Members
Overload List


%%PageItemTitle%%

PdfSeparationColor Class
Members

Xfinium.Pdf.Graphics Namespace : PdfSeparationColor Class
Defines a color based on a separation colorspace.
Object Model
PdfSeparationColor ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSeparationColor
   Inherits PdfColor
'Usage

Dim instance As PdfSeparationColor
public class PdfSeparationColor : PdfColor
public ref class PdfSeparationColor : public PdfColor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColor
Xfinium.Pdf.Graphics.PdfSeparationColor
Xfinium.Pdf.Graphics.PdfPantoneColor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColor Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfSeparationColor Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfSeparationColor Class

The following tables list the members exposed by PdfSeparationColor.

Public Constructors
 | Name | Description
Public Constructor | PdfSeparationColor Constructor | Initializes a new PdfSeparationColor object with a separation colorspace.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | Tint | Gets or sets the tint component.
Top
Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfSeparationColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfSeparationColor Constructor

Xfinium.Pdf.Graphics Namespace > PdfSeparationColor Class : PdfSeparationColor Constructor
The separation colorspace.
Initializes a new PdfSeparationColor object with a separation colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpace As PdfSeparationColorSpace _
)
'Usage

Dim colorSpace As PdfSeparationColorSpace

Dim instance As New PdfSeparationColor(colorSpace)
public PdfSeparationColor(
   PdfSeparationColorSpace colorSpace
)
public:
PdfSeparationColor(
   PdfSeparationColorSpace^ colorSpace
)

Parameters

colorSpace
The separation colorspace.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColor Class
PdfSeparationColor Members


%%PageItemTitle%% $$Methods$$

PdfSeparationColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfSeparationColor Class

For a list of all members of this type, see PdfSeparationColor members.

Public Methods
 | Name | Description
Public Method | Copy | Overridden. Copies this color.
Public Method | Equals | Determines whether the specified Object is equal to the current Object.
Public Method | GetHashCode | Serves as the default hash function.
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfSeparationColor Class
Xfinium.Pdf.Graphics Namespace


Copy Method (PdfSeparationColor)

Xfinium.Pdf.Graphics Namespace > PdfSeparationColor Class : Copy Method
Copies this color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Copy() As PdfColor
'Usage

Dim instance As PdfSeparationColor
Dim value As PdfColor

value = instance.Copy()
public override PdfColor Copy()
public:
PdfColor^ Copy(); override

Return Value

A copy of this color.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColor Class
PdfSeparationColor Members


Equals Method (PdfSeparationColor)

Xfinium.Pdf.Graphics Namespace > PdfSeparationColor Class : Equals Method
The Object to compare with the current Object.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PdfSeparationColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColor Class
PdfSeparationColor Members


GetHashCode Method (PdfSeparationColor)

Xfinium.Pdf.Graphics Namespace > PdfSeparationColor Class : GetHashCode Method
Serves as the default hash function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PdfSeparationColor
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

A hash code for the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColor Class
PdfSeparationColor Members


%%PageItemTitle%% $$Properties$$

PdfSeparationColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfSeparationColor Class

For a list of all members of this type, see PdfSeparationColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Public Property | Tint | Gets or sets the tint component.
Top
See Also

Reference

PdfSeparationColor Class
Xfinium.Pdf.Graphics Namespace


Tint Property

Xfinium.Pdf.Graphics Namespace > PdfSeparationColor Class : Tint Property
Gets or sets the tint component.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tint As Double
'Usage

Dim instance As PdfSeparationColor
Dim value As Double

instance.Tint = value

value = instance.Tint
public double Tint {get; set;}
public:
property double Tint {
   double get();
   void set (    double value);
}

Property Value

The tint component color in the range [0 1].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColor Class
PdfSeparationColor Members


%%PageItemTitle%%

PdfSeparationColorSpace Class
Members

Xfinium.Pdf.Graphics Namespace : PdfSeparationColorSpace Class
Defines a separation colorspace.
Object Model
PdfSeparationColorSpace ClassPdfColorSpace ClassPdfCosObject ClassPdfFunction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSeparationColorSpace
   Inherits PdfColorSpace
'Usage

Dim instance As PdfSeparationColorSpace
public class PdfSeparationColorSpace : PdfColorSpace
public ref class PdfSeparationColorSpace : public PdfColorSpace
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfColorSpace
Xfinium.Pdf.Graphics.PdfSeparationColorSpace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColorSpace Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfSeparationColorSpace Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfSeparationColorSpace Class

The following tables list the members exposed by PdfSeparationColorSpace.

Public Constructors
 | Name | Description
Public Constructor | PdfSeparationColorSpace Constructor | Initializes a new PdfSeparationColorSpace object.
Top
Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Colorant | Gets or sets the colorant name.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | TintTransform | Gets or sets the tint transform.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfSeparationColorSpace Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfSeparationColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfSeparationColorSpace Class : PdfSeparationColorSpace Constructor
Initializes a new PdfSeparationColorSpace object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSeparationColorSpace()
public PdfSeparationColorSpace()
public:
PdfSeparationColorSpace();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColorSpace Class
PdfSeparationColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfSeparationColorSpace Class Properties

Xfinium.Pdf.Graphics Namespace : PdfSeparationColorSpace Class

For a list of all members of this type, see PdfSeparationColorSpace members.

Public Properties
 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Colorant | Gets or sets the colorant name.
Public Property | ColorComponentCount | Overridden. Gets the number of components used by a color in this colorspace.
Public Property | CosObject | Gets the raw colorspace object. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Public Property | TintTransform | Gets or sets the tint transform.
Public Property | Type | Gets the colorspace type. (Inherited from Xfinium.Pdf.Graphics.PdfColorSpace)
Top
See Also

Reference

PdfSeparationColorSpace Class
Xfinium.Pdf.Graphics Namespace


AlternateColorSpace Property (PdfSeparationColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfSeparationColorSpace Class : AlternateColorSpace Property
Gets or sets the alternate colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AlternateColorSpace As PdfColorSpace
'Usage

Dim instance As PdfSeparationColorSpace
Dim value As PdfColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
public PdfColorSpace AlternateColorSpace {get; set;}
public:
property PdfColorSpace^ AlternateColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

The alternate color space that is used when the colorant is not supported by the destination device.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColorSpace Class
PdfSeparationColorSpace Members


Colorant Property

Xfinium.Pdf.Graphics Namespace > PdfSeparationColorSpace Class : Colorant Property
Gets or sets the colorant name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Colorant As String
'Usage

Dim instance As PdfSeparationColorSpace
Dim value As String

instance.Colorant = value

value = instance.Colorant
public string Colorant {get; set;}
public:
property String^ Colorant {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the colorant that this separation color space is intended to represent
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColorSpace Class
PdfSeparationColorSpace Members


ColorComponentCount Property (PdfSeparationColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfSeparationColorSpace Class : ColorComponentCount Property
Gets the number of components used by a color in this colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ColorComponentCount As Integer
'Usage

Dim instance As PdfSeparationColorSpace
Dim value As Integer

value = instance.ColorComponentCount
public override int ColorComponentCount {get;}
public:
property int ColorComponentCount {
   int get() override;
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColorSpace Class
PdfSeparationColorSpace Members


TintTransform Property (PdfSeparationColorSpace)

Xfinium.Pdf.Graphics Namespace > PdfSeparationColorSpace Class : TintTransform Property
Gets or sets the tint transform.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TintTransform As PdfFunction
'Usage

Dim instance As PdfSeparationColorSpace
Dim value As PdfFunction

instance.TintTransform = value

value = instance.TintTransform
public PdfFunction TintTransform {get; set;}
public:
property PdfFunction^ TintTransform {
   PdfFunction^ get();
   void set (    PdfFunction^ value);
}

Property Value

A function that is used to transform the tint values into the alternate color space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColorSpace Class
PdfSeparationColorSpace Members


%%PageItemTitle%%

PdfShading Class
Members

Xfinium.Pdf.Graphics Namespace : PdfShading Class
Defines the base class for PDF shadings.
Object Model
PdfShading ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfShading
'Usage

Dim instance As PdfShading
public class PdfShading
public ref class PdfShading
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfShading
Xfinium.Pdf.Graphics.PdfAxialShading
Xfinium.Pdf.Graphics.PdfFunctionShading
Xfinium.Pdf.Graphics.PdfRadialShading

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShading Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfShading Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfShading Class

The following tables list the members exposed by PdfShading.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts.
Public Property | ColorSpace | Gets or sets the shading color space.
Top
See Also

Reference

PdfShading Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfShading Class Properties

Xfinium.Pdf.Graphics Namespace : PdfShading Class

For a list of all members of this type, see PdfShading members.

Public Properties
 | Name | Description
Public Property | AntiAlias | Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts.
Public Property | ColorSpace | Gets or sets the shading color space.
Top
See Also

Reference

PdfShading Class
Xfinium.Pdf.Graphics Namespace


AntiAlias Property

Xfinium.Pdf.Graphics Namespace > PdfShading Class : AntiAlias Property
Gets or sets a value indicating whether to filter the shading function to prevent aliasing artifacts.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AntiAlias As Boolean
'Usage

Dim instance As PdfShading
Dim value As Boolean

instance.AntiAlias = value

value = instance.AntiAlias
public bool AntiAlias {get; set;}
public:
property bool AntiAlias {
   bool get();
   void set (    bool value);
}

Property Value

If true, the output device will antialias the shading output.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShading Class
PdfShading Members


ColorSpace Property (PdfShading)

Xfinium.Pdf.Graphics Namespace > PdfShading Class : ColorSpace Property
Gets or sets the shading color space.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorSpace As PdfColorSpace
'Usage

Dim instance As PdfShading
Dim value As PdfColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PdfColorSpace ColorSpace {get; set;}
public:
property PdfColorSpace^ ColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

The color space in which color values are expressed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShading Class
PdfShading Members


%%PageItemTitle%%

PdfShadingPattern Class
Members

Xfinium.Pdf.Graphics Namespace : PdfShadingPattern Class
Defines a shading based pattern.
Object Model
PdfShadingPattern ClassPdfMatrix ClassPdfShading Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfShadingPattern
   Inherits PdfPattern
'Usage

Dim instance As PdfShadingPattern
public class PdfShadingPattern : PdfPattern
public ref class PdfShadingPattern : public PdfPattern
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPattern
Xfinium.Pdf.Graphics.PdfShadingPattern

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingPattern Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfShadingPattern Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfShadingPattern Class

The following tables list the members exposed by PdfShadingPattern.

Public Constructors
 | Name | Description
Public Constructor | PdfShadingPattern Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Matrix | Gets or sets the pattern matrix.
Public Property | Shading | Gets or sets the shading.
Top
See Also

Reference

PdfShadingPattern Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfShadingPattern Constructor

Xfinium.Pdf.Graphics Namespace > PdfShadingPattern Class : PdfShadingPattern Constructor
Overload List
Overload | Description
PdfShadingPattern Constructor() | Initializes a new PdfShadingPattern object.
PdfShadingPattern Constructor(PdfShading) | Initializes a new PdfShadingPattern object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingPattern Class
PdfShadingPattern Members


%%PageItemTitle%%

PdfShadingPattern Constructor()

Xfinium.Pdf.Graphics Namespace > PdfShadingPattern Class > PdfShadingPattern Constructor : PdfShadingPattern Constructor()
Initializes a new PdfShadingPattern object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfShadingPattern()
public PdfShadingPattern()
public:
PdfShadingPattern();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingPattern Class
PdfShadingPattern Members
Overload List


%%PageItemTitle%%

PdfShadingPattern Constructor(PdfShading)

Xfinium.Pdf.Graphics Namespace > PdfShadingPattern Class > PdfShadingPattern Constructor : PdfShadingPattern Constructor(PdfShading)
The shading associated with this pattern.
Initializes a new PdfShadingPattern object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal shading As PdfShading _
)
'Usage

Dim shading As PdfShading

Dim instance As New PdfShadingPattern(shading)
public PdfShadingPattern(
   PdfShading shading
)
public:
PdfShadingPattern(
   PdfShading^ shading
)

Parameters

shading
The shading associated with this pattern.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingPattern Class
PdfShadingPattern Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfShadingPattern Class Properties

Xfinium.Pdf.Graphics Namespace : PdfShadingPattern Class

For a list of all members of this type, see PdfShadingPattern members.

Public Properties
 | Name | Description
Public Property | Matrix | Gets or sets the pattern matrix.
Public Property | Shading | Gets or sets the shading.
Top
See Also

Reference

PdfShadingPattern Class
Xfinium.Pdf.Graphics Namespace


Matrix Property (PdfShadingPattern)

Xfinium.Pdf.Graphics Namespace > PdfShadingPattern Class : Matrix Property
Gets or sets the pattern matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Matrix As PdfMatrix
'Usage

Dim instance As PdfShadingPattern
Dim value As PdfMatrix

instance.Matrix = value

value = instance.Matrix
public PdfMatrix Matrix {get; set;}
public:
property PdfMatrix^ Matrix {
   PdfMatrix^ get();
   void set (    PdfMatrix^ value);
}

Property Value

The pattern matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingPattern Class
PdfShadingPattern Members


Shading Property (PdfShadingPattern)

Xfinium.Pdf.Graphics Namespace > PdfShadingPattern Class : Shading Property
Gets or sets the shading.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Shading As PdfShading
'Usage

Dim instance As PdfShadingPattern
Dim value As PdfShading

instance.Shading = value

value = instance.Shading
public PdfShading Shading {get; set;}
public:
property PdfShading^ Shading {
   PdfShading^ get();
   void set (    PdfShading^ value);
}

Property Value

A PdfShading object associated with this pattern
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShadingPattern Class
PdfShadingPattern Members


%%PageItemTitle%%

PdfSingaporePostBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfSingaporePostBarcode Class
Defines a Singapore Post barcode.
Object Model
PdfSingaporePostBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSingaporePostBarcode
   Inherits PdfRm4sccBarcode
'Usage

Dim instance As PdfSingaporePostBarcode
public class PdfSingaporePostBarcode : PdfRm4sccBarcode
public ref class PdfSingaporePostBarcode : public PdfRm4sccBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfPostalBarcode
Xfinium.Pdf.Graphics.PdfRm4sccBarcode
Xfinium.Pdf.Graphics.PdfSingaporePostBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSingaporePostBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfSingaporePostBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfSingaporePostBarcode Class

The following tables list the members exposed by PdfSingaporePostBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfSingaporePostBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfSingaporePostBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfSingaporePostBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfSingaporePostBarcode Class : PdfSingaporePostBarcode Constructor
Overload List
Overload | Description
PdfSingaporePostBarcode Constructor() | Initializes a new PdfSingaporePostBarcode object.
PdfSingaporePostBarcode Constructor(String) | Initializes a new PdfSingaporePostBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSingaporePostBarcode Class
PdfSingaporePostBarcode Members


%%PageItemTitle%%

PdfSingaporePostBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfSingaporePostBarcode Class > PdfSingaporePostBarcode Constructor : PdfSingaporePostBarcode Constructor()
Initializes a new PdfSingaporePostBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSingaporePostBarcode()
public PdfSingaporePostBarcode()
public:
PdfSingaporePostBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSingaporePostBarcode Class
PdfSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PdfSingaporePostBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfSingaporePostBarcode Class > PdfSingaporePostBarcode Constructor : PdfSingaporePostBarcode Constructor(String)
The barcode data.
Initializes a new PdfSingaporePostBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfSingaporePostBarcode(data)
public PdfSingaporePostBarcode(
   string data
)
public:
PdfSingaporePostBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSingaporePostBarcode Class
PdfSingaporePostBarcode Members
Overload List


%%PageItemTitle%%

PdfSize Class
Members

Xfinium.Pdf.Graphics Namespace : PdfSize Class
Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSize
'Usage

Dim instance As PdfSize
public class PdfSize
public ref class PdfSize
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfSize

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSize Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfSize Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfSize Class

The following tables list the members exposed by PdfSize.

Public Constructors
 | Name | Description
Public Constructor | PdfSize Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the vertical component of this PdfSize object.
Public Property | Width | Gets or sets the horizontal component of this PdfSize object.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfSize Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfSize Constructor

Xfinium.Pdf.Graphics Namespace > PdfSize Class : PdfSize Constructor
Overload List
Overload | Description
PdfSize Constructor() | Initializes a new PdfSize object.
PdfSize Constructor(Double,Double) | Initializes a new PdfSize object with the given size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSize Class
PdfSize Members


%%PageItemTitle%%

PdfSize Constructor()

Xfinium.Pdf.Graphics Namespace > PdfSize Class > PdfSize Constructor : PdfSize Constructor()
Initializes a new PdfSize object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSize()
public PdfSize()
public:
PdfSize();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSize Class
PdfSize Members
Overload List


%%PageItemTitle%%

PdfSize Constructor(Double,Double)

Xfinium.Pdf.Graphics Namespace > PdfSize Class > PdfSize Constructor : PdfSize Constructor(Double,Double)
The horizontal component.
The vertical component.
Initializes a new PdfSize object with the given size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New PdfSize(width, height)
public PdfSize(
   double width,
   double height
)
public:
PdfSize(
   double width,
   double height
)

Parameters

width
The horizontal component.
height
The vertical component.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSize Class
PdfSize Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfSize Class Methods

Xfinium.Pdf.Graphics Namespace : PdfSize Class

For a list of all members of this type, see PdfSize members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfSize Class
Xfinium.Pdf.Graphics Namespace


ToString Method (PdfSize)

Xfinium.Pdf.Graphics Namespace > PdfSize Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfSize
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSize Class
PdfSize Members


%%PageItemTitle%% $$Properties$$

PdfSize Class Properties

Xfinium.Pdf.Graphics Namespace : PdfSize Class

For a list of all members of this type, see PdfSize members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the vertical component of this PdfSize object.
Public Property | Width | Gets or sets the horizontal component of this PdfSize object.
Top
See Also

Reference

PdfSize Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfSize)

Xfinium.Pdf.Graphics Namespace > PdfSize Class : Height Property
Gets or sets the vertical component of this PdfSize object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PdfSize
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The vertical component of this PdfSize object, typically measured in points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSize Class
PdfSize Members


Width Property (PdfSize)

Xfinium.Pdf.Graphics Namespace > PdfSize Class : Width Property
Gets or sets the horizontal component of this PdfSize object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PdfSize
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The horizontal component of this PdfSize object, typically measured in points.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSize Class
PdfSize Members


%%PageItemTitle%%

PdfSoftMask Class
Members

Xfinium.Pdf.Graphics Namespace : PdfSoftMask Class
Defines a soft mask.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSoftMask
   Inherits PdfStencilMask
'Usage

Dim instance As PdfSoftMask
public class PdfSoftMask : PdfStencilMask
public ref class PdfSoftMask : public PdfStencilMask
Remarks
A soft mask, also known as an alpha channel mask, uses a grayscale bitmap to define 256 transparency levels.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImageMask
Xfinium.Pdf.Graphics.PdfStencilMask
Xfinium.Pdf.Graphics.PdfSoftMask

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoftMask Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfSoftMask Class Members

Xfinium.Pdf.Graphics Namespace : PdfSoftMask Class

The following tables list the members exposed by PdfSoftMask.

Public Constructors
 | Name | Description
Public Constructor | PdfSoftMask Constructor | Initializes a new PdfSoftMask object.
Top
See Also

Reference

PdfSoftMask Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfSoftMask Constructor

Xfinium.Pdf.Graphics Namespace > PdfSoftMask Class : PdfSoftMask Constructor
A grayscale image that represents the soft mask.
Initializes a new PdfSoftMask object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal sourceImage As PdfImage _
)
'Usage

Dim sourceImage As PdfImage

Dim instance As New PdfSoftMask(sourceImage)
public PdfSoftMask(
   PdfImage sourceImage
)
public:
PdfSoftMask(
   PdfImage^ sourceImage
)

Parameters

sourceImage
A grayscale image that represents the soft mask.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoftMask Class
PdfSoftMask Members


%%PageItemTitle%%

PdfSscc18Barcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfSscc18Barcode Class
Defines a SSCC-18 (Serial Shipping Container Code) barcode.
Object Model
PdfSscc18Barcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSscc18Barcode
   Inherits PdfCode128CBarcode
'Usage

Dim instance As PdfSscc18Barcode
public class PdfSscc18Barcode : PdfCode128CBarcode
public ref class PdfSscc18Barcode : public PdfCode128CBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 17 digits
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128CBarcode
Xfinium.Pdf.Graphics.PdfSscc18Barcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSscc18Barcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfSscc18Barcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfSscc18Barcode Class

The following tables list the members exposed by PdfSscc18Barcode.

Public Constructors
 | Name | Description
Public Constructor | PdfSscc18Barcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfSscc18Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfSscc18Barcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfSscc18Barcode Class : PdfSscc18Barcode Constructor
Overload List
Overload | Description
PdfSscc18Barcode Constructor() | Initializes a new PdfSscc18Barcode object.
PdfSscc18Barcode Constructor(String) | Initializes a new PdfSscc18Barcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSscc18Barcode Class
PdfSscc18Barcode Members


%%PageItemTitle%%

PdfSscc18Barcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfSscc18Barcode Class > PdfSscc18Barcode Constructor : PdfSscc18Barcode Constructor()
Initializes a new PdfSscc18Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSscc18Barcode()
public PdfSscc18Barcode()
public:
PdfSscc18Barcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSscc18Barcode Class
PdfSscc18Barcode Members
Overload List


%%PageItemTitle%%

PdfSscc18Barcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfSscc18Barcode Class > PdfSscc18Barcode Constructor : PdfSscc18Barcode Constructor(String)
The barcode data.
Initializes a new PdfSscc18Barcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfSscc18Barcode(data)
public PdfSscc18Barcode(
   string data
)
public:
PdfSscc18Barcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSscc18Barcode Class
PdfSscc18Barcode Members
Overload List


%%PageItemTitle%%

PdfStandardFont Class
Members

Xfinium.Pdf.Graphics Namespace : PdfStandardFont Class
Defines a standard Pdf font.
Object Model
PdfStandardFont ClassPdfFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfStandardFont
   Inherits PdfFont
'Usage

Dim instance As PdfStandardFont
public class PdfStandardFont : PdfFont
public ref class PdfStandardFont : public PdfFont
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFont
Xfinium.Pdf.Graphics.PdfStandardFont

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardFont Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfStandardFont Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfStandardFont Class

The following tables list the members exposed by PdfStandardFont.

Public Constructors
 | Name | Description
Public Constructor | PdfStandardFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets a value indicating whether the font is bold.
Public Property | FontFace | Gets or sets the font face.
Public Property | Italic | Overridden. Gets or sets a value indicating whether the font is italic.
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfStandardFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStandardFont Constructor

Xfinium.Pdf.Graphics Namespace > PdfStandardFont Class : PdfStandardFont Constructor
Overload List
Overload | Description
PdfStandardFont Constructor() | Initializes a new PdfStandardFont object
PdfStandardFont Constructor(PdfStandardFontFace,Double) | Initializes a new PdfStandardFont object.
PdfStandardFont Constructor(PdfStandardFont) | Initializes a new PdfStandardFont object with another font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardFont Class
PdfStandardFont Members


%%PageItemTitle%%

PdfStandardFont Constructor()

Xfinium.Pdf.Graphics Namespace > PdfStandardFont Class > PdfStandardFont Constructor : PdfStandardFont Constructor()
Initializes a new PdfStandardFont object
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfStandardFont()
public PdfStandardFont()
public:
PdfStandardFont();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardFont Class
PdfStandardFont Members
Overload List


%%PageItemTitle%%

PdfStandardFont Constructor(PdfStandardFontFace,Double)

Xfinium.Pdf.Graphics Namespace > PdfStandardFont Class > PdfStandardFont Constructor : PdfStandardFont Constructor(PdfStandardFontFace,Double)
The font face.
Font size
Initializes a new PdfStandardFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fontFace As PdfStandardFontFace, _
   ByVal size As Double _
)
'Usage

Dim fontFace As PdfStandardFontFace
Dim size As Double

Dim instance As New PdfStandardFont(fontFace, size)
public PdfStandardFont(
   PdfStandardFontFace fontFace,
   double size
)
public:
PdfStandardFont(
   PdfStandardFontFace fontFace,
   double size
)

Parameters

fontFace
The font face.
size
Font size
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardFont Class
PdfStandardFont Members
Overload List


%%PageItemTitle%%

PdfStandardFont Constructor(PdfStandardFont)

Xfinium.Pdf.Graphics Namespace > PdfStandardFont Class > PdfStandardFont Constructor : PdfStandardFont Constructor(PdfStandardFont)
Source PDF font.
Initializes a new PdfStandardFont object with another font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PdfStandardFont _
)
'Usage

Dim font As PdfStandardFont

Dim instance As New PdfStandardFont(font)
public PdfStandardFont(
   PdfStandardFont font
)
public:
PdfStandardFont(
   PdfStandardFont^ font
)

Parameters

font
Source PDF font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardFont Class
PdfStandardFont Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfStandardFont Class Properties

Xfinium.Pdf.Graphics Namespace : PdfStandardFont Class

For a list of all members of this type, see PdfStandardFont members.

Public Properties
 | Name | Description
Public Property | Bold | Overridden. Gets or sets a value indicating whether the font is bold.
Public Property | FontFace | Gets or sets the font face.
Public Property | Italic | Overridden. Gets or sets a value indicating whether the font is italic.
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfStandardFont Class
Xfinium.Pdf.Graphics Namespace


Bold Property (PdfStandardFont)

Xfinium.Pdf.Graphics Namespace > PdfStandardFont Class : Bold Property
Gets or sets a value indicating whether the font is bold.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Bold As Boolean
'Usage

Dim instance As PdfStandardFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
public override bool Bold {get; set;}
public:
property bool Bold {
   bool get() override;
   void set (    bool value) override;
}

Property Value

If true, then the font has a bold appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardFont Class
PdfStandardFont Members


FontFace Property

Xfinium.Pdf.Graphics Namespace > PdfStandardFont Class : FontFace Property
Gets or sets the font face.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FontFace As PdfStandardFontFace
'Usage

Dim instance As PdfStandardFont
Dim value As PdfStandardFontFace

instance.FontFace = value

value = instance.FontFace
public PdfStandardFontFace FontFace {get; set;}
public:
property PdfStandardFontFace FontFace {
   PdfStandardFontFace get();
   void set (    PdfStandardFontFace value);
}

Property Value

A FontFace that represents the font face.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardFont Class
PdfStandardFont Members


Italic Property (PdfStandardFont)

Xfinium.Pdf.Graphics Namespace > PdfStandardFont Class : Italic Property
Gets or sets a value indicating whether the font is italic.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Italic As Boolean
'Usage

Dim instance As PdfStandardFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
public override bool Italic {get; set;}
public:
property bool Italic {
   bool get() override;
   void set (    bool value) override;
}

Property Value

If true, then the font has an italic appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardFont Class
PdfStandardFont Members


%%PageItemTitle%%

PdfStandardRectangle Class
Members

Xfinium.Pdf.Graphics Namespace : PdfStandardRectangle Class
Defines a rectangle in PDF coordinate system.
Object Model
PdfStandardRectangle ClassPdfPoint ClassPdfPoint Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfStandardRectangle
'Usage

Dim instance As PdfStandardRectangle
public class PdfStandardRectangle
public ref class PdfStandardRectangle
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfStandardRectangle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfStandardRectangle Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfStandardRectangle Class

The following tables list the members exposed by PdfStandardRectangle.

Public Constructors
 | Name | Description
Public Constructor | PdfStandardRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle height.
Public Property | LL | Gets the position of lower-left corner.
Public Property | LLX | Gets the lower-left x coordinate.
Public Property | LLY | Gets the lower-left y coordinate.
Public Property | UR | Gets the position of upper-right corner.
Public Property | URX | Gets the upper-right x coordinate.
Public Property | URY | Gets the upper-right y coordinate.
Public Property | Width | Gets or sets the rectangle width.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfStandardRectangle Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStandardRectangle Constructor

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : PdfStandardRectangle Constructor
Overload List
Overload | Description
PdfStandardRectangle Constructor() | Initializes a new PdfStandardRectangle object.
PdfStandardRectangle Constructor(Double,Double,Double,Double) | Initializes a new PdfStandardRectangle object.
PdfStandardRectangle Constructor(PdfPoint,PdfPoint) | Initializes a new PdfStandardRectangle object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


%%PageItemTitle%%

PdfStandardRectangle Constructor()

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class > PdfStandardRectangle Constructor : PdfStandardRectangle Constructor()
Initializes a new PdfStandardRectangle object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfStandardRectangle()
public PdfStandardRectangle()
public:
PdfStandardRectangle();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members
Overload List


%%PageItemTitle%%

PdfStandardRectangle Constructor(Double,Double,Double,Double)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class > PdfStandardRectangle Constructor : PdfStandardRectangle Constructor(Double,Double,Double,Double)
The lower-left x coordinate of the rectangle.
The lower-left y coordinate of the rectangle.
The upper-right x coordinate of the rectangle.
The upper-right y coordinate of the rectangle.
Initializes a new PdfStandardRectangle object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal llx As Double, _
   ByVal lly As Double, _
   ByVal urx As Double, _
   ByVal ury As Double _
)
'Usage

Dim llx As Double
Dim lly As Double
Dim urx As Double
Dim ury As Double

Dim instance As New PdfStandardRectangle(llx, lly, urx, ury)
public PdfStandardRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)
public:
PdfStandardRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)

Parameters

llx
The lower-left x coordinate of the rectangle.
lly
The lower-left y coordinate of the rectangle.
urx
The upper-right x coordinate of the rectangle.
ury
The upper-right y coordinate of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members
Overload List


%%PageItemTitle%%

PdfStandardRectangle Constructor(PdfPoint,PdfPoint)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class > PdfStandardRectangle Constructor : PdfStandardRectangle Constructor(PdfPoint,PdfPoint)
The position of lower-left corner of the rectangle.
The position of upper-right corner of the rectangle.
Initializes a new PdfStandardRectangle object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ll As PdfPoint, _
   ByVal ur As PdfPoint _
)
'Usage

Dim ll As PdfPoint
Dim ur As PdfPoint

Dim instance As New PdfStandardRectangle(ll, ur)
public PdfStandardRectangle(
   PdfPoint ll,
   PdfPoint ur
)
public:
PdfStandardRectangle(
   PdfPoint^ ll,
   PdfPoint^ ur
)

Parameters

ll
The position of lower-left corner of the rectangle.
ur
The position of upper-right corner of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfStandardRectangle Class Methods

Xfinium.Pdf.Graphics Namespace : PdfStandardRectangle Class

For a list of all members of this type, see PdfStandardRectangle members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfStandardRectangle Class
Xfinium.Pdf.Graphics Namespace


ToString Method (PdfStandardRectangle)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfStandardRectangle
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


%%PageItemTitle%% $$Properties$$

PdfStandardRectangle Class Properties

Xfinium.Pdf.Graphics Namespace : PdfStandardRectangle Class

For a list of all members of this type, see PdfStandardRectangle members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the rectangle height.
Public Property | LL | Gets the position of lower-left corner.
Public Property | LLX | Gets the lower-left x coordinate.
Public Property | LLY | Gets the lower-left y coordinate.
Public Property | UR | Gets the position of upper-right corner.
Public Property | URX | Gets the upper-right x coordinate.
Public Property | URY | Gets the upper-right y coordinate.
Public Property | Width | Gets or sets the rectangle width.
Top
See Also

Reference

PdfStandardRectangle Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfStandardRectangle)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : Height Property
Gets or sets the rectangle height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PdfStandardRectangle
Dim value As Double

value = instance.Height
public double Height {get;}
public:
property double Height {
   double get();
}

Property Value

The height of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


LL Property

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : LL Property
Gets the position of lower-left corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LL As PdfPoint
'Usage

Dim instance As PdfStandardRectangle
Dim value As PdfPoint

instance.LL = value

value = instance.LL
public PdfPoint LL {get; set;}
public:
property PdfPoint^ LL {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The position of lower-left corner of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


LLX Property (PdfStandardRectangle)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : LLX Property
Gets the lower-left x coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LLX As Double
'Usage

Dim instance As PdfStandardRectangle
Dim value As Double

value = instance.LLX
public double LLX {get;}
public:
property double LLX {
   double get();
}

Property Value

The lower-left x coordinate of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


LLY Property (PdfStandardRectangle)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : LLY Property
Gets the lower-left y coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property LLY As Double
'Usage

Dim instance As PdfStandardRectangle
Dim value As Double

value = instance.LLY
public double LLY {get;}
public:
property double LLY {
   double get();
}

Property Value

The lower-left y coordinate of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


UR Property

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : UR Property
Gets the position of upper-right corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UR As PdfPoint
'Usage

Dim instance As PdfStandardRectangle
Dim value As PdfPoint

instance.UR = value

value = instance.UR
public PdfPoint UR {get; set;}
public:
property PdfPoint^ UR {
   PdfPoint^ get();
   void set (    PdfPoint^ value);
}

Property Value

The position of upper-right corner of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


URX Property (PdfStandardRectangle)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : URX Property
Gets the upper-right x coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property URX As Double
'Usage

Dim instance As PdfStandardRectangle
Dim value As Double

value = instance.URX
public double URX {get;}
public:
property double URX {
   double get();
}

Property Value

The upper-right x coordinate of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


URY Property (PdfStandardRectangle)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : URY Property
Gets the upper-right y coordinate.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property URY As Double
'Usage

Dim instance As PdfStandardRectangle
Dim value As Double

value = instance.URY
public double URY {get;}
public:
property double URY {
   double get();
}

Property Value

The upper-right y coordinate of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


Width Property (PdfStandardRectangle)

Xfinium.Pdf.Graphics Namespace > PdfStandardRectangle Class : Width Property
Gets or sets the rectangle width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PdfStandardRectangle
Dim value As Double

value = instance.Width
public double Width {get;}
public:
property double Width {
   double get();
}

Property Value

The width of the rectangle.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStandardRectangle Class
PdfStandardRectangle Members


%%PageItemTitle%%

PdfStencilMask Class
Members

Xfinium.Pdf.Graphics Namespace : PdfStencilMask Class
Defines a stencil mask.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfStencilMask
   Inherits PdfImageMask
'Usage

Dim instance As PdfStencilMask
public class PdfStencilMask : PdfImageMask
public ref class PdfStencilMask : public PdfImageMask
Remarks
A stencil mask uses a monochrome bitmap for specifying the image area that will be painted on the page.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImageMask
Xfinium.Pdf.Graphics.PdfStencilMask
Xfinium.Pdf.Graphics.PdfSoftMask

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStencilMask Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfStencilMask Class Members

Xfinium.Pdf.Graphics Namespace : PdfStencilMask Class

The following tables list the members exposed by PdfStencilMask.

Public Constructors
 | Name | Description
Public Constructor | PdfStencilMask Constructor | Initializes a new PdfStencilMask object from a monochrome image.
Top
See Also

Reference

PdfStencilMask Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStencilMask Constructor

Xfinium.Pdf.Graphics Namespace > PdfStencilMask Class : PdfStencilMask Constructor
Monochrome image used as stencil mask.
Initializes a new PdfStencilMask object from a monochrome image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal sourceImage As PdfImage _
)
'Usage

Dim sourceImage As PdfImage

Dim instance As New PdfStencilMask(sourceImage)
public PdfStencilMask(
   PdfImage sourceImage
)
public:
PdfStencilMask(
   PdfImage^ sourceImage
)

Parameters

sourceImage
Monochrome image used as stencil mask.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStencilMask Class
PdfStencilMask Members


%%PageItemTitle%%

PdfStringAppearanceOptions Class
Members

Xfinium.Pdf.Graphics Namespace : PdfStringAppearanceOptions Class
Defines various appearance options for displaying text on page graphics.
Object Model
PdfStringAppearanceOptions ClassPdfBrush ClassPdfFont ClassPdfPen Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfStringAppearanceOptions
'Usage

Dim instance As PdfStringAppearanceOptions
public class PdfStringAppearanceOptions
public ref class PdfStringAppearanceOptions
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfStringAppearanceOptions

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringAppearanceOptions Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfStringAppearanceOptions Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfStringAppearanceOptions Class

The following tables list the members exposed by PdfStringAppearanceOptions.

Public Constructors
 | Name | Description
Public Constructor | PdfStringAppearanceOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Brush | Gets or sets the text brush.
Public Property | Font | Gets or sets the text font.
Public Property | Pen | Gets or sets the text pen.
Top
See Also

Reference

PdfStringAppearanceOptions Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStringAppearanceOptions Constructor

Xfinium.Pdf.Graphics Namespace > PdfStringAppearanceOptions Class : PdfStringAppearanceOptions Constructor
Overload List
Overload | Description
PdfStringAppearanceOptions Constructor() | Initializes a new PdfStringAppearanceOptions object.
PdfStringAppearanceOptions Constructor(PdfFont,PdfPen,PdfBrush) | Initializes a new PdfStringAppearanceOptions object with the specified pen and brush.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringAppearanceOptions Class
PdfStringAppearanceOptions Members


%%PageItemTitle%%

PdfStringAppearanceOptions Constructor()

Xfinium.Pdf.Graphics Namespace > PdfStringAppearanceOptions Class > PdfStringAppearanceOptions Constructor : PdfStringAppearanceOptions Constructor()
Initializes a new PdfStringAppearanceOptions object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfStringAppearanceOptions()
public PdfStringAppearanceOptions()
public:
PdfStringAppearanceOptions();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringAppearanceOptions Class
PdfStringAppearanceOptions Members
Overload List


%%PageItemTitle%%

PdfStringAppearanceOptions Constructor(PdfFont,PdfPen,PdfBrush)

Xfinium.Pdf.Graphics Namespace > PdfStringAppearanceOptions Class > PdfStringAppearanceOptions Constructor : PdfStringAppearanceOptions Constructor(PdfFont,PdfPen,PdfBrush)
Font for drawing text.
Pen for drawing text.
Brush for drawing text.
Initializes a new PdfStringAppearanceOptions object with the specified pen and brush.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PdfFont, _
   ByVal pen As PdfPen, _
   ByVal brush As PdfBrush _
)
'Usage

Dim font As PdfFont
Dim pen As PdfPen
Dim brush As PdfBrush

Dim instance As New PdfStringAppearanceOptions(font, pen, brush)
public PdfStringAppearanceOptions(
   PdfFont font,
   PdfPen pen,
   PdfBrush brush
)
public:
PdfStringAppearanceOptions(
   PdfFont^ font,
   PdfPen^ pen,
   PdfBrush^ brush
)

Parameters

font
Font for drawing text.
pen
Pen for drawing text.
brush
Brush for drawing text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringAppearanceOptions Class
PdfStringAppearanceOptions Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfStringAppearanceOptions Class Properties

Xfinium.Pdf.Graphics Namespace : PdfStringAppearanceOptions Class

For a list of all members of this type, see PdfStringAppearanceOptions members.

Public Properties
 | Name | Description
Public Property | Brush | Gets or sets the text brush.
Public Property | Font | Gets or sets the text font.
Public Property | Pen | Gets or sets the text pen.
Top
See Also

Reference

PdfStringAppearanceOptions Class
Xfinium.Pdf.Graphics Namespace


Brush Property (PdfStringAppearanceOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringAppearanceOptions Class : Brush Property
Gets or sets the text brush.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Brush As PdfBrush
'Usage

Dim instance As PdfStringAppearanceOptions
Dim value As PdfBrush

instance.Brush = value

value = instance.Brush
public PdfBrush Brush {get; set;}
public:
property PdfBrush^ Brush {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

The brush for filling the text outline.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringAppearanceOptions Class
PdfStringAppearanceOptions Members


Font Property (PdfStringAppearanceOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringAppearanceOptions Class : Font Property
Gets or sets the text font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As PdfFont
'Usage

Dim instance As PdfStringAppearanceOptions
Dim value As PdfFont

instance.Font = value

value = instance.Font
public PdfFont Font {get; set;}
public:
property PdfFont^ Font {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

The font used for drawing text.
Remarks
If the font is null, no text is drawn.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringAppearanceOptions Class
PdfStringAppearanceOptions Members


Pen Property (PdfStringAppearanceOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringAppearanceOptions Class : Pen Property
Gets or sets the text pen.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Pen As PdfPen
'Usage

Dim instance As PdfStringAppearanceOptions
Dim value As PdfPen

instance.Pen = value

value = instance.Pen
public PdfPen Pen {get; set;}
public:
property PdfPen^ Pen {
   PdfPen^ get();
   void set (    PdfPen^ value);
}

Property Value

A pen used for stroking the text outline.
Remarks
Stroking the text outline when a small font size is used results in a bolder text appearance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringAppearanceOptions Class
PdfStringAppearanceOptions Members


%%PageItemTitle%%

PdfStringLayoutOptions Class
Members

Xfinium.Pdf.Graphics Namespace : PdfStringLayoutOptions Class
Defines various layout options for displaying text on page graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfStringLayoutOptions
'Usage

Dim instance As PdfStringLayoutOptions
public class PdfStringLayoutOptions
public ref class PdfStringLayoutOptions
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfStringLayoutOptions

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfStringLayoutOptions Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfStringLayoutOptions Class

The following tables list the members exposed by PdfStringLayoutOptions.

Public Constructors
 | Name | Description
Public Constructor | PdfStringLayoutOptions Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height of rectangle that defines the text location.
Public Property | HorizontalAlign | Gets or sets the horizontal alignment of text.
Public Property | LineSpacingAdjustment | Gets or sets the line spacing adjustment.
Public Property | Rotation | Gets or sets the rotation angle of the text.
Public Property | VerticalAlign | Gets or sets the vertical alignment of text.
Public Property | Width | Gets or sets the width of rectangle that defines the text location.
Public Property | X | Gets or sets the X coordinate of the text anchor point.
Public Property | Y | Gets or sets the Y coordinate of the text anchor point.
Top
See Also

Reference

PdfStringLayoutOptions Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStringLayoutOptions Constructor

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : PdfStringLayoutOptions Constructor
Overload List
Overload | Description
PdfStringLayoutOptions Constructor() | Initializes a new PdfStringLayoutOptions object.
PdfStringLayoutOptions Constructor(PdfStringLayoutOptions) | Initializes a new PdfStringLayoutOptions object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


%%PageItemTitle%%

PdfStringLayoutOptions Constructor()

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class > PdfStringLayoutOptions Constructor : PdfStringLayoutOptions Constructor()
Initializes a new PdfStringLayoutOptions object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfStringLayoutOptions()
public PdfStringLayoutOptions()
public:
PdfStringLayoutOptions();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members
Overload List


%%PageItemTitle%%

PdfStringLayoutOptions Constructor(PdfStringLayoutOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class > PdfStringLayoutOptions Constructor : PdfStringLayoutOptions Constructor(PdfStringLayoutOptions)
Source layout options for initializing this object.
Initializes a new PdfStringLayoutOptions object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfStringLayoutOptions _
)
'Usage

Dim source As PdfStringLayoutOptions

Dim instance As New PdfStringLayoutOptions(source)
public PdfStringLayoutOptions(
   PdfStringLayoutOptions source
)
public:
PdfStringLayoutOptions(
   PdfStringLayoutOptions^ source
)

Parameters

source
Source layout options for initializing this object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfStringLayoutOptions Class Properties

Xfinium.Pdf.Graphics Namespace : PdfStringLayoutOptions Class

For a list of all members of this type, see PdfStringLayoutOptions members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height of rectangle that defines the text location.
Public Property | HorizontalAlign | Gets or sets the horizontal alignment of text.
Public Property | LineSpacingAdjustment | Gets or sets the line spacing adjustment.
Public Property | Rotation | Gets or sets the rotation angle of the text.
Public Property | VerticalAlign | Gets or sets the vertical alignment of text.
Public Property | Width | Gets or sets the width of rectangle that defines the text location.
Public Property | X | Gets or sets the X coordinate of the text anchor point.
Public Property | Y | Gets or sets the Y coordinate of the text anchor point.
Top
See Also

Reference

PdfStringLayoutOptions Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfStringLayoutOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : Height Property
Gets or sets the height of rectangle that defines the text location.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PdfStringLayoutOptions
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The height of text rectangle.
Remarks
The text is cut when its height is greater than this height. If this property is 0 or negative, its value is ignored and the text overflows.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


HorizontalAlign Property (PdfStringLayoutOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : HorizontalAlign Property
Gets or sets the horizontal alignment of text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalAlign As PdfStringHorizontalAlign
'Usage

Dim instance As PdfStringLayoutOptions
Dim value As PdfStringHorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
public PdfStringHorizontalAlign HorizontalAlign {get; set;}
public:
property PdfStringHorizontalAlign HorizontalAlign {
   PdfStringHorizontalAlign get();
   void set (    PdfStringHorizontalAlign value);
}

Property Value

Text horizontal alignment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


LineSpacingAdjustment Property

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : LineSpacingAdjustment Property
Gets or sets the line spacing adjustment.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineSpacingAdjustment As Double
'Usage

Dim instance As PdfStringLayoutOptions
Dim value As Double

instance.LineSpacingAdjustment = value

value = instance.LineSpacingAdjustment
public double LineSpacingAdjustment {get; set;}
public:
property double LineSpacingAdjustment {
   double get();
   void set (    double value);
}

Property Value

Adjustment of the default line spacing.
Remarks
This property is added to default line spacing in order to increase or decrease the spacing between lines of text in a text box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


Rotation Property (PdfStringLayoutOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : Rotation Property
Gets or sets the rotation angle of the text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Rotation As Double
'Usage

Dim instance As PdfStringLayoutOptions
Dim value As Double

instance.Rotation = value

value = instance.Rotation
public double Rotation {get; set;}
public:
property double Rotation {
   double get();
   void set (    double value);
}

Property Value

Text rotation angle in degrees.
Remarks
The text is rotated counterclockwise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


VerticalAlign Property (PdfStringLayoutOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : VerticalAlign Property
Gets or sets the vertical alignment of text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VerticalAlign As PdfStringVerticalAlign
'Usage

Dim instance As PdfStringLayoutOptions
Dim value As PdfStringVerticalAlign

instance.VerticalAlign = value

value = instance.VerticalAlign
public PdfStringVerticalAlign VerticalAlign {get; set;}
public:
property PdfStringVerticalAlign VerticalAlign {
   PdfStringVerticalAlign get();
   void set (    PdfStringVerticalAlign value);
}

Property Value

Vertical text alignment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


Width Property (PdfStringLayoutOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : Width Property
Gets or sets the width of rectangle that defines the text location.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PdfStringLayoutOptions
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The width of text rectangle.
Remarks
The text is automatically wrapped when the text width is greater than this width. If this property is 0 or negative, its value is ignored and the text is not wrapped.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


X Property (PdfStringLayoutOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : X Property
Gets or sets the X coordinate of the text anchor point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X As Double
'Usage

Dim instance As PdfStringLayoutOptions
Dim value As Double

instance.X = value

value = instance.X
public double X {get; set;}
public:
property double X {
   double get();
   void set (    double value);
}

Property Value

X coordinate of text anchor point.
Remarks
The anchor point depends on the horizontal text alignment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


Y Property (PdfStringLayoutOptions)

Xfinium.Pdf.Graphics Namespace > PdfStringLayoutOptions Class : Y Property
Gets or sets the Y coordinate of the text anchor point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PdfStringLayoutOptions
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

Y coordinate of text anchor point.
Remarks
The anchor point depends on the vertical text alignment.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStringLayoutOptions Class
PdfStringLayoutOptions Members


%%PageItemTitle%%

PdfTiffImage Class
Members

Xfinium.Pdf.Graphics Namespace : PdfTiffImage Class
Defines a TIFF image.
Object Model
PdfTiffImage ClassPdfAlternateImageCollection ClassPdfAlternateImage ClassPdfColorSpace ClassPdfCosDictionary ClassPdfImageMask ClassPdfMeasure ClassPdfPointData Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTiffImage
   Inherits PdfImage
'Usage

Dim instance As PdfTiffImage
public class PdfTiffImage : PdfImage
public ref class PdfTiffImage : public PdfImage
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImage
Xfinium.Pdf.Graphics.PdfTiffImage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTiffImage Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfTiffImage Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfTiffImage Class

The following tables list the members exposed by PdfTiffImage.

Public Constructors
 | Name | Description
Public Constructor | PdfTiffImage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ActiveFrame | Gets or sets the active frame.
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | FrameCount | Gets the image frame count.
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfTiffImage Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfTiffImage Constructor

Xfinium.Pdf.Graphics Namespace > PdfTiffImage Class : PdfTiffImage Constructor
Overload List
Overload | Description
PdfTiffImage Constructor(Stream) | Initializes a new PdfTiffImage object.
PdfTiffImage Constructor(Stream,Int32) | Initializes a new PdfTiffImage object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTiffImage Class
PdfTiffImage Members


%%PageItemTitle%%

PdfTiffImage Constructor(Stream)

Xfinium.Pdf.Graphics Namespace > PdfTiffImage Class > PdfTiffImage Constructor : PdfTiffImage Constructor(Stream)
TIFF stream.
Initializes a new PdfTiffImage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfTiffImage(stream)
public PdfTiffImage(
   Stream stream
)
public:
PdfTiffImage(
   Stream^ stream
)

Parameters

stream
TIFF stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTiffImage Class
PdfTiffImage Members
Overload List


%%PageItemTitle%%

PdfTiffImage Constructor(Stream,Int32)

Xfinium.Pdf.Graphics Namespace > PdfTiffImage Class > PdfTiffImage Constructor : PdfTiffImage Constructor(Stream,Int32)
TIFF stream.
TIFF frame to use for creating the image.
Initializes a new PdfTiffImage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal frameIndex As Integer _
)
'Usage

Dim stream As Stream
Dim frameIndex As Integer

Dim instance As New PdfTiffImage(stream, frameIndex)
public PdfTiffImage(
   Stream stream,
   int frameIndex
)
public:
PdfTiffImage(
   Stream^ stream,
   int frameIndex
)

Parameters

stream
TIFF stream.
frameIndex
TIFF frame to use for creating the image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTiffImage Class
PdfTiffImage Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfTiffImage Class Properties

Xfinium.Pdf.Graphics Namespace : PdfTiffImage Class

For a list of all members of this type, see PdfTiffImage members.

Public Properties
 | Name | Description
Public Property | ActiveFrame | Gets or sets the active frame.
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | FrameCount | Gets the image frame count.
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfTiffImage Class
Xfinium.Pdf.Graphics Namespace


ActiveFrame Property

Xfinium.Pdf.Graphics Namespace > PdfTiffImage Class : ActiveFrame Property
Gets or sets the active frame.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ActiveFrame As Integer
'Usage

Dim instance As PdfTiffImage
Dim value As Integer

instance.ActiveFrame = value

value = instance.ActiveFrame
public int ActiveFrame {get; set;}
public:
property int ActiveFrame {
   int get();
   void set (    int value);
}

Property Value

The active frame in the image that will be drawn on the PDF page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTiffImage Class
PdfTiffImage Members


FrameCount Property

Xfinium.Pdf.Graphics Namespace > PdfTiffImage Class : FrameCount Property
Gets the image frame count.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FrameCount As Integer
'Usage

Dim instance As PdfTiffImage
Dim value As Integer

value = instance.FrameCount
public int FrameCount {get;}
public:
property int FrameCount {
   int get();
}

Property Value

The number of frames in this TIFF image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTiffImage Class
PdfTiffImage Members


Height Property (PdfTiffImage)

Xfinium.Pdf.Graphics Namespace > PdfTiffImage Class : Height Property
Gets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PdfTiffImage
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The image height in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTiffImage Class
PdfTiffImage Members


Width Property (PdfTiffImage)

Xfinium.Pdf.Graphics Namespace > PdfTiffImage Class : Width Property
Gets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PdfTiffImage
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The image width in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTiffImage Class
PdfTiffImage Members


%%PageItemTitle%%

PdfTilingPattern Class
Members

Xfinium.Pdf.Graphics Namespace : PdfTilingPattern Class
Defines the base class for all tiling patterns.
Object Model
PdfTilingPattern ClassPdfGraphics ClassPdfMatrix Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfTilingPattern
   Inherits PdfPattern
'Usage

Dim instance As PdfTilingPattern
public abstract class PdfTilingPattern : PdfPattern
public ref class PdfTilingPattern abstract : public PdfPattern
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPattern
Xfinium.Pdf.Graphics.PdfTilingPattern
Xfinium.Pdf.Graphics.PdfColoredTilingPattern
Xfinium.Pdf.Graphics.PdfUncoloredTilingPattern

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTilingPattern Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfTilingPattern Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfTilingPattern Class

The following tables list the members exposed by PdfTilingPattern.

Public Properties
 | Name | Description
Public Property | Graphics | Gets the pattern graphics.
Public Property | Height | Gets the pattern height.
Public Property | Matrix | Gets or sets the pattern matrix.
Public Property | Width | Gets the pattern width.
Public Property | XStep | Gets the x step.
Public Property | YStep | Gets the y step.
Top
See Also

Reference

PdfTilingPattern Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfTilingPattern Class Properties

Xfinium.Pdf.Graphics Namespace : PdfTilingPattern Class

For a list of all members of this type, see PdfTilingPattern members.

Public Properties
 | Name | Description
Public Property | Graphics | Gets the pattern graphics.
Public Property | Height | Gets the pattern height.
Public Property | Matrix | Gets or sets the pattern matrix.
Public Property | Width | Gets the pattern width.
Public Property | XStep | Gets the x step.
Public Property | YStep | Gets the y step.
Top
See Also

Reference

PdfTilingPattern Class
Xfinium.Pdf.Graphics Namespace


Graphics Property (PdfTilingPattern)

Xfinium.Pdf.Graphics Namespace > PdfTilingPattern Class : Graphics Property
Gets the pattern graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Graphics As PdfGraphics
'Usage

Dim instance As PdfTilingPattern
Dim value As PdfGraphics

value = instance.Graphics
public PdfGraphics Graphics {get;}
public:
property PdfGraphics^ Graphics {
   PdfGraphics^ get();
}

Property Value

The pattern graphics surface used to create the pattern content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTilingPattern Class
PdfTilingPattern Members


Height Property (PdfTilingPattern)

Xfinium.Pdf.Graphics Namespace > PdfTilingPattern Class : Height Property
Gets the pattern height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PdfTilingPattern
Dim value As Double

value = instance.Height
public double Height {get;}
public:
property double Height {
   double get();
}

Property Value

The height of a pattern cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTilingPattern Class
PdfTilingPattern Members


Matrix Property (PdfTilingPattern)

Xfinium.Pdf.Graphics Namespace > PdfTilingPattern Class : Matrix Property
Gets or sets the pattern matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Matrix As PdfMatrix
'Usage

Dim instance As PdfTilingPattern
Dim value As PdfMatrix

instance.Matrix = value

value = instance.Matrix
public PdfMatrix Matrix {get; set;}
public:
property PdfMatrix^ Matrix {
   PdfMatrix^ get();
   void set (    PdfMatrix^ value);
}

Property Value

The pattern matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTilingPattern Class
PdfTilingPattern Members


Width Property (PdfTilingPattern)

Xfinium.Pdf.Graphics Namespace > PdfTilingPattern Class : Width Property
Gets the pattern width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As PdfTilingPattern
Dim value As Double

value = instance.Width
public double Width {get;}
public:
property double Width {
   double get();
}

Property Value

The width of a pattern cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTilingPattern Class
PdfTilingPattern Members


XStep Property

Xfinium.Pdf.Graphics Namespace > PdfTilingPattern Class : XStep Property
Gets the x step.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property XStep As Double
'Usage

Dim instance As PdfTilingPattern
Dim value As Double

instance.XStep = value

value = instance.XStep
public double XStep {get; set;}
public:
property double XStep {
   double get();
   void set (    double value);
}

Property Value

The desired horizontal spacing between pattern cells.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTilingPattern Class
PdfTilingPattern Members


YStep Property

Xfinium.Pdf.Graphics Namespace > PdfTilingPattern Class : YStep Property
Gets the y step.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property YStep As Double
'Usage

Dim instance As PdfTilingPattern
Dim value As Double

instance.YStep = value

value = instance.YStep
public double YStep {get; set;}
public:
property double YStep {
   double get();
   void set (    double value);
}

Property Value

The desired vertical spacing between pattern cells.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTilingPattern Class
PdfTilingPattern Members


%%PageItemTitle%%

PdfTransparencyGroup Class
Members

Xfinium.Pdf.Graphics Namespace : PdfTransparencyGroup Class
Defines a transparency group.
Object Model
PdfTransparencyGroup ClassPdfColorSpace Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTransparencyGroup
   Inherits PdfGroupXObject
'Usage

Dim instance As PdfTransparencyGroup
public class PdfTransparencyGroup : PdfGroupXObject
public ref class PdfTransparencyGroup : public PdfGroupXObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfGroupXObject
Xfinium.Pdf.Graphics.PdfTransparencyGroup

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTransparencyGroup Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfTransparencyGroup Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfTransparencyGroup Class

The following tables list the members exposed by PdfTransparencyGroup.

Public Constructors
 | Name | Description
Public Constructor | PdfTransparencyGroup Constructor | Initializes a new PdfTransparencyGroup object.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the colorspace.
Public Property | Isolated | Gets or sets a flag indicating whether the group is isolated.
Public Property | Knockout | Gets or sets a flag indicating whether the group is knockout.
Top
See Also

Reference

PdfTransparencyGroup Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfTransparencyGroup Constructor

Xfinium.Pdf.Graphics Namespace > PdfTransparencyGroup Class : PdfTransparencyGroup Constructor
Initializes a new PdfTransparencyGroup object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfTransparencyGroup()
public PdfTransparencyGroup()
public:
PdfTransparencyGroup();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTransparencyGroup Class
PdfTransparencyGroup Members


%%PageItemTitle%% $$Properties$$

PdfTransparencyGroup Class Properties

Xfinium.Pdf.Graphics Namespace : PdfTransparencyGroup Class

For a list of all members of this type, see PdfTransparencyGroup members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the colorspace.
Public Property | Isolated | Gets or sets a flag indicating whether the group is isolated.
Public Property | Knockout | Gets or sets a flag indicating whether the group is knockout.
Top
See Also

Reference

PdfTransparencyGroup Class
Xfinium.Pdf.Graphics Namespace


ColorSpace Property (PdfTransparencyGroup)

Xfinium.Pdf.Graphics Namespace > PdfTransparencyGroup Class : ColorSpace Property
Gets or sets the colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorSpace As PdfColorSpace
'Usage

Dim instance As PdfTransparencyGroup
Dim value As PdfColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PdfColorSpace ColorSpace {get; set;}
public:
property PdfColorSpace^ ColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

The group color space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTransparencyGroup Class
PdfTransparencyGroup Members


Isolated Property

Xfinium.Pdf.Graphics Namespace > PdfTransparencyGroup Class : Isolated Property
Gets or sets a flag indicating whether the group is isolated.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Isolated As Boolean
'Usage

Dim instance As PdfTransparencyGroup
Dim value As Boolean

instance.Isolated = value

value = instance.Isolated
public bool Isolated {get; set;}
public:
property bool Isolated {
   bool get();
   void set (    bool value);
}

Property Value

If this flag is true, objects within the group are composited against a fully transparent initial backdrop; if false, they are composited against the group's backdrop.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTransparencyGroup Class
PdfTransparencyGroup Members


Knockout Property

Xfinium.Pdf.Graphics Namespace > PdfTransparencyGroup Class : Knockout Property
Gets or sets a flag indicating whether the group is knockout.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Knockout As Boolean
'Usage

Dim instance As PdfTransparencyGroup
Dim value As Boolean

instance.Knockout = value

value = instance.Knockout
public bool Knockout {get; set;}
public:
property bool Knockout {
   bool get();
   void set (    bool value);
}

Property Value

If this flag is false, later objects within the group are composited with earlier ones with which they overlap; if true, they are composited with the group's initial backdrop and overwrite ("knock out") any earlier overlapping objects.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTransparencyGroup Class
PdfTransparencyGroup Members


%%PageItemTitle%%

PdfTrueTypeFont Class
Members

Xfinium.Pdf.Graphics Namespace : PdfTrueTypeFont Class
Defines the base class for TrueType fonts.
Object Model
PdfTrueTypeFont ClassPdfFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTrueTypeFont
   Inherits PdfFont
'Usage

Dim instance As PdfTrueTypeFont
public class PdfTrueTypeFont : PdfFont
public ref class PdfTrueTypeFont : public PdfFont
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFont
Xfinium.Pdf.Graphics.PdfTrueTypeFont
Xfinium.Pdf.Graphics.PdfAnsiTrueTypeFont
Xfinium.Pdf.Graphics.PdfUnicodeTrueTypeFont

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTrueTypeFont Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfTrueTypeFont Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfTrueTypeFont Class

The following tables list the members exposed by PdfTrueTypeFont.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Name | Gets the name of this font.
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
Public Methods
 | Name | Description
Public Method | EncodeString | Overridden. Encodes the given text to a byte array based on font's encoding.
Public Method | GetGlyphEmWidth | Gets the Em width of the given glyph when drawn with this font object.
Public Method | UpdateCharsSubset | Updates the set of characters that must be subset in the final font data.
Public Method | UpdateGlyphsSubset | Updates the set of glyphs that must be subset in the final font data.
Top
See Also

Reference

PdfTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfTrueTypeFont Class Methods

Xfinium.Pdf.Graphics Namespace : PdfTrueTypeFont Class

For a list of all members of this type, see PdfTrueTypeFont members.

Public Methods
 | Name | Description
Public Method | EncodeString | Overridden. Encodes the given text to a byte array based on font's encoding.
Public Method | GetGlyphEmWidth | Gets the Em width of the given glyph when drawn with this font object.
Public Method | UpdateCharsSubset | Updates the set of characters that must be subset in the final font data.
Public Method | UpdateGlyphsSubset | Updates the set of glyphs that must be subset in the final font data.
Top
See Also

Reference

PdfTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


EncodeString Method (PdfTrueTypeFont)

Xfinium.Pdf.Graphics Namespace > PdfTrueTypeFont Class : EncodeString Method
String to convert.
Encodes the given text to a byte array based on font's encoding.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function EncodeString( _
   ByVal text As String _
) As Byte()
'Usage

Dim instance As PdfTrueTypeFont
Dim text As String
Dim value() As Byte

value = instance.EncodeString(text)
public override byte[] EncodeString(
   string text
)
public:
array<byte>^ EncodeString(
   String^ text
) override

Parameters

text
String to convert.

Return Value

An array of bytes representing the string according to font encoding.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTrueTypeFont Class
PdfTrueTypeFont Members


GetGlyphEmWidth Method

Xfinium.Pdf.Graphics Namespace > PdfTrueTypeFont Class : GetGlyphEmWidth Method
the index of the glyph to get its width
Gets the Em width of the given glyph when drawn with this font object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetGlyphEmWidth( _
   ByVal glyph As Integer _
) As Integer
'Usage

Dim instance As PdfTrueTypeFont
Dim glyph As Integer
Dim value As Integer

value = instance.GetGlyphEmWidth(glyph)
public int GetGlyphEmWidth(
   int glyph
)
public:
int GetGlyphEmWidth(
   int glyph
)

Parameters

glyph
the index of the glyph to get its width

Return Value

The width of the glyph in Em units.
Remarks
To scale this value to font's current size, divide it by 2048 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetGlyphEmWidth(glyph) / 2048.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTrueTypeFont Class
PdfTrueTypeFont Members


UpdateCharsSubset Method

Xfinium.Pdf.Graphics Namespace > PdfTrueTypeFont Class : UpdateCharsSubset Method
Array of characters to be included in the subset.
Updates the set of characters that must be subset in the final font data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub UpdateCharsSubset( _
   ByVal chars() As Char _
)
'Usage

Dim instance As PdfTrueTypeFont
Dim chars() As Char

instance.UpdateCharsSubset(chars)
public void UpdateCharsSubset(
   char[] chars
)
public:
void UpdateCharsSubset(
   array<char>^ chars
)

Parameters

chars
Array of characters to be included in the subset.
Remarks
This method is called automatically when using the DrawString methods in the PdfGraphics class but when the low level methods in PdfContentStream class are used then the characters to be subset must be added manually.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTrueTypeFont Class
PdfTrueTypeFont Members


UpdateGlyphsSubset Method

Xfinium.Pdf.Graphics Namespace > PdfTrueTypeFont Class : UpdateGlyphsSubset Method
Array of glyph indexes to be included in the subset.
Updates the set of glyphs that must be subset in the final font data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub UpdateGlyphsSubset( _
   ByVal glyphs() As Integer _
)
'Usage

Dim instance As PdfTrueTypeFont
Dim glyphs() As Integer

instance.UpdateGlyphsSubset(glyphs)
public void UpdateGlyphsSubset(
   int[] glyphs
)
public:
void UpdateGlyphsSubset(
   array<int>^ glyphs
)

Parameters

glyphs
Array of glyph indexes to be included in the subset.
Remarks
This method is called automatically when using the DrawString methods in the PdfGraphics class but when the low level methods in PdfContentStream class are used then the glyphs to be subset must be added manually.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTrueTypeFont Class
PdfTrueTypeFont Members


%%PageItemTitle%% $$Properties$$

PdfTrueTypeFont Class Properties

Xfinium.Pdf.Graphics Namespace : PdfTrueTypeFont Class

For a list of all members of this type, see PdfTrueTypeFont members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Name | Gets the name of this font.
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


Name Property (PdfTrueTypeFont)

Xfinium.Pdf.Graphics Namespace > PdfTrueTypeFont Class : Name Property
Gets the name of this font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As PdfTrueTypeFont
Dim value As String

value = instance.Name
public string Name {get;}
public:
property String^ Name {
   String^ get();
}

Property Value

The name of the font as it appears in the font file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTrueTypeFont Class
PdfTrueTypeFont Members


%%PageItemTitle%%

PdfType1Font Class
Members

Xfinium.Pdf.Graphics Namespace : PdfType1Font Class
Defines a Type1 PDF font.
Object Model
PdfType1Font ClassPdfFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfType1Font
   Inherits PdfFont
'Usage

Dim instance As PdfType1Font
public class PdfType1Font : PdfFont
public ref class PdfType1Font : public PdfFont
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFont
Xfinium.Pdf.Graphics.PdfType1Font

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType1Font Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfType1Font Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfType1Font Class

The following tables list the members exposed by PdfType1Font.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateWithAfmMetrics | Creates a Type1 font from a combination of .afm and .pfb files.
static (Shared in Visual Basic) | CreateWithPfmMetrics | Creates a Type1 font from a combination of .pfm and .pfb files.
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfType1Font Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfType1Font Class Methods

Xfinium.Pdf.Graphics Namespace : PdfType1Font Class

For a list of all members of this type, see PdfType1Font members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateWithAfmMetrics | Creates a Type1 font from a combination of .afm and .pfb files.
static (Shared in Visual Basic) | CreateWithPfmMetrics | Creates a Type1 font from a combination of .pfm and .pfb files.
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfType1Font Class
Xfinium.Pdf.Graphics Namespace


CreateWithAfmMetrics Method

Xfinium.Pdf.Graphics Namespace > PdfType1Font Class : CreateWithAfmMetrics Method
afm data stream.
pfb data stream.
Font size.
If true, the font will be embedded in the PDF file.
Creates a Type1 font from a combination of .afm and .pfb files.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function CreateWithAfmMetrics( _
   ByVal metricsStream As Stream, _
   ByVal fontStream As Stream, _
   ByVal size As Double, _
   ByVal embed As Boolean _
) As PdfType1Font
'Usage

Dim metricsStream As Stream
Dim fontStream As Stream
Dim size As Double
Dim embed As Boolean
Dim value As PdfType1Font

value = PdfType1Font.CreateWithAfmMetrics(metricsStream, fontStream, size, embed)
public static PdfType1Font CreateWithAfmMetrics(
   Stream metricsStream,
   Stream fontStream,
   double size,
   bool embed
)
public:
static PdfType1Font^ CreateWithAfmMetrics(
   Stream^ metricsStream,
   Stream^ fontStream,
   double size,
   bool embed
)

Parameters

metricsStream
afm data stream.
fontStream
pfb data stream.
size
Font size.
embed
If true, the font will be embedded in the PDF file.

Return Value

A Type1 font object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType1Font Class
PdfType1Font Members


CreateWithPfmMetrics Method

Xfinium.Pdf.Graphics Namespace > PdfType1Font Class : CreateWithPfmMetrics Method
pfm data stream.
pfb data stream.
Font size.
If true, the font will be embedded in the PDF file.
Creates a Type1 font from a combination of .pfm and .pfb files.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function CreateWithPfmMetrics( _
   ByVal metricsStream As Stream, _
   ByVal fontStream As Stream, _
   ByVal size As Double, _
   ByVal embed As Boolean _
) As PdfType1Font
'Usage

Dim metricsStream As Stream
Dim fontStream As Stream
Dim size As Double
Dim embed As Boolean
Dim value As PdfType1Font

value = PdfType1Font.CreateWithPfmMetrics(metricsStream, fontStream, size, embed)
public static PdfType1Font CreateWithPfmMetrics(
   Stream metricsStream,
   Stream fontStream,
   double size,
   bool embed
)
public:
static PdfType1Font^ CreateWithPfmMetrics(
   Stream^ metricsStream,
   Stream^ fontStream,
   double size,
   bool embed
)

Parameters

metricsStream
pfm data stream.
fontStream
pfb data stream.
size
Font size.
embed
If true, the font will be embedded in the PDF file.

Return Value

A Type1 font object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType1Font Class
PdfType1Font Members


%%PageItemTitle%%

PdfType3Font Class
Members

Xfinium.Pdf.Graphics Namespace : PdfType3Font Class
Defines a Type3 font.
Object Model
PdfType3Font ClassPdfStandardRectangle ClassPdfMatrix ClassPdfType3GlyphCollection ClassPdfType3Glyph ClassPdfFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfType3Font
   Inherits PdfFont
'Usage

Dim instance As PdfType3Font
public class PdfType3Font : PdfFont
public ref class PdfType3Font : public PdfFont
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFont
Xfinium.Pdf.Graphics.PdfType3Font

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfType3Font Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfType3Font Class

The following tables list the members exposed by PdfType3Font.

Public Constructors
 | Name | Description
Public Constructor | PdfType3Font Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | FirstChar | Gets or sets the first char in the font.
Public Property | FontBBox | Gets or sets the font bbox.
Public Property | FontMatrix | Gets or sets the font matrix.
Public Property | Glyphs | Gets the font glyphs.
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | LastChar | Gets or sets the last char in the font.
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Widths | Gets or sets the character widths.
Top
Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfType3Font Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfType3Font Constructor

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class : PdfType3Font Constructor
Overload List
Overload | Description
PdfType3Font Constructor() | Initializes a new PdfType3Font object.
PdfType3Font Constructor(String) | Initializes a new PdfType3Font object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members


%%PageItemTitle%%

PdfType3Font Constructor()

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class > PdfType3Font Constructor : PdfType3Font Constructor()
Initializes a new PdfType3Font object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfType3Font()
public PdfType3Font()
public:
PdfType3Font();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members
Overload List


%%PageItemTitle%%

PdfType3Font Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class > PdfType3Font Constructor : PdfType3Font Constructor(String)
The font name.
Initializes a new PdfType3Font object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfType3Font(name)
public PdfType3Font(
   string name
)
public:
PdfType3Font(
   String^ name
)

Parameters

name
The font name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfType3Font Class Properties

Xfinium.Pdf.Graphics Namespace : PdfType3Font Class

For a list of all members of this type, see PdfType3Font members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | FirstChar | Gets or sets the first char in the font.
Public Property | FontBBox | Gets or sets the font bbox.
Public Property | FontMatrix | Gets or sets the font matrix.
Public Property | Glyphs | Gets the font glyphs.
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | LastChar | Gets or sets the last char in the font.
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Widths | Gets or sets the character widths.
Top
See Also

Reference

PdfType3Font Class
Xfinium.Pdf.Graphics Namespace


FirstChar Property

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class : FirstChar Property
Gets or sets the first char in the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FirstChar As Byte
'Usage

Dim instance As PdfType3Font
Dim value As Byte

instance.FirstChar = value

value = instance.FirstChar
public byte FirstChar {get; set;}
public:
property byte FirstChar {
   byte get();
   void set (    byte value);
}

Property Value

The code of first character available in the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members


FontBBox Property

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class : FontBBox Property
Gets or sets the font bbox.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FontBBox As PdfStandardRectangle
'Usage

Dim instance As PdfType3Font
Dim value As PdfStandardRectangle

instance.FontBBox = value

value = instance.FontBBox
public PdfStandardRectangle FontBBox {get; set;}
public:
property PdfStandardRectangle^ FontBBox {
   PdfStandardRectangle^ get();
   void set (    PdfStandardRectangle^ value);
}

Property Value

The smallest rectangle that encloses all the glyphs in the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members


FontMatrix Property

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class : FontMatrix Property
Gets or sets the font matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FontMatrix As PdfMatrix
'Usage

Dim instance As PdfType3Font
Dim value As PdfMatrix

instance.FontMatrix = value

value = instance.FontMatrix
public PdfMatrix FontMatrix {get; set;}
public:
property PdfMatrix^ FontMatrix {
   PdfMatrix^ get();
   void set (    PdfMatrix^ value);
}

Property Value

The matrix that maps the glyph space to text space.
Remarks
common practice is to define glyphs in terms of a 1000-unit glyph coordinate system, in which case the font matrix is [0.001 0 0 0.001 0 0].
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members


Glyphs Property (PdfType3Font)

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class : Glyphs Property
Gets the font glyphs.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Glyphs As PdfType3GlyphCollection
'Usage

Dim instance As PdfType3Font
Dim value As PdfType3GlyphCollection

value = instance.Glyphs
public PdfType3GlyphCollection Glyphs {get;}
public:
property PdfType3GlyphCollection^ Glyphs {
   PdfType3GlyphCollection^ get();
}

Property Value

The collection of font glyphs.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members


LastChar Property

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class : LastChar Property
Gets or sets the last char in the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LastChar As Byte
'Usage

Dim instance As PdfType3Font
Dim value As Byte

instance.LastChar = value

value = instance.LastChar
public byte LastChar {get; set;}
public:
property byte LastChar {
   byte get();
   void set (    byte value);
}

Property Value

The code of last character available in the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members


Widths Property

Xfinium.Pdf.Graphics Namespace > PdfType3Font Class : Widths Property
Gets or sets the character widths.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Widths As Double()
'Usage

Dim instance As PdfType3Font
Dim value() As Double

instance.Widths = value

value = instance.Widths
public double[] Widths {get; set;}
public:
property array<double>^ Widths {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of values that represent the character widths in glyph space.
Remarks
The number of elements in this array must be equal to LastChar - FirstChar + 1.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Font Class
PdfType3Font Members


%%PageItemTitle%%

PdfType3Glyph Class
Members

Xfinium.Pdf.Graphics Namespace : PdfType3Glyph Class
Defines a Type3 glyph.
Object Model
PdfType3Glyph ClassPdfGraphics ClassPdfSize Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfType3Glyph
   Inherits Xfinium.Pdf.PdfContentStreamContainer
'Usage

Dim instance As PdfType3Glyph
public class PdfType3Glyph : Xfinium.Pdf.PdfContentStreamContainer
public ref class PdfType3Glyph : public Xfinium.Pdf.PdfContentStreamContainer
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfType3Glyph

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Glyph Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfType3Glyph Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfType3Glyph Class

The following tables list the members exposed by PdfType3Glyph.

Public Constructors
 | Name | Description
Public Constructor | PdfType3Glyph Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Graphics | Gets the glyph graphics.
Public Property | Size | Gets the glyph size.
Top
See Also

Reference

PdfType3Glyph Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfType3Glyph Constructor

Xfinium.Pdf.Graphics Namespace > PdfType3Glyph Class : PdfType3Glyph Constructor
Overload List
Overload | Description
PdfType3Glyph Constructor(Byte) | Initializes a new PdfType3Glyph object.
PdfType3Glyph Constructor(Byte,PdfSize) | Initializes a new PdfType3Glyph object.
PdfType3Glyph Constructor(Byte,PdfSize,PdfStandardRectangle) | Initializes a new PdfType3Glyph object.
PdfType3Glyph Constructor(Byte,PdfSize,PdfStandardRectangle,Boolean) | Initializes a new PdfType3Glyph object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Glyph Class
PdfType3Glyph Members


%%PageItemTitle%%

PdfType3Glyph Constructor(Byte)

Xfinium.Pdf.Graphics Namespace > PdfType3Glyph Class > PdfType3Glyph Constructor : PdfType3Glyph Constructor(Byte)
The character code associated with the glyph.
Initializes a new PdfType3Glyph object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal code As Byte _
)
'Usage

Dim code As Byte

Dim instance As New PdfType3Glyph(code)
public PdfType3Glyph(
   byte code
)
public:
PdfType3Glyph(
   byte code
)

Parameters

code
The character code associated with the glyph.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Glyph Class
PdfType3Glyph Members
Overload List


%%PageItemTitle%%

PdfType3Glyph Constructor(Byte,PdfSize)

Xfinium.Pdf.Graphics Namespace > PdfType3Glyph Class > PdfType3Glyph Constructor : PdfType3Glyph Constructor(Byte,PdfSize)
The character code associated with the glyph.
The size of the glyph. The width must match the value specified in the PdfType3Font.Widths array.
Initializes a new PdfType3Glyph object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal code As Byte, _
   ByVal size As PdfSize _
)
'Usage

Dim code As Byte
Dim size As PdfSize

Dim instance As New PdfType3Glyph(code, size)
public PdfType3Glyph(
   byte code,
   PdfSize size
)
public:
PdfType3Glyph(
   byte code,
   PdfSize^ size
)

Parameters

code
The character code associated with the glyph.
size
The size of the glyph. The width must match the value specified in the PdfType3Font.Widths array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Glyph Class
PdfType3Glyph Members
Overload List


%%PageItemTitle%%

PdfType3Glyph Constructor(Byte,PdfSize,PdfStandardRectangle)

Xfinium.Pdf.Graphics Namespace > PdfType3Glyph Class > PdfType3Glyph Constructor : PdfType3Glyph Constructor(Byte,PdfSize,PdfStandardRectangle)
The character code associated with the glyph.
The size of the glyph. The width must match the value specified in the PdfType3Font.Widths array.
The glyph bounding box.
Initializes a new PdfType3Glyph object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal code As Byte, _
   ByVal size As PdfSize, _
   ByVal bbox As PdfStandardRectangle _
)
'Usage

Dim code As Byte
Dim size As PdfSize
Dim bbox As PdfStandardRectangle

Dim instance As New PdfType3Glyph(code, size, bbox)
public PdfType3Glyph(
   byte code,
   PdfSize size,
   PdfStandardRectangle bbox
)
public:
PdfType3Glyph(
   byte code,
   PdfSize^ size,
   PdfStandardRectangle^ bbox
)

Parameters

code
The character code associated with the glyph.
size
The size of the glyph. The width must match the value specified in the PdfType3Font.Widths array.
bbox
The glyph bounding box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Glyph Class
PdfType3Glyph Members
Overload List


%%PageItemTitle%%

PdfType3Glyph Constructor(Byte,PdfSize,PdfStandardRectangle,Boolean)

Xfinium.Pdf.Graphics Namespace > PdfType3Glyph Class > PdfType3Glyph Constructor : PdfType3Glyph Constructor(Byte,PdfSize,PdfStandardRectangle,Boolean)
The character code associated with the glyph.
The size of the glyph. The width must match the value specified in the PdfType3Font.Widths array.
The glyph bounding box.
True if the glyph describes both its shape and its color. If false the glyph specifies only shape.
Initializes a new PdfType3Glyph object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal code As Byte, _
   ByVal size As PdfSize, _
   ByVal bbox As PdfStandardRectangle, _
   ByVal coloredGlyph As Boolean _
)
'Usage

Dim code As Byte
Dim size As PdfSize
Dim bbox As PdfStandardRectangle
Dim coloredGlyph As Boolean

Dim instance As New PdfType3Glyph(code, size, bbox, coloredGlyph)
public PdfType3Glyph(
   byte code,
   PdfSize size,
   PdfStandardRectangle bbox,
   bool coloredGlyph
)
public:
PdfType3Glyph(
   byte code,
   PdfSize^ size,
   PdfStandardRectangle^ bbox,
   bool coloredGlyph
)

Parameters

code
The character code associated with the glyph.
size
The size of the glyph. The width must match the value specified in the PdfType3Font.Widths array.
bbox
The glyph bounding box.
coloredGlyph
True if the glyph describes both its shape and its color. If false the glyph specifies only shape.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Glyph Class
PdfType3Glyph Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfType3Glyph Class Properties

Xfinium.Pdf.Graphics Namespace : PdfType3Glyph Class

For a list of all members of this type, see PdfType3Glyph members.

Public Properties
 | Name | Description
Public Property | Graphics | Gets the glyph graphics.
Public Property | Size | Gets the glyph size.
Top
See Also

Reference

PdfType3Glyph Class
Xfinium.Pdf.Graphics Namespace


Graphics Property (PdfType3Glyph)

Xfinium.Pdf.Graphics Namespace > PdfType3Glyph Class : Graphics Property
Gets the glyph graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Graphics As PdfGraphics
'Usage

Dim instance As PdfType3Glyph
Dim value As PdfGraphics

value = instance.Graphics
public PdfGraphics Graphics {get;}
public:
property PdfGraphics^ Graphics {
   PdfGraphics^ get();
}

Property Value

The glyph graphics surface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Glyph Class
PdfType3Glyph Members


Size Property (PdfType3Glyph)

Xfinium.Pdf.Graphics Namespace > PdfType3Glyph Class : Size Property
Gets the glyph size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Size As PdfSize
'Usage

Dim instance As PdfType3Glyph
Dim value As PdfSize

value = instance.Size
public PdfSize Size {get;}
public:
property PdfSize^ Size {
   PdfSize^ get();
}

Property Value

The size of the glyph in glyph space.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3Glyph Class
PdfType3Glyph Members


%%PageItemTitle%%

PdfType3GlyphCollection Class
Members

Xfinium.Pdf.Graphics Namespace : PdfType3GlyphCollection Class
Defines a collection of PDF functions.
Object Model
PdfType3GlyphCollection ClassPdfType3Glyph Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfType3GlyphCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfType3Glyph)
'Usage

Dim instance As PdfType3GlyphCollection
public class PdfType3GlyphCollection : System.Collections.ObjectModel.Collection<PdfType3Glyph>
public ref class PdfType3GlyphCollection : public System.Collections.ObjectModel.Collection<PdfType3Glyph>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.PdfType3GlyphCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfType3GlyphCollection Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfType3GlyphCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfType3GlyphCollection Class

The following tables list the members exposed by PdfType3GlyphCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Top
See Also

Reference

PdfType3GlyphCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfUncoloredTilingPattern Class
Members

Xfinium.Pdf.Graphics Namespace : PdfUncoloredTilingPattern Class
Defines an uncolored PDF pattern.
Object Model
PdfUncoloredTilingPattern ClassPdfGraphics ClassPdfMatrix Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUncoloredTilingPattern
   Inherits PdfTilingPattern
'Usage

Dim instance As PdfUncoloredTilingPattern
public class PdfUncoloredTilingPattern : PdfTilingPattern
public ref class PdfUncoloredTilingPattern : public PdfTilingPattern
Remarks
An uncolored tiling pattern is one that has no inherent color, the color must be specified separately whenever the pattern is used.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfPattern
Xfinium.Pdf.Graphics.PdfTilingPattern
Xfinium.Pdf.Graphics.PdfUncoloredTilingPattern

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUncoloredTilingPattern Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfUncoloredTilingPattern Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfUncoloredTilingPattern Class

The following tables list the members exposed by PdfUncoloredTilingPattern.

Public Constructors
 | Name | Description
Public Constructor | PdfUncoloredTilingPattern Constructor | Initializes a new PdfUncoloredTilingPattern object.
Top
Public Properties
 | Name | Description
Public Property | Graphics | Gets the pattern graphics. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Height | Gets the pattern height. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Matrix | Gets or sets the pattern matrix. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Width | Gets the pattern width. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | XStep | Gets the x step. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | YStep | Gets the y step. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Top
See Also

Reference

PdfUncoloredTilingPattern Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfUncoloredTilingPattern Constructor

Xfinium.Pdf.Graphics Namespace > PdfUncoloredTilingPattern Class : PdfUncoloredTilingPattern Constructor
The width of the pattern cell.
The height of the pattern cell.
Initializes a new PdfUncoloredTilingPattern object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim width As Double
Dim height As Double

Dim instance As New PdfUncoloredTilingPattern(width, height)
public PdfUncoloredTilingPattern(
   double width,
   double height
)
public:
PdfUncoloredTilingPattern(
   double width,
   double height
)

Parameters

width
The width of the pattern cell.
height
The height of the pattern cell.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUncoloredTilingPattern Class
PdfUncoloredTilingPattern Members


%%PageItemTitle%%

PdfUnicodeTrueTypeFont Class
Members

Xfinium.Pdf.Graphics Namespace : PdfUnicodeTrueTypeFont Class
Defines an Unicode TrueType font.
Object Model
PdfUnicodeTrueTypeFont ClassPdfFontMetrics Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUnicodeTrueTypeFont
   Inherits PdfTrueTypeFont
'Usage

Dim instance As PdfUnicodeTrueTypeFont
public class PdfUnicodeTrueTypeFont : PdfTrueTypeFont
public ref class PdfUnicodeTrueTypeFont : public PdfTrueTypeFont
Remarks
An Unicde TrueType font can display all Unicode characters.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFont
Xfinium.Pdf.Graphics.PdfTrueTypeFont
Xfinium.Pdf.Graphics.PdfUnicodeTrueTypeFont

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUnicodeTrueTypeFont Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfUnicodeTrueTypeFont Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfUnicodeTrueTypeFont Class

The following tables list the members exposed by PdfUnicodeTrueTypeFont.

Public Constructors
 | Name | Description
Public Constructor | PdfUnicodeTrueTypeFont Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | EnableTextCopy | Gets or sets a value indicating whether the font supports text copy/paste operations.
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Name | Gets the name of this font. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | GetGlyphEmWidth | Gets the Em width of the given glyph when drawn with this font object. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | UpdateCharsSubset | Updates the set of characters that must be subset in the final font data. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | UpdateGlyphsSubset | Updates the set of glyphs that must be subset in the final font data. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Top
See Also

Reference

PdfUnicodeTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfUnicodeTrueTypeFont Constructor

Xfinium.Pdf.Graphics Namespace > PdfUnicodeTrueTypeFont Class : PdfUnicodeTrueTypeFont Constructor
Overload List
Overload | Description
PdfUnicodeTrueTypeFont Constructor(Stream,Double,Boolean) | Initializes a new PdfTrueTypeFont object.
PdfUnicodeTrueTypeFont Constructor(Stream,Int32,Double,Boolean) | Initializes a new PdfTrueTypeFont object.
PdfUnicodeTrueTypeFont Constructor(PdfUnicodeTrueTypeFont) | Initializes a new PdfUnicodeTrueTypeFont object.
PdfUnicodeTrueTypeFont Constructor(PdfUnicodeTrueTypeFont,Double) | Initializes a new PdfUnicodeTrueTypeFont object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUnicodeTrueTypeFont Class
PdfUnicodeTrueTypeFont Members


%%PageItemTitle%%

PdfUnicodeTrueTypeFont Constructor(Stream,Double,Boolean)

Xfinium.Pdf.Graphics Namespace > PdfUnicodeTrueTypeFont Class > PdfUnicodeTrueTypeFont Constructor : PdfUnicodeTrueTypeFont Constructor(Stream,Double,Boolean)
TrueType font stream
Font size.
If true, the font will be embedded in the PDF file.
Initializes a new PdfTrueTypeFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim stream As Stream
Dim size As Double
Dim embed As Boolean

Dim instance As New PdfUnicodeTrueTypeFont(stream, size, embed)
public PdfUnicodeTrueTypeFont(
   Stream stream,
   double size,
   bool embed
)
public:
PdfUnicodeTrueTypeFont(
   Stream^ stream,
   double size,
   bool embed
)

Parameters

stream
TrueType font stream
size
Font size.
embed
If true, the font will be embedded in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUnicodeTrueTypeFont Class
PdfUnicodeTrueTypeFont Members
Overload List


%%PageItemTitle%%

PdfUnicodeTrueTypeFont Constructor(Stream,Int32,Double,Boolean)

Xfinium.Pdf.Graphics Namespace > PdfUnicodeTrueTypeFont Class > PdfUnicodeTrueTypeFont Constructor : PdfUnicodeTrueTypeFont Constructor(Stream,Int32,Double,Boolean)
TrueType collection stream.
TrueType font index in the collection.
Font size.
If true, the font will be embedded in the PDF file.
Initializes a new PdfTrueTypeFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal index As Integer, _
   ByVal size As Double, _
   ByVal embed As Boolean _
)
'Usage

Dim stream As Stream
Dim index As Integer
Dim size As Double
Dim embed As Boolean

Dim instance As New PdfUnicodeTrueTypeFont(stream, index, size, embed)
public PdfUnicodeTrueTypeFont(
   Stream stream,
   int index,
   double size,
   bool embed
)
public:
PdfUnicodeTrueTypeFont(
   Stream^ stream,
   int index,
   double size,
   bool embed
)

Parameters

stream
TrueType collection stream.
index
TrueType font index in the collection.
size
Font size.
embed
If true, the font will be embedded in the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUnicodeTrueTypeFont Class
PdfUnicodeTrueTypeFont Members
Overload List


%%PageItemTitle%%

PdfUnicodeTrueTypeFont Constructor(PdfUnicodeTrueTypeFont)

Xfinium.Pdf.Graphics Namespace > PdfUnicodeTrueTypeFont Class > PdfUnicodeTrueTypeFont Constructor : PdfUnicodeTrueTypeFont Constructor(PdfUnicodeTrueTypeFont)
Source TrueType font.
Initializes a new PdfUnicodeTrueTypeFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PdfUnicodeTrueTypeFont _
)
'Usage

Dim font As PdfUnicodeTrueTypeFont

Dim instance As New PdfUnicodeTrueTypeFont(font)
public PdfUnicodeTrueTypeFont(
   PdfUnicodeTrueTypeFont font
)
public:
PdfUnicodeTrueTypeFont(
   PdfUnicodeTrueTypeFont^ font
)

Parameters

font
Source TrueType font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUnicodeTrueTypeFont Class
PdfUnicodeTrueTypeFont Members
Overload List


%%PageItemTitle%%

PdfUnicodeTrueTypeFont Constructor(PdfUnicodeTrueTypeFont,Double)

Xfinium.Pdf.Graphics Namespace > PdfUnicodeTrueTypeFont Class > PdfUnicodeTrueTypeFont Constructor : PdfUnicodeTrueTypeFont Constructor(PdfUnicodeTrueTypeFont,Double)
Source TrueType font.
Size of the new font.
Initializes a new PdfUnicodeTrueTypeFont object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal font As PdfUnicodeTrueTypeFont, _
   ByVal size As Double _
)
'Usage

Dim font As PdfUnicodeTrueTypeFont
Dim size As Double

Dim instance As New PdfUnicodeTrueTypeFont(font, size)
public PdfUnicodeTrueTypeFont(
   PdfUnicodeTrueTypeFont font,
   double size
)
public:
PdfUnicodeTrueTypeFont(
   PdfUnicodeTrueTypeFont^ font,
   double size
)

Parameters

font
Source TrueType font.
size
Size of the new font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUnicodeTrueTypeFont Class
PdfUnicodeTrueTypeFont Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfUnicodeTrueTypeFont Class Properties

Xfinium.Pdf.Graphics Namespace : PdfUnicodeTrueTypeFont Class

For a list of all members of this type, see PdfUnicodeTrueTypeFont members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | EnableTextCopy | Gets or sets a value indicating whether the font supports text copy/paste operations.
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Name | Gets the name of this font. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfUnicodeTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


EnableTextCopy Property

Xfinium.Pdf.Graphics Namespace > PdfUnicodeTrueTypeFont Class : EnableTextCopy Property
Gets or sets a value indicating whether the font supports text copy/paste operations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EnableTextCopy As Boolean
'Usage

Dim instance As PdfUnicodeTrueTypeFont
Dim value As Boolean

instance.EnableTextCopy = value

value = instance.EnableTextCopy
public bool EnableTextCopy {get; set;}
public:
property bool EnableTextCopy {
   bool get();
   void set (    bool value);
}

Property Value

If true the text drawn with the font can be selected, copied and pasted correctly in another applications. If false the copy/paste operations will generate garbage.
Remarks
This property must be set before drawing any text using the font otherwise the results are undefined.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUnicodeTrueTypeFont Class
PdfUnicodeTrueTypeFont Members


%%PageItemTitle%%

PdfUpcaBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfUpcaBarcode Class
Defines an UPC-A barcode.
Object Model
PdfUpcaBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUpcaBarcode
   Inherits PdfEanBarcode
'Usage

Dim instance As PdfUpcaBarcode
public class PdfUpcaBarcode : PdfEanBarcode
public ref class PdfUpcaBarcode : public PdfEanBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 11 digits
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfUpcaBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUpcaBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfUpcaBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfUpcaBarcode Class

The following tables list the members exposed by PdfUpcaBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfUpcaBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUpcaBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfUpcaBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfUpcaBarcode Class : PdfUpcaBarcode Constructor
Overload List
Overload | Description
PdfUpcaBarcode Constructor() | Initializes a new PdfUpcaBarcode object.
PdfUpcaBarcode Constructor(String) | Initializes a new PdfUpcaBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUpcaBarcode Class
PdfUpcaBarcode Members


%%PageItemTitle%%

PdfUpcaBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfUpcaBarcode Class > PdfUpcaBarcode Constructor : PdfUpcaBarcode Constructor()
Initializes a new PdfUpcaBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfUpcaBarcode()
public PdfUpcaBarcode()
public:
PdfUpcaBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUpcaBarcode Class
PdfUpcaBarcode Members
Overload List


%%PageItemTitle%%

PdfUpcaBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfUpcaBarcode Class > PdfUpcaBarcode Constructor : PdfUpcaBarcode Constructor(String)
The barcode data.
Initializes a new PdfUpcaBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfUpcaBarcode(data)
public PdfUpcaBarcode(
   string data
)
public:
PdfUpcaBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUpcaBarcode Class
PdfUpcaBarcode Members
Overload List


%%PageItemTitle%%

PdfUpceBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfUpceBarcode Class
Defines an UPC-E barcode.
Object Model
PdfUpceBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUpceBarcode
   Inherits PdfEanBarcode
'Usage

Dim instance As PdfUpceBarcode
public class PdfUpceBarcode : PdfEanBarcode
public ref class PdfUpceBarcode : public PdfEanBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 7 digits
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfEanBarcode
Xfinium.Pdf.Graphics.PdfUpceBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUpceBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfUpceBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfUpceBarcode Class

The following tables list the members exposed by PdfUpceBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfUpceBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUpceBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfUpceBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfUpceBarcode Class : PdfUpceBarcode Constructor
Overload List
Overload | Description
PdfUpceBarcode Constructor() | Initializes a new PdfUpceBarcode object.
PdfUpceBarcode Constructor(String) | Initializes a new PdfUpceBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUpceBarcode Class
PdfUpceBarcode Members


%%PageItemTitle%%

PdfUpceBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfUpceBarcode Class > PdfUpceBarcode Constructor : PdfUpceBarcode Constructor()
Initializes a new PdfUpceBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfUpceBarcode()
public PdfUpceBarcode()
public:
PdfUpceBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUpceBarcode Class
PdfUpceBarcode Members
Overload List


%%PageItemTitle%%

PdfUpceBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfUpceBarcode Class > PdfUpceBarcode Constructor : PdfUpceBarcode Constructor(String)
The barcode data.
Initializes a new PdfUpceBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfUpceBarcode(data)
public PdfUpceBarcode(
   string data
)
public:
PdfUpceBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUpceBarcode Class
PdfUpceBarcode Members
Overload List


%%PageItemTitle%%

PdfUspsFimBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfUspsFimBarcode Class
Defines an USPS FIM barcode.
Object Model
PdfUspsFimBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUspsFimBarcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfUspsFimBarcode
public class PdfUspsFimBarcode : Pdf1DBarcode
public ref class PdfUspsFimBarcode : public Pdf1DBarcode
Remarks
Supported characters: A, B, C, D
Data length: 1 character
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfUspsFimBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsFimBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfUspsFimBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfUspsFimBarcode Class

The following tables list the members exposed by PdfUspsFimBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfUspsFimBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUspsFimBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfUspsFimBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfUspsFimBarcode Class : PdfUspsFimBarcode Constructor
Overload List
Overload | Description
PdfUspsFimBarcode Constructor() | Initializes a new PdfUspsFimBarcode object.
PdfUspsFimBarcode Constructor(String) | Initializes a new PdfUspsFimBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsFimBarcode Class
PdfUspsFimBarcode Members


%%PageItemTitle%%

PdfUspsFimBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfUspsFimBarcode Class > PdfUspsFimBarcode Constructor : PdfUspsFimBarcode Constructor()
Initializes a new PdfUspsFimBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfUspsFimBarcode()
public PdfUspsFimBarcode()
public:
PdfUspsFimBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsFimBarcode Class
PdfUspsFimBarcode Members
Overload List


%%PageItemTitle%%

PdfUspsFimBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfUspsFimBarcode Class > PdfUspsFimBarcode Constructor : PdfUspsFimBarcode Constructor(String)
The barcode data.
Initializes a new PdfUspsFimBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfUspsFimBarcode(data)
public PdfUspsFimBarcode(
   string data
)
public:
PdfUspsFimBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsFimBarcode Class
PdfUspsFimBarcode Members
Overload List


%%PageItemTitle%%

PdfUspsHorizontalBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfUspsHorizontalBarcode Class
Defines a USPS horizontal barcode.
Object Model
PdfUspsHorizontalBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUspsHorizontalBarcode
   Inherits Pdf1DBarcode
'Usage

Dim instance As PdfUspsHorizontalBarcode
public class PdfUspsHorizontalBarcode : Pdf1DBarcode
public ref class PdfUspsHorizontalBarcode : public Pdf1DBarcode
Remarks
Supported characters: 1.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfUspsHorizontalBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsHorizontalBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfUspsHorizontalBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfUspsHorizontalBarcode Class

The following tables list the members exposed by PdfUspsHorizontalBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfUspsHorizontalBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUspsHorizontalBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfUspsHorizontalBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfUspsHorizontalBarcode Class : PdfUspsHorizontalBarcode Constructor
Overload List
Overload | Description
PdfUspsHorizontalBarcode Constructor() | Initializes a new PdfUspsHorizontalBarcode object.
PdfUspsHorizontalBarcode Constructor(String) | Initializes a new PdfUspsHorizontalBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsHorizontalBarcode Class
PdfUspsHorizontalBarcode Members


%%PageItemTitle%%

PdfUspsHorizontalBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfUspsHorizontalBarcode Class > PdfUspsHorizontalBarcode Constructor : PdfUspsHorizontalBarcode Constructor()
Initializes a new PdfUspsHorizontalBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfUspsHorizontalBarcode()
public PdfUspsHorizontalBarcode()
public:
PdfUspsHorizontalBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsHorizontalBarcode Class
PdfUspsHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PdfUspsHorizontalBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfUspsHorizontalBarcode Class > PdfUspsHorizontalBarcode Constructor : PdfUspsHorizontalBarcode Constructor(String)
The barcode data.
Initializes a new PdfUspsHorizontalBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfUspsHorizontalBarcode(data)
public PdfUspsHorizontalBarcode(
   string data
)
public:
PdfUspsHorizontalBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsHorizontalBarcode Class
PdfUspsHorizontalBarcode Members
Overload List


%%PageItemTitle%%

PdfUspsPicBarcode Class
Members

Xfinium.Pdf.Graphics Namespace : PdfUspsPicBarcode Class
Defines an USPS Package Identification Code barcode.
Object Model
PdfUspsPicBarcode ClassPdfColor ClassPdfColor ClassPdfFont ClassPdfBarcodeQuietZones ClassPdfColor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfUspsPicBarcode
   Inherits PdfCode128CBarcode
'Usage

Dim instance As PdfUspsPicBarcode
public class PdfUspsPicBarcode : PdfCode128CBarcode
public ref class PdfUspsPicBarcode : public PdfCode128CBarcode
Remarks
Supported characters: 0 1 2 3 4 5 6 7 8 9
Data length: 21 digits for standard barcode or 29 digits for concatenated barcode.
USPS PIC standard barcode structure:
1 - 2 - Application Identifier (91)
3 - 4 - Service Type Code (STC)
5 - 13 - Customer ID: DUNS number that uniquely identifies the customer
14 - 21 - Package Sequence Number (PSN)
USPS PIC concatenated barcode structure:
1 - 3 - Routing Application Identifier (420)
4 - 8 - 5-digit ZIP code
9 - 10 - Application Identifier (91)
11 - 12 - Service Type Code (STC)
13 - 21 - Customer ID: DUNS number that uniquely identifies the customer
22 - 29 - Package Sequence Number (PSN)
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfBarcode
Xfinium.Pdf.Graphics.Pdf1DBarcode
Xfinium.Pdf.Graphics.PdfCode128Barcode
Xfinium.Pdf.Graphics.PdfCode128CBarcode
Xfinium.Pdf.Graphics.PdfUspsPicBarcode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsPicBarcode Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfUspsPicBarcode Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfUspsPicBarcode Class

The following tables list the members exposed by PdfUspsPicBarcode.

Public Constructors
 | Name | Description
Public Constructor | PdfUspsPicBarcode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUspsPicBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfUspsPicBarcode Constructor

Xfinium.Pdf.Graphics Namespace > PdfUspsPicBarcode Class : PdfUspsPicBarcode Constructor
Overload List
Overload | Description
PdfUspsPicBarcode Constructor() | Initializes a new PdfUspsPicBarcode object.
PdfUspsPicBarcode Constructor(String) | Initializes a new PdfUspsPicBarcode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsPicBarcode Class
PdfUspsPicBarcode Members


%%PageItemTitle%%

PdfUspsPicBarcode Constructor()

Xfinium.Pdf.Graphics Namespace > PdfUspsPicBarcode Class > PdfUspsPicBarcode Constructor : PdfUspsPicBarcode Constructor()
Initializes a new PdfUspsPicBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfUspsPicBarcode()
public PdfUspsPicBarcode()
public:
PdfUspsPicBarcode();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsPicBarcode Class
PdfUspsPicBarcode Members
Overload List


%%PageItemTitle%%

PdfUspsPicBarcode Constructor(String)

Xfinium.Pdf.Graphics Namespace > PdfUspsPicBarcode Class > PdfUspsPicBarcode Constructor : PdfUspsPicBarcode Constructor(String)
The barcode data.
Initializes a new PdfUspsPicBarcode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal data As String _
)
'Usage

Dim data As String

Dim instance As New PdfUspsPicBarcode(data)
public PdfUspsPicBarcode(
   string data
)
public:
PdfUspsPicBarcode(
   String^ data
)

Parameters

data
The barcode data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfUspsPicBarcode Class
PdfUspsPicBarcode Members
Overload List


%%PageItemTitle%%

PdfVisualRectangle Class
Members

Xfinium.Pdf.Graphics Namespace : PdfVisualRectangle Class
Defines a rectangle relative to top left corner of the page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfVisualRectangle
'Usage

Dim instance As PdfVisualRectangle
public class PdfVisualRectangle
public ref class PdfVisualRectangle
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfVisualRectangle

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfVisualRectangle Class Members
Properties Methods

Xfinium.Pdf.Graphics Namespace : PdfVisualRectangle Class

The following tables list the members exposed by PdfVisualRectangle.

Public Constructors
 | Name | Description
Public Constructor | PdfVisualRectangle Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height.
Public Property | Left | Gets or sets left position.
Public Property | Top | Gets or sets top position.
Public Property | Width | Gets or sets the width.
Top
Public Methods
 | Name | Description
Public Method | IntersectsWith | Determines if this rectangle intersects with visualRectangle.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfVisualRectangle Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfVisualRectangle Constructor

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class : PdfVisualRectangle Constructor
Overload List
Overload | Description
PdfVisualRectangle Constructor() | Initializes a new PdfVisualRectangle object.
PdfVisualRectangle Constructor(Double,Double,Double,Double) | Initializes a new PdfVisualRectangle object.
PdfVisualRectangle Constructor(PdfVisualRectangle) | Initializes a new PdfVisualRectangle object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members


%%PageItemTitle%%

PdfVisualRectangle Constructor()

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class > PdfVisualRectangle Constructor : PdfVisualRectangle Constructor()
Initializes a new PdfVisualRectangle object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfVisualRectangle()
public PdfVisualRectangle()
public:
PdfVisualRectangle();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members
Overload List


%%PageItemTitle%%

PdfVisualRectangle Constructor(Double,Double,Double,Double)

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class > PdfVisualRectangle Constructor : PdfVisualRectangle Constructor(Double,Double,Double,Double)
The x coordinate of the rectangle's top left corner.
The y coordinate of the rectangle's top left corner.
The rectangle width.
The rectangle height.
Initializes a new PdfVisualRectangle object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

Dim instance As New PdfVisualRectangle(left, top, width, height)
public PdfVisualRectangle(
   double left,
   double top,
   double width,
   double height
)
public:
PdfVisualRectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x coordinate of the rectangle's top left corner.
top
The y coordinate of the rectangle's top left corner.
width
The rectangle width.
height
The rectangle height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members
Overload List


%%PageItemTitle%%

PdfVisualRectangle Constructor(PdfVisualRectangle)

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class > PdfVisualRectangle Constructor : PdfVisualRectangle Constructor(PdfVisualRectangle)
Source visual rectangle;
Initializes a new PdfVisualRectangle object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfVisualRectangle _
)
'Usage

Dim source As PdfVisualRectangle

Dim instance As New PdfVisualRectangle(source)
public PdfVisualRectangle(
   PdfVisualRectangle source
)
public:
PdfVisualRectangle(
   PdfVisualRectangle^ source
)

Parameters

source
Source visual rectangle;
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfVisualRectangle Class Methods

Xfinium.Pdf.Graphics Namespace : PdfVisualRectangle Class

For a list of all members of this type, see PdfVisualRectangle members.

Public Methods
 | Name | Description
Public Method | IntersectsWith | Determines if this rectangle intersects with visualRectangle.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfVisualRectangle Class
Xfinium.Pdf.Graphics Namespace


IntersectsWith Method

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class : IntersectsWith Method
The rectangle to test.
Determines if this rectangle intersects with visualRectangle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function IntersectsWith( _
   ByVal visualRectangle As PdfVisualRectangle _
) As Boolean
'Usage

Dim instance As PdfVisualRectangle
Dim visualRectangle As PdfVisualRectangle
Dim value As Boolean

value = instance.IntersectsWith(visualRectangle)
public bool IntersectsWith(
   PdfVisualRectangle visualRectangle
)
public:
bool IntersectsWith(
   PdfVisualRectangle^ visualRectangle
)

Parameters

visualRectangle
The rectangle to test.

Return Value

This method returns true if there is any intersection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members


ToString Method (PdfVisualRectangle)

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfVisualRectangle
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members


%%PageItemTitle%% $$Properties$$

PdfVisualRectangle Class Properties

Xfinium.Pdf.Graphics Namespace : PdfVisualRectangle Class

For a list of all members of this type, see PdfVisualRectangle members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height.
Public Property | Left | Gets or sets left position.
Public Property | Top | Gets or sets top position.
Public Property | Width | Gets or sets the width.
Top
See Also

Reference

PdfVisualRectangle Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfVisualRectangle)

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class : Height Property
Gets or sets the height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PdfVisualRectangle
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The rectangle height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members


Left Property (PdfVisualRectangle)

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class : Left Property
Gets or sets left position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Left As Double
'Usage

Dim instance As PdfVisualRectangle
Dim value As Double

instance.Left = value

value = instance.Left
public double Left {get; set;}
public:
property double Left {
   double get();
   void set (    double value);
}

Property Value

The x coordinate of rectangle's top left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members


Top Property (PdfVisualRectangle)

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class : Top Property
Gets or sets top position.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Top As Double
'Usage

Dim instance As PdfVisualRectangle
Dim value As Double

instance.Top = value

value = instance.Top
public double Top {get; set;}
public:
property double Top {
   double get();
   void set (    double value);
}

Property Value

The y coordinate of rectangle's top left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members


Width Property (PdfVisualRectangle)

Xfinium.Pdf.Graphics Namespace > PdfVisualRectangle Class : Width Property
Gets or sets the width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PdfVisualRectangle
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The rectangle width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVisualRectangle Class
PdfVisualRectangle Members


%%PageItemTitle%%

PdfXLJpegImage Class
Members

Xfinium.Pdf.Graphics Namespace : PdfXLJpegImage Class
Defines an extra large JPEG image.
Object Model
PdfXLJpegImage ClassPdfAlternateImageCollection ClassPdfAlternateImage ClassPdfColorSpace ClassPdfCosDictionary ClassPdfImageMask ClassPdfMeasure ClassPdfPointData Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfXLJpegImage
   Inherits PdfImage
'Usage

Dim instance As PdfXLJpegImage
public class PdfXLJpegImage : PdfImage
public ref class PdfXLJpegImage : public PdfImage
Remarks
Extra large JPEG images are not loaded in memory.
The image object keeps a reference to the input stream till the PDF file is generated and writes the image to the PDF file directly from the input stream.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfImage
Xfinium.Pdf.Graphics.PdfXLJpegImage

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXLJpegImage Members
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Members$$

PdfXLJpegImage Class Members
Properties

Xfinium.Pdf.Graphics Namespace : PdfXLJpegImage Class

The following tables list the members exposed by PdfXLJpegImage.

Public Constructors
 | Name | Description
Public Constructor | PdfXLJpegImage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfXLJpegImage Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfXLJpegImage Constructor

Xfinium.Pdf.Graphics Namespace > PdfXLJpegImage Class : PdfXLJpegImage Constructor
Overload List
Overload | Description
PdfXLJpegImage Constructor(Stream) | Initializes a new PdfXLJpegImage object.
PdfXLJpegImage Constructor(Stream,Boolean) | Initializes a new PdfXLJpegImage object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXLJpegImage Class
PdfXLJpegImage Members


%%PageItemTitle%%

PdfXLJpegImage Constructor(Stream)

Xfinium.Pdf.Graphics Namespace > PdfXLJpegImage Class > PdfXLJpegImage Constructor : PdfXLJpegImage Constructor(Stream)
JPEG stream.
Initializes a new PdfXLJpegImage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfXLJpegImage(stream)
public PdfXLJpegImage(
   Stream stream
)
public:
PdfXLJpegImage(
   Stream^ stream
)

Parameters

stream
JPEG stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXLJpegImage Class
PdfXLJpegImage Members
Overload List


%%PageItemTitle%%

PdfXLJpegImage Constructor(Stream,Boolean)

Xfinium.Pdf.Graphics Namespace > PdfXLJpegImage Class > PdfXLJpegImage Constructor : PdfXLJpegImage Constructor(Stream,Boolean)
JPEG stream.
If true, the input stream is disposed after the image has been written to the PDF file.
Initializes a new PdfXLJpegImage object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal disposeStream As Boolean _
)
'Usage

Dim stream As Stream
Dim disposeStream As Boolean

Dim instance As New PdfXLJpegImage(stream, disposeStream)
public PdfXLJpegImage(
   Stream stream,
   bool disposeStream
)
public:
PdfXLJpegImage(
   Stream^ stream,
   bool disposeStream
)

Parameters

stream
JPEG stream.
disposeStream
If true, the input stream is disposed after the image has been written to the PDF file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXLJpegImage Class
PdfXLJpegImage Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfXLJpegImage Class Properties

Xfinium.Pdf.Graphics Namespace : PdfXLJpegImage Class

For a list of all members of this type, see PdfXLJpegImage members.

Public Properties
 | Name | Description
Public Property | AlternateImages | Gets or sets the alternate images. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | BitsPerComponent | Gets or sets the bits per component. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | ColorSpace | Gets or sets the color space. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Height | Overridden. Gets the image height.
Public Property | Interpolate | Gets or sets a value indicating whether image interpolation is to be performed. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Mask | Gets or sets the image mask. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfImage)
Public Property | Width | Overridden. Gets the image width.
Top
See Also

Reference

PdfXLJpegImage Class
Xfinium.Pdf.Graphics Namespace


Height Property (PdfXLJpegImage)

Xfinium.Pdf.Graphics Namespace > PdfXLJpegImage Class : Height Property
Gets the image height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Height As Integer
'Usage

Dim instance As PdfXLJpegImage
Dim value As Integer

instance.Height = value

value = instance.Height
public override int Height {get; set;}
public:
property int Height {
   int get() override;
   void set (    int value) override;
}

Property Value

The image height in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXLJpegImage Class
PdfXLJpegImage Members


Width Property (PdfXLJpegImage)

Xfinium.Pdf.Graphics Namespace > PdfXLJpegImage Class : Width Property
Gets the image width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Property Width As Integer
'Usage

Dim instance As PdfXLJpegImage
Dim value As Integer

instance.Width = value

value = instance.Width
public override int Width {get; set;}
public:
property int Width {
   int get() override;
   void set (    int value) override;
}

Property Value

The image width in pixels.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXLJpegImage Class
PdfXLJpegImage Members


%%PageItemTitle%%

DataMatrixBarcodeSize Enumeration

Xfinium.Pdf.Graphics Namespace : DataMatrixBarcodeSize Enumeration
Supported DataMatrix barcode sizes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum DataMatrixBarcodeSize
   Inherits System.Enum
'Usage

Dim instance As DataMatrixBarcodeSize
public enum DataMatrixBarcodeSize : System.Enum
public enum class DataMatrixBarcodeSize : public System.Enum
Members
Member | Description
Auto | The smallest barcode size required to encode the data.
Rows104Columns104 | Barcode size: 104 rows by 104 columns.
Rows10Columns10 | Barcode size: 10 rows by 10 columns.
Rows120Columns120 | Barcode size: 120 rows by 120 columns.
Rows12Columns12 | Barcode size: 12 rows by 12 columns.
Rows12Columns26 | Barcode size: 12 rows by 26 columns.
Rows12Columns36 | Barcode size: 12 rows by 36 columns.
Rows132Columns132 | Barcode size: 132 rows by 132 columns.
Rows144Columns144 | Barcode size: 144 rows by 144 columns.
Rows14Columns14 | Barcode size: 14 rows by 14 columns.
Rows16Columns16 | Barcode size: 16 rows by 16 columns.
Rows16Columns36 | Barcode size: 16 rows by 36 columns.
Rows16Columns48 | Barcode size: 16 rows by 48 columns.
Rows18Columns18 | Barcode size: 18 rows by 18 columns.
Rows20Columns20 | Barcode size: 20 rows by 20 columns.
Rows22Columns22 | Barcode size: 22 rows by 22 columns.
Rows24Columns24 | Barcode size: 24 rows by 24 columns.
Rows26Columns26 | Barcode size: 26 rows by 26 columns.
Rows32Columns32 | Barcode size: 32 rows by 32 columns.
Rows36Columns36 | Barcode size: 36 rows by 36 columns.
Rows40Columns40 | Barcode size: 40 rows by 40 columns.
Rows44Columns44 | Barcode size: 44 rows by 44 columns.
Rows48Columns48 | Barcode size: 48 rows by 48 columns.
Rows52Columns52 | Barcode size: 52 rows by 52 columns.
Rows64Columns64 | Barcode size: 64 rows by 64 columns.
Rows72Columns72 | Barcode size: 72 rows by 72 columns.
Rows80Columns80 | Barcode size: 80 rows by 80 columns.
Rows88Columns88 | Barcode size: 88 rows by 88 columns.
Rows8Columns18 | Barcode size: 8 rows by 18 columns.
Rows8Columns32 | Barcode size: 8 rows by 32 columns.
Rows96Columns96 | Barcode size: 96 rows by 96 columns.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.DataMatrixBarcodeSize

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

DataMatrixEncoding Enumeration

Xfinium.Pdf.Graphics Namespace : DataMatrixEncoding Enumeration
Supported encoding modes for DataMatrix barcodes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum DataMatrixEncoding
   Inherits System.Enum
'Usage

Dim instance As DataMatrixEncoding
public enum DataMatrixEncoding : System.Enum
public enum class DataMatrixEncoding : public System.Enum
Members
Member | Description
ASCII | ASCII-only data (extended ASCII also included).
Auto | Encoding detected automatically based on data.
Base256 | Binary data.
Numeric | Numeric data (ASCII: 0x30 - 0x39)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.DataMatrixEncoding

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

Pdf417DataCompactionMode Enumeration

Xfinium.Pdf.Graphics Namespace : Pdf417DataCompactionMode Enumeration
Supported data compaction modes for PDF417 barcodes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf417DataCompactionMode
   Inherits System.Enum
'Usage

Dim instance As Pdf417DataCompactionMode
public enum Pdf417DataCompactionMode : System.Enum
public enum class Pdf417DataCompactionMode : public System.Enum
Members
Member | Description
Byte | Binary compaction mode - any binary data.
Numeric | Numeric compaction mode - recommended for numeric data (ASCII: 0x30 - 0x39).
Text | Text compaction mode - recommended for text based data.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.Pdf417DataCompactionMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

Pdf417ErrorCorrectionLevel Enumeration

Xfinium.Pdf.Graphics Namespace : Pdf417ErrorCorrectionLevel Enumeration
Supported error correction levels for PDF417 barcodes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf417ErrorCorrectionLevel
   Inherits System.Enum
'Usage

Dim instance As Pdf417ErrorCorrectionLevel
public enum Pdf417ErrorCorrectionLevel : System.Enum
public enum class Pdf417ErrorCorrectionLevel : public System.Enum
Members
Member | Description
Level0 | Level 0.
Level1 | Level 1.
Level2 | Level 2.
Level3 | Level 3.
Level4 | Level 4.
Level5 | Level 5.
Level6 | Level 6.
Level7 | Level 7.
Level8 | Level 8.
Remarks
The number of error correction codewords is 2^ErrorCorrectionLevel.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.Pdf417ErrorCorrectionLevel

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

Pdf417MicroBarcodeSize Enumeration

Xfinium.Pdf.Graphics Namespace : Pdf417MicroBarcodeSize Enumeration
Supported Micro PDF417 barcode sizes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum Pdf417MicroBarcodeSize
   Inherits System.Enum
'Usage

Dim instance As Pdf417MicroBarcodeSize
public enum Pdf417MicroBarcodeSize : System.Enum
public enum class Pdf417MicroBarcodeSize : public System.Enum
Members
Member | Description
Auto | The smallest barcode size required to encode the data.
Rows10Columns3 | Barcode size: 10 rows by 3 columns.
Rows10Columns4 | Barcode size: 10 rows by 4 columns.
Rows11Columns1 | Barcode size: 11 rows by 1 column.
Rows11Columns2 | Barcode size: 11 rows by 2 columns.
Rows12Columns3 | Barcode size: 12 rows by 3 columns.
Rows12Columns4 | Barcode size: 12 rows by 4 columns.
Rows14Columns1 | Barcode size: 14 rows by 1 column.
Rows14Columns2 | Barcode size: 14 rows by 2 columns.
Rows15Columns3 | Barcode size: 15 rows by 3 columns.
Rows15Columns4 | Barcode size: 15 rows by 4 columns.
Rows17Columns1 | Barcode size: 17 rows by 1 column.
Rows17Columns2 | Barcode size: 17 rows by 2 columns.
Rows20Columns1 | Barcode size: 20 rows by 1 column.
Rows20Columns2 | Barcode size: 20 rows by 2 columns.
Rows20Columns3 | Barcode size: 20 rows by 3 columns.
Rows20Columns4 | Barcode size: 20 rows by 4 columns.
Rows23Columns2 | Barcode size: 23 rows by 2 columns.
Rows24Columns1 | Barcode size: 24 rows by 1 column.
Rows26Columns2 | Barcode size: 26 rows by 2 columns.
Rows26Columns3 | Barcode size: 26 rows by 3 columns.
Rows26Columns4 | Barcode size: 26 rows by 4 columns.
Rows28Columns1 | Barcode size: 28 rows by 1 column.
Rows32Columns3 | Barcode size: 32 rows by 3 columns.
Rows32Columns4 | Barcode size: 32 rows by 4 columns.
Rows38Columns3 | Barcode size: 38 rows by 3 columns.
Rows38Columns4 | Barcode size: 38 rows by 4 columns.
Rows44Columns3 | Barcode size: 44 rows by 3 columns.
Rows44Columns4 | Barcode size: 44 rows by 4 columns.
Rows4Columns4 | Barcode size: 4 rows by 4 columns.
Rows6Columns3 | Barcode size: 6 rows by 3 columns.
Rows6Columns4 | Barcode size: 6 rows by 4 columns.
Rows8Columns2 | Barcode size: 8 rows by 2 columns.
Rows8Columns3 | Barcode size: 8 rows by 3 columns.
Rows8Columns4 | Barcode size: 8 rows by 4 columns.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.Pdf417MicroBarcodeSize

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfBarcodeTextPosition Enumeration

Xfinium.Pdf.Graphics Namespace : PdfBarcodeTextPosition Enumeration
Supported position for barcode text relative to barcode graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfBarcodeTextPosition
   Inherits System.Enum
'Usage

Dim instance As PdfBarcodeTextPosition
public enum PdfBarcodeTextPosition : System.Enum
public enum class PdfBarcodeTextPosition : public System.Enum
Members
Member | Description
Bottom | Barcode text is displayed at the bottom of the barcode.
BottomEmbedded | Barcode text is displayed at the bottom of the barcode but embedded in the barcode graphics.
None | No barcode text is displayed.
Top | Barcode text is displayed at the top of the barcode.
TopEmbedded | Barcode text is displayed at the top of the barcode but embedded in the barcode graphics.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfBarcodeTextPosition

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfBlendMode Enumeration

Xfinium.Pdf.Graphics Namespace : PdfBlendMode Enumeration
Supported PDF blend modes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfBlendMode
   Inherits System.Enum
'Usage

Dim instance As PdfBlendMode
public enum PdfBlendMode : System.Enum
public enum class PdfBlendMode : public System.Enum
Members
Member | Description
Color | Creates a color with the saturation and hue of the source color and the luminance of the backdrop color.
ColorBurn | Darkens the backdrop color to reflect the source color.
ColorDodge | Brightens the backdrop color to reflect the source color.
Darken | Selects the darker of the backdrop and source colors.
Difference | Subtracts the darker of the two constituents colors from the lighter.
Exclusion | Same as Difference, but lower in contrast.
HardLight | Multiplies or screens the colors depending on the source color.
Hue | Creates a color with the hue of the source color and the saturation and luminance of the backdrop color.
Lighten | Selects the lighter of the backdrop and source colors.
Luminosity | Creates a color with the luminance of the source color and the saturation and hue of the backdrop color.
Multiply | Multiplies the backdrop and source color.
None | Same as Normal.
Normal | Selects the source color.
Overlay | Multiplies or screens the colors depending on the backdrop color.
Saturation | Creates a color with the saturation of the source color and the hue and luminance of the backdrop color.
Screen | Multiplies the complements of backdrop and source color values, and then complements the result.
SoftLight | Darkens or lightens the colors depending on the source color.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfBlendMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfColorSpaceType Enumeration

Xfinium.Pdf.Graphics Namespace : PdfColorSpaceType Enumeration
Supported PDF colorspaces.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfColorSpaceType
   Inherits System.Enum
'Usage

Dim instance As PdfColorSpaceType
public enum PdfColorSpaceType : System.Enum
public enum class PdfColorSpaceType : public System.Enum
Members
Member | Description
CalGray | Calibrated gray colorspace.
CalRgb | Calibrated RGB colorspace.
Cmyk | Device CMYK colorspace.
DeviceN | DeviceN colorspace.
Gray | Device gray colorspace.
IccBased | ICC colorspace.
Indexed | Indexed colorspace.
Lab | Lab colorspace.
Pattern | Pattern colorspace.
Rgb | Device RGB colorspace.
Separation | Separation colorspace.
Unknown | Unknown colorspace.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfColorSpaceType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfFillMode Enumeration

Xfinium.Pdf.Graphics Namespace : PdfFillMode Enumeration
Support fill modes for Pdf paths.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFillMode
   Inherits System.Enum
'Usage

Dim instance As PdfFillMode
public enum PdfFillMode : System.Enum
public enum class PdfFillMode : public System.Enum
Members
Member | Description
EvenOdd | Even-odd mode.
NonZeroWinding | Non zero winding mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfFillMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfFlipDirection Enumeration

Xfinium.Pdf.Graphics Namespace : PdfFlipDirection Enumeration
Supported flip directions.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PdfFlipDirection
   Inherits System.Enum
'Usage

Dim instance As PdfFlipDirection
[Flags()]
public enum PdfFlipDirection : System.Enum
[Flags()]
public enum class PdfFlipDirection : public System.Enum
Members
Member | Description
HorizontalFlip | The content is flipped on horizontal.
NoFlip | The content is not flipped.
VerticalFlip | The content is flipped on vertical.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfFlipDirection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfGraphicAlign Enumeration

Xfinium.Pdf.Graphics Namespace : PdfGraphicAlign Enumeration
Specifies the available align modes for content relative to a parent container.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfGraphicAlign
   Inherits System.Enum
'Usage

Dim instance As PdfGraphicAlign
public enum PdfGraphicAlign : System.Enum
public enum class PdfGraphicAlign : public System.Enum
Members
Member | Description
Center | Content is centered on horizontal or aligned at middle on the vertical.
Far | Content is aligned to the right on horizontal or at bottom on the vertical.
Near | Content is aligned to the left on horizontal or at top on the vertical.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfGraphicAlign

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfLineCap Enumeration

Xfinium.Pdf.Graphics Namespace : PdfLineCap Enumeration
Supported line cap styles.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfLineCap
   Inherits System.Enum
'Usage

Dim instance As PdfLineCap
public enum PdfLineCap : System.Enum
public enum class PdfLineCap : public System.Enum
Members
Member | Description
Flat | Flat.
Round | Round.
Square | Square.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfLineCap

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfLineJoin Enumeration

Xfinium.Pdf.Graphics Namespace : PdfLineJoin Enumeration
Supported line join styles.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfLineJoin
   Inherits System.Enum
'Usage

Dim instance As PdfLineJoin
public enum PdfLineJoin : System.Enum
public enum class PdfLineJoin : public System.Enum
Members
Member | Description
Bevel | Beveled.
Miter | Miter.
Round | Round.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfLineJoin

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfPageGraphicsPosition Enumeration

Xfinium.Pdf.Graphics Namespace : PdfPageGraphicsPosition Enumeration
Supported positions for page graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPageGraphicsPosition
   Inherits System.Enum
'Usage

Dim instance As PdfPageGraphicsPosition
public enum PdfPageGraphicsPosition : System.Enum
public enum class PdfPageGraphicsPosition : public System.Enum
Members
Member | Description
OverExistingPageContent | The page graphics is placed on top of existing page content.
UnderExistingPageContent | The page graphics is placed under existing page content.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfPageGraphicsPosition

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfQrBarcodeCharacterSet Enumeration

Xfinium.Pdf.Graphics Namespace : PdfQrBarcodeCharacterSet Enumeration
Character sets supported in QR barcode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfQrBarcodeCharacterSet
   Inherits System.Enum
'Usage

Dim instance As PdfQrBarcodeCharacterSet
public enum PdfQrBarcodeCharacterSet : System.Enum
public enum class PdfQrBarcodeCharacterSet : public System.Enum
Members
Member | Description
Cp437 | CP437 character set.
ISO88591 | ISO 8859-1 character set.
ShiftJIS | Shift JIS character set.
UTF8 | UTF-8 character set.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfQrBarcodeCharacterSet

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfQrBarcodeErrorCorrectionLevel Enumeration

Xfinium.Pdf.Graphics Namespace : PdfQrBarcodeErrorCorrectionLevel Enumeration
Error correction levels defined by QR barcode specification.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfQrBarcodeErrorCorrectionLevel
   Inherits System.Enum
'Usage

Dim instance As PdfQrBarcodeErrorCorrectionLevel
public enum PdfQrBarcodeErrorCorrectionLevel : System.Enum
public enum class PdfQrBarcodeErrorCorrectionLevel : public System.Enum
Members
Member | Description
H | H error correction level.
L | L error correction level.
M | M error correction level.
Q | Q error correction level.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfQrBarcodeErrorCorrectionLevel

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStandardFontFace Enumeration

Xfinium.Pdf.Graphics Namespace : PdfStandardFontFace Enumeration
Supported standard PDF fonts.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfStandardFontFace
   Inherits System.Enum
'Usage

Dim instance As PdfStandardFontFace
public enum PdfStandardFontFace : System.Enum
public enum class PdfStandardFontFace : public System.Enum
Members
Member | Description
Courier | Courier.
CourierBold | Courier Bold.
CourierBoldItalic | Courier Bold Italic.
CourierItalic | Courier Italic.
HanyangSystemsGothicMedium | Korean The Hanyang Systems Gothic Medium.
HanyangSystemsGothicMediumBold | Korean The Hanyang Systems Gothic Medium Bold.
HanyangSystemsGothicMediumBoldItalic | Korean The Hanyang Systems Gothic Medium Bold Italic.
HanyangSystemsGothicMediumItalic | Korean The Hanyang Systems Gothic Medium Italic.
HanyangSystemsShinMyeongJoMedium | Korean Hanyang Systems Shin MyeongJo Medium.
HanyangSystemsShinMyeongJoMediumBold | Korean Hanyang Systems Shin MyeongJo Medium Bold.
HanyangSystemsShinMyeongJoMediumBoldItalic | Korean Hanyang Systems Shin MyeongJo Medium Bold Italic.
HanyangSystemsShinMyeongJoMediumItalic | Korean Hanyang Systems Shin MyeongJo Medium Italic.
HeiseiKakuGothicW5 | Japanese Heisei Kaku Gothic W5.
HeiseiKakuGothicW5Bold | Japanese Heisei Kaku Gothic W5 Bold.
HeiseiKakuGothicW5BoldItalic | Japanese Heisei Kaku Gothic W5 Bold Italic.
HeiseiKakuGothicW5Italic | Japanese Heisei Kaku Gothic W5 Italic.
HeiseiMinchoW3 | Japanese Heisei Mincho W3.
HeiseiMinchoW3Bold | Japanese Heisei Mincho W3 Bold.
HeiseiMinchoW3BoldItalic | Japanese Heisei Mincho W3 Bold Italic.
HeiseiMinchoW3Italic | Japanese Heisei Mincho W3 Italic.
Helvetica | Helvetica.
HelveticaBold | Helvetica Bold.
HelveticaBoldItalic | Helvetica Bold Italic.
HelveticaItalic | Helvetica Italic.
KozMinProVIRegular | Japanese KozMinProVI-Regular.
KozMinProVIRegularBold | Japanese KozMinProVI-Regular Bold.
KozMinProVIRegularBoldItalic | Japanese KozMinProVI-Regular Bold Italic.
KozMinProVIRegularItalic | Japanese KozMinProVI-Regular Italic.
MonotypeHeiMedium | Chinese Traditional The Monotype Hei Medium.
MonotypeHeiMediumBold | Chinese Traditional The Monotype Hei Medium Bold.
MonotypeHeiMediumBoldItalic | Chinese Traditional The Monotype Hei Medium Bold Italic.
MonotypeHeiMediumItalic | Chinese Traditional The Monotype Hei Medium Italic.
MonotypeSungLight | Chinese Traditional The Monotype Sung Light.
MonotypeSungLightBold | Chinese Traditional The Monotype Sung Light Bold.
MonotypeSungLightBoldItalic | Chinese Traditional The Monotype Sung Light Bold Italic.
MonotypeSungLightItalic | Chinese Traditional The Monotype Sung Light Italic.
SinoTypeSongLight | Chinese Simplified The SinoType Song Light.
SinoTypeSongLightBold | Chinese Simplified The SinoType Song Light Bold.
SinoTypeSongLightBoldItalic | Chinese Simplified The SinoType Song Light Bold Italic.
SinoTypeSongLightItalic | Chinese Simplified The SinoType Song Light Italic.
Symbol | Symbol.
TimesRoman | Times Roman.
TimesRomanBold | Times Roman Bold.
TimesRomanBoldItalic | Times Roman Bold Italic.
TimesRomanItalic | Times Roman Italic.
ZapfDingbats | ZapfDingbats.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfStandardFontFace

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStringHorizontalAlign Enumeration

Xfinium.Pdf.Graphics Namespace : PdfStringHorizontalAlign Enumeration
Supported horizontal align modes for text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfStringHorizontalAlign
   Inherits System.Enum
'Usage

Dim instance As PdfStringHorizontalAlign
public enum PdfStringHorizontalAlign : System.Enum
public enum class PdfStringHorizontalAlign : public System.Enum
Members
Member | Description
Center | Text is center aligned.
Justified | Text is justified when drawn in a box.
Left | Text is left aligned.
Right | Text is right aligned.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfStringHorizontalAlign

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStringVerticalAlign Enumeration

Xfinium.Pdf.Graphics Namespace : PdfStringVerticalAlign Enumeration
Supported vertical align modes for text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfStringVerticalAlign
   Inherits System.Enum
'Usage

Dim instance As PdfStringVerticalAlign
public enum PdfStringVerticalAlign : System.Enum
public enum class PdfStringVerticalAlign : public System.Enum
Members
Member | Description
Bottom | Text is bottom aligned at baseline.
Middle | Text is middle aligned.
Top | Text is top aligned.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.PdfStringVerticalAlign

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics Namespace


Xfinium.Pdf.Graphics.FormattedContent Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfFormattedBlock | Defines the base class for all formatted blocks.
Class | PdfFormattedBlockCollection | Defines a collection of formatted blocks.
Class | PdfFormattedContent | Defines a piece of formatted content that can be drawn on a page.
Class | PdfFormattedParagraph | Defines a formatted paragraph.
Class | PdfFormattedParagraphCollection | Defines a collection of formatted paragraphs.
Class | PdfFormattedTextBlock | Defines a formatted block of text.
Enumerations
 | Enumeration | Description
Enumeration | PdfFormattedParagraphLineSpacing | Specifies the available line spacing modes for paragraph lines.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Graphics.FormattedContent Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedBlockCollection
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedParagraphCollection
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedBlock
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedTextBlock
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedContent
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedParagraph
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfFormattedBlock Class
Members

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedBlock Class
Defines the base class for all formatted blocks.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfFormattedBlock
'Usage

Dim instance As PdfFormattedBlock
public abstract class PdfFormattedBlock
public ref class PdfFormattedBlock abstract
Remarks
A formatted block is a piece of content with unique formatting attributes.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedBlock
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedTextBlock

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedBlock Members
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Members$$

PdfFormattedBlock Class Members

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedBlock Class

The following tables list the members exposed by PdfFormattedBlock.

See Also

Reference

PdfFormattedBlock Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%%

PdfFormattedBlockCollection Class
Members

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedBlockCollection Class
Defines a collection of formatted blocks.
Object Model
PdfFormattedBlockCollection ClassPdfFormattedBlock Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFormattedBlockCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfFormattedBlock)
'Usage

Dim instance As PdfFormattedBlockCollection
public class PdfFormattedBlockCollection : System.Collections.ObjectModel.Collection<PdfFormattedBlock>
public ref class PdfFormattedBlockCollection : public System.Collections.ObjectModel.Collection<PdfFormattedBlock>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedBlockCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedBlockCollection Members
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Members$$

PdfFormattedBlockCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedBlockCollection Class

The following tables list the members exposed by PdfFormattedBlockCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Top
See Also

Reference

PdfFormattedBlockCollection Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%%

PdfFormattedContent Class
Members

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedContent Class
Defines a piece of formatted content that can be drawn on a page.
Object Model
PdfFormattedContent ClassPdfFormattedParagraphCollection ClassPdfFormattedParagraph Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFormattedContent
'Usage

Dim instance As PdfFormattedContent
public class PdfFormattedContent
public ref class PdfFormattedContent
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedContent

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Members
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Members$$

PdfFormattedContent Class Members
Properties Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedContent Class

The following tables list the members exposed by PdfFormattedContent.

Public Constructors
 | Name | Description
Public Constructor | PdfFormattedContent Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets the height of the formatted content.
Public Property | ParagraphHeights | Gets the height of each paragraph in the formatted content.
Public Property | Paragraphs | Gets the list of paragraphs.
Top
Public Methods
 | Name | Description
Public Method | ClearWordWrapState | Clears the internal word wrap state.
Public Method | SplitByBox | Overloaded. Gets the formatted content that fits in the given box.
Public Method | ToString | Returns a string that represents the current object.
Public Method | Wrap | Executes a wrap operation on the formatted content at the specified width.
Top
See Also

Reference

PdfFormattedContent Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%%

PdfFormattedContent Constructor

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class : PdfFormattedContent Constructor
Overload List
Overload | Description
PdfFormattedContent Constructor() | Initializes a new PdfFormattedContent object.
PdfFormattedContent Constructor(String) | Initializes a new PdfFormattedContent object with a text paragraph.
PdfFormattedContent Constructor(PdfFormattedContent) | Initializes a new PdfFormattedContent object with another formatted content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members


%%PageItemTitle%%

PdfFormattedContent Constructor()

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class > PdfFormattedContent Constructor : PdfFormattedContent Constructor()
Initializes a new PdfFormattedContent object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFormattedContent()
public PdfFormattedContent()
public:
PdfFormattedContent();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members
Overload List


%%PageItemTitle%%

PdfFormattedContent Constructor(String)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class > PdfFormattedContent Constructor : PdfFormattedContent Constructor(String)
Paragraph text.
Initializes a new PdfFormattedContent object with a text paragraph.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As String _
)
'Usage

Dim text As String

Dim instance As New PdfFormattedContent(text)
public PdfFormattedContent(
   string text
)
public:
PdfFormattedContent(
   String^ text
)

Parameters

text
Paragraph text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members
Overload List


%%PageItemTitle%%

PdfFormattedContent Constructor(PdfFormattedContent)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class > PdfFormattedContent Constructor : PdfFormattedContent Constructor(PdfFormattedContent)
Source content
Initializes a new PdfFormattedContent object with another formatted content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFormattedContent _
)
'Usage

Dim source As PdfFormattedContent

Dim instance As New PdfFormattedContent(source)
public PdfFormattedContent(
   PdfFormattedContent source
)
public:
PdfFormattedContent(
   PdfFormattedContent^ source
)

Parameters

source
Source content
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfFormattedContent Class Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedContent Class

For a list of all members of this type, see PdfFormattedContent members.

Public Methods
 | Name | Description
Public Method | ClearWordWrapState | Clears the internal word wrap state.
Public Method | SplitByBox | Overloaded. Gets the formatted content that fits in the given box.
Public Method | ToString | Returns a string that represents the current object.
Public Method | Wrap | Executes a wrap operation on the formatted content at the specified width.
Top
See Also

Reference

PdfFormattedContent Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


ClearWordWrapState Method

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class : ClearWordWrapState Method
Clears the internal word wrap state.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ClearWordWrapState()
'Usage

Dim instance As PdfFormattedContent

instance.ClearWordWrapState()
public void ClearWordWrapState()
public:
void ClearWordWrapState();
Remarks
This method must be called before re-drawing the PdfFormattedContent object if its content has changed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members


SplitByBox Method

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class : SplitByBox Method
Gets the formatted content that fits in the given box.
Overload List
Overload | Description
SplitByBox(Double,Double) | Gets the formatted content that fits in the given box.
SplitByBox(Double,Double,Boolean) | Gets the formatted content that fits in the given box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members


SplitByBox(Double,Double) Method

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class > SplitByBox Method : SplitByBox(Double,Double) Method
The box width.
The box height.
Gets the formatted content that fits in the given box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function SplitByBox( _
   ByVal width As Double, _
   ByVal height As Double _
) As PdfFormattedContent
'Usage

Dim instance As PdfFormattedContent
Dim width As Double
Dim height As Double
Dim value As PdfFormattedContent

value = instance.SplitByBox(width, height)
public PdfFormattedContent SplitByBox(
   double width,
   double height
)
public:
PdfFormattedContent^ SplitByBox(
   double width,
   double height
)

Parameters

width
The box width.
height
The box height.

Return Value

The formatted content that fits in the given box.
Remarks
This method modifies the current object, the formatted content that fits the given box is removed from current object and returned as a new object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members
Overload List


SplitByBox(Double,Double,Boolean) Method

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class > SplitByBox Method : SplitByBox(Double,Double,Boolean) Method
The box width.
The box height.
If true, the list of paragraphs is also updated to reflect the split.
Gets the formatted content that fits in the given box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function SplitByBox( _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal updateParagraphs As Boolean _
) As PdfFormattedContent
'Usage

Dim instance As PdfFormattedContent
Dim width As Double
Dim height As Double
Dim updateParagraphs As Boolean
Dim value As PdfFormattedContent

value = instance.SplitByBox(width, height, updateParagraphs)
public PdfFormattedContent SplitByBox(
   double width,
   double height,
   bool updateParagraphs
)
public:
PdfFormattedContent^ SplitByBox(
   double width,
   double height,
   bool updateParagraphs
)

Parameters

width
The box width.
height
The box height.
updateParagraphs
If true, the list of paragraphs is also updated to reflect the split.

Return Value

The formatted content that fits in the given box.
Remarks
This method modifies the current object, the formatted content that fits the given box is removed from current object and returned as a new object.
If this method is called multiple times but with a different width then the 'updateParagraphs' parameter should be set to true.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members
Overload List


ToString Method (PdfFormattedContent)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfFormattedContent
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members


Wrap Method

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class : Wrap Method
The width at which the formatted content is wrapped.
Executes a wrap operation on the formatted content at the specified width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub Wrap( _
   ByVal width As Double _
)
'Usage

Dim instance As PdfFormattedContent
Dim width As Double

instance.Wrap(width)
public void Wrap(
   double width
)
public:
void Wrap(
   double width
)

Parameters

width
The width at which the formatted content is wrapped.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members


%%PageItemTitle%% $$Properties$$

PdfFormattedContent Class Properties

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedContent Class

For a list of all members of this type, see PdfFormattedContent members.

Public Properties
 | Name | Description
Public Property | Height | Gets the height of the formatted content.
Public Property | ParagraphHeights | Gets the height of each paragraph in the formatted content.
Public Property | Paragraphs | Gets the list of paragraphs.
Top
See Also

Reference

PdfFormattedContent Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


Height Property (PdfFormattedContent)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class : Height Property
Gets the height of the formatted content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As PdfFormattedContent
Dim value As Double

value = instance.Height
public double Height {get;}
public:
property double Height {
   double get();
}

Property Value

The height of the formatted content wrapped at a specific width.
Remarks
The Wrap method must be called before reading this property. This property can also be read after the formatted content has been drawn on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members


ParagraphHeights Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class : ParagraphHeights Property
Gets the height of each paragraph in the formatted content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ParagraphHeights As Double()
'Usage

Dim instance As PdfFormattedContent
Dim value() As Double

value = instance.ParagraphHeights
public double[] ParagraphHeights {get;}
public:
property array<double>^ ParagraphHeights {
   array<double>^ get();
}

Property Value

The height of each paragraph in the formatted content wrapped at a specific width.
Remarks
The Wrap method must be called before reading this property. This property can also be read after the formatted content has been drawn on the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members


Paragraphs Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedContent Class : Paragraphs Property
Gets the list of paragraphs.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Paragraphs As PdfFormattedParagraphCollection
'Usage

Dim instance As PdfFormattedContent
Dim value As PdfFormattedParagraphCollection

value = instance.Paragraphs
public PdfFormattedParagraphCollection Paragraphs {get;}
public:
property PdfFormattedParagraphCollection^ Paragraphs {
   PdfFormattedParagraphCollection^ get();
}

Property Value

The list of paragraphs that compose this formatted piece of content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedContent Class
PdfFormattedContent Members


%%PageItemTitle%%

PdfFormattedParagraph Class
Members

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraph Class
Defines a formatted paragraph.
Object Model
PdfFormattedParagraph ClassPdfFormattedBlockCollection ClassPdfFormattedBlock ClassPdfFormattedBlock Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFormattedParagraph
'Usage

Dim instance As PdfFormattedParagraph
public class PdfFormattedParagraph
public ref class PdfFormattedParagraph
Remarks
A paragraph contains one or more formatted blocks, each one with its formatting attributes.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedParagraph

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Members
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Members$$

PdfFormattedParagraph Class Members
Properties Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraph Class

The following tables list the members exposed by PdfFormattedParagraph.

Public Constructors
 | Name | Description
Public Constructor | PdfFormattedParagraph Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Blocks | Gets the list of formatted blocks that compose this paragraph.
Public Property | Bullet | Gets or sets the bullet text.
Public Property | FirstLineIndent | Gets or sets the indentation of the first paragraph line.
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | LeftIndentation | Gets or sets the left indentation.
Public Property | LineSpacing | Gets or sets the line spacing in points.
Public Property | LineSpacingMode | Gets or sets the line spacing for the paragraph.
Public Property | RightIndentation | Gets or sets the right indentation.
Public Property | SpacingAfter | Gets or sets the spacing after the paragraph.
Public Property | SpacingBefore | Gets or sets the spacing before the paragraph.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfFormattedParagraph Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%%

PdfFormattedParagraph Constructor

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : PdfFormattedParagraph Constructor
Overload List
Overload | Description
PdfFormattedParagraph Constructor() | Initializes a new PdfFormattedParagraph object.
PdfFormattedParagraph Constructor(String) | Initializes a new PdfFormattedParagraph object.
PdfFormattedParagraph Constructor(PdfFormattedBlock[]) | Initializes a new PdfFormattedParagraph object.
PdfFormattedParagraph Constructor(PdfFormattedParagraph) | Initializes a new PdfFormattedParagraph object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


%%PageItemTitle%%

PdfFormattedParagraph Constructor()

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class > PdfFormattedParagraph Constructor : PdfFormattedParagraph Constructor()
Initializes a new PdfFormattedParagraph object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFormattedParagraph()
public PdfFormattedParagraph()
public:
PdfFormattedParagraph();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members
Overload List


%%PageItemTitle%%

PdfFormattedParagraph Constructor(String)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class > PdfFormattedParagraph Constructor : PdfFormattedParagraph Constructor(String)
Initial paragraph text.
Initializes a new PdfFormattedParagraph object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As String _
)
'Usage

Dim text As String

Dim instance As New PdfFormattedParagraph(text)
public PdfFormattedParagraph(
   string text
)
public:
PdfFormattedParagraph(
   String^ text
)

Parameters

text
Initial paragraph text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members
Overload List


%%PageItemTitle%%

PdfFormattedParagraph Constructor(PdfFormattedBlock[])

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class > PdfFormattedParagraph Constructor : PdfFormattedParagraph Constructor(PdfFormattedBlock[])
Initializes a new PdfFormattedParagraph object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ParamArray blocks() As PdfFormattedBlock _
)
'Usage

Dim blocks() As PdfFormattedBlock

Dim instance As New PdfFormattedParagraph(blocks)
public PdfFormattedParagraph(
   params PdfFormattedBlock[] blocks
)
public:
PdfFormattedParagraph(
   ... array<PdfFormattedBlock^>^ blocks
)

Parameters

blocks
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members
Overload List


%%PageItemTitle%%

PdfFormattedParagraph Constructor(PdfFormattedParagraph)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class > PdfFormattedParagraph Constructor : PdfFormattedParagraph Constructor(PdfFormattedParagraph)
Source paragraph.
Initializes a new PdfFormattedParagraph object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As PdfFormattedParagraph _
)
'Usage

Dim source As PdfFormattedParagraph

Dim instance As New PdfFormattedParagraph(source)
public PdfFormattedParagraph(
   PdfFormattedParagraph source
)
public:
PdfFormattedParagraph(
   PdfFormattedParagraph^ source
)

Parameters

source
Source paragraph.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfFormattedParagraph Class Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraph Class

For a list of all members of this type, see PdfFormattedParagraph members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfFormattedParagraph Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


ToString Method (PdfFormattedParagraph)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfFormattedParagraph
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


%%PageItemTitle%% $$Properties$$

PdfFormattedParagraph Class Properties

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraph Class

For a list of all members of this type, see PdfFormattedParagraph members.

Public Properties
 | Name | Description
Public Property | Blocks | Gets the list of formatted blocks that compose this paragraph.
Public Property | Bullet | Gets or sets the bullet text.
Public Property | FirstLineIndent | Gets or sets the indentation of the first paragraph line.
Public Property | HorizontalAlign | Gets or sets the horizontal align.
Public Property | LeftIndentation | Gets or sets the left indentation.
Public Property | LineSpacing | Gets or sets the line spacing in points.
Public Property | LineSpacingMode | Gets or sets the line spacing for the paragraph.
Public Property | RightIndentation | Gets or sets the right indentation.
Public Property | SpacingAfter | Gets or sets the spacing after the paragraph.
Public Property | SpacingBefore | Gets or sets the spacing before the paragraph.
Top
See Also

Reference

PdfFormattedParagraph Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


Blocks Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : Blocks Property
Gets the list of formatted blocks that compose this paragraph.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Blocks As PdfFormattedBlockCollection
'Usage

Dim instance As PdfFormattedParagraph
Dim value As PdfFormattedBlockCollection

value = instance.Blocks
public PdfFormattedBlockCollection Blocks {get;}
public:
property PdfFormattedBlockCollection^ Blocks {
   PdfFormattedBlockCollection^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


Bullet Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : Bullet Property
Gets or sets the bullet text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Bullet As PdfFormattedBlock
'Usage

Dim instance As PdfFormattedParagraph
Dim value As PdfFormattedBlock

instance.Bullet = value

value = instance.Bullet
public PdfFormattedBlock Bullet {get; set;}
public:
property PdfFormattedBlock^ Bullet {
   PdfFormattedBlock^ get();
   void set (    PdfFormattedBlock^ value);
}

Property Value

The text to be used as bullet for the paragraph.
Remarks
If this property is set to a PdfFormattedBlock object then the paragraph is considered to be part of a bulleted list.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


FirstLineIndent Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : FirstLineIndent Property
Gets or sets the indentation of the first paragraph line.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FirstLineIndent As Double
'Usage

Dim instance As PdfFormattedParagraph
Dim value As Double

instance.FirstLineIndent = value

value = instance.FirstLineIndent
public double FirstLineIndent {get; set;}
public:
property double FirstLineIndent {
   double get();
   void set (    double value);
}

Property Value

Value in points to indent the first line of the paragraph. If negative then it is left hanging indent.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


HorizontalAlign Property (PdfFormattedParagraph)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : HorizontalAlign Property
Gets or sets the horizontal align.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalAlign As PdfStringHorizontalAlign
'Usage

Dim instance As PdfFormattedParagraph
Dim value As PdfStringHorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
public PdfStringHorizontalAlign HorizontalAlign {get; set;}
public:
property PdfStringHorizontalAlign HorizontalAlign {
   PdfStringHorizontalAlign get();
   void set (    PdfStringHorizontalAlign value);
}

Property Value

The alignment of paragraph content on horizontal.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


LeftIndentation Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : LeftIndentation Property
Gets or sets the left indentation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LeftIndentation As Double
'Usage

Dim instance As PdfFormattedParagraph
Dim value As Double

instance.LeftIndentation = value

value = instance.LeftIndentation
public double LeftIndentation {get; set;}
public:
property double LeftIndentation {
   double get();
   void set (    double value);
}

Property Value

Indentantion of the left side of the paragraph relative to the left margin of the drawing box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


LineSpacing Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : LineSpacing Property
Gets or sets the line spacing in points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineSpacing As Double
'Usage

Dim instance As PdfFormattedParagraph
Dim value As Double

instance.LineSpacing = value

value = instance.LineSpacing
public double LineSpacing {get; set;}
public:
property double LineSpacing {
   double get();
   void set (    double value);
}

Property Value

The line spacing value, depends on the LineSpacingMode property.
Remarks
When the LineSpacingMode property is set to PdfFormattedParagraphLineSpacing.Exact the value of the line spacing is specified in this property.
When the LineSpacingMode property is set to PdfFormattedParagraphLineSpacing.Multiple the value of the line spacing is computed by multiplying the current line height with the value specified in this property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


LineSpacingMode Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : LineSpacingMode Property
Gets or sets the line spacing for the paragraph.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineSpacingMode As PdfFormattedParagraphLineSpacing
'Usage

Dim instance As PdfFormattedParagraph
Dim value As PdfFormattedParagraphLineSpacing

instance.LineSpacingMode = value

value = instance.LineSpacingMode
public PdfFormattedParagraphLineSpacing LineSpacingMode {get; set;}
public:
property PdfFormattedParagraphLineSpacing LineSpacingMode {
   PdfFormattedParagraphLineSpacing get();
   void set (    PdfFormattedParagraphLineSpacing value);
}

Property Value

The line spacing for the paragraph.
Remarks
When this property is set to PdfFormattedParagraphLineSpacing.Exact the value of the line spacing is specified in LineSpacing property.
When this property is set to PdfFormattedParagraphLineSpacing.Multiple the value of the line spacing is computed by multiplying the current line height with the value specified in LineSpacing property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


RightIndentation Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : RightIndentation Property
Gets or sets the right indentation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RightIndentation As Double
'Usage

Dim instance As PdfFormattedParagraph
Dim value As Double

instance.RightIndentation = value

value = instance.RightIndentation
public double RightIndentation {get; set;}
public:
property double RightIndentation {
   double get();
   void set (    double value);
}

Property Value

Indentantion of the right side of the paragraph relative to the right margin of the drawing box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


SpacingAfter Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : SpacingAfter Property
Gets or sets the spacing after the paragraph.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SpacingAfter As Double
'Usage

Dim instance As PdfFormattedParagraph
Dim value As Double

instance.SpacingAfter = value

value = instance.SpacingAfter
public double SpacingAfter {get; set;}
public:
property double SpacingAfter {
   double get();
   void set (    double value);
}

Property Value

The space in points below the paragraph.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


SpacingBefore Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraph Class : SpacingBefore Property
Gets or sets the spacing before the paragraph.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SpacingBefore As Double
'Usage

Dim instance As PdfFormattedParagraph
Dim value As Double

instance.SpacingBefore = value

value = instance.SpacingBefore
public double SpacingBefore {get; set;}
public:
property double SpacingBefore {
   double get();
   void set (    double value);
}

Property Value

The space in points above the paragraph content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraph Class
PdfFormattedParagraph Members


%%PageItemTitle%%

PdfFormattedParagraphCollection Class
Members

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraphCollection Class
Defines a collection of formatted paragraphs.
Object Model
PdfFormattedParagraphCollection ClassPdfFormattedParagraph Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFormattedParagraphCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfFormattedParagraph)
'Usage

Dim instance As PdfFormattedParagraphCollection
public class PdfFormattedParagraphCollection : System.Collections.ObjectModel.Collection<PdfFormattedParagraph>
public ref class PdfFormattedParagraphCollection : public System.Collections.ObjectModel.Collection<PdfFormattedParagraph>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedParagraphCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraphCollection Members
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Members$$

PdfFormattedParagraphCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraphCollection Class

The following tables list the members exposed by PdfFormattedParagraphCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates a new paragraph with the specified content and adds it to the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Top
See Also

Reference

PdfFormattedParagraphCollection Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Methods$$

PdfFormattedParagraphCollection Class Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraphCollection Class

For a list of all members of this type, see PdfFormattedParagraphCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Creates a new paragraph with the specified content and adds it to the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Top
See Also

Reference

PdfFormattedParagraphCollection Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


Add Method (PdfFormattedParagraphCollection)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraphCollection Class : Add Method
Creates a new paragraph with the specified content and adds it to the collection.
Overload List
Overload | Description
Add(String) | Creates a new paragraph with the specified content and adds it to the collection.
Add(PdfFormattedBlock[]) | Creates a new paragraph with the specified content and adds it to the collection.
Add(PdfFormattedParagraph) | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraphCollection Class
PdfFormattedParagraphCollection Members


Add(String) Method

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraphCollection Class > Add Method : Add(String) Method
Paragraph content.
Creates a new paragraph with the specified content and adds it to the collection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Add( _
   ByVal content As String _
) As PdfFormattedParagraph
'Usage

Dim instance As PdfFormattedParagraphCollection
Dim content As String
Dim value As PdfFormattedParagraph

value = instance.Add(content)
public PdfFormattedParagraph Add(
   string content
)
public:
PdfFormattedParagraph^ Add(
   String^ content
)

Parameters

content
Paragraph content.

Return Value

The new paragraph.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraphCollection Class
PdfFormattedParagraphCollection Members
Overload List


Add(PdfFormattedBlock[]) Method

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedParagraphCollection Class > Add Method : Add(PdfFormattedBlock[]) Method
Paragraph content.
Creates a new paragraph with the specified content and adds it to the collection.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Function Add( _
   ByVal ParamArray blocks() As PdfFormattedBlock _
) As PdfFormattedParagraph
'Usage

Dim instance As PdfFormattedParagraphCollection
Dim blocks() As PdfFormattedBlock
Dim value As PdfFormattedParagraph

value = instance.Add(blocks)
public PdfFormattedParagraph Add(
   params PdfFormattedBlock[] blocks
)
public:
PdfFormattedParagraph^ Add(
   ... array<PdfFormattedBlock^>^ blocks
)

Parameters

blocks
Paragraph content.

Return Value

The new paragraph.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedParagraphCollection Class
PdfFormattedParagraphCollection Members
Overload List


%%PageItemTitle%%

PdfFormattedTextBlock Class
Members

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedTextBlock Class
Defines a formatted block of text.
Object Model
PdfFormattedTextBlock ClassPdfAction ClassPdfBrush ClassPdfFont ClassPdfBrush Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFormattedTextBlock
   Inherits PdfFormattedBlock
'Usage

Dim instance As PdfFormattedTextBlock
public class PdfFormattedTextBlock : PdfFormattedBlock
public ref class PdfFormattedTextBlock : public PdfFormattedBlock
Remarks
All text in the block shares the same formatting attributes.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedBlock
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedTextBlock

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Members
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Members$$

PdfFormattedTextBlock Class Members
Properties Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedTextBlock Class

The following tables list the members exposed by PdfFormattedTextBlock.

Public Constructors
 | Name | Description
Public Constructor | PdfFormattedTextBlock Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action.
Public Property | BackgroundColor | Gets or sets the background color.
Public Property | Font | Gets or sets the font.
Public Property | Subscript | Gets the list of text blocks that are used as subscript for this block.
Public Property | Superscript | Gets the list of text blocks that are used as superscript for this block.
Public Property | Text | Gets or sets the text.
Public Property | TextColor | Gets or sets the text color.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfFormattedTextBlock Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%%

PdfFormattedTextBlock Constructor

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : PdfFormattedTextBlock Constructor
Overload List
Overload | Description
PdfFormattedTextBlock Constructor() | Initializes a new PdfFormattedTextBlock object.
PdfFormattedTextBlock Constructor(String) | Initializes a new PdfFormattedTextBlock object.
PdfFormattedTextBlock Constructor(String,PdfFont) | Initializes a new PdfFormattedTextBlock object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


%%PageItemTitle%%

PdfFormattedTextBlock Constructor()

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class > PdfFormattedTextBlock Constructor : PdfFormattedTextBlock Constructor()
Initializes a new PdfFormattedTextBlock object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfFormattedTextBlock()
public PdfFormattedTextBlock()
public:
PdfFormattedTextBlock();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members
Overload List


%%PageItemTitle%%

PdfFormattedTextBlock Constructor(String)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class > PdfFormattedTextBlock Constructor : PdfFormattedTextBlock Constructor(String)
Initial text.
Initializes a new PdfFormattedTextBlock object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As String _
)
'Usage

Dim text As String

Dim instance As New PdfFormattedTextBlock(text)
public PdfFormattedTextBlock(
   string text
)
public:
PdfFormattedTextBlock(
   String^ text
)

Parameters

text
Initial text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members
Overload List


%%PageItemTitle%%

PdfFormattedTextBlock Constructor(String,PdfFont)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class > PdfFormattedTextBlock Constructor : PdfFormattedTextBlock Constructor(String,PdfFont)
Initial text.
For used for displaying the text.
Initializes a new PdfFormattedTextBlock object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal font As PdfFont _
)
'Usage

Dim text As String
Dim font As PdfFont

Dim instance As New PdfFormattedTextBlock(text, font)
public PdfFormattedTextBlock(
   string text,
   PdfFont font
)
public:
PdfFormattedTextBlock(
   String^ text,
   PdfFont^ font
)

Parameters

text
Initial text.
font
For used for displaying the text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfFormattedTextBlock Class Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedTextBlock Class

For a list of all members of this type, see PdfFormattedTextBlock members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PdfFormattedTextBlock Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


ToString Method (PdfFormattedTextBlock)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PdfFormattedTextBlock
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

A string that represents the current object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


%%PageItemTitle%% $$Properties$$

PdfFormattedTextBlock Class Properties

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedTextBlock Class

For a list of all members of this type, see PdfFormattedTextBlock members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action.
Public Property | BackgroundColor | Gets or sets the background color.
Public Property | Font | Gets or sets the font.
Public Property | Subscript | Gets the list of text blocks that are used as subscript for this block.
Public Property | Superscript | Gets the list of text blocks that are used as superscript for this block.
Public Property | Text | Gets or sets the text.
Public Property | TextColor | Gets or sets the text color.
Top
See Also

Reference

PdfFormattedTextBlock Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


Action Property (PdfFormattedTextBlock)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : Action Property
Gets or sets the action.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Action As PdfAction
'Usage

Dim instance As PdfFormattedTextBlock
Dim value As PdfAction

instance.Action = value

value = instance.Action
public PdfAction Action {get; set;}
public:
property PdfAction^ Action {
   PdfAction^ get();
   void set (    PdfAction^ value);
}

Property Value

The action to be executed when the block is clicked.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


BackgroundColor Property (PdfFormattedTextBlock)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : BackgroundColor Property
Gets or sets the background color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BackgroundColor As PdfBrush
'Usage

Dim instance As PdfFormattedTextBlock
Dim value As PdfBrush

instance.BackgroundColor = value

value = instance.BackgroundColor
public PdfBrush BackgroundColor {get; set;}
public:
property PdfBrush^ BackgroundColor {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

The brush used to fill the text background.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


Font Property (PdfFormattedTextBlock)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : Font Property
Gets or sets the font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As PdfFont
'Usage

Dim instance As PdfFormattedTextBlock
Dim value As PdfFont

instance.Font = value

value = instance.Font
public PdfFont Font {get; set;}
public:
property PdfFont^ Font {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

The font used to display the text in the block.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


Subscript Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : Subscript Property
Gets the list of text blocks that are used as subscript for this block.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Subscript As List(Of PdfFormattedTextBlock)
'Usage

Dim instance As PdfFormattedTextBlock
Dim value As List(Of PdfFormattedTextBlock)

value = instance.Subscript
public List<PdfFormattedTextBlock> Subscript {get;}
public:
property List<PdfFormattedTextBlock^>^ Subscript {
   List<PdfFormattedTextBlock^>^ get();
}

Property Value

List of subscript blocks for this block.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


Superscript Property

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : Superscript Property
Gets the list of text blocks that are used as superscript for this block.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Superscript As List(Of PdfFormattedTextBlock)
'Usage

Dim instance As PdfFormattedTextBlock
Dim value As List(Of PdfFormattedTextBlock)

value = instance.Superscript
public List<PdfFormattedTextBlock> Superscript {get;}
public:
property List<PdfFormattedTextBlock^>^ Superscript {
   List<PdfFormattedTextBlock^>^ get();
}

Property Value

List of superscript blocks for this block.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


Text Property (PdfFormattedTextBlock)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : Text Property
Gets or sets the text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Text As String
'Usage

Dim instance As PdfFormattedTextBlock
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

The text content of the block.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


TextColor Property (PdfFormattedTextBlock)

Xfinium.Pdf.Graphics.FormattedContent Namespace > PdfFormattedTextBlock Class : TextColor Property
Gets or sets the text color.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextColor As PdfBrush
'Usage

Dim instance As PdfFormattedTextBlock
Dim value As PdfBrush

instance.TextColor = value

value = instance.TextColor
public PdfBrush TextColor {get; set;}
public:
property PdfBrush^ TextColor {
   PdfBrush^ get();
   void set (    PdfBrush^ value);
}

Property Value

The brush used to draw the text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormattedTextBlock Class
PdfFormattedTextBlock Members


%%PageItemTitle%%

PdfFormattedParagraphLineSpacing Enumeration

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraphLineSpacing Enumeration
Specifies the available line spacing modes for paragraph lines.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFormattedParagraphLineSpacing
   Inherits System.Enum
'Usage

Dim instance As PdfFormattedParagraphLineSpacing
public enum PdfFormattedParagraphLineSpacing : System.Enum
public enum class PdfFormattedParagraphLineSpacing : public System.Enum
Members
Member | Description
Exact | Fixed line spacing.
Multiple | The space between lines is the current line height multiplied by a specific factor.
Single | Default lines spacing.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.FormattedContent.PdfFormattedParagraphLineSpacing

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics.FormattedContent Namespace


Xfinium.Pdf.Graphics.Operators Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfBeginImageDataOperator | Defines the ID (begin inline image data) content stream operator.
Class | PdfBeginMarkedContentOperator | Defines the BMC (begin marked content) content stream operator.
Class | PdfBeginMarkedContentPropertyListOperator | Defines the BDC (begin marked content with properties list) content stream operator.
Class | PdfCCurveToOperator | Defines the c (curve to) content stream operator.
Class | PdfConcatenateMatrixOperator | Defines the cm (concatenate matrix) content stream operator.
Class | PdfContentStreamOperator | Defines the base class for PDF content stream operators.
Class | PdfContentStreamOperatorCollection | Defines a collection of content stream operators.
Class | PdfDefineMarkedContentOperator | Defines the MP (define marked-content point) content stream operator.
Class | PdfDefineMarkedContentPropertyListOperator | Defines the DP (define marked-content point with property list) content stream operator.
Class | PdfDisplayFormXObjectOperator | Defines the Do (display form XObject) content stream operator.
Class | PdfDisplayImageXObjectOperator | Defines the Do (display image XObject) content stream operator.
Class | PdfLineToOperator | Defines the l (line to) content stream operator.
Class | PdfMoveTextPositionOperator | Defines the Td (move text position) content stream operator.
Class | PdfMoveTextPositionSetLeadingOperator | Defines the TD (move text position and set leading) content stream operator.
Class | PdfMoveToOperator | Defines the m (move to) content stream operator.
Class | PdfRectangleOperator | Defines the re (rectangle) content stream operator.
Class | PdfSetCharacterSpacingOperator | Defines the Tc (set character spacing) content stream operator.
Class | PdfSetCmykFillOperator | Defines the k (set CMYK level for fill operations) content stream operator.
Class | PdfSetCmykStrokeOperator | Defines the K (set CMYK level for stroke operations) content stream operator.
Class | PdfSetFillColorNOperator | Defines the scn (set fill color) content stream operator.
Class | PdfSetFillColorOperator | Defines the sc (set fill color) content stream operator.
Class | PdfSetFillColorSpaceOperator | Defines the cs (set fill colorspace) content stream operator.
Class | PdfSetFlatnessToleranceOperator | Defines the i (set flatness tolerance) content stream operator.
Class | PdfSetGraphicsStateOperator | Defines the gs (set graphics state) content stream operator.
Class | PdfSetGrayFillOperator | Defines the g (set gray level for fill operations) content stream operator.
Class | PdfSetGrayStrokeOperator | Defines the G (set gray level for stroke operations) content stream operator.
Class | PdfSetLineCapOperator | Defines the J (set line cap) content stream operator.
Class | PdfSetLineDashPatternOperator | Defines the d (set line dash) content stream operator.
Class | PdfSetLineJoinOperator | Defines the j (set line join) content stream operator.
Class | PdfSetLineWidthOperator | Defines the w (set line width) content stream operator.
Class | PdfSetMiterLimitOperator | Defines the M (set miter limit) content stream operator.
Class | PdfSetRenderingIntentOperator | Defines the ri (set rendering intent) content stream operator.
Class | PdfSetRgbFillOperator | Defines the rg (set RGB level for fill operations) content stream operator.
Class | PdfSetRgbStrokeOperator | Defines the RG (set RGB level for stroke operations) content stream operator.
Class | PdfSetShadingOperator | Defines the sh (set shading) content stream operator.
Class | PdfSetStrokeColorNOperator | Defines the SCN (set stroke color) content stream operator.
Class | PdfSetStrokeColorOperator | Defines the SC (set stroke color) content stream operator.
Class | PdfSetStrokeColorSpaceOperator | Defines the CS (set stroke colorspace) content stream operator.
Class | PdfSetTextFontAndSizeOperator | Defines the Tf (set font and size) content stream operator.
Class | PdfSetTextHorizontalScalingOperator | Defines the Tz (set text horizontal scaling) content stream operator.
Class | PdfSetTextLeadingOperator | Defines the TL (set text leading) content stream operator.
Class | PdfSetTextMatrixOperator | Defines the Tm (set text matrix) content stream operator.
Class | PdfSetTextRenderingOperator | Defines the Tr (set text rendering mode) content stream operator.
Class | PdfSetTextRiseOperator | Defines the Ts (set text rise) content stream operator.
Class | PdfSetType3GlyphWidthAndBoundingBoxOperator | Defines the d1 (set glyph width and bounding box in Type 3 font) content stream operator.
Class | PdfSetType3GlyphWidthOperator | Defines the d0 (set glyph width in type 3 font) content stream operator.
Class | PdfSetWordSpacingOperator | Defines the Tw (set word spacing) content stream operator.
Class | PdfShowText2Operator | Defines the TJ (show text with position) content stream operator.
Class | PdfShowText3Operator | Defines the ' (move to next line and show text) content stream operator.
Class | PdfShowText4Operator | Defines the " (move to the next line and show a text string, using word spacing and character spacing) content stream operator.
Class | PdfShowTextOperator | Defines the Tj (show text) content stream operator.
Class | PdfVCurveToOperator | Defines the v (curve to) content stream operator.
Class | PdfYCurveToOperator | Defines the y (curve to) content stream operator.
Enumerations
 | Enumeration | Description
Enumeration | PdfContentStreamOperatorType | Supported operators in a PDF content stream.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Graphics.Operators Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperatorCollection
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginImageDataOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginMarkedContentOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginMarkedContentPropertyListOperator
Xfinium.Pdf.Graphics.Operators.PdfCCurveToOperator
Xfinium.Pdf.Graphics.Operators.PdfConcatenateMatrixOperator
Xfinium.Pdf.Graphics.Operators.PdfDefineMarkedContentOperator
Xfinium.Pdf.Graphics.Operators.PdfDefineMarkedContentPropertyListOperator
Xfinium.Pdf.Graphics.Operators.PdfDisplayFormXObjectOperator
Xfinium.Pdf.Graphics.Operators.PdfDisplayImageXObjectOperator
Xfinium.Pdf.Graphics.Operators.PdfLineToOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveTextPositionOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveTextPositionSetLeadingOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveToOperator
Xfinium.Pdf.Graphics.Operators.PdfRectangleOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCharacterSpacingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCmykFillOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCmykStrokeOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorNOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorSpaceOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFlatnessToleranceOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGraphicsStateOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGrayFillOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGrayStrokeOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineCapOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineDashPatternOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineJoinOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineWidthOperator
Xfinium.Pdf.Graphics.Operators.PdfSetMiterLimitOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRenderingIntentOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRgbFillOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRgbStrokeOperator
Xfinium.Pdf.Graphics.Operators.PdfSetShadingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorNOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorSpaceOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextFontAndSizeOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextHorizontalScalingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextLeadingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextMatrixOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextRenderingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextRiseOperator
Xfinium.Pdf.Graphics.Operators.PdfSetType3GlyphWidthAndBoundingBoxOperator
Xfinium.Pdf.Graphics.Operators.PdfSetType3GlyphWidthOperator
Xfinium.Pdf.Graphics.Operators.PdfSetWordSpacingOperator
Xfinium.Pdf.Graphics.Operators.PdfShowText2Operator
Xfinium.Pdf.Graphics.Operators.PdfShowText3Operator
Xfinium.Pdf.Graphics.Operators.PdfShowText4Operator
Xfinium.Pdf.Graphics.Operators.PdfShowTextOperator
Xfinium.Pdf.Graphics.Operators.PdfVCurveToOperator
Xfinium.Pdf.Graphics.Operators.PdfYCurveToOperator
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfBeginImageDataOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginImageDataOperator Class
Defines the ID (begin inline image data) content stream operator.
Object Model
PdfBeginImageDataOperator ClassPdfCosDictionary Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBeginImageDataOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfBeginImageDataOperator
public class PdfBeginImageDataOperator : PdfContentStreamOperator
public ref class PdfBeginImageDataOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginImageDataOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginImageDataOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfBeginImageDataOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginImageDataOperator Class

The following tables list the members exposed by PdfBeginImageDataOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfBeginImageDataOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | ImageData | Gets or sets the raw image data.
Public Property | ImageDictionary | Gets or sets the image dictionary.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfBeginImageDataOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfBeginImageDataOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginImageDataOperator Class : PdfBeginImageDataOperator Constructor
Overload List
Overload | Description
PdfBeginImageDataOperator Constructor() | Initializes a new PdfBeginImageDataOperator object.
PdfBeginImageDataOperator Constructor(PdfCosDictionary,Byte[]) | Initializes a new PdfBeginImageDataOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginImageDataOperator Class
PdfBeginImageDataOperator Members


%%PageItemTitle%%

PdfBeginImageDataOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginImageDataOperator Class > PdfBeginImageDataOperator Constructor : PdfBeginImageDataOperator Constructor()
Initializes a new PdfBeginImageDataOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfBeginImageDataOperator()
public PdfBeginImageDataOperator()
public:
PdfBeginImageDataOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginImageDataOperator Class
PdfBeginImageDataOperator Members
Overload List


%%PageItemTitle%%

PdfBeginImageDataOperator Constructor(PdfCosDictionary,Byte[])

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginImageDataOperator Class > PdfBeginImageDataOperator Constructor : PdfBeginImageDataOperator Constructor(PdfCosDictionary,Byte[])
The image ID in the /Resources dictionary.
The raw image data.
Initializes a new PdfBeginImageDataOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imageDictionary As PdfCosDictionary, _
   ByVal imageData() As Byte _
)
'Usage

Dim imageDictionary As PdfCosDictionary
Dim imageData() As Byte

Dim instance As New PdfBeginImageDataOperator(imageDictionary, imageData)
public PdfBeginImageDataOperator(
   PdfCosDictionary imageDictionary,
   byte[] imageData
)
public:
PdfBeginImageDataOperator(
   PdfCosDictionary^ imageDictionary,
   array<byte>^ imageData
)

Parameters

imageDictionary
The image ID in the /Resources dictionary.
imageData
The raw image data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginImageDataOperator Class
PdfBeginImageDataOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfBeginImageDataOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginImageDataOperator Class

For a list of all members of this type, see PdfBeginImageDataOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | ImageData | Gets or sets the raw image data.
Public Property | ImageDictionary | Gets or sets the image dictionary.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfBeginImageDataOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


ImageData Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginImageDataOperator Class : ImageData Property
Gets or sets the raw image data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageData As Byte()
'Usage

Dim instance As PdfBeginImageDataOperator
Dim value() As Byte

instance.ImageData = value

value = instance.ImageData
public byte[] ImageData {get; set;}
public:
property array<byte>^ ImageData {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The raw image data as it appears in the page content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginImageDataOperator Class
PdfBeginImageDataOperator Members


ImageDictionary Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginImageDataOperator Class : ImageDictionary Property
Gets or sets the image dictionary.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageDictionary As PdfCosDictionary
'Usage

Dim instance As PdfBeginImageDataOperator
Dim value As PdfCosDictionary

instance.ImageDictionary = value

value = instance.ImageDictionary
public PdfCosDictionary ImageDictionary {get; set;}
public:
property PdfCosDictionary^ ImageDictionary {
   PdfCosDictionary^ get();
   void set (    PdfCosDictionary^ value);
}

Property Value

The inline image dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginImageDataOperator Class
PdfBeginImageDataOperator Members


%%PageItemTitle%%

PdfBeginMarkedContentOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginMarkedContentOperator Class
Defines the BMC (begin marked content) content stream operator.
Object Model
PdfBeginMarkedContentOperator ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBeginMarkedContentOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfBeginMarkedContentOperator
public class PdfBeginMarkedContentOperator : PdfContentStreamOperator
public ref class PdfBeginMarkedContentOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginMarkedContentOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfBeginMarkedContentOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginMarkedContentOperator Class

The following tables list the members exposed by PdfBeginMarkedContentOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfBeginMarkedContentOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Tag | Gets or sets the tag.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfBeginMarkedContentOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfBeginMarkedContentOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentOperator Class : PdfBeginMarkedContentOperator Constructor
Overload List
Overload | Description
PdfBeginMarkedContentOperator Constructor() | Initializes a new PdfBeginMarkedContentOperator object.
PdfBeginMarkedContentOperator Constructor(PdfCosName) | Initializes a new PdfBeginMarkedContentOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentOperator Class
PdfBeginMarkedContentOperator Members


%%PageItemTitle%%

PdfBeginMarkedContentOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentOperator Class > PdfBeginMarkedContentOperator Constructor : PdfBeginMarkedContentOperator Constructor()
Initializes a new PdfBeginMarkedContentOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfBeginMarkedContentOperator()
public PdfBeginMarkedContentOperator()
public:
PdfBeginMarkedContentOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentOperator Class
PdfBeginMarkedContentOperator Members
Overload List


%%PageItemTitle%%

PdfBeginMarkedContentOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentOperator Class > PdfBeginMarkedContentOperator Constructor : PdfBeginMarkedContentOperator Constructor(PdfCosName)
The sequence tag.
Initializes a new PdfBeginMarkedContentOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As PdfCosName _
)
'Usage

Dim tag As PdfCosName

Dim instance As New PdfBeginMarkedContentOperator(tag)
public PdfBeginMarkedContentOperator(
   PdfCosName tag
)
public:
PdfBeginMarkedContentOperator(
   PdfCosName^ tag
)

Parameters

tag
The sequence tag.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentOperator Class
PdfBeginMarkedContentOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfBeginMarkedContentOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginMarkedContentOperator Class

For a list of all members of this type, see PdfBeginMarkedContentOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Tag | Gets or sets the tag.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfBeginMarkedContentOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Tag Property (PdfBeginMarkedContentOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentOperator Class : Tag Property
Gets or sets the tag.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As PdfCosName
'Usage

Dim instance As PdfBeginMarkedContentOperator
Dim value As PdfCosName

instance.Tag = value

value = instance.Tag
public PdfCosName Tag {get; set;}
public:
property PdfCosName^ Tag {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

A name object indicating the role or significance of the marked content sequence.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentOperator Class
PdfBeginMarkedContentOperator Members


%%PageItemTitle%%

PdfBeginMarkedContentPropertyListOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginMarkedContentPropertyListOperator Class
Defines the BDC (begin marked content with properties list) content stream operator.
Object Model
PdfBeginMarkedContentPropertyListOperator ClassPdfCosObject ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfBeginMarkedContentPropertyListOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfBeginMarkedContentPropertyListOperator
public class PdfBeginMarkedContentPropertyListOperator : PdfContentStreamOperator
public ref class PdfBeginMarkedContentPropertyListOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginMarkedContentPropertyListOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentPropertyListOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfBeginMarkedContentPropertyListOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginMarkedContentPropertyListOperator Class

The following tables list the members exposed by PdfBeginMarkedContentPropertyListOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfBeginMarkedContentPropertyListOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Properties | Gets or sets the properties.
Public Property | Tag | Gets or sets the tag.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfBeginMarkedContentPropertyListOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfBeginMarkedContentPropertyListOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentPropertyListOperator Class : PdfBeginMarkedContentPropertyListOperator Constructor
Overload List
Overload | Description
PdfBeginMarkedContentPropertyListOperator Constructor() | Initializes a new PdfBeginMarkedContentPropertyListOperator object.
PdfBeginMarkedContentPropertyListOperator Constructor(PdfCosName,PdfCosObject) | Initializes a new PdfBeginMarkedContentPropertyListOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentPropertyListOperator Class
PdfBeginMarkedContentPropertyListOperator Members


%%PageItemTitle%%

PdfBeginMarkedContentPropertyListOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentPropertyListOperator Class > PdfBeginMarkedContentPropertyListOperator Constructor : PdfBeginMarkedContentPropertyListOperator Constructor()
Initializes a new PdfBeginMarkedContentPropertyListOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfBeginMarkedContentPropertyListOperator()
public PdfBeginMarkedContentPropertyListOperator()
public:
PdfBeginMarkedContentPropertyListOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentPropertyListOperator Class
PdfBeginMarkedContentPropertyListOperator Members
Overload List


%%PageItemTitle%%

PdfBeginMarkedContentPropertyListOperator Constructor(PdfCosName,PdfCosObject)

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentPropertyListOperator Class > PdfBeginMarkedContentPropertyListOperator Constructor : PdfBeginMarkedContentPropertyListOperator Constructor(PdfCosName,PdfCosObject)
The sequence tag.
Properties ID or an inline dictionary.
Initializes a new PdfBeginMarkedContentPropertyListOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As PdfCosName, _
   ByVal properties As PdfCosObject _
)
'Usage

Dim tag As PdfCosName
Dim properties As PdfCosObject

Dim instance As New PdfBeginMarkedContentPropertyListOperator(tag, properties)
public PdfBeginMarkedContentPropertyListOperator(
   PdfCosName tag,
   PdfCosObject properties
)
public:
PdfBeginMarkedContentPropertyListOperator(
   PdfCosName^ tag,
   PdfCosObject^ properties
)

Parameters

tag
The sequence tag.
properties
Properties ID or an inline dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentPropertyListOperator Class
PdfBeginMarkedContentPropertyListOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfBeginMarkedContentPropertyListOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfBeginMarkedContentPropertyListOperator Class

For a list of all members of this type, see PdfBeginMarkedContentPropertyListOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Properties | Gets or sets the properties.
Public Property | Tag | Gets or sets the tag.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfBeginMarkedContentPropertyListOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Properties Property (PdfBeginMarkedContentPropertyListOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentPropertyListOperator Class : Properties Property
Gets or sets the properties.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Properties As PdfCosObject
'Usage

Dim instance As PdfBeginMarkedContentPropertyListOperator
Dim value As PdfCosObject

instance.Properties = value

value = instance.Properties
public PdfCosObject Properties {get; set;}
public:
property PdfCosObject^ Properties {
   PdfCosObject^ get();
   void set (    PdfCosObject^ value);
}

Property Value

A name object used as key in the /Resources/Properties dictionary or an inline dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentPropertyListOperator Class
PdfBeginMarkedContentPropertyListOperator Members


Tag Property (PdfBeginMarkedContentPropertyListOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfBeginMarkedContentPropertyListOperator Class : Tag Property
Gets or sets the tag.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As PdfCosName
'Usage

Dim instance As PdfBeginMarkedContentPropertyListOperator
Dim value As PdfCosName

instance.Tag = value

value = instance.Tag
public PdfCosName Tag {get; set;}
public:
property PdfCosName^ Tag {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

A name object indicating the role or significance of the marked content sequence.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfBeginMarkedContentPropertyListOperator Class
PdfBeginMarkedContentPropertyListOperator Members


%%PageItemTitle%%

PdfCCurveToOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfCCurveToOperator Class
Defines the c (curve to) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfCCurveToOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfCCurveToOperator
public class PdfCCurveToOperator : PdfContentStreamOperator
public ref class PdfCCurveToOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfCCurveToOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfCCurveToOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfCCurveToOperator Class

The following tables list the members exposed by PdfCCurveToOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfCCurveToOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X1 | Gets or sets the X coordinate of the first control point.
Public Property | X2 | Gets or sets the X coordinate of the second control point.
Public Property | X3 | Gets or sets the X coordinate of the third control point.
Public Property | Y1 | Gets or sets the Y coordinate of the first control point.
Public Property | Y2 | Gets or sets the Y coordinate of the second control point.
Public Property | Y3 | Gets or sets the Y coordinate of the third control point.
Top
See Also

Reference

PdfCCurveToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfCCurveToOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class : PdfCCurveToOperator Constructor
Overload List
Overload | Description
PdfCCurveToOperator Constructor() | Initializes a new PdfCCurveToOperator object.
PdfCCurveToOperator Constructor(Double,Double,Double,Double,Double,Double) | Initializes a new PdfCCurveToOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members


%%PageItemTitle%%

PdfCCurveToOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class > PdfCCurveToOperator Constructor : PdfCCurveToOperator Constructor()
Initializes a new PdfCCurveToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfCCurveToOperator()
public PdfCCurveToOperator()
public:
PdfCCurveToOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members
Overload List


%%PageItemTitle%%

PdfCCurveToOperator Constructor(Double,Double,Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class > PdfCCurveToOperator Constructor : PdfCCurveToOperator Constructor(Double,Double,Double,Double,Double,Double)
The X coordinate of the first control point.
The Y coordinate of the first control point.
The X coordinate of the second control point.
The Y coordinate of the second control point.
The X coordinate of the third control point.
The Y coordinate of the third control point.
Initializes a new PdfCCurveToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
'Usage

Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double

Dim instance As New PdfCCurveToOperator(x1, y1, x2, y2, x3, y3)
public PdfCCurveToOperator(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)
public:
PdfCCurveToOperator(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)

Parameters

x1
The X coordinate of the first control point.
y1
The Y coordinate of the first control point.
x2
The X coordinate of the second control point.
y2
The Y coordinate of the second control point.
x3
The X coordinate of the third control point.
y3
The Y coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfCCurveToOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfCCurveToOperator Class

For a list of all members of this type, see PdfCCurveToOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X1 | Gets or sets the X coordinate of the first control point.
Public Property | X2 | Gets or sets the X coordinate of the second control point.
Public Property | X3 | Gets or sets the X coordinate of the third control point.
Public Property | Y1 | Gets or sets the Y coordinate of the first control point.
Public Property | Y2 | Gets or sets the Y coordinate of the second control point.
Public Property | Y3 | Gets or sets the Y coordinate of the third control point.
Top
See Also

Reference

PdfCCurveToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


X1 Property (PdfCCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class : X1 Property
Gets or sets the X coordinate of the first control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X1 As Double
'Usage

Dim instance As PdfCCurveToOperator
Dim value As Double

instance.X1 = value

value = instance.X1
public double X1 {get; set;}
public:
property double X1 {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the first control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members


X2 Property (PdfCCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class : X2 Property
Gets or sets the X coordinate of the second control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X2 As Double
'Usage

Dim instance As PdfCCurveToOperator
Dim value As Double

instance.X2 = value

value = instance.X2
public double X2 {get; set;}
public:
property double X2 {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the second control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members


X3 Property (PdfCCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class : X3 Property
Gets or sets the X coordinate of the third control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X3 As Double
'Usage

Dim instance As PdfCCurveToOperator
Dim value As Double

instance.X3 = value

value = instance.X3
public double X3 {get; set;}
public:
property double X3 {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members


Y1 Property (PdfCCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class : Y1 Property
Gets or sets the Y coordinate of the first control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y1 As Double
'Usage

Dim instance As PdfCCurveToOperator
Dim value As Double

instance.Y1 = value

value = instance.Y1
public double Y1 {get; set;}
public:
property double Y1 {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the first control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members


Y2 Property (PdfCCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class : Y2 Property
Gets or sets the Y coordinate of the second control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y2 As Double
'Usage

Dim instance As PdfCCurveToOperator
Dim value As Double

instance.Y2 = value

value = instance.Y2
public double Y2 {get; set;}
public:
property double Y2 {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the second control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members


Y3 Property (PdfCCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfCCurveToOperator Class : Y3 Property
Gets or sets the Y coordinate of the third control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y3 As Double
'Usage

Dim instance As PdfCCurveToOperator
Dim value As Double

instance.Y3 = value

value = instance.Y3
public double Y3 {get; set;}
public:
property double Y3 {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCCurveToOperator Class
PdfCCurveToOperator Members


%%PageItemTitle%%

PdfConcatenateMatrixOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfConcatenateMatrixOperator Class
Defines the cm (concatenate matrix) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfConcatenateMatrixOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfConcatenateMatrixOperator
public class PdfConcatenateMatrixOperator : PdfContentStreamOperator
public ref class PdfConcatenateMatrixOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfConcatenateMatrixOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfConcatenateMatrixOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfConcatenateMatrixOperator Class

The following tables list the members exposed by PdfConcatenateMatrixOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfConcatenateMatrixOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | DX | Gets or sets the dx element of the transformation matrix.
Public Property | DY | Gets or sets the dy element of the transformation matrix.
Public Property | M11 | Gets or sets the m11 element of the transformation matrix.
Public Property | M12 | Gets or sets the m12 element of the transformation matrix.
Public Property | M21 | Gets or sets the m21 element of the transformation matrix.
Public Property | M22 | Gets or sets the m22 element of the transformation matrix.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfConcatenateMatrixOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfConcatenateMatrixOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class : PdfConcatenateMatrixOperator Constructor
Overload List
Overload | Description
PdfConcatenateMatrixOperator Constructor() | Initializes a new PdfConcatenateMatrixOperator object.
PdfConcatenateMatrixOperator Constructor(Double,Double,Double,Double,Double,Double) | Initializes a new PdfConcatenateMatrixOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members


%%PageItemTitle%%

PdfConcatenateMatrixOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class > PdfConcatenateMatrixOperator Constructor : PdfConcatenateMatrixOperator Constructor()
Initializes a new PdfConcatenateMatrixOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfConcatenateMatrixOperator()
public PdfConcatenateMatrixOperator()
public:
PdfConcatenateMatrixOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members
Overload List


%%PageItemTitle%%

PdfConcatenateMatrixOperator Constructor(Double,Double,Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class > PdfConcatenateMatrixOperator Constructor : PdfConcatenateMatrixOperator Constructor(Double,Double,Double,Double,Double,Double)
The m11 element of the transformation matrix.
The m12 element of the transformation matrix.
The m21 element of the transformation matrix.
The m22 element of the transformation matrix.
The dx element of the transformation matrix.
The dy element of the transformation matrix.
Initializes a new PdfConcatenateMatrixOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal m11 As Double, _
   ByVal m12 As Double, _
   ByVal m21 As Double, _
   ByVal m22 As Double, _
   ByVal dx As Double, _
   ByVal dy As Double _
)
'Usage

Dim m11 As Double
Dim m12 As Double
Dim m21 As Double
Dim m22 As Double
Dim dx As Double
Dim dy As Double

Dim instance As New PdfConcatenateMatrixOperator(m11, m12, m21, m22, dx, dy)
public PdfConcatenateMatrixOperator(
   double m11,
   double m12,
   double m21,
   double m22,
   double dx,
   double dy
)
public:
PdfConcatenateMatrixOperator(
   double m11,
   double m12,
   double m21,
   double m22,
   double dx,
   double dy
)

Parameters

m11
The m11 element of the transformation matrix.
m12
The m12 element of the transformation matrix.
m21
The m21 element of the transformation matrix.
m22
The m22 element of the transformation matrix.
dx
The dx element of the transformation matrix.
dy
The dy element of the transformation matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfConcatenateMatrixOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfConcatenateMatrixOperator Class

For a list of all members of this type, see PdfConcatenateMatrixOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | DX | Gets or sets the dx element of the transformation matrix.
Public Property | DY | Gets or sets the dy element of the transformation matrix.
Public Property | M11 | Gets or sets the m11 element of the transformation matrix.
Public Property | M12 | Gets or sets the m12 element of the transformation matrix.
Public Property | M21 | Gets or sets the m21 element of the transformation matrix.
Public Property | M22 | Gets or sets the m22 element of the transformation matrix.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfConcatenateMatrixOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


DX Property (PdfConcatenateMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class : DX Property
Gets or sets the dx element of the transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DX As Double
'Usage

Dim instance As PdfConcatenateMatrixOperator
Dim value As Double

instance.DX = value

value = instance.DX
public double DX {get; set;}
public:
property double DX {
   double get();
   void set (    double value);
}

Property Value

The dx element of the transformation matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members


DY Property (PdfConcatenateMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class : DY Property
Gets or sets the dy element of the transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DY As Double
'Usage

Dim instance As PdfConcatenateMatrixOperator
Dim value As Double

instance.DY = value

value = instance.DY
public double DY {get; set;}
public:
property double DY {
   double get();
   void set (    double value);
}

Property Value

The dy element of the transformation matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members


M11 Property (PdfConcatenateMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class : M11 Property
Gets or sets the m11 element of the transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M11 As Double
'Usage

Dim instance As PdfConcatenateMatrixOperator
Dim value As Double

instance.M11 = value

value = instance.M11
public double M11 {get; set;}
public:
property double M11 {
   double get();
   void set (    double value);
}

Property Value

The m11 element of the transformation matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members


M12 Property (PdfConcatenateMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class : M12 Property
Gets or sets the m12 element of the transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M12 As Double
'Usage

Dim instance As PdfConcatenateMatrixOperator
Dim value As Double

instance.M12 = value

value = instance.M12
public double M12 {get; set;}
public:
property double M12 {
   double get();
   void set (    double value);
}

Property Value

The m12 element of the transformation matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members


M21 Property (PdfConcatenateMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class : M21 Property
Gets or sets the m21 element of the transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M21 As Double
'Usage

Dim instance As PdfConcatenateMatrixOperator
Dim value As Double

instance.M21 = value

value = instance.M21
public double M21 {get; set;}
public:
property double M21 {
   double get();
   void set (    double value);
}

Property Value

The m21 element of the transformation matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members


M22 Property (PdfConcatenateMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfConcatenateMatrixOperator Class : M22 Property
Gets or sets the m22 element of the transformation matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M22 As Double
'Usage

Dim instance As PdfConcatenateMatrixOperator
Dim value As Double

instance.M22 = value

value = instance.M22
public double M22 {get; set;}
public:
property double M22 {
   double get();
   void set (    double value);
}

Property Value

Gets or sets the m22 element of the transformation matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConcatenateMatrixOperator Class
PdfConcatenateMatrixOperator Members


%%PageItemTitle%%

PdfContentStreamOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfContentStreamOperator Class
Defines the base class for PDF content stream operators.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfContentStreamOperator
'Usage

Dim instance As PdfContentStreamOperator
public class PdfContentStreamOperator
public ref class PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginImageDataOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginMarkedContentOperator
Xfinium.Pdf.Graphics.Operators.PdfBeginMarkedContentPropertyListOperator
Xfinium.Pdf.Graphics.Operators.PdfCCurveToOperator
Xfinium.Pdf.Graphics.Operators.PdfConcatenateMatrixOperator
Xfinium.Pdf.Graphics.Operators.PdfDefineMarkedContentOperator
Xfinium.Pdf.Graphics.Operators.PdfDefineMarkedContentPropertyListOperator
Xfinium.Pdf.Graphics.Operators.PdfDisplayFormXObjectOperator
Xfinium.Pdf.Graphics.Operators.PdfDisplayImageXObjectOperator
Xfinium.Pdf.Graphics.Operators.PdfLineToOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveTextPositionOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveTextPositionSetLeadingOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveToOperator
Xfinium.Pdf.Graphics.Operators.PdfRectangleOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCharacterSpacingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCmykFillOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCmykStrokeOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorNOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorSpaceOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFlatnessToleranceOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGraphicsStateOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGrayFillOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGrayStrokeOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineCapOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineDashPatternOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineJoinOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineWidthOperator
Xfinium.Pdf.Graphics.Operators.PdfSetMiterLimitOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRenderingIntentOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRgbFillOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRgbStrokeOperator
Xfinium.Pdf.Graphics.Operators.PdfSetShadingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorNOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorSpaceOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextFontAndSizeOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextHorizontalScalingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextLeadingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextMatrixOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextRenderingOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextRiseOperator
Xfinium.Pdf.Graphics.Operators.PdfSetType3GlyphWidthAndBoundingBoxOperator
Xfinium.Pdf.Graphics.Operators.PdfSetType3GlyphWidthOperator
Xfinium.Pdf.Graphics.Operators.PdfSetWordSpacingOperator
Xfinium.Pdf.Graphics.Operators.PdfShowText2Operator
Xfinium.Pdf.Graphics.Operators.PdfShowText3Operator
Xfinium.Pdf.Graphics.Operators.PdfShowText4Operator
Xfinium.Pdf.Graphics.Operators.PdfShowTextOperator
Xfinium.Pdf.Graphics.Operators.PdfVCurveToOperator
Xfinium.Pdf.Graphics.Operators.PdfYCurveToOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStreamOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfContentStreamOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfContentStreamOperator Class

The following tables list the members exposed by PdfContentStreamOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfContentStreamOperator Constructor | Initializes a new PdfContentStreamOperator object with the specified type.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted.
Public Property | OpCode | Gets the operator code.
Public Property | Type | Gets or sets the operator type.
Top
See Also

Reference

PdfContentStreamOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfContentStreamOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfContentStreamOperator Class : PdfContentStreamOperator Constructor
The operator type.
Initializes a new PdfContentStreamOperator object with the specified type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal type As PdfContentStreamOperatorType _
)
'Usage

Dim type As PdfContentStreamOperatorType

Dim instance As New PdfContentStreamOperator(type)
public PdfContentStreamOperator(
   PdfContentStreamOperatorType type
)
public:
PdfContentStreamOperator(
   PdfContentStreamOperatorType type
)

Parameters

type
The operator type.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStreamOperator Class
PdfContentStreamOperator Members


%%PageItemTitle%% $$Properties$$

PdfContentStreamOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfContentStreamOperator Class

For a list of all members of this type, see PdfContentStreamOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted.
Public Property | OpCode | Gets the operator code.
Public Property | Type | Gets or sets the operator type.
Top
See Also

Reference

PdfContentStreamOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Context Property (PdfContentStreamOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfContentStreamOperator Class : Context Property
Gets the content stream container from which the operator is extracted.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Context As PdfContentStreamContainer
'Usage

Dim instance As PdfContentStreamOperator
Dim value As PdfContentStreamContainer

value = instance.Context
public PdfContentStreamContainer Context {get;}
public:
property PdfContentStreamContainer^ Context {
   PdfContentStreamContainer^ get();
}

Property Value

A content stream container object, a Xfinium.Pdf.PdfPage or a Xfinium.Pdf.Graphics.PdfFormXObject.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStreamOperator Class
PdfContentStreamOperator Members


OpCode Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfContentStreamOperator Class : OpCode Property
Gets the operator code.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OpCode As String
'Usage

Dim instance As PdfContentStreamOperator
Dim value As String

value = instance.OpCode
public string OpCode {get;}
public:
property String^ OpCode {
   String^ get();
}

Property Value

The operator code as it is written in the content stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStreamOperator Class
PdfContentStreamOperator Members


Type Property (PdfContentStreamOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfContentStreamOperator Class : Type Property
Gets or sets the operator type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Type As PdfContentStreamOperatorType
'Usage

Dim instance As PdfContentStreamOperator
Dim value As PdfContentStreamOperatorType

instance.Type = value

value = instance.Type
public PdfContentStreamOperatorType Type {get; set;}
public:
property PdfContentStreamOperatorType Type {
   PdfContentStreamOperatorType get();
   void set (    PdfContentStreamOperatorType value);
}

Property Value

The type of this operator.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStreamOperator Class
PdfContentStreamOperator Members


%%PageItemTitle%%

PdfContentStreamOperatorCollection Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfContentStreamOperatorCollection Class
Defines a collection of content stream operators.
Object Model
PdfContentStreamOperatorCollection ClassPdfContentStreamOperator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfContentStreamOperatorCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfContentStreamOperator)
'Usage

Dim instance As PdfContentStreamOperatorCollection
public class PdfContentStreamOperatorCollection : System.Collections.ObjectModel.Collection<PdfContentStreamOperator>
public ref class PdfContentStreamOperatorCollection : public System.Collections.ObjectModel.Collection<PdfContentStreamOperator>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperatorCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStreamOperatorCollection Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfContentStreamOperatorCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics.Operators Namespace : PdfContentStreamOperatorCollection Class

The following tables list the members exposed by PdfContentStreamOperatorCollection.

Public Constructors
 | Name | Description
Public Constructor | PdfContentStreamOperatorCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Top
See Also

Reference

PdfContentStreamOperatorCollection Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfContentStreamOperatorCollection Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfContentStreamOperatorCollection Class : PdfContentStreamOperatorCollection Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfContentStreamOperatorCollection()
public PdfContentStreamOperatorCollection()
public:
PdfContentStreamOperatorCollection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentStreamOperatorCollection Class
PdfContentStreamOperatorCollection Members


%%PageItemTitle%%

PdfDefineMarkedContentOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfDefineMarkedContentOperator Class
Defines the MP (define marked-content point) content stream operator.
Object Model
PdfDefineMarkedContentOperator ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDefineMarkedContentOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfDefineMarkedContentOperator
public class PdfDefineMarkedContentOperator : PdfContentStreamOperator
public ref class PdfDefineMarkedContentOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfDefineMarkedContentOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfDefineMarkedContentOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfDefineMarkedContentOperator Class

The following tables list the members exposed by PdfDefineMarkedContentOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfDefineMarkedContentOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Tag | Gets or sets the tag.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfDefineMarkedContentOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfDefineMarkedContentOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentOperator Class : PdfDefineMarkedContentOperator Constructor
Overload List
Overload | Description
PdfDefineMarkedContentOperator Constructor() | Initializes a new PdfDefineMarkedContentOperator object.
PdfDefineMarkedContentOperator Constructor(PdfCosName) | Initializes a new PdfDefineMarkedContentOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentOperator Class
PdfDefineMarkedContentOperator Members


%%PageItemTitle%%

PdfDefineMarkedContentOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentOperator Class > PdfDefineMarkedContentOperator Constructor : PdfDefineMarkedContentOperator Constructor()
Initializes a new PdfDefineMarkedContentOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDefineMarkedContentOperator()
public PdfDefineMarkedContentOperator()
public:
PdfDefineMarkedContentOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentOperator Class
PdfDefineMarkedContentOperator Members
Overload List


%%PageItemTitle%%

PdfDefineMarkedContentOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentOperator Class > PdfDefineMarkedContentOperator Constructor : PdfDefineMarkedContentOperator Constructor(PdfCosName)
The sequence tag.
Initializes a new PdfDefineMarkedContentOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As PdfCosName _
)
'Usage

Dim tag As PdfCosName

Dim instance As New PdfDefineMarkedContentOperator(tag)
public PdfDefineMarkedContentOperator(
   PdfCosName tag
)
public:
PdfDefineMarkedContentOperator(
   PdfCosName^ tag
)

Parameters

tag
The sequence tag.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentOperator Class
PdfDefineMarkedContentOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfDefineMarkedContentOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfDefineMarkedContentOperator Class

For a list of all members of this type, see PdfDefineMarkedContentOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Tag | Gets or sets the tag.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfDefineMarkedContentOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Tag Property (PdfDefineMarkedContentOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentOperator Class : Tag Property
Gets or sets the tag.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As PdfCosName
'Usage

Dim instance As PdfDefineMarkedContentOperator
Dim value As PdfCosName

instance.Tag = value

value = instance.Tag
public PdfCosName Tag {get; set;}
public:
property PdfCosName^ Tag {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

A name object indicating the role or significance of the marked content sequence.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentOperator Class
PdfDefineMarkedContentOperator Members


%%PageItemTitle%%

PdfDefineMarkedContentPropertyListOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfDefineMarkedContentPropertyListOperator Class
Defines the DP (define marked-content point with property list) content stream operator.
Object Model
PdfDefineMarkedContentPropertyListOperator ClassPdfCosObject ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDefineMarkedContentPropertyListOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfDefineMarkedContentPropertyListOperator
public class PdfDefineMarkedContentPropertyListOperator : PdfContentStreamOperator
public ref class PdfDefineMarkedContentPropertyListOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfDefineMarkedContentPropertyListOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentPropertyListOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfDefineMarkedContentPropertyListOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfDefineMarkedContentPropertyListOperator Class

The following tables list the members exposed by PdfDefineMarkedContentPropertyListOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfDefineMarkedContentPropertyListOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Properties | Gets or sets the properties.
Public Property | Tag | Gets or sets the tag.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfDefineMarkedContentPropertyListOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfDefineMarkedContentPropertyListOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentPropertyListOperator Class : PdfDefineMarkedContentPropertyListOperator Constructor
Overload List
Overload | Description
PdfDefineMarkedContentPropertyListOperator Constructor() | Initializes a new PdfDefineMarkedContentPropertyListOperator object.
PdfDefineMarkedContentPropertyListOperator Constructor(PdfCosName,PdfCosObject) | Initializes a new PdfDefineMarkedContentPropertyListOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentPropertyListOperator Class
PdfDefineMarkedContentPropertyListOperator Members


%%PageItemTitle%%

PdfDefineMarkedContentPropertyListOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentPropertyListOperator Class > PdfDefineMarkedContentPropertyListOperator Constructor : PdfDefineMarkedContentPropertyListOperator Constructor()
Initializes a new PdfDefineMarkedContentPropertyListOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDefineMarkedContentPropertyListOperator()
public PdfDefineMarkedContentPropertyListOperator()
public:
PdfDefineMarkedContentPropertyListOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentPropertyListOperator Class
PdfDefineMarkedContentPropertyListOperator Members
Overload List


%%PageItemTitle%%

PdfDefineMarkedContentPropertyListOperator Constructor(PdfCosName,PdfCosObject)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentPropertyListOperator Class > PdfDefineMarkedContentPropertyListOperator Constructor : PdfDefineMarkedContentPropertyListOperator Constructor(PdfCosName,PdfCosObject)
The sequence tag.
Properties ID or an inline dictionary.
Initializes a new PdfDefineMarkedContentPropertyListOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tag As PdfCosName, _
   ByVal properties As PdfCosObject _
)
'Usage

Dim tag As PdfCosName
Dim properties As PdfCosObject

Dim instance As New PdfDefineMarkedContentPropertyListOperator(tag, properties)
public PdfDefineMarkedContentPropertyListOperator(
   PdfCosName tag,
   PdfCosObject properties
)
public:
PdfDefineMarkedContentPropertyListOperator(
   PdfCosName^ tag,
   PdfCosObject^ properties
)

Parameters

tag
The sequence tag.
properties
Properties ID or an inline dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentPropertyListOperator Class
PdfDefineMarkedContentPropertyListOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfDefineMarkedContentPropertyListOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfDefineMarkedContentPropertyListOperator Class

For a list of all members of this type, see PdfDefineMarkedContentPropertyListOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Properties | Gets or sets the properties.
Public Property | Tag | Gets or sets the tag.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfDefineMarkedContentPropertyListOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Properties Property (PdfDefineMarkedContentPropertyListOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentPropertyListOperator Class : Properties Property
Gets or sets the properties.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Properties As PdfCosObject
'Usage

Dim instance As PdfDefineMarkedContentPropertyListOperator
Dim value As PdfCosObject

instance.Properties = value

value = instance.Properties
public PdfCosObject Properties {get; set;}
public:
property PdfCosObject^ Properties {
   PdfCosObject^ get();
   void set (    PdfCosObject^ value);
}

Property Value

A name object used as key in the /Resources/Properties dictionary or an inline dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentPropertyListOperator Class
PdfDefineMarkedContentPropertyListOperator Members


Tag Property (PdfDefineMarkedContentPropertyListOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDefineMarkedContentPropertyListOperator Class : Tag Property
Gets or sets the tag.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Tag As PdfCosName
'Usage

Dim instance As PdfDefineMarkedContentPropertyListOperator
Dim value As PdfCosName

instance.Tag = value

value = instance.Tag
public PdfCosName Tag {get; set;}
public:
property PdfCosName^ Tag {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

A name object indicating the role or significance of the marked content sequence.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDefineMarkedContentPropertyListOperator Class
PdfDefineMarkedContentPropertyListOperator Members


%%PageItemTitle%%

PdfDisplayFormXObjectOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfDisplayFormXObjectOperator Class
Defines the Do (display form XObject) content stream operator.
Object Model
PdfDisplayFormXObjectOperator ClassPdfFormXObject ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDisplayFormXObjectOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfDisplayFormXObjectOperator
public class PdfDisplayFormXObjectOperator : PdfContentStreamOperator
public ref class PdfDisplayFormXObjectOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfDisplayFormXObjectOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayFormXObjectOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfDisplayFormXObjectOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfDisplayFormXObjectOperator Class

The following tables list the members exposed by PdfDisplayFormXObjectOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfDisplayFormXObjectOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | FormXObject | Gets or sets the form XObject.
Public Property | FormXObjectID | Gets or sets the form XObject ID.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfDisplayFormXObjectOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfDisplayFormXObjectOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayFormXObjectOperator Class : PdfDisplayFormXObjectOperator Constructor
Overload List
Overload | Description
PdfDisplayFormXObjectOperator Constructor() | Initializes a new PdfDisplayFormXObjectOperator object.
PdfDisplayFormXObjectOperator Constructor(PdfCosName) | Initializes a new PdfDisplayFormXObjectOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayFormXObjectOperator Class
PdfDisplayFormXObjectOperator Members


%%PageItemTitle%%

PdfDisplayFormXObjectOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayFormXObjectOperator Class > PdfDisplayFormXObjectOperator Constructor : PdfDisplayFormXObjectOperator Constructor()
Initializes a new PdfDisplayFormXObjectOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDisplayFormXObjectOperator()
public PdfDisplayFormXObjectOperator()
public:
PdfDisplayFormXObjectOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayFormXObjectOperator Class
PdfDisplayFormXObjectOperator Members
Overload List


%%PageItemTitle%%

PdfDisplayFormXObjectOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayFormXObjectOperator Class > PdfDisplayFormXObjectOperator Constructor : PdfDisplayFormXObjectOperator Constructor(PdfCosName)
The form XObject ID in the /Resources dictionary.
Initializes a new PdfDisplayFormXObjectOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal formXObjectID As PdfCosName _
)
'Usage

Dim formXObjectID As PdfCosName

Dim instance As New PdfDisplayFormXObjectOperator(formXObjectID)
public PdfDisplayFormXObjectOperator(
   PdfCosName formXObjectID
)
public:
PdfDisplayFormXObjectOperator(
   PdfCosName^ formXObjectID
)

Parameters

formXObjectID
The form XObject ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayFormXObjectOperator Class
PdfDisplayFormXObjectOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfDisplayFormXObjectOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfDisplayFormXObjectOperator Class

For a list of all members of this type, see PdfDisplayFormXObjectOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | FormXObject | Gets or sets the form XObject.
Public Property | FormXObjectID | Gets or sets the form XObject ID.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfDisplayFormXObjectOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


FormXObject Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayFormXObjectOperator Class : FormXObject Property
Gets or sets the form XObject.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FormXObject As PdfFormXObject
'Usage

Dim instance As PdfDisplayFormXObjectOperator
Dim value As PdfFormXObject

instance.FormXObject = value

value = instance.FormXObject
public PdfFormXObject FormXObject {get; set;}
public:
property PdfFormXObject^ FormXObject {
   PdfFormXObject^ get();
   void set (    PdfFormXObject^ value);
}

Property Value

The form XObject painted by this operator.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayFormXObjectOperator Class
PdfDisplayFormXObjectOperator Members


FormXObjectID Property (PdfDisplayFormXObjectOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayFormXObjectOperator Class : FormXObjectID Property
Gets or sets the form XObject ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FormXObjectID As PdfCosName
'Usage

Dim instance As PdfDisplayFormXObjectOperator
Dim value As PdfCosName

instance.FormXObjectID = value

value = instance.FormXObjectID
public PdfCosName FormXObjectID {get; set;}
public:
property PdfCosName^ FormXObjectID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The form XObject ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayFormXObjectOperator Class
PdfDisplayFormXObjectOperator Members


%%PageItemTitle%%

PdfDisplayImageXObjectOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfDisplayImageXObjectOperator Class
Defines the Do (display image XObject) content stream operator.
Object Model
PdfDisplayImageXObjectOperator ClassPdfVisualImage ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfDisplayImageXObjectOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfDisplayImageXObjectOperator
public class PdfDisplayImageXObjectOperator : PdfContentStreamOperator
public ref class PdfDisplayImageXObjectOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfDisplayImageXObjectOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayImageXObjectOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfDisplayImageXObjectOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfDisplayImageXObjectOperator Class

The following tables list the members exposed by PdfDisplayImageXObjectOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfDisplayImageXObjectOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Image | Gets the image painted by this operator.
Public Property | ImageID | Gets or sets the image ID.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfDisplayImageXObjectOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfDisplayImageXObjectOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayImageXObjectOperator Class : PdfDisplayImageXObjectOperator Constructor
Overload List
Overload | Description
PdfDisplayImageXObjectOperator Constructor() | Initializes a new PdfDisplayImageXObjectOperator object.
PdfDisplayImageXObjectOperator Constructor(PdfCosName) | Initializes a new PdfDisplayImageXObjectOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayImageXObjectOperator Class
PdfDisplayImageXObjectOperator Members


%%PageItemTitle%%

PdfDisplayImageXObjectOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayImageXObjectOperator Class > PdfDisplayImageXObjectOperator Constructor : PdfDisplayImageXObjectOperator Constructor()
Initializes a new PdfDisplayImageXObjectOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfDisplayImageXObjectOperator()
public PdfDisplayImageXObjectOperator()
public:
PdfDisplayImageXObjectOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayImageXObjectOperator Class
PdfDisplayImageXObjectOperator Members
Overload List


%%PageItemTitle%%

PdfDisplayImageXObjectOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayImageXObjectOperator Class > PdfDisplayImageXObjectOperator Constructor : PdfDisplayImageXObjectOperator Constructor(PdfCosName)
The image ID in the /Resources dictionary.
Initializes a new PdfDisplayImageXObjectOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imageID As PdfCosName _
)
'Usage

Dim imageID As PdfCosName

Dim instance As New PdfDisplayImageXObjectOperator(imageID)
public PdfDisplayImageXObjectOperator(
   PdfCosName imageID
)
public:
PdfDisplayImageXObjectOperator(
   PdfCosName^ imageID
)

Parameters

imageID
The image ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayImageXObjectOperator Class
PdfDisplayImageXObjectOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfDisplayImageXObjectOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfDisplayImageXObjectOperator Class

For a list of all members of this type, see PdfDisplayImageXObjectOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Image | Gets the image painted by this operator.
Public Property | ImageID | Gets or sets the image ID.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfDisplayImageXObjectOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Image Property (PdfDisplayImageXObjectOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayImageXObjectOperator Class : Image Property
Gets the image painted by this operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Image As PdfVisualImage
'Usage

Dim instance As PdfDisplayImageXObjectOperator
Dim value As PdfVisualImage

value = instance.Image
public PdfVisualImage Image {get;}
public:
property PdfVisualImage^ Image {
   PdfVisualImage^ get();
}

Property Value

The decoded image object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayImageXObjectOperator Class
PdfDisplayImageXObjectOperator Members


ImageID Property (PdfDisplayImageXObjectOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfDisplayImageXObjectOperator Class : ImageID Property
Gets or sets the image ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ImageID As PdfCosName
'Usage

Dim instance As PdfDisplayImageXObjectOperator
Dim value As PdfCosName

instance.ImageID = value

value = instance.ImageID
public PdfCosName ImageID {get; set;}
public:
property PdfCosName^ ImageID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The image ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDisplayImageXObjectOperator Class
PdfDisplayImageXObjectOperator Members


%%PageItemTitle%%

PdfLineToOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfLineToOperator Class
Defines the l (line to) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfLineToOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfLineToOperator
public class PdfLineToOperator : PdfContentStreamOperator
public ref class PdfLineToOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfLineToOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineToOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfLineToOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfLineToOperator Class

The following tables list the members exposed by PdfLineToOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfLineToOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X | Gets or sets the X coordinate of the point.
Public Property | Y | Gets or sets the Y coordinate of the point.
Top
See Also

Reference

PdfLineToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfLineToOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfLineToOperator Class : PdfLineToOperator Constructor
Overload List
Overload | Description
PdfLineToOperator Constructor() | Initializes a new PdfLineToOperator object.
PdfLineToOperator Constructor(Double,Double) | Initializes a new PdfLineToOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineToOperator Class
PdfLineToOperator Members


%%PageItemTitle%%

PdfLineToOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfLineToOperator Class > PdfLineToOperator Constructor : PdfLineToOperator Constructor()
Initializes a new PdfLineToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfLineToOperator()
public PdfLineToOperator()
public:
PdfLineToOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineToOperator Class
PdfLineToOperator Members
Overload List


%%PageItemTitle%%

PdfLineToOperator Constructor(Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfLineToOperator Class > PdfLineToOperator Constructor : PdfLineToOperator Constructor(Double,Double)
The X coordinate of the point.
The Y coordinate of the point.
Initializes a new PdfLineToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim x As Double
Dim y As Double

Dim instance As New PdfLineToOperator(x, y)
public PdfLineToOperator(
   double x,
   double y
)
public:
PdfLineToOperator(
   double x,
   double y
)

Parameters

x
The X coordinate of the point.
y
The Y coordinate of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineToOperator Class
PdfLineToOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfLineToOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfLineToOperator Class

For a list of all members of this type, see PdfLineToOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X | Gets or sets the X coordinate of the point.
Public Property | Y | Gets or sets the Y coordinate of the point.
Top
See Also

Reference

PdfLineToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


X Property (PdfLineToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfLineToOperator Class : X Property
Gets or sets the X coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X As Double
'Usage

Dim instance As PdfLineToOperator
Dim value As Double

instance.X = value

value = instance.X
public double X {get; set;}
public:
property double X {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineToOperator Class
PdfLineToOperator Members


Y Property (PdfLineToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfLineToOperator Class : Y Property
Gets or sets the Y coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PdfLineToOperator
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineToOperator Class
PdfLineToOperator Members


%%PageItemTitle%%

PdfMoveTextPositionOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveTextPositionOperator Class
Defines the Td (move text position) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfMoveTextPositionOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfMoveTextPositionOperator
public class PdfMoveTextPositionOperator : PdfContentStreamOperator
public ref class PdfMoveTextPositionOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveTextPositionOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfMoveTextPositionOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveTextPositionOperator Class

The following tables list the members exposed by PdfMoveTextPositionOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfMoveTextPositionOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TX | Gets or sets the X offset.
Public Property | TY | Gets or sets the Y offset.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfMoveTextPositionOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfMoveTextPositionOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionOperator Class : PdfMoveTextPositionOperator Constructor
Overload List
Overload | Description
PdfMoveTextPositionOperator Constructor() | Initializes a new PdfMoveTextPositionOperator object.
PdfMoveTextPositionOperator Constructor(Double,Double) | Initializes a new PdfMoveTextPositionOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionOperator Class
PdfMoveTextPositionOperator Members


%%PageItemTitle%%

PdfMoveTextPositionOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionOperator Class > PdfMoveTextPositionOperator Constructor : PdfMoveTextPositionOperator Constructor()
Initializes a new PdfMoveTextPositionOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfMoveTextPositionOperator()
public PdfMoveTextPositionOperator()
public:
PdfMoveTextPositionOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionOperator Class
PdfMoveTextPositionOperator Members
Overload List


%%PageItemTitle%%

PdfMoveTextPositionOperator Constructor(Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionOperator Class > PdfMoveTextPositionOperator Constructor : PdfMoveTextPositionOperator Constructor(Double,Double)
The X offset.
The Y offset.
Initializes a new PdfMoveTextPositionOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim tx As Double
Dim ty As Double

Dim instance As New PdfMoveTextPositionOperator(tx, ty)
public PdfMoveTextPositionOperator(
   double tx,
   double ty
)
public:
PdfMoveTextPositionOperator(
   double tx,
   double ty
)

Parameters

tx
The X offset.
ty
The Y offset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionOperator Class
PdfMoveTextPositionOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfMoveTextPositionOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveTextPositionOperator Class

For a list of all members of this type, see PdfMoveTextPositionOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TX | Gets or sets the X offset.
Public Property | TY | Gets or sets the Y offset.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfMoveTextPositionOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


TX Property (PdfMoveTextPositionOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionOperator Class : TX Property
Gets or sets the X offset.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TX As Double
'Usage

Dim instance As PdfMoveTextPositionOperator
Dim value As Double

instance.TX = value

value = instance.TX
public double TX {get; set;}
public:
property double TX {
   double get();
   void set (    double value);
}

Property Value

The X offset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionOperator Class
PdfMoveTextPositionOperator Members


TY Property (PdfMoveTextPositionOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionOperator Class : TY Property
Gets or sets the Y offset.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TY As Double
'Usage

Dim instance As PdfMoveTextPositionOperator
Dim value As Double

instance.TY = value

value = instance.TY
public double TY {get; set;}
public:
property double TY {
   double get();
   void set (    double value);
}

Property Value

The Y offset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionOperator Class
PdfMoveTextPositionOperator Members


%%PageItemTitle%%

PdfMoveTextPositionSetLeadingOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveTextPositionSetLeadingOperator Class
Defines the TD (move text position and set leading) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfMoveTextPositionSetLeadingOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfMoveTextPositionSetLeadingOperator
public class PdfMoveTextPositionSetLeadingOperator : PdfContentStreamOperator
public ref class PdfMoveTextPositionSetLeadingOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveTextPositionSetLeadingOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionSetLeadingOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfMoveTextPositionSetLeadingOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveTextPositionSetLeadingOperator Class

The following tables list the members exposed by PdfMoveTextPositionSetLeadingOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfMoveTextPositionSetLeadingOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TX | Gets or sets the X offset.
Public Property | TY | Gets or sets the Y offset.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfMoveTextPositionSetLeadingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfMoveTextPositionSetLeadingOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionSetLeadingOperator Class : PdfMoveTextPositionSetLeadingOperator Constructor
Overload List
Overload | Description
PdfMoveTextPositionSetLeadingOperator Constructor() | Initializes a new PdfMoveTextPositionSetLeadingOperator object.
PdfMoveTextPositionSetLeadingOperator Constructor(Double,Double) | Initializes a new PdfMoveTextPositionSetLeadingOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionSetLeadingOperator Class
PdfMoveTextPositionSetLeadingOperator Members


%%PageItemTitle%%

PdfMoveTextPositionSetLeadingOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionSetLeadingOperator Class > PdfMoveTextPositionSetLeadingOperator Constructor : PdfMoveTextPositionSetLeadingOperator Constructor()
Initializes a new PdfMoveTextPositionSetLeadingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfMoveTextPositionSetLeadingOperator()
public PdfMoveTextPositionSetLeadingOperator()
public:
PdfMoveTextPositionSetLeadingOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionSetLeadingOperator Class
PdfMoveTextPositionSetLeadingOperator Members
Overload List


%%PageItemTitle%%

PdfMoveTextPositionSetLeadingOperator Constructor(Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionSetLeadingOperator Class > PdfMoveTextPositionSetLeadingOperator Constructor : PdfMoveTextPositionSetLeadingOperator Constructor(Double,Double)
The X offset.
The Y offset.
Initializes a new PdfMoveTextPositionSetLeadingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tx As Double, _
   ByVal ty As Double _
)
'Usage

Dim tx As Double
Dim ty As Double

Dim instance As New PdfMoveTextPositionSetLeadingOperator(tx, ty)
public PdfMoveTextPositionSetLeadingOperator(
   double tx,
   double ty
)
public:
PdfMoveTextPositionSetLeadingOperator(
   double tx,
   double ty
)

Parameters

tx
The X offset.
ty
The Y offset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionSetLeadingOperator Class
PdfMoveTextPositionSetLeadingOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfMoveTextPositionSetLeadingOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveTextPositionSetLeadingOperator Class

For a list of all members of this type, see PdfMoveTextPositionSetLeadingOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TX | Gets or sets the X offset.
Public Property | TY | Gets or sets the Y offset.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfMoveTextPositionSetLeadingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


TX Property (PdfMoveTextPositionSetLeadingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionSetLeadingOperator Class : TX Property
Gets or sets the X offset.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TX As Double
'Usage

Dim instance As PdfMoveTextPositionSetLeadingOperator
Dim value As Double

instance.TX = value

value = instance.TX
public double TX {get; set;}
public:
property double TX {
   double get();
   void set (    double value);
}

Property Value

The X offset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionSetLeadingOperator Class
PdfMoveTextPositionSetLeadingOperator Members


TY Property (PdfMoveTextPositionSetLeadingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveTextPositionSetLeadingOperator Class : TY Property
Gets or sets the Y offset.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TY As Double
'Usage

Dim instance As PdfMoveTextPositionSetLeadingOperator
Dim value As Double

instance.TY = value

value = instance.TY
public double TY {get; set;}
public:
property double TY {
   double get();
   void set (    double value);
}

Property Value

The Y offset.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveTextPositionSetLeadingOperator Class
PdfMoveTextPositionSetLeadingOperator Members


%%PageItemTitle%%

PdfMoveToOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveToOperator Class
Defines the m (move to) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfMoveToOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfMoveToOperator
public class PdfMoveToOperator : PdfContentStreamOperator
public ref class PdfMoveToOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfMoveToOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveToOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfMoveToOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveToOperator Class

The following tables list the members exposed by PdfMoveToOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfMoveToOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X | Gets or sets the X coordinate of the point.
Public Property | Y | Gets or sets the Y coordinate of the point.
Top
See Also

Reference

PdfMoveToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfMoveToOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveToOperator Class : PdfMoveToOperator Constructor
Overload List
Overload | Description
PdfMoveToOperator Constructor() | Initializes a new PdfMoveToOperator object.
PdfMoveToOperator Constructor(Double,Double) | Initializes a new PdfMoveToOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveToOperator Class
PdfMoveToOperator Members


%%PageItemTitle%%

PdfMoveToOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveToOperator Class > PdfMoveToOperator Constructor : PdfMoveToOperator Constructor()
Initializes a new PdfMoveToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfMoveToOperator()
public PdfMoveToOperator()
public:
PdfMoveToOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveToOperator Class
PdfMoveToOperator Members
Overload List


%%PageItemTitle%%

PdfMoveToOperator Constructor(Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveToOperator Class > PdfMoveToOperator Constructor : PdfMoveToOperator Constructor(Double,Double)
The X coordinate of the point.
The Y coordinate of the point.
Initializes a new PdfMoveToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
'Usage

Dim x As Double
Dim y As Double

Dim instance As New PdfMoveToOperator(x, y)
public PdfMoveToOperator(
   double x,
   double y
)
public:
PdfMoveToOperator(
   double x,
   double y
)

Parameters

x
The X coordinate of the point.
y
The Y coordinate of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveToOperator Class
PdfMoveToOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfMoveToOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfMoveToOperator Class

For a list of all members of this type, see PdfMoveToOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X | Gets or sets the X coordinate of the point.
Public Property | Y | Gets or sets the Y coordinate of the point.
Top
See Also

Reference

PdfMoveToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


X Property (PdfMoveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveToOperator Class : X Property
Gets or sets the X coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X As Double
'Usage

Dim instance As PdfMoveToOperator
Dim value As Double

instance.X = value

value = instance.X
public double X {get; set;}
public:
property double X {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveToOperator Class
PdfMoveToOperator Members


Y Property (PdfMoveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfMoveToOperator Class : Y Property
Gets or sets the Y coordinate of the point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PdfMoveToOperator
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMoveToOperator Class
PdfMoveToOperator Members


%%PageItemTitle%%

PdfRectangleOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfRectangleOperator Class
Defines the re (rectangle) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRectangleOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfRectangleOperator
public class PdfRectangleOperator : PdfContentStreamOperator
public ref class PdfRectangleOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfRectangleOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectangleOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfRectangleOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfRectangleOperator Class

The following tables list the members exposed by PdfRectangleOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfRectangleOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Height | Gets or sets the rectangle height.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Width | Gets or sets the rectangle width.
Public Property | X | Gets or sets the X coordinate of the lower left corner.
Public Property | Y | Gets or sets the Y coordinate of the lower left corner.
Top
See Also

Reference

PdfRectangleOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfRectangleOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfRectangleOperator Class : PdfRectangleOperator Constructor
Overload List
Overload | Description
PdfRectangleOperator Constructor() | Initializes a new PdfRectangleOperator object.
PdfRectangleOperator Constructor(Double,Double,Double,Double) | Initializes a new PdfRectangleOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectangleOperator Class
PdfRectangleOperator Members


%%PageItemTitle%%

PdfRectangleOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfRectangleOperator Class > PdfRectangleOperator Constructor : PdfRectangleOperator Constructor()
Initializes a new PdfRectangleOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRectangleOperator()
public PdfRectangleOperator()
public:
PdfRectangleOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectangleOperator Class
PdfRectangleOperator Members
Overload List


%%PageItemTitle%%

PdfRectangleOperator Constructor(Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfRectangleOperator Class > PdfRectangleOperator Constructor : PdfRectangleOperator Constructor(Double,Double,Double,Double)
The X coordinate of the lower left corner.
The Y coordinate of the lower left corner.
The rectangle width.
The rectangle height.
Initializes a new PdfRectangleOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
'Usage

Dim x As Double
Dim y As Double
Dim width As Double
Dim height As Double

Dim instance As New PdfRectangleOperator(x, y, width, height)
public PdfRectangleOperator(
   double x,
   double y,
   double width,
   double height
)
public:
PdfRectangleOperator(
   double x,
   double y,
   double width,
   double height
)

Parameters

x
The X coordinate of the lower left corner.
y
The Y coordinate of the lower left corner.
width
The rectangle width.
height
The rectangle height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectangleOperator Class
PdfRectangleOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfRectangleOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfRectangleOperator Class

For a list of all members of this type, see PdfRectangleOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Height | Gets or sets the rectangle height.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Width | Gets or sets the rectangle width.
Public Property | X | Gets or sets the X coordinate of the lower left corner.
Public Property | Y | Gets or sets the Y coordinate of the lower left corner.
Top
See Also

Reference

PdfRectangleOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Height Property (PdfRectangleOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfRectangleOperator Class : Height Property
Gets or sets the rectangle height.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Height As Double
'Usage

Dim instance As PdfRectangleOperator
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
public:
property double Height {
   double get();
   void set (    double value);
}

Property Value

The rectangle height.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectangleOperator Class
PdfRectangleOperator Members


Width Property (PdfRectangleOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfRectangleOperator Class : Width Property
Gets or sets the rectangle width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Width As Double
'Usage

Dim instance As PdfRectangleOperator
Dim value As Double

instance.Width = value

value = instance.Width
public double Width {get; set;}
public:
property double Width {
   double get();
   void set (    double value);
}

Property Value

The rectangle width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectangleOperator Class
PdfRectangleOperator Members


X Property (PdfRectangleOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfRectangleOperator Class : X Property
Gets or sets the X coordinate of the lower left corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X As Double
'Usage

Dim instance As PdfRectangleOperator
Dim value As Double

instance.X = value

value = instance.X
public double X {get; set;}
public:
property double X {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the lower left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectangleOperator Class
PdfRectangleOperator Members


Y Property (PdfRectangleOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfRectangleOperator Class : Y Property
Gets or sets the Y coordinate of the lower left corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PdfRectangleOperator
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the lower left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectangleOperator Class
PdfRectangleOperator Members


%%PageItemTitle%%

PdfSetCharacterSpacingOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCharacterSpacingOperator Class
Defines the Tc (set character spacing) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetCharacterSpacingOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetCharacterSpacingOperator
public class PdfSetCharacterSpacingOperator : PdfContentStreamOperator
public ref class PdfSetCharacterSpacingOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCharacterSpacingOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCharacterSpacingOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetCharacterSpacingOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCharacterSpacingOperator Class

The following tables list the members exposed by PdfSetCharacterSpacingOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetCharacterSpacingOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CharacterSpacing | Gets or sets the character spacing.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetCharacterSpacingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetCharacterSpacingOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCharacterSpacingOperator Class : PdfSetCharacterSpacingOperator Constructor
Overload List
Overload | Description
PdfSetCharacterSpacingOperator Constructor() | Initializes a new PdfSetCharacterSpacingOperator object.
PdfSetCharacterSpacingOperator Constructor(Double) | Initializes a new PdfSetCharacterSpacingOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCharacterSpacingOperator Class
PdfSetCharacterSpacingOperator Members


%%PageItemTitle%%

PdfSetCharacterSpacingOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCharacterSpacingOperator Class > PdfSetCharacterSpacingOperator Constructor : PdfSetCharacterSpacingOperator Constructor()
Initializes a new PdfSetCharacterSpacingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetCharacterSpacingOperator()
public PdfSetCharacterSpacingOperator()
public:
PdfSetCharacterSpacingOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCharacterSpacingOperator Class
PdfSetCharacterSpacingOperator Members
Overload List


%%PageItemTitle%%

PdfSetCharacterSpacingOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCharacterSpacingOperator Class > PdfSetCharacterSpacingOperator Constructor : PdfSetCharacterSpacingOperator Constructor(Double)
The character spacing.
Initializes a new PdfSetCharacterSpacingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal characterSpacing As Double _
)
'Usage

Dim characterSpacing As Double

Dim instance As New PdfSetCharacterSpacingOperator(characterSpacing)
public PdfSetCharacterSpacingOperator(
   double characterSpacing
)
public:
PdfSetCharacterSpacingOperator(
   double characterSpacing
)

Parameters

characterSpacing
The character spacing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCharacterSpacingOperator Class
PdfSetCharacterSpacingOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetCharacterSpacingOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCharacterSpacingOperator Class

For a list of all members of this type, see PdfSetCharacterSpacingOperator members.

Public Properties
 | Name | Description
Public Property | CharacterSpacing | Gets or sets the character spacing.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetCharacterSpacingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


CharacterSpacing Property (PdfSetCharacterSpacingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCharacterSpacingOperator Class : CharacterSpacing Property
Gets or sets the character spacing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CharacterSpacing As Double
'Usage

Dim instance As PdfSetCharacterSpacingOperator
Dim value As Double

instance.CharacterSpacing = value

value = instance.CharacterSpacing
public double CharacterSpacing {get; set;}
public:
property double CharacterSpacing {
   double get();
   void set (    double value);
}

Property Value

The character spacing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCharacterSpacingOperator Class
PdfSetCharacterSpacingOperator Members


%%PageItemTitle%%

PdfSetCmykFillOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCmykFillOperator Class
Defines the k (set CMYK level for fill operations) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetCmykFillOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetCmykFillOperator
public class PdfSetCmykFillOperator : PdfContentStreamOperator
public ref class PdfSetCmykFillOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCmykFillOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykFillOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetCmykFillOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCmykFillOperator Class

The following tables list the members exposed by PdfSetCmykFillOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetCmykFillOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan level.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | K | Gets or sets the black level.
Public Property | M | Gets or sets the magenta level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Y | Gets or sets the yellow level.
Top
See Also

Reference

PdfSetCmykFillOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetCmykFillOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykFillOperator Class : PdfSetCmykFillOperator Constructor
Overload List
Overload | Description
PdfSetCmykFillOperator Constructor() | Initializes a new PdfSetCmykFillOperator object.
PdfSetCmykFillOperator Constructor(Double,Double,Double,Double) | Initializes a new PdfSetCmykFillOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykFillOperator Class
PdfSetCmykFillOperator Members


%%PageItemTitle%%

PdfSetCmykFillOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykFillOperator Class > PdfSetCmykFillOperator Constructor : PdfSetCmykFillOperator Constructor()
Initializes a new PdfSetCmykFillOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetCmykFillOperator()
public PdfSetCmykFillOperator()
public:
PdfSetCmykFillOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykFillOperator Class
PdfSetCmykFillOperator Members
Overload List


%%PageItemTitle%%

PdfSetCmykFillOperator Constructor(Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykFillOperator Class > PdfSetCmykFillOperator Constructor : PdfSetCmykFillOperator Constructor(Double,Double,Double,Double)
The cyan level.
The magenta level.
The yellow level.
The black level.
Initializes a new PdfSetCmykFillOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
'Usage

Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

Dim instance As New PdfSetCmykFillOperator(c, m, y, k)
public PdfSetCmykFillOperator(
   double c,
   double m,
   double y,
   double k
)
public:
PdfSetCmykFillOperator(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
The cyan level.
m
The magenta level.
y
The yellow level.
k
The black level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykFillOperator Class
PdfSetCmykFillOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetCmykFillOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCmykFillOperator Class

For a list of all members of this type, see PdfSetCmykFillOperator members.

Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan level.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | K | Gets or sets the black level.
Public Property | M | Gets or sets the magenta level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Y | Gets or sets the yellow level.
Top
See Also

Reference

PdfSetCmykFillOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


C Property (PdfSetCmykFillOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykFillOperator Class : C Property
Gets or sets the cyan level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property C As Double
'Usage

Dim instance As PdfSetCmykFillOperator
Dim value As Double

instance.C = value

value = instance.C
public double C {get; set;}
public:
property double C {
   double get();
   void set (    double value);
}

Property Value

The cyan level.
Remarks
The cyan level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykFillOperator Class
PdfSetCmykFillOperator Members


K Property (PdfSetCmykFillOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykFillOperator Class : K Property
Gets or sets the black level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property K As Double
'Usage

Dim instance As PdfSetCmykFillOperator
Dim value As Double

instance.K = value

value = instance.K
public double K {get; set;}
public:
property double K {
   double get();
   void set (    double value);
}

Property Value

The black level.
Remarks
The black level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykFillOperator Class
PdfSetCmykFillOperator Members


M Property (PdfSetCmykFillOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykFillOperator Class : M Property
Gets or sets the magenta level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M As Double
'Usage

Dim instance As PdfSetCmykFillOperator
Dim value As Double

instance.M = value

value = instance.M
public double M {get; set;}
public:
property double M {
   double get();
   void set (    double value);
}

Property Value

The magenta level.
Remarks
The magenta level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykFillOperator Class
PdfSetCmykFillOperator Members


Y Property (PdfSetCmykFillOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykFillOperator Class : Y Property
Gets or sets the yellow level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PdfSetCmykFillOperator
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

The yellow level.
Remarks
The yellow level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykFillOperator Class
PdfSetCmykFillOperator Members


%%PageItemTitle%%

PdfSetCmykStrokeOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCmykStrokeOperator Class
Defines the K (set CMYK level for stroke operations) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetCmykStrokeOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetCmykStrokeOperator
public class PdfSetCmykStrokeOperator : PdfContentStreamOperator
public ref class PdfSetCmykStrokeOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetCmykStrokeOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykStrokeOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetCmykStrokeOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCmykStrokeOperator Class

The following tables list the members exposed by PdfSetCmykStrokeOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetCmykStrokeOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan level.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | K | Gets or sets the black level.
Public Property | M | Gets or sets the magenta level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Y | Gets or sets the yellow level.
Top
See Also

Reference

PdfSetCmykStrokeOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetCmykStrokeOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykStrokeOperator Class : PdfSetCmykStrokeOperator Constructor
Overload List
Overload | Description
PdfSetCmykStrokeOperator Constructor() | Initializes a new PdfSetCmykStrokeOperator object.
PdfSetCmykStrokeOperator Constructor(Double,Double,Double,Double) | Initializes a new PdfSetCmykStrokeOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykStrokeOperator Class
PdfSetCmykStrokeOperator Members


%%PageItemTitle%%

PdfSetCmykStrokeOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykStrokeOperator Class > PdfSetCmykStrokeOperator Constructor : PdfSetCmykStrokeOperator Constructor()
Initializes a new PdfSetCmykStrokeOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetCmykStrokeOperator()
public PdfSetCmykStrokeOperator()
public:
PdfSetCmykStrokeOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykStrokeOperator Class
PdfSetCmykStrokeOperator Members
Overload List


%%PageItemTitle%%

PdfSetCmykStrokeOperator Constructor(Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykStrokeOperator Class > PdfSetCmykStrokeOperator Constructor : PdfSetCmykStrokeOperator Constructor(Double,Double,Double,Double)
The cyan level.
The magenta level.
The yellow level.
The black level.
Initializes a new PdfSetCmykStrokeOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
'Usage

Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

Dim instance As New PdfSetCmykStrokeOperator(c, m, y, k)
public PdfSetCmykStrokeOperator(
   double c,
   double m,
   double y,
   double k
)
public:
PdfSetCmykStrokeOperator(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
The cyan level.
m
The magenta level.
y
The yellow level.
k
The black level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykStrokeOperator Class
PdfSetCmykStrokeOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetCmykStrokeOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetCmykStrokeOperator Class

For a list of all members of this type, see PdfSetCmykStrokeOperator members.

Public Properties
 | Name | Description
Public Property | C | Gets or sets the cyan level.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | K | Gets or sets the black level.
Public Property | M | Gets or sets the magenta level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Y | Gets or sets the yellow level.
Top
See Also

Reference

PdfSetCmykStrokeOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


C Property (PdfSetCmykStrokeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykStrokeOperator Class : C Property
Gets or sets the cyan level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property C As Double
'Usage

Dim instance As PdfSetCmykStrokeOperator
Dim value As Double

instance.C = value

value = instance.C
public double C {get; set;}
public:
property double C {
   double get();
   void set (    double value);
}

Property Value

The cyan level.
Remarks
The cyan level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykStrokeOperator Class
PdfSetCmykStrokeOperator Members


K Property (PdfSetCmykStrokeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykStrokeOperator Class : K Property
Gets or sets the black level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property K As Double
'Usage

Dim instance As PdfSetCmykStrokeOperator
Dim value As Double

instance.K = value

value = instance.K
public double K {get; set;}
public:
property double K {
   double get();
   void set (    double value);
}

Property Value

The black level.
Remarks
The black level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykStrokeOperator Class
PdfSetCmykStrokeOperator Members


M Property (PdfSetCmykStrokeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykStrokeOperator Class : M Property
Gets or sets the magenta level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M As Double
'Usage

Dim instance As PdfSetCmykStrokeOperator
Dim value As Double

instance.M = value

value = instance.M
public double M {get; set;}
public:
property double M {
   double get();
   void set (    double value);
}

Property Value

The magenta level.
Remarks
The magenta level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykStrokeOperator Class
PdfSetCmykStrokeOperator Members


Y Property (PdfSetCmykStrokeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetCmykStrokeOperator Class : Y Property
Gets or sets the yellow level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As Double
'Usage

Dim instance As PdfSetCmykStrokeOperator
Dim value As Double

instance.Y = value

value = instance.Y
public double Y {get; set;}
public:
property double Y {
   double get();
   void set (    double value);
}

Property Value

The yellow level.
Remarks
The yellow level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetCmykStrokeOperator Class
PdfSetCmykStrokeOperator Members


%%PageItemTitle%%

PdfSetFillColorNOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorNOperator Class
Defines the scn (set fill color) content stream operator.
Object Model
PdfSetFillColorNOperator ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetFillColorNOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetFillColorNOperator
public class PdfSetFillColorNOperator : PdfContentStreamOperator
public ref class PdfSetFillColorNOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorNOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorNOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetFillColorNOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorNOperator Class

The following tables list the members exposed by PdfSetFillColorNOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetFillColorNOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | PatternID | Gets or sets the pattern ID.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetFillColorNOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetFillColorNOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorNOperator Class : PdfSetFillColorNOperator Constructor
Overload List
Overload | Description
PdfSetFillColorNOperator Constructor() | Initializes a new PdfSetFillColorNOperator object.
PdfSetFillColorNOperator Constructor(Double[],PdfCosName) | Initializes a new PdfSetFillColorNOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorNOperator Class
PdfSetFillColorNOperator Members


%%PageItemTitle%%

PdfSetFillColorNOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorNOperator Class > PdfSetFillColorNOperator Constructor : PdfSetFillColorNOperator Constructor()
Initializes a new PdfSetFillColorNOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetFillColorNOperator()
public PdfSetFillColorNOperator()
public:
PdfSetFillColorNOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorNOperator Class
PdfSetFillColorNOperator Members
Overload List


%%PageItemTitle%%

PdfSetFillColorNOperator Constructor(Double[],PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorNOperator Class > PdfSetFillColorNOperator Constructor : PdfSetFillColorNOperator Constructor(Double[],PdfCosName)
The color components.
The pattern ID in the /Resources dictionary.
Initializes a new PdfSetFillColorNOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorComponents() As Double, _
   ByVal patternID As PdfCosName _
)
'Usage

Dim colorComponents() As Double
Dim patternID As PdfCosName

Dim instance As New PdfSetFillColorNOperator(colorComponents, patternID)
public PdfSetFillColorNOperator(
   double[] colorComponents,
   PdfCosName patternID
)
public:
PdfSetFillColorNOperator(
   array<double>^ colorComponents,
   PdfCosName^ patternID
)

Parameters

colorComponents
The color components.
patternID
The pattern ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorNOperator Class
PdfSetFillColorNOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetFillColorNOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorNOperator Class

For a list of all members of this type, see PdfSetFillColorNOperator members.

Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | PatternID | Gets or sets the pattern ID.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetFillColorNOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


ColorComponents Property (PdfSetFillColorNOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorNOperator Class : ColorComponents Property
Gets or sets the color components.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorComponents As Double()
'Usage

Dim instance As PdfSetFillColorNOperator
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
public double[] ColorComponents {get; set;}
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

The color components.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorNOperator Class
PdfSetFillColorNOperator Members


PatternID Property (PdfSetFillColorNOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorNOperator Class : PatternID Property
Gets or sets the pattern ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PatternID As PdfCosName
'Usage

Dim instance As PdfSetFillColorNOperator
Dim value As PdfCosName

instance.PatternID = value

value = instance.PatternID
public PdfCosName PatternID {get; set;}
public:
property PdfCosName^ PatternID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The pattern ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorNOperator Class
PdfSetFillColorNOperator Members


%%PageItemTitle%%

PdfSetFillColorOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorOperator Class
Defines the sc (set fill color) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetFillColorOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetFillColorOperator
public class PdfSetFillColorOperator : PdfContentStreamOperator
public ref class PdfSetFillColorOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetFillColorOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorOperator Class

The following tables list the members exposed by PdfSetFillColorOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetFillColorOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetFillColorOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetFillColorOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorOperator Class : PdfSetFillColorOperator Constructor
Overload List
Overload | Description
PdfSetFillColorOperator Constructor() | Initializes a new PdfSetFillColorOperator object.
PdfSetFillColorOperator Constructor(Double[]) | Initializes a new PdfSetFillColorOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorOperator Class
PdfSetFillColorOperator Members


%%PageItemTitle%%

PdfSetFillColorOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorOperator Class > PdfSetFillColorOperator Constructor : PdfSetFillColorOperator Constructor()
Initializes a new PdfSetFillColorOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetFillColorOperator()
public PdfSetFillColorOperator()
public:
PdfSetFillColorOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorOperator Class
PdfSetFillColorOperator Members
Overload List


%%PageItemTitle%%

PdfSetFillColorOperator Constructor(Double[])

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorOperator Class > PdfSetFillColorOperator Constructor : PdfSetFillColorOperator Constructor(Double[])
The color components.
Initializes a new PdfSetFillColorOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorComponents() As Double _
)
'Usage

Dim colorComponents() As Double

Dim instance As New PdfSetFillColorOperator(colorComponents)
public PdfSetFillColorOperator(
   double[] colorComponents
)
public:
PdfSetFillColorOperator(
   array<double>^ colorComponents
)

Parameters

colorComponents
The color components.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorOperator Class
PdfSetFillColorOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetFillColorOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorOperator Class

For a list of all members of this type, see PdfSetFillColorOperator members.

Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetFillColorOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


ColorComponents Property (PdfSetFillColorOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorOperator Class : ColorComponents Property
Gets or sets the color components.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorComponents As Double()
'Usage

Dim instance As PdfSetFillColorOperator
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
public double[] ColorComponents {get; set;}
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

The color components.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorOperator Class
PdfSetFillColorOperator Members


%%PageItemTitle%%

PdfSetFillColorSpaceOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorSpaceOperator Class
Defines the cs (set fill colorspace) content stream operator.
Object Model
PdfSetFillColorSpaceOperator ClassPdfColorSpace ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetFillColorSpaceOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetFillColorSpaceOperator
public class PdfSetFillColorSpaceOperator : PdfContentStreamOperator
public ref class PdfSetFillColorSpaceOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFillColorSpaceOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorSpaceOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetFillColorSpaceOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorSpaceOperator Class

The following tables list the members exposed by PdfSetFillColorSpaceOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetFillColorSpaceOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the colorspace.
Public Property | ColorSpaceID | Gets or sets the colorspace ID.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetFillColorSpaceOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetFillColorSpaceOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorSpaceOperator Class : PdfSetFillColorSpaceOperator Constructor
Overload List
Overload | Description
PdfSetFillColorSpaceOperator Constructor() | Initializes a new PdfSetFillColorSpaceOperator object.
PdfSetFillColorSpaceOperator Constructor(PdfCosName) | Initializes a new PdfSetFillColorSpaceOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorSpaceOperator Class
PdfSetFillColorSpaceOperator Members


%%PageItemTitle%%

PdfSetFillColorSpaceOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorSpaceOperator Class > PdfSetFillColorSpaceOperator Constructor : PdfSetFillColorSpaceOperator Constructor()
Initializes a new PdfSetFillColorSpaceOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetFillColorSpaceOperator()
public PdfSetFillColorSpaceOperator()
public:
PdfSetFillColorSpaceOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorSpaceOperator Class
PdfSetFillColorSpaceOperator Members
Overload List


%%PageItemTitle%%

PdfSetFillColorSpaceOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorSpaceOperator Class > PdfSetFillColorSpaceOperator Constructor : PdfSetFillColorSpaceOperator Constructor(PdfCosName)
The colorspace ID in the /Resources dictionary.
Initializes a new PdfSetFillColorSpaceOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpaceID As PdfCosName _
)
'Usage

Dim colorSpaceID As PdfCosName

Dim instance As New PdfSetFillColorSpaceOperator(colorSpaceID)
public PdfSetFillColorSpaceOperator(
   PdfCosName colorSpaceID
)
public:
PdfSetFillColorSpaceOperator(
   PdfCosName^ colorSpaceID
)

Parameters

colorSpaceID
The colorspace ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorSpaceOperator Class
PdfSetFillColorSpaceOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetFillColorSpaceOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFillColorSpaceOperator Class

For a list of all members of this type, see PdfSetFillColorSpaceOperator members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the colorspace.
Public Property | ColorSpaceID | Gets or sets the colorspace ID.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetFillColorSpaceOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


ColorSpace Property (PdfSetFillColorSpaceOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorSpaceOperator Class : ColorSpace Property
Gets or sets the colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorSpace As PdfColorSpace
'Usage

Dim instance As PdfSetFillColorSpaceOperator
Dim value As PdfColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PdfColorSpace ColorSpace {get; set;}
public:
property PdfColorSpace^ ColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

The colorspace object set by this operator.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorSpaceOperator Class
PdfSetFillColorSpaceOperator Members


ColorSpaceID Property (PdfSetFillColorSpaceOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFillColorSpaceOperator Class : ColorSpaceID Property
Gets or sets the colorspace ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorSpaceID As PdfCosName
'Usage

Dim instance As PdfSetFillColorSpaceOperator
Dim value As PdfCosName

instance.ColorSpaceID = value

value = instance.ColorSpaceID
public PdfCosName ColorSpaceID {get; set;}
public:
property PdfCosName^ ColorSpaceID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The colorspace ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFillColorSpaceOperator Class
PdfSetFillColorSpaceOperator Members


%%PageItemTitle%%

PdfSetFlatnessToleranceOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFlatnessToleranceOperator Class
Defines the i (set flatness tolerance) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetFlatnessToleranceOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetFlatnessToleranceOperator
public class PdfSetFlatnessToleranceOperator : PdfContentStreamOperator
public ref class PdfSetFlatnessToleranceOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetFlatnessToleranceOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFlatnessToleranceOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetFlatnessToleranceOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFlatnessToleranceOperator Class

The following tables list the members exposed by PdfSetFlatnessToleranceOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetFlatnessToleranceOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | I | Gets or sets the flatness tolerance.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetFlatnessToleranceOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetFlatnessToleranceOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFlatnessToleranceOperator Class : PdfSetFlatnessToleranceOperator Constructor
Overload List
Overload | Description
PdfSetFlatnessToleranceOperator Constructor() | Initializes a new PdfSetFlatnessToleranceOperator object.
PdfSetFlatnessToleranceOperator Constructor(Double) | Initializes a new PdfSetFlatnessToleranceOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFlatnessToleranceOperator Class
PdfSetFlatnessToleranceOperator Members


%%PageItemTitle%%

PdfSetFlatnessToleranceOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFlatnessToleranceOperator Class > PdfSetFlatnessToleranceOperator Constructor : PdfSetFlatnessToleranceOperator Constructor()
Initializes a new PdfSetFlatnessToleranceOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetFlatnessToleranceOperator()
public PdfSetFlatnessToleranceOperator()
public:
PdfSetFlatnessToleranceOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFlatnessToleranceOperator Class
PdfSetFlatnessToleranceOperator Members
Overload List


%%PageItemTitle%%

PdfSetFlatnessToleranceOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFlatnessToleranceOperator Class > PdfSetFlatnessToleranceOperator Constructor : PdfSetFlatnessToleranceOperator Constructor(Double)
The flatness tolerance.
Initializes a new PdfSetFlatnessToleranceOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal i As Double _
)
'Usage

Dim i As Double

Dim instance As New PdfSetFlatnessToleranceOperator(i)
public PdfSetFlatnessToleranceOperator(
   double i
)
public:
PdfSetFlatnessToleranceOperator(
   double i
)

Parameters

i
The flatness tolerance.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFlatnessToleranceOperator Class
PdfSetFlatnessToleranceOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetFlatnessToleranceOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetFlatnessToleranceOperator Class

For a list of all members of this type, see PdfSetFlatnessToleranceOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | I | Gets or sets the flatness tolerance.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetFlatnessToleranceOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


I Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetFlatnessToleranceOperator Class : I Property
Gets or sets the flatness tolerance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property I As Double
'Usage

Dim instance As PdfSetFlatnessToleranceOperator
Dim value As Double

instance.I = value

value = instance.I
public double I {get; set;}
public:
property double I {
   double get();
   void set (    double value);
}

Property Value

The flatness tolerance.
Remarks
The value is a number in the range 0 to 100.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetFlatnessToleranceOperator Class
PdfSetFlatnessToleranceOperator Members


%%PageItemTitle%%

PdfSetGraphicsStateOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGraphicsStateOperator Class
Defines the gs (set graphics state) content stream operator.
Object Model
PdfSetGraphicsStateOperator ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetGraphicsStateOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetGraphicsStateOperator
public class PdfSetGraphicsStateOperator : PdfContentStreamOperator
public ref class PdfSetGraphicsStateOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGraphicsStateOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGraphicsStateOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetGraphicsStateOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGraphicsStateOperator Class

The following tables list the members exposed by PdfSetGraphicsStateOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetGraphicsStateOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | GraphicsStateID | Gets or sets the graphics state ID.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetGraphicsStateOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetGraphicsStateOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGraphicsStateOperator Class : PdfSetGraphicsStateOperator Constructor
Overload List
Overload | Description
PdfSetGraphicsStateOperator Constructor() | Initializes a new PdfSetGraphicsStateOperator object.
PdfSetGraphicsStateOperator Constructor(PdfCosName) | Initializes a new PdfSetGraphicsStateOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGraphicsStateOperator Class
PdfSetGraphicsStateOperator Members


%%PageItemTitle%%

PdfSetGraphicsStateOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGraphicsStateOperator Class > PdfSetGraphicsStateOperator Constructor : PdfSetGraphicsStateOperator Constructor()
Initializes a new PdfSetGraphicsStateOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetGraphicsStateOperator()
public PdfSetGraphicsStateOperator()
public:
PdfSetGraphicsStateOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGraphicsStateOperator Class
PdfSetGraphicsStateOperator Members
Overload List


%%PageItemTitle%%

PdfSetGraphicsStateOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGraphicsStateOperator Class > PdfSetGraphicsStateOperator Constructor : PdfSetGraphicsStateOperator Constructor(PdfCosName)
The graphics state ID in the /Resources dictionary.
Initializes a new PdfSetGraphicsStateOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal graphicsStateID As PdfCosName _
)
'Usage

Dim graphicsStateID As PdfCosName

Dim instance As New PdfSetGraphicsStateOperator(graphicsStateID)
public PdfSetGraphicsStateOperator(
   PdfCosName graphicsStateID
)
public:
PdfSetGraphicsStateOperator(
   PdfCosName^ graphicsStateID
)

Parameters

graphicsStateID
The graphics state ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGraphicsStateOperator Class
PdfSetGraphicsStateOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetGraphicsStateOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGraphicsStateOperator Class

For a list of all members of this type, see PdfSetGraphicsStateOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | GraphicsStateID | Gets or sets the graphics state ID.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetGraphicsStateOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


GraphicsStateID Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGraphicsStateOperator Class : GraphicsStateID Property
Gets or sets the graphics state ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property GraphicsStateID As PdfCosName
'Usage

Dim instance As PdfSetGraphicsStateOperator
Dim value As PdfCosName

instance.GraphicsStateID = value

value = instance.GraphicsStateID
public PdfCosName GraphicsStateID {get; set;}
public:
property PdfCosName^ GraphicsStateID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The graphics state ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGraphicsStateOperator Class
PdfSetGraphicsStateOperator Members


%%PageItemTitle%%

PdfSetGrayFillOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGrayFillOperator Class
Defines the g (set gray level for fill operations) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetGrayFillOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetGrayFillOperator
public class PdfSetGrayFillOperator : PdfContentStreamOperator
public ref class PdfSetGrayFillOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGrayFillOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayFillOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetGrayFillOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGrayFillOperator Class

The following tables list the members exposed by PdfSetGrayFillOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetGrayFillOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | G | Gets or sets the gray level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetGrayFillOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetGrayFillOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGrayFillOperator Class : PdfSetGrayFillOperator Constructor
Overload List
Overload | Description
PdfSetGrayFillOperator Constructor() | Initializes a new PdfSetGrayFillOperator object.
PdfSetGrayFillOperator Constructor(Double) | Initializes a new PdfSetGrayFillOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayFillOperator Class
PdfSetGrayFillOperator Members


%%PageItemTitle%%

PdfSetGrayFillOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGrayFillOperator Class > PdfSetGrayFillOperator Constructor : PdfSetGrayFillOperator Constructor()
Initializes a new PdfSetGrayFillOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetGrayFillOperator()
public PdfSetGrayFillOperator()
public:
PdfSetGrayFillOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayFillOperator Class
PdfSetGrayFillOperator Members
Overload List


%%PageItemTitle%%

PdfSetGrayFillOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGrayFillOperator Class > PdfSetGrayFillOperator Constructor : PdfSetGrayFillOperator Constructor(Double)
The gray level.
Initializes a new PdfSetGrayFillOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal g As Double _
)
'Usage

Dim g As Double

Dim instance As New PdfSetGrayFillOperator(g)
public PdfSetGrayFillOperator(
   double g
)
public:
PdfSetGrayFillOperator(
   double g
)

Parameters

g
The gray level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayFillOperator Class
PdfSetGrayFillOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetGrayFillOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGrayFillOperator Class

For a list of all members of this type, see PdfSetGrayFillOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | G | Gets or sets the gray level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetGrayFillOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


G Property (PdfSetGrayFillOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGrayFillOperator Class : G Property
Gets or sets the gray level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property G As Double
'Usage

Dim instance As PdfSetGrayFillOperator
Dim value As Double

instance.G = value

value = instance.G
public double G {get; set;}
public:
property double G {
   double get();
   void set (    double value);
}

Property Value

The gray level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayFillOperator Class
PdfSetGrayFillOperator Members


%%PageItemTitle%%

PdfSetGrayStrokeOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGrayStrokeOperator Class
Defines the G (set gray level for stroke operations) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetGrayStrokeOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetGrayStrokeOperator
public class PdfSetGrayStrokeOperator : PdfContentStreamOperator
public ref class PdfSetGrayStrokeOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetGrayStrokeOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayStrokeOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetGrayStrokeOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGrayStrokeOperator Class

The following tables list the members exposed by PdfSetGrayStrokeOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetGrayStrokeOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | G | Gets or sets the gray level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetGrayStrokeOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetGrayStrokeOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGrayStrokeOperator Class : PdfSetGrayStrokeOperator Constructor
Overload List
Overload | Description
PdfSetGrayStrokeOperator Constructor() | Initializes a new PdfSetGrayStrokeOperator object.
PdfSetGrayStrokeOperator Constructor(Double) | Initializes a new PdfSetGrayStrokeOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayStrokeOperator Class
PdfSetGrayStrokeOperator Members


%%PageItemTitle%%

PdfSetGrayStrokeOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGrayStrokeOperator Class > PdfSetGrayStrokeOperator Constructor : PdfSetGrayStrokeOperator Constructor()
Initializes a new PdfSetGrayStrokeOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetGrayStrokeOperator()
public PdfSetGrayStrokeOperator()
public:
PdfSetGrayStrokeOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayStrokeOperator Class
PdfSetGrayStrokeOperator Members
Overload List


%%PageItemTitle%%

PdfSetGrayStrokeOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGrayStrokeOperator Class > PdfSetGrayStrokeOperator Constructor : PdfSetGrayStrokeOperator Constructor(Double)
The gray level.
Initializes a new PdfSetGrayStrokeOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal g As Double _
)
'Usage

Dim g As Double

Dim instance As New PdfSetGrayStrokeOperator(g)
public PdfSetGrayStrokeOperator(
   double g
)
public:
PdfSetGrayStrokeOperator(
   double g
)

Parameters

g
The gray level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayStrokeOperator Class
PdfSetGrayStrokeOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetGrayStrokeOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetGrayStrokeOperator Class

For a list of all members of this type, see PdfSetGrayStrokeOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | G | Gets or sets the gray level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetGrayStrokeOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


G Property (PdfSetGrayStrokeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetGrayStrokeOperator Class : G Property
Gets or sets the gray level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property G As Double
'Usage

Dim instance As PdfSetGrayStrokeOperator
Dim value As Double

instance.G = value

value = instance.G
public double G {get; set;}
public:
property double G {
   double get();
   void set (    double value);
}

Property Value

The gray level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetGrayStrokeOperator Class
PdfSetGrayStrokeOperator Members


%%PageItemTitle%%

PdfSetLineCapOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineCapOperator Class
Defines the J (set line cap) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetLineCapOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetLineCapOperator
public class PdfSetLineCapOperator : PdfContentStreamOperator
public ref class PdfSetLineCapOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineCapOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineCapOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetLineCapOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineCapOperator Class

The following tables list the members exposed by PdfSetLineCapOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetLineCapOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | LineCap | Gets or sets the cap join.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetLineCapOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetLineCapOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineCapOperator Class : PdfSetLineCapOperator Constructor
Overload List
Overload | Description
PdfSetLineCapOperator Constructor() | Initializes a new PdfSetLineCapOperator object.
PdfSetLineCapOperator Constructor(PdfLineCap) | Initializes a new PdfSetLineCapOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineCapOperator Class
PdfSetLineCapOperator Members


%%PageItemTitle%%

PdfSetLineCapOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineCapOperator Class > PdfSetLineCapOperator Constructor : PdfSetLineCapOperator Constructor()
Initializes a new PdfSetLineCapOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetLineCapOperator()
public PdfSetLineCapOperator()
public:
PdfSetLineCapOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineCapOperator Class
PdfSetLineCapOperator Members
Overload List


%%PageItemTitle%%

PdfSetLineCapOperator Constructor(PdfLineCap)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineCapOperator Class > PdfSetLineCapOperator Constructor : PdfSetLineCapOperator Constructor(PdfLineCap)
The line cap style.
Initializes a new PdfSetLineCapOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal lineCap As PdfLineCap _
)
'Usage

Dim lineCap As PdfLineCap

Dim instance As New PdfSetLineCapOperator(lineCap)
public PdfSetLineCapOperator(
   PdfLineCap lineCap
)
public:
PdfSetLineCapOperator(
   PdfLineCap lineCap
)

Parameters

lineCap
The line cap style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineCapOperator Class
PdfSetLineCapOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetLineCapOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineCapOperator Class

For a list of all members of this type, see PdfSetLineCapOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | LineCap | Gets or sets the cap join.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetLineCapOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


LineCap Property (PdfSetLineCapOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineCapOperator Class : LineCap Property
Gets or sets the cap join.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineCap As PdfLineCap
'Usage

Dim instance As PdfSetLineCapOperator
Dim value As PdfLineCap

instance.LineCap = value

value = instance.LineCap
public PdfLineCap LineCap {get; set;}
public:
property PdfLineCap LineCap {
   PdfLineCap get();
   void set (    PdfLineCap value);
}

Property Value

The line cap style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineCapOperator Class
PdfSetLineCapOperator Members


%%PageItemTitle%%

PdfSetLineDashPatternOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineDashPatternOperator Class
Defines the d (set line dash) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetLineDashPatternOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetLineDashPatternOperator
public class PdfSetLineDashPatternOperator : PdfContentStreamOperator
public ref class PdfSetLineDashPatternOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineDashPatternOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineDashPatternOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetLineDashPatternOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineDashPatternOperator Class

The following tables list the members exposed by PdfSetLineDashPatternOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetLineDashPatternOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | DashArray | Gets or sets the dash array.
Public Property | DashPhase | Gets or sets the dash phase.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetLineDashPatternOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetLineDashPatternOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineDashPatternOperator Class : PdfSetLineDashPatternOperator Constructor
Overload List
Overload | Description
PdfSetLineDashPatternOperator Constructor() | Initializes a new PdfSetLineDashPatternOperator object.
PdfSetLineDashPatternOperator Constructor(Double[],Double) | Initializes a new PdfSetLineDashPatternOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineDashPatternOperator Class
PdfSetLineDashPatternOperator Members


%%PageItemTitle%%

PdfSetLineDashPatternOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineDashPatternOperator Class > PdfSetLineDashPatternOperator Constructor : PdfSetLineDashPatternOperator Constructor()
Initializes a new PdfSetLineDashPatternOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetLineDashPatternOperator()
public PdfSetLineDashPatternOperator()
public:
PdfSetLineDashPatternOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineDashPatternOperator Class
PdfSetLineDashPatternOperator Members
Overload List


%%PageItemTitle%%

PdfSetLineDashPatternOperator Constructor(Double[],Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineDashPatternOperator Class > PdfSetLineDashPatternOperator Constructor : PdfSetLineDashPatternOperator Constructor(Double[],Double)
An array of numbers that specify the lengths of alternating dashes and gaps.
The dash phase.
Initializes a new PdfSetLineDashPatternOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dashArray() As Double, _
   ByVal dashPhase As Double _
)
'Usage

Dim dashArray() As Double
Dim dashPhase As Double

Dim instance As New PdfSetLineDashPatternOperator(dashArray, dashPhase)
public PdfSetLineDashPatternOperator(
   double[] dashArray,
   double dashPhase
)
public:
PdfSetLineDashPatternOperator(
   array<double>^ dashArray,
   double dashPhase
)

Parameters

dashArray
An array of numbers that specify the lengths of alternating dashes and gaps.
dashPhase
The dash phase.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineDashPatternOperator Class
PdfSetLineDashPatternOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetLineDashPatternOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineDashPatternOperator Class

For a list of all members of this type, see PdfSetLineDashPatternOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | DashArray | Gets or sets the dash array.
Public Property | DashPhase | Gets or sets the dash phase.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetLineDashPatternOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


DashArray Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineDashPatternOperator Class : DashArray Property
Gets or sets the dash array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DashArray As Double()
'Usage

Dim instance As PdfSetLineDashPatternOperator
Dim value() As Double

instance.DashArray = value

value = instance.DashArray
public double[] DashArray {get; set;}
public:
property array<double>^ DashArray {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of numbers that specify the lengths of alternating dashes and gaps.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineDashPatternOperator Class
PdfSetLineDashPatternOperator Members


DashPhase Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineDashPatternOperator Class : DashPhase Property
Gets or sets the dash phase.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DashPhase As Double
'Usage

Dim instance As PdfSetLineDashPatternOperator
Dim value As Double

instance.DashPhase = value

value = instance.DashPhase
public double DashPhase {get; set;}
public:
property double DashPhase {
   double get();
   void set (    double value);
}

Property Value

The dash phase.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineDashPatternOperator Class
PdfSetLineDashPatternOperator Members


%%PageItemTitle%%

PdfSetLineJoinOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineJoinOperator Class
Defines the j (set line join) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetLineJoinOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetLineJoinOperator
public class PdfSetLineJoinOperator : PdfContentStreamOperator
public ref class PdfSetLineJoinOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineJoinOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineJoinOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetLineJoinOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineJoinOperator Class

The following tables list the members exposed by PdfSetLineJoinOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetLineJoinOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | LineJoin | Gets or sets the line join.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetLineJoinOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetLineJoinOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineJoinOperator Class : PdfSetLineJoinOperator Constructor
Overload List
Overload | Description
PdfSetLineJoinOperator Constructor() | Initializes a new PdfSetLineJoinOperator object.
PdfSetLineJoinOperator Constructor(PdfLineJoin) | Initializes a new PdfSetLineJoinOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineJoinOperator Class
PdfSetLineJoinOperator Members


%%PageItemTitle%%

PdfSetLineJoinOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineJoinOperator Class > PdfSetLineJoinOperator Constructor : PdfSetLineJoinOperator Constructor()
Initializes a new PdfSetLineJoinOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetLineJoinOperator()
public PdfSetLineJoinOperator()
public:
PdfSetLineJoinOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineJoinOperator Class
PdfSetLineJoinOperator Members
Overload List


%%PageItemTitle%%

PdfSetLineJoinOperator Constructor(PdfLineJoin)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineJoinOperator Class > PdfSetLineJoinOperator Constructor : PdfSetLineJoinOperator Constructor(PdfLineJoin)
The line join style.
Initializes a new PdfSetLineJoinOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal lineJoin As PdfLineJoin _
)
'Usage

Dim lineJoin As PdfLineJoin

Dim instance As New PdfSetLineJoinOperator(lineJoin)
public PdfSetLineJoinOperator(
   PdfLineJoin lineJoin
)
public:
PdfSetLineJoinOperator(
   PdfLineJoin lineJoin
)

Parameters

lineJoin
The line join style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineJoinOperator Class
PdfSetLineJoinOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetLineJoinOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineJoinOperator Class

For a list of all members of this type, see PdfSetLineJoinOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | LineJoin | Gets or sets the line join.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetLineJoinOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


LineJoin Property (PdfSetLineJoinOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineJoinOperator Class : LineJoin Property
Gets or sets the line join.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LineJoin As PdfLineJoin
'Usage

Dim instance As PdfSetLineJoinOperator
Dim value As PdfLineJoin

instance.LineJoin = value

value = instance.LineJoin
public PdfLineJoin LineJoin {get; set;}
public:
property PdfLineJoin LineJoin {
   PdfLineJoin get();
   void set (    PdfLineJoin value);
}

Property Value

The line join style.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineJoinOperator Class
PdfSetLineJoinOperator Members


%%PageItemTitle%%

PdfSetLineWidthOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineWidthOperator Class
Defines the w (set line width) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetLineWidthOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetLineWidthOperator
public class PdfSetLineWidthOperator : PdfContentStreamOperator
public ref class PdfSetLineWidthOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetLineWidthOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineWidthOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetLineWidthOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineWidthOperator Class

The following tables list the members exposed by PdfSetLineWidthOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetLineWidthOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | W | Gets or sets the line width.
Top
See Also

Reference

PdfSetLineWidthOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetLineWidthOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineWidthOperator Class : PdfSetLineWidthOperator Constructor
Overload List
Overload | Description
PdfSetLineWidthOperator Constructor() | Initializes a new PdfSetLineWidthOperator object.
PdfSetLineWidthOperator Constructor(Double) | Initializes a new PdfSetLineWidthOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineWidthOperator Class
PdfSetLineWidthOperator Members


%%PageItemTitle%%

PdfSetLineWidthOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineWidthOperator Class > PdfSetLineWidthOperator Constructor : PdfSetLineWidthOperator Constructor()
Initializes a new PdfSetLineWidthOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetLineWidthOperator()
public PdfSetLineWidthOperator()
public:
PdfSetLineWidthOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineWidthOperator Class
PdfSetLineWidthOperator Members
Overload List


%%PageItemTitle%%

PdfSetLineWidthOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineWidthOperator Class > PdfSetLineWidthOperator Constructor : PdfSetLineWidthOperator Constructor(Double)
The line width.
Initializes a new PdfSetLineWidthOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal w As Double _
)
'Usage

Dim w As Double

Dim instance As New PdfSetLineWidthOperator(w)
public PdfSetLineWidthOperator(
   double w
)
public:
PdfSetLineWidthOperator(
   double w
)

Parameters

w
The line width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineWidthOperator Class
PdfSetLineWidthOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetLineWidthOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetLineWidthOperator Class

For a list of all members of this type, see PdfSetLineWidthOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | W | Gets or sets the line width.
Top
See Also

Reference

PdfSetLineWidthOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


W Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetLineWidthOperator Class : W Property
Gets or sets the line width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property W As Double
'Usage

Dim instance As PdfSetLineWidthOperator
Dim value As Double

instance.W = value

value = instance.W
public double W {get; set;}
public:
property double W {
   double get();
   void set (    double value);
}

Property Value

The line width.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetLineWidthOperator Class
PdfSetLineWidthOperator Members


%%PageItemTitle%%

PdfSetMiterLimitOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetMiterLimitOperator Class
Defines the M (set miter limit) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetMiterLimitOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetMiterLimitOperator
public class PdfSetMiterLimitOperator : PdfContentStreamOperator
public ref class PdfSetMiterLimitOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetMiterLimitOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetMiterLimitOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetMiterLimitOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetMiterLimitOperator Class

The following tables list the members exposed by PdfSetMiterLimitOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetMiterLimitOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | M | Gets or sets the miter limit.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetMiterLimitOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetMiterLimitOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetMiterLimitOperator Class : PdfSetMiterLimitOperator Constructor
Overload List
Overload | Description
PdfSetMiterLimitOperator Constructor() | Initializes a new PdfSetMiterLimitOperator object.
PdfSetMiterLimitOperator Constructor(Double) | Initializes a new PdfSetMiterLimitOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetMiterLimitOperator Class
PdfSetMiterLimitOperator Members


%%PageItemTitle%%

PdfSetMiterLimitOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetMiterLimitOperator Class > PdfSetMiterLimitOperator Constructor : PdfSetMiterLimitOperator Constructor()
Initializes a new PdfSetMiterLimitOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetMiterLimitOperator()
public PdfSetMiterLimitOperator()
public:
PdfSetMiterLimitOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetMiterLimitOperator Class
PdfSetMiterLimitOperator Members
Overload List


%%PageItemTitle%%

PdfSetMiterLimitOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetMiterLimitOperator Class > PdfSetMiterLimitOperator Constructor : PdfSetMiterLimitOperator Constructor(Double)
The miter limit.
Initializes a new PdfSetMiterLimitOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal m As Double _
)
'Usage

Dim m As Double

Dim instance As New PdfSetMiterLimitOperator(m)
public PdfSetMiterLimitOperator(
   double m
)
public:
PdfSetMiterLimitOperator(
   double m
)

Parameters

m
The miter limit.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetMiterLimitOperator Class
PdfSetMiterLimitOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetMiterLimitOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetMiterLimitOperator Class

For a list of all members of this type, see PdfSetMiterLimitOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | M | Gets or sets the miter limit.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetMiterLimitOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


M Property (PdfSetMiterLimitOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetMiterLimitOperator Class : M Property
Gets or sets the miter limit.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M As Double
'Usage

Dim instance As PdfSetMiterLimitOperator
Dim value As Double

instance.M = value

value = instance.M
public double M {get; set;}
public:
property double M {
   double get();
   void set (    double value);
}

Property Value

The miter limit.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetMiterLimitOperator Class
PdfSetMiterLimitOperator Members


%%PageItemTitle%%

PdfSetRenderingIntentOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRenderingIntentOperator Class
Defines the ri (set rendering intent) content stream operator.
Object Model
PdfSetRenderingIntentOperator ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetRenderingIntentOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetRenderingIntentOperator
public class PdfSetRenderingIntentOperator : PdfContentStreamOperator
public ref class PdfSetRenderingIntentOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRenderingIntentOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRenderingIntentOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetRenderingIntentOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRenderingIntentOperator Class

The following tables list the members exposed by PdfSetRenderingIntentOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetRenderingIntentOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | RenderingIntent | Gets or sets the rendering intent.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetRenderingIntentOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetRenderingIntentOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRenderingIntentOperator Class : PdfSetRenderingIntentOperator Constructor
Overload List
Overload | Description
PdfSetRenderingIntentOperator Constructor() | Initializes a new PdfSetRenderingIntentOperator object.
PdfSetRenderingIntentOperator Constructor(PdfCosName) | Initializes a new PdfSetRenderingIntentOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRenderingIntentOperator Class
PdfSetRenderingIntentOperator Members


%%PageItemTitle%%

PdfSetRenderingIntentOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRenderingIntentOperator Class > PdfSetRenderingIntentOperator Constructor : PdfSetRenderingIntentOperator Constructor()
Initializes a new PdfSetRenderingIntentOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetRenderingIntentOperator()
public PdfSetRenderingIntentOperator()
public:
PdfSetRenderingIntentOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRenderingIntentOperator Class
PdfSetRenderingIntentOperator Members
Overload List


%%PageItemTitle%%

PdfSetRenderingIntentOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRenderingIntentOperator Class > PdfSetRenderingIntentOperator Constructor : PdfSetRenderingIntentOperator Constructor(PdfCosName)
The rendering intent.
Initializes a new PdfSetRenderingIntentOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal renderingIntent As PdfCosName _
)
'Usage

Dim renderingIntent As PdfCosName

Dim instance As New PdfSetRenderingIntentOperator(renderingIntent)
public PdfSetRenderingIntentOperator(
   PdfCosName renderingIntent
)
public:
PdfSetRenderingIntentOperator(
   PdfCosName^ renderingIntent
)

Parameters

renderingIntent
The rendering intent.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRenderingIntentOperator Class
PdfSetRenderingIntentOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetRenderingIntentOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRenderingIntentOperator Class

For a list of all members of this type, see PdfSetRenderingIntentOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | RenderingIntent | Gets or sets the rendering intent.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetRenderingIntentOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


RenderingIntent Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRenderingIntentOperator Class : RenderingIntent Property
Gets or sets the rendering intent.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RenderingIntent As PdfCosName
'Usage

Dim instance As PdfSetRenderingIntentOperator
Dim value As PdfCosName

instance.RenderingIntent = value

value = instance.RenderingIntent
public PdfCosName RenderingIntent {get; set;}
public:
property PdfCosName^ RenderingIntent {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The rendering intent.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRenderingIntentOperator Class
PdfSetRenderingIntentOperator Members


%%PageItemTitle%%

PdfSetRgbFillOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRgbFillOperator Class
Defines the rg (set RGB level for fill operations) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetRgbFillOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetRgbFillOperator
public class PdfSetRgbFillOperator : PdfContentStreamOperator
public ref class PdfSetRgbFillOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRgbFillOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbFillOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetRgbFillOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRgbFillOperator Class

The following tables list the members exposed by PdfSetRgbFillOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetRgbFillOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | B | Gets or sets the blue level.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | G | Gets or sets the green level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | R | Gets or sets the red level.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetRgbFillOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetRgbFillOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbFillOperator Class : PdfSetRgbFillOperator Constructor
Overload List
Overload | Description
PdfSetRgbFillOperator Constructor() | Initializes a new PdfSetRgbFillOperator object.
PdfSetRgbFillOperator Constructor(Double,Double,Double) | Initializes a new PdfSetRgbFillOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbFillOperator Class
PdfSetRgbFillOperator Members


%%PageItemTitle%%

PdfSetRgbFillOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbFillOperator Class > PdfSetRgbFillOperator Constructor : PdfSetRgbFillOperator Constructor()
Initializes a new PdfSetRgbFillOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetRgbFillOperator()
public PdfSetRgbFillOperator()
public:
PdfSetRgbFillOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbFillOperator Class
PdfSetRgbFillOperator Members
Overload List


%%PageItemTitle%%

PdfSetRgbFillOperator Constructor(Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbFillOperator Class > PdfSetRgbFillOperator Constructor : PdfSetRgbFillOperator Constructor(Double,Double,Double)
The red level.
The green level.
The blue level.
Initializes a new PdfSetRgbFillOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal r As Double, _
   ByVal g As Double, _
   ByVal b As Double _
)
'Usage

Dim r As Double
Dim g As Double
Dim b As Double

Dim instance As New PdfSetRgbFillOperator(r, g, b)
public PdfSetRgbFillOperator(
   double r,
   double g,
   double b
)
public:
PdfSetRgbFillOperator(
   double r,
   double g,
   double b
)

Parameters

r
The red level.
g
The green level.
b
The blue level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbFillOperator Class
PdfSetRgbFillOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetRgbFillOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRgbFillOperator Class

For a list of all members of this type, see PdfSetRgbFillOperator members.

Public Properties
 | Name | Description
Public Property | B | Gets or sets the blue level.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | G | Gets or sets the green level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | R | Gets or sets the red level.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetRgbFillOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


B Property (PdfSetRgbFillOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbFillOperator Class : B Property
Gets or sets the blue level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property B As Double
'Usage

Dim instance As PdfSetRgbFillOperator
Dim value As Double

instance.B = value

value = instance.B
public double B {get; set;}
public:
property double B {
   double get();
   void set (    double value);
}

Property Value

The blue level.
Remarks
The blue level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbFillOperator Class
PdfSetRgbFillOperator Members


G Property (PdfSetRgbFillOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbFillOperator Class : G Property
Gets or sets the green level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property G As Double
'Usage

Dim instance As PdfSetRgbFillOperator
Dim value As Double

instance.G = value

value = instance.G
public double G {get; set;}
public:
property double G {
   double get();
   void set (    double value);
}

Property Value

The green level.
Remarks
The green level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbFillOperator Class
PdfSetRgbFillOperator Members


R Property (PdfSetRgbFillOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbFillOperator Class : R Property
Gets or sets the red level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property R As Double
'Usage

Dim instance As PdfSetRgbFillOperator
Dim value As Double

instance.R = value

value = instance.R
public double R {get; set;}
public:
property double R {
   double get();
   void set (    double value);
}

Property Value

The red level.
Remarks
The red level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbFillOperator Class
PdfSetRgbFillOperator Members


%%PageItemTitle%%

PdfSetRgbStrokeOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRgbStrokeOperator Class
Defines the RG (set RGB level for stroke operations) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetRgbStrokeOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetRgbStrokeOperator
public class PdfSetRgbStrokeOperator : PdfContentStreamOperator
public ref class PdfSetRgbStrokeOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetRgbStrokeOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbStrokeOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetRgbStrokeOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRgbStrokeOperator Class

The following tables list the members exposed by PdfSetRgbStrokeOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetRgbStrokeOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | B | Gets or sets the blue level.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | G | Gets or sets the green level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | R | Gets or sets the red level.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetRgbStrokeOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetRgbStrokeOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbStrokeOperator Class : PdfSetRgbStrokeOperator Constructor
Overload List
Overload | Description
PdfSetRgbStrokeOperator Constructor() | Initializes a new PdfSetRgbStrokeOperator object.
PdfSetRgbStrokeOperator Constructor(Double,Double,Double) | Initializes a new PdfSetRgbStrokeOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbStrokeOperator Class
PdfSetRgbStrokeOperator Members


%%PageItemTitle%%

PdfSetRgbStrokeOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbStrokeOperator Class > PdfSetRgbStrokeOperator Constructor : PdfSetRgbStrokeOperator Constructor()
Initializes a new PdfSetRgbStrokeOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetRgbStrokeOperator()
public PdfSetRgbStrokeOperator()
public:
PdfSetRgbStrokeOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbStrokeOperator Class
PdfSetRgbStrokeOperator Members
Overload List


%%PageItemTitle%%

PdfSetRgbStrokeOperator Constructor(Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbStrokeOperator Class > PdfSetRgbStrokeOperator Constructor : PdfSetRgbStrokeOperator Constructor(Double,Double,Double)
The red level.
The green level.
The blue level.
Initializes a new PdfSetRgbStrokeOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal r As Double, _
   ByVal g As Double, _
   ByVal b As Double _
)
'Usage

Dim r As Double
Dim g As Double
Dim b As Double

Dim instance As New PdfSetRgbStrokeOperator(r, g, b)
public PdfSetRgbStrokeOperator(
   double r,
   double g,
   double b
)
public:
PdfSetRgbStrokeOperator(
   double r,
   double g,
   double b
)

Parameters

r
The red level.
g
The green level.
b
The blue level.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbStrokeOperator Class
PdfSetRgbStrokeOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetRgbStrokeOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetRgbStrokeOperator Class

For a list of all members of this type, see PdfSetRgbStrokeOperator members.

Public Properties
 | Name | Description
Public Property | B | Gets or sets the blue level.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | G | Gets or sets the green level.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | R | Gets or sets the red level.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetRgbStrokeOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


B Property (PdfSetRgbStrokeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbStrokeOperator Class : B Property
Gets or sets the blue level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property B As Double
'Usage

Dim instance As PdfSetRgbStrokeOperator
Dim value As Double

instance.B = value

value = instance.B
public double B {get; set;}
public:
property double B {
   double get();
   void set (    double value);
}

Property Value

The blue level.
Remarks
The blue level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbStrokeOperator Class
PdfSetRgbStrokeOperator Members


G Property (PdfSetRgbStrokeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbStrokeOperator Class : G Property
Gets or sets the green level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property G As Double
'Usage

Dim instance As PdfSetRgbStrokeOperator
Dim value As Double

instance.G = value

value = instance.G
public double G {get; set;}
public:
property double G {
   double get();
   void set (    double value);
}

Property Value

The green level.
Remarks
The green level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbStrokeOperator Class
PdfSetRgbStrokeOperator Members


R Property (PdfSetRgbStrokeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetRgbStrokeOperator Class : R Property
Gets or sets the red level.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property R As Double
'Usage

Dim instance As PdfSetRgbStrokeOperator
Dim value As Double

instance.R = value

value = instance.R
public double R {get; set;}
public:
property double R {
   double get();
   void set (    double value);
}

Property Value

The red level.
Remarks
The red level is in [0, 1] range.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetRgbStrokeOperator Class
PdfSetRgbStrokeOperator Members


%%PageItemTitle%%

PdfSetShadingOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetShadingOperator Class
Defines the sh (set shading) content stream operator.
Object Model
PdfSetShadingOperator ClassPdfShading ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetShadingOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetShadingOperator
public class PdfSetShadingOperator : PdfContentStreamOperator
public ref class PdfSetShadingOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetShadingOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetShadingOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetShadingOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetShadingOperator Class

The following tables list the members exposed by PdfSetShadingOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetShadingOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Shading | Gets the shading object associated with this operator.
Public Property | ShadingID | Gets or sets the shading ID.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetShadingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetShadingOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetShadingOperator Class : PdfSetShadingOperator Constructor
Overload List
Overload | Description
PdfSetShadingOperator Constructor() | Initializes a new PdfSetShadingOperator object.
PdfSetShadingOperator Constructor(PdfCosName) | Initializes a new PdfSetShadingOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetShadingOperator Class
PdfSetShadingOperator Members


%%PageItemTitle%%

PdfSetShadingOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetShadingOperator Class > PdfSetShadingOperator Constructor : PdfSetShadingOperator Constructor()
Initializes a new PdfSetShadingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetShadingOperator()
public PdfSetShadingOperator()
public:
PdfSetShadingOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetShadingOperator Class
PdfSetShadingOperator Members
Overload List


%%PageItemTitle%%

PdfSetShadingOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetShadingOperator Class > PdfSetShadingOperator Constructor : PdfSetShadingOperator Constructor(PdfCosName)
The shading ID in the /Resources dictionary.
Initializes a new PdfSetShadingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal shadingID As PdfCosName _
)
'Usage

Dim shadingID As PdfCosName

Dim instance As New PdfSetShadingOperator(shadingID)
public PdfSetShadingOperator(
   PdfCosName shadingID
)
public:
PdfSetShadingOperator(
   PdfCosName^ shadingID
)

Parameters

shadingID
The shading ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetShadingOperator Class
PdfSetShadingOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetShadingOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetShadingOperator Class

For a list of all members of this type, see PdfSetShadingOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Shading | Gets the shading object associated with this operator.
Public Property | ShadingID | Gets or sets the shading ID.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetShadingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Shading Property (PdfSetShadingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetShadingOperator Class : Shading Property
Gets the shading object associated with this operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Shading As PdfShading
'Usage

Dim instance As PdfSetShadingOperator
Dim value As PdfShading

value = instance.Shading
public PdfShading Shading {get;}
public:
property PdfShading^ Shading {
   PdfShading^ get();
}

Property Value

A Xfinium.Pdf.Graphics.PdfShading object that describes the shading painted by this operator.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetShadingOperator Class
PdfSetShadingOperator Members


ShadingID Property (PdfSetShadingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetShadingOperator Class : ShadingID Property
Gets or sets the shading ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShadingID As PdfCosName
'Usage

Dim instance As PdfSetShadingOperator
Dim value As PdfCosName

instance.ShadingID = value

value = instance.ShadingID
public PdfCosName ShadingID {get; set;}
public:
property PdfCosName^ ShadingID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The shading ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetShadingOperator Class
PdfSetShadingOperator Members


%%PageItemTitle%%

PdfSetStrokeColorNOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorNOperator Class
Defines the SCN (set stroke color) content stream operator.
Object Model
PdfSetStrokeColorNOperator ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetStrokeColorNOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetStrokeColorNOperator
public class PdfSetStrokeColorNOperator : PdfContentStreamOperator
public ref class PdfSetStrokeColorNOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorNOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorNOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetStrokeColorNOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorNOperator Class

The following tables list the members exposed by PdfSetStrokeColorNOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetStrokeColorNOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | PatternID | Gets or sets the pattern ID.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetStrokeColorNOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetStrokeColorNOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorNOperator Class : PdfSetStrokeColorNOperator Constructor
Overload List
Overload | Description
PdfSetStrokeColorNOperator Constructor() | Initializes a new PdfSetStrokeColorNOperator object.
PdfSetStrokeColorNOperator Constructor(Double[],PdfCosName) | Initializes a new PdfSetStrokeColorNOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorNOperator Class
PdfSetStrokeColorNOperator Members


%%PageItemTitle%%

PdfSetStrokeColorNOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorNOperator Class > PdfSetStrokeColorNOperator Constructor : PdfSetStrokeColorNOperator Constructor()
Initializes a new PdfSetStrokeColorNOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetStrokeColorNOperator()
public PdfSetStrokeColorNOperator()
public:
PdfSetStrokeColorNOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorNOperator Class
PdfSetStrokeColorNOperator Members
Overload List


%%PageItemTitle%%

PdfSetStrokeColorNOperator Constructor(Double[],PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorNOperator Class > PdfSetStrokeColorNOperator Constructor : PdfSetStrokeColorNOperator Constructor(Double[],PdfCosName)
The color components.
The pattern ID in the /Resources dictionary.
Initializes a new PdfSetStrokeColorNOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorComponents() As Double, _
   ByVal patternID As PdfCosName _
)
'Usage

Dim colorComponents() As Double
Dim patternID As PdfCosName

Dim instance As New PdfSetStrokeColorNOperator(colorComponents, patternID)
public PdfSetStrokeColorNOperator(
   double[] colorComponents,
   PdfCosName patternID
)
public:
PdfSetStrokeColorNOperator(
   array<double>^ colorComponents,
   PdfCosName^ patternID
)

Parameters

colorComponents
The color components.
patternID
The pattern ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorNOperator Class
PdfSetStrokeColorNOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetStrokeColorNOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorNOperator Class

For a list of all members of this type, see PdfSetStrokeColorNOperator members.

Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | PatternID | Gets or sets the pattern ID.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetStrokeColorNOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


ColorComponents Property (PdfSetStrokeColorNOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorNOperator Class : ColorComponents Property
Gets or sets the color components.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorComponents As Double()
'Usage

Dim instance As PdfSetStrokeColorNOperator
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
public double[] ColorComponents {get; set;}
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

The color components.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorNOperator Class
PdfSetStrokeColorNOperator Members


PatternID Property (PdfSetStrokeColorNOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorNOperator Class : PatternID Property
Gets or sets the pattern ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PatternID As PdfCosName
'Usage

Dim instance As PdfSetStrokeColorNOperator
Dim value As PdfCosName

instance.PatternID = value

value = instance.PatternID
public PdfCosName PatternID {get; set;}
public:
property PdfCosName^ PatternID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The pattern ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorNOperator Class
PdfSetStrokeColorNOperator Members


%%PageItemTitle%%

PdfSetStrokeColorOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorOperator Class
Defines the SC (set stroke color) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetStrokeColorOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetStrokeColorOperator
public class PdfSetStrokeColorOperator : PdfContentStreamOperator
public ref class PdfSetStrokeColorOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetStrokeColorOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorOperator Class

The following tables list the members exposed by PdfSetStrokeColorOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetStrokeColorOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetStrokeColorOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetStrokeColorOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorOperator Class : PdfSetStrokeColorOperator Constructor
Overload List
Overload | Description
PdfSetStrokeColorOperator Constructor() | Initializes a new PdfSetStrokeColorOperator object.
PdfSetStrokeColorOperator Constructor(Double[]) | Initializes a new PdfSetStrokeColorOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorOperator Class
PdfSetStrokeColorOperator Members


%%PageItemTitle%%

PdfSetStrokeColorOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorOperator Class > PdfSetStrokeColorOperator Constructor : PdfSetStrokeColorOperator Constructor()
Initializes a new PdfSetStrokeColorOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetStrokeColorOperator()
public PdfSetStrokeColorOperator()
public:
PdfSetStrokeColorOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorOperator Class
PdfSetStrokeColorOperator Members
Overload List


%%PageItemTitle%%

PdfSetStrokeColorOperator Constructor(Double[])

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorOperator Class > PdfSetStrokeColorOperator Constructor : PdfSetStrokeColorOperator Constructor(Double[])
The color components.
Initializes a new PdfSetStrokeColorOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorComponents() As Double _
)
'Usage

Dim colorComponents() As Double

Dim instance As New PdfSetStrokeColorOperator(colorComponents)
public PdfSetStrokeColorOperator(
   double[] colorComponents
)
public:
PdfSetStrokeColorOperator(
   array<double>^ colorComponents
)

Parameters

colorComponents
The color components.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorOperator Class
PdfSetStrokeColorOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetStrokeColorOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorOperator Class

For a list of all members of this type, see PdfSetStrokeColorOperator members.

Public Properties
 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetStrokeColorOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


ColorComponents Property (PdfSetStrokeColorOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorOperator Class : ColorComponents Property
Gets or sets the color components.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorComponents As Double()
'Usage

Dim instance As PdfSetStrokeColorOperator
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
public double[] ColorComponents {get; set;}
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

The color components.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorOperator Class
PdfSetStrokeColorOperator Members


%%PageItemTitle%%

PdfSetStrokeColorSpaceOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorSpaceOperator Class
Defines the CS (set stroke colorspace) content stream operator.
Object Model
PdfSetStrokeColorSpaceOperator ClassPdfColorSpace ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetStrokeColorSpaceOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetStrokeColorSpaceOperator
public class PdfSetStrokeColorSpaceOperator : PdfContentStreamOperator
public ref class PdfSetStrokeColorSpaceOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetStrokeColorSpaceOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorSpaceOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetStrokeColorSpaceOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorSpaceOperator Class

The following tables list the members exposed by PdfSetStrokeColorSpaceOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetStrokeColorSpaceOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the colorspace.
Public Property | ColorSpaceID | Gets or sets the colorspace ID.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetStrokeColorSpaceOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetStrokeColorSpaceOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorSpaceOperator Class : PdfSetStrokeColorSpaceOperator Constructor
Overload List
Overload | Description
PdfSetStrokeColorSpaceOperator Constructor() | Initializes a new PdfSetStrokeColorSpaceOperator object.
PdfSetStrokeColorSpaceOperator Constructor(PdfCosName) | Initializes a new PdfSetStrokeColorSpaceOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorSpaceOperator Class
PdfSetStrokeColorSpaceOperator Members


%%PageItemTitle%%

PdfSetStrokeColorSpaceOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorSpaceOperator Class > PdfSetStrokeColorSpaceOperator Constructor : PdfSetStrokeColorSpaceOperator Constructor()
Initializes a new PdfSetStrokeColorSpaceOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetStrokeColorSpaceOperator()
public PdfSetStrokeColorSpaceOperator()
public:
PdfSetStrokeColorSpaceOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorSpaceOperator Class
PdfSetStrokeColorSpaceOperator Members
Overload List


%%PageItemTitle%%

PdfSetStrokeColorSpaceOperator Constructor(PdfCosName)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorSpaceOperator Class > PdfSetStrokeColorSpaceOperator Constructor : PdfSetStrokeColorSpaceOperator Constructor(PdfCosName)
The colorspace ID in the /Resources dictionary.
Initializes a new PdfSetStrokeColorSpaceOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal colorSpaceID As PdfCosName _
)
'Usage

Dim colorSpaceID As PdfCosName

Dim instance As New PdfSetStrokeColorSpaceOperator(colorSpaceID)
public PdfSetStrokeColorSpaceOperator(
   PdfCosName colorSpaceID
)
public:
PdfSetStrokeColorSpaceOperator(
   PdfCosName^ colorSpaceID
)

Parameters

colorSpaceID
The colorspace ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorSpaceOperator Class
PdfSetStrokeColorSpaceOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetStrokeColorSpaceOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetStrokeColorSpaceOperator Class

For a list of all members of this type, see PdfSetStrokeColorSpaceOperator members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets or sets the colorspace.
Public Property | ColorSpaceID | Gets or sets the colorspace ID.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetStrokeColorSpaceOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


ColorSpace Property (PdfSetStrokeColorSpaceOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorSpaceOperator Class : ColorSpace Property
Gets or sets the colorspace.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorSpace As PdfColorSpace
'Usage

Dim instance As PdfSetStrokeColorSpaceOperator
Dim value As PdfColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
public PdfColorSpace ColorSpace {get; set;}
public:
property PdfColorSpace^ ColorSpace {
   PdfColorSpace^ get();
   void set (    PdfColorSpace^ value);
}

Property Value

The colorspace object set by this operator.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorSpaceOperator Class
PdfSetStrokeColorSpaceOperator Members


ColorSpaceID Property (PdfSetStrokeColorSpaceOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetStrokeColorSpaceOperator Class : ColorSpaceID Property
Gets or sets the colorspace ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColorSpaceID As PdfCosName
'Usage

Dim instance As PdfSetStrokeColorSpaceOperator
Dim value As PdfCosName

instance.ColorSpaceID = value

value = instance.ColorSpaceID
public PdfCosName ColorSpaceID {get; set;}
public:
property PdfCosName^ ColorSpaceID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The colorspace ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetStrokeColorSpaceOperator Class
PdfSetStrokeColorSpaceOperator Members


%%PageItemTitle%%

PdfSetTextFontAndSizeOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextFontAndSizeOperator Class
Defines the Tf (set font and size) content stream operator.
Object Model
PdfSetTextFontAndSizeOperator ClassPdfFont ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetTextFontAndSizeOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetTextFontAndSizeOperator
public class PdfSetTextFontAndSizeOperator : PdfContentStreamOperator
public ref class PdfSetTextFontAndSizeOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextFontAndSizeOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextFontAndSizeOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetTextFontAndSizeOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextFontAndSizeOperator Class

The following tables list the members exposed by PdfSetTextFontAndSizeOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetTextFontAndSizeOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Font | Gets the font object.
Public Property | FontID | Gets or sets the font ID.
Public Property | FontSize | Gets or sets the font size.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextFontAndSizeOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetTextFontAndSizeOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextFontAndSizeOperator Class : PdfSetTextFontAndSizeOperator Constructor
Overload List
Overload | Description
PdfSetTextFontAndSizeOperator Constructor() | Initializes a new PdfSetTextFontAndSizeOperator object.
PdfSetTextFontAndSizeOperator Constructor(PdfCosName,Double) | Initializes a new PdfSetTextFontAndSizeOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextFontAndSizeOperator Class
PdfSetTextFontAndSizeOperator Members


%%PageItemTitle%%

PdfSetTextFontAndSizeOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextFontAndSizeOperator Class > PdfSetTextFontAndSizeOperator Constructor : PdfSetTextFontAndSizeOperator Constructor()
Initializes a new PdfSetTextFontAndSizeOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetTextFontAndSizeOperator()
public PdfSetTextFontAndSizeOperator()
public:
PdfSetTextFontAndSizeOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextFontAndSizeOperator Class
PdfSetTextFontAndSizeOperator Members
Overload List


%%PageItemTitle%%

PdfSetTextFontAndSizeOperator Constructor(PdfCosName,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextFontAndSizeOperator Class > PdfSetTextFontAndSizeOperator Constructor : PdfSetTextFontAndSizeOperator Constructor(PdfCosName,Double)
The form XObject ID in the /Resources dictionary.
The font size.
Initializes a new PdfSetTextFontAndSizeOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal fontID As PdfCosName, _
   ByVal fontSize As Double _
)
'Usage

Dim fontID As PdfCosName
Dim fontSize As Double

Dim instance As New PdfSetTextFontAndSizeOperator(fontID, fontSize)
public PdfSetTextFontAndSizeOperator(
   PdfCosName fontID,
   double fontSize
)
public:
PdfSetTextFontAndSizeOperator(
   PdfCosName^ fontID,
   double fontSize
)

Parameters

fontID
The form XObject ID in the /Resources dictionary.
fontSize
The font size.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextFontAndSizeOperator Class
PdfSetTextFontAndSizeOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetTextFontAndSizeOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextFontAndSizeOperator Class

For a list of all members of this type, see PdfSetTextFontAndSizeOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Font | Gets the font object.
Public Property | FontID | Gets or sets the font ID.
Public Property | FontSize | Gets or sets the font size.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextFontAndSizeOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Font Property (PdfSetTextFontAndSizeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextFontAndSizeOperator Class : Font Property
Gets the font object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Font As PdfFont
'Usage

Dim instance As PdfSetTextFontAndSizeOperator
Dim value As PdfFont

instance.Font = value

value = instance.Font
public PdfFont Font {get; set;}
public:
property PdfFont^ Font {
   PdfFont^ get();
   void set (    PdfFont^ value);
}

Property Value

The font that will be used to draw text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextFontAndSizeOperator Class
PdfSetTextFontAndSizeOperator Members


FontID Property

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextFontAndSizeOperator Class : FontID Property
Gets or sets the font ID.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FontID As PdfCosName
'Usage

Dim instance As PdfSetTextFontAndSizeOperator
Dim value As PdfCosName

instance.FontID = value

value = instance.FontID
public PdfCosName FontID {get; set;}
public:
property PdfCosName^ FontID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The font ID in the /Resources dictionary.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextFontAndSizeOperator Class
PdfSetTextFontAndSizeOperator Members


FontSize Property (PdfSetTextFontAndSizeOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextFontAndSizeOperator Class : FontSize Property
Gets or sets the font size.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FontSize As Double
'Usage

Dim instance As PdfSetTextFontAndSizeOperator
Dim value As Double

instance.FontSize = value

value = instance.FontSize
public double FontSize {get; set;}
public:
property double FontSize {
   double get();
   void set (    double value);
}

Property Value

The size of the font used to draw text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextFontAndSizeOperator Class
PdfSetTextFontAndSizeOperator Members


%%PageItemTitle%%

PdfSetTextHorizontalScalingOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextHorizontalScalingOperator Class
Defines the Tz (set text horizontal scaling) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetTextHorizontalScalingOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetTextHorizontalScalingOperator
public class PdfSetTextHorizontalScalingOperator : PdfContentStreamOperator
public ref class PdfSetTextHorizontalScalingOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextHorizontalScalingOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextHorizontalScalingOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetTextHorizontalScalingOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextHorizontalScalingOperator Class

The following tables list the members exposed by PdfSetTextHorizontalScalingOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetTextHorizontalScalingOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | HorizontalScaling | Gets or sets the text horizontal scaling.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextHorizontalScalingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetTextHorizontalScalingOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextHorizontalScalingOperator Class : PdfSetTextHorizontalScalingOperator Constructor
Overload List
Overload | Description
PdfSetTextHorizontalScalingOperator Constructor() | Initializes a new PdfSetTextHorizontalScalingOperator object.
PdfSetTextHorizontalScalingOperator Constructor(Double) | Initializes a new PdfSetTextHorizontalScalingOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextHorizontalScalingOperator Class
PdfSetTextHorizontalScalingOperator Members


%%PageItemTitle%%

PdfSetTextHorizontalScalingOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextHorizontalScalingOperator Class > PdfSetTextHorizontalScalingOperator Constructor : PdfSetTextHorizontalScalingOperator Constructor()
Initializes a new PdfSetTextHorizontalScalingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetTextHorizontalScalingOperator()
public PdfSetTextHorizontalScalingOperator()
public:
PdfSetTextHorizontalScalingOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextHorizontalScalingOperator Class
PdfSetTextHorizontalScalingOperator Members
Overload List


%%PageItemTitle%%

PdfSetTextHorizontalScalingOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextHorizontalScalingOperator Class > PdfSetTextHorizontalScalingOperator Constructor : PdfSetTextHorizontalScalingOperator Constructor(Double)
The text horizontal scaling.
Initializes a new PdfSetTextHorizontalScalingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal horizontalScaling As Double _
)
'Usage

Dim horizontalScaling As Double

Dim instance As New PdfSetTextHorizontalScalingOperator(horizontalScaling)
public PdfSetTextHorizontalScalingOperator(
   double horizontalScaling
)
public:
PdfSetTextHorizontalScalingOperator(
   double horizontalScaling
)

Parameters

horizontalScaling
The text horizontal scaling.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextHorizontalScalingOperator Class
PdfSetTextHorizontalScalingOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetTextHorizontalScalingOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextHorizontalScalingOperator Class

For a list of all members of this type, see PdfSetTextHorizontalScalingOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | HorizontalScaling | Gets or sets the text horizontal scaling.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextHorizontalScalingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


HorizontalScaling Property (PdfSetTextHorizontalScalingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextHorizontalScalingOperator Class : HorizontalScaling Property
Gets or sets the text horizontal scaling.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HorizontalScaling As Double
'Usage

Dim instance As PdfSetTextHorizontalScalingOperator
Dim value As Double

instance.HorizontalScaling = value

value = instance.HorizontalScaling
public double HorizontalScaling {get; set;}
public:
property double HorizontalScaling {
   double get();
   void set (    double value);
}

Property Value

The text horizontal scaling.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextHorizontalScalingOperator Class
PdfSetTextHorizontalScalingOperator Members


%%PageItemTitle%%

PdfSetTextLeadingOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextLeadingOperator Class
Defines the TL (set text leading) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetTextLeadingOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetTextLeadingOperator
public class PdfSetTextLeadingOperator : PdfContentStreamOperator
public ref class PdfSetTextLeadingOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextLeadingOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextLeadingOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetTextLeadingOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextLeadingOperator Class

The following tables list the members exposed by PdfSetTextLeadingOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetTextLeadingOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TextLeading | Gets or sets the text leading.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextLeadingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetTextLeadingOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextLeadingOperator Class : PdfSetTextLeadingOperator Constructor
Overload List
Overload | Description
PdfSetTextLeadingOperator Constructor() | Initializes a new PdfSetTextLeadingOperator object.
PdfSetTextLeadingOperator Constructor(Double) | Initializes a new PdfSetTextLeadingOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextLeadingOperator Class
PdfSetTextLeadingOperator Members


%%PageItemTitle%%

PdfSetTextLeadingOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextLeadingOperator Class > PdfSetTextLeadingOperator Constructor : PdfSetTextLeadingOperator Constructor()
Initializes a new PdfSetTextLeadingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetTextLeadingOperator()
public PdfSetTextLeadingOperator()
public:
PdfSetTextLeadingOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextLeadingOperator Class
PdfSetTextLeadingOperator Members
Overload List


%%PageItemTitle%%

PdfSetTextLeadingOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextLeadingOperator Class > PdfSetTextLeadingOperator Constructor : PdfSetTextLeadingOperator Constructor(Double)
The text leading.
Initializes a new PdfSetTextLeadingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal textLeading As Double _
)
'Usage

Dim textLeading As Double

Dim instance As New PdfSetTextLeadingOperator(textLeading)
public PdfSetTextLeadingOperator(
   double textLeading
)
public:
PdfSetTextLeadingOperator(
   double textLeading
)

Parameters

textLeading
The text leading.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextLeadingOperator Class
PdfSetTextLeadingOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetTextLeadingOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextLeadingOperator Class

For a list of all members of this type, see PdfSetTextLeadingOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TextLeading | Gets or sets the text leading.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextLeadingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


TextLeading Property (PdfSetTextLeadingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextLeadingOperator Class : TextLeading Property
Gets or sets the text leading.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextLeading As Double
'Usage

Dim instance As PdfSetTextLeadingOperator
Dim value As Double

instance.TextLeading = value

value = instance.TextLeading
public double TextLeading {get; set;}
public:
property double TextLeading {
   double get();
   void set (    double value);
}

Property Value

The text leading.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextLeadingOperator Class
PdfSetTextLeadingOperator Members


%%PageItemTitle%%

PdfSetTextMatrixOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextMatrixOperator Class
Defines the Tm (set text matrix) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetTextMatrixOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetTextMatrixOperator
public class PdfSetTextMatrixOperator : PdfContentStreamOperator
public ref class PdfSetTextMatrixOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextMatrixOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetTextMatrixOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextMatrixOperator Class

The following tables list the members exposed by PdfSetTextMatrixOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetTextMatrixOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | DX | Gets or sets the dx element of the text matrix.
Public Property | DY | Gets or sets the dy element of the text matrix.
Public Property | M11 | Gets or sets the m11 element of the text matrix.
Public Property | M12 | Gets or sets the m12 element of the text matrix.
Public Property | M21 | Gets or sets the m21 element of the text matrix.
Public Property | M22 | Gets or sets the Y coordinate of the second control point.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextMatrixOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetTextMatrixOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class : PdfSetTextMatrixOperator Constructor
Overload List
Overload | Description
PdfSetTextMatrixOperator Constructor() | Initializes a new PdfSetTextMatrixOperator object.
PdfSetTextMatrixOperator Constructor(Double,Double,Double,Double,Double,Double) | Initializes a new PdfSetTextMatrixOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members


%%PageItemTitle%%

PdfSetTextMatrixOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class > PdfSetTextMatrixOperator Constructor : PdfSetTextMatrixOperator Constructor()
Initializes a new PdfSetTextMatrixOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetTextMatrixOperator()
public PdfSetTextMatrixOperator()
public:
PdfSetTextMatrixOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members
Overload List


%%PageItemTitle%%

PdfSetTextMatrixOperator Constructor(Double,Double,Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class > PdfSetTextMatrixOperator Constructor : PdfSetTextMatrixOperator Constructor(Double,Double,Double,Double,Double,Double)
The m11 element of the text matrix.
The m12 element of the text matrix.
The m21 element of the text matrix.
The m22 element of the text matrix.
The dx element of the text matrix.
The dy element of the text matrix.
Initializes a new PdfSetTextMatrixOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal m11 As Double, _
   ByVal m12 As Double, _
   ByVal m21 As Double, _
   ByVal m22 As Double, _
   ByVal dx As Double, _
   ByVal dy As Double _
)
'Usage

Dim m11 As Double
Dim m12 As Double
Dim m21 As Double
Dim m22 As Double
Dim dx As Double
Dim dy As Double

Dim instance As New PdfSetTextMatrixOperator(m11, m12, m21, m22, dx, dy)
public PdfSetTextMatrixOperator(
   double m11,
   double m12,
   double m21,
   double m22,
   double dx,
   double dy
)
public:
PdfSetTextMatrixOperator(
   double m11,
   double m12,
   double m21,
   double m22,
   double dx,
   double dy
)

Parameters

m11
The m11 element of the text matrix.
m12
The m12 element of the text matrix.
m21
The m21 element of the text matrix.
m22
The m22 element of the text matrix.
dx
The dx element of the text matrix.
dy
The dy element of the text matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetTextMatrixOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextMatrixOperator Class

For a list of all members of this type, see PdfSetTextMatrixOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | DX | Gets or sets the dx element of the text matrix.
Public Property | DY | Gets or sets the dy element of the text matrix.
Public Property | M11 | Gets or sets the m11 element of the text matrix.
Public Property | M12 | Gets or sets the m12 element of the text matrix.
Public Property | M21 | Gets or sets the m21 element of the text matrix.
Public Property | M22 | Gets or sets the Y coordinate of the second control point.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextMatrixOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


DX Property (PdfSetTextMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class : DX Property
Gets or sets the dx element of the text matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DX As Double
'Usage

Dim instance As PdfSetTextMatrixOperator
Dim value As Double

instance.DX = value

value = instance.DX
public double DX {get; set;}
public:
property double DX {
   double get();
   void set (    double value);
}

Property Value

The dx element of the text matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members


DY Property (PdfSetTextMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class : DY Property
Gets or sets the dy element of the text matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DY As Double
'Usage

Dim instance As PdfSetTextMatrixOperator
Dim value As Double

instance.DY = value

value = instance.DY
public double DY {get; set;}
public:
property double DY {
   double get();
   void set (    double value);
}

Property Value

The dy element of the text matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members


M11 Property (PdfSetTextMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class : M11 Property
Gets or sets the m11 element of the text matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M11 As Double
'Usage

Dim instance As PdfSetTextMatrixOperator
Dim value As Double

instance.M11 = value

value = instance.M11
public double M11 {get; set;}
public:
property double M11 {
   double get();
   void set (    double value);
}

Property Value

The m11 element of the text matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members


M12 Property (PdfSetTextMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class : M12 Property
Gets or sets the m12 element of the text matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M12 As Double
'Usage

Dim instance As PdfSetTextMatrixOperator
Dim value As Double

instance.M12 = value

value = instance.M12
public double M12 {get; set;}
public:
property double M12 {
   double get();
   void set (    double value);
}

Property Value

The m12 element of the text matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members


M21 Property (PdfSetTextMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class : M21 Property
Gets or sets the m21 element of the text matrix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M21 As Double
'Usage

Dim instance As PdfSetTextMatrixOperator
Dim value As Double

instance.M21 = value

value = instance.M21
public double M21 {get; set;}
public:
property double M21 {
   double get();
   void set (    double value);
}

Property Value

The m21 element of the text matrix.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members


M22 Property (PdfSetTextMatrixOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextMatrixOperator Class : M22 Property
Gets or sets the Y coordinate of the second control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property M22 As Double
'Usage

Dim instance As PdfSetTextMatrixOperator
Dim value As Double

instance.M22 = value

value = instance.M22
public double M22 {get; set;}
public:
property double M22 {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the second control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextMatrixOperator Class
PdfSetTextMatrixOperator Members


%%PageItemTitle%%

PdfSetTextRenderingOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextRenderingOperator Class
Defines the Tr (set text rendering mode) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetTextRenderingOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetTextRenderingOperator
public class PdfSetTextRenderingOperator : PdfContentStreamOperator
public ref class PdfSetTextRenderingOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextRenderingOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRenderingOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetTextRenderingOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextRenderingOperator Class

The following tables list the members exposed by PdfSetTextRenderingOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetTextRenderingOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TextRendering | Gets or sets the text rendering.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextRenderingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetTextRenderingOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextRenderingOperator Class : PdfSetTextRenderingOperator Constructor
Overload List
Overload | Description
PdfSetTextRenderingOperator Constructor() | Initializes a new PdfSetTextRenderingOperator object.
PdfSetTextRenderingOperator Constructor(Int32) | Initializes a new PdfSetTextRenderingOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRenderingOperator Class
PdfSetTextRenderingOperator Members


%%PageItemTitle%%

PdfSetTextRenderingOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextRenderingOperator Class > PdfSetTextRenderingOperator Constructor : PdfSetTextRenderingOperator Constructor()
Initializes a new PdfSetTextRenderingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetTextRenderingOperator()
public PdfSetTextRenderingOperator()
public:
PdfSetTextRenderingOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRenderingOperator Class
PdfSetTextRenderingOperator Members
Overload List


%%PageItemTitle%%

PdfSetTextRenderingOperator Constructor(Int32)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextRenderingOperator Class > PdfSetTextRenderingOperator Constructor : PdfSetTextRenderingOperator Constructor(Int32)
The text rendering.
Initializes a new PdfSetTextRenderingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal textRendering As Integer _
)
'Usage

Dim textRendering As Integer

Dim instance As New PdfSetTextRenderingOperator(textRendering)
public PdfSetTextRenderingOperator(
   int textRendering
)
public:
PdfSetTextRenderingOperator(
   int textRendering
)

Parameters

textRendering
The text rendering.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRenderingOperator Class
PdfSetTextRenderingOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetTextRenderingOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextRenderingOperator Class

For a list of all members of this type, see PdfSetTextRenderingOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TextRendering | Gets or sets the text rendering.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextRenderingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


TextRendering Property (PdfSetTextRenderingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextRenderingOperator Class : TextRendering Property
Gets or sets the text rendering.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextRendering As Integer
'Usage

Dim instance As PdfSetTextRenderingOperator
Dim value As Integer

instance.TextRendering = value

value = instance.TextRendering
public int TextRendering {get; set;}
public:
property int TextRendering {
   int get();
   void set (    int value);
}

Property Value

The text rendering.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRenderingOperator Class
PdfSetTextRenderingOperator Members


%%PageItemTitle%%

PdfSetTextRiseOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextRiseOperator Class
Defines the Ts (set text rise) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetTextRiseOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetTextRiseOperator
public class PdfSetTextRiseOperator : PdfContentStreamOperator
public ref class PdfSetTextRiseOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetTextRiseOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRiseOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetTextRiseOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextRiseOperator Class

The following tables list the members exposed by PdfSetTextRiseOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetTextRiseOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TextRendering | Gets or sets the text rise.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextRiseOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetTextRiseOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextRiseOperator Class : PdfSetTextRiseOperator Constructor
Overload List
Overload | Description
PdfSetTextRiseOperator Constructor() | Initializes a new PdfSetTextRiseOperator object.
PdfSetTextRiseOperator Constructor(Double) | Initializes a new PdfSetTextRiseOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRiseOperator Class
PdfSetTextRiseOperator Members


%%PageItemTitle%%

PdfSetTextRiseOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextRiseOperator Class > PdfSetTextRiseOperator Constructor : PdfSetTextRiseOperator Constructor()
Initializes a new PdfSetTextRiseOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetTextRiseOperator()
public PdfSetTextRiseOperator()
public:
PdfSetTextRiseOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRiseOperator Class
PdfSetTextRiseOperator Members
Overload List


%%PageItemTitle%%

PdfSetTextRiseOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextRiseOperator Class > PdfSetTextRiseOperator Constructor : PdfSetTextRiseOperator Constructor(Double)
The text rise.
Initializes a new PdfSetTextRiseOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal textRise As Double _
)
'Usage

Dim textRise As Double

Dim instance As New PdfSetTextRiseOperator(textRise)
public PdfSetTextRiseOperator(
   double textRise
)
public:
PdfSetTextRiseOperator(
   double textRise
)

Parameters

textRise
The text rise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRiseOperator Class
PdfSetTextRiseOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetTextRiseOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetTextRiseOperator Class

For a list of all members of this type, see PdfSetTextRiseOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | TextRendering | Gets or sets the text rise.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfSetTextRiseOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


TextRendering Property (PdfSetTextRiseOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetTextRiseOperator Class : TextRendering Property
Gets or sets the text rise.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TextRendering As Double
'Usage

Dim instance As PdfSetTextRiseOperator
Dim value As Double

instance.TextRendering = value

value = instance.TextRendering
public double TextRendering {get; set;}
public:
property double TextRendering {
   double get();
   void set (    double value);
}

Property Value

The text rise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetTextRiseOperator Class
PdfSetTextRiseOperator Members


%%PageItemTitle%%

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetType3GlyphWidthAndBoundingBoxOperator Class
Defines the d1 (set glyph width and bounding box in Type 3 font) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetType3GlyphWidthAndBoundingBoxOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetType3GlyphWidthAndBoundingBoxOperator
public class PdfSetType3GlyphWidthAndBoundingBoxOperator : PdfContentStreamOperator
public ref class PdfSetType3GlyphWidthAndBoundingBoxOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetType3GlyphWidthAndBoundingBoxOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetType3GlyphWidthAndBoundingBoxOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetType3GlyphWidthAndBoundingBoxOperator Class

The following tables list the members exposed by PdfSetType3GlyphWidthAndBoundingBoxOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | LLX | Gets or sets the X coordinate of the glyph lower left corner.
Public Property | LLY | Gets or sets the Y coordinate of the glyph lower left corner.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | URX | Gets or sets the X coordinate of the glyph upper right corner.
Public Property | URY | Gets or sets the Y coordinate of the glyph upper right corner.
Public Property | WX | Gets or sets the horizontal displacement.
Public Property | WY | Gets or sets the vertical displacement.
Top
See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class : PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor
Overload List
Overload | Description
PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor() | Initializes a new PdfSetType3GlyphWidthAndBoundingBoxOperator object.
PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor(Double,Double,Double,Double,Double,Double) | Initializes a new PdfSetType3GlyphWidthAndBoundingBoxOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members


%%PageItemTitle%%

PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class > PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor : PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor()
Initializes a new PdfSetType3GlyphWidthAndBoundingBoxOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetType3GlyphWidthAndBoundingBoxOperator()
public PdfSetType3GlyphWidthAndBoundingBoxOperator()
public:
PdfSetType3GlyphWidthAndBoundingBoxOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members
Overload List


%%PageItemTitle%%

PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor(Double,Double,Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class > PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor : PdfSetType3GlyphWidthAndBoundingBoxOperator Constructor(Double,Double,Double,Double,Double,Double)
The horizontal displacement.
The vertical displacement.
The X coordinate of the lower left corner.
The Y coordinate of the lower left corner.
The X coordinate of the glyph upper right corner.
The Y coordinate of the glyph upper right corner.
Initializes a new PdfSetType3GlyphWidthAndBoundingBoxOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal wx As Double, _
   ByVal wy As Double, _
   ByVal llx As Double, _
   ByVal lly As Double, _
   ByVal urx As Double, _
   ByVal ury As Double _
)
'Usage

Dim wx As Double
Dim wy As Double
Dim llx As Double
Dim lly As Double
Dim urx As Double
Dim ury As Double

Dim instance As New PdfSetType3GlyphWidthAndBoundingBoxOperator(wx, wy, llx, lly, urx, ury)
public PdfSetType3GlyphWidthAndBoundingBoxOperator(
   double wx,
   double wy,
   double llx,
   double lly,
   double urx,
   double ury
)
public:
PdfSetType3GlyphWidthAndBoundingBoxOperator(
   double wx,
   double wy,
   double llx,
   double lly,
   double urx,
   double ury
)

Parameters

wx
The horizontal displacement.
wy
The vertical displacement.
llx
The X coordinate of the lower left corner.
lly
The Y coordinate of the lower left corner.
urx
The X coordinate of the glyph upper right corner.
ury
The Y coordinate of the glyph upper right corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetType3GlyphWidthAndBoundingBoxOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetType3GlyphWidthAndBoundingBoxOperator Class

For a list of all members of this type, see PdfSetType3GlyphWidthAndBoundingBoxOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | LLX | Gets or sets the X coordinate of the glyph lower left corner.
Public Property | LLY | Gets or sets the Y coordinate of the glyph lower left corner.
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | URX | Gets or sets the X coordinate of the glyph upper right corner.
Public Property | URY | Gets or sets the Y coordinate of the glyph upper right corner.
Public Property | WX | Gets or sets the horizontal displacement.
Public Property | WY | Gets or sets the vertical displacement.
Top
See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


LLX Property (PdfSetType3GlyphWidthAndBoundingBoxOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class : LLX Property
Gets or sets the X coordinate of the glyph lower left corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LLX As Double
'Usage

Dim instance As PdfSetType3GlyphWidthAndBoundingBoxOperator
Dim value As Double

instance.LLX = value

value = instance.LLX
public double LLX {get; set;}
public:
property double LLX {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the glyph lower left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members


LLY Property (PdfSetType3GlyphWidthAndBoundingBoxOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class : LLY Property
Gets or sets the Y coordinate of the glyph lower left corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LLY As Double
'Usage

Dim instance As PdfSetType3GlyphWidthAndBoundingBoxOperator
Dim value As Double

instance.LLY = value

value = instance.LLY
public double LLY {get; set;}
public:
property double LLY {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the glyph lower left corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members


URX Property (PdfSetType3GlyphWidthAndBoundingBoxOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class : URX Property
Gets or sets the X coordinate of the glyph upper right corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property URX As Double
'Usage

Dim instance As PdfSetType3GlyphWidthAndBoundingBoxOperator
Dim value As Double

instance.URX = value

value = instance.URX
public double URX {get; set;}
public:
property double URX {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the glyph upper right corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members


URY Property (PdfSetType3GlyphWidthAndBoundingBoxOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class : URY Property
Gets or sets the Y coordinate of the glyph upper right corner.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property URY As Double
'Usage

Dim instance As PdfSetType3GlyphWidthAndBoundingBoxOperator
Dim value As Double

instance.URY = value

value = instance.URY
public double URY {get; set;}
public:
property double URY {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the glyph upper right corner.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members


WX Property (PdfSetType3GlyphWidthAndBoundingBoxOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class : WX Property
Gets or sets the horizontal displacement.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WX As Double
'Usage

Dim instance As PdfSetType3GlyphWidthAndBoundingBoxOperator
Dim value As Double

instance.WX = value

value = instance.WX
public double WX {get; set;}
public:
property double WX {
   double get();
   void set (    double value);
}

Property Value

The horizontal displacement.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members


WY Property (PdfSetType3GlyphWidthAndBoundingBoxOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthAndBoundingBoxOperator Class : WY Property
Gets or sets the vertical displacement.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WY As Double
'Usage

Dim instance As PdfSetType3GlyphWidthAndBoundingBoxOperator
Dim value As Double

instance.WY = value

value = instance.WY
public double WY {get; set;}
public:
property double WY {
   double get();
   void set (    double value);
}

Property Value

The vertical displacement.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthAndBoundingBoxOperator Class
PdfSetType3GlyphWidthAndBoundingBoxOperator Members


%%PageItemTitle%%

PdfSetType3GlyphWidthOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetType3GlyphWidthOperator Class
Defines the d0 (set glyph width in type 3 font) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetType3GlyphWidthOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetType3GlyphWidthOperator
public class PdfSetType3GlyphWidthOperator : PdfContentStreamOperator
public ref class PdfSetType3GlyphWidthOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetType3GlyphWidthOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetType3GlyphWidthOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetType3GlyphWidthOperator Class

The following tables list the members exposed by PdfSetType3GlyphWidthOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetType3GlyphWidthOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | WX | Gets or sets the horizontal displacement.
Public Property | WY | Gets or sets the vertical displacement.
Top
See Also

Reference

PdfSetType3GlyphWidthOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetType3GlyphWidthOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthOperator Class : PdfSetType3GlyphWidthOperator Constructor
Overload List
Overload | Description
PdfSetType3GlyphWidthOperator Constructor() | Initializes a new PdfSetType3GlyphWidthOperator object.
PdfSetType3GlyphWidthOperator Constructor(Double,Double) | Initializes a new PdfSetType3GlyphWidthOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthOperator Class
PdfSetType3GlyphWidthOperator Members


%%PageItemTitle%%

PdfSetType3GlyphWidthOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthOperator Class > PdfSetType3GlyphWidthOperator Constructor : PdfSetType3GlyphWidthOperator Constructor()
Initializes a new PdfSetType3GlyphWidthOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetType3GlyphWidthOperator()
public PdfSetType3GlyphWidthOperator()
public:
PdfSetType3GlyphWidthOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthOperator Class
PdfSetType3GlyphWidthOperator Members
Overload List


%%PageItemTitle%%

PdfSetType3GlyphWidthOperator Constructor(Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthOperator Class > PdfSetType3GlyphWidthOperator Constructor : PdfSetType3GlyphWidthOperator Constructor(Double,Double)
The horizontal displacement.
The vertical displacement.
Initializes a new PdfSetType3GlyphWidthOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal wx As Double, _
   ByVal wy As Double _
)
'Usage

Dim wx As Double
Dim wy As Double

Dim instance As New PdfSetType3GlyphWidthOperator(wx, wy)
public PdfSetType3GlyphWidthOperator(
   double wx,
   double wy
)
public:
PdfSetType3GlyphWidthOperator(
   double wx,
   double wy
)

Parameters

wx
The horizontal displacement.
wy
The vertical displacement.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthOperator Class
PdfSetType3GlyphWidthOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetType3GlyphWidthOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetType3GlyphWidthOperator Class

For a list of all members of this type, see PdfSetType3GlyphWidthOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | WX | Gets or sets the horizontal displacement.
Public Property | WY | Gets or sets the vertical displacement.
Top
See Also

Reference

PdfSetType3GlyphWidthOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


WX Property (PdfSetType3GlyphWidthOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthOperator Class : WX Property
Gets or sets the horizontal displacement.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WX As Double
'Usage

Dim instance As PdfSetType3GlyphWidthOperator
Dim value As Double

instance.WX = value

value = instance.WX
public double WX {get; set;}
public:
property double WX {
   double get();
   void set (    double value);
}

Property Value

The horizontal displacement.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthOperator Class
PdfSetType3GlyphWidthOperator Members


WY Property (PdfSetType3GlyphWidthOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetType3GlyphWidthOperator Class : WY Property
Gets or sets the vertical displacement.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WY As Double
'Usage

Dim instance As PdfSetType3GlyphWidthOperator
Dim value As Double

instance.WY = value

value = instance.WY
public double WY {get; set;}
public:
property double WY {
   double get();
   void set (    double value);
}

Property Value

The vertical displacement.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetType3GlyphWidthOperator Class
PdfSetType3GlyphWidthOperator Members


%%PageItemTitle%%

PdfSetWordSpacingOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetWordSpacingOperator Class
Defines the Tw (set word spacing) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSetWordSpacingOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfSetWordSpacingOperator
public class PdfSetWordSpacingOperator : PdfContentStreamOperator
public ref class PdfSetWordSpacingOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfSetWordSpacingOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetWordSpacingOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfSetWordSpacingOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetWordSpacingOperator Class

The following tables list the members exposed by PdfSetWordSpacingOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfSetWordSpacingOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | WordSpacing | Gets or sets the word spacing.
Top
See Also

Reference

PdfSetWordSpacingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfSetWordSpacingOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetWordSpacingOperator Class : PdfSetWordSpacingOperator Constructor
Overload List
Overload | Description
PdfSetWordSpacingOperator Constructor() | Initializes a new PdfSetWordSpacingOperator object.
PdfSetWordSpacingOperator Constructor(Double) | Initializes a new PdfSetWordSpacingOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetWordSpacingOperator Class
PdfSetWordSpacingOperator Members


%%PageItemTitle%%

PdfSetWordSpacingOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetWordSpacingOperator Class > PdfSetWordSpacingOperator Constructor : PdfSetWordSpacingOperator Constructor()
Initializes a new PdfSetWordSpacingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSetWordSpacingOperator()
public PdfSetWordSpacingOperator()
public:
PdfSetWordSpacingOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetWordSpacingOperator Class
PdfSetWordSpacingOperator Members
Overload List


%%PageItemTitle%%

PdfSetWordSpacingOperator Constructor(Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetWordSpacingOperator Class > PdfSetWordSpacingOperator Constructor : PdfSetWordSpacingOperator Constructor(Double)
The word spacing.
Initializes a new PdfSetWordSpacingOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal wordSpacing As Double _
)
'Usage

Dim wordSpacing As Double

Dim instance As New PdfSetWordSpacingOperator(wordSpacing)
public PdfSetWordSpacingOperator(
   double wordSpacing
)
public:
PdfSetWordSpacingOperator(
   double wordSpacing
)

Parameters

wordSpacing
The word spacing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetWordSpacingOperator Class
PdfSetWordSpacingOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSetWordSpacingOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfSetWordSpacingOperator Class

For a list of all members of this type, see PdfSetWordSpacingOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | WordSpacing | Gets or sets the word spacing.
Top
See Also

Reference

PdfSetWordSpacingOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


WordSpacing Property (PdfSetWordSpacingOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfSetWordSpacingOperator Class : WordSpacing Property
Gets or sets the word spacing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WordSpacing As Double
'Usage

Dim instance As PdfSetWordSpacingOperator
Dim value As Double

instance.WordSpacing = value

value = instance.WordSpacing
public double WordSpacing {get; set;}
public:
property double WordSpacing {
   double get();
   void set (    double value);
}

Property Value

The word spacing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSetWordSpacingOperator Class
PdfSetWordSpacingOperator Members


%%PageItemTitle%%

PdfShowText2Operator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText2Operator Class
Defines the TJ (show text with position) content stream operator.
Object Model
PdfShowText2Operator ClassPdfCosArray Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfShowText2Operator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfShowText2Operator
public class PdfShowText2Operator : PdfContentStreamOperator
public ref class PdfShowText2Operator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfShowText2Operator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText2Operator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfShowText2Operator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText2Operator Class

The following tables list the members exposed by PdfShowText2Operator.

Public Constructors
 | Name | Description
Public Constructor | PdfShowText2Operator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Text | Gets or sets the text.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfShowText2Operator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfShowText2Operator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText2Operator Class : PdfShowText2Operator Constructor
Overload List
Overload | Description
PdfShowText2Operator Constructor() | Initializes a new PdfShowText2Operator object.
PdfShowText2Operator Constructor(PdfCosArray) | Initializes a new PdfShowText2Operator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText2Operator Class
PdfShowText2Operator Members


%%PageItemTitle%%

PdfShowText2Operator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText2Operator Class > PdfShowText2Operator Constructor : PdfShowText2Operator Constructor()
Initializes a new PdfShowText2Operator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfShowText2Operator()
public PdfShowText2Operator()
public:
PdfShowText2Operator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText2Operator Class
PdfShowText2Operator Members
Overload List


%%PageItemTitle%%

PdfShowText2Operator Constructor(PdfCosArray)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText2Operator Class > PdfShowText2Operator Constructor : PdfShowText2Operator Constructor(PdfCosArray)
The text displayed by this operator as a COS array.
Initializes a new PdfShowText2Operator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As PdfCosArray _
)
'Usage

Dim text As PdfCosArray

Dim instance As New PdfShowText2Operator(text)
public PdfShowText2Operator(
   PdfCosArray text
)
public:
PdfShowText2Operator(
   PdfCosArray^ text
)

Parameters

text
The text displayed by this operator as a COS array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText2Operator Class
PdfShowText2Operator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfShowText2Operator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText2Operator Class

For a list of all members of this type, see PdfShowText2Operator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Text | Gets or sets the text.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfShowText2Operator Class
Xfinium.Pdf.Graphics.Operators Namespace


Text Property (PdfShowText2Operator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText2Operator Class : Text Property
Gets or sets the text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Text As PdfCosArray
'Usage

Dim instance As PdfShowText2Operator
Dim value As PdfCosArray

instance.Text = value

value = instance.Text
public PdfCosArray Text {get; set;}
public:
property PdfCosArray^ Text {
   PdfCosArray^ get();
   void set (    PdfCosArray^ value);
}

Property Value

The text displayed by this operator as a COS array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText2Operator Class
PdfShowText2Operator Members


%%PageItemTitle%%

PdfShowText3Operator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText3Operator Class
Defines the ' (move to next line and show text) content stream operator.
Object Model
PdfShowText3Operator ClassPdfCosString Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfShowText3Operator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfShowText3Operator
public class PdfShowText3Operator : PdfContentStreamOperator
public ref class PdfShowText3Operator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfShowText3Operator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText3Operator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfShowText3Operator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText3Operator Class

The following tables list the members exposed by PdfShowText3Operator.

Public Constructors
 | Name | Description
Public Constructor | PdfShowText3Operator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Text | Gets or sets the text.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfShowText3Operator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfShowText3Operator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText3Operator Class : PdfShowText3Operator Constructor
Overload List
Overload | Description
PdfShowText3Operator Constructor() | Initializes a new PdfShowText3Operator object.
PdfShowText3Operator Constructor(PdfCosString) | Initializes a new PdfShowText3Operator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText3Operator Class
PdfShowText3Operator Members


%%PageItemTitle%%

PdfShowText3Operator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText3Operator Class > PdfShowText3Operator Constructor : PdfShowText3Operator Constructor()
Initializes a new PdfShowText3Operator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfShowText3Operator()
public PdfShowText3Operator()
public:
PdfShowText3Operator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText3Operator Class
PdfShowText3Operator Members
Overload List


%%PageItemTitle%%

PdfShowText3Operator Constructor(PdfCosString)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText3Operator Class > PdfShowText3Operator Constructor : PdfShowText3Operator Constructor(PdfCosString)
The text displayed by this operator as a COS string.
Initializes a new PdfShowText3Operator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As PdfCosString _
)
'Usage

Dim text As PdfCosString

Dim instance As New PdfShowText3Operator(text)
public PdfShowText3Operator(
   PdfCosString text
)
public:
PdfShowText3Operator(
   PdfCosString^ text
)

Parameters

text
The text displayed by this operator as a COS string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText3Operator Class
PdfShowText3Operator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfShowText3Operator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText3Operator Class

For a list of all members of this type, see PdfShowText3Operator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Text | Gets or sets the text.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfShowText3Operator Class
Xfinium.Pdf.Graphics.Operators Namespace


Text Property (PdfShowText3Operator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText3Operator Class : Text Property
Gets or sets the text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Text As PdfCosString
'Usage

Dim instance As PdfShowText3Operator
Dim value As PdfCosString

instance.Text = value

value = instance.Text
public PdfCosString Text {get; set;}
public:
property PdfCosString^ Text {
   PdfCosString^ get();
   void set (    PdfCosString^ value);
}

Property Value

The text displayed by this operator as a COS string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText3Operator Class
PdfShowText3Operator Members


%%PageItemTitle%%

PdfShowText4Operator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText4Operator Class
Defines the " (move to the next line and show a text string, using word spacing and character spacing) content stream operator.
Object Model
PdfShowText4Operator ClassPdfCosString Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfShowText4Operator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfShowText4Operator
public class PdfShowText4Operator : PdfContentStreamOperator
public ref class PdfShowText4Operator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfShowText4Operator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText4Operator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfShowText4Operator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText4Operator Class

The following tables list the members exposed by PdfShowText4Operator.

Public Constructors
 | Name | Description
Public Constructor | PdfShowText4Operator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CharacterSpacing | Gets or sets the character spacing.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Text | Gets or sets the text.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | WordSpacing | Gets or sets the word spacing.
Top
See Also

Reference

PdfShowText4Operator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfShowText4Operator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText4Operator Class : PdfShowText4Operator Constructor
Overload List
Overload | Description
PdfShowText4Operator Constructor() | Initializes a new PdfShowText4Operator object.
PdfShowText4Operator Constructor(PdfCosString,Double,Double) | Initializes a new PdfShowText4Operator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText4Operator Class
PdfShowText4Operator Members


%%PageItemTitle%%

PdfShowText4Operator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText4Operator Class > PdfShowText4Operator Constructor : PdfShowText4Operator Constructor()
Initializes a new PdfShowText4Operator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfShowText4Operator()
public PdfShowText4Operator()
public:
PdfShowText4Operator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText4Operator Class
PdfShowText4Operator Members
Overload List


%%PageItemTitle%%

PdfShowText4Operator Constructor(PdfCosString,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText4Operator Class > PdfShowText4Operator Constructor : PdfShowText4Operator Constructor(PdfCosString,Double,Double)
The text displayed by this operator as a COS string.
The word spacing.
The character spacing.
Initializes a new PdfShowText4Operator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As PdfCosString, _
   ByVal wordSpacing As Double, _
   ByVal characterSpacing As Double _
)
'Usage

Dim text As PdfCosString
Dim wordSpacing As Double
Dim characterSpacing As Double

Dim instance As New PdfShowText4Operator(text, wordSpacing, characterSpacing)
public PdfShowText4Operator(
   PdfCosString text,
   double wordSpacing,
   double characterSpacing
)
public:
PdfShowText4Operator(
   PdfCosString^ text,
   double wordSpacing,
   double characterSpacing
)

Parameters

text
The text displayed by this operator as a COS string.
wordSpacing
The word spacing.
characterSpacing
The character spacing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText4Operator Class
PdfShowText4Operator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfShowText4Operator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowText4Operator Class

For a list of all members of this type, see PdfShowText4Operator members.

Public Properties
 | Name | Description
Public Property | CharacterSpacing | Gets or sets the character spacing.
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Text | Gets or sets the text.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | WordSpacing | Gets or sets the word spacing.
Top
See Also

Reference

PdfShowText4Operator Class
Xfinium.Pdf.Graphics.Operators Namespace


CharacterSpacing Property (PdfShowText4Operator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText4Operator Class : CharacterSpacing Property
Gets or sets the character spacing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CharacterSpacing As Double
'Usage

Dim instance As PdfShowText4Operator
Dim value As Double

instance.CharacterSpacing = value

value = instance.CharacterSpacing
public double CharacterSpacing {get; set;}
public:
property double CharacterSpacing {
   double get();
   void set (    double value);
}

Property Value

The character spacing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText4Operator Class
PdfShowText4Operator Members


Text Property (PdfShowText4Operator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText4Operator Class : Text Property
Gets or sets the text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Text As PdfCosString
'Usage

Dim instance As PdfShowText4Operator
Dim value As PdfCosString

instance.Text = value

value = instance.Text
public PdfCosString Text {get; set;}
public:
property PdfCosString^ Text {
   PdfCosString^ get();
   void set (    PdfCosString^ value);
}

Property Value

The text displayed by this operator as a COS string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText4Operator Class
PdfShowText4Operator Members


WordSpacing Property (PdfShowText4Operator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowText4Operator Class : WordSpacing Property
Gets or sets the word spacing.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WordSpacing As Double
'Usage

Dim instance As PdfShowText4Operator
Dim value As Double

instance.WordSpacing = value

value = instance.WordSpacing
public double WordSpacing {get; set;}
public:
property double WordSpacing {
   double get();
   void set (    double value);
}

Property Value

The word spacing.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowText4Operator Class
PdfShowText4Operator Members


%%PageItemTitle%%

PdfShowTextOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowTextOperator Class
Defines the Tj (show text) content stream operator.
Object Model
PdfShowTextOperator ClassPdfCosString Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfShowTextOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfShowTextOperator
public class PdfShowTextOperator : PdfContentStreamOperator
public ref class PdfShowTextOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfShowTextOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowTextOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfShowTextOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowTextOperator Class

The following tables list the members exposed by PdfShowTextOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfShowTextOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Text | Gets or sets the text.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfShowTextOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfShowTextOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowTextOperator Class : PdfShowTextOperator Constructor
Overload List
Overload | Description
PdfShowTextOperator Constructor() | Initializes a new PdfShowTextOperator object.
PdfShowTextOperator Constructor(PdfCosString) | Initializes a new PdfShowTextOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowTextOperator Class
PdfShowTextOperator Members


%%PageItemTitle%%

PdfShowTextOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowTextOperator Class > PdfShowTextOperator Constructor : PdfShowTextOperator Constructor()
Initializes a new PdfShowTextOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfShowTextOperator()
public PdfShowTextOperator()
public:
PdfShowTextOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowTextOperator Class
PdfShowTextOperator Members
Overload List


%%PageItemTitle%%

PdfShowTextOperator Constructor(PdfCosString)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowTextOperator Class > PdfShowTextOperator Constructor : PdfShowTextOperator Constructor(PdfCosString)
The text displayed by this operator as a COS string.
Initializes a new PdfShowTextOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As PdfCosString _
)
'Usage

Dim text As PdfCosString

Dim instance As New PdfShowTextOperator(text)
public PdfShowTextOperator(
   PdfCosString text
)
public:
PdfShowTextOperator(
   PdfCosString^ text
)

Parameters

text
The text displayed by this operator as a COS string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowTextOperator Class
PdfShowTextOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfShowTextOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfShowTextOperator Class

For a list of all members of this type, see PdfShowTextOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Text | Gets or sets the text.
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Top
See Also

Reference

PdfShowTextOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


Text Property (PdfShowTextOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfShowTextOperator Class : Text Property
Gets or sets the text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Text As PdfCosString
'Usage

Dim instance As PdfShowTextOperator
Dim value As PdfCosString

instance.Text = value

value = instance.Text
public PdfCosString Text {get; set;}
public:
property PdfCosString^ Text {
   PdfCosString^ get();
   void set (    PdfCosString^ value);
}

Property Value

The text displayed by this operator as a COS string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfShowTextOperator Class
PdfShowTextOperator Members


%%PageItemTitle%%

PdfVCurveToOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfVCurveToOperator Class
Defines the v (curve to) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfVCurveToOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfVCurveToOperator
public class PdfVCurveToOperator : PdfContentStreamOperator
public ref class PdfVCurveToOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfVCurveToOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVCurveToOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfVCurveToOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfVCurveToOperator Class

The following tables list the members exposed by PdfVCurveToOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfVCurveToOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X2 | Gets or sets the X coordinate of the second control point.
Public Property | X3 | Gets or sets the X coordinate of the third control point.
Public Property | Y2 | Gets or sets the Y coordinate of the second control point.
Public Property | Y3 | Gets or sets the Y coordinate of the third control point.
Top
See Also

Reference

PdfVCurveToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfVCurveToOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfVCurveToOperator Class : PdfVCurveToOperator Constructor
Overload List
Overload | Description
PdfVCurveToOperator Constructor() | Initializes a new PdfVCurveToOperator object.
PdfVCurveToOperator Constructor(Double,Double,Double,Double) | Initializes a new PdfVCurveToOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVCurveToOperator Class
PdfVCurveToOperator Members


%%PageItemTitle%%

PdfVCurveToOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfVCurveToOperator Class > PdfVCurveToOperator Constructor : PdfVCurveToOperator Constructor()
Initializes a new PdfVCurveToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfVCurveToOperator()
public PdfVCurveToOperator()
public:
PdfVCurveToOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVCurveToOperator Class
PdfVCurveToOperator Members
Overload List


%%PageItemTitle%%

PdfVCurveToOperator Constructor(Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfVCurveToOperator Class > PdfVCurveToOperator Constructor : PdfVCurveToOperator Constructor(Double,Double,Double,Double)
The X coordinate of the second control point.
The Y coordinate of the second control point.
The X coordinate of the third control point.
The Y coordinate of the third control point.
Initializes a new PdfVCurveToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
'Usage

Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double

Dim instance As New PdfVCurveToOperator(x2, y2, x3, y3)
public PdfVCurveToOperator(
   double x2,
   double y2,
   double x3,
   double y3
)
public:
PdfVCurveToOperator(
   double x2,
   double y2,
   double x3,
   double y3
)

Parameters

x2
The X coordinate of the second control point.
y2
The Y coordinate of the second control point.
x3
The X coordinate of the third control point.
y3
The Y coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVCurveToOperator Class
PdfVCurveToOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfVCurveToOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfVCurveToOperator Class

For a list of all members of this type, see PdfVCurveToOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X2 | Gets or sets the X coordinate of the second control point.
Public Property | X3 | Gets or sets the X coordinate of the third control point.
Public Property | Y2 | Gets or sets the Y coordinate of the second control point.
Public Property | Y3 | Gets or sets the Y coordinate of the third control point.
Top
See Also

Reference

PdfVCurveToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


X2 Property (PdfVCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfVCurveToOperator Class : X2 Property
Gets or sets the X coordinate of the second control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X2 As Double
'Usage

Dim instance As PdfVCurveToOperator
Dim value As Double

instance.X2 = value

value = instance.X2
public double X2 {get; set;}
public:
property double X2 {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the second control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVCurveToOperator Class
PdfVCurveToOperator Members


X3 Property (PdfVCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfVCurveToOperator Class : X3 Property
Gets or sets the X coordinate of the third control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X3 As Double
'Usage

Dim instance As PdfVCurveToOperator
Dim value As Double

instance.X3 = value

value = instance.X3
public double X3 {get; set;}
public:
property double X3 {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVCurveToOperator Class
PdfVCurveToOperator Members


Y2 Property (PdfVCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfVCurveToOperator Class : Y2 Property
Gets or sets the Y coordinate of the second control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y2 As Double
'Usage

Dim instance As PdfVCurveToOperator
Dim value As Double

instance.Y2 = value

value = instance.Y2
public double Y2 {get; set;}
public:
property double Y2 {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the second control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVCurveToOperator Class
PdfVCurveToOperator Members


Y3 Property (PdfVCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfVCurveToOperator Class : Y3 Property
Gets or sets the Y coordinate of the third control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y3 As Double
'Usage

Dim instance As PdfVCurveToOperator
Dim value As Double

instance.Y3 = value

value = instance.Y3
public double Y3 {get; set;}
public:
property double Y3 {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVCurveToOperator Class
PdfVCurveToOperator Members


%%PageItemTitle%%

PdfYCurveToOperator Class
Members

Xfinium.Pdf.Graphics.Operators Namespace : PdfYCurveToOperator Class
Defines the y (curve to) content stream operator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfYCurveToOperator
   Inherits PdfContentStreamOperator
'Usage

Dim instance As PdfYCurveToOperator
public class PdfYCurveToOperator : PdfContentStreamOperator
public ref class PdfYCurveToOperator : public PdfContentStreamOperator
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator
Xfinium.Pdf.Graphics.Operators.PdfYCurveToOperator

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfYCurveToOperator Members
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Members$$

PdfYCurveToOperator Class Members
Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfYCurveToOperator Class

The following tables list the members exposed by PdfYCurveToOperator.

Public Constructors
 | Name | Description
Public Constructor | PdfYCurveToOperator Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X1 | Gets or sets the X coordinate of the first control point.
Public Property | X3 | Gets or sets the X coordinate of the third control point.
Public Property | Y1 | Gets or sets the Y coordinate of the first control point.
Public Property | Y3 | Gets or sets the Y coordinate of the third control point.
Top
See Also

Reference

PdfYCurveToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%%

PdfYCurveToOperator Constructor

Xfinium.Pdf.Graphics.Operators Namespace > PdfYCurveToOperator Class : PdfYCurveToOperator Constructor
Overload List
Overload | Description
PdfYCurveToOperator Constructor() | Initializes a new PdfYCurveToOperator object.
PdfYCurveToOperator Constructor(Double,Double,Double,Double) | Initializes a new PdfYCurveToOperator object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfYCurveToOperator Class
PdfYCurveToOperator Members


%%PageItemTitle%%

PdfYCurveToOperator Constructor()

Xfinium.Pdf.Graphics.Operators Namespace > PdfYCurveToOperator Class > PdfYCurveToOperator Constructor : PdfYCurveToOperator Constructor()
Initializes a new PdfYCurveToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfYCurveToOperator()
public PdfYCurveToOperator()
public:
PdfYCurveToOperator();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfYCurveToOperator Class
PdfYCurveToOperator Members
Overload List


%%PageItemTitle%%

PdfYCurveToOperator Constructor(Double,Double,Double,Double)

Xfinium.Pdf.Graphics.Operators Namespace > PdfYCurveToOperator Class > PdfYCurveToOperator Constructor : PdfYCurveToOperator Constructor(Double,Double,Double,Double)
The X coordinate of the first control point.
The Y coordinate of the first control point.
The X coordinate of the third control point.
The Y coordinate of the third control point.
Initializes a new PdfYCurveToOperator object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
'Usage

Dim x1 As Double
Dim y1 As Double
Dim x3 As Double
Dim y3 As Double

Dim instance As New PdfYCurveToOperator(x1, y1, x3, y3)
public PdfYCurveToOperator(
   double x1,
   double y1,
   double x3,
   double y3
)
public:
PdfYCurveToOperator(
   double x1,
   double y1,
   double x3,
   double y3
)

Parameters

x1
The X coordinate of the first control point.
y1
The Y coordinate of the first control point.
x3
The X coordinate of the third control point.
y3
The Y coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfYCurveToOperator Class
PdfYCurveToOperator Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfYCurveToOperator Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfYCurveToOperator Class

For a list of all members of this type, see PdfYCurveToOperator members.

Public Properties
 | Name | Description
Public Property | Context | Gets the content stream container from which the operator is extracted. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | OpCode | Gets the operator code. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | Type | Gets or sets the operator type. (Inherited from Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperator)
Public Property | X1 | Gets or sets the X coordinate of the first control point.
Public Property | X3 | Gets or sets the X coordinate of the third control point.
Public Property | Y1 | Gets or sets the Y coordinate of the first control point.
Public Property | Y3 | Gets or sets the Y coordinate of the third control point.
Top
See Also

Reference

PdfYCurveToOperator Class
Xfinium.Pdf.Graphics.Operators Namespace


X1 Property (PdfYCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfYCurveToOperator Class : X1 Property
Gets or sets the X coordinate of the first control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X1 As Double
'Usage

Dim instance As PdfYCurveToOperator
Dim value As Double

instance.X1 = value

value = instance.X1
public double X1 {get; set;}
public:
property double X1 {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the first control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfYCurveToOperator Class
PdfYCurveToOperator Members


X3 Property (PdfYCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfYCurveToOperator Class : X3 Property
Gets or sets the X coordinate of the third control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X3 As Double
'Usage

Dim instance As PdfYCurveToOperator
Dim value As Double

instance.X3 = value

value = instance.X3
public double X3 {get; set;}
public:
property double X3 {
   double get();
   void set (    double value);
}

Property Value

The X coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfYCurveToOperator Class
PdfYCurveToOperator Members


Y1 Property (PdfYCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfYCurveToOperator Class : Y1 Property
Gets or sets the Y coordinate of the first control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y1 As Double
'Usage

Dim instance As PdfYCurveToOperator
Dim value As Double

instance.Y1 = value

value = instance.Y1
public double Y1 {get; set;}
public:
property double Y1 {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the first control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfYCurveToOperator Class
PdfYCurveToOperator Members


Y3 Property (PdfYCurveToOperator)

Xfinium.Pdf.Graphics.Operators Namespace > PdfYCurveToOperator Class : Y3 Property
Gets or sets the Y coordinate of the third control point.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y3 As Double
'Usage

Dim instance As PdfYCurveToOperator
Dim value As Double

instance.Y3 = value

value = instance.Y3
public double Y3 {get; set;}
public:
property double Y3 {
   double get();
   void set (    double value);
}

Property Value

The Y coordinate of the third control point.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfYCurveToOperator Class
PdfYCurveToOperator Members


%%PageItemTitle%%

PdfContentStreamOperatorType Enumeration

Xfinium.Pdf.Graphics.Operators Namespace : PdfContentStreamOperatorType Enumeration
Supported operators in a PDF content stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfContentStreamOperatorType
   Inherits System.Enum
'Usage

Dim instance As PdfContentStreamOperatorType
public enum PdfContentStreamOperatorType : System.Enum
public enum class PdfContentStreamOperatorType : public System.Enum
Members
Member | Description
BeginCompatibilitySection | BX - Begin compatibility section.
BeginImage | BI - Begin inline image object.
BeginImageData | ID - Begin inline image data.
BeginMarkedContent | BMC - Begin marked-content sequence.
BeginMarkedContentPropertyList | BDC - Begin marked-content sequence with property list.
BeginText | BT - Begin text object.
CCurveTo | c - Append curved segment to path.
CloseFillEvenOddStroke | b* - Close, fill, and stroke path using even-odd rule.
CloseFillNonZeroStroke | b - Close, fill, and stroke path using nonzero winding number rule.
CloseStroke | s - Close and stroke path.
CloseSubpath | h - Close subpath.
ConcatenateMatrix | cm - Concatenate matrix to current transformation matrix.
DefineMarkedContent | MP - Define marked-content point.
DefineMarkedContentPropertyList | DP - Define marked-content point with property list.
DisplayXObject | Do - Display named XObject
EndCompatibilitySection | EX - End compatibility section.
EndImage | EI - End inline image object.
EndMarkedContent | EMC - End marked-content sequence.
EndPath | n - End path without filling or stroking.
EndText | ET - End text object.
FillEvenOddStroke | B* - Fill and stroke path using even-odd rule.
FillNonZero | f - Fill path using nonzero winding number rule.
FillNonZero2 | F - Fill path using nonzero winding number rule (obsolete).
FillNonZeroStroke | B - Fill and stroke path using nonzero winding number rule.
FillOddEven | f* - Fill path using even-odd rule.
LineTo | l - Append straight line segment to path.
MoveStartNextTextLine | T* - Move to start of next text line.
MoveTextPosition | Td - Move text position.
MoveTextPositionSetLeading | TD - Move text position and set leading.
MoveTo | m - Begin new subpath.
Rectangle | re - Append rectangle to path.
RestoreGraphicsState | Q - Restore graphics state.
SaveGraphicsState | q - Save graphics state.
SetCharacterSpacing | Tc - Set character spacing.
SetClipEvenOdd | W* - Set clipping path using even-odd rule.
SetClipNonZero | W - Set clipping path using nonzero winding number rule.
SetCmykFill | k - Set CMYK color for nonstroking operations.
SetCmykStroke | K - Set CMYK color for stroking operations.
SetFillColor | sc - Set color for nonstroking operations.
SetFillColorN | scn - Set color for nonstroking operations (special colorspaces).
SetFillColorSpace | cs - Set color space for nonstroking operations.
SetFlatnessTolerance | i - Set flatness tolerance.
SetGraphicsState | gs - Set parameters from graphics state parameter dictionary.
SetGrayFill | g - Set gray level for nonstroking operations.
SetGrayStroke | G - Set gray level for stroking operations.
SetLineCap | J - Set line cap style.
SetLineDashPattern | d - Set line dash pattern.
SetLineJoin | j - Set line join style.
SetLineWidth | w - Set line width.
SetMiterLimit | M - Set miter limit.
SetRenderingIntent | ri - Set color rendering intent.
SetRgbFill | rg - Set RGB color for nonstroking operations.
SetRgbStroke | RG - Set RGB color for stroking operations.
SetShading | sh - Paint area defined by shading pattern.
SetStrokeColor | SC - Set color for stroking operations.
SetStrokeColorN | SCN - Set color for stroking operations (special colorspaces).
SetStrokeColorSpace | CS - Set color space for stroking operations.
SetTextFontAndSize | Tf - Set text font and size.
SetTextHorizontalScaling | Tz - Set horizontal text scaling.
SetTextLeading | TL - Set text leading.
SetTextMatrix | Tm - Set text matrix and text line matrix.
SetTextRendering | Tr - Set text rendering mode.
SetTextRise | Ts - Set text rise.
SetType3GlyphWidth | d0 - Set glyph width in Type 3 font.
SetType3GlyphWidthAndBoundingBox | d1 - Set glyph width and bounding box in Type 3 font.
SetWordSpacing | Tw - Set word spacing.
ShowText | Tj - Show text.
ShowText2 | TJ - Show text, allowing individual glyph positioning.
ShowText3 | ' - Move to next line and show text.
ShowText4 | " - Set word and character spacing, move to next line, and show text.
Stroke | S - troke path.
VCurveTo | v - Append curved segment to path (initial point replicated).
YCurveTo | y - Append curved segment to path (final point replicated).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.Operators.PdfContentStreamOperatorType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics.Operators Namespace


Xfinium.Pdf.Graphics.OptionalContent Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfOptionalContentDisplayTree | Defines the hierarchy of optional content groups that is displayed in the user interface by the viewer applications.
Class | PdfOptionalContentDisplayTreeNode | Defines a node in the optional content display tree.
Class | PdfOptionalContentDisplayTreeNodeCollection | Defines a collection of nodes in the optional content display tree.
Class | PdfOptionalContentGroup | Represents an optional content group.
Class | PdfOptionalContentGroupCollection | Defines a collection of optional content groups.
Class | PdfOptionalContentProperties | Defines the properties for optional content in the Pdf document.
Enumerations
 | Enumeration | Description
Enumeration | PdfOptionalContentGroupDefaultState | The possible default states for optional content.
Enumeration | PdfOptionalContentGroupExportState | Possible export states for an optional content group.
Enumeration | PdfOptionalContentGroupPrintState | Possible print states for an optional content group.
Enumeration | PdfOptionalContentGroupVisibilityState | Possible visibility states for an optional content group.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Graphics.OptionalContent Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentDisplayTreeNodeCollection
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentGroupCollection
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentDisplayTree
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentDisplayTreeNode
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentGroup
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentProperties
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfOptionalContentDisplayTree Class
Members

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTree Class
Defines the hierarchy of optional content groups that is displayed in the user interface by the viewer applications.
Object Model
PdfOptionalContentDisplayTree ClassPdfOptionalContentDisplayTreeNodeCollection ClassPdfOptionalContentDisplayTreeNode Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOptionalContentDisplayTree
'Usage

Dim instance As PdfOptionalContentDisplayTree
public class PdfOptionalContentDisplayTree
public ref class PdfOptionalContentDisplayTree
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentDisplayTree

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTree Members
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%% $$Members$$

PdfOptionalContentDisplayTree Class Members
Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTree Class

The following tables list the members exposed by PdfOptionalContentDisplayTree.

Public Constructors
 | Name | Description
Public Constructor | PdfOptionalContentDisplayTree Constructor | Initializes a new PdfOptionalContentDisplayTree object.
Top
Public Properties
 | Name | Description
Public Property | Nodes | Gets the collection of root nodes for the display tree.
Top
See Also

Reference

PdfOptionalContentDisplayTree Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentDisplayTree Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTree Class : PdfOptionalContentDisplayTree Constructor
Initializes a new PdfOptionalContentDisplayTree object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfOptionalContentDisplayTree()
public PdfOptionalContentDisplayTree()
public:
PdfOptionalContentDisplayTree();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTree Class
PdfOptionalContentDisplayTree Members


%%PageItemTitle%% $$Properties$$

PdfOptionalContentDisplayTree Class Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTree Class

For a list of all members of this type, see PdfOptionalContentDisplayTree members.

Public Properties
 | Name | Description
Public Property | Nodes | Gets the collection of root nodes for the display tree.
Top
See Also

Reference

PdfOptionalContentDisplayTree Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


Nodes Property (PdfOptionalContentDisplayTree)

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTree Class : Nodes Property
Gets the collection of root nodes for the display tree.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Nodes As PdfOptionalContentDisplayTreeNodeCollection
'Usage

Dim instance As PdfOptionalContentDisplayTree
Dim value As PdfOptionalContentDisplayTreeNodeCollection

value = instance.Nodes
public PdfOptionalContentDisplayTreeNodeCollection Nodes {get;}
public:
property PdfOptionalContentDisplayTreeNodeCollection^ Nodes {
   PdfOptionalContentDisplayTreeNodeCollection^ get();
}

Property Value

The root nodes of the display tree.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTree Class
PdfOptionalContentDisplayTree Members


%%PageItemTitle%%

PdfOptionalContentDisplayTreeNode Class
Members

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTreeNode Class
Defines a node in the optional content display tree.
Object Model
PdfOptionalContentDisplayTreeNode ClassPdfOptionalContentGroup ClassPdfOptionalContentDisplayTreeNodeCollection ClassPdfOptionalContentDisplayTreeNode Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOptionalContentDisplayTreeNode
'Usage

Dim instance As PdfOptionalContentDisplayTreeNode
public class PdfOptionalContentDisplayTreeNode
public ref class PdfOptionalContentDisplayTreeNode
Remarks
Each node in the tree is an optional content group.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentDisplayTreeNode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNode Members
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%% $$Members$$

PdfOptionalContentDisplayTreeNode Class Members
Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTreeNode Class

The following tables list the members exposed by PdfOptionalContentDisplayTreeNode.

Public Constructors
 | Name | Description
Public Constructor | PdfOptionalContentDisplayTreeNode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Group | Gets or sets the group associated with this node.
Public Property | Label | Gets or sets the node label.
Public Property | Nodes | Gets the collection of child nodes for this node.
Top
See Also

Reference

PdfOptionalContentDisplayTreeNode Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentDisplayTreeNode Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTreeNode Class : PdfOptionalContentDisplayTreeNode Constructor
Overload List
Overload | Description
PdfOptionalContentDisplayTreeNode Constructor(PdfOptionalContentGroup) | Initializes a new PdfOptionalContentDisplayTreeNode object.
PdfOptionalContentDisplayTreeNode Constructor(String) | Initializes a new PdfOptionalContentDisplayTreeNode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNode Class
PdfOptionalContentDisplayTreeNode Members


%%PageItemTitle%%

PdfOptionalContentDisplayTreeNode Constructor(PdfOptionalContentGroup)

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTreeNode Class > PdfOptionalContentDisplayTreeNode Constructor : PdfOptionalContentDisplayTreeNode Constructor(PdfOptionalContentGroup)
The group associated with this node.
Initializes a new PdfOptionalContentDisplayTreeNode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal group As PdfOptionalContentGroup _
)
'Usage

Dim group As PdfOptionalContentGroup

Dim instance As New PdfOptionalContentDisplayTreeNode(group)
public PdfOptionalContentDisplayTreeNode(
   PdfOptionalContentGroup group
)
public:
PdfOptionalContentDisplayTreeNode(
   PdfOptionalContentGroup^ group
)

Parameters

group
The group associated with this node.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNode Class
PdfOptionalContentDisplayTreeNode Members
Overload List


%%PageItemTitle%%

PdfOptionalContentDisplayTreeNode Constructor(String)

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTreeNode Class > PdfOptionalContentDisplayTreeNode Constructor : PdfOptionalContentDisplayTreeNode Constructor(String)
String label to be displayed for this node.
Initializes a new PdfOptionalContentDisplayTreeNode object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal label As String _
)
'Usage

Dim label As String

Dim instance As New PdfOptionalContentDisplayTreeNode(label)
public PdfOptionalContentDisplayTreeNode(
   string label
)
public:
PdfOptionalContentDisplayTreeNode(
   String^ label
)

Parameters

label
String label to be displayed for this node.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNode Class
PdfOptionalContentDisplayTreeNode Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfOptionalContentDisplayTreeNode Class Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTreeNode Class

For a list of all members of this type, see PdfOptionalContentDisplayTreeNode members.

Public Properties
 | Name | Description
Public Property | Group | Gets or sets the group associated with this node.
Public Property | Label | Gets or sets the node label.
Public Property | Nodes | Gets the collection of child nodes for this node.
Top
See Also

Reference

PdfOptionalContentDisplayTreeNode Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


Group Property

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTreeNode Class : Group Property
Gets or sets the group associated with this node.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Group As PdfOptionalContentGroup
'Usage

Dim instance As PdfOptionalContentDisplayTreeNode
Dim value As PdfOptionalContentGroup

instance.Group = value

value = instance.Group
public PdfOptionalContentGroup Group {get; set;}
public:
property PdfOptionalContentGroup^ Group {
   PdfOptionalContentGroup^ get();
   void set (    PdfOptionalContentGroup^ value);
}

Property Value

The group displayed in this node of the optional content display tree.
Remarks
Label and Group properties are exclusive.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNode Class
PdfOptionalContentDisplayTreeNode Members


Label Property

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTreeNode Class : Label Property
Gets or sets the node label.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Label As String
'Usage

Dim instance As PdfOptionalContentDisplayTreeNode
Dim value As String

instance.Label = value

value = instance.Label
public string Label {get; set;}
public:
property String^ Label {
   String^ get();
   void set (    String^ value);
}

Property Value

A string to be displayed in the tree as node label.
Remarks
Label and Group properties are exclusive.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNode Class
PdfOptionalContentDisplayTreeNode Members


Nodes Property (PdfOptionalContentDisplayTreeNode)

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTreeNode Class : Nodes Property
Gets the collection of child nodes for this node.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Nodes As PdfOptionalContentDisplayTreeNodeCollection
'Usage

Dim instance As PdfOptionalContentDisplayTreeNode
Dim value As PdfOptionalContentDisplayTreeNodeCollection

value = instance.Nodes
public PdfOptionalContentDisplayTreeNodeCollection Nodes {get;}
public:
property PdfOptionalContentDisplayTreeNodeCollection^ Nodes {
   PdfOptionalContentDisplayTreeNodeCollection^ get();
}

Property Value

The child nodes of this node.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNode Class
PdfOptionalContentDisplayTreeNode Members


%%PageItemTitle%%

PdfOptionalContentDisplayTreeNodeCollection Class
Members

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTreeNodeCollection Class
Defines a collection of nodes in the optional content display tree.
Object Model
PdfOptionalContentDisplayTreeNodeCollection ClassPdfOptionalContentDisplayTreeNode Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOptionalContentDisplayTreeNodeCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfOptionalContentDisplayTreeNode)
'Usage

Dim instance As PdfOptionalContentDisplayTreeNodeCollection
public class PdfOptionalContentDisplayTreeNodeCollection : System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>
public ref class PdfOptionalContentDisplayTreeNodeCollection : public System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentDisplayTreeNodeCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNodeCollection Members
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%% $$Members$$

PdfOptionalContentDisplayTreeNodeCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTreeNodeCollection Class

The following tables list the members exposed by PdfOptionalContentDisplayTreeNodeCollection.

Public Constructors
 | Name | Description
Public Constructor | PdfOptionalContentDisplayTreeNodeCollection Constructor | Initializes a new PdfOptionalContentDisplayTreeNodeCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Top
See Also

Reference

PdfOptionalContentDisplayTreeNodeCollection Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentDisplayTreeNodeCollection Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTreeNodeCollection Class : PdfOptionalContentDisplayTreeNodeCollection Constructor
Initializes a new PdfOptionalContentDisplayTreeNodeCollection object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfOptionalContentDisplayTreeNodeCollection()
public PdfOptionalContentDisplayTreeNodeCollection()
public:
PdfOptionalContentDisplayTreeNodeCollection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNodeCollection Class
PdfOptionalContentDisplayTreeNodeCollection Members


%%PageItemTitle%%

PdfOptionalContentGroup Class
Members

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroup Class
Represents an optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOptionalContentGroup
'Usage

Dim instance As PdfOptionalContentGroup
public class PdfOptionalContentGroup
public ref class PdfOptionalContentGroup
Remarks
An optional content group represents a collection of graphics that can be made visible or invisible dynamically by users of viewer applications.
The graphics belonging to an optional content group can be located anywhere in the document, on one or more pages and they need not be consecutive in drawing order
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentGroup

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Members
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%% $$Members$$

PdfOptionalContentGroup Class Members
Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroup Class

The following tables list the members exposed by PdfOptionalContentGroup.

Public Constructors
 | Name | Description
Public Constructor | PdfOptionalContentGroup Constructor | Initializes a new PdfOptionalContentGroup object.
Top
Public Properties
 | Name | Description
Public Property | DefaultState | Gets or sets the default state of the optional content group.
Public Property | ExportState | Gets or sets the export state of this optional content group.
Public Property | Locked | Gets or sets a value indicating whether the layer is locked when the Pdf file is displayed in the viewer application.
Public Property | Name | Gets or sets the name of the optional content group.
Public Property | PrintState | Gets or sets the print state of this optional content group.
Public Property | VisibilityState | Gets or sets the visibility state of this optional content group.
Top
See Also

Reference

PdfOptionalContentGroup Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentGroup Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentGroup Class : PdfOptionalContentGroup Constructor
Initializes a new PdfOptionalContentGroup object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfOptionalContentGroup()
public PdfOptionalContentGroup()
public:
PdfOptionalContentGroup();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Class
PdfOptionalContentGroup Members


%%PageItemTitle%% $$Properties$$

PdfOptionalContentGroup Class Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroup Class

For a list of all members of this type, see PdfOptionalContentGroup members.

Public Properties
 | Name | Description
Public Property | DefaultState | Gets or sets the default state of the optional content group.
Public Property | ExportState | Gets or sets the export state of this optional content group.
Public Property | Locked | Gets or sets a value indicating whether the layer is locked when the Pdf file is displayed in the viewer application.
Public Property | Name | Gets or sets the name of the optional content group.
Public Property | PrintState | Gets or sets the print state of this optional content group.
Public Property | VisibilityState | Gets or sets the visibility state of this optional content group.
Top
See Also

Reference

PdfOptionalContentGroup Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


DefaultState Property

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentGroup Class : DefaultState Property
Gets or sets the default state of the optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultState As PdfOptionalContentGroupDefaultState
'Usage

Dim instance As PdfOptionalContentGroup
Dim value As PdfOptionalContentGroupDefaultState

instance.DefaultState = value

value = instance.DefaultState
public PdfOptionalContentGroupDefaultState DefaultState {get; set;}
public:
property PdfOptionalContentGroupDefaultState DefaultState {
   PdfOptionalContentGroupDefaultState get();
   void set (    PdfOptionalContentGroupDefaultState value);
}

Property Value

On if the optional content group should be visible when the document is displayed, Off otherwise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Class
PdfOptionalContentGroup Members


ExportState Property

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentGroup Class : ExportState Property
Gets or sets the export state of this optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExportState As PdfOptionalContentGroupExportState
'Usage

Dim instance As PdfOptionalContentGroup
Dim value As PdfOptionalContentGroupExportState

instance.ExportState = value

value = instance.ExportState
public PdfOptionalContentGroupExportState ExportState {get; set;}
public:
property PdfOptionalContentGroupExportState ExportState {
   PdfOptionalContentGroupExportState get();
   void set (    PdfOptionalContentGroupExportState value);
}

Property Value

The export state of the optional content group.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Class
PdfOptionalContentGroup Members


Locked Property (PdfOptionalContentGroup)

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentGroup Class : Locked Property
Gets or sets a value indicating whether the layer is locked when the Pdf file is displayed in the viewer application.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Locked As Boolean
'Usage

Dim instance As PdfOptionalContentGroup
Dim value As Boolean

instance.Locked = value

value = instance.Locked
public bool Locked {get; set;}
public:
property bool Locked {
   bool get();
   void set (    bool value);
}

Property Value

True if the layer is locked, false otherwise. Default is locked.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Class
PdfOptionalContentGroup Members


Name Property (PdfOptionalContentGroup)

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentGroup Class : Name Property
Gets or sets the name of the optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfOptionalContentGroup
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Class
PdfOptionalContentGroup Members


PrintState Property

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentGroup Class : PrintState Property
Gets or sets the print state of this optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PrintState As PdfOptionalContentGroupPrintState
'Usage

Dim instance As PdfOptionalContentGroup
Dim value As PdfOptionalContentGroupPrintState

instance.PrintState = value

value = instance.PrintState
public PdfOptionalContentGroupPrintState PrintState {get; set;}
public:
property PdfOptionalContentGroupPrintState PrintState {
   PdfOptionalContentGroupPrintState get();
   void set (    PdfOptionalContentGroupPrintState value);
}

Property Value

The print state of the optional content group.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Class
PdfOptionalContentGroup Members


VisibilityState Property

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentGroup Class : VisibilityState Property
Gets or sets the visibility state of this optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VisibilityState As PdfOptionalContentGroupVisibilityState
'Usage

Dim instance As PdfOptionalContentGroup
Dim value As PdfOptionalContentGroupVisibilityState

instance.VisibilityState = value

value = instance.VisibilityState
public PdfOptionalContentGroupVisibilityState VisibilityState {get; set;}
public:
property PdfOptionalContentGroupVisibilityState VisibilityState {
   PdfOptionalContentGroupVisibilityState get();
   void set (    PdfOptionalContentGroupVisibilityState value);
}

Property Value

The visibility state of the optional content group.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Class
PdfOptionalContentGroup Members


%%PageItemTitle%%

PdfOptionalContentGroupCollection Class
Members

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroupCollection Class
Defines a collection of optional content groups.
Object Model
PdfOptionalContentGroupCollection ClassPdfOptionalContentGroup Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOptionalContentGroupCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfOptionalContentGroup)
'Usage

Dim instance As PdfOptionalContentGroupCollection
public class PdfOptionalContentGroupCollection : System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>
public ref class PdfOptionalContentGroupCollection : public System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentGroupCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroupCollection Members
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%% $$Members$$

PdfOptionalContentGroupCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroupCollection Class

The following tables list the members exposed by PdfOptionalContentGroupCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Top
See Also

Reference

PdfOptionalContentGroupCollection Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentProperties Class
Members

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentProperties Class
Defines the properties for optional content in the Pdf document.
Object Model
PdfOptionalContentProperties ClassPdfOptionalContentDisplayTree Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfOptionalContentProperties
'Usage

Dim instance As PdfOptionalContentProperties
public class PdfOptionalContentProperties
public ref class PdfOptionalContentProperties
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentProperties

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentProperties Members
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%% $$Members$$

PdfOptionalContentProperties Class Members
Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentProperties Class

The following tables list the members exposed by PdfOptionalContentProperties.

Public Constructors
 | Name | Description
Public Constructor | PdfOptionalContentProperties Constructor | Initializes a new PdfOptionalContentProperties object.
Top
Public Properties
 | Name | Description
Public Property | DisplayTree | Gets the tree of optional content groups.
Top
See Also

Reference

PdfOptionalContentProperties Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentProperties Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentProperties Class : PdfOptionalContentProperties Constructor
Initializes a new PdfOptionalContentProperties object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfOptionalContentProperties()
public PdfOptionalContentProperties()
public:
PdfOptionalContentProperties();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentProperties Class
PdfOptionalContentProperties Members


%%PageItemTitle%% $$Properties$$

PdfOptionalContentProperties Class Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentProperties Class

For a list of all members of this type, see PdfOptionalContentProperties members.

Public Properties
 | Name | Description
Public Property | DisplayTree | Gets the tree of optional content groups.
Top
See Also

Reference

PdfOptionalContentProperties Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


DisplayTree Property

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentProperties Class : DisplayTree Property
Gets the tree of optional content groups.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayTree As PdfOptionalContentDisplayTree
'Usage

Dim instance As PdfOptionalContentProperties
Dim value As PdfOptionalContentDisplayTree

value = instance.DisplayTree
public PdfOptionalContentDisplayTree DisplayTree {get;}
public:
property PdfOptionalContentDisplayTree^ DisplayTree {
   PdfOptionalContentDisplayTree^ get();
}

Property Value

The tree of optional content groups that is displayed in the user interface by the viewer applications.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentProperties Class
PdfOptionalContentProperties Members


%%PageItemTitle%%

PdfOptionalContentGroupDefaultState Enumeration

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroupDefaultState Enumeration
The possible default states for optional content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfOptionalContentGroupDefaultState
   Inherits System.Enum
'Usage

Dim instance As PdfOptionalContentGroupDefaultState
public enum PdfOptionalContentGroupDefaultState : System.Enum
public enum class PdfOptionalContentGroupDefaultState : public System.Enum
Members
Member | Description
None | The optional content group does not have a default state.
Off | The optional content group is invisible when the document is displayed.
On | The optional content group is visible when the document is displayed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentGroupDefaultState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentGroupExportState Enumeration

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroupExportState Enumeration
Possible export states for an optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfOptionalContentGroupExportState
   Inherits System.Enum
'Usage

Dim instance As PdfOptionalContentGroupExportState
public enum PdfOptionalContentGroupExportState : System.Enum
public enum class PdfOptionalContentGroupExportState : public System.Enum
Members
Member | Description
AlwaysExport | The optional content group is always exported.
ExportWhenVisible | The optional content group is exported if it is visible.
NeverExport | The optional content group is never exported.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentGroupExportState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentGroupPrintState Enumeration

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroupPrintState Enumeration
Possible print states for an optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfOptionalContentGroupPrintState
   Inherits System.Enum
'Usage

Dim instance As PdfOptionalContentGroupPrintState
public enum PdfOptionalContentGroupPrintState : System.Enum
public enum class PdfOptionalContentGroupPrintState : public System.Enum
Members
Member | Description
AlwaysPrint | The optional content group is always printed.
NeverPrint | The optional content group is never printed.
PrintWhenVisible | The optional content group is printed if it is visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentGroupPrintState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentGroupVisibilityState Enumeration

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroupVisibilityState Enumeration
Possible visibility states for an optional content group.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfOptionalContentGroupVisibilityState
   Inherits System.Enum
'Usage

Dim instance As PdfOptionalContentGroupVisibilityState
public enum PdfOptionalContentGroupVisibilityState : System.Enum
public enum class PdfOptionalContentGroupVisibilityState : public System.Enum
Members
Member | Description
AlwaysVisible | The optional content group is always visible no matter its default state.
NeverVisible | The optional content group is never visible no matter its default state.
VisibleWhenOn | The optional content group is visible if its default state is On.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.OptionalContent.PdfOptionalContentGroupVisibilityState

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics.OptionalContent Namespace


Xfinium.Pdf.Graphics.Svg Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfSvgDrawing | Defines a SVG drawing.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Graphics.Svg Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Xfinium.Pdf.PdfContentStreamContainer
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Graphics.Svg.PdfSvgDrawing
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfSvgDrawing Class
Members

Xfinium.Pdf.Graphics.Svg Namespace : PdfSvgDrawing Class
Defines a SVG drawing.
Object Model
PdfSvgDrawing ClassPdfCosDictionary ClassPdfFont ClassPdfFont ClassPdfFont ClassPdfFont ClassPdfGraphics ClassPdfMatrix ClassPdfMeasure ClassPdfPointData ClassPdfGroupXObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSvgDrawing
   Inherits Xfinium.Pdf.Graphics.PdfFormXObject
'Usage

Dim instance As PdfSvgDrawing
public class PdfSvgDrawing : Xfinium.Pdf.Graphics.PdfFormXObject
public ref class PdfSvgDrawing : public Xfinium.Pdf.Graphics.PdfFormXObject
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.PdfFormXObject
Xfinium.Pdf.Graphics.Svg.PdfSvgDrawing

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSvgDrawing Members
Xfinium.Pdf.Graphics.Svg Namespace


%%PageItemTitle%% $$Members$$

PdfSvgDrawing Class Members
Properties Methods

Xfinium.Pdf.Graphics.Svg Namespace : PdfSvgDrawing Class

The following tables list the members exposed by PdfSvgDrawing.

Public Constructors
 | Name | Description
Public Constructor | PdfSvgDrawing Constructor | Initializes a new PdfSvgDrawing object.
Top
Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | DefaultBoldFont | Default font to be used for rendering SVG bold text in the PDF file.
Public Property | DefaultBoldItalicFont | Default font to be used for rendering SVG bold italic text in the PDF file.
Public Property | DefaultItalicFont | Default font to be used for rendering SVG italic text in the PDF file.
Public Property | DefaultRegularFont | Default font to be used for rendering SVG text in the PDF file.
Public Property | Graphics | Gets the form XObject graphics. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Height | Gets the form XObject height. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Matrix | Gets or sets the form XObject matrix. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Width | Gets the form XObject width. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Top
Public Methods
 | Name | Description
Public Method | RenderSvgDrawing | Renders the SVG document as PDF graphics.
Top
See Also

Reference

PdfSvgDrawing Class
Xfinium.Pdf.Graphics.Svg Namespace


%%PageItemTitle%%

PdfSvgDrawing Constructor

Xfinium.Pdf.Graphics.Svg Namespace > PdfSvgDrawing Class : PdfSvgDrawing Constructor
Source stream with SVG document.
Initializes a new PdfSvgDrawing object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfSvgDrawing(stream)
public PdfSvgDrawing(
   Stream stream
)
public:
PdfSvgDrawing(
   Stream^ stream
)

Parameters

stream
Source stream with SVG document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSvgDrawing Class
PdfSvgDrawing Members


%%PageItemTitle%% $$Methods$$

PdfSvgDrawing Class Methods

Xfinium.Pdf.Graphics.Svg Namespace : PdfSvgDrawing Class

For a list of all members of this type, see PdfSvgDrawing members.

Public Methods
 | Name | Description
Public Method | RenderSvgDrawing | Renders the SVG document as PDF graphics.
Top
See Also

Reference

PdfSvgDrawing Class
Xfinium.Pdf.Graphics.Svg Namespace


RenderSvgDrawing Method

Xfinium.Pdf.Graphics.Svg Namespace > PdfSvgDrawing Class : RenderSvgDrawing Method
Renders the SVG document as PDF graphics.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RenderSvgDrawing()
'Usage

Dim instance As PdfSvgDrawing

instance.RenderSvgDrawing()
public void RenderSvgDrawing()
public:
void RenderSvgDrawing();
Remarks
This method performs an explicit rendering of the SVG content to PDF. After the rendering process the size of this PdfSvgDrawing object can be retrieved using the Xfinium.Pdf.Graphics.PdfFormXObject.Width and Xfinium.Pdf.Graphics.PdfFormXObject.Height properties.
An explicit call of this method is not required, the framework calls it when the SVG drawing is drawn on the target graphics surface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSvgDrawing Class
PdfSvgDrawing Members


%%PageItemTitle%% $$Properties$$

PdfSvgDrawing Class Properties

Xfinium.Pdf.Graphics.Svg Namespace : PdfSvgDrawing Class

For a list of all members of this type, see PdfSvgDrawing members.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | DefaultBoldFont | Default font to be used for rendering SVG bold text in the PDF file.
Public Property | DefaultBoldItalicFont | Default font to be used for rendering SVG bold italic text in the PDF file.
Public Property | DefaultItalicFont | Default font to be used for rendering SVG italic text in the PDF file.
Public Property | DefaultRegularFont | Default font to be used for rendering SVG text in the PDF file.
Public Property | Graphics | Gets the form XObject graphics. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Height | Gets the form XObject height. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Matrix | Gets or sets the form XObject matrix. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Width | Gets the form XObject width. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Top
See Also

Reference

PdfSvgDrawing Class
Xfinium.Pdf.Graphics.Svg Namespace


DefaultBoldFont Property

Xfinium.Pdf.Graphics.Svg Namespace > PdfSvgDrawing Class : DefaultBoldFont Property
Default font to be used for rendering SVG bold text in the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultBoldFont As PdfFont
'Usage

Dim instance As PdfSvgDrawing
Dim value As PdfFont

instance.DefaultBoldFont = value

value = instance.DefaultBoldFont
public PdfFont DefaultBoldFont {get; set;}
public:
property PdfFont^ DefaultBoldFont {
   PdfFont^ get();
   void set (    PdfFont^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSvgDrawing Class
PdfSvgDrawing Members


DefaultBoldItalicFont Property

Xfinium.Pdf.Graphics.Svg Namespace > PdfSvgDrawing Class : DefaultBoldItalicFont Property
Default font to be used for rendering SVG bold italic text in the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultBoldItalicFont As PdfFont
'Usage

Dim instance As PdfSvgDrawing
Dim value As PdfFont

instance.DefaultBoldItalicFont = value

value = instance.DefaultBoldItalicFont
public PdfFont DefaultBoldItalicFont {get; set;}
public:
property PdfFont^ DefaultBoldItalicFont {
   PdfFont^ get();
   void set (    PdfFont^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSvgDrawing Class
PdfSvgDrawing Members


DefaultItalicFont Property

Xfinium.Pdf.Graphics.Svg Namespace > PdfSvgDrawing Class : DefaultItalicFont Property
Default font to be used for rendering SVG italic text in the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultItalicFont As PdfFont
'Usage

Dim instance As PdfSvgDrawing
Dim value As PdfFont

instance.DefaultItalicFont = value

value = instance.DefaultItalicFont
public PdfFont DefaultItalicFont {get; set;}
public:
property PdfFont^ DefaultItalicFont {
   PdfFont^ get();
   void set (    PdfFont^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSvgDrawing Class
PdfSvgDrawing Members


DefaultRegularFont Property

Xfinium.Pdf.Graphics.Svg Namespace > PdfSvgDrawing Class : DefaultRegularFont Property
Default font to be used for rendering SVG text in the PDF file.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DefaultRegularFont As PdfFont
'Usage

Dim instance As PdfSvgDrawing
Dim value As PdfFont

instance.DefaultRegularFont = value

value = instance.DefaultRegularFont
public PdfFont DefaultRegularFont {get; set;}
public:
property PdfFont^ DefaultRegularFont {
   PdfFont^ get();
   void set (    PdfFont^ value);
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSvgDrawing Class
PdfSvgDrawing Members


Xfinium.Pdf.Graphics.Text Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfTextEngine | Provides various services related to text layout on PDF pages.
Class | PdfTextLine | Defines a line of text.
Class | PdfTextLineCollection | Defines a collection of text lines.
Enumerations
 | Enumeration | Description
Enumeration | PdfTextRenderingMode | Specifies the supported text rendering modes for a font.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Graphics.Text Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Graphics.Text.PdfTextLineCollection
Xfinium.Pdf.Graphics.Text.PdfTextEngine
Xfinium.Pdf.Graphics.Text.PdfTextLine
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfTextEngine Class
Members

Xfinium.Pdf.Graphics.Text Namespace : PdfTextEngine Class
Provides various services related to text layout on PDF pages.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextEngine
'Usage

Dim instance As PdfTextEngine
public class PdfTextEngine
public ref class PdfTextEngine
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Text.PdfTextEngine

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextEngine Members
Xfinium.Pdf.Graphics.Text Namespace


%%PageItemTitle%% $$Members$$

PdfTextEngine Class Members
Methods

Xfinium.Pdf.Graphics.Text Namespace : PdfTextEngine Class

The following tables list the members exposed by PdfTextEngine.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetStringHeight | Gets the height of the string wrapped at the specified width.
static (Shared in Visual Basic) | GetStringInBox | Gets the string that fits in the given box.
static (Shared in Visual Basic) | MeasureString | Measures the specified string.
static (Shared in Visual Basic) | WrapString | Wraps the string at the given width.
Top
See Also

Reference

PdfTextEngine Class
Xfinium.Pdf.Graphics.Text Namespace


%%PageItemTitle%% $$Methods$$

PdfTextEngine Class Methods

Xfinium.Pdf.Graphics.Text Namespace : PdfTextEngine Class

For a list of all members of this type, see PdfTextEngine members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetStringHeight | Gets the height of the string wrapped at the specified width.
static (Shared in Visual Basic) | GetStringInBox | Gets the string that fits in the given box.
static (Shared in Visual Basic) | MeasureString | Measures the specified string.
static (Shared in Visual Basic) | WrapString | Wraps the string at the given width.
Top
See Also

Reference

PdfTextEngine Class
Xfinium.Pdf.Graphics.Text Namespace


GetStringHeight Method

Xfinium.Pdf.Graphics.Text Namespace > PdfTextEngine Class : GetStringHeight Method
String to measure.
Font used to draw the string.
Maximum width for wrapping.
Gets the height of the string wrapped at the specified width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function GetStringHeight( _
   ByVal s As String, _
   ByVal font As PdfFont, _
   ByVal width As Double _
) As Double
'Usage

Dim s As String
Dim font As PdfFont
Dim width As Double
Dim value As Double

value = PdfTextEngine.GetStringHeight(s, font, width)
public static double GetStringHeight(
   string s,
   PdfFont font,
   double width
)
public:
static double GetStringHeight(
   String^ s,
   PdfFont^ font,
   double width
)

Parameters

s
String to measure.
font
Font used to draw the string.
width
Maximum width for wrapping.

Return Value

The total height of the text lines.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextEngine Class
PdfTextEngine Members


GetStringInBox Method

Xfinium.Pdf.Graphics.Text Namespace > PdfTextEngine Class : GetStringInBox Method
String to wrap in the box.
Font used to draw the string.
The box width.
The box height.
Gets the string that fits in the given box.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function GetStringInBox( _
   ByVal s As String, _
   ByVal font As PdfFont, _
   ByVal width As Double, _
   ByVal height As Double _
) As String
'Usage

Dim s As String
Dim font As PdfFont
Dim width As Double
Dim height As Double
Dim value As String

value = PdfTextEngine.GetStringInBox(s, font, width, height)
public static string GetStringInBox(
   string s,
   PdfFont font,
   double width,
   double height
)
public:
static String^ GetStringInBox(
   String^ s,
   PdfFont^ font,
   double width,
   double height
)

Parameters

s
String to wrap in the box.
font
Font used to draw the string.
width
The box width.
height
The box height.

Return Value

The number of characters in the string that fit in the given box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextEngine Class
PdfTextEngine Members


MeasureString Method

Xfinium.Pdf.Graphics.Text Namespace > PdfTextEngine Class : MeasureString Method
String to measure.
Font used to display the string.
Measures the specified string.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function MeasureString( _
   ByVal s As String, _
   ByVal font As PdfFont _
) As PdfSize
'Usage

Dim s As String
Dim font As PdfFont
Dim value As PdfSize

value = PdfTextEngine.MeasureString(s, font)
public static PdfSize MeasureString(
   string s,
   PdfFont font
)
public:
static PdfSize^ MeasureString(
   String^ s,
   PdfFont^ font
)

Parameters

s
String to measure.
font
Font used to display the string.

Return Value

The size of the string when displayed using the font.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextEngine Class
PdfTextEngine Members


WrapString Method

Xfinium.Pdf.Graphics.Text Namespace > PdfTextEngine Class : WrapString Method
String to wrap.
Font used to draw the text.
Maximum width for wrapping.
Wraps the string at the given width.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function WrapString( _
   ByVal s As String, _
   ByVal font As PdfFont, _
   ByVal width As Double _
) As PdfTextLineCollection
'Usage

Dim s As String
Dim font As PdfFont
Dim width As Double
Dim value As PdfTextLineCollection

value = PdfTextEngine.WrapString(s, font, width)
public static PdfTextLineCollection WrapString(
   string s,
   PdfFont font,
   double width
)
public:
static PdfTextLineCollection^ WrapString(
   String^ s,
   PdfFont^ font,
   double width
)

Parameters

s
String to wrap.
font
Font used to draw the text.
width
Maximum width for wrapping.

Return Value

A collection of text lines representing the wrapped text.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextEngine Class
PdfTextEngine Members


%%PageItemTitle%%

PdfTextLine Class
Members

Xfinium.Pdf.Graphics.Text Namespace : PdfTextLine Class
Defines a line of text.
Object Model
PdfTextLine ClassPdfVisualRectangle Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextLine
'Usage

Dim instance As PdfTextLine
public class PdfTextLine
public ref class PdfTextLine
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Graphics.Text.PdfTextLine

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextLine Members
Xfinium.Pdf.Graphics.Text Namespace


%%PageItemTitle%% $$Members$$

PdfTextLine Class Members
Properties

Xfinium.Pdf.Graphics.Text Namespace : PdfTextLine Class

The following tables list the members exposed by PdfTextLine.

Public Properties
 | Name | Description
Public Property | Rectangle | Gets the line rectangle.
Public Property | Text | Gets the text.
Top
See Also

Reference

PdfTextLine Class
Xfinium.Pdf.Graphics.Text Namespace


%%PageItemTitle%% $$Properties$$

PdfTextLine Class Properties

Xfinium.Pdf.Graphics.Text Namespace : PdfTextLine Class

For a list of all members of this type, see PdfTextLine members.

Public Properties
 | Name | Description
Public Property | Rectangle | Gets the line rectangle.
Public Property | Text | Gets the text.
Top
See Also

Reference

PdfTextLine Class
Xfinium.Pdf.Graphics.Text Namespace


Rectangle Property

Xfinium.Pdf.Graphics.Text Namespace > PdfTextLine Class : Rectangle Property
Gets the line rectangle.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Rectangle As PdfVisualRectangle
'Usage

Dim instance As PdfTextLine
Dim value As PdfVisualRectangle

value = instance.Rectangle
public PdfVisualRectangle Rectangle {get;}
public:
property PdfVisualRectangle^ Rectangle {
   PdfVisualRectangle^ get();
}

Property Value

The rectangle that bounds the text line.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextLine Class
PdfTextLine Members


Text Property (PdfTextLine)

Xfinium.Pdf.Graphics.Text Namespace > PdfTextLine Class : Text Property
Gets the text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Text As String
'Usage

Dim instance As PdfTextLine
Dim value As String

value = instance.Text
public string Text {get;}
public:
property String^ Text {
   String^ get();
}

Property Value

The text displayed in this line.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextLine Class
PdfTextLine Members


%%PageItemTitle%%

PdfTextLineCollection Class
Members

Xfinium.Pdf.Graphics.Text Namespace : PdfTextLineCollection Class
Defines a collection of text lines.
Object Model
PdfTextLineCollection ClassPdfTextLine Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfTextLineCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfTextLine)
'Usage

Dim instance As PdfTextLineCollection
public class PdfTextLineCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>
public ref class PdfTextLineCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Graphics.Text.PdfTextLineCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextLineCollection Members
Xfinium.Pdf.Graphics.Text Namespace


%%PageItemTitle%% $$Members$$

PdfTextLineCollection Class Members
Properties Methods

Xfinium.Pdf.Graphics.Text Namespace : PdfTextLineCollection Class

The following tables list the members exposed by PdfTextLineCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Top
See Also

Reference

PdfTextLineCollection Class
Xfinium.Pdf.Graphics.Text Namespace


%%PageItemTitle%%

PdfTextRenderingMode Enumeration

Xfinium.Pdf.Graphics.Text Namespace : PdfTextRenderingMode Enumeration
Specifies the supported text rendering modes for a font.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfTextRenderingMode
   Inherits System.Enum
'Usage

Dim instance As PdfTextRenderingMode
public enum PdfTextRenderingMode : System.Enum
public enum class PdfTextRenderingMode : public System.Enum
Members
Member | Description
ClipText | Add text to path for clipping.
Default | This value specifies that the text rendering mode is determined automatically based on the pen and brush availability in DrawString methods.
FillAndClipText | Fill text and add to path for clipping.
FillStrokeAndClipText | Fill, then stroke text and add to path for clipping.
FillStrokeText | Fill, then stroke text.
FillText | Fill text.
NoFillNoStrokeText | Neither fill nor stroke text (invisible).
StrokeAndClipText | Stroke text and add to path for clipping.
StrokeText | Stroke text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Graphics.Text.PdfTextRenderingMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Graphics.Text Namespace


Xfinium.Pdf.Imaging Namespace
Inheritance Hierarchy
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Imaging Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

XFINIUM.PDF Library


Xfinium.Pdf.Imaging.Png Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PngDecodeException | Defines an exception that is thrown when a PNG image cannot be decoded.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Imaging.Png Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Imaging.Png.PngDecodeException
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PngDecodeException Class
Members

Xfinium.Pdf.Imaging.Png Namespace : PngDecodeException Class
Defines an exception that is thrown when a PNG image cannot be decoded.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PngDecodeException
   Inherits Xfinium.Pdf.Core.Exceptions.PdfException
'Usage

Dim instance As PngDecodeException
public class PngDecodeException : Xfinium.Pdf.Core.Exceptions.PdfException
public ref class PngDecodeException : public Xfinium.Pdf.Core.Exceptions.PdfException
Inheritance Hierarchy

System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Imaging.Png.PngDecodeException

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PngDecodeException Members
Xfinium.Pdf.Imaging.Png Namespace


%%PageItemTitle%% $$Members$$

PngDecodeException Class Members
Properties Methods

Xfinium.Pdf.Imaging.Png Namespace : PngDecodeException Class

The following tables list the members exposed by PngDecodeException.

Public Constructors
 | Name | Description
Public Constructor | PngDecodeException Constructor | Initializes a new PngDecodeException object.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PngDecodeException Class
Xfinium.Pdf.Imaging.Png Namespace


%%PageItemTitle%%

PngDecodeException Constructor

Xfinium.Pdf.Imaging.Png Namespace > PngDecodeException Class : PngDecodeException Constructor
The exception message.
Initializes a new PngDecodeException object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PngDecodeException(message)
public PngDecodeException(
   string message
)
public:
PngDecodeException(
   String^ message
)

Parameters

message
The exception message.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PngDecodeException Class
PngDecodeException Members


Xfinium.Pdf.Imaging.Tiff Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | TiffDecodeException | Defines an exception that is thrown when a TIFF image cannot be decoded.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Imaging.Tiff Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Imaging.Tiff.TiffDecodeException
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

TiffDecodeException Class
Members

Xfinium.Pdf.Imaging.Tiff Namespace : TiffDecodeException Class
Defines an exception that is thrown when a TIFF image cannot be decoded.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class TiffDecodeException
   Inherits Xfinium.Pdf.Core.Exceptions.PdfException
'Usage

Dim instance As TiffDecodeException
public class TiffDecodeException : Xfinium.Pdf.Core.Exceptions.PdfException
public ref class TiffDecodeException : public Xfinium.Pdf.Core.Exceptions.PdfException
Inheritance Hierarchy

System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Imaging.Tiff.TiffDecodeException

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

TiffDecodeException Members
Xfinium.Pdf.Imaging.Tiff Namespace


%%PageItemTitle%% $$Members$$

TiffDecodeException Class Members
Properties Methods

Xfinium.Pdf.Imaging.Tiff Namespace : TiffDecodeException Class

The following tables list the members exposed by TiffDecodeException.

Public Constructors
 | Name | Description
Public Constructor | TiffDecodeException Constructor | Initializes a new TiffDecodeException object.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

TiffDecodeException Class
Xfinium.Pdf.Imaging.Tiff Namespace


%%PageItemTitle%%

TiffDecodeException Constructor

Xfinium.Pdf.Imaging.Tiff Namespace > TiffDecodeException Class : TiffDecodeException Constructor
The exception message.
Initializes a new TiffDecodeException object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TiffDecodeException(message)
public TiffDecodeException(
   string message
)
public:
TiffDecodeException(
   String^ message
)

Parameters

message
The exception message.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

TiffDecodeException Class
TiffDecodeException Members


Xfinium.Pdf.PdfFunctions Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfExponentialFunction | Defines a type 2 (Exponential Interpolation) function.
Class | PdfFunction | Defines the base class for all PDF functions.
Class | PdfFunctionCollection | Defines a collection of PDF functions.
Class | PdfPostScriptFunction | Defines a type 4 (PostScript) function.
Class | PdfSampleFunction | Defines a type 0 (Sampled) function.
Class | PdfStitchingFunction | Defines a type 3 (Stitching) function.
Enumerations
 | Enumeration | Description
Enumeration | PdfFunctionInterpolationMode | Supported interpolation modes for a type 0 function values.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.PdfFunctions Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfFunctions.PdfFunctionCollection
Xfinium.Pdf.PdfFunctions.PdfFunction
Xfinium.Pdf.PdfFunctions.PdfExponentialFunction
Xfinium.Pdf.PdfFunctions.PdfPostScriptFunction
Xfinium.Pdf.PdfFunctions.PdfSampleFunction
Xfinium.Pdf.PdfFunctions.PdfStitchingFunction
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfExponentialFunction Class
Members

Xfinium.Pdf.PdfFunctions Namespace : PdfExponentialFunction Class
Defines a type 2 (Exponential Interpolation) function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfExponentialFunction
   Inherits PdfFunction
'Usage

Dim instance As PdfExponentialFunction
public class PdfExponentialFunction : PdfFunction
public ref class PdfExponentialFunction : public PdfFunction
Remarks
Type 2 Pdf functions define an exponential interpolation of one input value and n output values.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfFunctions.PdfFunction
Xfinium.Pdf.PdfFunctions.PdfExponentialFunction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExponentialFunction Members
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%% $$Members$$

PdfExponentialFunction Class Members
Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfExponentialFunction Class

The following tables list the members exposed by PdfExponentialFunction.

Public Constructors
 | Name | Description
Public Constructor | PdfExponentialFunction Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | C0 | Gets or sets the function result when input value is 0.
Public Property | C1 | Gets or sets the function result when input value is 1.
Public Property | Domain | Gets or sets the function domain. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | Exponent | Gets or sets the interpolation exponent.
Public Property | Range | Gets or sets the function range. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Top
See Also

Reference

PdfExponentialFunction Class
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%%

PdfExponentialFunction Constructor

Xfinium.Pdf.PdfFunctions Namespace > PdfExponentialFunction Class : PdfExponentialFunction Constructor
Overload List
Overload | Description
PdfExponentialFunction Constructor() | Initilizes a new PdfExponentialFunction object.
PdfExponentialFunction Constructor(Double[],Double[],Int32) | Initializes new PdfExponentialFunction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExponentialFunction Class
PdfExponentialFunction Members


%%PageItemTitle%%

PdfExponentialFunction Constructor()

Xfinium.Pdf.PdfFunctions Namespace > PdfExponentialFunction Class > PdfExponentialFunction Constructor : PdfExponentialFunction Constructor()
Initilizes a new PdfExponentialFunction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfExponentialFunction()
public PdfExponentialFunction()
public:
PdfExponentialFunction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExponentialFunction Class
PdfExponentialFunction Members
Overload List


%%PageItemTitle%%

PdfExponentialFunction Constructor(Double[],Double[],Int32)

Xfinium.Pdf.PdfFunctions Namespace > PdfExponentialFunction Class > PdfExponentialFunction Constructor : PdfExponentialFunction Constructor(Double[],Double[],Int32)
An array of N numbers defining the function result when x = 0.0.
An array of N numbers defining the function result when x = 1.0.
The interpolation exponent. Each input value x will return n values.
Initializes new PdfExponentialFunction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal c0() As Double, _
   ByVal c1() As Double, _
   ByVal exponent As Integer _
)
'Usage

Dim c0() As Double
Dim c1() As Double
Dim exponent As Integer

Dim instance As New PdfExponentialFunction(c0, c1, exponent)
public PdfExponentialFunction(
   double[] c0,
   double[] c1,
   int exponent
)
public:
PdfExponentialFunction(
   array<double>^ c0,
   array<double>^ c1,
   int exponent
)

Parameters

c0
An array of N numbers defining the function result when x = 0.0.
c1
An array of N numbers defining the function result when x = 1.0.
exponent
The interpolation exponent. Each input value x will return n values.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExponentialFunction Class
PdfExponentialFunction Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfExponentialFunction Class Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfExponentialFunction Class

For a list of all members of this type, see PdfExponentialFunction members.

Public Properties
 | Name | Description
Public Property | C0 | Gets or sets the function result when input value is 0.
Public Property | C1 | Gets or sets the function result when input value is 1.
Public Property | Domain | Gets or sets the function domain. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | Exponent | Gets or sets the interpolation exponent.
Public Property | Range | Gets or sets the function range. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Top
See Also

Reference

PdfExponentialFunction Class
Xfinium.Pdf.PdfFunctions Namespace


C0 Property

Xfinium.Pdf.PdfFunctions Namespace > PdfExponentialFunction Class : C0 Property
Gets or sets the function result when input value is 0.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property C0 As Double()
'Usage

Dim instance As PdfExponentialFunction
Dim value() As Double

instance.C0 = value

value = instance.C0
public double[] C0 {get; set;}
public:
property array<double>^ C0 {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A double array specifying the function result when input value is 0.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExponentialFunction Class
PdfExponentialFunction Members


C1 Property

Xfinium.Pdf.PdfFunctions Namespace > PdfExponentialFunction Class : C1 Property
Gets or sets the function result when input value is 1.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property C1 As Double()
'Usage

Dim instance As PdfExponentialFunction
Dim value() As Double

instance.C1 = value

value = instance.C1
public double[] C1 {get; set;}
public:
property array<double>^ C1 {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

A double array specifying the function result when input value is 1.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExponentialFunction Class
PdfExponentialFunction Members


Exponent Property

Xfinium.Pdf.PdfFunctions Namespace > PdfExponentialFunction Class : Exponent Property
Gets or sets the interpolation exponent.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Exponent As Double
'Usage

Dim instance As PdfExponentialFunction
Dim value As Double

instance.Exponent = value

value = instance.Exponent
public double Exponent {get; set;}
public:
property double Exponent {
   double get();
   void set (    double value);
}

Property Value

The interpolation exponent.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExponentialFunction Class
PdfExponentialFunction Members


%%PageItemTitle%%

PdfFunction Class
Members

Xfinium.Pdf.PdfFunctions Namespace : PdfFunction Class
Defines the base class for all PDF functions.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfFunction
'Usage

Dim instance As PdfFunction
public abstract class PdfFunction
public ref class PdfFunction abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfFunctions.PdfFunction
Xfinium.Pdf.PdfFunctions.PdfExponentialFunction
Xfinium.Pdf.PdfFunctions.PdfPostScriptFunction
Xfinium.Pdf.PdfFunctions.PdfSampleFunction
Xfinium.Pdf.PdfFunctions.PdfStitchingFunction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunction Members
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%% $$Members$$

PdfFunction Class Members
Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfFunction Class

The following tables list the members exposed by PdfFunction.

Public Properties
 | Name | Description
Public Property | Domain | Gets or sets the function domain.
Public Property | Range | Gets or sets the function range.
Top
See Also

Reference

PdfFunction Class
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%% $$Properties$$

PdfFunction Class Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfFunction Class

For a list of all members of this type, see PdfFunction members.

Public Properties
 | Name | Description
Public Property | Domain | Gets or sets the function domain.
Public Property | Range | Gets or sets the function range.
Top
See Also

Reference

PdfFunction Class
Xfinium.Pdf.PdfFunctions Namespace


Domain Property (PdfFunction)

Xfinium.Pdf.PdfFunctions Namespace > PdfFunction Class : Domain Property
Gets or sets the function domain.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Domain As Double()
'Usage

Dim instance As PdfFunction
Dim value() As Double

instance.Domain = value

value = instance.Domain
public double[] Domain {get; set;}
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of 2 x m numbers, where m is the number of input values.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunction Class
PdfFunction Members


Range Property (PdfFunction)

Xfinium.Pdf.PdfFunctions Namespace > PdfFunction Class : Range Property
Gets or sets the function range.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Range As Double()
'Usage

Dim instance As PdfFunction
Dim value() As Double

instance.Range = value

value = instance.Range
public double[] Range {get; set;}
public:
property array<double>^ Range {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of 2 x n numbers, where n is the number of output values.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunction Class
PdfFunction Members


%%PageItemTitle%%

PdfFunctionCollection Class
Members

Xfinium.Pdf.PdfFunctions Namespace : PdfFunctionCollection Class
Defines a collection of PDF functions.
Object Model
PdfFunctionCollection ClassPdfFunction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfFunctionCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfFunction)
'Usage

Dim instance As PdfFunctionCollection
public class PdfFunctionCollection : System.Collections.ObjectModel.Collection<PdfFunction>
public ref class PdfFunctionCollection : public System.Collections.ObjectModel.Collection<PdfFunction>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.PdfFunctions.PdfFunctionCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunctionCollection Members
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%% $$Members$$

PdfFunctionCollection Class Members
Properties Methods

Xfinium.Pdf.PdfFunctions Namespace : PdfFunctionCollection Class

The following tables list the members exposed by PdfFunctionCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Top
See Also

Reference

PdfFunctionCollection Class
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%%

PdfPostScriptFunction Class
Members

Xfinium.Pdf.PdfFunctions Namespace : PdfPostScriptFunction Class
Defines a type 4 (PostScript) function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPostScriptFunction
   Inherits PdfFunction
'Usage

Dim instance As PdfPostScriptFunction
public class PdfPostScriptFunction : PdfFunction
public ref class PdfPostScriptFunction : public PdfFunction
Remarks
A type 4 PostScript function, also called a PostScript calculator function, is represented as a stream containing code written in a small subset of the PostScript language.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfFunctions.PdfFunction
Xfinium.Pdf.PdfFunctions.PdfPostScriptFunction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostScriptFunction Members
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%% $$Members$$

PdfPostScriptFunction Class Members
Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfPostScriptFunction Class

The following tables list the members exposed by PdfPostScriptFunction.

Public Constructors
 | Name | Description
Public Constructor | PdfPostScriptFunction Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Domain | Gets or sets the function domain. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | PostScript | Get or sets the PostScript code.
Public Property | Range | Gets or sets the function range. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Top
See Also

Reference

PdfPostScriptFunction Class
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%%

PdfPostScriptFunction Constructor

Xfinium.Pdf.PdfFunctions Namespace > PdfPostScriptFunction Class : PdfPostScriptFunction Constructor
Overload List
Overload | Description
PdfPostScriptFunction Constructor() | Initilizes a new PdfPostScriptFunction object.
PdfPostScriptFunction Constructor(Byte[]) | Initializes new PdfPostScriptFunction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostScriptFunction Class
PdfPostScriptFunction Members


%%PageItemTitle%%

PdfPostScriptFunction Constructor()

Xfinium.Pdf.PdfFunctions Namespace > PdfPostScriptFunction Class > PdfPostScriptFunction Constructor : PdfPostScriptFunction Constructor()
Initilizes a new PdfPostScriptFunction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPostScriptFunction()
public PdfPostScriptFunction()
public:
PdfPostScriptFunction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostScriptFunction Class
PdfPostScriptFunction Members
Overload List


%%PageItemTitle%%

PdfPostScriptFunction Constructor(Byte[])

Xfinium.Pdf.PdfFunctions Namespace > PdfPostScriptFunction Class > PdfPostScriptFunction Constructor : PdfPostScriptFunction Constructor(Byte[])
Postscript source code.
Initializes new PdfPostScriptFunction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal postScript() As Byte _
)
'Usage

Dim postScript() As Byte

Dim instance As New PdfPostScriptFunction(postScript)
public PdfPostScriptFunction(
   byte[] postScript
)
public:
PdfPostScriptFunction(
   array<byte>^ postScript
)

Parameters

postScript
Postscript source code.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostScriptFunction Class
PdfPostScriptFunction Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfPostScriptFunction Class Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfPostScriptFunction Class

For a list of all members of this type, see PdfPostScriptFunction members.

Public Properties
 | Name | Description
Public Property | Domain | Gets or sets the function domain. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | PostScript | Get or sets the PostScript code.
Public Property | Range | Gets or sets the function range. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Top
See Also

Reference

PdfPostScriptFunction Class
Xfinium.Pdf.PdfFunctions Namespace


PostScript Property

Xfinium.Pdf.PdfFunctions Namespace > PdfPostScriptFunction Class : PostScript Property
Get or sets the PostScript code.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PostScript As Byte()
'Usage

Dim instance As PdfPostScriptFunction
Dim value() As Byte

instance.PostScript = value

value = instance.PostScript
public byte[] PostScript {get; set;}
public:
property array<byte>^ PostScript {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The body of the function, written in PostScript language.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPostScriptFunction Class
PdfPostScriptFunction Members


%%PageItemTitle%%

PdfSampleFunction Class
Members

Xfinium.Pdf.PdfFunctions Namespace : PdfSampleFunction Class
Defines a type 0 (Sampled) function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfSampleFunction
   Inherits PdfFunction
'Usage

Dim instance As PdfSampleFunction
public class PdfSampleFunction : PdfFunction
public ref class PdfSampleFunction : public PdfFunction
Remarks
Type 0 Pdf functions use a sequence of sample values (contained in a stream) to provide an approximation for functions whose domains and ranges are bounded. The samples are organized as an m-dimensional table in which each entry has n components.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfFunctions.PdfFunction
Xfinium.Pdf.PdfFunctions.PdfSampleFunction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Members
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%% $$Members$$

PdfSampleFunction Class Members
Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfSampleFunction Class

The following tables list the members exposed by PdfSampleFunction.

Public Constructors
 | Name | Description
Public Constructor | PdfSampleFunction Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BitsPerSample | Gets or sets the bits per sample.
Public Property | Decode | Gets or sets the function's decoding array.
Public Property | Domain | Gets or sets the function domain. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | InterpolationMode | Gets or sets the interpolation mode.
Public Property | Range | Gets or sets the function range. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | Samples | Get or sets the function samples.
Public Property | Size | Gets or sets the number of samples.
Top
See Also

Reference

PdfSampleFunction Class
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%%

PdfSampleFunction Constructor

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class : PdfSampleFunction Constructor
Overload List
Overload | Description
PdfSampleFunction Constructor() | Initilizes a new PdfSampleFunction object.
PdfSampleFunction Constructor(Int32[],Int32,PdfFunctionInterpolationMode,Double[],Double[],Byte[]) | Initializes new PdfSampleFunction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members


%%PageItemTitle%%

PdfSampleFunction Constructor()

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class > PdfSampleFunction Constructor : PdfSampleFunction Constructor()
Initilizes a new PdfSampleFunction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfSampleFunction()
public PdfSampleFunction()
public:
PdfSampleFunction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members
Overload List


%%PageItemTitle%%

PdfSampleFunction Constructor(Int32[],Int32,PdfFunctionInterpolationMode,Double[],Double[],Byte[])

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class > PdfSampleFunction Constructor : PdfSampleFunction Constructor(Int32[],Int32,PdfFunctionInterpolationMode,Double[],Double[],Byte[])
An array of m positive integers specifying the number of samples in each input dimension of the sample table.
The number of bits used to represent each sample.
The interpolation mode between samples.
An array of 2 x m numbers specifying the linear mapping of input values into the domain of the function's sample table.
An array of 2 x n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.
Sample function data.
Initializes new PdfSampleFunction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal size() As Integer, _
   ByVal bitsPerSample As Integer, _
   ByVal interpolationMode As PdfFunctionInterpolationMode, _
   ByVal encode() As Double, _
   ByVal decode() As Double, _
   ByVal samples() As Byte _
)
'Usage

Dim size() As Integer
Dim bitsPerSample As Integer
Dim interpolationMode As PdfFunctionInterpolationMode
Dim encode() As Double
Dim decode() As Double
Dim samples() As Byte

Dim instance As New PdfSampleFunction(size, bitsPerSample, interpolationMode, encode, decode, samples)
public PdfSampleFunction(
   int[] size,
   int bitsPerSample,
   PdfFunctionInterpolationMode interpolationMode,
   double[] encode,
   double[] decode,
   byte[] samples
)
public:
PdfSampleFunction(
   array<int>^ size,
   int bitsPerSample,
   PdfFunctionInterpolationMode interpolationMode,
   array<double>^ encode,
   array<double>^ decode,
   array<byte>^ samples
)

Parameters

size
An array of m positive integers specifying the number of samples in each input dimension of the sample table.
bitsPerSample
The number of bits used to represent each sample.
interpolationMode
The interpolation mode between samples.
encode
An array of 2 x m numbers specifying the linear mapping of input values into the domain of the function's sample table.
decode
An array of 2 x n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.
samples
Sample function data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfSampleFunction Class Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfSampleFunction Class

For a list of all members of this type, see PdfSampleFunction members.

Public Properties
 | Name | Description
Public Property | BitsPerSample | Gets or sets the bits per sample.
Public Property | Decode | Gets or sets the function's decoding array.
Public Property | Domain | Gets or sets the function domain. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | InterpolationMode | Gets or sets the interpolation mode.
Public Property | Range | Gets or sets the function range. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | Samples | Get or sets the function samples.
Public Property | Size | Gets or sets the number of samples.
Top
See Also

Reference

PdfSampleFunction Class
Xfinium.Pdf.PdfFunctions Namespace


BitsPerSample Property (PdfSampleFunction)

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class : BitsPerSample Property
Gets or sets the bits per sample.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BitsPerSample As Integer
'Usage

Dim instance As PdfSampleFunction
Dim value As Integer

instance.BitsPerSample = value

value = instance.BitsPerSample
public int BitsPerSample {get; set;}
public:
property int BitsPerSample {
   int get();
   void set (    int value);
}

Property Value

The number of bits used to represent each sample.
Remarks
If the function has multiple output values, each one occupies BitsPerSample bits. Valid values are 1, 2, 4, 8, 12, 16, 24, and 32.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members


Decode Property

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class : Decode Property
Gets or sets the function's decoding array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Decode As Double()
'Usage

Dim instance As PdfSampleFunction
Dim value() As Double

instance.Decode = value

value = instance.Decode
public double[] Decode {get; set;}
public:
property array<double>^ Decode {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of 2 x n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members


Encode Property (PdfSampleFunction)

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class : Encode Property
Gets or sets the function's encoding array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Encode As Double()
'Usage

Dim instance As PdfSampleFunction
Dim value() As Double

instance.Encode = value

value = instance.Encode
public double[] Encode {get; set;}
public:
property array<double>^ Encode {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of 2 x m numbers specifying the linear mapping of input values into the domain of the function's sample table.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members


InterpolationMode Property

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class : InterpolationMode Property
Gets or sets the interpolation mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property InterpolationMode As PdfFunctionInterpolationMode
'Usage

Dim instance As PdfSampleFunction
Dim value As PdfFunctionInterpolationMode

instance.InterpolationMode = value

value = instance.InterpolationMode
public PdfFunctionInterpolationMode InterpolationMode {get; set;}
public:
property PdfFunctionInterpolationMode InterpolationMode {
   PdfFunctionInterpolationMode get();
   void set (    PdfFunctionInterpolationMode value);
}

Property Value

A PdfFunctionInterpolationMode that represents the order of interpolation between samples.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members


Samples Property

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class : Samples Property
Get or sets the function samples.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Samples As Byte()
'Usage

Dim instance As PdfSampleFunction
Dim value() As Byte

instance.Samples = value

value = instance.Samples
public byte[] Samples {get; set;}
public:
property array<byte>^ Samples {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

An array of sample values used for interpolation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members


Size Property (PdfSampleFunction)

Xfinium.Pdf.PdfFunctions Namespace > PdfSampleFunction Class : Size Property
Gets or sets the number of samples.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Size As Integer()
'Usage

Dim instance As PdfSampleFunction
Dim value() As Integer

instance.Size = value

value = instance.Size
public int[] Size {get; set;}
public:
property array<int>^ Size {
   array<int>^ get();
   void set (    array<int>^ value);
}

Property Value

An array of m positive integers specifying the number of samples in each input dimension of the sample table.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSampleFunction Class
PdfSampleFunction Members


%%PageItemTitle%%

PdfStitchingFunction Class
Members

Xfinium.Pdf.PdfFunctions Namespace : PdfStitchingFunction Class
Defines a type 3 (Stitching) function.
Object Model
PdfStitchingFunction ClassPdfFunctionCollection ClassPdfFunction Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfStitchingFunction
   Inherits PdfFunction
'Usage

Dim instance As PdfStitchingFunction
public class PdfStitchingFunction : PdfFunction
public ref class PdfStitchingFunction : public PdfFunction
Remarks
Type 3 Pdf functions define a stitching of the subdomains of several 1-input functions to produce a single new 1-input function.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfFunctions.PdfFunction
Xfinium.Pdf.PdfFunctions.PdfStitchingFunction

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStitchingFunction Members
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%% $$Members$$

PdfStitchingFunction Class Members
Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfStitchingFunction Class

The following tables list the members exposed by PdfStitchingFunction.

Public Constructors
 | Name | Description
Public Constructor | PdfStitchingFunction Constructor | Initilizes a new PdfStitchingFunction object.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the function bounds.
Public Property | Domain | Gets or sets the function domain. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | Encode | Gets or sets the function encode array.
Public Property | Functions | Gets the sub-functions that make up this function.
Public Property | Range | Gets or sets the function range. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Top
See Also

Reference

PdfStitchingFunction Class
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%%

PdfStitchingFunction Constructor

Xfinium.Pdf.PdfFunctions Namespace > PdfStitchingFunction Class : PdfStitchingFunction Constructor
Initilizes a new PdfStitchingFunction object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfStitchingFunction()
public PdfStitchingFunction()
public:
PdfStitchingFunction();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStitchingFunction Class
PdfStitchingFunction Members


%%PageItemTitle%% $$Properties$$

PdfStitchingFunction Class Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfStitchingFunction Class

For a list of all members of this type, see PdfStitchingFunction members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the function bounds.
Public Property | Domain | Gets or sets the function domain. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Public Property | Encode | Gets or sets the function encode array.
Public Property | Functions | Gets the sub-functions that make up this function.
Public Property | Range | Gets or sets the function range. (Inherited from Xfinium.Pdf.PdfFunctions.PdfFunction)
Top
See Also

Reference

PdfStitchingFunction Class
Xfinium.Pdf.PdfFunctions Namespace


Bounds Property (PdfStitchingFunction)

Xfinium.Pdf.PdfFunctions Namespace > PdfStitchingFunction Class : Bounds Property
Gets or sets the function bounds.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Bounds As Double()
'Usage

Dim instance As PdfStitchingFunction
Dim value() As Double

instance.Bounds = value

value = instance.Bounds
public double[] Bounds {get; set;}
public:
property array<double>^ Bounds {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of k - 1 numbers that, in combination with PdfFunction.Domain, define the intervals to which each function from the Functions array applies.
Remarks
Bounds elements must be in order of increasing value, and each value must be within the domain defined by PdfFunction.Domain.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStitchingFunction Class
PdfStitchingFunction Members


Encode Property (PdfStitchingFunction)

Xfinium.Pdf.PdfFunctions Namespace > PdfStitchingFunction Class : Encode Property
Gets or sets the function encode array.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Encode As Double()
'Usage

Dim instance As PdfStitchingFunction
Dim value() As Double

instance.Encode = value

value = instance.Encode
public double[] Encode {get; set;}
public:
property array<double>^ Encode {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of 2 x k numbers that, taken in pairs, map each subset of the domain defined by PdfFunction.Domain and the Bounds array to the domain of the corresponding function.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStitchingFunction Class
PdfStitchingFunction Members


Functions Property

Xfinium.Pdf.PdfFunctions Namespace > PdfStitchingFunction Class : Functions Property
Gets the sub-functions that make up this function.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Functions As PdfFunctionCollection
'Usage

Dim instance As PdfStitchingFunction
Dim value As PdfFunctionCollection

value = instance.Functions
public PdfFunctionCollection Functions {get;}
public:
property PdfFunctionCollection^ Functions {
   PdfFunctionCollection^ get();
}

Property Value

An array of k 1-input functions making up the stitching function.
Remarks
The output dimensionality of all functions must be the same, and compatible with the value of PdfFunction.Range if PdfFunction.Range is present.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStitchingFunction Class
PdfStitchingFunction Members


%%PageItemTitle%%

PdfFunctionInterpolationMode Enumeration

Xfinium.Pdf.PdfFunctions Namespace : PdfFunctionInterpolationMode Enumeration
Supported interpolation modes for a type 0 function values.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFunctionInterpolationMode
   Inherits System.Enum
'Usage

Dim instance As PdfFunctionInterpolationMode
public enum PdfFunctionInterpolationMode : System.Enum
public enum class PdfFunctionInterpolationMode : public System.Enum
Members
Member | Description
CubicSpline | Cubic spline interpolation.
Linear | Linear intepolation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.PdfFunctions.PdfFunctionInterpolationMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.PdfFunctions Namespace


Xfinium.Pdf.Portfolios Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfPortfolio | Defines a Pdf porfolio.
Class | PdfPortfolioAttributeDefinition | Represents the definition of a portfolio attribute.
Class | PdfPortfolioAttributeDefinitions | Represents the definitions of attributes available in this portfolio.
Class | PdfPortfolioFolder | Defines a PDF portfolio folder.
Class | PdfPortfolioFolderCollection | Defines a collection of portfolio folders.
Class | PdfPortfolioItem | Defines an item included in a Pdf portfolio.
Class | PdfPortfolioItemAttributes | Defines the attributes for a portfolio item.
Class | PdfPortfolioItemCollection | Defines a collection of portfolio items.
Class | PdfPortfolioSortInformation | Defines the sort order of the portfolio items.
Enumerations
 | Enumeration | Description
Enumeration | PdfPortfolioAttributeDefinitionType | Supported data types for portfolio attributes.
Enumeration | PdfPortfolioDisplayMode | Supported display modes for PDF portfolios.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Portfolios Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Portfolios.PdfPortfolioFolderCollection
Xfinium.Pdf.Portfolios.PdfPortfolioItemCollection
Xfinium.Pdf.PdfDocument
Xfinium.Pdf.Portfolios.PdfPortfolio
Xfinium.Pdf.Portfolios.PdfPortfolioAttributeDefinition
Xfinium.Pdf.Portfolios.PdfPortfolioAttributeDefinitions
Xfinium.Pdf.Portfolios.PdfPortfolioFolder
Xfinium.Pdf.Portfolios.PdfPortfolioItem
Xfinium.Pdf.Portfolios.PdfPortfolioItemAttributes
Xfinium.Pdf.Portfolios.PdfPortfolioSortInformation
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfPortfolio Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolio Class
Defines a Pdf porfolio.
Object Model
PdfPortfolio ClassPdfPortfolioAttributeDefinitions ClassPdfCosDictionary ClassPdfPortfolioFolderCollection ClassPdfPortfolioFolder ClassPdfPortfolioItemCollection ClassPdfPortfolioItem ClassPdfSecurityHandler ClassPdfPortfolioSortInformation ClassPdfPortfolioItem ClassPdfVersionExtension Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPortfolio
   Inherits Xfinium.Pdf.PdfDocument
'Usage

Dim instance As PdfPortfolio
public class PdfPortfolio : Xfinium.Pdf.PdfDocument
public ref class PdfPortfolio : public Xfinium.Pdf.PdfDocument
Inheritance Hierarchy

System.Object
Xfinium.Pdf.PdfDocument
Xfinium.Pdf.Portfolios.PdfPortfolio

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolio Class Members
Properties Methods

Xfinium.Pdf.Portfolios Namespace : PdfPortfolio Class

The following tables list the members exposed by PdfPortfolio.

Public Constructors
 | Name | Description
Public Constructor | PdfPortfolio Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AttributeDefinitions | Gets or sets the attribute definitions for this portfolio.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | DisplayMode | Gets or sets the portfolio display mode.
Public Property | Folders | Gets the root folders.
Public Property | ID | Gets the document ID. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | Items | Gets the portfolio items.
Public Property | PdfVersion | Gets or sets the PDF version of this PdfPortfolio object.
Public Property | SecurityHandler | Gets the document security handler. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | SortInformation | Gets or sets the sort information.
Public Property | StartupDocument | Gets or sets the startup document.
Public Property | VersionExtension | Gets or sets the PDF version extension.
Top
Public Methods
 | Name | Description
Public Method | Save | Overloaded. Overridden. Saves the Pdf document to the specified stream.
Top
See Also

Reference

PdfPortfolio Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolio Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : PdfPortfolio Constructor
Overload List
Overload | Description
PdfPortfolio Constructor() | Initializes a new PdfPortfolio object.
PdfPortfolio Constructor(Stream) | Initializes a new PdfPortfolio object.
PdfPortfolio Constructor(Stream,String) | Initializes a new PdfPortfolio object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


%%PageItemTitle%%

PdfPortfolio Constructor()

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class > PdfPortfolio Constructor : PdfPortfolio Constructor()
Initializes a new PdfPortfolio object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPortfolio()
public PdfPortfolio()
public:
PdfPortfolio();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members
Overload List


%%PageItemTitle%%

PdfPortfolio Constructor(Stream)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class > PdfPortfolio Constructor : PdfPortfolio Constructor(Stream)
The PDF stream.
Initializes a new PdfPortfolio object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream _
)
'Usage

Dim stream As Stream

Dim instance As New PdfPortfolio(stream)
public PdfPortfolio(
   Stream stream
)
public:
PdfPortfolio(
   Stream^ stream
)

Parameters

stream
The PDF stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members
Overload List


%%PageItemTitle%%

PdfPortfolio Constructor(Stream,String)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class > PdfPortfolio Constructor : PdfPortfolio Constructor(Stream,String)
The PDF stream.
Password for opening the PDF portfolio.
Initializes a new PdfPortfolio object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As Stream, _
   ByVal password As String _
)
'Usage

Dim stream As Stream
Dim password As String

Dim instance As New PdfPortfolio(stream, password)
public PdfPortfolio(
   Stream stream,
   string password
)
public:
PdfPortfolio(
   Stream^ stream,
   String^ password
)

Parameters

stream
The PDF stream.
password
Password for opening the PDF portfolio.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members
Overload List


%%PageItemTitle%% $$Methods$$

PdfPortfolio Class Methods

Xfinium.Pdf.Portfolios Namespace : PdfPortfolio Class

For a list of all members of this type, see PdfPortfolio members.

Public Methods
 | Name | Description
Public Method | Save | Overloaded. Overridden. Saves the Pdf document to the specified stream.
Top
See Also

Reference

PdfPortfolio Class
Xfinium.Pdf.Portfolios Namespace


Save Method (PdfPortfolio)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : Save Method
Saves the Pdf document to the specified stream.
Overload List
Overload | Description
Save(Stream,PdfSecurityHandler) | Saves the Pdf document to the specified stream.
Save(Stream) | Saves the Pdf document to the specified stream. (Inherited from Xfinium.Pdf.PdfDocument)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


Save(Stream,PdfSecurityHandler) Method

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class > Save Method : Save(Stream,PdfSecurityHandler) Method
Destination stream.
Security handler for encrypting the saved file.
Saves the Pdf document to the specified stream.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Save( _
   ByVal stream As Stream, _
   ByVal securityHandler As PdfSecurityHandler _
)
'Usage

Dim instance As PdfPortfolio
Dim stream As Stream
Dim securityHandler As PdfSecurityHandler

instance.Save(stream, securityHandler)
public override void Save(
   Stream stream,
   PdfSecurityHandler securityHandler
)
public:
void Save(
   Stream^ stream,
   PdfSecurityHandler^ securityHandler
) override

Parameters

stream
Destination stream.
securityHandler
Security handler for encrypting the saved file.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfPortfolio Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolio Class

For a list of all members of this type, see PdfPortfolio members.

Public Properties
 | Name | Description
Public Property | AttributeDefinitions | Gets or sets the attribute definitions for this portfolio.
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | DisplayMode | Gets or sets the portfolio display mode.
Public Property | Folders | Gets the root folders.
Public Property | ID | Gets the document ID. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | Items | Gets the portfolio items.
Public Property | PdfVersion | Gets or sets the PDF version of this PdfPortfolio object.
Public Property | SecurityHandler | Gets the document security handler. (Inherited from Xfinium.Pdf.PdfDocument)
Public Property | SortInformation | Gets or sets the sort information.
Public Property | StartupDocument | Gets or sets the startup document.
Public Property | VersionExtension | Gets or sets the PDF version extension.
Top
See Also

Reference

PdfPortfolio Class
Xfinium.Pdf.Portfolios Namespace


AttributeDefinitions Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : AttributeDefinitions Property
Gets or sets the attribute definitions for this portfolio.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AttributeDefinitions As PdfPortfolioAttributeDefinitions
'Usage

Dim instance As PdfPortfolio
Dim value As PdfPortfolioAttributeDefinitions

instance.AttributeDefinitions = value

value = instance.AttributeDefinitions
public PdfPortfolioAttributeDefinitions AttributeDefinitions {get; set;}
public:
property PdfPortfolioAttributeDefinitions^ AttributeDefinitions {
   PdfPortfolioAttributeDefinitions^ get();
   void set (    PdfPortfolioAttributeDefinitions^ value);
}

Property Value

Attribute definitions for this portfolio, used to define metadata information for items in the portfolio.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


DisplayMode Property (PdfPortfolio)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : DisplayMode Property
Gets or sets the portfolio display mode.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisplayMode As PdfPortfolioDisplayMode
'Usage

Dim instance As PdfPortfolio
Dim value As PdfPortfolioDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
public PdfPortfolioDisplayMode DisplayMode {get; set;}
public:
property PdfPortfolioDisplayMode DisplayMode {
   PdfPortfolioDisplayMode get();
   void set (    PdfPortfolioDisplayMode value);
}

Property Value

The display mode of this portfolio.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


Folders Property (PdfPortfolio)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : Folders Property
Gets the root folders.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Folders As PdfPortfolioFolderCollection
'Usage

Dim instance As PdfPortfolio
Dim value As PdfPortfolioFolderCollection

value = instance.Folders
public PdfPortfolioFolderCollection Folders {get;}
public:
property PdfPortfolioFolderCollection^ Folders {
   PdfPortfolioFolderCollection^ get();
}

Property Value

The list of root folders.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


Items Property (PdfPortfolio)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : Items Property
Gets the portfolio items.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Items As PdfPortfolioItemCollection
'Usage

Dim instance As PdfPortfolio
Dim value As PdfPortfolioItemCollection

value = instance.Items
public PdfPortfolioItemCollection Items {get;}
public:
property PdfPortfolioItemCollection^ Items {
   PdfPortfolioItemCollection^ get();
}

Property Value

The list of portfolio items.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


PdfVersion Property (PdfPortfolio)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : PdfVersion Property
Gets or sets the PDF version of this PdfPortfolio object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PdfVersion As PdfVersion
'Usage

Dim instance As PdfPortfolio
Dim value As PdfVersion

instance.PdfVersion = value

value = instance.PdfVersion
public PdfVersion PdfVersion {get; set;}
public:
property PdfVersion PdfVersion {
   PdfVersion get();
   void set (    PdfVersion value);
}

Property Value

The PDF version of this PdfPortfolio object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


SortInformation Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : SortInformation Property
Gets or sets the sort information.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SortInformation As PdfPortfolioSortInformation
'Usage

Dim instance As PdfPortfolio
Dim value As PdfPortfolioSortInformation

instance.SortInformation = value

value = instance.SortInformation
public PdfPortfolioSortInformation SortInformation {get; set;}
public:
property PdfPortfolioSortInformation^ SortInformation {
   PdfPortfolioSortInformation^ get();
   void set (    PdfPortfolioSortInformation^ value);
}

Property Value

The information for sorting the portfolio items in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


StartupDocument Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : StartupDocument Property
Gets or sets the startup document.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property StartupDocument As PdfPortfolioItem
'Usage

Dim instance As PdfPortfolio
Dim value As PdfPortfolioItem

instance.StartupDocument = value

value = instance.StartupDocument
public PdfPortfolioItem StartupDocument {get; set;}
public:
property PdfPortfolioItem^ StartupDocument {
   PdfPortfolioItem^ get();
   void set (    PdfPortfolioItem^ value);
}

Property Value

The document that is displayed when the portfolio is opened.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


VersionExtension Property (PdfPortfolio)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolio Class : VersionExtension Property
Gets or sets the PDF version extension.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property VersionExtension As PdfVersionExtension
'Usage

Dim instance As PdfPortfolio
Dim value As PdfVersionExtension

instance.VersionExtension = value

value = instance.VersionExtension
public PdfVersionExtension VersionExtension {get; set;}
public:
property PdfVersionExtension^ VersionExtension {
   PdfVersionExtension^ get();
   void set (    PdfVersionExtension^ value);
}

Property Value

The extended PDF version this portfolio implements.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolio Class
PdfPortfolio Members


%%PageItemTitle%%

PdfPortfolioAttributeDefinition Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioAttributeDefinition Class
Represents the definition of a portfolio attribute.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPortfolioAttributeDefinition
'Usage

Dim instance As PdfPortfolioAttributeDefinition
public class PdfPortfolioAttributeDefinition
public ref class PdfPortfolioAttributeDefinition
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Portfolios.PdfPortfolioAttributeDefinition

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinition Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolioAttributeDefinition Class Members
Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioAttributeDefinition Class

The following tables list the members exposed by PdfPortfolioAttributeDefinition.

Public Constructors
 | Name | Description
Public Constructor | PdfPortfolioAttributeDefinition Constructor | Initializes a new PdfPortfolioAttributeDefinition object.
Top
Public Properties
 | Name | Description
Public Property | Editable | Gets or sets a value indicating whether the attribute value can be edited.
Public Property | Name | Gets or sets the attribute definition name.
Public Property | Order | Gets or sets the attribute definition order.
Public Property | Type | Gets or sets the attribute definition type.
Public Property | Visible | Gets or sets the attribute definition visibility.
Top
See Also

Reference

PdfPortfolioAttributeDefinition Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioAttributeDefinition Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinition Class : PdfPortfolioAttributeDefinition Constructor
Initializes a new PdfPortfolioAttributeDefinition object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPortfolioAttributeDefinition()
public PdfPortfolioAttributeDefinition()
public:
PdfPortfolioAttributeDefinition();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinition Class
PdfPortfolioAttributeDefinition Members


%%PageItemTitle%% $$Properties$$

PdfPortfolioAttributeDefinition Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioAttributeDefinition Class

For a list of all members of this type, see PdfPortfolioAttributeDefinition members.

Public Properties
 | Name | Description
Public Property | Editable | Gets or sets a value indicating whether the attribute value can be edited.
Public Property | Name | Gets or sets the attribute definition name.
Public Property | Order | Gets or sets the attribute definition order.
Public Property | Type | Gets or sets the attribute definition type.
Public Property | Visible | Gets or sets the attribute definition visibility.
Top
See Also

Reference

PdfPortfolioAttributeDefinition Class
Xfinium.Pdf.Portfolios Namespace


Editable Property (PdfPortfolioAttributeDefinition)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinition Class : Editable Property
Gets or sets a value indicating whether the attribute value can be edited.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Editable As Boolean
'Usage

Dim instance As PdfPortfolioAttributeDefinition
Dim value As Boolean

instance.Editable = value

value = instance.Editable
public bool Editable {get; set;}
public:
property bool Editable {
   bool get();
   void set (    bool value);
}

Property Value

If true, the attribute value should be editable in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinition Class
PdfPortfolioAttributeDefinition Members


Name Property (PdfPortfolioAttributeDefinition)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinition Class : Name Property
Gets or sets the attribute definition name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfPortfolioAttributeDefinition
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The display name of the attribute definition
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when the property is set to null or an empty string.
Remarks
The attribute is displayed under this name in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinition Class
PdfPortfolioAttributeDefinition Members


Order Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinition Class : Order Property
Gets or sets the attribute definition order.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Order As Integer
'Usage

Dim instance As PdfPortfolioAttributeDefinition
Dim value As Integer

instance.Order = value

value = instance.Order
public int Order {get; set;}
public:
property int Order {
   int get();
   void set (    int value);
}

Property Value

The relative order of the attribute definition name in the user interface.
Remarks
Attributes are sorted in ascending order in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinition Class
PdfPortfolioAttributeDefinition Members


Type Property (PdfPortfolioAttributeDefinition)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinition Class : Type Property
Gets or sets the attribute definition type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Type As PdfPortfolioAttributeDefinitionType
'Usage

Dim instance As PdfPortfolioAttributeDefinition
Dim value As PdfPortfolioAttributeDefinitionType

instance.Type = value

value = instance.Type
public PdfPortfolioAttributeDefinitionType Type {get; set;}
public:
property PdfPortfolioAttributeDefinitionType Type {
   PdfPortfolioAttributeDefinitionType get();
   void set (    PdfPortfolioAttributeDefinitionType value);
}

Property Value

The type of this attribute definition.
Remarks
The value cannot be set to PdfPortfolioAttributeDefinitionType.NoType or PdfPortfolioAttributeDefinitionType.Unknown.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinition Class
PdfPortfolioAttributeDefinition Members


Visible Property (PdfPortfolioAttributeDefinition)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinition Class : Visible Property
Gets or sets the attribute definition visibility.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As PdfPortfolioAttributeDefinition
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

The initial visibility of the attribute definition in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinition Class
PdfPortfolioAttributeDefinition Members


%%PageItemTitle%%

PdfPortfolioAttributeDefinitions Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioAttributeDefinitions Class
Represents the definitions of attributes available in this portfolio.
Object Model
PdfPortfolioAttributeDefinitions ClassPdfPortfolioAttributeDefinition Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfPortfolioAttributeDefinitions
'Usage

Dim instance As PdfPortfolioAttributeDefinitions
[DefaultMember("Item")]
public class PdfPortfolioAttributeDefinitions
[DefaultMember("Item")]
public ref class PdfPortfolioAttributeDefinitions
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Portfolios.PdfPortfolioAttributeDefinitions

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinitions Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolioAttributeDefinitions Class Members
Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioAttributeDefinitions Class

The following tables list the members exposed by PdfPortfolioAttributeDefinitions.

Public Constructors
 | Name | Description
Public Constructor | PdfPortfolioAttributeDefinitions Constructor | Initializes a new PdfPortfolioAttributeDefinitions object.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets or sets an attribute definition.
Public Property | Keys | Gets the list of keys.
Top
See Also

Reference

PdfPortfolioAttributeDefinitions Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioAttributeDefinitions Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinitions Class : PdfPortfolioAttributeDefinitions Constructor
Initializes a new PdfPortfolioAttributeDefinitions object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPortfolioAttributeDefinitions()
public PdfPortfolioAttributeDefinitions()
public:
PdfPortfolioAttributeDefinitions();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinitions Class
PdfPortfolioAttributeDefinitions Members


%%PageItemTitle%% $$Properties$$

PdfPortfolioAttributeDefinitions Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioAttributeDefinitions Class

For a list of all members of this type, see PdfPortfolioAttributeDefinitions members.

Public Properties
 | Name | Description
Public Property | Item | Gets or sets an attribute definition.
Public Property | Keys | Gets the list of keys.
Top
See Also

Reference

PdfPortfolioAttributeDefinitions Class
Xfinium.Pdf.Portfolios Namespace


Item Property (PdfPortfolioAttributeDefinitions)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinitions Class : Item Property
The key used to identify the attribute.
Gets or sets an attribute definition.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal key As String _
) As PdfPortfolioAttributeDefinition
'Usage

Dim instance As PdfPortfolioAttributeDefinitions
Dim key As String
Dim value As PdfPortfolioAttributeDefinition

instance.Item(key) = value

value = instance.Item(key)
public PdfPortfolioAttributeDefinition this[
   string key
]; {get; set;}
public:
property PdfPortfolioAttributeDefinition^ default [String^] {
   PdfPortfolioAttributeDefinition^ get(String^ key);
   void set (String^ key, PdfPortfolioAttributeDefinition^ value);
}

Parameters

key
The key used to identify the attribute.

Property Value

The attribute if it exists, null otherwise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinitions Class
PdfPortfolioAttributeDefinitions Members


Keys Property (PdfPortfolioAttributeDefinitions)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinitions Class : Keys Property
Gets the list of keys.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Keys As String()
'Usage

Dim instance As PdfPortfolioAttributeDefinitions
Dim value() As String

value = instance.Keys
public string[] Keys {get;}
public:
property array<String^>^ Keys {
   array<String^>^ get();
}

Property Value

An array of strings representing the attribute definition keys.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinitions Class
PdfPortfolioAttributeDefinitions Members


%%PageItemTitle%%

PdfPortfolioFolder Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioFolder Class
Defines a PDF portfolio folder.
Object Model
PdfPortfolioFolder ClassPdfPortfolioFolderCollection ClassPdfPortfolioFolder ClassPdfPortfolioFolder ClassPdfPortfolioItemAttributes ClassPdfImage Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPortfolioFolder
'Usage

Dim instance As PdfPortfolioFolder
public class PdfPortfolioFolder
public ref class PdfPortfolioFolder
Remarks
Folders are used to group portfolio items for easier navigation.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Portfolios.PdfPortfolioFolder

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolioFolder Class Members
Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioFolder Class

The following tables list the members exposed by PdfPortfolioFolder.

Public Constructors
 | Name | Description
Public Constructor | PdfPortfolioFolder Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CreationDate | Gets or sets the folder creation date and time.
Public Property | Description | Gets or sets the folder description.
Public Property | Folders | Gets the sub-folders.
Public Property | ModifyDate | Gets or sets the folder modify date and time.
Public Property | Name | Gets or sets the folder name.
Public Property | Parent | Gets the parent folder.
Public Property | PortfolioAttributes | Gets or sets the folder attributes.
Public Property | Thumbnail | Gets or sets the folder thumbnail.
Top
See Also

Reference

PdfPortfolioFolder Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioFolder Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : PdfPortfolioFolder Constructor
Overload List
Overload | Description
PdfPortfolioFolder Constructor() | Initializes a new PdfPortfolioFolder object.
PdfPortfolioFolder Constructor(String) | Initializes a new PdfPortfolioFolder object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


%%PageItemTitle%%

PdfPortfolioFolder Constructor()

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class > PdfPortfolioFolder Constructor : PdfPortfolioFolder Constructor()
Initializes a new PdfPortfolioFolder object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPortfolioFolder()
public PdfPortfolioFolder()
public:
PdfPortfolioFolder();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members
Overload List


%%PageItemTitle%%

PdfPortfolioFolder Constructor(String)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class > PdfPortfolioFolder Constructor : PdfPortfolioFolder Constructor(String)
The folder name.
Initializes a new PdfPortfolioFolder object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New PdfPortfolioFolder(name)
public PdfPortfolioFolder(
   string name
)
public:
PdfPortfolioFolder(
   String^ name
)

Parameters

name
The folder name.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members
Overload List


%%PageItemTitle%% $$Properties$$

PdfPortfolioFolder Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioFolder Class

For a list of all members of this type, see PdfPortfolioFolder members.

Public Properties
 | Name | Description
Public Property | CreationDate | Gets or sets the folder creation date and time.
Public Property | Description | Gets or sets the folder description.
Public Property | Folders | Gets the sub-folders.
Public Property | ModifyDate | Gets or sets the folder modify date and time.
Public Property | Name | Gets or sets the folder name.
Public Property | Parent | Gets the parent folder.
Public Property | PortfolioAttributes | Gets or sets the folder attributes.
Public Property | Thumbnail | Gets or sets the folder thumbnail.
Top
See Also

Reference

PdfPortfolioFolder Class
Xfinium.Pdf.Portfolios Namespace


CreationDate Property (PdfPortfolioFolder)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : CreationDate Property
Gets or sets the folder creation date and time.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PdfPortfolioFolder
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time when the folder was created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


Description Property (PdfPortfolioFolder)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : Description Property
Gets or sets the folder description.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PdfPortfolioFolder
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

A description for with this PdfPortfolioFolder.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


Folders Property (PdfPortfolioFolder)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : Folders Property
Gets the sub-folders.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Folders As PdfPortfolioFolderCollection
'Usage

Dim instance As PdfPortfolioFolder
Dim value As PdfPortfolioFolderCollection

value = instance.Folders
public PdfPortfolioFolderCollection Folders {get;}
public:
property PdfPortfolioFolderCollection^ Folders {
   PdfPortfolioFolderCollection^ get();
}

Property Value

The list of sub-folders.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


ModifyDate Property (PdfPortfolioFolder)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : ModifyDate Property
Gets or sets the folder modify date and time.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ModifyDate As Date
'Usage

Dim instance As PdfPortfolioFolder
Dim value As Date

instance.ModifyDate = value

value = instance.ModifyDate
public DateTime ModifyDate {get; set;}
public:
property DateTime ModifyDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time when the folder was last modified.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


Name Property (PdfPortfolioFolder)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : Name Property
Gets or sets the folder name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfPortfolioFolder
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The folder name.
Remarks
Two sibling folders shall not share the same name following case normalization.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


Parent Property (PdfPortfolioFolder)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : Parent Property
Gets the parent folder.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As PdfPortfolioFolder
'Usage

Dim instance As PdfPortfolioFolder
Dim value As PdfPortfolioFolder

value = instance.Parent
public PdfPortfolioFolder Parent {get;}
public:
property PdfPortfolioFolder^ Parent {
   PdfPortfolioFolder^ get();
}

Property Value

The parent folder of this PdfPortfolioFolder.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


PortfolioAttributes Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : PortfolioAttributes Property
Gets or sets the folder attributes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PortfolioAttributes As PdfPortfolioItemAttributes
'Usage

Dim instance As PdfPortfolioFolder
Dim value As PdfPortfolioItemAttributes

instance.PortfolioAttributes = value

value = instance.PortfolioAttributes
public PdfPortfolioItemAttributes PortfolioAttributes {get; set;}
public:
property PdfPortfolioItemAttributes^ PortfolioAttributes {
   PdfPortfolioItemAttributes^ get();
   void set (    PdfPortfolioItemAttributes^ value);
}

Property Value

A dictionary of attributes for the folder.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


Thumbnail Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolder Class : Thumbnail Property
Gets or sets the folder thumbnail.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Thumbnail As PdfImage
'Usage

Dim instance As PdfPortfolioFolder
Dim value As PdfImage

instance.Thumbnail = value

value = instance.Thumbnail
public PdfImage Thumbnail {get; set;}
public:
property PdfImage^ Thumbnail {
   PdfImage^ get();
   void set (    PdfImage^ value);
}

Property Value

A thumbnail image for the folder.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolder Class
PdfPortfolioFolder Members


%%PageItemTitle%%

PdfPortfolioFolderCollection Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioFolderCollection Class
Defines a collection of portfolio folders.
Object Model
PdfPortfolioFolderCollection ClassPdfPortfolioFolder Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPortfolioFolderCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfPortfolioFolder)
'Usage

Dim instance As PdfPortfolioFolderCollection
public class PdfPortfolioFolderCollection : System.Collections.ObjectModel.Collection<PdfPortfolioFolder>
public ref class PdfPortfolioFolderCollection : public System.Collections.ObjectModel.Collection<PdfPortfolioFolder>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Portfolios.PdfPortfolioFolderCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolderCollection Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolioFolderCollection Class Members
Properties Methods

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioFolderCollection Class

The following tables list the members exposed by PdfPortfolioFolderCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Property | Parent | Gets the parent portfolio folder.
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Top
See Also

Reference

PdfPortfolioFolderCollection Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Properties$$

PdfPortfolioFolderCollection Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioFolderCollection Class

For a list of all members of this type, see PdfPortfolioFolderCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Property | Parent | Gets the parent portfolio folder.
Top
See Also

Reference

PdfPortfolioFolderCollection Class
Xfinium.Pdf.Portfolios Namespace


Parent Property (PdfPortfolioFolderCollection)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioFolderCollection Class : Parent Property
Gets the parent portfolio folder.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As PdfPortfolioFolder
'Usage

Dim instance As PdfPortfolioFolderCollection
Dim value As PdfPortfolioFolder

value = instance.Parent
public PdfPortfolioFolder Parent {get;}
public:
property PdfPortfolioFolder^ Parent {
   PdfPortfolioFolder^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioFolderCollection Class
PdfPortfolioFolderCollection Members


%%PageItemTitle%%

PdfPortfolioItem Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItem Class
Defines an item included in a Pdf portfolio.
Object Model
PdfPortfolioItem ClassPdfPortfolioItemAttributes ClassPdfPortfolioFolder Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPortfolioItem
'Usage

Dim instance As PdfPortfolioItem
public class PdfPortfolioItem
public ref class PdfPortfolioItem
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Portfolios.PdfPortfolioItem

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolioItem Class Members
Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItem Class

The following tables list the members exposed by PdfPortfolioItem.

Public Constructors
 | Name | Description
Public Constructor | PdfPortfolioItem Constructor | Initializes a new PdfPortfolioItem object.
Top
Public Properties
 | Name | Description
Public Property | Attributes | Gets or sets the attributes.
Public Property | CreationDate | Gets or sets the creation date and time.
Public Property | Description | Gets or sets the description.
Public Property | FileName | Gets or sets the file name.
Public Property | Folder | Gets or sets the folder.
Public Property | MimeType | Gets or sets the MIME type.
Public Property | ModifyDate | Gets or sets the modify date and time.
Public Property | Payload | Gets or sets the item payload.
Top
See Also

Reference

PdfPortfolioItem Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioItem Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : PdfPortfolioItem Constructor
Initializes a new PdfPortfolioItem object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPortfolioItem()
public PdfPortfolioItem()
public:
PdfPortfolioItem();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


%%PageItemTitle%% $$Properties$$

PdfPortfolioItem Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItem Class

For a list of all members of this type, see PdfPortfolioItem members.

Public Properties
 | Name | Description
Public Property | Attributes | Gets or sets the attributes.
Public Property | CreationDate | Gets or sets the creation date and time.
Public Property | Description | Gets or sets the description.
Public Property | FileName | Gets or sets the file name.
Public Property | Folder | Gets or sets the folder.
Public Property | MimeType | Gets or sets the MIME type.
Public Property | ModifyDate | Gets or sets the modify date and time.
Public Property | Payload | Gets or sets the item payload.
Top
See Also

Reference

PdfPortfolioItem Class
Xfinium.Pdf.Portfolios Namespace


Attributes Property (PdfPortfolioItem)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : Attributes Property
Gets or sets the attributes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Attributes As PdfPortfolioItemAttributes
'Usage

Dim instance As PdfPortfolioItem
Dim value As PdfPortfolioItemAttributes

instance.Attributes = value

value = instance.Attributes
public PdfPortfolioItemAttributes Attributes {get; set;}
public:
property PdfPortfolioItemAttributes^ Attributes {
   PdfPortfolioItemAttributes^ get();
   void set (    PdfPortfolioItemAttributes^ value);
}

Property Value

A dictionary of attributes associated with this PdfPortfolioItem.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


CreationDate Property (PdfPortfolioItem)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : CreationDate Property
Gets or sets the creation date and time.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CreationDate As Date
'Usage

Dim instance As PdfPortfolioItem
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
public DateTime CreationDate {get; set;}
public:
property DateTime CreationDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time when when this PdfPortfolioItem was created.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


Description Property (PdfPortfolioItem)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : Description Property
Gets or sets the description.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As PdfPortfolioItem
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

A description associated with this PdfPortfolioItem.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


FileName Property (PdfPortfolioItem)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : FileName Property
Gets or sets the file name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FileName As String
'Usage

Dim instance As PdfPortfolioItem
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
public:
property String^ FileName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the file associated with the content stored in Payload property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


Folder Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : Folder Property
Gets or sets the folder.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Folder As PdfPortfolioFolder
'Usage

Dim instance As PdfPortfolioItem
Dim value As PdfPortfolioFolder

instance.Folder = value

value = instance.Folder
public PdfPortfolioFolder Folder {get; set;}
public:
property PdfPortfolioFolder^ Folder {
   PdfPortfolioFolder^ get();
   void set (    PdfPortfolioFolder^ value);
}

Property Value

The folder that this PdfPortfolioItem belongs to.
Remarks
The portfolio item will be displayed in the root of the portfolio if it does not belong to a folder.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


MimeType Property (PdfPortfolioItem)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : MimeType Property
Gets or sets the MIME type.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MimeType As String
'Usage

Dim instance As PdfPortfolioItem
Dim value As String

instance.MimeType = value

value = instance.MimeType
public string MimeType {get; set;}
public:
property String^ MimeType {
   String^ get();
   void set (    String^ value);
}

Property Value

The MIME type of the portfolio item.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


ModifyDate Property (PdfPortfolioItem)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : ModifyDate Property
Gets or sets the modify date and time.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ModifyDate As Date
'Usage

Dim instance As PdfPortfolioItem
Dim value As Date

instance.ModifyDate = value

value = instance.ModifyDate
public DateTime ModifyDate {get; set;}
public:
property DateTime ModifyDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

The date and time when when this PdfPortfolioItem was last modified.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


Payload Property (PdfPortfolioItem)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : Payload Property
Gets or sets the item payload.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Payload As Byte()
'Usage

Dim instance As PdfPortfolioItem
Dim value() As Byte

instance.Payload = value

value = instance.Payload
public byte[] Payload {get; set;}
public:
property array<byte>^ Payload {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

The content of the portfolio item.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


%%PageItemTitle%%

PdfPortfolioItemAttributes Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItemAttributes Class
Defines the attributes for a portfolio item.
Object Model
PdfPortfolioItemAttributes ClassPdfCosObject Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfPortfolioItemAttributes
'Usage

Dim instance As PdfPortfolioItemAttributes
[DefaultMember("Item")]
public class PdfPortfolioItemAttributes
[DefaultMember("Item")]
public ref class PdfPortfolioItemAttributes
Remarks
The attributes keys must match the attribute definition keys.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Portfolios.PdfPortfolioItemAttributes

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItemAttributes Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolioItemAttributes Class Members
Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItemAttributes Class

The following tables list the members exposed by PdfPortfolioItemAttributes.

Public Constructors
 | Name | Description
Public Constructor | PdfPortfolioItemAttributes Constructor | Initializes a new PdfPortfolioItemAttributes object.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets or sets an attribute.
Public Property | Keys | Gets the list of attribute keys.
Top
See Also

Reference

PdfPortfolioItemAttributes Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioItemAttributes Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItemAttributes Class : PdfPortfolioItemAttributes Constructor
Initializes a new PdfPortfolioItemAttributes object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPortfolioItemAttributes()
public PdfPortfolioItemAttributes()
public:
PdfPortfolioItemAttributes();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItemAttributes Class
PdfPortfolioItemAttributes Members


%%PageItemTitle%% $$Properties$$

PdfPortfolioItemAttributes Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItemAttributes Class

For a list of all members of this type, see PdfPortfolioItemAttributes members.

Public Properties
 | Name | Description
Public Property | Item | Gets or sets an attribute.
Public Property | Keys | Gets the list of attribute keys.
Top
See Also

Reference

PdfPortfolioItemAttributes Class
Xfinium.Pdf.Portfolios Namespace


Item Property (PdfPortfolioItemAttributes)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItemAttributes Class : Item Property
The attribute key.
Gets or sets an attribute.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal attributeKey As String _
) As PdfCosObject
'Usage

Dim instance As PdfPortfolioItemAttributes
Dim attributeKey As String
Dim value As PdfCosObject

instance.Item(attributeKey) = value

value = instance.Item(attributeKey)
public PdfCosObject this[
   string attributeKey
]; {get; set;}
public:
property PdfCosObject^ default [String^] {
   PdfCosObject^ get(String^ attributeKey);
   void set (String^ attributeKey, PdfCosObject^ value);
}

Parameters

attributeKey
The attribute key.

Property Value

The attribute value if it exists, null otherwise.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItemAttributes Class
PdfPortfolioItemAttributes Members


Keys Property (PdfPortfolioItemAttributes)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItemAttributes Class : Keys Property
Gets the list of attribute keys.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Keys As String()
'Usage

Dim instance As PdfPortfolioItemAttributes
Dim value() As String

value = instance.Keys
public string[] Keys {get;}
public:
property array<String^>^ Keys {
   array<String^>^ get();
}

Property Value

An array of strings representing the attribute keys.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItemAttributes Class
PdfPortfolioItemAttributes Members


%%PageItemTitle%%

PdfPortfolioItemCollection Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItemCollection Class
Defines a collection of portfolio items.
Object Model
PdfPortfolioItemCollection ClassPdfPortfolioItem Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PdfPortfolioItemCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfPortfolioItem)
'Usage

Dim instance As PdfPortfolioItemCollection
[DefaultMember("Item")]
public class PdfPortfolioItemCollection : System.Collections.ObjectModel.Collection<PdfPortfolioItem>
[DefaultMember("Item")]
public ref class PdfPortfolioItemCollection : public System.Collections.ObjectModel.Collection<PdfPortfolioItem>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Portfolios.PdfPortfolioItemCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItemCollection Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolioItemCollection Class Members
Properties Methods

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItemCollection Class

The following tables list the members exposed by PdfPortfolioItemCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Property | Item | Gets the file atttachment with the specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Top
See Also

Reference

PdfPortfolioItemCollection Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Properties$$

PdfPortfolioItemCollection Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItemCollection Class

For a list of all members of this type, see PdfPortfolioItemCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Property | Item | Gets the file atttachment with the specified name.
Top
See Also

Reference

PdfPortfolioItemCollection Class
Xfinium.Pdf.Portfolios Namespace


Item Property (PdfPortfolioItemCollection)

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItemCollection Class : Item Property
Name of the file attachment to retrieve.
Gets the file atttachment with the specified name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal name As String _
) As PdfPortfolioItem
'Usage

Dim instance As PdfPortfolioItemCollection
Dim name As String
Dim value As PdfPortfolioItem

value = instance.Item(name)
public new PdfPortfolioItem this[
   string name
]; {get;}
public:
new property PdfPortfolioItem^ default [String^] {
   PdfPortfolioItem^ get(String^ name);
}

Parameters

name
Name of the file attachment to retrieve.

Property Value

The file attachment with the specified name or null if the name is not found.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItemCollection Class
PdfPortfolioItemCollection Members


%%PageItemTitle%%

PdfPortfolioSortInformation Class
Members

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioSortInformation Class
Defines the sort order of the portfolio items.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPortfolioSortInformation
'Usage

Dim instance As PdfPortfolioSortInformation
public class PdfPortfolioSortInformation
public ref class PdfPortfolioSortInformation
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Portfolios.PdfPortfolioSortInformation

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioSortInformation Members
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%% $$Members$$

PdfPortfolioSortInformation Class Members
Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioSortInformation Class

The following tables list the members exposed by PdfPortfolioSortInformation.

Public Constructors
 | Name | Description
Public Constructor | PdfPortfolioSortInformation Constructor | Initializes a new PdfPortfolioSortInformation object.
Top
Public Properties
 | Name | Description
Public Property | Ascending | Gets or sets a value indicating the sort order.
Public Property | SortFields | Gets or sets the list of fields used for sort order.
Top
See Also

Reference

PdfPortfolioSortInformation Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioSortInformation Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioSortInformation Class : PdfPortfolioSortInformation Constructor
Initializes a new PdfPortfolioSortInformation object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPortfolioSortInformation()
public PdfPortfolioSortInformation()
public:
PdfPortfolioSortInformation();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioSortInformation Class
PdfPortfolioSortInformation Members


%%PageItemTitle%% $$Properties$$

PdfPortfolioSortInformation Class Properties

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioSortInformation Class

For a list of all members of this type, see PdfPortfolioSortInformation members.

Public Properties
 | Name | Description
Public Property | Ascending | Gets or sets a value indicating the sort order.
Public Property | SortFields | Gets or sets the list of fields used for sort order.
Top
See Also

Reference

PdfPortfolioSortInformation Class
Xfinium.Pdf.Portfolios Namespace


Ascending Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioSortInformation Class : Ascending Property
Gets or sets a value indicating the sort order.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Ascending As Boolean()
'Usage

Dim instance As PdfPortfolioSortInformation
Dim value() As Boolean

instance.Ascending = value

value = instance.Ascending
public bool[] Ascending {get; set;}
public:
property array<bool>^ Ascending {
   array<bool>^ get();
   void set (    array<bool>^ value);
}

Property Value

If true, the items are sorted in ascending order.
Remarks
Each field in SortFields property has a corresponding order in this array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioSortInformation Class
PdfPortfolioSortInformation Members


SortFields Property

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioSortInformation Class : SortFields Property
Gets or sets the list of fields used for sort order.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SortFields As String()
'Usage

Dim instance As PdfPortfolioSortInformation
Dim value() As String

instance.SortFields = value

value = instance.SortFields
public string[] SortFields {get; set;}
public:
property array<String^>^ SortFields {
   array<String^>^ get();
   void set (    array<String^>^ value);
}

Property Value

An array of names specifying the fields used for sorting the portfolio items in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioSortInformation Class
PdfPortfolioSortInformation Members


%%PageItemTitle%%

PdfPortfolioAttributeDefinitionType Enumeration

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioAttributeDefinitionType Enumeration
Supported data types for portfolio attributes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPortfolioAttributeDefinitionType
   Inherits System.Enum
'Usage

Dim instance As PdfPortfolioAttributeDefinitionType
public enum PdfPortfolioAttributeDefinitionType : System.Enum
public enum class PdfPortfolioAttributeDefinitionType : public System.Enum
Members
Member | Description
CreationDate | Creation date of the file in the document attachment.
Date | Date attribute.
Description | Description of the document attachment.
FileName | File name of the document attachment.
ModDate | Modification date of the file in the document attachment.
NoType | The attribute has no data type associated with it.
Number | Number attribute
Size | Size of the file in the document attachment.
String | Text attribute.
Unknown | Unknown data type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Portfolios.PdfPortfolioAttributeDefinitionType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioDisplayMode Enumeration

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioDisplayMode Enumeration
Supported display modes for PDF portfolios.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPortfolioDisplayMode
   Inherits System.Enum
'Usage

Dim instance As PdfPortfolioDisplayMode
public enum PdfPortfolioDisplayMode : System.Enum
public enum class PdfPortfolioDisplayMode : public System.Enum
Members
Member | Description
Details | The portfolio is displayed in details mode, all the information is displayed in a column format.
Hidden | The portfolio information is initially hidden, without preventing the user from obtaining a file list via explicit action.
Tile | The portfolio is displayed in tile mode, with each file in the collection denoted by a small icon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Portfolios.PdfPortfolioDisplayMode

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Portfolios Namespace


Xfinium.Pdf.Redaction Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfContentRedactor | Defines a redactor for Pdf page content.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Redaction Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Xfinium.Pdf.Redaction.PdfContentRedactor
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfContentRedactor Class
Members

Xfinium.Pdf.Redaction Namespace : PdfContentRedactor Class
Defines a redactor for Pdf page content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfContentRedactor
'Usage

Dim instance As PdfContentRedactor
public class PdfContentRedactor
public ref class PdfContentRedactor
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Redaction.PdfContentRedactor

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Members
Xfinium.Pdf.Redaction Namespace


%%PageItemTitle%% $$Members$$

PdfContentRedactor Class Members
Methods

Xfinium.Pdf.Redaction Namespace : PdfContentRedactor Class

The following tables list the members exposed by PdfContentRedactor.

Public Constructors
 | Name | Description
Public Constructor | PdfContentRedactor Constructor | Initializes a new PdfContentRedactor object.
Top
Public Methods
 | Name | Description
Public Method | ApplyRedaction | Applies the redaction on the Pdf page.
Public Method | BeginRedaction | Initializes the redaction process.
Public Method | RedactAnnotation | Redacts the area specified by the redaction annotation.
Public Method | RedactAnnotations | Redacts the areas specified by the redaction annotations on the current page.
Public Method | RedactArea | Overloaded. Redacts the page content from the specified area.
Top
See Also

Reference

PdfContentRedactor Class
Xfinium.Pdf.Redaction Namespace


%%PageItemTitle%%

PdfContentRedactor Constructor

Xfinium.Pdf.Redaction Namespace > PdfContentRedactor Class : PdfContentRedactor Constructor
The page from which content is redacted.
Initializes a new PdfContentRedactor object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As PdfPage _
)
'Usage

Dim page As PdfPage

Dim instance As New PdfContentRedactor(page)
public PdfContentRedactor(
   PdfPage page
)
public:
PdfContentRedactor(
   PdfPage^ page
)

Parameters

page
The page from which content is redacted.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Class
PdfContentRedactor Members


%%PageItemTitle%% $$Methods$$

PdfContentRedactor Class Methods

Xfinium.Pdf.Redaction Namespace : PdfContentRedactor Class

For a list of all members of this type, see PdfContentRedactor members.

Public Methods
 | Name | Description
Public Method | ApplyRedaction | Applies the redaction on the Pdf page.
Public Method | BeginRedaction | Initializes the redaction process.
Public Method | RedactAnnotation | Redacts the area specified by the redaction annotation.
Public Method | RedactAnnotations | Redacts the areas specified by the redaction annotations on the current page.
Public Method | RedactArea | Overloaded. Redacts the page content from the specified area.
Top
See Also

Reference

PdfContentRedactor Class
Xfinium.Pdf.Redaction Namespace


ApplyRedaction Method

Xfinium.Pdf.Redaction Namespace > PdfContentRedactor Class : ApplyRedaction Method
Applies the redaction on the Pdf page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ApplyRedaction()
'Usage

Dim instance As PdfContentRedactor

instance.ApplyRedaction()
public void ApplyRedaction()
public:
void ApplyRedaction();
Remarks
The BeginRedaction / ApplyRedaction pair of methods lets you redact multiple areas on a Pdf page in a single step. The page content is redacted when this method is called if redaction has been initialized with the BeginRedaction method and redaction areas have been setup by one or more calls to RedactArea(PdfVisualRectangle) method.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Class
PdfContentRedactor Members


BeginRedaction Method

Xfinium.Pdf.Redaction Namespace > PdfContentRedactor Class : BeginRedaction Method
Initializes the redaction process.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub BeginRedaction()
'Usage

Dim instance As PdfContentRedactor

instance.BeginRedaction()
public void BeginRedaction()
public:
void BeginRedaction();
Remarks
The BeginRedaction / ApplyRedaction pair of methods lets you redact multiple areas on a Pdf page in a single step. When this method has been called, the RedactArea(PdfVisualRectangle) method has no immediate effect, the actual redaction takes place when ApplyRedaction method is called. If this method is called but the ApplyRedaction method is not called, the redaction process does not take place.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Class
PdfContentRedactor Members


RedactAnnotation Method

Xfinium.Pdf.Redaction Namespace > PdfContentRedactor Class : RedactAnnotation Method
The redaction annotation that specifies the area to redact.
Redacts the area specified by the redaction annotation.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RedactAnnotation( _
   ByVal redactionAnnotation As PdfRedactionAnnotation _
)
'Usage

Dim instance As PdfContentRedactor
Dim redactionAnnotation As PdfRedactionAnnotation

instance.RedactAnnotation(redactionAnnotation)
public void RedactAnnotation(
   PdfRedactionAnnotation redactionAnnotation
)
public:
void RedactAnnotation(
   PdfRedactionAnnotation^ redactionAnnotation
)

Parameters

redactionAnnotation
The redaction annotation that specifies the area to redact.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Class
PdfContentRedactor Members


RedactAnnotations Method

Xfinium.Pdf.Redaction Namespace > PdfContentRedactor Class : RedactAnnotations Method
Redacts the areas specified by the redaction annotations on the current page.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub RedactAnnotations()
'Usage

Dim instance As PdfContentRedactor

instance.RedactAnnotations()
public void RedactAnnotations()
public:
void RedactAnnotations();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Class
PdfContentRedactor Members


RedactArea Method

Xfinium.Pdf.Redaction Namespace > PdfContentRedactor Class : RedactArea Method
Redacts the page content from the specified area.
Overload List
Overload | Description
RedactArea(PdfVisualRectangle) | Redacts the page content from the specified area.
RedactArea(PdfVisualRectangle,PdfColor) | Redacts the page content from the specified area.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Class
PdfContentRedactor Members


RedactArea(PdfVisualRectangle) Method

Xfinium.Pdf.Redaction Namespace > PdfContentRedactor Class > RedactArea Method : RedactArea(PdfVisualRectangle) Method
Area from which the content should be redacted.
Redacts the page content from the specified area.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub RedactArea( _
   ByVal redactionArea As PdfVisualRectangle _
)
'Usage

Dim instance As PdfContentRedactor
Dim redactionArea As PdfVisualRectangle

instance.RedactArea(redactionArea)
public void RedactArea(
   PdfVisualRectangle redactionArea
)
public:
void RedactArea(
   PdfVisualRectangle^ redactionArea
)

Parameters

redactionArea
Area from which the content should be redacted.
Remarks
If BeginRedaction method has not been called before then the content is redacted immediately. Otherwise the redaction area is stored and the redaction takes place when ApplyRedaction method has been called.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Class
PdfContentRedactor Members
Overload List


RedactArea(PdfVisualRectangle,PdfColor) Method

Xfinium.Pdf.Redaction Namespace > PdfContentRedactor Class > RedactArea Method : RedactArea(PdfVisualRectangle,PdfColor) Method
Area from which the content should be redacted.
Color used for masking the redacted area.
Redacts the page content from the specified area.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Sub RedactArea( _
   ByVal redactionArea As PdfVisualRectangle, _
   ByVal redactionColor As PdfColor _
)
'Usage

Dim instance As PdfContentRedactor
Dim redactionArea As PdfVisualRectangle
Dim redactionColor As PdfColor

instance.RedactArea(redactionArea, redactionColor)
public void RedactArea(
   PdfVisualRectangle redactionArea,
   PdfColor redactionColor
)
public:
void RedactArea(
   PdfVisualRectangle^ redactionArea,
   PdfColor^ redactionColor
)

Parameters

redactionArea
Area from which the content should be redacted.
redactionColor
Color used for masking the redacted area.
Remarks
If BeginRedaction method has not been called before then the content is redacted immediately. Otherwise the redaction area is stored and the redaction takes place when ApplyRedaction method has been called.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfContentRedactor Class
PdfContentRedactor Members
Overload List


Xfinium.Pdf.Services Namespace
Inheritance Hierarchy
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Services Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

XFINIUM.PDF Library


Xfinium.Pdf.Spatial Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfCoordinateSystem | Defines the base class for spatial coordinate systems.
Class | PdfGeographicCoordinateSystem | Defines a geographic coordinate system.
Class | PdfGeospatialMeasure | Defines a geospatial measure.
Class | PdfMeasure | Defines the bae class for spatial PDF measures
Class | PdfNumberFormat | Defines how a measure units should be formatted for display.
Class | PdfNumberFormatCollection | Defines a collection of Pdf number formats.
Class | PdfPointData | Defines a class that specifies extended geospatial data.
Class | PdfProjectedCoordinateSystem | Defines a projected coordinate system.
Class | PdfRectilinearMeasure | Defines a rectilinear measure.
Class | PdfViewport | Defines a rectangular region of a page that supports a different measurement scale.
Class | PdfViewportCollection | Defines a collection of Pdf viewports.
Enumerations
 | Enumeration | Description
Enumeration | PdfFractionDisplay | Specifies the supported display modes for a fractional value.
Enumeration | PdfPointDataType | Specifies the supported types for values in a PdfPointData object.
Enumeration | PdfPreferredDisplayUnit | Specifies the supported values for preferred display units.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Spatial Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Spatial.PdfNumberFormatCollection
Xfinium.Pdf.Spatial.PdfViewportCollection
Xfinium.Pdf.Spatial.PdfCoordinateSystem
Xfinium.Pdf.Spatial.PdfGeographicCoordinateSystem
Xfinium.Pdf.Spatial.PdfProjectedCoordinateSystem
Xfinium.Pdf.Spatial.PdfMeasure
Xfinium.Pdf.Spatial.PdfGeospatialMeasure
Xfinium.Pdf.Spatial.PdfRectilinearMeasure
Xfinium.Pdf.Spatial.PdfNumberFormat
Xfinium.Pdf.Spatial.PdfPointData
Xfinium.Pdf.Spatial.PdfViewport
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfCoordinateSystem Class
Members

Xfinium.Pdf.Spatial Namespace : PdfCoordinateSystem Class
Defines the base class for spatial coordinate systems.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfCoordinateSystem
'Usage

Dim instance As PdfCoordinateSystem
public abstract class PdfCoordinateSystem
public ref class PdfCoordinateSystem abstract
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfCoordinateSystem
Xfinium.Pdf.Spatial.PdfGeographicCoordinateSystem
Xfinium.Pdf.Spatial.PdfProjectedCoordinateSystem

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCoordinateSystem Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfCoordinateSystem Class Members
Properties

Xfinium.Pdf.Spatial Namespace : PdfCoordinateSystem Class

The following tables list the members exposed by PdfCoordinateSystem.

Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code.
Public Property | WellKnownText | Gets or sets the wekk known text.
Top
See Also

Reference

PdfCoordinateSystem Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Properties$$

PdfCoordinateSystem Class Properties

Xfinium.Pdf.Spatial Namespace : PdfCoordinateSystem Class

For a list of all members of this type, see PdfCoordinateSystem members.

Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code.
Public Property | WellKnownText | Gets or sets the wekk known text.
Top
See Also

Reference

PdfCoordinateSystem Class
Xfinium.Pdf.Spatial Namespace


EPSG Property

Xfinium.Pdf.Spatial Namespace > PdfCoordinateSystem Class : EPSG Property
Gets or sets the EPSG code.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EPSG As Integer
'Usage

Dim instance As PdfCoordinateSystem
Dim value As Integer

instance.EPSG = value

value = instance.EPSG
public int EPSG {get; set;}
public:
property int EPSG {
   int get();
   void set (    int value);
}

Property Value

An EPSG reference code specifying the geographic coordinate system.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCoordinateSystem Class
PdfCoordinateSystem Members


WellKnownText Property

Xfinium.Pdf.Spatial Namespace > PdfCoordinateSystem Class : WellKnownText Property
Gets or sets the wekk known text.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property WellKnownText As String
'Usage

Dim instance As PdfCoordinateSystem
Dim value As String

instance.WellKnownText = value

value = instance.WellKnownText
public string WellKnownText {get; set;}
public:
property String^ WellKnownText {
   String^ get();
   void set (    String^ value);
}

Property Value

A string of Well Known Text describing the geographic coordinate system.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCoordinateSystem Class
PdfCoordinateSystem Members


%%PageItemTitle%%

PdfGeographicCoordinateSystem Class
Members

Xfinium.Pdf.Spatial Namespace : PdfGeographicCoordinateSystem Class
Defines a geographic coordinate system.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfGeographicCoordinateSystem
   Inherits PdfCoordinateSystem
'Usage

Dim instance As PdfGeographicCoordinateSystem
public class PdfGeographicCoordinateSystem : PdfCoordinateSystem
public ref class PdfGeographicCoordinateSystem : public PdfCoordinateSystem
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfCoordinateSystem
Xfinium.Pdf.Spatial.PdfGeographicCoordinateSystem

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeographicCoordinateSystem Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfGeographicCoordinateSystem Class Members
Properties

Xfinium.Pdf.Spatial Namespace : PdfGeographicCoordinateSystem Class

The following tables list the members exposed by PdfGeographicCoordinateSystem.

Public Constructors
 | Name | Description
Public Constructor | PdfGeographicCoordinateSystem Constructor | Initializes a new PdfGeographicCoordinateSystem object.
Top
Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code. (Inherited from Xfinium.Pdf.Spatial.PdfCoordinateSystem)
Public Property | WellKnownText | Gets or sets the wekk known text. (Inherited from Xfinium.Pdf.Spatial.PdfCoordinateSystem)
Top
See Also

Reference

PdfGeographicCoordinateSystem Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfGeographicCoordinateSystem Constructor

Xfinium.Pdf.Spatial Namespace > PdfGeographicCoordinateSystem Class : PdfGeographicCoordinateSystem Constructor
Initializes a new PdfGeographicCoordinateSystem object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfGeographicCoordinateSystem()
public PdfGeographicCoordinateSystem()
public:
PdfGeographicCoordinateSystem();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeographicCoordinateSystem Class
PdfGeographicCoordinateSystem Members


%%PageItemTitle%%

PdfGeospatialMeasure Class
Members

Xfinium.Pdf.Spatial Namespace : PdfGeospatialMeasure Class
Defines a geospatial measure.
Object Model
PdfGeospatialMeasure ClassPdfPoint ClassPdfCoordinateSystem ClassPdfCoordinateSystem ClassPdfPoint ClassPdfPoint Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfGeospatialMeasure
   Inherits PdfMeasure
'Usage

Dim instance As PdfGeospatialMeasure
public class PdfGeospatialMeasure : PdfMeasure
public ref class PdfGeospatialMeasure : public PdfMeasure
Remarks
The geospatial measure defines the relationship between points or regions in the two dimensional PDF object space and points or regions with respect to an underlying model of the earth.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfMeasure
Xfinium.Pdf.Spatial.PdfGeospatialMeasure

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfGeospatialMeasure Class Members
Properties

Xfinium.Pdf.Spatial Namespace : PdfGeospatialMeasure Class

The following tables list the members exposed by PdfGeospatialMeasure.

Public Constructors
 | Name | Description
Public Constructor | PdfGeospatialMeasure Constructor | Initializes a new PdfGeospatialMeasure object.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the map bounds.
Public Property | CoordinateSystem | Gets or sets the coordinate system.
Public Property | DisplayCoordinateSystem | Gets or sets the display coordinate system.
Public Property | GeographicPoints | Gets or sets the geographic points.
Public Property | LocalPoints | Gets or sets the local points.
Public Property | PreferredAngularDisplayUnit | Gets or sets the preferred unit for displaying angles.
Public Property | PreferredAreaDisplayUnit | Gets or sets the preferred unit for displaying areas.
Public Property | PreferredDistanceDisplayUnit | Gets or sets the preferred unit for displaying distances.
Top
See Also

Reference

PdfGeospatialMeasure Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfGeospatialMeasure Constructor

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : PdfGeospatialMeasure Constructor
Initializes a new PdfGeospatialMeasure object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfGeospatialMeasure()
public PdfGeospatialMeasure()
public:
PdfGeospatialMeasure();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


%%PageItemTitle%% $$Properties$$

PdfGeospatialMeasure Class Properties

Xfinium.Pdf.Spatial Namespace : PdfGeospatialMeasure Class

For a list of all members of this type, see PdfGeospatialMeasure members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the map bounds.
Public Property | CoordinateSystem | Gets or sets the coordinate system.
Public Property | DisplayCoordinateSystem | Gets or sets the display coordinate system.
Public Property | GeographicPoints | Gets or sets the geographic points.
Public Property | LocalPoints | Gets or sets the local points.
Public Property | PreferredAngularDisplayUnit | Gets or sets the preferred unit for displaying angles.
Public Property | PreferredAreaDisplayUnit | Gets or sets the preferred unit for displaying areas.
Public Property | PreferredDistanceDisplayUnit | Gets or sets the preferred unit for displaying distances.
Top
See Also

Reference

PdfGeospatialMeasure Class
Xfinium.Pdf.Spatial Namespace


Bounds Property (PdfGeospatialMeasure)

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : Bounds Property
Gets or sets the map bounds.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Bounds As PdfPoint()
'Usage

Dim instance As PdfGeospatialMeasure
Dim value() As PdfPoint

instance.Bounds = value

value = instance.Bounds
public PdfPoint[] Bounds {get; set;}
public:
property array<PdfPoint^>^ Bounds {
   array<PdfPoint^>^ get();
   void set (    array<PdfPoint^>^ value);
}

Property Value

An array of points that describes the bounds of an area for which geospatial transformations are valid.
Remarks
For maps, this bounding polygon is known as a neatline. These points (x and y) are expressed relative to a unit square that describes the bounds associated with a PdfViewport, Xfinium.Pdf.Graphics.PdfFormXObject or Xfinium.Pdf.Graphics.PdfImage.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


CoordinateSystem Property

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : CoordinateSystem Property
Gets or sets the coordinate system.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CoordinateSystem As PdfCoordinateSystem
'Usage

Dim instance As PdfGeospatialMeasure
Dim value As PdfCoordinateSystem

instance.CoordinateSystem = value

value = instance.CoordinateSystem
public PdfCoordinateSystem CoordinateSystem {get; set;}
public:
property PdfCoordinateSystem^ CoordinateSystem {
   PdfCoordinateSystem^ get();
   void set (    PdfCoordinateSystem^ value);
}

Property Value

A projected or geographic coordinate system object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


DisplayCoordinateSystem Property

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : DisplayCoordinateSystem Property
Gets or sets the display coordinate system.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisplayCoordinateSystem As PdfCoordinateSystem
'Usage

Dim instance As PdfGeospatialMeasure
Dim value As PdfCoordinateSystem

instance.DisplayCoordinateSystem = value

value = instance.DisplayCoordinateSystem
public PdfCoordinateSystem DisplayCoordinateSystem {get; set;}
public:
property PdfCoordinateSystem^ DisplayCoordinateSystem {
   PdfCoordinateSystem^ get();
   void set (    PdfCoordinateSystem^ value);
}

Property Value

A projected or geographic coordinate system that shall be used for the display of position values, such as latitude and longitude.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


GeographicPoints Property

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : GeographicPoints Property
Gets or sets the geographic points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property GeographicPoints As PdfPoint()
'Usage

Dim instance As PdfGeospatialMeasure
Dim value() As PdfPoint

instance.GeographicPoints = value

value = instance.GeographicPoints
public PdfPoint[] GeographicPoints {get; set;}
public:
property array<PdfPoint^>^ GeographicPoints {
   array<PdfPoint^>^ get();
   void set (    array<PdfPoint^>^ value);
}

Property Value

An array of points in geographic space as degrees of latitude and longitude, respectively.
Remarks
These values shall be based on the geographic coordinate system described CoordinateSystem.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


LocalPoints Property

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : LocalPoints Property
Gets or sets the local points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LocalPoints As PdfPoint()
'Usage

Dim instance As PdfGeospatialMeasure
Dim value() As PdfPoint

instance.LocalPoints = value

value = instance.LocalPoints
public PdfPoint[] LocalPoints {get; set;}
public:
property array<PdfPoint^>^ LocalPoints {
   array<PdfPoint^>^ get();
   void set (    array<PdfPoint^>^ value);
}

Property Value

An array of points in a 2D unit square.
Remarks
The unit square is mapped to the rectangular bounds of the PdfViewport, Xfinium.Pdf.Graphics.PdfFormXObject or Xfinium.Pdf.Graphics.PdfImage that contains the measure object.
This array shall contain the same number of points as the GeographicPoints array; each point is the unit square object position corresponding to the geospatial position in the GeographicPoints array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


PreferredAngularDisplayUnit Property

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : PreferredAngularDisplayUnit Property
Gets or sets the preferred unit for displaying angles.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PreferredAngularDisplayUnit As PdfPreferredDisplayUnit
'Usage

Dim instance As PdfGeospatialMeasure
Dim value As PdfPreferredDisplayUnit

instance.PreferredAngularDisplayUnit = value

value = instance.PreferredAngularDisplayUnit
public PdfPreferredDisplayUnit PreferredAngularDisplayUnit {get; set;}
public:
property PdfPreferredDisplayUnit PreferredAngularDisplayUnit {
   PdfPreferredDisplayUnit get();
   void set (    PdfPreferredDisplayUnit value);
}

Property Value

The preferred unit for displaying angles.
Remarks
Only these values are supported for this property: PdfPreferredDisplayUnit.Degree and PdfPreferredDisplayUnit.Grad.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


PreferredAreaDisplayUnit Property

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : PreferredAreaDisplayUnit Property
Gets or sets the preferred unit for displaying areas.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PreferredAreaDisplayUnit As PdfPreferredDisplayUnit
'Usage

Dim instance As PdfGeospatialMeasure
Dim value As PdfPreferredDisplayUnit

instance.PreferredAreaDisplayUnit = value

value = instance.PreferredAreaDisplayUnit
public PdfPreferredDisplayUnit PreferredAreaDisplayUnit {get; set;}
public:
property PdfPreferredDisplayUnit PreferredAreaDisplayUnit {
   PdfPreferredDisplayUnit get();
   void set (    PdfPreferredDisplayUnit value);
}

Property Value

The preferred unit for displaying areas.
Remarks
Only these values are supported for this property: PdfPreferredDisplayUnit.SquareMetre, PdfPreferredDisplayUnit.Hectare, PdfPreferredDisplayUnit.SquareKilometre, PdfPreferredDisplayUnit.SquareUSFoot, PdfPreferredDisplayUnit.Acre and PdfPreferredDisplayUnit.SquareMile.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


PreferredDistanceDisplayUnit Property

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : PreferredDistanceDisplayUnit Property
Gets or sets the preferred unit for displaying distances.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PreferredDistanceDisplayUnit As PdfPreferredDisplayUnit
'Usage

Dim instance As PdfGeospatialMeasure
Dim value As PdfPreferredDisplayUnit

instance.PreferredDistanceDisplayUnit = value

value = instance.PreferredDistanceDisplayUnit
public PdfPreferredDisplayUnit PreferredDistanceDisplayUnit {get; set;}
public:
property PdfPreferredDisplayUnit PreferredDistanceDisplayUnit {
   PdfPreferredDisplayUnit get();
   void set (    PdfPreferredDisplayUnit value);
}

Property Value

The preferred unit for displaying distances.
Remarks
Only these values are supported for this property: PdfPreferredDisplayUnit.Metre, PdfPreferredDisplayUnit.Kilometre, PdfPreferredDisplayUnit.Foot, PdfPreferredDisplayUnit.USFoot, PdfPreferredDisplayUnit.Mile and PdfPreferredDisplayUnit.NauticalMile.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


%%PageItemTitle%%

PdfMeasure Class
Members

Xfinium.Pdf.Spatial Namespace : PdfMeasure Class
Defines the bae class for spatial PDF measures
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class PdfMeasure
'Usage

Dim instance As PdfMeasure
public abstract class PdfMeasure
public ref class PdfMeasure abstract
Remarks
A measure specifies an alternative coordinate system for a region of a page. Along with the viewport, it provides the information needed to convert coordinates in the page's coordinate system to coordinates in the measuring coordinate system.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfMeasure
Xfinium.Pdf.Spatial.PdfGeospatialMeasure
Xfinium.Pdf.Spatial.PdfRectilinearMeasure

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfMeasure Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfMeasure Class Members

Xfinium.Pdf.Spatial Namespace : PdfMeasure Class

The following tables list the members exposed by PdfMeasure.

See Also

Reference

PdfMeasure Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfNumberFormat Class
Members

Xfinium.Pdf.Spatial Namespace : PdfNumberFormat Class
Defines how a measure units should be formatted for display.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfNumberFormat
'Usage

Dim instance As PdfNumberFormat
public class PdfNumberFormat
public ref class PdfNumberFormat
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfNumberFormat

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfNumberFormat Class Members
Properties

Xfinium.Pdf.Spatial Namespace : PdfNumberFormat Class

The following tables list the members exposed by PdfNumberFormat.

Public Constructors
 | Name | Description
Public Constructor | PdfNumberFormat Constructor | Initializes a new PdfNumberFormat object.
Top
Public Properties
 | Name | Description
Public Property | ConversionFactor | Gets or sets the conversion factor.
Public Property | DecimalSeparator | Gets or sets the decimal separator.
Public Property | Denominator | Gets or sets the denominator.
Public Property | DisplayMeasureUnitAsPrefix | Gets or sets a value indicating whether the MeasureUnit is displayed before or after the calculated unit value.
Public Property | FractionDisplay | Gets or sets the fraction display.
Public Property | MeasureUnit | Gets or sets the measure unit.
Public Property | Precision | Gets or sets the precision.
Public Property | Prefix | Gets or sets the prefix.
Public Property | ReduceFraction | Gets or sets a value indicating whether the fractional part can be reduced or the low-order zeros truncated.
Public Property | Suffix | Gets or sets the suffix.
Public Property | ThousandsSeparator | Gets or sets the thousands separator.
Top
See Also

Reference

PdfNumberFormat Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfNumberFormat Constructor

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : PdfNumberFormat Constructor
Initializes a new PdfNumberFormat object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfNumberFormat()
public PdfNumberFormat()
public:
PdfNumberFormat();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


%%PageItemTitle%% $$Properties$$

PdfNumberFormat Class Properties

Xfinium.Pdf.Spatial Namespace : PdfNumberFormat Class

For a list of all members of this type, see PdfNumberFormat members.

Public Properties
 | Name | Description
Public Property | ConversionFactor | Gets or sets the conversion factor.
Public Property | DecimalSeparator | Gets or sets the decimal separator.
Public Property | Denominator | Gets or sets the denominator.
Public Property | DisplayMeasureUnitAsPrefix | Gets or sets a value indicating whether the MeasureUnit is displayed before or after the calculated unit value.
Public Property | FractionDisplay | Gets or sets the fraction display.
Public Property | MeasureUnit | Gets or sets the measure unit.
Public Property | Precision | Gets or sets the precision.
Public Property | Prefix | Gets or sets the prefix.
Public Property | ReduceFraction | Gets or sets a value indicating whether the fractional part can be reduced or the low-order zeros truncated.
Public Property | Suffix | Gets or sets the suffix.
Public Property | ThousandsSeparator | Gets or sets the thousands separator.
Top
See Also

Reference

PdfNumberFormat Class
Xfinium.Pdf.Spatial Namespace


ConversionFactor Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : ConversionFactor Property
Gets or sets the conversion factor.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ConversionFactor As Double
'Usage

Dim instance As PdfNumberFormat
Dim value As Double

instance.ConversionFactor = value

value = instance.ConversionFactor
public double ConversionFactor {get; set;}
public:
property double ConversionFactor {
   double get();
   void set (    double value);
}

Property Value

The conversion factor used to multiply a value in partial units of the previous number format array element to obtain a value in the units of this object.
Remarks
When this object is in the first number format in the array, its meaning (that is, what it shall be multiplied by) depends on which property in the PdfRectilinearMeasure references the number format array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


DecimalSeparator Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : DecimalSeparator Property
Gets or sets the decimal separator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DecimalSeparator As String
'Usage

Dim instance As PdfNumberFormat
Dim value As String

instance.DecimalSeparator = value

value = instance.DecimalSeparator
public string DecimalSeparator {get; set;}
public:
property String^ DecimalSeparator {
   String^ get();
   void set (    String^ value);
}

Property Value

Text that shall be used as the decimal position in displaying numerical values.
Remarks
An empty string indicates that the default shall be used.
Default value is PERIOD (0x2E).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


Denominator Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : Denominator Property
Gets or sets the denominator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Denominator As Integer
'Usage

Dim instance As PdfNumberFormat
Dim value As Integer

instance.Denominator = value

value = instance.Denominator
public int Denominator {get; set;}
public:
property int Denominator {
   int get();
   void set (    int value);
}

Property Value

The denominator of a fractional display when FractionDisplay property is set to PdfFractionDisplay.Fraction.
Remarks
This property has meaning only if this object is the last one in a number format collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


DisplayMeasureUnitAsPrefix Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : DisplayMeasureUnitAsPrefix Property
Gets or sets a value indicating whether the MeasureUnit is displayed before or after the calculated unit value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisplayMeasureUnitAsPrefix As Boolean
'Usage

Dim instance As PdfNumberFormat
Dim value As Boolean

instance.DisplayMeasureUnitAsPrefix = value

value = instance.DisplayMeasureUnitAsPrefix
public bool DisplayMeasureUnitAsPrefix {get; set;}
public:
property bool DisplayMeasureUnitAsPrefix {
   bool get();
   void set (    bool value);
}

Property Value

If true the MeasureUnit is a prefix to the value, otherwise it is a suffix to the value.
Default is false.
The characters specified by Prefix and Suffix shall be concatenated before considering this property.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


FractionDisplay Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : FractionDisplay Property
Gets or sets the fraction display.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FractionDisplay As PdfFractionDisplay
'Usage

Dim instance As PdfNumberFormat
Dim value As PdfFractionDisplay

instance.FractionDisplay = value

value = instance.FractionDisplay
public PdfFractionDisplay FractionDisplay {get; set;}
public:
property PdfFractionDisplay FractionDisplay {
   PdfFractionDisplay get();
   void set (    PdfFractionDisplay value);
}

Property Value

A value indicating whether and in what manner to display a fractional value from the result of converting to the units of this object by means of the ConversionFactor property.
Remarks
This property has meaning only if this object is the last one in a number format collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


MeasureUnit Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : MeasureUnit Property
Gets or sets the measure unit.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MeasureUnit As String
'Usage

Dim instance As PdfNumberFormat
Dim value As String

instance.MeasureUnit = value

value = instance.MeasureUnit
public string MeasureUnit {get; set;}
public:
property String^ MeasureUnit {
   String^ get();
   void set (    String^ value);
}

Property Value

A text string specifying a label for displaying the units represented by this object in a user interface; the label should use a universally recognized abbreviation.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


Precision Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : Precision Property
Gets or sets the precision.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Precision As Integer
'Usage

Dim instance As PdfNumberFormat
Dim value As Integer

instance.Precision = value

value = instance.Precision
public int Precision {get; set;}
public:
property int Precision {
   int get();
   void set (    int value);
}

Property Value

The precision of decimal display when FractionDisplay property is set to PdfFractionDisplay.Decimal.
Remarks
The value must be a power of 10 (10, 100, 1000, 10000, etc).
This property has meaning only if this object is the last one in a number format collection.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


Prefix Property (PdfNumberFormat)

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : Prefix Property
Gets or sets the prefix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Prefix As String
'Usage

Dim instance As PdfNumberFormat
Dim value As String

instance.Prefix = value

value = instance.Prefix
public string Prefix {get; set;}
public:
property String^ Prefix {
   String^ get();
   void set (    String^ value);
}

Property Value

Text that shall be concatenated to the left of the label specified by MeasureUnit property.
Remarks
An empty string indicates that no text shall be added.
Default value is a single ASCII SPACE character (0x20).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


ReduceFraction Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : ReduceFraction Property
Gets or sets a value indicating whether the fractional part can be reduced or the low-order zeros truncated.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ReduceFraction As Boolean
'Usage

Dim instance As PdfNumberFormat
Dim value As Boolean

instance.ReduceFraction = value

value = instance.ReduceFraction
public bool ReduceFraction {get; set;}
public:
property bool ReduceFraction {
   bool get();
   void set (    bool value);
}

Property Value

If true then a fractional value formatted according to the Precision or Denominator properties may not have its denominator reduced or low-order zeros truncated.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


Suffix Property (PdfNumberFormat)

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : Suffix Property
Gets or sets the suffix.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Suffix As String
'Usage

Dim instance As PdfNumberFormat
Dim value As String

instance.Suffix = value

value = instance.Suffix
public string Suffix {get; set;}
public:
property String^ Suffix {
   String^ get();
   void set (    String^ value);
}

Property Value

Text that shall be concatenated after the label specified by MeasureUnit property.
Remarks
An empty string indicates that no text shall be added.
Default value is a single ASCII SPACE character (0x20).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


ThousandsSeparator Property

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : ThousandsSeparator Property
Gets or sets the thousands separator.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ThousandsSeparator As String
'Usage

Dim instance As PdfNumberFormat
Dim value As String

instance.ThousandsSeparator = value

value = instance.ThousandsSeparator
public string ThousandsSeparator {get; set;}
public:
property String^ ThousandsSeparator {
   String^ get();
   void set (    String^ value);
}

Property Value

Text that shall be used between orders of thousands in display of numerical values.
Remarks
An empty string indicates that no text shall be added.
Default value is COMMA (0x2C).
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


%%PageItemTitle%%

PdfNumberFormatCollection Class
Members

Xfinium.Pdf.Spatial Namespace : PdfNumberFormatCollection Class
Defines a collection of Pdf number formats.
Object Model
PdfNumberFormatCollection ClassPdfNumberFormat Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfNumberFormatCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfNumberFormat)
'Usage

Dim instance As PdfNumberFormatCollection
public class PdfNumberFormatCollection : System.Collections.ObjectModel.Collection<PdfNumberFormat>
public ref class PdfNumberFormatCollection : public System.Collections.ObjectModel.Collection<PdfNumberFormat>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Spatial.PdfNumberFormatCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormatCollection Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfNumberFormatCollection Class Members
Properties Methods

Xfinium.Pdf.Spatial Namespace : PdfNumberFormatCollection Class

The following tables list the members exposed by PdfNumberFormatCollection.

Public Constructors
 | Name | Description
Public Constructor | PdfNumberFormatCollection Constructor | Initializes a new PdfNumberFormatCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Top
See Also

Reference

PdfNumberFormatCollection Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfNumberFormatCollection Constructor

Xfinium.Pdf.Spatial Namespace > PdfNumberFormatCollection Class : PdfNumberFormatCollection Constructor
Initializes a new PdfNumberFormatCollection object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfNumberFormatCollection()
public PdfNumberFormatCollection()
public:
PdfNumberFormatCollection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormatCollection Class
PdfNumberFormatCollection Members


%%PageItemTitle%%

PdfPointData Class
Members

Xfinium.Pdf.Spatial Namespace : PdfPointData Class
Defines a class that specifies extended geospatial data.
Object Model
PdfPointData ClassPdfPointDataType Enumeration
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPointData
'Usage

Dim instance As PdfPointData
public class PdfPointData
public ref class PdfPointData
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfPointData

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPointData Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfPointData Class Members
Properties

Xfinium.Pdf.Spatial Namespace : PdfPointData Class

The following tables list the members exposed by PdfPointData.

Public Constructors
 | Name | Description
Public Constructor | PdfPointData Constructor | Initializes a new PdfPointData object.
Top
Public Properties
 | Name | Description
Public Property | ExtendedPoints | Gets or sets the extended points.
Public Property | PointTypes | Gets or sets the point types.
Top
See Also

Reference

PdfPointData Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfPointData Constructor

Xfinium.Pdf.Spatial Namespace > PdfPointData Class : PdfPointData Constructor
Initializes a new PdfPointData object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPointData()
public PdfPointData()
public:
PdfPointData();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPointData Class
PdfPointData Members


%%PageItemTitle%% $$Properties$$

PdfPointData Class Properties

Xfinium.Pdf.Spatial Namespace : PdfPointData Class

For a list of all members of this type, see PdfPointData members.

Public Properties
 | Name | Description
Public Property | ExtendedPoints | Gets or sets the extended points.
Public Property | PointTypes | Gets or sets the point types.
Top
See Also

Reference

PdfPointData Class
Xfinium.Pdf.Spatial Namespace


ExtendedPoints Property

Xfinium.Pdf.Spatial Namespace > PdfPointData Class : ExtendedPoints Property
Gets or sets the extended points.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExtendedPoints As Double()
'Usage

Dim instance As PdfPointData
Dim value() As Double

instance.ExtendedPoints = value

value = instance.ExtendedPoints
public double[] ExtendedPoints {get; set;}
public:
property array<double>^ ExtendedPoints {
   array<double>^ get();
   void set (    array<double>^ value);
}

Property Value

An array of arrays of values.
Remarks
The number of elements in each interior array shall correspond to the size of the PointTypes array; each element in the interior arrays is of a type defined by the corresponding name in the PointTypes array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPointData Class
PdfPointData Members


PointTypes Property

Xfinium.Pdf.Spatial Namespace > PdfPointData Class : PointTypes Property
Gets or sets the point types.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PointTypes As PdfPointDataType()
'Usage

Dim instance As PdfPointData
Dim value() As PdfPointDataType

instance.PointTypes = value

value = instance.PointTypes
public PdfPointDataType[] PointTypes {get; set;}
public:
property array<PdfPointDataType>^ PointTypes {
   array<PdfPointDataType>^ get();
   void set (    array<PdfPointDataType>^ value);
}

Property Value

An array of names that identify the internal data elements of the individual point arrays in the ExtendedPoints array.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPointData Class
PdfPointData Members


%%PageItemTitle%%

PdfProjectedCoordinateSystem Class
Members

Xfinium.Pdf.Spatial Namespace : PdfProjectedCoordinateSystem Class
Defines a projected coordinate system.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfProjectedCoordinateSystem
   Inherits PdfCoordinateSystem
'Usage

Dim instance As PdfProjectedCoordinateSystem
public class PdfProjectedCoordinateSystem : PdfCoordinateSystem
public ref class PdfProjectedCoordinateSystem : public PdfCoordinateSystem
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfCoordinateSystem
Xfinium.Pdf.Spatial.PdfProjectedCoordinateSystem

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfProjectedCoordinateSystem Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfProjectedCoordinateSystem Class Members
Properties

Xfinium.Pdf.Spatial Namespace : PdfProjectedCoordinateSystem Class

The following tables list the members exposed by PdfProjectedCoordinateSystem.

Public Constructors
 | Name | Description
Public Constructor | PdfProjectedCoordinateSystem Constructor | Initializes a new PdfProjectedCoordinateSystem object.
Top
Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code. (Inherited from Xfinium.Pdf.Spatial.PdfCoordinateSystem)
Public Property | WellKnownText | Gets or sets the wekk known text. (Inherited from Xfinium.Pdf.Spatial.PdfCoordinateSystem)
Top
See Also

Reference

PdfProjectedCoordinateSystem Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfProjectedCoordinateSystem Constructor

Xfinium.Pdf.Spatial Namespace > PdfProjectedCoordinateSystem Class : PdfProjectedCoordinateSystem Constructor
Initializes a new PdfProjectedCoordinateSystem object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfProjectedCoordinateSystem()
public PdfProjectedCoordinateSystem()
public:
PdfProjectedCoordinateSystem();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfProjectedCoordinateSystem Class
PdfProjectedCoordinateSystem Members


%%PageItemTitle%%

PdfRectilinearMeasure Class
Members

Xfinium.Pdf.Spatial Namespace : PdfRectilinearMeasure Class
Defines a rectilinear measure.
Object Model
PdfRectilinearMeasure ClassPdfNumberFormatCollection ClassPdfNumberFormat ClassPdfNumberFormatCollection ClassPdfNumberFormat ClassPdfNumberFormatCollection ClassPdfNumberFormat ClassPdfPoint ClassPdfNumberFormatCollection ClassPdfNumberFormat ClassPdfNumberFormatCollection ClassPdfNumberFormat ClassPdfNumberFormatCollection ClassPdfNumberFormat Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfRectilinearMeasure
   Inherits PdfMeasure
'Usage

Dim instance As PdfRectilinearMeasure
public class PdfRectilinearMeasure : PdfMeasure
public ref class PdfRectilinearMeasure : public PdfMeasure
Remarks
The rectilinear measure defines a rectilinear coordinate system. A rectilinear coordinate system is defined as one in which the x and y axes are perpendicular and have units that increment linearly (to the right and up, respectively).
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfMeasure
Xfinium.Pdf.Spatial.PdfRectilinearMeasure

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfRectilinearMeasure Class Members
Properties

Xfinium.Pdf.Spatial Namespace : PdfRectilinearMeasure Class

The following tables list the members exposed by PdfRectilinearMeasure.

Public Constructors
 | Name | Description
Public Constructor | PdfRectilinearMeasure Constructor | Initializes a new PdfRectilinearMeasure object.
Top
Public Properties
 | Name | Description
Public Property | Angle | Gets or sets the number formats for angles.
Public Property | Area | Gets or sets the number formats for area.
Public Property | CXY | Gets or sets the conversion factor.
Public Property | Distance | Gets or sets the number formats for distance.
Public Property | Origin | Gets or sets the origin of the measurement coordinate system.
Public Property | ScaleRatio | Gets or sets the scale ratio.
Public Property | Slope | Gets or sets the number formats for slopes.
Public Property | X | Gets or sets the number formats for X axis.
Public Property | Y | Gets or sets the number formats for Y axis.
Top
See Also

Reference

PdfRectilinearMeasure Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfRectilinearMeasure Constructor

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : PdfRectilinearMeasure Constructor
Initializes a new PdfRectilinearMeasure object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfRectilinearMeasure()
public PdfRectilinearMeasure()
public:
PdfRectilinearMeasure();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


%%PageItemTitle%% $$Properties$$

PdfRectilinearMeasure Class Properties

Xfinium.Pdf.Spatial Namespace : PdfRectilinearMeasure Class

For a list of all members of this type, see PdfRectilinearMeasure members.

Public Properties
 | Name | Description
Public Property | Angle | Gets or sets the number formats for angles.
Public Property | Area | Gets or sets the number formats for area.
Public Property | CXY | Gets or sets the conversion factor.
Public Property | Distance | Gets or sets the number formats for distance.
Public Property | Origin | Gets or sets the origin of the measurement coordinate system.
Public Property | ScaleRatio | Gets or sets the scale ratio.
Public Property | Slope | Gets or sets the number formats for slopes.
Public Property | X | Gets or sets the number formats for X axis.
Public Property | Y | Gets or sets the number formats for Y axis.
Top
See Also

Reference

PdfRectilinearMeasure Class
Xfinium.Pdf.Spatial Namespace


Angle Property

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : Angle Property
Gets or sets the number formats for angles.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Angle As PdfNumberFormatCollection
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As PdfNumberFormatCollection

instance.Angle = value

value = instance.Angle
public PdfNumberFormatCollection Angle {get; set;}
public:
property PdfNumberFormatCollection^ Angle {
   PdfNumberFormatCollection^ get();
   void set (    PdfNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of angles.
Remarks
The first element in the collection shall specify the conversion to the largest angle unit from degrees. The scale factor from CXY (if present) shall be used to convert from default PDF units to the appropriate units before applying the angle function.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


Area Property

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : Area Property
Gets or sets the number formats for area.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Area As PdfNumberFormatCollection
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As PdfNumberFormatCollection

instance.Area = value

value = instance.Area
public PdfNumberFormatCollection Area {get; set;}
public:
property PdfNumberFormatCollection^ Area {
   PdfNumberFormatCollection^ get();
   void set (    PdfNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of area.
Remarks
The first element in the collection shall specify the conversion to the largest area unit from units represented by the first element in X, squared. The scale factors from X, Y (if present) and CXY (if Y is present) shall be used to convert from default PDF units to the appropriate units before applying the area function.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


CXY Property

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : CXY Property
Gets or sets the conversion factor.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CXY As Double
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As Double

instance.CXY = value

value = instance.CXY
public double CXY {get; set;}
public:
property double CXY {
   double get();
   void set (    double value);
}

Property Value

A factor that shall be used to convert the largest units along the y axis to the largest units along the x axis.
Remarks
It shall be used for calculations (distance, area, and angle) where the units are be equivalent; if not specified, these calculations may not be performed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


Distance Property

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : Distance Property
Gets or sets the number formats for distance.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Distance As PdfNumberFormatCollection
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As PdfNumberFormatCollection

instance.Distance = value

value = instance.Distance
public PdfNumberFormatCollection Distance {get; set;}
public:
property PdfNumberFormatCollection^ Distance {
   PdfNumberFormatCollection^ get();
   void set (    PdfNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of distance in any direction.
Remarks
The first element in the collection shall specify the conversion to the largest distance unit from units represented by the first element in X. The scale factors from X, Y (if present) and CXY (if Y is present) shall be used to convert from default PDF units to the appropriate units before applying the distance function.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


Origin Property

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : Origin Property
Gets or sets the origin of the measurement coordinate system.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Origin As PdfPoint
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As PdfPoint

value = instance.Origin
public PdfPoint Origin {get;}
public:
property PdfPoint^ Origin {
   PdfPoint^ get();
}

Property Value

A point that specifies the origin of the measurement coordinate system in default PDF coordinate system (the same coordinate system used for defining the PdfViewport.Bounds.)
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


ScaleRatio Property

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : ScaleRatio Property
Gets or sets the scale ratio.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ScaleRatio As String
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As String

instance.ScaleRatio = value

value = instance.ScaleRatio
public string ScaleRatio {get; set;}
public:
property String^ ScaleRatio {
   String^ get();
   void set (    String^ value);
}

Property Value

A text string expressing the scale ratio of the drawing in the region corresponding to this object.
Remarks
Universally recognized unit abbreviations should be used, either matching those of the number format collections in this object or those of commonly used scale ratios.
For example: 1/4 in = 1 ft
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


Slope Property

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : Slope Property
Gets or sets the number formats for slopes.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Slope As PdfNumberFormatCollection
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As PdfNumberFormatCollection

instance.Slope = value

value = instance.Slope
public PdfNumberFormatCollection Slope {get; set;}
public:
property PdfNumberFormatCollection^ Slope {
   PdfNumberFormatCollection^ get();
   void set (    PdfNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of the slope of a line.
Remarks
The first element in the collection shall specify the conversion to the largest slope unit from units represented by the first element in Y divided by the first element in X. The scale factors from X, Y (if present) and CXY (if Y is present) shall be used to convert from default PDF units to the appropriate units before applying the slope function.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


X Property (PdfRectilinearMeasure)

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : X Property
Gets or sets the number formats for X axis.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property X As PdfNumberFormatCollection
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As PdfNumberFormatCollection

instance.X = value

value = instance.X
public PdfNumberFormatCollection X {get; set;}
public:
property PdfNumberFormatCollection^ X {
   PdfNumberFormatCollection^ get();
   void set (    PdfNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of change along the x axis and, if Y is not present, along the y axis as well.
Remarks
The first element in the array shall contain the scale factor for converting from default user space units to the largest units in the measuring coordinate system along that axis.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


Y Property (PdfRectilinearMeasure)

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : Y Property
Gets or sets the number formats for Y axis.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Y As PdfNumberFormatCollection
'Usage

Dim instance As PdfRectilinearMeasure
Dim value As PdfNumberFormatCollection

instance.Y = value

value = instance.Y
public PdfNumberFormatCollection Y {get; set;}
public:
property PdfNumberFormatCollection^ Y {
   PdfNumberFormatCollection^ get();
   void set (    PdfNumberFormatCollection^ value);
}

Property Value

A number format collection for measurement of change along the y.
Remarks
The first element in the array shall contain the scale factor for converting from default user space units to the largest units in the measuring coordinate system along the Y axis.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


%%PageItemTitle%%

PdfViewport Class
Members

Xfinium.Pdf.Spatial Namespace : PdfViewport Class
Defines a rectangular region of a page that supports a different measurement scale.
Object Model
PdfViewport ClassPdfStandardRectangle ClassPdfMeasure ClassPdfPointData Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfViewport
'Usage

Dim instance As PdfViewport
public class PdfViewport
public ref class PdfViewport
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Spatial.PdfViewport

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewport Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfViewport Class Members
Properties

Xfinium.Pdf.Spatial Namespace : PdfViewport Class

The following tables list the members exposed by PdfViewport.

Public Constructors
 | Name | Description
Public Constructor | PdfViewport Constructor | Initializes a new PdfViewport object.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the viewport bounds.
Public Property | Measure | Gets or sets the viewport measure.
Public Property | Name | Gets or sets the viewport name.
Public Property | PointData | Gets or sets the point data.
Top
See Also

Reference

PdfViewport Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfViewport Constructor

Xfinium.Pdf.Spatial Namespace > PdfViewport Class : PdfViewport Constructor
Initializes a new PdfViewport object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfViewport()
public PdfViewport()
public:
PdfViewport();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewport Class
PdfViewport Members


%%PageItemTitle%% $$Properties$$

PdfViewport Class Properties

Xfinium.Pdf.Spatial Namespace : PdfViewport Class

For a list of all members of this type, see PdfViewport members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the viewport bounds.
Public Property | Measure | Gets or sets the viewport measure.
Public Property | Name | Gets or sets the viewport name.
Public Property | PointData | Gets or sets the point data.
Top
See Also

Reference

PdfViewport Class
Xfinium.Pdf.Spatial Namespace


Bounds Property (PdfViewport)

Xfinium.Pdf.Spatial Namespace > PdfViewport Class : Bounds Property
Gets or sets the viewport bounds.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Bounds As PdfStandardRectangle
'Usage

Dim instance As PdfViewport
Dim value As PdfStandardRectangle

instance.Bounds = value

value = instance.Bounds
public PdfStandardRectangle Bounds {get; set;}
public:
property PdfStandardRectangle^ Bounds {
   PdfStandardRectangle^ get();
   void set (    PdfStandardRectangle^ value);
}

Property Value

A Xfinium.Pdf.Graphics.PdfStandardRectangle that defines the viewport area.
Remarks
The lower left and upper right corners of the rectangle determine the orientation of the measuring coordinate system (that is, the direction of the positive x and yaxes) in this viewport, which may have a different rotation from the page.
The viewport bounds are defined in the same coordinate system like the page media box and crop box.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewport Class
PdfViewport Members


Measure Property (PdfViewport)

Xfinium.Pdf.Spatial Namespace > PdfViewport Class : Measure Property
Gets or sets the viewport measure.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Measure As PdfMeasure
'Usage

Dim instance As PdfViewport
Dim value As PdfMeasure

instance.Measure = value

value = instance.Measure
public PdfMeasure Measure {get; set;}
public:
property PdfMeasure^ Measure {
   PdfMeasure^ get();
   void set (    PdfMeasure^ value);
}

Property Value

The viewport measure.
Remarks
The measure specifies the alternative coordinate system for the viewport. It provides the information needed to convert coordinates in the page's coordinate system to coordinates in the measuring coordinate system.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewport Class
PdfViewport Members


Name Property (PdfViewport)

Xfinium.Pdf.Spatial Namespace > PdfViewport Class : Name Property
Gets or sets the viewport name.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As PdfViewport
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the viewport to be displayed in the user interface.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewport Class
PdfViewport Members


PointData Property (PdfViewport)

Xfinium.Pdf.Spatial Namespace > PdfViewport Class : PointData Property
Gets or sets the point data.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PointData As PdfPointData
'Usage

Dim instance As PdfViewport
Dim value As PdfPointData

instance.PointData = value

value = instance.PointData
public PdfPointData PointData {get; set;}
public:
property PdfPointData^ PointData {
   PdfPointData^ get();
   void set (    PdfPointData^ value);
}

Property Value

The point data that specifies extended geospatial data.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewport Class
PdfViewport Members


%%PageItemTitle%%

PdfViewportCollection Class
Members

Xfinium.Pdf.Spatial Namespace : PdfViewportCollection Class
Defines a collection of Pdf viewports.
Object Model
PdfViewportCollection ClassPdfViewport Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfViewportCollection
   Inherits System.Collections.ObjectModel.Collection(Of PdfViewport)
'Usage

Dim instance As PdfViewportCollection
public class PdfViewportCollection : System.Collections.ObjectModel.Collection<PdfViewport>
public ref class PdfViewportCollection : public System.Collections.ObjectModel.Collection<PdfViewport>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Xfinium.Pdf.Spatial.PdfViewportCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewportCollection Members
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Members$$

PdfViewportCollection Class Members
Properties Methods

Xfinium.Pdf.Spatial Namespace : PdfViewportCollection Class

The following tables list the members exposed by PdfViewportCollection.

Public Constructors
 | Name | Description
Public Constructor | PdfViewportCollection Constructor | Initializes a new PdfViewportCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Top
See Also

Reference

PdfViewportCollection Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfViewportCollection Constructor

Xfinium.Pdf.Spatial Namespace > PdfViewportCollection Class : PdfViewportCollection Constructor
Initializes a new PdfViewportCollection object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfViewportCollection()
public PdfViewportCollection()
public:
PdfViewportCollection();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewportCollection Class
PdfViewportCollection Members


%%PageItemTitle%%

PdfFractionDisplay Enumeration

Xfinium.Pdf.Spatial Namespace : PdfFractionDisplay Enumeration
Specifies the supported display modes for a fractional value.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfFractionDisplay
   Inherits System.Enum
'Usage

Dim instance As PdfFractionDisplay
public enum PdfFractionDisplay : System.Enum
public enum class PdfFractionDisplay : public System.Enum
Members
Member | Description
Decimal | Show as decimal to the precision defined by the PdfNumberFormat.Precision property.
Fraction | Show as a fraction with denominator specified by the PdfNumberFormat.Denominator property.
Round | No fractional part; round to the nearest whole unit.
Truncate | No fractional part; truncate to achieve whole units.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Spatial.PdfFractionDisplay

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfPointDataType Enumeration

Xfinium.Pdf.Spatial Namespace : PdfPointDataType Enumeration
Specifies the supported types for values in a PdfPointData object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPointDataType
   Inherits System.Enum
'Usage

Dim instance As PdfPointDataType
public enum PdfPointDataType : System.Enum
public enum class PdfPointDataType : public System.Enum
Members
Member | Description
Altitude | The value represents altitude.
Latitude | The value represents latitude.
Longitude | The value represents longitude.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Spatial.PdfPointDataType

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfPreferredDisplayUnit Enumeration

Xfinium.Pdf.Spatial Namespace : PdfPreferredDisplayUnit Enumeration
Specifies the supported values for preferred display units.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfPreferredDisplayUnit
   Inherits System.Enum
'Usage

Dim instance As PdfPreferredDisplayUnit
public enum PdfPreferredDisplayUnit : System.Enum
public enum class PdfPreferredDisplayUnit : public System.Enum
Members
Member | Description
Acre | An acre.
Degree | A degree.
Foot | An international foot.
Grad | A grad (1/400 of a circle or 0.9 degrees).
Hectare | A hectare (10000 square metres).
Kilometre | A kilometre.
Metre | A metre.
Mile | An international mile.
NauticalMile | An international nautical mile.
SquareKilometre | A square kilometre.
SquareMetre | A square metre.
SquareMile | A square international mile.
SquareUSFoot | A square U.S. Survey foot.
USFoot | A U.S. Survey foot.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Spatial.PdfPreferredDisplayUnit

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Spatial Namespace


Xfinium.Pdf.Standards Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfAAggregateException | Represents one or more errors that occur during PDF/A formatting of a PDF document.
Class | PdfAException | Defines an exception that can be thrown while a document is formatted using PDF/A standard.
Class | PdfAExceptionCollection | Defines a read only collection of PDF/A exceptions.
Class | PdfAFormatter | Defines a formatter that can save PDF files in PDF/A format.
Enumerations
 | Enumeration | Description
Enumeration | PdfAError | Possible errors that can be detected in a document that needs to be formatted in PDF/A standard.
Enumeration | PdfAFormat | Supported PDF/A standards.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Standards Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Standards.PdfAExceptionCollection
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Standards.PdfAException
Xfinium.Pdf.Standards.PdfAAggregateException
Xfinium.Pdf.Standards.PdfAFormatter
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfAAggregateException Class
Members

Xfinium.Pdf.Standards Namespace : PdfAAggregateException Class
Represents one or more errors that occur during PDF/A formatting of a PDF document.
Object Model
PdfAAggregateException ClassPdfAExceptionCollection ClassPdfAException Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAAggregateException
   Inherits PdfAException
'Usage

Dim instance As PdfAAggregateException
public class PdfAAggregateException : PdfAException
public ref class PdfAAggregateException : public PdfAException
Inheritance Hierarchy

System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Standards.PdfAException
Xfinium.Pdf.Standards.PdfAAggregateException

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAAggregateException Members
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Members$$

PdfAAggregateException Class Members
Properties Methods

Xfinium.Pdf.Standards Namespace : PdfAAggregateException Class

The following tables list the members exposed by PdfAAggregateException.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the error code. (Inherited from Xfinium.Pdf.Standards.PdfAException)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | InnerExceptions | Gets the collection of inner exceptions.
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfAAggregateException Class
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Properties$$

PdfAAggregateException Class Properties

Xfinium.Pdf.Standards Namespace : PdfAAggregateException Class

For a list of all members of this type, see PdfAAggregateException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the error code. (Inherited from Xfinium.Pdf.Standards.PdfAException)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | InnerExceptions | Gets the collection of inner exceptions.
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PdfAAggregateException Class
Xfinium.Pdf.Standards Namespace


InnerExceptions Property

Xfinium.Pdf.Standards Namespace > PdfAAggregateException Class : InnerExceptions Property
Gets the collection of inner exceptions.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property InnerExceptions As PdfAExceptionCollection
'Usage

Dim instance As PdfAAggregateException
Dim value As PdfAExceptionCollection

value = instance.InnerExceptions
public PdfAExceptionCollection InnerExceptions {get;}
public:
property PdfAExceptionCollection^ InnerExceptions {
   PdfAExceptionCollection^ get();
}
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAAggregateException Class
PdfAAggregateException Members


%%PageItemTitle%%

PdfAException Class
Members

Xfinium.Pdf.Standards Namespace : PdfAException Class
Defines an exception that can be thrown while a document is formatted using PDF/A standard.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAException
   Inherits Xfinium.Pdf.Core.Exceptions.PdfException
'Usage

Dim instance As PdfAException
public class PdfAException : Xfinium.Pdf.Core.Exceptions.PdfException
public ref class PdfAException : public Xfinium.Pdf.Core.Exceptions.PdfException
Inheritance Hierarchy

System.Object
System.Exception
Xfinium.Pdf.Core.Exceptions.PdfException
Xfinium.Pdf.Standards.PdfAException
Xfinium.Pdf.Standards.PdfAAggregateException

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAException Members
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Members$$

PdfAException Class Members
Properties Methods

Xfinium.Pdf.Standards Namespace : PdfAException Class

The following tables list the members exposed by PdfAException.

Public Constructors
 | Name | Description
Public Constructor | PdfAException Constructor | Initializes a new PdfAException message.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the error code.
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfAException Class
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%%

PdfAException Constructor

Xfinium.Pdf.Standards Namespace > PdfAException Class : PdfAException Constructor
Error code.
The exception message.
Initializes a new PdfAException message.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal errorCode As PdfAError, _
   ByVal message As String _
)
'Usage

Dim errorCode As PdfAError
Dim message As String

Dim instance As New PdfAException(errorCode, message)
public PdfAException(
   PdfAError errorCode,
   string message
)
public:
PdfAException(
   PdfAError errorCode,
   String^ message
)

Parameters

errorCode
Error code.
message
The exception message.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAException Class
PdfAException Members


%%PageItemTitle%% $$Properties$$

PdfAException Class Properties

Xfinium.Pdf.Standards Namespace : PdfAException Class

For a list of all members of this type, see PdfAException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the error code.
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PdfAException Class
Xfinium.Pdf.Standards Namespace


ErrorCode Property

Xfinium.Pdf.Standards Namespace > PdfAException Class : ErrorCode Property
Gets the error code.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ErrorCode As PdfAError
'Usage

Dim instance As PdfAException
Dim value As PdfAError

value = instance.ErrorCode
public PdfAError ErrorCode {get;}
public:
property PdfAError ErrorCode {
   PdfAError get();
}

Property Value

A PdfAError code specifying the error encountered during PDF/A formatting.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAException Class
PdfAException Members


%%PageItemTitle%%

PdfAExceptionCollection Class
Members

Xfinium.Pdf.Standards Namespace : PdfAExceptionCollection Class
Defines a read only collection of PDF/A exceptions.
Object Model
PdfAExceptionCollection ClassPdfAException Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAExceptionCollection
   Inherits System.Collections.ObjectModel.ReadOnlyCollection(Of PdfAException)
'Usage

Dim instance As PdfAExceptionCollection
public class PdfAExceptionCollection : System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>
public ref class PdfAExceptionCollection : public System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<T>
Xfinium.Pdf.Standards.PdfAExceptionCollection

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAExceptionCollection Members
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Members$$

PdfAExceptionCollection Class Members
Properties Methods

Xfinium.Pdf.Standards Namespace : PdfAExceptionCollection Class

The following tables list the members exposed by PdfAExceptionCollection.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Top
Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Top
See Also

Reference

PdfAExceptionCollection Class
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%%

PdfAFormatter Class
Members

Xfinium.Pdf.Standards Namespace : PdfAFormatter Class
Defines a formatter that can save PDF files in PDF/A format.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfAFormatter
'Usage

Dim instance As PdfAFormatter
public class PdfAFormatter
public ref class PdfAFormatter
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Standards.PdfAFormatter

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAFormatter Members
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Members$$

PdfAFormatter Class Members
Methods

Xfinium.Pdf.Standards Namespace : PdfAFormatter Class

The following tables list the members exposed by PdfAFormatter.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Save | Saves the document to the stream in the specified PDF/A format.
Top
See Also

Reference

PdfAFormatter Class
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Methods$$

PdfAFormatter Class Methods

Xfinium.Pdf.Standards Namespace : PdfAFormatter Class

For a list of all members of this type, see PdfAFormatter members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Save | Saves the document to the stream in the specified PDF/A format.
Top
See Also

Reference

PdfAFormatter Class
Xfinium.Pdf.Standards Namespace


Save Method (PdfAFormatter)

Xfinium.Pdf.Standards Namespace > PdfAFormatter Class : Save Method
The document to save.
Destination stream where the document is saved.
PDF/A format for the saved document.
Saves the document to the stream in the specified PDF/A format.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Sub Save( _
   ByVal document As PdfFixedDocument, _
   ByVal stream As Stream, _
   ByVal format As PdfAFormat _
)
'Usage

Dim document As PdfFixedDocument
Dim stream As Stream
Dim format As PdfAFormat

PdfAFormatter.Save(document, stream, format)
public static void Save(
   PdfFixedDocument document,
   Stream stream,
   PdfAFormat format
)
public:
static void Save(
   PdfFixedDocument^ document,
   Stream^ stream,
   PdfAFormat format
)

Parameters

document
The document to save.
stream
Destination stream where the document is saved.
format
PDF/A format for the saved document.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAFormatter Class
PdfAFormatter Members


%%PageItemTitle%%

PdfAError Enumeration

Xfinium.Pdf.Standards Namespace : PdfAError Enumeration
Possible errors that can be detected in a document that needs to be formatted in PDF/A standard.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfAError
   Inherits System.Enum
'Usage

Dim instance As PdfAError
public enum PdfAError : System.Enum
public enum class PdfAError : public System.Enum
Members
Member | Description
AnnotationActionTypeIsNotAllowed | Annotation action type is not allowed in a PDF/A-1 document.
AnnotationAdditionalActionsAreNotAllowed | Annotation additional actions are not allowed in a PDF/A-1 document.
AnnotationAppearanceIsInvalid | Annotation normal appearance must be a form XObject in a PDF/A-1 document.
AnnotationAppearancesAreNotAllowed | Annotation can have only the normal appearance in a PDF/A-1 document.
AnnotationColorIsNotRgb | The annotation color must be a color RGB in a PDF/A-1 document.
AnnotationFKeyIsMissing | The /F (Flags) key in annotation dictionary is mandatory in a PDF/A-1 document.
AnnotationInteriorColorIsNotRgb | The annotation interior color must be a color RGB in a PDF/A-1 document.
AnnotationIsHidden | Annotation cannot be marked as hidden in a PDF/A-1 document.
AnnotationIsNotPrintable | Annotation must be marked as printable in a PDF/A-1 document.
AnnotationIsNotVisible | Annotation must be marked as visible in a PDF/A-1 document.
AnnotationNormalAppearanceIsMissing | Annotation must have a normal appearance set in a PDF/A-1 document.
AnnotationOpacityIsNotAllowed | Annotation opacity level less than 100% is not allowed in a PDF/A-1 document.
AnnotationTypeIsNotAllowed | The annotation type is not allowed in a PDF/A-1 document.
CmykOutputProfileDoesNotMatchDocumentContent | A CMYK color profile must be present in a PDF/A-1 document's OutputIntents when CMYK colors are used in the content.
DocumentAcroFormNeedAppearancesKeyIsNotAllowed | The /NeedAppearances key in AcroForm dictionary cannot be set to true in a PDF/A-1 document.
DocumentAdditionalActionsAreNotAllowed | Document additional actions are not allowed in a PDF/A-1 document.
DocumentAttachmentsAreNotAllowed | Document attachments (embedded files) are not allowed in a PDF/A-1 document.
DocumentMetadataIsMissing | Metadata is mising from the document.
DocumentOpenActionTypeIsNotAllowed | The type of the document open action is not allowed in a PDF/A-1 document.
ExtendedGraphicStateAlphaChannelIsNotAllowed | Alpha channels are not allowed in extended graphic state objects in a PDF/A-1 document.
ExtendedGraphicStateBlendModeIsNotAllowed | Blend modes are not allowed in extended graphic state objects in a PDF/A-1 document.
ExtendedGraphicStateRenderingIntentIsNotAllowed | /Rendering intent is not allowed in extended graphic state objects in a PDF/A-1 document.
ExtendedGraphicStateSoftMaskIsNotAllowed | Soft masks are not allowed in extended graphic state objects in a PDF/A-1 document.
ExtendedGraphicStateTR2KeyIsNotAllowed | /TR2 key is not allowed in extended graphic state objects in a PDF/A-1 document.
ExtendedGraphicStateTRKeyIsNotAllowed | /TR key is not allowed in extended graphic state objects in a PDF/A-1 document.
FieldAdditionalActionsAreNotAllowed | Field additional actions are not allowed in a PDF/A-1 document.
FieldWidgetActionIsNotAllowed | Field widget actions are not allowed in a PDF/A-1 document.
FieldWidgetAdditionalActionsAreNotAllowed | Field widget additional actions are not allowed in a PDF/A-1 document.
FieldWidgetAppearanceIsMissing | The appearance is missing from a field widget.
ImageAlternatesKeyIsNotAllowed | /Alternates key is not allowed in an image object in a PDF/A-1 document.
ImageInterpolateKeyIsNotAllowed | /Interpolate key is not allowed in an image object in a PDF/A-1 document.
ImageOPIKeyIsNotAllowed | /OPI key is not allowed in an image object in a PDF/A-1 document.
ImageRenderingIntentIsNotAllowed | /Rendering intent is not allowed in image objects in a PDF/A-1 document.
InvalidPdfADocument | The document cannot be formatted using PDF/A standard.
OptionalContentIsNotAllowed | Optional content is not allowed in a PDF/A-1 document.
PostScriptFormXObjectIsNotAllowed | PostScript form XObjects are not allowed in a PDF/A-1 document.
RgbCmykMixIsNotAllowed | RGB and CMYK colors cannot be used in the same time in a PDF/A-1 document.
RgbOutputProfileDoesNotMatchDocumentContent | A RGB color profile must be present in a PDF/A-1 document's OutputIntents when RGB colors are used in the content.
StandardPdfFontIsNotAllowed | Standard base 14 PDF fonts are not allowed in a PDF/A-1 document.
TextAnnotationCanBeRotated | Text annotation cannot be rotated in a PDF/A-1 document.
TextAnnotationCanBeZoomed | Text annotation cannot be zoomed in a PDF/A-1 document.
TrueTypeFontIsNotEmbedded | TrueType fonts must be embedded in a PDF/A-1 document.
Type0FontIsNotEmbedded | Type0 fonts must be embedded in a PDF/A-1 document.
Type1FontIsNotEmbedded | Type1 fonts must be embedded in a PDF/A-1 document.
XObjectOPIKeyIsNotAllowed | /OPI key is not allowed in a form XObject in a PDF/A-1 document.
XObjectPSKeyIsNotAllowed | /PS key is not allowed in a form XObject in a PDF/A-1 document.
XObjectRefKeyIsNotAllowed | /Ref key is not allowed in a PDF/A-1 document.
XObjectSoftMaskIsNotAllowed | A form XObject cannot have a softmask in a PDF/A-1 document.
XObjectSubtype2KeyIsNotAllowed | /Subtype2 key is not allowed in a form XObject in a PDF/A-1 document.
XObjectTransparencyGroupIsNotAllowed | An image or a form XObject cannot have a transparency group in a PDF/A-1 document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Standards.PdfAError

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Standards Namespace


%%PageItemTitle%%

PdfAFormat Enumeration

Xfinium.Pdf.Standards Namespace : PdfAFormat Enumeration
Supported PDF/A standards.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum PdfAFormat
   Inherits System.Enum
'Usage

Dim instance As PdfAFormat
public enum PdfAFormat : System.Enum
public enum class PdfAFormat : public System.Enum
Members
Member | Description
PdfA1b | PDF/A-1b format.
PdfA2b | PDF/A-2b format.
PdfA2u | PDF/A-2u format.
PdfA3b | PDF/A-3b format.
PdfA3u | PDF/A-3u format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xfinium.Pdf.Standards.PdfAFormat

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Xfinium.Pdf.Standards Namespace


Xfinium.Pdf.Transforms Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | PdfConvertImagesToGrayTransform | Defines a page transformation that converts all images on the page to gray.
Class | PdfConvertToCmykTransform | Defines a page transformation that converts all colors on a PDF page to CMYK.
Class | PdfConvertToGrayTransform | Defines a page transformation that converts all colors on a PDF page to gray.
Class | PdfConvertToRgbTransform | Defines a page transformation that converts all colors on a PDF page to RGB.
Class | PdfPageTransform | Defines the base class for page transformations.
Class | PdfPageTransformer | Defines a transformer for page content.
Class | PdfReplaceImageEventArgs | Defines the arguments for PdfReplaceImageTransform.ReplaceImage event.
Class | PdfReplaceImageTransform | Defines a page transformation that allows to replace an image with another image.
See Also

Reference

XFINIUM.PDF Library


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Xfinium.Pdf.Transforms Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
System.EventArgs
Xfinium.Pdf.Transforms.PdfReplaceImageEventArgs
Xfinium.Pdf.Transforms.PdfPageTransform
Xfinium.Pdf.Transforms.PdfConvertImagesToGrayTransform
Xfinium.Pdf.Transforms.PdfConvertToCmykTransform
Xfinium.Pdf.Transforms.PdfConvertToGrayTransform
Xfinium.Pdf.Transforms.PdfConvertToRgbTransform
Xfinium.Pdf.Transforms.PdfReplaceImageTransform
Xfinium.Pdf.Transforms.PdfPageTransformer
See Also

Reference

XFINIUM.PDF Library


%%PageItemTitle%%

PdfConvertImagesToGrayTransform Class
Members

Xfinium.Pdf.Transforms Namespace : PdfConvertImagesToGrayTransform Class
Defines a page transformation that converts all images on the page to gray.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfConvertImagesToGrayTransform
   Inherits PdfPageTransform
'Usage

Dim instance As PdfConvertImagesToGrayTransform
public class PdfConvertImagesToGrayTransform : PdfPageTransform
public ref class PdfConvertImagesToGrayTransform : public PdfPageTransform
Remarks
The 1bpp B/W images and image masks are not changed.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Transforms.PdfPageTransform
Xfinium.Pdf.Transforms.PdfConvertImagesToGrayTransform

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConvertImagesToGrayTransform Members
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Members$$

PdfConvertImagesToGrayTransform Class Members
Properties

Xfinium.Pdf.Transforms Namespace : PdfConvertImagesToGrayTransform Class

The following tables list the members exposed by PdfConvertImagesToGrayTransform.

Public Constructors
 | Name | Description
Public Constructor | PdfConvertImagesToGrayTransform Constructor | Initializes a new PdfConvertImagesToGrayTransform object.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Top
See Also

Reference

PdfConvertImagesToGrayTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%%

PdfConvertImagesToGrayTransform Constructor

Xfinium.Pdf.Transforms Namespace > PdfConvertImagesToGrayTransform Class : PdfConvertImagesToGrayTransform Constructor
Initializes a new PdfConvertImagesToGrayTransform object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfConvertImagesToGrayTransform()
public PdfConvertImagesToGrayTransform()
public:
PdfConvertImagesToGrayTransform();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConvertImagesToGrayTransform Class
PdfConvertImagesToGrayTransform Members


%%PageItemTitle%%

PdfConvertToCmykTransform Class
Members

Xfinium.Pdf.Transforms Namespace : PdfConvertToCmykTransform Class
Defines a page transformation that converts all colors on a PDF page to CMYK.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfConvertToCmykTransform
   Inherits PdfPageTransform
'Usage

Dim instance As PdfConvertToCmykTransform
public class PdfConvertToCmykTransform : PdfPageTransform
public ref class PdfConvertToCmykTransform : public PdfPageTransform
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Transforms.PdfPageTransform
Xfinium.Pdf.Transforms.PdfConvertToCmykTransform

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConvertToCmykTransform Members
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Members$$

PdfConvertToCmykTransform Class Members
Properties

Xfinium.Pdf.Transforms Namespace : PdfConvertToCmykTransform Class

The following tables list the members exposed by PdfConvertToCmykTransform.

Public Constructors
 | Name | Description
Public Constructor | PdfConvertToCmykTransform Constructor | Initializes a new PdfConvertToCmykTransform object.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Top
See Also

Reference

PdfConvertToCmykTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%%

PdfConvertToCmykTransform Constructor

Xfinium.Pdf.Transforms Namespace > PdfConvertToCmykTransform Class : PdfConvertToCmykTransform Constructor
Initializes a new PdfConvertToCmykTransform object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfConvertToCmykTransform()
public PdfConvertToCmykTransform()
public:
PdfConvertToCmykTransform();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConvertToCmykTransform Class
PdfConvertToCmykTransform Members


%%PageItemTitle%%

PdfConvertToGrayTransform Class
Members

Xfinium.Pdf.Transforms Namespace : PdfConvertToGrayTransform Class
Defines a page transformation that converts all colors on a PDF page to gray.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfConvertToGrayTransform
   Inherits PdfPageTransform
'Usage

Dim instance As PdfConvertToGrayTransform
public class PdfConvertToGrayTransform : PdfPageTransform
public ref class PdfConvertToGrayTransform : public PdfPageTransform
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Transforms.PdfPageTransform
Xfinium.Pdf.Transforms.PdfConvertToGrayTransform

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConvertToGrayTransform Members
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Members$$

PdfConvertToGrayTransform Class Members
Properties

Xfinium.Pdf.Transforms Namespace : PdfConvertToGrayTransform Class

The following tables list the members exposed by PdfConvertToGrayTransform.

Public Constructors
 | Name | Description
Public Constructor | PdfConvertToGrayTransform Constructor | Initializes a new PdfConvertToGrayTransform object.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Top
See Also

Reference

PdfConvertToGrayTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%%

PdfConvertToGrayTransform Constructor

Xfinium.Pdf.Transforms Namespace > PdfConvertToGrayTransform Class : PdfConvertToGrayTransform Constructor
Initializes a new PdfConvertToGrayTransform object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfConvertToGrayTransform()
public PdfConvertToGrayTransform()
public:
PdfConvertToGrayTransform();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConvertToGrayTransform Class
PdfConvertToGrayTransform Members


%%PageItemTitle%%

PdfConvertToRgbTransform Class
Members

Xfinium.Pdf.Transforms Namespace : PdfConvertToRgbTransform Class
Defines a page transformation that converts all colors on a PDF page to RGB.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfConvertToRgbTransform
   Inherits PdfPageTransform
'Usage

Dim instance As PdfConvertToRgbTransform
public class PdfConvertToRgbTransform : PdfPageTransform
public ref class PdfConvertToRgbTransform : public PdfPageTransform
Remarks
Gray colors and images and image masks are not changed.
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Transforms.PdfPageTransform
Xfinium.Pdf.Transforms.PdfConvertToRgbTransform

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConvertToRgbTransform Members
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Members$$

PdfConvertToRgbTransform Class Members
Properties

Xfinium.Pdf.Transforms Namespace : PdfConvertToRgbTransform Class

The following tables list the members exposed by PdfConvertToRgbTransform.

Public Constructors
 | Name | Description
Public Constructor | PdfConvertToRgbTransform Constructor | Initializes a new PdfConvertToRgbTransform object.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Top
See Also

Reference

PdfConvertToRgbTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%%

PdfConvertToRgbTransform Constructor

Xfinium.Pdf.Transforms Namespace > PdfConvertToRgbTransform Class : PdfConvertToRgbTransform Constructor
Initializes a new PdfConvertToRgbTransform object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfConvertToRgbTransform()
public PdfConvertToRgbTransform()
public:
PdfConvertToRgbTransform();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfConvertToRgbTransform Class
PdfConvertToRgbTransform Members


%%PageItemTitle%%

PdfPageTransform Class
Members

Xfinium.Pdf.Transforms Namespace : PdfPageTransform Class
Defines the base class for page transformations.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageTransform
'Usage

Dim instance As PdfPageTransform
public class PdfPageTransform
public ref class PdfPageTransform
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Transforms.PdfPageTransform
Xfinium.Pdf.Transforms.PdfConvertImagesToGrayTransform
Xfinium.Pdf.Transforms.PdfConvertToCmykTransform
Xfinium.Pdf.Transforms.PdfConvertToGrayTransform
Xfinium.Pdf.Transforms.PdfConvertToRgbTransform
Xfinium.Pdf.Transforms.PdfReplaceImageTransform

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageTransform Members
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Members$$

PdfPageTransform Class Members
Properties

Xfinium.Pdf.Transforms Namespace : PdfPageTransform Class

The following tables list the members exposed by PdfPageTransform.

Public Constructors
 | Name | Description
Public Constructor | PdfPageTransform Constructor | Initializes a new PdfPageTransform object.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the transform context.
Top
See Also

Reference

PdfPageTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%%

PdfPageTransform Constructor

Xfinium.Pdf.Transforms Namespace > PdfPageTransform Class : PdfPageTransform Constructor
Initializes a new PdfPageTransform object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfPageTransform()
public PdfPageTransform()
public:
PdfPageTransform();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageTransform Class
PdfPageTransform Members


%%PageItemTitle%% $$Properties$$

PdfPageTransform Class Properties

Xfinium.Pdf.Transforms Namespace : PdfPageTransform Class

For a list of all members of this type, see PdfPageTransform members.

Public Properties
 | Name | Description
Public Property | Context | Gets the transform context.
Top
See Also

Reference

PdfPageTransform Class
Xfinium.Pdf.Transforms Namespace


Context Property (PdfPageTransform)

Xfinium.Pdf.Transforms Namespace > PdfPageTransform Class : Context Property
Gets the transform context.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Context As PdfContentStreamContainer
'Usage

Dim instance As PdfPageTransform
Dim value As PdfContentStreamContainer

value = instance.Context
public PdfContentStreamContainer Context {get;}
public:
property PdfContentStreamContainer^ Context {
   PdfContentStreamContainer^ get();
}

Property Value

The content stream container on which the transformation is currently applied.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageTransform Class
PdfPageTransform Members


%%PageItemTitle%%

PdfPageTransformer Class
Members

Xfinium.Pdf.Transforms Namespace : PdfPageTransformer Class
Defines a transformer for page content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfPageTransformer
'Usage

Dim instance As PdfPageTransformer
public class PdfPageTransformer
public ref class PdfPageTransformer
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Transforms.PdfPageTransformer

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageTransformer Members
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Members$$

PdfPageTransformer Class Members
Methods

Xfinium.Pdf.Transforms Namespace : PdfPageTransformer Class

The following tables list the members exposed by PdfPageTransformer.

Public Constructors
 | Name | Description
Public Constructor | PdfPageTransformer Constructor | Initializes a new PdfPageTransformer object.
Top
Public Methods
 | Name | Description
Public Method | ApplyTransform | Applies the specified transformation on the page content.
Top
See Also

Reference

PdfPageTransformer Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%%

PdfPageTransformer Constructor

Xfinium.Pdf.Transforms Namespace > PdfPageTransformer Class : PdfPageTransformer Constructor
The page whose content will be transformed.
Initializes a new PdfPageTransformer object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal page As PdfPage _
)
'Usage

Dim page As PdfPage

Dim instance As New PdfPageTransformer(page)
public PdfPageTransformer(
   PdfPage page
)
public:
PdfPageTransformer(
   PdfPage^ page
)

Parameters

page
The page whose content will be transformed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageTransformer Class
PdfPageTransformer Members


%%PageItemTitle%% $$Methods$$

PdfPageTransformer Class Methods

Xfinium.Pdf.Transforms Namespace : PdfPageTransformer Class

For a list of all members of this type, see PdfPageTransformer members.

Public Methods
 | Name | Description
Public Method | ApplyTransform | Applies the specified transformation on the page content.
Top
See Also

Reference

PdfPageTransformer Class
Xfinium.Pdf.Transforms Namespace


ApplyTransform Method

Xfinium.Pdf.Transforms Namespace > PdfPageTransformer Class : ApplyTransform Method
The transformation to apply to the page content.
Applies the specified transformation on the page content.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub ApplyTransform( _
   ByVal pageTransform As PdfPageTransform _
)
'Usage

Dim instance As PdfPageTransformer
Dim pageTransform As PdfPageTransform

instance.ApplyTransform(pageTransform)
public void ApplyTransform(
   PdfPageTransform pageTransform
)
public:
void ApplyTransform(
   PdfPageTransform^ pageTransform
)

Parameters

pageTransform
The transformation to apply to the page content.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageTransformer Class
PdfPageTransformer Members


%%PageItemTitle%%

PdfReplaceImageEventArgs Class
Members

Xfinium.Pdf.Transforms Namespace : PdfReplaceImageEventArgs Class
Defines the arguments for PdfReplaceImageTransform.ReplaceImage event.
Object Model
PdfReplaceImageEventArgs ClassPdfImage ClassPdfCosName ClassPdfVisualImage ClassPdfCosName Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfReplaceImageEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PdfReplaceImageEventArgs
public class PdfReplaceImageEventArgs : System.EventArgs
public ref class PdfReplaceImageEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Xfinium.Pdf.Transforms.PdfReplaceImageEventArgs

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageEventArgs Members
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Members$$

PdfReplaceImageEventArgs Class Members
Properties

Xfinium.Pdf.Transforms Namespace : PdfReplaceImageEventArgs Class

The following tables list the members exposed by PdfReplaceImageEventArgs.

Public Properties
 | Name | Description
Public Property | NewImage | Gets or sets the image that will replace the old image.
Public Property | NewImageID | Gets or sets the ID of the new image.
Public Property | OldImage | Gets the image that will be replaced.
Public Property | OldImageID | Gets the ID of the old image.
Top
See Also

Reference

PdfReplaceImageEventArgs Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Properties$$

PdfReplaceImageEventArgs Class Properties

Xfinium.Pdf.Transforms Namespace : PdfReplaceImageEventArgs Class

For a list of all members of this type, see PdfReplaceImageEventArgs members.

Public Properties
 | Name | Description
Public Property | NewImage | Gets or sets the image that will replace the old image.
Public Property | NewImageID | Gets or sets the ID of the new image.
Public Property | OldImage | Gets the image that will be replaced.
Public Property | OldImageID | Gets the ID of the old image.
Top
See Also

Reference

PdfReplaceImageEventArgs Class
Xfinium.Pdf.Transforms Namespace


NewImage Property

Xfinium.Pdf.Transforms Namespace > PdfReplaceImageEventArgs Class : NewImage Property
Gets or sets the image that will replace the old image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NewImage As PdfImage
'Usage

Dim instance As PdfReplaceImageEventArgs
Dim value As PdfImage

instance.NewImage = value

value = instance.NewImage
public PdfImage NewImage {get; set;}
public:
property PdfImage^ NewImage {
   PdfImage^ get();
   void set (    PdfImage^ value);
}

Property Value

The replacement image.
Remarks
If this property is set to null, the image will be removed from the page.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageEventArgs Class
PdfReplaceImageEventArgs Members


NewImageID Property

Xfinium.Pdf.Transforms Namespace > PdfReplaceImageEventArgs Class : NewImageID Property
Gets or sets the ID of the new image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NewImageID As PdfCosName
'Usage

Dim instance As PdfReplaceImageEventArgs
Dim value As PdfCosName

instance.NewImageID = value

value = instance.NewImageID
public PdfCosName NewImageID {get; set;}
public:
property PdfCosName^ NewImageID {
   PdfCosName^ get();
   void set (    PdfCosName^ value);
}

Property Value

The ID used to reference the image in the page content.
Remarks
This ID identifies the image in the Resources dictionary and it is also used as parameter for the Do operator.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageEventArgs Class
PdfReplaceImageEventArgs Members


OldImage Property

Xfinium.Pdf.Transforms Namespace > PdfReplaceImageEventArgs Class : OldImage Property
Gets the image that will be replaced.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OldImage As PdfVisualImage
'Usage

Dim instance As PdfReplaceImageEventArgs
Dim value As PdfVisualImage

value = instance.OldImage
public PdfVisualImage OldImage {get;}
public:
property PdfVisualImage^ OldImage {
   PdfVisualImage^ get();
}

Property Value

The image that will be replaced.
Remarks
This property has a value if PdfReplaceImageTransform.DecodeOldImage property has been set to true
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageEventArgs Class
PdfReplaceImageEventArgs Members


OldImageID Property

Xfinium.Pdf.Transforms Namespace > PdfReplaceImageEventArgs Class : OldImageID Property
Gets the ID of the old image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OldImageID As PdfCosName
'Usage

Dim instance As PdfReplaceImageEventArgs
Dim value As PdfCosName

value = instance.OldImageID
public PdfCosName OldImageID {get;}
public:
property PdfCosName^ OldImageID {
   PdfCosName^ get();
}

Property Value

The ID used to reference the image in the page content.
Remarks
This ID identifies the image in the Resources dictionary and it is also used as parameter for the Do operator.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageEventArgs Class
PdfReplaceImageEventArgs Members


%%PageItemTitle%%

PdfReplaceImageTransform Class
Members

Xfinium.Pdf.Transforms Namespace : PdfReplaceImageTransform Class
Defines a page transformation that allows to replace an image with another image.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PdfReplaceImageTransform
   Inherits PdfPageTransform
'Usage

Dim instance As PdfReplaceImageTransform
public class PdfReplaceImageTransform : PdfPageTransform
public ref class PdfReplaceImageTransform : public PdfPageTransform
Inheritance Hierarchy

System.Object
Xfinium.Pdf.Transforms.PdfPageTransform
Xfinium.Pdf.Transforms.PdfReplaceImageTransform

Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageTransform Members
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Members$$

PdfReplaceImageTransform Class Members
Properties Events

Xfinium.Pdf.Transforms Namespace : PdfReplaceImageTransform Class

The following tables list the members exposed by PdfReplaceImageTransform.

Public Constructors
 | Name | Description
Public Constructor | PdfReplaceImageTransform Constructor | Initializes a new PdfReplaceImageTransform object.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Public Property | DecodeOldImage | Gets or sets a value indicating whether the old image will be decoded.
Top
Public Events
 | Name | Description
Public Event | ReplaceImage | Gets or sets the event that is fired when an image needs to be replaced.
Top
See Also

Reference

PdfReplaceImageTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%%

PdfReplaceImageTransform Constructor

Xfinium.Pdf.Transforms Namespace > PdfReplaceImageTransform Class : PdfReplaceImageTransform Constructor
Initializes a new PdfReplaceImageTransform object.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PdfReplaceImageTransform()
public PdfReplaceImageTransform()
public:
PdfReplaceImageTransform();
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageTransform Class
PdfReplaceImageTransform Members


%%PageItemTitle%% $$Properties$$

PdfReplaceImageTransform Class Properties

Xfinium.Pdf.Transforms Namespace : PdfReplaceImageTransform Class

For a list of all members of this type, see PdfReplaceImageTransform members.

Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Public Property | DecodeOldImage | Gets or sets a value indicating whether the old image will be decoded.
Top
See Also

Reference

PdfReplaceImageTransform Class
Xfinium.Pdf.Transforms Namespace


DecodeOldImage Property

Xfinium.Pdf.Transforms Namespace > PdfReplaceImageTransform Class : DecodeOldImage Property
Gets or sets a value indicating whether the old image will be decoded.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DecodeOldImage As Boolean
'Usage

Dim instance As PdfReplaceImageTransform
Dim value As Boolean

instance.DecodeOldImage = value

value = instance.DecodeOldImage
public bool DecodeOldImage {get; set;}
public:
property bool DecodeOldImage {
   bool get();
   void set (    bool value);
}

Property Value

If true the replaced image will be decoded so it can be saved and processed, if needed.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageTransform Class
PdfReplaceImageTransform Members


%%PageItemTitle%% $$Events$$

PdfReplaceImageTransform Class Events

Xfinium.Pdf.Transforms Namespace : PdfReplaceImageTransform Class

For a list of all members of this type, see PdfReplaceImageTransform members.

Public Events
 | Name | Description
Public Event | ReplaceImage | Gets or sets the event that is fired when an image needs to be replaced.
Top
See Also

Reference

PdfReplaceImageTransform Class
Xfinium.Pdf.Transforms Namespace


ReplaceImage Event

Xfinium.Pdf.Transforms Namespace > PdfReplaceImageTransform Class : ReplaceImage Event
Gets or sets the event that is fired when an image needs to be replaced.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event ReplaceImage As EventHandler(Of PdfReplaceImageEventArgs)
'Usage

Dim instance As PdfReplaceImageTransform
Dim handler As EventHandler(Of PdfReplaceImageEventArgs)

AddHandler instance.ReplaceImage, handler
public event EventHandler<PdfReplaceImageEventArgs> ReplaceImage
public:
event EventHandler<PdfReplaceImageEventArgs^>^ ReplaceImage
Event Data

The event handler receives an argument of type PdfReplaceImageEventArgs containing data related to this event. The following PdfReplaceImageEventArgs properties provide information specific to this event.

Property | Description
NewImage | Gets or sets the image that will replace the old image.
NewImageID | Gets or sets the ID of the new image.
OldImage | Gets the image that will be replaced.
OldImageID | Gets the ID of the old image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfReplaceImageTransform Class
PdfReplaceImageTransform Members


%%PageItemTitle%% $$Methods$$

PdfActionCollection Class Methods

Xfinium.Pdf.Actions Namespace : PdfActionCollection Class

For a list of all members of this type, see PdfActionCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Top
See Also

Reference

PdfActionCollection Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%% $$Properties$$

PdfActionCollection Class Properties

Xfinium.Pdf.Actions Namespace : PdfActionCollection Class

For a list of all members of this type, see PdfActionCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfAction>)
Top
See Also

Reference

PdfActionCollection Class
Xfinium.Pdf.Actions Namespace


%%PageItemTitle%%

PdfActionCollection Constructor

Xfinium.Pdf.Actions Namespace > PdfActionCollection Class : PdfActionCollection Constructor
Overload List
Overload | Description
PdfActionCollection Constructor | Initializes a new PdfActionCollection object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfActionCollection Class
PdfActionCollection Members


%%PageItemTitle%%

PdfGoTo3DViewAction Constructor

Xfinium.Pdf.Actions Namespace > PdfGoTo3DViewAction Class : PdfGoTo3DViewAction Constructor
Overload List
Overload | Description
PdfGoTo3DViewAction Constructor | Initializes a new PdfGoTo3DViewAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoTo3DViewAction Class
PdfGoTo3DViewAction Members


%%PageItemTitle%%

PdfGoToAction Constructor

Xfinium.Pdf.Actions Namespace > PdfGoToAction Class : PdfGoToAction Constructor
Overload List
Overload | Description
PdfGoToAction Constructor | Initializes a new PdfGoToAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGoToAction Class
PdfGoToAction Members


%%PageItemTitle%%

PdfHideAction Constructor

Xfinium.Pdf.Actions Namespace > PdfHideAction Class : PdfHideAction Constructor
Overload List
Overload | Description
PdfHideAction Constructor | Initializes a new PdfHideAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfHideAction Class
PdfHideAction Members


%%PageItemTitle%%

PdfJavaScriptAction Constructor

Xfinium.Pdf.Actions Namespace > PdfJavaScriptAction Class : PdfJavaScriptAction Constructor
Overload List
Overload | Description
PdfJavaScriptAction Constructor | Initializes a new PdfJavaScriptAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfJavaScriptAction Class
PdfJavaScriptAction Members


%%PageItemTitle%%

PdfLaunchAction Constructor

Xfinium.Pdf.Actions Namespace > PdfLaunchAction Class : PdfLaunchAction Constructor
Overload List
Overload | Description
PdfLaunchAction Constructor | Initializes a new PdfLaunchAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLaunchAction Class
PdfLaunchAction Members


%%PageItemTitle%%

PdfNamedAction Constructor

Xfinium.Pdf.Actions Namespace > PdfNamedAction Class : PdfNamedAction Constructor
Overload List
Overload | Description
PdfNamedAction Constructor | Initializes a new PdfNamedAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNamedAction Class
PdfNamedAction Members


%%PageItemTitle%%

PdfRemoteGoToAction Constructor

Xfinium.Pdf.Actions Namespace > PdfRemoteGoToAction Class : PdfRemoteGoToAction Constructor
Overload List
Overload | Description
PdfRemoteGoToAction Constructor | Initializes a new PdfRemoteGoToAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRemoteGoToAction Class
PdfRemoteGoToAction Members


%%PageItemTitle%%

PdfResetFormAction Constructor

Xfinium.Pdf.Actions Namespace > PdfResetFormAction Class : PdfResetFormAction Constructor
Overload List
Overload | Description
PdfResetFormAction Constructor | Initializes a new PdfResetFormAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfResetFormAction Class
PdfResetFormAction Members


%%PageItemTitle%%

PdfSubmitFormAction Constructor

Xfinium.Pdf.Actions Namespace > PdfSubmitFormAction Class : PdfSubmitFormAction Constructor
Overload List
Overload | Description
PdfSubmitFormAction Constructor | Initializes a new PdfSubmitFormAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSubmitFormAction Class
PdfSubmitFormAction Members


%%PageItemTitle%%

Pdf3DActivation Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DActivation Class : Pdf3DActivation Constructor
Overload List
Overload | Description
Pdf3DActivation Constructor | Initializes a new Pdf3DActivation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DActivation Class
Pdf3DActivation Members


%%PageItemTitle%%

Pdf3DAnimation Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DAnimation Class : Pdf3DAnimation Constructor
Overload List
Overload | Description
Pdf3DAnimation Constructor | Initializes a new Pdf3DAnimation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnimation Class
Pdf3DAnimation Members


%%PageItemTitle%% $$Methods$$

Pdf3DAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : Pdf3DAnnotation Class

For a list of all members of this type, see Pdf3DAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

Pdf3DAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DAnnotation Class : Pdf3DAnnotation Constructor
Overload List
Overload | Description
Pdf3DAnnotation Constructor | Initializes a new Pdf3DAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DAnnotation Class
Pdf3DAnnotation Members


%%PageItemTitle%%

Pdf3DBackground Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DBackground Class : Pdf3DBackground Constructor
Overload List
Overload | Description
Pdf3DBackground Constructor | Initializes a new Pdf3DBackground object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DBackground Class
Pdf3DBackground Members


%%PageItemTitle%% $$Methods$$

Pdf3DCrossSectionCollection Class Methods

Xfinium.Pdf.Annotations Namespace : Pdf3DCrossSectionCollection Class

For a list of all members of this type, see Pdf3DCrossSectionCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Top
See Also

Reference

Pdf3DCrossSectionCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Properties$$

Pdf3DCrossSectionCollection Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DCrossSectionCollection Class

For a list of all members of this type, see Pdf3DCrossSectionCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DCrossSection>)
Top
See Also

Reference

Pdf3DCrossSectionCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DCrossSection Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DCrossSection Class : Pdf3DCrossSection Constructor
Overload List
Overload | Description
Pdf3DCrossSection Constructor | Initializes a new Pdf3DCrossSection object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DCrossSection Class
Pdf3DCrossSection Members


%%PageItemTitle%%

Pdf3DLightingScheme Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DLightingScheme Class : Pdf3DLightingScheme Constructor
Overload List
Overload | Description
Pdf3DLightingScheme Constructor | Initializes a new Pdf3DLightingScheme object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DLightingScheme Class
Pdf3DLightingScheme Members


%%PageItemTitle%% $$Methods$$

Pdf3DNodeCollection Class Methods

Xfinium.Pdf.Annotations Namespace : Pdf3DNodeCollection Class

For a list of all members of this type, see Pdf3DNodeCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Top
See Also

Reference

Pdf3DNodeCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Properties$$

Pdf3DNodeCollection Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DNodeCollection Class

For a list of all members of this type, see Pdf3DNodeCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DNode>)
Top
See Also

Reference

Pdf3DNodeCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DNode Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DNode Class : Pdf3DNode Constructor
Overload List
Overload | Description
Pdf3DNode Constructor | Initializes a new Pdf3DNode object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DNode Class
Pdf3DNode Members


%%PageItemTitle%%

Pdf3DProjection Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DProjection Class : Pdf3DProjection Constructor
Overload List
Overload | Description
Pdf3DProjection Constructor | Initializes a new Pdf3DProjection object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DProjection Class
Pdf3DProjection Members


%%PageItemTitle%%

Pdf3DRendering Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DRendering Class : Pdf3DRendering Constructor
Overload List
Overload | Description
Pdf3DRendering Constructor | Initializes a new Pdf3DRendering object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DRendering Class
Pdf3DRendering Members


%%PageItemTitle%%

Pdf3DStream Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DStream Class : Pdf3DStream Constructor
Overload List
Overload | Description
Pdf3DStream Constructor | Initializes a new Pdf3DStream object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DStream Class
Pdf3DStream Members


%%PageItemTitle%% $$Methods$$

Pdf3DViewCollection Class Methods

Xfinium.Pdf.Annotations Namespace : Pdf3DViewCollection Class

For a list of all members of this type, see Pdf3DViewCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Top
See Also

Reference

Pdf3DViewCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Properties$$

Pdf3DViewCollection Class Properties

Xfinium.Pdf.Annotations Namespace : Pdf3DViewCollection Class

For a list of all members of this type, see Pdf3DViewCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Pdf3DView>)
Top
See Also

Reference

Pdf3DViewCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

Pdf3DView Constructor

Xfinium.Pdf.Annotations Namespace > Pdf3DView Class : Pdf3DView Constructor
Overload List
Overload | Description
Pdf3DView Constructor | Initializes a new Pdf3DView object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

Pdf3DView Class
Pdf3DView Members


%%PageItemTitle%% $$Properties$$

PdfAnnotationAppearance Class Properties

Xfinium.Pdf.Annotations Namespace : PdfAnnotationAppearance Class

For a list of all members of this type, see PdfAnnotationAppearance members.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Graphics | Gets the form XObject graphics. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Height | Gets the form XObject height. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Matrix | Gets or sets the form XObject matrix. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Width | Gets the form XObject width. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Top
See Also

Reference

PdfAnnotationAppearance Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfAnnotationAppearance Constructor

Xfinium.Pdf.Annotations Namespace > PdfAnnotationAppearance Class : PdfAnnotationAppearance Constructor
Overload List
Overload | Description
PdfAnnotationAppearance Constructor | Initializes a new PdfAnnotationAppearance object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAnnotationAppearance Class
PdfAnnotationAppearance Members


%%PageItemTitle%% $$Properties$$

PdfAnnotationCollection Class Properties

Xfinium.Pdf.Annotations Namespace : PdfAnnotationCollection Class

For a list of all members of this type, see PdfAnnotationCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfAnnotation>)
Top
See Also

Reference

PdfAnnotationCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PdfCircleAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfCircleAnnotation Class

For a list of all members of this type, see PdfCircleAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfCircleAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfCircleAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfCircleAnnotation Class : PdfCircleAnnotation Constructor
Overload List
Overload | Description
PdfCircleAnnotation Constructor | Initializes a new PdfCircleAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCircleAnnotation Class
PdfCircleAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfFileAttachmentAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfFileAttachmentAnnotation Class

For a list of all members of this type, see PdfFileAttachmentAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfFileAttachmentAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfFileAttachmentAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfFileAttachmentAnnotation Class : PdfFileAttachmentAnnotation Constructor
Overload List
Overload | Description
PdfFileAttachmentAnnotation Constructor | Initializes a new PdfFileAttachmentAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFileAttachmentAnnotation Class
PdfFileAttachmentAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfFreeTextAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfFreeTextAnnotation Class

For a list of all members of this type, see PdfFreeTextAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfFreeTextAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfFreeTextAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfFreeTextAnnotation Class : PdfFreeTextAnnotation Constructor
Overload List
Overload | Description
PdfFreeTextAnnotation Constructor | Initializes a new PdfFreeTextAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFreeTextAnnotation Class
PdfFreeTextAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfInkAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfInkAnnotation Class

For a list of all members of this type, see PdfInkAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfInkAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfInkAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfInkAnnotation Class : PdfInkAnnotation Constructor
Overload List
Overload | Description
PdfInkAnnotation Constructor | Initializes a new PdfInkAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInkAnnotation Class
PdfInkAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfLineAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfLineAnnotation Class

For a list of all members of this type, see PdfLineAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfLineAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfLineAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfLineAnnotation Class : PdfLineAnnotation Constructor
Overload List
Overload | Description
PdfLineAnnotation Constructor | Initializes a new PdfLineAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLineAnnotation Class
PdfLineAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfLinkAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfLinkAnnotation Class

For a list of all members of this type, see PdfLinkAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfLinkAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfLinkAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfLinkAnnotation Class : PdfLinkAnnotation Constructor
Overload List
Overload | Description
PdfLinkAnnotation Constructor | Initializes a new PdfLinkAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLinkAnnotation Class
PdfLinkAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfMarkupAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfMarkupAnnotation Class

For a list of all members of this type, see PdfMarkupAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfMarkupAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PdfPolygonAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfPolygonAnnotation Class

For a list of all members of this type, see PdfPolygonAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfPolygonAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PdfPolygonAnnotation Class Properties

Xfinium.Pdf.Annotations Namespace : PdfPolygonAnnotation Class

For a list of all members of this type, see PdfPolygonAnnotation members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the annotation author. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation interior color. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LineColor | Gets or sets the annotation line color. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Public Property | LineWidth | Gets or sets the line width. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Points | Gets or sets the polyline points. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from Xfinium.Pdf.Annotations.PdfMarkupAnnotation)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfPolylineAnnotation)
Top
See Also

Reference

PdfPolygonAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfPolygonAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfPolygonAnnotation Class : PdfPolygonAnnotation Constructor
Overload List
Overload | Description
PdfPolygonAnnotation Constructor | Initializes a new PdfPolygonAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolygonAnnotation Class
PdfPolygonAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfPolylineAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfPolylineAnnotation Class

For a list of all members of this type, see PdfPolylineAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfPolylineAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfPolylineAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfPolylineAnnotation Class : PdfPolylineAnnotation Constructor
Overload List
Overload | Description
PdfPolylineAnnotation Constructor | Initializes a new PdfPolylineAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPolylineAnnotation Class
PdfPolylineAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfRedactionAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfRedactionAnnotation Class

For a list of all members of this type, see PdfRedactionAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRedactionAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRedactionAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRedactionAnnotation Class : PdfRedactionAnnotation Constructor
Overload List
Overload | Description
PdfRedactionAnnotation Constructor | Initializes a new PdfRedactionAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRedactionAnnotation Class
PdfRedactionAnnotation Members


%%PageItemTitle%%

PdfRichMediaActivation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaActivation Class : PdfRichMediaActivation Constructor
Overload List
Overload | Description
PdfRichMediaActivation Constructor | Initializes a new PdfRichMediaActivation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaActivation Class
PdfRichMediaActivation Members


%%PageItemTitle%% $$Methods$$

PdfRichMediaAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAnnotation Class

For a list of all members of this type, see PdfRichMediaAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRichMediaAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaAnnotation Class : PdfRichMediaAnnotation Constructor
Overload List
Overload | Description
PdfRichMediaAnnotation Constructor | Initializes a new PdfRichMediaAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaAnnotation Class
PdfRichMediaAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfRichMediaAssetCollection Class Methods

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAssetCollection Class

For a list of all members of this type, see PdfRichMediaAssetCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Top
See Also

Reference

PdfRichMediaAssetCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PdfRichMediaAssetCollection Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaAssetCollection Class

For a list of all members of this type, see PdfRichMediaAssetCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaAsset>)
Top
See Also

Reference

PdfRichMediaAssetCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PdfRichMediaConfigurationCollection Class Methods

Xfinium.Pdf.Annotations Namespace : PdfRichMediaConfigurationCollection Class

For a list of all members of this type, see PdfRichMediaConfigurationCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Top
See Also

Reference

PdfRichMediaConfigurationCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PdfRichMediaConfigurationCollection Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaConfigurationCollection Class

For a list of all members of this type, see PdfRichMediaConfigurationCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaConfiguration>)
Top
See Also

Reference

PdfRichMediaConfigurationCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRichMediaContent Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaContent Class : PdfRichMediaContent Constructor
Overload List
Overload | Description
PdfRichMediaContent Constructor | Initializes a new PdfRichMediaContent object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaContent Class
PdfRichMediaContent Members


%%PageItemTitle%%

PdfRichMediaDeactivation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRichMediaDeactivation Class : PdfRichMediaDeactivation Constructor
Overload List
Overload | Description
PdfRichMediaDeactivation Constructor | Initializes a new PdfRichMediaDeactivation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRichMediaDeactivation Class
PdfRichMediaDeactivation Members


%%PageItemTitle%% $$Methods$$

PdfRichMediaInstanceCollection Class Methods

Xfinium.Pdf.Annotations Namespace : PdfRichMediaInstanceCollection Class

For a list of all members of this type, see PdfRichMediaInstanceCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Top
See Also

Reference

PdfRichMediaInstanceCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Properties$$

PdfRichMediaInstanceCollection Class Properties

Xfinium.Pdf.Annotations Namespace : PdfRichMediaInstanceCollection Class

For a list of all members of this type, see PdfRichMediaInstanceCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfRichMediaInstance>)
Top
See Also

Reference

PdfRichMediaInstanceCollection Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%% $$Methods$$

PdfRubberStampAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfRubberStampAnnotation Class

For a list of all members of this type, see PdfRubberStampAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRubberStampAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfRubberStampAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfRubberStampAnnotation Class : PdfRubberStampAnnotation Constructor
Overload List
Overload | Description
PdfRubberStampAnnotation Constructor | Initializes a new PdfRubberStampAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRubberStampAnnotation Class
PdfRubberStampAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfScreenAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfScreenAnnotation Class

For a list of all members of this type, see PdfScreenAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfScreenAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfScreenAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfScreenAnnotation Class : PdfScreenAnnotation Constructor
Overload List
Overload | Description
PdfScreenAnnotation Constructor | Initializes a new PdfScreenAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfScreenAnnotation Class
PdfScreenAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfSoundAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfSoundAnnotation Class

For a list of all members of this type, see PdfSoundAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfSoundAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfSoundAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfSoundAnnotation Class : PdfSoundAnnotation Constructor
Overload List
Overload | Description
PdfSoundAnnotation Constructor | Initializes a new PdfSoundAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSoundAnnotation Class
PdfSoundAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfSquareAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfSquareAnnotation Class

For a list of all members of this type, see PdfSquareAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfSquareAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfSquareAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfSquareAnnotation Class : PdfSquareAnnotation Constructor
Overload List
Overload | Description
PdfSquareAnnotation Constructor | Initializes a new PdfSquareAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSquareAnnotation Class
PdfSquareAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfTextAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfTextAnnotation Class

For a list of all members of this type, see PdfTextAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfTextAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfTextAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfTextAnnotation Class : PdfTextAnnotation Constructor
Overload List
Overload | Description
PdfTextAnnotation Constructor | Initializes a new PdfTextAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextAnnotation Class
PdfTextAnnotation Members


%%PageItemTitle%% $$Methods$$

PdfTextMarkupAnnotation Class Methods

Xfinium.Pdf.Annotations Namespace : PdfTextMarkupAnnotation Class

For a list of all members of this type, see PdfTextMarkupAnnotation members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfTextMarkupAnnotation Class
Xfinium.Pdf.Annotations Namespace


%%PageItemTitle%%

PdfTextMarkupAnnotation Constructor

Xfinium.Pdf.Annotations Namespace > PdfTextMarkupAnnotation Class : PdfTextMarkupAnnotation Constructor
Overload List
Overload | Description
PdfTextMarkupAnnotation Constructor | Initializes a new PdfTextMarkupAnnotation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextMarkupAnnotation Class
PdfTextMarkupAnnotation Members


%%PageItemTitle%% $$Properties$$

PdfPageOptionalContent Class Properties

Xfinium.Pdf.Content Namespace : PdfPageOptionalContent Class

For a list of all members of this type, see PdfPageOptionalContent members.

Public Properties
 | Name | Description
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Graphics | Gets the form XObject graphics. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Height | Gets the form XObject height. (Inherited from Xfinium.Pdf.Graphics.PdfPageContent)
Public Property | Matrix | Gets or sets the form XObject matrix. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Measure | Gets or sets the image measure. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | PointData | Gets or sets the point data. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | TransparencyGroup | Gets or sets the transparency group associated with this object. (Inherited from Xfinium.Pdf.Graphics.PdfFormXObject)
Public Property | Width | Gets the form XObject width. (Inherited from Xfinium.Pdf.Graphics.PdfPageContent)
Top
See Also

Reference

PdfPageOptionalContent Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfPathItemCollection Class Methods

Xfinium.Pdf.Content Namespace : PdfPathItemCollection Class

For a list of all members of this type, see PdfPathItemCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Top
See Also

Reference

PdfPathItemCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfPathItemCollection Class Properties

Xfinium.Pdf.Content Namespace : PdfPathItemCollection Class

For a list of all members of this type, see PdfPathItemCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfPathItem>)
Top
See Also

Reference

PdfPathItemCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfTextFragmentCollection Class Methods

Xfinium.Pdf.Content Namespace : PdfTextFragmentCollection Class

For a list of all members of this type, see PdfTextFragmentCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Top
See Also

Reference

PdfTextFragmentCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfTextFragmentCollection Class Properties

Xfinium.Pdf.Content Namespace : PdfTextFragmentCollection Class

For a list of all members of this type, see PdfTextFragmentCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextFragment>)
Top
See Also

Reference

PdfTextFragmentCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfTextGlyphCollection Class Methods

Xfinium.Pdf.Content Namespace : PdfTextGlyphCollection Class

For a list of all members of this type, see PdfTextGlyphCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Top
See Also

Reference

PdfTextGlyphCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfTextGlyphCollection Class Properties

Xfinium.Pdf.Content Namespace : PdfTextGlyphCollection Class

For a list of all members of this type, see PdfTextGlyphCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextGlyph>)
Top
See Also

Reference

PdfTextGlyphCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfTextSearchResultCollection Class Methods

Xfinium.Pdf.Content Namespace : PdfTextSearchResultCollection Class

For a list of all members of this type, see PdfTextSearchResultCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Top
See Also

Reference

PdfTextSearchResultCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfTextSearchResultCollection Class Properties

Xfinium.Pdf.Content Namespace : PdfTextSearchResultCollection Class

For a list of all members of this type, see PdfTextSearchResultCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextSearchResult>)
Top
See Also

Reference

PdfTextSearchResultCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfTextWordCollection Class Methods

Xfinium.Pdf.Content Namespace : PdfTextWordCollection Class

For a list of all members of this type, see PdfTextWordCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Top
See Also

Reference

PdfTextWordCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfTextWordCollection Class Properties

Xfinium.Pdf.Content Namespace : PdfTextWordCollection Class

For a list of all members of this type, see PdfTextWordCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextWord>)
Top
See Also

Reference

PdfTextWordCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfVisualImageCollection Class Methods

Xfinium.Pdf.Content Namespace : PdfVisualImageCollection Class

For a list of all members of this type, see PdfVisualImageCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Top
See Also

Reference

PdfVisualImageCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfVisualImageCollection Class Properties

Xfinium.Pdf.Content Namespace : PdfVisualImageCollection Class

For a list of all members of this type, see PdfVisualImageCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualImage>)
Top
See Also

Reference

PdfVisualImageCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Methods$$

PdfVisualObjectCollection Class Methods

Xfinium.Pdf.Content Namespace : PdfVisualObjectCollection Class

For a list of all members of this type, see PdfVisualObjectCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Top
See Also

Reference

PdfVisualObjectCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%% $$Properties$$

PdfVisualObjectCollection Class Properties

Xfinium.Pdf.Content Namespace : PdfVisualObjectCollection Class

For a list of all members of this type, see PdfVisualObjectCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfVisualObject>)
Top
See Also

Reference

PdfVisualObjectCollection Class
Xfinium.Pdf.Content Namespace


%%PageItemTitle%%

PdfCosArray Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosArray Class : PdfCosArray Constructor
Overload List
Overload | Description
PdfCosArray Constructor | Initializes a new PdfCosArray object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosArray Class
PdfCosArray Members


%%PageItemTitle%% $$Methods$$

PdfCosDictionaryContainer Class Methods

Xfinium.Pdf.Core.Cos Namespace : PdfCosDictionaryContainer Class

For a list of all members of this type, see PdfCosDictionaryContainer members.

Public Methods
 | Name | Description
Public Method | GetKeyValueAsBool | Gets the value of the specified key as a boolean. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | GetKeyValueAsNumber | Gets the value of the specified key as a double. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | GetKeyValueAsString | Gets the value of the specified key as a string. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Public Method | ToString | Returns a string that represents the current object. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosDictionary)
Top
See Also

Reference

PdfCosDictionaryContainer Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosDictionary Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : PdfCosDictionary Constructor
Overload List
Overload | Description
PdfCosDictionary Constructor | Initializes a new PdfCosDictionary object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


GetKeyValueAsBool Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : GetKeyValueAsBool Method
Gets the value of the specified key as a boolean.
Overload List
Overload | Description
GetKeyValueAsBool | Gets the value of the specified key as a boolean.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


GetKeyValueAsString Method

Xfinium.Pdf.Core.Cos Namespace > PdfCosDictionary Class : GetKeyValueAsString Method
Gets the value of the specified key as a string.
Overload List
Overload | Description
GetKeyValueAsString | Gets the value of the specified key as a string.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosDictionary Class
PdfCosDictionary Members


%%PageItemTitle%% $$Properties$$

PdfCosNull Class Properties

Xfinium.Pdf.Core.Cos Namespace : PdfCosNull Class

For a list of all members of this type, see PdfCosNull members.

Public Properties
 | Name | Description
Public Property | Type | Gets the object type. (Inherited from Xfinium.Pdf.Core.Cos.PdfCosObject)
Top
See Also

Reference

PdfCosNull Class
Xfinium.Pdf.Core.Cos Namespace


%%PageItemTitle%%

PdfCosStream Constructor

Xfinium.Pdf.Core.Cos Namespace > PdfCosStream Class : PdfCosStream Constructor
Overload List
Overload | Description
PdfCosStream Constructor | Initializes a new PdfCosStream object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCosStream Class
PdfCosStream Members


%%PageItemTitle%% $$Methods$$

PdfEncodingCollection Class Methods

Xfinium.Pdf.Core.Encodings Namespace : PdfEncodingCollection Class

For a list of all members of this type, see PdfEncodingCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Top
See Also

Reference

PdfEncodingCollection Class
Xfinium.Pdf.Core.Encodings Namespace


%%PageItemTitle%% $$Properties$$

PdfEncodingCollection Class Properties

Xfinium.Pdf.Core.Encodings Namespace : PdfEncodingCollection Class

For a list of all members of this type, see PdfEncodingCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfEncoding>)
Top
See Also

Reference

PdfEncodingCollection Class
Xfinium.Pdf.Core.Encodings Namespace


%%PageItemTitle%% $$Methods$$

PdfException Class Methods

Xfinium.Pdf.Core.Exceptions Namespace : PdfException Class

For a list of all members of this type, see PdfException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfException Class
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%% $$Properties$$

PdfException Class Properties

Xfinium.Pdf.Core.Exceptions Namespace : PdfException Class

For a list of all members of this type, see PdfException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PdfException Class
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%% $$Methods$$

PdfInvalidPageContentException Class Methods

Xfinium.Pdf.Core.Exceptions Namespace : PdfInvalidPageContentException Class

For a list of all members of this type, see PdfInvalidPageContentException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfInvalidPageContentException Class
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%% $$Properties$$

PdfInvalidPageContentException Class Properties

Xfinium.Pdf.Core.Exceptions Namespace : PdfInvalidPageContentException Class

For a list of all members of this type, see PdfInvalidPageContentException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PdfInvalidPageContentException Class
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%%

PdfInvalidPageContentException Constructor

Xfinium.Pdf.Core.Exceptions Namespace > PdfInvalidPageContentException Class : PdfInvalidPageContentException Constructor
Overload List
Overload | Description
PdfInvalidPageContentException Constructor | Initializes a new PdfInvalidPageContentException object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfInvalidPageContentException Class
PdfInvalidPageContentException Members


%%PageItemTitle%% $$Methods$$

PdfUnsupportedDataException Class Methods

Xfinium.Pdf.Core.Exceptions Namespace : PdfUnsupportedDataException Class

For a list of all members of this type, see PdfUnsupportedDataException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfUnsupportedDataException Class
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%% $$Properties$$

PdfUnsupportedDataException Class Properties

Xfinium.Pdf.Core.Exceptions Namespace : PdfUnsupportedDataException Class

For a list of all members of this type, see PdfUnsupportedDataException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PdfUnsupportedDataException Class
Xfinium.Pdf.Core.Exceptions Namespace


%%PageItemTitle%% $$Methods$$

ObfuscationAttribute Class Methods

Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace : ObfuscationAttribute Class

For a list of all members of this type, see ObfuscationAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

ObfuscationAttribute Class
Xfinium.Pdf.Core.Utility.CryptoObfuscatorHelper Namespace


%%PageItemTitle%% $$Methods$$

PdfNamedDestinationCollection Class Methods

Xfinium.Pdf.Destinations Namespace : PdfNamedDestinationCollection Class

For a list of all members of this type, see PdfNamedDestinationCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfNamedDestination>)
Top
See Also

Reference

PdfNamedDestinationCollection Class
Xfinium.Pdf.Destinations Namespace


%%PageItemTitle%%

PdfPageDirectDestination Constructor

Xfinium.Pdf.Destinations Namespace > PdfPageDirectDestination Class : PdfPageDirectDestination Constructor
Overload List
Overload | Description
PdfPageDirectDestination Constructor | Initializes a new PdfPageDirectDestination object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageDirectDestination Class
PdfPageDirectDestination Members


%%PageItemTitle%%

PdfPageNumberDestination Constructor

Xfinium.Pdf.Destinations Namespace > PdfPageNumberDestination Class : PdfPageNumberDestination Constructor
Overload List
Overload | Description
PdfPageNumberDestination Constructor | Initializes a new PdfPageNumberDestination object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageNumberDestination Class
PdfPageNumberDestination Members


%%PageItemTitle%% $$Methods$$

PdfFlowContentCollection Class Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentCollection Class

For a list of all members of this type, see PdfFlowContentCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Top
See Also

Reference

PdfFlowContentCollection Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowContentCollection Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowContentCollection Class

For a list of all members of this type, see PdfFlowContentCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowContent>)
Top
See Also

Reference

PdfFlowContentCollection Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Methods$$

PdfFlowHeadingContent Class Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowHeadingContent Class

For a list of all members of this type, see PdfFlowHeadingContent members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a string that represents the current object. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowTextContent)
Top
See Also

Reference

PdfFlowHeadingContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%%

PdfFlowHeadingContent Constructor

Xfinium.Pdf.FlowDocument Namespace > PdfFlowHeadingContent Class : PdfFlowHeadingContent Constructor
Overload List
Overload | Description
PdfFlowHeadingContent Constructor | Initializes a new PdfFlowHeadingContent object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFlowHeadingContent Class
PdfFlowHeadingContent Members


%%PageItemTitle%% $$Methods$$

PdfFlowTableCellCollection Class Methods

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCellCollection Class

For a list of all members of this type, see PdfFlowTableCellCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Top
See Also

Reference

PdfFlowTableCellCollection Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowTableCellCollection Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableCellCollection Class

For a list of all members of this type, see PdfFlowTableCellCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableCell>)
Top
See Also

Reference

PdfFlowTableCellCollection Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowTableRowCollection Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTableRowCollection Class

For a list of all members of this type, see PdfFlowTableRowCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFlowTableRow>)
Top
See Also

Reference

PdfFlowTableRowCollection Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Properties$$

PdfFlowTextContent Class Properties

Xfinium.Pdf.FlowDocument Namespace : PdfFlowTextContent Class

For a list of all members of this type, see PdfFlowTextContent members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the content background. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | DestinationName | Gets or sets the destination name. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | InnerMargins | Gets or sets the content inner margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Public Property | OuterMargins | Gets or sets the content outer margins. (Inherited from Xfinium.Pdf.FlowDocument.PdfFlowContent)
Top
See Also

Reference

PdfFlowTextContent Class
Xfinium.Pdf.FlowDocument Namespace


%%PageItemTitle%% $$Methods$$

PdfCalculatedFieldCollection Class Methods

Xfinium.Pdf.Forms Namespace : PdfCalculatedFieldCollection Class

For a list of all members of this type, see PdfCalculatedFieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Top
See Also

Reference

PdfCalculatedFieldCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfCalculatedFieldCollection Class Properties

Xfinium.Pdf.Forms Namespace : PdfCalculatedFieldCollection Class

For a list of all members of this type, see PdfCalculatedFieldCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfField>)
Top
See Also

Reference

PdfCalculatedFieldCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfCheckBoxField Constructor

Xfinium.Pdf.Forms Namespace > PdfCheckBoxField Class : PdfCheckBoxField Constructor
Overload List
Overload | Description
PdfCheckBoxField Constructor | Initializes a new PdfCheckBoxField object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckBoxField Class
PdfCheckBoxField Members


%%PageItemTitle%% $$Methods$$

PdfCheckBoxWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfCheckBoxWidget Class

For a list of all members of this type, see PdfCheckBoxWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfCheckBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfCheckBoxWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfCheckBoxWidget Class

For a list of all members of this type, see PdfCheckBoxWidget members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Checked | Gets or set a value indicating whether the check widget is in the checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckStyle | Gets or sets the style of the checked widget. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ExportValue | Gets or sets the widget's export value. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | UncheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | UncheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | UncheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfCheckBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfCheckBoxWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfCheckBoxWidget Class : PdfCheckBoxWidget Constructor
Overload List
Overload | Description
PdfCheckBoxWidget Constructor | Initializes a new PdfCheckBoxWidget object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckBoxWidget Class
PdfCheckBoxWidget Members


%%PageItemTitle%% $$Methods$$

PdfCheckWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfCheckWidget Class

For a list of all members of this type, see PdfCheckWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfCheckWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfCheckWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfCheckWidget Class : PdfCheckWidget Constructor
Overload List
Overload | Description
PdfCheckWidget Constructor | Initializes a new PdfCheckWidget object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCheckWidget Class
PdfCheckWidget Members


%%PageItemTitle%%

PdfComboBoxField Constructor

Xfinium.Pdf.Forms Namespace > PdfComboBoxField Class : PdfComboBoxField Constructor
Overload List
Overload | Description
PdfComboBoxField Constructor | Initializes a new PdfComboBoxField object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfComboBoxField Class
PdfComboBoxField Members


%%PageItemTitle%% $$Methods$$

PdfComboBoxWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfComboBoxWidget Class

For a list of all members of this type, see PdfComboBoxWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfComboBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfComboBoxWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfComboBoxWidget Class

For a list of all members of this type, see PdfComboBoxWidget members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfComboBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfComboBoxWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfComboBoxWidget Class : PdfComboBoxWidget Constructor
Overload List
Overload | Description
PdfComboBoxWidget Constructor | Initializes a new PdfComboBoxWidget object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfComboBoxWidget Class
PdfComboBoxWidget Members


%%PageItemTitle%% $$Methods$$

PdfFieldWidgetCollection Class Methods

Xfinium.Pdf.Forms Namespace : PdfFieldWidgetCollection Class

For a list of all members of this type, see PdfFieldWidgetCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Top
See Also

Reference

PdfFieldWidgetCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfFieldWidgetCollection Class Properties

Xfinium.Pdf.Forms Namespace : PdfFieldWidgetCollection Class

For a list of all members of this type, see PdfFieldWidgetCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFieldWidget>)
Top
See Also

Reference

PdfFieldWidgetCollection Class
Xfinium.Pdf.Forms Namespace


ImportData Method

Xfinium.Pdf.Forms Namespace > PdfForm Class : ImportData Method
Imports data from a stream.
Overload List
Overload | Description
ImportData | Imports data from a stream.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfForm Class
PdfForm Members


%%PageItemTitle%% $$Properties$$

PdfListBoxField Class Properties

Xfinium.Pdf.Forms Namespace : PdfListBoxField Class

For a list of all members of this type, see PdfListBoxField members.

Public Properties
 | Name | Description
Public Property | AlternateName | Gets or sets the field alternate name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CalculateAction | Gets or sets the calculate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | CommitOnSelectionChange | Gets or sets a value indicating whether the new value shall be committed as soon as a selection is made. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Export | Gets or sets a value indicating whether the field can be exported or not. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Form | Gets the Acrobat form this field belongs to. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | FormatAction | Gets or sets the format action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Items | Gets the items in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | KeyPressAction | Gets or sets the keypress action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | MappingName | Gets or sets the field mapping name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Name | Gets or sets the field name. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Sort | Gets or sets a value indicating whether the field's option items shall be sorted alphabetically. (Inherited from Xfinium.Pdf.Forms.PdfListField)
Public Property | Type | Gets the field type. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | ValidateAction | Gets or sets the validate action. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Value | Gets or sets the field value. (Inherited from Xfinium.Pdf.Forms.PdfField)
Public Property | Widgets | Gets the list of field widgets. (Inherited from Xfinium.Pdf.Forms.PdfField)
Top
See Also

Reference

PdfListBoxField Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfListBoxField Constructor

Xfinium.Pdf.Forms Namespace > PdfListBoxField Class : PdfListBoxField Constructor
Overload List
Overload | Description
PdfListBoxField Constructor | Initializes a new PdfListBoxField object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListBoxField Class
PdfListBoxField Members


%%PageItemTitle%% $$Methods$$

PdfListBoxWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfListBoxWidget Class

For a list of all members of this type, see PdfListBoxWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfListBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfListBoxWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfListBoxWidget Class

For a list of all members of this type, see PdfListBoxWidget members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfListBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfListBoxWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfListBoxWidget Class : PdfListBoxWidget Constructor
Overload List
Overload | Description
PdfListBoxWidget Constructor | Initializes a new PdfListBoxWidget object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfListBoxWidget Class
PdfListBoxWidget Members


%%PageItemTitle%% $$Methods$$

PdfListItemCollection Class Methods

Xfinium.Pdf.Forms Namespace : PdfListItemCollection Class

For a list of all members of this type, see PdfListItemCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Top
See Also

Reference

PdfListItemCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfListItemCollection Class Properties

Xfinium.Pdf.Forms Namespace : PdfListItemCollection Class

For a list of all members of this type, see PdfListItemCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfListItem>)
Top
See Also

Reference

PdfListItemCollection Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfPushButtonField Constructor

Xfinium.Pdf.Forms Namespace > PdfPushButtonField Class : PdfPushButtonField Constructor
Overload List
Overload | Description
PdfPushButtonField Constructor | Initializes a new PdfPushButtonField object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonField Class
PdfPushButtonField Members


%%PageItemTitle%% $$Methods$$

PdfPushButtonWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfPushButtonWidget Class

For a list of all members of this type, see PdfPushButtonWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfPushButtonWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfPushButtonWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfPushButtonWidget Class : PdfPushButtonWidget Constructor
Overload List
Overload | Description
PdfPushButtonWidget Constructor | Initializes a new PdfPushButtonWidget object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPushButtonWidget Class
PdfPushButtonWidget Members


%%PageItemTitle%%

PdfRadioButtonField Constructor

Xfinium.Pdf.Forms Namespace > PdfRadioButtonField Class : PdfRadioButtonField Constructor
Overload List
Overload | Description
PdfRadioButtonField Constructor | Initializes a new PdfRadioButtonField object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonField Class
PdfRadioButtonField Members


%%PageItemTitle%% $$Methods$$

PdfRadioButtonWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfRadioButtonWidget Class

For a list of all members of this type, see PdfRadioButtonWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfRadioButtonWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfRadioButtonWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfRadioButtonWidget Class

For a list of all members of this type, see PdfRadioButtonWidget members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Checked | Gets or set a value indicating whether the check widget is in the checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in checked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | CheckStyle | Gets or sets the style of the checked widget. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ExportValue | Gets or sets the widget's export value. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | UncheckedStateDownAppearance | Gets or sets the pressed visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | UncheckedStateNormalAppearance | Gets or sets the normal visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | UncheckedStateRolloverAppearance | Gets or sets the rollover visual appearance for the widget in unchecked state. (Inherited from Xfinium.Pdf.Forms.PdfCheckWidget)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfRadioButtonWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfRadioButtonWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfRadioButtonWidget Class : PdfRadioButtonWidget Constructor
Overload List
Overload | Description
PdfRadioButtonWidget Constructor | Initializes a new PdfRadioButtonWidget object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadioButtonWidget Class
PdfRadioButtonWidget Members


%%PageItemTitle%%

PdfSignatureField Constructor

Xfinium.Pdf.Forms Namespace > PdfSignatureField Class : PdfSignatureField Constructor
Overload List
Overload | Description
PdfSignatureField Constructor | Initializes a new PdfSignatureField object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureField Class
PdfSignatureField Members


%%PageItemTitle%%

PdfSignatureLockFieldAction Constructor

Xfinium.Pdf.Forms Namespace > PdfSignatureLockFieldAction Class : PdfSignatureLockFieldAction Constructor
Overload List
Overload | Description
PdfSignatureLockFieldAction Constructor | Initializes a new PdfSignatureLockFieldAction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureLockFieldAction Class
PdfSignatureLockFieldAction Members


%%PageItemTitle%% $$Methods$$

PdfSignatureWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfSignatureWidget Class

For a list of all members of this type, see PdfSignatureWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfSignatureWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%% $$Properties$$

PdfSignatureWidget Class Properties

Xfinium.Pdf.Forms Namespace : PdfSignatureWidget Class

For a list of all members of this type, see PdfSignatureWidget members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the widget background color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Blur | Gets or sets the blur action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderColor | Gets or sets the widget border color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | BorderWidth | Gets or sets the widget border width. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CosDictionary | Gets the COS dictionary asssociated with this object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Field | Gets the parent field. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Focus | Gets or sets the focus action. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Font | Gets or sets the widget font. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | Hidden | Gets or sets a value indicating whether to display the annotation or not. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ID | Gets or sets the annotation ID. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Invisible | Gets or sets a value indicating whether the annotation should be displayed if it does not belong to one of the standard annotation types. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Locked | Gets or sets a value indicating whether the annotation should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | LockedContents | Gets or sets a value indicating whether the annotation contents should be modified. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseDown | Gets or sets the mouse down action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseEnter | Gets or sets the mouse enter action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseLeave | Gets or sets the mouse leave action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | MouseUp | Gets or sets the mouse up action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NormalAppearance | Gets or sets the annotation normal appearance. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoRotate | Gets or sets a value indicating whether the annotation should be rotated when the page is rotated. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoView | Gets or sets a value indicating whether the annotation should be displayed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | NoZoom | Gets or sets a value indicating whether the annotation should be scaled to current page zoom. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Page | Gets the annotation page. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageClose | Gets or sets the page close action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageInvisible | Gets or sets the page invisible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageOpen | Gets or sets the page open action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | PageVisible | Gets or sets the page visible action. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Print | Gets or sets a value indicating whether the annotation should be printed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | ReadOnly | Gets or sets a value indicating whether the annotation is read only. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | TextColor | Gets or sets the widget text color. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | ToggleNoView | Gets or sets a value indicating whether the interpretation of NoView property should be reversed. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Type | Gets the type of the annotation. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Public Property | Visibility | Gets or sets the field widget visibility. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Public Property | VisualRectangle | Gets or sets the visual rectangle of this annotation object. (Inherited from Xfinium.Pdf.Annotations.PdfAnnotation)
Top
See Also

Reference

PdfSignatureWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfSignatureWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfSignatureWidget Class : PdfSignatureWidget Constructor
Overload List
Overload | Description
PdfSignatureWidget Constructor | Initializes a new PdfSignatureWidget object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSignatureWidget Class
PdfSignatureWidget Members


%%PageItemTitle%%

PdfTextBoxField Constructor

Xfinium.Pdf.Forms Namespace > PdfTextBoxField Class : PdfTextBoxField Constructor
Overload List
Overload | Description
PdfTextBoxField Constructor | Initializes a new PdfTextBoxField object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxField Class
PdfTextBoxField Members


%%PageItemTitle%% $$Methods$$

PdfTextBoxWidget Class Methods

Xfinium.Pdf.Forms Namespace : PdfTextBoxWidget Class

For a list of all members of this type, see PdfTextBoxWidget members.

Public Methods
 | Name | Description
Public Method | Flatten | Merges the annotation appearance with the page content stream. (Inherited from Xfinium.Pdf.Forms.PdfFieldWidget)
Top
See Also

Reference

PdfTextBoxWidget Class
Xfinium.Pdf.Forms Namespace


%%PageItemTitle%%

PdfTextBoxWidget Constructor

Xfinium.Pdf.Forms Namespace > PdfTextBoxWidget Class : PdfTextBoxWidget Constructor
Overload List
Overload | Description
PdfTextBoxWidget Constructor | Initializes a new PdfTextBoxWidget object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTextBoxWidget Class
PdfTextBoxWidget Members


%%PageItemTitle%% $$Methods$$

PdfFormattedBlockCollection Class Methods

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedBlockCollection Class

For a list of all members of this type, see PdfFormattedBlockCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Top
See Also

Reference

PdfFormattedBlockCollection Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Properties$$

PdfFormattedBlockCollection Class Properties

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedBlockCollection Class

For a list of all members of this type, see PdfFormattedBlockCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedBlock>)
Top
See Also

Reference

PdfFormattedBlockCollection Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Properties$$

PdfFormattedParagraphCollection Class Properties

Xfinium.Pdf.Graphics.FormattedContent Namespace : PdfFormattedParagraphCollection Class

For a list of all members of this type, see PdfFormattedParagraphCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFormattedParagraph>)
Top
See Also

Reference

PdfFormattedParagraphCollection Class
Xfinium.Pdf.Graphics.FormattedContent Namespace


%%PageItemTitle%% $$Methods$$

PdfContentStreamOperatorCollection Class Methods

Xfinium.Pdf.Graphics.Operators Namespace : PdfContentStreamOperatorCollection Class

For a list of all members of this type, see PdfContentStreamOperatorCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Top
See Also

Reference

PdfContentStreamOperatorCollection Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Properties$$

PdfContentStreamOperatorCollection Class Properties

Xfinium.Pdf.Graphics.Operators Namespace : PdfContentStreamOperatorCollection Class

For a list of all members of this type, see PdfContentStreamOperatorCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfContentStreamOperator>)
Top
See Also

Reference

PdfContentStreamOperatorCollection Class
Xfinium.Pdf.Graphics.Operators Namespace


%%PageItemTitle%% $$Methods$$

PdfOptionalContentDisplayTreeNodeCollection Class Methods

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTreeNodeCollection Class

For a list of all members of this type, see PdfOptionalContentDisplayTreeNodeCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Top
See Also

Reference

PdfOptionalContentDisplayTreeNodeCollection Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%% $$Properties$$

PdfOptionalContentDisplayTreeNodeCollection Class Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentDisplayTreeNodeCollection Class

For a list of all members of this type, see PdfOptionalContentDisplayTreeNodeCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentDisplayTreeNode>)
Top
See Also

Reference

PdfOptionalContentDisplayTreeNodeCollection Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentDisplayTreeNodeCollection Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTreeNodeCollection Class : PdfOptionalContentDisplayTreeNodeCollection Constructor
Overload List
Overload | Description
PdfOptionalContentDisplayTreeNodeCollection Constructor | Initializes a new PdfOptionalContentDisplayTreeNodeCollection object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTreeNodeCollection Class
PdfOptionalContentDisplayTreeNodeCollection Members


%%PageItemTitle%%

PdfOptionalContentDisplayTree Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentDisplayTree Class : PdfOptionalContentDisplayTree Constructor
Overload List
Overload | Description
PdfOptionalContentDisplayTree Constructor | Initializes a new PdfOptionalContentDisplayTree object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentDisplayTree Class
PdfOptionalContentDisplayTree Members


%%PageItemTitle%% $$Methods$$

PdfOptionalContentGroupCollection Class Methods

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroupCollection Class

For a list of all members of this type, see PdfOptionalContentGroupCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Top
See Also

Reference

PdfOptionalContentGroupCollection Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%% $$Properties$$

PdfOptionalContentGroupCollection Class Properties

Xfinium.Pdf.Graphics.OptionalContent Namespace : PdfOptionalContentGroupCollection Class

For a list of all members of this type, see PdfOptionalContentGroupCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfOptionalContentGroup>)
Top
See Also

Reference

PdfOptionalContentGroupCollection Class
Xfinium.Pdf.Graphics.OptionalContent Namespace


%%PageItemTitle%%

PdfOptionalContentGroup Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentGroup Class : PdfOptionalContentGroup Constructor
Overload List
Overload | Description
PdfOptionalContentGroup Constructor | Initializes a new PdfOptionalContentGroup object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentGroup Class
PdfOptionalContentGroup Members


%%PageItemTitle%%

PdfOptionalContentProperties Constructor

Xfinium.Pdf.Graphics.OptionalContent Namespace > PdfOptionalContentProperties Class : PdfOptionalContentProperties Constructor
Overload List
Overload | Description
PdfOptionalContentProperties Constructor | Initializes a new PdfOptionalContentProperties object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOptionalContentProperties Class
PdfOptionalContentProperties Members


%%PageItemTitle%% $$Methods$$

Pdf417MicroBarcode Class Methods

Xfinium.Pdf.Graphics Namespace : Pdf417MicroBarcode Class

For a list of all members of this type, see Pdf417MicroBarcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Top
See Also

Reference

Pdf417MicroBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

Pdf417RegularBarcode Class Methods

Xfinium.Pdf.Graphics Namespace : Pdf417RegularBarcode Class

For a list of all members of this type, see Pdf417RegularBarcode members.

Public Methods
 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from Xfinium.Pdf.Graphics.Pdf417Barcode)
Top
See Also

Reference

Pdf417RegularBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfAlternateImageCollection Class Methods

Xfinium.Pdf.Graphics Namespace : PdfAlternateImageCollection Class

For a list of all members of this type, see PdfAlternateImageCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Top
See Also

Reference

PdfAlternateImageCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfAlternateImageCollection Class Properties

Xfinium.Pdf.Graphics Namespace : PdfAlternateImageCollection Class

For a list of all members of this type, see PdfAlternateImageCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfAlternateImage>)
Top
See Also

Reference

PdfAlternateImageCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfAnsiTrueTypeFont Class Methods

Xfinium.Pdf.Graphics Namespace : PdfAnsiTrueTypeFont Class

For a list of all members of this type, see PdfAnsiTrueTypeFont members.

Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | GetGlyphEmWidth | Gets the Em width of the given glyph when drawn with this font object. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | UpdateCharsSubset | Updates the set of characters that must be subset in the final font data. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | UpdateGlyphsSubset | Updates the set of glyphs that must be subset in the final font data. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Top
See Also

Reference

PdfAnsiTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfAnsiTrueTypeFont Class Properties

Xfinium.Pdf.Graphics Namespace : PdfAnsiTrueTypeFont Class

For a list of all members of this type, see PdfAnsiTrueTypeFont members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Name | Gets the name of this font. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfAnsiTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfAxialShading Constructor

Xfinium.Pdf.Graphics Namespace > PdfAxialShading Class : PdfAxialShading Constructor
Overload List
Overload | Description
PdfAxialShading Constructor | Initializes a new PdfAxialShading object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfAxialShading Class
PdfAxialShading Members


%%PageItemTitle%% $$Methods$$

PdfBarcodeException Class Methods

Xfinium.Pdf.Graphics Namespace : PdfBarcodeException Class

For a list of all members of this type, see PdfBarcodeException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfBarcodeException Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfBarcodeException Class Properties

Xfinium.Pdf.Graphics Namespace : PdfBarcodeException Class

For a list of all members of this type, see PdfBarcodeException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PdfBarcodeException Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfCalGrayColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfCalGrayColorSpace Class : PdfCalGrayColorSpace Constructor
Overload List
Overload | Description
PdfCalGrayColorSpace Constructor | Initializes a new PdfCalGrayColorSpace object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalGrayColorSpace Class
PdfCalGrayColorSpace Members


%%PageItemTitle%%

PdfCalRgbColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfCalRgbColorSpace Class : PdfCalRgbColorSpace Constructor
Overload List
Overload | Description
PdfCalRgbColorSpace Constructor | Initializes a new PdfCalRgbColorSpace object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfCalRgbColorSpace Class
PdfCalRgbColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfCodabarBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCodabarBarcode Class

For a list of all members of this type, see PdfCodabarBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCodabarBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode11Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode11Barcode Class

For a list of all members of this type, see PdfCode11Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode11Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode25InterleavedBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode25InterleavedBarcode Class

For a list of all members of this type, see PdfCode25InterleavedBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode25InterleavedBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode32Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode32Barcode Class

For a list of all members of this type, see PdfCode32Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode39Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode32Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode39ExtendedBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode39ExtendedBarcode Class

For a list of all members of this type, see PdfCode39ExtendedBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode39Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode39ExtendedBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode93Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode93Barcode Class

For a list of all members of this type, see PdfCode93Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode93Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode93ExtendedBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode93ExtendedBarcode Class

For a list of all members of this type, see PdfCode93ExtendedBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode93ExtendedBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode128ABarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode128ABarcode Class

For a list of all members of this type, see PdfCode128ABarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode128ABarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode128Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode128Barcode Class

For a list of all members of this type, see PdfCode128Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode128Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode128BBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode128BBarcode Class

For a list of all members of this type, see PdfCode128BBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode128BBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCode128CBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCode128CBarcode Class

For a list of all members of this type, see PdfCode128CBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCode128CBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfColoredTilingPattern Class Properties

Xfinium.Pdf.Graphics Namespace : PdfColoredTilingPattern Class

For a list of all members of this type, see PdfColoredTilingPattern members.

Public Properties
 | Name | Description
Public Property | Graphics | Gets the pattern graphics. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Height | Gets the pattern height. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Matrix | Gets or sets the pattern matrix. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Width | Gets the pattern width. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | XStep | Gets the x step. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | YStep | Gets the y step. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Top
See Also

Reference

PdfColoredTilingPattern Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfCoop25Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfCoop25Barcode Class

For a list of all members of this type, see PdfCoop25Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfCoop25Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfDeviceNAttributes Constructor

Xfinium.Pdf.Graphics Namespace > PdfDeviceNAttributes Class : PdfDeviceNAttributes Constructor
Overload List
Overload | Description
PdfDeviceNAttributes Constructor | Initilizes a new PdfDeviceNAttributes object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNAttributes Class
PdfDeviceNAttributes Members


%%PageItemTitle%% $$Methods$$

PdfDeviceNColorantNameCollection Class Methods

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColorantNameCollection Class

For a list of all members of this type, see PdfDeviceNColorantNameCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<string>)
Top
See Also

Reference

PdfDeviceNColorantNameCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfDeviceNColorantNameCollection Class Properties

Xfinium.Pdf.Graphics Namespace : PdfDeviceNColorantNameCollection Class

For a list of all members of this type, see PdfDeviceNColorantNameCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<string>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<string>)
Top
See Also

Reference

PdfDeviceNColorantNameCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfDeviceNColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfDeviceNColorSpace Class : PdfDeviceNColorSpace Constructor
Overload List
Overload | Description
PdfDeviceNColorSpace Constructor | Initializes a new PdfDeviceNColorSpace object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDeviceNColorSpace Class
PdfDeviceNColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfEan8Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfEan8Barcode Class

For a list of all members of this type, see PdfEan8Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfEan8Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfEan13Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfEan13Barcode Class

For a list of all members of this type, see PdfEan13Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfEan13Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfExtendedGraphicState Constructor

Xfinium.Pdf.Graphics Namespace > PdfExtendedGraphicState Class : PdfExtendedGraphicState Constructor
Overload List
Overload | Description
PdfExtendedGraphicState Constructor | Initializes a new PdfExtendedGraphicState object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfExtendedGraphicState Class
PdfExtendedGraphicState Members


%%PageItemTitle%% $$Properties$$

PdfFedExGround96Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfFedExGround96Barcode Class

For a list of all members of this type, see PdfFedExGround96Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfFedExGround96Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfFormXObject Constructor

Xfinium.Pdf.Graphics Namespace > PdfFormXObject Class : PdfFormXObject Constructor
Overload List
Overload | Description
PdfFormXObject Constructor | Initializes a new PdfFormXObject object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFormXObject Class
PdfFormXObject Members


%%PageItemTitle%%

PdfFunctionShading Constructor

Xfinium.Pdf.Graphics Namespace > PdfFunctionShading Class : PdfFunctionShading Constructor
Overload List
Overload | Description
PdfFunctionShading Constructor | Initializes a new PdfFunctionShading object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfFunctionShading Class
PdfFunctionShading Members


%%PageItemTitle%% $$Properties$$

PdfIata25Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIata25Barcode Class

For a list of all members of this type, see PdfIata25Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIata25Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIccColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfIccColorSpace Class : PdfIccColorSpace Constructor
Overload List
Overload | Description
PdfIccColorSpace Constructor | Initializes a new PdfIccColorSpace object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIccColorSpace Class
PdfIccColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfIdentcodeBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIdentcodeBarcode Class

For a list of all members of this type, see PdfIdentcodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIdentcodeBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfIndexedColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfIndexedColorSpace Class : PdfIndexedColorSpace Constructor
Overload List
Overload | Description
PdfIndexedColorSpace Constructor | Initializes a new PdfIndexedColorSpace object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfIndexedColorSpace Class
PdfIndexedColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfIsbnBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIsbnBarcode Class

For a list of all members of this type, see PdfIsbnBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIsbnBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfIsmnBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIsmnBarcode Class

For a list of all members of this type, see PdfIsmnBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIsmnBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfIssnBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfIssnBarcode Class

For a list of all members of this type, see PdfIssnBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfIssnBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfJan13Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfJan13Barcode Class

For a list of all members of this type, see PdfJan13Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfJan13Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfKixBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfKixBarcode Class

For a list of all members of this type, see PdfKixBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfKixBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfLabColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfLabColorSpace Class : PdfLabColorSpace Constructor
Overload List
Overload | Description
PdfLabColorSpace Constructor | Initializes a new PdfLabColorSpace object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfLabColorSpace Class
PdfLabColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfLeitcodeBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfLeitcodeBarcode Class

For a list of all members of this type, see PdfLeitcodeBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfLeitcodeBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfMatrix25Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfMatrix25Barcode Class

For a list of all members of this type, see PdfMatrix25Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode25Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfMatrix25Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfMsiPlesseyBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfMsiPlesseyBarcode Class

For a list of all members of this type, see PdfMsiPlesseyBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfMsiPlesseyBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfPantoneColor Class Methods

Xfinium.Pdf.Graphics Namespace : PdfPantoneColor Class

For a list of all members of this type, see PdfPantoneColor members.

Public Methods
 | Name | Description
Public Method | Copy | Copies this color. (Inherited from Xfinium.Pdf.Graphics.PdfSeparationColor)
Public Method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Xfinium.Pdf.Graphics.PdfSeparationColor)
Public Method | GetHashCode | Serves as the default hash function. (Inherited from Xfinium.Pdf.Graphics.PdfSeparationColor)
Public Method | ToRgbColor | Converts this color to RGB. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfPantoneColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfPatternColor Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPatternColor Class

For a list of all members of this type, see PdfPatternColor members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets the colorspace. (Inherited from Xfinium.Pdf.Graphics.PdfColor)
Top
See Also

Reference

PdfPatternColor Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfPlanetBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPlanetBarcode Class

For a list of all members of this type, see PdfPlanetBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPlanetBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfPostalBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPostalBarcode Class

For a list of all members of this type, see PdfPostalBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPostalBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfPostNetBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPostNetBarcode Class

For a list of all members of this type, see PdfPostNetBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPostNetBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfPznBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfPznBarcode Class

For a list of all members of this type, see PdfPznBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | WideToNarrowRatio | Gets or sets the wide to narrow ratio. (Inherited from Xfinium.Pdf.Graphics.PdfCode39Barcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfPznBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfRadialShading Constructor

Xfinium.Pdf.Graphics Namespace > PdfRadialShading Class : PdfRadialShading Constructor
Overload List
Overload | Description
PdfRadialShading Constructor | Initializes a new PdfRadialShading object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRadialShading Class
PdfRadialShading Members


%%PageItemTitle%% $$Properties$$

PdfRm4sccBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfRm4sccBarcode Class

For a list of all members of this type, see PdfRm4sccBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfRm4sccBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfScc14Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfScc14Barcode Class

For a list of all members of this type, see PdfScc14Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfScc14Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfSeparationColorSpace Constructor

Xfinium.Pdf.Graphics Namespace > PdfSeparationColorSpace Class : PdfSeparationColorSpace Constructor
Overload List
Overload | Description
PdfSeparationColorSpace Constructor | Initializes a new PdfSeparationColorSpace object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfSeparationColorSpace Class
PdfSeparationColorSpace Members


%%PageItemTitle%% $$Properties$$

PdfSingaporePostBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfSingaporePostBarcode Class

For a list of all members of this type, see PdfSingaporePostBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfSingaporePostBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfSscc18Barcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfSscc18Barcode Class

For a list of all members of this type, see PdfSscc18Barcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfSscc18Barcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfStandardFont Class Methods

Xfinium.Pdf.Graphics Namespace : PdfStandardFont Class

For a list of all members of this type, see PdfStandardFont members.

Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfStandardFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%%

PdfStencilMask Constructor

Xfinium.Pdf.Graphics Namespace > PdfStencilMask Class : PdfStencilMask Constructor
Overload List
Overload | Description
PdfStencilMask Constructor | Initializes a new PdfStencilMask object from a monochrome image.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStencilMask Class
PdfStencilMask Members


%%PageItemTitle%%

PdfTransparencyGroup Constructor

Xfinium.Pdf.Graphics Namespace > PdfTransparencyGroup Class : PdfTransparencyGroup Constructor
Overload List
Overload | Description
PdfTransparencyGroup Constructor | Initializes a new PdfTransparencyGroup object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfTransparencyGroup Class
PdfTransparencyGroup Members


%%PageItemTitle%% $$Properties$$

PdfType1Font Class Properties

Xfinium.Pdf.Graphics Namespace : PdfType1Font Class

For a list of all members of this type, see PdfType1Font members.

Public Properties
 | Name | Description
Public Property | Bold | Gets or sets a value indicating whether the font is bold. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Italic | Gets or sets a value indicating whether the font is italic. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Metrics | Gets the font metrics. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Size | Gets or sets the font size. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Strikethrough | Gets or sets a value indicating whether the font is strikethrough. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | TextRenderingMode | Gets or sets the text rendering mode. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Public Property | Underline | Gets or sets a value indicating whether the font is underlined. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfType1Font Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfType3Font Class Methods

Xfinium.Pdf.Graphics Namespace : PdfType3Font Class

For a list of all members of this type, see PdfType3Font members.

Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfFont)
Top
See Also

Reference

PdfType3Font Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfType3GlyphCollection Class Methods

Xfinium.Pdf.Graphics Namespace : PdfType3GlyphCollection Class

For a list of all members of this type, see PdfType3GlyphCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Top
See Also

Reference

PdfType3GlyphCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfType3GlyphCollection Class Properties

Xfinium.Pdf.Graphics Namespace : PdfType3GlyphCollection Class

For a list of all members of this type, see PdfType3GlyphCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfType3Glyph>)
Top
See Also

Reference

PdfType3GlyphCollection Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfUncoloredTilingPattern Class Properties

Xfinium.Pdf.Graphics Namespace : PdfUncoloredTilingPattern Class

For a list of all members of this type, see PdfUncoloredTilingPattern members.

Public Properties
 | Name | Description
Public Property | Graphics | Gets the pattern graphics. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Height | Gets the pattern height. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Matrix | Gets or sets the pattern matrix. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | Width | Gets the pattern width. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | XStep | Gets the x step. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Public Property | YStep | Gets the y step. (Inherited from Xfinium.Pdf.Graphics.PdfTilingPattern)
Top
See Also

Reference

PdfUncoloredTilingPattern Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfUnicodeTrueTypeFont Class Methods

Xfinium.Pdf.Graphics Namespace : PdfUnicodeTrueTypeFont Class

For a list of all members of this type, see PdfUnicodeTrueTypeFont members.

Public Methods
 | Name | Description
Public Method | EncodeString | Encodes the given text to a byte array based on font's encoding. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | GetGlyphEmWidth | Gets the Em width of the given glyph when drawn with this font object. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | UpdateCharsSubset | Updates the set of characters that must be subset in the final font data. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Public Method | UpdateGlyphsSubset | Updates the set of glyphs that must be subset in the final font data. (Inherited from Xfinium.Pdf.Graphics.PdfTrueTypeFont)
Top
See Also

Reference

PdfUnicodeTrueTypeFont Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfUpcaBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfUpcaBarcode Class

For a list of all members of this type, see PdfUpcaBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUpcaBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfUpceBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfUpceBarcode Class

For a list of all members of this type, see PdfUpceBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Supplement | Gets or sets the data supplement. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementTextPosition | Gets or sets the position of the supplement text. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | SupplementYDimension | Gets or sets the Y dimension for the supplement barcode. (Inherited from Xfinium.Pdf.Graphics.PdfEanBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUpceBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfUspsFimBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfUspsFimBarcode Class

For a list of all members of this type, see PdfUspsFimBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUspsFimBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfUspsHorizontalBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfUspsHorizontalBarcode Class

For a list of all members of this type, see PdfUspsHorizontalBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUspsHorizontalBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Properties$$

PdfUspsPicBarcode Class Properties

Xfinium.Pdf.Graphics Namespace : PdfUspsPicBarcode Class

For a list of all members of this type, see PdfUspsPicBarcode members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets or sets the barcode background color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | BarcodeTextPosition | Gets or sets the barcode text position. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | BarColor | Gets or sets the barcode bar color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Data | Gets or sets the barcode data. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum should be computed. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Font | Gets or sets the barcode text font. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | Height | Gets the barcode height. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | QuietZones | Gets the barcode quiet zones. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | ShowCheckSum | Gets or sets indicating whether the computed checksum should be shown. (Inherited from Xfinium.Pdf.Graphics.Pdf1DBarcode)
Public Property | TextColor | Gets or sets the barcode text color. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | Width | Gets the barcode width. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | XDimension | Gets or sets the X dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Public Property | YDimension | Gets or sets the Y dimension. (Inherited from Xfinium.Pdf.Graphics.PdfBarcode)
Top
See Also

Reference

PdfUspsPicBarcode Class
Xfinium.Pdf.Graphics Namespace


%%PageItemTitle%% $$Methods$$

PdfTextLineCollection Class Methods

Xfinium.Pdf.Graphics.Text Namespace : PdfTextLineCollection Class

For a list of all members of this type, see PdfTextLineCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Top
See Also

Reference

PdfTextLineCollection Class
Xfinium.Pdf.Graphics.Text Namespace


%%PageItemTitle%% $$Properties$$

PdfTextLineCollection Class Properties

Xfinium.Pdf.Graphics.Text Namespace : PdfTextLineCollection Class

For a list of all members of this type, see PdfTextLineCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfTextLine>)
Top
See Also

Reference

PdfTextLineCollection Class
Xfinium.Pdf.Graphics.Text Namespace


%%PageItemTitle%% $$Methods$$

PngDecodeException Class Methods

Xfinium.Pdf.Imaging.Png Namespace : PngDecodeException Class

For a list of all members of this type, see PngDecodeException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PngDecodeException Class
Xfinium.Pdf.Imaging.Png Namespace


%%PageItemTitle%% $$Properties$$

PngDecodeException Class Properties

Xfinium.Pdf.Imaging.Png Namespace : PngDecodeException Class

For a list of all members of this type, see PngDecodeException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PngDecodeException Class
Xfinium.Pdf.Imaging.Png Namespace


%%PageItemTitle%% $$Methods$$

TiffDecodeException Class Methods

Xfinium.Pdf.Imaging.Tiff Namespace : TiffDecodeException Class

For a list of all members of this type, see TiffDecodeException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

TiffDecodeException Class
Xfinium.Pdf.Imaging.Tiff Namespace


%%PageItemTitle%% $$Properties$$

TiffDecodeException Class Properties

Xfinium.Pdf.Imaging.Tiff Namespace : TiffDecodeException Class

For a list of all members of this type, see TiffDecodeException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

TiffDecodeException Class
Xfinium.Pdf.Imaging.Tiff Namespace


%%PageItemTitle%%

PdfDocumentFeatures Constructor

Xfinium.Pdf Namespace > PdfDocumentFeatures Class : PdfDocumentFeatures Constructor
Overload List
Overload | Description
PdfDocumentFeatures Constructor | Initializes a new PdfDocumentFeatures object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentFeatures Class
PdfDocumentFeatures Members


%%PageItemTitle%% $$Methods$$

PdfDocumentFileAttachmentCollection Class Methods

Xfinium.Pdf Namespace : PdfDocumentFileAttachmentCollection Class

For a list of all members of this type, see PdfDocumentFileAttachmentCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfDocumentFileAttachment>)
Top
See Also

Reference

PdfDocumentFileAttachmentCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfDocumentInformation Constructor

Xfinium.Pdf Namespace > PdfDocumentInformation Class : PdfDocumentInformation Constructor
Overload List
Overload | Description
PdfDocumentInformation Constructor | Initializes a new PdfDocumentInformation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfDocumentInformation Class
PdfDocumentInformation Members


%%PageItemTitle%% $$Methods$$

PdfFunctionCollection Class Methods

Xfinium.Pdf.PdfFunctions Namespace : PdfFunctionCollection Class

For a list of all members of this type, see PdfFunctionCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Top
See Also

Reference

PdfFunctionCollection Class
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%% $$Properties$$

PdfFunctionCollection Class Properties

Xfinium.Pdf.PdfFunctions Namespace : PdfFunctionCollection Class

For a list of all members of this type, see PdfFunctionCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfFunction>)
Top
See Also

Reference

PdfFunctionCollection Class
Xfinium.Pdf.PdfFunctions Namespace


%%PageItemTitle%%

PdfStitchingFunction Constructor

Xfinium.Pdf.PdfFunctions Namespace > PdfStitchingFunction Class : PdfStitchingFunction Constructor
Overload List
Overload | Description
PdfStitchingFunction Constructor | Initilizes a new PdfStitchingFunction object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfStitchingFunction Class
PdfStitchingFunction Members


%%PageItemTitle%% $$Methods$$

PdfOutlineItemCollection Class Methods

Xfinium.Pdf Namespace : PdfOutlineItemCollection Class

For a list of all members of this type, see PdfOutlineItemCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Top
See Also

Reference

PdfOutlineItemCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Properties$$

PdfOutlineItemCollection Class Properties

Xfinium.Pdf Namespace : PdfOutlineItemCollection Class

For a list of all members of this type, see PdfOutlineItemCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfOutlineItem>)
Top
See Also

Reference

PdfOutlineItemCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfOutlineItem Constructor

Xfinium.Pdf Namespace > PdfOutlineItem Class : PdfOutlineItem Constructor
Overload List
Overload | Description
PdfOutlineItem Constructor | Initializes a new PdfOutlineItem object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutlineItem Class
PdfOutlineItem Members


%%PageItemTitle%% $$Methods$$

PdfOutputIntentCollection Class Methods

Xfinium.Pdf Namespace : PdfOutputIntentCollection Class

For a list of all members of this type, see PdfOutputIntentCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Top
See Also

Reference

PdfOutputIntentCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Properties$$

PdfOutputIntentCollection Class Properties

Xfinium.Pdf Namespace : PdfOutputIntentCollection Class

For a list of all members of this type, see PdfOutputIntentCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfOutputIntent>)
Top
See Also

Reference

PdfOutputIntentCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfOutputIntentCollection Constructor

Xfinium.Pdf Namespace > PdfOutputIntentCollection Class : PdfOutputIntentCollection Constructor
Overload List
Overload | Description
PdfOutputIntentCollection Constructor | Initializes a new PdfOutputIntentCollection object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntentCollection Class
PdfOutputIntentCollection Members


%%PageItemTitle%%

PdfOutputIntent Constructor

Xfinium.Pdf Namespace > PdfOutputIntent Class : PdfOutputIntent Constructor
Overload List
Overload | Description
PdfOutputIntent Constructor | Initializes a new PdfOutputIntent object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfOutputIntent Class
PdfOutputIntent Members


%%PageItemTitle%% $$Properties$$

PdfPageCollection Class Properties

Xfinium.Pdf Namespace : PdfPageCollection Class

For a list of all members of this type, see PdfPageCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfPage>)
Top
See Also

Reference

PdfPageCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Methods$$

PdfPageLabelingRangeCollection Class Methods

Xfinium.Pdf Namespace : PdfPageLabelingRangeCollection Class

For a list of all members of this type, see PdfPageLabelingRangeCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Top
See Also

Reference

PdfPageLabelingRangeCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%% $$Properties$$

PdfPageLabelingRangeCollection Class Properties

Xfinium.Pdf Namespace : PdfPageLabelingRangeCollection Class

For a list of all members of this type, see PdfPageLabelingRangeCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfPageLabelingRange>)
Top
See Also

Reference

PdfPageLabelingRangeCollection Class
Xfinium.Pdf Namespace


%%PageItemTitle%%

PdfPageLabelingRange Constructor

Xfinium.Pdf Namespace > PdfPageLabelingRange Class : PdfPageLabelingRange Constructor
Overload List
Overload | Description
PdfPageLabelingRange Constructor | Initializes a new PdfPageLabelingRange object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPageLabelingRange Class
PdfPageLabelingRange Members


%%PageItemTitle%%

PdfPage Constructor

Xfinium.Pdf Namespace > PdfPage Class : PdfPage Constructor
Overload List
Overload | Description
PdfPage Constructor | Initializes a new PdfPage object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPage Class
PdfPage Members


%%PageItemTitle%%

PdfVersionExtension Constructor

Xfinium.Pdf Namespace > PdfVersionExtension Class : PdfVersionExtension Constructor
Overload List
Overload | Description
PdfVersionExtension Constructor | Initializes a new PdfVersionExtension object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfVersionExtension Class
PdfVersionExtension Members


%%PageItemTitle%%

PdfViewerPreferences Constructor

Xfinium.Pdf Namespace > PdfViewerPreferences Class : PdfViewerPreferences Constructor
Overload List
Overload | Description
PdfViewerPreferences Constructor | Initializes a new PdfViewerPreferences object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewerPreferences Class
PdfViewerPreferences Members


%%PageItemTitle%%

PdfXmpMetadata Constructor

Xfinium.Pdf Namespace > PdfXmpMetadata Class : PdfXmpMetadata Constructor
Overload List
Overload | Description
PdfXmpMetadata Constructor | Initializes a new PdfXmpMetadata object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfXmpMetadata Class
PdfXmpMetadata Members


%%PageItemTitle%%

PdfPortfolioAttributeDefinitions Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinitions Class : PdfPortfolioAttributeDefinitions Constructor
Overload List
Overload | Description
PdfPortfolioAttributeDefinitions Constructor | Initializes a new PdfPortfolioAttributeDefinitions object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinitions Class
PdfPortfolioAttributeDefinitions Members


%%PageItemTitle%%

PdfPortfolioAttributeDefinition Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioAttributeDefinition Class : PdfPortfolioAttributeDefinition Constructor
Overload List
Overload | Description
PdfPortfolioAttributeDefinition Constructor | Initializes a new PdfPortfolioAttributeDefinition object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioAttributeDefinition Class
PdfPortfolioAttributeDefinition Members


%%PageItemTitle%% $$Methods$$

PdfPortfolioFolderCollection Class Methods

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioFolderCollection Class

For a list of all members of this type, see PdfPortfolioFolderCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioFolder>)
Top
See Also

Reference

PdfPortfolioFolderCollection Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioItemAttributes Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItemAttributes Class : PdfPortfolioItemAttributes Constructor
Overload List
Overload | Description
PdfPortfolioItemAttributes Constructor | Initializes a new PdfPortfolioItemAttributes object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItemAttributes Class
PdfPortfolioItemAttributes Members


%%PageItemTitle%% $$Methods$$

PdfPortfolioItemCollection Class Methods

Xfinium.Pdf.Portfolios Namespace : PdfPortfolioItemCollection Class

For a list of all members of this type, see PdfPortfolioItemCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfPortfolioItem>)
Top
See Also

Reference

PdfPortfolioItemCollection Class
Xfinium.Pdf.Portfolios Namespace


%%PageItemTitle%%

PdfPortfolioItem Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioItem Class : PdfPortfolioItem Constructor
Overload List
Overload | Description
PdfPortfolioItem Constructor | Initializes a new PdfPortfolioItem object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioItem Class
PdfPortfolioItem Members


%%PageItemTitle%%

PdfPortfolioSortInformation Constructor

Xfinium.Pdf.Portfolios Namespace > PdfPortfolioSortInformation Class : PdfPortfolioSortInformation Constructor
Overload List
Overload | Description
PdfPortfolioSortInformation Constructor | Initializes a new PdfPortfolioSortInformation object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPortfolioSortInformation Class
PdfPortfolioSortInformation Members


%%PageItemTitle%% $$Properties$$

PdfGeographicCoordinateSystem Class Properties

Xfinium.Pdf.Spatial Namespace : PdfGeographicCoordinateSystem Class

For a list of all members of this type, see PdfGeographicCoordinateSystem members.

Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code. (Inherited from Xfinium.Pdf.Spatial.PdfCoordinateSystem)
Public Property | WellKnownText | Gets or sets the wekk known text. (Inherited from Xfinium.Pdf.Spatial.PdfCoordinateSystem)
Top
See Also

Reference

PdfGeographicCoordinateSystem Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfGeographicCoordinateSystem Constructor

Xfinium.Pdf.Spatial Namespace > PdfGeographicCoordinateSystem Class : PdfGeographicCoordinateSystem Constructor
Overload List
Overload | Description
PdfGeographicCoordinateSystem Constructor | Initializes a new PdfGeographicCoordinateSystem object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeographicCoordinateSystem Class
PdfGeographicCoordinateSystem Members


%%PageItemTitle%%

PdfGeospatialMeasure Constructor

Xfinium.Pdf.Spatial Namespace > PdfGeospatialMeasure Class : PdfGeospatialMeasure Constructor
Overload List
Overload | Description
PdfGeospatialMeasure Constructor | Initializes a new PdfGeospatialMeasure object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfGeospatialMeasure Class
PdfGeospatialMeasure Members


%%PageItemTitle%% $$Methods$$

PdfNumberFormatCollection Class Methods

Xfinium.Pdf.Spatial Namespace : PdfNumberFormatCollection Class

For a list of all members of this type, see PdfNumberFormatCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Top
See Also

Reference

PdfNumberFormatCollection Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Properties$$

PdfNumberFormatCollection Class Properties

Xfinium.Pdf.Spatial Namespace : PdfNumberFormatCollection Class

For a list of all members of this type, see PdfNumberFormatCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfNumberFormat>)
Top
See Also

Reference

PdfNumberFormatCollection Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfNumberFormatCollection Constructor

Xfinium.Pdf.Spatial Namespace > PdfNumberFormatCollection Class : PdfNumberFormatCollection Constructor
Overload List
Overload | Description
PdfNumberFormatCollection Constructor | Initializes a new PdfNumberFormatCollection object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormatCollection Class
PdfNumberFormatCollection Members


%%PageItemTitle%%

PdfNumberFormat Constructor

Xfinium.Pdf.Spatial Namespace > PdfNumberFormat Class : PdfNumberFormat Constructor
Overload List
Overload | Description
PdfNumberFormat Constructor | Initializes a new PdfNumberFormat object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfNumberFormat Class
PdfNumberFormat Members


%%PageItemTitle%%

PdfPointData Constructor

Xfinium.Pdf.Spatial Namespace > PdfPointData Class : PdfPointData Constructor
Overload List
Overload | Description
PdfPointData Constructor | Initializes a new PdfPointData object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfPointData Class
PdfPointData Members


%%PageItemTitle%% $$Properties$$

PdfProjectedCoordinateSystem Class Properties

Xfinium.Pdf.Spatial Namespace : PdfProjectedCoordinateSystem Class

For a list of all members of this type, see PdfProjectedCoordinateSystem members.

Public Properties
 | Name | Description
Public Property | EPSG | Gets or sets the EPSG code. (Inherited from Xfinium.Pdf.Spatial.PdfCoordinateSystem)
Public Property | WellKnownText | Gets or sets the wekk known text. (Inherited from Xfinium.Pdf.Spatial.PdfCoordinateSystem)
Top
See Also

Reference

PdfProjectedCoordinateSystem Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfProjectedCoordinateSystem Constructor

Xfinium.Pdf.Spatial Namespace > PdfProjectedCoordinateSystem Class : PdfProjectedCoordinateSystem Constructor
Overload List
Overload | Description
PdfProjectedCoordinateSystem Constructor | Initializes a new PdfProjectedCoordinateSystem object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfProjectedCoordinateSystem Class
PdfProjectedCoordinateSystem Members


%%PageItemTitle%%

PdfRectilinearMeasure Constructor

Xfinium.Pdf.Spatial Namespace > PdfRectilinearMeasure Class : PdfRectilinearMeasure Constructor
Overload List
Overload | Description
PdfRectilinearMeasure Constructor | Initializes a new PdfRectilinearMeasure object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfRectilinearMeasure Class
PdfRectilinearMeasure Members


%%PageItemTitle%% $$Methods$$

PdfViewportCollection Class Methods

Xfinium.Pdf.Spatial Namespace : PdfViewportCollection Class

For a list of all members of this type, see PdfViewportCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Top
See Also

Reference

PdfViewportCollection Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%% $$Properties$$

PdfViewportCollection Class Properties

Xfinium.Pdf.Spatial Namespace : PdfViewportCollection Class

For a list of all members of this type, see PdfViewportCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PdfViewport>)
Top
See Also

Reference

PdfViewportCollection Class
Xfinium.Pdf.Spatial Namespace


%%PageItemTitle%%

PdfViewportCollection Constructor

Xfinium.Pdf.Spatial Namespace > PdfViewportCollection Class : PdfViewportCollection Constructor
Overload List
Overload | Description
PdfViewportCollection Constructor | Initializes a new PdfViewportCollection object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewportCollection Class
PdfViewportCollection Members


%%PageItemTitle%%

PdfViewport Constructor

Xfinium.Pdf.Spatial Namespace > PdfViewport Class : PdfViewport Constructor
Overload List
Overload | Description
PdfViewport Constructor | Initializes a new PdfViewport object.
Requirements

Supported .NET Platforms: .NET 2.0 - .NET 4.6, Windows Forms, ASP.NET, Windows Presentation Foundation 4.x, Silverlight 5, WinRT, Universal Windows Platform, Windows Phone 8 & 8.1, Xamarin iOS & Android, Portable Class Library

Target Platforms:Windows 10, Windows 8.1, Windows 8 , Windows 7, Windows Vista SP1 or later, Windows Server 2008, Windows Server 2008 R2

See Also

Reference

PdfViewport Class
PdfViewport Members


%%PageItemTitle%% $$Methods$$

PdfAAggregateException Class Methods

Xfinium.Pdf.Standards Namespace : PdfAAggregateException Class

For a list of all members of this type, see PdfAAggregateException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfAAggregateException Class
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Methods$$

PdfAException Class Methods

Xfinium.Pdf.Standards Namespace : PdfAException Class

For a list of all members of this type, see PdfAException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfAException Class
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Methods$$

PdfAExceptionCollection Class Methods

Xfinium.Pdf.Standards Namespace : PdfAExceptionCollection Class

For a list of all members of this type, see PdfAExceptionCollection members.

Public Methods
 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Top
See Also

Reference

PdfAExceptionCollection Class
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Properties$$

PdfAExceptionCollection Class Properties

Xfinium.Pdf.Standards Namespace : PdfAExceptionCollection Class

For a list of all members of this type, see PdfAExceptionCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PdfAException>)
Top
See Also

Reference

PdfAExceptionCollection Class
Xfinium.Pdf.Standards Namespace


%%PageItemTitle%% $$Properties$$

PdfConvertImagesToGrayTransform Class Properties

Xfinium.Pdf.Transforms Namespace : PdfConvertImagesToGrayTransform Class

For a list of all members of this type, see PdfConvertImagesToGrayTransform members.

Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Top
See Also

Reference

PdfConvertImagesToGrayTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Properties$$

PdfConvertToCmykTransform Class Properties

Xfinium.Pdf.Transforms Namespace : PdfConvertToCmykTransform Class

For a list of all members of this type, see PdfConvertToCmykTransform members.

Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Top
See Also

Reference

PdfConvertToCmykTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Properties$$

PdfConvertToGrayTransform Class Properties

Xfinium.Pdf.Transforms Namespace : PdfConvertToGrayTransform Class

For a list of all members of this type, see PdfConvertToGrayTransform members.

Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Top
See Also

Reference

PdfConvertToGrayTransform Class
Xfinium.Pdf.Transforms Namespace


%%PageItemTitle%% $$Properties$$

PdfConvertToRgbTransform Class Properties

Xfinium.Pdf.Transforms Namespace : PdfConvertToRgbTransform Class

For a list of all members of this type, see PdfConvertToRgbTransform members.

Public Properties
 | Name | Description
Public Property | Context | Gets the transform context. (Inherited from Xfinium.Pdf.Transforms.PdfPageTransform)
Top
See Also

Reference

PdfConvertToRgbTransform Class
Xfinium.Pdf.Transforms Namespace